Catalyst 4500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース IOS XE 3.3.0SG および IOS 15.1(1)SG
双方向フォワーディング検出の設定
双方向フォワーディング検出の設定
発行日;2012/09/05 | 英語版ドキュメント(2012/04/17 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

双方向フォワーディング検出の設定

機能情報の確認

内容

双方向フォワーディング検出の前提条件

双方向フォワーディング検出の制約事項

双方向フォワーディング検出について

BFD の動作

ネイバー関係

BFD の障害検出

BFD バージョンの相互運用性

BFD セッションの制限

非ブロードキャスト メディア インターフェイスに対する BFD サポート

ステートフル スイッチオーバー機能を持つノンストップ フォワーディングのための BFD サポート

ステートフル スイッチオーバーのための BFD サポート

スタティック ルーティングのための BFD サポート

障害検出に BFD を使用することの利点

BFD のハードウェア サポート

双方向フォワーディング検出の設定方法

インターフェイスでの BFD セッション パラメータの設定

ダイナミック ルーティング プロトコルに対する BFD サポートの設定

BGP に対する BFD サポートの設定

EIGRP に対する BFD サポートの設定

OSPF に対する BFD サポートの設定

スタティック ルーティングのための BFD サポートの設定

BFD エコー モードの設定

前提条件

制約事項 

BFD 低速タイマーの設定

非対称性のない BFD エコー モードのディセーブル化

BFD のモニタリングとトラブルシューティング

双方向フォワーディング検出の設定例

例:エコー モードがデフォルトでイネーブルになった EIGRP ネットワークでの BFD の設定

例:OSPF ネットワークでの BFD の設定

例:BGP ネットワークでの BFD ハードウェア オフロード サポートの設定

例:スタティック ルーティングのための BFD サポートの設定

その他の関連資料

関連資料

標準

管理情報ベース(MIB)

RFC

シスコのテクニカル サポート

双方向フォワーディング検出の設定


) Cisco IOS Release IOS 15.1(1)SG 以降では、双方向フォワーディング検出(BFD)は Catalyst 4900M および Catalyst 4948E イーサネット スイッチでだけサポートされます。


このマニュアルでは、BFD プロトコルをイネーブルにする方法について説明します。これは、あらゆるメディア タイプ、カプセル化、トポロジ、およびルーティング プロトコルの高速転送パス障害検出回数を提供するように設計された検出プロトコルです。

BFD は高速転送パス障害検出に加えて、ネットワーク管理者に一貫した障害検出方法を提供します。ネットワーク管理者は BFD を使用して、さまざまなルーティング プロトコルの hello メカニズムで、変動速度ではなく一定速度で転送パスの障害を検出できるため、ネットワーク プロファイリングおよびプランニングが容易になります。また、再コンバージェンス時間の整合性が保たれ、予測可能になります。

機能情報の確認

ご使用のソフトウェア リリースによっては、このモジュールに記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「シスコのテクニカル サポート」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。 Cisco.com のアカウントは不要です。

双方向フォワーディング検出の前提条件

前提条件は次のとおりです。

IP ルーティングは、参加しているすべてのスイッチでイネーブルにする必要があります。

BFD を導入する前に、BFD でサポートされる IP ルーティング プロトコルのいずれかをスイッチで設定しておくこと。使用する予定のルーティング プロトコルの高速コンバージェンスを実装する必要があります。高速コンバージェンスの設定については、お使いのバージョンの Cisco IOS ソフトウェアの IP ルーティングのマニュアルを参照してください。Cisco IOS ソフトウェアでの BFD ルーティング プロトコルのサポートの詳細については、「双方向フォワーディング検出の制約事項」を参照してください。

双方向フォワーディング検出の制約事項

次の制限があります。

BFD は直接接続されたネイバーだけに対して動作します。BFD のネイバーは 1 ホップ以内に限られます。マルチホップのコンフィギュレーションはサポートされません。

Cisco IOS Release 15.1(1)SG と Cisco Catalyst 4500 シリーズ スイッチ

Cisco Catalyst 4500 シリーズ スイッチでは、最小 hello 間隔 50 ms、倍率 3 で最大 128 の BFD セッションがサポートされます。この倍率は、セッションがダウンしたと宣言される前に失われた可能性のある連続するパケットの最小数を指定します。

SSO がデュアル RP システムでイネーブルになっている場合、次の制約事項が適用されます。

倍率 5 以上の最小 hello 間隔は 50 ms です。

より小さい値を設定できますが、SSO スイッチオーバー中にフラップが発生する場合があります。

エコー モードをイネーブルにするには、ピア システムを no ip redirects コマンドで設定する必要があります。


) プラットフォームとハードウェアの正確な制約事項については、お使いのソフトウェア バージョンの Cisco IOS ソフトウェアのリリース ノートを参照してください。


双方向フォワーディング検出について

「BFD の動作」

「障害検出に BFD を使用することの利点」

BFD の動作

BFD は、インターフェイス、データリンク、および転送プレーンを含めて、2 つの隣接スイッチ間の転送パスで、オーバーヘッドの少ない短期間の障害検出方法を提供します。

BFD はインターフェイス レベルおよびルーティング プロトコル レベルでイネーブルにする検出プロトコルです。シスコでは BFD 非同期モードをサポートしています。これは、スイッチ間の BFD ネイバー セッションをアクティブにして維持するための、2 台のシステム間の BFD 制御パケットの送信に依存します。したがって、BFD セッションを作成するには、両方のシステム(または BFD ピア)で BFD を設定する必要があります。適切なルーティング プロトコルに対して、インターフェイス レベルおよびルータ レベルで BFD がイネーブルになっている場合、BFD セッションが作成されて BFD タイマーがネゴシエートされ、ネゴシエートされた間隔で BFD ピアが互いに BFD 制御パケットの送信を開始します。

シスコは、BFD エコー モードをサポートしています。エコー パケットはフォワーディング エンジンによって送信され、検出を実行するために同じパスに沿って返信されます。もう一方の BFD セッションは、エコー パケットの実際のフォワーディングに参加しません。詳細については、「BFD エコー モードの設定」を参照してください。

ここでは、次の内容について説明します。

「ネイバー関係」

「BFD の障害検出」

「BFD バージョンの相互運用性」

「BFD セッションの制限」

「非ブロードキャスト メディア インターフェイスに対する BFD サポート」

「ステートフル スイッチオーバー機能を持つノンストップ フォワーディングのための BFD サポート」

「ステートフル スイッチオーバーのための BFD サポート」

「スタティック ルーティングのための BFD サポート」

ネイバー関係

BFD はあらゆるメディア タイプ、カプセル化、トポロジ、ルーティング プロトコル BGP、EIGRP、OSPF、およびスタティック ルートの個別の高速 BFD ピア障害検出時間を提供します。ローカル スイッチのルーティング プロトコルに高速障害検出通知を送信して、ルーティング テーブル再計算プロセスを開始すると、BFD はネットワーク コンバージェンス時間全体を大幅に短縮できます。図 37-1 に、OSPF と BFD を実行する 2 台のスイッチがある単純なネットワークを示します。OSPF がネイバー(1)を検出すると、OSPF ネイバー ルータ(2)で BFD ネイバー セッションを開始する要求が、ローカル BFD プロセスに送信されます。OSPF ネイバー ルータでの BFD ネイバー セッションが確立されます(3)。

図 37-1 BFD ネイバー関係の確立

図 37-2 に、ネットワーク(1)で障害が発生した場合を示します。OSPF ネイバー ルータでの BFD ネイバー セッションが停止されます(2)。BFD はローカル OSPF プロセスに BFD ネイバーに接続できなくなったことを通知します(3)。ローカル OSPF プロセスは OSPF ネイバー関係を解除します(4)。代替パスを使用できる場合、ルータはただちにコンバージェンスを開始します。

図 37-2 OSPF ネイバー関係の解除

 

ルーティング プロトコルでは、取得したネイバーそれぞれについて、BFD で登録する必要があります。ネイバーが登録されると、セッションがまだ存在していない場合、BFD によって、ネイバーとのセッションが開始されます。

次のとき、OSPF では、BFD を使用して登録が行われます。

ネイバーの Finite State Machine(FSM; 有限状態マシン)は、Full ステートに移行します。

OSPF BFD と BFD の両方がイネーブルにされます。

ブロードキャスト インターフェイスでは、OSPF によって、Designated Router(DR; 指定ルータ)と Backup Designated Router(BDR; バックアップ指定ルータ)とともにのみ、BFD セッションが確立されますが、DROTHER ステートのすべての 2 台のスイッチ(ルータ)間では確立されません。

BFD の障害検出

BFD セッションが確立され、タイマーの取り消しが完了すると、BFD ピアは IGP hello プロトコルと同様に動作する(ただし、より高速な)、BFD 制御パケットを送信して状態を検出します。次の点に注意する必要があります。

BFD はフォワーディング パスの障害検出プロトコルです。BFD は障害を検出しますが、障害が発生したピアをバイパスするには、ルーティング プロトコルがアクションを実行する必要があります。

通常、BFD はどのプロトコル レイヤでも使用できます。ただし、Cisco IOS Release 15.1(1)SG 用のシスコの BFD 実装では、特に BGP、EIGRP、IS-IS、および OSPF ルーティング プロトコル、およびスタティック ルーティングのレイヤ 3 クライアントだけがサポートされます。

Cisco IOS Release 15.1(1)SG のシスコの BFD 実装では、シスコ デバイスが複数のクライアント プロトコルに 1 つの BFD セッションを使用します。たとえば、同じピアへの同じリンクを介してネットワークで OSPF および EIGRP を実行している場合、1 つの BFD セッションだけが確立され、BFD で両方のルーティング プロトコルとセッション情報を共有します。ただし、IPv4 および IPv6 クライアントは BFD セッションを共有できません。

BFD バージョンの相互運用性

Cisco IOS Release 15.1(1)SG では BFD バージョン 1 および BFD バージョン 0 がサポートされます。デフォルトでは、すべての BFD セッションがバージョン 1 で実行され、バージョン 0 と相互運用可能です。システムで自動的に FD バージョン検出が実行される場合、ネイバー間の BFD セッションがネイバー間の最も一般的な BFD バージョンで実行されます。たとえば、BFD ネイバーが BFD バージョン 0 を実行し、他の BFD ネイバーがバージョン 1 を実行している場合、セッションで BFD バージョン 0 が実行されます。 show bfd neighbors [ details ] コマンドの出力で、BFD ネイバーが実行している BFD バージョンを確認できます。

BFD バージョン検出の例については、「例:エコー モードがデフォルトでイネーブルになった EIGRP ネットワークでの BFD の設定」を参照してください。

BFD セッションの制限

Cisco IOS Release 15.1(1)SG 以降、作成できる BFD セッションの最小数は、「hello」間隔によって異なることがあります。50ms の「hello」間隔では、128 セッションが許可されます。より大きい hello 間隔では、より多くのセッションが許可されます。

非ブロードキャスト メディア インターフェイスに対する BFD サポート

Cisco IOS Release 15.1(1) SG 以降では、BFD 機能が VLAN インターフェイスでサポートされます。

bfd interval コマンドは、BFD モニタリングを開始するインターフェイスで設定する必要があります。

ステートフル スイッチオーバー機能を持つノンストップ フォワーディングのための BFD サポート

通常、ネットワーキング デバイスを再起動すると、そのデバイスのすべてのルーティング ピアがデバイスの終了および再起動を検出します。この遷移によってルーティング フラップが発生し、そのために複数のルーティング ドメインに分散される可能性があります。ルーティングの再起動によって発生したルーティング フラップによって、ルーティングが不安定になります。これはネットワーク全体のパフォーマンスに悪影響を及ぼします。ノンストップ フォワーディング(NSF)は、ステートフル スイッチオーバー(SSO)がイネーブルになっているデバイスのルーティング フラップを抑制するのに役立ち、それによってネットワークの不安定さが減少します。

NSF では、ルーティング プロトコル情報がスイッチオーバー後に保存されるとき、既知のルータでデータ パケットのフォワーディングを継続できます。NSF を使用すると、ピア ネットワーキング デバイスでルーティング フラップが発生しません。スイッチオーバー時に、故障したアクティブ RP からスタンバイ RP が制御を引き継ぐ間も、データ トラフィックが転送されます。ラインカードおよびフォワーディング プロセッサの機能はスイッチオーバーによって維持され、アクティブな RP の Forwarding Information Base(FIB; 転送情報ベース)が NSF 動作で最新状態が維持されます。

デュアル RP をサポートするデバイスでは、SSO が RP の 1 つをアクティブなプロセッサとして確立し、他の RP はスタンバイ プロセッサに割り当てられ、それらの間で情報が同期されます。アクティブな RP に障害が発生したとき、ネットワーキング デバイスから削除されたとき、または手動でメンテナンスから排除されたときに、アクティブなプロセッサとスタンバイ プロセッサからのスイッチオーバーが発生します。

ステートフル スイッチオーバーのための BFD サポート

BFD プロトコルでは、隣接するフォワーディング エンジン間でパスに短期間の障害検出が行われます。デュアル RP スイッチ(冗長性のため)を使用するネットワーク導入では、スイッチにグレースフル リスタート メカニズムがあり、アクティブな RP とスタンバイ RP の間のスイッチオーバー時にフォワーディング状態が保護されます。

スタンバイ RP のステートフル BFD

スタンバイ RP へのスイッチオーバーを成功させるために、BFD プロトコルでチェックポイント メッセージを使用して、アクティブな RP Cisco IOS インスタンスからセッション情報をスタンバイ RP Cisco IOS インスタンスに送信します。セッション情報には、ローカル識別子およびリモート識別子、隣接ルータのタイマー情報、BFD セットアップ情報、およびセッション固有の情報(セッションのタイプやセッションのバージョンなど)が含まれます。さらに、BFD プロトコルはセッションの作成および削除のチェックポイント メッセージを送信して、スタンバイ RP でセッションを作成または削除します。

スタンバイ RP の BFD セッションはパケットの送受信を行わず、期限切れになったタイマーを処理しません。このようなセッションは、スイッチオーバーの発生を待ってからアクティブ セッションのパケットを送信し、セッションが隣接スイッチでタイム アウトにならないようにします。

スタンバイ RP の BFD プロトコルはスイッチオーバーの通知を受けると、状態をアクティブに変更し、自分自身をシスコ エクスプレス フォワーディングに登録することで、パケットを受信し、期限切れになったすべての要素にパケットを送信できるようにします。

また、BFD ではチェックポイント メッセージを使用して、アクティブな RP でクライアントによって作成されたセッションをスイッチオーバー時に維持します。スイッチオーバーが発生すると、BFD は SSO 再要求タイマーを起動します。クライアントは再要求タイマーによって指定された期間内のセッションを再要求する必要があります。そうしないと、セッションが削除されます。

タイマーの値は、BFD セッションの数およびプラットフォームによって異なります。

表 37-1 に、Cisco 4500 シリーズ スイッチのタイマー値について説明します。

表 37-1 Cisco 4500 シリーズ スイッチの BFD タイマー値

BFD セッションの最大数
BFD セッション タイプ
最小タイマー値(ms)
クライアント
コメント

128

非同期/エコー

50
倍率 3

すべて

SSO スイッチでは、5 の倍数の使用が推奨されます。

スタティック ルーティングのための BFD サポート

OSPF や BGP などの動的なルーティング プロトコルとは異なり、スタティック ルーティングにはピア検出の方法がありません。したがって、BFD が設定されると、ゲートウェイの到達可能性は完全に指定されたネイバーへの BFD セッションの状態に依存します。BFD セッションが開始されない限り、スタティック ルートのゲートウェイは到達不能と見なされ、したがって、影響を受けるルートが適切なルーティング情報ベース(RIB)にインストールされません。

BFD セッションが正常に確立されるように、ピア上のインターフェイスで BFD を設定し、ピア上の BFD クライアントに BFD ネイバーのアドレスを登録する必要があります。インターフェイスがダイナミック ルーティング プロトコルで使用される場合、後者の要件は通常、BFD の各ネイバーでルーティング プロトコル インスタンスを設定することによって満たされます。インターフェイスがスタティック ルーティングに排他的に使用される場合、この要件はピア上でスタティック ルートを設定することによって満たす必要があります。

BFD は IPv4 および IPv6 スタティック ルートでサポートされます。


) BFD セッションが起動状態のときに BFD 設定がリモート ピアから削除された場合、BFD セッションの最新状態がスタティック ルートに送信されません。その結果、スタティック ルートが RIB に残ります。唯一の回避策は、スタティック ルート BFD ネイバー設定を削除して、スタティック ルートが BFD セッション状態を追跡しないようにすることです。


障害検出に BFD を使用することの利点

機能を導入するときは、あらゆる代替策を検討し、トレードオフに注意することが重要です。

EIGRP、BGP、および OSPF の通常の導入で BFD に最も近い代替策は、EIGRP、BGP、および OSPF ルーティング プロトコルの変更された障害検出メカニズムを使用することです。

EIGRP の hello およびホールド タイマーを絶対最小値に設定する場合、EIGRP の障害検出速度が 1~2 秒程度に下がります。

BGP または OSPF に fast hello を使用する場合、この Interior Gateway Protocol(IGP)プロトコルによって障害検出メカニズムが最小 1 秒に減少します。

ルーティング プロトコルの減少したタイマー メカニズムで BFD を実装することには、次のような利点があります。

EIGRP、BGP、および OSPF タイマーによって 1 秒または 2 秒の最小検出タイマーを実現できますが、障害検出が 1 秒未満になる場合もあります。

BFD は特定のルーティング プロトコルに関連付けられていないため、EIGRP、BGP、および OSPF の汎用の整合性のある障害検出メカニズムとして使用できます。

BFD の一部をデータ プレーンに分散できるため、コントロール プレーンに全体が存在する分散 EIGRP、BGP、および OSPF タイマーよりも CPU の負荷を軽くすることができます。

BFD のハードウェア サポート

Catalyst 4500 は、ハードウェアで制限された数の BFD セッションをサポートします。BFD のハードウェアにセッションを配置することは、ハードウェア オフロードと呼びます。ハードウェア オフロードの利点は、セッション キープアライブがすべてハードウェアで処理され、CPU に負荷をかけないことです。

ハードウェアにすべての BFD セッションをオフロードすることはできません。オフロードされるセッションの要件は、次のとおりです。

BFD バージョン 1

IPv4

エコーなしモード

オフロードされるセッションの数は、スーパーバイザによって異なります。WS-X45-SUP6-E、WS-X45-SUP6L-E、WS-X4948-E および C4900M で、オフロードされるセッションの数は 63 です。

show bfd neighbors detail コマンドを実行すると、ソフトウェアおよびハードウェアの(オフロードされた)セッションの統計情報が表示されます。ハードウェアのセッションは、制限された統計情報のセットを提供します。具体的には、パケットの送受信間隔の統計情報は、ハードウェアのセッションに関して提供されません。

holddown と hello counts は、すべてのオフロードされたセッションでゼロです。


) ハードウェア オフロードは、IPv6 BFD セッションでサポートされません。


双方向フォワーディング検出の設定方法

インターフェイスで BFD を設定して、BFD プロセスを開始します。BFD プロセスが開始されると、隣接するデータベースにエントリが作成されません。つまり、BFD 制御パケットが送受信されません。Cisco IOS Release 15.1(1)SG の BFD バージョン 1 でサポートされない BFD エコー モードは、デフォルトではイネーブルです。BFD 制御パケットに加えて、BFD エコー パケットが送受信されます。適用可能なルーティング プロトコルの BFD サポートを設定すると、隣接作成が実行されます。ここでは、次の手順について説明します。

「インターフェイスでの BFD セッション パラメータの設定」(必須)

「ダイナミック ルーティング プロトコルに対する BFD サポートの設定」(必須)

「スタティック ルーティングのための BFD サポートの設定」(任意)

「BFD エコー モードの設定」(任意)

「BFD のモニタリングとトラブルシューティング」(任意)

インターフェイスでの BFD セッション パラメータの設定

この手順では、インターフェイスで基本 BFD セッション パラメータを設定することによって、インターフェイスで BFD を設定する方法を示します。BFD ネイバーに対して BFD セッションを実行するインターフェイスごとに、この手順を繰り返します。

BFD セッション パラメータを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

enable
 
Switch> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal
 
Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number
 

Switch(config)# interface gigabitethernet 6/1

インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier
 
Switch(config-if)# bfd interval 50 min_rx 50 multiplier 5
 
Switch(config-if)# no bfd echo

インターフェイスで BFD をイネーブルにします。

ハードウェア オフロードをイネーブルにするために、BFD エコー モードをディセーブルにします。

ステップ 5

end
 
Switch(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ダイナミック ルーティング プロトコルに対する BFD サポートの設定

ルータ レベルでダイナミック ルーティング プロトコルの BFD サポートをイネーブルにして、すべてのインターフェイスに対してグローバルに BFD サポートをイネーブルにするか、またはインターフェイス レベルでインターフェイスごとに BFD を設定することができます。

ここでは、次の手順について説明します。

「BGP に対する BFD サポートの設定」(任意)

「EIGRP に対する BFD サポートの設定」(任意)

「OSPF に対する BFD サポートの設定」(任意)

BGP に対する BFD サポートの設定

ここでは、BGP が BFD の登録プロトコルとなり、BFD から転送パスの検出障害メッセージを受信するように、BGP に対する BFD サポートを設定する手順について説明します。

前提条件

BGP は、参加しているすべてのスイッチで実行されている必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの設定」を参照してください。

BGP に対する BFD サポートを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

enable
 
Switch> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal
 
Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-tag
 
Switch(config)# router bgp tag1

BGP プロセスを指定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

neighbor ip-address fall-over bfd
 
Switch(config-router)# neighbor 172.16.10.2 fall-over bfd

フェールオーバーに対する BFD サポートをイネーブルにします。

ステップ 5

end
 
Switch(config-router)# end

スイッチ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 6

show bfd neighbors [ details ]
 
Switch# show bfd neighbors detail

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されることを確認します。

ステップ 7

show ip bgp neighbor
 
Switch# show ip bgp neighbor

(任意)ネイバーへの BGP および TCP 接続についての情報を表示します。

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次の項を参照してください。

「EIGRP に対する BFD サポートの設定」

「OSPF に対する BFD サポートの設定」

EIGRP に対する BFD サポートの設定

ここでは、EIGRP が BFD の登録プロトコルとなり、BFD から転送パスの検出障害メッセージを受信するように、EIGRP に対する BFD サポートを設定する手順について説明します。EIGRP に対する BFD サポートをイネーブルにするには、2 つの方法があります。

ルータ コンフィギュレーション モードで bfd all-interfaces コマンドを使用して、EIGRP がルーティングしているすべてのインターフェイスに対して BFD をイネーブルにできます。

ルータ コンフィギュレーション モードで bfd interface type number コマンドを使用して、EIGRP がルーティングしているインターフェイスのサブセットに対して BFD をイネーブルにできます。

前提条件

EIGRP は、関連するすべてのスイッチで実行する必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの設定」を参照してください。

EIGRP に対する BFD サポートを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

enable
 
Switch> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal
 
Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Switch eigrp as-number
 
Switch(config)# router eigrp 123

EIGRP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

bfd all-interfaces
or
bfd interface type number
 
Switch(config-router)# bfd all-interfaces
or
 
Switch(config-router)# bfd interface gigabitethernet 6/1

EIGRP ルーティング プロセスに関連付けられたすべてのインターフェイスで、BFD をグローバルにイネーブルにします。

または

EIGRP ルーティング プロセスに関連付けられた 1 つ以上のインターフェイスに対して、インターフェイスごとに BFD をイネーブルにします。

ステップ 5

end
 
Switch(config-router) end

スイッチ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 6

show bfd neighbors [ details ]
 
Switch# show bfd neighbors details

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されることを確認します。

ステップ 7

show ip eigrp interfaces [ type number ] [ as-number ] [ detail ]
 
Switch# show ip eigrp interfaces detail

(任意)EIGRP に対する BFD サポートがイネーブルになっているインターフェイスを表示します。

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次の項を参照してください。

「OSPF に対する BFD サポートの設定」

OSPF に対する BFD サポートの設定

ここでは、OSPF が BFD の登録プロトコルとなり、BFD から転送パスの検出障害メッセージを受信するように、OSPF に対する BFD サポートを設定する手順について説明します。すべてのインターフェイスでグローバルに OSPF に対する BFD を設定するか、または 1 つ以上のインターフェイスで選択的に設定することができます。

OSPF に対する BFD サポートをイネーブルにするには、2 つの方法があります。

ルータ コンフィギュレーション モードで bfd all-interfaces コマンドを使用して、OSPF がルーティングしているすべてのインターフェイスに対して BFD をイネーブルにできます。インターフェイス コンフィギュレーション モードで ip ospf bfd [ disable ] コマンドを使用して、個々のインターフェイスで BFD をディセーブルにできます。

インターフェイス コンフィギュレーション モードで ip ospf bfd コマンドを使用して、OSPF がルーティングしているインターフェイスのサブセットに対して BFD をイネーブルにできます。

OSPF に対する BFD サポートのタスクについては、次の項を参照してください。

「すべてのインターフェイスの OSPF に対する BFD サポートの設定」(任意)

「1 つ以上のインターフェイスの OSPF に対する BFD サポートの設定」(任意)

すべてのインターフェイスの OSPF に対する BFD サポートの設定

すべての OSPF インターフェイスに BFD を設定するには、この項の手順に従います。

すべての OSPF インターフェイスに対して BFD を設定するのではなく、特定の 1 つ以上のインターフェイスに対して BFD サポートを設定する場合は、「1 つ以上のインターフェイスの OSPF に対する BFD サポートの設定」を参照してください。

前提条件

OSPF は、参加しているすべてのスイッチで実行されている必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの設定」を参照してください。

すべてのインターフェイスで、OSPF に対する BFD サポートを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

enable
 
Switch> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal
 
Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Switch ospf process-id
 
Switch(config)# router ospf 4

OSPF プロセスを指定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

bfd all-interfaces
 
Switch(config-router)# bfd all-interfaces

OSPF ルーティング プロセスに関連付けられたすべてのインターフェイスで、BFD をグローバルにイネーブルにします。

ステップ 5

end
 
Switch(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 6

show bfd neighbors [ details ]
 
Switch# show bfd neighbors detail

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されるかどうかの検証に使用できる情報を表示します。

ステップ 7

show ip ospf
 
Switch# show ip ospf

(任意)OSPF に対して BFD がイネーブルになっているかどうかを検証するために使用できる情報を表示します。

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次の項を参照してください。

「BGP に対する BFD サポートの設定」

「EIGRP に対する BFD サポートの設定」

1 つ以上のインターフェイスの OSPF に対する BFD サポートの設定

1 つ以上の OSPF インターフェイスで BFD を設定するには、この項の手順に従います。

前提条件

OSPF は、参加しているすべてのスイッチで実行されている必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの設定」を参照してください。

1 つ以上のインターフェイスで OSPF の BFD サポーターを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

enable
 
Switch> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal
 
Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number
 
Switch(config)# interface gigabitethernet 6/1

インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip ospf bfd [ disable ]
 
Switch(config-if)# ip ospf bfd

OSPF ルーティング プロセスに関連付けられた 1 つ以上のインターフェイスに対して、インターフェイスごとに BFD をイネーブルまたはディセーブルにします。

キーワードを使用する必要があります。

ステップ 5

end
 
Switch(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 6

show bfd neighbors [ details ]
 
Switch# show bfd neighbors details

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されるかどうかの検証に使用できる情報を表示します。

neighbors details コマンドの出力には、変更された間隔ではなく、設定された間隔が表示されます。

ステップ 7

show ip ospf
 
Switch# show ip ospf

(任意)OSPF に対して BFD サポートがイネーブルになっているかどうかを検証するために使用できる情報を表示します。

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次の項を参照してください。

「BGP に対する BFD サポートの設定」

「EIGRP に対する BFD サポートの設定」

スタティック ルーティングのための BFD サポートの設定

スタティック ルーティングのための BFD サポートを設定するには、このタスクを実行します。各 BFD ネイバーに対してこの手順を繰り返します。詳細については、「例:スタティック ルーティングのための BFD サポートの設定」を参照してください。

スタティック ルーティングのための BFD サポートを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

enable
 
Switch> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal
 
Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number
 
Switch(config)# interface gigabitethernet6/1

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

no switchport
 
Switch(config-if)# no switchport

レイヤ 3 にインターフェイスを変更します。

ステップ 5

ip address ip-address mask
 
Switch(config-if)# ip address 10.201.201.1 255.255.255.0

インターフェイスに IP アドレスを設定します。

ステップ 6

bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier
 
Switch(config-if)# bfd interval 500 min_rx 500 multiplier 5

インターフェイスで BFD をイネーブルにします。

ステップ 7

exit
 
Switch(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

ip route static bfd interface-type interface-number ip-address [ group group-name [ passive ]]
 
Switch(config)# ip route static bfd
Gi6/1 10.1.1.1 group group1 passive

スタティック ルートの BFD ネイバーを指定します。

BFD が直接接続されたネイバーだけでサポートされているため、 interface-type interface-number 、および ip-address 引数は必須です。

ステップ 9

ip route [ vrf vrf-name ] prefix mask { ip- address | interface-type interface-number [ ip-address ]} [ dhcp ] [ distance ] [ name next-hop-name ] [ permanent | track number ] [ tag tag ]

 

Switch(config)# ip route 10.0.0.0 255.0.0.0

Gi6/1 10.201.201.2

スタティック ルートの BFD ネイバーを指定します。

ステップ 10

exit

 

Switch(config)# exit

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 11

show ip static route

 

Switch# show ip static route

(任意)スタティック ルート データベース情報を表示します。

ステップ 12

show ip static route bfd

 
Switch# show ip static route bfd

(任意)設定された BFD グループおよび nongroup エントリからスタティック BFD の設定に関する情報を表示します。

ステップ 13

exit

 

Switch# exit

特権 EXEC モードを終了し、ユーザ EXEC モードに戻ります。

BFD エコー モードの設定

デフォルトでは BFD エコー モードがイネーブルになっていますが、方向ごとに個別に実行できるように、ディセーブルにすることもできます。

BFD エコー モードは非同期 BFD で動作します。エコー パケットはフォワーディング エンジンによって送信され、検出を実行するために、同じパスで転送されます。反対側の BFD セッションはエコー パケットの実際のフォワーディングに関与しません。エコー機能およびフォワーディング エンジンが検出プロセスを処理するため、2 つの BFD ネイバー間で送信される BFD 制御パケットの数が減少します。また、フォワーディング エンジンが、リモート システムを介さずにリモート(ネイバー)システムの転送パスをテストするため、パケット内遅延が向上する可能性があり、それによって BFD バージョン 0 を BFD セッションの BFD 制御パケットを使用する場合に、障害検出時間を短縮できます。

エコー モードを両端で実行している(両方の BFD ネイバーがエコー モードを実行している)場合は、非対称性がないと表現されます。

前提条件

BFD は、参加しているすべてのスイッチで実行されている必要があります。

CPU 使用率の上昇を避けるために、BFD エコー モードを使用する前に、 no ip redirects コマンドを入力して、インターネット制御メッセージ プロトコル(ICMP)リダイレクト メッセージの送信をディセーブルにする必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの設定」を参照してください。

制約事項 

BFD バージョン 1 でサポートされる BFD エコー モード。

ここでは、BFD エコー モードの次の設定タスクについて説明します。

「BFD 低速タイマーの設定」

「非対称性のない BFD エコー モードのディセーブル化」


) BFD エコー モードは、Unicast Reverse Path Forwarding(uRPF; ユニキャスト リバース パス転送)の設定との組み合わせでは動作しません。BFD エコー モードと uRPF の設定がイネーブルの場合、セッションはフラップします。


BFD 低速タイマーの設定

この手順では、BFD の slow timer 値を変更する方法を示します。各 BFD スイッチに対してこの手順を繰り返します。

BFD 低速タイマーを設定する手順は、次のとおりです。

 

コマンドまたはアクション
目的

ステップ 1

enable
 
Switch> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal
 
Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

bfd slow-timer milliseconds
 
Switch(config)# bfd slow-timer 12000

BFD の slow timer を設定します。

ステップ 4

end
 
Switch(config)# end

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

非対称性のない BFD エコー モードのディセーブル化

この手順では、非対称性のない BFD エコー モードをディセーブルにする方法を示します。スイッチからエコー パケットが送信されず、スイッチはネイバー スイッチが受信した BFD エコー パケットを転送しません。

各 BFD スイッチに対してこの手順を繰り返します。

非対称性のない BFD エコー モードをディセーブルにするには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Switch> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Switch(config)# interface GigabitEthernet 6/1

インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

no bfd echo

 

Switch(config-if)# no bfd echo

BFD エコー モードをディセーブルにします。

ステップ 5

end

 

Switch(config-if)# end

グローバル設定モードを終了し、スイッチをグローバル コンフィギュレーション モードに戻します。

BFD のモニタリングとトラブルシューティング

ここでは、維持とトラブルシューティングのために BFD 情報を取得する方法について説明します。必要に応じてこれらのタスクのコマンドを、正しい順序で入力します。

BFD セッションの開始と障害の詳細については、「BFD の動作」を参照してください。

BFD のモニタリングとトラブルシューティングを行うには、次の手順を実行します。

 

コマンドまたはアクション
目的

ステップ 1

enable
 
Switch> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show bfd neighbors [ details ]
 
Switch# show bfd neighbors details

(任意)BFD 隣接関係データベースを表示します。

details キーワードを指定すると、すべての BFD プロトコル パラメータとネイバーごとにタイマーが表示されます。

ステップ 3

debug bfd [ packet | event ]
 
Switch# debug bfd packet

(任意)BFD パケットのデバッグ情報を表示します。

双方向フォワーディング検出の設定例

ここでは、次の設定例を示します。

「例:エコー モードがデフォルトでイネーブルになった EIGRP ネットワークでの BFD の設定」

「例:OSPF ネットワークでの BFD の設定」

「例:BGP ネットワークでの BFD ハードウェア オフロード サポートの設定」

「例:スタティック ルーティングのための BFD サポートの設定」

例:エコー モードがデフォルトでイネーブルになった EIGRP ネットワークでの BFD の設定

次に、Cisco IOS Release 15.1(1) SG で、デフォルトではイネーブルなエコー モードによって、EIGRP ネットワークの BFD を設定する例を示します。次の例では、EIGRP ネットワークにスイッチ A、スイッチ B およびスイッチ C が含まれます。スイッチ A のギガビット イーサネット インターフェイス 6/1 が、スイッチ B のギガビット イーサネット インターフェイス 6/1 と同じネットワークに接続されます。スイッチ B のギガビット イーサネット インターフェイス 6/1 が、スイッチ C のギガビット イーサネット インターフェイス 6/1 と同じネットワークに接続されます。

スイッチ A とスイッチ B がエコー モードをサポートした BFD バージョン 1 を実行し、スイッチ C はエコー モードをサポートしていない BFD バージョン 0 を実行しています。スイッチ C とその BFD ネイバー間の BFD セッションは、非対称でエコー モードを実行しています。これは、エコー モードがルート A およびスイッチ B の転送パスで実行され、それぞれのエコー パケットが BFD セッションと障害検出のために同じパスに沿って返されるのに対して、BFD ネイバー スイッチ C は、BFD バージョン 0 を実行し、BFD セッションと障害検出のために BFD 制御パケットを使用するためです。

図 37-3 に、複数のスイッチがある大規模な EIGRP ネットワークを示します。その中の 3 台は、ルーティング プロトコルとして EIGRP を実行している BFD ネイバーです。

図 37-3 V1 または V0 を実行する 3 台の BFD ネイバーがある EIGRP ネットワーク

この例は、グローバル コンフィギュレーション モードから開始し、BFD の設定を示します。

スイッチ A の設定:

interface GigabitEthernet6/2
no switch
ip address 10.4.9.14 255.255.255.0
!
interface GigabitEthernet6/1
no switchport
ip address 172.16.1.1 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
no shutdown
!
router eigrp 11
network 172.16.0.0
bfd all-interfaces
auto-summary
!
ip default-gateway 10.4.9.1
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.4.9.1
ip route 172.16.1.129 255.255.255.255 10.4.9.1
!

スイッチ B の設定:

!
interface GigabitEthernet6/2
no switchport
ip address 10.4.9.34 255.255.255.0
!
interface GigabitEthernet6/1
no switchport
ip address 172.16.1.2 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
!
router eigrp 11
network 172.16.0.0
bfd all-interfaces
auto-summary
!
ip default-gateway 10.4.9.1
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.4.9.1
ip route 172.16.1.129 255.255.255.255 10.4.9.1
!

スイッチ C の設定:

!
!
interface GigabitEthernet6/2
no switchport
no shutdown
ip address 10.4.9.34 255.255.255.0
!
interface GigabitEthernet6/1
no switchport
ip address 172.16.1.3 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
no shutdown
!
router eigrp 11
network 172.16.0.0
bfd all-interfaces
auto-summary
!
ip default-gateway 10.4.9.1
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.4.9.1
ip route 172.16.1.129 255.255.255.255 10.4.9.1
!
!
end
 

スイッチ A からの show bfd neighbors details コマンドの出力で、3 台のすべてのスイッチで BFD セッションが作成され、EIGRP が BFD サポートに対して登録されることを確認できます。出力の最初のグループは、IP アドレスが 172.16.1.3 のスイッチ C が BFD バージョン 0 を実行しているため、エコー モードを使用しないことを示します。出力の 2 番目のグループは、IP アドレスが 172.16.1.2 のスイッチ B が BFD バージョン 1 を実行していて、50 ミリ秒の BFD interval パラメータが使用されていることを示します。この出力では、対応するコマンド出力が太字で表示されています。

スイッチ A

SwitchA# show bfd neighbors details
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.1 172.16.1.3 5/3 1(RH) 150 (3 ) Up Gi6/1
Session state is UP and not using echo function.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holdown (hits): 150(0), Hello (hits): 50(1364284)
Rx Count: 1351813, Rx Interval (ms) min/max/avg: 28/64/49 last: 4 ms ago
Tx Count: 1364289, Tx Interval (ms) min/max/avg: 40/68/49 last: 32 ms ago
Registered protocols: EIGRP
Uptime: 18:42:45
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 3 - Your Discr.: 5
Min tx interval: 50000 - Min rx interval: 50000
Min Echo interval: 0
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.1 172.16.1.2 6/1 Up 0 (3 ) Up Gi6/1
Session state is UP and using echo function with 50 ms interval.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holdown (hits): 3000(0), Hello (hits): 1000(317)
Rx Count: 305, Rx Interval (ms) min/max/avg: 1/1016/887 last: 448 ms ago
Tx Count: 319, Tx Interval (ms) min/max/avg: 1/1008/880 last: 532 ms ago
Registered protocols: EIGRP
Uptime: 00:04:30
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 1 - Your Discr.: 6
Min tx interval: 1000000 - Min rx interval: 1000000
Min Echo interval: 50000
 

スイッチ B からの how bfd neighbors details コマンドの出力で、BFD セッションが作成され、EIGRP が BFD サポートに対して登録されていることを確認できます。前述のように、スイッチ A は BFD バージョン 1 を実行するため、エコー モードを実行しており、スイッチ C は BFD バージョン 0 を実行するため、エコー モードを実行しません。この出力では、対応するコマンド出力が太字で表示されています。

スイッチ B

SwitchB# show bfd neighbors details
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.2 172.16.1.1 1/6 Up 0 (3 ) Up Gi6/1
Session state is UP and using echo function with 50 ms interval.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holdown (hits): 3000(0), Hello (hits): 1000(337)
Rx Count: 341, Rx Interval (ms) min/max/avg: 1/1008/882 last: 364 ms ago
Tx Count: 339, Tx Interval (ms) min/max/avg: 1/1016/886 last: 632 ms ago
Registered protocols: EIGRP
Uptime: 00:05:00
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 6 - Your Discr.: 1
Min tx interval: 1000000 - Min rx interval: 1000000
Min Echo interval: 50000
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.2 172.16.1.3 3/6 1(RH) 118 (3 ) Up Gi6/1
Session state is UP and not using echo function.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holdown (hits): 150(0), Hello (hits): 50(5735)
Rx Count: 5731, Rx Interval (ms) min/max/avg: 32/72/49 last: 32 ms ago
Tx Count: 5740, Tx Interval (ms) min/max/avg: 40/64/50 last: 44 ms ago
Registered protocols: EIGRP
Uptime: 00:04:45
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 6 - Your Discr.: 3
Min tx interval: 50000 - Min rx interval: 50000
Min Echo interval: 0
 

図 37-4 は、スイッチ B でギガビット イーサネット インターフェイス 6/1 に障害が発生した状態を示しています。スイッチ B でギガビット イーサネット インターフェイス 6/1 をシャット ダウンした場合、スイッチ A とスイッチ B に対応する BFD セッションの BFD 値が小さくなります。

図 37-4 ギガビット イーサネット インターフェイス 6/1 の障害

スイッチ B でギガビット イーサネット インターフェイス 6/1 に障害が発生すると、BFD はスイッチ A またはスイッチ C の BFD ネイバーとしてスイッチ B を検出しなくなります。この例では、スイッチ B でギガビット イーサネット インターフェイス 6/1 が管理的にシャット ダウンされています。

スイッチ A での show bfd neighbors コマンドからの次の出力では、EIGRP ネットワークのスイッチ A に対する唯一の BFD ネイバーを示します。この出力では、対応するコマンド出力が太字で表示されています。

SwitchA# show bfd neighbors
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.1 172.16.1.3 5/3 1(RH) 134 (3 ) Up Gi6/1
 

スイッチ C での show bfd neighbors コマンドからの次の出力では、EIGRP ネットワークのスイッチ C に対する唯一の BFD ネイバーも示します。この出力では、対応するコマンド出力が太字で表示されています。

SwitchC# show bfd neighbors
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.1.3 172.16.1.1 3/5 1 114 (3 ) Up Gi6/1

例:OSPF ネットワークでの BFD の設定

次に、Cisco IOS Release 15.1(1) SG で、OSPF ネットワークの BFD を設定する例を示します。次の例は、スイッチ A とスイッチ B で構成される単純な OSPF ネットワークです。スイッチ A のギガビット イーサネット インターフェイス 6/1 が、スイッチ B のギガビット イーサネット インターフェイス 6/1 と同じネットワークに接続されます。この例は、グローバル コンフィギュレーション モードから開始し、BFD の設定を示します。スイッチ A とスイッチ B に対して、OSPF プロセスに関連付けられたすべてのインターフェイスで、BFD がグローバルに設定されます。

スイッチ A の設定:

!
interface GigsbitEthernet 6/1
no switchport
ip address 172.16.10.1 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
!
interface GigsbitEthernet 6/2
no switchport
ip address 172.17.0.1 255.255.255.0
!
router ospf 123
log-adjacency-changes detail
network 172.16.0.0 0.0.0.255 area 0
network 172.17.0.0 0.0.0.255 area 0
bfd all-interfaces

スイッチ B の設定:

!
interface GigsbitEthernet 6/1
no switchport
ip address 172.16.10.2 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
!
interface GigsbitEthernet 6/2
no switchport
ip address 172.18.0.1 255.255.255.0
!
router ospf 123
log-adjacency-changes detail
network 172.16.0.0 0.0.255.255 area 0
network 172.18.0.0 0.0.255.255 area 0
bfd all-interfaces
 

show bfd neighbors details コマンドの出力で、BFD セッションが作成され、BFD サポートに対して OSPF が登録されることを確認できます。この出力では、対応するコマンド出力が太字で表示されています。

スイッチ A

SwitchA# show bfd neighbors details
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.10.1 172.16.10.2 1/2 1 532 (3 ) Up Gi6/1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 200000, MinRxInt: 200000, Multiplier: 5
Received MinRxInt: 1000, Received Multiplier: 3
Holdown (hits): 600(22), Hello (hits): 200(84453)
Rx Count: 49824, Rx Interval (ms) min/max/avg: 208/440/332 last: 68 ms ago
Tx Count: 84488, Tx Interval (ms) min/max/avg: 152/248/196 last: 192 ms ago

Registered protocols: OSPF

Uptime: 02:18:49
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 2 - Your Discr.: 1
Min tx interval: 50000 - Min rx interval: 1000
Min Echo interval: 0
 

スイッチ B での show bfd neighbors details コマンドの出力で、BFD セッションが作成されたことを確認できます。

スイッチ B

SwitchB# attach 6
 
Switch> show bfd neighbors details
 
Cleanup timer hits: 0
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.10.2 172.16.10.1 8/1 1 1000 (5 ) Up Gi6/1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 1000, Multiplier: 3
Received MinRxInt: 200000, Received Multiplier: 5
Holdown (hits): 1000(0), Hello (hits): 200(5995)
Rx Count: 10126, Rx Interval (ms) min/max/avg: 152/248/196 last: 0 ms ago
Tx Count: 5998, Tx Interval (ms) min/max/avg: 204/440/332 last: 12 ms ago
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 5 - Length: 24
My Discr.: 1 - Your Discr.: 8
Min tx interval: 200000 - Min rx interval: 200000
Min Echo interval: 0
Uptime: 00:33:13
SSO Cleanup Timer called: 0
SSO Cleanup Action Taken: 0
Pseudo pre-emptive process count: 239103 min/max/avg: 8/16/8 last: 0 ms ago
IPC Tx Failure Count: 0
IPC Rx Failure Count: 0
Total Adjs Found: 1
 

show ip ospf コマンドの出力で、BFD が OSPF に対してイネーブルになっていることを確認できます。この出力では、対応するコマンド出力が太字で表示されています。

スイッチ A

SwitchA# show ip ospf
 
Routing Process "ospf 123" with ID 172.16.10.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0

BFD is enabled

Area BACKBONE(0)
Number of interfaces in this area is 2 (1 loopback)
Area has no authentication
SPF algorithm last executed 00:00:08.828 ago
SPF algorithm executed 9 times
Area ranges are
Number of LSA 3. Checksum Sum 0x028417
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 

スイッチ B

SwitchB# show ip ospf
 
Routing Process "ospf 123" with ID 172.18.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x0
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0

BFD is enabled

Area BACKBONE(0)
Number of interfaces in this area is 2 (1 loopback)
Area has no authentication
SPF algorithm last executed 02:07:30.932 ago
SPF algorithm executed 7 times
Area ranges are
Number of LSA 3. Checksum Sum 0x28417
Number of opaque link LSA 0. Checksum Sum 0x0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 

show ip ospf interface コマンドの出力で、スイッチ A とスイッチ B を接続しているインターフェイスで OSPF に対して BFD がイネーブルになっていることを確認できます。この出力では、対応するコマンド出力が太字で表示されています。

スイッチ A

SwitchA# show ip ospf interface gigabitethernet 6/1
 
show ip ospf interface gigabitethernet 6/1
Gigabitethernet 6/1 is up, line protocol is up
Internet Address 172.16.10.1/24, Area 0
Process ID 123, Router ID 172.16.10.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1, BFD enabled
Designated Router (ID) 172.18.0.1, Interface address 172.16.10.2
Backup Designated router (ID) 172.16.10.1, Interface address 172.16.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 172.18.0.1 (Designated Router)
Suppress hello for 0 neighbor(s)

スイッチ B

SwitchB# show ip ospf interface gigabitethernet 6/1
 
Gigabitethernet 6/1 is up, line protocol is up
Internet Address 172.18.0.1/24, Area 0
Process ID 123, Router ID 172.18.0.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1, BFD enabled
Designated Router (ID) 172.18.0.1, Interface address 172.18.0.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)

例:BGP ネットワークでの BFD ハードウェア オフロード サポートの設定

次に、Cisco IOS Release 15.1(1) SG で、BGP ネットワークの BFD ハードウェア オフロード サポートを設定する例を示します。次の例は、スイッチ A とスイッチ B で構成される単純な BGP ネットワークです。スイッチ A のギガビット イーサネット インターフェイス 6/1 が、スイッチ B のギガビット イーサネット インターフェイス 6/1 と同じネットワークに接続されます。

スイッチ A の設定:

!
interface GigabitEthernet 6/1
no switchport
ip address 1.1.1.1 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
no bfd echo
 
router bgp 10
neighbor 1.1.1.2 remote-as 10
neighbor 1.1.1.2 fall-over bfd
!

スイッチ B の設定:

!
interface GigabitEthernet 6/1
no switchport
ip address 1.1.1.2 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
no bfd echo
 
 
router bgp 10
neighbor 1.1.1.1 remote-as 10
neighbor 1.1.1.1 fall-over bfd
!
 

スイッチ A からの show bfd neighbors details コマンドの出力で、BFD セッションが作成され、BFD サポートに対して BGP が登録されることを確認できます。この出力では、対応するコマンド出力が太字で表示されています。

スイッチ A

SwitchA# show bfd neighbors details
 
IPv4 Sessions
NeighAddr LD/RD RH/RS State Int
1.1.1.1 1/1 Up Up Gi3/2
Session state is UP and not using echo function.
Session Host: Hardware
OurAddr: 1.1.1.2
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 50(0)
Rx Count: 8678
Tx Count: 8680
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Uptime: 00:06:18
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 1 - Your Discr.: 1
Min tx interval: 50000 - Min rx interval: 50000
Min Echo interval: 0
 

スイッチ B での show bfd neighbors details コマンドの出力で、BFD セッションが作成されたことを確認できます。

スイッチ B

SwitchB# attach 6
 
Switch> show bfd neighbors details
 
IPv4 Sessions
NeighAddr LD/RD RH/RS State Int
1.1.1.2 1/1 Up Up Gi1/2
Session state is UP and not using echo function.
Session Host: Hardware
OurAddr: 1.1.1.1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 50(0)
Rx Count: 10138
Tx Count: 10139
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Uptime: 00:07:22
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 1 - Your Discr.: 1
Min tx interval: 50000 - Min rx interval: 50000
Min Echo interval: 0
 

show ip bgp neighbors コマンドの出力で、BFD が BGP ネイバーに対してイネーブルになっていることを確認できます。

スイッチ A

SwitchA# show ip bgp neighbors
 
BGP neighbor is 1.1.1.2, remote AS 45000, external link
Using BFD to detect fast fallover
..

スイッチ B

SwitchB# show ip bgp neighbors
 
BGP neighbor is 1.1.1.1, remote AS 40000, external link
Using BFD to detect fast fallover
..

例:スタティック ルーティングのための BFD サポートの設定

次の例は、スイッチ A とスイッチ B で構成されるネットワークです。スイッチ A のギガビット イーサネット インターフェイス 6/1 が、スイッチ B のギガビット イーサネット インターフェイス 6/1 と同じネットワークに接続されます。起動する BFD セッションに対して、スイッチ B を設定する必要があります。

スイッチ A

configure terminal
no switchport
interface Gigabit Ethernet 6/1
ip address 10.201.201.1 255.255.255.0
bfd interval 500 min_rx 500 multiplier 5
ip route static bfd Gigabit Ethernet 6/1 10.201.201.2
ip route 10.0.0.0 255.0.0.0 Gigabit Ethernet 6/1 10.201.201.2

スイッチ B

configure terminal
no switchport
interface Gigabit Ethernet 6/1
ip address 10.201.201.2 255.255.255.0
bfd interval 500 min_rx 500 multiplier 5
ip route static bfd Gigabit Ethernet 6/1 10.201.201.1
ip route 10.1.1.1 255.255.255.255 Gigabit Ethernet 6/1 10.201.201.1

) スイッチ B のスタティック ルートが単独で存在していて、10.201.201.1 と 10.201.201.2 の間で BFD セッションをイネーブルにします。設定する有益なスタティック ルートがない場合、パケットの転送に影響しないプレフィックス、たとえば、ローカルで設定されたループバック インターフェイスを選択します。


その他の関連資料

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Command List, All Releases』

BGP の設定とモニタリング

Cisco IOS IP Routing Protocols Configuration Guide 』の「 Cisco BGP Overview 」の章

EIGRP の設定とモニタリング

Cisco IOS IP Routing Protocols Configuration Guide 』の「 Configuring EIGRP」の章

OSPF の設定とモニタリング

Cisco IOS IP Routing Protocols Configuration Guide 』の 「Configuring OSPF 」の章

BFD コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Routing: Protocol-Independent Command Reference』

BGP コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Routing: Protocol-Independent Command Reference』

EIGRP コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Routing: Protocol-Independent Command Reference』

OSPF コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Routing: Protocol-Independent Command Reference』

標準

標準
タイトル

IETF ドラフト

BFD for IPv4 and IPv6 (Single Hop) 、2009 年 2 月

IETF ドラフト

Bidirectional Forwarding Detection 、2009 年 2 月

管理情報ベース(MIB)

MIB
MIB へのリンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html