Catalyst 4500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース 12.2(44)SG
WCCP バージョン 2 サービスの設定
WCCP バージョン 2 サービスの設定
発行日;2013/08/06 | 英語版ドキュメント(2011/12/19 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 15MB) | フィードバック

目次

WCCP バージョン 2 サービスの設定

WCCP の概要

WCCP の概要

ハードウェアの加速

WCCP 構成の概要

WCCP の機能

HTTP および非 HTTP サービスのサポート

複数ルータのサポート

MD5 セキュリティ

Web コンテンツ パケットの返送

WCCP に関する制約事項

WCCP の設定

WCCP を使用したサービス グループの設定

Web キャッシュ サービスの指定

WCCP サービス グループのアクセス リストの使用

ルータおよびキャッシュ エンジンのパスワードの設定

WCCP 設定の確認およびモニタリング

WCCP の設定例

一般的な WCCP 設定の実行例

Web キャッシュ サービスの実行例

逆プロキシ サービスの実行例

アクセス リストの使用例

スイッチおよびコンテント エンジンへのパスワードの設定例

WCCP 設定の確認例

WCCP バージョン 2 サービスの設定


) WCCP v2 は Supervisor Engine 6-E でサポートされていません。


この章では、Catalyst 4500 シリーズ スイッチを設定し、Web Cache Communication Protocol(WCCP)バージョン 2 を使用してコンテント エンジンWeb キャッシュ)にトラフィックをリダイレクトする方法を説明します。


) この章の WCCP は WCCP バージョン 2 を表します。WCCP バージョン 1 はサポートされません。


この章の内容は、次のとおりです。

「WCCP の概要」

「WCCP に関する制約事項」

「WCCP の設定」

「WCCP 設定の確認およびモニタリング」

「WCCP の設定例」


) この章の作業は、コンテント エンジンがネットワークに設定されていることを前提にしています。Cisco コンテンツ エンジンおよび WCCP に関連付けられたハードウェアとネットワークの計画に関する情報については、次の場所にある Cisco.com から入手可能な製品マニュアルのリンクを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/configfun/configuration/guide/fcf018_ps1835_TSD_Products_Configuration_Guide_Chapter.html

および

http://www.cisco.com/en/US/tech/tk122/tk717/tsd_technology_support_protocol_home.html


WCCP の概要

ここでは WCCP について説明します。

「WCCP の概要」

「ハードウェアの加速」

「WCCP 構成の概要」

「WCCP の機能」

WCCP の概要

WCCP はシスコが開発したコンテンツ ルーティング技術で、ネットワーク インフラストラクチャにコンテント エンジンを統合することができます。

Cisco IOS WCCP 機能を使用すると、Cisco Content Engine(または WCCP を実行する他のコンテント エンジン)を使用してネットワークの Web トラフィック パターンをローカライズし、コンテンツ要求をローカルで処理できます。トラフィックのローカライズによって伝送コストを引き下げ、ダウンロード時間を短縮できます。

WCCP によって、Cisco IOS ルーティング プラットフォームはコンテンツ要求をトランスペアレントにリダイレクトできます。HTTP 要求の透過的なリダイレクトの主な利点は、ユーザが自分のブラウザを Web プロキシを使用するように設定しないですむことです。ユーザはターゲット URL を使用してコンテンツを要求できます。また、ユーザの要求はコンテンツ エンジンに自動的にリダイレクトされます。この場合の「透過的」とは、要求したファイル(Web ページなど)がコンテンツ エンジンから送信されたものであり、指定したサーバから送信されたものではないことがエンド ユーザにはわからないという意味です。

要求を受信したコンテント エンジンは、自分のローカル コンテンツを使用して要求に応じようとします。要求した情報が存在しない場合、コンテンツ エンジンから独自の要求が元のターゲット サーバに発行され、必要な情報が取得されます。コンテンツ エンジンは、要求された情報を取得すると、要求クライアントに転送し、以降の要求に対応するためにキャッシュします。そのため、ダウンロードのパフォーマンスが大きく向上し、送信コストが大幅に削減されます。

WCCP により、一連のコンテント エンジン( コンテント エンジン クラスタ と呼ぶ)が 1 つまたは複数のルータにコンテンツを提供できます。ネットワーク管理者は、このようなクラスタ処理機能を通じて使用するコンテント エンジンを簡単に拡張して、トラフィック負荷が重い場合でも処理することができます。シスコのクラスタ処理技術により、それぞれのコンテンツ メンバの同時動作が可能になり、直線的なスケーラビリティが実現します。クラスタ処理コンテンツ エンジンによって、キャッシュ ソリューションのスケーラビリティ、冗長性、および可用性が大幅に改善されます。最大 32 個のコンテンツ エンジンをクラスタ処理し、目的の容量まで拡張できます。

ハードウェアの加速

Catalyst 4500 シリーズ スイッチに Cisco Content Engine が直接接続されているとハードウェアが加速されます。これは、ソフトウェアのレイヤ 3 リダイレクションよりも効率的です。

直接接続されたコンテント エンジンを設定して、WCCP レイヤ 2 リダイレクション機能をマスク割り当てテーブルに基づいたロード バランシングとともに使用するようにネゴシエーションできるようにする必要があります。The show ip wccp web-cache detail コマンドを実行すると、それぞれのキャッシュで使用されるリダイレクション方法が表示されます。


) WCCP レイヤ 2 リダイレクション機能をマスク割り当てテーブルとともに使用するように設定できるのは、Cisco Content Engine ソフトウェア リリース 2.2 以上のリリースです。


WCCP 構成の概要


) WCCPv1 はサポートされません。


1 つのキャッシュ クラスタにサービスを提供するために複数のルータで WCCP を使用できます。図 49-1 に、複数のルータを使用した構成例を示します。

図 49-1 WCCP を使用した Cisco Content Engine ネットワーク構成

 

クラスタ、および同じサービスを実行しているクラスタに接続するルータ内のコンテンツ エンジンのサブセットは、サービス グループと呼ばれます。利用可能なサービスには、TCP およびユーザ データグラム プロトコル(UDP)リダイレクションがあります。

WCCP では、それぞれのコンテント エンジンは、サービス グループ内のすべてのルータを認識する必要があります。サービス グループ内のすべてのルータのアドレスを指定するには、次のいずれかの方法を選択する必要があります。

ユニキャスト:グループ内の各ルータのルータ アドレス リストを、各コンテンツ エンジンで設定します。この場合、グループ内の各ルータのアドレスは、設定時に各コンテンツ エンジンについて明示的に指定する必要があります。

マルチキャスト:単一のマルチキャスト アドレスを各コンテンツ エンジンで設定します。マルチキャスト アドレス方式の場合、コンテンツ エンジンは、サービス グループのすべてのルータに提供するシングル アドレス通知を送信します。たとえば、コンテンツ エンジンは、パケットを常にマルチキャスト アドレス 224.0.0.100 に送信するように示すことができます。それによって、マルチキャスト パケットは、WCCP を使用してリッスンしているグループ用に設定されたサービス グループ内のすべてのルータに送信されます(詳細については、 ip wccp group-listen インターフェイス コンフィギュレーション コマンドを参照してください)。

マルチキャスト オプションの場合に必要な操作は、各コンテンツ エンジンで単一のアドレスを指定することだけなので、設定が容易です。またこの方法では、コンテント エンジンに毎回異なるアドレスのリストを再設定せずに、サービス グループにダイナミックにルータを追加したり削除したりすることができます。

次のような流れで、WCCP 設定は機能します。

1. 各コンテンツ エンジンは、ルータ リストを使用して設定します。

2. 各コンテンツ エンジンはプレゼンスと、通信の確立に使用されたすべてのルータ リストをアナウンスします。ルータは、グループ内のコンテンツ エンジンのビュー(リスト)で応答します。

3. クラスタのすべてのコンテント エンジンのビューが同じであれば、1 つのコンテント エンジンが先頭として指定され、パケットのリダイレクション時にルータで適用する必要があるポリシーを設定します。

次の項では、ルータに WCCP を設定してサービス グループに参加させる方法を説明します。

WCCP の機能

ここでは、WCCP の次の機能について説明します。

HTTP および非 HTTP サービスのサポート

複数ルータのサポート

MD5 セキュリティ

Web コンテンツ パケットの返送

HTTP および非 HTTP サービスのサポート

WCCP は HTTP トラフィック(TCP ポート 80 のトラフィック)および非 HTTP トラフィック(TCP および UDP)のリダイレクションを可能にします。WCCP は他のポート向けパケットのリダイレクションもサポートします。これには、プロキシ Web キャッシュ処理、ファイル転送プロトコル(FTP)キャッシング、FTP プロキシ処理、ポートの Web キャッシング(ポート 80 を除く)、および Real Audio、Video、テレフォニー アプリケーション用のパケットが含まれます。

さまざまなタイプのサービスが利用できるようにするために、WCCP には複数の サービス グループ という考え方が導入されています。ダイナミック サービス ID 番号(「98」など)または定義済みサービス キーワード(「web-cache」など)を使用して、WCCP コンフィギュレーション コマンドでサービス情報を指定します。この情報は、サービス グループ メンバーが同じサービスを使用または提供していることを確認するために使用されます。


) Catalyst 4500 シリーズ スイッチは、最大 8 つのサービス グループをサポートします。


ACNS バージョン 5.2 ソフトウェアでサポートされている WCCP バージョン 2 サービスについては、『 Release Notes for Cisco ACNS Software, Release 5.2.3』を参照してください。

サービス グループのコンテント エンジンは、プロトコル(TCP または UDP)およびポート(送信元または宛先)によってリダイレクトされるトラフィックを指定します。それぞれのサービス グループにはプライオリティ レベルが割り当てられています。パケットは、サービス グループに対してプライオリティ順に照合され、トラフィック特性に一致する最高のプライオリティのサービス グループによってリダイレクトされます。

複数ルータのサポート

WCCP では、複数のルータをキャッシュ エンジンのクラスタに追加できます。サービス グループで複数のルータを使用すると、冗長化、インターフェイス集約、およびリダイレクション負荷の分散が可能になります。

MD5 セキュリティ

WCCP には任意の認証機能があり、パスワードおよび HMAC MD5 標準を使用して、どのルータおよびコンテント エンジンがサービス グループの一部になるかを制御できます。共有秘密キー MD5 ワンタイム認証( ip wccp [ password [ 0-7 ] password ] グローバル コンフィギュレーション コマンドを使用して設定)では、メッセージを代行受信、検査、およびリプレイから保護します。

Web コンテンツ パケットの返送

エラーや過負荷のために、コンテント エンジンがキャッシュした要求オブジェクトを提供できない場合、コンテント エンジンは本来の宛先であるサーバに転送するように要求をルータに返します。WCCP は、どの要求がサービスを実行されずにコンテント エンジンから返されたかを確認します。ルータは、この情報を使用して、要求を本来の宛先サーバに転送します(コンテンツ クラスタに要求を再送信しません)。これにより、エラー処理はクライアントに対してトランスペアレントになります。

コンテンツ エンジンがパケットを拒否し、パケット返送機能を開始する場合、一般的に次のような理由があります。

コンテント エンジンが過負荷でパケットを処理する余裕がない

コンテント エンジンに一定のフィルタリングがあり、パケットのキャッシングは逆効果である(IP 認証がオンの場合など)

WCCP に関する制約事項

WCCP には次のような制約事項があります。

WCCP が動作するのは IP ネットワークだけです。

ルータをマルチキャスト クラスタに対応させるには、Time To Live(TTL)値を 15 以下に設定する必要があります。

ほとんどの場合、メッセージは IP マルチキャストのため、メンバは関係のないメッセージや重複メッセージを受信することがあります。適切なフィルタリングを実行する必要があります。

1 つのサービス グループは最大 32 のコンテント エンジンと 32 のルータで構成できます。

クラスタのすべてのコンテンツ エンジンは、クラスタにサービスを提供するすべてのルータと通信できるように設定する必要があります。

最大 8 つのサービス グループがクライアントの同一インターフェイス上で同時にサポートされます。

L2 再書き込み転送方式はサポートされていますが、GRE カプセル化はサポートされていません。

コンテント エンジンには L3 で直接接続する必要があります。1 つまたは複数のホップを経た L3 接続はサポートされません。

レイヤ 2 リダイレクションでは、コンテント エンジンおよびクライアント インターフェイスはルータに直接接続し、異なる IP サブネットワークに存在することが必要です。

TCAM と親和性の高いマスクベース割り当てはサポートされていますが、ハッシュ バケットベース方式はサポートされません。

クライアント インターフェイスでの WCCP のリダイレクト ACL はサポートされません。

インターフェイスでの着信トラフィックのリダイレクションはサポートされますが、発信トラフィックのリダイレクションはサポートされません。

TCAM の空きがなくなると、トラフィックはリダイレクトされず、通常どおりに転送されます。

WCCP バージョン 2 規格では、最大 256 個のマスクをサポートします。ただし、Catalyst 4500 シリーズ スイッチは、単一のマスクへのマスク割り当てテーブルだけをサポートします。

WCCP の設定

次の設定作業では、ネットワークで使用するコンテンツ エンジンのインストールと設定が完了していることを前提としています。クラスタにコンテント エンジンを設定してから、ルータで WCCP 機能を設定する必要があります。コンテント エンジンの構成およびセットアップについては、『 Cisco Content Engine User Guide 』を参照してください。

キャッシュ エンジンに接続されているルータ インターフェイスに IP を設定する必要があります。ルータの設定例は、この章で説明します。コマンド構文の詳細については、『 Cisco IOS Configuration Fundamentals Command Reference ,Cisco IOS Release 12.3』を参照してください。

次の項では、WCCP の設定方法について説明します。

「WCCP を使用したサービス グループの設定」(必須)

「WCCP サービス グループのアクセス リストの使用」(任意)

「ルータおよびキャッシュ エンジンのパスワードの設定」(任意)

WCCP を使用したサービス グループの設定

WCCP は、トラフィックの代行受信およびリダイレクトを行うために導入された論理リダイレクション サービスに基づいてサービス グループを使用します。標準サービスはコンテント エンジンで、TCP ポート 80(HTTP)トラフィックを代行受信してコンテント エンジンにリダイレクトします。このサービスは、Web キャッシュ サービスの特徴はルータとコンテンツ エンジンの両方から認識されているため、 既知のサービス と呼ばれます。サービス ID 以外の well-known サービスの記述は不要です(この場合はコマンドライン インターフェイス(CLI)がコマンド構文に web-cache キーワードを提供します)。

ACNS バージョン 5.2 ソフトウェアでサポートされる WCCP サービスについては、『Release Notes for Cisco ACNS Software, Release 5.2.3』を参照してください。

Web キャッシュ サービス以外にも、最大 7 つのダイナミック サービスをスイッチで同時に実行できます。


) スイッチでは同時に複数のサービスが実行できます。また、ルータおよびコンテント エンジンは、同時に複数のサービス グループの一部になることができます。


ダイナミック サービスは、コンテンツ エンジンによって定義されます。コンテンツ エンジンは、代行受信するプロトコルまたはポート、およびトラフィックの分散方法をルータに指示します。ダイナミック サービス グループのトラフィックの特徴に関する情報は、ルータ自体にはありません。この情報は、グループに参加する最初のコンテンツ エンジンから提供されるためです。ダイナミック サービスでは、1 つのプロトコル(TCP または UDP)に最大 8 つのポートを指定できます。

たとえば、Cisco Content Engine ではダイナミック サービス 99 を使用して、リバース プロキシ サービスを指定します。ただし、このサービス番号は、他のコンテント エンジンでは他のサービスに使用されることがあります。次の設定情報は、Cisco ルータで汎用サービスをイネーブルにするためのものです。コンテント エンジンにサービスを設定する場合の詳細については、コンテント エンジンのマニュアルを参照してください。

Catalyst 4500 シリーズ スイッチでサービスをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# ip wccp { web-cache | service-number } [ group-address groupaddress ] [ group-list access-list ] [ password password ]

スイッチでイネーブルにするダイナミック サービス、サービス グループで使用する IP マルチキャスト アドレス(任意)、コンテント エンジン メンバーシップに使用するグループ リスト(任意)、MD5 認証の使用の有無(任意)を指定し、WCCP サービスをイネーブルにします。

ステップ 2

Switch(config)# interface type number

設定するクライアント インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Switch(config-if)# ip wccp { web-cache | service-number } redirect in

指定したクライアント インターフェイスで、入力トラフィックの WCCP リダイレクションをイネーブルにします。

ステップ 4

Switch(config)# interface type number

(マルチキャスト機能を実行する場合にだけ必要)マルチキャストを受信するように設定するコンテント エンジン インターフェイスを指定します。

ステップ 5

Switch(config-if)# ip wccp { web-cache | service-number } group-listen

(マルチキャスト機能を実行する場合にだけ必要)ステップ 4 で指定したインターフェイスで IP マルチキャスト パケット(コンテント エンジンから送信される WCCP プロトコル パケット)の受信をイネーブルにします。

Web キャッシュ サービスの指定

Web キャッシュ サービスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# ip wccp web-cache

スイッチで Web キャッシュ サービスをイネーブルにします。

ステップ 2

Switch(config)# interface type number

Web キャッシュ サービスを実行するクライアント インターフェイス番号を指定し、コンフィギュレーション モードを開始します。

ステップ 3

Switch(config-if)# ip wccp web-cache redirect in

ステップ 2 で指定したクライアント インターフェイスを使用して、コンテント エンジンにリダイレクトできるパケットかどうかのチェックをイネーブルにします。

WCCP サービス グループのアクセス リストの使用

Catalyst 4500 シリーズ スイッチは、アクセス リストを使用して、サービス グループに加入するコンテント エンジンを制限できます。

コンテント エンジンを制限するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# access-list access-list permit ip host host-address [ destination-address | destination-host | any ]

コンテント エンジンのユニキャスト アドレスに基づいたアクセス リストを作成します。

ステップ 2

Switch(config)# ip wccp web-cache group-list access-list

スイッチに、どのコンテント エンジンのサービス グループへの加入が許可または不許可であるかを示します。

ルータおよびキャッシュ エンジンのパスワードの設定

MD5 パスワード セキュリティでは、サービス グループに加入するコンテント エンジンおよび Catalyst 4500 シリーズ スイッチごとにサービス グループ パスワードを設定する必要があります。パスワードは最大 7 文字にできます。サービス グループのコンテント エンジンまたは Catalyst 4500 シリーズ スイッチは、WCCP メッセージ ヘッダーを確認した直後に、受信した WCCP パケットのセキュリティ コンポーネントを認証します。認証に失敗したパケットは廃棄されます。

WCCP 通信で Catalyst 4500 シリーズ スイッチが使用する MD5 パスワードを設定するには、次の作業を行います。

 

コマンド
目的

Switch(config)# ip wccp web-cache password password

Catalyst 4500 シリーズ スイッチに MD5 パスワードを設定します。

WCCP 設定の確認およびモニタリング

WCCP の設定を確認およびモニタリングするには、特権 EXEC モードで次の作業を行います。

 

コマンド
目的

Switch# show ip wccp [web-cache | service-number ]

WCCP に関連するグローバル情報を表示します。この情報には、実行中のプロトコルのバージョン、ルータ サービス グループのコンテント エンジンの数、ルータに接続可能なコンテント エンジン グループ、使用中のアクセス リストが含まれます。

Switch# show ip wccp { web-cache | service-number } detail

ルータが検出した、サービス グループのコンテント エンジンの情報を問い合わせます。Web キャッシュ サービスまたは指定のダイナミック サービスのいずれかの情報が表示されます。

Switch# show ip interface

ip wccp リダイレクション コマンドがクライアント インターフェイスで設定されているかどうかを表示します。たとえば、「Web Cache Redirect is enabled / disabled」などと表示されます。

Switch# show ip wccp { web-cache | service-number } view

特定のサービス グループで検出された装置、トラブルが発生しているコンテント エンジン、現在のスイッチに接続されているその他のすべてのスイッチで認識可能なコンテント エンジンを表示します。

view キーワードは、サービス グループのサービス一覧を示します。Web キャッシュ サービスまたは指定のダイナミック サービスのいずれかの情報が表示されます。

詳細なトラブルシューティング情報を表示するには、
show ip wccp { web-cache | service number } service コマンドを使用します。

WCCP の設定例

ここでは、次の設定例について説明します。

「一般的な WCCP 設定の実行例」

「Web キャッシュ サービスの実行例」

「逆プロキシ サービスの実行例」

「アクセス リストの使用例」

「スイッチおよびコンテント エンジンへのパスワードの設定例」

「WCCP 設定の確認例」

一般的な WCCP 設定の実行例

次に、一般的な WCCP 設定セッションの例を示します。VLAN 20 はクライアント インターフェイスです。VLAN 50 はコンテント エンジン インターフェイスです。

Switch# configure terminal
Switch(config)# ip wccp web-cache group-address 224.1.1.100 password alaska1
Switch(config)# interface vlan 20
Switch(config-if)# ip wccp web-cache redirect in
Switch(config)# interface vlan 50
Switch(config-if)# ip wccp web cache group-listen

Web キャッシュ サービスの実行例

次に、Web キャッシュ サービス設定セッション例を示します。

Switch# configure terminal
Switch(config)# ip wccp web-cache
Switch(config)# interface vlan 20
Switch(config-if)# ip wccp web-cache redirect in
Switch(config-if)# ^Z
Switch# copy running-config startup-config
Switch# show ip interface vlan 20 | include WCCP Redirect
WCCP Redirect inbound is enabled
WCCP Redirect exclude is disabled

逆プロキシ サービスの実行例

次に、リバース プロキシ サービスの実行にダイナミック サービス 99 を使用する Cisco Content Engine を使用してサービス グループを設定する例を示します。

Switch# configure terminal
router(config)# ip wccp 99
router(config)# interface vlan 40
router(config-if)# ip wccp 99 redirect in

アクセス リストの使用例

セキュリティを向上させるには、現在のスイッチで登録するコンテント エンジンのものとして有効な IP アドレスを、標準のアクセス リストを使用して Catalyst 4500 シリーズ スイッチに通知します。次に、サンプル ホストのアクセス リスト番号が 10 である標準的なアクセス リストの設定セッション例を示します。

router(config)# access-list 10 permit host 11.1.1.1
router(config)# access-list 10 permit host 11.1.1.2
router(config)# access-list 10 permit host 11.1.1.3
router(config)# ip wccp web-cache group-list 10

スイッチおよびコンテント エンジンへのパスワードの設定例

次に、WCCP パスワード設定セッションの例を示します。パスワードは alaska1 です。

Switch# configure terminal
router(config)# ip wccp web-cache password alaska1

WCCP 設定の確認例

設定の変更を確認するには、 more system:running-config 特権 EXEC コマンドを使用します。次に、Catalyst 4500 シリーズ スイッチの Web キャッシュ サービスとダイナミック サービス 99 がどちらもイネーブルである場合の例を示します。

Switch# more system:running-config
 
Building configuration...
Current configuration:
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname router4
!
enable secret 5 $1$nSVy$faliJsVQXVPW.KuCxZNTh1
enable password alabama1
!
ip subnet-zero
ip wccp web-cache
ip wccp 99
ip domain-name cisco.com
ip name-server 10.1.1.1
ip name-server 10.1.1.2
ip name-server 10.1.1.3
!
!
!
interface Vlan200
ip address 10.3.1.2 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect in
ip wccp 99 redirect in
no ip route-cache
no ip mroute-cache
!
interface Vlan300
ip address 10.4.1.1 255.255.255.0
!
interface Serial0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip default-gateway 10.3.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.1.1
no ip http server
!
!
!
line con 0
transport input none
line aux 0
transport input all
line vty 0 4
password alaska1
login
!
end