Catalyst 4500 シリーズ スイッチ Cisco IOS ソフトウェアコンフィギュレーションガイド リリース IOS-XE 3.1.0 SG
IP マルチキャストの設定
IP マルチキャストの設定
発行日;2012/01/30 | 英語版ドキュメント(2010/09/11 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

IP マルチキャストの設定

IP マルチキャストの概要

IP マルチキャスト プロトコル

インターネット グループ管理プロトコル

プロトコル独立マルチキャスト

ランデブー ポイント(RP)

IGMP スヌーピング

Catalyst 4500 シリーズ スイッチ上での IP マルチキャスト

CEF、MFIB、およびレイヤ 2 フォワーディング

IP マルチキャスト テーブル

ハードウェアおよびソフトウェアによる転送

非 RPF トラフィック

マルチキャスト高速ドロップ

マルチキャスト転送情報ベース

S/M, 224/4

双方向 PIM の使用に関する制約事項

サポートされない機能

IP マルチキャスト ルーティングの設定

IP マルチキャスト ルーティングのデフォルト設定

IP マルチキャスト ルーティングのイネーブル化

インターフェイス上での PIM のイネーブル化

デンス モードのイネーブル化

希薄モードのイネーブル化

スパース/デンス モードのイネーブル化

双方向モードのイネーブル化

PIM-SSM マッピングのイネーブル化

ランデブー ポイントの設定

Auto-RP の設定

単一スタティック RP の設定

IP マルチキャスト ルーティングのモニタリングおよびメンテナンス

システムおよびネットワークの統計情報の表示

マルチキャスト ルーティング テーブルの表示

IP MFIB の表示

双方向 PIM 情報の表示

PIM 統計情報の表示

テーブルおよびデータベースの削除

設定例

PIM デンス モードの例

PIM 希薄モードの例

双方向 PIM モードの例

単一スタティック RP を使用する希薄モードの例

Auto-RP を使用する希薄モードの例

IP マルチキャストの設定

この章では、Catalyst 4500 シリーズ スイッチ上での IP マルチキャスト ルーティングについて説明します。IP マルチキャスト ルーティングの設定手順および設定例も示します。


) IP マルチキャストの詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/products/ps6552/products_ios_technology_home.html



) この章で使用するスイッチ コマンドの構文および使用方法の詳細については、次の URL で『Cisco Catalyst 4500 Series Switch Command Reference』と関連資料を参照してください。

http://www.cisco.com/en/US/products//hw/switches/ps4324/index.html

Catalyst 4500 のコマンド リファレンスに掲載されていないコマンドについては、より詳細な Cisco IOS ライブラリを参照してください。次の URL で『Catalyst 4500 Series Switch Cisco IOS Command Referenceと関連資料を参照してください。

http://www.cisco.com/en/US/products/ps6350/index.html


この章の主な内容は、次のとおりです。

「IP マルチキャストの概要」

「IP マルチキャスト ルーティングの設定」

「IP マルチキャスト ルーティングのモニタリングおよびメンテナンス」

「設定例」

IP マルチキャストの概要

ここでは、次の内容について説明します。

「IP マルチキャスト プロトコル」

「Catalyst 4500 シリーズ スイッチ上での IP マルチキャスト」

「サポートされない機能」

IP 通信の一端である IP ユニキャストでは、送信元 IP ホストが特定の宛先 IP ホストにパケットを送信します。この場合、IP パケットに指定される宛先アドレスは、IP ネットワーク上で一意に識別される単一ホストのアドレスです。これらの IP パケットは、ネットワーク上の送信元ホストから、一連のルータによって宛先ホストに転送されます。送信元と宛先間のパス上の各ポイントでは、ルータがユニキャスト ルーティング テーブルを使用して、パケットの IP 宛先アドレスに基づきユニキャスト転送先を決定します。

IP 通信で IP ユニキャストの対極にある IP ブロードキャストでは、送信元ホストはネットワーク セグメント上のすべてのホストにパケットを送信します。IP ブロードキャスト パケットの宛先アドレスでは、宛先 IP アドレスのホスト部分がすべて 1 に設定され、ネットワーク部分がサブネットのアドレスに設定されています。一連の IP ホスト(ルータを含む)は、宛先アドレスとして IP ブロードキャスト アドレスを指定されたパケットが、サブネット上のすべての IP ホスト向けであることを認識しています。特に設定しない限り、ルータは IP ブロードキャスト パケットを転送しないので、一般的に IP ブロードキャスト通信はローカル サブネットに限定されます。

IP マルチキャストは、IP ユニキャスト通信と IP ブロードキャスト通信の中間に位置します。IP マルチキャスト通信によって、ホストは IP ネットワーク上の任意の場所にあるホストの グループ に IP パケットを送信します。IP マルチキャスト通信では、特定のグループに情報を送信するために、IP マルチキャスト グループ アドレス という特殊な形式の IP 宛先アドレスを使用します。IP マルチキャスト グループ アドレスは、パケットの IP 宛先アドレス フィールドに指定されます。

IP 情報をマルチキャストするには、レイヤ 3 スイッチおよびルータが、IP マルチキャスト グループの メンバ に接続するすべての出力インターフェイスに、着信 IP パケットを転送する必要があります。Catalyst 4500 シリーズ スイッチ上のマルチキャスト プロセスでは、Integrated Switching Engine でパケットが複製されて適切な出力インターフェイスに転送され、マルチキャスト グループの各メンバに送信されます。

IP マルチキャストはビデオ会議とほとんど同じものと見られがちです。ネットワークに初めて導入する IP マルチキャスト アプリケーションは、多くの場合ビデオ会議ですが、ビデオは企業のビジネス モデルに付加価値をもたらす、さまざまな IP マルチキャスト アプリケーションの 1 つに過ぎません。生産性の向上につながるこの他の IP マルチキャスト アプリケーションとしては、マルチメディア会議、データ複製、リアルタイム データ マルチキャスト、シミュレーション アプリケーションなどがあります。

ここでは、次の内容について説明します。

「IP マルチキャスト プロトコル」

「Catalyst 4500 シリーズ スイッチ上での IP マルチキャスト」

「サポートされない機能」

IP マルチキャスト プロトコル

Catalyst 4500 シリーズ スイッチでは、主に次のプロトコルを使用して IP マルチキャスト ルーティングを実行します。

Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)

Protocol Independent Multicast(PIM; プロトコル独立マルチキャスト)

Cisco Group Management Protocol(CGMP)

図 27-1 に、IP マルチキャスト環境でこれらのプロトコルが動作する箇所を示します。

図 27-1 IP マルチキャスト ルーティング プロトコル

 

インターネット グループ管理プロトコル

IP マルチキャスト ホストは IGMP メッセージを使用して、ローカルのレイヤ 3 スイッチまたはルータに要求を送信し、特定のマルチキャスト グループに加入して、マルチキャスト トラフィックの受信を開始します。IGMPv2 の一部の拡張機能を使用すると、IP ホストはレイヤ 3 スイッチまたはルータに対し、IP マルチキャスト グループを脱退してマルチキャスト グループ トラフィックを受信しないように求める要求も送信します。

レイヤ 3 スイッチまたはルータは、IGMP によって得た情報を使用して、マルチキャスト グループ メンバシップのリストをインターフェイス単位で維持します。インターフェイス上で少なくとも 1 つのホストが、マルチキャスト グループ トラフィックを受信するための IGMP 要求を送信している限り、そのインターフェイスのマルチキャスト グループ メンバシップはアクティブです。

プロトコル独立マルチキャスト

PIM が プロトコルに依存しない 理由は、使用されている任意のユニキャスト ルーティング プロトコルを利用してルーティング テーブルへの書き込みを行い(Enhanced Interior Gateway Routing Protocol(EIGRP)、Open Shortest Path First(OSPF)、Border Gateway Protocol(BGP)、およびスタティック ルートを含む)、IP マルチキャストをサポートするからです。PIM はさらに、完全に独立したマルチキャスト ルーティング テーブルを作成する代わりに、ユニキャスト ルーティング テーブルを使用して Reverse Path Forwarding(RPF)チェック機能を実行します。PIM は、他のルーティング プロトコルが行うような、ルータ間でのマルチキャスト ルーティング アップデートの送受信は行いません。

PIM デンス モード(PIM-DM)

PIM Dense Mode(PIM-DM; PIM デンス モード)は、 プッシュ モデルを使用してネットワークのすべての部分にマルチキャスト トラフィックをフラッディングさせます。PIM-DM は、LAN TV や企業情報または財務情報ブロードキャストなど、大部分の LAN でマルチキャストの受信が必要とされるネットワークでの使用を目的としています。ネットワーク上のすべてのサブネットにアクティブな受信者が存在する場合、効率的な配信メカニズムになります。


) Supervisor Engine 7-E は、PIM デンス モードで(*, G)用のカウンタをインクリメントしません。(*, G)カウンタは、双方向 PIM モードの実行中にインクリメントされます。


PIM デンス モードの詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_pim_dense_rfrsh_ps6350_TSD_Products_Configuration_Guide_Chapter.html

PIM 希薄モード(PIM-SM)

PIM Sparse Mode(PIM-SM; PIM 希薄モード)は、 プル モデルを使用してマルチキャスト トラフィックを配信します。明示的にデータを要求していて、かつアクティブな受信者のいるネットワークだけに、トラフィックが転送されます。PIM-SM は、デスクトップ ビデオ会議や企業コンピューティングなど、少数の受信者がそれぞれ異なるマルチキャストを一般に同時使用するネットワークでの使用を目的としています。


) Supervisor Engine 7-E は、PIM デンス モードで(*, G)用のカウンタをインクリメントしません。(*, G)カウンタは、双方向 PIM モードの実行中にインクリメントされます。


双方向 PIM(Bidir-PIM)モード

Bidirectional PIM(Bidir-PIM; 双方向 PIM)モードでは、グループの Rendezvous Point(RP; ランデブー ポイント)をルートとする双方向の共有ツリー上でのみ、トラフィックがルーティングされます。RP の IP アドレスは、すべてのルータにより、その IP アドレスをルートとするループフリーのスパニング ツリー トポロジを確立する鍵として機能します。

Bidir-PIM は、個々の PIM ドメイン内の多数対多数の用途での使用を目的としています。双方向モードのマルチキャスト グループは、送信元の数による着信オーバーヘッドを生じることなく、任意の数の送信元まで拡張できます。


) Supervisor Engine 7-E は、PIM デンス モードまたはスパース モードで(*, G)用のカウンタをインクリメントしません。(*, G)カウンタは、双方向 PIM モードの実行中にインクリメントされます。


双方向モードの詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6552/ps6592/prod_white_paper0900aecd80310db2.pdf.

ランデブー ポイント(RP)

また、PIM を希薄モードで動作するよう構成する場合は、1 つまたは複数のルータを Rendezvous Point(RP; ランデブー ポイント)とするよう選択する必要があります。マルチキャスト グループへの送信者は RP を使用して自身の存在をアナウンスします。マルチキャスト パケットの受信者は RP を使用して、新しい送信者について学習します。1 つのマルチキャスト グループのパケットが 1 つまたは複数の RP を使用できるように Cisco IOS ソフトウェアを構成できます。

RP アドレスは、パケットをグループに送信するホストの代わりに PIM Register メッセージを送信するためにファースト ホップ ルータによって使用されます。RP アドレスは、RP に PIM Join メッセージおよび Prune メッセージを送信して、グループ メンバシップを通知するためにラスト ホップ ルータによって使用されます。RP ルータを含め、すべてのルータ上で RP アドレスを設定する必要があります。

PIM ルータは、複数のグループに対する RP となることができます。同じグループの PIM ドメイン内で同時に使用できる RP アドレスは 1 つだけです。アクセス リストによって指定される条件によって、ルータがどのグループに対する RP であるかが決定されます(別のグループは別の RP を使用できます)。

IGMP スヌーピング

IGMP スヌーピングは、レイヤ 2 スイッチング環境でのマルチキャストに使用します。IGMP スヌーピングを使用する場合、レイヤ 3 スイッチまたはルータは、ホストとルータ間で転送される IGMP パケットのレイヤ 3 情報を検証します。スイッチが特定のマルチキャスト グループのホストから IGMP Host Report を受信すると、スイッチはそのホストのポート番号を対応するマルチキャスト テーブル エントリに追加します。スイッチがホストから IGMP Leave Group メッセージを受信すると、スイッチはテーブル エントリからそのホストのポートを削除します。

Catalyst 4500 シリーズ スイッチ上での IP マルチキャスト

Catalyst 4500 シリーズ スイッチは、レイヤ 2 でイーサネット ブリッジング、レイヤ 3 で IP ルーティングを行う ASIC ベースのIntegrated Switching Engine をサポートしています。この ASIC はパケット転送専用に設計されているので、Access Control List(ACL; アクセス コントロール リスト)および QoS(Quality of Service)をイネーブルにした状態で、Integrated Switching Engineハードウェアにより非常に高いパフォーマンスを実現します ハードウェアによるワイヤスピードでの転送は、例外パケットを処理するように設計された CPU サブシステム ソフトウェアよりもきわめて高速となります。

Integrated Switching Engine ハードウェアは、VLAN 間ルーティング用のインターフェイスおよびレイヤ 2 ブリッジング用のスイッチポートをサポートしています。また、ホスト、スイッチ、またはルータとの接続を設定できる物理レイヤ 3 インターフェイスともなります。

図 27-2 に、Integrated Switching Engine ハードウェアでのレイヤ 2 およびレイヤ 3 フォワーディングの概念図を示します。

図 27-2 ハードウェアでのレイヤ 2 およびレイヤ 3 フォワーディングの概念図

 

ここでは、次の内容について説明します。

「CEF、MFIB、およびレイヤ 2 フォワーディング」

「IP マルチキャスト テーブル」

「ハードウェアおよびソフトウェアによる転送」

「非 RPF トラフィック」

「マルチキャスト高速ドロップ」

「マルチキャスト転送情報ベース」

「S/M, 224/4」

CEF、MFIB、およびレイヤ 2 フォワーディング

Catalyst 4500 シリーズ スイッチに実装された IP マルチキャストは、中央集中型 Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)の拡張機能です。CEF は、上位レイヤのユニキャスト ルーティング テーブル(BGP、OSPF、EIGRP などのユニキャスト ルーティング プロトコルによって作成される)から情報を抽出し、この情報をハードウェア Forwarding Information Base(FIB; 転送情報ベース)にロードします。FIB 内のユニキャスト ルートを使用すると、上位レイヤ ルーティング テーブルでルートが変更された場合に、ハードウェア ルーティング ステートの 1 つのルートを変更するだけで済みます。ハードウェアでユニキャスト パケットを転送するために、Integrated Switching Engine は Ternary CAM(TCAM)から送信元および宛先ルートを検索し、ハードウェア FIB から隣接インデックスを取り出して、ハードウェア ネイバー テーブル関係からレイヤ 2 リライト情報およびネクストホップ アドレスを取得します。

Multicast Forwarding Information Base(MFIB; マルチキャスト転送情報ベース)サブシステムは、ユニキャスト CEF のマルチキャスト版です。この MFIB サブシステムは、PIM および IGMP によって作成されるマルチキャスト ルートを抽出し、ハードウェア転送のためのプロトコル独立フォーマットにします。MFIB サブシステムは、プロトコル固有の情報を削除し、必要なフォワーディング情報だけを残します。MFIB テーブルの各エントリは、(S,G)または(*,G)ルート、入力 RPF VLAN、およびレイヤ 3 出力インターフェイスのリストで構成されます。MFIB サブシステムは、プラットフォーム依存の管理ソフトウェアと連携して、このマルチキャスト ルーティング情報をハードウェア FIB とハードウェア Replica Expansion Table(RET; レプリカ拡張テーブル)にロードします。

Catalyst 4500 シリーズ スイッチは、レイヤ 3 ルーティングとレイヤ 2 ブリッジングを同時に実行します。1 つの VLAN インターフェイスに複数のレイヤ 2 スイッチポートを設定できます。マルチキャスト パケットを転送すべき出力スイッチポートのセットを決定するために、スーパーバイザ エンジンは、レイヤ 3 の MFIB 情報とレイヤ 2 のフォワーディング情報を結合して、パケット複製用のハードウェア RET に保存します。

図 27-3 に、Catalyst 4500 シリーズ スイッチがユニキャスト ルーティング、マルチキャスト ルーティング、およびレイヤ 2 ブリッジング情報を組み合わせ、ハードウェアで転送を実行する機能の概要を示します。

図 27-3 ハードウェアでの CEF、MFIB、およびレイヤ 2 転送情報の組み合わせ

 

MFIB ルートは、CEF ユニキャスト ルートと同様にレイヤ 3 であるため、該当するレイヤ 2 情報と結合する必要があります。MFIB ルートの例を示します。

(*,224.1.2.3)
RPF interface is Vlan3
Output Interfaces are:
Vlan 1
Vlan 2
 

ルート(*,224.1.2.3)がハードウェア FIB テーブルにロードされ、出力インターフェイスのリストが RET にロードされます。出力インターフェイスのリストへのポインタ、RET インデックス、および RPF インターフェイスも、(*,224.1.2.3)ルートとともにハードウェア FIB にロードされます。ハードウェアにこの情報をロードすることで、レイヤ 2 情報との結合を開始できるようになります。VLAN 1 上の出力インターフェイスについて、Integrated Switching Engine は VLAN 1 上でスパニングツリー フォワーディング ステートにあるすべてのスイッチポートにパケットを送信する必要があります。同じプロセスが VLAN 2 に適用されます。VLAN 2 内のスイッチポートのセットを決定するために、レイヤ 2 転送テーブルが使用されます。

ハードウェアがパケットをルーティングする場合、すべての出力インターフェイスのすべてのスイッチポートにパケットを送信するだけでなく、ハードウェアは入力 VLAN の(パケットが到着したスイッチポートを除く)すべてのスイッチポートにも、パケットを送信します。たとえば、VLAN 3 に 2 つのスイッチポート Gig 3/1 および Gig 3/2 があると仮定します。Gig 3/1 上のホストがマルチキャスト パケットを送信すると、Gig 3/2 上のホストもそのパケットを受信しなければならない場合があります。Gig 3/2 上のホストにマルチキャスト パケットを送信するには、RET にロードされるポートセットに入力 VLAN のすべてのスイッチポートを追加する必要があります。

VLAN 1 に 1/1 と 1/2 が、VLAN 2 に 2/1 と 2/2 が、VLAN 3 に 3/1 と 3/2 が含まれていれば、このルート用の RET チェーンに、スイッチポートの 1/1、1/2、2/1、2/2、3/1、および 3/2 が含まれることになります。

IGMP スヌーピングがオンの場合、パケットは VLAN 2 のすべての出力スイッチポートに転送されるとは限りません。IGMP スヌーピングによって、グループ メンバまたはルータが存在すると判断されたスイッチポートだけに、パケットが転送されます。たとえば、VLAN 1 で IGMP スヌーピングがイネーブルで、IGMP スヌーピングによってポート 1/2 のみにグループ メンバが存在すると判断された場合、RET チェーンには、スイッチポート 1/1、1/2、2/1、2/2、3/1、および 3/2 が含まれることになります。

IP マルチキャスト テーブル

図 27-4 に、Catalyst 4500 シリーズ スイッチがハードウェアで IP マルチキャスト パケットを転送する目的で使用する主なデータ構造を示します。

図 27-4 IP マルチキャスト テーブルおよびプロトコル

 

Integrated Switching Engine は、個々の IP マルチキャスト ルートを識別する目的で、ハードウェア FIB テーブルを維持します。各エントリは、宛先グループの IP アドレスおよびオプションの送信元 IP アドレスで構成されます。マルチキャスト トラフィックは、主に(S,G)および(*,G)の 2 種類のルート上を流れます。(S,G)ルートは、マルチキャスト送信元の IP アドレスと、マルチキャスト グループ宛先の IP アドレスに基づいて、送信元からグループへ流れます。(*,G)ルート上のトラフィックは、PIM RP からグループ G のすべてのレシーバーに流れます。スパース モード グループだけが(*,G)ルートを使用します。Integrated Switching Engine ハードウェアには、合計 128,000 のルート用のスペースが準備されています。これらがユニキャスト ルート、マルチキャスト ルート、およびマルチキャスト高速ドロップ エントリによって共有されます。

RET の場合は、最大で 102K 個のエントリを使用することができます(フラッディング セットに 32K が、マルチキャスト エントリに 70K が使用されます)。RET リソースは、レイヤ 3 マルチキャスト ルートとレイヤ 2 マルチキャスト エントリの両方で共有されます。ハードウェアで使用できる出力インターフェイス リストの実際の数は、特定の設定によって異なります。マルチキャスト ルートの総数が 32,000 を超えると、Integrated Switching Engine によってマルチキャスト パケットをスイッチングできなくなる場合があります。そのパケットは、CPU サブシステムによってきわめて低い速度で転送されることになります


) (RET では 102K エントリまでサポートされます(フラッディング セットに 32K、multicast エントリに 70K を使用))。



) Supervisor Engine 7-E では、部分的なマルチキャスト ルーティングがサポートされません。ハードウェア ルーティングとソフトウェア ルーティングだけがサポートされます。


ハードウェアおよびソフトウェアによる転送

Integrated Switching Engine は通常、パケットをハードウェアで非常に高速で転送します。CPU サブシステムは、例外パケットをソフトウェアで転送します。Integrated Switching Engine が大部分のパケットをハードウェアで転送していることは、統計レポートからわかります。

複製は、パケットの 1 コピーを送信する代わりに、パケットを複製して複数のコピーを送信する転送の一種です。レイヤ 3 で複製が行われるのは、マルチキャスト パケットに限られます。ユニキャスト パケットが複数のレイヤ 3 インターフェイス用に複製されることはありません。IP マルチキャスト動作では、着信した IP マルチキャスト パケットごとに、そのパケットの多くの複製が送信されます。

IP マルチキャスト パケットを伝送するルートのタイプは、次のとおりです。

ハードウェア ルート

ソフトウェア ルート

部分的なルート

ハードウェア ルートは、Integrated Switching Engine ハードウェアがパケットのすべての複製を転送する場合に発生します。ソフトウェア ルートは、CPU サブシステム ソフトウェアがパケットのすべての複製を転送する場合に発生します。部分的なルートは、Integrated Switching Engine が一部の複製をハードウェアで転送し、CPU サブシステムが一部の複製をソフトウェアで転送する場合に発生します。

部分的なルート


) 以下に記載する条件が成立する場合、CPU サブシステム ソフトウェアによって複製が転送されますが、ハードウェアによる複製の転送パフォーマンスに影響はありません。


あるルートに対するパケットの複製の一部が CPU サブシステムによって転送される条件は、次のとおりです。

ip igmp join-group コマンドを使用して、マルチキャスト送信元の RPF インターフェイス上の IP マルチキャスト グループのメンバとしてスイッチを設定している場合

スイッチが PIM 希薄モードの送信元へのファースト ホップである場合。この場合、スイッチは RP に PIM Register メッセージを送信する必要があります。

ソフトウェア ルート


) RPF インターフェイスまたは出力インターフェイスの設定について次の条件が 1 つでも成立すると、出力のすべての複製はソフトウェアで実行されます。


あるルートに対するパケットの複製の一部が CPU サブシステム ソフトウェアによって転送される条件は、次のとおりです。

インターフェイスがマルチキャスト ヘルパーを使用して設定されている場合

インターフェイスが GRE トンネルまたは Distance Vector Multicast Routing Protocol(DVMRP; ディスタンス ベクトル マルチキャスト ルーティング プロトコル)トンネルである場合

インターフェイスが Advanced Research Products Agency(ARPA; 高等研究計画局)以外のカプセル化を使用している場合

次のパケットは、常にソフトウェアによって転送されます。

224.0.0.*(* は 0 ~ 255)の範囲のマルチキャスト グループに送信されるパケット。この範囲は、ルーティング プロトコルが使用します。レイヤ 3 スイッチングでは、この範囲以外のすべてのマルチキャスト グループ アドレスがサポートされています。

IP オプション付きのパケット

非 RPF トラフィック

Reverse Path Forwarding(RPF)チェックに失敗したトラフィックを、非 RPF トラフィックといいます。Integrated Switching Engine は、非 RPF トラフィックをフィルタリング(持続的にドロップ)するか、またはレート制限して転送します。

複数の レイヤ 3 スイッチ またはルータが同一の LAN セグメントに接続されている冗長な構成で、送信元から発信インターフェイス上の受信側へマルチキャスト トラフィックを転送するのは、1 台の装置だけです。図 27-5に、一般的なネットワーク構成で非 RPF トラフィックが発生した状況を示します。

図 27-5 スタブ ネットワークにおける冗長マルチキャスト ルータ構成

 

この種のトポロジでは、PIM Designated Router(PIM DR; PIM 代表ルータ)であるルータ A だけが共通の VLAN にデータを転送します。ルータ B は転送されたマルチキャスト トラフィックを受信しますが、このトラフィックをドロップします。不正なインターフェイスでこのトラフィックが着信したので、RPF チェックに失敗するためです。このように RPF チェックに失敗するトラフィックを、非 RPF トラフィックといいます。

マルチキャスト高速ドロップ

PIM-SM、PIM-DM などの IP マルチキャスト プロトコルでは、(S,G)または(*,G)ルートごとに、対応する着信インターフェイスがあります。このインターフェイスを、RPF インターフェイスといいます。予測される RPF インターフェイスとは異なるインターフェイスにパケットが到着することもあります。その場合、PIM によってパケットに特殊なプロトコル処理を行うために、そのパケットを CPU サブシステム ソフトウェアに転送する必要があります。PIM が実行する特殊なプロトコル処理の例としては、PIM アサート プロトコルがあります。

デフォルトでは、Integrated Switching Engine ハードウェアは、非 RPF インターフェイスに着信したすべてのパケットを CPU サブシステム ソフトウェアに送信します。ただし、これらの非 RPF パケットはほとんどの場合、マルチキャスト ルーティング プロトコルに必要ではないので、多くの場合、ソフトウェアによる処理は不要です。何の処置も行わなければ、ソフトウェアに送信される非 RPF パケットのため、CPU に負荷がかかるおそれがあります。

この問題を回避するため、CPU サブシステム ソフトウェアは、RPF に失敗したパケットのうち、スイッチ上で稼動している PIM プロトコルが必要としないパケットを受信した時点で、高速ドロップ エントリをハードウェアにロードします。高速ドロップ エントリは、(S,G,着信インターフェイス)によって表されます。高速ドロップ エントリに一致するパケットは、入力 VLAN でブリッジングされますが、ソフトウェアには送信されません。したがって、CPU サブシステム ソフトウェアがこれらの RPF エラーを処理し、必ずしも過負荷になるものではありません。

リンクのダウン、ユニキャスト ルーティング テーブルの変更などのプロトコル イベントによって、安全に高速ドロップが可能なパケットの集合に影響が出ることがあります。以前は高速ドロップを行っても問題のなかったパケットを、トポロジの変更後、PIM ソフトウェアに処理させるため、CPU サブシステム ソフトウェアに転送する必要があります。CPU サブシステム ソフトウェアは、プロトコル イベントに応答して高速ドロップ エントリのフラッシュを行い、IOS の PIM コードが必要な RPF エラーをすべて処理できるようにします。

一部のトポロジでは、RPF エラーが繰り返し発生する可能性があるので、ハードウェアにおける高速ドロップ エントリの使用が特に重要になります。高速ドロップ エントリがなければ、処理する必要のない RPF エラー パケットによって CPU が過負荷になる可能性があります。

マルチキャスト転送情報ベース

Multicast Forwarding Information Base(MFIB; マルチキャスト転送情報ベース)サブシステムは、Integrated Switching Engine 上の Catalyst 4500 シリーズ スイッチ ハードウェアの IP マルチキャスト ルーティングをサポートします。MFIB は、論理的には CPU サブシステム ソフトウェアの IP マルチキャスト ルーティング プロトコル(PIM、IGMP、MSDP、MBGP、および DVMRP)と、ハードウェアで IP マルチキャスト ルーティングを管理するためのプラットフォーム固有のコードとの中間に存在します。MFIB は、マルチキャスト ルーティング プロトコルによって作成されたルーティング テーブル情報を、Integrated Switching Engine ハードウェアが効率的に処理して転送に使用可能な、簡易なフォーマットに変換します。

マルチキャスト ルーティング テーブルの情報を表示するには、 show ip mroute コマンドを使用します。MFIB テーブルの情報を表示するには、 show ip mfib コマンドを使用します。

MFIB テーブルには、IP マルチキャスト ルートの集合が含まれます。IP マルチキャスト ルートには、(S,G)ルート、(*,G)ルートなど、いくつかのタイプがあります。MFIB テーブルの各ルートに、オプションの 1 つまたは複数のフラグを対応付けることができます。ルート フラグは、ルートに一致するパケットの転送方法を指示します。たとえば、MFIB ルートに付けられた Internal Copy(IC)フラグは、スイッチ上のプロセスがパケットのコピーを受信する必要があることを意味します。MFIB ルートに対応付けできるフラグは、次のとおりです。

Internal Copy(IC)フラグ:ルータ上のプロセスが、特定のルートに一致するすべてのパケットのコピーを受信する必要がある場合に設定します。

Signalling(S)フラグ:このルートに一致するパケットを受信したときに、プロセスに通知する必要がある場合に設定します。シグナリング インターフェイス上でのパケット受信に応答して、プロトコル コードが MFIB ステートを更新するなどの動作を行うことが考えられます。

Connected(C)フラグ:このフラグを MFIB ルートに設定した場合、直接接続されたホストによってルートに送信されたパケットだけをプロトコル プロセスに通知する必要があるという点を除き、Signalling(S)フラグと同じ意味を持ちます。

ルートには、1 つまたは複数のインターフェイスに対応するオプションのフラグを設定することもできます。たとえば、VLAN 1 に関するフラグを設定した(S,G)ルートは、VLAN 1 に着信するパケットの取り扱いを指示するとともに、このルートに一致するパケットを VLAN 1 に転送すべきかどうかも示します。MFIB でサポートされるインターフェイス単位のフラグは、次のとおりです

Accepting(A):マルチキャスト ルーティングで RPF インターフェイスであることが明らかなインターフェイスに設定します。Accepting(A)をマークされたインターフェイスに着信したパケットは、すべての Forwarding(F)インターフェイスに転送されます。

Forwarding(F):上記のように、Accepting(A)フラグと組み合わせて使用します。Forwarding インターフェイスの集合は、マルチキャスト「olist」(output interface list)と呼ばれるものを形成します。

Signalling(S):このインターフェイスにパケットが着信したとき、IOS の何らかのマルチキャスト ルーティング プロトコル プロセスに通知する必要がある場合に設定します。


) PIM-SM ルーティングを使用している場合、MFIB ルートには、PimTunnel [1.2.3.4] などのインターフェイスが含まれる場合があります。このインターフェイスは、パケットが特定の宛先アドレスに対してトンネリングされていることを表すために、MFIB サブシステムが作成する仮想インターフェイスです。PimTunnel インターフェイスは、通常の show interface コマンドでは表示できません。


S/M, 224/4

MFIB では、マルチキャスト対応のインターフェイスごとに(S/M, 224/4)エントリが作成されます。このエントリによって、直接接続されたネイバーから送信されたすべてのパケットが、PIM-SM RP に Register カプセル化されるようになります。一般に、PIM-SM によって(S,G)ルートが確立されるまでの間、ごく少数のパケットだけが(S/M, 224/4)ルートを使用して転送されます。

たとえば、IP アドレス 10.0.0.1 およびネットマスク 255.0.0.0 のインターフェイスで、送信元アドレスがクラス A ネットワーク 10 に所属する IP マルチキャスト パケットにすべて一致するルートが作成されると仮定します。このルートは、慣例的なサブネット/マスク長の表記では(10/8,224/4)と記述されます。インターフェイスに複数の IP アドレスが割り当てられている場合には、これらの IP アドレスごとに 1 つずつルートが作成されます。

双方向 PIM の使用に関する制約事項

制約事項は次のとおりです。

IPv4 双方向(Bidir)PIM は、Supervisor Engine 7-E 上でサポートされます。IPv6 Bidir PIM はサポートされません。

Catalyst 4500 スイッチを使用すると、ハードウェア内の Bidir PIM トラフィックを最大 7 つの RP に転送できます。8 つ以上の Bidir RP を設定した場合は、ハードウェア内のトラフィックを最初の 7 つの RP だけに転送できます。残りの RP に向けられたトラフィックは、ソフトウェア内で転送されます。

サポートされない機能

このリリースでは、次の IP マルチキャスト機能はサポートされません。

マルチキャスト グループへの伝送速度の制御

IP マルチキャスト ルーティングの設定

ここでは、IP マルチキャスト ルーティングの設定作業について説明します。

「IP マルチキャスト ルーティングのデフォルト設定」

「IP マルチキャスト ルーティングのイネーブル化」

「インターフェイス上での PIM のイネーブル化」

「双方向モードのイネーブル化」

「PIM-SSM マッピングのイネーブル化」

「ランデブー ポイントの設定」

「単一スタティック RP の設定」

Auto-RP、PIM バージョン 2、および IP マルチキャスト スタティック ルートなどの IP マルチキャスト ルーティングの詳細については、『 Cisco IOS IP and IP Routing Configuration Guide, Release 12.3 』を参照してください。

IP マルチキャスト ルーティングのデフォルト設定

表 27-1 に、IP マルチキャストのデフォルト設定を示します。

 

表 27-1 IP マルチキャストのデフォルト設定

機能
デフォルト値

RPF のレート制限

グローバルでイネーブル

IP マルチキャスト ルーティング

グローバルでディセーブル

(注) IP マルチキャスト ルーティングがディセーブルになっている場合、IP マルチキャスト トラフィック データは Catalyst 4500 シリーズ スイッチによって転送されません。ただし、IP マルチキャスト制御トラフィックは引き続き処理および転送されます。したがって、IP マルチキャスト ルーティングをディセーブルにしても、IP マルチキャスト ルートはルーティング テーブルに残ります。

PIM

すべてのインターフェイス上でディセーブル

IGMP スヌーピング

すべての VLAN インターフェイス上でイネーブル

(注) 特定のインターフェイス上で IGMP スヌーピングをディセーブルにすると、すべての出力ポートが Integrated Switching Engine によって転送されます。入力 VLAN インターフェイス上で IGMP スヌーピングをディセーブルにすると、そのインターフェイスに関連するマルチキャスト パケットは、VLAN 上のすべてのフォワーディング スイッチポートに送信されます。


) Source Specific Multicast および IGMPv3 がサポートされています。


IGMPv3 および IGMP を備えた Source Specific Multicast の詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_cfg_ssm_ps6350_TSD_Products_Configuration_Guide_Chapter.html

IP マルチキャスト ルーティングのイネーブル化

IP マルチキャスト ルーティングをイネーブルにすると、Catalyst 4500 シリーズ スイッチでマルチキャスト パケットを転送できるようになります。ルータ上で IP マルチキャスト ルーティングをイネーブルにするには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Switch(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします

インターフェイス上での PIM のイネーブル化

インターフェイス上で PIM をイネーブルにすると、そのインターフェイス上で IGMP 動作もイネーブルになります。インターフェイスは、デンス モード、スパース モード、またはスパース/デンス モードのいずれかに設定できます。これらのモードは、レイヤ 3 スイッチまたはルータによるマルチキャスト ルーティング テーブルの書き込み方法と、レイヤ 3 スイッチまたはルータが直接接続された LAN から受信したマルチキャスト パケットの転送方法を決定します。インターフェイスで IP マルチキャスト ルーティングを実行するには、PIM を上記のモードのいずれかでイネーブルにする必要があります。

マルチキャスト ルーティング テーブルの書き込みでは、デンス モード インターフェイスは常にテーブルに追加されます。希薄モード インターフェイスは、ダウンストリーム ルータから定期的な Join メッセージを受信した場合、またはインターフェイス上に直接接続されたメンバが存在する場合に限り、テーブルに追加されます。LAN から転送する場合、グループが認識している RP があれば、希薄モード動作が行われます。その場合、パケットはカプセル化され、その RP に送信されます。認識している RP がなければ、パケットはデンス モードの方式でフラッディングされます。特定の送信元からのマルチキャスト トラフィックが十分であれば、受信側のファーストホップ ルータがその送信元に Join メッセージを送信し、送信元を基点とするディストリビューション ツリーが構築されます。

デフォルトで設定されるモードはありません。デフォルトでは、インターフェイス上でマルチキャスト ルーティングはディセーブルに設定されています。

デンス モードのイネーブル化

インターフェイス上の PIM をデンス モードに設定するには、次の作業を行います。

 

コマンド
目的

Switch(config-if)# ip pim dense-mode

インターフェイス上でデンス モード PIM をイネーブルにします。

PIM インターフェイスをデンス モードに設定する例については、この章の最後にある 「PIM デンス モードの例」 を参照してください。

希薄モードのイネーブル化

インターフェイス上の PIM を希薄モードに設定するには、次の作業を行います。

 

コマンド
目的

Switch(config-if)# ip pim sparse-mode

インターフェイス上で希薄モード PIM をイネーブルにします

PIM インターフェイスを希薄モードに設定する例については、この章の最後にある 「PIM 希薄モードの例」 を参照してください。

スパース/デンス モードのイネーブル化

ip pim sparse-mode または ip pim dense-mode コマンドを使用すると、インターフェイス全体に希薄モードまたはデンス モードが適用されます。ただし、環境によっては、単一リージョン内の一部のグループについては PIM を希薄モードで実行し、残りのグループについてはデンス モードで実行しなければならない場合があります。

デンス モードだけ、または希薄モードだけをイネーブルにするのではなく、スパース/デンス モードをイネーブルにできます。この場合、グループがデンス モードであればインターフェイスはデンス モードとして扱われ、グループが希薄モードであればインターフェイスは希薄モードとして扱われます。グループを希薄グループとして扱い、インターフェイスがスパース/デンス モードである場合には、RP が必要です。

スパース/デンス モードを設定する場合、スパースまたはデンスの概念はスイッチ上のグループに適用され、ネットワーク管理者は同じ概念をネットワーク全体に適用する必要があります。

スパース/デンス モードのもう 1 つの利点は、Auto-RP 情報をデンス モードの方式で配布しながら、ユーザ グループのマルチキャスト グループを希薄モードの方式で使用できるという点です。したがって、リーフ ルータ上にデフォルト RP を設定する必要はありません。

インターフェイスが デンス モードで取り扱われる場合、次のいずれかの条件が満たされると、そのインターフェイスはマルチキャスト ルーティング テーブルの発信インターフェイス リストに追加されます。

インターフェイス上にメンバまたは DVMRP ネイバーが存在する場合

PIM ネイバーが存在し、グループがプルーニングされていない場合

インターフェイスが希薄モードで取り扱われる場合、次のいずれかの条件が満たされると、そのインターフェイスはマルチキャスト ルーティング テーブルの発信インターフェイス リストに追加されます。

インターフェイス上にメンバまたは DVMRP ネイバーが存在する場合

インターフェイス上の PIM ネイバーが明示的な Join メッセージを受信している場合

PIM がグループと同じモードで動作できるようにするには、次の作業を行います。

 

コマンド
目的

Switch(config-if)# ip pim sparse-dense-mode

PIM がグループに応じて、希薄モードまたはデンス モードのいずれかで動作できるようにします。

双方向モードのイネーブル化

Bidir-PIM のほとんどの設定要件は、PIM-SM の設定要件と同じです。双方向モードでマルチキャスト グループのトラフィックを伝送する場合に、インターフェイスをイネーブルまたはディセーブルにする必要はありません。その代わりに、どのマルチキャスト グループが双方向モードで動作するかを設定します。PIM-SM と同様に、Auto-RP、スタティック RP 設定、または PIM Version 2 Bootstrap Router(PIMv2 BSR; PIM バージョン 2 ブートストラップ ルータ)メカニズムを使用して、この設定を行えます。

Bidir-PIM をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Switch(config)# ip pim bidir-enable

スイッチ上で Bidir-PIM をイネーブルにします。

Bidir-PIM を設定するには、group-to-RP マッピングの配布に使用する方法に応じて、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Switch(config)# ip pim rp-address rp-address [access-list] [override] bidir

特定のグループの PIM RP のアドレスを設定し、双方向モードを指定します。Auto-RP メカニズムまたは PIMv2 BSR メカニズムのどちらも使用せずに group-to-RP マッピングを配布する場合は、このコマンドを使用します。

Switch(config)# ip pim rp-candidate type number [group-list access-list] bidir

ルータ自体を BSR に対する PIM バージョン 2 の候補 RP としてアドバタイズし、双方向モードを指定します。PIMv2 BSR メカニズムを使用して group-to-RP マッピングを配布する場合は、このコマンドを使用します。

Switch(config)# ip pim send-rp-address type number scope ttl-value [group-list access-list] [interval seconds] bidir

Auto-RP を使用してルータが RP として動作する対象となるグループが設定されるようにルータを設定し、双方向モードを指定します。Auto-RP を使用して group-to-RP マッピングを配布する場合は、このコマンドを使用します。

Bidir-PIM を設定する方法の例については、「双方向 PIM モードの例」のセクションを参照してください。

PIM-SSM マッピングのイネーブル化

Catalyst 4500 では SSM マッピングがサポートされ、URD と IGMP v3lite のいずれも利用できない場合、あるいはエンド システムでの SSM のサポートが、管理上または技術上の理由で望ましくないか、不可能である場合の SSM の移行が可能です。SSM マッピングにより、IGMPv3 が未サポートである従来型の Set-Top Box(STB; セットトップ ボックス)に映像を配信したり、IGMPv3 ホスト スタックを利用しないアプリケーションに対して、SSM を活用できます。

詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_ssm_mapping_ps6350_TSD_Products_Configuration_Guide_Chapter.html

ランデブー ポイントの設定

プロトコル独立マルチキャスト希薄モード(PIM-SM)で実行するネットワークでは、ランデブー ポイント(RP)が必要です。PIM-SM では、明示的にマルチキャスト データを要求していて、かつアクティブな受信者のいるネットワーク セグメントだけに、トラフィックが転送されます。

ランデブー ポイントを設定するには、いくつかの方法があります。最も一般的なのは、ここで説明するようにスタティック RP を使用する場合と、Auto-RP プロトコルを使用する場合です。その他に、ここでは説明を省きますが、Bootstrap Router(BSR; ブートストラップ ルータ)プロトコルを使用する方法があります。

Auto-RP の設定

Auto-Rendezvous Point(Auto-RP; 自動ランデブー ポイント)は、PIM ネットワークでの group-to-RP マッピングの配布を自動化します。Auto-RP を動作させるには、RP から RP アナウンス メッセージを受信し、競合を調整する RP マッピング エージェントとして RP ルータを設定する必要があります。そして RP マッピング エージェントは、デンス モード フラッディングを経由してすべての他のルータに一貫した group-to-RP マッピングを送信します。

この結果、すべてのルータはサポートするグループに対して使用する RP を自動的に検出します。Internet Assigned Numbers Authority(IANA; インターネット割り当て番号局)は、2 つのグループ アドレス 224.0.1.39 および 224.0.1.40 を Auto-RP に割り当てます。

マッピング エージェントは、複数の候補 RP から RP として使用可能であるというアナウンスを受信します。次に、マッピング エージェントは、どの候補 RP が RP として選択されたかをアナウンスします。このアナウンスは、他のマッピング エージェントによる決定とは無関係に送信されます。

Auto-RP を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Switch> enable

特権 EXEC モードをイネーブルにします。

ステップ 2

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Switch(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

ステップ 4

Switch(config)# interface [FastEthernet | GigabitEthernet | Loopback | Null | Port-channel | TenGigabitEthernet | Tunnel | Vlan] number

PIM をイネーブルにできるホストに接続するインターフェイスを選択します。

ステップ 5

Switch(config-if)# ip pim [sparse-mode | sparse-dense-mode]

インターフェイス上で PIM 希薄モードまたはスパース/デンス モードをイネーブルにします。希薄モードで Auto-RP を設定する場合は、次のステップで Auto-RP リスナーを設定する必要があります。

ステップ 6

Switch(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

すべての PIM インターフェイス上でステップ 4 および 5 を繰り返します。

--

ステップ 8

Switch(config)# ip pim autorp listener

2 つの Auto-RP グループ 224.0.1.39 および 224.0.1.40 の IP マルチキャスト トラフィックを PIM デンス モードにして、PIM 希薄モードで動作しているインターフェイス全体にフラッディングさせます。

ステップ 8 で希薄モードを設定している場合は、このステップを省略します。

ステップ 9

Switch(config)# ip pim send-rp-announce { interface-type interface-number | ip-address } scope ttl-value [ group-list access-list ] [ interval seconds ] [ bidir ]

PIM が有効なすべてのインターフェイスに RP アナウンスを送信します。

このステップは、RP ルータでのみ行います。

interface-type 引数および interface-number 引数を使用して、RP アドレスとして使用する IP アドレスを定義します。

ip-address 引数を使用して、直接接続されている IP アドレスを RP アドレスとして指定します。

引数が設定されている場合、RP アナウンス メッセージは、この IP アドレスの接続先であるインターフェイスから送信されます(つまり、RP アナウンス メッセージの IP ヘッダーにある送信元アドレスがそのインターフェイスの IP アドレスです)。

これは、最大 31 ホップがイネーブル化されているインターフェイスの例です。RP として認識されるルータの IP アドレスは、ループバック インターフェイス 0 に関連付けられている IP アドレスです。アクセス リスト 5 は、このルータが RP として動作するグループを記述します。

ステップ 10

Switch(config)# ip pim send-rp-discovery [interface-type interface-number] scope ttl-value [ interval seconds ]

ルータを RP マッピング エージェントとして設定します。

このステップは、RP ルータでのみ行います。

オプションの interface-type 引数および interface-number 引数を使用して、RP マッピング エージェントの送信元アドレスとして使用する IP アドレスを定義します。

scope キーワードおよび ttl-value 引数を使用して、Auto-RP 検出メッセージの IP ヘッダーに Time-to-Live(TTL; 存続可能時間)値を指定します。

オプションの interval キーワードおよび seconds 引数を使用して、Auto-RP 検出メッセージの送信間隔を指定します。

(注) Auto-RP 検出メッセージを送信する間隔を、デフォルト値の 60 秒から長くすると、group-to-RP マッピングのフラッディングがさらに頻繁に発生します。ネットワーク環境によっては、間隔を長くすることによる短所(制御パケットのオーバーヘッドの増加)が、長所(より頻繁な group-to-RP マッピングの更新)を上回ってしまう場合があります。

次に、ループバック インターフェイス 1 の Auto-RP 検出メッセージを 31 ホップに制限する例を示します。

ステップ 11

Switch(config)# ip pim rp-announce-filter rp-list access-list group-list access-list

RP から送信された着信 Auto-RP アナウンス メッセージをフィルタリングします。

このステップは、RP ルータでのみ行います。

次の 2 つのアクセス リストの例が、このステップに該当します。

access-list 1 permit 10.0.0.1
access-list 1 permit 10.0.0.2
access-list 2 permit 224.0.0.0 15.255.255.255

ステップ 12

Switch(config)# interface type number

PIM をイネーブルにできるホストに接続するインターフェイスを選択します。

ステップ 13

Switch(config-if)# interface ethernet 1

ip multicast boundary access-list [ filter-autorp ]

管理用スコープの境界を設定します。

このステップは、他のルータの境界であるインターフェイス上で実行します。

アクセス リストは、この作業では表示されません。

deny キーワードを使用するアクセス リスト エントリによって、そのエントリと一致するパケットのマルチキャスト境界が作成されます。

ステップ 14

Switch(config-if)# end

EXEC モードに戻ります。

ステップ 15

Switch# show ip pim autorp

(任意)Auto-RP 情報を表示します。

ステップ 16

Switch# show ip pim rp [ mapping ] [ rp-address ]

(任意)ネットワークで認知されている RP を表示し、ルータが各 RP について学習した方法を示します。

ステップ 17

Switch# show ip igmp groups [group-name | group-address | interface-type interface-number] [detail]

(任意)ルータに直接接続されていて、IGMP 経由で学習された受信者を持つマルチキャスト グループを表示します。

受信者の情報を表示結果に表示するには、このコマンドを実行するときに受信者がネットワーク上でアクティブである必要があります。

ステップ 18

Switch# show ip mroute [ group-address | group-name ] [ source-address | source-name ] [ interface-type interface-number ] [ summary ] [ count ] [ active kbps ]

(任意)IP マルチキャスト ルーティング(mroute)テーブルの内容を表示します。

次に、Auto-RP を設定する例を示します。

Switch> enable

Switch# configure terminal

Switch(config)# ip multicast-routing

Switch(config)# interface ethernet 1

Switch(config-if)# ip pim sparse-mode

Switch(config-if)# end

Switch(config)# ip pim autorp listener
Switch(config)# ip pim send-rp-announce loopback0 scope 31 group-list 5
Switch(config)# ip pim send-rp-discovery loopback 1 scope 31

Switch(config)# ip pim rp-announce-filter rp-list 1 group-list 2

Switch(config)# interface ethernet 1

Switch(config-if)# ip multicast boundary 10 filter-autorp

Switch(config-if)# end

Switch# show ip pim autorp

Switch# show ip pim rp mapping

Switch# show ip igmp groups

Switch# show ip mroute cbone-audio

単一スタティック RP の設定

PIM 希薄モードを設定している場合、マルチキャスト グループの PIM RP を設定する必要があります。RP は、各デバイスで静的に設定するか、ダイナミック メカニズムによって学習できます。ここでは、Auto-RP などのダイナミック メカニズムで RP を学習するルータではなく、RP を静的に設定する方法について説明します。

PIM 代表ルータ(DR)は、共有ツリーの下層まで配布するために、直接接続されているマルチキャスト送信元から RP へデータを転送します。データは、2 つの方法のいずれかで RP に転送されます。データはレジスタ パケットにカプセル化され、RP に直接ユニキャストされるか、RP 自体が送信元ツリーに参加している場合は、RPF 転送アルゴリズムごとにマルチキャスト転送されます。受信者に直接接続しているラスト ホップ ルータは、各自の判断で送信元ツリーに参加し、共有ツリーからプルーニングします。

アクセス リストによって定義される複数のグループに単一の RP を設定できます。あるグループに RP が設定されていない場合、ルータはグループを PIM デンス モード技術を使用してデンスとして扱います(この状態が生じないようにするには、no ip pim dm-fallback コマンドを設定します)。

ip pim rp-address コマンドで設定された RP と Auto-RP によって学習された RP の間で競合が発生している場合、override キーワードを設定する場合を除き、Auto-RP 情報が使用されます。

単一スタティック RP を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Switch> enable

特権 EXEC モードをイネーブルにします。

ステップ 2

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Switch(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

ステップ 4

Switch(config)# interface type number

PIM をイネーブルにできるホストに接続するインターフェイスを選択します。

ステップ 5

Switch(config-if)# ip pim [sparse-mode | sparse-dense-mode]

特定のインターフェイス上で PIM をイネーブルにします。希薄モードを使用する必要があります。

ステップ 6

IP マルチキャストを使用するインターフェイスすべてについて、ステップ 4 および 5 を繰り返します。

--

ステップ 7

Switch(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

Switch(config)# ip pim rp-address rp-address [access-list] [override]

特定のグループの PIM RP のアドレスを設定します。

このステップは、すべてのルータで行います。

access-list 引数は、この RP がどのマルチキャスト グループに使用されるかを定義するアクセス リストの番号または名前を指定します。

override キーワードは、このコマンドを使用して設定された RP と Auto-RP によって学習された RP の間に競合が発生している場合に、このコマンドで設定された RP が優先されるかどうかを指定します。

ステップ 9

Switch(config)# end

現在のコンフィギュレーション セッションを終了して、EXEC モードに戻ります。

ステップ 10

Switch# show ip pim rp [ mapping ] [ rp-address ]

(任意)ネットワークで認知されている RP を表示し、ルータが各 RP について学習した方法を示します。

ステップ 11

Switch# show ip igmp groups [group-name | group-address | interface-type interface-number] [detail]

(任意)ルータに直接接続されていて、IGMP 経由で学習された受信者を持つマルチキャスト グループを表示します。

受信者の情報を表示結果に表示するには、このコマンドを実行するときに受信者がネットワーク上でアクティブである必要があります。

ステップ 12

Switch# show ip mroute [ group-address | group-name ] [ source-address | source-name ] [ interface-type interface-number ] [ summary ] [ count ] [ active kbps ]

(任意)IP マルチキャスト ルーティング(mroute)テーブルの内容を表示します。

次に、単一スタティック RP を設定する例を示します。

Switch> enable

Switch# configure terminal

Switch(config)# ip multicast-routing

Switch(config)# interface ethernet 1

Switch(config-if)# ip pim sparse-mode

Switch(config-if)# exit

Switch(config)# ip pim rp-address 192.168.0.0

Switch(config)# end

Switch# show ip pim rp mapping

Switch# show ip igmp groups

Switch# show ip mroute cbone-audio

IP マルチキャスト ルーティングのモニタリングおよびメンテナンス

特定のキャッシュ、テーブル、またはデータベースの内容をすべて削除できます。さらに、特定の統計情報を表示することもできます。ここでは、IP マルチキャストのモニタリングおよびメンテナンス方法について説明します。

「システムおよびネットワークの統計情報の表示」

「マルチキャスト ルーティング テーブルの表示」

「IP MFIB の表示」

「双方向 PIM 情報の表示」

「PIM 統計情報の表示」

「テーブルおよびデータベースの削除」

システムおよびネットワークの統計情報の表示

IP ルーティング テーブルやデータベースの内容など、特定の統計情報を表示できます。表示された情報に基づいて、リソースの利用状況を調べたり、ネットワーク上で発生した問題を解決できます。また、ノードの到達可能性に関する情報を表示し、使用するデバイスのパケットがネットワーク上でたどるルーティング パスを明らかにすることもできます。

各種のルーティング統計情報を表示するには、次の作業を行います。

 

コマンド
目的

Switch# ping [ group-name | group-address ]

マルチキャスト グループ アドレスに Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)エコー要求を送信します。

Switch# show ip mroute [ hostname | group_number ]

IP マルチキャスト ルーティング テーブルの内容を表示します。

Switch# show ip pim interface [ type number ] [ count ]

PIM に設定されているインターフェイスに関する情報を表示します

Switch# show ip interface

すべてのインターフェイスについて PIM 情報を表示します。

マルチキャスト ルーティング テーブルの表示

デンス モードで動作しているルータに関する show ip mroute コマンドの出力例を示します。このコマンドでは、マルチキャスト グループ cbone-audio に関する IP マルチキャスト FIB テーブルの内容が表示されます。

Switch# show ip mroute cbone-audio
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
R - RP-bit set, F - Register flag, T - SPT-bit set
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode
 
(*, 224.0.255.1), uptime 0:57:31, expires 0:02:59, RP is 0.0.0.0, flags: DC
Incoming interface: Null, RPF neighbor 0.0.0.0, Dvmrp
Outgoing interface list:
Ethernet0, Forward/Dense, 0:57:31/0:02:52
Tunnel0, Forward/Dense, 0:56:55/0:01:28
 
(198.92.37.100/32, 224.0.255.1), uptime 20:20:00, expires 0:02:55, flags: C
Incoming interface: Tunnel0, RPF neighbor 10.20.37.33, Dvmrp
Outgoing interface list:
Ethernet0, Forward/Dense, 20:20:00/0:02:52
 

次に、希薄モードで動作しているルータに関する show ip mroute コマンドの出力例を示します。

Switch# show ip mroute
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
R - RP-bit set, F - Register flag, T - SPT-bit set
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode
 
(*, 224.0.255.3), uptime 5:29:15, RP is 198.92.37.2, flags: SC
Incoming interface: Tunnel0, RPF neighbor 10.3.35.1, Dvmrp
Outgoing interface list:
Ethernet0, Forward/Sparse, 5:29:15/0:02:57
 
(198.92.46.0/24, 224.0.255.3), uptime 5:29:15, expires 0:02:59, flags: C
Incoming interface: Tunnel0, RPF neighbor 10.3.35.1
Outgoing interface list:
Ethernet0, Forward/Sparse, 5:29:15/0:02:57

) ハードウェアで転送されるパケットについては、インターフェイス タイマーは更新されません。エントリ タイマーは、約 5 秒ごとに更新されます。


次に、show ip mroute コマンドに summary キーワードを指定した場合の出力例を示します。

Switch# show ip mroute summary
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode
 
(*, 224.255.255.255), 2d16h/00:02:30, RP 171.69.10.13, flags: SJPC
 
(*, 224.2.127.253), 00:58:18/00:02:00, RP 171.69.10.13, flags: SJC
 
(*, 224.1.127.255), 00:58:21/00:02:03, RP 171.69.10.13, flags: SJC
 
(*, 224.2.127.254), 2d16h/00:00:00, RP 171.69.10.13, flags: SJCL
(128.9.160.67/32, 224.2.127.254), 00:02:46/00:00:12, flags: CLJT
(129.48.244.217/32, 224.2.127.254), 00:02:15/00:00:40, flags: CLJT
(130.207.8.33/32, 224.2.127.254), 00:00:25/00:02:32, flags: CLJT
(131.243.2.62/32, 224.2.127.254), 00:00:51/00:02:03, flags: CLJT
(140.173.8.3/32, 224.2.127.254), 00:00:26/00:02:33, flags: CLJT
(171.69.60.189/32, 224.2.127.254), 00:03:47/00:00:46, flags: CLJT
 

次に、show ip mroute コマンドに active キーワードを指定した場合の出力例を示します。

Switch# show ip mroute active
 
Active IP Multicast Sources - sending >= 4 kbps
 
Group: 224.2.127.254, (sdr.cisco.com)
Source: 146.137.28.69 (mbone.ipd.anl.gov)
Rate: 1 pps/4 kbps(1sec), 4 kbps(last 1 secs), 4 kbps(life avg)
 
Group: 224.2.201.241, ACM 97
Source: 130.129.52.160 (webcast3-e1.acm97.interop.net)
Rate: 9 pps/93 kbps(1sec), 145 kbps(last 20 secs), 85 kbps(life avg)
 
Group: 224.2.207.215, ACM 97
Source: 130.129.52.160 (webcast3-e1.acm97.interop.net)
Rate: 3 pps/31 kbps(1sec), 63 kbps(last 19 secs), 65 kbps(life avg)
 

次に、show ip mroute コマンドに count キーワードを指定した場合の出力例を示します。

Switch# show ip mroute count
 
IP Multicast Statistics - Group count: 8, Average sources per group: 9.87
Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
 
Group: 224.255.255.255, Source count: 0, Group pkt count: 0
RP-tree: 0/0/0/0
 
Group: 224.2.127.253, Source count: 0, Group pkt count: 0
RP-tree: 0/0/0/0
 
Group: 224.1.127.255, Source count: 0, Group pkt count: 0
RP-tree: 0/0/0/0
 
Group: 224.2.127.254, Source count: 9, Group pkt count: 14
RP-tree: 0/0/0/0
Source: 128.2.6.9/32, 2/0/796/0
Source: 128.32.131.87/32, 1/0/616/0
Source: 128.125.51.58/32, 1/0/412/0
Source: 130.207.8.33/32, 1/0/936/0
Source: 131.243.2.62/32, 1/0/750/0
Source: 140.173.8.3/32, 1/0/660/0
Source: 146.137.28.69/32, 1/0/584/0
Source: 171.69.60.189/32, 4/0/447/0
Source: 204.162.119.8/32, 2/0/834/0
 
Group: 224.0.1.40, Source count: 1, Group pkt count: 3606
RP-tree: 0/0/0/0
Source: 171.69.214.50/32, 3606/0/48/0, RPF Failed: 1203
 
Group: 224.2.201.241, Source count: 36, Group pkt count: 54152
RP-tree: 7/0/108/0
Source: 13.242.36.83/32, 99/0/123/0
Source: 36.29.1.3/32, 71/0/110/0
Source: 128.9.160.96/32, 505/1/106/0
Source: 128.32.163.170/32, 661/1/88/0
Source: 128.115.31.26/32, 192/0/118/0
Source: 128.146.111.45/32, 500/0/87/0
Source: 128.183.33.134/32, 248/0/119/0
Source: 128.195.7.62/32, 527/0/118/0
Source: 128.223.32.25/32, 554/0/105/0
Source: 128.223.32.151/32, 551/1/125/0
Source: 128.223.156.117/32, 535/1/114/0
Source: 128.223.225.21/32, 582/0/114/0
Source: 129.89.142.50/32, 78/0/127/0
Source: 129.99.50.14/32, 526/0/118/0
Source: 130.129.0.13/32, 522/0/95/0
Source: 130.129.52.160/32, 40839/16/920/161
Source: 130.129.52.161/32, 476/0/97/0
Source: 130.221.224.10/32, 456/0/113/0
Source: 132.146.32.108/32, 9/1/112/0

) マルチキャスト ルートのバイトおよびパケット統計情報がサポートされるのは、最初の 1024 個のマルチキャスト ルートに限られます。出力インターフェイスの統計情報は維持されません。


IP MFIB の表示

MFIB のすべてのルート(上位レイヤのルーティング プロトコル データベースには存在しないが、高速スイッチングをさらに高速化するために使用されるルートも含む)を表示できます。これらのルートは、デンス モード転送が使用されている場合でも、MFIB に表示されます。

MFIB の各種のルーティング ルートを表示するには、次の作業のいずれかを行います。

 

コマンド
目的

Switch# show ip mfib

パケット転送に使用されている(S,G)ルートおよび(*,G)ルートを表示します。すべてのマルチキャスト ルートについて、高速スイッチング、低速スイッチング、およびパーシャル スイッチングされたパケットの数が表示されます。

Switch# show ip mfib all

MFIB のすべてのルート(上位レイヤのルーティング プロトコル データベースには存在しないが、高速スイッチングをさらに高速化するために使用されるルートも含む)を表示します。これらのルートには、(S/M,224/4)ルートが含まれます。

Switch# show ip mfib log [n]

最近発生した n 個の MFIB 関連イベント ログを、新しい順に表示します。

Switch# show ip mfib counters

MFIB 関連イベントのカウンタを表示します。0 以外のカウンタだけが表示されます。

次に、 show ip mfib コマンドの出力例を示します。

IP Multicast Forwarding Information Base
Entry Flags: C - Directly Connected, S - Signal,
IC - Internal Copy
Interface Flags: A - Accept, F - Forward, S - Signal,
NP - Not platform switched
Packets: Fast/Partial/Slow Bytes: Fast/Partial/Slow:
(171.69.10.13, 224.0.1.40), flags (IC)
Packets: 2292/2292/0, Bytes: 518803/0/518803
Vlan7 (A)
Vlan100 (F NS)
Vlan105 (F NS)
(*, 224.0.1.60), flags ()
Packets: 2292/0/0, Bytes: 518803/0/0
Vlan7 (A NS)
(*, 224.0.1.75), flags ()
Vlan7 (A NS)
(10.34.2.92, 239.192.128.80), flags ()
Packets: 24579/100/0, 2113788/15000/0 bytes
Vlan7 (F NS)
Vlan100 (A)
(*, 239.193.100.70), flags ()
Packets: 1/0/0, 1500/0/0 bytes
Vlan7 (A)
..
 

高速スイッチング パケットの数は、該当するルート上でハードウェアによってスイッチングされたパケット数を表します。

部分的スイッチング パケットの数は、高速スイッチング パケットが、ソフトウェア処理のため、あるいは 1 つまたは複数の非プラットフォーム スイッチド インターフェイス(PimTunnel インターフェイスなど)に転送されるため、CPU にコピーされた回数を表します。

低速スイッチング パケットの数は、該当するルート上で完全にソフトウェアによってスイッチングされたパケット数を表します。

双方向 PIM 情報の表示

Bidir-PIM 情報を表示するには、必要に応じて次のコマンドを使用します。

 

コマンド
目的

Switch(config)# show ip pim interface [type number] [df | count] [rp-address]

DF に関連付けられたユニキャスト ルーティング メトリックと共に、インターフェイスの各 RP において選定した DF に関する情報を表示します。

Switch(config)# show ip pim rp [mapping | metric] [rp-address]

各 RP のユニキャスト ルーティング メトリックと共に、Auto-RP または BSR を通じて学習した RP に関する情報を表示します。

PIM 統計情報の表示

次に、show ip pim interface コマンドの出力例を示します。

Switch# show ip pim interface
 
Address Interface Mode Neighbor Query DR
Count Interval
198.92.37.6 Ethernet0 Dense 2 30 198.92.37.33
198.92.36.129 Ethernet1 Dense 2 30 198.92.36.131
10.1.37.2 Tunnel0 Dense 1 30 0.0.0.0
 

次に、show ip pim interface コマンドに count を指定した場合の出力例を示します。

Switch# show ip pim interface count
 
Address Interface FS Mpackets In/Out
171.69.121.35 Ethernet0 * 548305239/13744856
171.69.121.35 Serial0.33 * 8256/67052912
198.92.12.73 Serial0.1719 * 219444/862191
 

次に、IP マルチキャストがイネーブルに設定されている状態で show ip pim interface コマンドに count を指定した場合の出力例を示します。この例では、高速スイッチングおよびプロセス スイッチングされる PIM インターフェイスのリストと、これらのパケット数が表示されます。IP マルチキャストがイネーブルに設定されているインターフェイスには、H が表示されます。

Switch# show ip pim interface count
 
States: FS - Fast Switched, H - Hardware Switched
Address Interface FS Mpackets In/Out
192.1.10.2 Vlan10 * H 40886/0
192.1.11.2 Vlan11 * H 0/40554
192.1.12.2 Vlan12 * H 0/40554
192.1.23.2 Vlan23 * 0/0
192.1.24.2 Vlan24 * 0/0

テーブルおよびデータベースの削除

特定のキャッシュ、テーブル、またはデータベースの内容をすべて削除できます。特定のキャッシュ、テーブル、またはデータベースの内容が無効である場合、または無効であると考えられる場合に、これらの削除が必要になります。

IP マルチキャスト キャッシュ、テーブル、およびデータベースを削除するには、次の作業のいずれかを行います。

 

コマンド
目的
Switch# clear ip mroute

IP ルーティング テーブルのエントリを削除します。

Switch# clear ip mfib counters

ルート単位およびグローバルの MFIB カウンタをすべて削除します。


) IP マルチキャスト ルートは、データ パケットが着信した時点で、プロトコル イベントへの応答として再生成されます。


設定例

ここでは、IP マルチキャスト ルーティングの設定例を示します。

「PIM デンス モードの例」

「PIM 希薄モードの例」

「双方向 PIM モードの例」

「単一スタティック RP を使用する希薄モードの例」

「Auto-RP を使用する希薄モードの例」

PIM デンス モードの例

次に、イーサネット インターフェイス上のデンス モード PIM の設定例を示します。

ip multicast-routing
interface ethernet 0
ip pim dense-mode

PIM 希薄モードの例

次に、希薄モード PIM の設定例を示します。RP ルータは、アドレス 10.8.0.20 のルータです。

ip multicast-routing
ip pim rp-address 10.8.0.20 1
interface ethernet 1
ip pim sparse-mode

双方向 PIM モードの例

デフォルトでは、双方向 RP により、すべてのグループが双方向としてアドバタイズされます。RP のアクセス リストを使用することにより、双方向としてアドバタイズされるグループのリストを指定できます。deny キーワードを使用したグループは、デンス モードで動作します。単一のアクセス リストでは、permit キーワードまたは deny キーワードのどちらかだけを使用できるため、希薄モードで動作するグループには、非双方向の異なる RP アドレスが必要です。

次に、希薄モードおよび双方向モードの両方のグループの RP を設定する例を示します。224/8 と 227/8 は双方向のグループ、226/8 は希薄モード、225/8 はデンス モードです。希薄モードおよび双方向モードの動作において異なる IP アドレスを使用するには、RP を設定する必要があります。また、この設定を可能にするために 2 つのループバック インターフェイスが使用されており、PIM ドメイン内の他のルータでの Auto-RP アナウンスの受信と RP との通信を可能にするために、これらのインターフェイスのアドレスを PIM ドメイン全体にルーティングする必要があります。

ip multicast-routing !Enable IP multicast routing
ip pim bidir-enable !Enable bidir-PIM
!
interface loopback 0
description One Loopback adddress for this routers Bidir Mode RP function
ip address 10.0.1.1 255.255.255.0
ip pim sparse-dense-mode
!
interface loopback 1
description One Loopback adddress for this routers Sparse Mode RP function
ip address 10.0.2.1 255.255.255.0
ip pim sparse-dense-mode
ip pim send-rp-announce Loopback0 scope 10 group-list 45 bidir
ip pim send-rp-announce Loopback1 scope 10 group-list 46
ip pim send-rp-discovery scope 10
access-list 45 permit 224.0.0.0 0.255.255.255
access-list 45 permit 227.0.0.0 0.255.255.255
access-list 45 deny 225.0.0.0 0.255.255.255
access-list 46 permit 226.0.0.0 0.255.255.255

単一スタティック RP を使用する希薄モードの例

次に、すべてのマルチキャスト グループの PIM RP アドレスを 192.168.1.1 に設定し、すべてのグループが希薄モードで動作するように定義する例を示します。

ip multicast-routing
interface ethernet 1
ip pim sparse-mode
ip pim rp-address 192.168.1.1
no ip pim dm-fallback

) 双方向モードおよび希薄モードの両方のグループに対して同じ RP は使用できません。


次に、マルチキャスト グループ 225.2.2.2 についてのみ PIM RP アドレスを 172.16.1.1 に設定する例を示します。

access list 1 225.2.2.2 0.0.0.0
ip pim rp-address 172.17.1.1

Auto-RP を使用する希薄モードの例

次に、Auto-RP を使用して希薄モードを設定する例を示します。

ip multicast-routing
ip pim autorp listener
ip pim send-rp-announce Loopback0 scope 16 group-list 1
ip pim send-rp-discovery Loopback1 scope 16
no ip pim dm-fallback
access-list 1 permit 239.254.2.0 0.0.0.255
access-list 1 permit 239.254.3.0 0.0.0.255
.
.
.
access-list 10 permit 224.0.1.39
access-list 10 permit 224.0.1.40
access-list 10 permit 239.254.2.0 0.0.0.255
access-list 10 permit 239.254.3.0 0.0.0.255