Catalyst 4500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2(46)SG
イーサネット CFM および OAM の設定
イーサネット CFM および OAM の設定
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

イーサネット CFM および OAM の設定

用語の定義

イーサネット CFM の概要

CFM ドメイン

CFM メンテナンス ポイント

パケット転送の一般的なルール

内側向き MEP

外側向き MEP

透過ポート

CFM メッセージ

クロスチェック機能

SNMP トラップ

CFM の IP SLA サポート

イーサネット CFM の設定

イーサネット CFM のデフォルト設定

イーサネット CFM 設定時の注意事項

ポートの CFM のディセーブル化

VLAN 上のイーサネット CFM サービスの設定

VLAN のイーサネット CFM クロスチェックの設定

IP SLA CFM 動作の設定

IP SLA CFM プローブ動作またはジッタ動作の手動による設定

エンドポイント ディスカバリを行う IP SLA 動作の設定

イーサネット CFM 情報の表示

例:内側向き MEP を持つスイッチポート/VLAN CFM

イーサネット OAM プロトコルの概要

OAM 機能

OAM メッセージ

イ-サネット OAM のセットアップと設定

イーサネット OAM のデフォルト設定

イーサネット OAM 設定時の注意事項

インターフェイスでのイーサネット OAM のイネーブル化

イーサネット OAM リモート ループバックのイネーブル化

イーサネット OAM リンク モニタリングの設定

イーサネット OAM リモート障害表示の設定

イーサネット OAM テンプレートの設定

イーサネット OAM プロトコル情報の表示

イーサネット CFM とイーサネット OAM の相互作用

イーサネット OAM および CFM の設定例

イーサネット CFM および OAM の設定

イーサネット Operations, Administration, and Maintenance(OAM; 運用管理および保守)は、イーサネット ネットワークの設置、モニタリング、およびトラブルシューティングのためのプロトコルで、イーサネット インフラストラクチャ内の管理機能が強化されます。Catalyst 4500 シリーズ スイッチは、IEEE 802.1ag の Connectivity Fault Management(CFM; 接続障害管理)、IEEE 802.ah のイーサネット OAM ディスカバリ、リンク モニタリング、リモート障害検知、およびリモート ループバックをサポートします。イーサネット OAM マネージャは、CFM と OAM の間の相互作用を制御します。

CFM のコマンドおよび設定情報の詳細については、次の URL にアクセスして、Cisco IOS フィーチャ モジュールを参照してください。

http://www.cisco.com/en/US/products/ps6922/products_feature_guide09186a008066fcb8.html

イーサネット OAM プロトコルのコマンドおよび設定に関する詳細については、次の URL にアクセスして、Cisco IOS フィーチャ モジュールを参照してください。

http://www.cisco.com/en/US/products/ps6922/products_feature_guide09186a008067344c.html

CFM およびイーサネット OAM コマンドのマニュアルについては、次の URL を参照してください。

http://www.cisco.com/en/US/products/ps6922/products_command_reference_book09186a0080699104.html

この章の内容は、次のとおりです。

「イーサネット CFM の概要」

「イーサネット CFM の設定」

「イーサネット CFM 情報の表示」

「例:内側向き MEP を持つスイッチポート/VLAN CFM」

「イーサネット OAM プロトコルの概要」

「イ-サネット OAM のセットアップと設定」

「イーサネット OAM プロトコル情報の表示」

「イーサネット CFM とイーサネット OAM の相互作用」

用語の定義

 

用語
定義

CC

Ethernet OAM Continuity Check

CFM

Ethernet Connectivity Fault Management

EI

Ethernet Infrastructure または EVC Infrastructure

EVC

Ethernet Virtual Circuit:イーサネット バーチャル サーキット

MEP

Maintenance Endpoint

MIP

Maintenance Intermediate Point

OAM

Operations Administration and Maintenance

UNI

User to Network Interface

イーサネット CFM の概要

イーサネット CFM は、サービス インスタンスごと(VLAN ごと)のエンドツーエンド イーサネット レイヤ OAM プロトコルで、予防的な接続モニタリング、障害検証、および障害分離の機能が含まれています。エンドツーエンドは、Provider Edge(PE; プロバイダー エッジ)デバイスから PE デバイス(PE-to-PE)、または Customer Edge(CE; カスタマー エッジ)デバイスから CE デバイス(CE-to-CE)で可能です。イーサネット CFM は、IEEE 802.1ag で仕様が定められた、イーサネット ネットワークのレイヤ 2 ping、レイヤ 2 traceroute、およびエンドツーエンドの接続性検証に関する規格です。

CFM とは異なり、他のメトロ イーサネット OAM プロトコルはエンドツーエンド テクノロジーではありません。たとえば、IEEE 802.3ah OAM は物理回線ごとのシングルホップ プロトコルであり、エンドツーエンド方式でもサービス認識方式でもありません。

ここでは、イーサネット CFM の概要について説明します。

「CFM ドメイン」

「CFM メンテナンス ポイント」

「パケット転送の一般的なルール」

「CFM メッセージ」

「クロスチェック機能」

「SNMP トラップ」

「CFM の IP SLA サポート」

CFM ドメイン

CFM メンテナンス ドメインは、シングル エンティティにより所有および運用が行われ、一連の内部境界ポートにより定義される、ネットワーク上の管理空間です。管理者は一意のメンテナンス レベル(0 ~ 7)を割り当て、ドメインの階層構造を定義します。ドメインが大きいほど、レベルは高くなります。たとえば、図56-1 に示すように、オペレータ ドメインより大きなサービス プロバイダー ドメインのメンテナンス レベルが 6 に、オペレータ ドメインのメンテナンス レベルが 3 または 4 に設定されるような場合もあります。

図56-2 に示すように、複数のエンティティによる管理は許可されないため、ドメインが交差したり重複したりすることはできません。ドメインが接触したりネストすることは可能です(外側のドメインのメンテナンス レベルがネストされたドメインより高い場合)。ドメインのネストは、サービス プロバイダーが 1 つまたは複数のオペレータにイーサネット サービスを提供する契約を締結する場合に便利です。各オペレータはそれぞれ専用のメンテナンス ドメインを持ち、サービス プロバイダー ドメインはオペレータ ドメインのスーパーセットになります。ネストするドメインのメンテナンス レベルは管理組織間で通知される必要があります。CFM はメッセージを交換し、ドメインの操作を個別に実行します。

図56-1 CFM メンテナンス ドメイン

 

図56-2 ドメイン間で許可される関係

 

CFM メンテナンス ポイント

メンテナンス ポイントは、メンテナンス ドメイン内の CFM に参加するインターフェイス上の境界点です。メンテナンス ポイントでは、下位レベルのフレームがすべてドロップされ、上位レベルのフレームがすべて転送されます。メンテナンス ポイントには次の 2 種類があります。

Maintenance End Point(MEP)は、ドメインのエッジに存在して境界を定義し、CFM メッセージをこの境界内に限定します。MEP は、デフォルトで 内側向き です。内側向きとは、その MEP が(ポートに接続された)回線側でなく、リレー機能側を経由して通信することを意味します。外側向きの MEP が設定されると、リレー機能側でなく、回線側を経由して通信します。

内側向き MEP は、リレー機能経由で CFM フレームを送受信します。回線側から着信する、自分と同レベルまたは下位レベルの CFM フレームをすべてドロップします。リレー側から着信する CFM フレームについては、自分と同レベルのフレームを処理し、下位レベルのフレームをドロップします。内側向き MEP は、リレー側と回線側のどちらから受信した CFM フレームでも、自分より上位レベルのフレームはすべて透過的に転送します。CFM はプロバイダーのメンテナンス レベル(UPE-to-UPE)で実行され、具体的には User Network Interface(UNI)にある内側向き MEP と連動します。

外側向き MEP(OFM)は、回線側の CFM フレームを送受信します。リレー機能側から着信する自分と同レベルまたは下位レベルの CFM フレームをすべてドロップします。回線側から着信する CFM フレームについては、自分と同レベルのフレームを処理し、下位レベルのフレームをドロップします。OFM は、リレー側と回線側のどちらから受信したフレームでも、自分より上位レベルの CFM フレームはすべて透過的に転送します。

Maintenance Intermediate Point(MIP)はドメインの内側にあり、境界上にはありません。また、traceroute および loopback メッセージによりトリガーされたときにのみ、CFM に応答します。MIP は MEP および他の MIP から受信した CFM フレームを転送し、下位レベルの CFM フレームをすべてドロップします。上位レベルの CFM フレームは、リレー側と回線側のどちらから受信したフレームでもすべて転送します。

内側向き MEP が設定されているポートが Spanning-Tree Protocol(STP; スパニング ツリー プロトコル)によりブロックされると、その MEP は CFM メッセージを受信することも送信することもできません。外側向き MEP(OFM)が設定されているポートが STP によりブロックされると、その OFM は回線側からの CFM メッセージだけを受信し、回線側に向かう CFM メッセージだけを送信することができます。MIP が設定されているポートが STP によりブロックされると、そのポートはリレー機能側からのメッセージを受信したり応答することはできませんが、回線側からの CFM メッセージを受信したりそれに応答することができます。

パケット転送の一般的なルール

イーサネット CFM フレームの転送やドロップは、階層型メンテナンス ドメインの厳密なルールに基づいて行われる必要があります。ブリッジ ポート上に設定されている MEP および MIP はフィルタとして機能し、適正なレベルに属さない CFM フレームをドロップすることで CFM フレームを適切なドメインの境界内に限定します。

次の内容について説明します。

「内側向き MEP」

「外側向き MEP」

「透過ポート」

内側向き MEP

内側向き MEP には次の機能があります。

MEP が設定されているポートに接続されている回線経由ではなく、リレー機能経由で、自分と同じレベルの CFM フレームを送受信します。

回線側から着信する自分と同じレベル(または下位レベル)の CFM フレームをすべてドロップします。

リレー機能方向から着信する自分と同じレベルの CFM フレームをすべて処理します。

ポートの回線に到着するパケットは回線側から着信しているパケットです。

内部的に CPU から到着するパケット、またはハードウェア(またはソフトウェア)のブリッジ処理により内部的に到着するパケットは、リレー機能側から着信しているパケットです。

リレー機能方向から着信する下位レベルの CFM フレームをすべてドロップします。

リレー機能側と回線側のどちらから着信したフレームでも、上位レベルの CFM フレームはすべて透過的に転送します。


) レベル L(L != 7)の MEP には、同じポート上にレベル M > L の MIP が必要です。したがって、MEP のレベルより上位レベルの CFM フレームは、この MIP によりカタログ化されます。


MEP が設定されているポートが STP によりブロックされると、MEP は CFM メッセージを送信することも受信することもできません。


) Catalyst 4500 Supervisor Engine 6-ME の場合、外側向き MEP はスーパーバイザのアップリンク ポートでのみサポートされます。


外側向き MEP

外側向き MEP には次の機能があります。

MEP が設定されているポートに接続されている回線を経由する自分と同じレベルの CFM フレームを送受信します。

リレー機能側から着信する自分と同じレベル(または下位レベル)の CFM フレームをすべてドロップします。

回線方向から着信する自分と同じレベルの CFM フレームをすべて処理します。

回線方向から着信する下位レベルの CFM フレームをすべてドロップします。

リレー機能側と回線側のどちらから着信したフレームでも、上位レベルの CFM フレームはすべて透過的に転送します。

レベル L(L != 7)の MEP には、同じポート上にレベル M > L の MIP が必要です。したがって、MEP のレベルより上位レベルの CFM フレームは、この MIP によりカタログ化されます。

MEP が設定されているポートが STP によりブロックされた場合でも、MEP は回線経由で CFM メッセージを送受信できます。

MIP は、回線経由とリレー機能経由のどちらでも、自分と同じレベルの CFM フレームのカタログ化や転送を行います。

MIP は、回線側とリレー機能側のどちらから着信した CFM フレームでも、下位レベルのフレームをすべて停止しドロップします。

MIP は、回線側とリレー機能側のどちらから着信したフレームでも、上位レベルの CFM フレームはすべて透過的に転送します。

MIP が設定されているポートが STP によりブロックされると、MIP は CFM メッセージを受信したりリレー機能側へリレーしたりできなくなりますが、回線からの CFM メッセージを受信したりそれに応答することはできます。

透過ポート

透過ポートは MEP も MIP も設定されていないポートであり、CFM フレームを通常のデータ トラフィックのように転送します。

STP ブロッキングは、内側向き MEP を持つポートの場合と同じように、透過ポート上の CFM フレームにも適用されます。つまり、ポートが STP によりブロックされると、CFM フレームはポートでの入出力時にドロップされます。

CFM メッセージ

CFM は、EtherType または MAC アドレス(マルチキャスト メッセージの場合)で識別される標準イーサネット フレームを使用します。すべての CFM メッセージは、メンテナンス ドメイン内および Service-Provider VLAN(S-VLAN)内に限定されます。次の 4 つの CFM メッセージがサポートされています。

Continuity Check(CC)メッセージ ― MEP 間で定期的に交換されるマルチキャスト ハートビート メッセージ。これにより MEP はドメイン内の他の MEP を、また MIP は MEP を検出できます。CC メッセージはドメイン内または VLAN 内に限定されます。

ループバック メッセージ ― 管理者の要求により MEP が送信する、特定のメンテナンス ポイントとの接続を確認するためのユニキャスト フレーム。接続先に到達できるかどうかを示します。ループバック メッセージは、Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)の ping メッセージと同様です。

traceroute メッセージ ― 管理者の要求で MEP が送信する、目的の MEP までのパスを(ホップ単位で)追跡するためのマルチキャスト フレーム。traceroute メッセージは、概念的には UDP traceroute メッセージと同様です。

AIS メッセージ ― 第 56 章「イーサネット CFM および OAM の設定」 の説明を参照してください。

クロスチェック機能

クロスチェック機能では、(クロスチェック メッセージを使用して)ダイナミックに設定された MEP と、(設定により)サービスが提供される MEP との間の、プロビジョニング後のタイマー駆動型サービスを検証します。この機能により、マルチポイント サービスのすべてのエンドポイントが動作可能であることが検証されます。クロスチェック機能は 1 回だけ実行され、CLI(コマンドライン インターフェイス)から開始されます。

SNMP トラップ

MEP は、CC トラップとクロスチェック トラップの 2 種類の SNMP トラップを生成します。

サポートされる CC トラップには次のものがあります。

MEP アップ

MEP ダウン

相互接続(サービス ID と VLAN が一致しない)

ループ

設定エラー

サポートされるクロスチェック トラップには次のものがあります。

サービス アップ

MEP なし(所定の MEP がダウン)

未知の MEP

CFM の IP SLA サポート

メトロ スイッチは IP Service Level Agreement(SLA; サービス レベル契約)を使用した CFM をサポートしています。SLA によってイーサネット レイヤのネットワーク パフォーマンス メトリックを収集できます。IP SLA CFM 動作で使用可能な統計情報の測定には、Rount-Trip Time(RTT; ラウンドトリップ時間)、ジッタ(インターパケット遅延のばらつき)、パケット損失があります。複数の IP SLA 動作をスケジューリングし、SNMP トラップ通知と Syslog メッセージを使用すると、しきい値の超過を予防的にモニタリングできます。

IP SLA と CFM の統合により、CFM MEP 間でイーサネット データ フレームを送受信してイーサネット レイヤ統計測定を行えます。パフォーマンスは送信元 MEP と宛先 MEP の間で測定されます。パフォーマンス メトリックが IP レイヤに限られている IP SLA 動作と異なり、IP SLA と CFM の併用によりレイヤ 2 のパフォーマンス メトリックが得られます。

イーサネット ping 動作とジッタ動作を個別に手動で設定できます。また、特定のメンテナンス ドメインおよび VLAN に存在するすべての MEP について CFM データベースに問い合わせを行う、IP SLA 自動イーサネット動作を設定することもできます。この動作では引き続いて、検出した MEP を基に個別のイーサネット ping 動作またはジッタ動作を自動的に作成します。

CFM を使用した IP SLA 動作の詳細については、次の URL にアクセスして、『 IP SLAs for Metro-Ethernet 』フィーチャ モジュールを参照してください。

http://www.cisco.com/en/US/products/ps6922/products_feature_guide09186a00807d72f5.html

イーサネット CFM の設定

イーサネット CFM を設定するには、ネットワークの準備とサービスの設定が必要です。任意でクロスチェックを設定し、それをイネーブルにすることもできます。ここでは、次の内容について説明します。

「イーサネット CFM のデフォルト設定」

「イーサネット CFM 設定時の注意事項」

「ポートの CFM のディセーブル化」

「VLAN 上のイーサネット CFM サービスの設定」

「VLAN のイーサネット CFM クロスチェックの設定」

「IP SLA CFM 動作の設定」

イーサネット CFM のデフォルト設定

CFM はグローバルにディセーブルとなっています。

CFM はすべてのインターフェイス上でイネーブルです。ポートは、フロー ポイント(MIP/MEP)または透過ポートとして設定することも、ディセーブルにする(CFM ディセーブル)こともできます。デフォルトでは、ポートは、MEP または MIP に設定されるまで、またはディセーブルにされるまで透過ポートです。

MEP も MIP も設定されていません。

イーサネット CFM 設定時の注意事項

CFM 設定時の注意事項および制約事項は次のとおりです。

ポート上に MEP を設定する場合は、その前に MIP を設定してください。ただし、MEP がレベル 7 の場合または MEP が外側向き MEP(OFM)の場合を除きます。同様に、ポート上の MIP を削除する場合は、その前にすべての MEP を削除する必要があります。

STP がブロックされたポート上の OFM では、CFM ユニキャスト パケット(ループバック メッセージおよび traceroute 応答)は許可されません。このため、ブロックされたポートは ping と traceroute に応答することができません。

ルーテッド ポート上では CFM がサポートされないため、CFM を設定できません。

dot1q トンネル ポート上では CFM がサポートされないため、CFM を設定できません。

EtherChannel ポート チャネル上では CFM がサポートされます。EtherChannel ポート チャネルを MEP または MIP として設定できます。ただし、EtherChannel に属する個別ポート上では CFM がサポートされないため、EtherChannel グループに CFM ポートを追加できません。

VLAN インターフェイス上では CFM を設定できません。

EoMPLS ポート上では CFM を設定できません。

PVLAN 隔離ホスト ポート、コミュニティ ホスト ポート、または混合モード アクセス ポート上では CFM がサポートされないため、CFM を設定できません。

PVLAN トランク上の内側向き MEP には、通常 VLAN 上でのみ CFM がサポートされます。PVLAN セカンダリ トランク上の通常 VLAN および隔離 VLAN 上では OFM がサポートされます。同様に、混合モード トランク ポート上の通常 VLAN およびプライマリ VLAN 上では OFM がサポートされます。

PVALN 上の CFM サービスは PVLAN トランクで終了します。PVLAN トランク間では、PVLAN から別の PVLAN への CFM サービス変換はサポートされません。

ポートの CFM のディセーブル化

CFM がグローバルにイネーブルになっている場合、ポート(またはポート チャネル)上で個別に CFM をディセーブルにできます。


) デフォルトでは、CFM はグローバルにすべてのポートでディセーブルおよびイネーブルになります。


ネットワークで VLAN 上のイーサネット CFM を設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Switch(config)# interface interface-id

設定する物理インターフェイスまたはポート チャネルを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Switch(config-if)# no ehernet cfm enable

CFM をグローバルにディセーブルにします。

インターフェイス上で CFM がディセーブルになっている場合、そのインターフェイスに到着するすべての CFM フレームは通常のデータ トラフィックとして転送され、CPU による処理は行われません。

ステップ 4

Switch(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 5

Switch(config)# end

特権 EXEC モードに戻ります。

VLAN 上のイーサネット CFM サービスの設定

ネットワークで VLAN 上のイーサネット CFM を設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Switch(config)# ethernet cfm enable

CFM をグローバルにイネーブルにします。

ステップ 3

Switch(config)# vlan vlan-id

VLAN を設定します。

ステップ 4

Switch(config)# ethernet cfm traceroute cache [ size entries | hold-time minutes ]

(任意)CFM traceroute キャッシュを設定します。最大キャッシュ サイズまたはホールド タイムを設定できます。

(任意) size には、キャッシュ サイズをエントリの行数で入力します。指定できる範囲は 1 ~ 4095 で、デフォルトは 100 行です。

(任意) hold-time には、最大キャッシュ ホールド タイムを分単位で入力します。指定できる範囲は 1 ~ 65535 で、デフォルトは 100 分です。

ステップ 5

Switch(config)# ethernet cfm domain domain-name level level-id {direction outward}

CFM ドメインの定義とドメイン レベルの設定を行い、ドメインの ethernet-cfm コンフィギュレーション モードを開始します。指定できるメンテナンス レベル番号の範囲は 0 ~ 7 です。

方向を outward として設定します。これは OFM の設定に必要です。

ステップ 6

Switch(config-ether-cfm)# [no] service csi-id vlan vlan-id

EVC のメンテナンス ドメイン内のカスタマーに対応する一意の ID を設定します。

ステップ 7

Switch(config-ether-cfm)# mep archive-hold-time minutes

(任意)存在しない MEP からのデータが削除されるまでの保持時間を分単位で設定します。指定できる範囲は 1 ~ 65535 で、デフォルトは 100 分です。

ステップ 8

Switch(config-ether-cfm)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

Switch(config)# interface interface-id

設定する物理インターフェイスまたはポート チャネルを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 10

Switch(config-if)# ethernet cfm mip level level-id

ステップ 3 で定義したドメイン レベル ID のオペレータ レベル MIP を設定します。


) このインターフェイス上で MEP をレベル 7 に設定する予定がある場合は、同じインターフェイス上の MIP をこのコマンドで設定しないでください。


ステップ 11

Switch(config-if)# ethernet cfm mep level level-id {[inward] | outward} mpid id vlan {vlan-id | any | vlan-id-vlan-id [,vlan-id-vlan-id]}

(任意)メンテナンス レベルごとに MEP を設定します。指定できる MEP レベルの範囲は 0 ~ 7 です。

エンド ポイントの方向を指定します(outward 方向は必須で、inward 方向は任意です)。

mpid identifier には、MEP の ID を入力します。ID は VLAN(サービス インスタンス)ごとに一意である必要があります。有効範囲は 1 ~ 8191 です。

vlan vlan-id には、サービス プロバイダーの VLAN ID または ID を VLAN-ID(1 ~ 4095)として入力します。VLAN-ID の範囲を指定する場合はハイフンで区切って示し、VLAN-ID を列記する場合はカンマで区切って示します。


) レベル ID ごとにこのコマンドを繰り返します。


ステップ 12

Switch(config-ether-cfm)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 13

Switch(config)# ethernet cfm cc {[ enable ] level { level-id | any } vlan { vlan-id | any }}

ドメインごとの CC パラメータを設定します。設定を適用するドメインはレベル ID で識別されます。

enable を入力して、ドメイン レベルの CFM CC をイネーブルにします。

メンテナンス レベル level に、レベル番号(0 ~ 7)またはすべてのメンテナンス レベルを表す any を入力します。

チェックを適用する VLAN を VLAN-ID(1 ~ 4095)として入力します。VLAN-ID の範囲を指定する場合はハイフンで区切って示し、VLAN-ID を列記する場合はカンマで区切って示します。すべての VLAN を表す場合は any を入力します。

ステップ 14

Switch(config)# snmp-server enable traps ethernet cfm cc [ mep-up ] [ mep-down ] [ config ] [ loop ] [ cross-connect ]

(任意)イーサネット CFM CC トラップをイネーブルにします。

ステップ 15

Switch(config)# snmp-server enable traps ethernet cfm crosscheck [ mep-unknown ] [ mep-missing ] [ service-up ]

(任意)イーサネット CFM クロスチェック トラップをイネーブルにします。

ステップ 16

Switch(config)# end

特権 EXEC モードに戻ります。

ステップ 17

Switch# show ethernet cfm domain brief
Switch# show ethernet cfm maintenance-points local
Switch# show ethernet cfm traceroute-cache

設定を確認します。

ステップ 18

Switch# show running-config

入力を確認します。

ステップ 19

Switch# copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

設定を削除する場合、またはデフォルト設定に戻す場合は、上記コマンドの no 形式を使用します。

VLAN のイーサネット CFM クロスチェックの設定

VLAN のイーサネット CFM クロスチェックを設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Switch(config)# ethernet cfm mep crosscheck start-delay delay

クロスチェックが開始されるまでにリモート MEP がアクティブになるのを待つ時間を秒数で設定します。指定できる範囲は 1 ~ 65535 です。デフォルトは 30 秒です。

ステップ 3

Switch(config)# ethernet cfm domain domain-name level level-id {direction outward}

CFM ドメインの定義とドメイン レベルの設定を行い、ドメインの ethernet-cfm コンフィギュレーション モードを開始します。指定できるメンテナンス レベル番号の範囲は 0 ~ 7 です。

方向を outward として設定します。これは OFM の設定に必要です。

ステップ 4

Switch(config-ether-cfm)# mep crosscheck mpid identifier vlan vlan-id [ mac remote MAC address ]

メンテナンス ドメイン内のリモート MEP を定義します。

mpid identifier には、リモート MEP の ID を入力します。有効範囲は 1 ~ 8191 です。

vlan vlan-id に指定できる VLAN 範囲は 1 ~ 3581 です。

(任意)リモート MEP の MAC アドレスを指定します。

ステップ 5

Switch(config)# end

特権 EXEC モードに戻ります。

ステップ 6

Switch# ethernet cfm mep crosscheck { enable | disable } level level-id vlan { vlan-id | any}

1 つまたは複数のメンテナンス レベルと VLAN の CFM クロスチェックを、イネーブルまたはディセーブルにします。

level level-id にはレベル ID(0 ~ 7)を入力します。レベル ID の範囲を指定する場合はハイフンで区切って示し、レベル ID を列記する場合はカンマで区切って示します。

vlan vlan-id には、サービス プロバイダーの VLAN ID または ID を VLAN-ID(1 ~ 3581)として入力します。VLAN-ID の範囲を指定する場合はハイフンで区切って示し、VLAN-ID を列記する場合はカンマで区切って示します。すべての VLAN を表す場合は any を入力します。

ステップ 7

Switch# show ethernet cfm maintenance-points remote crosscheck

設定を確認します。

ステップ 8

Switch# show ethernet cfm errors

クロスチェック動作の結果を表示します。

ステップ 9

Switch# copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

設定を削除する場合、またはデフォルト設定に戻す場合は、各コマンドの no 形式を使用します。

IP SLA CFM 動作の設定

IP SLA のイーサネット ping 動作またはジッタ エコー動作を手動で設定したり、エンドポイント ディスカバリを行う IP SLA イーサネット動作を設定することができます。また、複数の動作をスケジューリングすることもできます。一方向遅延の正確な統計情報を得るには、各エンドポイント スイッチのクロックを同期させる必要があります。各エンドポイント スイッチに Network Time Protocol(NTP)を設定すると、各エンドポイント スイッチは同じクロック ソースに同期します。


) Catalyst 4500 シリーズ スイッチに Class of Service(CoS; サービス クラス)プローブを設定する場合は、最初に mls qos グローバル コンフィギュレーション コマンドを入力して、グローバルに QoS をイネーブルにする必要があります。


IP SLA イーサネット動作の詳細については、次の URL にアクセスして、『 IP SLAs for Metro-Ethernet 』フィーチャ モジュールを参照してください。

http://www.cisco.com/en/US/products/ps6922/products_feature_guide09186a00807d72f5.html

IP SLA 動作の設定に関する詳細については、次の URL で『 Cisco IOS IP SLAs Configuration Guide 』Release 12.4T を参照してください。

http://www.cisco.com/en/US/products/ps6441/products_configuration_guide_book09186a0080707055.html

IP SLA コマンドの詳細については、次の URL にあるコマンド リファレンスを参照してください。

http://www.cisco.com/en/US/products/ps6441/products_command_reference_book09186a008049739b.html

ここでは、次の内容について説明します。

「IP SLA CFM プローブ動作またはジッタ動作の手動による設定」

「エンドポイント ディスカバリを行う IP SLA 動作の設定」

IP SLA CFM プローブ動作またはジッタ動作の手動による設定

IP SLA イーサネット エコー(ping)動作またはジッタ動作を手動で設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip sla operation-number

IP SLA 動作を作成し、IP SLA コンフィギュレーション モードを開始します。

ステップ 3

ethernet echo mpid identifier domain domain-name vlan vlan-id

または

ethernet jitter mpid identifier domain domain-name vlan vlan-id [ interval interpacket-interval ] [ num-frames number-of frames transmitted ]

IP SLA 動作をエコー(ping)動作またはジッタ動作として設定し、IP SLA イーサネット エコー コンフィギュレーション モードを開始します。

ping 動作には echo を入力し、ジッタ動作には jitter を入力します。

mpid identifier には、MEP の ID を入力します。ID は VLAN(サービス インスタンス)ごとに一意である必要があります。有効範囲は 1 ~ 8191 です。

domain domain-name には、CFM ドメイン名を入力します。

vlan vlan-id に指定できる VLAN 範囲は 1 ~ 4095 です。

(任意 ― ジッタの場合のみ) interval およびジッタ パケットの送信間隔を入力します。

(任意 ― ジッタの場合のみ) num-frames および送信するフレーム数を入力します。

ステップ 4

cos cos-value

(任意)この動作の CoS 値を設定します。

Catalyst 3750 Metro スイッチ上で cos パラメータを設定する前に、 mls qos グローバル コンフィギュレーション コマンドを入力して、QoS をグローバルにイネーブルにします。

ステップ 5

frequency seconds

(任意)IP SLA 動作を繰り返す間隔を設定します。指定できる範囲は 1 ~ 604800 秒です。デフォルトは 60 秒です。

ステップ 6

history history-parameter

(任意)IP SLA 動作に関する統計履歴情報を収集するためのパラメータを指定します。

ステップ 7

owner owner-id

(任意)IP SLA 動作の SNMP オーナーを設定します。

ステップ 8

request-data-size bytes

(任意)IP SLA 要求パケットのプロトコル データのサイズを指定します。指定できる範囲は 0 ~「使用するプロトコルで許可される最大サイズ」です。デフォルトは 66 バイトです。

ステップ 9

tag text

(任意)IP SLA 動作のユーザ指定 ID を作成します。

ステップ 10

threshold milliseconds

(任意)ネットワーク モニタリング統計情報の算出に使用するしきい値の上限値をミリ秒で指定します。指定できる範囲は 0 ~ 2147483647 です。デフォルトは 5000 です。

ステップ 11

timeout milliseconds

(任意)IP SLA 動作の要求パケットに対する応答を待つ時間をミリ秒で指定します。指定できる範囲は 0 ~ 604800000 です。デフォルトは 5000 です。

ステップ 12

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 13

ip sla schedule operation-number [ ageout seconds ] [ life { forever | seconds }] [ recurring ] [ start-time { hh:mm {:ss } [ month day | day month ] | pending | now | after hh:mm:ss }]

IP SLA 動作のスケジューリングに関する時間パラメータを設定します。

operation-number ― IP SLA 動作番号を入力します。

(任意) ageout seconds ― 情報をアクティブに収集していない場合、動作をメモリに常駐させておく時間を秒数で入力します。指定できる範囲は 0 ~ 2073600 秒です。デフォルトは 0 秒です。

(任意) life ― 動作の実行を無期限( forever )に設定するか、秒数で指定します。指定できる範囲は 0 ~ 2147483647 秒です。デフォルトは 3600 秒(1時間)です。

(任意) recurring ― 毎日、自動的にプローブがスケジュールされるように設定します。

(任意) start-time ― 情報の収集を開始する時刻を入力します。

開始時刻を指定する場合は、時、分、秒(24 時間表記)、月日を入力します。

pending を入力した場合、開始時刻を指定するまで情報収集は行われません。

now を入力した場合、すぐに動作が開始されます。

after hh:mm:ss と入力した場合、指定した時刻が経過すると動作が開始されます。

ステップ 14

end

特権 EXEC モードに戻ります。

ステップ 15

show ip sla configuration [ operation-number ]

設定されている IP SLA 動作を表示します。

ステップ 16

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

IP SLA 動作を削除するには、no ip sla operation-number グローバル コンフィギュレーション コマンドを入力します。

エンドポイント ディスカバリを行う IP SLA 動作の設定

IP SLA を使用して、ドメインおよび VLAN ID の CFM エンドポイントを自動的に検出するには、次の手順を実行します。検出したエンドポイントに対する ping 動作またはジッタ動作を設定できます。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip sla ethernet-monitor operation-number

IP SLA 自動イーサネット動作の設定を開始し、IP SLA イーサネット モニタ コンフィギュレーション モードを開始します。

ステップ 3

type echo domain domain-name vlan vlan-id [ exclude-mpids mp-ids ]

または

type jitter domain domain-name vlan vlan-id [ exclude-mpids mp-ids ] [ interval interpacket-interval ] [ num-frames number-of frames transmitted ]

エコー(ping)動作またはジッタ動作が作成されるように自動イーサネット動作を設定し、IP SLA イーサネット エコー コンフィギュレーション モードを開始します。

ping 動作には type echo を入力し、ジッタ動作には type jitter を入力します。

mpid identifier には、MEP の ID を入力します。有効範囲は 1 ~ 8191 です。

domain domain-name には、CFM ドメイン名を入力します。

vlan vlan-id に指定できる VLAN 範囲は 1 ~ 4095 です。

(任意) exclude-mpids mp-ids を入力して、指定された MEP ID を除外します。

(任意 ― ジッタの場合のみ) interval およびジッタ パケットの送信間隔を入力します。

(任意 ― ジッタの場合のみ) num-frames および送信するフレーム数を入力します。

ステップ 4

cos cos-value

(任意)この動作の CoS 値を設定します。

ステップ 5

owner owner-id

(任意)IP SLA 動作の SNMP オーナーを設定します。

ステップ 6

request-data-size bytes

(任意)IP SLA 要求パケットのプロトコル データのサイズを指定します。指定できる範囲は 0 ~「使用するプロトコルで許可される最大サイズ」です。デフォルトは 66 バイトです。

ステップ 7

tag text

(任意)IP SLA 動作のユーザ指定 ID を作成します。

ステップ 8

threshold milliseconds

(任意)ネットワーク モニタリング統計情報の算出に使用するしきい値の上限値をミリ秒で指定します。指定できる範囲は 0 ~ 2147483647 です。デフォルトは 5000 です。

ステップ 9

timeout milliseconds

(任意)IP SLA 動作の要求パケットに対する応答を待つ時間をミリ秒で指定します。指定できる範囲は 0 ~ 604800000 です。デフォルトは 5000 です。

ステップ 10

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

ip sla schedule operation-number [ ageout seconds ] [ life { forever | seconds }] [ recurring ] [ start-time { hh:mm {:ss } [ month day | day month ] | pending | now | after hh:mm:ss }]

IP SLA 動作のスケジューリングに関する時間パラメータを設定します。

operation-number ― IP SLA 動作番号を入力します。

(任意) ageout seconds ― 情報をアクティブに収集していない場合、動作をメモリに常駐させておく時間を秒数で入力します。指定できる範囲は 0 ~ 2073600 秒です。デフォルトは 0 秒です。

(任意) life ― 動作の実行を無期限( forever )に設定するか、秒数で指定します。指定できる範囲は 0 ~ 2147483647 秒です。デフォルトは 3600 秒(1時間)です。

(任意) recurring ― 毎日、自動的にプローブがスケジュールされるように設定します。

(任意) start-time ― 情報の収集を開始する時刻を入力します。

開始時刻を指定する場合は、時、分、秒(24 時間表記)、月日を入力します。

pending を入力した場合、開始時刻を指定するまで情報収集は行われません。

now を入力した場合、すぐに動作が開始されます。

after hh:mm:ss と入力した場合、指定した時刻が経過すると動作が開始されます。

ステップ 12

end

特権 EXEC モードに戻ります。

ステップ 13

show ip sla configuration [ operation-number ]

設定されている IP SLA 動作を表示します。

ステップ 14

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

IP SLA 動作を削除するには、 no ip sla operation-number グローバル コンフィギュレーション コマンドを入力します。

イーサネット CFM 情報の表示

イーサネット CFM 情報を表示するには、 表56-1 に示す特権 EXEC コマンドを使用します。

 

表56-1 CFM 情報の表示

コマンド
目的
show ethernet cfm domain brief

CFM メンテナンス ドメインに関する簡潔な説明を表示します。

show ethernet cfm errors

デバイスが最後にリセットされてから、またはログが最後にクリアされてからデバイス ログに記録された CFM CC エラー状況を表示します。CFM クロスチェックがイネーブルになっている場合は、CFM クロスチェック動作の結果を表示します。

show ethernet cfm maintenance-points local

デバイスに設定されているメンテナンス ポイントを表示します。

show ethernet cfm maintenance-points remote [detail | domain | level]

CFM データベース内のリモート メンテナンス ポイントのドメインまたはレベルに関する情報、または詳細情報を表示します。

show ethernet cfm maintenance-points remote crosscheck

クロスチェック リストにスタティックに設定されたリモート メンテナンス ポイントに関する情報を表示します。

show ethernet cfm traceroute-cache

traceroute キャッシュの内容を表示します。

IP SLA イーサネット CFM 情報を表示するには、 表56-2 に示す特権 EXEC コマンドを使用します。

 

表56-2 IP SLA CFM 情報の表示

コマンド
目的
show ip sla configuration [ entry-number ]

すべての IP SLA 動作または特定の IP SLA 動作に関する、デフォルト値をすべて含めた設定値を表示します。

show ip sla ethernet-monitor configuration [ entry-number ]

IP SLA 自動イーサネット動作の設定を表示します。

show ip sla statistics [ entry-number | aggregated | details ]

動作ステータスおよび統計情報の現在値または集約値を表示します。

例:内側向き MEP を持つスイッチポート/VLAN CFM

次に、2 つのスイッチ間の VLAN ベース CFM 設定の例を示します。この例では、Supervisor Engine II+10GE スイッチ(g6-1)と Metro Ethernet Supervisor Engine 6-E スイッチ(Switch)が接続されています。具体的には g6-1 の Gi 6/5 と Switch の gi3/5 がイーサネット ケーブルで接続されています。

Supervisor Engine II+10GE(「g6-1」)の設定
-----------------------------------------------------

!
ethernet cfm domain customer2 level 6
ethernet cfm domain PROVIDER2 level 5
service customerX vlan 102
ethernet cfm enable
!
!
vlan 102
!
interface GigabitEthernet6/2
switchport access vlan 102
ethernet cfm mip level 6
ethernet cfm mep level 5 mpid 2101 vlan 102
!
interface GigabitEthernet6/5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 102
switchport mode trunk
ethernet cfm mip level 5
!
ethernet cfm cc enable level 5 vlan 102
!
 

「g6-1」からの画面ダンプ
-----------------------------------------------------

g6-1# show ethernet cfm main rem
Can only Ping/Traceroute to remote MEPs marked with *
 
-------------------------------------------------------------------------------
MPID Level Mac Address Vlan PortState InGressPort Age(sec) Service ID
-------------------------------------------------------------------------------
2111* 5 001b.d550.90fd 102 UP Gi6/5 6 customerX
 
Total Remote MEPs: 1
g6-1#
 
g6-1# show ethernet cfm main local
sh ethernet cfm main local
-------------------------------------------------------------------------------
MPID Level Type VLAN Port CC-Status MAC DomainName
-------------------------------------------------------------------------------
2101 5 MEP I 102 Gi6/2 Enabled 000a.4172.df3d PROVIDER2
 
 
-------------------------------------------------------------------------------
Level Type Port MAC
-------------------------------------------------------------------------------
6 MIP Gi6/2 000a.4172.df3d
5 MIP Gi6/5 000a.4172.df3d
g6-1#
 
 

メトロ イーサネット Supervisor Engine 6-E スイッチ(「Switch」)の設定
-----------------------------------------------------

!
ethernet cfm domain customer2 level 6
ethernet cfm domain PROVIDER2 level 5
service customerX vlan 102
ethernet cfm enable
!
vlan 102
!
interface GigabitEthernet3/1
switchport mode trunk
ethernet cfm mip level 6
ethernet cfm mep level 5 mpid 2111 vlan 102
!
interface GigabitEthernet3/5
switchport mode trunk
ethernet cfm mip level 5
!
ethernet cfm cc enable level 5 vlan 102
!
 

「Switch」の画面ダンプ
-----------------------------------------------------

Switch# show ethernet cfm main rem
Can only Ping/Traceroute to remote MEPs marked with *
 
MPID Level Mac Address Vlan PortState InGressPort Age(sec) Service ID
2101* 5 000a.4172.df3d 102 UP Gi3/5 1 customerX
Total Remote MEPs: 1
Switch# show ethernet cfm main local
MPID DomainName Level Type VLAN Port CC-Status MAC
2111 PROVIDER2 5 MEP 102 Gi3/1 Enabled 001b.d550.90fd
 
Level Type Port MAC
6 MIP Gi3/1 001b.d550.90fd
5 MIP Gi3/5 001b.d550.90fd
 

イーサネット OAM プロトコルの概要

イーサネット OAM プロトコルは、メトロ イーサネット ネットワークおよびイーサネット WAN の設置、モニタリング、トラブルシューティングを行うためのもので、OSI モデルのデータリンク レイヤのオプション サブレイヤに準拠しています。リンクの通常動作にはイーサネット OAM を必要としません。イーサネット OAM は、ネットワークまたはネットワークの一部(インターフェイスを指定)の全二重ポイントツーポイント リンクまたはエミュレートされたポイントツーポイント イーサネット リンク上に実装できます。

OAM フレームは OAM Protocol Data Unit(OAM PDU)とも呼ばれ、低速プロトコル宛先 MAC アドレス(0180.c200.0002)を使用します。OAM フレームは MAC サブレイヤで代行受信され、イーサネット ネットワーク内の複数のホップには伝播されません。イーサネット OAM は比較的低速なプロトコル(最大転送速度が毎秒 10 フレーム)なので、通常動作への影響はわずかです。ただし、リンク モニタリングをイネーブルにした場合は、CPU がエラー カウンタを頻繁にポーリングする必要があるため、ポーリングの対象になるインターフェイスの数が増えるに従って CPU の負荷も増えます。

イーサネット OAM は、主として次の 2 つのコンポーネントで構成されます。

OAM クライアント ― リンク上のイーサネット OAM の確立と管理、および OAM サブレイヤのイネーブル化と設定を行います。OAM ディスカバリ フェーズ中、リモート ピアから受信する OAM PDU をモニタリングし OAM 機能をイネーブルにします。OAM クライアントは、ディスカバリ フェーズが終了すると、OAM PDU に対する応答規則および OAM リモート ループバック モードを管理します。

OAM サブレイヤ ― 上位 MAC サブレイヤ側と下位 MAC サブレイヤ側の 2 つの 標準 IEEE 802.3 MAC サービス インターフェイスを提供します。OAM サブレイヤは OAM クライアントの専用インターフェイスとして機能し、OAM 制御情報と PDU を OAM クライアントとの間で送受信します。OAM サブレイヤには次のコンポーネントが含まれます。

制御ブロックは、OAM クライアントとその他の OAM サブレイヤ内部ブロックとの間のインターフェイスを提供します。

マルチプレクサは、MAC クライアントからのフレーム、制御ブロック、およびパーサーを管理し、制御ブロックからの OAM PDU とパーサーからのループバック フレームを下位レイヤに渡します。

パーサーは、フレームを OAM PDU、MAC クライアント フレーム、またはループバック フレームに分類したあと、適切なエンティティに送信します。具体的には、OAM PDU を制御ブロックに送信し、MAC クライアント フレームを上位サブレイヤに、ループバック フレームをマルチプレクサに送信します。

OAM 機能

IEEE 802.3ah では、次の OAM 機能が定義されています。

ディスカバリ機能では、ネットワーク内のデバイスとその OAM 機能を識別します。OAM PDU を定期的に使用し、OAM モード、OAM 設定、OAM 機能、PDU 設定、およびプラットフォーム アイデンティティを通知します。オプションのフェーズを使用すると、ローカル ステーションがピアの OAM エンティティの設定を許可したり拒否したりできます。

リンク モニタリングでは、さまざまな状況下のリンク障害を検出し表示します。リンクの問題が検出された場合には、イベント通知 OAM PDU を使用してリモートの OAM デバイスに通知します。エラー イベントには、シンボル エラー数、フレーム エラー数、指定フレーム数内のフレーム エラー数、または指定時間内のエラー秒数がそれぞれの設定しきい値を超過した場合が含まれます。

リモート障害表示機能では、ピアに対し OAM エンティティの品質が徐々に劣化していることを各種条件で通知します。Link Fault は信号の損失、Dying Gasp は回復不能な状況、Critical Event は指定されていないベンダー固有のクリティカル イベントを示します。スイッチは Link Fault OAM PDU と Critical Event OAM PDU を受信して処理することができますが、生成はできません。スイッチが生成できるのは、Dying Gasp OAM PDU です。この PDU は、イーサネット OAM がディセーブルになったとき、インターフェイスがシャットダウンしたとき、インターフェイスが errdisable ステートになったとき、またはスイッチがリロードしたときに生成されます。スイッチは、停電に起因する Dying Gasp PDU に応答できますが、生成はできません。

リモート ループバック モードは、設置時またはトラブルシューティング時にリモート ピアとのリンク品質を確認するために使用します。このモードにあるスイッチは、OAM PDU でないフレームまたはポーズ フレームでないフレームを受信すると、そのフレームを同じポート上で送り返します。ユーザからはリンクが機能している状態に見えます。送り返されたループバック確認応答を利用すると、遅延、ジッタ、およびスループットのテストができます。

OAM メッセージ

イーサネット OAM メッセージや PDU は、標準長のタグなしイーサネット フレーム(64 ~ 1518)です。これらは複数のホップに伝播されず、最大伝送速度が毎秒 10 OAM PDU です。メッセージ タイプにはインフォメーション(information)、イベント通知(event notification)、ループバック制御(loopback control)、およびベンダー固有の OAM PDU(vendor-specific OAM PDU)があります。

イ-サネット OAM のセットアップと設定

ここでは、次の情報について説明します。

「イーサネット OAM のデフォルト設定」

「イーサネット OAM 設定時の注意事項」

「インターフェイスでのイーサネット OAM のイネーブル化」

「イーサネット OAM リモート ループバックのイネーブル化」

「イーサネット OAM リンク モニタリングの設定」

「イーサネット OAM リモート障害表示の設定」

「イーサネット OAM テンプレートの設定」

イーサネット OAM のデフォルト設定

デフォルト設定は次のとおりです。

イーサネット OAM はすべてのインターフェイスでディセーブルです。

インターフェイス上でイーサネット OAM がイネーブルになると、リンク モニタリングが自動的にオンになります。

リモート ループバックはディセーブルです。

イーサネット OAM テンプレートは設定されていません。

イーサネット OAM 設定時の注意事項

イーサネット OAM の設定時は、次の注意事項に従ってください。

スイッチでは、Cyclic Redundancy Code(CRC)エラーを伴って送信された出力フレームのモニタリングをサポートしていません。 ethernet oam link-monitor transmit crc インターフェイス コンフィギュレーション コマンドまたはテンプレート コンフィギュレーション コマンドが表示されますが、スイッチではサポートしていません。コマンドは受け付けられますが、インターフェイスには適用されません。

リモート障害表示では、スイッチは Link Fault と Critical Event OAM PDU を生成しません。ただし、これらの PDU をリンク パートナーから受信した場合には処理を行います。スイッチは Dying Gasp OAM PDU の生成と受信を行います。この PDU は、イーサネット OAM がディセーブルになったとき、インターフェイスがシャットダウンしたとき、インターフェイスが errdisable ステートになったとき、またはスイッチがリロードしたときに生成されます。スイッチは、停電に起因する Dying Gasp PDU に応答できますが、生成はできません。

スイッチは、EtherChannel、ISL トランク、および混合モード トランクに属するポートでのイーサネット OAM ループバックをサポートしません。

インターフェイスでのイーサネット OAM のイネーブル化

インターフェイス上でイーサネット OAM をイネーブルにするには、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイスを EOM インターフェイスとして設定することを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ethernet oam

インターフェイス上でイーサネット OAM をイネーブルにします。

ステップ 4

ethernet oam [ max-rate oampdus | min-rate seconds | mode { active | passive } | timeout seconds ]

次の OAM パラメータを任意で設定します。

(任意) max-rate oampdus を入力し、1 秒あたり送信される OAM PDU の最大数を設定します。有効範囲は 1 ~ 10 です。

(任意) min-rate seconds を入力し、1 秒あたり 1 つの OAM PDU が送信されるときの最小伝送速度を秒単位で設定します。有効範囲は 1 ~ 10 です。

(任意) mode active を入力して、OAM クライアント モードをアクティブにします。active がデフォルトです。

(任意) mode passive を入力して、OAM クライアント モードをパッシブにします。


) トラフィックが通過する 2 つのインターフェイス上でイーサネット OAM をイネーブルにする場合には、少なくとも 1 つをアクティブ モードにする必要があります。


(任意) timeout seconds を入力して、OAM クライアントのタイムアウト時間を設定します。有効範囲は 2 ~ 30 です。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show ethernet oam status [ interface interface-id ]

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイス上のイーサネット OAM をディセーブルにするには、 no ethernet oam インターフェイス コンフィギュレーション コマンドを入力します。

次に、スイッチで OAM の基本パラメータを設定する例を示します。

Switch(config)# int gi1/3
Switch(config-if)# ethernet oam
Switch(config-if)# ethernet oam max-rate 9
Switch(config-if)# ethernet oam mode passive
Switch(config-if)# end
Switch# show ethernet oam status int gi1/2
GigabitEthernet1/2
 
General
-------
Admin state: enabled
Mode: passive
PDU max rate: 9 packets per second
PDU min rate: 1 packet per 1 second
Link timeout: 5 seconds
High threshold action: no action
Link fault action: no action
Dying gasp action: no action
Critical event action: no action
 
Link Monitoring
---------------
Status: supported (on)
 
Symbol Period Error
Window: 100 x 1048576 symbols
Low threshold: 1 error symbol(s)
High threshold: none
 
Frame Error
Window: 10 x 100 milliseconds
Low threshold: 1 error frame(s)
High threshold: none
 
Frame Period Error
Window: 1000 x 10000 frames
Low threshold: 1 error frame(s)
High threshold: none
 
Frame Seconds Error
Window: 100 x 100 milliseconds
Low threshold: 1 error second(s)
High threshold: none
 
Receive-Frame CRC Error
Window: 10 x 100 milliseconds
Low threshold: 10 error frame(s)
High threshold: none
 
Transmit-Frame CRC Error: Not Supported

イーサネット OAM リモート ループバックのイネーブル化

ローカル OAM クライアントが OAM リモート ループバック動作を開始するには、インターフェイス上でイーサネット OAM リモート ループバックをイネーブルにする必要があります。この設定が変更されると、ローカル OAM クライアントは設定情報をリモート ピアと交換します。リモート ループバックはデフォルトでディセーブルです。

リモート ループバックには次の制限事項があります。

ループバックされるのはデータ パケットだけです。

ISL ポートまたは EtherChannel に属するポートにイーサネット OAM リモート ループバックを設定することはできません。

リモート ループバックは最大 16 ポートでサポートされます。

インターフェイス上でイーサネット OAM リモート ループバックをイネーブルにするには、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイスを EOM インターフェイスとして設定することを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ethernet oam remote-loopback { supported | timeout seconds }

インターフェイス上でイーサネット リモート ループバックをイネーブルにしたり、ループバック タイムアウト時間を設定したりします。

supported を入力して、リモート ループバックをイネーブルにします。

timeout seconds を入力して、リモート ループバック タイムアウト時間を設定します。指定できる範囲は 1 ~ 10 秒です。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

ethernet oam remote-loopback { start | stop } { interface interface-id }

インターフェイス上でイーサネット OAM リモート ループバックをオンまたはオフにします。

ステップ 6

show ethernet oam status [ interface interface-id ]

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

リモート ループバック サポートをディセーブルにしたり、タイムアウト設定を削除したりするには、 no ethernet oam remote-loopback { supported | timeout } インターフェイス コンフィギュレーション コマンドを使用します。

次に、OAM リモート ループバックをイネーブルにする例を示します。

Switch(config)# int gi1/3
Switch(config-if)# ethernet oam
Switch(config-if)# ethernet oam remote-loopback supported
Switch(config-if)# end
Switch# show running int gi1/1
Building configuration...
 
Current configuration : 209 bytes
!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,19
switchport mode trunk
ethernet oam remote-loopback supported
ethernet oam
end
 
Switch# ethernet oam remote-loopback start int gi1/1
This is a intrusive loopback.
Therefore, while you test Ethernet OAM MAC connectivity,
you will be unable to pass traffic across that link.
Proceed with Remote Loopback? [confirm]
 
Switch# ethernet oam remote-loopback stop int gi1/1
Switch#
*Apr 9 12:52:39.793: %ETHERNET_OAM-6-LOOPBACK: Interface Gi1/1 has exited the master loopback mode.

イーサネット OAM リンク モニタリングの設定

リンク モニタリング機能に高しきい値と低しきい値を設定できます。高しきい値を何も設定しない場合のデフォルトは、 none です(高しきい値は未設定)。低しきい値を設定しない場合、デフォルトは高しきい値より小さな値になります。

excrc エラーと trxcrc エラーは非標準のため、シスコではこれらに関するリンク イベント PDU を生成しません。

インターフェイス上でイーサネット OAM リンク モニタリングを設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ethernet oam link-monitor supported

インターフェイスをイネーブルにしてリンク モニタリングをサポートします。これがデフォルト設定です。

以前に no ethernet oam link-monitor supported コマンドを入力してリンク モニタリングをディセーブルにしていた場合にのみ、このコマンドを入力する必要があります。

ステップ 4

ethernet oam link-monitor symbol-period { threshold { high { high symbols | none } | low { low-symbols }} | window symbols }
Repeat this step to configure both high and low thresholds.

(任意)エラー シンボル期間リンク イベントをトリガーする、エラー シンボル期間の高しきい値および低しきい値を設定します。

threshold high high-symbols を入力して、高しきい値をシンボル数で設定します。指定できる範囲は 1 ~ 65535 です。デフォルトは none です。

threshold high none を入力して、高しきい値をディセーブルにします(すでに設定していた場合)。これがデフォルト設定です。

threshold low low-symbols を入力して、低しきい値をシンボル数で設定します。指定できる範囲は 0 ~ 65535 です。この値は高しきい値よりも小さくする必要があります。

window symbols を入力して、ポーリング期間のウィンドウ サイズをシンボル数で設定します。指定できる範囲は 1 ~ 65535 シンボルです。

ステップ 5

ethernet oam link-monitor frame { threshold { high { high-frames | none } | low { low-frames }} | window milliseconds }
Repeat this step to configure both high and low thresholds.

(任意)エラー フレーム リンク イベントをトリガーする、エラー フレームの高しきい値および低しきい値を設定します。

threshold high high-frames を入力して、高しきい値をフレーム数で設定します。指定できる範囲は 1 ~ 65535 です。デフォルトは none です。

threshold high none を入力して、高しきい値をディセーブルにします(すでに設定していた場合)。これがデフォルト設定です。

threshold low low-frames を入力して、低しきい値をフレーム数で設定します。指定できる範囲は 0 ~ 65535 です。デフォルトは 1 です。

window milliseconds を入力して、エラー フレームをカウントするウィンドウ サイズを時間で設定します。指定できる範囲は 10 ~ 600、ミリ秒単位で 100 の倍数です。デフォルトは 100 です。

ステップ 6

ethernet oam link-monitor frame-period { threshold { high { high-frames | none } | low { low-frames }} | window frames }
Repeat this step to configure both high and low thresholds.

(任意)エラー フレーム期間リンク イベントをトリガーする、エラー フレーム期間の高しきい値および低しきい値を設定します。

threshold high high-frames を入力して、高しきい値をフレーム数で設定します。指定できる範囲は 1 ~ 65535 です。デフォルトは none です。

threshold high none を入力して、高しきい値をディセーブルにします(すでに設定していた場合)。これがデフォルト設定です。

threshold low low-frames を入力して、低しきい値をフレーム数で設定します。指定できる範囲は 0 ~ 65535 です。デフォルトは 1 です。

window frames を入力して、ポーリングのウィンドウ サイズをフレーム数で入力します。指定できる範囲は 1 ~ 65535 で、それぞれの値は 10000 フレームの倍数です。デフォルトは 1000 です。

ステップ 7

ethernet oam link-monitor frame-seconds { threshold { high { high-frames | none } | low { low-frames }} | window milliseconds }
Repeat this step to configure both high and low thresholds.

(任意)エラー フレーム秒リンク イベントをトリガーする、フレーム秒エラーの高しきい値および低しきい値を設定します。

threshold high high-frames を入力して、エラー フレーム秒の高しきい値を秒数で設定します。指定できる範囲は 1 ~ 900 です。デフォルトは none です。

threshold high none を入力して、高しきい値をディセーブルにします(すでに設定していた場合)。これがデフォルト設定です。

threshold low low-frames を入力して、低しきい値をフレーム数で設定します。指定できる範囲は 1 ~ 900 です。デフォルトは 1 です。

window frames を入力して、ポーリングのウィンドウ サイズをミリ秒で入力します。指定できる範囲は 100 ~ 9000 で、それぞれの値は 100 ミリ秒の倍数です。デフォルトは 1000 です。

ステップ 8

ethernet oam link-monitor receive-crc { threshold { high { high-frames | none } | low { low-frames }} | window milliseconds }
Repeat this step to configure both high and low thresholds.

(任意)一定期間に CRC エラーを伴って受信した入力フレームをモニタリングするためのしきい値を設定します。

threshold high high-frames を入力して、CRC エラーを伴って受信したフレーム数の高しきい値を設定します。指定できる範囲は 1 ~ 65535 フレームです。

threshold high none を入力して、高しきい値をディセーブルにします。

threshold low low-frames を入力して、低しきい値をフレーム数で設定します。指定できる範囲は 0 ~ 65535 です。デフォルトは 1 です。

window milliseconds を入力して、CRC エラーを伴うフレームをカウントするウィンドウ サイズを時間で設定します。指定できる範囲は 10 ~ 1800、ミリ秒単位で 100 の倍数です。デフォルトは 100 です。

ステップ 9

[no] ethernet link-monitor on

(任意)インターフェイス上でのリンク モニタリング動作を( no キーワードの入力時に)開始または停止します。リンク モニタリング動作は、サポートをイネーブルにすると自動的に開始されます。

ステップ 10

end

特権 EXEC モードに戻ります。

ステップ 11

show ethernet oam status [ interface interface-id ]

設定を確認します。

ステップ 12

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ethernet oam link-monitor transmit-crc { threshold { high { high-frames | none } | low { low-frames }} | window milliseconds } コマンドはスイッチに表示され、入力することができますが、サポートされていません。このコマンドの no 形式を入力して設定をディセーブルにします。しきい値の設定をディセーブルにするには、各コマンドの no 形式を使用します。

シンボル エラー カウンタは、次のラインカードおよびスーパーバイザ カードでサポートされています。

スーパーバイザ カード:WS-X4515、WS-X4516、WS-X4013+、WS-X4013+TS、WS-X4516-10GE、WS-X4013+10GE

ラインカード:WS-X4148-RJ、WS-X4124-RJ、WS-X4232、WS-X4232-RJ-XX、WS-X4148-RJ21、WS-X4504-FX-MT、WS-X4224-RJ21-XX、WS-X4124-FX-MT、WS-X4232-L3

上記以外のカードではシンボル エラー カウンタをサポートしていません。

イーサネット OAM リモート障害表示の設定

次の場合に、インターフェイス上で errdisable アクションを発生させるように設定することができます。

インターフェイス上に設定されたリンク モニタリングの高しきい値を超過

Dying Gasp の受信時、インターフェイス上で shut を実行

Dying Gasp の受信時、reload コマンドを実行

Dying Gasp の受信時、インターフェイス上で no ethernet oam コマンドを実行

インターフェイス上でイーサネット OAM リモート障害表示アクションをイネーブルにするには、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ethernet oam remote-failure [ dying-gasp]
action error-disable-interface

インターフェイス上でイーサネット OAM リモート障害アクションを設定します。 dying-gasp を選択することで、イーサネット OAM がディセーブルにされた場合またはインターフェイスが errdisable ステートに入った場合に、インターフェイスをシャットダウンさせ、インターフェイスをディセーブルにするように設定できます。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show ethernet oam status [ interface interface-id ]

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次に、スイッチ インターフェイス上でイーサネット OAM リモート障害アクションを設定する例を示します。

Switch# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# int gi1/1
Switch(config-if)# ethernet oam remote-failure dying-gasp action error
Switch(config-if)# ethernet oam link-monitor high-threshold action error
Switch(config-if)# end
Switch# show running-config int gi1/1
Building configuration...
 
Current configuration : 353 bytes
!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,19
switchport mode trunk
ethernet oam remote-loopback supported
ethernet oam link-monitor high-threshold action error-disable-interface
ethernet oam remote-failure dying-gasp action error-disable-interface
ethernet oam
end
Switch# show ethernet oam status int gi1/1
GigabitEthernet1/1
General
-------
Admin state: enabled
Mode: active
PDU max rate: 10 packets per second
PDU min rate: 1 packet per 1 second
Link timeout: 5 seconds
High threshold action: error disable interface
Link fault action: no action
Dying gasp action: error disable interface
Critical event action: no action
 
Link Monitoring
---------------
Status: supported (on)
 
Symbol Period Error
Window: 100 x 1048576 symbols
Low threshold: 1 error symbol(s)
High threshold: none
 
Frame Error
Window: 10 x 100 milliseconds
Low threshold: 1 error frame(s)
High threshold: none
 
Frame Period Error
Window: 1000 x 10000 frames
Low threshold: 1 error frame(s)
High threshold: none
 
Frame Seconds Error
Window: 100 x 100 milliseconds
Low threshold: 1 error second(s)
High threshold: none
 
Receive-Frame CRC Error
Window: 10 x 100 milliseconds
Low threshold: 10 error frame(s)
High threshold: none
 
Transmit-Frame CRC Error: Not Supported
 

EtherChannel インターフェイス上でイーサネット OAM フェールオーバー アクションをイネーブルにするには、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel interface-id

インターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport mode mode

EtherChannel インターフェイスのモードを設定します。

ステップ 4

ethernet oam link-monitor high-threshold action failover

ポート チャネル インターフェイス上でイーサネット OAM リモート障害アクションをフェールオーバーに設定します。このアクションは、リンク モニタリング RFI の場合に限って設定可能です。

EtherChannel インターフェイスにフェールオーバーが設定されていて、そのインターフェイスが EtherChannel の最後のメンバー ポートの場合には、インターフェイスは errdisable になりません。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show ethernet oam status [ interface interface-id ]

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチは Link Fault と Critical Event OAM PDU を生成しません。ただし、これらの PDU をリンク パートナーから受信した場合には処理を行います。スイッチは Dying Gasp OAM PDU の送受信をサポートします。この PDU は、イーサネット OAM がディセーブルになったとき、インターフェイスがシャットダウンしたとき、インターフェイスが errdisable ステートになったとき、またはスイッチがリロードしたときに生成されます。スイッチは、停電に起因する Dying Gasp PDU に応答できますが、生成はできません。リモート障害表示アクションをディセーブルにするには、 no ethernet remote-failure { critical-event | dying-gasp | link-fault } action コマンドを入力します。

イーサネット OAM テンプレートの設定

テンプレートを作成すると、複数のイーサネット OAM インターフェイスに共通のオプションをまとめて設定できます。このテンプレートは、フレーム エラー、フレーム期間エラー、フレーム秒エラー、受信 CRS エラー、シンボル期間エラー、およびしきい値をモニタリングするように設定できます。また、高しきい値を超過した場合に、そのインターフェイスを errdisable ステートにするようにテンプレートを設定することもできます。これらの手順は任意で、順序を変えて実行したり、さまざまなオプションを設定するために繰り返したりできます。

イーサネット OAM テンプレートを設定し、インターフェイスに関連付けるには、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

template template-name

テンプレートを作成し、テンプレート コンフィギュレーション モードを開始します。

ステップ 3

ethernet oam link-monitor receive-crc { threshold { high { high-frames | none } | low { low-frames }} | window milliseconds }

(任意)一定期間に CRC エラーを伴って受信した入力フレームをモニタリングするためのしきい値を設定します。

threshold high high-frames を入力して、CRC エラーを伴って受信したフレーム数の高しきい値を設定します。指定できる範囲は 1 ~ 65535 フレームです。

threshold high none を入力して、高しきい値をディセーブルにします。

threshold low low-frames を入力して、低しきい値をフレーム数で設定します。指定できる範囲は 0 ~ 65535 です。デフォルトは 1 です。

window milliseconds を入力して、CRC エラーを伴うフレームをカウントするウィンドウ サイズを時間で設定します。指定できる範囲は 10 ~ 1800、ミリ秒単位で 100 の倍数です。デフォルトは 100 です。

ステップ 4

ethernet oam link-monitor symbol-period { threshold { high { high symbols | none } | low { low-symbols }} | window symbols }

(任意)エラー シンボル期間リンク イベントをトリガーする、エラー シンボル期間の高しきい値および低しきい値を設定します。

threshold high high-symbols を入力して、高しきい値をシンボル数で設定します。有効範囲は 1 ~ 65535 です。

threshold high none を入力して、高しきい値をディセーブルにします。

threshold low low-symbols を入力して、低しきい値をシンボル数で設定します。指定できる範囲は 0 ~ 65535 です。この値は高しきい値よりも小さくする必要があります。

window symbols を入力して、ポーリング期間のウィンドウ サイズをシンボル数で設定します。指定できる範囲は 1 ~ 65535 シンボルです。

ステップ 5

ethernet oam link-monitor frame { threshold { high { high-frames | none } | low { low-frames }} | window milliseconds }

(任意)エラー フレーム リンク イベントをトリガーする、エラー フレームの高しきい値および低しきい値を設定します。

threshold high high-frames を入力して、高しきい値をフレーム数で設定します。指定できる範囲は 1 ~ 65535 です。高しきい値を入力する必要があります。

threshold high none を入力して、高しきい値をディセーブルにします。

threshold low low-frames を入力して、低しきい値をフレーム数で設定します。指定できる範囲は 0 ~ 65535 です。デフォルトは 1 です。

window milliseconds を入力して、エラー フレームをカウントするウィンドウ サイズを時間で設定します。指定できる範囲は 10 ~ 600、ミリ秒単位で 100 の倍数です。デフォルトは 100 です。

ステップ 6

ethernet oam link-monitor frame-period { threshold { high { high-frames | none } | low { low-frames }} | window frames }

(任意)エラー フレーム期間リンク イベントをトリガーする、エラー フレーム期間の高しきい値および低しきい値を設定します。

threshold high high-frames を入力して、高しきい値をフレーム数で設定します。指定できる範囲は 1 ~ 65535 です。高しきい値を入力する必要があります。

threshold high none を入力して、高しきい値をディセーブルにします。

threshold low low-frames を入力して、低しきい値をフレーム数で設定します。指定できる範囲は 0 ~ 65535 です。デフォルトは 1 です。

window frames を入力して、ポーリングのウィンドウ サイズをフレーム数で入力します。指定できる範囲は 1 ~ 65535 で、それぞれの値は 10000 フレームの倍数です。デフォルトは 1000 です。

ステップ 7

ethernet oam link-monitor frame-seconds { threshold { high { high-seconds | none } | low { low-seconds }} | window milliseconds }

(任意)エラー フレーム秒リンク イベントをトリガーする、フレーム秒の高しきい値および低しきい値を設定します。

threshold high high-seconds を入力して、高しきい値を秒数で設定します。指定できる範囲は 1 ~ 900 です。高しきい値を入力する必要があります。

threshold high none を入力して、高しきい値をディセーブルにします。

threshold low low-frames を入力して、低しきい値をフレーム数で設定します。指定できる範囲は 1 ~ 900 です。デフォルトは 1 です。

window frames を入力して、ポーリングのウィンドウ サイズをフレーム数で入力します。指定できる範囲は 100 ~ 9000 で、それぞれの値は 100 ミリ秒の倍数です。デフォルトは 1000 です。

ステップ 8

ethernet oam link-monitor high threshold action error-disable-interface

(任意)エラーの高しきい値を超過した場合にそのインターフェイスを errdisable ステートにするようにスイッチを設定します。

ステップ 9

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 10

interface interface-id

イーサネット OAM インターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 11

source-template template-name

テンプレートを関連付けて、設定したオプションをインターフェイスに適用します。

ステップ 12

end

特権 EXEC モードに戻ります。

ステップ 13

show ethernet oam status [ interface interface-id ]

設定を確認します。

ステップ 14

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチは、CRC エラーを伴う出力フレームのモニタリングをサポートしません。 ethernet oam link-monitor transmit-crc { threshold { high { high-frames | none } | low { low-frames }} | window milliseconds } コマンドはスイッチに表示され、入力することができますが、サポートされていません。テンプレートからオプションを削除するには、各コマンドの no 形式を使用します。ソース テンプレートのアソシエーションを削除するには、 no source-template template-name コマンドを使用します。

次に、イーサネット OAM テンプレートを設定し、インターフェイスに関連付ける例を示します。

Switch# conf t
Switch(config)# template oam
Switch(config-template)# ethernet oam link-monitor receive-crc threshold high 1000
Switch(config-template)# ethernet oam link-monitor receive-crc threshold low 10
Switch(config-template)# ethernet oam link-monitor symbol-period threshold high 5000
Switch(config-template)# ethernet oam link-monitor symbol-period threshold low 5
Switch(config-template)# ethernet oam link-monitor frame threshold high 8000
Switch(config-template)# ethernet oam link-monitor frame threshold low 8
Switch(config-template)# ethernet oam link-monitor frame-period threshold hig 9000
Switch(config-template)# ethernet oam link-monitor frame-period threshold low 9
Switch(config-template)# ethernet oam link-monitor high action error-disable-interface
Switch(config-template)# exit
Switch(config)# int gi1/2
Switch(config-if)# source template oam
Switch(config-if)# end
Switch# show ethernet oam status int gi1/2
GigabitEthernet1/2
General
-------
Admin state: enabled
Mode: active
PDU max rate: 10 packets per second
PDU min rate: 1 packet per 1 second
Link timeout: 5 seconds
High threshold action: error disable interface
Link fault action: no action
Dying gasp action: no action
Critical event action: no action
 
Link Monitoring
---------------
Status: supported (on)
 
Symbol Period Error
Window: 100 x 1048576 symbols
Low threshold: 5 error symbol(s)
High threshold: 5000 error symbol(s)
 
Frame Error
Window: 10 x 100 milliseconds
Low threshold: 8 error frame(s)
High threshold: 8000 error frame(s)
 
Frame Period Error
Window: 1000 x 10000 frames
Low threshold: 9 error frame(s)
High threshold: 9000 error frame(s)
 
Frame Seconds Error
Window: 100 x 100 milliseconds
Low threshold: 1 error second(s)
High threshold: none
 
Receive-Frame CRC Error
Window: 10 x 100 milliseconds
Low threshold: 10 error frame(s)
High threshold: 1000 error frame(s)
 
Transmit-Frame CRC Error: Not Supported

イーサネット OAM プロトコル情報の表示

イーサネット OAM プロトコル情報を表示するには、 表56-3 に示す特権 EXEC コマンドを使用します。

 

表56-3 イーサネット OAM プロトコル情報の表示

コマンド
目的
show ethernet oam discovery [ interface interface-id ]

すべてのイーサネット OAM インターフェイスまたは指定したインターフェイスのディスカバリ情報を表示します。

show ethernet oam statistics [ interface interface-id ]

イーサネット OAM パケットに関する詳細情報を表示します。

show ethernet oam status [ interface interface-id ]

すべてのインターフェイスまたは指定したインターフェイスのイーサネット OAM 設定を表示します。

show ethernet oam summary

スイッチ上でアクティブになっているイーサネット OAM セッションを表示します。

次に、これらのコマンドを適用する例を示します。

Switch# show ethernet oam discovery
GigabitEthernet1/1
Local client
------------
Administrative configurations:
Mode: active
Unidirection: not supported
Link monitor: supported (on)
Remote loopback: supported
MIB retrieval: not supported
Mtu size: 1500
 
Operational status:
Port status: operational
Loopback status: no loopback
PDU revision: 10
 
Remote client
-------------
MAC address: 000f.8f03.3591
Vendor(oui): 00000C(cisco)
 
Administrative configurations:
PDU revision: 2
Mode: active
Unidirection: not supported
Link monitor: supported
Remote loopback: supported
MIB retrieval: not supported
Mtu size: 1500
 
Switch# show ethernet oam statistics
GigabitEthernet1/1
Counters:
---------
Information OAMPDU Tx : 101163
Information OAMPDU Rx : 51296
Unique Event Notification OAMPDU Tx : 0
Unique Event Notification OAMPDU Rx : 0
Duplicate Event Notification OAMPDU TX : 0
Duplicate Event Notification OAMPDU RX : 0
Loopback Control OAMPDU Tx : 12
Loopback Control OAMPDU Rx : 0
Variable Request OAMPDU Tx : 0
Variable Request OAMPDU Rx : 0
Variable Response OAMPDU Tx : 0
Variable Response OAMPDU Rx : 0
Cisco OAMPDU Tx : 7
Cisco OAMPDU Rx : 8
Unsupported OAMPDU Tx : 0
Unsupported OAMPDU Rx : 0
Frames Lost due to OAM : 0
 
Local Faults:
-------------
0 Link Fault records
2 Dying Gasp records
Total dying gasps : 7
Time stamp : 1d01h
 
Total dying gasps : 6
Time stamp : 1d01h
 
0 Critical Event records
 
Remote Faults:
--------------
0 Link Fault records
2 Dying Gasp records
Total dying gasps : 8
Time stamp : 1d01h
 
Total dying gasps : 7
Time stamp : 1d01h
 
0 Critical Event records
 
Local event logs:
-----------------
0 Errored Symbol Period records
0 Errored Frame records
0 Errored Frame Period records
0 Errored Frame Second records
 
Remote event logs:
------------------
0 Errored Symbol Period records
0 Errored Frame records
0 Errored Frame Period records
0 Errored Frame Second records
 
 
Switch# show ethernet oam summary
Symbols: * - Master Loopback State, # - Slave Loopback State
& - Error Block State
Capability codes: L - Link Monitor, R - Remote Loopback
U - Unidirection, V - Variable Retrieval
Local Remote
Interface MAC Address OUI Mode Capability
 
Gi1/1 000f.8f03.3591 00000C active L R

イーサネット CFM とイーサネット OAM の相互作用

CFM とイーサネット OAM が相互作用するように OAM マネージャ インフラストラクチャを設定することもできます。CFM MEP が設定されているインターフェイス上でイーサネット OAM プロトコルが稼働している場合、イーサネット OAM は CFM にインターフェイスの状態を通知します。相互作用はイーサネット OAM から CFM プロトコルへの単方向で、ユーザ ネットワーク インターフェイスのポート ステータス情報だけ交換されます。

イーサネット OAM プロトコルは、次の状況が発生すると CFM に通知します。

ローカル インターフェイスでエラーしきい値が超過した。

Port StatusType Length Value(TLV)内に Local_Excessive_Errors ポート ステータスを挿入して送信することによって、CFM はこの通知に応答します。

イーサネット OAM が、リモート エンドポイントのエラーしきい値が超過したことを示す OAM PDU をリモート側から受信した。

Port Status TLV 内に Remote_Excessive_Errors ポート ステータスを挿入して送信することによって、CFM はこの通知に応答します。

ローカル ポートがループバック モードに設定された。

Port Status TLV 内に Test ポート ステータスを挿入して送信することによって、CFM は応答します。

リモート ポートがループバック モードに設定された。

Port Status TLV 内に Test ポート ステータスを挿入して送信することによって、CFM は応答します。

CFM およびイーサネット OAM との相互作用に関する詳細については、次の URL にアクセスして『 Ethernet Connectivity Fault Management 』フィーチャ モジュールを参照してください。

http://www.cisco.com/en/US/products/ps6922/products_feature_guide09186a008066fcb8.html

イーサネット OAM および CFM の設定例

次に、サービス プロバイダー ネットワークを想定して、イーサネット OAM と CFM の間のインターワーキングの設定例を示します。このネットワークには、各エンドポイントの CE スイッチに接続された PE スイッチがあるものとします。CE スイッチと PE スイッチとの間で CFM、E-LMI、およびイーサネット OAM を設定する必要があります。

CE スイッチ 1(CE1)の設定

Switch# config t
Switch(config)# interface GigabitEthernet1/1
Switch(config-if)# switchport trunk allowed vlan 10
Switch(config-if)# switchport mode trunk
Switch(config-if)# ethernet oam remote-loopback supported
Switch(config-if)# ethernet oam
Switch(config-if)# exit
 

PE スイッチ 1(PE1)の設定

Switch# config t
Switch(config)# interface FastEthernet1/20
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# ethernet cfm mip level 7
Switch(config-if)# ethernet cfm mep level 4 mpid 100 vlan 100
Switch(config-if)# ethernet oam remote-loopback supported
Switch(config-if)# ethernet oamt
 

PE スイッチ 2(PE2)の設定

Switch# config t
Switch(config)# interface GigabitEthernet1/20
Switch(config-if)# switchport mode trunk
Switch(config-if)# ethernet cfm mip level 7
Switch(config-if)# ethernet cfm mep level 4 mpid 101 vlan 10
Switch(config-if)# ethernet oam remote-loopback supported
Switch(config-if)# ethernet oam
 

CE スイッチ 2(CE2)の設定

Switch# config t
Switch(config)# interface GigabitEthernet1/1
Switch(config-if)# switchport trunk allowed vlan 10
Switch(config-if)# switchport mode trunk
Switch(config-if)# ethernet oam remote-loopback supported
Switch(config-if)# ethernet oam
Switch(config-if)# exit
 

次に、この構成での PE スイッチのポート ステータスの例を示します。両方のスイッチのポート ステータスには UP が表示されます。

スイッチ PE1:

Switch# show ethernet cfm maintenance points remote
MPID Level Mac Address Vlan PortState InGressPort Age(sec) Service ID
101 * 4 0015.633f.6900 10 UP Gi1/1 27 blue
 

スイッチ PE2:

Switch# show ethernet cfm maintenance points remote
MPID Level Mac Address Vlan PortState InGressPort Age(sec) Service ID
100 * 4 0012.00a3.3780 10 UP Gi1/1 8 blue
Total Remote MEPs: 1
 

次に、CE1(または PE1)でリモート ループバックを開始した場合の出力例を示します。リモート PE スイッチのポート ステータスには Test が表示され、リモート CE スイッチは errdisable モードになります。

Switch# ethernet oam remote-loopback start interface gigabitethernet 1/1
This is a intrusive loopback.
Therefore, while you test Ethernet OAM MAC connectivity,
you will be unable to pass traffic across that link.
Proceed with Remote Loopback? [confirm]
 

スイッチ PE1:

Switch# show ethernet cfm maintenance points remote
MPID Level Mac Address Vlan PortState InGressPort Age(sec) Service ID
101 * 4 0015.633f.6900 10 UP Gi1/1 27 blue
 

スイッチ PE2:

Switch# show ethernet cfm maintenance points remote
MPID Level Mac Address Vlan PortState InGressPort Age(sec) Service ID
100 * 4 0012.00a3.3780 10 TEST Gi1/1 8 blue
Total Remote MEPs: 1
 

また、PE1 と接続している CE1 インターフェイスをシャットダウンした場合は、リモート PE2 ポートのポート ステータスには Down が表示されます。