Catalyst 4500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2(44)SG
レイヤ 3 インターフェイスの設定
レイヤ 3 インターフェイスの設定
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

レイヤ 3 インターフェイスの設定

レイヤ 3 インターフェイスの概要

論理レイヤ 3 VLAN インターフェイス

物理レイヤ 3 インターフェイス

SVI 自動ステート除外の概要

レイヤ 3 インターフェイス カウンタの概要

設定時の注意事項

論理レイヤ 3 VLAN インターフェイスの設定

レイヤ 3 インターフェイスとしての VLAN の設定

SVI 自動ステート除外の設定

IP MTU サイズの設定

レイヤ 3 インターフェイス カウンタの設定

物理レイヤ 3 インターフェイスの設定

EIGRP スタブ ルーティングの設定

概要

EIGRP スタブ ルーティングの設定方法

デュアルホーム リモート トポロジ

EIGRP スタブ ルーティングの設定作業リスト

EIGRP のモニタリングおよびメンテナンス

EIGRP の設定例

経路集約の例

ルート認証の例

スタブ ルーティングの例

レイヤ 3 インターフェイスの設定

この章では、Catalyst 4500 シリーズ スイッチ上のレイヤ 3 インターフェイスについて説明します。設定上の注意事項、設定手順、および設定例についても示します。

この章の主な内容は、次のとおりです。

「レイヤ 3 インターフェイスの概要」

「設定時の注意事項」

「論理レイヤ 3 VLAN インターフェイスの設定」

「レイヤ 3 インターフェイスとしての VLAN の設定」

「物理レイヤ 3 インターフェイスの設定」

「EIGRP スタブ ルーティングの設定」


) この章のスイッチ コマンドの構文および使用方法の詳細については、『Catalyst 4500 Series Switch Cisco IOS Command Reference』および次の URL の関連マニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122sr/cr/index.htm


レイヤ 3 インターフェイスの概要

ここでは、次の内容について説明します。

「論理レイヤ 3 VLAN インターフェイス」

「物理レイヤ 3 インターフェイス」

「SVI 自動ステート除外の概要」

「レイヤ 3 インターフェイス カウンタの概要」

Catalyst 4500 ファミリ スイッチは、Cisco IOS IP および IP ルーティング プロトコルでレイヤ 3 インターフェイスをサポートしています。 ネットワーク レイヤであるレイヤ 3 は、主にパケット内データの論理インターネットワーク パスへのルーティングを行います。

データ リンク レイヤであるレイヤ 2 は、 物理 レイヤ(レイヤ 1)を制御するプロトコルと、メディアに伝送される前のデータのフレーミング方法が含まれています。LAN 上の 2 つのセグメント間でフレーム内のデータをフィルタリングおよび転送するレイヤ 2 の機能を、ブリッジングといいます。

Catalyst 4500 シリーズ スイッチは、2 種類のレイヤ 3 インターフェイスをサポートしています。論理レイヤ 3 VLAN(仮想 LAN )インターフェイスは、ルーティングとブリッジングの機能を統合します。Catalyst 4500 シリーズ スイッチは、物理レイヤ 3 インターフェイスを使用して従来のルータのように設定できます。

論理レイヤ 3 VLAN インターフェイス

論理レイヤ 3 VLAN インターフェイスは、レイヤ 2 スイッチ上の VLAN への論理ルーティング インターフェイスとして機能します。従来のネットワークでは、ルータとスイッチ間の物理インターフェイスが VLAN 間ルーティングを実行する必要がありました。Catalyst 4500 シリーズ スイッチは単一の Catalyst 4500 シリーズ スイッチでのルーティングとブリッジング機能を統合することで、VLAN 間ルーティングをサポートします。

図27-1では、従来のネットワークで 3 台の物理デバイスによって実行されていたルーティングとブリッジング機能が、どのようにして 1 台の Catalyst 4500 シリーズ スイッチ上で論理的に実行されているかを示します。

図27-1 Catalyst 4500 シリーズ スイッチの論理レイヤ 3 VLAN インターフェイス

 

物理レイヤ 3 インターフェイス

物理レイヤ 3 インターフェイスは、従来のルータに等しい機能をサポートします。これらのレイヤ 3 インターフェイスは、Catalyst 4500 シリーズ スイッチへの物理ルーティング インターフェイスをホストに提供します。

図27-2に、Catalyst 4500 シリーズ スイッチが従来のルータとして機能する例を示します。

図27-2 Catalyst 4500 シリーズ スイッチの物理レイヤ 3 インターフェイス

 

SVI 自動ステート除外の概要


) Supervisor Engine 6-E は、SVI 自動ステート除外をサポートしていません。


ルータ VLAN インターフェイスは「アップ/アップ」状態となるために、次の一般的な条件を満たす必要があります。

VLAN がスイッチの VLAN データベースに存在し、「アクティブ」であること。

VLAN インターフェイスがルータに存在し、管理上のダウン状態であること。

少なくとも 1 つのレイヤ 2(アクセス ポートまたはトランク)ポートが存在し、この VLAN 上でリンクが「アップ」状態であり、VLAN でスパニングツリー フォワーディング ステートであること。


) 対応する VLAN リンクに属する最初のスイッチポートがアップになり、スパニングツリー フォワーディング ステートとなると、VLAN インターフェイスのプロトコル ライン ステートがアップになります。


通常、VLAN 内に VLAN インターフェイスのポートが複数ある場合は、VLAN 内のすべてのポートが「ダウン」するときにSVI が「ダウン」します。SVI 自動ステート除外機能は、SVI の「アップおよびダウン」カウント時にカウントしないポートをマーキングするノブになり、ポートでイネーブルであるすべての VLAN に適用されます。

VLAN インターフェイスは、レイヤ 2 ポートがコンバージェンス(つまり、リスニングおよびラーニングからフォワーディングに移行)する時間を経過した後、起ち上がります。これにより、ルーティング プロトコルおよびその他の機能が VLAN インターフェイスをフル稼働させるまで使用しないようにします。また、ブラック ホール ルーティングなどの別の問題が発生しないようにします。

レイヤ 3 インターフェイス カウンタの概要


) Supervisor Engine 6-E は、レイヤ 2 インターフェイス カウンタをサポートしていません。Supervisor Engine 6-E は、レイヤ 3(SVI)インターフェイス カウンタをサポートしています。


Supervisor Engine 6-E では、IPv4 パケットおよび IPv6 パケットはハードウェア転送エンジンによりルーティングされます。このエンジンは、最大 4095 個のインターフェイスについてルーティングされたパケットのカウントの統計情報をサポートします。この統計は、次のカウンタが含まれます。

入力ユニキャスト

入力マルチキャスト

出力ユニキャスト

出力マルチキャスト

各種のカウンタについて、パケット数および送受信される合計バイト数の両方がカウントされます。

サポートされるカウンタの合計数が、サポートされるレイヤ 3 インターフェイスの合計数より少ないため、レイヤ 3 インターフェイスのカウンタがなくなる場合もあります。そのため、ユーザがレイヤ 3 インターフェイスにカウンタを割り当てると、あるレイヤ 3 インターフェイスのデフォルト設定にはカウンタがなくなります。


) レイヤ 3 インターフェイス カウンタをイネーブルにするには、インターフェイス モードで counter コマンドを発行する必要があります。レイヤ 3 インターフェイス カウンタを設定する手順については、「レイヤ 3 インターフェイス カウンタの設定」を参照してください。


これらのハードウェア カウンタは、show interface コマンドの出力に表示されます。次に例を示します。

Switch# show interface vlan 1
Vlan1 is up, line protocol is up
Hardware is Ethernet SVI, address is 0005.9a38.6cff (bia 0005.9a38.6cff)
Internet address is 10.0.0.1/8
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes <====
L3 out Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes <====
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
1 packets output, 46 bytes, 0 underruns
0 output errors, 0 interface resets
0 output buffer failures, 0 output buffers swapped out

設定時の注意事項

Catalyst 4500 シリーズ スイッチは、AppleTalk ルーティングおよび IPX ルーティングをサポートします。AppleTalk ルーティングおよび IPX ルーティングについては、次の URL の『Cisco IOS AppleTalk and Novell IPX Configuration Guide』の「Configuring AppleTalk」および「Configuring Novell IPX」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/atipx_c/index.htm


) Supervisor Engine 6-E は、AppleTalk および IPX ルーティングをサポートしていません。


Catalyst 4500 シリーズ スイッチは、レイヤ 3 ファスト イーサネット、ギガビット イーサネット、10 ギガビット イーサネット インターフェイスでサブインターフェイスまたは encapsulation キーワードをサポートしていません。


) Cisco IOS ソフトウェアが稼働するすべてのレイヤ 3 インターフェイスと同様に、Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)に割り当てられる IP アドレスおよびネットワークは、スイッチ上の他のレイヤ 3 インターフェイスに割り当てられるものと重複できません。


論理レイヤ 3 VLAN インターフェイスの設定


) 論理レイヤ 3 VLAN インターフェイスを設定する前に、スイッチ上に VLAN を作成および設定し、レイヤ 2 インターフェイスに VLAN メンバシップを割り当てる必要があります。また、IP ルーティングがディセーブルの場合は IP ルーティングをイネーブルにし、IP ルーティング プロトコルを指定する必要があります。


論理レイヤ 3 VLANインターフェイスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# vlan vlan_ID

VLAN を作成します。

ステップ 2

Switch(config)# interface vlan vlan_ID

設定するインターフェイスを選択します。

ステップ 3

Switch(config-if)# ip address ip_address subnet_mask

IP アドレスおよび IP サブネットを設定します。

ステップ 4

Switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 6

Switch# copy running-config startup-config

設定変更内容を NVRAM に保存します。

ステップ 7

Switch# show interfaces [ type slot/interface ]
Switch# show ip interfaces [ type slot/interface ]
Switch# show running-config interfaces [ type slot/interface ]
Switch# show running-config interfaces vlan vlan_ID

設定を確認します。

次に、論理レイヤ 3 VLAN インターフェイス vlan 2 を設定し、IP アドレスを割り当てる例を示します。

Switch> enable
Switch# config term
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# vlan 2
Switch(config)# interface vlan 2
Switch(config-if)# ip address 10.1.1.1 255.255.255.248
Switch(config-if)# no shutdown
Switch(config-if)# end
 

次に、show interfacesコマンドを使用して、レイヤ 3 VLAN インターフェイス vlan 2 のインターフェイス IP アドレスの設定およびステータスを表示する例を示します。

Switch# show interfaces vlan 2
Vlan2 is up, line protocol is down
Hardware is Ethernet SVI, address is 00D.588F.B604 (bia 00D.588F.B604)
Internet address is 172.20.52.106/29
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
Switch#
 

次に、show running-configコマンドを使用して、レイヤ 3 VLAN インターフェイス vlan 2 のインターフェイス IP アドレスの設定を表示する例を示します。

Switch# show running-config
Building configuration...
 
Current configuration : !
interface Vlan2
ip address 10.1.1.1 255.255.255.248
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end

レイヤ 3 インターフェイスとしての VLAN の設定

ここでは、次の内容について説明します。

「SVI 自動ステート除外の設定」

「IP MTU サイズの設定」

「レイヤ 3 インターフェイス カウンタの設定」

SVI 自動ステート除外の設定


) Supervisor Engine 6-E は、SVI 自動ステート除外機能をサポートしていません。



) SVI 自動ステート除外機能は、デフォルトでイネーブルであり、STP ステートと同期しています。


SVI 自動ステート除外機能は、次のポート設定変更が発生した場合に、スイッチのレイヤ 3 インターフェイスのシャットダウン(または起動)を行います。

VLAN 上の最後のポートがダウンし、その VLAN 上のレイヤ 3 インターフェイスがシャットダウンする場合(SVI 自動ステート)。

VLAN 上の最初のポートが立ち上がった状態に戻り、それまでシャットダウンしていた VLAN 上のレイヤ 3 インターフェイスが起ち上がる場合。

SVI 自動ステート除外は、SVI のステータス定義(アップまたはダウン)に含まれるアクセス ポートまたはトランクを、それが同じ VLAN に属する場合でも除外します。さらに、除外されたアクセス ポートまたはトランクがアップ状態であり、VLAN 内の別のポートがダウン状態である場合でも、SVI ステートはダウンに変更されます。

SVI ステートを「アップ」にするには、少なくとも VLAN 内の 1 つのポートがアップ状態であり、除外されていない必要があります。これは、SVI ステータスの決定時にモニタリング ポートのステータスを除外するために役立ちます。

SVI 自動ステート除外を適用するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Switch(config)# interface interface-id

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Switch(config-if)# switchport autostate exclude

SVI のステータス定義(アップまたはダウン)に含まれるアクセス ポートまたはトランクを除外します。

ステップ 4

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 5

Switch# show run int g3/4

実行コンフィギュレーションを表示します。

ステップ 6

Switch# show int g3/4 switchport

設定を確認します。

次に、SVI 自動ステート除外をインターフェイス g3/1 に適用する例を示します。

Switch# conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface g3/1
Switch(config-if)# switchport autostate exclude
Switch(config-if)# end
Switch# show run int g3/4
Building configuration...
 
Current configuration : 162 bytes
!
interface GigabitEthernet3/4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,3
switchport autostate exclude <=====
switchport mode trunk
end
 
Switch# show int g3/4 switchport
Name: Gi3/4
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q Operational Trunking Encapsulation: dot1q Negotiation of Trunking: On Access Mode VLAN: 1 (default) Trunking Native Mode VLAN: 1 (default) Administrative Native VLAN tagging: enabled Voice VLAN: none Administrative private-vlan host-association: none Administrative private-vlan mapping: none Administrative private-vlan trunk native VLAN: none Administrative private-vlan trunk Native VLAN tagging: enabled Administrative private-vlan trunk encapsulation: dot1q Administrative private-vlan trunk normal VLANs: none Administrative private-vlan trunk associations: none Administrative private-vlan trunk mappings: none Operational private-vlan: none Trunking VLANs Enabled: 2,3 Pruning VLANs Enabled: 2-1001 Capture Mode Disabled Capture VLANs Allowed: ALL
Autostate mode exclude <======
 
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
Switch#

IP MTU サイズの設定

インターフェイスから送信された IPv4 パケットまたは IPv6 パケットの Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズをプロトコルごとに設定できます。

MTU の制限事項については、「MTU の概要」を参照してください。


) インターフェイスにプロトコルに限定されない MTU 値を設定するには、mtu インターフェイス コンフィギュレーション コマンドを使用します。MTU 値の(mtu インターフェイス コンフィギュレーション コマンドを使用した)変更は、IP MTU 値に影響を与えます。現在の IP MTU 値が MTU 値と一致する場合に MTU 値を変更すると、IP MTU 値は新しい MTU と一致するよう自動的に変更されます。ただし、逆の場合は同様ではありません。IP MTU 値を変更しても mtu コマンドの値には影響がありません。


MTU サイズの設定については、「MTU サイズの設定」を参照してください。

インターフェイスから送信された IPv4 パケットまたは IPv6 パケットの Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズをプロトコルごとに設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Switch(config)# interface interface-id

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Switch(config-if)# [no] ip mtu <mtu_size>
または
Switch(config-if)# [no] ipv6 mtu <mtu_size>

MPv4 MTU サイズを設定します。

MPv6 MTU サイズを設定します。

このコマンドの no 形式を使用すると、デフォルトの MTU サイズ(1500 バイト)に戻ります。

ステップ 4

Switch(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 5

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 6

Switch# show run interface interface-id

実行コンフィギュレーションを表示します。

次に、インターフェイスで IPv4 MTU を設定する例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface vlan 1
Switch(config-if)# ip mtu 68
Switch(config-if)# exit
Switch(config)# end
Switch# show ip interface vlan 1
Vlan1 is up, line protocol is up
Internet address is 10.10.10.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 68 bytes
Helper address is not set
.........................(continued)
 
The following example shows how to configure ipv6 mtu on an interface
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface vlan 1
Switch(config-if)# ipv6 mtu 1280
Switch(config)# end
Switch# show ipv6 nterface vlan 1
 
This example shows how to verify the configuration
Vlan1 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::214:6AFF:FEBC:DEEA
Global unicast address(es):
1001::1, subnet is 1001::/64
Joined group address(es):
FF02::1
FF02::1:FF00:1
FF02::1:FFBC:DEEA
MTU is 1280 bytes
...................(continued)

) CLI を使用して IPv6 をインターフェイスでイネーブルにする場合、次のメッセージが表示される場合があります。
% Hardware MTU table exhausted このようなシナリオでは、ハードウェアでプログラムされている IPv6 MTU 値が IPv6 インターフェイス MTU 値と異なっています。この状況は、ハードウェア MTU テーブルにさらに値を保存する容量がない場合に発生します。使用していない MTU 値の設定を解除することでテーブル内のスペースを空けてから、インターフェイスで IPv6 をディセーブルにして再度イネーブルにするか、MTU 設定を再度適用します。


レイヤ 3 インターフェイス カウンタの設定


) Supervisor Engine 6-E は、インターフェイス カウンタをサポートしていません。



) ラインカードを削除すると、このラインカードのポート上でイネーブルにされているレイヤ 3 カウンタは未設定となります。そのため、ラインカードを再度挿入するときにレイヤ 3 カウンタを再度イネーブルにするには、そのラインカードのレイヤ 3 ポートに対してカウンタ CLI を再設定する必要があります。


レイヤ 3 インターフェイス カウンタを設定する(カウンタをレイヤ 3 インターフェイスに割り当てる)には、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Switch(config)# interface interface-id

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Switch(config-if)# counter

カウンタををイネーブルにします。

ステップ 4

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 5

Switch# show run interface interface-id

実行コンフィギュレーションを表示します。

次に、インターフェイス VLAN 1 上でカウンタをイネーブルにする例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface vlan 1
Switch(config-if)# counter
Switch(config-if)# end
Switch#
00:17:15: %SYS-5-CONFIG_I: Configured from console by console
Switch# show run interface vlan 1
Building configuration...
 
Current configuration : 63 bytes
!
interface Vlan1
ip address 10.0.0.1 255.0.0.0
counter
end

) カウンタを削除するには、counter コマンドの no 形式を使用します。


最大数のカウンタがすでに割り当てられている場合は、counter コマンドは失敗し、エラー メッセージが表示されます。

Switch# config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fa3/2
Switch(config-if)# no switchport
Switch(config-if)# counter
Counter resource exhausted
Switch(config-if)# end
Switch#
00:24:18: %SYS-5-CONFIG_I: Configured from console by console
 

この場合、別のインターフェイスのカウンタを解放して新しいインターフェイスが使用できるようにする必要があります。

物理レイヤ 3 インターフェイスの設定


) 物理レイヤ 3 インターフェイスを設定する前に、IP ルーティングがディセーブルの場合は IP ルーティングをイネーブルにし、IP ルーティング プロトコルを指定する必要があります。


物理レイヤ 3 インターフェイスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# ip routing

IP ルーティングをイネーブルにします(IP ルーティングがディセーブルになっている場合のみ)。

ステップ 2

Switch(config)# interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 3

Switch(config-if)# no switchport

このポートを物理レイヤ 2 ポートから物理レイヤ 3 ポートに変換します。

ステップ 4

Switch(config-if)# ip address ip_address subnet_mask

IP アドレスおよび IP サブネットを設定します。

ステップ 5

Switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Switch# copy running-config startup-config

設定変更内容を NVRAM に保存します。

ステップ 8

Switch# show interfaces [ type slot/interface ]
Switch# show ip interfaces [ type slot/interface ]
Switch# show running-config interfaces [ type slot/interface ]

設定を確認します。

次に、インターフェイス FastEthernet 2/1 に IP アドレスを設定する例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# ip routing
Switch(config)# interface fastethernet 2/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.1.1.1 255.255.255.248
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch#
 

次に、show running-config コマンドを使用して、インターフェイス FastEthernet 2/1 のインターフェイス IP アドレスの設定を表示する例を示します。

Switch# show running-config
Building configuration...
!
interface FastEthernet2/1
no switchport
ip address 10.1.1.1 255.255.255.248
!
...
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end

EIGRP スタブ ルーティングの設定

ここでは、次の内容について説明します。

「概要」

「EIGRP スタブ ルーティングの設定方法」

「EIGRP のモニタリングおよびメンテナンス」

「EIGRP の設定例」

概要

EIGRP スタブ ルーティング機能は、すべてのイメージで使用することができ、エンド ユーザの近くにルーテッド トラフィックを移動することでリソースの利用率を低減させます。

IP ベース イメージには EIGRP スタブ ルーティングのみが含まれています。IP サービス イメージには、完全な EIGRP ルーティングが含まれています。

EIGRP スタブ ルーティングを使用するネットワークでは、IP トラフィックがユーザに到達するには、ルート EIGRP スタブ ルーティングを設定しているスイッチを通過する必要があります。スイッチは、ユーザ インターフェイスとして設定されているインターフェイスまたは他のデバイスに接続されているインターフェイスにルーテッド トラフィックを送信します。

EIGRP スタブ ルーティングを使用する場合、EIGRP を使用するように、ディストリビューション ルータおよびリモート ルータを設定し、さらにスイッチのみをスタブとして設定する必要があります。指定したルートのみがスイッチから伝播されます。スイッチは、サマリー、接続ルート、およびルーティング アップデートに対するすべてのクエリーに応答します。

スタブであることを通知するパケットを受信するネイバーは、スタブ ルータに対してルートのクエリーを実行せず、スタブ ピアを有するルータはそのピアに対するクエリーを実行しません。スタブ ルータは、ディストリビューション ルータに依存してすべてのピアに適切なアップデートを送信します。

図27-3 では、スイッチ B が EIGRP スタブ ルータとして設定されています。スイッチ A および C は残りの WAN に接続されています。スイッチ B は、接続ルート、スタティック ルート、再配布ルート、集約ルートをスイッチ A および C からホスト A、B、および C にアドバタイズします。スイッチ B はスイッチ A から学習したルートをアドバタイズしません(逆の場合も同様です)。

図27-3 EIGRP スタブ ルータの構成

 

EIGRP スタブ ルーティングの詳細については、『Cisco IOS IP Configuration Guide, Volume 2 of 3: Routing Protocols』Release 12.2 の「Configuring EIGRP Stub Routing」を参照してください。

EIGRP スタブ ルーティングの設定方法

EIGRP スタブ ルーティング機能は、ネットワークの安定性を高め、リソース利用率を抑え、スタブ ルータ構成を簡素化します。

スタブ ルーティングは、一般的に、ハブ アンド スポーク型のネットワーク トポロジで使用されます。ハブ アンド スポーク型ネットワークでは、1 つまたは複数のエンド ネットワーク(スタブ)が、1 つまたは複数のディストリビューション ルータ(ハブ)に接続したリモート ルータ(スポーク)に接続しています。リモート ルータは 1 つまたは複数のディストリビューション ルータにのみ隣接します。IP トラフィックがリモート ルータに到達する唯一のルートは、ディストリビューション ルータを経由するものです。このタイプの構成は、一般的に、ディストリビューション ルータが直接 WAN に接続している WAN トポロジで使用されています。ディストリビューション ルータは多くのリモート ルータに接続できます。多くの場合、ディストリビューション ルータは 100 以上のリモート ルータに接続されます。ハブ アンド スポーク型のトポロジでは、リモート ルータはすべての非ローカル トラフィックをディストリビューション ルータに転送する必要があるため、リモート ルータが完全なルーティング テーブルを保持する必要はなくなります。一般に、ディストリビューション ルータはデフォルト ルート以外の情報をリモート ルータに送信する必要はありません。

EIGRP スタブ ルーティング機能を使用する場合、EIGRP を使用するように、ディストリビューション ルータおよびリモート ルータを設定し、さらにリモート ルータのみをスタブとして設定する必要があります。指定したルートのみがリモート(スタブ)ルータから伝播されます。スタブ ルータはサマリー、接続ルート、再配布スタティック ルート、外部ルート、および内部ルートのすべてのクエリーを「アクセス不可」のメッセージで応答します。スタブとして設定されたルータは、すべての隣接ルータに特別なピア情報パケットを送信し、自身がスタブ ルータであることを報告します。

スタブであることを通知するパケットを受信するネイバーは、スタブ ルータに対してルートのクエリーを実行せず、スタブ ピアを有するルータはそのピアに対するクエリーを実行しません。スタブ ルータは、ディストリビューション ルータに依存してすべてのピアに適切なアップデートを送信します。

図27-4 に、単純なハブ アンド スポーク構成を示します。

図27-4 単純なハブ アンド スポーク型ネットワーク

 

スタブ ルーティング機能自体は、ルートがリモート ルータにアドバタイズされるのを防ぐことはありません。図27-4 の例では、リモート ルータはディストリビューション ルータのみを通じて企業ネットワークおよびインターネットにアクセスできます。この例では、リモート ルータが完全なルート テーブルを保有しても機能面での意味はありません。企業ネットワークとインターネットへのパスは常にディストリビューション ルータを経由するためです。ルート テーブルが大きくなると、リモート ルータに必要なメモリ量が減るだけです。帯域幅とメモリは、ディストリビューション ルータのルートを集約およびフィルタリングすることによって節約できます。リモート ルータは、宛先に関わりなく、ディストリビューション ルータにすべての非ローカル トラフィックを送信する必要があるため、他のネットワークから学習されたルートを受け取る必要がありません。真のスタブ ネットワークが望ましい場合、ディストリビューション ルータはリモート ルータにデフォルト ルートのみを送信するように設定する必要があります。EIGRPスタブ ルーティング機能では、自動的にディストリビューション ルータでの要約をイネーブルにしません。ほとんどの場合、ネットワーク管理者がディストリビューション ルータでの集約を設定する必要があります。


) ディストリビューション ルータがリモート ルータにデフォルト ルートのみを送信するように設定する場合、リモート ルータで ip classless コマンドを使用する必要があります。デフォルトでは、EIGRP スタブ ルーティング機能をサポートするすべての Cisco IOS イメージで ip classless コマンドがイネーブルになっています。


スタブ機能を使用しない場合、ディストリビューション ルータからリモート ルータに送信されるルートがフィルタリングまたは集約されたあとでも、問題が生じることがあります。ルートが企業ネットワーク内のどこかで失われた場合、EIGRP はディストリビューション ルータにクエリーを送信できます。そのあと、ディストリビューション ルータはルートが集約されている場合でもリモート ルータにクエリーを送信します。WAN リンクを使用したディストリビューション ルータとリモート ルータ間の通信に問題がある場合、EIGRP Stuck In Active(SIA)状態が発生し、ネットワークのどこかで不安定になる可能性があります。EIGRP スタブ ルーティング機能を使用することにより、ネットワーク管理者はリモート ルータへクエリーが送信されないようにできます。

デュアルホーム リモート トポロジ

リモート ルータを単一のディストリビューション ルータに接続する簡単なハブ アンド スポーク型ネットワーク以外に、リモート ルータを複数のディストリビューション ルータにデュアルホーム接続できます。この構成では冗長性が増し、一意性の問題が生じますが、スタブ機能がこれらの問題の対処に役立ちます。

デュアルホーム リモート ルータは、複数のディストリビューション ルータ(ハブ)を使用します。ただし、スタブ ルーティングの原理はハブ アンド スポーク型トポロジの場合と同じです。図27-5 にリモート ルータを 1 つ使用した一般的なデュアルホーム リモート トポロジを示していますが、ディストリビューション ルータ 1 とディストリビューション ルータ 2 の同じインターフェイスに 100 以上のルータを接続できます。リモート ルータは最適なルートを使用して宛先に到達します。ディストリビューション ルータ 1 に障害が発生した場合、リモート ルータはディストリビューション ルータ 2 を使用して企業ネットワークに到達できます。

図27-5 単純なデュアルホーム リモート トポロジ

 

図27-5 に、リモート ルータ 1 つとディストリビューション ルータ 2 つから構成される簡単なデュアルホーム リモートを示します。いずれのディストリビューション ルータも企業ネットワークとスタブ ネットワーク 10.1.1.0/24 へのルートを維持します。

デュアルホーム ルーティングによって、EIGRP ネットワークが不安定になる場合があります。図27-6 では、ディストリビューション ルータ 1 はネットワーク 10.3.1.0/24 に直接接続しています。ディストリビューション ルータ 1 に集約またはフィルタリングが適用された場合、このルータは直接接続したすべての EIGRP ネイバー(ディストリビューション ルータ 2 およびリモート ルータ)にネットワーク 10.3.1.0/24 をアドバタイズします。

図27-6 ディストリビューション ルータ 1 を 2 つのネットワークに接続したデュアルホーム リモート トポロジ

 

図27-6 に、ディストリビューション ルータ 1 をネットワーク 10.3.1.0/24 とネットワーク 10.2.1.0/24 の両方に接続した単純なデュアルホーム リモート ルータを示します。

ディストリビューション ルータ 1 とディストリビューション ルータ 2 間の 10.2.1.0/24 リンクに障害が発生した場合、ディストリビューション ルータ 2 からネットワーク 10.3.1.0/24 までの最低コスト パスはリモート ルータを経由します(図27-7 を参照)。それまで企業ネットワーク 10.2.1.0/24 を通過していたトラフィックが今度は帯域幅の相当低い接続を介して送信されるため、このルートは望ましくありません。低帯域幅 WAN 接続の利用率が高くなりすぎると、企業ネットワーク全体に影響するような多くの問題の原因になります。リモート ルータを通過する低帯域幅ルートの利用によって、WAN EIGRP ディストリビューション ルータがドロップする場合があります。ディストリビューションおよびリモート ルータのシリアル回線もドロップし、ディストリビューションおよびコア ルータで EIGRP SIA エラーが発生する可能性があります。

図27-7 ディストリビューション ルータへのルートに障害が発生したデュアルホーム リモート トポロジ

 

ディストリビューション ルータ2 からのトラフィックがネットワーク 10.3.1.0/24 に到達するために、リモート ルータを通過するのは望ましくありません。リンクが負荷を処理できるサイズであれば、バックアップ ルートの 1 つを使用することもできます。ただし、このタイプのほとんどのネットワークは、リモート ルータをリンク速度が比較的遅いリモート オフィスに配置しています。この問題は、ディストリビューション ルータとリモート ルータで適切な集約が設定されていれば防ぐことができます。

通常、ディストリビューション ルータからのトラフィックが中継パスとしてリモート ルータを使用するのは不適切です。ディストリビューション ルータからリモート ルータへの一般的な接続は、ネットワーク コアにおける接続よりも帯域幅が相当低くなります。中継パスとして接続帯域幅に限りがあるリモート ルータを使用した場合、一般にリモート ルータに過度の輻輳が生じます。EIGRP スタブ ルーティング機能は、リモート ルータがディストリビューション ルータにコア ルートをアドバタイズしないようにしてこの問題を防ぎます。ディストリビューション ルータ 1 を通じてリモート ルータが学習したルートは、ディストリビューション ルータ 2 にアドバタイズされません。リモート ルータはディストリビューション ルータ 2 にコア ルートをアドバタイズしないため、ディストリビューション ルータはネットワーク コアに向けられたトラフィックにはリモート ルータを中継点として使用しません。

EIGRP スタブ ルーティング機能は、ネットワークの安定性を高めるのに役立ちます。ネットワークが不安定になった場合、この機能は EIGRP クエリーが帯域幅に限りのあるリンクを使用して非中継ルータに送信されるのを防ぎます。その代わりに、スタブ ルータが接続されたディストリビューション ルータが、スタブ ルータに代わってクエリーに応答します。この機能は輻輳のある、または問題のある WAN リンクによってネットワークが不安定になる可能性を大幅に減らします。また EIGRP スタブ ルーティング機能は、ハブ アンド スポーク型ネットワークの設定とメンテナンスを簡易化します。デュアルホーム リモート構成でスタブ ルーティングがイネーブルになっている場合、リモート ルータにフィルタリングを設定して、リモート ルータがハブ ルータへの中継パスのように見えないようにする必要はありません。


注意 EIGRP スタブ ルーティングはスタブ ルータでのみ使用します。スタブ ルータは、コア中継トラフィックが通過すべきでないネットワーク コアまたはディストリビューション レイヤに接続されたルータとして定義されます。スタブ ルータは、ディストリビューション ルータ以外の EIGRP ネイバーを持つことはできません。この制約事項を無視すると、好ましくない動作が生じます。


) ATM、イーサネット、フレーム リレー、ISDN PRI、X.25 などのマルチアクセス インターフェイスは、そのインターフェイス上のすべてのルータ(ハブ以外)がスタブ ルータとして設定されている場合にのみ、EIGRP スタブ ルーティング機能がサポートされます。


EIGRP スタブ ルーティングの設定作業リスト

ここでは、EIGRP スタブ ルーティングを設定するために実行する作業について説明します。最初に説明する作業は必須で、最後の作業はオプションです。

EIGRP スタブ ルーティングの設定(必須)

EIGRP スタブ ルーティングの確認(任意)

EIGRP スタブ ルーティングの設定

EIGRP スタブ ルーティングをリモート ルータまたはスポーク ルータに設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

router(config)# router eigrp 1

EIGRP プロセスを実行するリモート ルータまたはディストリビューション ルータを設定します。

ステップ 2

router(config-router)# network network-number

EIGRP ディストリビューション ルータのネットワーク アドレスを指定します。

ステップ 3

router(config-router)# eigrp stub [receive-only | connected | static | summary]

リモート ルータを EIGRP スタブ ルータとして設定します。

EIGRP スタブ ルーティングの確認

リモート ルータが EIGRP でスタブ ルータとして設定されていることを確認するには、特権 EXEC モードでディストリビューション ルータから show ip eigrp neighbor detail コマンドを使用します。出力の最後の行は、リモート ルータまたはスポーク ルータのスタブ ステータスを示します。次の例は、show ip eigrp neighbor detail コマンドの出力を示します。

router# show ip eigrp neighbor detail
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
0 10.1.1.2 Se3/1 11 00:00:59 1 4500 0 7
Version 12.1/1.2, Retrans:2, Retries: 0
Stub Peer Advertising ( CONNECTED SUMMARY ) Routes
 

EIGRP のモニタリングおよびメンテナンス

ネイバーテーブルからネイバーを削除するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# clear ip eigrp neighbors [ ip-address | interface ]

ネイバー テーブルからネイバーを削除します。

各種のルーティング統計を表示するには、EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show ip eigrp interfaces [ interface ] [ as-number ]

EIGRP に設定されているインターフェイスに関する情報を表示します。

Router# show ip eigrp neighbors [type|number|static]

EIGRP によって検出されたネイバーを表示します。

Router# show ip eigrp topology [autonomous-system-number | [[ ip-address ] mask ]]

指定されたプロセスの EIGRP トポロジ テーブルを表示します。

Router# show ip eigrp traffic [autonomous-system-number]

すべてまたは指定された EIGRP プロセスの送受信パケット数を表示します。

EIGRP の設定例

ここでは、次の例について説明します。

経路集約の例

ルート認証の例

スタブ ルーティングの例

経路集約の例

次の例では、インターフェイス上に経路集約を設定し、また、自動サマリー機能を設定します。この設定によって、EIGRP は、イーサネット インターフェイス 0 からのネットワーク 10.0.0.0 だけを集約するようになります。さらに、この例では自動集約をディセーブルにします。

interface Ethernet 0
ip summary-address eigrp 1 10.0.0.0 255.0.0.0
!
router eigrp 1
network 172.16.0.0
no auto-summary

) インターフェイスからのデフォルト ルート(0.0.0.0)を生成するのに、ip summary-address eigrp サマライズ コマンドは使用しないでください。このコマンドを使用すると、管理ディスタンスが 5 で、ヌル 0 インターフェイスへの EIGRP 集約デフォルト ルートが作成されます。このデフォルト ルートの管理ディスタンスの値が小さいと、ルーティング テーブル内の他のネイバーから学習されたデフォルト ルートにこのルートが置き換えられてしまうことがあります。ネイバーによって学習されたデフォルト ルートが集約デフォルト ルートによって置き換えられた場合、または集約ルートが存在する唯一のデフォルト ルートである場合、そのデフォルト ルート宛てのすべてのトラフィックはルータを離れず、その代わりに、このトラフィックがヌル 0 インターフェイスに送信され、そこでドロップされます。

所定のインターフェイスからのデフォルト ルートだけを送信するようにするには、distribute-list コマンドを使用することを推奨します。このコマンドを設定して、インターフェイスから送信されるデフォルト(0.0.0.0)以外のすべての発信ルート アドバタイズメントをフィルタリングできます。


ルート認証の例

次の例では、自律システム 1 で EIGRP パケットの MD5 認証をイネーブルにします。

ルータ A

interface ethernet 1
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 holly
key chain holly
key 1
key-string 0987654321
accept-lifetime 04:00:00 Dec 4 1996 infinite
send-lifetime 04:00:00 Dec 4 1996 04:48:00 Dec 4 1996
exit
key 2
key-string 1234567890
accept-lifetime 04:00:00 Dec 4 1996 infinite
send-lifetime 04:45:00 Dec 4 1996 infinite
 

ルータ B

interface ethernet 1
ip authentication mode eigrp 1 md5
ip authentication key-chain eigrp 1 mikel
key chain mikel
key 1
key-string 0987654321
accept-lifetime 04:00:00 Dec 4 1996 infinite
send-lifetime 04:00:00 Dec 4 1996 infinite
exit
key 2
key-string 1234567890
accept-lifetime 04:00:00 Dec 4 1996 infinite
send-lifetime 04:45:00 Dec 4 1996 infinite
 

ルータ A は 1 のキーを使用した EIGRP パケットの MD5 ダイジェストを受け入れ、確認を試みます。また、2 のキーを使用したパケットも受け入れ、他のすべての MD5 パケットがドロップされます。ルータ A は、キー 2 を使用したすべての EIGRP パケットを送信します。

ルータ B はキー 1 またはキー 2 を受け入れ、キー 1 を送信します。このシナリオでは、MD5 が認証します。

スタブ ルーティングの例

eigrp stub コマンドでスタブとして設定されたルータは、デフォルトで接続および集約ルーティング情報をすべての隣接ルータと共有します。この動作を変更する場合、eigrp stub コマンドで 4 つのオプション キーワードを使用できます。

receive-only

connected

static

summary

ここでは、eigrp stub コマンドのすべての形式の設定例を示します。eigrp stub コマンドはいくつかのオプションを指定して変更できます。これらのオプションは、receive-only キーワードを除いて、どのような組み合わせも可能です。receive-only キーワードは、ルータがその EIGRP 自律システム内の他のルータとルートを共有することを制限します。また receive-only キーワードを使用すると、すべてのタイプのルートの送信が停止するため、他のオプションと併用できません。他の 3 つのオプション キーワード(connected、static、および summary)は、どのように組み合わせても使用できますが、receive-only キーワードと一緒には使用できません。これらの 3 つのキーワードのいずれかを eigrp stubコマンドで個別に使用した場合、接続および集約ルートは自動的に送信されません。

connected キーワードを指定すると、EIGRP スタブ ルーティング機能によって接続ルートが送信されます。接続ルートがネットワーク文で扱われない場合、EIGRP プロセスで redistribute connected コマンドを使用して接続ルートを再配布する必要が生じる場合があります。このオプションは、デフォルトでイネーブルに設定されています。

static キーワードを指定すると、EIGRP スタブ ルーティング機能によってスタティック ルートが送信されます。このオプションを指定しない場合、EIGRP は通常は自動的に再配布される内部スタティック ルートを含むすべてのスタティック ルートを送信しません。ただし、redistribute static コマンドを使用してスタティック ルートを再配布する必要があります。

summary キーワードを使用すると、EIGRP スタブ ルーティング機能によって集約ルートが送信されます。集約ルートは、summary address コマンドを使用して手動で作成することもでき、auto-summary コマンドをイネーブルにしてメジャー ネットワークの境界ルータで自動的に作成することもできます。このオプションは、デフォルトでイネーブルに設定されています。

次に、接続および集約ルートをアドバタイズするスタブとしてルータを設定するために eigrp stub コマンドが使用する例を示します。

router eigrp 1
network 10.0.0.0
eigrp stub
 

次に、接続およびスタティック ルート(集約ルートの送信は禁止)をアドバタイズするスタブとしてルータを設定するために eigrp stub connected static コマンドを使用する例を示します。

router eigrp 1
network 10.0.0.0
eigrp stub connected static
 

次に、ルータをスタブとして設定するのに eigrp stub receive-only コマンドを使用する例を示します。この設定では、接続、集約、またはスタティック ルートは送信されません。

router eigrp 1
network 10.0.0.0 eigrp
stub receive-only