Catalyst 4500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2(44)SG
EtherChannel の設定
EtherChannel の設定
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

EtherChannel の設定

EtherChannel の概要

ポートチャネル インターフェイス

EtherChannel の設定方法

EtherChannel 設定の概要

EtherChannel の手動設定

PAgP EtherChannel の設定

IEEE 802.3ad LACP EtherChannel 設定

ロード バランシング

EtherChannel 設定時の注意事項および制約事項

EtherChannel の設定

レイヤ 3 EtherChannel の設定

ポートチャネル論理インターフェイスの作成

物理インターフェイスのレイヤ 3 EtherChannel としての設定

レイヤ 2 EtherChannel の設定

LACP システム プライオリティおよびシステム ID の設定

EtherChannel ロード バランシングの設定

EtherChannel からのインターフェイスの削除

EtherChannel の削除

EtherChannel の設定

この章では、CLI(コマンドライン インターフェイス)を使用して Catalyst 4500 シリーズ スイッチ レイヤ 2 またはレイヤ 3 インターフェイス上で EtherChannel を設定する方法について説明します。設定上の注意事項、設定手順、および設定例についても示します。

この章の主な内容は、次のとおりです。

「EtherChannel の概要」

「EtherChannel 設定時の注意事項および制約事項」

「EtherChannel の設定」


) 以降のコマンドは、スーパーバイザ エンジンのアップリンク ポートを含む Catalyst 4500 シリーズ スイッチ上のすべてのイーサネット インターフェイスで使用できます。



) この章のスイッチ コマンドの構文および使用方法の詳細については、『Catalyst 4500 Series Switch Cisco IOS Command Reference』および次の URL の関連マニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122sr/cr/index.htm


EtherChannel の概要

EtherChannel は、個々のイーサネット リンクを 1 つの論理リンクにバンドルし、Catalyst 4500 シリーズ スイッチと別のスイッチまたはホスト間で最大 1600 Mbps(Fast EtherChannel 全二重)、16 Gbps(Gigabit EtherChannel)、または40 Gbps(10 Gigabit EtherChannel)の帯域幅を可能にします。

Catalyst 4500 シリーズ スイッチ スイッチは、最大 64 個の EtherChannel をサポートしています。Catalyst 4500 シリーズ スイッチ スイッチにある複数のモジュール上の(設定に互換性のある)イーサネット インターフェイスを 8 つまで使用して、1 つの EtherChannel を形成できます。各 EtherChannel のすべてのインターフェイスは同じ速度で、レイヤ 2 またはレイヤ 3 インターフェイスとして設定されている必要があります。


) Catalyst 4500 シリーズ スイッチ スイッチに接続するネットワーク デバイスによって、1 つの EtherChannel にバンドルできるインターフェイス数が制限される場合があります。


EtherChannel 内のセグメントで障害が発生すると、障害リンク上でそれまで伝送されていたトラフィックがその EtherChannel 内の残りのセグメントに切り替えられます。セグメントに障害が発生すると、スイッチ、EtherChannel、障害リンクを特定する SNMP(簡易ネットワーク管理プロトコル)トラップが送信されます。EtherChannel の 1 つのセグメントに着信したブロードキャスト パケットおよびマルチキャスト パケットが、EtherChannel の別のセグメントに戻されることはありません。


) Catalyst 4500 シリーズ スイッチのポート チャネル リンク障害のスイッチオーバーには、50 ミリ秒かかり、SONET のようなリンク障害のスイッチオーバーには十分です。


ここでは、EtherChannel の機能について説明します。

「ポートチャネル インターフェイス」

「EtherChannel の設定方法」

「ロード バランシング」

ポートチャネル インターフェイス

各 EtherChannel には、番号付きのポートチャネル インターフェイスが 1 つずつあります。ポートチャネル インターフェイスに適用される設定は、そのインターフェイスに割り当てられたすべての物理インターフェイスに影響します。


) QoS(Quality Of Service)はメンバに伝播しません。デフォルトは QoS cos = 0 および QoS dscp = 0 で、ポートチャネルに適用されます。個々のインターフェイスに適用される入力および出力ポリシーは無視されます。


EtherChannel を設定したあとで、ポートチャネル インターフェイスに適用する設定は、EtherChannel に対して有効になります。一方、物理インターフェイスに適用する設定は、適用先のインターフェイスだけに有効です。EtherChannel のすべてのポートのパラメータを変更するには、ポートチャネル インターフェイスに対してコンフィギュレーション コマンドを適用してください(このようなコマンドには、Spanning-Tree Protocol [STP; スパニングツリー プロトコル] コマンドや、レイヤ 2 EtherChannel をトランクとして設定するコマンドがあります)。

EtherChannel の設定方法

ここでは、EtherChannel の設定方法について説明します。

「EtherChannel 設定の概要」

「EtherChannel の手動設定」

「PAgP EtherChannel の設定」

「IEEE 802.3ad LACP EtherChannel 設定」

EtherChannel 設定の概要

EtherChannel を手動で設定することもできますが、Port Aggregation Control Protocol(PAgP)を使用することも、または Cisco IOS Release 12.2(25)EWA 以降のリリースでは Link Aggregation Control Protocol(LACP)を使用して EtherChannel を形成することもできます。EtherChannel プロトコルにより、同様の特性を持つポートが、接続されたネットワーク デバイスとのダイナミック ネゴシエーションを通じて EtherChannel を形成できます。PAgP はシスコ独自のプロトコルで、LACP は IEEE 802.3ad で定義されています。

PAgP と LACP は相互動作しません。PAgP を使用するように設定されたポートは、LACP を使用するように設定されたポートと EtherChannel を形成できず、その逆もまた不可能です。

表20-1 に、ユーザが設定できる EtherChannel モードを示します。

 

表20-1 EtherChannel のモード

モード
説明

on

LANポートを無条件にチャネル化するモード。 on モードでは、 on モードの LAN ポート グループが、 on モードの別の LAN ポート グループに接続されている場合に限り、使用可能な EtherChannel が存在します。 on モードで設定されたポートはネゴシエーションを行わないため、ポート間のネゴシエーション トラフィックはありません。

auto

PAgP モード。LAN ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した PAgP パケットには応答しますが、PAgP ネゴシエーションは開始しません。

desirable

PAgP モード。LAN ポートをアクティブ ネゴシエーション ステートにします。ポートは PAgP パケットを送信して、他の LAN ポートとのネゴシエーションを開始します。

passive

LACP モード。ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した LACP パケットには応答しますが、LCAP ネゴシエーションは開始しません。

active

LACP モード。ポートをアクティブ ネゴシエーション ステートにします。ポートは LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

EtherChannel の手動設定

手動で設定された EtherChannel ポートは、EtherChannel プロトコル パケットを交換しません。EtherChannel 内のすべてのポートを互換性がある設定にした場合のみ、手動で設定されたEtherChannel が形成されます。

PAgP EtherChannel の設定

PAgP は、LAN ポート間で PAgP パケットを交換することにより、EtherChannel を自動的に作成します。PAgP パケットが交換されるのは、 auto モードおよび desirable モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能を動的に学習し、他の LAN ポートに通知します。PAgP は、正確に一致しているイーサネット リンクを識別すると、これらのリンクを 1 つの EtherChannel としてまとめます。形成された EtherChannel は、単一ブリッジ ポートとしてスパニングツリーに追加されます。

auto モードおよび desirable モードでは、PAgP が LAN ポート間でネゴシエーションを行い、ポート速度やトランキング ステートなどの基準に従って EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel は VLAN 数も基準として使用します。

PAgP モードが異なる場合でも、モードに互換性があるかぎり、LAN ポートで EtherChannel を形成できます。次に例を示します。

desirable モードの LAN ポートは、 desirable モードの他の LAN ポートと EtherChannel を形成できます。

desirable モードの LAN ポートは、 auto モードの他の LAN ポートと EtherChannel を形成できます。

auto モードの LAN ポートは、双方のポートがネゴシエーションを開始しないので、 auto モードの他の LAN ポートと EtherChannel を形成できません。

IEEE 802.3ad LACP EtherChannel 設定

Cisco IOS Release 12.2(25)EWA 以降のリリースは、IEEE 802.3ad LACP EtherChannel をサポートしています。LACP は、LAN ポート間で LACP パケットを交換することにより、EtherChannel を自動的に作成します。LACP パケットが交換されるのは、 passive および active モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能を動的に学習し、他の LAN ポートに通知します。LACP は、正確に一致しているイーサネット リンクを識別すると、これらのリンクを 1 つの EtherChannel としてまとめます。形成された EtherChannel は、単一ブリッジ ポートとしてスパニングツリーに追加されます。

passive および active モードでは、LACP が LAN ポート間でネゴシエーションを行い、ポート速度やトランキング ステートなどの基準に従って EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel は VLAN 数も基準として使用します。

LACP モードが異なる場合でも、モードに互換性があるかぎり、LAN ポートで EtherChannel を形成できます。次に例を示します。

active モードの LAN ポートは、 active モードの他の LAN ポートと EtherChannel を形成できます。

active モードの LAN ポートは、 passive モードの他の LAN ポートと EtherChannel を形成できます。

passive モードの LAN ポートは、双方のポートがネゴシエーションを開始しないので、 passive モードの他の LAN ポートと EtherChannel を形成できません。

LACP の設定に使用するパラメータは、次のとおりです。

LACP システム プライオリティ ― LACP が稼働する各 スイッチ上で、LACP システム プライオリティを設定できます。システム プライオリティは、自動的に設定することも、CLI を使用して設定することもできます。「LACP システム プライオリティおよびシステム ID の設定」を参照してください。LACP は、システム プライオリティとスイッチの MAC(メディア アクセス制御)アドレスを組み合わせてシステム ID を形成します。また、これを他のシステムとのネゴシエーション時にも使用します。


) LACP システム ID は、LACP システム プライオリティ値とスイッチの MAC アドレスを組み合わせたものです。


LACP ポート プライオリティ ― LACP を使用するように設定されている各ポート上で、LACP ポート プライオリティを設定する必要があります。ポート プライオリティは、自動的に設定することも、CLI を使用して設定することもできます。「レイヤ 2 EtherChannel の設定」を参照してください。LACP は、ポート プライオリティとポート番号を組み合わせて、ポート ID を形成します。

LACP 管理キー ― LACP は、LACP を使用するように設定された各ポートのチャネル グループ ID 番号と等しい管理キー値を自動的に設定します。他のポートに合算されるポートの能力は、管理キーを使用して定義します。他のポートに合算されるポートの能力は、次の要因によって決定します。

ポートの物理特性(データ レート、デュプレックス能力、ポイントツーポイントまたは共有メディアなど)

ユーザが設定したコンフィギュレーション制約

LACP は、最大数の互換ポートを EtherChannel に設定しようとします(ハードウェア上の最大許容数は 8 ポートです)。ポートをチャネルにアクティブとして組み込めない場合は、チャネル ポートで障害が発生した場合にも自動的に組み込まれません。


) スタンバイおよび「サブチャネル化」は LACP および PAgP でサポートされません。


ロード バランシング

EtherChannel は、チャネルのリンクに対するトラフィック負荷のバランスを取ります。つまり EtherChannel は、フレーム内のアドレスやポートで構成されるバイナリ パターンの一部を数値化し、チャネル内のリンクの 1 つを選択します。負荷のバランスを取るために、EtherChannel は、MAC アドレス、IP アドレス、またはレイヤ 4 ポート番号と、メッセージの送信元、メッセージの宛先、または両方を使用します。

最も多様な設定が可能なオプションを使用してください。たとえば、チャネルのトラフィックが単一の MAC アドレスのみに送信される場合、宛先 MAC アドレスを使用すると、常にチャネル内の同じリンクが選択されてしまいます。送信元アドレスまたは IP アドレスを使用する方が、ロード バランシングの効果が上がります。


) ロード バランシングは、グローバルにのみ設定可能です。したがって、すべてのチャネル(手動設定、PAgP、または LACP)は同じロード バランシング方式を使用します。


ロード バランシングについての詳細は、「EtherChannel ロード バランシングの設定」を参照してください。

EtherChannel 設定時の注意事項および制約事項

EtherChannel インターフェイスの設定に問題があると、ネットワーク ループなどの問題を回避するために、EtherChannel インターフェイスが自動的にディセーブルになります。次の注意事項と制約事項に従って、設定時に問題が起こらないようにしてください。

すべてのモジュールのイーサネット インターフェイスはすべて、物理的に連続しているかまたは同一モジュール上といったインターフェイスに関する要件のない EtherChannel(最大 8 つのインターフェイス)をサポートしています。

EtherChannel のすべてのインターフェイスを、同じ速度およびデュプレックス モードで動作するように設定します。

EtherChannel のすべてのインターフェイスをイネーブルにします。EtherChannel 内のインターフェイスを 1 つダウンにするとリンク障害として処理され、そのインターフェイスのトラフィックが EtherChannel 内の残りのインターフェイスの 1 つに転送されます。

インターフェイスの 1 つが Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)宛先ポートの場合、EtherChannel は形成されません。

レイヤ 3 EtherChannel の場合

レイヤ 3 アドレスを、チャネルの物理インターフェイスではなく、ポートチャネル論理インターフェイスに割り当てます。

レイヤ 2 EtherChannel の場合

EtherChannel 内のすべてのインターフェイスを同じ VLAN に割り当てるか、またはトランクとして設定してください。

トランク インターフェイスから EtherChannel を設定する場合は、すべてのトランクでトランキング モードとネイティブ VLAN が同じであることを確認してください。EtherChannel のインターフェイスのトランク モードが異なる、またはネイティブ VLAN が異なる場合、予期しない結果を招くことがあります。

EtherChannel は、トランキング レイヤ 2 EtherChannel 内のすべてのインターフェイスで同じ許容範囲の VLAN をサポートしています。選択したインターフェイスの許容範囲が異なる場合、インターフェイスは EtherChannel を形成しません。

STP ポート パス コストが異なるインターフェイスは、互換性がある設定を行っているかぎり、EtherChannel を形成できます。異なる STP ポート パス コストを設定しても、EtherChannel のインターフェイスの互換性は損なわれません。

EtherChannel を設定したあとで、ポートチャネル インターフェイスに適用する設定は、EtherChannel に対して有効になります。一方、物理インターフェイスに適用する設定は、設定するインターフェイスだけに有効です。

ストーム制御はこの規則の例外です。たとえば、EtherChannel の一部のメンバにストーム制御を設定することはできません。ストーム制御はすべてのポートに対して設定するか、設定しないかのどちらかにする必要があります。一部のポートのみにストーム制御を設定する場合、そのポートは EtherChannel インターフェイスからドロップされます(中断ステート)。したがって、物理インターフェイス レベルではなく、ポートチャネル インターフェイス レベルでストーム制御を設定してください。

ポート セキュリティがイネーブルである物理インターフェイスは、ポート セキュリティが EtherChannel 上でもイネーブルである場合にのみ、レイヤ 2 EtherChannel に加入できます。イネーブルでない場合、コマンドは CLI によって拒否されます。

802.1X ポートに EtherChannel は設定できません。

EtherChannel の設定

ここでは、EtherChannel を設定する手順について説明します。

「レイヤ 3 EtherChannel の設定」

「レイヤ 2 EtherChannel の設定」

「LACP システム プライオリティおよびシステム ID の設定」

「EtherChannel ロード バランシングの設定」

「EtherChannel からのインターフェイスの削除」

「EtherChannel の削除」


) インターフェイスが正しく設定されていることを確認してください(EtherChannel 設定時の注意事項および制約事項を参照)。


レイヤ 3 EtherChannel の設定

レイヤ 3 EtherChannel を設定するには、ポートチャネル論理インターフェイスを作成し、イーサネット インターフェイスをポートチャネルにします。

ここでは、レイヤ 3 EtherChannel の設定について説明します。

「ポートチャネル論理インターフェイスの作成」

「物理インターフェイスのレイヤ 3 EtherChannel としての設定」

ポートチャネル論理インターフェイスの作成


) IP アドレスを物理インターフェイスから EtherChannel に移動させるには、ポートチャネル インターフェイスを設定する前に物理インターフェイスからIPアドレスを削除する必要があります。


レイヤ 3 EtherChannel 用のポートチャネル インターフェイスを作成するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# interface port-channel port_channel_number

ポートチャネル インターフェイスを作成します。 port_channel _number の値は 1 ~ 64 です。

ステップ 2

Switch(config-if)# ip address ip_address mask

EtherChannel に IP アドレスおよびサブネット マスクを割り当てます。

ステップ 3

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Switch# show running-config interface port-channel port_channel_number

設定を確認します。

次に、インターフェイス port-channel 1 を作成する例を示します。

Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# ip address 172.32.52.10 255.255.255.0
Switch(config-if)# end
 

次に、インターフェイス port-channel 1 の設定を確認する例を示します。

Switch# show running-config interface port-channel 1
Building configuration...
 
Current configuration:
!
interface Port-channel1
ip address 172.32.52.10 255.255.255.0
no ip directed-broadcast
end
 
Switch#

物理インターフェイスのレイヤ 3 EtherChannel としての設定

物理インターフェイスをレイヤ 3 EtherChannel として設定するには、各インターフェイスで次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port

設定する物理インターフェイスを選択します。

ステップ 2

Switch(config-if)# no switchport

このインターフェイスをレイヤ 3 ルーテッド ポートにします。

ステップ 3

Switch(config-if)# no ip address

この物理インターフェイスに IP アドレスが割り当てられていないことを確認します。

ステップ 4

Switch(config-if)# channel-group port_channel_number mode {active | on | auto | passive | desirable }

ポートチャネルでインターフェイスを設定し、PAgP または LACP モードを指定します。

PAgP を使用する場合、キーワード auto または desirable を入力します。

LACP を使用する場合は、キーワードactive または passive を入力します。

ステップ 5

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 6

Switch# show running-config interface port-channel port_channel_number
 
Switch# show running-config interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port
 
Switch# show interfaces { fastethernet | gigabitethernet | tengigabitethernet } slot / port etherchannel
 
Switch# show etherchannel 1 port-channel

設定を確認します。

次に、インターフェイス FastEthernet 5/4 および 5/5 を、port-channel 1、PAgP モード desirable に設定する例を示します。

Switch# configure terminal
Switch(config)# interface range fastethernet 5/4 - 5 (Note: Space is mandatory.)
Switch(config-if)# no switchport
Switch(config-if)# no ip address
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# end

range キーワードの詳細については、「インターフェイスの範囲設定」を参照してください。


次に、インターフェイス FastEthernet 5/4 の設定を確認する例を2つ示します。

Switch# show running-config interface fastethernet 5/4
Building configuration...
 
Current configuration:
!
interface FastEthernet5/4
no ip address
no switchport
no ip directed-broadcast
channel-group 1 mode desirable
end
 
Switch# show interfaces fastethernet 5/4 etherchannel
Port state = EC-Enbld Up In-Bndl Usr-Config
Channel group = 1 Mode = Desirable Gcchange = 0
Port-channel = Po1 GC = 0x00010001 Pseudo-port-channel = Po1
Port indx = 0 Load = 0x55
 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
 
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/4 SC U6/S7 30s 1 128 Any 55
 
Partner's information:
 
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa5/4 JAB031301 0050.0f10.230c 2/45 1s SAC 2D
 
Age of the port in the current state: 00h:54m:52s
 
Switch#
 

次に、インターフェイス port-channel 1 を設定したあとで、インターフェイスの設定を確認する例を示します。

Switch# show etherchannel 1 port-channel
 
Channel-group listing:
----------------------
Group: 1
------------
 
Port-channels in the group:
----------------------
Port-channel: Po1
------------
 
Age of the Port-channel = 01h:56m:20s
Logical slot/port = 10/1 Number of ports = 2
GC = 0x00010001 HotStandBy port = null
Port state = Port-channel L3-Ag Ag-Inuse
 
Ports in the Port-channel:
 
Index Load Port
-------------------
1 00 Fa5/6
0 00 Fa5/7
 
Time since last port bundled: 00h:23m:33s Fa5/6
 
Switch#

レイヤ 2 EtherChannel の設定

レイヤ 2 EtherChannel を設定するには、 channel-group コマンドでイーサネット インターフェイスを設定します。これにより、ポートチャネル論理インターフェイスが作成されます。


channel-group コマンドでレイヤ 2 イーサネット インターフェイスを設定すると、Cisco IOS ソフトウェアはレイヤ 2 EtherChannel のポートチャネル インターフェイスを作成します。


レイヤ 2 イーサネット インターフェイスをレイヤ 2 EtherChannel として設定するには、各インターフェイスで次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port

設定する物理インターフェイスを選択します。

ステップ 2

Switch(config-if)# channel-group port_channel_number mode {active | on | auto | passive | desirable }

ポートチャネルでインターフェイスを設定し、PAgP または LACP モードを指定します。

PAgP を使用する場合、キーワード auto または desirable を入力します。

LACP を使用する場合は、キーワードactive または passive を入力します。

ステップ 3

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Switch# show running-config interface { fastethernet | gigabitethernet } slot / port
 
Switch# show interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port etherchannel

設定を確認します。

次に、インターフェイス FastEthernet 5/6 および 5/7 を、port-channel 2、PAgP モード desirable に設定する例を示します。

Switch# configure terminal
Switch(config)# interface range fastethernet 5/6 - 7 (Note: Space is mandatory.)
Switch(config-if-range)# channel-group 2 mode desirable
Switch(config-if-range)# end
Switch# end

range キーワードの詳細については、「インターフェイスの範囲設定」を参照してください。


次に、インターフェイス port-channel 2 の設定を確認する例を示します。

Switch# show running-config interface port-channel 2
Building configuration...
 
Current configuration:
!
interface Port-channel2
switchport access vlan 10
switchport mode access
end
 
Switch#
 

次に、インターフェイス FastEthernet 5/6 の設定を確認する例を2つ示します。

Switch# show running-config interface fastethernet 5/6
Building configuration...
 
Current configuration:
!
interface FastEthernet5/6
switchport access vlan 10
switchport mode access
channel-group 2 mode desirable
end
 
Switch# show interfaces fastethernet 5/6 etherchannel
Port state = EC-Enbld Up In-Bndl Usr-Config
Channel group = 1 Mode = Desirable Gcchange = 0
Port-channel = Po1 GC = 0x00010001
Port indx = 0 Load = 0x55
 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/6 SC U6/S7 30s 1 128 Any 56
 
Partner's information:
 
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa5/6 JAB031301 0050.0f10.230c 2/47 18s SAC 2F
 
Age of the port in the current state: 00h:10m:57s
 

次に、インターフェイス port-channel 2 を設定したあとで、インターフェイスの設定を確認する例を示します。

Switch# show etherchannel 2 port-channel
Port-channels in the group:
----------------------
 
Port-channel: Po2
------------
 
Age of the Port-channel = 00h:23m:33s
Logical slot/port = 10/2 Number of ports in agport = 2
GC = 0x00020001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
 
Ports in the Port-channel:
 
Index Load Port
-------------------
1 00 Fa5/6
0 00 Fa5/7
 
Time since last port bundled: 00h:23m:33s Fa5/6
 
Switch#
 

LACP システム プライオリティおよびシステム ID の設定

LACP システム ID は、LACP システム プライオリティ値とスイッチの MAC アドレスを組み合わせたものです。

LACP システム プライオリティおよびシステム ID を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# lacp system-priority priority_value

(LACP で任意)有効な値は 1 ~ 65535 です。数値が大きいほど、プライオリティは低くなります。デフォルトは 32768 です。

Switch(config)# no system port-priority

デフォルト値に戻します。

ステップ 2

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Switch# show lacp sys-id

設定を確認します。

次に、LACP システム プライオリティを設定する例を示します。

Switch# configure terminal
Switch(config)# lacp system-priority 23456
Switch(config)# end
Switch# show module
 
Mod Ports Card Type Model Serial No.
----+-----+--------------------------------------+-----------------+-----------
1 2 1000BaseX (GBIC) Supervisor(active) WS-X4014 JAB063808YZ
2 48 10/100BaseTX (RJ45) WS-X4148-RJ JAB0447072W
3 48 10/100BaseTX (RJ45)V WS-X4148-RJ45V JAE061704J6
4 48 10/100BaseTX (RJ45)V WS-X4148-RJ45V JAE061704ML
 
M MAC addresses Hw Fw Sw Status
--+--------------------------------+---+------------+----------------+---------
1 0005.9a39.7a80 to 0005.9a39.7a81 2.1 12.1(12r)EW 12.1(13)EW(0.26) Ok
2 0002.fd80.f530 to 0002.fd80.f55f 0.1 Ok
3 0009.7c45.67c0 to 0009.7c45.67ef 1.6 Ok
4 0009.7c45.4a80 to 0009.7c45.4aaf 1.6 Ok
 

次に、設定を確認する例を示します。

Switch# show lacp sys-id
23456,0050.3e8d.6400
Switch#
 

最初にシステム プライオリティが表示され、次にスイッチの MAC アドレスが表示されます。

EtherChannel ロード バランシングの設定


) ロード バランシングは、グローバルにのみ設定可能です。したがって、すべてのチャネル(手動設定、PAgP、または LACP)は同じロード バランシング方式を使用します。


EtherChannel ロード バランシングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# [ no ] port-channel load-balance { src-mac | dst-mac | src-dst-mac | src-ip | dst-ip | src-dst-ip | src-port | dst-port | src-dst-port }

EtherChannel ロード バランシングを設定します。

EtherChannel ロード バランシングをデフォルト設定に戻すには、 no キーワードを使用します。

ステップ 2

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Switch# show etherchannel load-balance

設定を確認します。

ロード バランシングのキーワードは次のとおりです。

src-mac ― 送信元 MAC アドレス

dst-mac ― 宛先 MAC アドレス

src-dst-mac ― 送信元および宛先 MAC アドレス

src-ip ― 送信元 IP アドレス

dst-ip ― 宛先 IP アドレス

src-dst-ip ― 送信元および宛先 IP アドレス(デフォルト)

src-port ― 送信元レイヤ 4 ポート

dst-port ― 宛先レイヤ 4 ポート

src-dst-port ― 送信元および宛先レイヤ 4 ポート

次に、送信元および宛先 IP アドレスを使用するように EtherChannel を設定する例を示します。

Switch# configure terminal
Switch(config)# port-channel load-balance src-dst-ip
Switch(config)# end
Switch#
 

次に、設定を確認する例を示します。

Switch# show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-dst-ip
 
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
IPv4: Source XOR Destination IP address
IPv6: Source XOR Destination IP address
Switch#
 

EtherChannel からのインターフェイスの削除

EtherChannel からイーサネット インターフェイスを削除するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port

設定する物理インターフェイスを選択します。

ステップ 2

Switch(config-if)# no channel-group

ポートチャネル インターフェイスからインターフェイスを削除します。

ステップ 3

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Switch# show running-config interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port
Switch# show interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port etherchannel

設定を確認します。

次に、インターフェイス FastEthernet 5/4 および 5/5 を、port-channel 1 から削除する例を示します。

Switch# configure terminal
Switch(config)# interface range fastethernet 5/4 - 5 (Note: Space is mandatory.)
Switch(config-if)# no channel-group 1
Switch(config-if)# end

EtherChannel の削除

EtherChannel を削除すると、メンバ ポートがシャットダウンされ、チャネル グループから削除されます。


) EtherChannel をレイヤ 2 からレイヤ 3 に、またはレイヤ 3 からレイヤ 2 に変更する場合、EtherChannel を削除し、適切な設定で再び作成する必要があります。


EtherChannel を削除するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# no interface port-channel port_channel_number

ポートチャネル インターフェイスを削除します。

ステップ 2

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Switch# show etherchannel summary

設定を確認します。

次に、port-channel 1 を削除する例を示します。

Switch# configure terminal
Switch(config)# no interface port-channel 1
Switch(config)# end