Catalyst 4000 ファミリー スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド,Cisco IOS Release 12.1(13)EW
ポリシーベース ルーティングの設定
ポリシーベース ルーティングの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

ポリシーベース ルーティングの設定

ポリシーベース ルーティングの概要

PBRの概要

ポリシーベース ルーティングの使用

ポリシーベース ルーティングの設定作業リスト

PBRのイネーブル化

ローカルPBRのイネーブル化

サポートされない機能

ポリシーベース ルーティングの設定例

同等アクセス例

ネクストホップを変更する例

ACEの拒否例

ポリシーベース ルーティングの設定

この章では、ルータでのPolicy-Based Routing (PBR;ポリシーベース ルーティング)の設定作業について説明します。主な内容は次のとおりです。

「ポリシーベース ルーティングの概要」

「ポリシーベース ルーティングの設定作業リスト」

「ポリシーベース ルーティングの設定例」


) この章で使用しているPBRコマンドの詳細については、『Cisco IOS Quality of Service Solutions Command Reference』を参照してください。



) 機能に関するハードウェア プラットフォームまたはソフトウェア イメージの情報を確認するには、Cisco.comのFeature Navigatorを使用してその機能に関する情報を検索するか、特定のリリースのソフトウェア リリース ノートを参照してください。


ポリシーベース ルーティングの概要

PBRは、トラフィック フローに定義ポリシーを設定し、ルートにおけるルーティング プロトコルへの依存度を軽くして、パケットのルーティングを柔軟に行えるようにします。このためPBRは、ルーティング プロトコルが提供する既存のメカニズムを拡張、補完することでルーティングの制御を強化します。PBRにより、高コスト リンクにおけるプライオリティ トラフィックなど、特定のトラフィックのパスを指定することができます。

設定したポリシーに基づいてパケットをルーティングする方法として、PBRを設定できます。たとえば、特定のエンド システムのID、アプリケーション プロトコル、またはパケット サイズに基づいてパスの許可や拒否を行うルーティング ポリシーを実装できます。

PBRを使用すると、次の作業が可能になります。

拡張アクセス リスト基準に基づいた、トラフィックの分類。リストにアクセスし、一致基準を設定します。

特定のトラフィック処理が行われたパスへのパケットのルーティング

ポリシーは、IPアドレス、ポート番号、またはプロトコルをベースとします。ポリシーを単純にするには、これらの記述子のいずれか1つを使用します。複雑なポリシーにするには、これらをすべて使用します。

PBRの概要

PBRがイネーブルのインターフェイスで受信されたすべてのパケットは、ルート マップという拡張パケット フィルタを通過します。PBRで使用するルート マップはポリシーを要求し、パケットの転送先を判断します。

ルート マップはステートメントで構成されています。ルート マップ ステートメントは許可または拒否とマークでき、次の方法で解釈されます。

ステートメントが拒否とマークされている場合、一致基準に合致したパケットは通常転送チャネルを通じて送り返され、宛先ベースのルーティングを実行します。

ステートメントが許可とマークされていてパケットがアクセス リストと一致している場合、最初の有効set句がそのパケットに適用されます。

PBRを着信インターフェイス(パケットを受信するインターフェイス)に指定できますが、発信インターフェイスには指定できません。

ポリシーベース ルーティングの使用

特定のパケットを、最短と思われるパス以外の方法でルーティングする場合は、PBRをイネーブルにします。たとえば、PBRは次のような機能を提供します。

同等アクセス

プロトコル依存ルーティング

送信元依存ルーティング

双方向対バッチ トラフィックに基づくルーティング

専用リンクに基づくルーティング

アプリケーションまたはトラフィックによっては、送信元依存ルーティングが有効です。たとえば、在庫記録を本社に送信する場合は広帯域で高コストのリンクを短時間使用し、電子メールなどの日常的に使うアプリケーション データは狭帯域で低コストのリンクで送信します。

ポリシーベース ルーティングの設定作業リスト

ここでは、PBRを設定するために実行する作業について説明します。最初に説明する作業は必須、その後の作業は任意です。

PBRのイネーブル化(必須)

ローカルPBRのイネーブル化(任意)

この章の「ポリシーベース ルーティングの設定例」を参照してください。

PBRのイネーブル化

PBRをイネーブルにするには、一致基準とすべての一致句が一致した場合の動作を指定するルート マップを作成する必要があります。次に、特定のインターフェイスでそのルート マップ用のPBRをイネーブルにします。指定したインターフェイスに着信したパケットのうち、一致句と一致したものはすべてPBRの対象になります。

インターフェイスでPBRをイネーブルにするには、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# route-map map-tag [ permit | deny ] [ sequence-number ]

パケットが出力される場所を制御するルート マップを定義します。このコマンドを入力すると、ルータはルートマップ コンフィギュレーション モードになります。

ステップ 2

Switch(config-route-map)# match ip address { access-list-number | name } [ ...access-list-number | name ]

一致基準を指定します。1つまたは複数の標準または拡張アクセス リストで許可された送信元および宛先IPアドレスを照合します。

ステップ 3


 

Switch(config-route-map)# set ip next-hop ip-address [... ip-address ]
 
 
Switch(config-route-map)# set interface interface-type interface-number
[... type number ]
 
 
 
 
 
 
 
Switch(config-route-map)# set ip default next-hop ip-address [... ip-address ]
 
 
 
 
 
 
Switch(config-route-map)# set default interface interface-type interface-number [... type ...number ]

基準と一致するパケットの動作を指定します。次のいずれかまたはすべてを指定できます。

パケットをルーティングするネクストホップを指定します(ネクストホップは隣接している必要があります)。この動作は、通常のルーティング テーブルで指定されているネクストホップと同じです。

パケットの出力インターフェイスを設定します。この動作は、パケットがローカル インターフェイスの外に転送されるよう指定します。インターフェイスは(スイッチ ポートではない)レイヤ3インターフェイスでなければならず、パケットの宛先アドレスはそのインターフェイスに割り当てられたIPネットワーク内に存在している必要があります。パケットの宛先アドレスがネットワークにない場合、パケットは廃棄されます。

その宛先に明示経路がない場合にパケットをルーティングするネクストホップを設定します。ネクストホップにパケットを転送する前に、スイッチはパケットの宛先アドレスをユニキャスト ルーティング テーブル内で検索します。一致するものが見つかった場合、パケットはルーティング テーブルを経由して転送されます。一致するものが見つからなかった場合、パケットは指定されたネクストホップに転送されます。

その宛先に明示経路がない場合のパケットの出力インターフェイスを設定します。ネクストホップにパケットを転送する前に、スイッチはパケットの宛先アドレスをユニキャスト ルーティング テーブル内で検索します。一致するものが見つかった場合、パケットはルーティング テーブルを経由して転送されます。一致するものが見つからなかった場合、パケットは指定された出力インターフェイスに転送されます。パケットの宛先アドレスがネットワークにない場合、パケットは廃棄されます。

ステップ 4

Switch(config-route-map)# interface interface-type interface-number

インターフェイスを設定します。このコマンドを入力すると、ルータはインターフェイス コンフィギュレーション モードになります。

ステップ 5

Switch(config-if)# ip policy route-map map-tag

PBRで使用するルート マップを識別します。1つのインターフェイスに対して使用できるルート マップ タグは1つだけですが、異なるシーケンス番号を持つルート マップ エントリを複数設定できます。これらのエントリは、一致するものが見つかるまでシーケンス番号順に評価されます。一致するものがない場合、パケットは通常通りルーティングされます。

set コマンドは、他のコマンドとともに使用できます。これらのコマンドは、上記のステップ3に示す順序に従って評価されます。使用可能なネクストホップはインターフェイスで暗黙指定されます。ローカル ルータがネクストホップを見つけ、それが使用可能なインターフェイスである場合、ローカル ルータはパケットをルーティングします。

ローカルPBRのイネーブル化

ルータで生成されたパケットは、通常通りにポリシー ルーティングされません。これらパケットでローカルPBRをイネーブルにするには、ルータが使用すべきルート マップを示すために、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
説明
Switch(config)# ip local policy route-map map-tag

ローカルPBRで使用するルート マップを識別します。

これで、ルータから発信されたパケットはすべて、ローカルPBRの対象となります。

ローカルPBRで使用するルート マップ(ある場合)を表示するには、 show ip local policy コマンドを使用します。

サポートされない機能

config-route-mapモードの次のPBRコマンドはCLI(コマンドライン インターフェイス)のものですが、Catalyst 4000ファミリー スイッチのCisco IOSではサポートされていません。これらのコマンドを使用しようとすると、エラー メッセージが表示されます。

match-length

set ip qos

set ip tos

set ip precedence

ポリシーベース ルーティングの設定例

ここでは、PBRの設定例を示します。

同等アクセス例

ネクストホップを変更する例

ACEの拒否例

ポリシーベース ルーティングの構成方法については、この章の「ポリシーベース ルーティングの設定作業リスト」を参照してください。

同等アクセス例

次に、2つの送信元が、異なるサービス プロバイダに対して同等アクセスを持つ例を示します。ルータにパケットの宛先について明示経路がない場合、送信元1.1.1.1からファスト イーサネット インターフェイス1に着信したパケットは、6.6.6.6にあるルータへ送信されます。ルータにパケットの宛先について明示経路がない場合、送信元2.2.2.2から着信したパケットは、7.7.7.7にあるルータへ送信されます。ルータに宛先の明示経路がない他のすべてのパケットは廃棄されます。

Switch (config)# access-list 1 permit ip 1.1.1.1
access-list 2 permit ip 2.2.2.2
!
interface fastethernet 1
ip policy route-map equal-access
!
route-map equal-access permit 10
match ip address 1
set ip default next-hop 6.6.6.6
route-map equal-access permit 20
match ip address 2
set ip default next-hop 7.7.7.7
route-map equal-access permit 30
set default interface null0
 

) 廃棄するパケットが最初の2つのroute-map句と一致しない場合、set default interface null0set interface null0に変更します。


ネクストホップを変更する例

次に、異なる送信元から異なる場所(ネクストホップ)へルーティングする例を示します。送信元1.1.1.1から着信したパケットは3.3.3.3にあるネクストホップに送信され、送信元2.2.2.2から着信したパケットは3.3.3.5にあるネクストホップへ送信されます。

access-list 1 permit ip 1.1.1.1
access-list 2 permit ip 2.2.2.2
!
interface ethernet 1
ip policy route-map Texas
!
route-map Texas permit 10
match ip address 1
set ip next-hop 3.3.3.3
!
route-map Texas permit 20
match ip address 2
set ip next-hop 3.3.3.5
 

ACEの拒否例

次に、指定されたルート マップ シーケンスの処理を停止し、次のシーケンスに飛ぶ例を示します。送信元1.1.1.1から着信したパケットは、シーケンス10をスキップしてシーケンス20に飛びます。サブネット1.1.1.0から着信する他のすべてのパケットは、シーケンス10の設定ステートメントに従います。

access-list 1 deny ip 1.1.1.1
access-list 1 permit ip 1.1.1.0 0.0.0.255
access-list 2 permit ip 1.1.1.1
access-list 2 permit ip 2.2.2.2
!
interface ethernet 1
ip policy route-map Texas
!
route-map Texas permit 10
match ip address 1
set ip next-hop 3.3.3.3
!
route-map Texas permit 20
match ip address 2
set ip next-hop 3.3.3.5