Catalyst 4000 ファミリー スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド,Cisco IOS Release 12.1(13)EW
レイヤ3インターフェイスの設定
レイヤ3インターフェイスの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

レイヤ3インターフェイスの設定

レイヤ3インターフェイスの概要

論理レイヤ3 VLANインターフェイス

物理レイヤ3インターフェイス

設定時の注意事項

論理レイヤ3 VLANインターフェイスの設定

物理レイヤ3インターフェイスの設定

レイヤ3インターフェイスの設定

この章では、Catalyst 4000ファミリー スイッチ上のレイヤ3インターフェイスについて説明します。設定上の注意事項、設定手順、および設定例も示します。

この章の主な内容は、次のとおりです。

「レイヤ3インターフェイスの概要」

「設定時の注意事項」

「論理レイヤ3 VLANインターフェイスの設定」

「物理レイヤ3インターフェイスの設定」


) この章で使用しているスイッチ コマンドの構文および使用方法の詳細については、『Cisco IOS Command Reference for the Catalyst 4000 Family Switch』および次のURLにあるマニュアルを参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/index.htm


レイヤ3インターフェイスの概要

Catalyst 4000ファミリー スイッチは、Cisco IOS IPおよびIPルーティング プロトコルでレイヤ3インターフェイスをサポートします。 ネットワーク 層であるレイヤ3は、主にパケット内データの論理インターネットワーク パスへのルーティングに責任を持ちます。

データ リンク 層であるレイヤ2は、 物理 層(レイヤ1)を制御するプロトコルと、メディアに伝送される前のデータのフレーミング手順を格納しています。LAN上の2つのセグメント間でフレーム内のデータをフィルタリングおよび転送するレイヤ2の機能は、ブリッジングとして知られています。

Catalyst 4000ファミリー スイッチは2種類のレイヤ3インターフェイスをサポートしています。論理レイヤ3 VLAN(仮想LAN)インターフェイスは、ルーティングとブリッジングの機能を統合します。Catalyst 4000ファミリー スイッチは、物理レイヤ3インターフェイスを使用して従来のルータのような設定を行います。

このセクションの内容は次のとおりです。

「論理レイヤ3 VLANインターフェイス」

「物理レイヤ3インターフェイス」

論理レイヤ3 VLANインターフェイス

論理レイヤ3 VLANインターフェイスは、レイヤ2スイッチ上のVLANへの論理ルーティング インターフェイスとして機能します。従来のネットワークでは、ルータとスイッチ間の物理インターフェイスがVLAN間ルーティングを実行する必要がありました。Catalyst 4000ファミリー スイッチは単一のCatalyst 4000ファミリー スイッチでのルーティングとブリッジング機能を統合することで、VLAN間ルーティングをサポートします。

図 20-1に、1つのCatalyst 4000ファミリー スイッチ上で従来のネットワークにおける物理デバイスのルーティングとブリッジング機能を論理的に実行する3つの例を示します。

図 20-1 Catalyst 4000ファミリー スイッチの論理レイヤ3 VLANインターフェイス

 

物理レイヤ3インターフェイス

物理レイヤ3インターフェイスは、従来のルータに等しい機能をサポートします。これらのレイヤ3インターフェイスは、Catalyst 4000ファミリー スイッチへの物理ルーティング インターフェイスを持つホストとして機能します。

図 20-2に、Catalyst 4000ファミリー スイッチが従来のルータとして機能する例を示します。

図 20-2 Catalyst 4000ファミリー スイッチの物理レイヤ3インターフェイス

 

設定時の注意事項

Catalyst 4000ファミリー スイッチは、AppleTalkルーティングとInternetwork Packet Exchange(IPX)ルーティングをサポートします。AppleTalkルーティングとIPXルーティングについては、次のURLの『Cisco IOS AppleTalk and Novell IPX Configuration Guide』の「Configuring AppleTalk」と「Configuring Novell IPX」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/atipx_c/index.htm

Catalyst 4000ファミリー スイッチは、レイヤ3ファスト イーサネットまたはギガビット イーサネット インターフェイスでサブインターフェイスまたは encapsulation キーワードをサポートしません。

論理レイヤ3 VLANインターフェイスの設定


) 論理レイヤ3 VLANインターフェイスを設定する前に、スイッチ上にVLANを作成および設定し、レイヤ2インターフェイスにVLANメンバーシップを割り当てる必要があります。また、IPルーティングがディセーブルの場合はIPルーティングをイネーブルにし、IPルーティング プロトコルを指定する必要があります。


論理レイヤ3 VLANインターフェイスを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# vlan vlan_ID

VLANを作成します。

ステップ 2

Switch(config)# interface vlan vlan_ID

設定するインターフェイスを選択します。

ステップ 3

Switch(config-if)# ip address ip_address subnet_mask

IPアドレスおよびIPサブネットを設定します。

ステップ 4

Switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 6

Switch# copy running-config startup-config

設定変更内容をNVRAM(不揮発性RAM)に保存します。

ステップ 7

Switch# show interfaces [ type slot/interface ]
Switch# show ip interfaces [ type slot/interface ]
Switch# show running-config interfaces [ type slot/interface ]
Switch# show running-config interfaces vlan vlan_ID

設定を確認します。

次に、論理レイヤ3 VLANインターフェイスvlan 2を設定し、IPアドレスを割り当てる例を示します。

Switch> enable
Switch# config term
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# vlan 2
Switch(config)# interface vlan 2
Switch(config-if)# ip address 10.1.1.1 255.255.255.248
Switch(config-if)# no shutdown
Switch(config-if)# end
 

次に、show interfacesコマンドを使用して、レイヤ3 VLANインターフェイスvlan 2のインターフェイスIPアドレスの設定およびステータスを表示する例を示します。

Switch# show interfaces vlan 2
Vlan2 is up, line protocol is down
Hardware is Ethernet SVI, address is 00D.588F.B604 (bia 00D.588F.B604)
Internet address is 172.20.52.106/29
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
Switch#
 

次に、show running-configコマンドを使用して、レイヤ3 VLANインターフェイスvlan 2のインターフェイスIPアドレスの設定を表示する例を示します。

Switch# show running-config
Building configuration...
 
Current configuration : !
interface Vlan2
ip address 10.1.1.1 255.255.255.248
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end
 

物理レイヤ3インターフェイスの設定


) 物理レイヤ3インターフェイスを設定する前に、IPルーティングがディセーブルの場合はIPルーティングをイネーブルにし、IPルーティング プロトコルを指定する必要があります。


物理レイヤ3インターフェイスを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# ip routing

IPルーティングをイネーブルにします(IPルーティングがディセーブルになっている場合のみ)。

ステップ 2

Switch(config)# interface { fastethernet | gigabitethernet } slot / port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 3

Switch(config-if)# no switchport

このポートを物理レイヤ2ポートから物理レイヤ3ポートに変換します。

ステップ 4

Switch(config-if)# ip address ip_address subnet_mask

IPアドレスおよびIPサブネットを設定します。

ステップ 5

Switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Switch# copy running-config startup-config

設定変更内容をNVRAMに保存します。

ステップ 8

Switch# show interfaces [ type slot/interface ]
Switch# show ip interfaces [ type slot/interface ]
Switch# show running-config interfaces [ type slot/interface ]

設定を確認します。

次に、インターフェイスFastEthernet 2/1にIPアドレスを設定する例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# ip routing
Switch(config)# interface fastethernet 2/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.1.1.1 255.255.255.248
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch#
 

次に、show running-configコマンドを使用して、インターフェイスFastEthernet 2/1のインターフェイスIPアドレスの設定を表示する例を示します。

Switch# show running-config
Building configuration...
!
interface FastEthernet2/1
no switchport
ip address 10.1.1.1 255.255.255.248
!
...
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
end