Catalyst 4000 ファミリー スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド,Cisco IOS Release 12.1(13)EW
EtherChannelの概要と設定
EtherChannelの概要と設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

EtherChannelの概要と設定

EtherChannelの概要

ポートチャネル インターフェイスの概要

EtherChannelの設定方法の概要

EtherChannel設定の概要

EtherChannelの手動設定の概要

PAgP EtherChannel設定の概要

IEEE 802.3ad LACP EtherChannel設定の概要

ロードバランシングの概要

EtherChannel設定時の注意事項および制約事項

EtherChannelの設定

レイヤ3 EtherChannelの設定

ポートチャネル論理インターフェイスの作成

物理インターフェイスのレイヤ3 EtherChannelとしての設定

レイヤ2 EtherChannelの設定

LACPシステム プライオリティおよびシステムIDの設定

EtherChannelロードバランシングの設定

EtherChannelからのインターフェイスの削除

EtherChannelの削除

EtherChannelの概要と設定

この章では、CLI(コマンドライン インターフェイス)を使用してCatalyst 4000ファミリー スイッチ レイヤ2またはレイヤ3インターフェイスでEtherChannelを設定する方法について説明します。設定上の注意事項、設定手順、および設定例も示します。

この章の主な内容は、次のとおりです。

「EtherChannelの概要」

「EtherChannel設定時の注意事項および制約事項」

「EtherChannelの設定」


) 以降のコマンドは、スーパバイザ エンジンのアップリンク ポートを含むCatalyst 4000ファミリー スイッチ上のすべてのイーサネット インターフェイスで使用できます。



) この章で使用しているスイッチ コマンドの構文および使用方法の詳細については、『Cisco IOS Command Reference for the Catalyst 4000 Family Switch』および次のURLにあるマニュアルを参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/index.htm


EtherChannelの概要

EtherChannelは個々のイーサネット リンクを1つの論理リンクにバンドルし、Catalyst 4000ファミリー スイッチと別のスイッチまたはホスト間で最大1600 Mbps(Fast EtherChannel全二重)または16 Gbps(Gigabit EtherChannel)の帯域幅を可能にします。

Catalyst 4000ファミリー スイッチは、最大64個のEtherChannelをサポートします。Catalyst 4000ファミリー スイッチにある複数のモジュール上の(設定に互換性のある)イーサネット インターフェイスを8つまで使用して、1つのEtherChannelを形成できます。各EtherChannelのすべてのインターフェイスは同じ速度で、レイヤ2またはレイヤ3インターフェイスとして設定されている必要があります。


) Catalyst 4000ファミリー スイッチに接続するネットワーク デバイスによって、1つのEtherChannelにバンドルできるインターフェイス数が制限される場合があります。


EtherChannel内のセグメントで障害が発生すると、障害リンク上でそれまで伝送されていたトラフィックがそのEtherChannel内の残りのセグメントに切り替えられます。セグメントに障害が発生した後で、スイッチ、EtherChannel、障害リンクを特定するSNMP(簡易ネットワーク管理プロトコル)トラップが送信されます。EtherChannelの1つのセグメントに着信したブロードキャスト パケットおよびマルチキャスト パケットが、EtherChannelの別のセグメントに戻されることはありません。

ここでは、EtherChannelの機能について説明します。

「ポートチャネル インターフェイスの概要」

「EtherChannelの設定方法の概要」

「ロードバランシングの概要」

ポートチャネル インターフェイスの概要

各EtherChannelには、番号付きのポートチャネル インターフェイスが1つずつあります。ポートチャネル インターフェイスに適用される設定は、そのインターフェイスに割り当てられたすべての物理インターフェイスに影響します。


) Quality of Service(QoS;サービス品質)はメンバーに伝播しません。デフォルトはQoS cos = 0およびQoS dscp = 0で、ポートチャネルに適用されます。個々のインターフェイスに適用される入力および出力ポリシーは無視されます。


EtherChannelを設定した後で、ポートチャネル インターフェイスに適用する設定は、EtherChannelに対して有効になります。一方、物理インターフェイスに適用する設定は、適用先のインターフェイスだけに有効です。EtherChannelのすべてのポートのパラメータを変更するには、ポートチャネル インターフェイスに対してコンフィギュレーション コマンドを適用してください(このようなコマンドには、Spanning-Tree Protocol(STP;スパニングツリー プロトコル)コマンドや、レイヤ2 EtherChannelをトランクとして設定するコマンドがあります)。

EtherChannelの設定方法の概要

ここでは、EtherChannelの設定方法について説明します。

「EtherChannel設定の概要」

「EtherChannelの手動設定の概要」

「PAgP EtherChannel設定の概要」

「IEEE 802.3ad LACP EtherChannel設定の概要」

EtherChannel設定の概要

EtherChannelを手動で設定することも、Port Aggregation Control Protocol(PAgP)またはCisco IOS Release 12.1(13)EW以降のリリースではLink Aggregation Control Protocol(LACP)を使用してEtherChannelを形成することもできます。EtherChannelプロトコルにより、同様の特性の持つポートが、接続されたネットワーク デバイスとのダイナミック ネゴシエーションを通じてEtherChannelを形成できます。PAgPはシスコ独自のプロトコルで、LACPはIEEE 802.3adで定義されています。

PAgPおよびLACPは相互運用しません。PAgPを使用するように設定されたポートは、LACPを使用するように設定されたポートとEtherChannelを形成できず、その逆もまた不可能です。

表 17-1 に、ユーザが設定できるEtherChannelモードを示します。

 

表 17-1 EtherChannelのモード

モード
説明

on

LANポートを無条件にチャネル化するモード。 on モードでは、 on モードのLANポート グループが、 on モードの別のLANポート グループに接続されている場合に限り、使用可能なEtherChannelが存在します。 on モードで設定されたポートはネゴシエーションを行わないため、ポート間のネゴシエーション トラフィックはありません。

auto

PAgPモード。LANポートをパッシブ ネゴシエーション ステートにします。ポートは受信したPAgPパケットには応答しますが、PAgPネゴシエーションは開始しません。

desirable

PAgPモード。LANポートをアクティブ ネゴシエーション ステートにします。ポートはPAgPパケットを送信して、他のLANポートとのネゴシエーションを開始します。

passive

LACPモード。ポートをパッシブ ネゴシエーション ステートにします。ポートは受信したLACPパケットには応答しますが、LCAPネゴシエーションは開始しません。

active

LACPモード。ポートをアクティブ ネゴシエーション ステートにします。ポートはLACPパケットを送信して、他のポートとのネゴシエーションを開始します。

EtherChannelの手動設定の概要

手動で設定されたEtherChannelポートはEtherChannelプロトコル パケットを交換しません。EtherChannel内のすべてのポートを互換性がある設定にした場合のみ、手動で設定されたEtherChannelが形成されます。

PAgP EtherChannel設定の概要

PAgPは、LANポート間でPAgPパケットを交換することにより、EtherChannelを自動的に作成します。PAgPパケットが交換されるのは、 auto モードおよび desirable モードのポート間に限られます。

このプロトコルは、LANポート グループの機能を動的に学習し、他のLANポートに通知します。PAgPは、正確に一致しているイーサネット リンクを識別すると、これらのリンクを1つのEtherChannelとしてまとめます。形成されたEtherChannelは、単一ブリッジ ポートとしてスパニングツリーに追加されます。

auto モードおよび desirable モードでは、PAgPがLANポート間でネゴシエーションを行い、ポート速度やトランキング ステートなどの基準に従ってEtherChannelを形成できるかどうかを判別します。レイヤ2 EtherChannelはVLAN(仮想LAN)数も基準として使用します。

PAgPモードが異なる場合でも、モードに互換性がある限りLANポートでEtherChannelを形成できます。以下の例を参照してください。

desirable モードのLANポートは、 desirable モードの他のLANポートとEtherChannelを形成できます。

desirable モードのLANポートは、 auto モードの他のLANポートとEtherChannelを形成できます。

auto モードのLANポートは、双方のポートがネゴシエーションを開始しないので、 auto モードの他のLANポートとEtherChannelを形成できません。

IEEE 802.3ad LACP EtherChannel設定の概要

Cisco IOS Release 12.1(13)EW以降のリリースは、IEEE 802.3ad LACP EtherChannelをサポートしています。LACPは、LANポート間でLACPパケットを交換することにより、EtherChannelを自動的に作成します。LACPパケットが交換されるのは、 passive および active モードのポート間に限られます。

このプロトコルは、LANポート グループの機能を動的に学習し、他のLANポートに通知します。LACPは、正確に一致しているイーサネット リンクを識別すると、これらのリンクを1つのEtherChannelとしてまとめます。形成されたEtherChannelは、単一ブリッジ ポートとしてスパニングツリーに追加されます。

passive および active モードでは、LACPがLANポート間でネゴシエーションを行い、ポート速度やトランキング ステートなどの基準に従ってEtherChannelを形成できるかどうかを判別します。レイヤ2 EtherChannelはVLAN数も基準として使用します。

LACPモードが異なる場合でも、モードに互換性がある限りLANポートでEtherChannelを形成できます。以下の例を参照してください。

active モードのLANポートは、 active モードの他のLANポートとEtherChannelを形成できます。

active モードのLANポートは、 passive モードの他のLANポートとEtherChannelを形成できます。

passive モードのLANポートは、双方のポートがネゴシエーションを開始しないので、 passive モードの他のLANポートとEtherChannelを形成できません。

LACPの設定に使用するパラメータは、次のとおりです。

LACPシステム プライオリティ ― LACPが稼働している各スイッチに、LACPシステム プライオリティを設定できます。システム プライオリティは、自動的に設定することも、CLIを使用して設定することもできます。「LACPシステム プライオリティおよびシステムIDの設定」を参照してください。LACPは、システム プライオリティとスイッチのMAC(メディア アクセス制御)アドレスを組み合わせて、システムIDを形成します。また、これを他のシステムとのネゴシエーション時にも使用します。


) LACPシステムIDは、LACPシステム プライオリティ値とスイッチのMACアドレスを組み合わせたものです。


LACPポート プライオリティ ― LACPを使用するように設定された各ポートに、LACPシステム プライオリティを設定する必要があります。ポート プライオリティは、自動的に設定することも、CLIを使用して設定することもできます。「レイヤ2 EtherChannelの設定」を参照してください。LACPは、ポート プライオリティとポート番号を組み合わせて、ポートIDを形成します。


) スタンバイおよび「サブチャネル化」はLACPおよびPAgPでサポートされません。


LACP管理キー ― LACPは、LACPを使用するように設定された各ポートのチャネル グループID番号と等しい管理キー値を自動的に設定します。他のポートに合算されるポートの能力は、管理キーを使用して定義します。他のポートに合算されるポートの能力は、次の要因によって決定します。

ポートの物理特性(データ レート、デュプレックス能力、ポイントツーポイントまたは共有メディアなど)

ユーザが設定したコンフィギュレーション制約

LACPは、最大数の互換ポートをEtherChannelに設定しようとします(ハードウェア上の最大許容数は8ポートです)。ポートをチャネルにアクティブとして組み込めない場合は、チャネル ポートで障害が発生した場合にも自動的に組み込まれません。

ロードバランシングの概要

EtherChannelは、チャネルの各リンクに対するトラフィック負荷のバランスを取ります。つまり、EtherChannelは、フレーム内のアドレスやポートで構成されるバイナリ パターンの一部分を数値化し、チャネル内のリンクの1つを選択します。負荷のバランスを取るために、EtherChannelは、MACアドレス、IPアドレス、またはレイヤ4ポート番号と、メッセージの送信元、メッセージの宛先、または両方を使用します。

最も多様な設定が可能なオプションを使用してください。たとえば、チャネルのトラフィックが単一のMACアドレスのみに送信される場合、宛先MACアドレスを使用すると、常にチャネル内の同じリンクが選択されてしまいます。送信元アドレスまたはIPアドレスを使用する方が、ロードバランシングの効果が上がります。


) ロードバランシングは、グローバルにのみ設定可能です。したがって、すべてのチャネル(手動設定、PAgP、またはLACP)は同じロードバランシング方式を使用します。


ロードバランシングについての詳細は、「EtherChannelロードバランシングの設定」を参照してください。

EtherChannel設定時の注意事項および制約事項

EtherChannelインターフェイスの設定に問題があると、ネットワーク ループなどの問題を回避するために、EtherChannelインターフェイスが自動的にディセーブルになります。次の注意事項と制約事項に従って、設定時に問題が起こらないようにしてください。

すべてのモジュールのイーサネット インターフェイスはすべて、物理的な連続性または同一モジュール上といったインターフェイスに関する要件のないEtherChannel(最大8つのインターフェイス)をサポートします。

EtherChannelのすべてのインターフェイスを、同じ速度およびデュプレックス モードで動作するように設定します。

EtherChannelのすべてのインターフェイスをイネーブルにします。EtherChannel内のインターフェイスを1つシャットダウンすると、リンク障害として処理され、そのインターフェイスのトラフィックがEtherChannel内の残りのインターフェイスの1つに転送されます。

インターフェイスの1つがSwitched Port Analyzer(SPAN;スイッチド ポート アナライザ)宛先ポートの場合、EtherChannelは形成されません。

レイヤ3 EtherChannelの場合

レイヤ3アドレスを、チャネルの物理インターフェイスではなく、ポートチャネル論理インターフェイスに割り当てます。

レイヤ2 EtherChannelの場合

EtherChannel内のすべてのインターフェイスを同じVLANに割り当てるか、またはトランクとして設定してください。

トランク インターフェイスからEtherChannelを設定する場合は、すべてのトランクでトランキング モードが同じであることを確認してください。EtherChannelのインターフェイスのトランク モードが異なる場合、予期せぬ結果を招くことがあります。

EtherChannelは、トランキング レイヤ2 EtherChannel内のすべてのインターフェイスで同じ許容範囲のVLANをサポートします。VLANの許容範囲が異なる場合、インターフェイスはEtherChannelを形成しません。

STPポート パス コストが異なるインターフェイスは、互換性がある設定を行っている限り、EtherChannelを形成できます。異なるSTPポート パス コストを設定しても、EtherChannelの構成とインターフェイスの互換性は損なわれません。

EtherChannelを設定した後で、ポートチャネル インターフェイスに適用する設定は、EtherChannelに対して有効になります。一方、物理インターフェイスに適用する設定は、適用先のインターフェイスだけに有効です。

802.1xポートにEtherChannelは設定できません。

EtherChannelの設定

ここでは、EtherChannelを設定する手順について説明します。

「レイヤ3 EtherChannelの設定」

「レイヤ2 EtherChannelの設定」

「LACPシステム プライオリティおよびシステムIDの設定」

「EtherChannelロードバランシングの設定」

「EtherChannelからのインターフェイスの削除」

「EtherChannelの削除」


) インターフェイスが正しく設定されていることを確認します(EtherChannel設定時の注意事項および制約事項を参照)。


レイヤ3 EtherChannelの設定

レイヤ3 EtherChannelを設定するには、ポートチャネル論理インターフェイスを作成し、イーサネット インターフェイスをポートチャネルにします。

ここではレイヤ3 EtherChannelの設定について説明します。

「ポートチャネル論理インターフェイスの作成」

「物理インターフェイスのレイヤ3 EtherChannelとしての設定」

ポートチャネル論理インターフェイスの作成


) IPアドレスを物理インターフェイスからEtherChannelに移動するには、ポートチャネル インターフェイスを設定する前に物理インターフェイスからIPアドレスを削除する必要があります。


レイヤ3 EtherChannel用のポートチャネル インターフェイスを作成するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# interface port-channel port_channel_number

ポートチャネル インターフェイスを作成します。 port_channel _numberの値は1~64です。

ステップ 2

Switch(config-if)# ip address ip_address mask

EtherChannelにIPアドレスおよびサブネット マスクを割り当てます。

ステップ 3

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Switch# show running-config interface port-channel port_channel_number

設定を確認します。

次に、インターフェイスport-channel 1を作成する例を示します。

Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# ip address 172.32.52.10 255.255.255.0
Switch(config-if)# end
 

次に、インターフェイスport-channel 1の設定を確認する例を示します。

Switch# show running-config interface port-channel 1
Building configuration...
 
Current configuration:
!
interface Port-channel1
ip address 172.32.52.10 255.255.255.0
no ip directed-broadcast
end
 
Switch#
 

物理インターフェイスのレイヤ3 EtherChannelとしての設定

物理インターフェイスをレイヤ3 EtherChannelとして設定するには、各インターフェイスで次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# interface { fastethernet | gigabitethernet } slot / port

設定する物理インターフェイスを選択します。

ステップ 2

Switch(config-if)# no switchport

このインターフェイスをレイヤ3ルーテッド ポートにします。

ステップ 3

Switch(config-if)# no ip address

この物理インターフェイスにIPアドレスが割り当てられていないことを確認します。

ステップ 4

Switch(config-if)# channel-group port_channel_number mode {active | on | auto} | {passive | desirable }

ポートチャネルでインターフェイスを設定し、PAgPまたはLACPモードを指定します。

PAgPを使用する場合、キーワードactiveおよびdesirableを選択します。

LACPを使用する場合、キーワードactiveおよびpassiveを選択します。

ステップ 5

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 6

Switch# show running-config interface port-channel port_channel_number
 
Switch# show running-config interface { fastethernet | gigabitethernet } slot / port
 
Switch# show interfaces { fastethernet | gigabitethernet } slot / port etherchannel
 
Switch# show etherchannel 1 port-channel

設定を確認します。

次に、インターフェイスFastEthernet 5/4および5/5を、ポートチャネル1、PAgPモード desirable に設定する例を示します。

Switch# configure terminal
Switch(config)# interface range fastethernet 5/4 - 5 (Note: Space is mandatory.)
Switch(config-if)# no switchport
Switch(config-if)# no ip address
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# end
 

rangeキーワードの詳細については、「インターフェイスの範囲設定」を参照してください。


次に、インターフェイスFastEthernet 5/4の設定を確認する例を2つ示します。

Switch# show running-config interface fastethernet 5/4
Building configuration...
 
Current configuration:
!
interface FastEthernet5/4
no ip address
no switchport
no ip directed-broadcast
channel-group 1 mode desirable
end
 
Switch# show interfaces fastethernet 5/4 etherchannel
Port state = EC-Enbld Up In-Bndl Usr-Config
Channel group = 1 Mode = Desirable Gcchange = 0
Port-channel = Po1 GC = 0x00010001 Pseudo-port-channel = Po1
Port indx = 0 Load = 0x55
 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
 
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/4 SC U6/S7 30s 1 128 Any 55
 
Partner's information:
 
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa5/4 JAB031301 0050.0f10.230c 2/45 1s SAC 2D
 
Age of the port in the current state: 00h:54m:52s
 
Switch#
 

次に、インターフェイスport-channel 1を設定した後で、インターフェイスの設定を確認する例を示します。

Switch# show etherchannel 1 port-channel
 
Channel-group listing:
----------------------
Group: 1
------------
 
Port-channels in the group:
----------------------
Port-channel: Po1
------------
 
Age of the Port-channel = 01h:56m:20s
Logical slot/port = 10/1 Number of ports = 2
GC = 0x00010001 HotStandBy port = null
Port state = Port-channel L3-Ag Ag-Inuse
 
Ports in the Port-channel:
 
Index Load Port
-------------------
1 00 Fa5/6
0 00 Fa5/7
 
Time since last port bundled: 00h:23m:33s Fa5/6
 
Switch#
 

レイヤ2 EtherChannelの設定

レイヤ2 EtherChannelを設定するには、 channel-group コマンドでイーサネット インターフェイスを設定します。これにより、ポートチャネル論理インターフェイスが作成されます。


channel-groupコマンドでレイヤ2イーサネット インターフェイスを設定すると、IOSはレイヤ2 EtherChannelのポートチャネル インターフェイスを作成します。


レイヤ2イーサネット インターフェイスをレイヤ2 EtherChannelとして設定するには、各インターフェイスで次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# interface { fastethernet | gigabitethernet } slot / port

設定する物理インターフェイスを選択します。

ステップ 2

Switch(config-if)# channel-group port_channel_number mode {active | on | auto} | {passive | desirable }

ポートチャネルでインターフェイスを設定し、PAgPまたはLACPモードを指定します。

PAgPを使用する場合、キーワードactive およびdesirableを選択します。

LACPを使用する場合、キーワードactive およびpassiveを選択します。

ステップ 3

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Switch# show running-config interface { fastethernet | gigabitethernet } slot / port
 
Switch# show interface { fastethernet | gigabitethernet } slot / port etherchannel

設定を確認します。

次に、インターフェイスFastEthernet 5/6および5/7を、ポートチャネル2、PAgPモード desirable に設定する例を示します。

Switch# configure terminal
Switch(config)# interface range fastethernet 5/6 - 7 (Note: Space is mandatory.)
Switch(config-if-range)# channel-group 2 mode desirable
Switch(config-if-range)# end

rangeキーワードの詳細については、「インターフェイスの範囲設定」を参照してください。


次に、インターフェイスport-channel 2の設定を確認する例を示します。

Switch# show running-config interface port-channel 2
Building configuration...
 
Current configuration:
!
interface Port-channel2
switchport access vlan 10
switchport mode access
end
 
Switch#
 

次に、インターフェイスFastEthernet 5/6の設定を確認する例を2つ示します。

Switch# show running-config interface fastethernet 5/6
Building configuration...
 
Current configuration:
!
interface FastEthernet5/6
switchport access vlan 10
switchport mode access
channel-group 2 mode desirable
end
 
Switch# show interfaces fastethernet 5/6 etherchannel
Port state = EC-Enbld Up In-Bndl Usr-Config
Channel group = 1 Mode = Desirable Gcchange = 0
Port-channel = Po1 GC = 0x00010001
Port indx = 0 Load = 0x55
 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
 
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/6 SC U6/S7 30s 1 128 Any 56
 
Partner's information:
 
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa5/6 JAB031301 0050.0f10.230c 2/47 18s SAC 2F
 
Age of the port in the current state: 00h:10m:57s
 

次に、インターフェイスport-channel 2を設定した後で、インターフェイスの設定を確認する例を示します。

Switch# show etherchannel 2 port-channel
Port-channels in the group:
----------------------
 
Port-channel: Po2
------------
 
Age of the Port-channel = 00h:23m:33s
Logical slot/port = 10/2 Number of ports in agport = 2
GC = 0x00020001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
 
Ports in the Port-channel:
 
Index Load Port
-------------------
1 00 Fa5/6
0 00 Fa5/7
 
Time since last port bundled: 00h:23m:33s Fa5/6
 
Switch#

LACPシステム プライオリティおよびシステムIDの設定

LACPシステムIDは、LACPシステム プライオリティ値とスイッチのMACアドレスを組み合わせたものです。

LACPシステム プライオリティおよびシステムIDを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Router(config)# lacp system-priority priority_value

(LACPで任意)有効な値は1~65535です。数が大きくなるほどプライオリティは低くなります。デフォルトは32768です。

Router(config)# no system port-priority

デフォルト値に戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show lacp sys-id

設定を確認します。

次に、LACPシステム プライオリティを設定する例を示します。

Switch# configure terminal
Switch(config)# lacp system-priority 23456
Switch(config)# end
Switch(config)#
Switch>show module
 
Mod Ports Card Type Model Serial No.
----+-----+--------------------------------------+-----------------+-----------
1 2 1000BaseX (GBIC) Supervisor(active) WS-X4014 JAB063808YZ
2 48 10/100BaseTX (RJ45) WS-X4148-RJ JAB0447072W
3 48 10/100BaseTX (RJ45)V WS-X4148-RJ45V JAE061704J6
4 48 10/100BaseTX (RJ45)V WS-X4148-RJ45V JAE061704ML
 
M MAC addresses Hw Fw Sw Status
--+--------------------------------+---+------------+----------------+---------
1 0005.9a39.7a80 to 0005.9a39.7a81 2.1 12.1(12r)EW 12.1(13)EW(0.26) Ok
2 0002.fd80.f530 to 0002.fd80.f55f 0.1 Ok
3 0009.7c45.67c0 to 0009.7c45.67ef 1.6 Ok
4 0009.7c45.4a80 to 0009.7c45.4aaf 1.6 Ok
 

次に、設定を確認する例を示します。

Switch# show lacp sys-id
23456,0050.3e8d.6400
Switch#
 

システム プライオリティがまず表示され、次にスイッチのMACアドレスが表示されます。

EtherChannelロードバランシングの設定


) ロードバランシングは、グローバルにのみ設定可能です。したがって、すべてのチャネル(手動設定、PAgP、またはLACP)は同じロードバランシング方式を使用します。


EtherChannelロードバランシングを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# [ no ] port-channel load-balance { src-mac | dst-mac | src-dst-mac | src-ip | dst-ip | src-dst-ip | src-port | dst-port | src-dst-port }

EtherChannelロードバランシングを設定します。

EtherChannelロードバランシングをデフォルト設定に戻すには、 no キーワードを使用します。

ステップ 2

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Switch# show etherchannel load-balance

設定を確認します。

ロードバランシングのキーワードは次のとおりです。

src-mac ― 送信元のMACアドレス

dst-mac ― 宛先のMACアドレス

src-dst-mac ― 送信元および宛先のMACアドレス

src-ip ― 送信元のIPアドレス

dst-ip ― 宛先のIPアドレス

src-dst-ip ― 送信元および宛先のIPアドレス(デフォルト)

src-port ― 送信元のレイヤ4ポート

dst-port ― 宛先のレイヤ4ポート

src-dst-port ― 送信元および宛先のレイヤ4ポート

次に、送信元および宛先のIPアドレスを使用するようにEtherChannelを設定する例を示します。

Switch# configure terminal
Switch(config)# port-channel load-balance dst-mac
Switch(config)# end
Switch(config)#
 

次に、設定を確認する例を示します。

Switch# show etherchannel load-balance
Source XOR Destination IP address
Switch#
 

EtherChannelからのインターフェイスの削除

EtherChannelからイーサネット インターフェイスを削除するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# interface { fastethernet | gigabitethernet } slot / port

設定する物理インターフェイスを選択します。

ステップ 2

Switch(config-if)# no channel-group

ポートチャネル インターフェイスからインターフェイスを削除します。

ステップ 3

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Switch# show running-config interface { fastethernet | gigabitethernet } slot / port
Switch# show interface { fastethernet | gigabitethernet } slot / port etherchannel

設定を確認します。

次に、インターフェイスFastEthernet 5/4および5/5を、ポートチャネル1から削除する例を示します。

Switch# configure terminal
Switch(config)# interface range fastethernet 5/4 - 5 (Note: Space is mandatory.)
Switch(config-if)# no channel-group 1
Switch(config-if)# end
 

EtherChannelの削除

EtherChannelを削除すると、メンバー ポートがシャットダウンされ、Channelグループから削除されます。


) ポートをレイヤ2からレイヤ3、またはレイヤ3からレイヤ2に変更する前に、EtherChannelを削除する必要があります。


EtherChannelを削除するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# no interface port-channel port_channel_number

ポートチャネル インターフェイスを削除します。

ステップ 2

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Switch# show etherchannel summary

設定を確認します。

次に、port-channel 1を削除する例を示します。

Switch# configure terminal
Switch(config)# no interface port-channel 1
Switch(config)# end