Catalyst 4000 ファミリー スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド,Cisco IOS Release 12.1(13)EW
スイッチの初期設定
スイッチの初期設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

スイッチの初期設定

デフォルト スイッチ設定

スイッチの設定

コンフィギュレーション モードによるスイッチの設定

実行コンフィギュレーションの確認

実行コンフィギュレーションの起動ファイルへの保存

NVRAMでの設定の確認

デフォルト ゲートウェイの設定

スタティック ルートの設定

イネーブルEXECコマンドへのアクセス制御

スタティック イネーブル パスワードの設定または変更

enable passwordコマンドおよびenable secretコマンドの使用

イネーブル パスワードの設定または変更

イネーブルEXECモードに対するTACACS+パスワード保護の設定

パスワードの暗号化

複数のイネーブル レベルの設定

コマンドのイネーブル レベルの設定

回線のデフォルト イネーブル レベルの変更

イネーブル レベルへのログイン

イネーブル レベルの終了

パスワード、アクセス レベル、およびイネーブル レベルの設定の表示

イネーブル パスワードを忘れた場合の回復方法

スーパバイザ エンジンのスタートアップ コンフィギュレーションの変更

スーパバイザ エンジンのブート コンフィギュレーションの概要

ROMモニタの概要

ソフトウェア コンフィギュレーション レジスタの設定

ブート フィールドの変更およびbootコマンドの使用

ブート フィールドの変更

コンフィギュレーション レジスタ設定値の確認

スタートアップ システム イメージの指定

フラッシュ メモリの使用

フラッシュ メモリの機能

セキュリティ上の注意

フラッシュ メモリの設定

環境変数の制御

BOOTLDR環境変数の設定

スイッチの初期設定

この章では、Catalyst 4000ファミリー スイッチを最初に設定する方法について説明します。ここに示す情報は、次のマニュアルの管理情報と管理手順を補足するものです。

次のURLの『Cisco IOS Configuration Fundamentals Configuration Guide』Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/fun_c/index.htm

次のURLの『Cisco IOS Configuration Fundamentals Configuration Command Reference』Release 12.1

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/fun_r/index.htm

この章の主な内容は、次のとおりです。

「デフォルト スイッチ設定」

「スイッチの設定」

「イネーブルEXECコマンドへのアクセス制御」

「イネーブル パスワードを忘れた場合の回復方法」

「スーパバイザ エンジンのスタートアップ コンフィギュレーションの変更」


) この章で使用しているスイッチ コマンドの構文および使用方法の詳細については、『Cisco IOS Command Reference for the Catalyst 4000 Family Switch』および次のURLにある関連マニュアルを参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/index.htm


デフォルト スイッチ設定

ここでは、Catalyst 4000ファミリー スイッチのデフォルト設定について説明します。 表 3-1 に各機能のデフォルト設定を示します。

 

表 3-1 デフォルト スイッチ設定

機能
デフォルト設定

管理用接続

ユーザ モード

グローバル スイッチ情報

システム名、システムの連絡先、ロケーションにはデフォルト値が設定されていません。

システム クロック

システム クロック タイムには値が設定されていません。

パスワード

ユーザ モードまたはイネーブル モードのパスワードは設定されていません( Return キーを押してください)。

スイッチ プロンプト

Switch>

インターフェイス

イネーブル、速度とフロー制御は自動ネゴシエーション、IPアドレスは指定されていません。

スイッチの設定

ここではスイッチの設定方法について説明します。

「コンフィギュレーション モードによるスイッチの設定」

「実行コンフィギュレーションの確認」

「実行コンフィギュレーションの起動ファイルへの保存」

「NVRAMでの設定の確認」

「デフォルト ゲートウェイの設定」

「スタティック ルートの設定」

コンフィギュレーション モードによるスイッチの設定

コンフィギュレーション モードからスイッチを設定する手順は、次のとおりです。


ステップ 1 スーパバイザ エンジンのコンソール インターフェイスに、コンソール端末を接続します。

ステップ 2 数秒後に、ユーザEXECプロンプト( Switch> )が表示されます。この後、イネーブルEXECモード(別名、イネーブル モード)を開始できます。 enable と入力して、イネーブル モードを開始します。

Switch> enable

) コンフィギュレーションを変更する場合は、イネーブル モードを開始している必要があります。


プロンプトがイネーブル プロンプト(#)に変わります。

Switch#
 

ステップ 3 イネーブル プロンプト(#)に、 configure terminal コマンドを入力して、コンフィギュレーション モードを開始します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
 

ステップ 4 グローバル コンフィギュレーション モード プロンプトに、 interface type slot/interface コマンドを入力して、インターフェイス コンフィギュレーション モードを開始します。

Switch(config)# interface fastethernet 5/1
Switch(config-if)#
 

ステップ 5 これらのモードのいずれかで、スイッチ設定の変更を行います。

ステップ 6 コンフィギュレーション モードを終了するには、 end コマンドを入力します。

ステップ 7 設定値を保存します(実行コンフィギュレーションの起動ファイルへの保存を参照)。


 

これで最小限のスイッチ設定が完了し、入力した設定を使用してルータを起動できるようになりました。コンフィギュレーション コマンドのリストを確認するには、プロンプトで ? を入力するか、またはコンフィギュレーション モードで help キーを押します。

実行コンフィギュレーションの確認

入力したコンフィギュレーションまたは変更を確認するには、次の例に示すように、イネーブルプロンプト(#)で show running-config コマンドを入力します。

Switch# show running-config
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
 
(テキスト出力は省略)
 
!
line con 0
transport input none
line vty 0 4
exec-timeout 0 0
password lab
login
transport input lat pad dsipcon mop telnet rlogin udptn nasi
!
end
Switch#
 

実行コンフィギュレーションの起動ファイルへの保存


注意 次のコマンドで、コンフィギュレーション モードで入力した設定値を保存します。この作業を行わないと、次回システムをリロードするときに設定が消失します。

コンフィギュレーション、コンフィギュレーションへの変更内容、または起動コンフィギュレーションへの変更をNVRAM(不揮発性RAM)に保存するには、イネーブル プロンプト(#)で copy running-config startup-config コマンドを入力します。

Switch# copy running-config startup-config
 

NVRAMでの設定の確認

NVRAMに保存されている情報を表示するには、 show startup-config EXECコマンドを入力します。

次に一般的なシステム設定の例を示します。

Switch# show startup-config
Using 1579 out of 491500 bytes, uncompressed size = 7372 bytes
Uncompressed configuration from 1579 bytes to 7372 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Switch
!
!
ip subnet-zero
!
!
!
!
interface GigabitEthernet1/1
no snmp trap link-status
!
interface GigabitEthernet1/2
no snmp trap link-status
!--More--
 
(テキスト出力は省略)
 
!
line con 0
exec-timeout 0 0
transport input none
line vty 0 4
exec-timeout 0 0
password lab
login
transport input lat pad dsipcon mop telnet rlogin udptn nasi
!
end
 
Switch#
 

デフォルト ゲートウェイの設定


) スイッチがデフォルト ゲートウェイを使用するのは、ルーティング プロトコルが設定されていない場合に限られます。


スイッチにルーティング プロトコルが設定されていない場合、他のサブネットにデータを送信するデフォルト ゲートウェイを設定します。デフォルト ゲートウェイには、スイッチに直接接続するルータ上のインターフェイスのIPアドレスを指定する必要があります。

デフォルト ゲートウェイを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# ip default-gateway IP-address

デフォルト ゲートウェイを設定します。

ステップ 2

Switch# show ip route

デフォルト ゲートウェイがIPルーティング テーブルに正しく表示されることを確認します。

次に、デフォルト ゲートウェイを設定し、その設定を確認する例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# ip default-gateway 172.20.52.35
Switch(config)# end
3d17h: %SYS-5-CONFIG_I: Configured from console by console
Switch# show ip route
Default gateway is 172.20.52.35
 
Host Gateway Last Use Total Uses Interface
ICMP redirect cache is empty
Switch#
 

スタティック ルートの設定

TelnetステーションまたはSNMP(簡易ネットワーク管理プロトコル)ネットワーク管理ワークステーションが、スイッチと異なるネットワークに存在し、ルーティング プロトコルが設定されていない場合、使用しているエンド ステーションが存在するネットワークに対応するスタティック ルーティング テーブル エントリを追加しなければならない場合があります。

スタティック ルートを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# ip route dest_IP_address mask {forwarding_IP | vlan vlan_ID}

リモート ネットワークへのスタティック ルートを設定します。

ステップ 2

Switch# show running-config

スタティック ルートが正しく表示されることを確認します。

次に、スイッチ上で ip route コマンドを使用して、IPアドレス171.10.5.10のワークステーションへのスタティック ルートを設定する例を示します。この場合、サブネット マスクと転送ルータのIPアドレス172.20.3.35を用います。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# ip route 171.10.5.10 255.255.255.255 172.20.3.35
Switch(config)# end
Switch#
 

次に、 show running-config コマンドを使用して、スタティック ルートの設定を確認する例を示します。

Switch# show running-config
Building configuration...
.
(テキスト出力は省略)
.
ip default-gateway 172.20.52.35
ip classless
ip route 171.10.5.10 255.255.255.255 172.20.3.35
no ip http server
!
line con 0
transport input none
line vty 0 4
exec-timeout 0 0
password lab
login
transport input lat pad dsipcon mop telnet rlogin udptn nasi
!
end
 
Switch#
 

次に、スイッチ上で ip route コマンドを使用して、IPアドレス171.20.5.3のワークステーションへのスタティック ルートを設定する例を示します。この場合、サブネット マスクと接続されているVLAN (仮想LAN)1を用います。

Switch# configure terminal
Switch(config)# ip route 171.20.5.3 255.255.255.255 vlan 1
Switch(config)# end
Switch#
 

次に、 show running-config コマンドを使用して、スタティック ルートの設定を確認する例を示します。

Switch# show running-config
Building configuration...
.
(テキスト出力は省略)
.
ip default-gateway 172.20.52.35
ip classless
ip route 171.20.5.3 255.255.255.255 Vlan1
no ip http server
!
!
x25 host z
!
line con 0
transport input none
line vty 0 4
exec-timeout 0 0
password lab
login
transport input lat pad dsipcon mop telnet rlogin udptn nasi
!
end
 
Switch#
 

イネーブルEXECコマンドへのアクセス制御

次の手順に従って、システム コンフィギュレーション ファイルとイネーブルEXECコマンドへのアクセスを制御します。

「スタティック イネーブル パスワードの設定または変更」

「enable passwordコマンドおよびenable secretコマンドの使用」

「イネーブル パスワードの設定または変更」

「イネーブルEXECモードに対するTACACS+パスワード保護の設定」

「パスワードの暗号化」

「複数のイネーブル レベルの設定」

スタティック イネーブル パスワードの設定または変更

イネーブル モードへのアクセスを制御するスタティック パスワードを設定または変更するには、次の作業を行います。

 

コマンド
説明

Switch(config)# enable password password

イネーブルEXECモードの新しいパスワードを設定するか、または既存のパスワードを変更します。

次に、イネーブルEXECモードでイネーブル パスワードを"lab"に設定する例を示します。

Switch# configure terminal
Switch(config)# enable password lab
Switch(config)#
 

パスワードまたはアクセス レベルの設定を表示する方法については、「パスワード、アクセス レベル、およびイネーブル レベルの設定の表示」を参照してください。

enable passwordコマンドおよびenable secretコマンドの使用

ネットワークで送受信されるパスワードまたはTrivial File Transfer Protocol(TFTP ;簡易ファイル転送プロトコル)サーバに保存されるパスワードについて、セキュリティをさらに強化するには、 enable password または enable secret コマンドを使用します。どちらのコマンドも、イネーブル モード(デフォルト)または指定したその他のイネーブル レベルにアクセスするために、ユーザが入力しなければならない暗号化パスワードを設定します。

enable secret コマンドの使用を推奨します。

enable secret コマンドを設定した場合、このコマンドは enable password コマンドよりも優先されます。同時に2つのコマンドを有効にすることはできません。

スイッチがイネーブル パスワードを要求するように設定するには、次のいずれかの作業を行います。

 

コマンド
説明

Switch(config)# enable password [ level level ] { password | encryption-type encrypted-password }

イネーブルEXECモードを開始するためのパスワードを設定します。

Switch(config)# enable secret [ level level ] { password | encryption-type encrypted-password }

不可逆的な暗号化方式を使用して保存される、シークレット パスワードを設定します(enable passwordコマンドおよびenable secretコマンドの両方を設定した場合は、イネーブル シークレット パスワードを入力する必要があります)。

level オプションを使用してどちらかのパスワード コマンドを入力すると、特定のイネーブル レベルにアクセスするためのパスワードを定義できます。レベルを指定してパスワードを設定した後、そのイネーブル レベルにアクセスする必要のあるユーザだけに、パスワードを通知してください。各レベルでアクセスできるコマンドを指定するには、 privilege level コンフィギュレーション コマンドを使用します。

service password-encryption コマンドをイネーブルにしている場合は、入力したパスワードが暗号化されます。 more system:running-config コマンドを使用してパスワードを表示すると、パスワードは暗号化形式で表示されます。

暗号化タイプを指定する場合は、暗号化パスワード(別のCatalyst 4000ファミリー スイッチの設定からコピーした暗号化パスワード)を入力する必要があります。


) 暗号化パスワードを忘れた場合、回復はできません。NVRAMを消去し、新しいパスワードを設定する必要があります。詳細については、「イネーブル パスワードを忘れた場合の回復方法」を参照してください。


パスワードまたはアクセス レベルの設定を表示する方法については、「パスワード、アクセス レベル、およびイネーブル レベルの設定の表示」を参照してください。

イネーブル パスワードの設定または変更

イネーブル パスワードを設定または変更するには、次の作業を行います。

 

コマンド
説明
Switch(config-line)# password password

イネーブル レベルの新しいパスワードを設定するか、または既存のパスワードを変更します。

パスワードまたはアクセス レベルの設定を表示する方法については、「パスワード、アクセス レベル、およびイネーブル レベルの設定の表示」を参照してください。

イネーブルEXECモードに対するTACACS+パスワード保護の設定

TACACS+とRADIUSの詳細については、次のマニュアルを参照してください。

次のURLの『 Cisco IOS Security Configuration Guide 』Release 12.1の「Authentication, Authorization, and Accounting (AAA)」の章
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/secur_c/scprt1/index.htm

次のURLの『 Cisco IOS Security Command Reference 』Release 12.1
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/secur_r/index.htm

TACACS+プロトコルを設定してユーザがイネーブルEXECモードにアクセスできるかどうかを判別するには、次の作業を行います。

 

コマンド
説明

Switch(config)# enable use-tacacs

イネーブルEXECモードに対する、TACACS形式のユーザIDおよびパスワード チェック メカニズムを設定します。

イネーブルEXECモードにTACACSパスワード保護を設定すると、 enable EXECコマンドでは、新しいユーザ名と新しいパスワードが要求されます。この情報は認証のためにTACACS+サーバに渡されます。古いTACACSプロトコルを拡張し、機能が追加された拡張TACACSを使用する場合も、既存のUNIXユーザ識別コードはすべてTACACS+サーバに渡されます。

古いTACACSプロトコルの拡張は、TACACSに機能を追加します。拡張TACACSはプロトコル トランスレータとルータの使用に関する情報を提供します。この情報は、UNIX監査証跡とアカウンティング ファイルで使用されます。


) 拡張TACACSを使用せずにenable use-tacacsコマンドを使用すると、有効なユーザ名およびパスワードさえあれば、だれでもイネーブルEXECモードにアクセスできることになり、セキュリティ上のリスクが発生しやすくなります。この問題が発生するのは、enableコマンドの入力によって実行されるクエリが、拡張TACACSを使用しなかった場合のログイン試行と区別できないためです。


パスワードの暗号化

プロトコル アナライザでパケットを調べる(パスワードを読み取る)ことができるため、パスワードを暗号化するようにCisco IOSソフトウェアを設定することによって、アクセス セキュリティを強化できます。暗号化を行うと、コンフィギュレーション ファイル内でのパスワード読み取りを不可能にすることができます。

パスワードを暗号化するようにCisco IOSソフトウェアを設定するには、次の作業を行います。

 

コマンド
説明

Switch(config)# service password-encryption

パスワードを暗号化します。

暗号化は、現在の設定が保存されるとき、またはパスワードが設定されるときに行われます。パスワードの暗号化は、認証キー パスワード、イネーブル コマンド パスワード、コンソールおよび仮想端末回線アクセス パスワード、およびBorder Gateway Protocol(BGP)ネイバ パスワードを含む、すべてのパスワードに適用されます。 service password-encryption コマンドを使用すると、許可されていないユーザがコンフィギュレーション ファイルのパスワードを表示できなくなります。


注意 service password-encryptionコマンドでは、高度なネットワーク セキュリティは提供されません。このコマンドを使用する場合は、そのほかのネットワーク セキュリティ手段も講じる必要があります。

暗号化パスワードを忘れた場合、パスワードの回復はできません(元のパスワードを取り戻すことはできません)。ただし、暗号化パスワードを忘れても、スイッチの制御を取り戻すことはできます。詳細については、「イネーブル パスワードを忘れた場合の回復方法」を参照してください。

パスワードまたはアクセス レベルの設定を表示する方法については、「パスワード、アクセス レベル、およびイネーブル レベルの設定の表示」を参照してください。

複数のイネーブル レベルの設定

Cisco IOSソフトウェアには、パスワード セキュリティのモードがデフォルトで2つあります。ユーザEXECモードとイネーブルEXECモードです。各モードに、最大16個の階層レベルからなるコマンドを設定できます。複数のパスワードを設定すると、ユーザ グループ別に特定のコマンドへのアクセスを許可することができます。

たとえば、多くのユーザが clear line コマンドにアクセスできるようにするには、このコマンドにレベル2セキュリティを割り当て、レベル2パスワードを広範囲に配布します。一方、 configure コマンドにアクセスできるユーザを限定する場合には、このコマンドにレベル3セキュリティを割り当て、そのパスワードを配布するユーザ数を減らします。

ここでは、追加レベルのセキュリティを設定する手順について説明します。

「コマンドのイネーブル レベルの設定」

「回線のデフォルト イネーブル レベルの変更」

「イネーブル レベルへのログイン」

「イネーブル レベルの終了」

「パスワード、アクセス レベル、およびイネーブル レベルの設定の表示」

コマンドのイネーブル レベルの設定

コマンドのイネーブル レベルを設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch(config)# privilege mode level level command

コマンドのイネーブル レベルを設定します。

ステップ 2

Switch(config)# enable password level level [ encryption-type ] password

イネーブル レベルにアクセスするためのイネーブル パスワードを指定します。

パスワードまたはアクセス レベルの設定を表示する方法については、「パスワード、アクセス レベル、およびイネーブル レベルの設定の表示」を参照してください。

回線のデフォルト イネーブル レベルの変更

特定の回線または回線グループのデフォルト イネーブル レベルを変更するには、次の作業を行います。

 

コマンド
説明

Switch(config-line)# privilege level level

回線のデフォルト イネーブル レベルを変更します。

パスワードまたはアクセス レベルの設定を表示する方法については、「パスワード、アクセス レベル、およびイネーブル レベルの設定の表示」を参照してください。

イネーブル レベルへのログイン

特定のイネーブル レベルにログインするには、次の作業を行います。

 

コマンド
説明
Switch# enable level

指定されたイネーブル レベルにログインします。

イネーブル レベルの終了

特定のイネーブル レベルを終了するには、次の作業を行います。

 

コマンド
説明
Switch# disable level

特定のイネーブル レベルを終了します。

パスワード、アクセス レベル、およびイネーブル レベルの設定の表示

詳細なパスワード情報を表示するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch# show running-config

パスワードおよびアクセス レベルの設定を表示します。

ステップ 2

Switch# show privilege

イネーブル レベルの設定を表示します。

次に、パスワードおよびアクセス レベルの設定を表示する例を示します。

Switch# show running-config
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname Switch
!
boot system flash sup-bootflash
enable password lab
!
(テキスト出力は省略)
 

次に、イネーブル レベルの設定を表示する例を示します。

Switch# show privilege
Current privilege level is 15
Switch#

イネーブル パスワードを忘れた場合の回復方法


) NVRAMにあらかじめ設定されているコンフィギュレーション レジスタについては、「ソフトウェア コンフィギュレーション レジスタの設定」を参照してください。


イネーブル パスワードを忘れた場合の回復手順は、次のとおりです。


ステップ 1 コンソール インターフェイスに接続します。

ステップ 2 起動後5秒間Ctrl-Cを押して、ブート シーケンスを停止し、ROMモニタを開始します。

ステップ 3 コンフィギュレーション メモリ(NVRAM)を読み込まずに起動するように、スイッチを設定します。

ステップ 4 システムを再起動します。

ステップ 5 イネーブル モードにアクセスします(パスワードが設定されていない場合は、パスワードを指定しません)。

ステップ 6 パスワードを表示または変更するか、設定を消去します。

ステップ 7 通常どおりNVRAMを読み込んで起動するように、スイッチを再設定します。

ステップ 8 システムを再起動します。


 

スーパバイザ エンジンのスタートアップ コンフィギュレーションの変更

ここでは、スーパバイザ エンジンのスタートアップ コンフィギュレーションの機能と、コンフィギュレーション レジスタおよびBOOT変数を変更する手順について説明します。

「スーパバイザ エンジンのブート コンフィギュレーションの概要」

「ソフトウェア コンフィギュレーション レジスタの設定」

「スタートアップ システム イメージの指定」

「環境変数の制御」

「BOOTLDR環境変数の設定」

スーパバイザ エンジンのブート コンフィギュレーションの概要

スーパバイザ エンジンのブート プロセスには、2つのソフトウェア イメージが関与します。ROMモニタとスーパバイザ エンジン ソフトウェアです。スイッチを起動またはリセットすると、ROMMONコードが実行されます。NVRAMに保存されている設定に応じて、スーパバイザ エンジンはROMMONモードを継続するか、またはスーパバイザ エンジン ソフトウェアをロードします。

ユーザ側で設定できる2つのパラメータによって、スイッチの起動方法が決まります。コンフィギュレーション レジスタとBOOT環境変数です。コンフィギュレーション レジスタについては、「ブート フィールドの変更およびbootコマンドの使用」を参照してください。BOOT環境変数については、「スタートアップ システム イメージの指定」を参照してください。

ROMモニタの概要

ROMモニタ(ROMMON)はスイッチの起動時、リセット時、または致命的な例外が発生した場合に呼び出されます。スイッチでROMMONモードが開始されるのは、スイッチが有効なソフトウェア イメージを見つけることができなかった場合、NVRAM内の設定が壊れていた場合、またはコンフィギュレーション レジスタがROMMONモードを開始するように設定されていた場合です。ROMMONモードでは、ブートフラッシュまたはフラッシュ ディスクからソフトウェア イメージを手動でロードできます。または、管理インターフェイスから起動することもできます。ROMMONモードはプライマリ イメージをロードします。このプライマリ イメージで、BOOTLDR環境変数を使用してローカルに、またはネットワークを通じて、指定されたソースから起動するセカンダリ イメージを設定できます。この変数については、「BOOTLDR環境変数の設定」を参照してください。

また、スイッチを再起動して、起動後の最初の5秒間にCtrl-C を押しても、ROMMONモードを開始できます。端末サーバから接続している場合は、エスケープによってTelnetプロンプトを表示し、 send break コマンドを入力すると、ROMMONモードが開始されます。


) コンフィギュレーション レジスタでCtrl-Cがディセーブルに設定されているかどうかに関わらず、スイッチの再起動後5秒間は常にCtrl-Cがイネーブルになります。


ROMモニタの機能は、次のとおりです。

電源投入時の信頼性テスト

ハードウェアの初期化

起動能力(手動による起動および自動起動が可能)

ファイル システム(ROMMONの実行時は読み出し専用)

ソフトウェア コンフィギュレーション レジスタの設定

スイッチは16ビットのソフトウェア コンフィギュレーション レジスタを使用します。このコンフィギュレーション レジスタに特定のシステム パラメータを設定できます。ソフトウェア コンフィギュレーション レジスタの設定は、NVRAMにあらかじめ設定されています。

次の場合は、ソフトウェア コンフィギュレーション レジスタの設定値を変更する必要があります。

起動元およびデフォルトのブート ファイル名を選択する場合

ブロードキャスト アドレスを制御する場合

コンソール端末のボーレートを設定する場合

フラッシュ メモリからオペレーティング ソフトウェアをロードする場合

忘れたパスワードを回復する場合

ブートストラップ プログラム プロンプトで boot コマンドを使用し、手動でシステムを起動する場合

システム ブートストラップ ソフトウェア(ブート イメージ)またはオンボード フラッシュ メモリ上のデフォルトのシステム イメージから自動的に起動し、NVRAM上のコンフィギュレーション ファイル内の boot system コマンドを読み込むように強制的に設定する場合


注意 手違い等によってCatalyst 4000 ファミリー スイッチが停止するような事態を避けるために、コンフィギュレーション レジスタ設定を有効にするには、表 3-2に記載されている個々の設定値を使用するのではなく、設定値を組み合わせる必要があることを理解しておいてください。たとえば、出荷時のデフォルトである0x0102という値は、2つの設定値の組み合わせです。

表 3-2 に、各ソフトウェア コンフィギュレーション メモリ ビットの意味を示します。 表 3-3 に、 ブート フィールド の定義を示します。

 

表 3-2 ソフトウェア コンフィギュレーション レジスタ ビット

ビット番号1
16進数
意味

00 ~ 03

0x0000 ~ 0x000F

ブート フィールド( 表 3-3 を参照)

04

0x0010

未使用

05

0x0020

ビット2はコンソール回線速度

06

0x0040

システム ソフトウェアにNVRAMの内容を無視させます。

07

0x0080

OEM2ビットをイネーブルにします。

08

0x0100

未使用

09

0x0200

未使用

10

0x0400

すべてゼロのIPブロードキャスト

11~12

0x0800 ~ 0x1000

コンソール回線速度のビット1と0(デフォルトは9600ボー)

13

0x2000

ネットブートの失敗後にROMモニタをロードします。

14

0x4000

IPブロードキャストでネットワーク番号を使用しません。

1.コンフィギュレーション レジスタの出荷時デフォルト値は0x0102です。この値は、次の設定値を組み合わせたものです。バイナリ ビット 8 = 0x0100、およびバイナリ ビット00~03 = 0x0002(表 3-3を参照)。

2.OEM = Original Equipment Manufacturer

 

表 3-3 ブート フィールド(コンフィギュレーション レジスタ ビット00~03)の説明

ブート フィールド
意味

00

システム ブートストラップ プロンプトの状態(自動起動しません)。

01

オンボード フラッシュ メモリ上で最初に検出されたシステム イメージを起動します。

02~0F

BOOT環境変数で指定されたイメージを使用して自動起動します。複数のイメージが指定されている場合、スイッチはBOOT変数で最初に指定されたイメージの起動を試みます。スイッチがこのイメージからの起動に成功すると、再起動時に同じイメージが使用されます。スイッチがBOOT変数で最初に指定されたイメージからの起動に失敗すると、スイッチはBOOT変数の次のイメージからの起動を試みます。BOOT変数の最後のイメージからスイッチが起動できない場合、スイッチはBOOT変数の最初に戻って起動を試みます。自動起動は、スイッチがBOOT変数で指定されたいずれかのイメージからの起動に成功するまで続きます。

ブート フィールドの変更およびbootコマンドの使用

コンフィギュレーション レジスタのブート フィールドにより、スイッチはオペレーティング システム イメージをロードするかどうかを決定し、ロードする場合はシステム イメージをどこから取得するかを決定します。ここでは、コンフィギュレーション レジスタのブート フィールドの使用方法および設定手順と、コンフィギュレーション レジスタのブート フィールドを変更する場合の手順について説明します。ROMMONでは、コンフィギュレーション レジスタの変更とブート設定の変更に confreg コマンドを使用できます。

ソフトウェア コンフィギュレーション レジスタのビット0~3が、ブート フィールドを形成します。


) システムおよびスペア製品のコンフィギュレーション レジスタの出荷時デフォルト値は、0x0102です。


ブート フィールドを00または01(0-0-0-0または0-0-0-1)に設定すると、システムはシステム コンフィギュレーション ファイルの起動命令を無視して、次の動作を行います。

ブート フィールドが00に設定されている場合は、システム ブートストラップまたはROMMONプロンプトで boot コマンドを入力し、手動でオペレーティング システムを起動する必要があります。

ブート フィールドが01に設定されている場合は、ブートフラッシュSIMMで最初に検出されたイメージを起動します。

ブート フィールド全体が0-0-1-0~1-1-1-1の範囲の値である場合、スイッチはスタートアップ コンフィギュレーション ファイルの boot system コマンドで指定されるシステム イメージをロードします。

boot コマンドは単独でも入力できますが、フラッシュ メモリに保存されたファイル名、ネットワーク サーバからの起動を指定するファイル名など、追加の起動命令を含めることもできます。ファイル名または他の起動命令を指定せずに boot コマンドを使用すると、システムはデフォルトのフラッシュ イメージ(オンボード フラッシュ メモリ上の最初のイメージ)から起動します。また、特定のフラッシュ イメージから起動するように指定することもできます( boot system flash filename コマンドを使用)。

また、 boot コマンドを使用して、スーパバイザ エンジン上のスロット0にあるコンパクト フラッシュ カードに保存されたイメージを起動することもできます。

ブート フィールドの変更

ソフトウェア コンフィギュレーション レジスタのブート フィールドを変更できます。ソフトウェア コンフィギュレーション レジスタのブート フィールドを変更するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch# show version

現在のコンフィギュレーション レジスタ設定値を確認します。

ステップ 2

Switch# configure terminal

コンフィギュレーション モードを開始し、terminalオプションを指定します。

ステップ 3

Switch(config)# config-register value

スイッチへの希望するシステム イメージのロード方法に応じて、既存のコンフィギュレーション レジスタ設定値を変更します。

ステップ 4

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 5

Switch# reload

スイッチを再起動して、変更を有効にします。

 

スイッチがCisco IOSオペレーティング システムを実行しているときにコンフィギュレーション レジスタを変更する場合は、次の手順を実行します。


ステップ 1 enable コマンドおよびパスワードを入力して、イネーブル レベルを開始します。

Switch> enable
Password:
Switch#
 

ステップ 2 EXECモード プロンプト(#)で、 configure terminal コマンドを次のように入力します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
 

ステップ 3 コンフィギュレーション レジスタを0x102に設定します。

Switch(config)# config-register 0x102
 

value コマンド変数を指定して、コンフィギュレーション レジスタの内容を設定します。 value は、先頭が0xの16進数です(ソフトウェア コンフィギュレーション レジスタ ビットを参照)。

ステップ 4 コンフィギュレーション モードを終了するには、 end コマンドを入力します。新しい設定値がメモリに保存されます。ただし、システムを再起動するまで新しい設定値は有効になりません。

ステップ 5 show version EXECコマンドを入力して、現在有効なコンフィギュレーション レジスタ値を表示します。これは次回のリロード時に使用されます。この値は次の出力例のように、画面の最後の行に表示されます。

Configuration register is 0x141 (will be 0x102 at next reload)
 

ステップ 6 設定値を保存します(実行コンフィギュレーションの起動ファイルへの保存を参照。コンソールから reload コマンドを入力するなどの方法でシステムをリロードしないかぎり、コンフィギュレーション レジスタの変更は有効になりません)。

ステップ 7 システムを再起動します。システムを再起動した時点で、新しいコンフィギュレーション レジスタ値が有効になります。


 

コンフィギュレーション レジスタを変更する手順は、以上で完了です。

コンフィギュレーション レジスタ設定値の確認

現在のコンフィギュレーション レジスタ設定値を確認するには、 show version EXECコマンドを使用します。コンフィギュレーション レジスタのブート フィールド値を確認するには、ROMMONモードで show version コマンドを使用します。

スイッチのコンフィギュレーション レジスタ設定値を確認するには、次の作業を行います。

 

コマンド
説明
Switch# show version

コンフィギュレーション レジスタ設定値を表示します。

次に示す show version コマンドの出力例で現在のコンフィギュレーション レジスタは、スイッチがオペレーティング システム イメージを自動的にロードしないように設定されています。レジスタはROMMONモードを開始し、ユーザによるROMモニタ コマンドの入力を待機します。

Switch#show version
Cisco Internetwork Operating System Software
IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-IS-M), Experimental
Version 12.1(20010828:211314) [cisco 105]
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Thu 06-Sep-01 15:40 by
Image text-base:0x00000000, data-base:0x00ADF444
 
ROM:1.15
Switch uptime is 10 minutes
System returned to ROM by reload
Running default software
 
cisco Catalyst 4000 (MPC8240) processor (revision 3) with 262144K bytes
of memory.
Processor board ID Ask SN 12345
Last reset from Reload
Bridging software.
49 FastEthernet/IEEE 802.3 interface(s)
20 Gigabit Ethernet/IEEE 802.3 interface(s)
271K bytes of non-volatile configuration memory.
 
Configuration register is 0xEC60
 
Switch#
 

スタートアップ システム イメージの指定

スタートアップ コンフィギュレーション ファイルまたはBOOT環境変数に複数のブート コマンドを入力して、システム イメージをロードするためのバックアップ手段を得ることができます。

BOOT環境変数については、『Cisco IOS Configuration Fundamentals Configuration Guide 』の「Loading and Maintaining System Images and Microcode」の章の「Specify the Startup System Image in the Configuration File」でも説明しています。

以下の項目に従って、フラッシュ メモリから起動するようにスイッチを設定してください。フラッシュ メモリはSIMMまたはフラッシュ ディスクのいずれかになります。フラッシュ メモリのタイプについては、適切なハードウェアのインストールおよびメンテナンス マニュアルを確認してください。

フラッシュ メモリの使用

フラッシュ メモリを使用すると、次の作業が可能になります。

TFTPによるシステム イメージのフラッシュ メモリへのコピー

フラッシュ メモリからの自動または手動によるシステムの起動

TFTPまたはRemote Copy Protocol(RCP)によるフラッシュ メモリ イメージのネットワーク サーバへのコピー

フラッシュ メモリの機能

フラッシュ メモリを使用すると、次の作業が可能になります。

TFTPまたはRCP転送による複数のシステム ソフトウェア イメージのリモートでのロード(各ファイルのロードに1回の転送)

フラッシュ メモリに保存されたシステム ソフトウェア イメージからの、手動または自動によるスイッチの起動(ROMからの直接起動も可能)

セキュリティ上の注意

フラッシュ メモリからロードする場合、次のセキュリティ上の注意を参照してください。


注意 フラッシュ メモリに保存されたシステム イメージを変更できるのは、コンソール端末のイネーブルEXECレベルからに限られます。

フラッシュ メモリの設定

スイッチがフラッシュ メモリから起動するように設定する手順は、次のとおりです。ハードウェアのインストール方法については、適切なハードウェアのインストールおよびメンテナンス マニュアルを参照してください。


ステップ 1 TFTPまたはその他のプロトコルで、システム イメージをフラッシュ メモリにコピーします。次のURLの『 Cisco IOS Configuration Fundamentals Configuration Guide 』 Release 12.1の「Cisco IOS File Management」と「Loading and Maintaining System Images」の章を参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/fun_c/fcprt2/fcd203.htm

ステップ 2 フラッシュ メモリ内の必要なファイルからシステムが自動的に起動するように設定します。コンフィギュレーション レジスタ値を変更しなければならない場合もあります。コンフィギュレーション レジスタを変更する方法については、「ブート フィールドの変更およびbootコマンドの使用」を参照してください。

ステップ 3 設定を保存します。

ステップ 4 システムの電源をオフにしてから再びオンにしてシステムを再起動し、すべて正常に動作しているかどうかを確認します。


 

環境変数の制御

環境変数の制御はROMモニタが行いますが、特定のコマンドを使用して環境変数を作成、変更、または表示できます。BOOT変数とBOOTLDR変数を作成または変更するには、それぞれ boot systemとboot bootldr グローバル コンフィギュレーション コマンドを使用します。

BOOT環境変数の詳しい設定手順については、『 Configuration Fundamentals Configuration Guide 』の「Loading and Maintaining System Images and Microcode」の章の「Specify the Startup System Image in the Configuration File」を参照してください。


boot systemとboot bootldrグローバル コンフィギュレーション コマンドが有効なのは、実行コンフィギュレーションだけです。後で使用できるようにコンフィギュレーションを保存する場合は、ROMモニタ制御下に情報を置くスタートアップ コンフィギュレーションに環境変数の設定を保存する必要があります。環境変数を実行コンフィギュレーションからスタートアップ コンフィギュレーションに保存するには、copy system:running-config nvram:startup-configコマンドを使用します。


BOOT変数およびBOOTLDR変数の内容を表示するには、 show bootvar コマンドを使用します。このコマンドは、スタートアップ コンフィギュレーション内のこれらの変数の設定値を表示しますが、実行コンフィギュレーションの設定値がスタートアップ コンフィギュレーションの設定値と異なっている場合には、実行コンフィギュレーション内の設定値も表示します。次に、スイッチ上のBOOT変数とBOOTLDR変数を確認する例を示します。

Switch# show bootvar
BOOTLDR variable = bootflash:cat4000-is-mz,1;
Configuration register is 0x0
 
Switch#
 

BOOTLDR環境変数の設定


) Cisco IOSソフトウェアをアップグレードする方法として、ネットワーク イメージをバックフラッシュにコピーして、BOOTLDRを使用せずに直接バックフラッシュから起動する方法がよく用いられます。


BOOTLDR環境変数は、フラッシュ ファイルシステムと、システム ソフトウェアのロードに必要なブート ローダ イメージを格納したファイル名を指定します。この変数は別のソースから最後のイメージをロードする、プライマリCisco IOSイメージを定義します。


) BOOTLDR変数が示すイメージは、起動が予定されているネットワークのイメージよりも新しいものにはなりません。


BOOTLDR環境変数を設定するには、次の作業を行います。

 

コマンド
説明

ステップ 1

Switch# dir bootflash:

ブートフラッシュにブート ローダ イメージが含まれているかどうかを確認します。

ステップ 2

Switch# configure terminal

端末からコンフィギュレーション モードを開始します。

ステップ 3

Switch(config)# boot bootldr bootflash: boot_loader

BOOTLDR環境変数を設定して、ブート ローダ イメージのフラッシュ デバイスおよびファイル名を指定します。このステップにより、実行時のBOOTLDR環境変数が変更されます。

ステップ 4

Switch# end

コンフィギュレーション モードを終了します。

ステップ 5

Switch# copy system:running-config
nvram:startup-config

この実行時のBOOTLDR環境変数をスタートアップ コンフィギュレーションに保存します。

ステップ 6

Switch# show bootvar

(任意)BOOTLDR環境変数の内容を確認します。

次に、BOOTLDR変数を設定する例を示します。

Switch# dir bootflash:
Directory of bootflash:/
 
1 -rw- 1599488 Nov 29 2002 11:12:29 cat4000-is-mz.XE.bin
 
15990784 bytes total (14391168 bytes free)
Switch# configure terminal
Switch (config)# boot bootldr bootflash:cat4000-is-mz.XE.bin
Switch (config)# end
Switch# copy system:running-config nvram:startup-config
[ok]
Switch# show bootvar
BOOTLDR variable = bootflash:cat4000-is-mz,1
Configuration register is 0x0