Catalyst 3750 スイッチ ソフトウェア コンフィギュレーション ガイド,12.2(52)SE
Catalyst 3750G Integrated Wireless LAN Controller スイッチの設定
Catalyst 3750G Integrated Wireless LAN Controller スイッチの設定
発行日;2012/07/30 | 英語版ドキュメント(2009/10/13 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 19MB) | フィードバック

目次

Catalyst 3750G Integrated Wireless LAN Controller スイッチの設定

ワイヤレス LAN コントローラ スイッチの概要

ワイヤレス LAN コントローラ スイッチおよびスイッチ スタック

コントローラとスイッチの相互作用

内部ポート

ワイヤレス LAN コントローラ スイッチの設定

内部ポート設定

内部ポートの再設定

コントローラへのアクセス

内部ワイヤレス コントローラ情報の表示

Catalyst 3750G Integrated Wireless LAN Controller スイッチの設定

Catalyst 3750 Integrated Wireless LAN Controller スイッチは、Catalyst 3750 スイッチと最大 25 または 50 の Lightweight アクセス ポイントをサポートする Cisco 4400 シリーズ ワイヤレス LAN コントローラを統合したものです。スイッチおよび内部コントローラでは個別のソフトウェア バージョンが稼動していて、個別にアップグレードする必要があります。スイッチとコントローラとの相互作用は最小限ですが、ソフトウェア イメージが正確に動作するためには、ワイヤレス LAN コントローラ スイッチと互換性がなければいけません。スイッチとコントローラ ソフトウェアとの互換性に関する情報は、Catalyst 3750 スイッチのリリース ノートを参照してください。


) ワイヤレス LAN コントローラ スイッチをスタックで使用する際に、このイメージをスタック内のすべてのスイッチにロードします。ただし、ワイヤレス機能は Catalyst 3750G Integrated Wireless LAN Controller スイッチに限り利用可能です。


統合コントローラでは、Cisco 4402 ワイヤレス コントローラ用のソフトウェアが稼動しています。コントローラ ソフトウェア リリースの詳細については、『 Release Notes for Cisco Wireless LAN Controllers and Lightweight Access Point 』Release 4.0.x.0 を参照してください。コントローラ ソフトウェアのアップグレード手順については、『 Cisco Wireless LAN Controller Configuration Guide 』Release 4.0 を参照してください。

スイッチとコントローラ ソフトウェアに互換性がない場合、互換性を持たせるようにソフトウェアをアップグレードまたはダウングレードする必要があります。

Catalyst 3750 イメージとコントローラ イメージで Wireless LAN Control Protocol(WCP)のバージョンが異なる場合、スイッチで Syslog メッセージが生成されます。システムが機能している場合、イメージを同期させるためにソフトウェアをアップグレードまたはダウングレードします。

WCP が動作を停止した場合、スイッチ上の 2 番めのコンソール ポートを使用してコントローラ ソフトウェアをアップグレードまたはダウングレードすることができます。WCP が動作を停止した場合、スイッチは約 320 秒毎にワイヤレス LAN コントローラをリセットします。

この付録は、スイッチで動作するソフトウェアに適用される情報およびワイヤレス LAN コントローラ スイッチに固有の機能だけについて説明します。Catalyst 3750G スイッチに固有のスイッチ コマンドの詳細については、このリリースに対応するコマンド リファレンスを参照してください。

この付録で説明する内容は、次のとおりです。

「ワイヤレス LAN コントローラ スイッチの概要」

「ワイヤレス LAN コントローラ スイッチの設定」

「内部ワイヤレス コントローラ情報の表示」

ワイヤレス LAN コントローラ スイッチの概要

Catalyst 3750 Integrated Wireless LAN Controller スイッチは、最大 25 または 50 の Lightweight アクセス ポイントをサポートする統合ワイヤレス LAN コントローラを備えた、レイヤ 3 IEEE 802.3af 準拠のスイッチです。このスイッチは、Catalyst 3750 スイッチのインフラストラクチャにワイヤレス LAN コントローラとアクセス ポイントを組み合わせて、IEEE 802.11 モバイル ワイヤレス ソリューションを提供します。

ワイヤレス LAN コントローラ スイッチの機能は次のとおりです。

レイヤ 2 および レイヤ 3 ワイヤレス モビリティ

レイヤ 3 Lightweight Access Point Protocol(LWAPP)を使用してコントローラと同一または異なるサブネットにあるアクセス ポイントを制御する、アプライアンス モードのワイヤレス LAN コントローラ

レイヤ 3 ローミング

ワイヤレス トラフィックの単一の入力点

ワイヤレス トラフィックと既存の有線ネットワーク インフラストラクチャとの統合

レイヤ 2 スイッチングおよびレイヤ 3 ルーティング機能

Catalyst 3750 IP ベースおよび IP サービス暗号化と非暗号化イメージを保有しているソフトウェア パリティ

25 と 50 のアクセス ポイントと最大 500 ワイヤレス ユーザに最適化

アクセス ポイントや IP 電話などの他のネットワーク アプライアンスに対する給電用の Power over Ethernet(PoE; イーサネット経由の電源供給)ポート

Catalyst 3750G スイッチ ソフトウェアは、ルーティング、ブリッジング、Access Control List(ACL; アクセス コントロール リスト)、および QoS(Quality of Service)など、すべてのスイッチ機能を扱います。コントローラは、すべてのワイヤレス機能を扱います。Catalyst 3750G スイッチおよび内部ワイヤレス コントローラは、2 つのギガビット イーサネット リンクによって内部的に接続されています。これらのリンクは、スイッチ ワイヤレス トラフィックをコントローラに転送するように自動的に設定されるため、ユーザの設定は最小限で済みます。

ワイヤレス LAN コントローラ スイッチおよびスイッチ スタック

ワイヤレス LAN コントローラ スイッチは、スイッチ スタック内の他の Catalyst 3750 スイッチと共存できます。ただし、コントローラを機能させるには、スタック内のすべてのスイッチでコントローラをサポートするソフトウェアが稼動している必要があります。ワイヤレス コントローラの冗長性をサポートするには、少なくとも 2 つの LAN コントローラ スイッチをスタック内に搭載します。スタックに搭載するワイヤレス LAN コントローラ スイッチは、4 台以下にします。

ワイヤレス LAN コントローラ スイッチは、スタック内のマスター スイッチまたはメンバー スイッチです。ワイヤレス LAN コントローラ スイッチのスタック動作は、他の Catalyst 3750 スイッチの動作と一貫性があります。ワイヤレス機能を使用すると、スタック内のあるワイヤレス LAN コントローラ スイッチがシャットダウンした場合に、このスイッチ内のコントローラが制御するアクセス ポイントとワイヤレス クライアントが、スタック内の他のワイヤレス LAN コントローラ スイッチのコントローラに自動的に移行するように、アクセス ポイントを設定することができます。ワイヤレス クライアントのトラフィックは、再アソシエーションおよび再認証のために短時間中断します。

スイッチ スタック内では、各スイッチに固有のスイッチ番号(1 ~ 9)が割り当てられます。これと同じスイッチ番号がスタック内のスイッチまたはスタンドアロン スイッチ内のコントローラにアクセスする際にも使用され、スイッチ番号はデフォルトで 1 になります。たとえば、スタック メンバー 3 のコントローラにアクセスするには、 session 3 processor 1 特権 EXEC コマンドを使用します(processor 1 はコントローラを表します)。スタンドアロン スイッチのコントローラにアクセスするには、コマンド session 1 processor 1 を使用します。


) スイッチ スタックへのスイッチの追加または取り外しの際には、必ずスイッチの電源をオフにしてください。


コントローラとスイッチの相互作用

Catalyst 3750G スイッチとその内部コントローラは、個別に管理されます。スイッチ CLI(コマンドライン インターフェイス)、eXpresso、または CNA を使用してスイッチを管理することができます。コントローラの CLI、内蔵コントローラ GUI、または WCS を使用してコントローラを管理できます。GUI または WCS を使用するには、3750 CLI、コントローラ CLI、eXpresso、または Express Setup を使用してコントローラ管理インターフェイスを設定する必要があります。eXpresso および Express Setup の使用方法については、『 Catalyst 3750 Integrated Wireless LAN Controller Switch Getting Started Guide 』を参照してください。コントローラ CLI にアクセスするには、 session switch-number processor 1 特権 EXEC コマンドを入力します。

ワイヤレス LAN コントローラ スイッチの電源をオンにすると、Catalyst 3750 スイッチとワイヤレス コントローラで Power-On Self Test(POST; 電源投入時自己診断テスト)が個別に実行されます。両方で個別のコンフィギュレーション ファイルを保持しており、これらは個別に保存またはクリアする必要があります。

これらのスイッチとコントローラとの相互作用について、以下の点に注意してください。

Catalyst 3750G スイッチとコントローラは、個別のコンフィギュレーション ファイルを保持しています。これらは自動的に同期しません。

スイッチをリセットすると、スイッチがコントローラを自動的にリセットします。コントローラがスイッチによってリセットされる場合、コントローラ設定は自動的に保存されません。

スイッチとコントローラでパスワード回復は別々に機能します。

スイッチの Mode ボタンを押すと、スイッチのパスワード回復手順をトリガーできます(スイッチパスワード回復手順の詳細については、「トラブルシューティング」を参照してください)。

コントローラのパスワード回復機能は、ユーザがコントローラ ブートアップ プロセスでエスケープを開始する場合にアクセス可能な非表示のブートアップ メニューから clear config を選択することで実行できます。これには、2 番めのコンソール ポートを介してコントローラにシリアル コンソール アクセスする必要があります。

内部ポート

2 つの内部ギガビット ポートでスイッチとコントローラ ハードウェアが接続されています。これらのポートは、ワイヤレス制御とデータ トラフィックを伝送し、またスイッチとコントローラの管理トラフィックも伝送します。スイッチとコントローラ間の内部トラフィックが可能になるように、リンクが自動的に設定されます。さらに、Catalyst 3750G スイッチによって内部 VLAN ID が選択され、コントローラに伝えられます。内部 VLAN(仮想 LAN)を設定することはできません。

コントローラを使用して正確に操作するには、(ギガビット イーサネット ポート 27 および 28 として識別される)内部ポートには次のような特性が必要です。

IEEE 802.1Q トランク モード

ポート集約プロトコル(PAgP)および Link Aggregation Control Protocol(LACP)がディセーブルなスタティック EtherChannel ポート

Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)フレーム生成がディセーブル

Spanning-Tree Protocol(STP; スパニング ツリー プロトコル)PortFast モードがイネーブル

Cisco Discovery Protocol(CDP)がディセーブル

UniDirectional Link Detection(UDLD)がディセーブル

EtherChannel ポート グループ内のメンバシップを含むこれらのパラメータでポートは自動的に設定され、これらの設定は変更できません。ただし、EtherChannel ポート グループはスイッチとスタックで一意であることが重要です。内部ポートを含む他のポートは、そのポートグループに属することはできません。スイッチ スタックに複数のワイヤレス LAN コントローラ スイッチが含まれている場合、内部ポート チャネル番号が各スイッチで異なっていなければなりません。

必要に応じてポート チャネル番号を再設定することができ、他のパラメータを使用してこれらのポートを明示的に設定することが可能です。ただし、ACL、VLAN マップ、IP ソースガードなどのトラフィック フローを制限する機能を設定しないようにします。

ワイヤレス LAN コントローラ スイッチの設定

(スタンドアロンまたはスイッチ スタック内の)Catalyst 3750 スイッチを設定したときに使用したのと同じコマンドを使用して、ワイヤレス LAN コントローラ スイッチを設定します。このセクションでは、ワイヤレス LAN コントローラ スイッチ固有の設定だけについて説明します。内容は次のとおりです。

「内部ポート設定」

「内部ポートの再設定」

「コントローラへのアクセス」

内部ポート設定

「内部ポート」で説明しているように、スイッチとコントローラを接続する内部ポートはギガビット イーサネット ポート 27 および 28 です。スイッチとコントローラとの相互作用に必要なため、そのセクションで定義したパラメータを変更しないでください。内部ポートの設定例は次のとおりです。

!
interface Port-channel41
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
end
 
!
interface GigabitEthernet2/0/27
description This interface is permanently connected to wireless controller
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
end
 
!
interface GigabitEthernet2/0/28
description This interface is permanently connected to wireless controller
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
end
 

インターフェイス コンフィギュレーション モードで、これらのポートにある他のパラメータを設定することも可能です。たとえば、デフォルトでは、全 VLAN 上にあるすべてのトラフィックがコントローラに送信されます。 switchport trunk allowed vlan インターフェイス コンフィギュレーション コマンドを使用して、内部トランクで許可されている VLAN を制限します。他のポートと同じように内部ポートに対してインターフェイス コンフィギュレーション モードを開始します。たとえば、ワイヤレス LAN コントローラ スイッチがスタンドアロン スイッチまたはスタックのスイッチ メンバー 1 の場合、このコマンドを使用して内部ポート 27 でインターフェイス コンフィギュレーション モードを開始します。

Switch(config)# gigabitethernet1/0/27
Switch(config-if)#
 

内部ポートは、PAgP と LACP がディセーブルなスタティック EtherChannel に属するように自動的に設定されます。スイッチ スタック内の他のポート(内部またはそれ以外)は、この EtherChannel のメンバーにはなれません。スイッチが自動的に設定した内部ポート チャネル番号を識別するには、 show etherchannel summary 特権 EXEC コマンドを使用します。

次の出力は、スタック内のスイッチ 1 の内部ポートがポート チャネル 40 に属していることを示しています。このポートチャネルはスタック内の他のポートに使用しないようにします。

Switch# show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
 
Number of channel-groups in use: 36
Number of aggregators: 36
 
Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------
1 Po1(SD) LACP Gi2/0/1(D)
<output truncated>
33 Po33(SD) LACP Gi2/0/17(D)
40 Po40(SU) - Gi1/0/27(P) Gi1/0/28(P)
 

内部ポートの再設定

内部ポートの自動設定は修正できませんが、何らかの理由で自動設定がなくなった場合、ポートをその設定で再設定します。

自動設定で内部ポートを設定するには、特権 EXEC モードで次の手順を実行します。

 

 
コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

内部ポートの 1 つを指定し、インターフェイス コンフィギュレーション モードを開始します。内部ポートは、 gigabitethernet switch-number / 0 / 27 および gigabitethernet switch-number / 0 / 28 です。

ステップ 3

channel-group channel -group-number mode on

チャネル グループにポートを割り当て、PAgP モードまたは LACP モードをディセーブルにします。

channel-group-number の範囲は 1 ~ 48 です。

mode on を選択すると、ポートで PAgP または LACP が機能しなくなります。

(注) スイッチ スタック内の他のポートは、このチャネル グループのメンバーにはなれません。

ステップ 4

exit

特権 EXEC モードに戻ります。

ステップ 5

interface interface-id

他の内部ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

channel-group channel -group-number mode on

ステップ 3 で使用したのと同じチャネル グループをポートに割り当てます。

ステップ 7

exit

特権 EXEC モードに戻ります。

ステップ 8

interface port-channel channel -group-number

内部ポートを含むポート チャネルのインターフェイス コンフィギュレーション モードを開始します。

ステップ 9

channel-group channel -group-number mode on

ステップ 3 で使用したのと同じチャネル グループをポートに割り当てます。

ステップ 10

switchport mode trunk

内部ポートをトランク モードにします。

ステップ 11

switchport trunk encapsulation dot1q

トランク カプセル化方式を IEEE 802.1Q に設定します。

ステップ 12

switchport no negotiate

DTP フレームの生成をディセーブルにします。

ステップ 13

spanning tree portfast

STP PortFast モードをイネーブルにします。

ステップ 14

no cdp

CDP をディセーブルにします。

ステップ 15

no udld

UDLD をディセーブルにします(デフォルトはディセーブルです)。

ステップ 16

switchport trunk allowed vlan remove vlan-list

指定した VLAN からのトランク上で VLAN トラフィックを許可しないことで、コントローラに送信される VLAN トラフィックを制御します。

ステップ 17

exit

特権 EXEC モードに戻ります。

ステップ 18

show running-config

設定を確認します。

ステップ 19

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

コントローラへのアクセス

内蔵コントローラ GUI、WCS、またはコントローラ CLI を使用して内部ワイヤレス コントローラを設定することができます。管理インターフェイス IP アドレスを使用してブラウザまたは WCS からコントローラ GUI にアクセスします。

session stack-member-number processor 1 特権 EXEC コマンドを使用して、スイッチ スタックのマスター スイッチまたはスタンドアロン ワイヤレス LAN コントローラ スイッチからコントローラ CLI にアクセスします。このコマンドを使用すると、コントローラ CLI でコントローラ コンフィギュレーション コマンドを開始することができます。次に、スタック内のスイッチ 2 をワイヤレス LAN コントローラ スイッチと想定している例を示します。

Switch# session 1 processor 1
(Cisco Controller)
User:
 

コントローラ CLI 設定情報については、『 Cisco Wireless LAN Controller Configuration Guide 』Release 4.0 を参照してください。

内部ワイヤレス コントローラ情報の表示

コントローラ GUI のアクセスを使用する場合、管理インターフェイス IP アドレスを入力する必要があります。スイッチ CLI から、キーワードを指定またはなしで show platform wireless-controller 特権 EXEC コマンドを入力して、管理 IP アドレスと内部コントローラの他の情報を表示します。以下に例を示します。

Switch# show platform wireless-controller
Wireless Controller in Switch 2
Operational Status of the Controller : operational
Service VLAN : 4095
Service Port Mac Address : 000b.8540.3783
Service IP Address : 127.0.1.2
Management IP Address : 22.2.2.2
Management VLAN : 7
Software Version : 3.3.0.3
Keepalive Version(controller/switch) : 1/1
Keepalives Missed : 0
Controller accepts http/https : 0/1
Controller's Status Line : up
Watchdog resets of Controller : 0
Controller resets total : 0
Unacknowledged control messages : 0
 
Wireless Controller in Switch 3
Operational Status of the Controller : operational
Service VLAN : 4095
Service Port Mac Address : 000b.8540.33e3
Service IP Address : 127.0.1.3
Management IP Address : 8.8.8.8
Management VLAN : 8
Software Version : 3.3.0.3
Keepalive Version(controller/switch) : 1/1
Keepalives Missed : 0
Controller accepts http/https : 0/1
Controller's Status Line : up
Watchdog resets of Controller : 0
Controller resets total : 0
Unacknowledged control messages : 0