Catalyst 3750 スイッチ ソフトウェア コンフィギュ レーション ガイド 12.2(50)SE
Auto Smartport マクロの設定
Auto Smartport マクロの設定
発行日;2012/01/30 | 英語版ドキュメント(2011/09/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 19MB) | フィードバック

目次

Auto Smartport マクロの設定

Auto Smartport マクロおよびスタティック Smartports マクロの概要

Auto Smartport の設定

デフォルトの Auto Smartport 設定

Auto Smartport の設定に関する注意事項

Auto Smartport のイネーブル化

Auto Smartport 組み込みマクロの設定

イベント トリガーの設定

Auto Smartport ユーザ定義マクロの設定

スタティック Smartport マクロの設定

デフォルトのスタティック Smartport 設定

スタティック Smartport コンフィギュレーションに関する注意事項

スタティック Smartport マクロの適用

Auto Smartport マクロおよびスタティック Smartport マクロの表示

Auto Smartport マクロの設定

この章では、Auto Smartport マクロとスタティック Smartport マクロを Catalyst 3750 スイッチ上で設定して適用する方法を説明します。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


「Auto Smartport マクロおよびスタティック Smartports マクロの概要」

「Auto Smartport の設定」

「スタティック Smartport マクロの設定」

「Auto Smartport マクロおよびスタティック Smartport マクロの表示」

Auto Smartport マクロおよびスタティック Smartports マクロの概要

Auto Smartport マクロは、ポートで検出されたデバイス タイプに基づいてポートを動的に設定します。スイッチはポート上で新しいデバイスを検出すると、ポートに適切な Auto Smartport マクロを適用します。ポートでリンクダウン イベントが発生すると、スイッチによってマクロは削除されます。たとえば、Cisco IP Phone をポートに接続すると、Auto Smartport は IP Phone マクロを自動的に適用します。IP Phone マクロを使用すると、QoS(Quality of Service)、セキュリティ機能、および専用の音声 VLAN で遅延に影響されやすい音声トラフィックを適切に処理できます。

Auto Smartport マクロに加え、 スタティック Smartport マクロでは、ポートに接続されているデバイスに基づいて手動で適用するポート設定が提供されます。スタティック Smartport マクロを適用すると、マクロ内の CLI コマンドが既存のポート設定に追加されます。ポート上でリンクダウン イベントが発生した場合、スイッチはスタティック マクロを削除しません。

Auto Smartport は イベント トリガー を使用してデバイスをマクロにマッピングします。多くの一般的なイベント トリガーは、接続デバイスから受信する Cisco Discovery Protocol(CDP)に基づいています。デバイス(Cisco IP Phone、Cisco ワイヤレス アクセス ポイント、シスコ製スイッチ、またはシスコ製ルータ)の検出により、CDP イベント トリガーが呼び出されます。他のイベント トリガーは MAC Authentication Bypass(MAB; MAC 認証バイパス)および 802.1x 認証メッセージを使用します。

スイッチ ソフトウェアに組み込まれている Auto Smartport マクロは、CLI コマンドのグループです。ポート上で CISCO_PHONE イベントが検出されると、スイッチによって CISCO_PHONE_AUTO_SMARTPORT マクロでコマンドが適用されます。Cisco IOS スクリプト機能(コマンドの自動化や変数の代入を行うための BASH に似ている言語構文)を使用してユーザ定義のマクロを作成することもできます。

Auto Smartport の設定

「デフォルトの Auto Smartport 設定」

「Auto Smartport の設定に関する注意事項」

「Auto Smartport のイネーブル化」

「Auto Smartport 組み込みマクロの設定」

「イベント トリガーの設定」

「Auto Smartport ユーザ定義マクロの設定」

デフォルトの Auto Smartport 設

Auto Smartport はディセーブルに設定されます。

Cisco IOS シェルはイネーブルに設定されます。

表 13-1 に、スイッチ ソフトウェアに組み込まれている Auto Smartport 組み込みマクロを示します。

 

表 13-1 Auto Smartport 組み込みマクロ

マクロ名
説明

CISCO_PHONE_AUTO_
SMARTPORT

このマクロを使用して、Cisco IP Phone に IP Phone マクロを適用します。このマクロによって、ポート上で QoS、ポート セキュリティ、Address Resolution Protocol(ARP;
アドレス解決プロトコル)インスペクション(ダイナミック ARP インスペクション)、IP ソース ガード、DHCP スヌーピング、ストーム制御、およびスパニング ツリー保護が
イネーブルになります。

CISCO_SWITCH_AUTO_
SMARTPORT

このマクロを使用して、シスコ製スイッチにスイッチ マクロを適用します。このマクロによって、ポート上でトランキングがイネーブルになります。

CISCO_ROUTER_AUTO_
SMARTPORT

このマクロを使用して、シスコ製ルータにルータ マクロを適用します。このマクロによって、ポート上で QoS、トランキング、およびスパニング ツリー保護がイネーブルになります。

CISCO_AP_AUTO_
SMARTPORT

このマクロを使用して、Cisco AP にワイヤレス Access Point(AP; アクセス ポイント)マクロを適用します。このマクロによって、ポート上で自律ワイヤレス アクセス ポイントと QoS のサポートがイネーブルになります。

CISCO_LWAP_AUTO_
SMARTPORT

このマクロを使用して、シスコ製軽量ワイヤレス AP に軽量ワイヤレス アクセス ポイント マクロを適用します。このマクロによって、ポート上で QoS、ポート セキュリティ、ダイナミック ARP インスペクション、IP ソース ガード、DHCP スヌーピング、ストーム制御、およびスパニング ツリー保護がイネーブルになります。

CISCO_DOT1X_DESKTOP_
AUTO_SMARTPORT

このマクロを使用して、IEEE 802.1x 認証デバイスにデスクトップ マクロを適用します。このマクロによって、セキュリティおよびスパニング ツリー保護を含む基本のデスクトップ設定がイネーブルになります。

CISCO_DOT1X_EASY_AUTO_SMARTPORT

このマクロを使用して、IEEE 802.1x-認証デスクトップ デバイスにデスクトップ マクロを適用します。このマクロは、802.1x、MAB、ゲスト VLAN、認証に失敗した VLAN のサポートを提供し、802.1x のタイムアウトを 3 秒に短縮します。

CISCO_DOT1X_MAB_
GUEST_AUTO_SMARTPORT

このマクロを使用して、802.1x 認証デバイス、MAB 認証デバイス、および ゲスト VLAN 認証デバイスにデスクトップ マクロを適用します。

CISCO_DOT1X_MAB_
TIMEOUT_AUTO_
SMARTPORT

このマクロを使用して、アグレッシブ タイムアウトで設定されている 802.1x 認証デバイス、MAB 認証デバイス、およびゲスト VLAN 認証デバイスにデスクトップ マクロを適用します。

CISCO_DOT1X_AUTH_
FAIL_AUTO_SMARTPORT

このマクロを使用して、802.1x 認証デバイス、MAB 認証デバイス、および認証に失敗した VLAN 認証デバイスにデスクトップ マクロを適用します。

CISCO_DOT1X_CRITICAL_
AUTO_SMARTPORT

このマクロを使用して、802.1x 認証デバイス、MAB 認証デバイス、およびクリティカル VLAN 認証デバイスにデスクトップ マクロを適用します。

Auto Smartport の設定に関する注意事項

組み込みマクロは削除または変更を行うことはできません。ただし、同じ名前のユーザ定義のマクロを作成して組み込みマクロを上書きすることはできます。元の組み込みマクロを復元するには、ユーザ定義のマクロを削除します。

Auto Smartport マクロの適用時にシステムの競合を回避するためには、802.1x 認証以外のすべてのポート設定を削除します。

マクロが元の設定と競合すると、一部のマクロ コマンドが適用されなかったり、一部のアンチマクロ コマンドが削除されたりする場合があります (アンチマクロはリンク ダウン時に適用されるマクロを削除する適用済みマクロの一部です)。

たとえば、802.1x 認証がイネーブルの場合は、switchport mode access 設定を削除できません。switchport mode 設定を削除する前に 802.1x 認証を削除します。

Auto Smartport マクロを適用する場合は、ポートを EtherChannel のメンバーにしないでください。

組み込みマクロのデフォルト データ VLAN は VLAN 1 です。デフォルト音声 VLAN は VLAN 2 です。スイッチが別の VLAN を使用している場合は、組み込みマクロのデフォルト値を変更する必要があります。組み込みマクロのデフォルト値を表示するには、 show shell functions 特権 EXEC コマンドを使用します。

802.1x 認証または MAB の場合は、Cisco Attribute-Value(AV; アトリビュート値)ペアの auto-smart-port=event trigger をサポートしてシスコ以外のデバイスを検出するように RADIUS サーバを設定します。

CDP、MAB、802.1x 認証をサポートしないステーショナリ デバイス(ネットワーク プリンタなど)の場合は、ポート上で Auto Smartport をディセーブルにすることを推奨します。

認証がポート上でイネーブルの場合、 macro auto global processing グローバル コンフィギュレーション コマンドに cdp-fallback キーワードが使用されない限り、スイッチは CDP を無視します。

マクロ内の CLI コマンドの順序と対応するアンチマクロは異なる場合があります。

Auto Smartport のイネーブル化

すべてのポート上で Auto Smartport マクロが自動的に適用されるようにスイッチを設定するには、 macro auto global processing グローバル コンフィギュレーション コマンドを使用します。特定のポート上で Auto Smartport マクロをディセーブルにするには、インターフェイス モードで no auto global processing を使用します。

特権 EXEC モードで、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

macro auto global processing [cdp-fallback]

スイッチで Auto Smartport をグローバルにイネーブルにします。

(任意)ポートで 802.1x がイネーブルになっていて、RADIUS サーバがイベント トリガーを送信しない場合は、 cdp-fallback キーワードを使用してスイッチで CDP 機能情報を使用できるようにします。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show running-config

Auto Smartport がイネーブルになっていることを確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

デフォルト設定に戻すには、 no macro auto global processing グローバル コンフィギュレーション コマンドを使用します。

show shell functions および show shell triggers 特権 EXEC コマンドを使用してイベント トリガー、組み込みマクロ、および組み込みマクロのデフォルト値を表示します。

次に、スイッチ上で Auto Smartport をイネーブルにする方法と、特定のインターフェイス上で機能をディセーブルにする例を示します。

Switch(config)# macro auto global processing
Switch(config)# interface interface_id
Switch(config-if)# no macro auto processing
 

Auto Smartport 組み込みマクロの設定

スイッチはイベント トリガーから組み込みマクロへ自動的にマッピングします。組み込みマクロのデフォルト値は、スイッチ固有の値に置き換えることができます。

特権 EXEC モードで、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

macro auto execute event trigger builtin built-in macro name [parameter=value] [parameter=value]

イベント トリガーから組み込みマクロへのマッピングを定義します。

event trigger を指定します。

CISCO_PHONE_EVENT

CISCO_SWITCH_EVENT

CISCO_ROUTER_EVENT

CISCO_WIRELESS_AP_EVENT

CISCO_WIRELESS_LIGHTWEIGHT_AP_EVENT

WORD :ユーザ定義のイベント トリガーを適用します。

builtin built-in macro name を指定します。

CISCO_PHONE_AUTO_SMARTPORT
(任意)パラメータ値 $ACCESS_VLAN=(1) および $VOICE_VLAN=(2) を指定します。

CISCO_SWITCH_AUTO_SMARTPORT
(任意)パラメータ値 $NATIVE_VLAN=(1) を指定します。

CISCO_ROUTER_AUTO_SMARTPORT
(任意)パラメータ値 $NATIVE_VLAN=(1) を指定します。

CISCO_AP_AUTO_SMARTPORT
(任意)パラメータ値 $NATIVE_VLAN=(1) を指定します。

CISCO_LWAP_AUTO_SMARTPORT
(任意)パラメータ値 $ACCESS_VLAN=(1) を指定します。

CISCO_DOT1X_DESKTOP_AUTO_SMARTPORT
(任意)パラメータ値 $ACCESS_VLAN=(1) を指定します。

CISCO_DOT1X_EASY_AUTO_SMARTPORT
(任意)パラメータ値 $ACCESS_VLAN=(1) を指定します。

CISCO_DOT1X_MAB_GUEST_AUTO_SMARTPORT
(任意)パラメータ値 $ACCESS_VLAN=(1) を指定します。

CISCO_DOT1X_MAB_TIMEOUT_AUTO_SMARTPORT
(任意)パラメータ $ACCESS_VLAN=(1) を指定します。

CISCO_DOT1X_AUTH_FAIL_AUTO_SMARTPORT
(任意)パラメータ値 $ACCESS_VLAN=(1) を指定します。

CISCO_DOT1X_CRITICAL_AUTO_SMARTPORT
(任意)パラメータ値 $CRITICAL_VLAN=(1) を指定します。

(任意) parameter=value $ から始まるデフォルト値を置き換えます。名前と値のペアをスペースで区切った形([<name1>=<value1> <name2>=<value2>...])で新しい値を入力します。デフォルト値はカッコ内に示されます。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show running-config

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次に、シスコ製スイッチと Cisco IP Phone をスイッチに接続するための 2 つの組み込み Auto Smartport マクロを使用する例を示します。次に、トランク インターフェイスのデフォルトの音声 VLAN、アクセス VLAN、およびネイティブ VLAN を変更する例を示します。

Switch# configure terminal
Switch(config)#!!!the next command modifies the access and voice vlans
Switch(config)#!!!for the built in Cisco IP phone auto smartport macro
Switch(config)# macro auto execute CISCO_PHONE_EVENT builtin CISCO_PHONE_AUTO_SMARTPORT ACCESS_VLAN=10 VOICE_VLAN=20
Switch(config)#
Switch(config)#!!!the next command modifies the Native vlan used for inter switch trunks
Switch(config)# macro auto execute CISCO_SWITCH_EVENT builtin CISCO_SWITCH_AUTO_SMARTPORT NATIVE_VLAN=10
Switch(config)#
Switch(config)#!!!the next command enables auto smart ports globally
Switch(config)# macro auto global processing cdp-fallback
Switch(config)#
Switch(config)# exit
 
Switch# !!!here's the running configuration of the interface connected
Switch# !!!to another Cisco Switch after the Macro is applied
Switch#
Switch# show running-config interface Gi1/0/1
Building configuration...
 
Current configuration : 284 bytes
!
interface gigabitethernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
macro description CISCO_SWITCH_EVENT
end
 

イベント トリガーの設定

MAB または 802.1x 認証を使用して Auto Smartport マクロをトリガーする場合は、RADIUS サーバから送信された Cisco AV ペア( auto-smart-port=event trigger )に対応するイベント トリガーを作成する必要があります。

イベント トリガーを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

shell trigger identifier description

イベント トリガー ID および説明を指定します。 ID の単語の間にはスペースやハイフンを含めないでください。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show shell triggers

スイッチ上のイベント トリガーを表示します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

no shell trigger identifier グローバル コンフィギュレーション コマンドを使用してイベント トリガーを削除します。

次に、RADIUS_MAB_EVENT という名前のユーザ定義イベント トリガーを組み込みマクロ CISCO_DOT1X_MAB_GUEST_AUTO_SMARTPORT にマップし、デフォルト VLAN を VLAN 10 に置き換える例と、設定を確認する例を示します。

a. デバイスを MAB 対応スイッチ ポートに接続します。

b. RADIUS サーバ上で、AV ペアを auto-smart-port =RADIUS_MAB_EVENT に設定します。

c. スイッチで、イベント トリガー RADIUS_MAB_EVENT を作成します。

d. スイッチは、RADIUSサーバからの AV ペア=RADIUS_MAB_EVENT 応答を認識し、マクロ CISCO_DOT1X_MAB_GUEST_AUTO_SMARTPORT を適用します。

Switch# configure terminal
Enter configuration commands, one per line.End with CNTL/Z.
Switch(config)# !!! create a user defined trigger and map
Switch(config)# !!! a system defined macro to it
Switch(config)# !!! first create the trigger event
Switch(config)# shell trigger RADIUS_MAB_EVENT MAC_AuthBypass Event
Switch(config)#
Switch(config)#!!! map a system defined macro to the trigger event
Switch(config)# macro auto execute RADIUS_MAB_EVENT builtin ?
CISCO_DOT1X_DESKTOP_AUTO_SMARTPORT
CISCO_DOT1X_EASY_AUTO_SMARTPORT
CISCO_DOT1X_MAB_GUEST_AUTO_SMARTPORT
CISCO_DOT1X_MAB_TIMEOUT_AUTO_SMARTPORT
CISCO_DOT1X_AUTH_FAIL_AUTO_SMARTPORT
CISCO_DOT1X_CRITICAL_AUTO_SMARTPORT
CISCO_AP_AUTO_SMARTPORT
CISCO_LWAP_AUTO_SMARTPORT
CISCO_PHONE_AUTO_SMARTPORT
CISCO_ROUTER_AUTO_SMARTPORT
CISCO_SWITCH_AUTO_SMARTPORT
LINE <cr>
Switch(config)# macro auto execute RADIUS_MAB_EVENT builtin CISCO_DOT1X_MAB_GUEST_AUTO_SMARTPORT ACCESS_VLAN=10
Switch(config)# exit
Switch# show shell triggers
User defined triggers
---------------------
Trigger Id: RADIUS_MAB_EVENT
Trigger description: MAC_AuthBypass Event
Trigger environment:
Trigger mapping function: CISCO_DOT1X_MAB_GUEST_AUTO_SMARTPORT
<output truncated>
 

次に、 show shell triggers 特権 EXEC コマンドを使用して、スイッチ ソフトウェアでイベント トリガーを表示する例を示します。

Switch# show shell triggers
 
User defined triggers
---------------------
Built-in triggers
-----------------
Trigger Id: CISCO_PHONE_EVENT
Trigger description: Event for ip-phone macro
Trigger environment: ACCESS_VLAN=1 VOICE_VLAN=2
Trigger mapping function: CISCO_PHONE_AUTO_SMARTPORT
 
Trigger Id: CISCO_ROUTER_EVENT
Trigger description: Event for router macro
Trigger environment: NATIVE_VLAN=1
Trigger mapping function: CISCO_ROUTER_AUTO_SMARTPORT
 
Trigger Id: CISCO_SWITCH_EVENT
Trigger description: Event for switch macro
Trigger environment: NATIVE_VLAN=1
Trigger mapping function: CISCO_SWITCH_AUTO_SMARTPORT
 
Trigger Id: CISCO_WIRELESS_AP_EVENT
Trigger description: Event for Wireless Access Point macro
Trigger environment: NATIVE_VLAN=1
Trigger mapping function: CISCO_AP_AUTO_SMARTPORT
 
Trigger Id: CISCO_WIRELESS_LIGHTWEIGHT_AP_EVENT
Trigger description: Event for Wireless Lightweight Access Point macro
Trigger environment: NATIVE_VLAN=1
Trigger mapping function: CISCO_LWAP_AUTO_SMARTPORT
 

次に、 show shell functions 特権 EXEC コマンドを使用してスイッチ ソフトウェアの組み込みマクロを表示する例を示します。

Switch# show shell functions
#User defined functions:
 
#Built-in functions:
function CISCO_AP_AUTO_SMARTPORT () {
if [[ $LINKUP -eq YES ]]; then
conf t
interface $INTERFACE
macro description $TRIGGER
switchport trunk encapsulation dot1q
switchport trunk native vlan $NATIVE_VLAN
switchport trunk allowed vlan ALL
switchport mode trunk
switchport nonegotiate
auto qos voip trust
mls qos trust cos
exit
end
fi
if [[ $LINKUP -eq NO ]]; then
conf t
interface $INTERFACE
no macro description
no switchport nonegotiate
no switchport trunk native vlan $NATIVE_VLAN
no switchport trunk allowed vlan ALL
no auto qos voip trust
no mls qos trust cos
if [[ $AUTH_ENABLED -eq NO ]]; then
no switchport mode
no switchport trunk encapsulation
fi
exit
end
fi
}
 
function CISCO_SWITCH_AUTO_SMARTPORT () {
if [[ $LINKUP -eq YES ]]; then
conf t
interface $INTERFACE
macro description $TRIGGER
auto qos voip trust
switchport trunk encapsulation dot1q
switchport trunk native vlan $NATIVE_VLAN
switchport trunk allowed vlan ALL
switchport mode trunk
exit
end
else
conf t
interface $INTERFACE
no macro description
no auto qos voip trust
no switchport mode trunk
no switchport trunk encapsulation dot1q
no switchport trunk native vlan $NATIVE_VLAN
no switchport trunk allowed vlan ALL
exit
end
fi
}
 
<output truncated>
 

Auto Smartport ユーザ定義マクロの設定

Cisco IOS シェルは、ユーザ定義の Auto Smartport マクロを設定するための基本的なスクリプト機能を提供します。これらのマクロには複数の行を含むことができ、どの CLI コマンドでも含めることができます。マクロ内で変数の置換、条件、関数、およびトリガーを定義することもできます。

ユーザ定義イベント トリガーをユーザ定義マクロにマップするには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

macro auto execute event trigger [parameter=value] { function contents }

イベント トリガーにマップするユーザ定義マクロを指定します。

{ function contents } トリガーに関連付けるユーザ定義マクロを指定します。マクロの内容を波カッコで囲んで入力します。左波カッコで IOS シェル コマンドを開始し、右波カッコでコマンドのグループ化を終了します。

(任意) parameter=value $ から始まるデフォルト値を置き換え、スペースで区切られた名前値のペア([<name1>=<value1> <name2>=<value2>...])の形式で新しい値を入力します。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show running-config

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次に、Cisco Digital Media Player(DMP)という名前のユーザ定義イベント トリガーをユーザ定義マクロにマップする例を示します。

a. DMP を 802.1X または MAB 対応のスイッチ ポートに接続します。

b. RADIUS サーバ上で、AV ペアを auto-smart-port =CISCO_DMP_EVENT に設定します。

c. スイッチ上で、イベント トリガー CISCO_DMP_EVENT を作成し、次のユーザ定義マクロ コマンドを入力します。

d. スイッチは、RADIUS サーバからの AV ペア=CISCO_DMP_EVENT 応答を認識し、このイベント トリガーに関連付けられているマクロを適用します。

Switch(config)# shell trigger CISCO_DMP_EVENT Cisco DMP player
Switch(config)# macro auto execute CISCO_DMP_EVENT {
if [[ $LINKUP -eq YES ]]; then
conf t
interface $INTERFACE
macro description $TRIGGER
switchport access vlan 1
switchport mode access
switchport port-security
switchport port-security maximum 1
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
spanning-tree portfast
spanning-tree bpduguard enable
exit
fi
if [[ $LINKUP -eq NO ]]; then
conf t
interface $INTERFACE
no macro description $TRIGGER
no switchport access vlan 1
if [[ $AUTH_ENABLED -eq NO ]]; then
no switchport mode access
fi
no switchport port-security
no switchport port-security maximum 1
no switchport port-security violation restrict
no switchport port-security aging time 2
no switchport port-security aging type inactivity
no spanning-tree portfast
no spanning-tree bpduguard enable
exit
fi
}
Switch(config)# end
 

 

表 13-2 サポート対象の Cisco IOS シェル キーワード

コマンド
説明

{

コマンドのグループ化を開始します。

}

コマンドのグループ化を終了します。

[[

条件付きコンストラクトとして使用します。

]]

条件付きコンストラクトとして使用します。

else

条件付きコンストラクトとして使用します。

-eq

条件付きコンストラクトとして使用します。

fi

条件付きコンストラクトとして使用します。

if

条件付きコンストラクトとして使用します。

then

条件付きコンストラクトとして使用します。

-z

条件付きコンストラクトとして使用します。

$

$ 文字で始まる変数はパラメータ値に置き換えられます。

#

コメント テキストを入力するには # 文字を使用します。

 

表 13-3 サポートされない Cisco IOS シェル予約済みキーワード

コマンド
説明

|

パイプライン

case

条件付きコンストラクト

esac

条件付きコンストラクト

for

ルーピング コンストラクト

function

シェル関数

in

条件付きコンストラクト

select

条件付きコンストラクト

time

パイプライン

until

ルーピング コンストラクト

while

ルーピング コンストラクト

スタティック Smartport マクロの設定

ここでは、スタティック Smartport マクロを設定し、イネーブルにする方法について説明します。

「デフォルトのスタティック Smartport 設定」

「スタティック Smartport コンフィギュレーションに関する注意事項」

「スタティック Smartport マクロの適用」

デフォルトのスタティック Smartport 設定

スイッチ上ではスタティック Smartport マクロはイネーブルになっていません。

 

表 13-4 デフォルトのスタティック Smartport マクロ

マクロ名1
説明

cisco-global

Rapid PVST+、ループ ガード、リンク ステート障害用のダイナミック ポート エラー回復をイネーブルにするには、このグローバル コンフィギュレーション マクロを使用します。

cisco-desktop

PC などのデスクトップ デバイスをスイッチ ポートに接続する場合、ネットワーク セキュリティと信頼性を高めるために、このインターフェイス コンフィギュレーション マクロを使用します。

cisco-phone

Cisco IP Phone を装備した PC などのデスクトップ デバイスをスイッチ ポートに接続する場合、この
インターフェイス コンフィギュレーション マクロを使用します。このマクロは、 cisco-desktop マクロの拡張機能で、同じセキュリティ機能と復元力機能を提供します。ただし、遅延に影響されやすい音声トラフィックを適切に処理するために、専用音声 VLAN が追加されています。

cisco-switch

アクセス スイッチとディストリビューション スイッチを接続する場合、または Small Form-Factor Pluggable(SFP)を使用して接続したアクセス スイッチの間で、このインターフェイス コンフィギュレーション マクロを使用します。

cisco-router

スイッチと WAN ルータを接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。

cisco-wireless

スイッチとワイヤレス アクセス ポイントを接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。

1.シスコのデフォルト SmartPort マクロは、スイッチで稼動するソフトウェアのバージョンによって異なります。

スタティック Smartport コンフィギュレーションに関する注意事項

スイッチまたはスイッチ インターフェイスにマクロをグローバルに適用しても、インターフェイスの既存の設定は維持されます。これは、差分設定に適用する場合に役立ちます。

構文エラーまたは設定エラーが原因でコマンドが失敗した場合でも、マクロは引き続き残りのコマンドを適用します。マクロを適用およびデバッグして、構文エラーまたは設定エラーを検出するには、 macro global trace macro-name グローバル コンフィギュレーション コマンド、または macro trace macro-name インターフェイス コンフィギュレーション コマンドを使用できます。

特定のインターフェイス タイプ固有の CLI コマンドもあります。設定を受け入れないインターフェイスにマクロを適用すると、マクロは構文チェックまたは設定チェックに失敗し、スイッチはエラー メッセージを返します。

インターフェイス範囲へのマクロの適用は、単一インターフェイスへのマクロの適用と同じです。インターフェイス範囲を使用すると、インターフェイス範囲内の各インターフェイスへマクロが順番に適用されます。1 つのインターフェイスでマクロ コマンドの実行に失敗しても、マクロは残りのインターフェイス上に適用されます。

スイッチまたはスイッチ インターフェイスにマクロを適用すると、マクロ名が自動的にスイッチまたはインターフェイスに追加されます。 show running-config ユーザ EXEC コマンドを使用して、適用されたコマンドおよびマクロ名を表示できます。

スタティック Smartport マクロの適用

スタティック SmartPort マクロを適用するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

show parser macro

スイッチ ソフトウェアに組み込まれたシスコのデフォルト スタティック SmartPort マクロを表示します。

ステップ 2

show parser macro name macro-name

適用する特定のマクロを表示します。

ステップ 3

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

macro global { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

マクロに定義されている個々のコマンドをスイッチに適用するには、 macro global apply macro-name を入力します。マクロを適用およびデバッグして、構文エラーまたは設定エラーを検出するには、 macro global trace macro-name を指定します。

parameter value キーワードを使用して、マクロに必要な値を加えます。 $ で始まるキーワードには、一意のパラメータ値が必要です。

macro global apply macro-name ? コマンドを使用すると、
マクロに必要な値のリストを表示できます。キーワード値を入力しないでマクロを適用すると、コマンドは無効になり適用されません。

(任意)スイッチに固有の一意のパラメータ値を指定します。キーワードの値のペアは、最大 3 つまで入力できます。パラメータ キーワードの照合では大文字と小文字が区別されます。対応する値は、一致するキーワードすべてを置き換えます。

ステップ 5

interface interface-id

(任意)インターフェイス コンフィギュレーション モードを開始し、マクロを適用するインターフェイスを指定します。

ステップ 6

default interface interface-id

(任意)指定のインターフェイスからすべての設定情報を消去します。

ステップ 7

macro { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

マクロに定義されている個々のコマンドをポートに適用するには、 macro global apply macro-name を入力します。マクロを適用およびデバッグして、構文エラーまたは設定エラーを検出するには、 macro global trace macro-name を指定します。

parameter value キーワードを使用して、マクロに必要な値を加えます。 $ で始まるキーワードには、一意のパラメータ値が必要です。

macro global apply macro-name ? コマンドを使用すると、
マクロに必要な値のリストを表示できます。キーワード値を入力しないでマクロを適用すると、コマンドは無効になり適用されません。

(任意)スイッチに固有の一意のパラメータ値を指定します。キーワードの値のペアは、最大 3 つまで入力できます。パラメータ キーワードの照合では大文字と小文字が区別されます。対応する値は、一致するキーワードすべてを置き換えます。

ステップ 8

end

特権 EXEC モードに戻ります。

ステップ 9

show running-config interface interface-id

マクロがインターフェイスに適用されたことを確認します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

マクロ内にある各コマンドの no バージョンを入力することによってのみ、スイッチ上のグローバル マクロ適用済みの設定を削除できます。ポート上のマクロ適用済みの設定を削除するには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを入力します。

次に、 cisco-desktop マクロを表示してそのマクロを適用し、インターフェイスのアクセス VLAN ID を 25 に設定する例を示します。

Switch# show parser macro cisco-desktop
--------------------------------------------------------------
Macro name : cisco-desktop
Macro type : default
 
# Basic interface - Enable data VLAN only
# Recommended value for access vlan (AVID) should not be 1
switchport access vlan $AVID
switchport mode access
 
# Enable port security limiting port to a single
# MAC address -- that of desktop
switchport port-security
switchport port-security maximum 1
 
# Ensure port-security age is greater than one minute
# and use inactivity timer
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
 
# Configure port as an edge network port
spanning-tree portfast
spanning-tree bpduguard enable
--------------------------------------------------------------
Switch#
Switch# configure terminal
Switch(config)# interface gigabitethernet1/0/4
Switch(config-if)# macro apply cisco-desktop $AVID 25
 

Auto Smartport マクロおよびスタティック Smartport マクロの表示

Auto SmartPort マクロおよびスタティック Smartport マクロを表示するには、 表 13-5 の特権 EXEC コマンドを 1 つまたは複数使用します。

 

表 13-5 Auto Smartport マクロとスタティック Smartport マクロを表示するためのコマンド

コマンド
目的

show parser macro

すべてのスタティック Smartport マクロを表示します。

show parser macro name macro-name

特定のスタティック Smartport マクロを表示します。

show parser macro brief

スタティック Smartport マクロ名を表示します。

show parser macro description [ interface interface-id ]

すべてのインターフェイスまたは指定されたインターフェイスの
スタティック Smartport マクロの説明を表示します。

show shell

Auto Smartport イベント トリガーとマクロに関する情報を表示します。