Catalyst 3750 スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)SED
EtherChannel の設定
EtherChannel の設定
発行日;2012/01/12 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

EtherChannel の設定

EtherChannel の概要

EtherChannel の概要

ポート チャネル インターフェイス

PAgP

PAgP モード

PAgP と他の機能との相互作用

LACP

LACP モード

LACP と他の機能との相互作用

EtherChannel の On モード

ロードバランシングおよび転送方式

EtherChannel およびスイッチ スタック

EtherChannel の設定

EtherChannel のデフォルト設定

EtherChannel 設定時の注意事項

レイヤ 2 EtherChannel の設定

レイヤ 3 EtherChannel の設定

ポート チャネル論理インターフェイスの作成

物理インターフェイスの設定

EtherChannel ロードバランシングの設定

PAgP 学習方式およびプライオリティの設定

LACP ホットスタンバイ ポートの設定

LACP システム プライオリティの設定

LACP ポート プライオリティの設定

EtherChannel、PAgP、および LACP ステータスの表示

EtherChannel の設定

この章では、Catalyst 3750 スイッチのレイヤ 2 およびレイヤ 3 ポートに EtherChannel を設定する方法について説明します。EtherChannel は、スイッチ、ルータ、サーバ間に耐障害性を備えた高速リンクを提供します。EtherChannel を使用して配線クローゼットとデータ センタ間の帯域幅を拡張したり、ボトルネックが発生しやすいネットワーク内の任意の場所に EtherChannel を配備できます。EtherChannel には、残りのリンク間で負荷を再分配し、リンク切断から自動的に回復する機能があります。リンクに障害が発生した場合、EtherChannel は仲介なしに、障害のあるリンクからチャネル内の残りのリンクにトラフィックをリダイレクトします。特に明記しないかぎり、 スイッチ という用語はスタンドアロン スイッチおよびスイッチ スタックを意味します。


) この章で使用されるコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「EtherChannel の概要」

「EtherChannel の設定」

「EtherChannel、PAgP、および LACP ステータスの表示」

EtherChannel の概要

ここでは、EtherChannel の機能について説明します。

「EtherChannel の概要」

「ポート チャネル インターフェイス」

「PAgP」

「LACP」

「EtherChannel の On モード」

「ロードバランシングおよび転送方式」

「EtherChannel およびスイッチ スタック」

EtherChannel の概要

EtherChannel は、単一の論理リンクにバンドルされた個々のファスト イーサネットまたはギガビット イーサネット リンクで構成されます(図34-1を参照)。

図34-1 EtherChannel の一般的な構成

 

EtherChannel は、スイッチ間またはスイッチとホスト間に、最大 800 Mbps(ファスト EtherChannel)または最大 8 Gbps(ギガビット EtherChannel)の全二重帯域幅を提供します。

各 EtherChannel には、最大 8 つの(設定に互換性のある)イーサネット ポートを含めることができます。各 EtherChannel 内のすべてのポートは、レイヤ 2 またはレイヤ 3 ポートのいずれかとして設定する必要があります。EtherChannel の数は48に制限されています。詳細については、「EtherChannel 設定時の注意事項」を参照してください。EtherChannel レイヤ 3 ポートは、ルーテッド ポートで構成されます。ルーテッド ポートは、 no switchport インターフェイス コンフィギュレーション コマンドを使用してレイヤ 3 モードに設定された物理ポートです。詳細については、 第 11 章「インターフェイス特性の設定」 を参照してください。

EtherChannel は、Port Aggregation Protocol(PAgP)、Link Aggregation Control Protocol(LACP)、または On の、いずれかのモードに設定できます。EtherChannel の両端で同じモードを設定します。

EtherChannel の片端を PAgP モードまたは LACP モードに設定すると、システムはアクティブにするポートを決定するため、チャネルの他端とネゴシエートします。互換性のないポートはサスペンドされます。

EtherChannel を on モードに設定した場合は、ネゴシエートは行われません。スイッチは
EtherChannel 内の互換性があるポートすべてをアクティブにします。チャネルの他端(他のスイッチ上)も on に設定されている必要があります。そうしないと、パケットを喪失する可能性があります。

EtherChannel はスタンドアロン スイッチ、スタック内の単一スイッチ、またはスタック内の複数のスイッチ(クロススタック EtherChannel とも呼ばれています)上に作成できます(図34-2および図34-3を参照)。

EtherChannel 内のリンクで障害が発生すると、障害リンク上でそれまで伝送されていたトラフィックは、その EtherChannel 内の別のリンクに移動します。スイッチのトラップがイネーブルになっている場合は、スイッチ、EtherChannel、および障害リンクを特定するトラップが送信されます。EtherChannel の 1 つのリンクに着信したブロードキャストおよびマルチキャスト パケットは、EtherChannel の別のリンクに戻らないようにブロックされます。

図34-2 単一スイッチ EtherChannel

 

図34-3 クロススタック EtherChannel

 

ポート チャネル インターフェイス

EtherChannel を作成すると、ポート チャネル論理インターフェイスも作成されます。

レイヤ 2 ポートの場合は、 channel-group インターフェイス コンフィギュレーション コマンドを使用して、ポート チャネル論理インターフェイスを動的に作成します。

また、 interface port-channel port-channel-number グローバル コンフィギュレーション コマンドを使用して、ポート チャネル論理インターフェイスを手動で作成することもできます。ただし、その場合、論理インターフェイスを物理ポートにバインドするには、 channel-group
channel-group-number
コマンドを使用する必要があります。 channel-group-number
port
- channel-numberと同じ値に設定したり、新しい値を使用したりすることができます。新しい値を使用すると、 channel-group コマンドによって新しいポート チャネルが動的に作成されます。

レイヤ 3 ポートの場合は、 interface port-channel グローバル コンフィギュレーション コマンド、およびそのあとに no switchport インターフェイス コンフィギュレーション コマンドを使用して、論理インターフェイスを手動で作成する必要があります。その後、 channel-group インターフェイス コンフィギュレーション コマンドを使用して、手動で EtherChannel にインターフェイスを割り当てます。

レイヤ 2 およびレイヤ 3 ポートのいずれの場合も、 channel-group コマンドを実行すると、物理ポートと論理ポートがバインドされます(図34-4を参照)。

各 EtherChannel には、1 ~48番のポート チャネル論理インターフェイスがあります。このポート チャネル インターフェイス番号は、 channel-group インターフェイス コンフィギュレーション コマンドで指定した番号に対応します。

図34-4 物理ポート、論理ポート チャネル、およびチャネル グループの関係

 

EtherChannel を設定したあとに、ポート チャネル インターフェイスの設定を変更すると、そのポート チャネル インターフェイスに割り当てられたすべての物理ポートの設定も変更されます。物理ポートの設定を変更した場合は、設定を適用したポートのみが影響を受けます。EtherChannel のすべてのポートのパラメータを変更するには、コンフィギュレーション コマンドをポート チャネル インターフェイスに適用します。たとえば、スパニングツリー コマンドまたはレイヤ 2 EtherChannel をトランクとして設定するコマンドなどです。

PAgP

Port Aggregation Protocol(PAgP; ポート集約プロトコル)はシスコ独自のプロトコルで、シスコ製スイッチと、PAgP に対応するためにライセンスを得たベンダーが認可したスイッチのみで動作します。PAgP を使用すると、イーサネット ポートで PAgP パケットを交換することにより、EtherChannel を自動的に作成できます。PAgP を使用できるのは、単一スイッチ EtherChannel 構成の場合のみです。クロススタック EtherChannel の場合は、PAgP をイネーブルにできません。詳細については、「EtherChannel 設定時の注意事項」を参照してください。

スイッチ スタックは PAgP を使用することによって、PAgP をサポートできるパートナーの識別情報、および各ポートの機能を学習します。次に、設定が類似している(スタック内の単一のスイッチ上の)ポートを、単一の論理リンク(チャネルまたは集約ポート)に動的にグループ化します。設定が類似しているポートをグループ化する場合の基準は、ハードウェア、管理、およびポート パラメータ制約です。たとえば、速度、デュプレックス モード、ネイティブ VLAN(仮想 LAN)、VLAN 範囲、トランキング ステータスおよびタイプが同じであるポートが PAgP によってグループ化されます。リンクが EtherChannel にグループ化されたあと、グループは PAgP によって単一のスイッチ ポートとしてスパニングツリーに追加されます。

PAgP モード

表34-1 に、 channel-group インターフェイス コンフィギュレーション コマンドでユーザが設定できる EtherChannel PAgP モードを示します。

 

表34-1 EtherChannel PAgP モード

モード
説明

auto

ポートをパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信した PAgP パケットに応答しますが、PAgP パケット ネゴシエーションを開始しません。この設定では、PAgP パケットの伝送が最小化されます。EtherChannel メンバーがスイッチ スタックのさまざまなスイッチに属している場合(クロススタック EtherChannel)、このモードはサポートされません。

desirable

ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートは PAgP パケットを送信し、他のインターフェイスとのネゴシエーションを開始します。EtherChannel メンバーがスイッチ スタック内で異なるスイッチに属している場合(クロススタック EtherChannel)、このモードはサポートされません。

スイッチ ポートは、 auto または desirable モードに設定されたパートナー ポートとのみ PAgP パケットを交換します。 on モードに設定されたポートは、PAgP パケットを交換しません。

auto および desirable モードの場合、ポートはパートナー ポートとネゴシエーションを行い、一定の基準に従って EtherChannel を形成できるかどうかを判別します。その基準とは、ポート速度、(レイヤ 2 EtherChannel の場合)トランキング ステート、VLAN 番号などです。

ポート間で PAgP モードが異なっていても、モードに互換性があれば EtherChannel を形成できます。次に例を示します。

desirable モードのポートは、 desirable または auto モードの別のポートと EtherChannel を形成できます。

auto モードのポートは、 desirable モードの別のポートと EtherChannel を形成できます。

auto モードのポートは、 auto モードの別のポートとは EtherChannel を形成することができません。どちらのポートも、PAgP ネゴシエーションを開始しないためです。

PAgP 機能を持つパートナーにスイッチが接続されている場合は、 non-silent キーワードを使用して、非サイレント動作を行うようにスイッチ ポートを設定できます。 auto または desirable モードの場合は、 non-silent を指定しないとサイレント モードになります。

PAgP 機能を備えていない、または備えていてもパケット送信量がわずかしかないデバイスにスイッチが接続されている場合は、サイレント モードを使用します。サイレント パートナーの例としては、トラフィックを生成しないファイル サーバやパケット アナライザがあります。この場合、サイレント パートナーに接続された物理ポート上で PAgP を稼働させると、このスイッチ ポートが動作しなくなります。ただし、サイレント設定を使用すると、PAgP が動作したり、チャネル グループにポートを接続したり、ポートの伝送に使用できます。

PAgP と他の機能との相互作用

Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)および Cisco Discovery Protocol(CDP)は、EtherChannel の物理ポートを使用してパケットを送受信します。トランク ポートは、番号が最小の VLAN 上で PAgP Protocol Data Unit(PDU; プロトコル データ ユニット)を送受信します。

レイヤ 2 EtherChannel では、チャネル内で最初に起動するポートが EtherChannel に MAC アドレスを提供します。このポートがバンドルから削除されると、バンドル内の他のポートの 1 つが EtherChannel に MAC アドレスを提供します。レイヤ 3 EtherChannel の場合は、( interface port-channel グローバル コンフィギュレーション コマンドを使用して)ポートが作成された直後に、スタック マスターから MAC アドレスが割り当てられます。

PAgP は、auto または desirable モードに設定され、PAgP がイネーブルである稼働状態のポートからのみ PAgP PDU を送受信します。

LACP

LACP は IEEE 802.3ad で定義されていて、シスコ製スイッチは IEEE 802.3ad プロトコルに準拠するスイッチ間のイーサネット チャネルを管理できます。LACP を使用すると、イーサネット ポート間で LACP パケットを交換することにより、EtherChannel を自動的に作成できます。

スイッチ スタックは LACP を使用することによって、LACP をサポートできるパートナーの識別情報、および各ポートの機能を学習します。次に、同一設定のポートを 1 つの論理リンク(チャネルまたは集約ポート)に動的にグループ化します。設定が類似しているポートをグループ化する場合の基準は、ハードウェア、管理、およびポート パラメータ制約です。たとえば、速度、デュプレックス モード、ネイティブ VLAN、VLAN 範囲、トランキング ステータスおよびタイプが同じであるポートが LACP によってグループ化されます。リンクが EtherChannel にグループ化されたあと、グループは LACP によって単一のスイッチ ポートとしてスパニングツリーに追加されます。

LACP モード

表34-2 に、 channel-group インターフェイス コンフィギュレーション コマンドで使用するユーザ設定可能な EtherChannel LACP モードを示します。

 

表34-2 EtherChannel LACP モード

モード
説明

active

ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートは LACP パケットを送信し、他のポートとのネゴシエーションを開始します。

passive

ポートをパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信した LACP パケットに応答しますが、LACP パケット ネゴシエーションを開始しません。この設定では、LACP パケットの伝送が最小化されます。

active および passive LACP モードの場合、ポートはパートナー ポートとネゴシエーションを行い、一定の基準に従って EtherChannel を形成できるかどうかを判別します。その基準とは、ポート速度、(レイヤ 2 EtherChannel の場合)トランキング ステート、VLAN 番号などです。

ポート間で LACP モードが異なっていても、モードに互換性があれば EtherChannel を形成できます。次に例を示します。

active モードのポートは、 active または passive モードの別のポートと EtherChannel を形成できます。

passive モードのポートは、 passive モードの別のポートとは EtherChannel を形成することができません。どちらのポートも、LACP ネゴシエーションを開始しないためです。

LACP と他の機能との相互作用

DTP および CDP は、EtherChannel の物理ポートを経由してパケットを送受信します。トランク ポートは、番号が最も小さい VLAN 上で LACP PDU を送受信します。

レイヤ 2 EtherChannel では、チャネル内で最初に起動するポートが EtherChannel に MAC アドレスを提供します。このポートがバンドルから削除されると、バンドル内の他のポートの 1 つが EtherChannel に MAC アドレスを提供します。レイヤ 3 EtherChannel の場合は、 interface port-channel グローバル コンフィギュレーション コマンドを使用してインターフェイスが作成された直後に、スタック マスターから MAC アドレスが割り当てられます。

LACP は、active または passive モードに設定され、LACP がイネーブルである稼働状態のポートからのみ LACP PDU を送受信します。

EtherChannel の On モード

EtherChannel の on モードは EtherChannel を手動で設定するために使用します。on モードでは、ポートはネゴシエーションなしで EtherChannel に参加します。 on モードは、リモート デバイスが PAgP または LACP をサポートしていない場合に役立ちます。on モードでは、リンクの両端のスイッチが on モードに設定されている場合のみ、EtherChannel を使用できます。

同一チャネル グループ内で、on モードに設定されたポートは、速度やデュプレックスなどのポート特性に互換性を持たせる必要があります。互換性のないポートは、on モードに設定されていてもサスペンドされます。


注意 on モードは注意して使用してください。これは手動設定であり、EtherChannel の両端のポートが同一の設定である必要があります。グループの設定を間違えると、パケットが失われたり、スパニングツリー ループが発生することがあります。

ロードバランシングおよび転送方式

EtherChannel は、フレーム内のアドレスに基づいて形成されたバイナリ パターンを部分的に縮小し、チャネル内の 1 つのリンクを選択する数値にすることによって、チャネル内のリンク間でトラフィックの負荷を分散させます。EtherChannel のロードバランシングには、MAC アドレスや IP アドレス、送信元アドレスや宛先アドレス、または送信元と宛先の両方のアドレスを使用できます。選択したモードは、スイッチ上で設定されているすべての EtherChannel に適用されます。ロードバランシングおよび転送方法を設定するには、 port-channel load-balance グローバル コンフィギュレーション コマンドを使用します。

送信元 MAC アドレス転送の場合、EtherChannel に転送されたパケットは、着信パケットの送信元 MAC アドレスに基づいてチャネル ポート間で分配されます。したがって、ロードバランシングを行うために、異なるホストからのパケットにはチャネル内の別のポート、同じホストからのパケットにはチャネル内の同じポートが使用されます。

宛先 MAC アドレス転送の場合、EtherChannel に転送されたパケットは、着信パケットに指定されている宛先ホストの MAC アドレスに基づいてチャネル ポート間で分配されます。したがって、同じ宛先へのパケットは同じポートを経由して転送され、異なる宛先へのパケットはチャネル内の別のポートを経由して送信されます。

送信元/宛先 MAC アドレス転送の場合、EtherChannel に転送されたパケットは、送信元および宛先の両方の MAC アドレスに基づいてチャネル ポート間で分配されます。この転送方式は、送信元 MAC アドレス転送方式と宛先 MAC アドレス転送方式の負荷分散を組み合わせたものです。特定のスイッチに対して送信元 MAC アドレス転送と宛先 MAC アドレス転送のいずれが適切であるかが不明な場合に使用できます。送信元/宛先 MAC アドレス転送の場合、ホスト A からホスト B、ホスト A からホスト C、およびホスト C からホスト B に送信されるパケットは、それぞれ異なるチャネル ポートを使用できます。

送信元 IP アドレスベース転送の場合、EtherChannel に転送されたパケットは、着信パケットの送信元 IP アドレスに基づいて EtherChannel ポート間で分配されます。したがって、ロードバランシングを行うために、異なる IP アドレスからのパケットにはチャネル内の別のポート、同じ IP アドレスからのパケットにはチャネル内の同じポートが使用されます。

宛先 IP アドレスベース転送の場合、EtherChannel に転送されたパケットは、着信パケットの宛先 IP アドレスに基づいて EtherChannel ポート間で分配されます。したがって、ロードバランシングを行うために、同じ送信元 IP アドレスから異なる宛先 IP アドレスに送信されるパケットは異なるチャネル ポートに送信される場合があります。ただし、異なる送信元 IP アドレスから同じ宛先 IP アドレスに送信されるパケットは、常に同じチャネル ポートに送信されます。

送信元/宛先 IP アドレスベース転送の場合、EtherChannel に転送されたパケットは、着信パケットの送信元および宛先の両方の IP アドレスに基づいて EtherChannel ポート間で分配されます。この転送方式は、送信元 IP アドレスベース転送方式と宛先 IP アドレスベース転送方式を組み合わせたものです。特定のスイッチに対して送信元 IP アドレスベース転送と宛先 IP アドレスベース転送のいずれが適切であるかが不明な場合に使用できます。この方式では、IP アドレス A から IP アドレス B に、IP アドレス A から IP アドレス C に、および IP アドレス C から IP アドレス B に送信されるパケットは、それぞれ異なるチャネル ポートを使用できます。

ロードバランシング方式ごとに利点が異なります。ロードバランシング方式は、ネットワーク内のスイッチの位置、および負荷分散が必要なトラフィックの種類に基づいて選択する必要があります。図34-5では、4 台のワークステーションで構成された EtherChannel がルータと通信しています。ルータは単一の MAC アドレスを持つデバイスであるため、スイッチ EtherChannel で送信元ベース転送を行うことにより、ルータが使用できる全帯域をスイッチが使用するようになります。ルータは、宛先ベース転送を行うように設定されます。このように設定すると、多数のワークステーションで、ルータ EtherChannel からのトラフィックが均等に分散されることが保証されるためです。

設定には最も柔軟なオプションを使用してください。たとえば、チャネル上のトラフィックが単一 MAC アドレスを宛先とする場合、宛先 MAC アドレスを使用すると、チャネル内の同じリンクが常に選択されます。送信元アドレスまたは IP アドレスを使用した方が、ロードバランシングの効率がよくなることがあります。

図34-5 負荷分散および転送方法

 

EtherChannel およびスイッチ スタック

EtherChannel に参加しているポートを持つスタック メンバーに障害が発生するか、またはこのスタック メンバーがスタックから脱退すると、スタック マスターはこのスタック メンバーのスイッチ ポートを EtherChannel から削除します。EtherChannel 内にポートが残っている場合、これらのポートは引き続き接続された状態を維持します。

既存のスタックにスイッチが追加されると、新しいスイッチはスタック マスターから実行コンフィギュレーションを受信し、EtherChannel 関連のスタック設定を使用して自身の設定を更新します。スタック メンバーは動作情報(動作中のポート リスト、およびチャネル メンバーであるポートのリスト)も受信します。

EtherChannel が設定された 2 つのスタックを結合すると、セルフループ ポートになります。スパニングツリーはこの状況を検出して、適宜に対応します。権利を獲得したスイッチ スタックでは PAgP または LACP 設定が変更されませんが、権利を獲得しなかったスイッチ スタックでは、スタックの再起動後に PAgP または LACP 設定が失われます。

PAgP を使用すると、スタック マスターが障害を起こすかスタックから脱退した場合、新しいスタック マスターが選択されます。EtherChannel の帯域幅が変更されないかぎり、スパニングツリーの再コンバージェンスは発生しません。新しいスタック マスターにより、スタック メンバーの設定とスタック マスターの設定が同期されます。古いスタック マスター上にあるポートが EtherChannel に含まれる場合を除き、PAgP 設定はスタック マスターの変更による影響を受けません。

LACP を使用すると、システム ID ではスタック マスターからのスタック MAC アドレスが使用され、スタック マスターが変わると、LACP システム ID が変わることがあります。LACP システム ID が変わると、EtherChannel 全体がフラップし、STP 再コンバージェンスが発生します。マスターのフェールオーバー中にスタック MAC アドレスを変えるかどうかを制御するには、 stack-mac persistent timer コマンドを使用します。

スイッチ スタックの詳細については、 第 5 章「スイッチ スタックの管理」 を参照してください。

EtherChannel の設定

ここでは、次の設定について説明します。

「EtherChannel のデフォルト設定」

「EtherChannel 設定時の注意事項」

「レイヤ 2 EtherChannel の設定」(必須)

「レイヤ 3 EtherChannel の設定」(必須)

「EtherChannel ロードバランシングの設定」(任意)

「PAgP 学習方式およびプライオリティの設定」(任意)

「LACP ホットスタンバイ ポートの設定」(任意)


) ポートが正しく設定されていることを確認してください。詳細については、「EtherChannel 設定時の注意事項」を参照してください。



) EtherChannel を設定したあとに、ポート チャネル インターフェイスの設定を変更すると、そのポート チャネル インターフェイスに割り当てられたすべての物理ポートの設定も変更されます。物理ポートの設定変更では、そのポートのみが変更されます。


EtherChannel のデフォルト設定

表34-3 に、EtherChannel のデフォルト設定を示します。

 

表34-3 EtherChannel のデフォルト設定

機能
デフォルト設定

チャネル グループ

割り当てなし

ポート チャネル論理インターフェイス

定義なし

PAgP モード

デフォルトなし

PAgP の学習方式

すべてのポートで集約ポート学習

PAgP プライオリティ

すべてのポートで 128

LACP モード

デフォルトなし

LACP の学習方式

すべてのポートで集約ポート学習

LACP ポート プライオリティ

すべてのポートで 32768

LACP システム プライオリティ

32768

LACP システム ID

LACP プライオリティおよびスタック MAC アドレス

ロードバランシング

スイッチの負荷分散は、着信パケットの送信元 MAC アドレスに基づいて行われます。

EtherChannel 設定時の注意事項

EtherChannel が正しく設定されていない場合、ネットワーク ループなどの問題を回避するために、一部の EtherChannel ポートが自動的にディセーブルになることがあります。設定上の問題を防ぐには、次の注意事項に従ってください。

スイッチ スタック上では、48を超える数の EtherChannel を設定しないでください。

同じタイプのイーサネット ポートを最大で 8 つ備えた PAgP EtherChannel を設定してください。

同じタイプのイーサネット ポートを最大で 16 個備えた LACP EtherChannel を設定してください。最大 8 つのポートをアクティブにしたり、スタンバイ モードにできます。

クロススタック EtherChannel で最大 2 つの 10 ギガビット イーサネット モジュール ポートを設定します。

EtherChannel 内の全ポートが、同じ速度および同じデュプレックス モードで動作するように設定してください。

EtherChannel のすべてのポートをイネーブルにしてください。 shutdown インターフェイス コンフィギュレーション コマンドを使用してディセーブル化された EtherChannel のポートは、リンク障害として処理され、トラフィックは EtherChannel の残りのポートのいずれかに転送されます。

グループを初めて作成したときは、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。次に示すパラメータのいずれかの設定を変更する場合は、グループ内のすべてのポートに関する設定も変更してください。

許可 VLAN リスト

各 VLAN のスパニングツリー パス コスト

各 VLAN のスパニングツリー ポート プライオリティ

スパニングツリーの PortFast 設定

ポートが複数の EtherChannel グループのメンバーにならないように設定してください。

Etherchannel を、PAgP モードおよび LACP モードの両方に設定しないでください。PAgP および LACP が稼働している複数の EtherChannel グループは、スタック内の同じスイッチまたは別のスイッチ上で共存できます。各 EtherChannel グループは PAgP または LACP のいずれかを実行できますが、相互運用はできません。

EtherChannel の一部として Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)宛先ポートを設定しないでください。

EtherChannel の一部としてセキュア ポートを設定したり、その逆の設定を行わないでください。

EtherChannel の一部として、プライベート VLAN を設定しないでください。

EtherChannel のアクティブ メンバーまたは未アクティブ メンバーのポートは IEEE 802.1x ポートとして設定しないでください。EtherChannelポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。


) Cisco IOS Release 12.2(18)SE 以前のソフトウェア リリースでは、EtherChannel のアクティブでないポートで IEEE 802.1x がイネーブルの場合、ポートは EtherChannel に参加しません。


EtherChannel がスイッチ インターフェイスに設定されている場合、インターフェイスから
EtherChannel コンフィギュレーションを削除してから dot1x system-auth-control グローバル コンフィギュレーション コマンドを使用してスイッチで IEEE 802.1x をグローバルにイネーブルにします。

レイヤ 2 EtherChannel の場合

EtherChannel 内の全ポートを同じ VLAN に割り当てるか、またはトランクとして設定してください。複数のネイティブ VLAN に接続されるポートは、EtherChannel を形成することができません。

トランク ポートから EtherChannel を設定する場合は、すべてのトランクでトランキング モード(ISL または IEEE 802.1Q)が同じであることを確認してください。EtherChannel ポートでトランク モードが統一されていない場合は、予想外の結果を招くことがあります。

EtherChannel がサポートする VLAN の許容範囲は、トランキング レイヤ 2 EtherChannel 内の全ポートで同じです。VLAN の許容範囲が同じでない場合は、PAgP が auto モードまたは desirable モードに設定されていても、ポートは EtherChannel を形成しません。

ポートのスパニングツリー パス コストが異なっていても、他の設定条件に矛盾がなければ、EtherChannel を形成できます。異なるスパニングツリー パス コストを設定すること自体は、EtherChannel 形成の支障にはなりません。

レイヤ 3 EtherChannel の場合は、レイヤ 3 アドレスをチャネル内の物理ポートでなく、ポート チャネル論理インターフェイスに割り当ててください。

クロススタック EtherChannel 設定の場合は、EtherChannel 用のすべてのポートが LACP 用に設定されているか、 channel-group channel-group-number mode on インターフェイス コンフィギュレーション コマンドでチャネル グループに含まれるように手動設定されているかを確認します。PAgP プロトコルは、クロススタック EtherChannel ではサポートされません。

クロススタック EtherChannel が設定されていて、スイッチ スタックが分割されている場合、ループおよび転送が正しく動作しないことがあります。

レイヤ 2 EtherChannel の設定

レイヤ 2 EtherChannel を設定するには、 channel-group インターフェイス コンフィギュレーション コマンドを使用して、チャネル グループにポートを割り当てます。このコマンドにより、ポート チャネル論理インターフェイスが自動的に作成されます。

auto モードか desirable モードのポートで PAgP をイネーブルにした場合は、 on モードか LACP モードに再設定してから、このポートをクロススタック EtherChannel に追加する必要があります。PAgP では、クロススタック EtherChannel がサポートされません。

レイヤ 2 EtherChannel にレイヤ 2 イーサネット ポートを割り当てるには、イネーブル EXEC モードで次の手順を実行します。この手順は必須です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

物理ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

有効なインターフェイスは物理ポートなどです。

PAgP EtherChannel の場合、同一タイプ、同一速度のポートを 8 つまで同一グループに設定できます。

LACP EtherChannel の場合は、同一タイプのイーサネット ポートを 16 個まで設定できます。最大 8 つのポートをアクティブにしたり、スタンバイ モードにできます。

ステップ 3

switchport mode { access | trunk }

switchport access vlan vlan-id

全ポートをスタティック アクセス ポートとして同じ VLAN に割り当てるか、またはトランクとして設定します。

ポートをスタティック アクセス ポートとして設定する場合は、ポートを 1 つの VLAN にのみ割り当ててください。指定できる範囲は 1 ~ 4094 です。

ステップ 4

channel-group channel -group-number mode { auto [ non-silent ] | desirable [ non-silent ] | on } | { active | passive }

ポートをチャネル グループに割り当て、PAgP または LACP モードを指定します。

channel-group-number の範囲は 1 ~ 48です。

mode には、次のキーワードのいずれかを選択します。

auto PAgP デバイスが検出された場合にのみ、PAgP をイネーブルにします。ポートをパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信した PAgP パケットに応答しますが、PAgP パケット ネゴシエーションを開始しません。EtherChannel メンバーがスイッチ スタック内で異なるスイッチに属している場合、このキーワードはサポートされません。

desirable PAgP を無条件でイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートは PAgP パケットを送信し、他のインターフェイスとのネゴシエーションを開始します。EtherChannel メンバーがスイッチ スタック内で異なるスイッチに属している場合、このキーワードはサポートされません。

on PAgP や LACP を使用せずに、ポートを強制的にチャネル化します。 on モードでは、 on モードのポート グループが on モードの別のポート グループに接続されている場合のみ、EtherChannel を使用することができます。

non-silent (任意)PAgP 対応のパートナーに接続されたスイッチのポートが auto または desirable モードの場合に、非サイレント動作を行うようにこのポートを設定します。 non-silent を指定しなかった場合は、サイレントが指定されたものとみなされます。サイレント設定は、ファイル サーバまたはパケット アナライザに接続する場合に使用します。この設定を使用すると、PAgP が動作したり、チャネル グループにポートを接続したり、ポートを伝送に使用できます。

active ― LACP デバイスが検出された場合のみ、LACP をイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートは LACP パケットを送信し、他のインターフェイスとのネゴシエーションを開始します。

passive ポートで LACP をイネーブルにしてパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信した LACP パケットに応答しますが、LACP パケット ネゴシエーションを開始しません。

スイッチとパートナー間で互換性のあるモードの詳細については、「PAgP モード」および「LACP モード」を参照してください。

ステップ 5

end

イネーブル EXEC モードに戻ります。

ステップ 6

show running-config

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

EtherChannel グループからポートを削除するには、 no channel-group インターフェイス コンフィギュレーション コマンドを使用します。

次に、スタック内の 1 つのスイッチに EtherChannelを設定する例を示します。2 つのポートは、VLAN 10 のスタティック アクセス ポートとして、PAgP モードが desirable であるチャネル 5 に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode desirable non-silent
Switch(config-if-range)# end
 

次に、スタック内の 1 つのスイッチに EtherChannelを設定する例を示します。2 つのポートは、VLAN 10 のスタティック アクセス ポートとして、LACP モードが active であるチャネル 5 に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode active
Switch(config-if-range)# end
 

次に、クロススタック EtherChannel を設定する例を示します。この例では LACP パッシブ モードを使用し、スタック メンバー 2 の 2 つのポートとスタック メンバー 3 の 1 つのポートを、VLAN 10 のスタティック アクセス ポートとしてチャネル 5 に割り当てます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/4 -5
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode active
Switch(config-if-range)# exit
Switch(config)# interface gigabitethernet3/0/3
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10
Switch(config-if)# channel-group 5 mode active
Switch(config-if)# exit

レイヤ 3 EtherChannel の設定

レイヤ 3 EtherChannel を設定するには、ポート チャネル論理インターフェイスを作成し、そのポート チャネルにイーサネット ポートを組み込みます。次に設定方法を説明します。

ポート チャネル論理インターフェイスの作成

レイヤ 3 EtherChannel を設定する場合、まず interface port-channel グローバル コンフィギュレーション コマンドを使用し、ポート チャネル論理インターフェイスを手動で作成しなければなりません。次に、 channel-group インターフェイス コンフィギュレーション コマンドを使用して論理インターフェイスをチャネル グループに配置します。


) 物理ポートから EtherChannel に IP アドレスを移動するには、物理ポートから IP アドレスを削除してから、その IP アドレスをポート チャネル インターフェイス上で設定する必要があります。


レイヤ 3 EtherChannel 用のポート チャネル インターフェイスを作成するには、イネーブル EXEC モードで次の手順を実行します。この手順は必須です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel port- channel-number

ポート チャネル論理インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

port - channel-number の範囲は 1 ~ 48 です。

ステップ 3

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 4

ip address ip-address mask

EtherChannel に IP アドレスおよびサブネット マスクを割り当てます。

ステップ 5

end

イネーブル EXEC モードに戻ります。

ステップ 6

show etherchannel channel-group-number detail

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ステップ 8

レイヤ 3 EtherChannel にイーサネット ポートを割り当てます。詳細については、「物理インターフェイスの設定」を参照してください。

ポート チャネルを削除するには、 no interface port-channel port-channel-number グローバル コンフィギュレーション コマンドを使用します。

次に、論理ポート チャネル 5 を作成し、IP アドレスとして 172.10.20.10 を割り当てる例を示します。

Switch# configure terminal
Switch(config)# interface port-channel 5
Switch(config-if)# no switchport
Switch(config-if)# ip address 172.10.20.10 255.255.255.0
Switch(config-if)# end

物理インターフェイスの設定

レイヤ 3 EtherChannel にイーサネット ポートを割り当てるには、イネーブル EXEC モードで次の手順を実行します。この手順は必須です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

物理ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

有効なインターフェイスは物理ポートなどです。

PAgP EtherChannel の場合、同一タイプ、同一速度のポートを 8 つまで同一グループに設定できます。

LACP EtherChannel の場合は、同一タイプのイーサネット ポートを 16 個まで設定できます。最大 8 つのポートをアクティブにしたり、スタンバイ モードにできます。

ステップ 3

no ip address

この物理ポートに割り当てられている IP アドレスをすべて削除します。

ステップ 4

no switchport

ポートをレイヤ 3 モードにします。

ステップ 5

channel-group channel -group-number mode { auto [ non-silent ] | desirable [ non-silent ] | on } | { active | passive }

ポートをチャネル グループに割り当て、PAgP または LACP モードを指定します。

channel-group-number の範囲は 1 ~ 48 です。この番号は、「ポート チャネル論理インターフェイスの作成」で設定した port-channel-number (論理ポート)と同一である必要があります。

mode には、次のキーワードのいずれかを選択します。

auto ― PAgP デバイスが検出された場合のみ、PAgP をイネーブルにします。ポートをパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信した PAgP パケットに応答しますが、PAgP パケット ネゴシエーションを開始しません。EtherChannel メンバーがスイッチ スタック内で異なるスイッチに属している場合、このキーワードはサポートされません。

desirable ― 無条件に、PAgP をイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートは PAgP パケットを送信し、他のインターフェイスとのネゴシエーションを開始します。EtherChannel メンバーがスイッチ スタック内で異なるスイッチに属している場合、このキーワードはサポートされません。

on ― PAgP や LACP を使用せずに、ポートを強制的にチャネル化します。 on モードでは、 on モードのポート グループが on モードの別のポート グループに接続されている場合のみ、EtherChannel を使用することができます。

non-silent ― (任意)PAgP 対応のパートナーに接続されたスイッチのポートが auto または desirable モードの場合に、非サイレント動作を行うようにこのポートを設定します。
non-silent
を指定しなかった場合は、サイレントが指定されたものとみなされます。サイレント設定は、ファイル サーバまたはパケット アナライザに接続する場合に使用します。この設定を使用すると、PAgP が動作したり、チャネル グループにポートを接続したり、ポートを伝送に使用できます。

active ― LACP デバイスが検出された場合のみ、LACP をイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートは LACP パケットを送信し、他のインターフェイスとのネゴシエーションを開始します。

passive ポートで LACP をイネーブルにしてパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信した LACP パケットに応答しますが、LACP パケット ネゴシエーションを開始しません。

スイッチとパートナー間で互換性のあるモードの詳細については、「PAgP モード」および「LACP モード」を参照してください。

ステップ 6

end

イネーブル EXEC モードに戻ります。

ステップ 7

show running-config

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次に、EtherChannel を設定する例を示します。2 つのポートは、LACP モードが active であるチャネル 5 に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# no ip address
Switch(config-if-range)# no switchport
Switch(config-if-range)# channel-group 5 mode active
Switch(config-if-range)# end
 

次に、クロススタック EtherChannel を設定する例を示します。スタック メンバー 2 の 2 つのポートとスタック メンバー 3 の 1 つのポートは、LACP アクティブ モードでチャネル 7 に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/4 -5
Switch(config-if-range)# no ip address
Switch(config-if-range)# no switchport
Switch(config-if-range)# channel-group 7 mode active
Switch(config-if-range)# exit
Switch(config)# interface gigabitethernet3/0/3
Switch(config-if)# no ip address
Switch(config-if)# no switchport
Switch(config-if)# channel-group 7 mode active
Switch(config-if)# exit

EtherChannel ロードバランシングの設定

ここでは、送信元ベースまたは宛先ベースの転送方法を使用し、EtherChannel のロードバランシングを設定する方法について説明します。詳細については、「ロードバランシングおよび転送方式」を参照してください。

EtherChannel のロードバランシングを設定するには、イネーブル EXEC モードで次の手順を実行します。この手順は任意です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-channel load-balance { dst-ip | dst-mac | src-dst-ip | src-dst-mac | src-ip | src-mac }

EtherChannel のロードバランシング方法を設定します。

デフォルトは src-mac です。

次のいずれかの負荷分散方式を選択します。

dst-ip ― 宛先ホスト IP アドレスに基づいて負荷分散を行います。

dst-mac ― 着信パケットの宛先ホスト MAC アドレスに基づいて負荷分散を行います。

src-dst-ip ― 送信元/宛先ホスト IP アドレスに基づいて負荷分散を行います。

src-dst-mac ― 送信元/宛先ホスト MAC アドレスに基づいて負荷分散を行います。

src-ip ― 送信元ホスト IP アドレスに基づいて負荷分散を行います。

src-mac ― 着信パケットの送信元 MAC アドレスに基づいて、負荷分散を行います。

ステップ 3

end

イネーブル EXEC モードに戻ります。

ステップ 4

show etherchannel load-balance

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

EtherChannel のロードバランシングをデフォルト設定に戻すには、 no port-channel load-balance グローバル コンフィギュレーション コマンドを使用します。

PAgP 学習方式およびプライオリティの設定

ネットワーク デバイスは PAgP の物理ラーナーまたは集約ポート ラーナーとして分類されます。物理ポートでアドレスを学習し、その知識に基づいて伝送を指示するデバイスが物理ラーナーです。集約(論理)ポートでアドレスを学習するデバイスは、集約ポート ラーナーです。学習方式はリンクの両端で同一に設定する必要があります。

デバイスとそのパートナーが両方とも集約ポート ラーナーである場合、これらは論理ポート チャネルのアドレスを学習します。このデバイスは EtherChannel のポートのいずれかを使用し、送信元にパケットを送信します。集約ポート学習の場合、どの物理ポートにパケットが着信するかは重要ではありません。

PAgP は、パートナー デバイスが物理ラーナーになる時期、論理デバイスが集約ポート ラーナーになる時期を自動的に検出することはできません。したがって、物理ポートを使用してアドレスを学習する場合は、ローカル デバイスに手動で学習方式を設定する必要があります。負荷分散方式を送信元ベースに設定して、指定された送信元 MAC アドレスが常に同じ物理ポートに送信されるようにする必要もあります。

グループ内の 1 つのポートですべての伝送を行うように設定して、他のポートをホット スタンバイに使用することもできます。選択された 1 つのポートでハードウェア信号が検出されなくなった場合は、数秒以内にグループ内の未使用のポートに切り替えて動作できます。あるポートが常にパケット伝送に選択されるように設定するには、 pagp port-priority インターフェイス コンフィギュレーション コマンドを使用してプライオリティを変更します。プライオリティが高いほど、そのポートが選択される可能性が高まります。


physical-portキーワードが CLI(コマンドライン インターフェイス)で用意されている場合でも、スイッチは集約ポートでのみアドレス学習を実行できます。pagp learn-method コマンドおよび pagp port-priority コマンドは、スイッチ ハードウェアに影響を及ぼしませんが、Catalyst 1900 スイッチなど、物理ポートによるアドレス学習のみをサポートするデバイスとの PAgP インターオペラビリティを実現するのに必要です。

Catalyst 3750 スイッチに対するリンクの相手方が物理ラーナー(Catalyst 1900 シリーズ スイッチなど)である場合は、pagp learn-method physical-port インターフェイス コンフィギュレーション コマンドを使用して、Catalyst 3750 スイッチを物理ポート ラーナーとして設定することを推奨します。送信元 MAC アドレスに基づいて負荷分散方式を設定するには、port-channel load-balance src-macグローバル コンフィギュレーション コマンドを使用します。この設定により、送信元アドレスの学習元である EtherChannel 内の同じポートを使用して、パケットが Catalyst 1900 スイッチに送信されます。pagp learn-method コマンドは、この場合にのみ使用してください。


スイッチを PAgP 物理ポート ラーナーとして設定し、バンドル内の同じポートがパケット送信用として選択されるようにプライオリティを調整するには、イネーブル EXEC モードで次の手順を実行します。この手順は任意です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

伝送用のポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

pagp learn-method physical-port

PAgP 学習方式を選択します。

デフォルトでは、 aggregation-port learning が選択されています。これにより、EtherChannel 内のいずれかのポートを使用して、パケットが送信元に送信されます。集約ポート学習の場合、どの物理ポートにパケットが着信するかは重要ではありません。

物理ラーナーである別のスイッチに接続するには、 physical-port を選択します。 port-channel load-balance グローバル コンフィギュレーション コマンドは、必ず src-mac に設定してください(EtherChannel ロードバランシングの設定を参照)。

学習方式はリンクの両端で同一に設定する必要があります。

ステップ 4

pagp port-priority priority

選択したポートがパケット伝送用として選択されるように、プライオリティを割り当てます。

priority の範囲は 0 ~ 255 です。デフォルト値は 128 です。プライオリティが高いほど、ポートが PAgP 伝送に使用される可能性が高まります。

ステップ 5

end

イネーブル EXEC モードに戻ります。

ステップ 6

show running-config

または

show pagp channel-group-number internal

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

プライオリティをデフォルト設定に戻すには、 no pagp port-priority インターフェイス コンフィギュレーション コマンドを使用します。学習方式をデフォルト設定に戻すには、 no pagp learn-method インターフェイス コンフィギュレーション コマンドを使用します。

LACP ホットスタンバイ ポートの設定

LACP がイネーブルの場合、チャネル内に最大数の LACP 対応ポートを設定しようとします(最大 16 ポート)。同時にアクティブにできる LACP リンクは 8 つのみです。これ以上のリンクはソフトウェアによってホットスタンバイ モードになります。アクティブ リンクの 1 つが非アクティブになると、代わりにホットスタンバイ モードになっているリンクがアクティブになります。

EtherChannel グループに 8 リンクより多く設定されている場合、LACP プライオリティに基づいて、アクティブにするホットスタンバイ ポートがソフトウェアによって自動的に決定されます。ソフトウェアは LACP が動作するシステム間のリンクごとに、次の要素(プライオリティ順)からなる一意のプライオリティを割り当てます。

LACP システム プライオリティ

システム ID(スイッチ MAC アドレス)

LACP ポート プライオリティ

ポート番号

プライオリティを比較する場合、値が小さいほどプライオリティは大きくなります。ハードウェアの制限により互換性のあるポートの一部を集約できない場合は、プライオリティによって、スタンバイ モードにする必要があるポートが決定されます。

どのポートがアクティブであり、どのポートがホット スタンバイであるかは、2 つのステップで判断されます。まず、システム プライオリティとシステム ID の数値が低いシステムが判断を行います。次にそのシステムは、ポート プライオリティとポート番号の値に基づき、アクティブなポートとホット スタンバイになっているポートを判断します。他のシステムのポートプライオリティとポート番号の値は使用されません。

LACP システム プライオリティおよび LACP ポート プライオリティのデフォルト値を変更して、ソフトウェアによるアクティブおよびスタンバイ リンクの選択方法を変更できます。詳細については、「LACP システム プライオリティの設定」および「LACP ポート プライオリティの設定」を参照してください。

LACP システム プライオリティの設定

lacp system-priorityグローバル コンフィギュレーション コマンドを使用して、LACP で使用可能なすべての EtherChannel にシステム プライオリティを設定できます。各 LACP 設定チャネルにはシステム プライオリティを設定できません。この値をデフォルトから変更すると、アクティブおよびスタンバイ リンクの選択方法を変更できます。

ホットスタンバイ モードのポートを確認するには、 show etherchannel summary イネーブル EXEC コマンドを使用します(ホットスタンバイ モードのポートには H ポートステート フラグが付加されます)。

LACP システム プライオリティを設定するには、イネーブル EXEC モードで次の手順を行います。この手順は任意です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

lacp system-priority priority

LACP システム プライオリティを設定します。

priority の範囲は 1 ~ 65535 です。デフォルト値は 32768 です。

値が小さいほど、システム プライオリティは高くなります。

ステップ 3

end

イネーブル EXEC モードに戻ります。

ステップ 4

show running-config

または

show lacp sys-id

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

LACP システム プライオリティをデフォルト値に戻すには、 no lacp system-priority グローバル コンフィギュレーション コマンドを使用します。

LACP ポート プライオリティの設定

すべてのポートは、デフォルトで同じポート プライオリティに設定されています。ローカル システムのシステム プライオリティおよびシステム ID の値がリモート システムよりも小さい場合は、LACP EtherChannel ポートのポート プライオリティをデフォルトよりも小さな値に変更して、最初にアクティブになるホットスタンバイ リンクを変更できます。ポート番号が小さなホットスタンバイ ポートほど、先にチャネル内でアクティブになります。ホットスタンバイ モードのポートを確認するには、 show etherchannel summary イネーブル EXEC コマンドを使用します(ホットスタンバイ モードのポートには H ポートステート フラグが付加されます)。


) LACP が互換性のあるすべてのポートを集約できない場合(たとえば、リモート システムのハードウェア上の制限など)、EtherChannel にアクティブに含められないすべてのポートはホット スタンバイ ステートとなり、チャネル ポートのいずれかが故障した場合のみ使用されます。


LACP ポート プライオリティを設定するには、イネーブル EXEC モードで次の手順を行います。この手順は任意です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

lacp port-priority priority

LACP ポート プライオリティを設定します。

priority の範囲は 1 ~ 65535 です。デフォルト値は 32768 です。値が小さいほど、ポートが LACP 伝送に使用される可能性が高まります。

ステップ 4

end

イネーブル EXEC モードに戻ります。

ステップ 5

show running-config

または

show lacp [ channel-group-number ] internal

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

LACP ポート プライオリティをデフォルト値に戻すには、 no lacp port-priority インターフェイス コンフィギュレーション コマンドを使用します。

EtherChannel、PAgP、および LACP ステータスの表示

EtherChannel、PAgP、および LACP ステータス情報を表示するには、 表34-4 に記載されたイネーブル EXEC コマンドを使用します。

 

表34-4 EtherChannel、PAgP、および LACP ステータスを表示するためのコマンド

コマンド
説明

show etherchannel [ channel-group-number { detail | port | port-channel | protocol | summary }] { detail | load-balance | port | port-channel | protocol | summary }

EtherChannel 情報を簡潔、詳細に、1 行のサマリー形式で表示します。さらに、ロードバランスまたはフレーム分散方式、ポート、ポート チャネル、プロトコル情報も表示します。

show pagp [ channel-group-number ] { counters | internal | neighbor }

トラフィック情報、内部 PAgP 設定、近接情報などの PAgP 情報を表示します。

show lacp [channel-group-number] {counters | internal | neighbor}

トラフィック情報、内部 LACP 設定、近接情報などの LACP 情報を表示します。

PAgP チャネルグループ情報およびトラフィック カウンタをクリアするには、 clear pagp { channel-group-number counters | counters }イネーブル EXEC コマンドを使用します。

LACP チャネルグループ情報およびトラフィック カウンタをクリアするには、 clear lacp { channel-group-number counters | counters }イネーブル EXEC コマンドを使用します。

出力内のフィールドについては、 このリリースのコマンド リファレンス を参照してください。

EtherChannel をダウンストリーム インターフェイスとして設定しないでください。

インターフェイス gi0/1 ~ gi0/16 のみが特定のリンク ステート グループ内のダウンストリーム ポートとして設定できます。

インターフェイス gi0/19 ~ gi0/24 のみが特定のリンク ステート グループ内のアップストリーム ポートとして設定できます。