Catalyst 3750 スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.1(19)EA1
EtherChannelの設定
EtherChannelの設定
発行日;2012/01/09 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

EtherChannelの設定

EtherChannelの概要

EtherChannelの概要

ポート チャネル インターフェイス

PAgP

PAgPモード

PAgPと他の機能との相互作用

LACP

LACPモード

LACPと他の機能との相互作用

ロードバランシングおよび転送方式

EtherChannelおよびスイッチ スタック

EtherChannelの設定

EtherChannelのデフォルト設定

EtherChannel設定時の注意事項

レイヤ2 EtherChannelの設定

レイヤ3 EtherChannelの設定

ポート チャネル論理インターフェイスの作成

物理インターフェイスの設定

EtherChannelロードバランシングの設定

PAgP学習方式およびプライオリティの設定

LACPホットスタンバイ ポートの設定

LACPシステム プライオリティの設定

LACPポート プライオリティの設定

EtherChannel、PAgP、およびLACPステータスの表示

EtherChannelの設定

この章では、Catalyst 3750スイッチのレイヤ2およびレイヤ3ポートにEtherChannelを設定する方法について説明します。EtherChannelは、スイッチ、ルータ、サーバ間にフォールトトレラントな高速リンクを提供します。EtherChannelを使用して配線クローゼットとデータ センタ間の帯域幅を拡張したり、ボトルネックが発生しやすいネットワーク内の任意の場所にEtherChannelを配置することができます。EtherChannelには、残りのリンク間で負荷を再分配し、リンク切断から自動的に回復する機能があります。リンクに障害が発生した場合、EtherChannelは仲介なしに、障害のあるリンクからチャネル内の残りのリンクにトラフィックをリダイレクトします。特に明記しないかぎり、 スイッチ という用語はスタンドアロン スイッチおよびスイッチ スタックを意味します。


) この章で使用されるコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「EtherChannelの概要」

「EtherChannelの設定」

「EtherChannel、PAgP、およびLACPステータスの表示」

EtherChannelの概要

ここでは、EtherChannelの機能について説明します。

「EtherChannelの概要」

「ポート チャネル インターフェイス」

「PAgP」

「LACP」

「ロードバランシングおよび転送方式」

「EtherChannelおよびスイッチ スタック」

EtherChannelの概要

EtherChannelは、単一の論理リンクにバンドルされた個々のファスト イーサネットまたはギガビット イーサネット リンクで構成されます(図 30-1を参照)。

図 30-1 EtherChannelの一般的な構成

 

EtherChannelは、スイッチ間またはスイッチとホスト間に、最大800 Mbps(Fast EtherChannel)または最大8 Gbps(Gigabit EtherChannel)の全二重帯域幅を提供します。

各EtherChannelには、最大8つの(設定に互換性のある)イーサネット ポートを含めることができます。各EtherChannel内のすべてのポートは、レイヤ2またはレイヤ3ポートのいずれかとして設定する必要があります。Catalyst 3750スイッチのEtherChannel数は、最大で12です。詳細については、「EtherChannel設定時の注意事項」を参照してください。EtherChannelレイヤ3ポートは、ルーテッド ポートで構成されます。ルーテッド ポートは、 no switchport インターフェイス コンフィギュレーション コマンドを使用してレイヤ3モードに設定された物理ポートです。詳細については、 第11章「インターフェイス特性の設定」 を参照してください。

EtherChannelはスタンドアロン スイッチ、スタック内の単一スイッチ、またはスタック内の複数のスイッチ(別名Cross-Stack EtherChannel)上に作成できます(図 30-2および図 30-3を参照)。

EtherChannel内のリンクで障害が発生すると、障害リンク上でそれまで伝送されていたトラフィックがそのEtherChannel内の残りのリンクに切り替えられます。障害時には、スイッチ、EtherChannel、障害リンクを特定するトラップが送信されます。EtherChannelの1つのリンクに着信したブロードキャストおよびマルチキャスト パケットが、EtherChannelの別のリンクに戻されることはありません。

図 30-2 単一スイッチEtherChannel

 

図 30-3 Cross-Stack EtherChannel

 

ポート チャネル インターフェイス

EtherChannelを作成すると、ポート チャネル論理インターフェイスも作成されます。

レイヤ2ポートの場合は、 channel-group インターフェイス コンフィギュレーション コマンドを使用して、ポート チャネル論理インターフェイスを動的に作成します。

また、 interface port-channel port-channel-number グローバル コンフィギュレーション コマンドを使用して、ポート チャネル論理インターフェイスを手動で作成することもできます。ただし、その場合、論理インターフェイスを物理ポートにバインドするには、 channel-group channel-group-number コマンドを使用する必要があります。 channel-group-number port - channel-numberと同じ値に設定したり、新しい値を使用することができます。新しい値を使用すると、 channel-group コマンドによって新しいポート チャネルが動的に作成されます。

レイヤ3ポートの場合は、 interface port-channel グローバル コンフィギュレーション コマンド、およびそのあとに no switchport インターフェイス コンフィギュレーション コマンドを使用して、論理インターフェイスを手動で作成する必要があります。その後、 channel-group インターフェイス コンフィギュレーション コマンドを使用して、手動でEtherChannelにインターフェイスを割り当てます。

レイヤ2およびレイヤ3ポートのいずれの場合も、 channel-group コマンドを実行すると、物理ポートと論理インターフェイスがバインドされます(図 30-4を参照)。

各EtherChannelには1~12番のポート チャネル論理インターフェイスがあります。このポート チャネル インターフェイス番号は、 channel-group インターフェイス コンフィギュレーション コマンドで指定された番号に対応します。

図 30-4 物理ポート、論理ポート チャネル、およびチャネル グループの関係

 

EtherChannelを設定したあとに、ポート チャネル インターフェイスの設定を変更すると、そのポート チャネル インターフェイスに割り当てられたすべての物理ポートの設定も変更されます。物理ポートの設定を変更した場合は、設定を適用したポートだけが影響を受けます。EtherChannelのすべてのポートのパラメータを変更するには、コンフィギュレーション コマンドをポート チャネル インターフェイスに適用します。たとえば、スパニングツリー コマンドまたはレイヤ2 EtherChannelをトランクとして設定するコマンドなどです。

PAgP

Port Aggregation Protocol(PAgP;ポート集約プロトコル)はシスコ独自のプロトコルで、シスコ製スイッチと、PAgPに対応するためにライセンスを得たベンダーが認可したスイッチのみで動作します。PAgPを使用すると、イーサネット ポート間でPAgPパケットを交換することにより、EtherChannelを自動的に作成できます。PAgPを使用できるのは、単一スイッチEtherChannel構成の場合のみです。Cross-Stack EtherChannelの場合は、PAgPをイネーブルにできません。詳細については、「EtherChannel設定時の注意事項」を参照してください。

スイッチ スタックはPAgPを使用することによって、PAgPをサポートできるパートナーの識別情報、および各ポートの機能を学習します。次に、設定が類似している(スタック内の単一のスイッチ上の)ポートを、単一の論理リンク(チャネルまたは集約ポート)に動的にグループ化します。設定が類似しているポートをグループ化する場合の基準は、ハードウェア、管理、およびポート パラメータ制約です。たとえば、速度、デュプレックス モード、ネイティブVLAN、VLAN範囲、トランキング ステータスおよびタイプが同じであるポートがPAgPによってグループ化されます。リンクがEtherChannelにグループ化されたあと、グループはPAgPによって単一のスイッチ ポートとしてスパニングツリーに追加されます。

PAgPモード

表 30-1 に、 channel-group インターフェイス コンフィギュレーション コマンドでユーザが設定できるEtherChannel PAgPモードを示します。

 

表 30-1 EtherChannel PAgPモード

モード
説明

auto

ポートをパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信したPAgPパケットに応答しますが、PAgPパケット ネゴシエーションを開始しません。この設定では、PAgPパケットの伝送が最小化されます。

desirable

ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートはPAgPパケットを送信し、他のポートとのネゴシエーションを開始します。

on

PAgPやLACPを使用せずに、ポートを強制的にチャネル化します。 on モードでは、 on モードのポート グループが on モードの別のポート グループに接続されている場合のみ、EtherChannelを使用することが可能となります。この設定は、EtherChannelメンバーがスイッチ スタック(Cross-Stack EtherChannel)内の別のスイッチに属している場合のみサポートされます。

スイッチ ポートは、 auto または desirable モードに設定されたパートナー ポートとのみPAgPパケットを交換します。 on モードに設定されたポートは、PAgPパケットを交換しません。

auto および desirable モードの場合、ポートはパートナー ポートとネゴシエーションを行い、一定の基準に従ってEtherChannelを形成できるかどうかを判別します。その基準とは、ポート速度、(レイヤ2 EtherChannelの場合)トランキング ステート、VLAN番号などです。

ポート間でPAgPモードが異なっていても、モードに互換性があればEtherChannelを形成することができます。次に例を示します。

desirable モードのポートは、 desirable または auto モードの別のポートとEtherChannelを形成できます。

auto モードのポートは、 desirable モードの別のポートとEtherChannelを形成できます。

auto モードのポートは、 auto モードの別のポートとはEtherChannelを形成できません。どちらのポートも、PAgPネゴシエーションを開始しないためです。

ポート チャネルに追加された on モードのポートは、チャネル内の既存の on モードのポートと同じ特性を持つように強制的に変更されます。


注意 モードをonに設定(手動設定)するときは注意が必要です。onモードに設定されているすべてのポートは、同じグループにバンドルされ、強制的に同じ特性を持つように変更されます。グループの設定を間違えると、パケットが失われたり、スパニングツリー ループが発生することがあります。

PAgP機能を持つパートナーにスイッチが接続されている場合は、 non-silent キーワードを使用して、非サイレント動作を行うようにスイッチ ポートを設定できます。 auto または desirable モードの場合は、 non-silent を指定しないとサイレント モードになります。

PAgP機能を備えていない、または備えていてもパケット送信量がわずかしかないデバイスにスイッチが接続されている場合は、サイレント モードを使用します。サイレント パートナーの例としては、トラフィックを生成しないファイル サーバやパケット アナライザがあります。この場合、サイレント パートナーに接続された物理ポート上でPAgPを稼働させると、このスイッチ ポートが動作しなくなります。ただし、サイレント設定を使用すると、PAgPが動作したり、チャネル グループにポートを接続したり、ポートを伝送に使用したりすることができます。

PAgPと他の機能との相互作用

Dynamic Trunking Protocol(DTP)およびCisco Discovery Protocol(CDP)は、EtherChannelの物理ポートを使用してパケットを送受信します。トランク ポートは、番号が最小のVLAN上でPAgP Protocol Data Unit(PDU;プロトコル データ ユニット)を送受信します。

レイヤ2 EtherChannelでは、チャネル内で最初に起動するポートがEtherChannelにMACアドレスを提供します。このポートがバンドルから削除されると、バンドル内の他のポートの1つがEtherChannelにMACアドレスを提供します。レイヤ3 EtherChannelの場合は、( interface port-channel グローバル コンフィギュレーション コマンドを使用して)インターフェイスが作成された直後に、スタック マスターからMACアドレスが割り当てられます。

PAgPは、autoまたはdesirableモードに設定され、PAgPがイネーブルである稼働状態のポートからのみPAgP PDUを送受信します。

LACP

LACPはIEEE 802.3adで定義されていて、シスコ製スイッチはIEEE 802.3adプロトコルに準拠するスイッチ間のイーサネット チャネルを管理できます。LACPを使用すると、イーサネット ポート間でLACPパケットを交換することにより、EtherChannelを自動的に作成できます。LACPを使用できるのは、単一スイッチEtherChannel構成の場合のみです。Cross-Stack EtherChannelの場合はLACPをイネーブルにできません。詳細については、「EtherChannel設定時の注意事項」を参照してください。

スイッチ スタックはLACPを使用することによって、LACPをサポートできるパートナーの識別情報、および各ポートの機能を学習します。次に、設定が類似している (スタック内の単一のスイッチ上の) ポートを、単一の論理リンク(チャネルまたは集約ポート)に動的にグループ化します。設定が類似しているポートをグループ化する場合の基準は、ハードウェア、管理、およびポート パラメータ制約です。たとえば、速度、デュプレックス モード、ネイティブVLAN、VLAN範囲、トランキング ステータスおよびタイプが同じであるポートがLACPによってグループ化されます。リンクがEtherChannelにグループ化されたあと、グループはLACPによって単一のスイッチ ポートとしてスパニングツリーに追加されます。

LACPモード

表 30-2 に、 channel-group インターフェイス コンフィギュレーション コマンドで使用するユーザ設定可能なEtherChannel LACPモードを示します。

 

表 30-2 EtherChannel LACPモード

モード
説明

active

ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートはLACPパケットを送信し、他のポートとのネゴシエーションを開始します。

passive

ポートをパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信したLACPパケットに応答しますが、LACPパケット ネゴシエーションを開始しません。この設定では、LACPパケットの伝送が最小化されます。

on

PAgPやLACPを使用せずに、ポートを強制的にチャネル化します。 on モードでは、 on モードのポート グループが on モードの別のポート グループに接続されている場合のみ、EtherChannelを使用することが可能となります。この設定は、EtherChannelメンバーがスイッチ スタック(Cross-Stack EtherChannel)内の別のスイッチに属している場合のみサポートされます。

active および passive LACP モードの場合、ポートはパートナー ポートとネゴシエーションを行い、一定の基準に従ってEtherChannelを形成できるかどうかを判別します。その基準とは、ポート速度、(レイヤ2 EtherChannelの場合)トランキング ステート、VLAN番号などです。

ポート間でLACPモードが異なっていても、モードに互換性があればEtherChannelを形成できます。次に例を示します。

active モードのポートは、 active または passive モードの別のポートとEtherChannelを形成できます。

passive モードのポートは、 passive モードの別のポートとはEtherChannelを形成することができません。どちらのポートも、LACPネゴシエーションを開始しないためです。

LACPと他の機能との相互作用

DTPおよびCDPは、EtherChannelの物理ポートを経由してパケットを送受信します。トランク ポートは、番号が最も小さいVLAN上でLACP PDUを送受信します。

レイヤ2 EtherChannelでは、チャネル内で最初に起動するポートがEtherChannelにMACアドレスを提供します。このポートがバンドルから削除されると、バンドル内の他のポートの1つがEtherChannelにMACアドレスを提供します。レイヤ3 EtherChannelの場合は、 interface port-channel グローバル コンフィギュレーション コマンドを使用してインターフェイスが作成された直後に、スタック マスターからMACアドレスが割り当てられます。

LACPは、activeまたはpassiveモードに設定され、LACPがイネーブルである稼働状態のポートからのみLACP PDUを送受信します。

ロードバランシングおよび転送方式

EtherChannelは、フレーム内のアドレスに基づいて形成されたバイナリ パターンを部分的に縮小し、チャネル内の1つのリンクを選択する数値にすることによって、チャネル内のリンク間でトラフィックの負荷を分散させます。EtherChannelのロードバランシングには、MACアドレスやIPアドレス、送信元アドレスや宛先アドレス、または送信元と宛先の両方のアドレスを使用できます。選択したモードは、スイッチ上で設定されているすべてのEtherChannelに適用されます。ロードバランシングおよび転送方法を設定するには、 port-channel load-balance グローバル コンフィギュレーション コマンドを使用します。

送信元MACアドレス転送の場合、EtherChannelに転送されたパケットは、着信パケットの送信元MACアドレスに基づいてチャネル ポート間で分配されます。したがって、ロードバランシングを行うために、異なるホストからのパケットにはチャネル内の別のポート、同じホストからのパケットにはチャネル内の同じポートが使用されます。

宛先MACアドレス転送の場合、EtherChannelに転送されたパケットは、着信パケットに指定されている宛先ホストのMACアドレスに基づいてチャネル ポート間で分配されます。したがって、同じ宛先へのパケットは同じポートを経由して転送され、異なる宛先へのパケットはチャネル内の別のポートを経由して送信されます。

送信元/宛先MACアドレス転送の場合、EtherChannelに転送されたパケットは、送信元および宛先の両方のMACアドレスに基づいてチャネル ポート間で分配されます。この転送方式は、送信元MACアドレス転送方式と宛先MACアドレス転送方式の負荷分散を組み合わせたものです。特定のスイッチに対して送信元MACアドレス転送と宛先MACアドレス転送のいずれが適切であるかが不明な場合に使用できます。送信元/宛先MACアドレス転送の場合、ホストAからホストB、ホストAからホストC、およびホストCからホストBに送信されるパケットは、それぞれ異なるチャネル ポートを使用できます。

送信元IPアドレスベース転送の場合、EtherChannelに転送されたパケットは、着信パケットの送信元IPアドレスに基づいてEtherChannelポート間で分配されます。したがって、ロードバランシングを行うために、異なるIPアドレスからのパケットにはチャネル内の別のポート、同じIPアドレスからのパケットにはチャネル内の同じポートが使用されます。

宛先IPアドレスベース転送の場合、EtherChannelに転送されたパケットは、着信パケットの宛先IPアドレスに基づいてEtherChannelポート間で分配されます。したがって、ロードバランシングを行うために、同じ送信元IPアドレスから異なる宛先IPアドレスに送信されるパケットは異なるチャネル ポートに送信される場合があります。ただし、異なる送信元IPアドレスから同じ宛先IPアドレスに送信されるパケットは、常に同じチャネル ポートに送信されます。

送信元/宛先IPアドレスベース転送の場合、EtherChannelに転送されたパケットは、着信パケットの送信元および宛先の両方のIPアドレスに基づいてEtherChannelポート間で分配されます。この転送方式は、送信元IPアドレスベース転送方式と宛先IPアドレスベース転送方式を組み合わせたものです。特定のスイッチに対して送信元IPアドレスベース転送と宛先IPアドレスベース転送のいずれが適切であるかが不明な場合に使用できます。この方式では、IPアドレスAからIPアドレスBに、IPアドレスAからIPアドレスCに、およびIPアドレスCからIPアドレスBに送信されるパケットは、それぞれ異なるチャネル ポートを使用できます。

ロードバランシング方式ごとに利点が異なります。ロードバランシング方式は、ネットワーク内のスイッチの位置、および負荷分散が必要なトラフィックの種類に基づいて選択する必要があります。図 30-5では、4台のワークステーションで構成されたEtherChannelがルータと通信しています。ルータは単一のMACアドレスを持つデバイスであるため、スイッチEtherChannelで送信元ベース転送を行うことにより、ルータが使用できる全帯域をスイッチが使用するようになります。ルータは、宛先ベース転送を行うように設定されます。このように設定すると、多数のワークステーションで、ルータEtherChannelからのトラフィックが均等に分散されることが保証されるためです。

設定には最も柔軟なオプションを使用してください。たとえば、チャネル上のトラフィックが単一MACアドレスを宛先とする場合、宛先MACアドレスを使用すると、チャネル内の同じリンクが常に選択されます。送信元アドレスまたはIPアドレスを使用した方が、ロードバランシングの効率がよくなることがあります。

図 30-5 負荷分散および転送方法

 

EtherChannelおよびスイッチ スタック

EtherChannelに参加しているポートを持つスタック メンバーに障害が発生するか、またはこのスタック メンバーがスタックから脱退すると、スタック マスターはこのスタック メンバーのスイッチ ポートをEtherChannelから削除します。EtherChannel内にポートが残っている場合、これらのポートは引き続き接続された状態です。

既存のスタックにスイッチが追加されると、新しいスイッチはスタック マスターから実行コンフィギュレーションを受信し、EtherChannel関連のスタック設定を使用して自身の設定を更新します。スタック メンバーは動作情報(動作中のポート リスト、およびチャネル メンバーであるポートのリスト)も受信します。

EtherChannelが設定された2つのスタックを結合すると、セルフループ ポートになります。スパニングツリーはこの状況を検出して、適宜に対応します。権利を獲得したスイッチ スタックではPAgPまたはLACP設定が変更されませんが、権利を獲得しなかったスイッチ スタックでは、スタックの再起動後にPAgPまたはLACP設定が失われます。

スタック マスターに障害が発生するか、スタックから脱退した場合、新しいスタック マスターが選択されます。EtherChannelの帯域幅が変更されない限り、スパニングツリーの再コンバージェンスは発生しません。新しいスタック マスターにより、スタック メンバーの設定とスタック マスターの設定が同期されます。EtherChannelが古いスタック マスター上にある場合を除き、PAgPまたはLACP設定はスタック マスターの変更による影響を受けません。

スイッチ スタックの詳細については、 第5章「スイッチ スタックの管理」 を参照してください。

EtherChannelの設定

ここでは、レイヤ2およびレイヤ3ポートにEtherChannelを設定する方法について説明します。

「EtherChannelのデフォルト設定」

「EtherChannel設定時の注意事項」

「レイヤ2 EtherChannelの設定」(必須)

「レイヤ3 EtherChannelの設定」(必須)

「EtherChannelロードバランシングの設定」(任意)

「PAgP学習方式およびプライオリティの設定」(任意)

「LACPホットスタンバイ ポートの設定」(任意)


) ポートが正しく設定されていることを確認してください。詳細については、「EtherChannel設定時の注意事項」を参照してください。



) EtherChannelを設定したあとに、ポート チャネル インターフェイスの設定を変更すると、そのポート チャネル インターフェイスに割り当てられたすべての物理ポートの設定も変更されます。物理ポートの設定変更では、そのポートのみが変更されます。


EtherChannelのデフォルト設定

表 30-3 に、EtherChannelのデフォルト設定を示します。

 

表 30-3 EtherChannelのデフォルト設定

機能
デフォルト設定

チャネル グループ

割り当てなし

ポート チャネル論理インターフェイス

定義なし

PAgPモード

デフォルトなし

PAgPの学習方式

すべてのポートで集約ポート学習

PAgPプライオリティ

すべてのポートで128

LACPモード

デフォルトなし

LACPの学習方式

すべてのポートで集約ポート学習

LACPポート プライオリティ

すべてのポートで32768

LACPシステム プライオリティ

32768

LACPシステムID

LACPシステム プライオリティおよびスイッチのMACアドレス

ロードバランシング

スイッチの負荷分散は、着信パケットの送信元MACアドレスに基づいて行われます。

EtherChannel設定時の注意事項

EtherChannelが正しく設定されていない場合、ネットワーク ループなどの問題を回避するために、一部のEtherChannelポートが自動的にディセーブルになることがあります。設定上の問題を防ぐには、次の注意事項に従ってください。

Catalyst 3750スイッチ スタックには12個を超えるEtherChannelを設定できません。

同じタイプのイーサネット ポートを最大で8つ備えたPAgP EtherChannelを設定してください。

同じタイプのイーサネット ポートを最大で16個備えたLACP EtherChannelを設定してください。最大8つのポートをアクティブにしたり、スタンバイ モードにすることができます。 スイッチがスイッチ スタックに属している場合、LACP EtherChannel内の16個のポートを同じスイッチに設定する必要があります。

EtherChannel内の全ポートが、同じ速度および同じデュプレックス モードで動作するように設定してください。

EtherChannelのすべてのポートをイネーブルにしてください。 shutdown インターフェイス コンフィギュレーション コマンドを使用してディセーブル化されたEtherChannelのポートは、リンク障害として処理され、トラフィックはEtherChannelの残りのポートのいずれかに転送されます。

グループを初めて作成したときは、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。次に示すパラメータのいずれかの設定を変更する場合は、グループ内のすべてのポートに関する設定も変更してください。

許可VLANリスト

各VLANのスパニングツリー パス コスト

各VLANのスパニングツリー ポート プライオリティ

スパニングツリーのPortFast設定

ポートが複数のEtherChannelグループのメンバーにならないように設定してください。

EtherChannelを、PAgPモードおよびLACPモードの両方に設定しないでください。PAgPおよびLACPが稼働している複数のEtherChannelグループを、スタック内の同じスイッチまたは別のスイッチ上で共存させることができます(クロススタック構成の場合を除く)。各EtherChannelグループはPAgPまたはLACPのいずれかを実行できますが、相互運用はできません。

EtherChannelの一部としてSwitched Port Analyzer(SPAN;スイッチド ポート アナライザ)宛先を設定しないでください。

EtherChannelの一部としてセキュア ポートを設定したり、その逆の設定を行わないでください。

EtherChannelのアクティブ メンバーであるポートを802.1xポートとして設定しないでください。EtherChannelのまだアクティブになっていないポートで802.1xをイネーブルにしても、ポートはEtherChannelに加入しません。

レイヤ2 EtherChannelの場合

EtherChannel内の全ポートを同じVLANに割り当てるか、またはトランクとして設定してください。複数のネイティブVLANに接続されるポートは、EtherChannelを形成することができません。

トランク ポートからEtherChannelを設定する場合は、すべてのトランクでトランキング モード(ISLまたは802.1Q)が同じであることを確認してください。EtherChannelポートでトランク モードが統一されていない場合は、予想外の結果を招くことがあります。

EtherChannelがサポートするVLANの許容範囲は、トランキング レイヤ2 EtherChannel内の全ポートで同じです。VLANの許容範囲が同じでない場合は、PAgPが auto モードまたは desirable モードに設定されていても、ポートはEtherChannelを形成しません。

ポートのスパニングツリー パス コストが異なっていても、他の設定条件に矛盾がなければ、EtherChannelを形成できます。異なるスパニングツリー パス コストを設定すること自体は、EtherChannel形成の支障にはなりません。

レイヤ3 EtherChannelの場合は、レイヤ3アドレスをチャネル内の物理ポートでなく、ポート チャネル論理インターフェイスに割り当ててください。

Cross-Stack EtherChannel構成の場合は、 channel-group channel-group-number mode on インターフェイス コンフィギュレーション コマンドを使用して、EtherChannelの対象となるすべてのポート上でPAgPおよびLACPをディセーブルにしてください。既存のEtherChannelにスタック メンバー ポートを追加する前に、チャネル グループのメンバーであるすべてのポート上でPAgPおよびLACPを手動でディセーブルにし、Cross-Stack EtherChannelを手動で設定してください。PAgPおよびLACPは、Cross-Stack EtherChannelではサポートされません。

Cross-Stack EtherChannelが設定されていて、スイッチ スタックが分割されている場合、ループおよび転送が正しく動作しないことがあります。

レイヤ2 EtherChannelの設定

レイヤ2 EtherChannelを設定するには、 channel-group インターフェイス コンフィギュレーション コマンドを使用して、チャネル グループにポートを割り当てます。このコマンドにより、ポート チャネル論理インターフェイスが自動的に作成されます。

auto または desirable モードのポートでPAgPがイネーブルである場合は、 channel-group channel-group-number mode on インターフェイス コンフィギュレーション コマンドを使用してこのポートを on モードに再設定してから、Cross-Stack EtherChannelに追加する必要があります。PAgPは、Cross-Stack EtherChannelではサポートされません。

active または passive モードのポート上でLACPがイネーブルである場合は、 channel-group channel-group-number mode on インターフェイス コンフィギュレーション コマンドを使用してこのポートを on モードに再設定してから、Cross-Stack EtherChannelに追加する必要があります。LACPは、Cross-Stack EtherChannelではサポートされません。

レイヤ2 EtherChannelにレイヤ2イーサネット ポートを割り当てるには、イネーブルEXECモードで次の手順を実行します。この手順は必須です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

物理ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

有効なインターフェイスは物理ポートなどです。

PAgP EtherChannelの場合、同一タイプ、同一速度のポートを8つまで同一グループに設定できます。

LACP EtherChannelの場合は、同一タイプのイーサネット ポートを16個まで設定できます。最大8つのポートをアクティブにしたり、スタンバイ モードにすることができます。 スイッチがスイッチ スタックに属している場合、LACP EtherChannel内の16個のポートを同じスイッチに設定する必要があります。

ステップ 3

switchport mode { access | trunk }

switchport access vlan vlan-id

全ポートをスタティック アクセス ポートとして同じVLANに割り当てるか、またはトランクとして設定します。

ポートをスタティック アクセス ポートとして設定する場合は、ポートを1つのVLANにのみ割り当ててください。指定できる範囲は1~4094です。

ステップ 4

channel-group channel -group-number mode { auto [ non-silent ] | desirable [ non-silent ] | on } | { active | passive }

ポートをチャネル グループに割り当て、PAgPまたはLACPモードを指定します。

channel-group-number の範囲は1~12です。

mode には、次のキーワードのいずれかを選択します。

auto PAgPデバイスが検出された場合にのみ、PAgPをイネーブルにします。ポートをパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信したPAgPパケットに応答しますが、PAgPパケット ネゴシエーションを開始しません。

desirable PAgPを無条件でイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートはPAgPパケットを送信し、他のポートとのネゴシエーションを開始します。

on PAgPやLACPを使用せずに、ポートを強制的にチャネル化します。 on モードでは、 on モードのポート グループが on モードの別のポート グループに接続されている場合のみ、EtherChannelを使用することが可能となります。このキーワードは、EtherChannelメンバーがスイッチ スタック(Cross-Stack EtherChannel)内の別のスイッチに属している場合に、使用する必要があります。

non-silent (任意)PAgP対応のパートナーに接続されたスイッチのポートが auto または desirable モードの場合に、非サイレント動作を行うようにこのポートを設定します。 non-silent を指定しなかった場合は、サイレントが指定されたものとみなされます。サイレント設定は、ファイル サーバまたはパケット アナライザに接続する場合に使用します。この設定を使用すると、PAgPが動作したり、チャネル グループにポートを接続したり、ポートを伝送に使用したりすることができます。

active LACPデバイスが検出された場合のみ、LACPをイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートはLACPパケットを送信し、他のポートとのネゴシエーションを開始します。

passive ポートでLACPをイネーブルにしてパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信したLACPパケットに応答しますが、LACPパケット ネゴシエーションを開始しません。

スイッチとパートナー間で互換性のあるモードの詳細については、「PAgPモード」および「LACPモード」を参照してください。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show running-config

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

EtherChannelグループからポートを削除するには、 no channel-group インターフェイス コンフィギュレーション コマンドを使用します。

次に、スタック内の1つのスイッチにEtherChannelを設定する例を示します。2つのポートはVLAN 10のスタティック アクセス ポートとして、PAgPモードが desirable であるチャネル5に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode desirable non-silent
Switch(config-if-range)# end
 

次に、スタック内の1つのスイッチにEtherChannelを設定する例を示します。2つのポートはVLAN 10のスタティック アクセス ポートとして、LACPモードが active であるチャネル5に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode active
Switch(config-if-range)# end
 

次に、Cross-Stack EtherChannelを設定する例を示します。スタック メンバー2上のポート2つと、スタック メンバー3上のポート1つは、VLAN 10のスタティック アクセス ポートとして、PAgPおよびLACPモードがディセーブル( on )であるチャネル5に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/3 -4
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode on
Switch(config-if-range)# exit
Switch(config)# interface gigabitethernet3/0/3
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10
Switch(config-if)# channel-group 5 mode on
Switch(config-if)# exit

レイヤ3 EtherChannelの設定

レイヤ3 EtherChannelを設定するには、ポート チャネル論理インターフェイスを作成し、そのポート チャネルにイーサネット ポートを組み込みます。次に設定方法を説明します。

ポート チャネル論理インターフェイスの作成

レイヤ3 EtherChannelを設定する場合、まず interface port-channel グローバル コンフィギュレーション コマンドを使用し、ポート チャネル論理インターフェイスを手動で作成しなければなりません。次に、 channel-group インターフェイス コンフィギュレーション コマンドを使用して論理インターフェイスをチャネル グループに配置します。


) 物理ポートからEtherChannelにIPアドレスを移動するには、物理ポートからIPアドレスを削除してから、そのIPアドレスをポート チャネル インターフェイス上で設定する必要があります。


レイヤ3 EtherChannel用のポート チャネル インターフェイスを作成するには、イネーブルEXECモードで次の手順を実行します。この手順は必須です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel port- channel-number

ポート チャネル論理インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

port - channel-numberの範囲は1~12です。

ステップ 3

no switchport

インターフェイスをレイヤ3モードにします。

ステップ 4

ip address ip-address mask

EtherChannelにIPアドレスおよびサブネット マスクを割り当てます。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show etherchannel channel-group-number detail

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ステップ 8

レイヤ3 EtherChannelにイーサネット ポートを割り当てます。詳細については、「物理インターフェイスの設定」を参照してください。

ポート チャネルを削除するには、 no interface port-channel port-channel-number グローバル コンフィギュレーション コマンドを使用します。

次に、論理ポート チャネル5を作成し、IPアドレスとして172.10.20.10を割り当てる例を示します。

Switch# configure terminal
Switch(config)# interface port-channel 5
Switch(config-if)# no switchport
Switch(config-if)# ip address 172.10.20.10 255.255.255.0
Switch(config-if)# end

物理インターフェイスの設定

レイヤ3 EtherChannelにイーサネット ポートを割り当てるには、イネーブルEXECモードで次の手順を実行します。この手順は必須です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

物理ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

有効なインターフェイスは物理ポートなどです。

PAgP EtherChannelの場合、同一タイプ、同一速度のポートを8つまで同一グループに設定できます。

LACP EtherChannelの場合は、同一タイプのイーサネット ポートを16個まで設定できます。最大8つのポートをアクティブにしたり、スタンバイ モードにすることができます。 スイッチがスイッチ スタックに属している場合、LACP EtherChannel内の16個のポートを同じスイッチに設定する必要があります。

ステップ 3

no ip address

この物理ポートに割り当てられているIPアドレスをすべて削除します。

ステップ 4

no switchport

ポートをレイヤ3モードにします。

ステップ 5

channel-group channel -group-number mode { auto [ non-silent ] | desirable [ non-silent ] | on } | { active | passive }

ポートをチャネル グループに割り当て、PAgPまたはLACPモードを指定します。

channel-group-number の範囲は1~12です。この番号は、「ポート チャネル論理インターフェイスの作成」で設定した port-channel-number (論理ポート)と同じでなければなりません。

mode には、次のキーワードのいずれかを選択します。

auto ― PAgPデバイスが検出された場合のみ、PAgPをイネーブルにします。ポートをパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信したPAgPパケットに応答しますが、PAgPパケット ネゴシエーションを開始しません。

desirable ― PAgPを無条件でイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートはPAgPパケットを送信し、他のポートとのネゴシエーションを開始します。

on ― PAgPやLACPを使用せずに、ポートを強制的にチャネル化します。 on モードでは、 on モードのポート グループが on モードの別のポート グループに接続されている場合のみ、EtherChannelを使用することが可能となります。このキーワードは、EtherChannelメンバーがスイッチ スタック(Cross-Stack EtherChannel)内の別のスイッチに属している場合に、使用する必要があります。

non-silent ― (任意)PAgP対応のパートナーに接続されたスイッチのポートが auto または desirable モードの場合に、非サイレント動作を行うようにこのポートを設定します。 non-silent を指定しなかった場合は、サイレントが指定されたものとみなされます。サイレント設定は、ファイル サーバまたはパケット アナライザに接続する場合に使用します。この設定を使用すると、PAgPが動作したり、チャネル グループにポートを接続したり、ポートを伝送に使用したりすることができます。

active LACPデバイスが検出された場合のみ、LACPをイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。このステートの場合、ポートはLACPパケットを送信し、他のポートとのネゴシエーションを開始します。

passive ポートでLACPをイネーブルにしてパッシブ ネゴシエーション ステートにします。このステートの場合、ポートは受信したLACPパケットに応答しますが、LACPパケット ネゴシエーションを開始しません。

スイッチとパートナー間で互換性のあるモードの詳細については、「PAgPモード」および「LACPモード」を参照してください。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show running-config

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次に、EtherChannelを設定する例を示します。2つのポートは、LACPモードが active であるチャネル5に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# no ip address
Switch(config-if-range)# no switchport
Switch(config-if-range)# channel-group 5 mode active
Switch(config-if-range)# end
 

次に、Cross-Stack EtherChannelを設定する例を示します。スタック メンバー2上のポート2つと、スタック メンバー3上のポート1つは、PAgPおよびLACPモードがディセーブル( on であるチャネル5に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/3 -4
Switch(config-if-range)# no ip address
Switch(config-if-range)# no switchport
Switch(config-if-range)# channel-group 5 mode on
Switch(config-if-range)# exit
Switch(config)# interface gigabitethernet3/0/3
Switch(config-if)# no ip address
Switch(config-if-range)# no switchport
Switch(config-if)# channel-group 5 mode on
Switch(config-if)# exit

EtherChannelロードバランシングの設定

ここでは、送信元ベースまたは宛先ベースの転送方法を使用し、EtherChannelのロードバランシングを設定する方法について説明します。詳細については、「ロードバランシングおよび転送方式」を参照してください。

EtherChannelのロードバランシングを設定するには、イネーブルEXECモードで次の手順を実行します。この手順は任意です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-channel load-balance { dst-ip | dst-mac | src-dst-ip | src-dst-mac | src-ip | src-mac }

EtherChannelのロードバランシング方法を設定します。

デフォルトは src-mac です。

次のいずれかの負荷分散方式を選択します。

dst-ip ― 宛先ホストIPアドレスに基づいて負荷分散を行います。

dst-mac ― 着信パケットの宛先ホストMACアドレスに基づいて負荷分散を行います。

src-dst-ip ― 送信元/宛先ホストIPアドレスに基づいて負荷分散を行います。

src-dst-mac ― 送信元/宛先ホストMACアドレスに基づいて負荷分散を行います。

src-ip ― 送信元ホストIPアドレスに基づいて負荷分散を行います。

src-mac ― 着信パケットの送信元MACアドレスに基づいて、負荷分散を行います。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show etherchannel load-balance

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

EtherChannelのロードバランシングをデフォルト設定に戻すには、 no port-channel load-balance グローバル コンフィギュレーション コマンドを使用します。

PAgP学習方式およびプライオリティの設定

ネットワーク デバイスはPAgPの物理ラーナーまたは集約ポート ラーナーとして分類されます。物理ポートでアドレスを学習し、その知識に基づいて伝送を指示するデバイスが物理ラーナーです。集約(論理)ポートでアドレスを学習するデバイスは、集約ポート ラーナーです。学習方式はリンクの両端で同一に設定する必要があります。

デバイスとそのパートナーが両方とも集約ポート ラーナーである場合、これらは論理ポート チャネルのアドレスを学習します。このデバイスはEtherChannelのポートのいずれかを使用し、送信元にパケットを送信します。集約ポート学習の場合、どの物理ポートにパケットが着信するかは重要ではありません。

PAgPは、パートナー デバイスが物理ラーナーになる時期、論理デバイスが集約ポート ラーナーになる時期を自動的に検出することはできません。したがって、物理ポートを使用してアドレスを学習する場合は、ローカル デバイスに手動で学習方式を設定する必要があります。負荷分散方式を送信元ベースに設定して、指定された送信元MACアドレスが常に同じ物理ポートに送信されるようにする必要もあります。

グループ内の1つのポートですべての伝送を行うように設定して、他のポートをホット スタンバイに使用することもできます。選択された1つのポートでハードウェア信号が検出されなくなった場合は、数秒以内にグループ内の未使用のポートに切り替えて動作させることができます。あるポートが常にパケット伝送に選択されるように設定するには、 pagp port-priority インターフェイス コンフィギュレーション コマンドを使用してプライオリティを変更します。プライオリティが高いほど、そのポートが選択される可能性が高まります。


physical-portキーワードがCLI(コマンドライン インターフェイス)に用意されている場合でも、Catalyst 3750スイッチは集約ポートでのみアドレス学習を実行できます。pagp learn-methodコマンドおよびpagp port-priorityコマンドは、スイッチ ハードウェアに対して無効です。ただし、このコマンドは、Catalyst 1900スイッチなど物理ポートでのアドレス学習だけをサポートするデバイスとの間でPAgPインターオペラビリティを確立する場合に必要となります。

Catalyst 3750スイッチとのリンク パートナーが物理ラーナー(Catalyst 1900シリーズ スイッチなど)である場合は、pagp learn-method physical-portインターフェイス コンフィギュレーション コマンドを使用して、Catalyst 3750スイッチを物理ポート ラーナーとして設定することを推奨します。送信元MACアドレスに基づいて負荷分散方式を設定するには、port-channel load-balance src-macグローバル コンフィギュレーション コマンドを使用します。この設定により、送信元アドレスの学習元であるEtherChannel内の同じポートを使用して、パケットがCatalyst 1900スイッチに送信されます。pagp learn-methodコマンドは、この場合にのみ使用してください。


スイッチをPAgP物理ポート ラーナーとして設定し、バンドル内の同じポートがパケット送信用として選択されるようにプライオリティを調整するには、イネーブルEXECモードで次の手順を実行します。この手順は任意です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

伝送ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

pagp learn-method physical-port

PAgP学習方式を選択します。

デフォルトでは、 aggregation-port 学習が選択されています。これにより、EtherChannel内のいずれかのポートを使用して、パケットが送信元に送信されます。集約ポート学習の場合、どの物理ポートにパケットが着信するかは重要ではありません。

物理ラーナーである別のスイッチに接続するには、 physical-port を選択します。 port-channel load-balance グローバル コンフィギュレーション コマンドは、必ず src-mac に設定してください(EtherChannelロードバランシングの設定を参照)。

学習方式はリンクの両端で同一に設定する必要があります。

ステップ 4

pagp port-priority priority

選択したポートがパケット伝送用として選択されるように、プライオリティを割り当てます。

priority の範囲は0~255です。デフォルト値は128です。プライオリティが高いほど、ポートがPAgP伝送に使用される可能性が高まります。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show running-config

または

show pagp channel-group-number internal

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

プライオリティをデフォルト設定に戻すには、 no pagp port-priority インターフェイス コンフィギュレーション コマンドを使用します。学習方式をデフォルト設定に戻すには、 no pagp learn-method インターフェイス コンフィギュレーション コマンドを使用します。

LACPホットスタンバイ ポートの設定

LACPがイネーブルの場合、チャネル内に最大数のLACP対応ポートを設定しようとします(最大16ポート)。同時にアクティブにできるLACPリンクは8つのみです。これ以上のリンクはソフトウェアによってホットスタンバイ モードになります。アクティブ リンクの1つが非アクティブになると、代わりにホットスタンバイ モードになっているリンクがアクティブになります。

EtherChannelグループに8リンクより多く設定されている場合、LACPプライオリティに基づいて、アクティブにするホットスタンバイ ポートがソフトウェアによって自動的に決定されます。ソフトウェアはLACPが動作するシステム間のリンクごとに、次の要素(プライオリティ順)からなる一意のプライオリティを割り当てます。

LACPシステム プライオリティ

システムID(LACPシステム プライオリティとスイッチMACアドレスの組み合わせ)

LACPポート プライオリティ

ポート番号

プライオリティを比較する場合、値が小さいほどプライオリティは大きくなります。ハードウェアの制限により互換性のあるポートの一部を集約できない場合は、プライオリティによって、スタンバイ モードにする必要があるポートが決定されます。

ポートは、リンクのプライオリティ順に(プライオリティが最大のリンクに接続されたポートが最初)、集約内でアクティブになるとみなされます。各ポートは、それ以前に選択されたポートのプライオリティの高さが変更されない場合に、アクティブに選択されます。それ以外の場合、ポートはスタンバイ モードに選択されます。

LACPシステム プライオリティおよびLACPポート プライオリティのデフォルト値を変更して、ソフトウェアによるアクティブおよびスタンバイ リンクの選択方法を変更できます。詳細については、「LACPシステム プライオリティの設定」および「LACPポート プライオリティの設定」を参照してください。

LACPシステム プライオリティの設定

lacp system-priorityグローバル コンフィギュレーション コマンドを使用して、LACPで使用可能なすべてのEtherChannelにシステム プライオリティを設定できます。各LACP設定チャネルにはシステム プライオリティを設定できません。この値をデフォルトから変更すると、アクティブおよびスタンバイ リンクの選択方法を変更できます。

ホットスタンバイ モードのポートを確認するには、show etherchannel summaryイネーブルEXECコマンドを使用します(ホットスタンバイ モードのポートには H ポート ステート フラグが付加されます)。

LACPシステム プライオリティを設定するには、イネーブルEXECモードで次の手順を行います。この手順は任意です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

lacp system-priority priority

LACPシステム プライオリティを設定します。

priority の範囲は1~65535です。デフォルト値は32768です。

値が小さいほど、システム プライオリティは高くなります。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show running-config

または

show lacp sys-id

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

LACPシステム プライオリティをデフォルト値に戻すには、 no lacp system-priority グローバル コンフィギュレーション コマンドを使用します。

LACPポート プライオリティの設定

すべてのポートは、デフォルトで同じポート プライオリティに設定されています。 ローカル システムのシステム プライオリティおよびシステムIDの値がリモート システムよりも小さい場合は、 LACP EtherChannelポートのポート プライオリティをデフォルトよりも小さな値に変更して、最初にアクティブになるホットスタンバイ リンクを変更することができます。 ポート番号が小さなホットスタンバイ ポートほど、先にチャネル内でアクティブになります。ホットスタンバイ モードのポートを確認するには、show etherchannel summaryイネーブルEXECコマンドを使用します(ホットスタンバイ モードのポートには H ポート ステート フラグが付加されます)。


) LACPが互換性のあるすべてのポートを集約できない場合(たとえば、リモート システムのハードウェア上の制限など)、EtherChannelにアクティブに含められないすべてのポートはホット スタンバイ ステートとなり、チャネル ポートのいずれかが故障した場合のみ使用されます。


LACPポート プライオリティを設定するには、イネーブルEXECモードで次の手順を行います。この手順は任意です。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

lacp port-priority priority

LACPポート プライオリティを設定します。

priority の範囲は1~65535です。デフォルト値は32768です。 値が小さいほど、ポートがLACP伝送に使用される可能性が高まります。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show running-config

または

show lacp [ channel-group-number ] internal

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

LACPポート プライオリティをデフォルト値に戻すには、 no lacp port-priority インターフェイス コンフィギュレーション コマンドを使用します。

EtherChannel、PAgP、およびLACPステータスの表示

EtherChannel、PAgP、およびLACPステータス情報を表示するには、 表 30-4 に記載されたイネーブルEXECコマンドを使用します。

 

表 30-4 EtherChannel、PAgP、およびLACPステータスを表示するためのコマンド

コマンド
説明

show etherchannel [ channel-group-number { detail | port | port-channel | protocol | summary }] { detail | load-balance | port | port-channel | protocol | summary }

EtherChannel情報を簡潔、詳細に、1行のサマリー形式で表示します。さらに、ロードバランスまたはフレーム分散方式、ポート、ポート チャネル、プロトコル情報も表示します。

show pagp [ channel-group-number ] { counters | internal | neighbor }

トラフィック情報、内部PAgP設定、近接情報などのPAgP情報を表示します。

show lacp [channel-group-number] {counters | internal | neighbor}

トラフィック情報、内部LACP設定、近接情報などのLACP情報を表示します。

PAgPチャネルグループ情報およびトラフィック カウンタをクリアするには、 clear pagp { channel-group-number counters | counters }イネーブルEXECコマンドを使用します。

LACPチャネルグループ情報およびトラフィック カウンタをクリアするには、 clear lacp { channel-group-number counters | counters }イネーブルEXECコマンドを使用します。

出力内の各フィールドについては、このリリースのコマンド リファレンスを参照してください。