Catalyst 3750 スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.1(19)EA1
SmartPortマクロの設定
SmartPortマクロの設定
発行日;2012/01/09 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

SmartPortマクロの設定

SmartPortマクロの概要

SmartPortマクロの設定

SmartPortマクロのデフォルト設定

SmartPortマクロ設定時の注意事項

SmartPortマクロの作成および適用

SmartPortマクロの表示

SmartPortマクロの設定

この章では、Catalyst 3750スイッチにSmartPortマクロを設定して適用する方法について説明します。


) この章で使用されるコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「SmartPortマクロの概要」

「SmartPortマクロの設定」

「SmartPortマクロの表示」

SmartPortマクロの概要

SmartPortマクロは、共通の設定を保存および共有するのに便利な方法です。SmartPortマクロを使用して、ネットワークのスイッチの位置に基づく機能および設定をイネーブルにしたり、ネットワーク上で大規模な設定配置を行うことができます。

各SmartPortマクロは、定義するCLI(コマンド ライン インターフェイス)コマンドのセットです。SmartPortマクロは、新しいCLIコマンドを含まず、既存のCLIコマンドのグループを簡略化します。

インターフェイスでSmartPortマクロを適用すると、マクロ内のCLIコマンドがこのインターフェイス上で設定されます。マクロがインターフェイスに適用されても、既存のインターフェイスの設定は失われません。新しいコマンドはインターフェイスに追加され、実行コンフィギュレーション ファイルに保存されます。

SmartPortマクロの設定

新たにSmartPortマクロを作成したり、ご使用のアプリケーションに特有の新しいマクロを作成するのに、既存のマクロをテンプレートとして使用することができます。マクロが作成されると、インターフェイスまたはインターフェイス範囲にこれを適用することができます。

ここでは、次の内容について説明します。

「SmartPortマクロのデフォルト設定」

「SmartPortマクロ設定時の注意事項」

「SmartPortマクロの作成および適用」

SmartPortマクロのデフォルト設定

スイッチで設定されるデフォルトのSmartPortマクロはありません。

SmartPortマクロ設定時の注意事項

スイッチでマクロを設定するには、次の注意事項に従ってください。

マクロを作成する場合は、 exit または end コマンドを使用しないでください。これは、異なるコマンド モードで実行する exit または end コマンドとなる可能性があります。

マクロを作成するには、すべてのCLIコマンドがインターフェイス コンフィギュレーション モード コマンドである必要があります。

CLIコマンドには、あるインターフェイス タイプに特有のものもあります。設定が採用されていないインターフェイスにマクロが適用されると、マクロが構文または設定の確認を行わないため、スイッチからエラー メッセージが返されます。

マクロがインターフェイスに適用されると、インターフェイス上の既存の設定はすべて保持されます。これは、インターフェイスに差分設定を適用する場合に役立ちます。

コマンドを追加または削除してマクロ定義を変更する場合、この変更は元のマクロが適用されていたインターフェイスに反映されません。新しいコマンドまたは変更したコマンドを適用するには、インターフェイスに更新されたマクロを再適用する必要があります。

マクロがインターフェイス上で実行しているものを表示したり、またはマクロをデバックして、構文や設定のエラーを判別するには、 macro trace macro-name インターフェイス コンフィギュレーション コマンドを使用します。

マクロを適用するときに、構文エラーまたは設定エラーによりコマンドに障害が生じた場合、マクロは残りのコマンドをインターフェイスに適用し続けます。

インターフェイス範囲にマクロを適用することは、単一のインターフェイスにマクロを適用するのと同じです。インターフェイス範囲を使用すると、マクロはその範囲内の各インターフェイスに順番に適用されます。1つのインターフェイスでマクロ コマンドに障害が生じても、このコマンドは残りのインターフェイスでは適用されます。

SmartPortマクロの作成および適用

SmartPortマクロを作成および適用するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

macro name macro-name

マクロ定義を作成して、マクロ名を入力します。マクロ定義には、最大3000文字まで含めることができます。

1行につき1つのコマンドで、マクロ コマンドを入力します。マクロを終了するには、 @ 文字を使用します。マクロ内でコメント テキストを入力するには、行の始めに # 文字を使用します。

マクロでは exit または end コマンドを使用しないことを推奨します。これは、異なるコマンド モードで実行する exit または end コマンドとなる可能性があります。最良の結果を出すには、マクロ内のすべてのコマンドがインターフェイス コンフィギュレーション モード コマンドである必要があります。

ステップ 3

interface interface-id

インターフェイス コンフィギュレーション モードで、マクロを適用するインターフェイスを指定します。

ステップ 4

macro { apply | trace } macro-name

マクロで定義された各コマンドをインターフェイスに適用するには、 macro apply macro-name を入力します。 macro trace macro-name を指定して、各コマンドの適用および印刷を行ったあと、インターフェイスに適用されます。

ステップ 5

macro description text

(任意)インターフェイスに適用されるマクロについての説明を入力します。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show parser macro

マクロが作成されたことを確認します。

ステップ 8

show running-config interface interface-id

マクロがインターフェイスに適用されたことを確認します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

macro name グローバル コンフィギュレーション コマンドの no 形式によって、マクロの定義のみが削除されます。マクロがすでに適用されているインターフェイスの設定には影響しません。 default interface interface-id インターフェイス コンフィギュレーション コマンドを入力して、マクロに適用されたインターフェイス上の設定を削除することができます。また、元のマクロ内ですべての対応するコマンドの no 形式を含む既存のマクロに、 anti-macro を作成することができます。次に、インターフェイスにアンチマクロを適用します。

アクセス スイッチ インターフェイスに desktop-config マクロを定義して、このマクロをギガビット イーサネット ポート2に適用し、インターフェイスに説明を追加し、設定を確認する例を示します。

Switch(config)# macro name desktop-config
# Put the switch in access mode
switchport mode access
# Allow port to move to forwarding state quickly
spanning-tree portfast
# BPDUs should not be sent into the network
spanning-tree bpduguard enable
# Restrict the port to one address -- that of desktop
switchport port-security maximum 1
# Put all data traffic in vlan 1
switchport access vlan 1
@
 
Switch(config)# interface gigabitethernet1/0/2
Switch(config-if)# macro apply desktop-config
Switch(config-if)# macro description desktop-config
Switch(config-if)# end
Switch# show parser macro name desktop-config
Macro name : desktop-config
Macro type : customizable
 
macro description desktop-config
# Put the switch in access mode
switchport mode access
# Allow port to move to forwarding state quickly
spanning-tree portfast
# BPDUs should not be sent into the network
spanning-tree bpduguard enable
# Restrict the port to one address -- that of desktop
switchport port-security maximum 1
# Put all data traffic in vlan 1
switchport access vlan 1
 
Switch# show parser macro description
Interface Macro Description
--------------------------------------------------------------
Gi1/0/2 desktop-config
--------------------------------------------------------------

SmartPortマクロの表示

SmartPortマクロを表示するには、 表 12-1 に示すイネーブルEXECコマンドを1つまたは複数使用します。

 

表 12-1 SmartPortマクロを表示するコマンド

コマンド
説明

show parser macro

設定されたすべてのマクロを表示します。

show parser macro name macro-name

特定のマクロを表示します。

show parser macro brief

設定されたマクロ名を表示します。

show parser macro description [ interface interface-id ]

すべてのインターフェイスまたは特定のインターフェイスに関するマクロの説明を表示します。