Catalyst 3550 マルチレイヤ スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)SEC
WCCP を使用した Web キャッシュ サービスの設定
WCCP を使用した Web キャッシュ サービスの設定
発行日;2013/09/26 | 英語版ドキュメント(2009/02/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

WCCP を使用した Web キャッシュ サービスの設定

WCCP の概要

WCCP メッセージ交換

WCCP ネゴシエーション

MD5 セキュリティ

パケットのリダイレクト

サポートしない WCCPv2 機能

WCCP の設定

WCCP のデフォルト設定

WCCP 設定時の注意事項

Web キャッシュ サービスのイネーブル化、パスワードの設定、クライアントから受信したトラフィックのリダイレクト

WCCP のモニタおよびメンテナンス

WCCP を使用した Web キャッシュ サービスの設定

この章では、Web Cache Communication Protocol(WCCP)を使用し、トラフィックをキャッシュ エンジン(Cisco Cache Engine 550 などの Web キャッシュ)にリダイレクトするように Catalyst 3550 スイッチを設定する方法について説明します。WCCP はシスコが開発したコンテンツ ルーティング技術で、ネットワーク インフラストラクチャにキャッシュ エンジンを統合することができます。キャッシュ エンジンは、頻繁にアクセスのあるコンテンツを透過的に格納し、その同じコンテンツへの要求を満たし、Web サーバから同一コンテンツが繰り返し伝送されることを防ぎます。キャッシュ エンジンは、コンテンツ配信を加速させ、最大限のスケーラビリティとコンテンツの可用性を実現します。サービスプロバイダー ネットワークのアクセス ポイント(POP)で、WCCP およびキャッシュ エンジン ソリューションを展開できます。エンタープライズ ネットワークでは、地域ポイントおよび小規模ブランチ オフィスで WCCP およびキャッシュ エンジン ソリューションを展開できます。

この機能を使用するには、元々拡張マルチレイヤ イメージ(EMI)と呼ばれていた IP サービス イメージがスイッチにインストールされている必要があります。


) この章で使用しているコマンドの構文および使用方法の詳細については、『Cisco IOS Configuration Fundamentals Command Reference, Release 12.2』の「System Management Commands」の「WCCP Router Configuration Commands」を参照してください。


この章で説明する内容は、次のとおりです。

「WCCP の概要」

「WCCP の設定」

「WCCP のモニタおよびメンテナンス」

WCCP の概要

WCCP およびシスコのキャッシュ エンジン(または WCCP が稼働している他のキャッシュ エンジン)は、ネットワークでの Web トラフィック パターンをローカライズし、コンテンツ要求がローカルで実現されるようにします。

WCCP により、サポート対象の Cisco ルータおよびスイッチは、コンテンツ要求を透過的にリダイレクトできます。透過リダイレクトを使用すると、ユーザは使用しているブラウザが Web プロキシを使用するように設定する必要がありません。代わりに、ターゲット URL を使用してコンテンツを要求すると、要求が自動的にキャッシュ エンジンにリダイレクトされます。 透過 という用語は、エンド ユーザが、自分の要求したファイル(Web ページなど)が、もとの指定したサーバからではなくキャッシュ エンジンから送信されるのを知らないという意味です。

キャッシュ エンジンは要求を受け取ると、専用のローカル キャッシュから対応しようとします。要求された情報が存在しない場合、キャッシュ エンジンは別個の要求をエンド サーバに送信し、要求された情報を取得します。取得した情報は、キャッシュ エンジンが要求元のクライアントに転送するとともに、その後の要求に応えるため、情報をキャッシュします。

このソフトウェア リリースでは、WCCP バージョン 2(WCCPv2)だけをサポートします。WCCPv2 機能のサブセットのみがサポートされます。詳細については、「サポートしない WCCPv2 機能」を参照してください。

WCCPv2 を使用すると、複数のルータまたはスイッチが、キャッシュ エンジン クラスタ(一連のキャッシュ エンジン)を処理できます。ただし、このリリースでは、図 33-1に示すように、1 台の Catalyst 3550 スイッチのみがクラスタを処理できます。コンテンツは、キャッシュ エンジンでは複製されません。

図 33-1 シスコのキャッシュ エンジンおよび WCCPv2 ネットワーク コンフィギュレーション

 

WCCP メッセージ交換

この一連のイベントでは、WCCP メッセージ交換を説明します。

1. キャッシュ エンジンは、WCCP を使用して IP アドレスを WCCP 対応スイッチに送信し、 Here I am メッセージを通して自己の存在を伝えます。スイッチおよびキャッシュ エンジンは、UDP ポート 2048 に基づき、制御チャネルを介して互いに通信します。

2. WCCP 対応スイッチは、キャッシュ エンジンの IP 情報を使用してクラスタ ビュー(クラスタ内のキャッシュのリスト)を作成します。このビューが、 I see you メッセージでクラスタ内の各キャッシュ エンジンに送信すると、本質的にすべてのキャッシュ エンジンが互いの存在を認識するようになります。クラスタのメンバーシップが一定時間同じままになった後で、安定したビューが確立されます。

3. 安定したビューが確立されると、クラスタ内の低い IP アドレスを持つキャッシュ エンジンが指定キャッシュ エンジンとして選択されます。

WCCP ネゴシエーション

WCCP プロトコル メッセージを交換するとき、指定キャッシュ エンジンおよび WCCP 対応スイッチは次の項目をネゴシエートします。

転送方式(スイッチがパケットをキャッシュ エンジンに転送するときに使用される方式)。スイッチは、パケット宛先 MAC アドレスをターゲット キャッシュ エンジン MAC アドレスに置き換えて、レイヤ 2 ヘッダーを書き換えます。次にスイッチは、パケットをキャッシュ エンジンに転送します。この転送方式では、ターゲット キャッシュ エンジンがレイヤ 2 でスイッチに直接接続されている必要があります。

割り当て方式(パケットをクラスタ内のキャッシュ エンジン間に配信するときに使用される方式)。スイッチは、宛先 IP アドレスの最下位ビットを、どのキャッシュ エンジンがリダイレクトされたパケットを受信するかを決定するために使用します。使用するビット数は、キャッシュ エンジンの数に基づきます。キャッシュ エンジンが 2 のべき乗に等しい場合(たとえば、1、2、4 など)、スイッチは均等にキャッシュ エンジン間にトラフィックを分散(ロード バランス)します。

スイッチは、『 WCCP V2.0 Internet-Draft 説明されているマスク割り当て方式をサポートしていません。

パケット戻し方式(パケットをキャッシュ エンジンから通常の転送用スイッチに戻すときに使用される方式)。キャッシュ エンジンがパケットを拒否し、パケット戻し機能を起動するのには以下の理由があります。

キャッシュ エンジンが過負荷となり、パケットにサービスする余裕がない。

キャッシュ エンジンが Web サーバからエラー メッセージ(プロトコル エラーや認証エラーなど)を受け取り、ダイナミック クライアント バイパス機能を実装している。バイパスは、クライアントがキャッシュ エンジンをバイパスし、Web サーバに直接接続できるようにします。

キャッシュ エンジンはパケットを WCCP 対応スイッチに戻し、キャッシュ エンジンが存在しないかのように Web サーバに転送します。キャッシュ エンジンは、再接続試行を代行受信しません。このようにして、キャッシュ エンジンは効率的にキャッシュ エンジンへのパケットのリダイレクトをキャンセルし、バイパス フローを作成します。スイッチは、総称ルーティング カプセル化(GRE)トンネルを介して戻されたパケットを受信します。スイッチの CPU は Cisco Express Forwarding を使用して、これらのパケットをターゲット Web サーバに送信します。サーバが要求された情報に応答しているとき、スイッチは通常のレイヤ 3 転送を使用して、情報を 要求しているクライアントに戻します。

MD5 セキュリティ

WCCPv2 は各プロトコル メッセージでオプションのセキュリティ コンポーネントを提供し、スイッチとキャッシュ エンジン間のメッセージで MD5 認証をスイッチが使用できるようにします。(スイッチの認証がイネーブルになっているとき)で認証されないメッセージは、スイッチによって廃棄されます。 ip wccp web-cache password password グローバル コンフィギュレーション コマンドを使用してセキュリティ機能をイネーブルにします。パスワード文字列は、MD5 値と組み合され、スイッチとキャッシュ エンジン間の接続のセキュリティを確立します。各キャッシュ エンジンで同じパスワードを設定する必要があります。

パケットのリダイレクト

WCCP がスイッチ上で設定された後、スイッチはクライアントから受信したすべての HTTP TCP ポート 80 パケットをキャッシュ エンジンに転送します。ただし、以下のパケットはリダイレクトされません。

キャッシュ エンジンから発信され、Web サーバに宛てられたパケット

キャッシュ エンジンから発信され、クライアントに宛てられたパケット

キャッシュ エンジンにより返送または拒否されたパケット これらのパケットは、Web サーバに送信されます。

サポートしない WCCPv2 機能

次の WCCPv2 機能は、このソフトウェア リリースでサポートされていません。

ip wccp [ service-number ] グローバルおよびインターフェイス コンフィギュレーション コマンドを使用して設定された WCCP サービス番号。これらのコマンドはサポートされません。

このソフトウェア リリースでは、TCP ポート 80 のキャッシュだけをサポートします。

ip wccp redirect out インターフェイス コンフィギュレーション コマンドを使用して設定された発信インターフェイスでのパケットのリダイレクト (このコマンドはサポートされません)

このソフトウェア リリースでは、着信インターフェイス上でだけでパケットのリダイレクトをサポートします。

複数の Catalyst 3550 スイッチの複数のキャッシュ エンジンへの接続。

このソフトウェア リリースは、複数のキャッシュ エンジンへの 1 台のスイッチのみの接続をサポートします。

WCCP マルチキャスト。 ip wccp web-cache group-address および ip wccp web-cache group listen グローバル コンフィギュレーション コマンドはサポートされません。

WCCP アクセス リスト。 ip wccp web-cache redirect-list および ip wccp web-cache group-list グローバル コンフィギュレーション コマンドはサポートされません。

WCCP 関連カウンタの統計情報。カウンタの統計情報は提供されません。これらは、 show ip wccp web-cache view 特権 EXEC コマンドの出力でゼロとして表示されます。

WCCP の設定

ここでは、スイッチで WCCP を設定する方法について説明します。

「WCCP のデフォルト設定」

「WCCP 設定時の注意事項」

「Web キャッシュ サービスのイネーブル化、パスワードの設定、クライアントから受信したトラフィックのリダイレクト」(必須)

WCCP のデフォルト設定

表 33-1 に、WCCP のデフォルト設定を示します。

 

表 33-1 WCCP のデフォルト設定

機能
デフォルト設定

WCCP イネーブル ステート。

WCCP サービスはディセーブルです。

プロトコル バージョン。

WCCPv2

インターフェイス上で受信したトラフィックのリダイレクト。

ディセーブル

WCCP 設定時の注意事項

スイッチで WCCP を設定する前に、次に挙げる設定時の注意事項を確認してください。

スイッチは GRE を使用したトラフィック転送をサポートしていないため、GRE のキャッシュ エンジンを設定しないでください。詳細については、キャッシュ エンジンに付属するマニュアルを参照してください。

スイッチが WCCP リダイレクトのレイヤ 2 の書き換えを実行できるように、キャッシュ エンジンからスイッチに直接レイヤ 2 接続を作成します。Cisco Cache Engine で直接接続するには、ファスト イーサネット インターフェイスを必要とします。接続が直接レイヤ 2 接続の場合、キャッシュ エンジンに 10/100/1000 ポートを使用してスイッチを接続することもできます。

単一の Catalyst 3550 スイッチに最大 32 台のキャッシュ エンジンを接続します。

複数のキャッシュ エンジンには 1 台の Catalyst 3550 スイッチのみを接続します。複数の Catalyst 3550 スイッチを複数のキャッシュ エンジンに接続しないでください。

Web クライアント、キャッシュ エンジン、およびレイヤ 3 インターフェイスとしての Web サーバ(ルーテッド ポートおよびスイッチ仮想インターフェイス [SVI])に接続されたスイッチ インターフェイスを設定します。HTTP パケットのリダイレクトが機能するためには、サーバ、キャッシュ エンジン、およびクライアントが、異なるサブネット上に存在する必要があります。

同じスイッチ インターフェイス上に、クライアント、キャッシュ エンジン、または Web サーバを設定しないでください。

カスタマー エッジ(CE)デバイスで、WCCP およびマルチ VPN ルーティング/転送(マルチ VRF)の両方を使用してスイッチを設定しないでください。

Switch Database Management(SDM)テンプレートを変更して、スイッチが 144 ビット レイヤ 3 TCAM をサポートできるようにするには、sdm prefer extended-match、sdm prefer access extended-match、または sdm prefer routing extended-match グローバル コンフィギュレーション コマンドを使用します。SDM テンプレートの詳細については、「ユーザ選択機能のためのシステム リソースの最適化」を参照してください。

同じスイッチ インターフェイス上では、WCCP とポリシー ベース ルーティング(PBR)を設定しないでください。

Web キャッシュ サービスのイネーブル化、パスワードの設定、クライアントから受信したトラフィックのリダイレクト

MD5 パスワード セキュリティでは、スイッチとキャッシュ エンジンで同じパスワードを設定する必要があります。各キャッシュ エンジンまたはスイッチは、WCCP メッセージ ヘッダーの検証後すぐに、受信した WCCP パケットのセキュリティ コンポーネントを認証します。認証に失敗したパケットは廃棄されます。

WCCP パケット リダイレクトが機能するために、クライアントに接続されたスイッチ インターフェイスが着信 HTTP パケットをリダイレクトするように設定する必要があります。

この手順では、ルーテッド ポートでこれらの機能を設定する方法を示します。これらの機能を SVI で設定するには、手順に従った設定例を参照してください。

Web キャッシュ サービスのイネーブル化、パスワードの設定、ルーテッド インターフェイスの設定、クライアントから受信した着信パケットのキャッシュ エンジンへのリダイレクトをイネーブルにするには、特権 EXEC モードで次の手順を実行します。この手順は必須です。


) WCCP コマンドを設定する前に SDM テンプレートを設定し、スイッチを再起動します。詳細については、「ユーザ選択機能のためのシステム リソースの最適化」を参照してください。


 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip wccp web-cache [ password encryption-number password ]

スイッチで Web キャッシュ サービスをイネーブルにします。デフォルトでは、この機能はディセーブルになっています。

(任意) [ password encryption-number password ] には、暗号化番号を指定します。指定できる範囲は 0 ~ 7 です。暗号化しない場合は 0、独自の場合は 7 を使用します。7 文字以内でパスワード名を指定します。スイッチは、パスワードと MD5 認証値を組み合わせて、スイッチとキャッシュ エンジンとの接続にセキュリティを確保します。デフォルトでは、パスワードは設定されておらず、認証も実行されていません。

各キャッシュ エンジンで同じパスワードを設定する必要があります。

認証がイネーブルになっている場合、スイッチは認証されないメッセージを廃棄します。

ステップ 3

interface interface-id

キャッシュ エンジンまたは Web サーバに接続されたインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

no switchport

レイヤ 3 モードを開始します。

ステップ 5

ip address ip-address subnet-mask

IP アドレスおよびサブネット マスクを設定します。

ステップ 6

no shutdown

インターフェイスをイネーブルにします。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。各キャッシュ エンジンおよび Web サーバにステップ 3 ~ 7 を繰り返します。

ステップ 8

interface interface-id

クライアントに接続するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

no switchport

レイヤ 3 モードを開始します。

ステップ 10

ip address ip-address subnet-mask

IP アドレスおよびサブネット マスクを設定します。

ステップ 11

no shutdown

インターフェイスをイネーブルにします。

ステップ 12

ip wccp web-cache redirect in

クライアントから受信したパケットをキャッシュ エンジンにリダイレクトします。

ステップ 13

exit

グローバル コンフィギュレーション モードに戻ります。各クライアントにステップ 8 ~ 13 を繰り返します。

ステップ 14

end

特権 EXEC モードに戻ります。

ステップ 15

show ip wccp web-cache

および

show running-config

設定を確認します

ステップ 16

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

Web キャッシュ サービスをディセーブルにするには、 no ip wccp web-cache グローバル コンフィギュレーション コマンドを使用します。着信パケット リダイレクトをディセーブルにするには、 no ip wccp web-cache redirect in インターフェイス コンフィギュレーション コマンドを使用します。

次に、ルーテッド インターフェイスを設定し、Web キャッシュ サービスをイネーブルにする例を示します。ファスト イーサネット ポート 1 はキャッシュ エンジンに接続され、IP アドレス 172.20.10.30 のルーテッド ポートとして設定され、再イネーブル化されています。ギガビット イーサネット ポート 1 はインターネット経由で Web サーバに接続され、IP アドレス 175.20.20.10 のルーテッド ポートとして設定され、再イネーブル化されています。ファスト イーサネット ポート 2 ~ 5 はクライアントに接続され、IP アドレス 175.20.30.20、175.20.40.30、175.20.50.40、および 175.20.60.50 のルーテッド ポートとして設定されています。スイッチは、クライアント インターフェイスから受信した HTTP パケットをキャッシュ エンジンにリダイレクトします。

Switch# configure terminal
Switch(config)# ip wccp web-cache
Switch(config)# interface fastethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 172.20.10.30 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 175.20.20.10 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface fastethernet0/2
Switch(config-if)# no switchport
Switch(config-if)# ip address 175.20.30.20 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)# ip wccp web-cache redirect in
Switch(config-if)# exit
Switch(config)# interface fastethernet0/3
Switch(config-if)# no switchport
Switch(config-if)# ip address 175.20.40.30 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)# ip wccp web-cache redirect in
Switch(config-if)# exit
Switch(config)# interface fastethernet0/4
Switch(config-if)# no switchport
Switch(config-if)# ip address 175.20.50.40 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)# ip wccp web-cache redirect in
Switch(config-if)# exit
Switch(config)# interface fastethernet0/5
Switch(config-if)# no switchport
Switch(config-if)# ip address 175.20.60.50 255.255.255.0
Switch(config-if)# no shutdown
Switch(config-if)# ip wccp web-cache redirect in
Switch(config-if)# exit
 

次に、SVI を設定し、Web キャッシュ サービスをイネーブルにする例を示します。VLAN 299 は、IP アドレス 175.20.20.10 で作成および設定されています。ギガビット イーサネットのポート 1 をインターネット経由で Web サーバに接続し、VLAN 299 のアクセス ポートとして設定します。VLAN 300 は、IP アドレス 172.20.10.30 で作成および設定されています。ファスト イーサネット ポート 1 はキャッシュ エンジンに接続され、VLAN 300 のアクセス ポートとして設定されています。VLAN 301 は、IP アドレス 175.20.30.50 で作成および設定されています。クライアントに接続されているファスト イーサネット ポート 2 ~ 5 は、VLAN 301 のアクセス ポートとして設定されています。スイッチは、クライアント インターフェイスから受信した HTTP パケットをキャッシュ エンジンにリダイレクトします。

Switch# configure terminal
Switch(config)# ip wccp web-cache
Switch(config)# vlan 299
Switch(config-vlan)# exit
Switch(config)# interface vlan 299
Switch(config-if)# ip address 175.20.20.10 255.255.255.0
Switch(config-if)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 299
Switch(config)# vlan 300
Switch(config-vlan)# exit
Switch(config)# interface vlan 300
Switch(config-if)# ip address 172.20.10.30 255.255.255.0
Switch(config-if)# exit
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 300
Switch(config-if)# exit
Switch(config)# vlan 301
Switch(config-vlan)# exit
Switch(config)# interface vlan 301
Switch(config-if)# ip address 175.20.30.20 255.255.255.0
Switch(config-if)# ip wccp web-cache redirect in
Switch(config-if)# exit
Switch(config)# interface range fastethernet0/2 - 5
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 301
Switch(config-if-range)# exit
 

WCCP のモニタおよびメンテナンス

WCCP をモニタしてメンテナンスするには、 表 33-2 に記載された特権 EXEC コマンドを 1 つまたは複数使用します。

 

表 33-2 WCCP のモニタおよびメンテナンスのためのコマンド

コマンド
目的

clear ip wccp web-cache

Web キャッシュ サービスの統計情報を削除します。

show ip wccp web-cache

WCCP に関連するグローバル情報を表示します。

show ip wccp web-cache detail

WCCP クラスタのスイッチおよびすべてのキャッシュ エンジンの情報を表示します。

show ip interface

たとえば、「 Web Cache Redirect is enabled / disabled. 」など、インターフェイス上で設定された IP WCCP リダイレクト コマンドに関するステータスを表示します。

show ip wccp web-cache view

他のどのメンバが検出されたか、またはされなかったのかを表示します。