Catalyst 3550 マルチレイヤ スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)SEC
VLAN の設定
VLAN の設定
発行日;2013/09/26 | 英語版ドキュメント(2009/02/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

VLAN の設定

VLAN の概要

サポートされる VLAN

VLAN ポート メンバーシップ モード

標準範囲 VLAN の設定

トークンリング VLAN

標準範囲 VLAN 設定時の注意事項

VLAN コンフィギュレーション モードのオプション

config-vlan モードでの VLAN 設定

VLAN コンフィギュレーション モードでの VLAN 設定

VLAN 設定の保存

イーサネット VLAN のデフォルト設定

イーサネット VLAN の作成または変更

VLAN の削除

VLAN へのスタティック アクセス ポートの割り当て

拡張範囲 VLAN の設定

VLAN のデフォルト設定

拡張範囲 VLAN 設定時の注意事項

拡張範囲 VLAN の作成

内部 VLAN ID を指定した拡張範囲 VLAN の作成

VLAN の表示

VLAN トランクの設定

トランキングの概要

カプセル化タイプ

IEEE 802.1Q の設定に関する考慮事項

レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

トランク ポートとしてのイーサネット インターフェイスの設定

他の機能との相互作用

トランク ポートの設定

トランクでの許可 VLAN の定義

プルーニング適格リストの変更

タグなしトラフィック用ネイティブ VLAN の設定

STP による負荷分散

STP ポート プライオリティによる負荷分散

STP パス コストによる負荷分散

VMPS の設定

VMPS の概要

ダイナミック ポート VLAN メンバーシップ

VMPS データベース コンフィギュレーション ファイル

VMPS クライアントのデフォルト設定

VMPS 設定時の注意事項

VMPS クライアントの設定

VMPS の IP アドレスの入力

VMPS クライアント上のダイナミックアクセス ポートの設定

VLAN メンバーシップの再確認

再確認インターバルの変更

再試行回数の変更

VMPS のモニタリング

ダイナミック ポート VLAN メンバーシップのトラブルシューティング

VMPS の設定例

VLAN の設定

この章では、Catalyst 3550 スイッチでの標準範囲 VLAN(VLAN ID 1 ~ 1005)および拡張範囲 VLAN(VLAN ID 1006 ~ 4094)の設定手順について説明します。また、VLAN モードおよび VLAN Membership Policy Server(VMPS)に関する情報が含まれます。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「VLAN の概要」

「標準範囲 VLAN の設定」

「拡張範囲 VLAN の設定」

「VLAN の表示」

「VLAN トランクの設定」

「VMPS の設定」

VLAN の概要

VLAN は、ユーザの物理的な位置に関係なく、機能、プロジェクト チーム、またはアプリケーションなどで論理的に分割されたスイッチド ネットワークです。VLAN は、物理 LAN と同じ属性をすべて備えていますが、同じ LAN セグメントに物理的に配置されていないエンド ステーションもグループ化できます。どのスイッチ ポートも VLAN に割り当てることができます。ユニキャスト、ブロードキャスト、およびマルチキャスト パケットは、VLAN 内のエンド ステーションだけに転送およびフラッディングが行われます。各 VLAN は 1 つの論理ネットワークと見なされ、VLAN に属さないステーション宛のパケットは、ルータまたはブリッジを経由して伝送しなければなりません(図 11-1を参照)。VLAN はそれぞれが独立した論理ネットワークと見なされるので、VLAN ごとに独自の MIB 情報があり、それぞれが独自にスパニングツリーの実装をサポートします。「STP の設定」および「MSTP の設定」を参照してください。


) VLAN を作成する前に、VLAN トランキング プロトコル(VTP)を使用してネットワークのグローバルな VLAN 設定を維持するかどうかを決定する必要があります。VTP の詳細については、「VTP の設定」を参照してください。


図 11-1 に、論理的に定義されたネットワークにセグメント化された VLAN の例を示します。

図 11-1 論理的に定義されたネットワークとしての VLAN

 

VLAN は通常、IP サブネットワークに対応付けられます。たとえば、特定の IP サブネットに含まれるエンド ステーションはすべて同じ VLAN に属します。スイッチ上のインターフェイスの VLAN メンバーシップは、インターフェイスごとに手動で割り当てます。この方法でスイッチ インターフェイスを VLAN に割り当てた場合、これをインターフェイス ベース(またはスタティック)VLAN メンバーシップと呼びます。

VLAN 間のトラフィックは、ルーティングまたはフォールバック ブリッジングする必要があります。Catalyst 3550 スイッチは、Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)を使用して、VLAN 間でトラフィックをルーティングできます。VLAN 間でトラフィックをルーティングするには、SVI を明示的に設定して IP アドレスを割り当てる必要があります。詳細については、「スイッチ仮想インターフェイス」および「レイヤ 3 インターフェイスの設定」を参照してください。

サポートされる VLAN

Catalyst 3550 スイッチは、VTP クライアント、サーバ、およびトランスペアレントの各モードで 1005 の VLAN をサポートしています。VLAN は、1 ~ 4094 の番号で識別されます。VLAN ID 1002 ~ 1005 は、トークンリングおよびファイバ分散データ インターフェイス(FDDI)VLAN 専用です。VTP は、VLAN ID が 1 ~ 1005 の標準範囲 VLAN のみを学習します。1005 を超える VLAN ID は拡張範囲 VLAN と呼ばれ、VLAN データベースには格納されません。1006 ~ 4094 の VLAN ID を作成する場合は、スイッチを VTP トランスペアレント モードにする必要があります。

スイッチは、最大 128 のスパニングツリー インスタンスを持つ Per-VLAN Spanning-Tree Plus(PVST+)および Rapid PVST+ をサポートします。VLAN ごとに 1 つずつスパニングツリー インスタンスを使用できます。スパニングツリー インスタンス数および VLAN 数の詳細については、「標準範囲 VLAN 設定時の注意事項」を参照してください。スイッチは、イーサネット ポート経由の VLAN トラフィックの送信方式として、Inter-Switch Link(ISL)および IEEE 802.1Q トランキングの両方をサポートします。

VLAN ポート メンバーシップ モード

VLAN に属するポートは、メンバーシップ モードを割り当てることで設定します。メンバーシップ モードは、各ポートが伝送できるトラフィックの種類、および所属できる VLAN の数を決定します。 表 11-1 に、各種メンバーシップ モード、およびそれぞれのメンバーシップと VTP の特性を示します。

 

表 11-1 ポート メンバーシップ モード

メンバーシップ モード
VLAN メンバーシップの特性
VTP の特性

スタティック アクセス

スタティック アクセス ポートは、手動で割り当てられ、1 つの VLAN だけに所属します。詳細については、「VLAN へのスタティック アクセス ポートの割り当て」を参照してください。

VTP は必須ではありません。VTP を使用して情報をグローバルに伝播させない場合は、VTP モードをトランスペアレントに設定して、VTP をディセーブルにします。VTP に加入するには、あるスイッチのトランク ポートに接続した別のスイッチ上に 1 つまたは複数のトランク ポートがなければなりません。

トランク(ISL または
IEEE 802.1Q)

デフォルトで、トランク ポートは拡張範囲 VLAN を含むすべての VLAN のメンバです。ただし、メンバーシップは許可 VLAN リストを設定して制限できます。また、プルーニング適格リストを変更して、リストに指定したトランク ポート上の VLAN へのフラッディング トラフィックを阻止することもできます。トランク ポートの設定については、「トランク ポートとしてのイーサネット インターフェイスの設定」を参照してください。

VTP を推奨しますが、必須ではありません。VTP は、ネットワーク全体にわたって VLAN の追加、削除、名前変更を管理することにより、VLAN 設定の整合性を維持します。VTP はトランク リンクを通じて他のスイッチと VLAN コンフィギュレーション メッセージを交換します。

ダイナミック アクセス

ダイナミック アクセス ポートは 1 つの VLAN(VLAN ID が 1 ~ 4094)に所属でき、VMPS によって動的に割り当てられます。VMPS には Catalyst 5000 または Catalyst 6500 シリーズ スイッチを使用できますが、Catalyst 3550 スイッチは使用できません。

同一スイッチ上でダイナミックアクセス ポートとトランク ポートを使用できますが、ダイナミックアクセス ポートは別のスイッチではなく、エンド ステーションに接続する必要があります。

設定については、「VMPS クライアント上のダイナミックアクセス ポートの設定」を参照してください。

VTP は必須です。

VMPS およびクライアントを同じ VTP ドメイン名で設定してください。

VMPS クライアント スイッチの再確認間隔とリトライ回数を変更できます。

音声 VLAN

音声 VLAN ポートは、Cisco IP Phone に接続し、電話に接続されたデバイスからの音声トラフィックに 1 つの VLAN を、データ トラフィックに別の VLAN を使用するように設定されたアクセス ポートです。音声 VLAN ポートの詳細については、「音声 VLAN の設定」を参照してください。

VTP は必須ではなく、音声 VLAN には影響を与えません。

トンネル( dot1q-tunnel

トンネル ポートは、サービスプロバイダー ネットワーク上でカスタマー VLAN の整合性を保つための 802.1Q トンネリングに使用されます。トンネル ポートは、サービスプロバイダー ネットワークのエッジ スイッチ上に設定し、カスタマー インターフェイスの 802.1Q トランク ポートに接続して、非対称リンクを作成します。トンネル ポートは、トンネリング専用の単一の VLAN に属します。

トンネル ポートの詳細については、「IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングの設定」を参照してください。

VTP は必須ではありません。 switchport access vlan インターフェイス コンフィギュレーション コマンドを使用して、手動で VLAN にトンネル ポートを割り当てます。

モードとその機能の詳しい定義については、表 11-4 を参照してください。

ポートが VLAN に所属すると、スイッチは VLAN 単位で、ポートに対応するアドレスを学習して管理します。詳細については、「MAC アドレス テーブルの管理」を参照してください。

標準範囲 VLAN の設定

標準範囲 VLAN は、VLAN ID が 1 ~ 1005 の VLAN です。スイッチが VTP サーバ モードまたはトランスペアレント モードになっている場合は、VLAN データベース内の VLAN 2 ~ 1001 に設定を追加、変更、または削除できます (VLAN ID 1 および 1002 ~ 1005 は自動作成され、削除できません)。


) スイッチが VTP トランスペアレント モードの場合、拡張範囲 VLAN(ID が 1006 ~ 4094 の VLAN)も作成できます。ただし、これらの拡張範囲 VLAN は VLAN データベースに保存されません。「拡張範囲 VLAN の設定」を参照してください。


VLAN ID 1 ~ 1005 の設定はファイル vlan.dat (VLAN データベース)に書き込まれます。この設定を表示するには、 show vlan 特権 EXEC コマンドを入力します。 vlan.dat ファイルはフラッシュ メモリに格納されます。


注意 vlan.dat ファイルを手動で削除しようとすると、VLAN データベースの不整合が生じる可能性があります。VLAN 設定を変更する場合は、ここに記載されたコマンド、およびこのリリースに対応するコマンド リファレンスに記載されたコマンドを使用します。VTP 設定の変更手順については「VTP の設定」を参照してください。

さらに、インターフェイス コンフィギュレーション モードを使用して、ポートのメンバーシップ モードの定義、VLAN に対するポートの追加および削除を行います。これらのコマンドの実行結果は、実行コンフィギュレーション ファイルに書き込まれます。このファイルを表示するには、 show running-config 特権 EXEC コマンドを使用します。

VLAN データベースに新しい標準範囲 VLAN を作成したり、VLAN データベース内の既存の VLAN を変更したりする場合、次のパラメータを設定できます。

VLAN ID

VLAN 名

VLAN タイプ(イーサネット、FDDI、FDDI Network Entity Title(NET)、TrBRF または TrCRF、トークンリング、トークンリング Net)

VLAN ステート(アクティブまたは中断)

VLAN の最大伝送単位(MTU)

Security Association Identifier(SAID)

TrBRF VLAN のブリッジ識別番号

FDDI および TrCRF VLAN のリング番号

TrCRF VLAN の親 VLAN 番号

TrCRF VLAN のスパニングツリー プロトコル(STP)タイプ

ある VLAN タイプから別の VLAN タイプに変換するときに使用する VLAN 番号


) ここでは、これらのパラメータの大部分の設定手順について説明しません。VLAN 設定を制御するコマンドおよびパラメータの詳細については、このリリースに対応するコマンド リファレンスを参照してください。


ここでは、標準範囲 VLAN に関する次の情報について説明します。

「トークンリング VLAN」

「標準範囲 VLAN 設定時の注意事項」

「VLAN コンフィギュレーション モードのオプション」

「VLAN 設定の保存」

「イーサネット VLAN のデフォルト設定」

「イーサネット VLAN の作成または変更」

「VLAN の削除」

「VLAN へのスタティック アクセス ポートの割り当て」

トークンリング VLAN

このスイッチはトークンリング接続をサポートしていませんが、トークンリング接続を行っている Catalyst 5000 シリーズ スイッチなどのリモート デバイスを、サポート対象スイッチのうちの 1 台から管理できます。VTP バージョン 2 が稼働しているスイッチは、次のトークンリング VLAN に関する情報をアドバタイズします。

トークンリング TrBRF VLAN

トークンリング TrCRF VLAN

トークンリング VLAN の詳しい設定手順については、『 Catalyst 5000 Series Software Configuration Guide 』を参照してください。

標準範囲 VLAN 設定時の注意事項

ネットワーク内で標準範囲 VLAN を作成または変更する場合には、次の注意事項に従ってください。

スイッチは、VTP クライアント、サーバ、およびトランスペアレントの各モードで 1005 の VLAN をサポートしています。

標準範囲 VLAN は、1 ~ 1001 の番号で識別します。VLAN 番号 1002 ~ 1005 は、トークンリングおよび FDDI VLAN 専用です。

VLAN 1 ~ 1005 の VLAN 設定は、常に VLAN データベースに格納されます。VTP モードがトランスペアレント モードの場合、VTP と VLAN の設定もスイッチの実行コンフィギュレーション ファイルに保存されます。

スイッチは VTP トランスペアレント モード(VTP はディセーブル)で、VLAN ID 1006 ~ 4094 もサポートします。これらは拡張範囲 VLAN であり、設定オプションには制限があります。拡張範囲 VLAN は、VLAN データベースには保存されません。「拡張範囲 VLAN の設定」を参照してください。

VLAN を作成する前に、スイッチを VTP サーバ モードまたは VTP トランスペアレント モードにしておく必要があります。スイッチが VTP サーバである場合は、VTP ドメインを定義する必要があります。VTP ドメインを定義しないと、VTP は機能しません。

スイッチは、トークンリングまたは FDDI メディアをサポートしません。スイッチは FDDI、FDDI-Net、TrCRF、または TrBRF トラフィックを伝送しませんが、VTP を介して VLAN 設定を伝播します。

スイッチは 128 のスパニングツリー インスタンスをサポートします。スイッチのアクティブな VLAN 数が、サポートされているスパニングツリー インスタンス数よりも多い場合、スパニングツリーは 128 の VLAN でイネーブルにできます。残りの VLAN で、スパニングツリーはディセーブルになります。スイッチ上の使用可能なスパニングツリー インスタンスをすべて使い切ってしまった後に、VTP ドメインの中にさらに別の VLAN を追加すると、そのスイッチ上にスパニングツリーが稼働しない VLAN が生成されます。そのスイッチのトランク ポート上でデフォルトの許可リスト(すべての VLAN を許可するリスト)が設定されていると、すべてのトランク ポート上に新しい VLAN が割り当てられます。ネットワーク トポロジによっては、新しい VLAN 上で、切断されないループが生成されることがあります。特に、複数の隣接スイッチでスパニングツリー インスタンスをすべて使用してしまっている場合には注意が必要です。スパニングツリー インスタンスの割り当てを使い果たしたスイッチのトランク ポートに許可リストを設定することにより、このような可能性を防ぐことができます。

スイッチ上の VLAN 数がサポートされるスパニングツリー インスタンス数を超える場合は、IEEE 802.1S Multiple STP(MSTP)をスイッチに設定して、複数の VLAN を単一の STP インスタンスにマッピングすることを推奨します。MSTP の詳細については、「MSTP の設定」を参照してください。

VLAN コンフィギュレーション モードのオプション

標準範囲 VLAN(VLAN ID が 1 ~ 1005)を設定するには、次に示す 2 つのコンフィギュレーション モードを使用します。

「config-vlan モードでの VLAN 設定」

config-vlan モードを開始するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを入力します。

「VLAN コンフィギュレーション モードでの VLAN 設定」

VLAN データベース コンフィギュレーション モードを開始するには、 vlan database 特権 EXEC コマンドを入力します。

config-vlan モードでの VLAN 設定

config-vlan モードを開始するには、VLAN ID を指定して vlan グローバル コンフィギュレーション コマンドを入力します。VLAN を新規に作成するには新しい VLAN ID を、VLAN を変更するには、既存の VLAN ID を入力します。デフォルトの VLAN 設定を使用するか( 表 11-2 を参照)、複数のコマンドを入力して VLAN を設定できます。このモードで使用できるコマンドの詳細については、このリリースのコマンド リファレンスに記載されている vlan グローバル コンフィギュレーション コマンドを参照してください。設定を終了したら、config-vlan モードを終了して、設定を有効にする必要があります。VLAN 設定を表示するには、 show vlan 特権 EXEC コマンドを入力します。

この config-vlan モードは、拡張範囲 VLAN(VLAN ID が 1005 より大きい)を作成するときに使用する必要があります。「拡張範囲 VLAN の設定」を参照してください。

VLAN コンフィギュレーション モードでの VLAN 設定

VLAN コンフィギュレーション モードを開始するには、 vlan database 特権 EXEC コマンドを入力します。次に、新しい VLAN ID を指定して vlan コマンドを入力して VLAN を作成するか、既存の VLAN ID を入力して VLAN を変更します。デフォルトの VLAN 設定を使用するか( 表 11-2 を参照)、複数のコマンドを入力して VLAN を設定できます。このモードで使用できるキーワードの詳細については、このリリースのコマンド リファレンスに記載されている vlan VLAN コンフィギュレーション コマンドを参照してください。設定を終了したら、 apply または exit を入力して、設定を有効にする必要があります。 exit コマンドを入力すると、すべてのコマンドが適用されて、VLAN データベースが更新されます。VTP ドメイン内の他のスイッチに VTP メッセージが送信され、特権 EXEC モード プロンプトが表示されます。

VLAN 設定の保存

VLAN ID 1 ~ 1005 の設定は、常に VLAN データベースに保存されます(vlan.dat ファイル)。VTP モードがトランスペアレント モードの場合は、スイッチの実行コンフィギュレーション ファイルへの保存も行われるため、 copy running-config startup-config 特権 EXEC コマンドを入力して設定をスタートアップ コンフィギュレーション ファイルに保存できます。 show running-config vlan 特権 EXEC コマンドを使用して、スイッチの実行コンフィギュレーション ファイルを表示できます。VLAN 設定を表示するには、 show vlan 特権 EXEC コマンドを入力します。

VLAN および VTP 情報(拡張範囲 VLAN 設定情報を含む)をスタートアップ コンフィギュレーション ファイルに保存して、スイッチを再起動すると、スイッチの設定は次のように決定されます。

スタートアップ コンフィギュレーションの VTP モードがトランスペアレントであり、VLAN データベースと VLAN データベース内の VTP ドメイン名がスタートアップ コンフィギュレーション ファイルの内容に一致する場合は、VLAN データベースが無視され(クリアされ)ます。スタートアップ コンフィギュレーション ファイル内の VTP および VLAN 設定が使用されます。VLAN データベース内の VLAN データベース リビジョン番号は変更されません。

スタートアップ コンフィギュレーション内の VTP モードまたはドメイン名が VLAN データベースと一致しない場合、最初の 1005 個の VLAN ID のドメイン名、VTP モード、および設定には、VLAN データベース情報が使用されます。

VTP モードがサーバの場合、最初の 1005 個の VLAN ID のドメイン名および VLAN 設定には VLAN データベース情報が使用されます。

スイッチが Cisco IOS Release 12.1(9)EA1 以降を実行し、古いスタートアップ コンフィギュレーション ファイルを使用してスイッチを起動した場合、コンフィギュレーション ファイルに VTP または VLAN 情報が含まれていないため、スイッチには VLAN データベース設定が使用されます。

スイッチで 12.1(9)EA1 よりも前の Cisco IOS リリースが動作しており、スイッチのブートに Cisco IOS Release 12.1(9)EA1 以降のスタートアップ コンフィギュレーション ファイルを使用した場合、スイッチのイメージは、スタートアップ コンフィギュレーション ファイルの VLAN および VTP 設定を認識しないので、スイッチは VLAN データベース設定を使用します。


注意 VLAN データベース設定が起動時に使用され、スタートアップ コンフィギュレーション ファイルに拡張範囲 VLAN 設定が含まれている場合、この情報はシステムの起動時に失われます。

イーサネット VLAN のデフォルト設定

表 11-2 にイーサネット VLAN のデフォルト設定を示します。


) スイッチがサポートするのは、イーサネット インターフェイスだけです。FDDI およびトークンリング VLAN は、ローカルではサポートされないので、FDDI およびトークンリング メディア固有の特性は、他のスイッチに対する VTP グローバル アドバタイズにのみ設定します。


 

表 11-2 イーサネット VLAN のデフォルトおよび範囲

パラメータ
デフォルト
範囲

VLAN 名

VLANxxxx xxxx は VLAN ID 番号に等しい 4 桁の数字(先行ゼロを含む)です。

範囲なし

IEEE 802.10 SAID

100001(100000 と VLAN ID の和)

1 ~ 4294967294

MTU サイズ

1500

1500 ~ 18190

トランスレーショナル ブリッジ 1

0

0 ~ 1005

トランスレーショナル ブリッジ 2

0

0 ~ 1005

VLAN ステート

active

アクティブ、中断

リモート SPAN

disabled

イネーブル、ディセーブル

イーサネット VLAN の作成または変更

VLAN データベース内の各イーサネット VLAN には、1 ~ 1001 の 4 桁の一意の ID が設定されています。VLAN ID 1002 ~ 1005 は、トークンリングおよび FDDI VLAN 用に予約されています。標準範囲 VLAN を作成して VLAN データベースに追加するには、VLAN に番号および名前を割り当てます。


) スイッチが VTP トランスペアレント モードの場合、1006 を超える VLAN ID を割り当てることができますが、それらは VLAN データベースには追加されません。「拡張範囲 VLAN の設定」を参照してください。


VLAN の追加時に指定されるデフォルト パラメータの一覧は、「標準範囲 VLAN の設定」を参照してください。

config-vlan モードを使用してイーサネット VLAN を作成または変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id

VLAN ID を入力して、config-vlan モードを開始します。VLAN を新規に作成するには新しい VLAN ID を、既存の VLAN を変更するには、その VLAN ID を入力します。

(注) このコマンドで指定できる VLAN ID 範囲は 1 ~ 4094 です。1005 を超える VLAN ID(拡張範囲 VLAN)を追加する手順については、「拡張範囲 VLAN の設定」を参照してください。

ステップ 3

name vlan-name

(任意)VLAN の名前を入力します。名前を指定しなかった場合には、デフォルトとして、VLAN という語の後ろに先行ゼロを含めた vlan-id が付加されます。たとえば、VLAN 4 のデフォルトの VLAN 名は VLAN0004 になります。

ステップ 4

mtu mtu-size

(任意)MTU サイズ(または他の VLAN 特性)を変更します。

ステップ 5

remote-span

(任意)リモート SPAN セッションに対する RSPAN VLAN として、VLAN を設定します。リモート SPAN の詳細は、「SPAN および RSPAN の設定」を参照してください。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show vlan { name vlan-name | id vlan-id }

入力内容を確認します。

ステップ 8

copy running-config startup config

(任意)スイッチが VTP トランスペアレント モードである場合、VLAN 設定は実行コンフィギュレーション ファイルと VLAN データベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLAN 名をデフォルトの設定に戻すには、 no vlan name no vlan mtu 、または no remote span コマンドを使用します。

次に、config-vlan モードを使用して、イーサネット VLAN 20 を作成し、 test20 という名前を付け、VLAN データベースに追加する例を示します。

Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end
 

VLAN コンフィギュレーション モードを使用してイーサネット VLAN を作成または変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

vlan database

VLAN データベース コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id name vlan-name

番号を割り当てることによって、イーサネット VLAN を追加します。指定できる範囲は 1 ~ 1001 です。先行ゼロは入力しないでください。

名前を指定しなかった場合には、デフォルトとして、VLAN という語の後ろに先行ゼロを含めた vlan-id が付加されます。たとえば、VLAN 4 のデフォルトの VLAN 名は VLAN0004 になります。

ステップ 3

vlan vlan-id mtu mtu-size

(任意)VLAN を変更するには、VLAN を指定し、MTU サイズなどの特性を変更します。

ステップ 4

exit

VLAN データベースをアップデートし、アップデート情報を管理ドメイン全体に伝播して、特権 EXEC モードに戻ります。

ステップ 5

show vlan { name vlan-name | id vlan-id }

入力内容を確認します。

ステップ 6

copy running-config startup config

(任意)スイッチが VTP トランスペアレント モードである場合、VLAN 設定は実行コンフィギュレーション ファイルと VLAN データベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。


) VLAN データベース コンフィギュレーション モードの場合は、RSPAN VLAN を設定できません。


VLAN 名をデフォルト設定に戻すには、 no vlan vlan-id name VLAN コンフィギュレーション コマンドを使用します。

次に、VLAN コンフィギュレーション モードを使用してイーサネット VLAN 20 を作成し、 test20 という名前を付け、VLAN データベースに追加する例を示します。

Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
APPLY completed.
Exiting....
Switch#

VLAN の削除

VTP サーバ モードのスイッチから VLAN を削除すると、VTP ドメイン内のすべてのスイッチの VLAN データベースから、その VLAN が削除されます。VTP トランスペアレント モードのスイッチから VLAN を削除した場合、そのスイッチ上に限り VLAN が削除されます。

イーサネット VLAN 1 および FDDI、またはトークンリング VLAN 1002 ~ 1005 の、メディア タイプ別のデフォルト VLAN は削除できません。


注意 VLAN を削除すると、その VLAN に割り当てられていたすべてのポートが非アクティブになります。これらのポートは、新しい VLAN に割り当てられるまで、元の VLAN に(非アクティブで)対応付けられたままです。

グローバル コンフィギュレーション モードを使用してスイッチ上の VLAN を削除するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no vlan vlan-id

VLAN ID を入力して、VLAN を削除します。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show vlan brief

VLAN が削除されたことを確認します。

ステップ 5

copy running-config startup config

(任意)スイッチが VTP トランスペアレント モードである場合、VLAN 設定は実行コンフィギュレーション ファイルと VLAN データベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLAN データベース コンフィギュレーション モードで VLAN を削除するには、 vlan database 特権 EXEC コマンド使用して、VLAN データベース コンフィギュレーション モードを開始してから、 no vlan vlan-id VLAN コンフィギュレーション コマンドを実行します。

VLAN へのスタティック アクセス ポートの割り当て

VTP をディセーブルにすることによって(VTP トランスペアレント モード)、VTP に VLAN 設定情報をグローバルに伝播させずに、スタティック アクセス ポートを VLAN に割り当てることができます。クラスタ メンバ スイッチのポートを VLAN に割り当てる場合、最初に rcommand 特権 EXEC コマンドを使用して、そのメンバ スイッチにログインします。


) 存在しない VLAN にインターフェイスを割り当てると、新しい VLAN が作成されます (「イーサネット VLAN の作成または変更」を参照)。


VLAN データベース内の VLAN にポートを割り当てるには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

VLAN に追加するインターフェイスを入力します。

ステップ 3

switchport mode access

ポート(レイヤ 2 アクセス ポート)の VLAN メンバーシップ モードを定義します。

ステップ 4

switchport access vlan vlan-id

VLAN にポートを割り当てます。指定できる VLAN ID の範囲は 1 ~ 4094 です。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show running-config interface interface-id

インターフェイスの VLAN メンバーシップ モードを確認します。

ステップ 7

show interfaces interface-id switchport

表示された Administrative Mode および Access Mode VLAN フィールドの設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 default interfac e interface-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、VLAN 2 のアクセス ポートとしてポートを設定する例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end
Switch#

拡張範囲 VLAN の設定

スイッチが VTP トランスペアレント モード(VTP がディセーブル)の場合、拡張範囲 VLAN(VLAN ID が許可されているどのスイッチ ポート コマンドに対しても 1006 ~ 4094)を作成できます。config-vlan モードを開始し、拡張範囲 VLAN を設定するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを入力します。VLAN データベース コンフィギュレーション モード( vlan database 特権 EXEC コマンドを入力してアクセスします)は、拡張範囲をサポートしません。

拡張範囲 VLAN 設定は、VLAN データベースには保存されません。VTP モードはトランスペアレントであるため、それらの設定はスイッチの実行コンフィギュレーション ファイルに格納されます。 copy running-config startup-config 特権 EXEC コマンドを使用すると、スタートアップ コンフィギュレーション ファイルに設定を保存できます。


) スイッチは 4094 の VLAN ID をサポートしますが、実際にサポートされる VLAN の数については、「サポートされる VLAN」を参照してください。


ここでは拡張範囲 VLAN について説明します。内容は次のとおりです。

「VLAN のデフォルト設定」

「拡張範囲 VLAN 設定時の注意事項」

「拡張範囲 VLAN の作成」

「内部 VLAN ID を指定した拡張範囲 VLAN の作成」

VLAN のデフォルト設定

表 11-2 にイーサネット VLAN のデフォルト設定を示します。拡張範囲 VLAN については MTU サイズしか変更できません。残りの特性はデフォルト状態のままにしておく必要があります。

拡張範囲 VLAN 設定時の注意事項

拡張範囲 VLAN を作成するときは次の注意事項に従ってください。

拡張範囲 VLAN を追加するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを使用して、config-vlan モードを開始する必要があります。VLAN データベース コンフィギュレーション モード(開始するには vlan database 特権 EXEC コマンドを入力)では、拡張範囲 VLAN を追加できません。

拡張範囲の VLAN ID は、VLAN データベースに保存されず、VTP で認識されません。

プルーニング適格範囲に拡張範囲 VLAN を含めることはできません。

拡張範囲 VLAN を作成するときは、スイッチを VTP トランスペアレント モードにする必要があります。VTP モードがサーバまたはクライアントの場合、エラー メッセージが生成され、拡張範囲 VLAN が拒否されます。

グローバル コンフィギュレーション モードまたは VLAN データベース コンフィギュレーション モードで、VTP モードをトランスペアレントに設定できます。「VTP のディセーブル化(VTP トランスペアレント モード)」を参照してください。VTP トランスペアレント モードでスイッチが始動するように、この設定をスタートアップ コンフィギュレーションに保存する必要があります。このようにしないと、スイッチをリセットした場合に、拡張範囲 VLAN 設定が失われます。

拡張範囲 VLAN は VQP でサポートされません。それらの VLAN は、VMPS によって設定できません。

拡張範囲 VLAN では、STP はデフォルトでイネーブルになりますが、no spanning-tree vlan vlan-id グローバル コンフィギュレーション コマンドを使用してディセーブルにできます。スイッチ上に最大数(128)のスパニングツリー インスタンスが存在している場合、新たに作成されるどの VLAN でもスパニングツリーはディセーブルになります。スイッチ上の VLAN 数がサポートされるスパニングツリー インスタンスの最大数を超える場合は、IEEE 802.1S Multiple STP(MSTP)をスイッチに設定して、複数の VLAN を単一の STP インスタンスにマッピングすることを推奨します。MSTP の詳細については、「MSTP の設定」を参照してください。

Catalyst 3550 スイッチ上の各ルーテッド ポートは、内部 VLAN を使用するために作成します。この内部 VLAN は拡張範囲 VLAN 番号を使用し、その内部 VLAN ID は拡張範囲 VLAN には使用できません。内部 VLAN として割り当て済みの VLAN ID を指定して拡張範囲 VLAN を作成すると、エラー メッセージが生成され、コマンドは拒否されます。

内部 VLAN ID は拡張範囲の下部の方なので、拡張範囲 VLAN を作成するには最大の番号(4094)から始めて最小値(1006)へと動いて、内部 VLAN ID を使用する可能性を減らすことを推奨します。

拡張範囲 VLAN を設定する前に、 show vlan internal usage 特権 EXEC コマンドを入力して、どの VLAN が内部 VLAN として割り当てられているかを確認します。

必要に応じて、内部 VLAN に割り当てられたルーテッド ポートをシャットダウンできます。これにより、内部 VLAN が解放され、拡張範囲 VLAN を作成してポートを再度イネーブルにし、別の VLAN を内部 VLAN として使用します。「内部 VLAN ID を指定した拡張範囲 VLAN の作成」を参照してください。

拡張範囲 VLAN の作成

グローバル コンフィギュレーション モードで拡張範囲 VLAN を作成するには、 vlan グローバル コンフィギュレーション コマンドを入力し、1006 ~ 4094 の VLAN ID を指定します。このコマンドによって config-vlan モードが開始されます。拡張範囲 VLAN はイーサネット VLAN のデフォルトの特性を備えており( 表 11-2 を参照)、変更できるパラメータは MTU サイズだけです。全パラメータのデフォルト設定については、コマンド リファレンスの vlan グローバル コンフィギュレーション コマンドの説明を参照してください。スイッチが VTP トランスペアレント モードでない場合に拡張範囲 VLAN ID を入力すると、config-vlan モードの終了時にエラー メッセージが生成され、拡張範囲 VLAN が作成されません。

拡張範囲 VLAN は VLAN データベースに保存されずに、スイッチの実行コンフィギュレーション ファイルに保存されます。拡張範囲 VLAN 設定をスイッチのスタートアップ コンフィギュレーション ファイルに保存するには、 copy running-config startup-config 特権 EXEC コマンドを使用します。


) 拡張範囲 VLAN を作成する前に、show vlan internal usage 特権 EXEC コマンドを入力して、VLAN ID が内部的に使用されていないことを確認します。VLAN ID が内部的に使用されている場合に、それを解放するには、「内部 VLAN ID を指定した拡張範囲 VLAN の作成」を参照してから拡張範囲 VLAN を作成してください。


拡張範囲 VLAN を作成するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp mode transparent

スイッチを VTP トランスペアレント モードに設定し、VTP をディセーブルにします。

ステップ 3

vlan vlan-id

拡張範囲 VLAN ID を入力して、config-vlan モードを開始します。指定できる範囲は 1006 ~ 4094 です。

ステップ 4

mtu mtu-size

(任意)MTU サイズを変更して、VLAN を変更します。

コマンドだけです。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show vlan id vlan-id

VLAN が作成されたことを確認します。

ステップ 7

copy running-config startup config

スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。拡張範囲 VLAN 設定を保存するには、VTP トランスペアレント モード設定および拡張範囲 VLAN 設定をスイッチのスタートアップ コンフィギュレーション ファイルに保存する必要があります。これらを保存しないと、スイッチをリセットした場合に、スイッチがデフォルトで VTP サーバ モードになり、拡張範囲 VLAN ID は保存されません。

拡張範囲 VLAN を削除するには、 no vlan vlan-id グローバル コンフィギュレーション コマンドを使用します。

スタティック アクセス ポートを拡張範囲 VLAN に割り当てる手順は、標準範囲 VLAN の手順と同じです。「VLAN へのスタティック アクセス ポートの割り当て」を参照してください。

次の例は、すべてのデフォルト特性を備えた新しい拡張範囲 VLAN を作成し、config-vlan モードを開始し、スイッチのスタートアップ コンフィギュレーション ファイルに新しい VLAN を保存する方法を示しています。

Switch(config)# vtp mode transparent
Switch(config)# vlan 2000
Switch(config-vlan)# end
Switch# copy running-config startup config

内部 VLAN ID を指定した拡張範囲 VLAN の作成

内部 VLAN に割り当て済みの拡張範囲 VLAN ID を入力すると、エラー メッセージが生成され、拡張範囲 VLAN は拒否されます。内部 VLAN ID を手動で解放するには、内部 VLAN ID を使用しているルーテッド ポートを一時的にシャットダウンする必要があります。

内部 VLAN に割り当てられた VLAN ID を解放してその ID で拡張範囲 VLAN を作成するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

show vlan internal usage

スイッチが内部的に使用している VLAN ID を表示します。使用したい VLAN ID が内部 VLAN である場合は、その VLAN ID を使用しているルーテッド ポートが表示されます。そのポート番号をステップ 3 で入力してください。

ステップ 2

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface interface-id

その VLAN ID を使用しているルーテッド ポートのインターフェイス ID を入力します。

ステップ 4

shutdown

ポートをシャットダウンして内部 VLAN ID を解放します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

vtp mode transparent

VTP モードをトランスペアレントに設定して拡張範囲 VLAN を作成します。

ステップ 7

vlan vlan-id

新しい拡張範囲 VLAN ID を入力し、config-vlan モードを開始します。

ステップ 8

exit

config-vlan モードを終了してグローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface interface-id

ステップ 4 でシャットダウンしたルーテッド ポートのインターフェイス ID を入力します。

ステップ 10

no shutdown

ルーテッド ポートを再度イネーブルにします。新しい内部 VLAN ID が割り当てられます。

ステップ 11

end

特権 EXEC モードに戻ります。

ステップ 12

copy running-config startup config

スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。拡張範囲 VLAN 設定を保存するには、スイッチのスタートアップ コンフィギュレーション ファイルに VTP トランスペアレント モード設定と拡張範囲 VLAN 設定を保存する必要があります。これらを保存しないと、スイッチをリセットした場合に、スイッチがデフォルトで VTP サーバ モードになり、拡張範囲 VLAN ID は保存されません。

VLAN の表示

拡張範囲 VLAN を含む、スイッチ上のすべての VLAN のリストを表示するには、 show vlan 特権 EXEC コマンドを使用します。VLAN ステータス、ポート、および設定情報も表示されます。VLAN データベース内の標準範囲 VLAN(1 ~ 1005)を表示するには、 show VLAN コンフィギュレーション コマンド(開始するには vlan database 特権 EXEC コマンドを入力)を使用します。スイッチ上の VLAN ID のリストを表示するには、 show running-config vlan 特権 EXEC コマンドを使用し、オプションとして VLAN ID の範囲を入力します。

表 11-3 に、VLAN を監視するためのコマンドを示します。

 

表 11-3 VLAN モニタ コマンド

コマンド
コマンド モード
目的

show

VLAN コンフィギュレーション

VLAN データベース内の VLAN のステータスを表示します。

show current [ vlan-id ]

VLAN コンフィギュレーション

VLAN データベース内のすべての VLAN または特定の VLAN のステータスを表示します。

show interfaces [ vlan vlan-id ]

特権 EXEC

スイッチ上に設定されたすべてのインターフェイスまたは特定の VLAN の特性を表示します。

show running-config vlan

特権 EXEC

スイッチ上のすべての VLAN または特定の範囲の VLAN を表示します。

show vlan [ id vlan-id ]

特権 EXEC

スイッチ上のすべての VLAN または特定の VLAN のパラメータを表示します。

show コマンド オプションおよび出力フィールドの詳細については、このリリースに対応するコマンド リファレンスを参照してください。

VLAN トランクの設定

ここでは、スイッチ上の VLAN トランクの機能について説明します。

「トランキングの概要」

「カプセル化タイプ」

「レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定」

トランキングの概要

トランクとは、1 つまたは複数のイーサネット スイッチ インターフェイスと他のネットワーキング デバイス(ルータ、スイッチなど)の間のポイントツーポイント リンクです。ファスト イーサネット トランクおよびギガビット イーサネット トランクは 1 つのリンクを介して複数の VLAN トラフィックを伝送するので、VLAN をネットワーク全体に拡張できます。

すべてのイーサネット インターフェイス上で、2 種類のトランキング カプセル化方式を使用できます。

スイッチ間リンク(ISL):ISL は、シスコ独自のトランキング カプセル化方式です。

802.1Q:802.1Q は、業界標準のトランキング カプセル化方式です。

図 11-2 に、IEEE 802.1Q または ISL トランクによって接続されるスイッチのネットワークを示します。

図 11-2 IEEE 802.1Q または ISL トランキング環境のスイッチ

 

トランクを設定できるのは、1 つのイーサネット インターフェイスまたは EtherChannel バンドルに対してです。EtherChannel の詳細については、「EtherChannel の設定」を参照してください。

イーサネット トランク インターフェイスは、 表 11-4 に示すトランキング モードをサポートしています。インターフェイスをトランキングまたは非トランキングとして設定したり、ネイバー インターフェイスとトランキングのネゴシエーションを行ったりするように設定できます。トランキングを自動ネゴシエーションするには、インターフェイスが同じ VTP ドメインに存在する必要があります。

トランク ネゴシエーションは、PPP(ポイントツーポイント プロトコル)である Dynamic Trunking Protocol( DTP; ダイナミック トランキング プロトコル)によって管理されます。ただし、一部のインターネットワーキング デバイスによって DTP フレームが不正に転送されて、矛盾した設定となる場合があります。

この事態を避けるには、DTP をサポートしないデバイスに接続されたインターフェイスが DTP フレームを転送しないように、つまり DTP をオフにするように設定する必要があります。

これらのリンク上でトランキングを行わない場合は、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、トランキングをディセーブルにします。

DTP をサポートしていない装置でトランキングをイネーブルにするには、 switchport mode trunk および switchport nonegotiate インターフェイス コンフィギュレーション コマンドを使用して、インターフェイスがトランクになっても DTP フレームを生成しないように設定します。

GigaStack GBIC では、ダイナミックトランキングは 2 台のスイッチが単一の GigaStack GBIC リンクで接続されている場合にのみサポートされます。スタック内の 3 台以上のスイッチが GigaStack GBIC リンクで接続されている場合にトランキングが必要な場合、このようにトランキングを手動で設定する必要があります。

shutdown インターフェイス コンフィギュレーション コマンドを使用して、GigaStack ポートを手動でシャット ダウンします。

switchport mode trunk インターフェイス コンフィギュレーション コマンドを両方の GBIC インターフェイスで使用してインターフェイスをトランクにすることで、GigaStack ポート上でトランク モードを手動で設定します。

no shutdown インターフェイス コンフィギュレーション コマンドで、GigaStack ポートを起動します。

さらに、トランクでの ISL または 802.1Q カプセル化の使用、またはカプセル化タイプの自動ネゴシエーションも指定することもできます。DTP は ISL トランクおよび 802.1Q トランクの両方の自動ネゴシエーションをサポートします。


) トンネル ポートは DTP をサポートしません。トンネル ポートの詳細については、「IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングの設定」を参照してください。


 

表 11-4 レイヤ 2 インターフェイス モード

モード
機能

switchport mode access

インターフェイス(アクセス ポート)を永続的な非トランキング モードにします。インターフェイスは、ネイバー インターフェイスがトランク インターフェイスである場合でも、非トランク インターフェイスになります。

switchport mode dynamic desirable

インターフェイスがリンクのトランク リンクへの変換をアクティブに実行するようにします。インターフェイスは、ネイバー インターフェイスが trunk desirable 、または auto モードに設定されている場合、トランク インターフェイスになります。すべてのイーサネット インターフェイスのデフォルトのスイッチポート モードは、 dynamic desirable です。

switchport mode dynamic auto

インターフェイスがリンクをトランク リンクに変換できるようにします。インターフェイスは、ネイバー インターフェイスが trunk または desirable モードに設定されている場合、トランク インターフェイスになります。

switchport mode trunk

インターフェイスは永続的なトランキング モードになり、リンクをトランク リンクに変換するためにネゴシエーションを行います。インターフェイスは、ネイバー インターフェイスがトランク インターフェイスでない場合でも、トランク インターフェイスになります。

switchport nonegotiate

インターフェイスが DTP フレームを生成しないようにします。このコマンドは、インターフェイス スイッチポート モードが access または trunk の場合だけ使用できます。トランク リンクを確立するには、手動でネイバー インターフェイスをトランク インターフェイスとして設定する必要があります。

switchport mode dot1q-tunnel

802.1Q トランク ポートと非対称リンクで接続するトンネル(非トランキング)ポートとして、インターフェイスを設定します。802.1Q トンネリングは、サービスプロバイダー ネットワーク上でカスタマー VLAN の整合性を保つために使用します。トンネル ポートの詳細については、「IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングの設定」を参照してください。

カプセル化タイプ

表 11-5 に、イーサネット トランクのカプセル化タイプおよびキーワードを示します。

 

表 11-5 イーサネット トランクのカプセル化タイプ

カプセル化
機能

switchport trunk encapsulation isl

トランク リンクに ISL カプセル化を指定します。

switchport trunk encapsulation dot1q

トランク リンクに 802.1Q カプセル化を指定します。

switchport trunk encapsulation negotiate

インターフェイスがネイバー インターフェイスとネゴシエーションを行い、近接インターフェイスの設定および機能に応じて、ISL トランク(優先)または 802.1Q トランクになるよう指定します。


) スイッチはレイヤ 3 トランクをサポートしません。したがって、サブインターフェイスを設定したり、レイヤ 3 インターフェイスで encapsulation キーワードを使用したりすることはできません。ただし、スイッチは、同等の機能を備えたレイヤ 2 トランクおよびレイヤ 3 VLAN インターフェイスをサポートします。


リンクが ISL トランクまたは 802.1Q トランクのどちらになるかは、接続された 2 つのインターフェイスのトランキング モード、トランク カプセル化タイプ、およびハードウェア機能によって決まります。

IEEE 802.1Q の設定に関する考慮事項

IEEE 802.1Q トランクでは、ネットワークに次の制約があります。

IEEE 802.1Q トランクを使用して接続している Cisco スイッチのネットワークでは、トランク上で許容される VLAN ごとに 1 つのスパニングツリー インスタンスが維持されます。他社製のデバイスは、すべての VLAN でスパニングツリー インスタンスを 1 つサポートする場合があります。

IEEE 802.1Q トランクを使用して Cisco スイッチを他社製のデバイスに接続する場合、Cisco スイッチは、トランクの VLAN のスパニングツリー インスタンスを、他社製の IEEE 802.1Q スイッチのスパニングツリー インスタンスと結合します。ただし、各 VLAN のスパニングツリー情報は、他社製の IEEE 802.1Q スイッチからなるクラウドにより分離された Cisco スイッチによって維持されます。Cisco スイッチを分離する他社製の IEEE 802.1Q クラウドは、スイッチ間の単一トランク リンクとして扱われます。

IEEE 802.1Q トランクに対応するネイティブ VLAN が、トランク リンクの両側で一致していなければなりません。トランクの片側のネイティブ VLAN と反対側のネイティブ VLAN が異なっていると、スパニングツリー ループが発生する可能性があります。

ネットワーク上のすべてのネイティブ VLAN についてスパニングツリーをディセーブルにせずに、IEEE 802.1Q トランクのネイティブ VLAN 上のスパニングツリーをディセーブルにすると、スパニングツリー ループが発生することがあります。IEEE 802.1Q トランクのネイティブ VLAN 上でスパニングツリーをイネーブルのままにしておくか、またはネットワーク上のすべての VLAN でスパニングツリーをディセーブルにすることを推奨します。また、ネットワークにループがないことを確認してから、スパニングツリーをディセーブルにしてください。

レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

表 11-6 に、レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定を示します。

 

表 11-6 レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

機能
デフォルト設定

インターフェイス モード

switchport mode dynamic desirable

トランク カプセル化

switchport trunk encapsulation negotiate

VLAN 許容範囲

VLAN 1 ~ 4094

プルーニングに適格な VLAN 範囲

VLAN 2 ~ 1001

デフォルト VLAN(アクセス ポート用)

VLAN 1

ネイティブ VLAN(IEEE 802.1Q トランク用)

VLAN 1

トランク ポートとしてのイーサネット インターフェイスの設定

トランク ポートは VTP アドバタイズを送受信するので、VTP を使用する場合は、スイッチ上で少なくとも 1 つのトランク ポートが設定されており、別のスイッチのトランク ポートに接続されていることを確認する必要があります。そうでない場合、スイッチは VTP アドバタイズを受信できません。

ここでは、スイッチ上でイーサネット インターフェイスをトランク ポートとして設定する手順について説明します。

「他の機能との相互作用」

「トランクでの許可 VLAN の定義」

「プルーニング適格リストの変更」

「タグなしトラフィック用ネイティブ VLAN の設定」


) デフォルトでは、インターフェイスはレイヤ 2 モードです。レイヤ 2 インターフェイスのデフォルト モードは、switchport mode dynamic desirable インターフェイス コンフィギュレーション モードです。隣接インターフェイスがトランキングをサポートし、トランキングを許可するように設定されている場合、リンクはレイヤ 2 トランクです。また、インターフェイスがレイヤ 3 モードの場合は、switchport インターフェイス コンフィギュレーション コマンドを入力するとレイヤ 2 トランクになります。デフォルトでは、トランクはカプセル化のネゴシエーションを行います。ネイバー インターフェイスがそれぞれ ISL と 802.1Q のカプセル化方式をサポートし、いずれのインターフェイスもカプセル化タイプのネゴシエーションに設定されている場合、トランクは ISL カプセル化方式を使用します。


他の機能との相互作用

トランキングは他の機能と次のように相互作用します。

トランク ポートは、トンネル ポートにできません。

トランク ポートをまとめて EtherChannel ポート グループにすることはできますが、グループ内のすべてのトランクに同じ設定をする必要があります。グループを初めて作成したときには、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。次のパラメータのいずれかについて、設定を変更すると、入力した設定値がスイッチによってグループ内のすべてのポートに伝播されます。

許可 VLAN リスト

各 VLAN の STP ポート プライオリティ

STP PortFast の設定値

トランク ステータス(ポート グループ内の 1 つのポートがトランクでなくなると、すべてのポートがトランクでなくなります)。

PVST+ モードで設定するトランク ポートの数は 24 まで、MST モードで設定するトランク ポートの数は 40 までにすることを推奨します。

トランク ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。IEEE 802.1X 対応ポートのモードをトランクに変更しようとしても、ポート モードは変更されません。

ダイナミック モードのポートは、ネイバーとトランク ポートへの変更をネゴシエートする場合があります。ダイナミック ポートで IEEE 802.1X をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1X はイネーブルになりません。IEEE 802.1X 対応ポートをダイナミックに変更しようとしても、ポート モードは変更されません。

保護ポートは、IEEE 802.1Q トランクでサポートされます。

トランク ポートの設定

ISL または IEEE 802.1Q トランク ポートとしてポートを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トランキング用に設定するポートを入力します。

ステップ 3

switchport trunk encapsulation { isl | dot1q | negotiate }

ISL または 802.1Q カプセル化をサポートするように、またはカプセル化タイプについてネイバー インターフェイスとネゴシエーションする(デフォルト)ようにポートを設定します。

リンクの両端を同一カプセル化タイプで設定する必要があります。

ステップ 4

switchport mode { dynamic { auto | desirable } | trunk }

インターフェイスをレイヤ 2 トランクとして設定します(インターフェイスがレイヤ 2 アクセス ポートまたはトンネル ポートであり、トランキング モードを設定する場合に限り必要となります)。

dynamic auto :ネイバー インターフェイスが trunk または desirable モードに設定されている場合に、インターフェイスをトランク リンクとして設定します。

dynamic desirable :ネイバー インターフェイスが trunk、desirable、または auto モードに設定されている場合に、インターフェイスをトランク リンクとして設定します。

trunk :ネイバー インターフェイスがトランク インターフェイスでない場合でも、インターフェイスを永続的なトランキング モードに設定して、リンクをトランク リンクに変換するようにネゴシエートします。

ステップ 5

switchport access vlan vlan-id

(任意)インターフェイスがトランキングを停止した場合に使用するデフォルト VLAN を指定します。

ステップ 6

switchport trunk native vlan vlan-id

802.1Q トランク用にネイティブ VLAN を指定します。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show interfaces interface-id switchport

インターフェイスのスイッチポート設定を表示します。 Administrative Mode および Administrative Trunking Encapsulation フィールドに表示されます。

ステップ 9

show interfaces interface-id trunk

インターフェイスのトランク設定を表示します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。トランキング インターフェイスのすべてのトランキング特性をデフォルトにリセットするには、 no switchport trunk インターフェイス コンフィギュレーション コマンドを使用します。トランキングをディセーブルにするには、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、ポートをスタティック アクセス ポートとして設定します。

次に、IEEE 802.1Q トランクとしてポートを設定する例を示します。この例では、ネイバー インターフェイスが IEEE 802.1Q トランキングをサポートするように設定されていることを前提としています。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# switchport mode dynamic desirable
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# end

トランクでの許可 VLAN の定義

デフォルトでは、トランク ポートはすべての VLAN に対してトラフィックを送受信します。各トランク上では、すべての VLAN ID が許可されます。ただし、許可リストから VLAN を削除することにより、それらの VLAN からのトラフィックがトランク上を流れないようにすることができます。トランクが伝送するトラフィックを制限するには、 switchport trunk allowed vlan remove vlan-list インターフェイス コンフィギュレーション コマンドを使用して、許可リストから特定の VLAN を削除します。

スパニングツリー ループまたはストームの危険性を減らすには、許可リストから VLAN 1 を削除して個々の VLAN トランク ポートの VLAN 1 をディセーブルにします。これは、VLAN 1 最小化と呼ばれます。VLAN 1 最小化は、個々の VLAN トランク リンクで VLAN 1(すべてのシスコ スイッチのトランク ポートのデフォルト VLAN)をディセーブルにします。その結果、スパニングツリー アドバタイズを含むユーザ トラフィックは VLAN 1 で送受信されません。

トランク ポートから VLAN 1 を削除した場合、インターフェイスは管理トラフィック(Cisco Discovery Protocol(CDP)、ポート集約プロトコル(PAgP)、Link Aggregation Control Protocol(LACP)、ダイナミック トランキング プロトコル(DTP)、および VLAN 1 の VLAN トランキング プロトコル(VTP))を送受信し続けます。

VLAN 1 をディセーブルにしたトランク ポートが非トランク ポートに変換されると、そのポートはアクセス VLAN に追加されます。アクセス VLAN が 1 に設定されている場合、 switchport trunk allowed 設定に関係なく、ポートは VLAN 1 に追加されます。ポート上でディセーブルになっている任意の VLAN について同様のことが当てはまります。

トランク ポートは、VLAN がイネーブルになっており、VTP が VLAN を認識し、なおかつポートの許可リストにその VLAN が登録されている場合に、VLAN のメンバになることができます。VTP が新しくイネーブルにされた VLAN を認識し、その VLAN がトランク ポートの許可リストに登録されている場合、トランク ポートは自動的にその VLAN のメンバになります。VTP が新しい VLAN を認識し、その VLAN がトランク ポートの許可リストに登録されていない場合には、トランク ポートはその VLAN のメンバにはなりません。

ISL トランクまたは IEEE 802.1Q トランクの許可リストを変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、設定するポートを入力します。

ステップ 3

switchport mode trunk

インターフェイスを VLAN トランク ポートとして設定します。

ステップ 4

switchport trunk allowed vlan { add | all | except | remove } vlan-list

(任意)トランク上で許可される VLAN のリストを設定します。

add all except 、および remove キーワードの使用方法については、このリリースに対応するコマンド リファレンスを参照してください。

vlan-list パラメータは、1 ~ 4094 の単一の VLAN 番号、または 2 つの VLAN 番号(小さい方が先、ハイフンで区切る)で指定された VLAN 範囲です。カンマで区切った VLAN パラメータの間、またはハイフンで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべての VLAN が許可されます。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Trunking VLANs Enabled フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべての VLAN の許可 VLAN リストをデフォルトに戻すには、 no switchport trunk allowed vlan インターフェイス コンフィギュレーション コマンドを使用します。

次に、許可 VLAN リストから VLAN 2 を削除する例を示します。

Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end
Switch#

プルーニング適格リストの変更

プルーニング適格リストは、トランク ポートだけに適用されます。トランク ポートごとに独自の適格リストがあります。この手順を有効にするには、VTP プルーニングがイネーブルに設定されている必要があります。VTP プルーニングをイネーブルにする方法については、「VTP プルーニングのイネーブル化」を参照してください。

トランク ポートのプルーニング適格リストから VLAN を削除するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、VLAN プルーニングを適用するトランク ポートを選択します。

ステップ 3

switchport trunk pruning vlan { add | except | none | remove } vlan-list [ ,vlan [ ,vlan [ ,,, ]]

トランクからのプルーニングを許可する VLAN のリストを設定します (「VTP プルーニング」を参照してください)。

add except none 、および remove キーワードの使用方法については、このリリースに対応するコマンド リファレンスを参照してください。

連続していない VLAN ID は、カンマ(スペースなし)で区切ります。ID の範囲はハイフンで指定します。有効な ID は、2 ~ 1001 です。 拡張範囲 VLAN(VLAN ID 1006 ~ 4094)はプルーニングできません。

プルーニング不適格の VLAN は、フラッディング トラフィックを受信します。

デフォルトでは、プルーニングが許可される VLAN のリストには、VLAN 2 ~ 1001 が含まれます。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show interfaces interface-id switchport

表示された Pruning VLANs Enabled フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべての VLAN のプルーニング適格リストをデフォルトに戻すには、 no switchport trunk pruning vlan インターフェイス コンフィギュレーション コマンドを使用します。

タグなしトラフィック用ネイティブ VLAN の設定

IEEE 802.1Q タギングが設定されたトランク ポートは、タグ付きトラフィックおよびタグなしトラフィックの両方を受信できます。デフォルトでは、タグなしトラフィックは、ポートに設定されたネイティブ VLAN に転送されます。ネイティブ VLAN は、デフォルトでは VLAN 1 です。


) ネイティブ VLAN には任意の VLAN ID を割り当てることができます。


IEEE 802.1Q 設定についての詳細は、「カプセル化タイプ」を参照してください。

IEEE 802.1Q トランクでネイティブ VLAN を設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、IEEE 802.1Q トランクとして設定するインターフェイスを定義します。

ステップ 3

switchport trunk native vlan vlan-id

トランク ポート上でタグなしトラフィックを送受信する VLAN を設定します。

vlan-id に指定できる範囲は 1 ~ 4094 です。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show interfaces interface-id switchport

Trunking Native Mode VLAN フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ネイティブ VLAN をデフォルト(VLAN 1)に戻すには、 no switchport trunk native vlan インターフェイス コンフィギュレーション コマンドを使用します。

パケットの VLAN ID が出力ポートのネイティブ VLAN ID と同じであれば、そのパケットはタグなしで送信されます。ネイティブ VLAN ID と異なる場合は、スイッチはそのパケットをタグ付きで送信します。

STP による負荷分散

負荷分散により、スイッチに接続しているパラレル トランクの提供する帯域幅が分割されます。STP は通常、ループを防止するために、スイッチ間で 1 つのパラレル リンク以外のすべてのリンクをブロックします。負荷分散を行うと、トラフィックの所属する VLAN に基づいて、リンク間でトラフィックが分散されます。

トランク ポートで負荷分散を設定するには、STP ポート プライオリティまたは STP パス コストを使用します。STP ポート プライオリティを使用して負荷分散を設定する場合には、両方の負荷分散リンクを同じスイッチに接続する必要があります。STP パス コストを使用して負荷分散を設定する場合には、それぞれの負荷分散リンクを同一のスイッチにも、2 台の異なるスイッチにも接続できます。STP の詳細については、「STP の設定」を参照してください。

STP ポート プライオリティによる負荷分散

同一スイッチ上の 2 つのポートがループを形成すると、STP ポート プライオリティの設定により、イネーブルになるポートとブロッキング ステートになるポートが決まります。パラレル トランク ポートにプライオリティを設定することにより、そのポートに、特定の VLAN のすべてのトラフィックを伝送させることができます。VLAN に対するプライオリティの高い(値の小さい)トランク ポートがその VLAN のトラフィックを転送します。同じ VLAN に対してプライオリティの低い(値の大きい)トランク ポートは、その VLAN に対してブロッキング ステートのままです。1 つのトランク ポートが特定の VLAN に関するすべてのトラフィックを送受信することになります。

図 11-3 に、サポート対象スイッチを接続する 2 つのトランクを示します。この例では、スイッチは次のように設定されています。

VLAN 8 ~ 10 は、トランク 1 で 16 というポート プライオリティが割り当てられています。

VLAN 3 ~ 6 は、トランク 1 でデフォルトのポート プライオリティである 128 のままです。

VLAN 3 ~ 6 は、トランク 2 で 16 というポート プライオリティが割り当てられています。

VLAN 8 ~ 10 は、トランク 2 でデフォルトのポート プライオリティである 128 のままです。

このように設定すると、トランク 1 が VLAN 8 ~ 10 のトラフィックを伝送し、トランク 2 が VLAN 3 ~ 6 のトラフィックを伝送します。アクティブ トランクで障害が起きた場合には、プライオリティの低いトランクが引き継ぎ、それらすべての VLAN のトラフィックを伝送します。いずれのトランク ポート上でも、トラフィックの重複は発生しません。

図 11-3 STP ポート プライオリティによる負荷分散

 

 

図 11-3 に示すようにネットワークを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

スイッチ 1 で、グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp domain domain-name

VTP 管理ドメインを設定します。

1 ~ 32 文字のドメイン名を使用できます。

ステップ 3

vtp mode server

スイッチ 1 を VTP サーバとして設定します。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show vtp status

スイッチ A および B の両方で、VTP 設定を確認します。

表示された VTP Operating Mode および VTP Domain Name フィールドをチェックします。

ステップ 6

show vlan

スイッチ A のデータベースに VLAN が存在していることを確認します。

ステップ 7

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 8

interface fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、トランクに設定するインターフェイスとしてファスト イーサネット ポート 0/1 を定義します。

ステップ 9

switchport trunk encapsulation { isl | dot1q | negotiate }

ISL カプセル化または 802.1Q カプセル化をサポートするように、またはネイバー インターフェイスとネゴシエーションするようにポートを設定します。

リンクの両端を同一カプセル化タイプで設定する必要があります。

ステップ 10

switchport mode trunk

ポートをトランク ポートとして設定します。

ステップ 11

end

特権 EXEC モードに戻ります。

ステップ 12

show interfaces fastethernet 0/1switchport

VLAN 設定を確認します。

ステップ 13

ファスト イーサネット ポート 0/2 に対して、スイッチ A 上でステップ 7 ~ 11 を繰り返します。

ステップ 14

スイッチ B でステップ 7 ~ 11 を繰り返し、ファスト イーサネット ポート 0/1 および 0/2 でトランク ポートを設定します。

ステップ 15

show vlan

トランク リンクがアクティブになると、VTP がスイッチ B に VTP および VLAN 情報を渡します。スイッチ B が VLAN 設定を学習したことを確認します。

ステップ 16

configure terminal

スイッチ A で、グローバル コンフィギュレーション モードを開始します。

ステップ 17

interface fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、STP ポート プライオリティを設定するインターフェイスを定義します。

ステップ 18

spanning-tree vlan 8-10 port-priority 16

VLAN 8 ~ 10 にポート プライオリティ 16 を割り当てます。

ステップ 19

spanning-tree vlan 10 port-priority 16

VLAN 10 にポート プライオリティ 16 を割り当てます。

ステップ 20

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 21

interface fastethernet 0/2

インターフェイス コンフィギュレーション モードを開始し、STP ポート プライオリティを設定するインターフェイスを定義します。

ステップ 22

spanning-tree vlan 3-6 port-priority 16

VLAN 3 ~ 6 にポート プライオリティ 16 を割り当てます。

ステップ 23

end

特権 EXEC モードに戻ります。

ステップ 24

show running-config

入力内容を確認します。

ステップ 25

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

STP パス コストによる負荷分散

トランクにそれぞれ異なるパス コストを設定し、各パス コストをそれぞれ異なる VLAN 群に対応付けることによって、VLAN トラフィックを分散するパラレル トランクを設定できます。VLAN はトラフィックを分離します。ループは存在しないため、STP はポートをディセーブルにせず、リンクが失われた場合でも冗長性が維持されます。

図 11-4 で、トランク ポート 1 および 2 は 100BASE-T ポートです。VLAN のパス コストは次のように割り当てられます。

VLAN 2 ~ 4 は、トランク ポート 1 で 30 というパス コストが割り当てられています。

VLAN 8 ~ 10 は、トランク ポート 1 で 100BASE-T のデフォルトのパス コスト 19 のままになっています。

VLAN 8 ~ 10 は、トランク ポート 2 で 30 というパス コストが割り当てられています。

VLAN 2 ~ 4 は、トランク ポート 2 で 100BASE-T のデフォルトのパス コスト 19 のままになっています。

図 11-4 パス コストによってトラフィックが分散される負荷分散トランク

 

図 11-4 に示すようにネットワークを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

スイッチ A で、グローバル コンフィギュレーション モードを開始します。

ステップ 2

interfa c e fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、トランクに設定するインターフェイスとしてファスト イーサネット ポート 0/1 を定義します。

ステップ 3

switchport trunk encapsulation
{ isl | dot1q | negotiate }

ISL カプセル化または 802.1Q カプセル化をサポートするようにポートを設定します。

リンクの両端を同一カプセル化タイプで設定する必要があります。

ステップ 4

switchport mode trunk

ポートをトランク ポートとして設定します。

トランクのデフォルトは ISL トランキングです。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

スイッチ A のインターフェイス ファスト イーサネット 0/2 に対してステップ 2 ~ 4 を繰り返します。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show running-config

入力内容を確認します。

表示で、インターフェイス ファスト イーサネット 0/1 およびファスト イーサネット 0/2 がトランク ポートとして設定されていることを確認します。

ステップ 9

show vlan

トランク リンクがアクティブになると、スイッチ A がもう一方のスイッチから VTP 情報を受信します。スイッチ A が VLAN 設定を学習したことを確認します。

ステップ 10

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 11

interface fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、STP コストを設定するインターフェイスとしてファスト イーサネット ポート 0/1 を定義します。

ステップ 12

spanning-tree vlan 2-4 cost 30

VLAN 2 ~ 4 のスパニングツリー パス コストを 30 に設定します。

ステップ 13

end

グローバル コンフィギュレーション モードに戻ります。

ステップ 14

スイッチ A インターフェイス ファスト イーサネット 0/2 でステップ 9 ~ 11 を繰り返し、VLAN 8、9、および 10 のスパニングツリー パス コストを 30 に設定します。

ステップ 15

exit

特権 EXEC モードに戻ります。

ステップ 16

show running-config

入力内容を確認します。

画面で、インターフェイス ファスト イーサネット 0/1 および 0/2 のパス コストが正しく設定されていることを確認してください。

ステップ 17

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VMPS の設定

このスイッチを VMPS サーバにすることはできませんが、VMPS のクライアントとして機能させ、VLAN Query Protocol(VQP)を介して通信できます。VMPS は、ダイナミック アクセス ポート VLAN メンバーシップを動的に割り当てます。

ここでは VMPS の設定について説明します。

「VMPS の概要」

「VMPS クライアントのデフォルト設定」

「VMPS 設定時の注意事項」

「VMPS クライアントの設定」

「VMPS のモニタリング」

「ダイナミック ポート VLAN メンバーシップのトラブルシューティング」

「VMPS の設定例」

VMPS の概要

VMPS はクライアントから VQP 要求を受け取ると、VMPS データベースで MAC アドレスから VLAN へのマッピングを検索します。サーバの応答は、このマッピングと、サーバがセキュア モードにあるかどうかに基づいて行われます。セキュア モードによって、VLAN がポートで許可されていない場合にサーバがポートをシャットダウンするか、それとも単に VLAN へのポート アクセスを拒否するかどうかが決まります。

要求に対する応答では、VMPS は次のいずれかのアクションを実行します。

割り当てられた VLAN がポート グループに限定されている場合、VMPS はこのグループに対する要求ポートを確認し、次のように応答します。

VLAN がポートで許可されている場合、VMPS は VLAN 名を応答としてクライアントに送信します。

VLAN がポートで許可されておらず、VMPS がセキュア モードでない場合、VMPS は access-denied 応答を送信します。

そのポートで VLAN が許可されておらず、なおかつ VMPS がセキュア モードの場合、VMPS は ポートシャットダウン 応答を送信します。

データベース内の VLAN がポート上の現在の VLAN と一致せず、なおかつポート上にアクティブ ホストが存在する場合、VMPS は VMPS のセキュア モードに応じて、 アクセス拒否 または ポートシャットダウン 応答を送信します。

スイッチは access-denied 応答を VMPS から受信すると、MAC アドレスとポート間のトラフィックをブロックし続けます。スイッチはポート向けのパケットをモニタし続け、新しいアドレスを識別すると VMPS にクエリーを送信します。VMPS から ポートシャットダウン 応答を受信した場合、スイッチはそのポートをディセーブルにします。このポートは、デバイス マネージャ、CLI、Network Assistant、または SNMP を使用して、手動で再びイネーブルにする必要があります。

また、セキュリティ上の理由から、コンフィギュレーション テーブル内の明示的なエントリを使用して、特定の MAC アドレスへのアクセスを拒否することもできます。VLAN 名に none キーワードを入力した場合、VMPS は VMPS のセキュア モードの設定に応じて、 access-denied 応答または port-shutdown 応答を送信します。

ダイナミック ポート VLAN メンバーシップ

スイッチ上のダイナミック(非トランキング)ポートは、VLAN ID が 1 から 1005 までの 1 つの VLAN にだけ所属できます。リンクがアップになっても、VMPS によって VLAN が割り当てられるまで、このポートとの間でトラフィック転送は行われません。VMPS は、ダイナミック ポートに接続した新しいホストの最初のパケットから送信元 MAC アドレスを受信し、VMPS データベース内の VLAN とその MAC アドレスを照合します。

一致した場合、VMPS はそのポートの VLAN 番号を送信します。クライアント スイッチがまだ設定されていない場合は、スイッチは VMPS からトランク ポートで受信した最初の VTP パケットからのドメイン名を使用します。クライアント スイッチがすでに設定されている場合は、クエリー パケットにスイッチのドメイン名を含めて VMPS に送信し、VLAN 番号を取得します。VMPS はパケット内のドメイン名が自身のドメイン名と一致することを確認した後、要求を受け入れ、クライアントに割り当てられた VLAN 番号を応答します。一致しない場合、(VMPS セキュア モードの設定に応じて)VMPS は要求を拒否するか、ポートをシャットダウンします。

ダイナミック ポート上で複数のホスト(MAC アドレス)をアクティブにできますが、それらのホストはすべて同じ VLAN に存在する必要があります。ただし、ポート上でアクティブなホスト数が 20 を超えると、VMPS はダイナミック ポートをシャットダウンします。

ダイナミック ポート上でリンクがダウンになると、ポートは切り離された状態に戻り、VLAN の所属から外れます。ポート経由でオンラインになるホストは VMPS によって VQP 経由で再チェックされてから、ポートが VLAN に割り当てられます。

VMPS データベース コンフィギュレーション ファイル

VMPS には、ユーザが作成したデータベース コンフィギュレーション ファイルが格納されています。この ASCII テキスト ファイルは、VMPS 用のサーバとして機能する、スイッチからアクセス可能な TFTP サーバに格納されます。このファイルには、ドメイン名、フォールバック VLAN 名、および MAC アドレスから VLAN へのマッピングなどの VMPS 情報が含まれています。スイッチは VMPS として機能できませんが、Catalyst 5000 または Catalyst 6000 シリーズのスイッチは VMPS として使用できます。

フォールバック VLAN 名を設定できます。データベースにない MAC アドレスを持つデバイスを接続する場合、VMPS はフォールバック VLAN 名をクライアントに送信します。フォールバック VLAN 名を設定していない場合で、かつ MAC アドレスがデータベースに含まれていない場合には、VMPS から access-denied 応答が送信されます。VMPS がセキュア モードの場合には、 port-shutdown 応答が送信されます。

VMPS データベース コンフィギュレーション ファイル内でポート名が使用されている場合、サーバは必ずポートの命名にスイッチでの表記法を使用する必要があります。たとえば、Fa0/4 は、固定ファスト イーサネット ポート番号 4 です。スイッチがクラスタ メンバになっている場合、コマンド スイッチではタイプの前にスイッチの名前が追加されます。たとえば、 es3%Fa0/4 は、メンバ スイッチ 3 の固定ファスト イーサネット ポート番号 4 を示します。ポート名が必要な場合、クラスタをサポートするよう設定されている VMPS データベース コンフィギュレーション ファイル内では、これらの命名規則に従う必要があります。

VMPS クライアントのデフォルト設定

表 11-7 に、クライアント スイッチのデフォルトの VMPS およびダイナミック ポート設定を示します。

 

表 11-7 デフォルトの VMPS クライアントおよびダイナミック ポート設定

機能
デフォルト設定

VMPS ドメイン サーバ

なし

VMPS 再確認インターバル

60 分

VMPS サーバ再試行回数

3

ダイナミック ポート

未設定

VMPS 設定時の注意事項

ダイナミック アクセス ポート VLAN メンバーシップには、次の注意事項および制限事項があります。

VMPS を設定してから、ポートをダイナミック ポートとして設定する必要があります。

スイッチのクラスタと VMPS 間の通信は、コマンド スイッチによって管理され、標準のポート名とは異なるポート命名規則を含んでいます。クラスタベースのポート命名規則については、「VMPS データベース コンフィギュレーション ファイル」を参照してください。

ポートをダイナミック アクセス ポートとして設定すると、そのポートに対してスパニングツリーの PortFast 機能が自動的にイネーブルになります。PortFast モードにより、ポートをフォワーディング ステートに移行させるプロセスが短縮されます。

IEEE 802.1x ポートをダイナミック アクセス ポートとして設定することはできません。ダイナミック アクセス(VQP)ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。IEEE 802.1x 対応ポートを変更してダイナミック VLAN を割り当てようとしても、エラー メッセージが表示され、VLAN 設定は変更されません。

トランク ポートをダイナミック アクセス ポートにすることはできませんが、トランク ポートに対して switchport access vlan dynamic インターフェイス コンフィギュレーション コマンドを入力することは可能です。その場合、スイッチの設定は維持され、後にアクセス ポートとして設定された場合には、その設定が適用されます。

ダイナミック アクセス設定を有効にするには、ポート上でトランキングをオフにしておく必要があります。

ダイナミック アクセス ポートをモニタ ポートにすることはできません。

セキュア ポートをダイナミック アクセス ポートにすることはできません。ポートをダイナミックにするには、ポート上でポート セキュリティをディセーブルにしておく必要があります。

ダイナミック アクセス ポートを EtherChannel グループのメンバにすることはできません。

ポート チャネルをダイナミック アクセス ポートとして設定することはできません。

ダイナミック アクセス ポートは、フォールバック ブリッジングに加入できます。

VMPS クライアントと VMPS サーバの VTP 管理ドメインは、同じでなければなりません。

VQP は、拡張範囲 VLAN(1006 よりも大きい VLAN ID)をサポートしません。拡張範囲 VLAN を VMPS によって設定することはできません。

VMPS サーバ上に設定された VLAN を音声 VLAN にしないでください。

VMPS クライアントの設定

ダイナミック VLAN を設定するには、VMPS(サーバ)を使用します。スイッチを VMPS クライアントにすることはできますが、VMPS サーバにすることはできません。

VMPS の IP アドレスの入力

スイッチをクライアントとして設定するには、サーバの IP アドレスを最初に入力する必要があります。


) スイッチ クラスタに対して VMPS を定義する場合は、コマンド スイッチにこのアドレスを入力する必要があります。


VMPS の IP アドレスを入力するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps server ipaddress primary

プライマリ VMPS サーバとして動作するスイッチの IP アドレスを入力します。

ステップ 3

vmps server ipaddress

セカンダリ VMPS サーバとして動作するスイッチの IP アドレスを入力します。

セカンダリ サーバのアドレスは、3 つまで入力できます。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show vmps

表示された VMPS Domain Server フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。


) VMPS サーバに接続したスイッチ ポートを、ダイナミック アクセス ポートにすることはできません。スタティック アクセス ポートまたはトランク ポートにはできます。「トランク ポートとしてのイーサネット インターフェイスの設定」を参照してください。


VMPS クライアント上のダイナミックアクセス ポートの設定

クラスタ メンバ スイッチのポートをダイナミック ポートとして設定するには、最初に rcommand 特権 EXEC コマンドを使用して、メンバ スイッチにログインします。


注意 ダイナミック ポート VLAN メンバーシップはエンド ステーション用、またはエンド ステーションに接続されたハブ用です。他のスイッチにダイナミック アクセス ポートを接続すると、接続が切断されることがあります。

VMPS クライアント スイッチにダイナミック アクセス ポートを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、エンド ステーションに接続しているスイッチ ポートを指定します。

ステップ 3

switchport mode access

ポートをアクセス モードにします。

ステップ 4

switchport access vlan dynamic

ポートをダイナミック VLAN メンバーシップ適格として設定します。

ダイナミック アクセス ポートは、エンド ステーションに接続されている必要があります。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Operational Mode フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。インターフェイスをデフォルトのスイッチポート モード(dynamic desirable)に戻すには、 no switchport mode インターフェイス コンフィギュレーション コマンドを使用します。アクセス モードをスイッチのデフォルト VLAN にリセットするには、 no switchport access インターフェイス コンフィギュレーション コマンドを使用します。


switchport access vlan dynamic インターフェイス コンフィギュレーション コマンドを使用してダイナミック アクセス ポートを設定した場合、DTP ネゴシエーションによってインターフェイスがアクセス モードからトランク モードに変更されると、そのポートで不正ユーザによるネットワーク リソースへのアクセスが許可されるおそれがあります。これを回避するには、ポートをスタティック アクセス ポートとして設定します。


VLAN メンバーシップの再確認

スイッチが VMPS から受信したダイナミック ポート VLAN メンバーシップの割り当てを確認するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

vmps reconfirm

ダイナミック ポート VLAN メンバーシップを再確認します。

ステップ 2

show vmps

ダイナミック VLAN の再確認ステータスを確認します。

再確認インターバルの変更

VMPS クライアントは、VMPS から受信した VLAN メンバーシップ情報を定期的に再確認します。この再確認を行う間隔を分単位で設定できます。

クラスタのメンバ スイッチを設定する場合、このパラメータはコマンド スイッチの再確認インターバルの設定値以上でなければなりません。メンバ スイッチにログインするには、最初に rcommand 特権 EXEC コマンドを使用する必要があります。

再確認インターバルを変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps reconfirm minutes

ダイナミック VLAN メンバーシップの再確認を行う間隔(分)を入力します。

1 ~ 120 の数字を入力します。デフォルトは 60 分です。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show vmps

表示された Reconfirm Interval フィールドのダイナミック VLAN の再確認ステータスを確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチのデフォルト設定に戻すには、 no vmps reconfirm グローバル コンフィギュレーション コマンドを使用します。

再試行回数の変更

スイッチが次のサーバにクエリーを送信する前に、VMPS との接続を試行する回数を変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps retry count

再試行の回数を変更します。

再試行は 1 ~ 10 回の範囲で指定でき、デフォルトは 3 回です。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show vmps

表示された Server Retry Count フィールドの設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチのデフォルト設定に戻すには、 no vmps retry グローバル コンフィギュレーション コマンドを使用します。

VMPS のモニタリング

show vmps 特権 EXEC コマンドを使用して、VMPS に関する情報を表示できます。スイッチは VMPS に関する次の情報を表示します。

 

VMPS VQP バージョン

VMPS との通信に使用する VQP のバージョン。スイッチは VQP バージョン 1 を使用する VMPS にクエリーを送信します。

再確認インターバル

VLAN から MAC アドレスへの割り当てを再確認するまでスイッチが待機する時間(分)。

サーバ再試行回数

VQP が VMPS へクエリーを再送信する回数。この回数すべてを試行しても応答が得られない場合、スイッチはセカンダリ VMPS へのクエリーを開始します。

VMPS ドメイン サーバ

設定された VLAN メンバーシップ ポリシー サーバの IP アドレス。スイッチは current と表示されているサーバにクエリーを送信します。primary と表示されているサーバは、プライマリ サーバです。

VMPS アクション

最新の再確認試行の結果。再確認は、再確認インターバルが経過したときに自動的に行われますが、 vmps reconfirm 特権 EXEC コマンドを入力するか、Network Assistant または SNMP で同等の操作を行うことによって、強制的に再確認することもできます。

次に、 show vmps 特権 EXEC コマンドの出力例を示します。

Switch# show vmps
 
VQP Client Status:
--------------------
VMPS VQP Version: 1
Reconfirm Interval: 60 min
Server Retry Count: 3
VMPS domain server: 172.20.128.86 (primary, current)
172.20.128.87
 
Reconfirmation status
---------------------
VMPS Action: No Dynamic Port
 

ダイナミック ポート VLAN メンバーシップのトラブルシューティング

VMPS は、次の条件下でダイナミックアクセス ポートをシャットダウンします

VMPS がセキュア モードであり、なおかつホストのポートへの接続を許可しない場合。VMPS はポートをシャットダウンして、ホストがネットワークに接続できないようにします。

20 を超えるアクティブ ホストがダイナミック ポートにある場合

ディセーブルのダイナミック ポートを再度イネーブルにするには、 no shutdown インターフェイス コンフィギュレーション コマンドを入力します。

VMPS の設定例

図 11-5 に、VMPS サーバ スイッチと、ダイナミック ポートのある VMPS クライアント スイッチで構成されるネットワークを示します。この例の前提条件は次のとおりです。

VMPS サーバと VMPS クライアントは、それぞれ別のスイッチです。

Catalyst 6500 シリーズのスイッチ A が、プライマリ VMPS サーバです。

Catalyst 5000 シリーズのスイッチ C およびスイッチ J が、セカンダリ VMPS サーバです。

エンド ステーションはクライアント(スイッチ B、スイッチ I)に接続されています。

データベース コンフィギュレーション ファイルは、IP アドレス 172.20.22.7 の TFTP サーバに保存されています。

図 11-5 ダイナミック ポート VLAN メンバーシップの構成例