Catalyst 2970 スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)SEC
VLANの設定
VLANの設定
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

VLANの設定

VLANの概要

サポートされるVLAN

VLANポート メンバーシップ モード

標準範囲VLANの設定

トークンリングVLAN

標準範囲VLAN設定時の注意事項

VLANコンフィギュレーション モードのオプション

config-vlanモードでのVLAN設定

VLANデータベース コンフィギュレーション モードでのVLAN設定

VLAN設定の保存

イーサネットVLANのデフォルト設定

イーサネットVLANの作成または変更

VLANの削除

VLANへのスタティック アクセス ポートの割り当て

拡張範囲VLANの設定

VLANのデフォルト設定

拡張範囲VLAN設定時の注意事項

拡張範囲VLANの作成

VLANの表示

VLANトランクの設定

トランキングの概要

カプセル化タイプ

IEEE 802.1Qの設定に関する考慮事項

レイヤ2イーサネット インターフェイスVLANのデフォルト設定

トランク ポートとしてのイーサネット インターフェイスの設定

他の機能との相互作用

トランク ポートの設定

トランクでの許可VLANの定義

プルーニング適格リストの変更

タグなしトラフィック用ネイティブVLANの設定

トランク ポートの負荷分散の設定

STPポート プライオリティによる負荷分散

STPパス コストによる負荷分散

VMPSの設定

VMPSの概要

ダイナミックアクセス ポートVLANメンバーシップ

VMPSクライアントのデフォルト設定

VMPS設定時の注意事項

VMPSクライアントの設定

VMPSのIPアドレスの入力

VMPSクライアント上のダイナミックアクセス ポートの設定

VLANメンバーシップの再確認

再確認インターバルの変更

再試行回数の変更

VMPSのモニタ

ダイナミックアクセス ポートVLANメンバーシップのトラブルシューティング

VMPSの設定例

VLANの設定

この章では、Catalyst 2970スイッチでの標準範囲VLAN(仮想LAN)(VLAN ID 1~1005)および拡張範囲VLAN(VLAN ID 1006~4094)の設定手順について説明します。VLANメンバーシップ モード、VLANコンフィギュレーション モード、VLANトランク、およびVLAN Membership Policy Server(VMPS;VLANメンバーシップ ポリシー サーバ)からの動的VLAN割り当てについても説明します。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「VLANの概要」

「標準範囲VLANの設定」

「拡張範囲VLANの設定」

「VLANの表示」

「VLANトランクの設定」

「VMPSの設定」

VLANの概要

VLANは、ユーザの物理的な位置に関係なく、機能、プロジェクト チーム、またはアプリケーションなどで論理的に分割されたスイッチド ネットワークです。VLANは、物理LANと同じ属性をすべて備えていますが、同じLANセグメントに物理的に配置されていないエンド ステーションもグループ化できます。どのスイッチ ポートもVLANに割り当てることができます。ユニキャスト、ブロードキャスト、およびマルチキャスト パケットは、VLAN内のエンド ステーションだけに転送およびフラッディングが行われます。各VLANは1つの論理ネットワークとみなされ、VLANに割り当てられていないステーション宛てのパケットは、ルータまたはフォールバック ブリッジングをサポートするスイッチを経由して転送しなければなりません(図11-1を参照)。VLANはそれぞれが独立した論理ネットワークとみなされるので、VLANごとに独自のブリッジMIB(管理情報ベース)情報があり、スパニングツリーの独自の実装をサポートできます。 第14章「STPの設定」 を参照してください。


) VLANを作成する前に、VLAN Trunking Protocol(VTP;VLANトランキング プロトコル)を使用してネットワークのグローバルなVLAN設定を維持するかどうかを決定する必要があります。VTPの詳細については、第12章「VTPの設定」を参照してください。


図11-1に、論理的に定義されたネットワークにセグメント化されたVLANの例を示します。

図11-1 論理的に定義されたネットワークとしてのVLAN

 

VLANは通常、IPサブネットワークに対応付けられます。たとえば、特定のIPサブネットに含まれるすべてのエンド ステーションは同一のVLANに所属させます。スイッチ上のインターフェイスのVLANメンバーシップは、インターフェイスごとに手動で割り当てます。この方法でスイッチ インターフェイスをVLANに割り当てた場合、これをインターフェイス ベース(またはスタティック)VLANメンバーシップと呼びます。

VLAN間のトラフィックは、ルーティングまたはフォールバック ブリッジングする必要があります。

サポートされるVLAN

スイッチは、VTPクライアント、サーバ、およびトランスペアレント モードでVLANをサポートします。VLANは、1~4094の番号で識別します。VLAN ID 1002~1005は、トークンリングおよびFiber Distributed Data Interface(FDDI)VLAN専用です。VTPは、VLAN IDが1~1005の標準範囲VLANのみを学習します。1005を超えるVLAN IDは拡張範囲VLANと呼ばれ、VLANデータベースには格納されません。1006~4094のVLAN IDを作成する場合は、スイッチをVTPトランスペアレント モードにする必要があります。

スイッチは合計1005の(標準範囲および拡張範囲)VLANをサポートしますが、スイッチ ハードウェアの使用は設定した機能の数に影響を受けます。

スイッチは、最大128のスパニングツリー インスタンスを持つPer-VLAN Spanning-Tree Plus(PVST+)またはRapid PVST+をサポートします。VLANごとに1つずつスパニングツリー インスタンスを使用できます。スパニングツリー インスタンス数およびVLAN数の詳細については、「標準範囲VLAN設定時の注意事項」を参照してください。スイッチはイーサネット ポート経由のVLANトラフィック送信に関して、ISL(スイッチ間リンク)およびIEEE 802.1Qトランキング方式の両方をサポートします。

VLANポート メンバーシップ モード

VLANに所属するポートは、メンバーシップ モードを割り当てることで設定します。メンバーシップ モードは、各ポートが伝送できるトラフィックの種類、および所属できるVLANの数を指定します。 表11-1 に、各種メンバーシップ モード、およびそれぞれのメンバーシップとVTPの特性を示します。

 

表11-1 ポートのメンバーシップ モードとその特性

メンバーシップ モード
VLANメンバーシップの特性
VTPの特性

スタティック アクセス

スタティック アクセス ポートは、手動で割り当てられ、1つのVLANだけに所属します。

詳細は、「VLANへのスタティック アクセス ポートの割り当て」を参照してください。

VTPは必須ではありません。VTPを使用して情報をグローバルに伝播させない場合は、VTPモードをトランスペアレントに設定します。VTPに参加する場合は、2台めのスイッチのトランク ポートに接続されたスイッチ上に、トランク ポートが少なくとも1つなければなりません。

トランク(ISLまたはIEEE 802.1Q)

デフォルトで、トランク ポートは拡張範囲VLANを含むすべてのVLANのメンバーです。ただし、メンバーシップは許可VLANリストを設定して制限できます。また、プルーニング適格リストを変更して、リストに指定したトランク ポート上のVLANへのフラッディング トラフィックを阻止することもできます。

トランク ポートの設定については、「トランク ポートとしてのイーサネット インターフェイスの設定」を参照してください。

VTPを推奨しますが、必須ではありません。VTPは、ネットワーク全体にわたってVLANの追加、削除、名前変更を管理することにより、VLAN設定の整合性を維持します。VTPはトランク リンクを通じて他のスイッチとVLANコンフィギュレーション メッセージを交換します。

ダイナミック アクセス

ダイナミックアクセス ポートは1つのVLAN(VLAN IDが1~4094)にのみ所属し、VMPSによって動的に割り当てられます。VMPSにはCatalyst 5000またはCatalyst 6500シリーズ スイッチを使用できますが、Catalyst 2970は使用できません。Catalyst 2970スイッチはVMPSクライアントです。

同一スイッチ上でダイナミックアクセス ポートとトランク ポートを使用できますが、ダイナミックアクセス ポートは別のスイッチではなく、エンド ステーションまたはハブに接続する必要があります。

設定情報については、「VMPSクライアント上のダイナミックアクセス ポートの設定」を参照してください。

VTPは必須です。

VMPSおよびクライアントを同じVTPドメイン名で設定してください。

VTPに参加する場合は、2台めのスイッチのトランク ポートに接続されたスイッチ上に、トランク ポートが少なくとも1つなければなりません。

音声VLAN

音声VLANポートは、Cisco IP Phoneに接続し、電話に接続された装置からの音声トラフィックに1つのVLANを、データ トラフィックに別のVLANを使用するように設定されたアクセス ポートです。

音声VLANポートの詳細については、 第13章「音声VLANの設定」 を参照してください。

VTPは不要です。VTPは音声VLANに作用しません。

アクセス モードとトランク モード、および機能の定義の詳細については、表11-4を参照してください。

ポートがVLANに所属すると、スイッチはVLAN単位で、ポートに対応するアドレスを学習して管理します。詳細は、「MACアドレス テーブルの管理」を参照してください。

標準範囲VLANの設定

標準範囲VLANは、VLAN IDが1~1005のVLANです。スイッチがVTPサーバまたはトランスペアレント モードの場合、VLANデータベース内のVLAN 2~1001の設定を追加、変更、または削除できます(VLAN ID 1および1002~1005は自動作成され、削除できません)。


) スイッチがVTPトランスペアレント モードの場合、拡張範囲VLAN(IDが1006~4094のVLAN)も作成できます。ただし、これらの拡張範囲VLANはVLANデータベースに格納されません。「拡張範囲VLANの設定」を参照してください。


VLAN ID 1~1005の設定はファイル vlan.dat (VLANデータベース)に書き込まれます。この設定を表示するには、 show vlan イネーブルEXECコマンドを入力します。 vlan.dat ファイルはフラッシュ メモリに保存されます。


注意 vlan.datファイルを手動で削除しようとすると、VLANデータベースの不整合が生じる可能性があります。VLAN設定を変更する場合は、ここに記載されたコマンド、およびこのリリースに対応するコマンド リファレンスに記載されたコマンドを使用します。 VTP設定の変更手順については、第12章「VTPの設定」を参照してください。

さらに、インターフェイス コンフィギュレーション モードを使用して、ポートのメンバーシップ モードの定義、VLANに対するポートの追加および削除を行います。これらのコマンドの実行結果は、実行コンフィギュレーション ファイルに書き込まれます。このファイルを表示するには、 show running-config イネーブルEXECコマンドを使用します。

VLANデータベースに新しい標準範囲VLANを作成したり、VLANデータベース内の既存のVLANを変更したりする場合、次のパラメータを設定できます。

VLAN ID

VLAN名

VLANタイプ(イーサネット、FDDI、FDDI Network Entity Title[NET]、TrBRFまたはTrCRF、トークンリング、トークンリングNet)

VLANステート(アクティブまたはサスペンド)

VLANのMaximum Transmission Unit(MTU;最大伝送ユニット)

Security Association Identifier(SAID)

Token Ring Bridge Relay Function(TrBRF;トークンリング ブリッジ リレー機能)VLANのブリッジ識別番号

FDDIおよびTrCRF VLANのリング番号

Token Ring Concentrator Relay Function(TrCRF;トークンリング コンセントレータ リレー機能)VLANの親VLAN番号

TrCRF VLANのSpanning-Tree Protocol(STP;スパニングツリー プロトコル)タイプ

あるVLANタイプから別のVLANタイプに変換するときに使用するVLAN番号


) ここでは、これらのパラメータの大部分の設定手順について説明しません。VLAN設定を制御するコマンドおよびパラメータの詳細については、このリリースに対応するコマンド リファレンスを参照してください。


ここでは、標準範囲VLANの設定情報について説明します。

「トークンリングVLAN」

「標準範囲VLAN設定時の注意事項」

「VLANコンフィギュレーション モードのオプション」

「VLAN設定の保存」

「イーサネットVLANのデフォルト設定」

「イーサネットVLANの作成または変更」

「VLANの削除」

「VLANへのスタティック アクセス ポートの割り当て」

トークンリングVLAN

このスイッチはトークンリング接続をサポートしていませんが、トークンリング接続を行っているCatalyst 5000シリーズ スイッチなどのリモート装置を、サポート対象スイッチのうちの1台から管理できます。VTPバージョン2が稼働しているスイッチは、次のトークンリングVLANに関する情報をアドバタイズします。

トークンリングTrBRF VLAN

トークンリングTrCRF VLAN

トークンリングVLANの詳しい設定手順については、『 Catalyst 5000 Series Software Configuration Guide 』を参照してください。

標準範囲VLAN設定時の注意事項

ネットワーク内で標準範囲VLANを作成または変更する場合には、次の注意事項に従ってください。

スイッチは、VTPクライアント、サーバ、およびトランスペアレント モードで1005のVLANをサポートします。

標準範囲VLANは、1~1001の番号で識別します。VLAN番号1002~1005は、トークンリングおよびFDDI VLAN専用です。

VLAN 1~1005のVLAN設定は、常にVLANデータベースに格納されます。VTPモードがトランスペアレントの場合、VTPおよびVLAN設定はスイッチの実行コンフィギュレーション ファイルにも格納されます。

スイッチはVTPトランスペアレント モード(VTPはディセーブル)で、VLAN ID 1006~4094もサポートします。これらは拡張範囲VLANであり、設定オプションには制限があります。拡張範囲VLANはVLANデータベースには格納されません。「拡張範囲VLANの設定」を参照してください。

VLANを作成する前に、スイッチをVTPサーバ モードまたはVTPトランスペアレント モードにしておく必要があります。スイッチがVTPサーバである場合には、VTPドメインを定義する必要があります。VTPドメインを定義しないと、VTPは機能しません。

スイッチは、トークンリングまたはFDDIメディアをサポートしません。スイッチはFDDI、FDDI-Net、TrCRF、またはTrBRFトラフィックを伝送しませんが、VTPを介してVLAN設定を伝播します。

スイッチは128のスパニングツリー インスタンスをサポートします。スイッチのアクティブなVLAN数が、サポートされているスパニングツリー インスタンス数よりも多い場合、スパニングツリーは128個のVLANでイネーブルにできます。残りのVLANで、スパニングツリーはディセーブルになります。スイッチ上の使用可能なスパニングツリー インスタンスをすべて使い切ってしまったあとに、VTPドメインの中にさらに別のVLANを追加すると、そのスイッチ上にスパニングツリーが稼働しないVLANが生成されます。そのスイッチのトランク ポート上でデフォルトの許可リスト(すべてのVLANを許可するリスト)が設定されていると、すべてのトランク ポート上に新しいVLANが割り当てられます。ネットワーク トポロジーによっては、新しいVLAN上で、切断されないループが生成されることがあります。特に、複数の隣接スイッチでスパニングツリー インスタンスをすべて使用してしまっている場合には注意が必要です。スパニングツリー インスタンスの割り当てを使い果たしたスイッチのトランク ポートに許可リストを設定することにより、このような可能性を防ぐことができます。

スイッチ上のVLANの数がサポートされているスパニング ツリー インスタンスの最大数を超える場合、スイッチ上にIEEE 802.1s Multiple STP(MSTP)を設定して、複数のVLANを単一のスパニング ツリー インスタンスにマッピングすることを推奨します。MSTPの詳細については、 第15章「MSTPの設定」 を参照してください。

VLANコンフィギュレーション モードのオプション

標準範囲VLAN(VLAN IDが1~1005)を設定するには、次に示す2つのコンフィギュレーション モードを使用します。

「config-vlanモードでのVLAN設定」

config-vlanモードを開始するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを入力します。

「VLANデータベース コンフィギュレーション モードでのVLAN設定」

VLANデータベース コンフィギュレーション モードを開始するには、 vlan database イネーブルEXECコマンドを入力します。

config-vlanモードでのVLAN設定

config-vlanモードにアクセスするには、VLAN IDを指定して vlan グローバル コンフィギュレーション コマンドを入力します。新しいVLAN IDを入力してVLANを作成するか、既存のVLAN IDを入力してVLANを変更します。デフォルトのVLAN設定を使用するか( 表11-2 を参照)、複数のコマンドを入力してVLANを設定できます。このモードで使用できるコマンドの詳細については、このリリースに対応するコマンド リファレンスの vlan グローバル コンフィギュレーション コマンドに関する説明を参照してください。設定を終了したら、config-vlanモードを終了して、設定を有効にする必要があります。VLAN設定を表示するには、 show vlan イネーブルEXECコマンドを入力します。

このconfig-vlanモードは、拡張範囲VLAN(VLAN IDが1005より大きい)を作成するときに使用する必要があります。「拡張範囲VLANの設定」を参照してください。

VLANデータベース コンフィギュレーション モードでのVLAN設定

VLANデータベース コンフィギュレーション モードを開始するには、 vlan database イネーブルEXECコマンドを入力します。次に、新しいVLAN IDを指定して vlan コマンドを入力してVLANを作成するか、既存のVLAN IDを入力してVLANを変更します。デフォルトのVLAN設定を使用するか( 表11-2 を参照)、複数のコマンドを入力してVLANを設定できます。このモードで使用できるキーワードの詳細については、このリリースに対応するコマンド リファレンスの vlan VLANデータベース コンフィギュレーション コマンドに関する説明を参照してください。設定を終了したら、 apply または exit を入力して、設定を有効にする必要があります。 exit コマンドを入力すると、すべてのコマンドが適用されて、VLANデータベースが更新されます。VTPドメイン内の他のスイッチにVTPメッセージが送信され、イネーブルEXECモード プロンプトが表示されます。

VLAN設定の保存

VLAN ID 1~1005の設定は、常にVLANデータベースに保存されます(vlan.datファイル)。VTPモードがトランスペアレントの場合、それらの設定もスイッチの実行コンフィギュレーション ファイルに格納されます。 copy running-config startup-config イネーブルEXECコマンドを使用して、スタートアップ コンフィギュレーション ファイルに設定を保存できます。VLAN設定を表示するには、 show vlan イネーブルEXECコマンドを入力します。

VLANおよびVTP情報(拡張範囲VLAN設定情報を含む)をスタートアップ コンフィギュレーション ファイルに保存して、スイッチを再起動すると、スイッチの設定は次のように選択されます。

スタートアップ コンフィギュレーションおよびVLANデータベース内のVTPモードがトランスペアレントで、VLANデータベースとスタートアップ コンフィギュレーション ファイルのVTPドメイン名が一致する場合は、VLANデータベースが無視され(クリアされ)、スタートアップ コンフィギュレーション ファイル内のVTPおよびVLAN設定が使用されます。VLANデータベース内のVLANデータベース リビジョン番号は変更されません。

スタートアップ コンフィギュレーション内のVTPモードまたはドメイン名がVLANデータベースと一致しない場合、最初の1005個のVLANのドメイン名、VTPモード、およびVTP設定にはVLANデータベース情報が使用されます。

VTPモードがサーバの場合、最初の1005個のVLANのドメイン名およびVLAN設定にはVLANデータベース情報が使用されます。


注意 起動時にVLANデータベース コンフィギュレーションが使用され、スタートアップ コンフィギュレーション ファイルに拡張範囲VLAN設定が含まれていた場合、システム起動時にこの情報は失われます。

イーサネットVLANのデフォルト設定

表11-2 にイーサネットVLANのデフォルト設定を示します。


) スイッチがサポートするのは、イーサネット インターフェイスだけです。FDDIおよびトークンリングVLANは、ローカルではサポートされないので、FDDIおよびトークンリング メディア固有の特性は、他のスイッチに対するVTPグローバル アドバタイズに限って設定します。


 

表11-2 イーサネットVLANのデフォルト値および範囲

パラメータ
デフォルト値
範囲

VLAN ID

1

1~4094


) 拡張範囲VLAN(VLAN ID 1006~4094)はVLANデータベースには保存されません。


VLAN名

VLANxxxx xxxx はVLAN ID番号に等しい4桁の数字(先行ゼロを含む)です。

範囲なし

IEEE 802.10 SAID

100001(100000とVLAN IDの和)

1~4294967294

MTUサイズ

1500

1500~18190

トランスレーショナル
ブリッジ1

0

0~1005

トランスレーショナル
ブリッジ2

0

0~1005

VLANステート

アクティブ

アクティブ、サスペンド

リモートSPAN

ディセーブル

イネーブル、ディセーブル

イーサネットVLANの作成または変更

VLANデータベース内の各イーサネットVLANには、1~1001の4桁の一意のIDが設定されています。VLAN ID 1002~1005は、トークンリングおよびFDDI VLAN用に予約されています。標準範囲VLANを作成してVLANデータベースに追加するには、VLANに番号および名前を割り当てます。


) スイッチがVTPトランスペアレント モードの場合、1006を超えるVLAN IDを割り当てることができますが、それらをVLANデータベースに追加することはできません。「拡張範囲VLANの設定」を参照してください。


VLANの追加時に指定されるデフォルト パラメータの一覧は、「標準範囲VLANの設定」を参照してください。

config-vlanモードを使用してイーサネットVLANを作成または変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id

VLAN IDを入力して、config-vlanモードを開始します。新規のVLAN IDを入力してVLANを作成するか、または既存のVLAN IDを入力してそのVLANを変更します。


) このコマンドで指定できるVLAN ID範囲は1~4094です。1005を超えるVLAN ID(拡張範囲VLAN)を追加する手順については、「拡張範囲VLANの設定」を参照してください。


ステップ 3

name vlan-name

(任意)VLANの名前を入力します。VLAN名を指定しなかった場合には、デフォルトとして、VLANという語の後ろに先行ゼロを含めた vlan-id が付加されます。たとえば、VLAN 4のデフォルトのVLAN名はVLAN0004になります。

ステップ 4

mtu mtu-size

(任意)MTUサイズ(または他のVLAN特性)を変更します。

ステップ 5

remote-span

(任意)リモートSwitched Port Analyzer(SPAN;スイッチド ポート アナライザ)セッションに対するRSPAN VLANとして、VLANを設定します。リモートSPANの詳細は、 第23章「SPANおよびRSPANの設定」 を参照してください。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 8

copy running-config startup config

(任意)スイッチがVTPトラスペアレント モードである場合、VLAN設定は実行コンフィギュレーション ファイルとVLANデータベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLAN名をデフォルトの設定に戻すには、 no name no mtu または no remote-span config-vlanコマンドを使用します。

次に、config-vlanモードを使用して、イーサネットVLAN 20を作成し、 test20 という名前を付け、VLANデータベースに追加する例を示します。

Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end
 

VLANデータベース コンフィギュレーション モードを使用することによって、イーサネットVLANを作成または変更することもできます。


) VLANデータベース コンフィギュレーション モードは、RSPAN VLAN設定または拡張範囲VLANをサポートしません。


VLANデータベース コンフィギュレーション モードを使用してイーサネットVLANを作成または変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

vlan database

VLANデータベース コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id name vlan-name

番号を割り当てることによって、イーサネットVLANを追加します。指定できる範囲は1~1001です。 vlan first-vlan-id end last-vlan-id を入力すると、連続するVLANの範囲を作成または変更できます。


) VLANデータベース コンフィギュレーション モードでVLAN IDを入力する場合、先行ゼロは入力しません。


VLAN名を指定しなかった場合には、デフォルトとして、VLANという語の後ろに先行ゼロを含めた vlan-id が付加されます。たとえば、VLAN 4のデフォルトのVLAN名はVLAN0004になります。

ステップ 3

vlan vlan-id mtu mtu-size

(任意)VLANを変更するには、VLANを指定し、MTUサイズなどの特性を変更します。

ステップ 4

exit

VLANデータベースをアップデートし、アップデート情報を管理ドメイン全体に伝播して、イネーブルEXECモードに戻ります。

ステップ 5

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 6

copy running-config startup config

(任意)スイッチがVTPトラスペアレント モードである場合、VLAN設定は実行コンフィギュレーション ファイルとVLANデータベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLAN名をデフォルトの設定に戻すには、 no vlan vlan-id name または no vlan vlan-id mtu VLANデータベース コンフィギュレーション コマンドを使用します。

次に、VLANコンフィギュレーション モードを使用して、イーサネットVLAN 20を作成し、 test20 という名前を付け、VLANデータベースに追加する例を示します。

Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
APPLY completed.
Exiting....
 

VLANの削除

VTPサーバ モードのスイッチからVLANを削除すると、VTPドメイン内のすべてのスイッチのVLANデータベースから、そのVLANが削除されます。VTPトランスペアレント モードのスイッチからVLANを削除した場合、そのスイッチに限ってVLANが削除されます。

メディア タイプが異なるデフォルトのVLANを削除することはできません。たとえば、イーサネットVLAN 1、およびFDDIまたはトークンリングVLANの1002~1005を削除することはできません。


注意 VLANを削除すると、そのVLANに割り当てられていたすべてのポートが非アクティブになります。これらのポートは、新しいVLANに割り当てられるまで、元のVLANに(非アクティブで)対応付けられたままです。

スイッチ上でVLANを削除するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no vlan vlan-id

VLAN IDを入力して、VLANを削除します。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show vlan brief

VLANが削除されたことを確認します。

ステップ 5

copy running-config startup config

(任意)スイッチがVTPトランスペアレント モードである場合、VLAN設定は実行コンフィギュレーション ファイルとVLANデータベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLANデータベース コンフィギュレーション モードを使用してVLANを削除するには、 vlan database イネーブルEXECコマンド使用して、VLANデータベース コンフィギュレーション モードを開始してから、 no vlan vlan-id VLANデータベース コンフィギュレーション コマンドを実行します。

VLANへのスタティック アクセス ポートの割り当て

VTPをディセーブルにすることによって(VTPトランスペアレント モード)、VTPにVLAN設定情報をグローバルに伝播させずに、スタティック アクセス ポートをVLANに割り当てることができます。

クラスタ メンバー スイッチのポートをVLANに割り当てる場合、最初に rcommand イネーブルEXECコマンドを使用して、そのクラスタ メンバー スイッチにログインします。


) 存在しないVLANにインターフェイスを割り当てると、新しいVLANが作成されます(イーサネットVLANの作成または変更を参照)。


VLANデータベース内のVLANにポートを割り当てるには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

VLANに追加するインターフェイスを入力します。

ステップ 3

switchport mode access

ポート(レイヤ2アクセス ポート)のVLANメンバーシップ モードを定義します。

ステップ 4

switchport access vlan vlan-id

VLANにポートを割り当てます。有効なVLAN IDは1~4094です。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show running-config interface interface-id

インターフェイスのVLANメンバーシップ モードを確認します。

ステップ 7

show interfaces interface-id switchport

表示された Administrative Mode および Access Mode VLAN フィールドの設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

インターフェイスをデフォルトの設定に戻すには、 default interfac e interface-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、VLAN 2のアクセス ポートとしてポートを設定する例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end

拡張範囲VLANの設定

スイッチがVTPトランスペアレント モード(VTPがディセーブル)の場合、拡張範囲VLAN(1006~4094)を作成できます。サービス プロバイダーは拡張範囲VLANを使用することにより、インフラストラクチャを拡張して、多数の顧客に対応できます。拡張範囲VLAN IDは、VLAN IDが許可されている任意のswitchportコマンドで使用できます。拡張範囲VLANを設定する場合は、必ずconfig-vlanモード(開始するには vlan vlan-id グローバル コンフィギュレーション コマンドを入力)を使用してください。拡張範囲はVLANデータベース コンフィギュレーション モード(開始するには vlan database イネーブルEXECコマンドを入力)ではサポートされません。

拡張範囲VLANの設定はVLANデータベースには格納されません。ただし、VTPモードがトランスペアレントであるため、スイッチの実行コンフィギュレーション ファイルに格納されます。設定をスタートアップ コンフィギュレーション ファイルに保存するには、 copy running-config startup-config イネーブルEXECコマンドを使用します。


) スイッチは4094のVLAN IDをサポートしますが、実際にサポートされるVLANの数については、「サポートされるVLAN」を参照してください。


ここでは、拡張範囲VLANの設定情報について説明します。

「VLANのデフォルト設定」

「拡張範囲VLAN設定時の注意事項」

「拡張範囲VLANの作成」

VLANのデフォルト設定

イーサネットVLANのデフォルト設定については、表11-2を参照してください。拡張範囲VLANで変更できるのは、MTUサイズとリモートSPANコンフィギュレーション ステートだけです。その他のすべての特性はデフォルト ステートのまま残してください。

拡張範囲VLAN設定時の注意事項

拡張範囲VLANを作成するときは次の注意事項に従ってください。

拡張範囲VLANを追加するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを使用して、config-vlanモードを開始する必要があります。VLANデータベース コンフィギュレーション モード(開始するには vlan database イネーブルEXECコマンドを入力)では、拡張範囲VLANを追加できません。

拡張範囲のVLAN IDは、VLANデータベースに保存されず、VTPで認識されません。

プルーニング適格範囲に拡張範囲VLANを含めることはできません。

拡張範囲VLANを作成するときは、スイッチをVTPトランスペアレント モードにする必要があります。VTPモードがサーバまたはクライアントの場合、エラー メッセージが生成され、拡張範囲VLANが拒否されます。

グローバル コンフィギュレーション モードまたはVLANデータベース コンフィギュレーション モードで、VTPモードをトランスペアレントに設定できます。「VTPのディセーブル化(VTPトランスペアレント モード)」を参照してください。VTPトランスペアレント モードでスイッチが起動するように、この設定をスタートアップ コンフィギュレーションに保存する必要があります。このようにしないと、スイッチをリセットした場合に、拡張範囲VLAN設定が失われます。

拡張範囲VLANでは、STPはデフォルトでイネーブルになりますが、no spanning-tree vlan vlan-idグローバル コンフィギュレーション コマンドを使用してディセーブルにできます。スイッチ上に最大数のスパニングツリー インスタンスが存在している場合に、VLANを新規作成すると、このVLAN上でスパニングツリーはディセーブルになります。スイッチ上のVLANの数がスパニング ツリー インスタンスの最大数を超える場合、スイッチ上にIEEE 802.1s MSTPを設定して、複数のVLANを単一のスパニング ツリー インスタンスにマッピングすることを推奨します。MSTPの詳細については、 第15章「MSTPの設定」 を参照してください。

スイッチは合計1005の(標準範囲および拡張範囲)VLANをサポートしますが、機能の設定数によりスイッチ ハードウェアの動作は変わります。拡張範囲VLANを作成するときに、使用できるハードウェア リソースが不足していると、エラー メッセージが生成され、拡張範囲VLANが拒否されます。

拡張範囲VLANの作成

グローバル コンフィギュレーション モードで拡張範囲VLANを作成するには、 vlan グローバル コンフィギュレーション コマンドを入力し、1006~4094のVLAN IDを指定します。このコマンドによってconfig-vlanモードが開始されます。拡張範囲VLANはデフォルトのイーサネットVLAN特性( 表11-2 を参照)を使用します。変更できるパラメータはMTUサイズおよびRSPAN設定だけです。すべてのパラメータのデフォルト値については、コマンド リファレンスに記載された vlan グローバル コンフィギュレーション コマンドの説明を参照してください。スイッチがVTPトランスペアレント モードでない場合に拡張範囲VLAN IDを入力すると、config-vlanモードの終了時にエラー メッセージが生成され、拡張範囲VLANが作成されません。

拡張範囲VLANはVLANデータベースに保存されずに、スイッチの実行コンフィギュレーション ファイルに保存されます。拡張範囲VLAN設定をスイッチのスタートアップ コンフィギュレーション ファイルに保存するには、 copy running-config startup-config イネーブルEXECコマンドを使用します。

拡張範囲VLANを作成するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp mode transparent

スイッチをVTPトランスペアレント モードに設定し、VTPをディセーブルにします。

ステップ 3

vlan vlan-id

拡張範囲VLAN IDを入力して、config-vlanモードを開始します。指定できる範囲は1006~4094です。

ステップ 4

mtu mtu-size

(任意)MTUサイズを変更して、VLANを変更します。


) config-vlanモードのCLIヘルプにはすべてのVLANコマンドが表示されますが、拡張範囲VLANでサポートされるのはmtu mtu-sizeおよびremote-spanコマンドだけです。


ステップ 5

remote-span

(任意)RSPAN VLANとしてVLANを設定します。「RSPAN VLANとしてのVLANの設定」を参照してください。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show vlan id vlan-id

VLANが作成されたことを確認します。

ステップ 8

copy running-config startup config

スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。拡張範囲VLAN設定を保存するには、VTPトランスペアレント モード設定および拡張範囲VLAN設定をスイッチのスタートアップ コンフィギュレーション ファイルに保存する必要があります。これらを保存しないと、スイッチをリセットした場合に、スイッチがデフォルトでVTPサーバ モードになり、拡張範囲VLAN IDは保存されません。

拡張範囲VLANを削除するには、 no vlan vlan-id グローバル コンフィギュレーション コマンドを使用します。

スタティック アクセス ポートを拡張範囲VLANに割り当てる手順は、標準範囲VLANの手順と同じです。「VLANへのスタティック アクセス ポートの割り当て」を参照してください。

次に、すべてデフォルトの特性で拡張範囲VLANを新規作成し、config-vlanモードを開始して、新規VLANをスイッチのスタートアップ コンフィギュレーション ファイルに保存する例を示します。

Switch(config)# vtp mode transparent
Switch(config)# vlan 2000
Switch(config-vlan)# end
Switch# copy running-config startup config

VLANの表示

拡張範囲VLANを含む、スイッチ上のすべてのVLANのリストを表示するには、 show vlan イネーブルEXECコマンドを使用します。VLANステータス、ポート、および設定情報も表示されます。VLANデータベース内の標準範囲VLAN(1~1005)を表示するには、 show VLANデータベース コンフィギュレーション コマンド(開始するには vlan database イネーブルEXECコマンドを入力)を使用します。

表11-3 にVLANをモニタするためのコマンドを示します。

 

表11-3 VLANモニタ コマンド

コマンド
コマンド モード
目的

show

VLANデータベース
コンフィギュレーション

VLANデータベース内のVLANのステータスを表示します。

show current [ vlan-id ]

VLANデータベース
コンフィギュレーション

VLANデータベース内のすべてのVLANまたは特定のVLANのステータスを表示します。

show interfaces [ vlan vlan-id ]

イネーブルEXEC

スイッチ上に設定されたすべてのインターフェイスまたは特定のVLANの特性を表示します。

show vlan [ id vlan-id ]

イネーブルEXEC

スイッチ上のすべてのVLANまたは特定のVLANのパラメータを表示します。

showコマンド オプションおよび出力フィールドの詳細については、このリリースに対応するコマンド リファレンスを参照してください。

VLANトランクの設定

ここでは、次の概要について説明します。

「トランキングの概要」

「カプセル化タイプ」

「レイヤ2イーサネット インターフェイスVLANのデフォルト設定」

「トランク ポートとしてのイーサネット インターフェイスの設定」

「トランク ポートの負荷分散の設定」

トランキングの概要

トランクとは、1つまたは複数のイーサネット スイッチ インターフェイスと他のネットワーキング装置(ルータ、スイッチなど)の間のポイントツーポイント リンクです。イーサネット トランクは単一リンクを介して複数のVLANトラフィックを伝送できるので、VLANをネットワーク全体に拡張できます。

すべてのイーサネット インターフェイス上で、2種類のトランキング カプセル化方式を使用できます。

ISL ― ISLはシスコ独自のトランキング カプセル化方式です。

IEEE 802.1Q ― 業界標準のトランキング カプセル化

図11-2に、ISLトランクで接続されているスイッチ ネットワークを示します。

図11-2 ISLトランキング環境のスイッチ

 

トランクを設定できるのは、1つのイーサネット インターフェイスまたはEtherChannelバンドルに対してです。EtherChannelの詳細については、 第29章「EtherChannelの設定」 を参照してください。

イーサネット トランク インターフェイスは、 表11-4 に示すトランキング モードをサポートしています。インターフェイスをトランキングまたは非トランキングとして設定したり、近接インターフェイスとトランキングのネゴシエーションを行ったりするように設定できます。トランキングを自動ネゴシエーションするには、インターフェイスが同じVTPドメインに存在する必要があります。

トランク ネゴシエーションは、PPP(ポイントツーポイント プロトコル)であるDynamic Trunking Protocol(DTP)によって管理されます。ただし、一部のインターネットワーキング装置によってDTPフレームが不正に転送されて、矛盾した設定となる場合があります。

この事態を避けるには、DTPをサポートしない装置に接続されたインターフェイスがDTPフレームを転送しないように、つまりDTPをオフにするように設定する必要があります。

これらのリンクを介してトランキングを行わない場合は、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、トランキングをディセーブルにします。

DTPをサポートしていない装置へのトランキングをイネーブルにするには、 switchport mode trunk および switchport nonegotiate インターフェイス コンフィギュレーション コマンドを使用して、インターフェイスがトランクになってもDTPフレームを生成しないように設定します。 switchport trunk encapsulation isl または switchport trunk encapsulation dot1q インターフェイスを使用して、トランク ポートのカプセル化タイプを選択します。

トランクにISLカプセル化を使用させるのか、IEEE 802.1Qカプセル化を使用させるのか、それともカプセル化タイプの自動ネゴシエーションを行うのかをDTPインターフェイス上で指定することもできます。DTPはISLトランクおよびIEEE 802.1Qトランクの両方の自動ネゴシエーションをサポートします。

 

表11-4 レイヤ2インターフェイス モード

モード
機能

switchport mode access

インターフェイス(アクセス ポート)を永続的な非トランキング モードにして、リンクの非トランク リンクへの変換をネゴシエートします。インターフェイスは、近接インターフェイスがトランク インターフェイスかどうかに関係なく、非トランク インターフェイスになります。

switchport mode dynamic auto

インターフェイスがリンクをトランク リンクに変換できるようにします。インターフェイスは、近接インターフェイスが trunk または desirable モードに設定されている場合、トランク インターフェイスになります。すべてのイーサネット インターフェイスのデフォルトのスイッチポート モードは dynamic auto です。

switchport mode dynamic desirable

インターフェイスがリンクのトランク リンクへの変換をアクティブに実行するようにします。インターフェイスは、近接インターフェイスが trunk desirable 、または auto モードに設定されている場合、トランク インターフェイスになります。

switchport mode trunk

インターフェイスを永続的なトランキング モードにして、近接リンクのトランク リンクへの変換をネゴシエートします。インターフェイスは、近接インターフェイスがトランク インターフェイスでない場合でも、トランク インターフェイスになります。

switchport nonegotiate

インターフェイスがDTPフレームを生成しないようにします。このコマンドは、インターフェイス スイッチポート モードが access または trunk の場合だけ使用できます。トランク リンクを確立するには、手動で近接インターフェイスをトランク インターフェイスとして設定する必要があります。

カプセル化タイプ

表11-5 に、イーサネット トランクのカプセル化タイプおよびキーワードを示します。

 

表11-5 イーサネット トランクのカプセル化タイプ

カプセル化
機能

switchport trunk encapsulation isl

トランク リンクにISLカプセル化を指定します。

switchport trunk encapsulation dot1q

トランク リンクにIEEE 802.1Qカプセル化を指定します。

switchport trunk encapsulation negotiate

インターフェイスが近接インターフェイスとネゴシエーションを行い、近接インターフェイスの設定および機能に応じてISLトランク(優先)またはIEEE 802.1Qトランクになるように指定します。これがスイッチのデフォルトです。

リンクがISLトランクまたはIEEE 802.1Qトランクのどちらになるかは、接続された2つのインターフェイスのトランキング モード、トランク カプセル化タイプ、およびハードウェア機能によって決まります。

IEEE 802.1Qの設定に関する考慮事項

IEEE 802.1Qトランクは、ネットワークのトランキング方式について次の制約があります。

IEEE 802.1Qトランクを使用して接続しているシスコ製スイッチのネットワークでは、スイッチはトランク上で許容されるVLANごとに1つのスパニングツリー インスタンスを維持します。他社製の装置は、すべてのVLANでスパニングツリー インスタンスを1つサポートする場合があります。

IEEE 802.1Qトランクを使用してシスコ製スイッチを他社製の装置に接続する場合、シスコ製スイッチは、トランクのVLANのスパニングツリー インスタンスを、他社製のIEEE 802.1Qスイッチのスパニングツリー インスタンスと結合します。ただし、各VLANのスパニングツリー情報は、他社製のIEEE 802.1Qスイッチからなるクラウドにより分離されたシスコ製スイッチによって維持されます。シスコ製スイッチを分離する他社製のIEEE 802.1Qクラウドは、スイッチ間の単一トランク リンクとして扱われます。

IEEE 802.1Qトランクに対応するネイティブVLANが、トランク リンクの両側で一致していなければなりません。トランクの片側のネイティブVLANと反対側のネイティブVLANが異なっていると、スパニングツリー ループが発生する可能性があります。

ネットワーク上のすべてのネイティブVLANについてスパニングツリーをディセーブルにせずに、IEEE 802.1QトランクのネイティブVLAN上のスパニングツリーをディセーブルにすると、スパニングツリー ループが発生することがあります。IEEE 802.1QトランクのネイティブVLAN上でスパニングツリーをイネーブルのままにしておくか、またはネットワーク上のすべてのVLANでスパニングツリーをディセーブルにすることを推奨します。また、ネットワークにループがないことを確認してから、スパニングツリーをディセーブルにしてください。

レイヤ2イーサネット インターフェイスVLANのデフォルト設定

表11-6 に、レイヤ2イーサネット インターフェイスVLANのデフォルト設定を示します。

 

表11-6 レイヤ2イーサネット インターフェイスVLANのデフォルト設定

機能
デフォルト設定

インターフェイス モード

switchport mode dynamic auto

トランク カプセル化

switchport trunk encapsulation negotiate

VLAN許容範囲

VLAN 1~4094

プルーニングに適格なVLAN範囲

VLAN 2~1001

デフォルトVLAN(アクセス ポート用)

VLAN 1

ネイティブVLAN(IEEE 802.1Qトランク用)

VLAN 1

トランク ポートとしてのイーサネット インターフェイスの設定

トランク ポートはVTPアドバタイズを送受信するので、VTPを使用する場合は、スイッチ上で少なくとも1つのトランク ポートが設定されており、そのトランク ポートが第2のスイッチのトランク ポートに接続されていることを確認する必要があります。そうでない場合、スイッチはVTPアドバタイズを受信できません。

ここでは、次の設定情報について説明します。

「他の機能との相互作用」

「トランクでの許可VLANの定義」

「プルーニング適格リストの変更」

「タグなしトラフィック用ネイティブVLANの設定」


) トランクはデフォルトでカプセル化のネゴシエーションを行います。近接インターフェイスがISLおよびIEEE 802.1Qカプセル化をサポートしていて、なおかつ両方のインターフェイスがカプセル化タイプのネゴシエーションを行うように設定されている場合、トランクはISLカプセル化を使用します。


他の機能との相互作用

トランキングは他の機能と次のように相互作用します。

トランク ポートをセキュア ポートにすることはできません。

トランク ポートをまとめてEtherChannelポート グループにすることはできますが、グループ内のすべてのトランクに同じ設定をする必要があります。グループを初めて作成したときには、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。次のパラメータのいずれかについて、設定を変更すると、入力した設定値がスイッチによってグループ内のすべてのポートに伝播されます。

許可VLANリスト

各VLANのSTPポート プライオリティ

STP PortFastの設定値

トランク ステータス ― ポート グループ内の1つのポートがトランクでなくなると、すべてのポートがトランクでなくなります。

PVSTモードで設定するトランク ポートは24個まで、MSTモードで設定するトランク ポートは40個までにすることを推奨します。

トランク ポートでIEEE 802.1xをイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1xはイネーブルになりません。IEEE 802.1x対応ポートをトランクに変更しようとしても、ポート モードは変更されません。

ダイナミック モードのポートは、ネイバとトランク ポートへの変更をネゴシエートする場合があります。ダイナミック ポートでIEEE 802.1xをイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1xはイネーブルになりません。IEEE 802.1x対応ポートをダイナミックに変更しようとしても、ポート モードは変更されません。

トランク ポートの設定

ポートをトランク ポートとして設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トランクに設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport trunk encapsulation { isl | dot1q | negotiate }

ISLまたはIEEE 802.1Qカプセル化をサポートする、またはカプセル化タイプについて近接インターフェイスとネゴシエーションを行う(デフォルト)ようにポートを設定します。

同じカプセル化タイプを指定して、リンクの各終端を設定する必要があります。

ステップ 4

switchport mode { dynamic { auto | desirable } | trunk }

インターフェイスをレイヤ2トランクとして設定します(インターフェイスがレイヤ2アクセス ポートである場合、またはトランキング モードを指定するときに限り、必須です)。

dynamic auto ― 近接インターフェイスがtrunkまたはdesirableモードに設定されている場合に、インターフェイスをトランク リンクとして設定します。これがデフォルトです。

dynamic desirable ― 近接インターフェイスがtrunk、desirable、またはautoモードに設定されている場合に、インターフェイスをトランク リンクとして設定します。

trunk ― 近接インターフェイスがトランク インターフェイスでない場合でも、インターフェイスを永続的なトランキング モードに設定して、リンクをトランク リンクに変換するようにネゴシエートします。

ステップ 5

switchport access vlan vlan-id

(任意)インターフェイスがトランキングを停止した場合に使用するデフォルトVLANを指定します。

ステップ 6

switchport trunk native vlan vlan-id

IEEE 802.1Qトランク用のネイティブVLANを指定します。

ステップ 7

end

イネーブルEXECモードに戻ります。

ステップ 8

show interfaces interface-id switchport

インターフェイスのスイッチポート設定を表示します。 Administrative Mode および Administrative Trunking Encapsulation フィールドに表示されます。

ステップ 9

show interfaces interface-id trunk

インターフェイスのトランク設定を表示します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

インターフェイスをデフォルト設定に戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。トランキング インターフェイスのすべてのトランキング特性をデフォルトにリセットするには、 no switchport trunk インターフェイス コンフィギュレーション コマンドを使用します。トランキングをディセーブルにするには、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、ポートをスタティック アクセス ポートとして設定します。

次に、IEEE 802.1Qトランクとしてポートを設定する例を示します。この例では、近接インターフェイスがIEEE 802.1Qトランキングをサポートするように設定されていることを前提としています。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gigabitethernet0/2
Switch(config-if)# switchport mode dynamic desirable
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# end
 

トランクでの許可VLANの定義

デフォルトでは、トランク ポートはすべてのVLANに対してトラフィックを送受信します。各トランクですべてのVLAN ID(1~4094)が許可されます。ただし、許可リストからVLANを削除することにより、それらのVLANからのトラフィックがトランク上を流れないようにすることができます。トランクが伝送するトラフィックを制限するには、 switchport trunk allowed vlan remove vlan-list インターフェイス コンフィギュレーション コマンドを使用して、許可リストから特定のVLANを削除します。


) VLAN 1は、すべてのシスコ製スイッチのすべてのトランク ポートのデフォルトVLANです。以前は、すべてのトランク リンクでVLAN 1を必ずイネーブルにする必要がありました。VLAN 1の最小化機能を使用して、個々のVLANトランク リンクでVLAN 1をディセーブルに設定できます。これにより、ユーザ トラフィック(スパニングツリー アドバタイズなど)はVLAN 1で送受信されなくなります。


スパニングツリー ループまたはストームのリスクを軽減するには、許可リストからVLAN 1を削除して個々のVLANトランク ポートでVLAN 1をディセーブルにします。トランク ポートからVLAN 1を削除した場合、インターフェイスは引き続きVLAN 1内でCisco Discovery Protocol(CDP)、Port Aggregation Protocol(PAgP)、Link Aggregation Control Protocol(LACP)、DTP、およびVTPなどの管理トラフィックを送受信します。

VLAN 1をディセーブルにしたトランク ポートが非トランク ポートになると、そのポートはアクセスVLANに追加されます。アクセスVLANが1に設定されると、 switchport trunk allowed の設定には関係なく、ポートはVLAN 1に追加されます。ポート上でディセーブルになっている任意のVLANについて同様のことが当てはまります。

トランク ポートは、VLANがイネーブルになっており、VTPがVLANを認識し、なおかつポートの許可リストにそのVLANが登録されている場合に、VLANのメンバーになることができます。VTPが新しくイネーブルにされたVLANを認識し、そのVLANがトランク ポートの許可リストに登録されている場合、トランク ポートは自動的にそのVLANのメンバーになります。VTPが新しいVLANを認識し、そのVLANがトランク ポートの許可リストに登録されていない場合には、トランク ポートはそのVLANのメンバーにはなりません。

トランクの許可リストを変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport mode trunk

インターフェイスをVLANトランク ポートとして設定します。

ステップ 4

switchport trunk allowed vlan { add | all | except | remove } vlan-list

(任意)トランク上で許可されるVLANのリストを設定します。

add all except 、および remove キーワードの使用方法については、このリリースに対応するコマンド リファレンスを参照してください。

vlan-list パラメータは、1~4094の単一のVLAN番号、または2つのVLAN番号(小さい方が先、ハイフンで区切る)で指定されたVLAN範囲です。カンマで区切ったVLANパラメータの間、またはハイフンで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべてのVLANが許可されます。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Trunking VLANs Enabled フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

すべてのVLANの許可VLANリストをデフォルトに戻すには、 no switchport trunk allowed vlan インターフェイス コンフィギュレーション コマンドを使用します。

次に、ポートの許可VLANリストからVLAN 2を削除する例を示します。

Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end

プルーニング適格リストの変更

プルーニング適格リストは、トランク ポートだけに適用されます。トランク ポートごとに専用の適格リストがあります。この手順を有効にするには、VTPプルーニングがイネーブルに設定されている必要があります。VTPプルーニングをイネーブルにする方法については、「VTPプルーニングのイネーブル化」を参照してください。

トランク ポートのプルーニング適格リストからVLANを削除するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

VLANプルーニングを適用するトランク ポートを選択し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport trunk pruning vlan { add | except | none | remove } vlan-list [ ,vlan [ ,vlan [ ,,, ]]

トランクからのプルーニングを許可するVLANのリストを設定します( VTPプルーニングを参照)。

add except none 、および remove キーワードの使用方法については、このリリースに対応するコマンド リファレンスを参照してください。

連続していないVLAN IDは、カンマ(スペースなし)で区切ります。IDの範囲はハイフンで指定します。有効なID範囲は2~1001です。拡張範囲VLAN(VLAN ID 1006~4094)はプルーニングできません。

プルーニング不適格のVLANは、フラッディング トラフィックを受信します。

デフォルトでは、プルーニングが許可されるVLANのリストには、VLAN 2~1001が含まれます。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show interfaces interface-id switchport

表示された Pruning VLANs Enabled フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

すべてのVLANのプルーニング適格リストをデフォルトに戻すには、 no switchport trunk pruning vlan インターフェイス コンフィギュレーション コマンドを使用します。

タグなしトラフィック用ネイティブVLANの設定

IEEE 802.1Qタギングが設定されたトランク ポートは、タグ付きトラフィックおよびタグなしトラフィックの両方を受信できます。デフォルトでは、タグなしトラフィックは、ポートに設定されたネイティブVLANに転送されます。ネイティブVLANは、デフォルトではVLAN 1です。


) ネイティブVLANには任意のVLAN IDを割り当てることができます。


IEEE 802.1Q設定についての詳細は、「IEEE 802.1Qの設定に関する考慮事項」を参照してください。

IEEE 802.1QトランクでネイティブVLANを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

IEEE 802.1Qトランクとして設定するインターフェイスを定義して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport trunk native vlan vlan-id

トランク ポート上でタグなしトラフィックを送受信するVLANを設定します。

vlan-id に指定できる範囲は、1~4094です。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show interfaces interface-id switchport

Trunking Native Mode VLAN フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

ネイティブVLANをデフォルト(VLAN 1)に戻すには、 no switchport trunk native vlan インターフェイス コンフィギュレーション コマンドを使用します。

パケットのVLAN IDが出力ポートのネイティブVLAN IDと同じであれば、そのパケットはタグなしで送信されます。ネイティブVLAN IDと異なる場合は、スイッチはそのパケットをタグ付きで送信します。

トランク ポートの負荷分散の設定

負荷分散により、スイッチに接続しているパラレル トランクの提供する帯域幅が分割されます。STPは通常、ループを防止するために、スイッチ間で1つのパラレル リンク以外のすべてのリンクをブロックします。負荷分散を行うと、トラフィックの所属するVLANに基づいて、リンク間でトラフィックが分散されます。

トランク ポートで負荷分散を設定するには、STPポート プライオリティまたはSTPパス コストを使用します。STPポート プライオリティを使用して負荷分散を設定する場合には、両方の負荷分散リンクを同じスイッチに接続する必要があります。STPパス コストを使用して負荷分散を設定する場合には、それぞれの負荷分散リンクを同一のスイッチにも、2台の異なるスイッチにも接続できます。STPの詳細については、 第14章「STPの設定」 を参照してください。

STPポート プライオリティによる負荷分散

同一スイッチ上の2つのポートがループを形成すると、スイッチはSTPポート プライオリティを使用して、どのポートをイネーブルとし、どのポートをブロッキング ステートとするかを判断します。パラレル トランク ポートにプライオリティを設定することにより、そのポートに、特定のVLANのすべてのトラフィックを伝送させることができます。VLANに対するプライオリティの高い(値の小さい)トランク ポートがそのVLANのトラフィックを転送します。同じVLANに対してプライオリティの低い(値の大きい)トランク ポートは、そのVLANに対してブロッキング ステートのままです。1つのトランク ポートが特定のVLANに関するすべてのトラフィックを送受信することになります。

図11-3に、サポート対象スイッチを接続する2つのトランクを示します。この例では、スイッチは次のように設定されています。

VLAN 8~10は、トランク1で16というポート プライオリティが割り当てられています。

VLAN 3~6は、トランク1でデフォルトのポート プライオリティである128のままです。

VLAN 3~6は、トランク2で16というポート プライオリティが割り当てられています。

VLAN 8~10は、トランク2でデフォルトのポート プライオリティである128のままです。

このように設定すると、トランク1がVLAN 8~10のトラフィックを伝送し、トランク2がVLAN 3~6のトラフィックを伝送します。アクティブ トランクで障害が起きた場合には、プライオリティの低いトランクが引き継ぎ、それらすべてのVLANのトラフィックを伝送します。いずれのトランク ポート上でも、トラフィックの重複は発生しません。

図11-3 STPポート プライオリティによる負荷分散

 

図11-3のようにネットワークを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

スイッチAで、グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp domain domain-name

VTP管理ドメインを設定します。

1~32文字のドメイン名を使用できます。

ステップ 3

vtp mode server

スイッチAをVTPサーバとして設定します。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show vtp status

スイッチAおよびBの両方で、VTP設定を確認します。

表示された VTP Operating Mode および VTP Domain Name フィールドをチェックします。

ステップ 6

show vlan

スイッチAのデータベースにVLANが存在していることを確認します。

ステップ 7

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 8

interface gigabitethernet 0/1

トランクとして設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

switchport trunk encapsulation { isl | dot1q | negotiate }

ISLまたはIEEE 802.1Qカプセル化をサポートする、または近接インターフェイスとネゴシエーションを行うようにポートを設定します。同じカプセル化タイプを指定して、リンクの各終端を設定する必要があります。

ステップ 10

switchport mode trunk

ポートをトランク ポートとして設定します。

ステップ 11

end

イネーブルEXECモードに戻ります。

ステップ 12

show interfaces gigabitethernet 0/1 switchport

VLAN設定を確認します。

ステップ 13

スイッチAでスイッチの第2インターフェイスについて、ステップ7~11を繰り返します。

ステップ 14

スイッチBでステップ7~11を繰り返し、スイッチAで設定されたトランク ポートに接続するトランク ポートを設定します。

ステップ 15

show vlan

トランク リンクがアクティブになると、VTPがスイッチBにVTPおよびVLAN情報を渡します。スイッチBがVLAN設定を学習したことを確認します。

ステップ 16

configure terminal

スイッチAで、グローバル コンフィギュレーション モードを開始します。

ステップ 17

interface gigabitethernet 0/1

STPのポート プライオリティを設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 18

spanning-tree vlan 8-10 port-priority 16

VLAN 8~10にポート プライオリティ16を割り当てます。

ステップ 19

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 20

interface gigabitethernet0/2

STPのポート プライオリティを設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 21

spanning-tree vlan 3-6 port-priority 16

VLAN 3~6にポート プライオリティ16を割り当てます。

ステップ 22

end

イネーブルEXECモードに戻ります。

ステップ 23

show running-config

設定を確認します。

ステップ 24

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

STPパス コストによる負荷分散

トランクにそれぞれ異なるパス コストを設定し、各パス コストをそれぞれ異なるVLAN群に対応付け、各VLANでポートをブロックすることによって、VLANトラフィックを分散するパラレル トランクを設定できます。VLANはトラフィックを分離し、リンクが失われた場合に備えて冗長性を維持します。

図11-4で、トランク ポート1および2は100BASE-Tポートとして設定されています。次のVLANパス コストが割り当てられています。

VLAN 2~4は、トランク ポート1で30というパス コストが割り当てられています。

VLAN 8~10は、トランク ポート1で100BASE-Tのデフォルトのパス コストである19のままです。

VLAN 8~10は、トランク ポート2で30というパス コストが割り当てられています。

VLAN 2~4は、トランク ポート2で100BASE-Tのデフォルトのパス コストである19のままです。

図11-4 パス コストによってトラフィックが分散される負荷分散トランク

 

図11-4のようにネットワークを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

スイッチAで、グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface gigabitethernet0/1

トランクとして設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport trunk encapsulation
{ isl | dot1q | negotiate }

ISLまたはIEEE 802.1Qカプセル化をサポートするようにポートを設定します。同じカプセル化タイプを指定して、リンクの各終端を設定する必要があります。

ステップ 4

switchport mode trunk

ポートをトランク ポートとして設定します。トランクのデフォルトはISLトランキングです。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

スイッチAの第2インターフェイスで、ステップ2~5を繰り返します。

ステップ 7

end

イネーブルEXECモードに戻ります。

ステップ 8

show running-config

設定を確認します。画面で、インターフェイスがトランク ポートとして設定されていることを確認してください。

ステップ 9

show vlan

トランク リンクがアクティブになると、スイッチAがもう一方のスイッチからVTP情報を受信します。スイッチAがVLAN設定を学習したことを確認します。

ステップ 10

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 11

interface gigabitethernet0/1

STPコストを設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 12

spanning-tree vlan 2-4 cost 30

VLAN 2~4のスパニングツリー パス コストを30に設定します。

ステップ 13

end

グローバル コンフィギュレーション モードに戻ります。

ステップ 14

スイッチAに設定したもう一方のトランク インターフェイスで、ステップ9~13を繰り返し、VLAN 8、9、および10のスパニングツリー パス コストを30に設定します。

ステップ 15

exit

イネーブルEXECモードに戻ります。

ステップ 16

show running-config

設定を確認します。両方のトランク インターフェイスに対してパス コストが正しく設定されていることを表示で確認します。

ステップ 17

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

VMPSの設定

VLAN Query Protocol(VQP)は、ダイナミックアクセス ポートをサポートする場合に使用します。ダイナミックアクセス ポートはVLANに永続的に割り当てられるのではなく、ポートで認識されたMAC(メディア アクセス制御)送信元アドレスに基づいてVLANを割り当てます。未知のMACアドレスが検出されるたびに、スイッチはリモートVMPSにVQPクエリーを送信します。クエリーには新たに検出されたMACアドレスとそのアドレスを検出したポートが含まれます。VMPSはそのポートのVLAN割り当てで応答します。このスイッチをVMPSサーバにすることはできませんが、VMPSのクライアントとして機能させ、VQPを介して通信できます。

ここでは、次の情報について説明します。

「VMPSの概要」

「VMPSクライアントのデフォルト設定」

「VMPS設定時の注意事項」

「VMPSクライアントの設定」

「VMPSのモニタ」

「ダイナミックアクセス ポートVLANメンバーシップのトラブルシューティング」

「VMPSの設定例」

VMPSの概要

クライアント スイッチは新しいホストのMACアドレスを受信するたびに、VMPSにVQPクエリーを送信します。このクエリーを受信したVMPSは、データベースでMACアドレスとVLANのマッピングを検索します。サーバの応答は、このマッピングと、サーバがオープン モードかセキュア モードかに基づいて行われます。セキュア モードの場合、サーバは不正なホストが検出されると、ポートをシャットダウンします。オープン モードでは、サーバはホストに対してポート アクセスを拒否するだけです。

ポートが 未割り当て の場合(つまり、VLAN割り当てがまだ設定されていない場合)、VMPSは次のいずれかの応答を行います。

そのポートでホストが許可されている場合、VMPSは割り当てられたVLAN名を指定し、ホストへのアクセスを許可する VLAN割り当て 応答をクライアントに送信します。

そのポートでホストが許可されておらず、なおかつVMPSがオープン モードの場合、VMPSは アクセス拒否 応答を送信します。

そのポートでVLANが許可されておらず、なおかつVMPSがセキュア モードの場合、VMPSは ポートシャットダウン 応答を送信します。

ポートにVLAN割り当てがすでに設定されている場合、VMPSは次のいずれかの応答を行います。

データベース内のVLANがポート上の現在のVLANと一致した場合、VMPSは 成功 応答を送信し、ホストへのアクセスを許可します。

データベース内のVLANがポート上の現在のVLANと一致せず、なおかつポート上にアクティブ ホストが存在する場合、VMPSはVMPSのセキュア モードに応じて、 アクセス拒否 または ポートシャットダウン 応答を送信します。

VMPSから アクセス拒否 応答を受信した場合、スイッチはそのホストMACアドレスのトラフィックを双方向で引き続きブロックします。スイッチはポート宛のパケットを引き続きモニタし、新しいホスト アドレスを検出するとVMPSにクエリーを送信します。VMPSから ポートシャットダウン 応答を受信した場合、スイッチはそのポートをディセーブルにします。Network Assistant、CLI(コマンドライン インターフェイス)、またはSNMP(簡易ネットワーク管理プロトコル)を使用して、ポートを手動で再びイネーブルにする必要があります。

ダイナミックアクセス ポートVLANメンバーシップ

ダイナミックアクセス ポートが所属できるのは、VLAN IDが1~4094の1つのVLANだけです。リンクがアップになっても、VMPSによってVLANが割り当てられるまで、このポートとの間でトラフィック転送は行われません。VMPSは、ダイナミックアクセス ポートに接続した新しいホストの最初のパケットから送信元MACアドレスを受信し、VMPSデータベースのVLANとそのMACアドレスを照合します。

一致した場合、VMPSはそのポートのVLAN番号を送信します。クライアント スイッチがまだ設定されていない場合は、スイッチはVMPSからトランク ポートで受信した最初のVTPパケットからのドメイン名を使用します。クライアント スイッチがすでに設定されている場合は、クエリー パケットにスイッチのドメイン名を含めてVMPSに送信し、VLAN番号を取得します。VMPSはパケット内のドメイン名が自身のドメイン名と一致することを確認したあと、要求を受け入れ、クライアントに割り当てられたVLAN番号を応答します。一致しない場合、(VMPSセキュア モードの設定に応じて)VMPSは要求を拒否するか、ポートをシャットダウンします。

ダイナミックアクセス ポート上で複数のホスト(MACアドレス)をアクティブにできますが、それらのホストはすべて同じVLANに存在する必要があります。ただし、ポート上でアクティブなホスト数が20を超えると、VMPSはダイナミックアクセス ポートをシャットダウンします。

ダイナミックアクセス ポート上でリンクがダウンになると、ポートは切り離された状態に戻り、VLANの所属から外れます。ポート経由でオンラインになるホストはVMPSによってVQP経由で再チェックされてから、ポートがVLANに割り当てられます。

ダイナミックアクセス ポートは、直接ホスト接続に使用したり、ネットワークに接続したりできます。スイッチ上のポートごとに、最大20のMACアドレスを使用できます。ダイナミックアクセス ポートが一度に所属できるVLANは1つだけですが、VLANは検出されたMACアドレスに基づいてあとで変更されることがあります。

VMPSクライアントのデフォルト設定

表11-7 に、クライアント スイッチ上のVMPSおよびダイナミックアクセス ポートのデフォルト設定を示します。

 

表11-7 VMPSクライアントおよびダイナミックアクセス ポートのデフォルト設定

機能
デフォルト設定

VMPSドメイン サーバ

なし

VMPS再確認インターバル

60分

VMPSサーバ再試行回数

3

ダイナミックアクセス ポート

未設定

VMPS設定時の注意事項

ダイナミックアクセス ポートVLANメンバーシップには、次の注意事項および制限事項があります。

VMPSを設定してから、ポートをダイナミックアクセス ポートとして設定する必要があります。

ポートをダイナミックアクセス ポートとして設定すると、そのポートに対してスパニングツリーのPortFast機能が自動的にイネーブルになります。PortFastモードにより、ポートをフォワーディング ステートに移行させるプロセスが短縮されます。

IEEE 802.1xポートをダイナミックアクセス ポートとして設定することはできません。ダイナミックアクセス(VQP)ポートでIEEE 802.1xをイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1xはイネーブルになりません。IEEE 802.1x対応ポートを変更してダイナミックVLANを割り当てようとしても、エラー メッセージが表示され、VLAN設定は変更されません。

トランク ポートをダイナミックアクセス ポートにすることはできませんが、トランク ポートに対して switchport access vlan dynamic インターフェイス コンフィギュレーション コマンドを入力することは可能です。その場合、スイッチの設定は維持され、あとにアクセス ポートとして設定された場合には、その設定が適用されます。

ダイナミックアクセス設定を有効にするには、ポート上でトランキングをオフにしておく必要があります。

ダイナミックアクセス ポートをモニタ ポートにすることはできません。

セキュア ポートをダイナミックアクセス ポートにすることはできません。ポートをダイナミックにするには、ポート上でポート セキュリティをディセーブルにしておく必要があります。

ダイナミックアクセス ポートをEtherChannelグループのメンバーにすることはできません。

ポート チャネルをダイナミックアクセス ポートとして設定することはできません。

VMPSクライアントとVMPSサーバのVTP管理ドメインは、同じでなければなりません。

VMPSサーバ上に設定されたVLANを音声VLANにしないでください。

VMPSクライアントの設定

ダイナミックVLANを設定するには、VMPS(サーバ)を使用します。スイッチをVMPSクライアントにすることはできますが、VMPSサーバにすることはできません。

VMPSのIPアドレスの入力

スイッチをクライアントとして設定するには、サーバのIPアドレスを最初に入力する必要があります。


) スイッチ クラスタに対してVMPSを定義する場合は、コマンド スイッチにこのアドレスを入力する必要があります。


VMPSのIPアドレスを入力するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps server ipaddress primary

プライマリVMPSサーバとして動作するスイッチのIPアドレスを入力します。

ステップ 3

vmps server ipaddress

(任意)セカンダリVMPSサーバとして動作するスイッチのIPアドレスを入力します。

セカンダリ サーバのアドレスは、3つまで入力できます。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show vmps

表示された VMPS Domain Server フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。


) ダイナミックアクセス ポートを動作させるには、VMPSにIP接続できなければなりません。IP接続が可能かどうかをテストするには、VMPSのIPアドレスにpingを実行し、応答が得られるかどうかを確認します。


VMPSクライアント上のダイナミックアクセス ポートの設定

クラスタ メンバー スイッチのポートをダイナミックアクセス ポートとして設定するには、最初に rcommand イネーブルEXECコマンドを使用して、そのクラスタ メンバー スイッチにログインします。


注意 ダイナミックアクセス ポートVLANメンバーシップはエンド ステーション用、またはエンド ステーションに接続されたハブ用です。他のスイッチにダイナミックアクセス ポートを接続すると、接続が切断されることがあります。

VMPSクライアント スイッチにダイナミックアクセス ポートを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

エンド ステーションに接続するスイッチ ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport mode access

ポートをアクセス モードにします。

ステップ 4

switchport access vlan dynamic

ポートをダイナミックVLANメンバーシップ適格として設定します。

ダイナミックアクセス ポートは、エンド ステーションに接続されている必要があります。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Operational Mode フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

インターフェイスをデフォルト設定に戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。インターフェイスをデフォルトのスイッチポート モード(dynamic auto)に戻すには、 no switchport mode インターフェイス コンフィギュレーション コマンドを使用します。アクセス モードをスイッチのデフォルトVLANにリセットするには、 no switchport access vlan インターフェイス コンフィギュレーション コマンドを使用します。

VLANメンバーシップの再確認

スイッチがVMPSから受信したダイナミックアクセス ポートVLANメンバーシップの割り当てを確認するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

vmps reconfirm

ダイナミックアクセス ポートVLANメンバーシップを再確認します。

ステップ 2

show vmps

ダイナミックVLANの再確認ステータスを確認します。

再確認インターバルの変更

VMPSクライアントは、VMPSから受信するVLANメンバーシップの情報を定期的に再確認します。再確認を実行する間隔は数字を使用して分単位で設定できます。

クラスタのメンバー スイッチを設定する場合、このパラメータはコマンド スイッチの再確認インターバルの設定値以上でなければなりません。メンバー スイッチにログインするには、最初に rcommand イネーブルEXECコマンドを使用する必要があります。

再確認インターバルを変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps reconfirm minutes

ダイナミックVLANメンバーシップの再確認を行う間隔(分)を入力します。指定できる範囲は1~120分です。デフォルトは60分です。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show vmps

表示された Reconfirm Interval フィールドのダイナミックVLANの再確認ステータスを確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

スイッチのデフォルト設定に戻すには、 no vmps reconfirm グローバル コンフィギュレーション コマンドを使用します。

再試行回数の変更

スイッチが次のサーバにクエリーを送信する前に、VMPSとの接続を試行する回数を変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps retry count

再試行の回数を変更します。指定できる再試行回数の範囲は1~10です。デフォルトは3です。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show vmps

表示された Server Retry Count フィールドの設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルにエントリを保存します。

スイッチのデフォルト設定に戻すには、 no vmps retry グローバル コンフィギュレーション コマンドを使用します。

VMPSのモニタ

show vmps イネーブルEXECコマンドを使用して、VMPSに関する情報を表示できます。スイッチはVMPSに関する次の情報を表示します。

VMPS VQPバージョン ― VMPSとの通信に使用するVQPのバージョン。スイッチはVQPバージョン1を使用するVMPSにクエリーを送信します。

再確認インターバル ― スイッチがVLANとMACアドレスの割り当てを再確認する間隔(分)

サーバ再試行回数 ― VQPがVMPSにクエリーを再送信する回数。この回数すべてを試行しても応答が得られない場合、スイッチはセカンダリVMPSへのクエリーを開始します。

VMPSドメイン サーバ ― 設定されているVLANメンバーシップ ポリシー サーバのIPアドレス。スイッチはcurrentと表示されているサーバにクエリーを送信します。primaryと表示されているサーバは、プライマリ サーバです。

VMPS動作 ― 最新の再確認の結果。再確認は、再確認インターバルが経過したときに自動的に行われますが、 vmps reconfirm イネーブルEXECコマンドを入力するか、Network AssistantまたはSNMPで同等の操作を行うことによって、強制的に再確認することもできます。

次に、 show vmps イネーブルEXECコマンドの出力例を示します。

Switch# show vmps
VQP Client Status:
--------------------
VMPS VQP Version: 1
Reconfirm Interval: 60 min
Server Retry Count: 3
VMPS domain server: 172.20.128.86 (primary, current)
172.20.128.87
 
Reconfirmation status
---------------------
VMPS Action: other
 

ダイナミックアクセス ポートVLANメンバーシップのトラブルシューティング

VMPSは次の状況でダイナミックアクセス ポートをシャットダウンします。

VMPSがセキュア モードであり、なおかつホストのポートへの接続を許可しない場合。VMPSはポートをシャットダウンして、ホストがネットワークに接続できないようにします。

ダイナミックアクセス ポート上のアクティブ ホストが20を超えた場合

ディセーブルにされているダイナミックアクセス ポートを再びイネーブルにするには、 shutdown インターフェイス コンフィギュレーション コマンドに続けて、 no shutdown インターフェイス コンフィギュレーション コマンドを入力します。

VMPSの設定例

図11-5に、VMPSサーバ スイッチと、ダイナミックアクセス ポートを備えたVMPSクライアント スイッチが含まれるネットワークの例を示します。この例の前提条件は次のとおりです。

VMPSサーバとVMPSクライアントは、それぞれ別個のスイッチです。

Catalyst 6500シリーズのスイッチAが、プライマリVMPSサーバです。

Catalyst 6500シリーズのスイッチCおよびスイッチJが、セカンダリVMPSサーバです。

エンド ステーションはクライアント(スイッチB、スイッチI)に接続されています。

データベース コンフィギュレーション ファイルは、IPアドレス172.20.22.7のTFTPサーバに保管されています。

図11-5 ダイナミック ポートVLANメンバーシップの構成例