Catalyst 2955 スイッチ ハードウェア インストレーション ガイド
CLIベースのセットアップ プロ グラムによるスイッチの設定
CLIベースのセットアップ プログラムによるスイッチの設定
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

CLIベースのセットアップ プログラムによるスイッチの設定

必要なコンポーネントの取り出し

電源の接続

コンソール ポートの接続

端末エミュレーション ソフトウェアの起動

初期設定情報の入力

IP設定

セットアップ プログラムの完了

CLIベースのセットアップ プログラムによるスイッチの設定

ここでは、CLI(コマンドライン インターフェイス)ベースの、スタンドアロン スイッチのセットアップ手順について説明します。製品概要については、 第2章「概要」 を参照してください。電源にスイッチを接続する前に、 第3章「インストレーション」 の安全上の警告を再確認してください。スイッチの電源への接続、スイッチのラックへの設置、またはイーサネット ポートへの接続の手順については 第3章「インストレーション」 を参照してください。


注意 危険環境でスイッチを設置する場合は、第4章「危険環境でのインストレーション」の安全上の警告を再確認してください。危険環境での設置手順については、第4章「危険環境でのインストレーション」を参照してください。

インストレーションの手順は次のとおりです。

1. 「必要なコンポーネントの取り出し」

2. 「コンソール ポートの接続」

3. 「端末エミュレーション ソフトウェアの起動」

4. 「電源の接続」

5. 「初期設定情報の入力」

必要なコンポーネントの取り出し

図 1-1 に示されているものを梱包箱から取り出します。

図 1-1 Catalyst 2955スイッチおよびアダプタ ケーブル

 

 

1

Catalyst 2955スイッチ

2

RJ-45/DB-9アダプタ ケーブル


) スイッチ ポートを他のイーサネット装置に接続するには、カテゴリ5ストレート ケーブルが必要です。


電源の接続

Catalyst 2955スイッチをDC電源に接続する手順については、「DC電源の配線」を参照してください。Catalyst 2955スイッチを、オプションの電源コンバータを使用してACまたはDC電源に接続する手順については、「電源コンバータへのスイッチの接続」を参照してください。

電源が入ると、スイッチは自動的にPower-on Self-Test(POST;電源投入時セルフテスト)を開始します。POSTは、スイッチが正常に機能していることを確認する一連のテストです。


) アップリンク ポート ステータスLEDは、POST実行時のシステム情報およびステータス情報を示します。Catalyst 2955C-12および2955S-12では、アップリンク ポートには13および14というラベルが付いています。Catalyst 2955T-12では、アップリンク ポートには1および2というラベルが付いています。


Catalyst 2955C-12および2955S-12がPOSTを開始すると、次の状態になります。

アップリンク ポート13のLEDはオレンジです。

アップリンク ポート14のLEDはグリーンに点滅します。

Catalyst 2955T-12がPOSTを開始すると、次の状態になります。

アップリンク ポート1のLEDはオレンジです。

アップリンク ポート2のLEDはグリーンに点滅します。

Catalyst 2955C-12および2955S-12でPOSTが正常に終了すると、次の状態になります。

アップリンク ポート13のLEDはグリーンに点灯します。

アップリンク ポート14のLEDは、フラッシュ ファイルシステムが初期化されている間、消灯します。

Catalyst 2955T-12でPOSTが正常に終了すると、次の状態になります。

アップリンク ポート1のLEDはグリーンに点灯します。

アップリンク ポート2のLEDは、フラッシュ ファイルシステムが初期化されている間、消灯します。

Catalyst 2955C-12および2955S-12のPOSTでエラーが発生すると、次の状態になります。

アップリンク ポート13のLEDはオレンジに点滅します。

アップリンク ポート14のLEDはグリーンに点灯します。

Catalyst 2955T-12のPOSTでエラーが発生すると、次の状態になります。

アップリンク ポート1のLEDはオレンジに点滅します。

アップリンク ポート2のLEDはグリーンに点灯します。


) POSTのエラーはほとんどの場合、回復不可能な障害です。POSTでエラーが発生した場合は、ただちに製品を購入した代理店に連絡してください。「テクニカル サポート」を参照してください。


コンソール ポートの接続

コンソール ポートを使用して初期設定を実行できます。PCにコンソール ポートを接続するには、付属のRJ-45/DB-9アダプタ ケーブルを使用します。


警告 スイッチまたはネットワーク上の装置に電源が入った状態で、ポートに接続するケーブルの着脱を行うと、アーク放電を生じることがあります。その場合、危険な場所でインストレーションを行うと爆発する危険性があります。作業を始める前に、スイッチの電源が切断され、偶発的に電源がオンになる可能性がなく、周囲に危険性がないことを確認してください。


スイッチにPCまたは端末を接続する手順は、次のとおりです。


ステップ 1 付属のRJ-45/DB-9アダプタ ケーブルを使用して、RJ-45コネクタをスイッチの背面のコンソール ポートに差し込みます(を参照)。

ステップ 2 アダプタ ケーブルのDB-9メスDTEをPCのシリアル ポートに取り付けるか、または適切なアダプタを端末に取り付けます。


 

図 1-2 PCとスイッチの接続

 

 

1

Catalyst 2955スイッチ

2

RJ-45/DB-9アダプタ ケーブル

端末エミュレーション ソフトウェアの起動

スイッチの電源を入れる前に、PCの端末エミュレーション セッションを起動して、POSTからの出力を表示できるようにします。


警告 スイッチまたはネットワーク上の装置に電源が入った状態で、コンソール ケーブルの着脱を行うと、アーク放電を生じることがあります。その場合、危険場所でインストレーションを行うと爆発する危険性があります。作業を始める前に、電源が切断されていて周囲に危険性がないことを確認してください。

スイッチの動作を確認するには、インストレーションに先立って、危険性のない場所でスイッチのPOSTを実行します。


端末エミュレーション ソフトウェア(通常、HyperTerminalまたはProcomm PlusなどのPCアプリケーション)は、PCまたは端末とスイッチの間の通信を確立します。

端末エミュレーション セッションを起動する手順は、次のとおりです。


ステップ 1 PCまたは端末を使用している場合は、端末エミュレーション ソフトウェアを起動します。

ステップ 2 PCまたは端末のボーレートおよびデータ フォーマットを、以下に示すコンソール ポートのデフォルト特性に合わせて設定します。

9600ボー

8データ ビット

1ストップ ビット

パリティなし

なし(フロー制御)


 

初期設定情報の入力

スイッチを設定するには、スイッチの電源投入後に自動的に実行される、セットアップ プログラムを完了する必要があります。スイッチがローカル ルータやインターネットと通信するのに必要なIPアドレスやその他の設定情報を割り当てる必要があります。これらの情報は、スイッチの設定や管理にNetwork Assistantを使用する場合にも必要です。

IP設定

セットアップ プログラムを完了するには、ネットワーク管理者から次の情報を入手しておく必要があります。

スイッチのIPアドレス

サブネット マスク(IPネットマスク)

デフォルト ゲートウェイ(ルータ)

イネーブル シークレット パスワード

イネーブル パスワード

Telnetパスワード

セットアップ プログラムの完了

セットアップ プログラムを完了し、スイッチの初期設定を作成する手順は、次のとおりです。


ステップ 1 次の2つのプロンプトで、 Yes を入力します。

Would you like to enter the initial configuration dialog? [yes/no]: yes
 
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system.
 
Would you like to enter basic management setup? [yes/no]: yes
 

ステップ 2 スイッチのホスト名を入力して、Returnキーを押します。

ホスト名は、コマンド スイッチでは28文字以内、メンバー スイッチでは31文字以内に制限されています。どのスイッチのホスト名でも、最後の文字には -n (nは数字)を使用しないでください。

Enter host name [Switch]: host_name
 

ステップ 3 イネーブル シークレット パスワードを入力して、Returnキーを押します。

パスワードは1~25文字の英数字で、先頭を数字にすることもできます。大文字と小文字の区別があります。スペースは使用できますが、先行スペースは無視されます。シークレット パスワードは暗号化され、イネーブル パスワードはプレーン テキストです。

Enter enable secret: secret_password
 

ステップ 4 イネーブル パスワードを入力して、Returnキーを押します。

Enter enable password: enable_password
 

) イネーブル シークレット パスワードおよびイネーブル パスワードが同じ場合は、CLIにより警告メッセージが表示されます。

パスワードを再入力するか、またはイネーブル シークレット パスワードに他のパスワードを選択することにより、この警告を無効にすることができます。


ステップ 5 仮想端末(Telnet)のパスワードを入力し、Returnキーを押します。

パスワードは1~25文字の英数字で、大文字と小文字の区別があります。スペースは使用できますが、先行スペースは無視されます。

Enter virtual terminal password: terminal-password
 

ステップ 6 (任意)プロンプトに応答してSNMP(簡易ネットワーク管理プロトコル)を設定します。SNMPは、CLI、デバイス マネージャ、またはNetwork Assistantアプリケーションを使用して、あとで設定してもかまいません。あとでSNMPを設定するには、 no を入力します。

Configure SNMP Network Management? [no]: no
 

) SNMPを設定する手順については、スイッチのソフトウェア コンフィギュレーション ガイドを参照してください。


ステップ 7 管理ネットワークに接続するインターフェイス名(物理インターフェイスまたはVLAN[仮想LAN]名)を入力して、 Return キーを押します。このリリースでは、そのインターフェイスとして常にvlan1を使用します。

Enter interface name used to connect to the
management network from the above interface summary: vlan1
 

ステップ 8 スイッチのIPアドレスとサブネット マスクを入力し、Returnキーを押してインターフェイスを設定します。下に示すIPアドレスとサブネット マスクは一例です。

Configuring interface vlan1:
Configure IP on this interface? [yes]: yes
IP address for this interface: 10.4.120.106
Subnet mask for this interface [255.0.0.0]: 255.0.0.0
 

ステップ 9 Yを入力して、スイッチをクラスタ コマンド スイッチとして設定します。Nを入力すると、メンバー スイッチまたはスタンドアロン スイッチとして設定されます。

N を入力した場合、そのスイッチはNetwork Assistant GUIでは候補スイッチとして表示されます。コマンド スイッチとしてのスイッチの設定は、CLI、デバイス マネージャ、またはNetwork Assistantアプリケーションを使用して、あとで行ってもかまいません。あとで設定する場合は、 no を入力します。

Would you like to enable as a cluster command switch? [yes/no]: no
 

以上で、スイッチの初期設定が完了しました。スイッチではこの設定を表示します。次に、出力例を示します。

The following configuration command script was created:
hostname host_name
enable secret 5 $1$Max7$Qgr9eXBhtcBJw3KK7bc850
enable password my
line vty 0 15
password my_password
snmp-server community public
!
no ip routing
!
interface Vlan1
no shutdown
ip address 172.20.139.145 255.255.255.224
!
interface Vlan2
shutdown
no ip address
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
...(テキスト出力は省略)
!!!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
end
 

ステップ 10 次の選択が表示されます。

[0] Go to the IOS command prompt without saving this config.
 
[1] Return back to the setup without saving this config.
 
[2] Save this configuration to nvram and exit.
 

次回のスイッチ再起動時に使用するために設定を保存する場合は、オプション2を選択してNVRAM(不揮発性RAM)に保存してください。

 
Enter your selection [2]:2
 

選択を行って Return キーを押します。


 

セットアップ プログラムが完了すると、スイッチは作成されたデフォルト設定を実行できます。この設定を変更するか、他の管理作業を実行する場合には、次のいずれかのツールを使用します。

CLI

Network Assistant(1つまたは複数のスイッチ用)

CLIを使用するには、端末エミュレーション プログラムを使用してコンソール ポートから、またはTelnetを使用してネットワークから、 Switch >プロンプトにコマンドを入力します。設定情報については、スイッチのソフトウェア コンフィギュレーション ガイドまたはスイッチのコマンド リファレンスを参照してください。

Network Assistantの使用方法については、Cisco.comで提供されている『 Getting Started with Cisco Network Assistant 』を参照してください。