Catalyst 2950 LRE デスクトップ スイッチ ソフトウェア コンフィギュレーション ガイド
QoS の設定
QoSの設定
発行日;2012/01/12 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

QoSの設定

QoSの概要

QoSの基本モデル

分類

QoS ACLに基づく分類

クラス マップおよびポリシー マップに基づく分類

ポリシングおよびマーキング

マッピング テーブル

キューイングおよびスケジューリング

CoSの概要

ポート プライオリティ

ポート スケジューリング

CoSおよびWRR

QoSの設定

QoSのデフォルト設定

設定時の注意事項

ポートの信頼状態による分類の設定

QoSドメイン内のポートの信頼状態の設定

インターフェイスのCoS値の設定

信頼性のある境界の設定

パススルー モードのイネーブル化

QoSポリシーの設定

ACLによるトラフィックの分類

クラス マップによるトラフィックの分類

ポリシー マップによるトラフィックの分類、ポリシング、およびマーキング

CoSマップの設定

CoS/DSCPマップの設定

DSCP/CoSマップの設定

CoSおよびWRRの設定

CoSプライオリティ キューの設定

WRRの設定

QoS情報の表示

QoS設定例

既存の配線クローゼットに適したQoSの設定

インテリジェント型配線クローゼットに適したQoSの設定

QoSの設定

この章では、Quality of Service(QoS;サービス品質)コマンドを使用してQoSを設定する方法について説明します。QoSにより、特定のトラフィック タイプを他のタイプより優先的に処理することができます。QoSを使用しなかった場合、スイッチはパケットの内容やサイズに関係なく各パケットにベストエフォート型のサービスを提供します。信頼性、遅延限度、またはスループットに関して保証することなく、スイッチはパケットを送信します。

この章で説明されている機能を使用するには、EI(拡張ソフトウェア イメージ)をスイッチにインストールしておく必要があります。

スイッチにSI(標準ソフトウェア イメージ)をインストールしている場合、一部の機能は設定できません。 表 26-1 に、設定できる各機能についての参照先を示します。

 

表 26-1 標準ソフトウェア機能について説明しているセクション

内容
セクション

出力ポートでのキューイングおよびスケジューリング

「キューイングおよびスケジューリング」

QoSの設定

「QoSの設定」

「QoSのデフォルト設定」

「ポートの信頼状態による分類の設定」

「CoSおよびWRRの設定」


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


QoSは、Cluster Management Suite(CMS)を使用することによって、またはCLI(コマンドライン インターフェイス)から設定できます。CMSでの設定手順については、CMSのオンラインヘルプを参照してください。CMSのアクセス方法および使用方法については、 第3章「CMSの基本」 を参照してください。

EIが稼働しているスイッチでは、次のウィザードを使用してQoSを設定することもできます。

プライオリティ データ ウィザード ― TCPポートまたはUDPポートに基づいてデータ アプリケーションにプライオリティを設定できます。標準アプリケーション リストが用意されており、優先させるアプリケーション、プライオリティ レベル、さらに優先処理を行うインターフェイスを選択します。プライオリティ データ ウィザードの使用手順については、ウィザードのオンラインヘルプを参照してください。

ビデオ ウィザード ― 指定したビデオ サーバからのトラフィックに、データ トラフィックより高いプライオリティを与えます。このウィザードでは、ビデオ サーバがクラスタ内の単一装置に接続されていることが前提となります。ビデオ ウィザードの使用手順については、ウィザードのオンラインヘルプを参照してください。

この章で説明する内容は、次のとおりです。

「QoSの概要」

「QoSの設定」

「QoS情報の表示」

「QoS設定例」

QoSの概要

ここでは、スイッチにQoSを実装する手順について説明します。SIがインストールされているスイッチでは、ここで説明する概念および機能が当てはまらない場合があります。使用可能な機能の一覧については、表 26-1を参照してください。

ネットワークは通常、ベストエフォート型の配信方式で動作します。したがって、すべてのトラフィックに等しいプライオリティが与えられ、正しいタイミングで配信される可能性も同じです。輻輳が発生した場合に、廃棄される可能性についても、すべてのトラフィックで同じです。

QoS機能を設定すると、特定のネットワーク トラフィックを選択し、相対的な重要性に応じてそのトラフィックに優先度を指定し、輻輳管理および輻輳回避技術を使用して、優先処理を実行することができます。ネットワークにQoSを実装すると、ネットワーク パフォーマンスの予測可能性が向上し、帯域幅をより効率的に利用できるようになります。

QoSは、Internet Engineering Task Force(IETF)の新しい規格であるDiffServアーキテクチャに基づいて実装します。このアーキテクチャでは、ネットワークに入るときに各パケットを分類することが規定されています。分類はIPパケット ヘッダーのdeprecated IP Type-of-Service(ToS;サービス タイプ)フィールドの6ビットを使用して、分類( class )情報として伝達されます。

分類情報をレイヤ2フレームで伝達することもできます。レイヤ2フレームまたはレイヤ3パケットのこれらの特殊なビットについて、次に説明します。図 26-1を参照してください。

レイヤ2フレームのプライオリティ値

レイヤ2 802.1Qフレーム ヘッダーには、2バイトのタグ制御情報フィールドがあり、上位3ビット(ユーザ プライオリティ ビット)でClass of Service(CoS;サービス クラス)値が伝達されます。レイヤ2 802.1Qトランクとして設定されたインターフェイス上では、ネイティブVLANのトラフィックを除くすべてのトラフィックが802.1Qフレームにされます。

他のフレーム タイプでレイヤ2 CoS値を伝達することはできません。

レイヤ2 CoS値の範囲は、0(ロー プライオリティ)~7(ハイ プライオリティ)です。

レイヤ3パケットのプライオリティ ビット

レイヤ3 IPパケットは、Differentiated Services Code Point(DSCP)値を伝送できます。サポートされるDSCP値は、0、8、10、16、18、24、26、32、34、40、46、48、および56です。

図 26-1 フレームおよびパケットにおけるQoS分類レイヤ

 

インターネットにアクセスするすべてのスイッチおよびルータは、クラス情報に基づいて、同じクラス情報が与えられているパケットは同じ扱いで転送を処理し、異なるクラス情報のパケットにはそれぞれ異なる扱いをします。パケットのクラス情報は、設定されているポリシー、パケットの詳細な検証、またはその両方に基づいて、エンド ホストが割り当てるか、または伝送中にスイッチまたはルータで割り当てることができます。パケットの詳細な検証は、コア スイッチおよびルータの負荷が重くならないように、ネットワークのエッジ付近で行います。

パス上のスイッチおよびルータは、クラス情報を使用して、個々のトラフィック クラスに割り当てるリソースの容量を制限することができます。DiffServアーキテクチャでトラフィックを処理するときの、各装置の動作をホップ単位動作といいます。パス上のすべての装置に一貫性のあるホップ単位動作をさせることによって、エンドツーエンドのQoSソリューションを構築できます。

ネットワーク上でQoSを実装する作業は、インターネットワーキング装置が提供するQoS機能、ネットワークのトラフィック タイプおよびパターン、さらには着信/発信トラフィックに求める制御のきめ細かさによって、簡単にも複雑にもなります。

QoSの基本モデル

図 26-2に、QoSの基本モデルを示します。入力インターフェイスでのアクションには、トラフィックの分類、ポリシング、およびマーキングがあります。


) スイッチにSIがインストールされている場合は、使用できるのはキューイングおよびスケジューリング機能だけです。


分類では、トラフィックの種類を1つずつ区別します。詳細は、「分類」を参照してください。

ポリシングでは、設定されているポリサーに基づいて、パケットが適合か、不適合かを判別します。ポリサーにより、トラフィックのフローが消費する帯域幅が制限されます。この判別結果がマーカーに引き渡されます。詳細は、「ポリシングおよびマーキング」を参照してください。

マーキングでは、パケットが不適合の場合の対処法に関して、ポリサーおよび設定情報を検討し、パケットの扱い(パケットを変更しないで通過させるか、パケットのDSCP値をマーク ダウンするか、またはパケットを廃棄するか)を決定します。詳細は、「ポリシングおよびマーキング」を参照してください。

出力インターフェイスでのアクションには、キューイングおよびスケジューリングがあります。

キューイングでは、CoS値を検討して、4つの出力キューのどれにパケットを格納するかを決定します。

スケジューリングでは、設定されているWeighted Round Robin(WRR;重み付きラウンドロビン)のウェイトに基づいて、4つの出力キューを処理します。

図 26-2 QoSの基本モデル

 

分類


) この機能を使用できるのは、スイッチでEIが稼働している場合に限られます。


分類とは、パケットのフィールドを検証して、トラフィックの種類を区別するプロセスです。

分類は物理インターフェイス単位でのみ行われます。VLANレベルでのパケット分類はサポートされません。

着信トラフィックの分類に、フレームまたはパケットのどのフィールドを使用するかは、ユーザ側で指定します。

非IPトラフィックには、次の分類オプションを使用できます。

ポートのデフォルトを使用します。フレームにCoS値が指定されていない場合、スイッチは着信フレームにデフォルトのポートCoS値を割り当てます。

着信フレームのCoS値を信頼します(ポートがCoSを信頼するように設定します)。レイヤ2 802.1Qフレームのヘッダーは、タグ制御情報フィールドの上位3ビットでCoS値を伝達します。CoS値の範囲は、0(ロー プライオリティ)~7(ハイ プライオリティ)です。

非IPトラフィックにDSCPを信頼するように設定するのは無意味です。このオプションを指定してポートを設定しても、非IPトラフィックを受信すると、スイッチはデフォルトのポートCoS値を割り当て、そのCoS値に基づいてトラフィックを分類します。

IPトラフィックには、次の分類オプションを使用できます。

着信パケットのIP DSCP値を信頼します(ポートがDSCPを信頼するように設定します)。スイッチは内部で使用するパケットに同じDSCPを割り当てます。IETFは、1バイトのToSフィールドの上位6ビットをDSCPとして定義しています。個々のDSCP値が表すプライオリティは、設定可能です。サポートされるDSCP値は、0、8、10、16、18、24、26、32、34、40、46、48、および56です。

着信パケットのCoS値(存在する場合)を信頼します。スイッチは、CoSとDSCPのマッピングを使用してDSCPを生成します。


) インターフェイスは、CoSまたはDSCPのどちらかを信頼するように設定できますが、同時に両方を設定することはできません。


QoS ACLに基づく分類

IP標準Access Control List(ACL;アクセス制御リスト)、IP拡張ACL、およびレイヤ2 MAC ACLを使用すると、同じ特性(クラス)を備えたパケット グループを定義できます。QoSのコンテキストでは、Access Control Entry(ACE;アクセス制御エントリ)の許可および拒否アクションの意味が、セキュリティACLの場合とは異なります。

許可アクションとの一致が検出されると(最初の一致の原則)、指定のQoS関連アクションが実行されます。

許可アクションとの一致が検出されないまま、すべてのACEの検証が終了した場合、そのパケットではQoS処理が実行されません。

インターフェイスに複数のACLが設定されており、パケットで最初のACLと許可アクションの一致が検出された場合、QoS処理が開始されます。

スイッチでは、QoS ACLの拒否アクション設定はサポートされません。

クラス マップでシステム定義マスクを使用できます。ただし、次の制限事項があります。

ポリシー マップに含まれる複数のクラス マップで、システム定義マスクとユーザ定義マスクを組み合わせて使用することはできません。

ポリシー マップに含まれるシステム定義マスクは、すべて同じタイプのシステム マスクを使用する必要があります。たとえば、 permit tcp any any ACEを使用するクラス マップと permit ip any any ACEを使用するクラス マップを同じポリシー マップに含めることはできません。

ポリシー マップには、すべて同じユーザ定義マスクまたは同じシステム定義マスクを使用している場合にかぎり、複数のクラス マップを含めることができます。


) システム定義マスクの詳細については、「アクセス制御パラメータの概要」を参照してください。


ACLの制限事項についての詳細は、「ACLの設定」を参照してください。

ACLでトラフィック クラスを定義したあとで、そのトラフィック クラスにポリシーを結合できます。ポリシーにはそれぞれにアクションを指定した複数のクラスを含めることができます。ポリシーには、特定のアグリゲートとしてクラスを分類する(DSCPを割り当てるなど)コマンドまたはクラスのレート制限を実施するコマンドを含めることができます。このポリシーを特定のポートに結合すると、そのポートでポリシーが有効になります。

IP ACLを実装してIPトラフィックを分類する場合は、 access-list グローバル コンフィギュレーション コマンドを使用します。レイヤ2 MAC ACLを実装してレイヤ2 トラフィックを分類する場合は、 mac access-list extended グローバル コンフィギュレーション コマンドを使用します。

クラス マップおよびポリシー マップに基づく分類

クラス マップは、特定のトラフィック フロー(またはクラス)を他のあらゆるトラフィックから分離して名前をつけるメカニズムです。クラス マップでは、特定のトラフィック フローをさらに分類するための照合で使用する条件を定義します。この条件には、ACLによって定義されたアクセス グループとの照合を含めることができます。複数のトラフィック タイプを分類する場合は、別のクラス マップを作成し、異なる名前を使用することができます。パケットをクラス マップ条件と照合したあとで、ポリシー マップを使用してさらに分類します。

ポリシー マップでは、作用対象のトラフィック クラスを指定します。アクションには、トラフィック クラスの具体的なDSCP値の設定、トラフィック帯域幅制限の指定、トラフィックが適合する場合に実行するアクションの指定が含まれます。ポリシー マップを効率的に機能させるには、インターフェイスにポリシー マップを結合しなければなりません。

クラス マップを作成するには、 class-map グローバル コンフィギュレーション コマンドまたは class ポリシー マップ コンフィギュレーション コマンドを使用します。多数のポート間でマップを共有する場合には、 class-map グローバル コンフィギュレーション コマンドを使用する必要があります。 class-map グローバル コンフィギュレーション コマンドを入力すると、クラス マップ コンフィギュレーション モードが開始されます。このモードで、 match クラス マップ コンフィギュレーション コマンドを使用して、トラフィックの一致条件を定義します。

ポリシー マップは、 policy-map グローバル コンフィギュレーション コマンドを使用して作成し、名前を付けます。このコマンドを入力すると、ポリシー マップ コンフィギュレーション モードが開始されます。このモードでは、 class または set ポリシー マップ コンフィギュレーション コマンドを使用することによって、特定のトラフィック クラスに対して実行するアクションを指定します。ポリシー マップを効率的に機能させるには、 service-policy インターフェイス コンフィギュレーション コマンドを使用してインターフェイスにマップを結合します。

ポリシー マップには、ポリサー、トラフィックの帯域幅制限、および限度を超えた場合のアクションを定義するコマンドを含めることもできます。詳細は、「ポリシングおよびマーキング」を参照してください。

ポリシー マップには、次の特性もあります。

ポリシー マップには、複数のclassコマンドを指定できます。

1つのインターフェイスから受信されたトラフィック タイプごとに、別々のポリシー マップ クラスを設定できます。

ポリシー マップのコンフィギュレーション ステートは、インターフェイスの信頼状態のためアクションより優先されます。

設定手順については、「QoSポリシーの設定」を参照してください。

ポリシングおよびマーキング


) この機能を使用できるのは、スイッチでEIが稼働している場合に限られます。


ポリシングには、トラフィックの帯域幅限度を指定するポリサーの作成が伴います。この限度を超えたパケットは、 不適合 パケットです。各ポリサーでは、不適合パケットに対するアクションを指定します。マーカーが実行するこれらのアクションには、パケットの廃棄または新しいユーザ定義値を使用したパケットのマークダウンが含まれます。

個別のポリサーを作成できます。QoSはポリサーで指定された帯域幅限度を、一致したトラフィック クラスごとに別々に適用します。このタイプのポリサーは、 policy-map コンフィギュレーション コマンドを使用して、ポリシー マップの中で設定します。

ポリシングおよびポリサーを設定する場合、次の考慮事項があります。

デフォルトでは、ポリサーは設定されません。

ポリサーを設定できるのは、物理ポートに限られます。VLANレベルでのポリシングはサポートされません。

入力方向でパケットに適用できるのは、1つのポリサーだけです。

設定できるのは、平均速度パラメータおよび認定バースト パラメータだけです。

ポリシングは入力インターフェイス上で実行されます。

ギガビット対応イーサネット入力ポート上でサポートされるポリサーは60個です。

10/100イーサネット入力ポートでサポートされるポリサーは6個です。

平均バースト速度の粒度は、10/100ポートで1 Mbps、ギガビット イーサネット ポートで8 Mbpsです。

QoS対応として設定されているインターフェイスを介して受信したすべてのトラフィックは、そのインターフェイスに結合されたポリシー マップに基づいて分類、ポリシング、およびマーキングが行われます。QoS対応として設定されているトランク インターフェイスの場合、インターフェイスを介して受信した すべて のVLANのトラフィックは、そのインターフェイスに結合されたポリシー マップに基づいて分類、ポリシング、およびマーキングが行われます。


) 出力インターフェイスにポリサーを設定することはできません。


マッピング テーブル


) この機能を使用できるのは、スイッチでEIが稼働している場合に限られます。


分類時に、QoSは設定可能なCoS/DSCPマップを使用して、受け取ったCoS値から内部DSCP値を導き出します。このDSCP値は、トラフィックのプライオリティを表します。

トラフィックがスケジューリング ステージに到達する前に、QoSは設定可能なDSCP/CoSマップを使用して、内部DSCP値からCoS値を導き出します。CoS値を使用して、4種類の出力キューから1つが選択されます。

CoS/DSCPマップおよびDSCP/CoSマップのデフォルト値は、使用しているネットワークに適している場合と適さない場合があります。

設定手順については、「CoSマップの設定」を参照してください。

キューイングおよびスケジューリング


) この機能は、SIでもEIでもサポートされます。


スイッチは、QoSベースの802.1p CoS値を提供します。QoSは、分類およびスケジューリングを使用して、スイッチからのネットワーク トラフィックを予測可能な方法で送信します。QoSによる分類では、各フレームにプライオリティ別のCoS値が割り当てられ、電話など、プライオリティの高いトラフィックが優先されます。

CoSの概要

Catalyst 6000ファミリー スイッチと共に使用するCatalyst 2950スイッチ上で802.1p CoSを設定する場合は、あらかじめCatalyst 6000のマニュアルを参照してください。802.1pの実装方式が異なるので、互換性を保証するには、その相違を理解しておく必要があります。

ポート プライオリティ

管理目的で定義されたVLANのユーザから受信したフレームは、分類、すなわち タグ付け してから他の装置へ伝送されます。管理者が定義したルールに基づいて、各フレーム ヘッダーに一意の識別情報(タグ)が挿入されてから転送されることになります。各装置では、タグを検証し、認識した上で、他のスイッチ、ルータ、またはエンド ステーションにブロードキャストを行うか、または伝送します。フレームが最終スイッチまたはルータに到達すると、タグが削除されて、宛先エンド ステーションに送信されます。識別情報(タグ)なしでトランクまたはアクセス ポートに割り当てられたVLANを、「ネイティブ」または「タグなし」フレームと呼びます。

タグ情報のあるIEEE 802.1Qフレームには、ヘッダー フレームのプライオリティ値が使用されます。ネイティブ フレームには、入力ポートのデフォルト プライオリティが使用されます。

ポート スケジューリング

スイッチ上の各ポートには、着信トラフィック用に1つずつ受信キュー バッファ(入力ポート)があります。タグなしフレームが着信すると、そのフレームのポート デフォルト プライオリティとして、ポートの値が割り当てられます。この値は、CLIまたはCMSを使用して割り当てます。タグ付きのフレームは、引き続きそのフレームに割り当てられたCoS値を使用して、入力ポートを通過します。

CoSは、フレームのタグまたはポート情報に応じて、通常プライオリティの送信キューおよびハイ プライオリティの送信キューを指定して各送信ポート(出力ポート)を設定します。通常プライオリティ キュー内のフレームが転送されるのは、ハイ プライオリティ キューのフレームが転送されてからです。

スイッチ(802.1pユーザ プライオリティ)には、4つのプライオリティ キューがあります。フレームは、ユーザが定義したプライオリティ/キュー マッピングに基づいて適切なキューに転送されます。

CoSおよびWRR

スイッチは、各出力ポートで4つのCoSキューをサポートしています。各キューで、次のタイプのスケジューリングを指定できます。

完全優先スケジューリング

完全優先スケジューリングは、キューのプライオリティに基づきます。キューのプライオリティ値は0~7で、7が最高です。ハイ プライオリティのキューにあるパケットは、常に最初に伝送され、ロー プライオリティのキューにあるパケットは、ハイ プライオリティのキューが空になるまでは伝送されません。

WRRスケジューリング

WRRスケジューリングでは、他のCoSキューとの比較でキューの重要性(ウェイト)を示す値を指定しなければなりません。WRRスケジューリングは、ロー プライオリティのキューがハイ プライオリティのトラフィック伝送中に完全に放置されないようにします。WRRは、いくつかのパケットを各キューから順に伝送します。送信されるパケットの数は、関連するキューの重要性に応じます。たとえば、あるキューのウェイトが3で、別のキューのウェイトが4である場合、第2のキューからパケットが4つ送信されるたびに、最初のキューから3つ送信されます。このスケジューリングを使用することによって、ロー プライオリティのキューは、ハイ プライオリティのキューが空にならなくてもパケットを送信することができます。

QoSの設定

QoSを設定する前に、次の事項を十分に理解しておく必要があります。

使用するアプリケーションのタイプおよびネットワークのトラフィック パターン。

トラフィックの特性およびネットワークのニーズ。バースト性の高いトラフィックかどうかの判別。音声およびビデオ ストリーム用の帯域確保の必要性。

ネットワークの帯域幅要件および速度。

ネットワーク上の輻輳発生位置。

ここでは、スイッチ上でQoSを設定する手順について説明します。


) SIが稼働しているスイッチの場合、設定できるのは「ポートの信頼状態による分類の設定」および「CoSおよびWRRの設定」で説明する機能だけです。「QoS情報の表示」で説明するように、QoS情報を表示することもできます。


「QoSのデフォルト設定」

「設定時の注意事項」

「ポートの信頼状態による分類の設定」

「QoSポリシーの設定」

「CoSマップの設定」

「CoSおよびWRRの設定」

QoSのデフォルト設定

QoSのデフォルト設定は、次のとおりです。


) ポリシー マップ、ポリサー、CoS/DSCPマップ、およびDSCP/CoSマップを設定できるのは、スイッチ上でEIが稼働している場合だけです。


デフォルトのポートCoS値は0です。

0のCoS値がすべての着信パケットに割り当てられます。

デフォルトのポートの信頼状態はuntrusted(信頼性がない)です。

ポリシー マップは設定されません。

ポリサーは設定されません。

デフォルトのCoS/DSCPマップは、 表 26-3 のとおりです。

デフォルトのDSCP/CoSマップは、 表 26-4 のとおりです。

デフォルトのQoSおよびWRR値については、「CoSおよびWRRの設定」を参照してください。


) Release 12.1(11)EA1より前のソフトウェア リリースでは、スイッチはDSCP値を変更しないで、着信パケットのCoS値を使用します。ポート上でパススルー モードをイネーブルにすると、このように設定できます。詳細は、「パススルー モードのイネーブル化」を参照してください。


設定時の注意事項


) これらの注意事項が適用されるのは、スイッチでEIが稼働している場合に限られます。


QoSの設定を始める前に、次の注意事項を確認してください。

スイッチ上でEtherChannelポートが設定されている場合、EtherChannelを形成する個々の物理ポートにQoSの分類、ポリシング、マッピング、およびキューイングを設定する必要があります。また、QoSの設定をEtherChannelの全ポートで照合するかどうかを決定する必要があります。

IPフラグメントと設定されているIP拡張ACLを照合することによって、QoSを実施することができます。IPフラグメントは、ベストエフォート型トラフィックとして送信されます。IPフラグメントはIPヘッダーのフィールドで示されます。

スイッチが受信する制御トラフィック(スパニングツリーBridge Protocol Data Unit[BPDU;ブリッジ プロトコル データ ユニット]、ルーティング アップデート パケットなど)は、あらゆる入力QoS処理の対象になります。

クラス マップに結合できるのは、物理インターフェイス用に作成されたACLだけです。

1つのクラス マップで使用できるACLは1つ、使用できる match コマンドは1つだけです。ACLに複数のアクセス制御エントリ、すなわちフィールドとパケットの内容を照合するコマンドを指定できます。

出力方向でのACL分類が含まれるポリシー マップを使用することはできません。また、 service-policy input policy-map-name インターフェイス コンフィギュレーション コマンドを使用してインターフェイスに結合することもできません。

ポリシー マップでclass-defaultという名前のクラスを使用することはできません。
class class-defaultポリシー マップ コンフィギュレーション コマンドによって定義されたポリシー マップに基づくトラフィック フィルタリングは行われません。

ACL設定時の注意事項についての詳細は、「QoS ACLに基づく分類」を参照してください。

物理インターフェイスへのACLの適用については、「物理インターフェイスにACLを適用する場合の注意事項」を参照してください。


) スイッチにIEEE 802.3xフロー制御が設定されている場合は、QoSを設定しないでください。インターフェイスにQoSを設定する前に、スイッチ上でフロー制御がディセーブルになっていることを確認してください。


ポートの信頼状態による分類の設定

ここでは、ポートの信頼状態を使用して着信トラフィックを分類する方法について説明します。

「QoSドメイン内のポートの信頼状態の設定」

「インターフェイスのCoS値の設定」

「信頼性のある境界の設定」

「パススルー モードのイネーブル化」


) この機能は、SIでもEIでもサポートされます。


QoSドメイン内のポートの信頼状態の設定

QoSドメインに入るパケットは、QoSドメインのエッジで分類されます。パケットがエッジで分類されると、QoSドメイン内の各スイッチでパケットを分類する必要がないので、QoSドメイン内のスイッチ ポートをいずれか1つの信頼状態に設定できます。図 26-3に、ネットワーク トポロジーの例を示します。

図 26-3 QoSドメイン内のポートの信頼状態

 

ポートが受信したトラフィックの分類を信頼するように設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、信頼するインターフェイスを指定します。

有効なインターフェイスには物理インターフェイスが含まれます。

ステップ 3

mls qos trust [ cos | dscp ]

ポートの信頼状態を設定します。

デフォルトでは、ポートは信頼性がありません。

キーワードの意味は次のとおりです。

cos ― パケットCoS値を使用して入力パケットを分類します。タグ付きIPパケットの場合、CoS/DSCPマップに基づいて、パケットのDSCP値が変更されます。パケットに割り当てられる出力キューは、パケットCoS値に基づいて決まります。

dscp ― パケットDSCP値を使用して入力パケットを分類します。非IPパケットの場合、タグ付きパケットではパケットCoS値が0に設定され、タグなしパケットにはデフォルトのポートCoSが使用されます。スイッチは内部で、DSCP/CoSマップを使用してCoS値を変更します。このキーワードを使用できるのは、スイッチでEIが稼働している場合に限られます。


) Release 12.1(11)EA1より前のソフトウェア リリースでは、mls qos trustコマンドを使用できるのは、スイッチでEIが稼働している場合に限られます。


ネットワークがイーサネットLANで構成される場合は、 cos キーワードを使用してください。

ネットワークがイーサネットLANだけで構成されていない場合で、高度なQoS機能とその実装方法の知識がある場合は、 dscp キーワードを使用します。

コマンドの詳細については、このリリースに対応するコマンド リファレンスを参照してください。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show mls qos interface [ interface-id ] [ policers ]

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

untrusted(信頼性がない)状態にポートを戻す場合は、 no mls qos trust インターフェイス コンフィギュレーション コマンドを使用します。

デフォルトのCoS値を変更する方法については、「インターフェイスのCoS値の設定」を参照してください。CoS/DSCPマップを設定する方法については、「CoS/DSCPマップの設定」を参照してください。

インターフェイスのCoS値の設定

QoSは、信頼性のあるポートおよび信頼性のないポートで受信したタグなしフレームに、 mls qos cos インターフェイス コンフィギュレーション コマンドで指定されたCoS値を割り当てます。

デフォルトのポートCoS値を定義する場合、またはポート上のすべての着信パケットにデフォルトのCoS値を割り当てる場合には、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、信頼するインターフェイスを指定します。

有効なインターフェイスには物理インターフェイスが含まれます。

ステップ 3

mls qos cos { default-cos | override }

デフォルトのポートCoS値を設定します。

default-cos には、ポートに割り当てるデフォルトのCoS値を指定します。ポートがCoSを信頼するように設定されており、パケットがタグなしの場合、デフォルトのCoS値がパケットのCoS値になります。CoS値に指定できる範囲は0~7です。デフォルト値は0です。

着信パケットにすでに設定されている信頼状態を変更し、すべての着信パケットにデフォルトのポートCoS値を適用する場合は、 override キーワードを使用します。デフォルトでは、CoSの上書きはディセーブルに設定されています。

特定のポートに届くすべての着信パケットに、他のポートからのパケットより高いプライオリティを与える場合には、 override キーワードを使用します。ポートがすでにDSCPを信頼するように設定されている場合、設定済みの信頼状態がこのコマンドによって上書き変更され、すべての着信CoS値にこのコマンドで設定されたデフォルトのCoS値が割り当てられます。着信パケットがタグ付きの場合、出力ポートで、ポートのデフォルトCoSを使用してパケットのCoS値が変更されます。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show mls qos interface

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

デフォルトの設定に戻す場合は、no mls qos cos { default-cos | override } インターフェイス コンフィギュレーション コマンドを使用します。

信頼性のある境界の設定

一般的なネットワークでは、図 26-3で示すようにCisco IP Phoneをスイッチ ポートに接続します。電話からスイッチに送信されたトラフィックは通常、802.1Qヘッダーを使用するタグでマーキングされます。ヘッダーにはVLAN情報とともに、パケットのプライオリティを決定する3ビットのCoSフィールドが含まれます。Cisco IP Phoneの設定では通常、電話からスイッチに送信されるトラフィックを信頼し、音声トラフィックがネットワーク上の他のタイプのトラフィックより優先されるようにします。 mls qos trust cos インターフェイス コンフィギュレーション コマンドを使用することによって、電話を接続するスイッチ ポートがそのポートで受信したあらゆるトラフィックのCoSラベルを信頼するように設定できます。

状況によっては、IP PhoneにPCまたはワークステーションを接続する場合もあります。このような状況では、スイッチのCLIから switchport priority extend cos インターフェイス コンフィギュレーション コマンドを使用して、PCから受信したトラフィックのプライオリティが変更されるように電話を設定できます。このコマンドを使用すると、PCが高プライオリティのデータ キューを使用しないようにできます。

ただし、ユーザが電話をバイパスしてPCをスイッチに直接接続した場合、スイッチは(信頼するCoSの設定に基づいて)PCによって生成されたCoSラベルを信頼するので、高プライオリティ キューが誤って使用される可能性があります。信頼性のある境界機能は、Cisco Discovery Protocol(CDP)を使用してCisco IP Phone(Cisco IP Phone 7910、7935、7940、7960など)がスイッチ ポートに接続されていることを検出することによって、この問題を解消します。電話が検出されなかった場合、信頼性のある境界機能はスイッチ ポートの信頼設定をディセーブルにし、高プライオリティ キューが誤って使用されないようにします。

スイッチ ポートに信頼性のある境界を設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

cdp enable

CDPをグローバルでイネーブルにします。デフォルトでは、イネーブルに設定されています。

ステップ 3

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、信頼するインターフェイスを指定します。

有効なインターフェイスには物理インターフェイスが含まれます。

ステップ 4

cdp enable

インターフェイスでCDPをイネーブルにします。デフォルトではCDPはイネーブルに設定されています。

ステップ 5

mls qos trust device cisco-phone

Cisco IP Phoneをインターフェイス上で信頼性のある装置として設定します。

ステップ 6

mls qos trust cos

入力パケットのCoS値を信頼するように、ポートの信頼状態を設定します。

デフォルトでは、ポートは信頼性がありません。


) Release 12.1(11)EA1より前のソフトウェア リリースでは、mls qos trust cosコマンドを使用できるのは、スイッチでEIが稼働している場合に限られます。


コマンドの詳細については、このリリースに対応するコマンド リファレンスを参照してください。

ステップ 7

end

イネーブルEXECモードに戻ります。

ステップ 8

show mls qos interface [ interface-id ] [ policers ]

設定を確認します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

no mls qos trust インターフェイス コンフィギュレーション コマンドを入力しても、信頼性のある境界はディセーブルになりません。このコマンドを入力し、ポートがCisco IP Phoneに接続されている場合、ポートは受信したトラフィックの分類を信用しないことになります。信頼性のある境界をディセーブルにするには、 no mls qos trust device インターフェイス コンフィギュレーション コマンドを使用します。

mls qos cos override インターフェイス コンフィギュレーション コマンドを入力した場合、ポートはCisco IP Phoneに接続されている場合も含めて、受信したトラフィックの分類を信頼しません。

表 26-2 に、IP Phoneがある場合とない場合のポート設定を示します。

 

表 26-2 信頼性のある境界がイネーブルの場合のポート設定

ポートの設定
Cisco IP Phoneがある場合
Cisco IP Phoneがない場合

ポートは着信パケットのCoS値を信頼します。

パケットのCoS値が信頼されます。

パケットのCoS値がデフォルトのCoS値に割り当てられます。

ポートは着信パケットのDSCP値を信頼します。

パケットのDSCP値が信頼されます。

タグ付きの非IPパケットの場合、パケットのCoS値は0に設定されます。

タグなしの非IPパケットの場合、パケットのCoS値がデフォルトのCoS値に割り当てられます。

ポートは着信パケットにデフォルトのCoS値を割り当てます。

パケットのCoS値がデフォルトのCoS値に割り当てられます。

パケットのCoS値がデフォルトのCoS値に割り当てられます。

パススルー モードのイネーブル化

Release 12.1(11)EA1より前のソフトウェア リリースでは、スイッチはパススルー モードです。この場合、スイッチはDSCP値を変更しないで着信パケットのCoS値を使用し、4つの出力キューの1つからパケットを送信します。スイッチでRelease 12.1(11)EA1より前のソフトウェア リリースが稼働している場合、パススルー モードをイネーブルまたはディセーブルにすることはできません。

Release 12.1(11)EA1以降では、スイッチはパケットを変更しないで、すべての着信パケットに0のCoS値を割り当てます。スイッチは、パケットの内容またはサイズに関係なく、各パケットにベスト エフォート型のサービスを提供し、単一出力キューからパケットを送信します。

パススルー モードをイネーブルにするには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、パススルー モードをイネーブルにするインターフェイスを指定します。

有効なインターフェイスには物理インターフェイスが含まれます。

ステップ 3

mls qos trust cos pass-through dscp

パススルー モードをイネーブルにします。着信パケットのCoS値を信頼し、DSCP値を変更しないでパケットを送信するように、インターフェイスが設定されます。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show mls qos interface [ interface-id ]

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

パススルー モードをディセーブルにするには、 no mls qos trust pass-through dscp インターフェイス コンフィギュレーション コマンドを使用します。

パススルー モードがイネーブルのときに、 mls qos cos override および mls qos trust [ cos | dscp ] インターフェイス コマンドを入力すると、パススルー モードがディセーブルになります。

mls qos cos override および mls qos trust [ cos | dscp ]インターフェイス コマンドがすでに設定されているときに、 mls qos trust cos pass-through dscp インターフェイス コンフィギュレーション コマンドを入力すると、パススルー モードがディセーブルになります。

QoSポリシーの設定


) この機能を使用できるのは、スイッチでEIが稼働している場合に限られます。


QoSポリシーを設定するには、通常、トラフィックをクラス別に分類し、各トラフィック クラスに適用するポリシーを設定し、ポリシーをインターフェイスに結合する必要があります。

基本情報については、「分類」および「ポリシングおよびマーキング」を参照してください。

ここでは、次の設定手順について説明します。

「ACLによるトラフィックの分類」

「クラス マップによるトラフィックの分類」

「ポリシー マップによるトラフィックの分類、ポリシング、およびマーキング」

ACLによるトラフィックの分類

IP標準ACLまたはIP拡張ACLを使用することによって、IPトラフィックを分類できます。レイヤ2トラフィックは、レイヤ2 MAC ACLを使用することによって分類できます。

IPトラフィック用にIP標準ACLを作成するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

access-list access-list-number { permit | remark } { source source-wildcard | host source | any }

IP標準ACLを作成し、必要な回数だけコマンドを繰り返します。

access-list-number には、ACL番号を入力します。有効範囲は1~99および1300~1999です。

permit を入力し、条件と一致した場合にアクセスを許可するかどうかを指定します。

remark を入力し、100文字以内のACLエントリのコメントを指定します。


) QoS ACLでは、拒否(deny)ステートメントはサポートされません。詳細については、「QoS ACLに基づく分類」を参照してください。


source は、パケットが送られてくるネットワークまたはホストの送信元アドレスです。次の3つの方法のいずれかで指定されます。

ドット付き10進表記で32ビットの値。

キーワード any は0.0.0.0 255.255.255.255という source および source-wildcard の省略形です。source-wildcardの入力は不要です。

キーワード host は、 source 0.0.0.0という source および source-wildcard の省略形です。

(任意) source-wildcard 変数によって、ワイルドカード ビットがsourceに適用されます(最初のリスト項目を参照)。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show access-lists

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

IP標準ACLの作成手順については、「物理インターフェイスにACLを適用する場合の注意事項」を参照してください。

ACLを削除する場合は、 no access-list access-list-number グローバル コンフィギュレーション コマンドを使用します。

指定した2つのネットワーク上のホストだけにアクセスを許可する例を示します。ネットワーク アドレスのホスト部分にワイルドカード ビットが適用されます。ACLのステートメントと一致しない送信元アドレスのホストはすべて拒否されます。

Switch(config)# access-list 1 permit 192.5.255.0 0.0.0.255
Switch(config)# access-list 1 permit 36.0.0.0 0.0.0.255
 

IPトラフィック用にIP拡張ACLを作成するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

access-list access-list-number
{ permit | remark } protocol
{ source source-wildcard | host source | any} [operator port ] { destination destination-wildcard | host destination | any } [ operator port ] [ dscp dscp-value ] [ time-range time-range-name ]

IP拡張ACLを作成し、必要な回数だけコマンドを繰り返します。

access-list-number には、ACL番号を入力します。有効範囲は100~199および2000~2699です。

permit を入力し、条件と一致した場合にアクセスを許可します。

remark を入力し、100文字以内のACLエントリのコメントを指定します。


) QoS ACLでは、拒否(deny)ステートメントはサポートされません。詳細については、「QoS ACLに基づく分類」を参照してください。


protocol には、IPプロトコルの名前または番号を入力します。疑問符( ? )を使用すると、使用できるプロトコル キーワードのリストが表示されます。

source には、パケットの送信元となるネットワークまたはホストを指定します。 source-wildcard では、無視するビット位置に1を入力することによって、ワイルドカード ビットを指定します。 source および source-wilcard を指定するには、ドット付き10進表記を使用するか、 source 0.0.0.0 source-wildcard 255.255.255.255の省略形として any キーワードを使用するか、または source 0.0.0.0を表すキーワードとして host を使用します。

destination には、パケットの宛先となるネットワークまたはホストを指定します。 destination および destination-wildcard には、 source および source-wildcard での説明と同じオプションを使用できます。

宛先ポートまたは送信元ポートを定義します。

operator に使用できるのは eq (equal)だけです。

source source-wildcard の後ろに operator を指定した場合、送信元ポートと定義したポートが同じ場合に条件が一致します。

destination destination-wildcard の後ろに operator を指定した場合、宛先ポートと定義したポートが同じ場合に条件が一致します。

port は、TCPまたはUDPポートを表す10進数または名前です。指定できる番号は0~65535です。

TCPポート名は、TCPトラフィック専用です。

UDPポート名は、UDPトラフィック専用です。

dscp は、サポートされる13のDSCP値(0、8、10、16、18、24、26、32、34、40、46、48、および56)のいずれともパケットを照合する場合に入力します。または疑問符( ? )を入力すると、使用できる値のリストが表示されます。

time-range キーワードは任意です。このキーワードについては、「ACLへの時間範囲の適用」を参照してください。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show access-lists

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

IP拡張ACLの作成手順については、「物理インターフェイスにACLを適用する場合の注意事項」を参照してください。

ACLを削除する場合は、 no access-list access-list-number グローバル コンフィギュレーション コマンドを使用します。

TCPポートが番号25で宛先IPアドレスが128.88.1.2からのTCPトラフィックだけを許可するACLの作成例を示します。

Switch(config)# access-list 102 permit tcp 0.0.0.0 255.255.255.255 128.88.1.2 0.0.0.0 eq 25
 

レイヤ2トラフィック用にレイヤ2 MAC ACLを作成するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mac access-list extended name

リスト名を指定することによって、レイヤ2 MAC ACLを作成します。

このコマンドを入力すると、拡張MAC ACLコンフィギュレーション モードに切り替わります。

ステップ 3

permit を入力し、条件と一致した場合にアクセスを許可します。


) QoS ACLでは、拒否(deny)ステートメントはサポートされません。詳細については、「QoS ACLに基づく分類」を参照してください。


source MAC address には、パケットの送信元となるホストのMACアドレスを指定します。このアドレスを指定するには、すべての送信元のMACアドレスを拒否する any キーワードを使用するか、または host キーワードおよび16進形式(H.H.H)の送信元を使用します。

destination MAC address には、パケットの宛先となるホストのMACアドレスを指定します。このアドレスを指定するには、すべての宛先のMACアドレスを拒否する any キーワードを使用するか、または host キーワードおよび16進形式(H.H.H)の宛先を使用します。

(任意)次のオプションを入力することもできます。

aarp | amber | appletalk | dec-spanning | decnet-iv | diagnostic | dsm | etype-6000 | etype-8042 | lat | lavc-sca | mop-console | mop-dump | msdos | mumps | netbios | vines-echo |vines-ip | xns-idp ― (非IPプロトコル)

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show access-lists [ number | name ]

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

MAC拡張ACLの作成手順については、「名前付きMAC拡張ACLの作成」を参照してください。

ACLを削除する場合は、 no mac access-list extended name グローバル コンフィギュレーション コマンドを使用します。

許可(permit)ステートメントを指定したレイヤ2 MAC ACLの作成例を示します。このステートメントにより、MACアドレス0001.0000.0001のホストからMACアドレス0002.0000.0001へのトラフィックが許可されます。

Switch(config)# mac access-list extended maclist1
Switch(config-ext-macl)# permit host 0001.0000.0001 host 0002.0000.0001
 

クラス マップによるトラフィックの分類

個々のトラフィック フロー(またはクラス)を他のあらゆるトラフィックから分離して名前をつけるには、 class-map グローバル コンフィギュレーション コマンドを使用します。クラス マップでは、さらに細かく分類するために、特定のトラフィック フローと照合する条件を定義します。matchステートメントにはACLだけを含めることができます。一致条件は、クラス マップ コンフィギュレーション モードの中でmatchステートメントを1つ入力することによって定義します。


classポリシー マップ コンフィギュレーション コマンドを使用することによって、ポリシー マップの作成時にクラス マップを作成することもできます。詳細は、「ポリシー マップによるトラフィックの分類、ポリシング、およびマーキング」を参照してください。


クラス マップを作成し、トラフィックを分類するための一致条件を定義するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

access-list access-list-number permit { source source-wildcard | host source | any }

または

access-list access-list-number
{ permit | remark } protocol
{ source source-wildcard | host source | any } [ operator port ] { destination destination-wildcard | host destination | any } [ operator port ] [ dscp dscp-value ] [ time-range time-range-name ]

または

mac access-list extended name

permit { any | host source MAC address } { any | host destination MAC address } [ aarp | amber | dec-spanning | decnet-iv | diagnostic | dsm | etype-6000 | etype-8042 | lat | lavc-sca | mop-console | mop-dump | msdos | mumps | netbios | vines-echo |vines-ip | xns-idp]

ステップ 3

class-map class-map-name

クラス マップを作成し、クラス マップ コンフィギュレーション モードを開始します。

デフォルトでは、クラス マップは定義されません。

class-map-name には、クラス マップ名を指定します。

ステップ 4

トラフィックを分類するための一致条件を定義します。

デフォルトでは、一致条件はサポートされません。

指定できる一致条件は、1つのクラス マップに1つだけです。また、1つのクラス マップでサポートされるACLは1つだけです。

access-group acl-index または access-group name acl-name には、ステップ3で作成したACLの番号または名前を指定します。

ip dscp dscp-list には、着信パケットと照合するmatchステートメントごとに、最大8つのIP DSCP値からなるリストを1つずつ入力します。各値はスペースで区切ります。サポートされるDSCP値は、0、8、10、16、18、24、26、32、34、40、46、48、および56です。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show class-map [ class-map-name ]

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

既存のクラス マップを削除するには、 no class-map class-map-name グローバル コンフィギュレーション コマンドを使用します。一致条件を削除するには、no match { access-group acl-index | name acl-name | ip dscp}クラス マップ コンフィギュレーション コマンドを使用します。

class1 というクラス マップの設定例を示します。 class1 には、一致条件として、 103 というACLが1つあります。

Switch(config)# access-list 103 permit any any tcp eq 80
Switch(config)# class-map class1
Switch(config-cmap)# match access-group 103
Switch(config-cmap)# end
Switch#
 

ポリシー マップによるトラフィックの分類、ポリシング、およびマーキング

ポリシー マップでは、作用対象のトラフィック クラスを指定します。アクションは、トラフィック クラスのCoS値またはDSCP値を信頼し、トラフィック クラスに特定のDSCP値を設定し、一致する各トラフィック クラスにトラフィック帯域幅制限を指定し(ポリサー)、トラフィックが適合する場合に実行するアクション(マーキング)です。

ポリシー マップには、次の特性もあります。

1つのポリシー マップに、それぞれ異なる一致条件とポリサーを指定した複数のクラス ステートメントを指定できます。

1つのインターフェイスから受信されたトラフィック タイプごとに、別々のポリシー マップ クラスを設定できます。

入力方向で1つのインターフェイスに1つだけポリシー マップを結合できます。

ポリシー マップを作成するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

access-list access-list-number permit { source source-wildcard | host source | any }

または

access-list access-list-number { permit | remark } protocol { source source-wildcard | host source | any } [ operator port ] { destination destination-wildcard | host destination | any} [ operator port ] [ dscp dscp-value ] [ time-range time-range-name ]

または

mac access-list extended name

permit { any | host source MAC address } { any | host destination MAC address } [ aarp | amber | appletalk |dec-spanning | decnet-iv | diagnostic | dsm | etype-6000 | etype-8042 | lat | lavc-sca | mop-console | mop-dump | msdos | mumps | netbios | vines-echo |vines-ip | xns-idp]

ステップ 3

policy-map policy-map-name

ポリシー マップ名を入力することによってポリシー マップを作成し、ポリシー マップ コンフィギュレーション モードを開始します。

デフォルトでは、ポリシー マップは定義されません。

ポリシー マップのデフォルトの動作では、パケットがIPパケットの場合はDSCPが0に、パケットがタグ付きの場合はCoSが0に設定されます。ポリシングは実行されません。

ステップ 4

class class-map-name [ access-group name acl-index-or-name ]

トラフィックの分類を定義し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

デフォルトでは、ポリシー マップ クラス マップは定義されません。

class-map グローバル コンフィギュレーション コマンドを使用してトラフィック クラスがすでに定義されている場合は、このコマンドで class-map-name にその名前を指定します。

access-group name acl-index-or-name には、ステップ2で作成したACLの番号または名前を指定します。


) ポリシー マップでclass-defaultという名前のクラスを使用することはできません。class class-defaultポリシー マップ コンフィギュレーション コマンドによって定義されたポリシー マップに基づくトラフィック フィルタリングは行われません。


ステップ 5

set { ip dscp new-dscp }

パケットに新しい値を設定することによって、IPトラフィックを分類します。

ip dscp new-dscp には、分類されたトラフィックに割り当てる新しいDSCP値を入力します。サポートされるDSCP値は、0、8、10、16、18、24、26、32、34、40、46、48、および56です。

ステップ 6

police rate-bps burst-byte [ exceed-action { drop | dscp dscp-value }]

分類したトラフィックにポリサーを定義します。

ギガビット対応イーサネット入力ポート上では最大60、10/100イーサネット入力ポートでは最大6つのポリサーを設定できます。

rate-bps には、平均トラフィック伝送速度をビット/秒(bps)で指定します。有効範囲は、10/100イーサネット ポートでは1~100 Mbps、ギガビット対応のイーサネット ポートでは8~1000 Mbpsです。

burst-byte には、標準バースト サイズをバイト数で指定します。10/100ポートに使用できる値は、4096、8192、16384、32768、および65536です。ギガビット対応のイーサネット ポートに指定できる値は、4096、8192、16348、32768、65536、131072、262144、および524288です。

(任意)速度を超過した場合に実行するアクションを指定します。パケットを廃棄する場合は、 exceed-action drop キーワードを使用します。DSCP値を引き下げてパケットを送信する場合は、 exceed-action dscp dscp-value キーワードを使用します。

ステップ 7

exit

ポリシー マップ コンフィギュレーション モードに戻ります。

ステップ 8

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、ポリシー マップに結合するインターフェイスを指定します。

有効なインターフェイスには物理インターフェイスが含まれます。

ステップ 10

service-policy input policy-map-name

特定インターフェイスの入力に指定したポリシー マップを適用します。

サポートされるポリシー マップは、1方向1インターフェイスに1つだけです。

ステップ 11

end

イネーブルEXECモードに戻ります。

ステップ 12

show policy-map [ policy-map-name class class-name ]

設定を確認します。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

既存のポリシー マップを削除するには、no policy-map policy-map-name グローバル コンフィギュレーション コマンドを使用します。既存のクラス マップを削除するには、no class class-map-name ポリシー マップ コンフィギュレーション コマンドを使用します。割り当てられたDSCP値を削除するには、 no set ip dscp new-dscp ポリシー マップ コンフィギュレーション コマンドを使用します。既存のポリサーを削除するには、no police rate-bps burst-byte [exceed-action { drop | dscp dscp-value }]ポリシー マップ コンフィギュレーション コマンドを使用します。ポリシー マップとインターフェイスの対応づけを削除するには、no service-policy input policy-map-name インターフェイス コンフィギュレーション コマンドを使用します。

ポリシー マップを作成し、入力インターフェイスに結合する例を示します。この設定では、IP標準ACLでネットワーク10.1.0.0からのトラフィックを許可します。この分類にトラフィックが一致した場合、着信パケットのDSCP値が信頼されます。一致したトラフィックが5000000 bpsという平均トラフィック伝送速度、および8192バイトという標準バースト サイズを超過している場合、DSCP値が10に引き下げられて送信されます。

Switch(config)# access-list 1 permit 10.1.0.0 0.0.255.255
Switch(config)# class-map ipclass1
Switch(config-cmap)# match access-group 1
Switch(config-cmap)# exit
Switch(config)# policy-map flow1t
Switch(config-pmap)# class ipclass1
Switch(config-pmap-c)# police 5000000 8192 exceed-action dscp 10
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# service-policy input flow1t
 

次に、2つの許可(permit)ステートメントを指定してレイヤ2 MAC ACLを作成し、入力インターフェイスに適応する例を示します。最初の許可(permit)ステートメントにより、MACアドレス0001.0000.0001のホストからMACアドレス0002.0000.0001のホストへのトラフィックが許可されます。

Switch(config)# mac access-list extended maclist1
Switch(config-ext-mac)# permit host 0001.0000.0001 host 0002.0000.0001
Switch(config-ext-mac)# exit
Switch(config)# mac access-list extended maclist2
Switch(config-ext-mac)# permit host 0001.0000.0003 host 0002.0000.0003
Switch(config-ext-mac)# exit
Switch(config)# class-map macclass1
Switch(config-cmap)# match access-group name maclist1
Switch(config-cmap)# exit
Switch(config)# policy-map macpolicy1
Switch(config-pmap)# class macclass1
Switch(config-pmap-c)# set ip dscp 56
Switch(config-pmap-c)# exit
Switch(config-pmap)# class macclass2 maclist2
Switch(config-pmap-c)# set ip dscp 48
Switch(config-pmap-c)# exit
Switch(config-pmap)# exit
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# mls qos trust cos
Switch(config-if)# service-policy input macpolicy1
 

CoSマップの設定


) この機能を使用できるのは、スイッチでEIが稼働している場合に限られます。


ここでは、CoSマップの設定手順について説明します。

「CoS/DSCPマップの設定」

「DSCP/CoSマップの設定」

マップはすべてグローバルに定義されています。

CoS/DSCPマップの設定

CoS/DSCPマップを使用して、着信パケットのCoS値を、QoSがトラフィックのプライオリティを表すために内部使用するDSCP値に対応づけます。

表 26-3 に、デフォルトのCoS/DSCPマップを示します。

 

表 26-3 デフォルトのCoS/DSCPマップ

CoS値

0

1

2

3

4

5

6

7

DSCP値

0

8

16

24

32

40

48

56

これらの値が使用しているネットワークに適さない場合は、値を変更する必要があります。

CoS/DSCPマップを変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mls qos map cos-dscp dscp1...dscp8

CoS/DSCPマップを変更します。

dscp1...dscp8には、CoS値0~7に対応する8つのDSCP値を入力します。各DSCP値はスペースで区切ります。

サポートされるDSCP値は、0、8、10、16、18、24、26、32、34、40、46、48、および56です。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show mls qos maps cos-dscp

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

デフォルトのマップに戻す場合は、 no mls qos map cos-dscp グローバル コンフィギュレーション コマンドを使用します。

CoS/DSCPマップを変更して表示する例を示します。

Switch# configure terminal
Switch(config)# mls qos map cos-dscp 8 8 8 8 24 32 56 56
Switch(config)# end
Switch# show mls qos maps cos-dscp
 
Cos-dscp map:
cos: 0 1 2 3 4 5 6 7
--------------------------------
dscp: 8 8 8 8 24 32 56 56
 

DSCP/CoSマップの設定

DSCP/CoSマップを使用して、着信パケットのDSCP値を、4つの出力キューの1つを選択するために使用されるCoS値に対応づけます。

スイッチは次のDSCP値をサポートします。0、8、10、16、18、24、26、32、34、40、46、48、および56です。

表 26-4 に、デフォルトのDSCP/CoSマップを示します。

 

表 26-4 デフォルトのDSCP/CoSマップ

DSCP値

0

8、10

16、18

24、26

32、34

40、46

48

56

CoS値

0

1

2

3

4

5

6

7

これらの値が使用しているネットワークに適さない場合は、値を変更する必要があります。

DSCP/CoSマップを変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mls qos map dscp-cos dscp-list to cos

DSCP/CoSマップを変更します。

dscp-listには、最大13のDSCP値をスペースで区切って入力します。さらに、 to キーワードを入力します。

cosには、DSCP値と対応するCoS値を入力します。

サポートされるDSCP値は、0、8、10、16、18、24、26、32、34、40、46、48、および56です。CoSの範囲は0~7です。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show mls qos maps dscp-cos

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

デフォルトのマップに戻す場合は、 no mls qos map dscp-cosグローバル コンフィギュレーション コマンドを使用します。

DSCP値26および48をCoS値7に対応づける例を示します。残りのDSCP値に関しては、デフォルトのDSCP/CoSマッピングです。

Switch(config)# mls qos map dscp-cos 26 48 to 7
Switch(config)# exit
 
Switch# show mls qos maps dscp-cos
 
Dscp-cos map:
dscp: 0 8 10 16 18 24 26 32 34 40 46 48 56
-----------------------------------------------
cos: 0 1 1 2 2 3 7 4 4 5 5 7 7
 

CoSおよびWRRの設定


) この機能は、EIでもSIでもサポートされます。


ここでは、CoSプライオリティおよびWRRを設定する手順について説明します。

「CoSプライオリティ キューの設定」

「WRRの設定」

CoSプライオリティ キューの設定

CoSプライオリティ キューを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

wrr-queue cos-map qid cos1..cosn

CoSプライオリティ キューのキューIDを指定します(範囲は1~4で、1が最下位のCoSプライオリティ キューです)。

キューIDに対応するCoS値を指定します。

デフォルト値は次のとおりです。

CoS値 CoSプライオリティ キュー

0、1 1

2、3 2

4、5 3

6、7 4

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show wrr-queue cos-map

CoSプライオリティ キューのマッピングを表示します。

新しいCoS設定値をディセーブルにし、デフォルト値に戻すには、 no wrr-queue cos-map グローバル コンフィギュレーション コマンドを使用します。

WRRの設定

WRRプライオリティを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

wrr-queue bandwidth weight1...weight4

WRRウェイトを4つのCoSキューに割り当てます(WRR値の範囲は1~255です)。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show wrr-queue bandwidth

CoSプライオリティ キューへのWRR帯域幅割り当てを表示します。

WRRスケジューラをディセーブルにし、完全優先スケジューラをイネーブルにするには、

no wrr-queue bandwidth グローバル コンフィギュレーション コマンドを使用します。

QoS情報の表示

QoS情報を表示するには、 表 26-5 のイネーブルEXECコマンドを1つまたは複数使用します。

 

表 26-5 QoS情報を表示するためのコマンド

コマンド
目的

show class-map [ class-map-name ]1

トラフィックを分類するための一致条件を定義したQoSクラス マップを表示します。

show policy-map [ policy-map-name [ class class-name ]]1

着信トラフィックの分類条件を定義したQoSポリシー マップを表示します。

show mls qos maps [ cos-dscp | dscp-cos ]1

QoSマッピング情報を表示します。マップは、トラフィックのプライオリティを表す内部DSCP値を生成する目的で使用されます。

show mls qos interface [ interface-id ] [ policers ]1

インターフェイス レベルでのQoS情報を表示します。出力キューおよびCoS/出力キュー マップ、ポリサーが設定されているインターフェイス、入力および出力統計情報(廃棄されたバイト数など)が含まれます。2

show mls masks [ qos | security ] 1

QoS ACLおよびセキュリティACLに使用されているマスク3の詳細情報を表示します。

show wrr-queue cos-map

CoSプライオリティ キューのマッピングを表示します。

show wrr-queue bandwidth

CoSプライオリティ キューへのWRR帯域幅割り当てを表示します。

1.EIが稼働しているスイッチでしか使用できません。

2.show mls qos interface statisticsイネーブルEXECコマンドを使用することによって、ハードウェアにバイトまたはパケットの統計情報を収集させるDSCP値を13まで定義できます。

3.スイッチCLIコマンドおよび出力では、アクセス制御パラメータをマスクと呼びます。

QoS設定例


) これらの例が適用されるのは、スイッチでEIが稼働している場合に限られます。


ここでは、既存のネットワークと予定しているネットワーク変更に基づいて、QoS機能を迅速に実装できるように、QoSの移行方法を示します。図 26-4を参照してください。項目は次のとおりです。

「既存の配線クローゼットに適したQoSの設定」

「インテリジェント型配線クローゼットに適したQoSの設定」

図 26-4 QoSを設定するネットワークの例

 

既存の配線クローゼットに適したQoSの設定

図 26-4の既存の配線クローゼットは、既存のCatalyst 2900 XLスイッチおよび3500 XLスイッチで構成されています。これらのスイッチでは、QoSベースのIEEE 802.1p CoS値をサポートする、IOS Release 12.0(5)XP以降が稼働しています。QoSによる分類では、各フレームにプライオリティ別のCoS値が割り当てられ、プライオリティの高いトラフィックが優先されます。

Catalyst 2900 XLおよび3500 XLスイッチでは、各ポートにデフォルトのCoS値を設定することによって( switchport priority default default-priority-id インターフェイス コンフィギュレーション コマンド)、タグなし(ネイティブ)のイーサネット フレームを入力ポートで分類することができます。タグ情報のあるIEEE 802.1Qフレームには、ヘッダー フレームのプライオリティ値が使用されます。Catalyst 3524-PWR XLおよびCatalyst 3548 XLスイッチでは、 switchport priority default override インターフェイス コンフィギュレーション コマンドによって、このプライオリティをデフォルト値で上書きできます。上書き機能が備わっていないCatalyst 2950スイッチおよびCatalyst 2900 XLまたは他の3500 XLモデルの場合、 mls qos cos override インターフェイス コンフィギュレーション コマンドを使用することにより、Catalyst 3550-12Tスイッチはディストリビューション レイヤで802.1p CoS値を上書きできます。

Catalyst 2900 XLスイッチおよび3500 XLスイッチの場合、CoSは、フレームのタグまたはポート情報に応じて、通常プライオリティの送信キューおよびハイ プライオリティの送信キューを指定して各送信ポート(出力ポート)を設定します。通常プライオリティ キュー内のフレームが転送されるのは、ハイ プライオリティ キューのフレームが転送されてからです。0~3の802.1p CoS値が設定されているフレームは、通常プライオリティの送信キューに格納され、4~7のCoS値が設定されているフレームは、緊急(ハイ プライオリティ)キューに格納されます。

インテリジェント型配線クローゼットに適したQoSの設定

図 26-4のインテリジェント型配線クローゼットは、Catalyst 2950スイッチで構成されています。スイッチのうちの1台はビデオ サーバに接続されており、IPアドレスは172.20.10.16です。

この例の目的は、他のあらゆるトラフィックよりもビデオ トラフィックが優先されるようにすることです。そのためには、46というDSCP値をビデオ トラフィックに割り当てます。このトラフィックは、他のキューより頻繁に処理されるキュー4に格納されます。

ビデオ パケットが他のすべてのトラフィックより優先されるようにスイッチを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

access-list 1 permit 172.20.10.16

IP標準ACLを定義し、172.20.10.16のビデオ サーバからのトラフィックを許可します。

ステップ 3

class-map videoclass

videoclass というクラス マップを作成し、クラス マップ コンフィギュレーション モードを開始します。

ステップ 4

match access-group 1

ACL 1によって指定されたトラフィックを照合することによって、一致条件を定義します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

policy-map videopolicy

videopolicy というポリシー マップを作成し、ポリシー マップ コンフィギュレーション モードを開始します。

ステップ 7

class videoclass

作用対象のクラスを指定し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

ステップ 8

set ip dscp 46

トラフィックがACL 1と一致した場合は、着信パケットのDSCP値を46に設定します。

ステップ 9

police 5000000 8192 exceed-action drop

5 Mbpsの平均トラフィック伝送速度、8192バイトのバースト サイズを超えるトラフィックを廃棄するために、分類されたビデオ トラフィックにポリサーを定義します。

ステップ 10

exit

ポリシー マップ コンフィギュレーション モードに戻ります。

ステップ 11

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 12

interface gigabitethernet0/1

インターフェイス コンフィギュレーション モードを開始し、入力インターフェイスを指定します。

ステップ 13

service-policy input videopolicy

入力インターフェイスにポリシーを適用します。

ステップ 14

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 15

wrr-queue bandwidth 1 2 3 4

キュー4に高いWRRウェイトを割り当てます。

ステップ 16

wrr-queue cos-map 4 6 7

CoS値6およびCoS値7でキュー4が選択されるように、CoS/出力キュー マップを設定します。

ステップ 17

end

イネーブルEXECモードに戻ります。

ステップ 18

show class-map videoclass

show policy-map videopolicy

show mls qos maps [ cos-dscp | dscp-cos ]

設定を確認します。

ステップ 19

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。