Catalyst 2950 LRE デスクトップ スイッチ ソフトウェア コンフィギュレーション ガイド
スイッチのIPアドレスおよびデフォル ト ゲートウェイの割り当て
スイッチのIPアドレスおよびデフォルト ゲートウェイの割り当て
発行日;2012/01/12 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

スイッチのIPアドレスおよびデフォルト ゲートウェイの割り当て

起動プロセスの概要

スイッチ情報の割り当て

デフォルトのスイッチ情報

DHCPベースの自動設定の概要

DHCPクライアントの要求プロセス

DHCPサーバの設定

TFTPサーバの設定

DNSの設定

リレー装置の設定

コンフィギュレーション ファイルの入手方法

構成例

手動でのスイッチ情報の割り当て

実行コンフィギュレーションの確認と保存

スイッチのIPアドレスおよびデフォルト ゲートウェイの割り当て

この章では、自動および手動の各種の方法でスイッチの初期設定(たとえば、スイッチIPアドレスやデフォルトのゲートウェイ情報の割り当て)を行う方法について説明します。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「起動プロセスの概要」

「スイッチ情報の割り当て」

「実行コンフィギュレーションの確認と保存」

起動プロセスの概要

スイッチ情報(IPアドレス、サブネット マスク、デフォルト ゲートウェイ、シークレット、およびTelnetパスワードなど)を割り当てるには、まず、スイッチに付属のハードウェア インストレーション ガイドに従ってスイッチを設置して、電源をオンにする必要があります。

通常のブート プロセスにはブートローダ ソフトウェアの操作も含まれます。ブート ローダは以下のアクティビティを実行します。

下位レベルのCPU初期化を行います。CPUレジスタを初期化することにより、物理メモリがマッピングされる場所、容量、速度などを制御します。

CPUサブシステムのPower-on Self-Test(POST;電源投入時セルフテスト)を行います。CPU DRAMと、フラッシュ ファイル システムを構成するフラッシュ デバイスの部分をテストします。

システム ボード上のフラッシュ ファイル システムを初期化します。

デフォルトのオペレーティング システム ソフトウェアをメモリにロードし、スイッチを起動します。

ブート ローダによってフラッシュ ファイル システムにアクセスしてから、オペレーティング システムをロードします。通常、ブート ローダは、オペレーティング システムのロード、圧縮解除、および起動の目的でのみ使用します。オペレーティング システムがCPUを制御できるようになると、ブート ローダは、次にシステムがリセットされるか電源が投入されるまでは非アクティブとなります。

また、オペレーティング システムが使用不可能となるほどの重大な障害が発生した場合は、ブート ローダはシステムにトラップドア アクセスを行います。トラップドア メカニズムによるシステムへのアクセス機能により、必要があれば、フラッシュ ファイル システムをフォーマットし、XMODEMプロトコルを使用してオペレーティング システムのソフトウェアイメージを再インストールし、失われたパスワードを回復し、最終的にオペレーティング システムを再起動することができます。詳細については、「ソフトウェアが破損した場合の回復」および「パスワードを忘れた場合の回復」を参照してください。

スイッチ情報を割り当てるには、まずPCまたは端末をコンソール ポートに接続し、PCまたは端末エミュレーション ソフトウェアのボーレートおよび文字フォーマットがスイッチのコンソール ポートのものと一致することを確認します。詳細については、スイッチのハードウェア インストレーション ガイドを参照してください。

スイッチ情報の割り当て

IP情報の割り当ては、スイッチのセットアップ プログラムまたはDynamic Host Configuration Protocol(DHCP)サーバを使用するか、手動で行います。

新規ユーザで個々のIP情報についてプロンプトを表示させたい場合には、スイッチのセットアップ プログラムを使用します。このプログラムを使用すると、ホスト名とイネーブル シークレット パスワードを設定することもできます。また、任意で、Telnetパスワードを割り当てたり(リモート管理中のセキュリティ確保のため)、スイッチをクラスタのコマンドまたはメンバー スイッチとして、あるいはスタンドアロン スイッチとして設定することができます。セットアップ プログラムの使用方法の詳細については、Cisco.comのリリース ノートを参照してください。

サーバ設定後のIP情報の中央集中型管理と自動割り当てには、DHCPサーバを使用します。


) DHCPを使用している場合は、スイッチが動的に割り当てられたIPアドレスを受信してコンフィギュレーション ファイルを読み込むまでは、セットアップ プログラムからの質問に応答しないでください。


スイッチ設定の手順に精通した経験豊かなユーザの場合、手動で設定を行います。そうでない場合は、上記で説明したセットアップ プログラムを使用します。

ここでは、次の設定手順について説明します。

「デフォルトのスイッチ情報」

「DHCPベースの自動設定の概要」

「手動でのスイッチ情報の割り当て」

デフォルトのスイッチ情報

表 4-1 に、デフォルトのスイッチ情報を示します。

 

表 4-1 デフォルトのスイッチ情報

機能
デフォルト値

IPアドレスおよびサブネット マスク

IPアドレスまたはサブネット マスクは定義されていません。

デフォルト ゲートウェイ

デフォルト ゲートウェイは定義されていません。

イネーブル シークレット パスワード

パスワードは定義されていません。

ホスト名

出荷時設定のホスト名は Switch です。

Telnetパスワード

パスワードは定義されていません。

クラスタ コマンド スイッチ機能

ディセーブル

クラスタ名

クラスタ名は定義されていません。

DHCPベースの自動設定の概要

DHCPは、インターネットホストおよびインターネットワーキング デバイスに設定情報を提供します。このプロトコルは、2つのコンポーネントで構成されています。1つはDHCPサーバから装置にコンフィギュレーション パラメータを提供するコンポーネント、もう1つは装置にネットワーク アドレスを割り当てるコンポーネントです。DHCPはクライアント/サーバ モデルに基づいています。指定されたDHCPサーバが、動的に設定される装置に対して、ネットワークアドレスを割り当て、コンフィギュレーション パラメータを提供します。

DHCPベースの自動設定中、スイッチ(DHCPクライアント)は起動時に、IPアドレス情報およびコンフィギュレーション ファイルによって自動的に設定されます。

DHCPベースの自動設定を使用すると、スイッチ上でDHCPクライアント側の設定を行う必要はありません。ただし、DHCPサーバにはIPアドレスに対応する各種のリース オプションを設定する必要があります。DHCPを使用してネットワーク上にコンフィギュレーション ファイルをリレーする場合は、Trivial File Transfer Protocol(TFTP;簡易ファイル転送プロトコル)サーバおよびDomain Name System(DNS;ドメイン ネーム システム)サーバの設定が必要なこともあります。

DHCPサーバは、スイッチと同じLAN上にあっても、異なるLAN上にあっても構いません。DHCPサーバが別のLANで実行されている場合は、DHCPリレーを設定する必要があります。リレー装置は、直接接続されている2つのLAN間でブロードキャスト トラフィックを転送します。ルータはブロードキャスト パケットを転送しませんが、受信したパケットの宛先IPアドレスに基づいてパケットを転送します。

DHCPベースの自動設定は、スイッチのBOOTPクライアント機能に代わるものです。

DHCPクライアントの要求プロセス

スイッチを起動したときに、 スイッチにコンフィギュレーション ファイルがなかった場合、スイッチはDHCPサーバに設定情報を自動的に要求します。

次の場合にはDHCPの自動設定は行われません。

コンフィギュレーション ファイルがあり、スイッチ上でservice configグローバル コンフィギュレーション コマンドがディセーブルになっている場合。

コンフィギュレーション ファイルがあり、スイッチ上でservice configグローバル コンフィギュレーション コマンドがイネーブルになっている場合。この場合、スイッチはコンフィギュレーション ファイルに向けてTFTP要求をブロードキャストします。

図 4-1に、DHCPクライアントとDHCPサーバ間で交換される一連のメッセージを示します。

図 4-1 DHCPクライアント/サーバ間のメッセージ交換

 

クライアントであるスイッチAは、DHCPサーバの場所を特定するために、DHCPDISCOVERメッセージをブロードキャストします。DHCPサーバは、DHCPOFFERユニキャスト メッセージによって、使用可能なコンフィギュレーション パラメータ(IPアドレス、サブネット マスク、ゲートウェイIPアドレス、DNS IPアドレス、IPアドレス用のリースなど)をクライアントに提示します。

DHCPREQUESTブロードキャスト メッセージでは、クライアントは、提示された設定情報に対して、DHCPサーバに正式な要求を戻します。この正式な要求はブロードキャストされるため、クライアントからDHCPDISCOVERブロードキャスト メッセージを受信した他のDHCPサーバはすべて、クライアントに提示したIPアドレスを再利用することができます。

DHCPサーバは、DHCPACKユニキャスト メッセージをクライアントに戻すことで、IPアドレスがクライアントに割り当てられたことを確認します。このメッセージによって、クライアントとサーバは結び付けられ、クライアントはサーバから受信した設定情報を使用します。スイッチの受信する情報量は、DHCPサーバの設定方法によって異なります。詳細は、「DHCPサーバの設定」を参照してください。

DHCPOFFERユニキャスト メッセージによって送信されたコンフィギュレーション パラメータが無効である(コンフィギュレーション エラーがある)場合、クライアントはDHCPサーバに、DHCPDECLINEブロードキャスト メッセージを戻します。

DHCPサーバはクライアントに、提示されたコンフィギュレーション パラメータが割り当てられていない、パラメータのネゴシエーション中にエラーが発生した、またはDHCPOFFERメッセージに対するクライアントの応答が遅れている(DHCPサーバがパラメータを別のクライアントに割り当てた)という意味のDHCPNAK拒否ブロードキャスト メッセージを送信します。

DHCPクライアントは、複数のDHCPサーバまたはBOOTPサーバから提示を受け取り、そのうちの任意の1つを受け入れることができますが、通常は最初に受け取った提示を受け入れます。DHCPサーバから提示されたIPアドレスが必ずしもクライアントに割り当てられるわけではありません。ただし、サーバは通常、クライアントが正式にアドレスを要求するまではアドレスを保管しておきます。スイッチがBOOTPサーバからの応答を受け入れて、自身を設定する場合、スイッチはスイッチ コンフィギュレーション ファイルを入手するために、TFTP要求をユニキャストするのではなくブロードキャストします。

DHCPサーバの設定

DHCPサーバには、スイッチ ハードウェア アドレスによって各スイッチにバインドされた、専用のリースを設定する必要があります。

スイッチにIPアドレス情報を受信させるには、DHCPサーバに次のリース オプションを設定する必要があります。

クライアントのIPアドレス(必須)

クライアントのサブネット マスク(必須)

DNSサーバのIPアドレス(任意)

ルータのIPアドレス(スイッチで使用するデフォルトのゲートウェイ アドレス)(必須)

スイッチにTFTPサーバからコンフィギュレーション ファイルを受信させる場合は、DHCPサーバに次のリース オプションを設定する必要があります。

TFTPサーバ名(必須)

ブート ファイル名(クライアントが必要とするコンフィギュレーション ファイル名)(推奨)

ホスト名(任意)

DHCPサーバの設定によっては、スイッチはIPアドレス情報またはコンフィギュレーション ファイル、あるいはその両方を受信できます。

DHCPサーバに上記のリース オプションを設定しない場合、DHCPサーバはクライアントの要求に対して、設定されているパラメータだけに応答します。IPアドレスおよびサブネット マスクが応答に含まれていないと、スイッチは設定されません。ルータのIPアドレスまたはTFTPサーバ名が見つからない場合、スイッチはTFTP要求をユニキャストせずにブロードキャストする場合があります。その他のリース オプションが使用できない場合は、自動設定には影響しません。

DHCPサーバは、スイッチと同じLAN上にあっても、異なるLAN上にあっても構いません。DHCPサーバが別のLANで実行されている場合は、DHCPリレーを設定する必要があります。詳細は、「リレー装置の設定」を参照してください。DHCPサーバがシスコ製装置である場合は、『 Cisco IOS IP and IP Routing Configuration Guide for Release 12.1 』の「 IP Addressing and Services 」を参照してください。

TFTPサーバの設定

DHCPサーバの設定に基づいて、スイッチはTFTPサーバから1つまたは複数のコンフィギュレーション ファイルをダウンロードしようとします。TFTPサーバへのIP接続に必要なすべてのオプションについてスイッチに応答するようDHCPを設定している場合、かつ、TFTPサーバ名、アドレス、およびコンフィギュレーション ファイル名を指定してDHCPサーバを設定している場合、スイッチは指定されたTFTPサーバから指定されたコンフィギュレーション ファイルをダウンロードしようとします。

コンフィギュレーション ファイル名、およびTFTPサーバを指定しなかった場合、またはコンフィギュレーション ファイルをダウンロードできなかった場合は、スイッチはファイル名とTFTPサーバアドレスをさまざまに組み合わせてコンフィギュレーション ファイルをダウンロードしようとします。ファイルには、(あれば)特定のコンフィギュレーション ファイル名と次のファイルが指定されています。network-config、cisconet.cfg、 hostname .config、または hostname .cfgです。この場合、 hostname はスイッチの現在のホスト名です。使用されるTFTPサーバアドレスには、(あれば)指定されたTFTPサーバのアドレス、およびブロードキャスト アドレス(255.255.255.255)が含まれています。

スイッチが正常にコンフィギュレーション ファイルをダウンロードするには、TFTPサーバは、そのベース ディレクトリに1つまたは複数のコンフィギュレーション ファイルを含んでいる必要があります。設定できるファイルは、次のとおりです。

DHCP応答で指定されているコンフィギュレーション ファイル(実際のスイッチ コンフィギュレーション ファイル)

network-confgまたはcisconet.cfgファイル(デフォルトのコンフィギュレーション ファイル)

router-confgまたはciscortr.cfgファイル(これらのファイルには、すべてのスイッチに共通のコマンドが含まれています。通常、DHCPおよびTFTPサーバが適切に設定されていれば、これらのファイルはアクセスされません)

DHCPサーバ リース データベースにTFTPサーバ名を指定する場合は、DNSサーバのデータベースにTFTPサーバ名とIPアドレスのマッピングを設定する必要もあります。

使用するTFTPサーバが、スイッチとは異なるLAN上にある場合、またはスイッチがブロードキャスト アドレスを使用してアクセスした場合(前述のすべての必須情報がDHCPサーバの応答に含まれていない場合に発生)は、リレーを設定してTFTPサーバにTFTPパケットを転送する必要があります。詳細は、「リレー装置の設定」を参照してください。すべての必須情報を含むようDHCPサーバを設定することを推奨します。

DNSの設定

DHCPサーバは、DNSサーバを使用してTFTPサーバ名をIPアドレスに変換します。DNSサーバ上で、TFTPサーバ名からIPアドレスへのマッピングを設定する必要があります。TFTPサーバには、スイッチのコンフィギュレーション ファイルが存在します。

DNSサーバのIPアドレスを、DHCP応答がIPアドレスを取得するDHCPサーバのリース データベースに設定できます。リース データベースには、DNSサーバのIPアドレスを最大2つまで入力できます。

DNSサーバは、スイッチと同じLAN上に存在しても、またスイッチとは別のLAN上に存在していてもかまいません。DHCPサーバが別のLAN上に存在する場合、スイッチはルータを介してDHCPサーバにアクセス可能でなければなりません。

リレー装置の設定

別のLAN上にあるホストからの応答が必要なブロードキャスト パケットをスイッチが送信する場合は、リレー装置を設定する必要があります。スイッチが送信する可能性のあるブロードキャスト パケットの例としてDHCPパケット、DNSパケット、場合によってはTFTPパケットが挙げられます。リレー装置は、インターフェイス上の受信ブロードキャスト パケットを宛先ホストに転送するように設定しなければなりません。

リレー装置がシスコ製ルータである場合、IPルーティングをイネーブルにし( ip routing グローバル コンフィギュレーション コマンド)、 ip helper-address インターフェイス コンフィギュレーション コマンドを使用して、ヘルパー アドレスを設定します。

図 4-2では、ルータ インターフェイスを次のように設定しています。

インターフェイス 10.0.0.2では、

router(config-if)# ip helper-address 20.0.0.2
router(config-if)# ip helper-address 20.0.0.3
router(config-if)# ip helper-address 20.0.0.4
 

インターフェイス 20.0.0.1では、

router(config-if)# ip helper-address 10.0.0.1

図 4-2 自動設定でのリレー装置の使用

 

コンフィギュレーション ファイルの入手方法

IPアドレスおよびコンフィギュレーション ファイル名がDHCPで専用のリースとして取得できるかどうかに応じて、スイッチは次の方法で設定情報を入手します。

IPアドレスおよびコンフィギュレーション ファイル名が、スイッチ用に予約され、DHCP応答(1ファイル読み込み方式)で提供されている場合

スイッチは、DHCPサーバからIPアドレス、サブネット マスク、TFTPサーバ アドレス、およびコンフィギュレーション ファイル名を受け取ります。スイッチは、TFTPサーバにユニキャスト メッセージを送信して、指定されたコンフィギュレーション ファイルをサーバのベース ディレクトリから検索し入手して、ブートアップ プロセスを完了します。

スイッチのIPアドレスおよびコンフィギュレーション ファイル名が予約されているが、DHCP応答にTFTPサーバ アドレスが含まれていない場合(1ファイル読み込み方式)

スイッチは、DHCPサーバからIPアドレス、サブネット マスク、コンフィギュレーション ファイル名を受け取ります。スイッチは、TFTPサーバにブロードキャスト メッセージを送信して、指定されたコンフィギュレーション ファイルをサーバのベース ディレクトリから検索し、入手してブートアップ プロセスを完了します。

IPアドレスだけがスイッチ用に予約され、DHCP応答で提供されており、コンフィギュレーション ファイル名は提供されない場合(2ファイル読み込み方式)

スイッチは、DHCPサーバからIPアドレス、サブネット マスク、およびTFTPサーバ アドレスを受け取ります。スイッチは、TFTPサーバにユニキャストメッセージを送り、network-confgまたはcisconet.cfgのデフォルト コンフィギュレーション ファイルを取得します(network-confgファイルが読み込めない場合、スイッチはcisconet.cfgファイルを読み込みます)。

デフォルト コンフィギュレーション ファイルには、スイッチのホスト名からIPアドレスへのマッピングが含まれています。スイッチは、ファイルの情報をホスト テーブルに書き込み、ホスト名を入手します。ファイルにホスト名がない場合、スイッチはDHCP応答で指定されたホスト名を使用します。DHCP応答でホスト名が指定されていない場合、スイッチはデフォルトの Switch をホスト名として使用します。

デフォルトのコンフィギュレーション ファイルまたはDHCP応答からホスト名を入手したあと、スイッチはホスト名と同じ名前のコンフィギュレーション ファイル(network-confgまたはcisconet.cfgのどちらが先に読み込まれたかに応じて、 hostname -confgまたは hostname .cfg)をTFTPサーバから読み込みます。cisconet.cfgファイルが読み込まれている場合は、ホストのファイル名は8文字に切り捨てられます。

network-confg、cisconet.cfg、またはホスト名と同じ名前のファイルを読み込むことができない場合、スイッチはrouter-confgファイルを読み込みます。router-confgファイルを読み込むことができない場合、スイッチはciscortr.cfgファイルを読み込みます。


) DHCP応答からTFTPサーバを入手できなかった場合、ユニキャスト伝送によるコンフィギュレーション ファイルの読み込みに失敗した場合、またはTFTPサーバ名をIPアドレスに変換できない場合には、スイッチはTFTPサーバ要求をブロードキャストします。


構成例

図 4-3に、DHCPベースの自動設定を使用してIP情報を検索するネットワークの構成例を示します。

図 4-3 DHCPベースの自動設定を使用するネットワークの構成例

 

表 4-2 に、DHCPサーバ上の専用のリースのコンフィギュレーションを示します。

 

表 4-2 DHCPサーバのコンフィギュレーション

スイッチ1
スイッチ2
スイッチ3
スイッチ4

バインディング キー(ハードウェア アドレス)

00e0.9f1e.2001

00e0.9f1e.2002

00e0.9f1e.2003

00e0.9f1e.2004

IPアドレス

10.0.0.21

10.0.0.22

10.0.0.23

10.0.0.24

サブネット マスク

255.255.255.0

255.255.255.0

255.255.255.0

255.255.255.0

ルータ アドレス

10.0.0.10

10.0.0.10

10.0.0.10

10.0.0.10

DNSサーバ アドレス

10.0.0.2

10.0.0.2

10.0.0.2

10.0.0.2

TFTPサーバ名

maritsu または 10.0.0.3

maritsu または 10.0.0.3

maritsu または 10.0.0.3

maritsu または 10.0.0.3

ブート ファイル名(コンフィギュレーション ファイル)(任意)

switch1-confg

switch2-confg

switch3-confg

switch4-confg

ホスト名(任意)

switch1

switch2

switch3

switch4

DNSサーバ コンフィギュレーション

DNSサーバは、TFTPサーバ名 maritsu をIPアドレス10.0.0.3にマッピングします。

TFTPサーバ コンフィギュレーション(UNIX)

TFTPサーバのベース ディレクトリは、/tftpserver/work/に設定されています。このディレクトリには、2ファイル読み込み方式で使用されるnetwork-confgファイルがあります。このファイルには、IPアドレスに基づいてスイッチに割り当てられるホスト名が含まれています。ベース ディレクトリには、次に示すように、各スイッチのコンフィギュレーション ファイル( switch1-confg switch2-confg など)も含まれています。

prompt> cd /tftpserver/work/
prompt> ls
network-confg
switch1-confg
switch2-confg
switch3-confg
switch4-confg
prompt> cat network-confg
ip host switch1 10.0.0.21
ip host switch2 10.0.0.22
ip host switch3 10.0.0.23
ip host switch4 10.0.0.24
 

DHCPクライアント コンフィギュレーション

スイッチ1~スイッチ4には、コンフィギュレーション ファイルは存在しません。

コンフィギュレーションの説明

図 4-3の場合、スイッチ1はコンフィギュレーション ファイルを次のようにして読み込みます。

DHCPサーバからIPアドレス10.0.0.21を入手します。

DHCPサーバの応答でコンフィギュレーション ファイル名が提供されない場合、スイッチ1はTFTPサーバのベース ディレクトリからnetwork-confgファイルを読み込みます。

ホスト テーブルにnetwork-confgファイルの内容を追加します。

IPアドレス10.0.0.21をもとにホスト テーブルを検索し、ホスト名(switch1)を取得します。

ホスト名に対応するコンフィギュレーション ファイルを読み込みます。たとえば、TFTPサーバから switch1-confg を読み込みます。

スイッチ2~スイッチ4も、同様にコンフィギュレーション ファイルおよびIPアドレスを取得します。

手動でのスイッチ情報の割り当て

複数のSwitched Virtual Interface(SVI)またはポートに手動でIP情報を割り当てるには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vlan-id

インターフェイス コンフィギュレーション モードを開始し、IP情報を割り当てるVLANを入力します。指定できる範囲は、拡張ソフトウェア イメージがインストールされている場合は1~4094、標準ソフトウェア イメージがインストールされている場合は1~1001です。先行ゼロは入力しません。

ステップ 3

ip address ip-address subnet-mask

IPアドレスおよびサブネット マスクを入力します。

ステップ 4

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 5

ip default-gateway ip-address

スイッチに直接接続しているネクスト ホップのルータ インターフェイスのIPアドレスを入力します。このスイッチにはデフォルト ゲートウェイが設定されています。デフォルト ゲートウェイは、スイッチから宛先IPアドレスを取得していないIPパケットを受信します。

デフォルト ゲートウェイが設定されると、スイッチは、ホストが接続する必要のあるリモート ネットワークに接続できます。


) IPでルーティングするようにスイッチを設定すると、デフォルト ゲートウェイを設定する必要はありません。


ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show running-config

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチのIPアドレスを削除する場合は no ip address インターフェイス コンフィギュレーション コマンドを使用します。Telnetセッションからアドレスを削除すると、スイッチの接続は切断されます。デフォルト ゲートウェイのアドレスを削除する場合は、 no ip default-gateway グローバル コンフィギュレーション コマンドを使用します。

スイッチのシステム名の設定、イネーブルEXECコマンドへのアクセスの保護、時刻および日付の設定については、 第7章「スイッチの管理」 を参照してください。

実行コンフィギュレーションの確認と保存

次のイネーブルEXECコマンドを使用すると、入力した設定や変更を確認できます。

Switch# show running-config
 
Building configuration...
 
Current configuration : 2081 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname Switch
!
enable secret 5 $1$ej9.$DMUvAUnZOAmvmgqBEzIxE0
!
ip subnet-zero
!
vlan 3020
cluster enable Test 0
cluster member 1 mac-address 0030.9439.0900
cluster member 2 mac-address 0001.425b.4d80
!
spanning-tree extend system-id
!
!
interface Port-channel1
no ip address
!
interface FastEthernet0/1
switchport mode access
switchport voice vlan 400
switchport priority extend cos 5
no ip address
spanning-tree portfast trunk
!
interface FastEthernet0/2
switchport mode access
no ip address
!
...
interface FastEthernet0/8
switchport mode access
switchport voice vlan 350
no ip address
spanning-tree portfast trunk
!
interface FastEthernet0/9
switchport mode access
no ip address
shutdown
!
interface FastEthernet0/10
switchport trunk native vlan 2
no ip address
speed 100
!
interface FastEthernet0/11
switchport voice vlan 4046
no ip address
shutdown
spanning-tree portfast trunk
!
interface FastEthernet0/12
switchport mode access
switchport voice vlan 4011
no ip address
shutdown
spanning-tree portfast trunk
!
interface GigabitEthernet0/1
no ip address
shutdown
!
interface GigabitEthernet0/2
no ip address
shutdown
!
interface Vlan1
ip address 172.20.139.133 255.255.255.224
no ip route-cache
!
ip default-gateway 172.20.139.129
ip http server
!
ip access-list extended CMP-NAT-ACL
!
snmp-server engineID local 8000000903000005742809C1
snmp-server community public RO
snmp-server community public@es0 RO
snmp-server enable traps MAC-Notification
!
line con 0
password letmein
line vty 0 4
password letmein
login
line vty 5 15
password letmein
login
!
end
 

スタートアップ コンフィギュレーションに対して行った設定や変更をフラッシュ メモリに保存するには、次のイネーブルEXECコマンドを使用します。

Switch# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
 

このコマンドにより、入力した設定値が保存されます。保存できなかった場合、設定は次のシステム リロード時に失われます。フラッシュ メモリのNVRAM(不揮発性RAM)セクションに保存されている情報を表示するには、 show startup-config または more startup-config イネーブルEXECコマンドを使用します。