Catalyst 2950/2955 スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.1(22)EA5
VLANの設定
VLANの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

VLANの設定

VLANの概要

サポートされるVLAN

VLANポート メンバーシップ モード

標準範囲VLANの設定

トークンリングVLAN

標準範囲VLAN設定時の注意事項

VLANコンフィギュレーション モードのオプション

config-vlanモードでのVLAN設定

VLANコンフィギュレーション モードでのVLAN設定

VLAN設定の保存

イーサネットVLANのデフォルト設定

イーサネットVLANの作成または変更

VLANの削除

VLANへのスタティック アクセス ポートの割り当て

拡張範囲VLANの設定

VLANのデフォルト設定

拡張範囲VLAN設定時の注意事項

拡張範囲VLANの作成

VLANの表示

VLANトランクの設定

トランキングの概要

IEEE 802.1Qの設定に関する考慮事項

レイヤ2イーサネット インターフェイスVLANのデフォルト設定

トランク ポートとしてのイーサネット インターフェイスの設定

他の機能との相互作用

トランク ポートの設定

トランクでの許可VLANの定義

プルーニング適格リストの変更

タグなしトラフィック用ネイティブVLANの設定

STPによる負荷分散

STPポート プライオリティによる負荷分散

STPパス コストによる負荷分散

VMPSの設定

VMPSの概要

ダイナミック ポートVLANメンバーシップ

VMPSデータベース コンフィギュレーション ファイル

VMPSクライアントのデフォルト設定

VMPS設定時の注意事項

VMPSクライアントの設定

VMPSのIPアドレスの入力

VMPSクライアント上のダイナミック アクセス ポートの設定

VLANメンバーシップの再確認

再確認インターバルの変更

再試行回数の変更

VMPSのモニタ

ダイナミック ポートVLANメンバーシップのトラブルシューティング

VMPSの設定例

VLANの設定

この章では、Catalyst 2950またはCatalyst 2955スイッチ上で標準範囲VLANを設定する方法について説明します。VLANモードやVLAN Membership Policy Server(VMPS;VLANメンバーシップ ポリシー サーバ)についても説明します。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「VLANの概要」

「標準範囲VLANの設定」

「拡張範囲VLANの設定」

「VLANの表示」

「VLANトランクの設定」

「VMPSの設定」

VLANの概要

VLANは、ユーザの物理的な位置に関係なく、機能、プロジェクト チーム、またはアプリケーションなどで論理的に分割されたスイッチド ネットワークです。VLANは、物理LANと同じ属性をすべて備えていますが、同じLANセグメントに物理的に配置されていないエンド ステーションもグループ化できます。どのスイッチ ポートもVLANに割り当てることができます。ユニキャスト、ブロードキャスト、およびマルチキャスト パケットは、VLAN内のエンド ステーションだけにフォワーディングおよびフラッディングが行われます。各VLANは1つの論理ネットワークとみなされ、VLANに割り当てられていないステーション宛てのパケットは、ルータまたはブリッジを経由して転送しなければなりません(図16-1を参照)。VLANはそれぞれが独立した論理ネットワークとみなされるので、VLANごとに独自のブリッジMIB情報があり、スパニングツリーの独自の実装をサポートできます。「STPの設定」および「MSTPの設定」を参照してください。


) VLANを作成する前に、VLAN Trunking Protocol(VTP;VLANトランキング プロトコル)を使用してネットワークのグローバルなVLAN設定を維持するかどうかを決定する必要があります。VTPの詳細については、「VTPの設定」を参照してください。


図16-1に、論理的に定義されたネットワークにセグメント化されたVLANの例を示します。

図16-1 論理的に定義されたネットワークとしてのVLAN

 

通常、VLANはIPサブネットワークに対応付けられます。たとえば、特定のIPサブネットに含まれるすべてのエンド ステーションは同一のVLANに所属させます。スイッチ上のインターフェイスのVLANメンバーシップは、インターフェイスごとに手動で割り当てます。この方法でスイッチ インターフェイスをVLANに割り当てた場合、これをインターフェイス ベース(またはスタティック)VLANメンバーシップと呼びます。

サポートされるVLAN

Catalyst 2950スイッチがサポートするVLANの数は、Standard Software Image(SI;標準ソフトウェア イメージ)で64です。Catalyst 2950およびCatalyst 2955スイッチがサポートするVLANの数は、Enhanced Software Image(EI;拡張ソフトウェア イメージ)で250です。各イメージをサポートするスイッチの一覧については、リリース ノートを参照してください。VLANは、1~4094の番号で識別します。VLAN ID1002~1005は、トークンリングおよびFDDI VLAN専用です。VTPは、VLAN IDが1~1005の標準範囲VLANだけを学習します。1005を超えるVLAN IDは拡張範囲VLANであり、VLANデータベースには格納されません。1006~4094のVLAN IDを作成する場合は、スイッチをVTPトランスペアレント モードにする必要があります。

スイッチは、最大64のスパニングツリー インスタンスを持つPer-VLAN Spanning-Tree plus(PVST+)およびRapid PVST+をサポートします。各VLANごとに1つのスパニングツリー インスタンスが許可されます。スパニングツリー インスタンス数およびVLAN数の詳細については、「標準範囲VLAN設定時の注意事項」を参照してください。イーサネット ポートを介してVLANトラフィックを送信するために、スイッチはIEEE 802.1Qトランキングをサポートします。

VLANポート メンバーシップ モード

VLANに所属するポートは、メンバーシップ モードを指定して設定します。メンバーシップ モードにより、各ポートが伝送できるトラフィックの種類、および所属できるVLANの数が決まります。 表16-1 に、各種メンバーシップ モード、およびそれぞれのメンバーシップとVTPの特長を示します。

 

表16-1 ポート メンバーシップ モード

メンバーシップ モード
VLANメンバーシップの特長
VTPの特長

スタティック アクセス

スタティック アクセス ポートは、手動で割り当てられ、1つのVLANだけに所属します。詳細は、「VLANへのスタティック アクセス ポートの割り当て」を参照してください。

VTPは必須ではありません。VTPを使用して情報をグローバルに伝播させない場合は、VTPモードをトランスペアレントに設定して、VTPをディセーブルにします。VTPに参加する場合は、2台めのスイッチのトランク ポートに接続されたスイッチに、トランク ポートが1つ以上なければなりません。

802.1Qトランク

デフォルトで、トランク ポートは拡張範囲VLANを含むすべてのVLANのメンバーです。ただし、メンバーシップは許可VLANリストを設定して制限できます。また、プルーニング適格リストを変更して、リストに指定したトランク ポートのVLANへのフラッディング トラフィックを阻止することもできます。トランク ポートの設定については、「トランク ポートとしてのイーサネット インターフェイスの設定」を参照してください。

VTPを推奨しますが、必須ではありません。VTPは、ネットワーク全体に渡ってVLANの追加、削除、名前変更を管理することにより、VLAN設定の整合性を維持します。VTPはトランク リンクを通じて他のスイッチとVLANコンフィギュレーション メッセージを交換します。

ダイナミック アクセス

ダイナミック アクセス ポートは、1つのVLAN(VLAN IDが1~4094)に属し、VMPSによって動的に割り当てられます。VMPSにはCatalyst 5000またはCatalyst 6500シリーズ スイッチを使用できますが、Catalyst 2950または2955スイッチは使用できません。

同一スイッチでダイナミック アクセス ポートとトランク ポートを使用できますが、ダイナミック アクセス ポートは別のスイッチでなくエンド ステーションに接続する必要があります。

設定手順については、「VMPSクライアント上のダイナミック アクセス ポートの設定」を参照してください。

VTPは必須です。

VMPSおよびクライアントを同じVTPドメイン名で設定してください。

VMPSクライアント スイッチで再確認インターバルおよび再試行回数を変更できます。

音声VLAN

音声VLANポートは、Cisco IP Phoneに接続されたアクセス ポートであり、1つのVLANを音声トラフィック用に使用し、別のVLANを電話に接続された装置からのデータ トラフィック用に使用するように設定されています。音声VLANポートの詳細については、「音声VLANの設定」を参照してください。

VTPは必須ではありません。音声VLANに作用しません。

モードおよび機能の定義の詳細については、表16-4を参照してください。

ポートがVLANに所属すると、スイッチはVLAN単位で、ポートに対応するアドレスを学習して管理します。詳細は、「MACアドレス テーブルの管理」を参照してください。

標準範囲VLANの設定

標準範囲VLANは、VLAN IDが1~1005のVLANです。スイッチがVTPサーバまたはトランスペアレント モードの場合、VLANデータベース内のVLAN 2~1001の設定を追加、変更、または削除できます(VLAN ID 1および1002~1005は自動作成され、削除できません)。


) スイッチがVTPトランスペアレント モードの場合、拡張範囲VLAN(IDが1006~4094のVLAN)も作成できます。ただしこれらの拡張範囲VLANはVLANデータベースに格納されません。「拡張範囲VLANの設定」を参照してください。


VLAN IDが1~1005の設定はファイル vlan.dat (VLANデータベース)に書き込まれ、 show vlan イネーブルEXECコマンドを入力すると表示できます。 vlan.dat ファイルはフラッシュ メモリに保存されます。


注意 vlan.datファイルを手動で削除しようとすると、VLANデータベースの不整合が生じる可能性があります。VLAN設定を変更する場合は、ここに記載されたコマンド、およびこのリリースに対応するコマンド リファレンスに記載されたコマンドを使用します。VTP設定の変更手順については、「VTPの設定」を参照してください。

さらに、インターフェイス コンフィギュレーション モードを使用して、ポートのメンバーシップ モードの定義、VLANに対するポートの追加および削除を行います。これらのコマンドの実行結果は実行コンフィギュレーション ファイルに書き込まれます。このファイルを表示するには、 show running-config イネーブルEXECコマンドを使用します。

VLANデータベースに新しい標準範囲VLANを作成したり、VLANデータベース内の既存のVLANを変更する場合、次のパラメータを設定できます。

VLAN ID

VLAN名

VLANタイプ(イーサネット、Fiber Distributed Data Interface[FDDI]、FDDI Network Entity Title[NET]、TrBRFまたはTrCRF、トークンリング、トークンリングNet)

VLANステート(アクティブまたはサスペンド)

VLANのMaximum Transmission Unit(MTU;最大伝送ユニット)

Security Association Identifier(SAID)

TrBRF VLANのブリッジ識別番号

FDDIおよびTrCRF VLANのリング番号

TrCRF VLANの親VLAN番号

TrCRF VLANのSpanning-Tree Protocol(STP;スパニングツリー プロトコル)タイプ

あるVLANタイプから別のVLANタイプに変換するときに使用するVLAN番号


) ここでは、これらのパラメータの大部分の設定手順について説明しません。VLAN設定を制御するコマンドおよびパラメータの詳細については、このリリースに対応するコマンド リファレンスを参照してください。


ここでは、標準範囲VLANの次の内容について説明します。

「トークンリングVLAN」

「標準範囲VLAN設定時の注意事項」

「VLANコンフィギュレーション モードのオプション」

「VLAN設定の保存」

「イーサネットVLANのデフォルト設定」

「イーサネットVLANの作成または変更」

「VLANの削除」

「VLANへのスタティック アクセス ポートの割り当て」

トークンリングVLAN

このスイッチはトークンリング接続をサポートしていませんが、トークンリング接続を行っているCatalyst 5000シリーズ スイッチなどのリモート装置を、サポート対象スイッチのうちの1台から管理できます。VTPバージョン2が稼働しているスイッチは、次のトークンリングVLANに関する情報をアドバタイズします。

トークンリングTrBRF VLAN

トークンリングTrCRF VLAN

トークンリングVLANの詳しい設定手順については、『 Catalyst 5000 Series Software Configuration Guide 』を参照してください。

標準範囲VLAN設定時の注意事項

ネットワーク内で標準範囲VLANを作成または変更する場合には、次の注意事項に従ってください。

各スイッチ モデルでサポートされているVLANの最大数については、 表16-1 を参照してください。250個のVLANをサポートしているスイッチで、VTPが、アクティブなVLAN数として250を示すことがありますが、そのうちの4つ(1002~1005)はトークンリングおよびFDDI専用です。

標準範囲VLANは、1~1001の番号で識別します。VLAN番号1002~1005は、トークンリングおよびFDDI VLAN専用です。

VLAN 1~1005のVLAN設定は、常にVLANデータベースに格納されます。VTPモードがトランスペアレントの場合、VTPおよびVLAN設定はスイッチの実行コンフィギュレーション ファイルにも格納されます。

スイッチは、VTPトランスペアレント モード(VTPはディセーブル)のVLAN ID1006~4094もサポートします。これらは拡張範囲VLANであり、設定オプションには制限があります。拡張範囲VLANはVLANデータベースには格納されません。「拡張範囲VLANの設定」を参照してください。

VLANを作成する前に、スイッチをVTPサーバ モードまたはVTPトランスペアレント モードにしておく必要があります。スイッチがVTPサーバである場合には、VTPドメインを定義する必要があります。VTPドメインを定義しないと、VTPは機能しません。

このスイッチは、トークンリングまたはFDDIメディアをサポートしません。このスイッチはFDDI、FDDI-Net、TrCRF、またはTrBRFトラフィックを伝送しませんが、VTPを介してVLAN設定を伝播します。

スイッチはスパニングツリー インスタンスを64個サポートします。スイッチのアクティブなVLAN数が、サポートされているスパニングツリー インスタンス数よりも多い場合、スパニングツリーは64個のVLANでイネーブルにできます。残りのVLANで、スパニングツリーはディセーブルになります。スイッチ上の使用可能なスパニングツリー インスタンスをすべて使い切ってしまったあとに、VTPドメインの中にさらに別のVLANを追加すると、そのスイッチにスパニングツリーが稼働しないVLANが生成されます。そのスイッチのトランク ポートでデフォルトの許可リスト(すべてのVLANを許可するリスト)が設定されていると、すべてのトランク ポートに新しいVLANが割り当てられます。ネットワーク トポロジーによっては、新しいVLAN上で、切断されないループが生成されることがあります。特に、複数の隣接スイッチでスパニングツリー インスタンスをすべて使用してしまっている場合には注意が必要です。このような事態を防ぐには、スパニングツリー インスタンスの割り当てを使い切っているスイッチのトランク ポートに、許可リストを設定します。

スイッチ上のVLAN数がサポートされるスパニングツリー インスタンス数を超える場合は、IEEE 802.1s Multiple STP(MSTP)をスイッチに設定して、複数のVLANを単一のSTPインスタンスにマッピングすることを推奨します。MSTPの詳細については、「MSTPの設定」を参照してください。

VLANコンフィギュレーション モードのオプション

標準範囲VLAN(VLAN IDが1~1005)を設定するには、次に示す2つのコンフィギュレーション モードを使用します。

「config-vlanモードでのVLAN設定」

config-vlanモードを開始するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを入力します。

「VLANコンフィギュレーション モードでのVLAN設定」

VLANデータベース コンフィギュレーション モードを開始するには、 vlan database イネーブルEXECコマンドを入力します。

config-vlanモードでのVLAN設定

config-vlanモードにアクセスするには、VLAN IDを指定して vlan グローバル コンフィギュレーション コマンドを入力します。新しいVLAN IDを指定してVLANを作成するか、または既存のVLAN IDを使用してVLANを変更します。デフォルトのVLAN設定を使用するか( 表16-2 を参照)、または複数のコマンドを入力してVLANを設定できます。このモードで使用できるコマンドの詳細については、このリリースに対応するコマンド リファレンスの vlan グローバル コンフィギュレーション コマンドに関する説明を参照してください。設定を終了したら、config-vlanモードを終了して、設定を有効にする必要があります。VLAN設定を表示するには、 show vlan イネーブルEXECコマンドを入力します。

拡張範囲VLAN(VLAN IDが1005を超える)を作成する場合は、このconfig-vlanモードを使用する必要があります。「拡張範囲VLANの設定」を参照してください。

VLANコンフィギュレーション モードでのVLAN設定

VLANコンフィギュレーション モードを開始するには、 vlan database イネーブルEXECコマンドを入力します。次に、新しいVLAN IDを指定して vlan コマンドを入力し、VLANを作成するか、または既存のVLAN IDを入力してVLANを修正します。デフォルトのVLAN設定を使用するか( 表16-2 を参照)、または複数のコマンドを入力してVLANを設定できます。このモードで使用できるキーワードの詳細については、このリリースに対応するコマンド リファレンスの vlan VLANコンフィギュレーション コマンドに関する説明を参照してください。設定を終了したら、 apply または exit を入力して、設定を有効にする必要があります。 exit コマンドを入力すると、すべてのコマンドが適用されて、VLANデータベースが更新されます。VTPドメイン内の他のスイッチにVTPメッセージが送信され、イネーブルEXECモード プロンプトが表示されます。

VLAN設定の保存

VLAN ID 1~1005の設定は、常にVLANデータベースに保存されます(vlan.datファイル)。VTPモードがトランスペアレントである場合、設定はスイッチの実行コンフィギュレーション ファイルにも保存されます。設定をスタートアップ コンフィギュレーション ファイルに保存するには、 copy running-config startup-config イネーブルEXECコマンドを使用します。スイッチの実行コンフィギュレーション ファイルを表示するには、 show running-config vlan イネーブルEXECコマンドを使用します。VLAN設定を表示するには、 show vlan イネーブルEXECコマンドを入力します。

VLANおよびVTP情報(拡張範囲VLAN設定情報を含む)をスタートアップ コンフィギュレーション ファイルに保存して、スイッチを再起動すると、スイッチの設定は次のように決定されます。

スタートアップ コンフィギュレーションのVTPモードがトランスペアレントで、VLANデータベースのVLANデータベース名およびVTPドメイン名がスタートアップ コンフィギュレーション ファイル内のVLANデータベース名およびVTPドメイン名と一致する場合、VLANデータベースは無視(クリア)されます。スタートアップ コンフィギュレーション ファイルのVTP設定およびVLAN設定が使用されます。VLANデータベースのVLANデータベース リビジョン番号は変更されません。

スタートアップ コンフィギュレーション内のVTPモードまたはドメイン名がVLANデータベースと一致しない場合は、ドメイン名、VTPモード、最初の1005のVLAN IDの設定は、VLANデータベースの情報を使用します。

VTPモードがサーバの場合は、最初の1005のVLAN IDのドメイン名とVLAN設定は、VLANデータベースの情報を使用します。

Cisco IOS Release 12.1(9)EA1以降が稼働しているスイッチを起動するために、古いスタートアップ コンフィギュレーション ファイルを使用している場合、コンフィギュレーション ファイルにはVTPまたはVLAN情報が含まれていません。したがって、スイッチはVLANデータベース コンフィギュレーションを使用します。

Cisco IOS 12.1(9)EA1より前のリリースが稼働しているスイッチを起動するために、Cisco IOS Release 12.1(9)EA1以降のスタートアップ コンフィギュレーション ファイルを使用している場合、スイッチのイメージはスタートアップ コンフィギュレーション ファイル内のVLANおよびVTP設定を認識しません。したがって、スイッチはVLANデータベース コンフィギュレーションを使用します。


注意 起動時にVLANデータベース コンフィギュレーションが使用され、スタートアップ コンフィギュレーション ファイルに拡張範囲VLAN設定が含まれていた場合、システム起動時にこの情報は失われます。

イーサネットVLANのデフォルト設定

表16-2 にイーサネットVLANのデフォルト設定を示します。


) スイッチがサポートするのは、イーサネット インターフェイスだけです。FDDIおよびトークンリングVLANは、ローカルではサポートされないので、FDDIおよびトークンリング メディア固有の特性は、他のスイッチに対するVTPグローバル アドバタイズに限って設定します。


 

表16-2 イーサネットVLANのデフォルト値および範囲

パラメータ
デフォルト値
範囲

VLAN ID

1

1~4094


) 拡張範囲VLAN(VLAN IDが1006~4094)はVLANデータベースに保存されません。


VLAN名

VLANxxxx xxxx は4桁の数字(先行ゼロを含む)がVLAN ID番号に等しいことを示します。

範囲なし

IEEE 802.10 SAID

100001(100000とVLAN IDの和)

1~4294967294

MTUサイズ

1500

1500~18190

トランスレーショナル
ブリッジ1

0

0~1005

トランスレーショナル
ブリッジ2

0

0~1005

VLANステート

アクティブ

アクティブ、サスペンド

Remote SPAN(RSPAN)

ディセーブル

イネーブル、ディセーブル

イーサネットVLANの作成または変更

VLANデータベース内の各イーサネットVLANには、1~1001の4桁の一意のIDが設定されています。VLAN ID 1002~1005は、トークンリングおよびFDDI VLAN用に予約されています。標準範囲VLANを作成してVLANデータベースに追加するには、VLANに番号および名前を割り当てます。


) スイッチがVTPトランスペアレント モードで、EIがインストールされている場合、1006を超えるVLAN IDを割り当てることができますが、それらをVLANデータベースに追加することはできません。「拡張範囲VLANの設定」を参照してください。


VLANの追加時に指定されるデフォルト パラメータの一覧は、「標準範囲VLANの設定」を参照してください。

config-vlanモードを使用してイーサネットVLANを作成または変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id

VLAN IDを入力して、config-vlanモードを開始します。新規のVLAN IDを入力してVLANを作成するか、または既存のVLAN IDを入力してVLANを変更します。


) このコマンドで使用できるVLAN IDは、1~4094です。1005を超えるVLAN ID(拡張範囲VLAN)を追加する場合については、「拡張範囲VLANの設定」を参照してください。


ステップ 3

name vlan-name

(任意)VLANの名前を入力します。VLAN名を指定しない場合には、デフォルトとして、VLANという語の後ろに先行ゼロを含めた vlan-id が付加されます。たとえば、VLAN 4のデフォルトのVLAN名はVLAN0004です。

ステップ 4

mtu mtu-size

(任意)MTUサイズ(または他のVLAN特性)を変更します。

ステップ 5

remote-span

(任意)VLANをRSPANセッションのRSPAN VLANとして設定します。RSPANの詳細については、「SPANおよびRSPANの設定」を参照してください。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 8

copy running-config startup config

(任意)スイッチがVTPトラスペアレント モードである場合、VLAN設定は実行コンフィギュレーション ファイルとVLANデータベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLAN名をデフォルト設定に戻すには、 no vlan name no vlan mtu 、または no remote span config-vlanコマンドを使用します。

次に、config-vlanモードを使用して、イーサネットVLAN 20を作成し、 test20 という名前を付け、VLANデータベースに追加する例を示します。

Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end
 

VLANコンフィギュレーション モードを使用してイーサネットVLANを作成または変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

vlan database

VLANデータベース コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id name vlan-name

番号を割り当てることによって、イーサネットVLANを追加します。指定できる範囲は1~1001です。先行ゼロは入力しないでください。

VLAN名を指定しない場合には、デフォルトとして、VLANという語の後ろに先行ゼロを含めた vlan-id が付加されます。たとえば、VLAN 4のデフォルトのVLAN名はVLAN0004です。

ステップ 3

vlan vlan-id mtu mtu-size

(任意)VLANを変更するには、VLANを指定し、MTUサイズなどの特性を変更します。

ステップ 4

exit

VLANデータベースをアップデートし、アップデート情報を管理ドメイン全体に伝播して、イネーブルEXECモードに戻ります。

ステップ 5

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 6

copy running-config startup config

(任意)スイッチがVTPトラスペアレント モードである場合、VLAN設定は実行コンフィギュレーション ファイルとVLANデータベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。


) VLANデータベース コンフィギュレーション モードでは、RSPAN VLANを設定できません。


VLAN名をデフォルト設定に戻すには、 no vlan vlan-id name VLANコンフィギュレーション コマンドを使用します。

次に、VLANデータベース コンフィギュレーション モードを使用して、イーサネットVLAN 20を作成し、 test20 という名前を付け、VLANデータベースに追加する例を示します。

Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
APPLY completed.
Exiting....
Switch#
 

VLANの削除

VTPサーバ モードのスイッチからVLANを削除すると、VTPドメイン内のすべてのスイッチのVLANデータベースから、そのVLANが削除されます。VTPトランスペアレント モードのスイッチからVLANを削除した場合、そのスイッチに限ってVLANが削除されます。

メディア タイプが異なるデフォルトのVLANを削除することはできません。たとえば、イーサネットVLAN 1、およびFDDIまたはトークンリングVLANの1002~1005を削除することはできません。


注意 VLANを削除すると、そのVLANに割り当てられていたすべてのポートが非アクティブになります。これらのポートは、新しいVLANに割り当てられるまで、元のVLANに(非アクティブで)対応付けられたままです。

グローバル コンフィギュレーション モードを使用してスイッチ上でVLANを削除するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no vlan vlan-id

VLAN IDを入力して、VLANを削除します。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show vlan brief

VLANが削除されたことを確認します。

ステップ 5

copy running-config startup config

(任意)スイッチがVTPトラスペアレント モードである場合、VLAN設定は実行コンフィギュレーション ファイルとVLANデータベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLANデータベース コンフィギュレーション モードでVLANを削除するには、 vlan database イネーブルEXECコマンド使用して、VLANデータベース コンフィギュレーション モードを開始してから、 no vlan vlan-id VLANコンフィギュレーション コマンドを実行します。

VLANへのスタティック アクセス ポートの割り当て

VTPをディセーブルにしてVTPによりVLAN設定情報をグローバルに伝播せずに(VTPトランスペアレント モード)、スタティック アクセス ポートをVLANに割り当てることができます。クラスタ メンバー スイッチのポートをVLANに割り当てる場合、最初に rcommand イネーブルEXECコマンドを使用して、そのメンバー スイッチにログインします。


) 存在しないVLANにインターフェイスを割り当てると、新しいVLANが作成されます(イーサネットVLANの作成または変更を参照)。


VLANデータベース内のVLANにポートを割り当てるには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

VLANに追加するインターフェイスを入力します。

ステップ 3

switchport mode access

ポート(レイヤ2アクセス ポート)のVLANメンバーシップ モードを定義します。

ステップ 4

switchport access vlan vlan-id

VLANにポートを割り当てます。有効なVLAN IDは1~4094です。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show running-config interface interface-id

インターフェイスのVLANメンバーシップ モードを確認します。

ステップ 7

show interfaces interface-id switchport

表示された Administrative Mode および Access Mode VLAN フィールドの設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 default interfac e interface-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、ポートをVLAN 2のアクセス ポートとして設定する方法を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end
Switch#

拡張範囲VLANの設定

スイッチがVTPトランスペアレント モード(VTPがディセーブル)で、EIがインストールされている場合、拡張範囲VLAN(VLAN IDを許可するあらゆるスイッチ ポート コマンド向けに1006~4094)を作成できます。config-vlanモードにアクセスし、拡張範囲VLANを設定するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを入力します。VLANデータベース コンフィギュレーション モード(開始するには vlan database イネーブルEXECコマンドを入力)では、拡張範囲はサポートされていません。

拡張範囲VLANの設定はVLANデータベースには格納されません。ただし、VTPモードがトランスペアレントであるため、スイッチの実行コンフィギュレーション ファイルに格納されます。 copy running-config startup-config イネーブルEXECコマンドを使用すると、スタートアップ コンフィギュレーション ファイルに設定を保存できます。


) スイッチは4094のVLAN IDをサポートしますが、実際のサポート対象VLAN番号については、「サポートされるVLAN」を参照してください。


ここでは、拡張範囲VLANに関する次の情報を示します。

「VLANのデフォルト設定」

「拡張範囲VLAN設定時の注意事項」

「拡張範囲VLANの作成」

「VLANの表示」

VLANのデフォルト設定

イーサネットVLANのデフォルト設定については、表16-2を参照してください。拡張範囲VLANではMTUサイズのみを変更できます。その他のすべての特性はデフォルト ステートのまま残してください。

拡張範囲VLAN設定時の注意事項

拡張範囲VLANを作成するときは次の注意事項に従ってください。

拡張範囲VLANを追加するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを使用して、config-vlanモードを開始する必要があります。VLANデータベース コンフィギュレーション モード(開始するには vlan database イネーブルEXECコマンドを入力)では、拡張範囲VLANを追加できません。

拡張範囲のVLAN IDは、VLANデータベースに保存されず、VTPで認識されません。

プルーニング適格範囲に拡張範囲VLANを含めることはできません。

拡張範囲VLANを作成するときは、スイッチをVTPトランスペアレント モードにする必要があります。VTPモードがサーバまたはクライアントの場合、エラー メッセージが生成され、拡張範囲VLANが拒否されます。

グローバル コンフィギュレーション モードまたはVLANデータベース コンフィギュレーション モードで、VTPモードをトランスペアレントに設定できます。「VTPのディセーブル化(VTPトランスペアレント モード)」を参照してください。VTPトランスペアレント モードでスイッチが起動するように、この設定をスタートアップ コンフィギュレーションに保存する必要があります。このようにしないと、スイッチをリセットした場合に、拡張範囲VLAN設定が失われます。

拡張範囲VLANは、VLAN Query Protocol(VQP)ではサポートされていません。拡張範囲VLANはVMPSでは設定できません。

拡張範囲VLANでは、STPはデフォルトでイネーブルになりますが、no spanning-tree vlan vlan-idグローバル コンフィギュレーション コマンドを使用してディセーブルにできます。スイッチに存在するスパニングツリー インスタンス数が最大(64)である場合に、VLANを新規作成すると、このVLAN上でスパニングツリーはディセーブルになります。スイッチのVLAN数がスパニングツリー インスタンスの最大数を超える場合は、スイッチ上でIEEE 802.1s MSTPを設定して、複数のVLANを1つのSTPインスタンスに対応付けることを推奨します。MSTPの詳細については、「MSTPの設定」を参照してください。

拡張範囲VLANの作成

グローバル コンフィギュレーション モードで拡張範囲VLANを作成するには、 vlan グローバル コンフィギュレーション コマンドを入力し、1006~4094のVLAN IDを指定します。このコマンドによってconfig-vlanモードが開始されます。拡張範囲VLANはデフォルトのイーサネットVLAN特性( 表16-2 を参照)を持ち、変更できるパラメータはMTUサイズだけです。すべてのパラメータのデフォルト値についてはコマンド リファレンスに記載された vlan グローバル コンフィギュレーション コマンドの説明を参照してください。スイッチがVTPトランスペアレント モードでない場合に拡張範囲VLAN IDを入力すると、config-vlanモードの終了時にエラー メッセージが生成され、拡張範囲VLANが作成されません。

拡張範囲VLANはVLANデータベースに保存されずに、スイッチの実行コンフィギュレーション ファイルに保存されます。拡張範囲VLAN設定をスイッチのスタートアップ コンフィギュレーション ファイルに保存するには、 copy running-config startup-config イネーブルEXECコマンドを使用します。

拡張範囲VLANを作成するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp mode transparent

スイッチをVTPトランスペアレント モードに設定し、VTPをディセーブルにします。

ステップ 3

vlan vlan-id

拡張範囲VLAN IDを入力して、config-vlanモードを開始します。指定できる範囲は1006~4094です。

ステップ 4

mtu mtu-size

(任意)MTUサイズを変更して、VLANを変更します。


) config-vlanモードのCLIヘルプにはすべてのコマンドが表示されますが、拡張範囲VLANでサポートされているのはmtu mtu-sizeコマンドだけです。


ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show vlan id vlan-id

VLANが作成されたことを確認します。

ステップ 7

copy running-config startup config

スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。拡張範囲VLAN設定を保存するには、VTPトランスペアレント モード設定および拡張範囲VLAN設定をスイッチのスタートアップ コンフィギュレーション ファイルに保存する必要があります。これらを保存しないと、スイッチをリセットした場合に、スイッチがデフォルトでVTPサーバ モードになり、拡張範囲VLAN IDは保存されません。

拡張範囲VLANを削除するには、 no vlan vlan-id グローバル コンフィギュレーション コマンドを使用します。

スタティック アクセス ポートを拡張範囲VLANに割り当てる手順は、標準範囲VLANの手順と同じです。「VLANへのスタティック アクセス ポートの割り当て」を参照してください。

次に、(EIがインストールされている場合に)すべての特性がデフォルトである拡張範囲VLANを新規作成し、config-vlanモードを開始して、新規VLANをスイッチのスタートアップ コンフィギュレーション ファイルに保存する例を示します。

Switch(config)# vtp mode transparent
Switch(config)# vlan 2000
Switch(config-vlan)# end
Switch# copy running-config startup config

VLANの表示

拡張範囲VLANを含めてスイッチ上のすべてのVLANのリストを表示するには、 show vlan イネーブルEXECコマンドを使用します。VLANステータス、ポート、および設定情報も表示されます。VLANデータベース内の標準範囲VLAN(1~1005)を表示するには、 show VLANコンフィギュレーション コマンド(開始するには vlan database イネーブルEXECコマンドを入力)を使用します。スイッチのVLAN IDのリストを表示するには、 show running-config vlan イネーブルEXECコマンドを使用します。オプションとして、VLAN ID範囲を入力することもできます。

表16-3 にVLANをモニタするためのコマンドを示します。

 

表16-3 VLANモニタ コマンド

コマンド
コマンド モード
目的

show

VLAN設定

VLANデータベース内のVLANのステータスを表示します。

show current [ vlan-id ]

VLAN設定

VLANデータベース内のすべてのVLANまたは特定のVLANのステータスを表示します。

show interfaces [ vlan vlan-id ]

イネーブルEXEC

スイッチに設定されたすべてのインターフェイスまたは特定のVLANの特性を表示します。

show running-config vlan

イネーブルEXEC

スイッチのすべてのVLANまたは特定の範囲のVLANを表示します。

show vlan [ id vlan-id ]

イネーブルEXEC

スイッチのすべてのVLANまたは特定のVLANのパラメータを表示します。

showコマンド オプションおよび出力フィールドの詳細については、このリリースに対応するコマンド リファレンスを参照してください。

VLANトランクの設定

ここでは、スイッチのVLANトランク機能について説明します。

「トランキングの概要」

「IEEE 802.1Qの設定に関する考慮事項」

「レイヤ2イーサネット インターフェイスVLANのデフォルト設定」

トランキングの概要

トランクとは、1つまたは複数のイーサネット スイッチ インターフェイスと他のネットワーキング装置(ルータ、スイッチなど)の間のポイントツーポイント リンクです。ファスト イーサネットおよびギガビット イーサネット トランクは単一リンクを介して複数のVLANトラフィックを伝送できるため、VLANをネットワーク全体に拡張できます。

スイッチは、IEEE 802.1Qの業界標準トランキング カプセル化をサポートしています。

図16-2に、IEEE 802.1Qトランクで接続されているスイッチ ネットワークを示します。

図16-2 IEEE 802.1Qトランキング環境のスイッチ

 

トランクを設定できるのは、1つのイーサネット インターフェイスまたはEtherChannelバンドルに対してです。EtherChannelの詳細については、「EtherChannelの設定」を参照してください。

イーサネット トランク インターフェイスは、 表16-4 に示すトランキング モードをサポートしています。インターフェイスをトランキングまたは非トランキングとして設定したり、近接インターフェイスとトランキングをネゴシエーションするように設定できます。トランキングを自動ネゴシエーションするには、インターフェイスが同じVTPドメインに存在する必要があります。

トランク ネゴシエーションは、PPP(ポイントツーポイント プロトコル)であるDynamic Trunking Protocol(DTP)によって管理されます。ただし、一部のインターネットワーキング装置によってDTPフレームが不正に転送されて、矛盾した設定となる場合があります。

これを避けるには、DTPをサポートしない装置に接続されたインターフェイスがDTPフレームを転送しないように、つまりDTPをオフにするように設定する必要があります。

これらのリンクを介してトランキングを行わない場合は、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、トランキングをディセーブルにします。

DTPをサポートしていない装置へのトランキングをイネーブルにするには、 switchport mode trunk および switchport nonegotiate インターフェイス コンフィギュレーション コマンドを使用して、インターフェイスがトランクになってもDTPフレームを生成しないように設定します。

GigaStack GBICでは、ダイナミック トランキングは、2つのスイッチが1つのGigaStack GBICリンクに接続されている場合のみサポートされます。スタック内の3つ以上のスイッチがGigaStack GBICリンクによって接続されているときにトランキングが必要な場合、次の方法で手動でとランキングを設定する必要があります。

shutdown インターフェイス コンフィギュレーション コマンドを使用して、GigaStackポートを手動でシャットダウンします。

両方のGBICインターフェイスで switchport mode trunk インターフェイス コンフィギュレーション コマンドを使用してGigaStackポートでトランク モードを手動で設定し、インターフェイスをトランクにします。

GigaStackポートを再起動するには、 no shutdown インターフェイス コンフィギュレーション コマンドを使用します。

 

表16-4 レイヤ2インターフェイス モード

モード
機能

switchport mode access

インターフェイス(アクセス ポート)を永続的な非トランキング モードにします。インターフェイスは、近接インターフェイスがトランク インターフェイスの場合にも、非トランク インターフェイスになります。

switchport mode dynamic desirable

インターフェイスがリンクのトランク リンクへの変換をアクティブに実行するようにします。インターフェイスは、近接インターフェイスが trunk desirable 、または auto モードに設定されている場合、トランク インターフェイスになります。すべてのイーサネット インターフェイスのデフォルトのスイッチポート モードは dynamic desirable です。

switchport mode dynamic auto

インターフェイスがリンクをトランク リンクに変換できるようにします。インターフェイスは、近接インターフェイスが trunk または desirable モードに設定されている場合、トランク インターフェイスになります。

switchport mode trunk

インターフェイスを永続的なトランキング モードにして、リンクのトランク リンクへの変換をネゴシエートします。インターフェイスは、近接インターフェイスがトランク インターフェイスでない場合にも、トランク インターフェイスになります。

switchport nonegotiate

インターフェイスがDTPフレームを生成しないようにします。このコマンドは、インターフェイス スイッチポート モードが access または trunk の場合だけ使用できます。トランク リンクを確立するには、手動で近接インターフェイスをトランク インターフェイスとして設定する必要があります。

IEEE 802.1Qの設定に関する考慮事項

IEEE 802.1Qトランクは、ネットワークに次の制限を課します。

IEEE 802.1Qトランクを使用して接続しているシスコ スイッチ ネットワークでは、トランク上で許容されるVLANごとに1つのスパニングツリー インスタンスを維持します。他社製の装置は、すべてのVLANでスパニングツリー インスタンスを1つサポートしています。

IEEE 802.1Qトランクを介してシスコ製スイッチを他社製の装置に接続する場合、シスコ製スイッチは、トランクのVLANのスパニングツリー インスタンスを、他社製のIEEE 802.1Qスイッチのスパニングツリー インスタンスと統合します。ただし、各VLANのスパニングツリー情報は、他社製のIEEE 802.1Qスイッチからなるクラウドにより切り離されたシスコ製スイッチによって維持されます。シスコ製スイッチを隔てる他社製のIEEE 802.1Qクラウドは、スイッチ間の単一トランク リンクとして扱われます。

IEEE 802.1Qトランクに対応するネイティブVLANが、トランク リンクの両側で一致していなければなりません。トランクの片側のネイティブVLANと反対側のネイティブVLANが異なっていると、スパニングツリー ループが発生する可能性があります。

ネットワーク上のすべてのネイティブVLANについてスパニングツリーをディセーブルにせずに、IEEE 802.1QトランクのネイティブVLAN上のスパニングツリーをディセーブルにすると、スパニングツリー ループが発生することがあります。IEEE 802.1QトランクのネイティブVLAN上でスパニングツリーをイネーブルのままにしておくか、またはネットワーク上のすべてのVLANでスパニングツリーをディセーブルにすることを推奨します。また、ネットワークにループがないことを確認してから、スパニングツリーをディセーブルにしてください。

レイヤ2イーサネット インターフェイスVLANのデフォルト設定

表16-5 に、レイヤ2イーサネット インターフェイスVLANのデフォルト設定を示します。

 

表16-5 レイヤ2イーサネット インターフェイスVLANのデフォルト設定

機能
デフォルト値

インターフェイス モード

switchport mode dynamic desirable

VLAN許容範囲

VLAN 1~4094

プルーニングに適格なVLAN範囲

VLAN 2~1001

デフォルトVLAN(アクセス ポート用)

VLAN 1

ネイティブVLAN(IEEE 802.1Qトランク用)

VLAN 1

トランク ポートとしてのイーサネット インターフェイスの設定

トランク ポートはVTPアドバタイズを送受信するので、VTPを使用するには、スイッチで少なくとも1つのトランク ポートが設定されており、そのトランク ポートが2番めのスイッチのトランク ポートに接続されていることを確認する必要があります。そうでない場合、スイッチはVTPアドバタイズを受信できません。

ここでは、スイッチ上でイーサネット インターフェイスをトランク ポートとして設定する手順を示します。

「他の機能との相互作用」

「トランクでの許可VLANの定義」

「プルーニング適格リストの変更」

「タグなしトラフィック用ネイティブVLANの設定」


) レイヤ2インターフェイスのデフォルト モードは、switchport mode dynamic desirableインターフェイス コンフィギュレーション モードです。近接インターフェイスがトランキングをサポートしており、トランキングを許可する設定になっている場合、リンクはレイヤ2トランクになります。


他の機能との相互作用

トランキングは他の機能と次のように相互作用します。

トランク ポートをセキュア ポートにすることはできません。

トランク ポートをまとめてEtherChannelポート グループにすることはできますが、グループ内のすべてのトランクに同じ設定をする必要があります。グループを初めて作成したときには、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。次のパラメータのいずれかについて設定を変更すると、入力した設定値がスイッチによってグループ内の全ポートに伝播されます。

許可VLANリスト

各VLANのSTPポート プライオリティ

STP PortFastの設定値

トランク ステータス(ポート グループ内のいずれかのポートがトランクでなくなると、すべてのポートがトランクでなくなります。)

トランク ポートでIEEE 802.1xをイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1xはイネーブルになりません。IEEE 802.1x対応ポートをトランクに変更しようとしても、ポート モードは変更されません。

ダイナミック モードのポートは、ネイバとトランク ポートへの変更をネゴシエートする場合があります。ダイナミック ポートでIEEE 802.1xをイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1xはイネーブルになりません。IEEE 802.1x対応ポートをダイナミック ポートに変更しようとしても、ポート モードは変更されません。

保護ポートは、IEEE 802.1Qトランクでサポートされています。

トランク ポートの設定

ポートをIEEE 802.1Qトランク ポートとして設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トランキング用に設定するポートを入力します。

ステップ 3

switchport mode { dynamic { auto | desirable } | trunk }

インターフェイスをレイヤ2トランクとして設定します(インターフェイスがレイヤ2アクセス ポートである場合、またはトランキング モードを指定する場合に限り、必須です)。

dynamic auto ― 近接インターフェイスがtrunkまたはdesirableモードに設定されている場合に、インターフェイスをトランク リンクとして設定します。

dynamic desirable ― 近接インターフェイスがtrunk、desirable、またはautoモードに設定されている場合に、インターフェイスをトランク リンクとして設定します。

trunk ― 近接インターフェイスがトランク インターフェイスでない場合でも、インターフェイスを永続的なトランキング モードに設定して、リンクをトランク リンクに変換するようにネゴシエートします。

ステップ 4

switchport access vlan vlan-id

(任意)インターフェイスがトランキングを停止した場合に使用するデフォルトVLANを指定します。

ステップ 5

switchport trunk native vlan vlan-id

ネイティブVLANを指定します。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show interfaces interface-id switchport

インターフェイスのスイッチポート設定を表示します。
Administrative Mode および Administrative Trunking Encapsulation フィールドに表示されます。

ステップ 8

show interfaces interface-id trunk

インターフェイスのトランク設定を表示します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。トランキング インターフェイスのすべてのトランキング特性をデフォルトにリセットするには、 no switchport trunk インターフェイス コンフィギュレーション コマンドを使用します。トランキングをディセーブルにするには、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、ポートをスタティック アクセス ポートとして設定します。

次に、ポートをIEEE 802.1Qトランクとして設定する方法を示します。この例では、近接インターフェイスがIEEE 802.1Qトランキングをサポートするように設定されていることを前提としています。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# switchport mode dynamic desirable
Switch(config-if)# end
 

トランクでの許可VLANの定義

デフォルトでは、トランク ポートはすべてのVLANに対してトラフィックを送受信します。各トランクでは、すべてのVLAN IDが許可されます。しかし、許可リストからVLANを削除することにより、それらのVLANからのトラフィックがトランク上を流れないようにすることができます。トランクが伝送するトラフィックを制限するには、 switchport trunk allowed vlan remove vlan-list インターフェイス コンフィギュレーション コマンドを使用して、許可リストから特定のVLANを削除します。

スパニングツリー ループまたはストームのリスクを削減するには、許可リストからVLAN 1を削除し、個々のVLANトランク ポートのVLAN 1をディセーブルにします。これは、VLAN 1最小化と呼ばれています。VLAN 1最小化は、個々のVLANトランク リンクのVLAN 1(すべてのシスコ製スイッチのトランク ポートにおけるデフォルトVLAN)をディセーブルにします。その結果、スパニングツリー アドバタイズを含むユーザ トラフィックはVLAN 1では送受信されません。

トランク ポートからVLAN 1を削除しても、インターフェイスは引き続きVLAN 1で、Cisco Discovery Protocol(CDP)、Port Aggregation Protocol(PAgP)、Link Aggregation Control Protocol(LACP)、Dynamic Trunking Protocol(DTP)、VLAN Trunking Protocol(VTP)などの管理トラフィックを送受信します。

VLAN 1がディセーブルなトランク ポートが非トランク ポートに変更されると、それはアクセスVLANに追加されます。アクセスVLANが1に設定されると、ポートは switchport trunk allowed の設定値に関係なくVLAN 1に追加されます。ポート上でディセーブルなどのVLANにも同じことが当てはまります。

トランク ポートは、VLANがイネーブルになっており、VTPがVLANを認識し、かつポートの許可リストにそのVLANが登録されている場合に、VLANのメンバーになることができます。VTPが新しくイネーブルにされたVLANを認識し、そのVLANがトランク ポートの許可リストに登録されている場合、トランク ポートは自動的にそのVLANのメンバーになります。VTPが新しいVLANを認識し、そのVLANがトランク ポートの許可リストに登録されていない場合には、トランク ポートはそのVLANのメンバーにはなりません。

IEEE 802.1Qトランクの許可リストを変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、設定するポートを入力します。

ステップ 3

switchport mode trunk

インターフェイスをVLANトランク ポートとして設定します。

ステップ 4

switchport trunk allowed vlan { add | all | except | remove } vlan-list

(任意)トランク上で許可されるVLANのリストを設定します。

add all except 、および remove キーワードの使用方法については、このリリースに対応するコマンド リファレンスを参照してください。

vlan-list パラメータは、1~4094の単一のVLAN番号か、または2つのVLAN番号で記述される1つのVLAN範囲(最初に小さい番号、ハイフンで区切られる)かのいずれかになります。コンマで区切ったVLANパラメータの間、またはハイフンで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべてのVLANが許可されます。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Trunking VLANs Enabled フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべてのVLANの許可VLANリストをデフォルトに戻すには、 no switchport trunk allowed vlan インターフェイス コンフィギュレーション コマンドを使用します。

次に許可VLANリストからVLAN 2を削除する例を示します。

Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end
Switch#

プルーニング適格リストの変更

プルーニング適格リストは、トランク ポートだけに適用されます。トランク ポートごとに独自の適格リストがあります。この手順を有効にするには、VTPプルーニングがイネーブルに設定されている必要があります。VTPプルーニングをイネーブルにする方法については、「VTPプルーニングのイネーブル化」を参照してください。

トランク ポートのプルーニング適格リストからVLANを削除するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、VLANプルーニングを適用するトランク ポートを選択します。

ステップ 3

switchport trunk pruning vlan { add | except | none | remove } vlan-list [ ,vlan [ ,vlan [ ,,, ]]

トランクからのプルーニングを許可するVLANのリストを設定します( VTPプルーニングを参照)。

add except none 、および remove キーワードの使用方法については、このリリースに対応するコマンド リファレンスを参照してください。

連続していないVLAN IDは、カンマ(スペースなし)で区切ります。IDの範囲は、ハイフンで表します。指定できるIDは、2~1001です。 拡張範囲VLAN(VLAN IDが1006~4094)はプルーニングできません。

プルーニング不適格のVLANは、フラッディング トラフィックを受信します。

デフォルトでは、プルーニングが許可されるVLANのリストには、VLAN 2~1001が含まれます。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show interfaces interface-id switchport

表示された Pruning VLANs Enabled フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべてのVLANのプルーニング適格リストをデフォルトに戻すには、 no switchport trunk pruning vlan インターフェイス コンフィギュレーション コマンドを使用します。

タグなしトラフィック用ネイティブVLANの設定

IEEE 802.1Qタギングが設定されたトランク ポートは、タグ付きトラフィックおよびタグなしトラフィックの両方を受信できます。デフォルトでは、タグなしトラフィックは、ポートに設定されたネイティブVLANに転送されます。ネイティブVLANは、デフォルトではVLAN 1です。


) ネイティブVLANは、管理VLANとは関係なく、任意のVLAN IDを割り当てることができます。


IEEE 802.1Q設定についての詳細は、「IEEE 802.1Qの設定に関する考慮事項」を参照してください。

IEEE 802.1QトランクでネイティブVLANを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、IEEE 802.1Qトランクとして設定するインターフェイスを定義します。

ステップ 3

switchport trunk native vlan vlan-id

トランク ポートでタグなしトラフィックを送受信するVLANを設定します。

vlan-id に指定できる範囲は1~4094です。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show interfaces interface-id switchport

Trunking Native Mode VLAN フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ネイティブVLANをデフォルト(VLAN 1)に戻すには、 no switchport trunk native vlan インターフェイス コンフィギュレーション コマンドを使用します。

パケットのVLAN IDが出力ポートのネイティブVLAN IDと同じであれば、そのパケットはタグなしで送信されます。ネイティブVLAN IDと異なる場合は、スイッチはそのパケットをタグ付きで送信します。

STPによる負荷分散

負荷分散により、スイッチに接続しているパラレル トランクの提供する帯域幅が分割されます。STPは通常、ループを防止するために、スイッチ間で1つのパラレル リンク以外のすべてのリンクをブロックします。負荷分散を行うと、トラフィックの所属するVLANに基づいて、リンク間でトラフィックが分散されます。

トランク ポートで負荷分散を設定するには、STPポート プライオリティまたはSTPパス コストを使用します。STPポート プライオリティを使用して負荷分散を設定する場合には、両方の負荷分散リンクを同じスイッチに接続する必要があります。STPパス コストを使用して負荷分散を設定する場合には、それぞれの負荷分散リンクを同一のスイッチにも、2台の異なるスイッチにも接続できます。STPの詳細については、「STPの設定」を参照してください。

STPポート プライオリティによる負荷分散

同一スイッチの2つのポートがループを形成すると、イネーブルになるポートとブロッキング ステートになるポートは、STPポート プライオリティの設定によって決まります。パラレル トランク ポートにプライオリティを設定することにより、そのポートに、特定のVLANのすべてのトラフィックを伝送させることができます。VLANに対するプライオリティの高い(値の小さい)トランク ポートがそのVLANのトラフィックを転送します。同じVLANに対してプライオリティの低い(値の大きい)トランク ポートは、そのVLANに対してブロッキング ステートのままです。1つのトランク ポートが特定のVLANに関するすべてのトラフィックを送受信することになります。

図16-3に、サポート対象スイッチを接続する2つのトランクを示します。この例では、スイッチは次のように設定されています。

VLAN 8~10は、トランク1で16というポート プライオリティが与えられています。

VLAN 3~6は、トランク1でデフォルトのポート プライオリティである128のままです。

VLAN 3~6は、トランク2で16というポート プライオリティが与えられています。

VLAN 8~10は、トランク2でデフォルトのポート プライオリティである128のままです。

このように設定すると、トランク1がVLAN 8~10のトラフィックを伝送し、トランク2がVLAN 3~6のトラフィックを伝送します。アクティブ トランクで障害が起きた場合には、プライオリティの低いトランクが引き継ぎ、それらすべてのVLANのトラフィックを伝送します。いずれのトランク ポートでも、トラフィックの重複は発生しません。

図16-3 STPポート プライオリティによる負荷分散

 

図16-3に示すように、ネットワークを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

スイッチ1で、グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp domain domain-name

VTP管理ドメインを設定します。

1~32文字のドメイン名を使用できます。

ステップ 3

vtp mode server

スイッチ1をVTPサーバとして設定します。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show vtp status

スイッチAおよびスイッチBの両方で、VTP設定を確認します。

表示された VTP Operating Mode および VTP Domain Name フィールドをチェックします。

ステップ 6

show vlan

スイッチAのデータベースにVLANが存在していることを確認します。

ステップ 7

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 8

interface fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、トランクとして設定されるインターフェイスとしてポートFastEthernet 0/1を定義します。

ステップ 9

switchport mode trunk

ポートをトランク ポートとして設定します。

ステップ 10

end

イネーブルEXECモードに戻ります。

ステップ 11

show interfaces fastethernet 0/1switchport

VLANの設定を確認します。

ステップ 12

スイッチAのポートFastEthernet 0/2についてステップ7~ステップ11を繰り返します。

ステップ 13

スイッチBでステップ7~ステップ11を繰り返し、ポートFastEthernet 0/1および0/2のトランク ポートを設定します。

ステップ 14

show vlan

トランク リンクがアクティブになると、VTPがスイッチBにVTPおよびVLAN情報を渡します。スイッチBがVLAN設定を学習していることを確認します。

ステップ 15

configure terminal

スイッチAで、グローバル コンフィギュレーション モードを開始します。

ステップ 16

interface fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、STPポート プライオリティを設定するインターフェイスを定義します。

ステップ 17

spanning-tree vlan 8-10 port-priority 16

VLAN 8~10にポート プライオリティ16を割り当てます。

ステップ 18

spanning-tree vlan 10 port-priority 16

VLAN 10にポート プライオリティ10を割り当てます。

ステップ 19

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 20

interface fastethernet 0/2

インターフェイス コンフィギュレーション モードを開始し、STPポート プライオリティを設定するインターフェイスを定義します。

ステップ 21

spanning-tree vlan 3-6 port-priority 16

VLAN 3~6にポート プライオリティ16を割り当てます。

ステップ 22

end

イネーブルEXECモードに戻ります。

ステップ 23

show running-config

設定を確認します。

ステップ 24

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

STPパス コストによる負荷分散

トランクに異なるパス コストを設定し、各パス コストを異なるVLAN群に対応付けることにより、VLANトラフィックを分担するようにパラレル トランクを設定できます。VLANはトラフィックを個別に維持します。ループが発生しないので、STPによってポートがディセーブルになることもなく、またリンクが切断されても冗長性が維持されます。

図16-4で、トランク ポート1および2は100BASE-Tポートです。VLANのパス コストは次のように設定されています。

VLAN 2~4には、トランク ポート1で30というパス コストが割り当てられています。

VLAN 8~10は、トランク ポート1で100BASE-Tのデフォルトのパス コストである19のままになっています。

VLAN 8~10には、トランク ポート2で30というパス コストが割り当てられています。

VLAN 2~4は、トランク ポート2で100BASE-Tのデフォルトのパス コストである19のままになっています。

図16-4 パス コストによってトラフィックが分散される負荷分散トランク

 

図16-4に示すように、ネットワークを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

スイッチAで、グローバル コンフィギュレーション モードを開始します。

ステップ 2

interfa c e fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、トランクとして設定されるインターフェイスとしてポートFastEthernet 0/1を定義します。

ステップ 3

switchport mode trunk

ポートをトランク ポートとして設定します。

ステップ 4

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 5

スイッチAでインターフェイスFastEthernet 0/2についてステップ2~4を繰り返します。

ステップ 6

end

イネーブルEXECモードに戻ります。

ステップ 7

show running-config

設定を確認します。

表示されたインターフェイスFastEthernet 0/1およびFastEthernet 0/2がトランク ポートとして設定されていることを確認します。

ステップ 8

show vlan

トランク リンクがアクティブになると、スイッチAが他のスイッチから送られたVTP情報を受信します。スイッチAがVLAN設定を学習していることを確認します。

ステップ 9

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 10

interface fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、STPコストを設定するインターフェイスとしてポートFastEthernet 0/1を定義します。

ステップ 11

spanning-tree vlan 2-4 cost 30

VLAN 2~4についてスパニングツリー パス コストを30に設定します。

ステップ 12

end

グローバル コンフィギュレーション モードに戻ります。

ステップ 13

スイッチAでインターフェイスFastEthernet 0/2についてステップ9~ステップ11を繰り返し、VLAN 8、9、および10について、スパニングツリー パス コストを30に設定します。

ステップ 14

exit

イネーブルEXECモードに戻ります。

ステップ 15

show running-config

設定を確認します。

表示されたインターフェイスFastEthernet 0/1およびFastEthernet 0/2にパス コストが正しく設定されていることを確認します。

ステップ 16

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VMPSの設定

このスイッチをVMPSサーバにすることはできませんが、VMPSのクライアントとして機能させ、VQPを介して通信できます。VMPSはダイナミック アクセス ポートVLANメンバーシップを動的に割り当てます。ここでは、VMPSの設定に関する次の情報について説明します。

「VMPSの概要」

「VMPSクライアントのデフォルト設定」

「VMPS設定時の注意事項」

「VMPSクライアントの設定」

「VMPSのモニタ」

「ダイナミック ポートVLANメンバーシップのトラブルシューティング」

「VMPSの設定例」

VMPSの概要

VMPSがクライアント スイッチからVQP要求を受信すると、VMPSはデータベースを検索してMAC(メディア アクセス制御)アドレスとVLANのマッピングを調べます。サーバの応答は、このマッピングと、サーバがセキュア モードであるかどうかに基づいて行われます。VLANがポートで許可されない場合にサーバがそのポートをシャットダウンするか、または単にVLANへのポート アクセスを拒否するかはセキュア モードによって決定されます。

VMPSは要求に対する応答として、次のいずれかの動作を実行します。

割り当てられたVLANがポートのグループに制限されている場合、VMPSは要求側のポートをこのグループと照らし合わせて確認し、次のように応答します。

そのポートでVLANが許可されている場合、VMPSは応答でVLAN名をクライアントに送信します。

そのポートでVLANが許可されておらず、なおかつVMPSがセキュア モードでない場合、VMPSは アクセス拒否 応答を送信します。

そのポートでVLANが許可されておらず、なおかつVMPSがセキュア モードである場合、VMPSは ポート シャットダウン 応答を送信します。

データベース内のVLANがポート上の現在のVLANと一致せず、なおかつポートにアクティブ ホストが存在する場合、VMPSはVMPSのセキュア モードに応じて、 アクセス拒否 または ポート シャットダウン 応答を送信します。

VMPSから アクセス拒否 応答を受信した場合、スイッチはそのMACアドレスまたはポートからのトラフィックを引き続きブロックします。スイッチはポート宛のパケットを引き続きモニタし、新しいアドレスを検出するとVMPSにクエリを送信します。VMPSから ポート シャットダウン 応答を受信した場合、スイッチはそのポートをディセーブルにします。デバイス マネージャ、CLI(コマンドライン インターフェイス)、Network Assistant、またはSNMP(簡易ネットワーク管理プロトコル)を使用して、ポートを手動で再度イネーブルにする必要があります。

また、コンフィギュレーション テーブルの明示的なエントリを使用して、特定のMACアドレスへのアクセスを、セキュリティ上の理由から拒否することもできます。VLAN名に none キーワードを入力すると、VMPSセキュア モード設定に応じて、VMPSは アクセス拒否 または ポート シャットダウン 応答を送信します。

ダイナミック ポートVLANメンバーシップ

スイッチのダイナミック(非トランキング)ポートが所属できるのは、VLAN IDが1~1005の1つのVLANだけです。リンクがアップになっても、VMPSによってVLANが割り当てられるまで、このポートとの間でトラフィック転送は行われません。VMPSは、ダイナミック ポートに接続した新しいホストの最初のパケットから送信元MACアドレスを受信し、VMPSデータベースによってそのMACアドレスとVLANとのマッチングを試みます。

一致するVLANが存在すれば、VMPSはそのポートのVLAN番号を送信します。クライアント スイッチがまだ設定されていない場合は、スイッチはVMPSからトランク ポートで受信した最初のVTPパケットからのドメイン名を使用します。クライアント スイッチがすでに設定されている場合は、クエリ パケットにスイッチのドメイン名を含めてVMPSに送信し、VLAN番号を取得します。VMPSはパケット内のドメイン名が自身のドメイン名と一致することを確認したあと、要求を受け入れ、クライアントに割り当てられたVLAN番号を応答します。一致するVLANが存在しなければ、(VMPSセキュア モードの設定に応じて)VMPSは要求を拒否するか、またはポートをシャットダウンします。

ダイナミック ポートで複数のホスト(MACアドレス)をアクティブにできますが、それらのホストはすべて同じVLANに存在する必要があります。ただし、ポートでアクティブなホスト数が20を超えると、VMPSはダイナミック ポートをシャットダウンします。

ダイナミック ポートでリンクがダウンすると、ポートは隔離されたステートに戻り、VLANには所属しません。ポート経由でオンラインになるホストはVMPSによってVQP経由で再チェックされ、そのあとポートがVLANに割り当てられます。

VMPSデータベース コンフィギュレーション ファイル

VMPSには、ユーザが作成するデータベース コンフィギュレーション ファイルが含まれています。このASCIIテキスト ファイルは、VMPSのサーバとして動作する、スイッチからアクセス可能なTFTPサーバに保管します。このファイルには、VMPS情報(ドメイン名、代替VLAN名、MACアドレスとVLANのマッピングなど)が指定されています。このスイッチをVMPSとして機能させることはできませんが、Catalyst 5000またはCatalyst 6000シリーズ スイッチをVMPSとして使用できます。

代替VLAN名を設定できます。データベースにないMACアドレスを持つ装置を接続すると、VMPSは代替VLAN名をクライアントに送信します。代替VLAN名を設定せず、なおかつMACアドレスがデータベースに存在しない場合には、VMPSは アクセス拒否 応答を送信します。VMPSがセキュア モードの場合には、 ポート シャットダウン 応答を送信します。

ポート名がVMPSデータベース コンフィギュレーション ファイルで使用されている場合、サーバはスイッチのポート名に関する表記法を使用する必要があります。たとえばFa0/4は、固定ファスト イーサネット ポート4となります。スイッチがクラスタ メンバーの場合、コマンド スイッチはスイッチ タイプより先にスイッチ名を追加します。たとえば、 es3%Fa0/4 は、メンバー スイッチ3の固定ファスト イーサネット ポート4を表します。ポート名が必要なときに、VMPSデータベース コンフィギュレーション ファイルをクラスタ サポート用に設定する場合は、この表記法を使用する必要があります。

VMPSクライアントのデフォルト設定

表16-6 に、クライアント スイッチのVMPSおよびダイナミック ポートのデフォルト設定を示します。

 

表16-6 VMPSクライアントおよびダイナミック ポートのデフォルト設定

機能
デフォルト値

VMPSドメイン サーバ

設定なし

VMPS再確認インターバル

60分

VMPSサーバ再試行回数

3

ダイナミック ポート

設定なし

VMPS設定時の注意事項

ダイナミック アクセス ポートVLANメンバーシップには、次の注意事項および制限事項があります。

VMPSを設定してから、ポートをダイナミックとして設定する必要があります。

スイッチ クラスタとVMPSの間の通信は、コマンド スイッチによって管理され、標準のポート名とは異なるポート名の表記法を使用します。クラスタ ベースのポート名の表記法については、「VMPSデータベース コンフィギュレーション ファイル」を参照してください。

ポートをダイナミック アクセス ポートとして設定すると、そのポートに対してスパニングツリーのPortFast機能が自動的にイネーブルになります。PortFastモードにより、ポートをフォワーディング ステートに設定するプロセスが短縮されます。

IEEE 802.1Xポートをダイナミック アクセス ポートとして設定することはできません。ダイナミック アクセス(VQP)ポートでIEEE 802.1xをイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1xはイネーブルになりません。IEEE 802.1x対応ポートを変更してダイナミックVLANを割り当てようとしても、エラー メッセージが表示され、VLAN設定は変更されません。

トランク ポートをダイナミック アクセス ポートにすることはできませんが、トランク ポートに対して switchport access vlan dynamic インターフェイス コンフィギュレーション コマンドを入力することは可能です。 その場合、スイッチの設定は維持され、あとにアクセス ポートとして設定された場合には、その設定が適用されます。

ダイナミック アクセス設定を有効にするには、事前にポート上でトランキングをオフにする必要があります。

ダイナミック アクセス ポートは、ネットワーク ポートまたはモニタ ポートにすることはできません。

セキュア ポートをダイナミック アクセス ポートにすることはできません。ポートをダイナミックにするには、事前にポートでポート セキュリティをディセーブルにする必要があります。

ダイナミック アクセス ポートをEtherChannelグループのメンバーにすることはできません。

ポート チャネルをダイナミック アクセス ポートとして設定することはできません。

VMPSクライアントとVMPSサーバのVTP管理ドメインは、同じでなければなりません。

VQPは拡張範囲VLAN(1006を超えるVLAN ID)をサポートしていません。拡張範囲VLANをVMPSで設定することはできません。

VMPSサーバ上に設定されたVLANは、音声VLANにしないでください。

VMPSクライアントの設定

ダイナミックVLANを設定するには、VMPS(サーバ)を使用します。スイッチをVMPSクライアントにすることはできますが、VMPSサーバにすることはできません。

VMPSのIPアドレスの入力

スイッチをクライアントとして設定するには、サーバのIPアドレスを最初に入力する必要があります。


) スイッチ クラスタに対してVMPSを定義する場合は、コマンド スイッチにこのアドレスを入力する必要があります。


VMPSのIPアドレスを入力するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps server ipaddress primary

プライマリVMPSサーバとして動作するスイッチのIPアドレスを入力します。

ステップ 3

vmps server ipaddress

セカンダリVMPSサーバとして動作するスイッチのIPアドレスを入力します。

セカンダリ サーバのアドレスは、3つまで入力できます。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show vmps

表示された VMPS domain server フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。


) VMPSサーバに接続されたスイッチ ポートをダイナミック アクセス ポートにすることはできません。このポートは、スタティック アクセス ポートまたはトランク ポートのいずれかにすることができます。「トランク ポートとしてのイーサネット インターフェイスの設定」を参照してください。


VMPSクライアント上のダイナミック アクセス ポートの設定

クラスタ メンバー スイッチのポートをダイナミック ポートとして設定するには、最初に rcommand イネーブルEXECコマンドを使用して、そのメンバー スイッチにログインします。


注意 ダイナミック ポートVLANメンバーシップはエンド ステーション用、またはエンド ステーションに接続されたハブ用です。他のスイッチにダイナミック アクセス ポートを接続すると、接続が切断されることがあります。

VMPSクライアント スイッチにダイナミック アクセス ポートを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、エンド ステーションに接続されたスイッチ ポートを指定します。

ステップ 3

switchport mode access

ポートをアクセス モードにします。

ステップ 4

switchport access vlan dynamic

ポートをダイナミックVLANメンバーシップ適格として設定します。

ダイナミック アクセス ポートは、エンド ステーションに接続されている必要があります。

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Operational Mode フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。インターフェイスをデフォルトのスイッチポート モード(dynamic desirable)に戻すには、 no switchport mode インターフェイス コンフィギュレーション コマンドを使用します。アクセス モードをスイッチのデフォルトVLANにリセットするには、 no switchport access インターフェイス コンフィギュレーション コマンドを使用します。


switchport access vlan dynamicインターフェイス コンフィギュレーション コマンドを使用してダイナミック アクセス ポートを設定する場合、インターフェイスがDTPネゴシエーションを介してアクセス モードからトランク モードに変更されると、不正ユーザによるネットワーク リソースへのアクセスをポートが許可する可能性があります。ポートをスタティック アクセス ポートとして設定することで、これを回避できます。


VLANメンバーシップの再確認

スイッチがVMPSから受信したダイナミック ポートVLANメンバーシップの割り当てを確認するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

vmps reconfirm

ダイナミック ポートVLANメンバーシップを再確認します。

ステップ 2

show vmps

ダイナミックVLANの再確認ステータスを確認します。

再確認インターバルの変更

VMPSクライアントは、VMPSから受信するVLANメンバーシップ情報を定期的に再確認します。再確認が行われる間隔(分)を設定できます。

クラスタのメンバー スイッチを設定する場合、このパラメータはコマンド スイッチの再確認インターバルの設定値以上でなければなりません。メンバー スイッチにログインするには、最初に rcommand イネーブルEXECコマンドを使用する必要があります。

再確認インターバルを変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps reconfirm minutes

ダイナミックVLANメンバーシップの再確認を行う間隔(分)を入力します。

1~120分の数値を入力します。デフォルトは60分です。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show vmps

表示された Reconfirm Interval フィールドのダイナミックVLANの再確認ステータスを確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチのデフォルト設定に戻すには、 no vmps reconfirm グローバル コンフィギュレーション コマンドを使用します。

再試行回数の変更

スイッチが次のサーバにクエリを送信する前に、VMPSとの接続を試行する回数を変更するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps retry count

再試行の回数を変更します。

指定できる再試行回数の範囲は1~10回です。デフォルトは3回です。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show vmps

表示された Server Retry Count フィールドの設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチのデフォルト設定に戻すには、 no vmps retry グローバル コンフィギュレーション コマンドを使用します。

VMPSのモニタ

show vmps イネーブルEXECコマンドを使用して、VMPSに関する情報を表示できます。スイッチはVMPSに関する次の情報を表示します。

 

VMPS VQPバージョン(VMPS VQP Version)

VMPSとの通信に使用するVQPのバージョン。スイッチはVQPバージョン1を使用するVMPSにクエリを送信します。

再確認インターバル(Reconfirm Interval)

スイッチがVLANとMACアドレスの割り当てを再確認する間隔(分)。

サーバ再試行回数(Server Retry Count)

VQPがVMPSにクエリを再送信する回数。この回数すべてを試行しても応答が得られない場合、スイッチはセカンダリVMPSへのクエリを開始します。

VMPSドメイン サーバ

設定されているVLANメンバーシップ ポリシー サーバのIPアドレス。スイッチはcurrentに指定があるサーバにクエリを送信します。primaryと表示されているサーバが、プライマリ サーバです。

VMPS動作(VMPS Action)

最新の再確認の結果。再確認は、再確認インターバルとして設定された時間が経過すると自動的に行われます。また、 vmps reconfirm イネーブルEXECコマンドを入力するか、Network AssistantまたはSNMPの同等のコマンドを使用することによって、強制的に再確認できます。

次に show vmps イネーブルEXECコマンドの出力例を示します。

Switch# show vmps
 
VQP Client Status:
--------------------
VMPS VQP Version: 1
Reconfirm Interval: 60 min
Server Retry Count: 3
VMPS domain server: 172.20.128.86 (primary, current)
172.20.128.87
 
Reconfirmation status
---------------------
VMPS Action: No Dynamic Port
 

ダイナミック ポートVLANメンバーシップのトラブルシューティング

VMPSは次の状況でダイナミック ポートをシャットダウンします。

VMPSがセキュア モードであり、なおかつホストのポートへの接続を許可しない場合。VMPSはポートをシャットダウンして、ホストがネットワークに接続できないようにします。

ダイナミック ポートのアクティブ ホストが20を超えた場合。

ディセーブル化されているダイナミック ポートを再びイネーブルにするには、 no shutdown インターフェイス コンフィギュレーション コマンドを使用します。

VMPSの設定例

図16-5に、VMPSサーバ スイッチと、ダイナミック ポートを備えたVMPSクライアント スイッチを含むネットワークの例を示します。この例の前提条件は次のとおりです。

VMPSサーバとVMPSクライアントは、それぞれ別個のスイッチです。

Catalyst 6500シリーズであるスイッチAが、プライマリVMPSサーバです。

Catalyst 5000シリーズであるスイッチCおよびスイッチJが、セカンダリVMPSサーバです。

エンド ステーションはクライアントであるスイッチBおよびスイッチIに接続されています。

データベース コンフィギュレーション ファイルは、IPアドレス172.20.22.7のTFTPサーバに保管されています。

図16-5 ダイナミック ポートVLANメンバーシップの構成例