Catalyst 2950/2955 スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.1(22)EA5
Smartportマクロの設定
Smartportマクロの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

Smartportマクロの設定

Smartportマクロの概要

Smartportマクロの設定

Smartportマクロのデフォルト設定

Smartportマクロ設定時の注意事項

Smartportマクロの作成

Smartportマクロの適用

シスコのデフォルトSmartportマクロの適用

Smartportマクロの表示

Smartportマクロの設定

この章では、Catalyst 2950スイッチにSmartportマクロを設定し、適用する方法について説明します。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章の内容は、次のとおりです。

「Smartportマクロの概要」

「Smartportマクロの設定」

「Smartportマクロの表示」

Smartportマクロの概要

Smartportマクロは、共通の設定を保存し共有するための便利な方法です。ネットワーク内のスイッチの設置場所に応じて機能および設定をイネーブルにする場合、およびネットワーク全体の設定を行う場合にSmartportマクロを使用できます。

各Smartportマクロは、CLI(コマンドライン インターフェイス)コマンドをまとめて定義したものです。Smartportマクロには新しいCLIコマンドはなく、単に既存のCLIコマンドをまとめたものです。

インターフェイスにSmartportマクロを適用すると、マクロに含まれるCLIコマンドがインターフェイスに設定されます。マクロをインターフェイスに適用しても、既存のインターフェイスの設定は失われません。新しいコマンドがインターフェイスに追加されて、実行中のコンフィギュレーション ファイルに保存されます。

スイッチ ソフトウェアには、シスコのデフォルトのSmartportマクロが組み込まれています( 表11-1 を参照)。組み込まれているマクロやコマンドを表示するには、 show parser macro ユーザEXECコマンドを使用します。

 

表11-1 シスコのデフォルトSmartportマクロ

マクロ名1
説明

cisco-global

VLAN(仮想LAN)間の負荷分散をイネーブルにし、スパニングツリー インスタンスの高速コンバージェンスとポートのエラー回復を可能にするには、このグローバル コンフィギュレーション マクロを使用します。

cisco-desktop

PCなどのデスクトップ デバイスをスイッチ ポートに接続する場合のネットワーク セキュリティと信頼性を向上させるには、このインターフェイス コンフィギュレーション マクロを使用します。

cisco-phone

Cisco IP Phoneが接続されたPCなどのデスクトップ デバイスをスイッチ ポートに接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。このマクロは cisco-desktop マクロを拡張したもので、同様のセキュリティと復元力がありますが、遅延に影響されやすい音声トラフィックを適切に処理するため、専用の音声VLANが付加されています。

cisco-switch

アクセス スイッチとディストリビューション スイッチを接続する場合、あるいはGigaStackモジュールまたはGBIC(ギガビット インターフェイス コンバータ)を使用して接続されたアクセス スイッチ間を接続する場合、このインターフェイス コンフィギュレーション コマンドを使用します。

cisco-router

スイッチとWANルータを接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。

cisco-lre-cpe

スイッチをマンションやホテルに設置する場合、またはVideo-on-Demand(VoD)やマルチキャスト ビデオの配信に使用する場合のパフォーマンスを最適化するには、このインターフェイス コンフィギュレーション マクロを使用します。

cisco-wireless

スイッチと無線アクセス ポイントを接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。

1.シスコのデフォルトのSmartportマクロは、スイッチで稼働しているソフトウェアのバージョンによって異なります。

シスコでは、Catalystスイッチ用にあらかじめテストしたシスコ推奨の基本設定テンプレート集を用意しています。オンライン リファレンス ガイドのテンプレートには、ポートの利用に応じてSmartportマクロを作成するのに使用できるCLIコマンドが用意されています。設定のテンプレートを使用してSmartportマクロを作成し、シスコ推奨のネットワーク設計およびネットワーク構成を構築し、稼働させることができます。シスコ推奨のコンフィギュレーション テンプレートの詳細については、次のSmartportのWebサイトを参照してください。

http://www.cisco.com/go/smartports

Smartportマクロの設定

新規のSmartportマクロを作成するか、または既存のマクロをテンプレートとして使用して、アプリケーション固有のマクロを新しく作成できます。マクロを作成すると、そのマクロを特定のスイッチまたはスイッチ インターフェイス、あるいは特定の範囲のインターフェイスにグローバルに適用できます。

ここでは、次の内容について説明します。

「Smartportマクロのデフォルト設定」

「Smartportマクロ設定時の注意事項」

「Smartportマクロの作成」

「Smartportマクロの適用」

「シスコのデフォルトSmartportマクロの適用」

Smartportマクロのデフォルト設定

イネーブルになったSmartportマクロはありません。

Smartportマクロ設定時の注意事項

スイッチ上でマクロを設定する場合、次の注意事項に従ってください。

マクロを作成する場合、 exit または end コマンドを使用しないでください。また、 interface interface-id を使用してコマンド モードを変更しないでください。 exit end 、または interface interface-id に続くコマンドが異なるコマンド モードで実行される原因になります。

マクロを作成する場合、CLIコマンドはすべて同じコンフィギュレーション モードにする必要があります。

一意の値を割り当てる必要があるマクロを作成する場合、 parameter value キーワードを使用してインターフェイスに固有の値を指定します。キーワード マッチングは大文字と小文字が区別されます。一致したキーワードは、対応する値に置換されます。完全に一致したキーワードは、長い文字列の一部であっても、一致したとみなされ、対応する値に置換されます。

マクロ名は大文字と小文字が区別されます。たとえば、コマンド macro name Sample-Macro macro name sample-macro は異なる別のマクロとなります。

パラメータ値を必要とするキーワードが含まれたマクロもあります。マクロに必要な値の一覧を表示するには、 macro global apply macro-name ? グローバル コンフィギュレーション コマンドまたは macro apply macro-name ? インターフェイス コンフィギュレーション コマンドを使用します。キーワードの値を入力しないでマクロを適用すると、コマンドは無効となり、適用されません。

マクロをスイッチまたはスイッチ インターフェイスにグローバルに適用しても、インターフェイスの既存の設定はすべて保持されます。これは、増分設定を適用する場合に便利です。

コマンドを追加または削除してマクロの定義を変更しても、その変更は元のマクロが適用されたインターフェイスには反映されません。新しいコマンドまたは変更したコマンドを適用するには、更新したマクロをインターフェイスに再度適用する必要があります。

マクロを適用し、構文エラーや設定エラーがないかデバッグするには、 macro global trace macro-name グローバル コンフィギュレーション コマンドまたは macro trace macro-name インターフェイス コンフィギュレーション コマンドを使用します。構文エラーまたは設定エラーによりコマンド実行が失敗した場合、マクロは残りのコマンドの適用を続行します。

一部のCLIコマンドは、特定のインターフェイス タイプに固有のコマンドです。設定を受け入れないインターフェイスにマクロが適用されると、マクロは構文チェックまたは設定チェックでエラーとなり、スイッチはエラー メッセージを返します。

マクロを特定の範囲のインターフェイスに適用するのは、マクロを1つのインターフェイスに適用する場合と同じです。特定の範囲のインターフェイスに適用する場合、マクロはその範囲内のインターフェイスに順次適用されます。あるインターフェイスでマクロのコマンドがエラーになっても、残りのインターフェイスには継続して適用されます。

マクロをスイッチまたはスイッチ インターフェイスに適用する場合、スイッチまたはインターフェイスに自動的にマクロ名が付加されます。適用されたコマンド名およびマクロ名を表示するには、 show running-config ユーザEXECコマンドを使用します。

スイッチ ソフトウェアには、シスコのデフォルトのSmartportマクロが組み込まれています。組み込まれているマクロやコマンドを表示するには、 show parser macro ユーザEXECコマンドを使用します。

シスコのデフォルトのSmartportマクロをインターフェイスに適用する場合は、次の注意事項に従ってください。

show parser macro ユーザEXECコマンドを使用して、スイッチのすべてのマクロを表示します。 show parser macro name macro-name ユーザEXECコマンドを使用して、特定のマクロの内容を表示します。

$ で始まるキーワードには、一意のパラメータ値が必要です。 parameter value キーワードを使用して、シスコのデフォルトのマクロに、必要な値を付加します。

シスコのデフォルトのマクロは、必要なキーワードを識別しやすくするために $ 文字を使用します。マクロ作成時、キーワードの定義のために自由に $ 文字を使用できます。

Smartportマクロの作成

Smartportマクロを作成するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

macro name macro-name

マクロの定義を作成し、マクロ名を入力します。マクロの定義は最大3000文字です。

マクロ コマンドを入力します。コマンドは1行につき1つです。マクロの末尾には、 @ を使用します。マクロ内にコメントを記述する場合は、行頭に # を使用します。

(任意)キーワードを指定するために、ヘルプ ストリングを使用してマクロ内にキーワードを定義できます。マクロで使用可能なキーワードを定義するには、 # macro keywords word と入力します。スペースで区切って、最大3個のヘルプ ストリング キーワードをマクロに組み込むことができます。

マクロ名は大文字と小文字が区別されます。たとえば、コマンド macro name Sample-Macro macro name sample-macro は異なる別のマクロとなります。

マクロを作成する場合、 exit または end コマンドを使用しないでください。また、 interface interface-id を使用してコマンド モードを変更しないでください。 exit end 、または interface interface-id に続くコマンドが異なるコマンド モードで実行される原因になります。マクロ内のコマンドはすべて、同じコンフィギュレーション モードにする必要があります。

ステップ 3

end

イネーブルEXECモードに戻ります。

ステップ 4

show parser macro name macro-name

マクロが作成されたことを確認します。

macro name グローバル コンフィギュレーション コマンドの no 形式は、マクロ定義を削除するだけです。マクロが適用されたインターフェイスの設定には影響しません。

次に、スイッチポート アクセスVLANおよびセキュアMAC(メディア アクセス制御)アドレスを定義し、 # macro keywords によって2つのヘルプ ストリング キーワードを組み込んだマクロを作成する方法を示します。

Switch(config)# macro name test
switchport access vlan $VLANID
switchport port-security maximum $MAX
#macro keywords $VLANID $MAX
@
 

Smartportマクロの適用

Smartportマクロを適用するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

macro global { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

マクロで定義した個々のコマンドをスイッチに適用するには、 macro global apply macro-name を使用します。マクロを適用して、構文エラーや設定エラーがないかデバッグするには、 macro global trace macro-name を指定します。

(任意)スイッチに固有の一意のパラメータ値を指定します。キーワード値のペアは、3つまで入力できます。パラメータのキーワード マッチングは大文字と小文字が区別されます。一致したキーワードは、対応する値に置換されます。

パラメータ値を必要とするキーワードが含まれたマクロもあります。マクロに必要な値の一覧を表示するには、 macro global apply macro-name ? コマンドを使用します。キーワードの値を入力しないでマクロを適用すると、コマンドは無効となり、適用されません。

ステップ 3

macro global description text

(任意)スイッチに適用されるマクロの説明を入力します。

ステップ 4

interface interface-id

(任意)インターフェイス コンフィギュレーション モードを開始し、マクロを適用するインターフェイスを指定します。

ステップ 5

default interface interface-id

(任意)指定したインターフェイスの設定をすべてクリアします。

ステップ 6

macro { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

マクロで定義した個々のコマンドをインターフェイスを適用するには、 macro apply macro-name を使用します。マクロを適用して、構文エラーや設定エラーがないかデバッグするには、 macro trace macro-name を指定します。

(任意)インターフェイスに固有の一意のパラメータ値を指定します。キーワード値のペアは、3つまで入力できます。パラメータのキーワード マッチングは大文字と小文字が区別されます。一致したキーワードは、対応する値に置換されます。

パラメータ値を必要とするキーワードが含まれたマクロもあります。マクロに必要な値の一覧を表示するには、 macro apply macro-name ? コマンドを使用します。キーワードの値を入力しないでマクロを適用すると、コマンドは無効となり、適用されません。

ステップ 7

macro description text

(任意)インターフェイスに適用されるマクロの説明を入力します。

ステップ 8

end

イネーブルEXECモードに戻ります。

ステップ 9

show parser macro description [ interface interface-id ]

マクロがインターフェイスに適用されたことを確認します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイス上のグローバル マクロによる設定を削除するには、マクロ内に設定された各コマンドの no 形式を使用します。インターフェイス上のマクロによる設定を削除するには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、 snmp というユーザ作成マクロを適用し、ホスト名アドレスを test-server に設定し、IP precedence値を 7 に設定する方法を示します。

Switch(config)# macro global apply snmp ADDRESS test-server VALUE 7
 

次に、 macro global trace グローバル コンフィギュレーション コマンドを使用して snmp というユーザ作成マクロをデバッグし、スイッチへの適用時にマクロに構文エラーや設定エラーがないかを確認します。

Switch(config)# macro global trace snmp VALUE 7
Applying command...‘snmp-server enable traps port-security’
Applying command...‘snmp-server enable traps linkup’
Applying command...‘snmp-server enable traps linkdown’
Applying command...‘snmp-server host’
%Error Unknown error.
Applying command...‘snmp-server ip precedence 7’
 

次に、 desktop-config というユーザ作成マクロを適用して、設定を確認する方法を示します。

Switch(config)# interface fastethernet0/2
Switch(config-if)# macro apply desktop-config
Switch(config-if)# end
Switch# show parser macro description
Interface Macro Description
--------------------------------------------------------------
Gi0/2 desktop-config
--------------------------------------------------------------
 

次に、 desktop-config というユーザ作成マクロを適用して、VLAN 1をVLAN 25に置換する方法を示します。

Switch(config-if)# macro apply desktop-config vlan 25

シスコのデフォルトSmartportマクロの適用

Smartportマクロを適用するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
目的

ステップ 1

show parser macro

スイッチ ソフトウェアに組み込まれたシスコのデフォルトのSmartportマクロを表示します。

ステップ 2

show parser macro name macro-name

適用する特定のマクロを表示します。

ステップ 3

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

macro global { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

parameter value キーワードを使用して、シスコのデフォルトのマクロに必要な値を付加し、マクロをスイッチに適用します。 $ で始まるキーワードには、一意のパラメータ値が必要です。

マクロに必要な値の一覧を表示するには、 macro global apply macro-name ? コマンドを使用します。キーワードの値を入力しないでマクロを適用すると、コマンドは無効となり、適用されません。

ステップ 5

interface interface-id

(任意)インターフェイス コンフィギュレーション モードを開始し、マクロを適用するインターフェイスを指定します。

ステップ 6

default interface interface-id

(任意)指定したインターフェイスの設定をすべてクリアします。

ステップ 7

macro { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

parameter value キーワードを使用して、シスコのデフォルトのマクロに必要な値を付加し、マクロをインターフェイスに適用します。 $ で始まるキーワードには、一意のパラメータ値が必要です。

マクロに必要な値の一覧を表示するには、
macro apply macro-name ? コマンドを使用します。キーワードの値を入力しないでマクロを適用すると、コマンドは無効となり、適用されません。

ステップ 8

end

イネーブルEXECモードに戻ります。

ステップ 9

show running-config interface interface-id

マクロがインターフェイスに適用されたことを確認します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイス上のグローバル マクロによる設定を削除するには、マクロ内に設定された各コマンドの no 形式を使用します。インターフェイス上のマクロによる設定を削除するには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、 cisco-desktop マクロを表示する方法、マクロの適用方法、インターフェイスでアクセスVLAN IDを25に設定する方法を示します。

Switch# show parser macro cisco-desktop
--------------------------------------------------------------
Macro name : cisco-desktop
Macro type : default
 
# Basic interface - Enable data VLAN only
# Recommended value for access vlan (AVID) should not be 1
switchport access vlan $AVID
switchport mode access
 
# Enable port security limiting port to a single
# MAC address -- that of desktop
switchport port-security
switchport port-security maximum 1
 
# Ensure port-security age is greater than one minute
# and use inactivity timer
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
 
# Configure port as an edge network port
spanning-tree portfast
spanning-tree bpduguard enable
--------------------------------------------------------------
Switch#
Switch# configure terminal
Switch(config)# fastethernet0/4
Switch(config-if)# macro apply cisco-desktop $AVID 25
 

Smartportマクロの表示

Smartportマクロを表示するには、 表11-2 のイネーブルEXECコマンドを1つまたは複数使用します。

 

表11-2 Smartportマクロを表示するコマンド

コマンド
目的

show parser macro

設定したすべてのマクロを表示します。

show parser macro name macro-name

特定のマクロを表示します。

show parser macro brief

設定したマクロ名を表示します。

show parser macro description [ interface interface-id ]

すべてのインターフェイスまたは特定のインターフェイスのマクロの説明を表示します。