Catalyst 2940 スイッチ ハードウェア インストレーション ガイド
CLIベースのセットアップ プログラム によるスイッチの設定
CLIベースのセットアップ プログラムによるスイッチの設定
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

CLIベースのセットアップ プログラムによるスイッチの設定

CLIへのアクセス方法

Express SetupによるCLIへのアクセス(未設定のスイッチのみ)

コンソール ポートによるCLIへのアクセス

必要なコンポーネントの取り出し

電源への接続

コンソール ポートの接続

端末エミュレーション ソフトウェアの起動

初期設定情報の入力

IP設定

セットアップ プログラムの完了

次の作業

CLIベースのセットアップ プログラムによるスイッチの設定

この付録では、スタンドアロン スイッチでCLI(コマンドライン インターフェイス)ベースのセットアップ手順を使用する方法について説明します。内容は次のとおりです。

「CLIへのアクセス方法」

「必要なコンポーネントの取り出し」

「電源への接続」

「コンソール ポートの接続」

「電源への接続」

「初期設定情報の入力」

「セットアップ プログラムの完了」

「次の作業」

CLIへのアクセス方法

CLIにアクセスするには、次の方法があります。

「Express SetupによるCLIへのアクセス(未設定のスイッチのみ)」

「コンソール ポートによるCLIへのアクセス」

Express SetupによるCLIへのアクセス(未設定のスイッチのみ)

スイッチをExpress Setupモードにし、さらにスイッチのイーサネット ポートをPCまたはワークステーションのイーサネット ポートに接続することにより、未設定スイッチのCLIにアクセスできます。スイッチをExpress Setupモードにするには、Getting Started Guideで説明した手順に従ってください。

スイッチをExpress Setupモードにしたあと、IPアドレス 10.0.0.1 を使用してスイッチにTelnet接続し、 setupユーザEXECコマンドを入力します。この章の以下の項を参照し、CLIを使用してスイッチを設定します。

「初期設定情報の入力」

「セットアップ プログラムの完了」

スイッチの設定情報を入力したら、 write memory イネーブルEXECコマンドを使用してフラッシュ メモリに保存します。


) Express Setupモードにある間、IPアドレス10.0.0.1は、write memoryコマンドを実行するまでスイッチ上でアクティブのままです。write memoryコマンドを実行すると、Telnet接続は失われます。


CLIの使用に関する詳細については、このリリースに対応するコマンド リファレンスを参照してください。

コンソール ポートによるCLIへのアクセス

スイッチのコンソール ポートをPCまたはワークステーションのシリアル ポートに接続してCLIにアクセスし、Telnetセッションを通じてスイッチにアクセスできます。コンソール ポートからスイッチにアクセスするには、この章の「必要なコンポーネントの取り出し」で説明する手順に従ってください。

必要なコンポーネントの取り出し

図 C-1 に示すものを梱包箱から取り出します。

図 C-1 Catalyst 2940スイッチ、コンソール ケーブル、およびAC電源コード

 

 

1

スイッチ

3

AC電源コード

2

コンソール ケーブル

電源への接続

電源に接続する手順は、次のとおりです。


ステップ 1 付属品のAC電源コードの一端を、スイッチの背面パネルにある電源コネクタに接続します(図 C-2を参照)。

図 C-2 スイッチとAC電源との接続

 

 

1

スイッチ

2

AC電源コード

ステップ 2 電源コードの反対側をアースしたAC電源コンセントに接続します。

スイッチの電源を投入すると、Power-on Self-Test(POST;電源投入時セルフテスト)が開始されます。これは、スイッチが適切に動作することを自動的に確認する一連のテストです。POSTに失敗した場合は、「トラブルシューティング」を参照して、原因を特定してください。


 

コンソール ポートの接続

コンソール ポートを使用して初期設定を行うことができます。スイッチのコンソール ポートにPCを接続するには、付属のRJ-45/DB-9アダプタ ケーブルを使用します。

スイッチにPCまたは端末を接続する手順は、次のとおりです。


ステップ 1 付属のRJ-45/DB-9アダプタ ケーブルを使用して、RJ-45コネクタをスイッチの背面にあるコンソール ポートに差し込みます(図 C-3参照)。

図 C-3 スイッチとPCとの接続

 

 

1

スイッチ

3

RJ-45/DB-9アダプタ(コンソール)ケーブル

2

AC電源コード

ステップ 2 アダプタ ケーブルのDB-9メスDTEをPCのシリアル ポートに取り付けるか、適切なアダプタを端末に取り付けます。


 

端末エミュレーション ソフトウェアの起動

スイッチに接続し、電源を入れる前に、端末エミュレーション セッションを開始して、POSTからの出力が表示されるようにします。

端末エミュレーション ソフトウェア(HyperterminalまたはProcommPlusなどのPCアプリケーション)により、スイッチとユーザのPCまたは端末との通信が可能になります。


) スイッチの電源を投入する前に端末エミュレーション プログラムを起動した場合、PCまたは端末はブートローダ シーケンスを表示します。セットアップ プログラムのプロンプトを表示するには、Enterを押す必要があります。


端末エミュレーション セッションを開始する手順は、次のとおりです。


ステップ 1 PCまたは端末を使用して、端末エミュレーション プログラムを起動します。

ステップ 2 端末エミュレーション セッションを開始します。

ステップ 3 コンソール ポートのデフォルト特性に合わせて、PCまたは端末のボーレートおよびキャラクタ フォーマットを設定します。

9600ボー

8データ ビット

1ストップ ビット

パリティなし

なし(フロー制御)

ステップ 4 Enter キーを押します。次のプロンプトが表示されます。

Switch>
 


 

初期設定情報の入力

スイッチを設定するには、スイッチの電源を投入した後自動的に起動するセットアップ プログラムを完了する必要があります。スイッチがローカル ルータやインターネットと通信するために必要なIPアドレスおよび他の設定情報を割り当てなければなりません。Network Assistantを使用してスイッチを設定、管理する場合にもこの情報は必要です。

IP設定

セットアップ プログラムを実行する前に、ネットワーク管理者から次の情報を入手しておく必要があります。

スイッチのIPアドレス

サブネット マスク(IPネットマスク)

デフォルト ゲートウェイ(ルータ)

イネーブル シークレット パスワード

イネーブル パスワード

Telnetパスワード

セットアップ プログラムの完了

セットアップ プログラムを完了し、スイッチの初期設定を作成する手順は、次のとおりです。


ステップ 1 これらの2つのプロンプトに Yes と入力します。

Would you like to enter the initial configuration dialog? [yes/no]: yes
 
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system.
 
Would you like to enter basic management setup? [yes/no]: yes
 

ステップ 2 スイッチのホスト名を入力し、Returnキーを押します。

ホスト名は、コマンド スイッチでは28文字以内、メンバー スイッチでは31文字以内に制限されています。どのスイッチのホスト名でも、最後の文字には -n (nは数字)を使用しないでください。

Enter host name [Switch]: host_name
 

ステップ 3 イネーブル シークレット パスワードを入力し、Returnキーを押します。

パスワードは1~25文字の英数字で、先頭を数字にすることもできます。パスワードでは大文字と小文字が区別されます。スペースは使用できますが、先行スペースは無視されます。シークレット パスワードは暗号化されており、またイネーブル パスワードはプレーン テキストです。

Enter enable secret: secret_password

ステップ 4 イネーブル パスワードを入力し、Returnキーを押します。

Enter enable password: enable_password
 

ステップ 5 仮想端末(Telnet)のパスワードを入力し、Returnキーを押します。

パスワードは1~25文字の英数字で、大文字と小文字が区別されます。スペースは使用できますが、先行スペースは無視されます。

Enter virtual terminal password: terminal-password
 

ステップ 6 (任意)プロンプトに応答してSNMP(簡易ネットワーク管理プロトコル)を設定します。あとでCLI、デバイス マネージャ、またはNetwork Assistantを使用してSNMPを設定することもできます。SNMPをあとで設定するには、 no を入力します。

Configure SNMP Network Management? [no]: no
 

ステップ 7 管理ネットワークへ接続するインターフェイスのインターフェイス名(物理インターフェイスまたはVLAN名)を入力し、 Return を押します。このリリースでは、このインターフェイスとして常に vlan1 を使用します。

Enter interface name used to connect to the
management network from the above interface summary: vlan1
 

ステップ 8 スイッチのIPアドレスとサブネット マスクを入力し、Returnキーを押してインターフェイスを設定します。次に示すIPアドレスおよびサブネット マスクは一例です。

Configuring interface vlan1:
Configure IP on this interface? [yes]: yes
IP address for this interface: 10.4.120.106
Subnet mask for this interface [255.0.0.0]: 255.0.0.0

ステップ 9 Yを入力して、スイッチをクラスタ コマンド スイッチとして設定します。Nを入力すると、メンバー スイッチまたはスタンドアロン スイッチとして設定されます。

N を入力した場合は、Network Assistant GUIに候補スイッチとして表示されます。あとでCLIまたはNetwork Assistantインターフェイスを使用して、スイッチをコマンド スイッチとして設定できます。あとで設定するには、 no を入力します。

Would you like to enable as a cluster command switch? [yes/no]: no
 

これでスイッチの初期設定が完了し、スイッチはその初期設定を表示します。出力例は以下のとおりです。

The following configuration command script was created:
hostname host_name
enable secret 5 $1$Max7$Qgr9eXBhtcBJw3KK7bc850
enable password my
line vty 0 15
password my_password
snmp-server community public
!
no ip routing
!
interface Vlan1
no shutdown
ip address 172.20.139.145 255.255.255.224
!
interface Vlan2
shutdown
no ip address
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
...(テキスト出力は省略)
!!!
interface GigabitEthernet0/1
!
end
 

ステップ 10 次のような選択が表示されます。

[0] Go to the IOS command prompt without saving this config.
 
[1] Return back to the setup without saving this config.
 
[2] Save this configuration to nvram and exit.
 
If you want to save the configuration and use it the next time the switch reboots, save it in nonvolatile RAM (NVRAM) by selecting option 2.
 
Enter your selection [2]:2
 

いずれかを選択して、 Returnキー を押します。


 

次の作業

セットアップ プログラムが完了すると、スイッチは作成されたデフォルト設定で動作します。

製品の概要情報については、「概要」を参照してください。

スイッチをデスクの上下または壁面に取り付けたり、Small Form-factor Pluggable(SFP)モジュールに接続したりする際の取り付け手順の詳細については、「インストレーション」を参照してください。このセットアップ手順を完了するより先に、ご使用のPCを固定IPアドレスで設定しないでください。

設定を変更したい場合、または他の管理作業を実行したい場合、以下のいずれかのツールを使用します。

CLI

ブラウザからデバイス マネージャ(スイッチが1台の場合)

Network Assistant(スイッチが1台または複数の場合)

CLIを使用するには、端末エミュレーション プログラムを使用してコンソール ポートを経由するか、Telnetセッションを使用してネットワーク経由で Switch >プロンプトにコマンドを入力します。設定手順については、スイッチのソフトウェア コンフィギュレーション ガイドまたはスイッチのコマンド リファレンスを参照してください。

Network Assistantを使用する場合は、『 Getting Started with Cisco Network Assistant 』ガイドを参照してください。