Catalyst 2940 スイッチ ソフトウェア コンフィギュレーション ガイド 12.1(22)EA11 and Later
VLAN の設定
VLAN の設定
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

VLAN の設定

VLAN の概要

サポートされる VLAN

VLAN ポート メンバーシップ モード

標準範囲 VLAN の設定

トークンリング VLAN

標準範囲 VLAN 設定時の注意事項

VLAN コンフィギュレーション モードのオプション

config-vlan モードでの VLAN 設定

VLAN コンフィギュレーション モードでの VLAN 設定

VLAN 設定の保存

イーサネット VLAN のデフォルト設定

イーサネット VLAN の作成または変更

VLAN の削除

VLAN へのスタティック アクセス ポートの割り当て

拡張範囲 VLAN の設定

VLAN のデフォルト設定

拡張範囲 VLAN 設定時の注意事項

拡張範囲 VLAN の作成

VLAN の表示

VLAN トランクの設定

トランキングの概要

IEEE 802.1Q の設定に関する考慮事項

レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

トランク ポートとしてのイーサネット インターフェイスの設定

他の機能との相互作用

トランク ポートの設定

トランクでの許可 VLAN の定義

プルーニング適格リストの変更

タグなしトラフィック用ネイティブ VLAN の設定

STP によるロード シェアリング

STP ポート プライオリティによるロード シェアリング

STP パス コストによるロード シェアリング

VMPS の設定

VMPS の概要

ダイナミック ポート VLAN メンバーシップ

VMPS データベース コンフィギュレーション ファイル

VMPS クライアントのデフォルト設定

VMPS 設定時の注意事項

VMPS クライアントの設定

VMPS の IP アドレスの入力

VMPS クライアント上のダイナミック アクセス ポートの設定

VLAN メンバーシップの再確認

再確認インターバルの変更

再試行回数の変更

VMPS のモニタ

ダイナミック ポート VLAN メンバーシップのトラブルシューティング

VMPS の設定例

VLAN の設定

この章では、Catalyst2940 スイッチ上で標準範囲 VLAN を設定する方法について説明します。VLAN モードや VLAN Membership Policy Server(VMPS; VLAN メンバーシップ ポリシー サーバ)についても説明します。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「VLAN の概要」

「標準範囲 VLAN の設定」

「拡張範囲 VLAN の設定」

「VLAN の表示」

「VLAN トランクの設定」

「VMPS の設定」

VLAN の概要

VLAN は、ユーザの物理的な位置に関係なく、機能、プロジェクト チーム、またはアプリケーションなどで論理的に分割されたスイッチド ネットワークです。VLAN は、物理 LAN と同じ属性をすべて備えていますが、同じ LAN セグメントに物理的に配置されていない端末もグループ化できます。どのスイッチ ポートも VLAN に割り当てることができます。ユニキャスト、ブロードキャスト、およびマルチキャスト パケットは、VLAN 内の端末だけにフォワーディングおよびフラッディングが行われます。各 VLAN は 1 つの論理ネットワークとみなされ、VLAN に割り当てられていないステーション宛てのパケットは、ルータまたはブリッジを経由して転送しなければなりません(図13-1 を参照)。VLAN はそれぞれが独立した論理ネットワークとみなされるので、VLAN ごとに独自の MIB(管理情報ベース)情報があり、スパニング ツリーの独自の実装をサポートできます。「STP の設定」および「MSTP の設定」を参照してください。


) VLAN を作成する前に、VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)を使用してネットワークのグローバルな VLAN 設定を維持するかどうかを決定する必要があります。VTP の詳細については、「VTP の設定」を参照してください。


図13-1 に、論理的に定義されたネットワークにセグメント化された VLAN の例を示します。

図13-1 論理的に定義されたネットワークとしての VLAN

 

VLAN は IP サブネットワークに対応付けられます。たとえば、特定の IP サブネットに含まれるすべての端末は同一の VLAN に属します。スイッチ上のインターフェイスの VLAN メンバーシップは、インターフェイスごとに手動で割り当てます。この方法でスイッチ インターフェイスを VLAN に割り当てた場合、これをインターフェイス ベース(またはスタティック)VLAN メンバーシップと呼びます。

サポートされる VLAN

Catalyst 2940 スイッチは 128 の VLAN をサポートします。標準範囲 VLAN は、1 ~ 4094 の番号で識別します。VLAN ID 1002 ~ 1005 は、トークンリングおよび FDDI VLAN 専用です。VTP は、VLAN ID が 1 ~ 1005 の標準範囲 VLAN のみを学習します。1005 より大きい VLAN ID は、拡張範囲 VLAN であり、VLAN データベースには保存されません。1006 ~ 4094 の VLAN ID を作成する場合は、スイッチは VTP トランスペアレント モードである必要があります。

スイッチは、最大 64 のスパニング ツリー インスタンスを持つ Per-VLAN Spanning Tree Plus(PVST+)をサポートします。VLAN ごとに 1 つのスパニング ツリー インスタンスが許可されます。スパニング ツリー インスタンス数および VLAN 数の詳細については、「標準範囲 VLAN 設定時の注意事項」を参照してください。イーサネット ポートを介して VLAN トラフィックを送信するために、スイッチは IEEE 802.1Q トランキングをサポートします。

VLAN ポート メンバーシップ モード

VLAN に属するポートは、メンバーシップ モードを指定して設定します。メンバーシップ モードにより、各ポートが伝送できるトラフィックの種類、および所属できる VLAN の数が決まります。 表13-1 に、各種メンバーシップ モード、およびそれぞれのメンバーシップと VTP 特性を示します。

 

表13-1 ポート メンバーシップ モード

メンバーシップ モード
VLAN メンバーシップの特性
VTP の特性

スタティック アクセス

スタティック アクセス ポートは、手動で割り当てられ、1 つの VLAN だけに属します。詳細については、「VLAN へのスタティック アクセス ポートの割り当て」を参照してください。

VTP は必須ではありません。VTP を使用して情報をグローバルに伝播させない場合は、VTP モードをトランスペアレントに設定して、VTP をディセーブルにします。VTP に参加する場合は、2 台めのスイッチのトランク ポートに接続されたスイッチ上に、トランク ポートが少なくとも 1 つなければなりません。

802.1Q トランク

デフォルトで、トランク ポートは拡張範囲 VLAN を含むすべての VLAN のメンバーです。ただし、メンバーシップは許可 VLAN リストを設定して制限できます。また、プルーニング適格リストを変更して、リストに指定したトランク ポート上の VLAN へのフラッディング トラフィックをブロックすることもできます。トランク ポートの設定については、「トランク ポートとしてのイーサネット インターフェイスの設定」を参照してください。

VTP を推奨しますが、必須ではありません。VTP は、ネットワーク全体にわたって VLAN の追加、削除、名前変更を管理することにより、VLAN 設定の整合性を維持します。VTP はトランク リンクを通じて他のスイッチと VLAN コンフィギュレーション メッセージを交換します。

ダイナミックアクセス

ダイナミックアクセス ポートは 1 つの VLAN(VLAN ID が 1 ~ 4094)にのみ属し、VMPS によって動的に割り当てられます。VMPS には Catalyst 5000 または Catalyst 6500 シリーズ スイッチを使用できますが、Catalyst 2940 スイッチは使用できません。

同一スイッチ上でダイナミックアクセス ポートとトランク ポートを使用できますが、ダイナミックアクセス ポートは別のスイッチでなく端末に接続する必要があります。

設定手順については、「VMPS クライアント上のダイナミック アクセス ポートの設定」を参照してください。

VTP は必須です。

VMPS およびクライアントを同じ VTP ドメイン名で設定してください。

VMPS クライアント スイッチ上で再確認インターバルおよび再試行回数を変更できます。

音声 VLAN

音声 VLAN ポートは、Cisco IP Phone に接続されたアクセス ポートで、1 つの VLAN は音声トラフィック用に、もう 1 つの VLAN は Cisco IP Phone に接続しているデバイスからのデータ トラフィック用に使用するように設定できます。音声 VLAN ポートの詳細については、「音声 VLAN の設定」を参照してください。

VTP は必須ではありません。VTP は音声 VLAN では効果はありません。

モードおよび機能の定義の詳細については、 表13-4 を参照してください。

ポートが VLAN に属すると、スイッチは VLAN 単位で、ポートに対応するアドレスを学習して管理します。詳細については、「MAC アドレス テーブルの管理」を参照してください。

標準範囲 VLAN の設定

標準範囲 VLAN は、VLAN ID が 1 ~ 1005 の VLAN です。スイッチが VTP サーバまたはトランスペアレント モードの場合、VLAN データベース内の VLAN 2 ~ 1001 の設定を追加、変更、または削除できます(VLAN ID 1 および 1002 ~ 1005 は自動作成され、削除できません)。


) スイッチがトランスペアレント モードの場合、拡張範囲 VLAN(1006 ~ 4094 の ID を持つ VLAN)を作成できますが、これらの VLAN は VLAN データベースには保存されません。「拡張範囲 VLAN の設定」を参照してください。


VLAN ID 1 ~ 1005 の設定はファイル vlan.dat (VLAN データベース)に書き込まれます。この設定を表示するには、 show vlan 特権 EXEC コマンドを入力します。 vlan.dat ファイルはフラッシュ メモリに保存されます。


注意 vlan.dat ファイルを手動で削除しようとすると、VLAN データベースの不整合が生じる可能性があります。VLAN 設定を変更する場合は、ここに記載されたコマンド、およびこのリリースに対応するコマンド リファレンスに記載されたコマンドを使用します。VTP 設定の変更手順については、「VTP の設定」を参照してください。

さらに、インターフェイス コンフィギュレーション モードを使用して、ポートのメンバーシップ モードの定義、VLAN に対するポートの追加および削除を行います。これらのコマンドの実行結果は実行コンフィギュレーション ファイルに書き込まれます。このファイルを表示するには、 show running-config 特権 EXEC コマンドを使用します。

VLAN データベースに新しい標準範囲 VLAN を作成したり、VLAN データベース内の既存の VLAN を変更したりする場合、次のパラメータを設定できます。

VLAN ID

VLAN 名

VLAN タイプ(イーサネット、Fiber Distributed Data Interface [FDDI]、FDDI Network Entity Title [NET]、TrBRF または TrCRF、トークンリング、トークンリング Net)

VLAN ステート(アクティブまたは一時停止)

VLAN の Maximum Transmission Unit(MTU; 最大伝送ユニット)

Security Association Identifier(SAID)

TrBRF VLAN のブリッジ識別番号

FDDI および TrCRF VLAN のリング番号

TrCRF VLAN の親 VLAN 番号

TrCRF VLAN の Spanning-Tree Protocol(STP; スパニング ツリー プロトコル)タイプ

ある VLAN タイプから別の VLAN タイプに変換するときに使用する VLAN 番号


) ここでは、これらのパラメータの大部分の設定手順について説明しません。VLAN 設定を制御するコマンドおよびパラメータの詳細については、このリリースに対応するコマンド リファレンスを参照してください。


ここでは、標準範囲 VLAN の次の内容について説明します。

「トークンリング VLAN」

「標準範囲 VLAN 設定時の注意事項」

「VLAN コンフィギュレーション モードのオプション」

「VLAN 設定の保存」

「イーサネット VLAN のデフォルト設定」

「イーサネット VLAN の作成または変更」

「VLAN の削除」

「VLAN へのスタティック アクセス ポートの割り当て」

トークンリング VLAN

スイッチはトークンリング接続をサポートしていませんが、トークンリング接続を行っている Catalyst 5000 シリーズ スイッチなどのリモート装置を、サポート対象スイッチのうちの 1 台から管理できます。VTP バージョン 2 が稼働しているスイッチは、次のトークンリング VLAN に関する情報をアドバタイズします。

トークンリング TrBRF VLAN

トークンリング TrCRF VLAN

トークンリング VLAN の詳しい設定手順については、『 Catalyst 5000 Series Software Configuration Guide 』を参照してください。

標準範囲 VLAN 設定時の注意事項

ネットワーク内で標準範囲 VLAN を作成または変更する場合には、次の注意事項に従ってください。

スイッチは最大 128 の VLAN をサポートします。

標準範囲 VLAN は、1 ~ 1001 の番号で識別します。VLAN 番号 1002 ~ 1005 は、トークンリングおよび FDDI VLAN 専用です。

VLAN 1 ~ 1005 の VLAN 設定は、常に VLAN データベースに格納されます。VTP モードがトランスペアレントの場合、VTP および VLAN 設定はスイッチの実行コンフィギュレーション ファイルにも格納されます。

VTP がトランスペアレント モード(VTP がディセーブル)の場合、スイッチは 1006 ~ 4094 の VLAN ID もサポートします。これらは拡張範囲 VLAN であり、設定オプションは制限されます。拡張範囲 VLAN は、VLAN データベースには保存されません。「拡張範囲 VLAN の設定」を参照してください。

VLAN を作成する前に、スイッチを VTP サーバ モードまたは VTP トランスペアレント モードにしておく必要があります。スイッチが VTP サーバである場合には、VTP ドメインを定義する必要があります。VTP ドメインを定義しないと、VTP は機能しません。

このスイッチは、トークンリングまたは FDDI メディアをサポートしません。スイッチは FDDI、FDDI-Net、TrCRF、または TrBRF トラフィックを伝送しませんが、VTP を介して VLAN 設定を伝播します。

スイッチは 64 のスパニング ツリー インスタンスをサポートします。スイッチのアクティブな VLAN 数が、サポートされているスパニング ツリー インスタンス数よりも多い場合、スパニング ツリーは 64 の VLAN でイネーブルにできます。残りの VLAN では、スパニング ツリーはディセーブルになります。スイッチ上の使用可能なスパニング ツリー インスタンスをすべて使い切ってしまったあとに、VTP ドメインの中にさらに別の VLAN を追加すると、そのスイッチ上にスパニング ツリーが稼働しない VLAN が生成されます。そのスイッチのトランク ポート上でデフォルトの許可リスト(すべての VLAN を許可するリスト)が設定されていると、すべてのトランク ポート上に新しい VLAN が割り当てられます。ネットワーク トポロジによっては、新しい VLAN 上で、中断されないループが生成されることがあります。特に、複数の隣接スイッチでスパニング ツリー インスタンスをすべて使用してしまっている場合などです。スパニング ツリー インスタンスの割り当てを使い果たしたスイッチのトランク ポートに許可リストを設定することにより、このような可能性を防止できます。

スイッチ上の VLAN の数がサポートされているスパニング ツリー インスタンスの最大数を超える場合、スイッチ上に IEEE 802.1S Multiple STP(MSTP)を設定して、複数の VLAN を単一の STP インスタンスにマッピングすることを推奨します。MSTP の詳細については、「MSTP の設定」を参照してください。

VLAN コンフィギュレーション モードのオプション

標準範囲 VLAN(VLAN ID が 1 ~ 1005)を設定するには、次に示す 2 つのコンフィギュレーション モードを使用します。

「config-vlan モードでの VLAN 設定」

config-vlan モードにアクセスするには、 vlan vlan-id グローバル コンフィギュレーション コマンドを入力します。

「VLAN コンフィギュレーション モードでの VLAN 設定」

VLAN データベース コンフィギュレーション モードにアクセスするには、 vlan database 特権 EXEC コマンドを入力します。

config-vlan モードでの VLAN 設定

config-vlan モードにアクセスするには、VLAN ID を指定して vlan グローバル コンフィギュレーション コマンドを入力します。新しい VLAN ID を指定して VLAN を作成するか、または既存の VLAN ID を使用して VLAN を変更します。デフォルトの VLAN 設定を使用するか( 表13-2 を参照)、または複数のコマンドを入力して VLAN を設定できます。このモードで使用できるコマンドの詳細については、このリリースに対応するコマンド リファレンスの vlan グローバル コンフィギュレーション コマンドに関する説明を参照してください。設定を終了したら、config-vlan モードを終了して、設定を有効にする必要があります。VLAN 設定を表示するには、 show vlan 特権 EXEC コマンドを入力します。

この config-vlan モードは、拡張範囲 VLAN(VLAN ID が 1005 より大きい)を作成するときに使用する必要があります。「拡張範囲 VLAN の設定」を参照してください。

VLAN コンフィギュレーション モードでの VLAN 設定

VLAN コンフィギュレーション モードにアクセスするには、 vlan database 特権 EXEC コマンドを入力します。次に、新しい VLAN ID を指定して vlan コマンドを入力し、VLAN を作成するか、または既存の VLAN ID を入力して VLAN を変更します。デフォルトの VLAN 設定を使用するか( 表13-2 を参照)、または複数のコマンドを入力して VLAN を設定できます。このモードで使用できるキーワードの詳細については、このリリースに対応するコマンド リファレンスの vlan VLAN コンフィギュレーション コマンドに関する説明を参照してください。設定を終了したら、 apply または exit を入力して、設定を有効にする必要があります。 exit コマンドを入力すると、すべてのコマンドが適用されて、VLAN データベースがアップデートされます。VTP ドメイン内の他のスイッチに VTP メッセージが送信され、特権 EXEC モード プロンプトが表示されます。

VLAN 設定の保存

VLAN ID 1 ~ 1005 の設定は、常に VLAN データベースに保存されます(vlan.dat ファイル)。VTP モードがトランスペアレントである場合、設定はスイッチの実行コンフィギュレーション ファイルにも保存されます。設定をスタートアップ コンフィギュレーション ファイルに保存するには、 copy running-config startup-config 特権 EXEC コマンドを使用します。スイッチの実行コンフィギュレーション ファイルを表示するには、 show running-config vlan 特権 EXEC コマンドを使用します。VLAN 設定を表示するには、 show vlan 特権 EXEC コマンドを入力します。

VLAN および VTP 情報(拡張範囲 VLAN の設定情報を含む)をスタートアップ コンフィギュレーション ファイルに保存して、スイッチを再起動すると、スイッチの設定は次のように決定されます。

スタートアップ コンフィギュレーションとVLAN データベース内の VTP モードがトランスペアレントであり、VLAN データベースとスタートアップ コンフィギュレーション ファイルの VTP ドメイン名が一致する場合、VLANデータベースは無視(消去)され、スタートアップ コンフィギュレーション ファイル内の VTP および VLAN 設定が使用されます。VLAN データベース内の VLAN データベース リビジョン番号は変更されません。

スタートアップ コンフィギュレーション内の VTP モードまたはドメイン名が VLAN データベースと一致しない場合、最初の 1005 個の VLAN ID のドメイン名、VTP モード、および設定には VLAN データベース情報が使用されます。

VTP モードがサーバの場合、最初の 1005 個の VLAN ID のドメイン名および VLAN 設定には VLAN データベース情報が使用されます。


注意 起動時に VLAN データベースの設定が使用され、スタートアップ コンフィギュレーション ファイルに拡張範囲 VLAN 設定が含まれていた場合、システム起動時にこの情報は失われます。

イーサネット VLAN のデフォルト設定

表13-2 にイーサネット VLAN のデフォルト設定を示します。


) スイッチがサポートするのは、イーサネット インターフェイスだけです。FDDI およびトークンリング VLAN は、ローカルではサポートされないので、FDDI およびトークンリング メディア固有の特性は、他のスイッチに対する VTP グローバル アドバタイズに限って設定します。


 

表13-2 イーサネット VLAN のデフォルト値および範囲

パラメータ
デフォルト値
範囲

VLAN ID

1

1 ~ 4094


) 拡張範囲 VLAN(VLAN ID 1006 ~ 4094)は VLAN データベースには保存されません。


VLAN 名

VLANxxxx xxxx は 4 桁の数字(先行 0 を含む)が VLAN ID 番号に等しいことを示します。

範囲なし

IEEE 802.10 SAID

100001(100000 と VLAN ID の和)

1 ~ 4294967294

MTU サイズ

1500

1500 ~ 18190

トランスレーショナル ブリッジ 1

0

0 ~ 1005

トランスレーショナル ブリッジ 2

0

0 ~ 1005

VLAN ステート

active

active、suspend

イーサネット VLAN の作成または変更

VLAN データベース内の各イーサネット VLAN には、1 ~ 1001 の 4 桁の一意の ID が設定されています。VLAN ID 1002 ~ 1005 は、トークンリングおよび FDDI VLAN 用に予約されています。標準範囲 VLAN を作成して VLAN データベースに追加するには、VLAN に番号および名前を割り当てます。


) スイッチが VTP トランスペアレント モードの場合、1006 を超える VLAN ID を割り当てることができますが、それらを VLAN データベースに追加することはできません。「拡張範囲 VLAN の設定」を参照してください。


VLAN の追加時に指定されるデフォルト パラメータの一覧は、「標準範囲 VLAN の設定」を参照してください。

config-vlan モードを使用してイーサネット VLAN を作成または変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id

VLAN ID を入力して、config-vlan モードを開始します。新規の VLAN ID を入力して VLAN を作成するか、または既存の VLAN ID を入力して VLAN を変更します。


) このコマンドの使用可能な VLAN ID は 1 ~ 4094 です。1005 を超える VLAN ID(拡張範囲 VLAN)を追加する手順については、「拡張範囲 VLAN の設定」を参照してください。


ステップ 3

name vlan-name

(任意)VLAN の名前を入力します。VLAN 名を指定しなかった場合には、デフォルトとして、VLAN という語の後ろに先行ゼロを含めた vlan-id が付加されます。たとえば、VLAN 4 のデフォルトの VLAN 名は VLAN0004 です。

ステップ 4

mtu mtu-size

(任意)MTU サイズ(または他の VLAN 特性)を変更します。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 7

copy running-config startup config

(任意)スイッチが VTP トラスペアレント モードである場合、VLAN 設定は実行コンフィギュレーション ファイルと VLAN データベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLAN 名をデフォルト設定に戻すには、 no vlan name または no vlan mtu config-vlan コマンドを使用します。

次に、config-vlan モードを使用して、イーサネット VLAN 20 を作成し、 test20 という名前を付け、VLAN データベースに追加する例を示します。

Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end
 

VLAN コンフィギュレーション モードを使用してイーサネット VLAN を作成または変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

vlan database

VLAN データベース コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id name vlan-name

番号を割り当てることによって、イーサネット VLAN を追加します。指定できる範囲は 1 ~ 1001 です。先行 0 は入力しないでください。

VLAN 名を指定しなかった場合には、デフォルトとして、VLAN という語の後ろに先行ゼロを含めた vlan-id が付加されます。たとえば、VLAN 4 のデフォルトの VLAN 名は VLAN0004 です。

ステップ 3

vlan vlan-id mtu mtu-size

(任意)VLAN を変更するには、VLAN を指定し、MTU サイズなどの特性を変更します。

ステップ 4

exit

VLAN データベースをアップデートし、アップデート情報を管理ドメイン全体に伝播して、特権 EXEC モードに戻ります。

ステップ 5

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 6

copy running-config startup config

(任意)スイッチが VTP トラスペアレント モードである場合、VLAN 設定は実行コンフィギュレーション ファイルと VLAN データベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLAN 名をデフォルト設定に戻すには、 no vlan vlan-id name VLAN コンフィギュレーション コマンドを使用します。

次に、VLAN データベース コンフィギュレーション モードを使用して、イーサネット VLAN 20 を作成し、 test20 という名前を付け、VLAN データベースに追加する例を示します。

Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
APPLY completed.
Exiting....
Switch#

VLAN の削除

VTP サーバ モードのスイッチから VLAN を削除すると、VTP ドメイン内のすべてのスイッチの VLAN データベースから、その VLAN が削除されます。VTP トランスペアレント モードのスイッチから VLAN を削除した場合、そのスイッチに限って VLAN が削除されます。

メディア タイプが異なるデフォルトの VLAN を削除することはできません。たとえば、イーサネット VLAN 1、および FDDI またはトークンリング VLAN の 1002 ~ 1005 を削除することはできません。


注意 VLAN を削除すると、その VLAN に割り当てられていたすべてのポートが非アクティブになります。これらのポートは、新しい VLAN に割り当てられるまで、元の VLAN に(非アクティブで)対応付けられたままです。

グローバル コンフィギュレーション モードを使用してスイッチ上で VLAN を削除するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no vlan vlan-id

VLAN ID を入力して、VLAN を削除します。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show vlan brief

VLAN が削除されたことを確認します。

ステップ 5

copy running-config startup config

(任意)スイッチが VTP トラスペアレント モードである場合、VLAN 設定は実行コンフィギュレーション ファイルと VLAN データベースに保存されます。この場合、スイッチのスタートアップ コンフィギュレーション ファイルに設定が保存されます。

VLAN データベース コンフィギュレーション モードで VLAN を削除するには、 vlan database 特権 EXEC コマンド使用して、VLAN データベース コンフィギュレーション モードを開始してから、 no vlan vlan-id VLAN コンフィギュレーション コマンドを実行します。

VLAN へのスタティック アクセス ポートの割り当て

VTP をディセーブル(VTP トランスペアレント モード)にすることによって VLAN 設定情報をグローバルに伝播せずに、スタティック アクセス ポートを VLAN に割り当てることができます。クラスタ メンバー スイッチのポートを VLAN に割り当てる場合、最初に rcommand 特権 EXEC コマンドを使用して、そのメンバー スイッチにログインします。


) 存在しない VLAN にインターフェイスを割り当てると、新しい VLAN が作成されます(イーサネット VLAN の作成または変更を参照)。


VLAN データベース内の VLAN にポートを割り当てるには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

VLAN に追加するインターフェイスを入力します。

ステップ 3

switchport mode access

ポート(レイヤ 2 アクセス ポート)の VLAN メンバーシップ モードを定義します。

ステップ 4

switchport access vlan vlan-id

VLAN にポートを割り当てます。有効な VLAN ID は 1 ~ 4094 です。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show running-config interface interface-id

インターフェイスの VLAN メンバーシップ モードを確認します。

ステップ 7

show interfaces interface-id switchport

表示された Administrative Mode および Access Mode VLAN フィールドの設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 default interfac e interface-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、ポートを VLAN 2 のアクセス ポートとして設定する例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end
Switch#

拡張範囲 VLAN の設定

スイッチが VTP トランスペアレント モード(VTP がディセーブル)の場合、拡張範囲 VLAN(VLAN ID を許可する任意のスイッチ ポート コマンドについては 1006 ~ 4094 の範囲)を作成できます。config-vlan モードにアクセスし、拡張範囲 VLAN を設定するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを入力します。VLAN データベース コンフィギュレーション モード( vlan database 特権 EXEC コマンドを入力することによりアクセス)は、拡張範囲をサポートしていません。

拡張範囲 VLAN の設定は、VLAN データベースには保存されません。VTP モードがトランスペアレントであるため、スイッチの実行コンフィギュレーション ファイルに保存されます。
copy running-config startup-config 特権 EXEC コマンドを使用すると、スタートアップ コンフィギュレーション ファイルに設定を保存できます。


) スイッチは 4094 個の VLAN ID をサポートしますが、実際にサポートされる VLAN の数については「サポートされる VLAN」を参照してください。


ここでは、拡張範囲 VLAN に関する次の情報を示します。

「VLAN のデフォルト設定」

「拡張範囲 VLAN 設定時の注意事項」

「拡張範囲 VLAN の作成」

「VLAN の表示」

VLAN のデフォルト設定

イーサネット VLAN のデフォルト設定については、 表13-2 を参照してください。拡張範囲 VLAN で変更できるのは、MTU サイズだけです。その他のすべての特性はデフォルト ステートのまま残してください。

拡張範囲 VLAN 設定時の注意事項

拡張範囲 VLAN を作成するときは次の注意事項に従ってください。

拡張範囲 VLAN を追加するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを使用して、config-vlan モードを開始する必要があります。VLAN データベース コンフィギュレーション モード(開始するには vlan database 特権 EXEC コマンドを入力することによりアクセス)では、拡張範囲 VLAN を追加できません。

拡張範囲の VLAN ID は、VLAN データベースに保存されず、VTP で認識されません。

プルーニング適格範囲に拡張範囲 VLAN を含めることはできません。

拡張範囲 VLAN を作成するときは、スイッチを VTP トランスペアレント モードにする必要があります。VTP モードがサーバまたはクライアントの場合、エラー メッセージが生成され、拡張範囲 VLAN が拒否されます。

グローバル コンフィギュレーション モードまたは VLAN データベース コンフィギュレーション モードで、VTP モードをトランスペアレントに設定できます。「VTP のディセーブル化(VTP トランスペアレント モード)」を参照してください。VTP トランスペアレント モードでスイッチが起動するように、この設定をスタートアップ コンフィギュレーションに保存する必要があります。このようにしないと、スイッチをリセットした場合に、拡張範囲 VLAN 設定が失われます。

拡張範囲 VLAN は、VQP によってサポートされません。VMPS で設定することはできません。

拡張範囲 VLAN では、STP はデフォルトでイネーブルですが、no spanning-tree vlan vlan-id グローバル コンフィギュレーション コマンドを使用してディセーブルにできます。スイッチ上に最大数(64)のスパニング ツリー インスタンスが存在している場合に、VLAN を新規作成すると、この VLAN 上でスパニング ツリーはディセーブルになります。スイッチ上の VLAN の数がサポートされているスパニング ツリー インスタンスの最大数を超える場合、スイッチ上に IEEE 802.1S MSTP を設定して、複数の VLAN を単一の STP インスタンスにマッピングすることを推奨します。MSTP の詳細については、「MSTP の設定」を参照してください。

拡張範囲 VLAN の作成

グローバル コンフィギュレーション モードで拡張範囲 VLAN を作成するには、 vlan グローバル コンフィギュレーション コマンドを入力し、1006 ~ 4094 の VLAN ID を指定します。このコマンドによって config-vlan モードが開始されます。拡張範囲 VLAN はデフォルトのイーサネット VLAN 特性( 表13-2 を参照)を使用します。変更できるパラメータは MTU サイズだけです。すべてのパラメータのデフォルト値については、コマンド リファレンスに記載された vlan グローバル コンフィギュレーション コマンドの説明を参照してください。スイッチが VTP トランスペアレント モードでない場合に拡張範囲 VLAN ID を入力すると、config-vlan モードの終了時にエラー メッセージが生成され、拡張範囲 VLAN が作成されません。

拡張範囲 VLAN は VLAN データベースに保存されずに、スイッチの実行コンフィギュレーション ファイルに保存されます。拡張範囲 VLAN 設定をスイッチのスタートアップ コンフィギュレーション ファイルに保存するには、 copy running-config startup-config 特権 EXEC コマンドを使用します。

拡張範囲 VLAN を作成するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp mode transparent

スイッチを VTP トランスペアレント モードに設定します(VTP をディセーブルにします)。

ステップ 3

vlan vlan-id

拡張範囲 VLAN ID を入力して、config-vlan モードを開始します。指定できる範囲は 1006 ~ 4094 です。

ステップ 4

mtu mtu-size

(任意)MTU サイズを変更して、VLAN を変更します。


) config-vlan モードの CLI ヘルプにはすべての VLAN コマンドが表示されますが、拡張範囲 VLAN でサポートされるのは mtu mtu-size コマンドだけです。


ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show vlan id vlan-id

VLAN が作成されたことを確認します。

ステップ 7

copy running-config startup config

スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。拡張範囲 VLAN 設定を保存するには、VTP トランスペアレント モード設定および拡張範囲 VLAN 設定をスイッチのスタートアップ コンフィギュレーション ファイルに保存する必要があります。これらを保存しないと、スイッチをリセットした場合に、スイッチがデフォルトで VTP サーバ モードになり、拡張範囲 VLAN ID は保存されません。

拡張範囲 VLAN を削除するには、 no vlan vlan-id グローバル コンフィギュレーション コマンドを使用します。

スタティック アクセス ポートを拡張範囲 VLAN に割り当てる手順は、標準範囲 VLAN の手順と同じです。「VLAN へのスタティック アクセス ポートの割り当て」を参照してください。

次に、すべてデフォルトの特性で拡張範囲 VLAN を新規作成し、config-vlan モードを開始して、新規 VLAN をスイッチのスタートアップ コンフィギュレーション ファイルに保存する例を示します。

Switch(config)# vtp mode transparent
Switch(config)# vlan 2000
Switch(config-vlan)# end
Switch# copy running-config startup config
 

VLAN の表示

拡張範囲 VLAN を含む、スイッチ上のすべての VLAN のリストを表示するには、 show vlan 特権 EXEC コマンドを使用します。VLAN ステータス、ポート、および設定情報も表示されます。VLAN データベース内の標準範囲 VLAN(1 ~ 1005)を表示するには、 show VLAN コンフィギュレーション コマンド(開始するには vlan database 特権 EXEC コマンドを入力)を使用します。スイッチ上の VLAN ID のリストを表示するには、 show running-config vlan 特権 EXEC コマンドを使用します。オプションとして、VLAN ID 範囲を入力することもできます。

表13-3 に VLAN をモニタするためのコマンドを示します。

 

表13-3 VLAN モニタ コマンド

コマンド
コマンド モード
目的

show

VLAN コンフィギュレーション

VLAN データベース内の VLAN のステータスを表示します。

show current [ vlan-id ]

VLAN コンフィギュレーション

VLAN データベース内のすべての VLAN または特定の VLAN のステータスを表示します。

show interfaces [ vlan vlan-id ]

特権 EXEC

スイッチ上に設定されたすべてのインターフェイスまたは特定の VLAN の特性を表示します。

show running-config vlan

特権 EXEC

スイッチ上のすべての VLAN または特定の範囲の VLAN を表示します。

show vlan [ id vlan-id ]

特権 EXEC

スイッチ上のすべての VLAN または特定の VLAN のパラメータを表示します。

show コマンド オプションおよび出力フィールドの詳細については、このリリースに対応するコマンド リファレンスを参照してください。

VLAN トランクの設定

ここでは、スイッチの VLAN トランク機能について説明します。

「トランキングの概要」

「IEEE 802.1Q の設定に関する考慮事項」

「レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定」

トランキングの概要

トランクは、1 つまたは複数のイーサネット スイッチ インターフェイスと他のネットワーキング装置(ルータ、スイッチなど)の間のポイントツーポイント リンクです。ファスト イーサネットおよびギガビット イーサネット トランクは単一リンクを介して複数の VLAN トラフィックを伝送できるため、VLAN をネットワーク全体に拡張できます。

スイッチは、業界標準のトランキング カプセル化である IEEE 802.1Q をサポートしています。

図13-2に、IEEE 802.1Q トランクで接続されているスイッチ ネットワークを示します。

図13-2 IEEE 802.1Q トランキング カプセル化のスイッチ

 

トランクを設定できるのは、1 つのイーサネット インターフェイスまたは EtherChannel バンドルに対してです。EtherChannel の詳細については、「EtherChannel の設定」を参照してください。

イーサネット トランク インターフェイスは、 表13-4 に示すトランキング モードをサポートしています。インターフェイスをトランキングまたは非トランキングとして設定したり、近接インターフェイスとトランキングをネゴシエートするように設定できます。トランキングの自動ネゴシエーションを設定するには、インターフェイスが同じ VTP ドメインに存在する必要があります。

トランク ネゴシエーションは、PPP(ポイントツーポイント プロトコル)である Dynamic Trunking Protocol(DTP)によって管理されます。ただし、一部のインターネットワーキング装置によって DTP フレームが不正に転送されて、誤った設定となる場合があります。

この事態を避けるには、DTP をサポートしない装置に接続されたインターフェイスが DTP フレームを転送しないように、つまり DTP をオフにするように設定する必要があります。

これらのリンクを介してトランキングを行わない場合は、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、トランキングをディセーブルにします。

DTP をサポートしていない装置へのトランキングをイネーブルにするには、 switchport mode trunk および switchport nonegotiate インターフェイス コンフィギュレーション コマンドを使用して、インターフェイスがトランクになっても DTP フレームを生成しないように設定します。

 

表13-4 レイヤ 2 インターフェイス モード

モード
機能

switchport mode access

インターフェイス(アクセス ポート)を永続的な非トランキング モードにします。インターフェイスは、近接インターフェイスがトランク インターフェイスの場合にも、非トランク インターフェイスになります。

switchport mode dynamic desirable

インターフェイスがリンクのトランク リンクへの変換をアクティブに実行するようにします。インターフェイスは、近接インターフェイスが trunk desirable 、または auto モードに設定されている場合、トランク インターフェイスになります。すべてのイーサネット インターフェイスのデフォルトのスイッチポート モードは dynamic desirable です。

switchport mode dynamic auto

インターフェイスがリンクをトランク リンクに変換できるようにします。インターフェイスは、近接インターフェイスが trunk または desirable モードに設定されている場合、トランク インターフェイスになります。

switchport mode trunk

インターフェイスを永続的なトランキング モードにして、リンクのトランク リンクへの変換をネゴシエートします。インターフェイスは、近接インターフェイスがトランク インターフェイスでない場合にも、トランク インターフェイスになります。

switchport nonegotiate

インターフェイスが DTP フレームを生成しないようにします。このコマンドは、インターフェイス スイッチポート モードが access または trunk の場合だけ使用できます。トランク リンクを確立するには、手動で近接インターフェイスをトランク インターフェイスとして設定する必要があります。

IEEE 802.1Q の設定に関する考慮事項

IEEE 802.1Q トランクに関して、ネットワーク上で次の制限事項があります。

IEEE 802.1Q トランクを使用して接続しているシスコ スイッチのネットワークでは、トランク上で許容される VLAN ごとに 1 つのスパニング ツリー インスタンスを維持します。他社製の装置は、すべての VLAN でスパニング ツリー インスタンスを 1 つサポートしています。

IEEE 802.1Q トランクを介してシスコ スイッチを他社製の装置に接続する場合、シスコ スイッチは、トランクの VLAN のスパニング ツリー インスタンスを、他社製の IEEE 802.1Q スイッチのスパニング ツリー インスタンスと統合します。ただし、各 VLAN のスパニング ツリー情報は、他社製の IEEE 802.1Q スイッチからなるクラウドにより分離されたシスコ スイッチによって維持されます。シスコ スイッチを分離する他社製の IEEE 802.1Q クラウドは、スイッチ間の単一トランク リンクとして扱われます。

IEEE 802.1Q トランクに対応するネイティブ VLAN が、トランク リンクの両端で一致していなければなりません。トランクの片側のネイティブ VLAN と反対側のネイティブ VLAN が異なっていると、スパニング ツリー ループが発生する可能性があります。

ネットワーク上のすべてのネイティブ VLAN についてスパニング ツリーをディセーブルにしないで、IEEE 802.1Q トランクのネイティブ VLAN 上のスパニング ツリーをディセーブルにすると、スパニング ツリー ループが発生することがあります。IEEE 802.1Q トランクのネイティブ VLAN 上でスパニング ツリーをイネーブルのままにしておくか、またはネットワーク上のすべての VLAN でスパニング ツリーをディセーブルにすることを推奨します。また、ネットワークにループがないことを確認してから、スパニング ツリーをディセーブルにしてください。

レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

表13-5 に、レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定を示します。

 

表13-5 レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

機能
デフォルト設定

インターフェイス モード

switchport mode dynamic desirable

VLAN 許可範囲

VLAN 1 ~ 4094

プルーニングに適格な VLAN 範囲

VLAN 2 ~ 1001

デフォルト VLAN(アクセス ポート用)

VLAN 1

ネイティブ VLAN(IEEE 802.1Q トランク用)

VLAN 1

トランク ポートとしてのイーサネット インターフェイスの設定

トランク ポートは VTP アドバタイズを送受信するので、VTP を使用する場合は、スイッチ上で少なくとも 1 つのトランク ポートが設定されており、そのトランク ポートが第 2 のスイッチのトランク ポートに接続されていることを確認する必要があります。そうでない場合、スイッチは VTP アドバタイズを受信できません。

ここでは、スイッチ上でイーサネット インターフェイスをトランク ポートとして設定する手順を示します。

「他の機能との相互作用」

「トランクでの許可 VLAN の定義」

「プルーニング適格リストの変更」

「タグなしトラフィック用ネイティブ VLAN の設定」


) レイヤ 2 インターフェイスのデフォルト モードは、switchport mode dynamic desirable インターフェイス コンフィギュレーション モードです。近接インターフェイスがトランキングをサポートしており、トランキングを許可する設定になっている場合、リンクはレイヤ 2 トランクになります。


他の機能との相互作用

トランキングは他の機能と次のように相互作用します。

トランク ポートをセキュア ポートにすることはできません。

トランク ポートをまとめて EtherChannel ポート グループにすることはできますが、グループ内のすべてのトランクに同じ設定をする必要があります。グループを初めて作成したときには、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。次のパラメータのいずれかについて、設定を変更すると、設定値がスイッチによってグループ内のすべてのポートに伝播されます。

許可 VLAN リスト

各 VLAN の STP ポート プライオリティ

STP PortFast の設定値

トランク ステータス(ポート グループ内の 1 つのポートがトランクでなくなると、すべてのポートがトランクでなくなります)

トランク ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。IEEE 802.1x 対応ポートをトランクに変更しようとしても、ポート モードは変更されません。

ダイナミック モードのポートは、ネイバーとトランク ポートへの変更をネゴシエートする場合があります。ダイナミック ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。IEEE 802.1x 対応ポートをダイナミック ポートに変更しようとしても、ポート モードは変更されません。

IEEE 802.1Q トランクでは保護ポートがサポートされています。

トランク ポートの設定

ポートを IEEE 802.1Q トランク ポートとして設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トランキング用に設定するポートを入力します。

ステップ 3

switchport mode { dynamic { auto | desirable } | trunk }

インターフェイスをレイヤ 2 トランクとして設定します(インターフェイスがレイヤ 2 アクセス ポートである場合、またはトランキング モードを指定する場合に限り必須です)。

dynamic auto -- 近接インターフェイスが trunk または desirable モードに設定されている場合に、インターフェイスをトランク リンクとして設定します。

dynamic desirable -- 近接インターフェイスが trunk、desirable、または auto モードに設定されている場合に、インターフェイスをトランク リンクとして設定します。

trunk -- 近接インターフェイスがトランク インターフェイスでない場合でも、インターフェイスを永続的なトランキング モードに設定して、リンクをトランク リンクに変換するようにネゴシエートします。

ステップ 4

switchport access vlan vlan-id

(任意)インターフェイスがトランキングを停止した場合に使用するデフォルト VLAN を指定します。

ステップ 5

switchport trunk native vlan vlan-id

ネイティブ VLAN を指定します。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show interfaces interface-id switchport

インターフェイスのスイッチポート設定を表示します。 Administrative Mode および Administrative Trunking Encapsulation フィールドに表示されます。

ステップ 8

show interfaces interface-id trunk

インターフェイスのトランク設定を表示します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。トランキング インターフェイスのすべてのトランキング特性をデフォルトにリセットするには、 no switchport trunk インターフェイス コンフィギュレーション コマンドを使用します。トランキングをディセーブルにするには、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、ポートをスタティック アクセス ポートとして設定します。

次に、ポートを IEEE 802.1Q トランクとして設定する例を示します。この例では、近接インターフェイスが IEEE 802.1Q トランクをサポートするように設定されていることを前提としています。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# switchport mode dynamic desirable
Switch(config-if)# end

トランクでの許可 VLAN の定義

デフォルトでは、トランク ポートはすべての VLAN に対してトラフィックを送受信します。すべての VLAN ID は各トランクで許可されます。しかし、許可リストから VLAN を削除することにより、それらの VLAN からのトラフィックがトランク上を流れないようにできます。トランクが伝送するトラフィックを制限するには、 switchport trunk allowed vlan remove vlan-list インターフェイス コンフィギュレーション コマンドを使用して、許可リストから特定の VLAN を削除します。

スパニング ツリーのループまたはストームのリスクを軽減するため、VLAN 1 を許可リストから削除することで、個々の VLAN トランク ポート上の VLAN 1 をディセーブルにできます。この方法は、VLAN 1 の最小化と呼ばれます。VLAN 1 の最小化は、個々の VLAN トランク リンク上の VLAN 1(すべてのシスコ スイッチ トランク ポート上のデフォルト VLAN)をディセーブルにします。結果として、スパニング ツリーのアドバタイズを含む非ユーザのトラフィックが VLAN 1 上で送受信されます。

VLAN 1 をトランク ポートから削除しても、インターフェイスは管理トラフィックを送受信し続けます(VLAN 1 内の Cisco Discovery Protocol [CDP]、Port Aggregation Protocol [PAgP]、Link Aggregation Control Protocol [LACP]、DTP、VTP など)。

ディセーブルにされた VLAN 1 のトランク ポートが非トランク ポートに変更された場合、アクセス VLAN に追加されます。アクセス VLAN が 1 に設定されている場合、ポートは、 switchport trunk allowed の設定にかかわらず VLAN 1 に追加されます。ポート上でディセーブルになっている VLAN については同様のことが言えます。

トランク ポートは、VLAN がイネーブルになっており、VTP が VLAN を認識し、かつポートの許可リストにその VLAN が登録されている場合に、VLAN のメンバーになることができます。VTP が新しくイネーブルにされた VLAN を認識し、その VLAN がトランク ポートの許可リストに登録されている場合、トランク ポートは自動的にその VLAN のメンバーになります。VTP が新しい VLAN を認識し、その VLAN がトランク ポートの許可リストに登録されていない場合には、トランク ポートはその VLAN のメンバーにはなりません。

IEEE 802.1Q トランクの許可リストを変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、設定するポートを入力します。

ステップ 3

switchport mode trunk

インターフェイスを VLAN トランク ポートとして設定します。

ステップ 4

switchport trunk allowed vlan { add | all | except | remove } vlan-list

(任意)トランク上で許可される VLAN のリストを設定します。

add all except remove キーワードの使用方法については、このリリースに対応するコマンド リファレンスを参照してください。

vlan-list パラメータは、1 ~ 4094 の単一の VLAN 番号、または 2 つの VLAN 番号(小さい方が先、ハイフンで区切る)で指定された VLAN 範囲です。カンマで区切った VLAN パラメータの間、またはハイフンで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべての VLAN が許可されます。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Trunking VLANs Enabled フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべての VLAN の許可 VLAN リストをデフォルトに戻すには、 no switchport trunk allowed vlan インターフェイス コンフィギュレーション コマンドを使用します。

次に、許可 VLAN リストから VLAN 2 を削除する例を示します。

Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end
Switch#

プルーニング適格リストの変更

プルーニング適格リストは、トランク ポートだけに適用されます。トランク ポートごとに独自の適格リストがあります。この手順を有効にするには、VTP プルーニングがイネーブルに設定されている必要があります。VTP プルーニングをイネーブルにする方法については、「VTP プルーニングのイネーブル化」を参照してください。

トランク ポートのプルーニング適格リストから VLAN を削除するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、VLAN プルーニングを適用するトランク ポートを選択します。

ステップ 3

switchport trunk pruning vlan { add | except | none | remove } vlan-list [ ,vlan [ ,vlan [ ,,, ]]]

トランクからのプルーニングを許可する VLAN のリストを設定します( VTP プルーニングを参照)。

add except none remove キーワードの使用方法については、このリリースに対応するコマンド リファレンスを参照してください。

連続していない VLAN ID は、カンマ(スペースなし)で区切ります。ID の範囲は、ハイフンで表します。有効な ID は、2 ~ 1001 です。 拡張範囲 VLAN(VLAN ID 1006 ~ 4094) はプルーニングできません。

プルーニング不適格の VLAN は、フラッディング トラフィックを受信します。

デフォルトでは、プルーニングが許可される VLAN のリストには、VLAN 2 ~ 1001 が含まれます。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show interfaces interface-id switchport

表示された Pruning VLANs Enabled フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべての VLAN のプルーニング適格リストをデフォルトに戻すには、 no switchport trunk pruning vlan インターフェイス コンフィギュレーション コマンドを使用します。

タグなしトラフィック用ネイティブ VLAN の設定

IEEE 802.1Q タギングが設定されたトランク ポートは、タグ付きトラフィックおよびタグなしトラフィックの両方を受信できます。デフォルトでは、タグなしトラフィックは、ポートに設定されたネイティブ VLAN に転送されます。ネイティブ VLAN は、デフォルトでは VLAN 1 です。


) ネイティブ VLAN は、管理 VLAN とは関係なく、任意の VLAN ID を割り当てることができます。


IEEE 802.1Q 設定の詳細については、「IEEE 802.1Q の設定に関する考慮事項」を参照してください。

IEEE 802.1Q トランクでネイティブ VLAN を設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、IEEE 802.1Q トランクとして設定するインターフェイスを定義します。

ステップ 3

switchport trunk native vlan vlan-id

トランク ポート上でタグなしトラフィックを送受信する VLAN を設定します。

vlan-id の範囲は 1 ~ 4094 です。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show interfaces interface-id switchport

Trunking Native Mode VLAN フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ネイティブ VLAN をデフォルト(VLAN 1)に戻すには、 no switchport trunk native vlan インターフェイス コンフィギュレーション コマンドを使用します。

パケットの VLAN ID が発信ポートのネイティブ VLAN ID と同じであれば、そのパケットはタグなしで送信されます。ネイティブ VLAN ID と異なる場合は、スイッチはそのパケットをタグ付きで送信します。

STP によるロード シェアリング

ロード シェアリングにより、スイッチに接続しているパラレル トランクの提供する帯域幅が分割されます。STP は通常、ループを防止するために、スイッチ間で 1 つのパラレル リンク以外のすべてのリンクをブロックします。ロード シェアリングを行うと、トラフィックの属する VLAN に基づいて、リンク間でトラフィックが分割されます。

トランク ポートでロード シェアリングを設定するには、STP ポート プライオリティまたは STP パス コストを使用します。STP ポート プライオリティを使用してロード シェアリングを設定する場合には、両方のロード シェアリング リンクを同じスイッチに接続する必要があります。STP パス コストを使用してロード シェアリングを設定する場合には、それぞれのロード シェアリング リンクを同一のスイッチにも、2 台の異なるスイッチにも接続できます。STP の詳細については、「STP の設定」を参照してください。

STP ポート プライオリティによるロード シェアリング

同一スイッチ上の 2 つのポートがループを形成すると、イネーブルになるポートとブロッキング ステートになるポートは、STP ポート プライオリティの設定によって決まります。パラレル トランク ポートにプライオリティを設定することにより、そのポートに、特定の VLAN のすべてのトラフィックを伝送させることができます。VLAN に対するプライオリティの高い(値の小さい)トランク ポートがその VLAN のトラフィックを転送します。同じ VLAN に対してプライオリティの低い(値の大きい)トランク ポートは、その VLAN に対してブロッキング ステートのままです。1 つのトランク ポートが特定の VLAN に関するすべてのトラフィックを送受信することになります。

図13-3 に、サポート対象スイッチを接続する 2 つのトランクを示します。この例では、スイッチは次のように設定されています。

VLAN 8 ~ 10 は、トランク 1 で 16 というポート プライオリティが割り当てられています。

VLAN 3 ~ 6 は、トランク 1 でデフォルトのポート プライオリティである 128 のままです。

VLAN 3 ~ 6 は、トランク 2 で 16 というポート プライオリティが割り当てられています。

VLAN 8 ~ 10 は、トランク 2 でデフォルトのポート プライオリティである 128 のままです。

このように設定すると、トランク 1 が VLAN 8 ~ 10 のトラフィックを伝送し、トランク 2 が VLAN 3 ~ 6 のトラフィックを伝送します。アクティブ トランクで障害が起きた場合には、プライオリティの低いトランクが引き継ぎ、それらすべての VLAN のトラフィックを伝送します。いずれのトランク ポート上でも、トラフィックの重複は発生しません。

図13-3 STP ポート プライオリティによるロード シェアリング

 

 

図13-3 に示すように、ネットワークを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

スイッチ 1 で、グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp domain domain-name

VTP 管理ドメインを設定します。

1 ~ 32 文字のドメイン名を使用できます。

ステップ 3

vtp mode server

スイッチ 1 を VTP サーバとして設定します。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show vtp status

スイッチ A およびスイッチ B の両方で、VTP 設定を確認します。

表示された VTP Operating Mode および VTP Domain Name フィールドをチェックします。

ステップ 6

show vlan

スイッチ A のデータベースに VLAN が存在していることを確認します。

ステップ 7

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 8

interface fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、トランクとして設定されるインターフェイスとしてポート FastEthernet 0/1 を定義します。

ステップ 9

switchport mode trunk

ポートをトランク ポートとして設定します。

ステップ 10

end

特権 EXEC モードに戻ります。

ステップ 11

show interfaces fastethernet 0/1switchport

VLAN 設定を確認します。

ステップ 12

スイッチ A のポート FastEthernet port 0/2 についてステップ 7 ~ 11 を繰り返します。

ステップ 13

スイッチ B でステップ 7 ~ 11 を繰り返し、ポート FastEthernet 0/1 および 0/2 のトランク ポートを設定します。

ステップ 14

show vlan

トランク リンクがアクティブになると、VTP がスイッチ B に VTP および VLAN 情報を渡します。スイッチ B が VLAN 設定を学習していることを確認します。

ステップ 15

configure terminal

スイッチ A で、グローバル コンフィギュレーション モードを開始します。

ステップ 16

interface fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、STP ポート プライオリティを設定するインターフェイスを定義します。

ステップ 17

spanning-tree vlan 8-10 port-priority 16

VLAN 8 ~ 10 にポート プライオリティ 16 を割り当てます。

ステップ 18

spanning-tree vlan 10 port-priority 16

VLAN 10 にポート プライオリティ 16 を割り当てます。

ステップ 19

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 20

interface fastethernet 0/2

インターフェイス コンフィギュレーション モードを開始し、STP ポート プライオリティを設定するインターフェイスを定義します。

ステップ 21

spanning-tree vlan 3-6 port-priority 16

VLAN 3 ~ 6 にポート プライオリティ 16 を割り当てます。

ステップ 22

end

特権 EXEC モードに戻ります。

ステップ 23

show running-config

設定を確認します。

ステップ 24

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

STP パス コストによるロード シェアリング

トランクに異なるパス コストを設定し、各パス コストを異なる VLAN 群に対応付けることにより、VLAN トラフィックを分散するようにパラレル トランクを設定できます。VLAN はトラフィックを個別に維持します。ループが発生しないので、STP によってポートがディセーブルになることもなく、またリンクが切断されても冗長性が維持されます。

図13-4 で、トランク ポート 1 および 2 は 100BASE-T ポートです。VLAN のパス コストは次のように設定されています。

VLAN 2 ~ 4 には、トランク ポート 1 で 30 というパス コストが割り当てられています。

VLAN 8 ~ 10 は、トランク ポート 1 で 100BASE-T のデフォルトのパス コストである 19 のままです。

VLAN 8 ~ 10 には、トランク ポート 2 で 30 というパス コストが割り当てられています。

VLAN 2 ~ 4 は、トランク ポート 2 で 100BASE-T のデフォルトのパス コストである 19 のままです。

図13-4 パス コストによってトラフィックが分散されるロード シェアリング トランク

 

図13-4 に示すように、ネットワークを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

スイッチ A で、グローバル コンフィギュレーション モードを開始します。

ステップ 2

interfa c e fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、トランクとして設定されるインターフェイスとしてポート FastEthernet 0/1 を定義します。

ステップ 3

switchport mode trunk

ポートをトランク ポートとして設定します。

ステップ 4

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 5

スイッチ A でインターフェイス FastEthernet 0/2 についてステップ 2 ~ 4 を繰り返します。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show running-config

設定を確認します。

表示されたインターフェイス FastEthernet 0/1 および FastEthernet 0/2 がトランク ポートとして設定されていることを確認します。

ステップ 8

show vlan

トランク リンクがアクティブになると、スイッチ A が他のスイッチから送られた VTP 情報を受信します。スイッチ A が VLAN 設定を学習していることを確認します。

ステップ 9

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 10

interface fastethernet 0/1

インターフェイス コンフィギュレーション モードを開始し、STP コストを設定するインターフェイスとしてポート FastEthernet 0/1 を定義します。

ステップ 11

spanning-tree vlan 2-4 cost 30

VLAN 2 ~ 4 についてスパニング ツリー パス コストを 30 に設定します。

ステップ 12

end

グローバル コンフィギュレーション モードに戻ります。

ステップ 13

スイッチ A でインターフェイス FastEthernet 0/2 についてステップ 9 ~ 11 を繰り返し、VLAN 8、9、10 について、スパニング ツリー パス コストを 30 に設定します。

ステップ 14

exit

特権 EXEC モードに戻ります。

ステップ 15

show running-config

設定を確認します。

表示されたインターフェイス FastEthernet 0/1 および FastEthernet 0/2 にパス コストが正しく設定されていることを確認します。

ステップ 16

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VMPS の設定

スイッチを VMPS サーバにすることはできませんが、VMPS のクライアントとして機能させ、VLAN Query Protocol(VQP)を介して通信できます。VMPS はダイナミックアクセス ポート VLAN メンバーシップを動的に割り当てます。

ここでは、VMPS の設定に関する次の情報について説明します。

「VMPS の概要」

「VMPS クライアントのデフォルト設定」

「VMPS 設定時の注意事項」

「VMPS クライアントの設定」

「VMPS のモニタ」

「ダイナミック ポート VLAN メンバーシップのトラブルシューティング」

「VMPS の設定例」

VMPS の概要

VMPS がクライアント スイッチから VQP 要求を受信すると、VMPS はデータベースを検索して MAC アドレスと VLAN のマッピングを調べます。サーバの応答は、このマッピングと、サーバがセキュア モードであるかどうかに基づいて行われます。VLAN がポート上で許可されない場合にサーバがそのポートをシャットダウンするか、または単に VLAN へのポート アクセスを拒否するかはセキュア モードによって決定されます。

VMPS は要求に対する応答として、次のいずれかの動作を実行します。

割り当てられた VLAN がポートのグループに制限されている場合、VMPS は要求側のポートをこのグループと照らし合わせて確認し、次のように応答します。

そのポートで VLAN が許可されている場合、VMPS は応答で VLAN 名をクライアントに送信します。

そのポートで VLAN が許可されておらず、なおかつ VMPS がセキュア モードでない場合、VMPS は アクセス拒否 応答を送信します。

そのポートで VLAN が許可されておらず、なおかつ VMPS がセキュア モードである場合、VMPS は ポート シャットダウン 応答を送信します。

データベース内の VLAN がポート上の現在の VLAN と一致せず、なおかつポート上にアクティブ ホストが存在する場合、VMPS は VMPS のセキュア モードに応じて、 アクセス拒否 または ポート シャットダウン 応答を送信します。

VMPS から アクセス拒否 応答を受信した場合、スイッチはその MAC アドレスまたはポートからのトラフィックを引き続きブロックします。スイッチはポート宛てのパケットを引き続きモニタし、新しいアドレスを検出すると VMPS にクエリーを送信します。VMPS から ポート シャットダウン 応答を受信した場合、スイッチはそのポートをディセーブルにします。デバイス マネージャ、CLI、Network Assistant、または SNMP を使用して、ポートを手動で再度イネーブルにする必要があります。

また、コンフィギュレーション テーブルの明示的なエントリを使用して、特定の MAC アドレスへのアクセスを、セキュリティ上の理由から拒否することもできます。VLAN 名に none キーワードを入力すると、VMPS セキュア モード設定に応じて、VMPS は アクセス拒否 または ポート シャットダウン 応答を送信します。

ダイナミック ポート VLAN メンバーシップ

スイッチのダイナミック(非トランキング)ポートが所属できるのは、VLAN ID が 1 ~ 1005 の 1 つの VLAN だけです。リンクがアップになっても、VMPS によって VLAN が割り当てられるまで、このポートとの間でトラフィック転送は行われません。VMPS は、ダイナミック ポートに接続した新しいホストの最初のパケットから送信元 MAC アドレスを受信し、VMPS データベースによってその MAC アドレスと VLAN との一致処理を試みます。

一致する VLAN が存在すれば、VMPS はそのポートの VLAN 番号を送信します。クライアント スイッチがまだ設定されていない場合は、スイッチは VMPS からトランク ポートで受信した最初の VTP パケットからのドメイン名を使用します。クライアント スイッチがすでに設定されている場合は、クエリー パケットにスイッチのドメイン名を含めて VMPS に送信し、VLAN 番号を取得します。VMPS はパケット内のドメイン名が自身のドメイン名と一致することを確認したあと、要求を受け入れ、クライアントに割り当てられた VLAN 番号を応答します。一致する VLAN が存在しなければ、(VMPS セキュア モードの設定に応じて)VMPS は要求を拒否するか、またはポートをシャットダウンします。

ダイナミック ポート上で複数のホスト(MAC アドレス)をアクティブにできますが、それらのホストはすべて同じ VLAN に存在する必要があります。ただし、ポート上でアクティブなホスト数が 20 を超えると、VMPS はダイナミック ポートをシャットダウンします。

ダイナミック ポート上でリンクがダウンになると、ポートは隔離されたステートに戻り、VLAN には属しません。ポート経由でオンラインになるホストは VMPS によって VQP 経由で再チェックされ、そのあとポートが VLAN に割り当てられます。

VMPS データベース コンフィギュレーション ファイル

VMPS には、ユーザが作成するデータベース コンフィギュレーション ファイルが含まれています。この ASCII テキスト ファイルは、VMPS サーバとして動作する、スイッチからアクセス可能な TFTP サーバに保存します。このファイルには、VMPS 情報(ドメイン名、代替 VLAN 名、MAC アドレスと VLAN のマッピングなど)が指定されています。このスイッチを VMPS として機能させることはできませんが、Catalyst 5000 または Catalyst 6000 シリーズ スイッチを VMPS として使用できます。

代替 VLAN 名を設定できます。データベースにない MAC アドレスを持つ装置を接続すると、VMPS は代替 VLAN 名をクライアントに送信します。代替 VLAN 名を設定しないで、なおかつ MAC アドレスがデータベースに存在しない場合には、VMPS は アクセス拒否 応答を送信します。VMPS がセキュア モードの場合には、 ポート シャットダウン 応答を送信します。

ポート名が VMPS データベース コンフィギュレーション ファイルで使用されている場合、サーバはスイッチのポート名に関する表記法を使用する必要があります。たとえば、Fa0/4Gi0/17 は、固定ファスト イーサネット ポート番号 4 ギガビット イーサネット ポート番号 17 を表します。スイッチがクラスタ メンバーである場合は、コマンド スイッチによってタイプの前にスイッチ名が追加されます。たとえば、 es3%Fa0/4es3%Gi0/17 は、メンバー スイッチ 3 の固定ファスト イーサネット ポート番号 4 ギガビット イーサネット ポート番号 17 を表します。ポート名が必要なときに、VMPS データベース コンフィギュレーション ファイルをクラスタ サポート用に設定する場合は、この表記法を使用する必要があります。

VMPS クライアントのデフォルト設定

表13-6 に、クライアント スイッチ上の VMPS およびダイナミック ポートのデフォルト設定を示します。

 

表13-6 VMPS クライアントおよびダイナミック ポートのデフォルト設定

機能
デフォルト設定

VMPS ドメイン サーバ(VMPS Domain Server)

なし

VMPS 再確認インターバル

60 分

VMPS サーバ再試行回数

3

ダイナミック ポート

設定なし

VMPS 設定時の注意事項

ダイナミック アクセス ポート VLAN メンバーシップには、次の注意事項および制限事項があります。

VMPS を設定してから、ポートをダイナミックとして設定する必要があります。

スイッチ クラスタと VMPS の間の通信は、コマンド スイッチによって管理され、標準のポート名とは異なるポート名の表記法を使用します。クラスタ ベースのポート名の表記法については、「VMPS データベース コンフィギュレーション ファイル」を参照してください。

ポートをダイナミック アクセス ポートとして設定すると、そのポートに対してスパニング ツリーの PortFast 機能が自動的にイネーブルになります。PortFast モードにより、ポートをフォワーディング ステートに設定するプロセスが短縮されます。

IEEE 802.1x ポートをダイナミック アクセス ポートとして設定することはできません。ダイナミックアクセス(VQP)ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。IEEE 802.1x 対応ポートを変更してダイナミック VLAN を割り当てようとしても、エラー メッセージが表示され、VLAN 設定は変更されません。

トランク ポートをダイナミックアクセス ポートにすることはできませんが、トランク ポートに対して switchport access vlan dynamic インターフェイス コンフィギュレーション コマンドを入力することは可能です。その場合、スイッチの設定は維持され、あとでアクセス ポートとして設定された場合には、その設定が適用されます。

ダイナミックアクセス設定を有効にするには、事前にポート上でトランキングをオフにする必要があります。

ダイナミック アクセス ポートは、ネットワーク ポートまたはモニタ ポートにすることはできません。

セキュア ポートをダイナミック アクセス ポートにすることはできません。ポートをダイナミックにするには、事前にポート上でポート セキュリティをディセーブルにする必要があります。

ダイナミック アクセス ポートを EtherChannel グループのメンバーにすることはできません。

ポート チャネルをダイナミックアクセス ポートとして設定することはできません。

VMPS クライアントと VMPS サーバの VTP 管理ドメインは、同じでなければなりません。

VQP は拡張範囲 VLAN(VLAN ID が 1006 より大きい)をサポートしません。拡張範囲 VLAN は、VMPS で設定することはできません。

VMPS サーバ上に設定された VLAN を音声 VLAN にしないでください。

VMPS クライアントの設定

ダイナミック VLAN を設定するには、VMPS(サーバ)を使用します。スイッチを VMPS クライアントにすることはできますが、VMPS サーバにすることはできません。

VMPS の IP アドレスの入力

スイッチをクライアントとして設定するには、サーバの IP アドレスを最初に入力する必要があります。


) スイッチ クラスタに対して VMPS を定義する場合は、コマンド スイッチにこのアドレスを入力する必要があります。


VMPS の IP アドレスを入力するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps server ipaddress primary

プライマリ VMPS サーバとして動作するスイッチの IP アドレスを入力します。

ステップ 3

vmps server ipaddress

セカンダリ VMPS サーバとして動作するスイッチの IP アドレスを入力します。

セカンダリ サーバのアドレスは、3 つまで入力できます。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show vmps

表示された VMPS Domain Server フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。


) VMPS サーバに接続されたスイッチ ポートをダイナミックアクセス ポートにすることはできません。このポートは、スタティック アクセス ポートまたはトランク ポートのいずれかにできます。「トランク ポートとしてのイーサネット インターフェイスの設定」を参照してください。


VMPS クライアント上のダイナミック アクセス ポートの設定

クラスタ メンバー スイッチのポートをダイナミック ポートとして設定するには、最初に rcommand 特権 EXEC コマンドを使用して、そのメンバー スイッチにログインします。


注意 ダイナミック ポート VLAN メンバーシップは端末用、または端末に接続されたハブ用です。他のスイッチにダイナミック アクセス ポートを接続すると、接続が切断されることがあります。

VMPS クライアント スイッチにダイナミック アクセス ポートを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、端末に接続されたスイッチ ポートを指定します。

ステップ 3

switchport mode access

ポートをアクセス モードにします。

ステップ 4

switchport access vlan dynamic

ポートをダイナミック VLAN メンバーシップ適格として設定します。

ダイナミック アクセス ポートは、端末に接続されている必要があります。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Operational Mode フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。インターフェイスをデフォルトのスイッチポート モード(dynamic desirable)に戻すには、 no switchport mode インターフェイス コンフィギュレーション コマンドを使用します。アクセス モードをスイッチのデフォルト VLAN にリセットするには、 no switchport access インターフェイス コンフィギュレーション コマンドを使用します。


switchport access vlan dynamic インターフェイス コンフィギュレーション コマンドを使用して、ダイナミック アクセス ポートを設定すると、インターフェイスが DTP ネゴシエーションを介してアクセス モードからトランク モードに変更されるときに、不正ユーザがネットワーク リソースにアクセスするおそれがあります。その問題を回避するには、ポートをスタティック アクセス ポートとして設定します。


VLAN メンバーシップの再確認

スイッチが VMPS から受信したダイナミック ポート VLAN メンバーシップの割り当てを確認するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

vmps reconfirm

ダイナミック ポート VLAN メンバーシップを再確認します。

ステップ 2

show vmps

ダイナミック VLAN の再確認ステータスを確認します。

再確認インターバルの変更

VMPS クライアントは、VMPS から受信する VLAN メンバーシップ情報を定期的に再確認します。再確認が行われる間隔(分)を設定できます。

クラスタのメンバー スイッチを設定する場合、このパラメータはコマンド スイッチの再確認インターバルの設定値以上でなければなりません。メンバー スイッチにログインするには、最初に rcommand 特権 EXEC コマンドを使用する必要があります。

再確認インターバルを変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps reconfirm minutes

ダイナミック VLAN メンバーシップの再確認を行う間隔(分)を入力します。

1 ~ 120 分の値を入力します。デフォルトは 60 分です。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show vmps

表示された Reconfirm Interval フィールドのダイナミック VLAN の再確認ステータスを確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチのデフォルト設定に戻すには、 no vmps reconfirm グローバル コンフィギュレーション コマンドを使用します。

再試行回数の変更

スイッチが次のサーバにクエリーを送信する前に、VMPS との接続を試行する回数を変更するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps retry count

再試行回数を変更します。

指定できる再試行回数の範囲は 1 ~ 10 回です。デフォルトは 3 回です。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show vmps

表示された Server Retry Count フィールドの設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチのデフォルト設定に戻すには、 no vmps retry グローバル コンフィギュレーション コマンドを使用します。

VMPS のモニタ

show vmps 特権 EXEC コマンドを使用して、VMPS に関する情報を表示できます。スイッチは VMPS に関する次の情報を表示します。

 

VMPS VQP バージョン(VMPS VQP Version)

VMPS との通信に使用する VQP のバージョン。スイッチは VQP バージョン 1 を使用する VMPS にクエリーを送信します。

再確認インターバル(Reconfirm Interval)

スイッチが VLAN と MAC アドレスの割り当てを再確認する間隔(分)。

サーバ再試行回数
(Server Retry Count)

VQP が VMPS にクエリーを再送信する回数。この回数すべてを試行しても応答が得られない場合、スイッチはセカンダリ VMPS へのクエリーを開始します。

VMPS ドメイン サーバ(VMPS Domain Server)

設定されている VLAN メンバーシップ ポリシー サーバの IP アドレス。スイッチは current に指定があるサーバにクエリーを送信します。primary と表示されているサーバが、プライマリ サーバです。

VMPS 動作
(VMPS Action)

最新の再確認の結果。再確認は、再確認インターバルが経過したときに自動的に行われますが、 vmps reconfirm 特権 EXEC コマンドを入力するか、Network Assistant または SNMP で同等の操作を行うことによって、強制的に再確認することもできます。

次に、 show vmps 特権 EXEC コマンドの出力例を示します。

Switch# show vmps
 
VQP Client Status:
--------------------
VMPS VQP Version: 1
Reconfirm Interval: 60 min
Server Retry Count: 3
VMPS domain server: 172.20.128.86 (primary, current)
172.20.128.87
 
Reconfirmation status
---------------------
VMPS Action: No Dynamic Port
 

ダイナミック ポート VLAN メンバーシップのトラブルシューティング

VMPS は次の状況でダイナミック ポートをシャットダウンします。

VMPS がセキュア モードであり、なおかつホストのポートへの接続を許可しない場合。VMPS はポートをシャットダウンして、ホストがネットワークに接続できないようにします。

ダイナミック ポート上のアクティブ ホストが 20 を超えた場合。

ディセーブル化されているダイナミック ポートを再びイネーブルにするには、 no shutdown インターフェイス コンフィギュレーション コマンドを使用します。

VMPS の設定例

図13-5 に、VMPS サーバ スイッチと、ダイナミック ポートを備えた VMPS クライアント スイッチを含むネットワークの例を示します。この例の前提条件は次のとおりです。

VMPS サーバと VMPS クライアントは、それぞれ別個のスイッチです。

Catalyst 6500 シリーズであるスイッチ A が、プライマリ VMPS サーバです。

Catalyst 5000 シリーズであるスイッチ C および J が、セカンダリ VMPS サーバです。

端末は、クライアント、スイッチ B、およびスイッチ I に接続されます。

データベース コンフィギュレーション ファイルは、IP アドレス 172.20.22.7 の TFTP サーバに保存されています。

図13-5 ダイナミック ポート VLAN メンバーシップの構成例