Catalyst 2940 スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.1(22)EA7
SmartPort マクロの設定
SmartPort マクロの設定
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

SmartPort マクロの設定

SmartPort マクロの概要

SmartPort マクロの設定

SmartPort マクロのデフォルト設定

SmartPort マクロ設定時の注意事項

SmartPort マクロの作成

SmartPort マクロの適用

シスコのデフォルト設定の Smartport マクロの適用

SmartPort マクロの表示

SmartPort マクロの設定

この章では、Catalyst 2940 スイッチ上で SmartPort マクロを設定し、適用する方法について説明します。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「SmartPort マクロの概要」

「SmartPort マクロの設定」

「SmartPort マクロの表示」

SmartPort マクロの概要

SmartPort マクロは共通の設定を保存、共有する利便性を提供します。SmartPort マクロを使用すると、ネットワークのスイッチの場所に基づいて機能および設定をイネーブルにできます。また、ネットワークを介した大量の設定配信に使用することもできます。

各 SmartPort マクロは、定義した CLI(コマンドライン インターフェイス)コマンドで構成されます。SmartPort マクロには新しい CLI コマンドは含まれません。既存の CLI コマンドを単純にグループ化するものです。

SmartPort マクロをインターフェイス上に適用すると、マクロ内の CLI コマンドがインターフェイス上に設定されます。インターフェイスにマクロが適用されても、既存のインターフェイスの設定は失われません。新しいコマンドがインターフェイスに追加され、実行コンフィギュレーション ファイルに保存されます。

スイッチ ソフトウェアには、シスコのデフォルト設定で Smartport マクロが埋め込まれています( 表9-1 を参照)。 show parser macro ユーザ EXEC コマンドを使用すると、Smartport マクロに含まれる次のマクロおよびコマンドが表示されます。

 

表9-1 シスコのデフォルトの Smartport マクロ

マクロ名 1
説明

cisco-global

VLAN 間の負荷分散をイネーブルにして、スパニングツリー インスタンスの高速コンバージェンスを提供し、ポートのエラー回復をイネーブルにするには、このグローバル コンフィギュレーション マクロを使用します

cisco-desktop

PC などのデスクトップ装置がスイッチ ポートに接続しているとき、ネットワークのセキュリティおよび信頼性の向上のために、このインターフェイス コンフィギュレーション マクロを使用します

cisco-phone

Cisco IP Phone と接続する PC などのデスクトップ装置がスイッチ ポートに接続しているときは、このインターフェイス コンフィギュレーション マクロを使用します。このマクロは cisco-desktop マクロの拡張で、セキュリティおよび復元力の機能は同じですが、専用の音声 VLAN を追加することにより、遅延に影響されやすい音声トラフィックの適切な処理を保証します。

cisco-switch

アクセス スイッチとディストリビューション スイッチの接続時、または、ギガスタック モジュールまたは GBIC(ギガビット インターフェイス コンバータ)を使用して接続されたアクセス スイッチ間の接続時には、このインターフェイス コンフィギュレーション マクロを使用します

cisco-router

スイッチおよび WAN ルータの接続時には、このインターフェイス コンフィギュレーション マクロを使用します

cisco-wireless

スイッチおよびワイヤレス アクセス ポイントの接続時には、このインターフェイス コンフィギュレーション マクロを使用します

1.シスコのデフォルトの Smartport マクロは、スイッチ上で稼働するソフトウェア バージョンにより異なります。

また、シスコでは Catalyst スイッチ用に、事前テスト済みでシスコ推奨のベースライン コンフィギュレーション テンプレート集を提供しています。オンラインのリファレンス ガイド テンプレートでは、ポートの使用方法に基づいて Smartport マクロを作成できる CLI コマンドを提供しています。コンフィギュレーション テンプレートを使用して Smartport マクロを作成し、シスコ推奨のネットワークの構成および設定を構築および配備できます。シスコ推奨のコンフィギュレーション テンプレートの詳細については、次の Smartport の Web サイトを参照してください。

http://www.cisco.com/go/smartports

SmartPort マクロの設定

新しい SmartPort マクロを作成、または既存のマクロをテンプレートとして使用し、利用するアプリケーション固有の新しいマクロを作成できます。マクロ作成後、単一のスイッチ、または単一のスイッチ インターフェイスや特定の範囲のインターフェイスにグローバルに適用できます。

ここでは、次の内容について説明します。

「SmartPort マクロのデフォルト設定」

「SmartPort マクロ設定時の注意事項」

「SmartPort マクロの作成」

「SmartPort マクロの適用」

「シスコのデフォルト設定の Smartport マクロの適用」

SmartPort マクロのデフォルト設定

イネーブルな Smartport マクロはありません。

SmartPort マクロ設定時の注意事項

スイッチにマクロを設定するときには、次の注意事項に従ってください。

マクロを作成するときは、 exit または end コマンドを使用したり、または interface interface-id を使用してコマンド モードを変更したりしないでください。異なるコマンド モードで exit end 、または interface interface-id が実行される場合があります。

マクロ作成時、すべての CLI コマンドは同じコンフィギュレーション モードである必要があります。

一意の値を割り当てる必要があるマクロを作成するときは、 parameter value キーワードを使用して、インターフェイスに固有の値を指定します。キーワードの一致では、大文字と小文字が区別されます。キーワードがすべて一致すると、対応する値に交換されます。より大きいストリングの一部であっても、キーワードが完全一致すると一致したとみなされ、対応する値に交換されます。

マクロ名では、大文字と小文字が区別されます。たとえば、コマンド macro name Sample-Macro および macro name sample-macro は、2 つの別々のマクロとなります。

マクロには、パラメータ値を必要とするキーワードを含むものもあります。 macro global apply macro-name ? グローバル コンフィギュレーション コマンドまたは macro apply macro-name ? インターフェイス コンフィギュレーション コマンドを使用して、マクロで必要な任意の値のリストを表示できます。キーワード値を入力せずにマクロを適用する場合、コマンドは無効になり、適用されません。

スイッチまたはスイッチ インターフェイスにグローバルなマクロが適用されると、インターフェイス上の既存のすべての設定が保持されます。これは、増分設定を適用する際に役立ちます。

コマンドの追加または削除によってマクロの定義を変更する場合、既に元のマクロが適用されているインターフェイスには変更は反映されません。新しいコマンド、または変更したコマンドで更新されたマクロをインターフェイスに再度適用する必要があります。

macro global trace macro-name グローバル コンフィギュレーション コマンドまたは macro trace macro-name インターフェイス コンフィギュレーション コマンドを使用してマクロを適用およびデバッグし、任意の構文エラーまたはコンフィギュレーション エラーを検出できます。構文またはコンフィギュレーションのエラーが原因でコマンドが無効になる場合、マクロは引き続き残りのコマンドを適用します。

特定のインターフェイス タイプに特化している CLI コマンドもあります。マクロがその設定を受け入れないインターフェイスに適用されると、マクロは構文チェックおよび設定確認ができず、スイッチはエラー メッセージを戻します。

マクロをインターフェイス範囲に適用することは、マクロを単一のインターフェイスに適用することと同じです。インターフェイス範囲を使用すると、マクロはその範囲内の各インターフェイスに順番に適用されていきます。1 つのインターフェイスでマクロ コマンドが失敗しても、残りのインターフェイスには引き続き適用されます。

スイッチまたはスイッチ インターフェイスにマクロを適用すると、このマクロ名がスイッチまたはスイッチ インターフェイスに自動的に追加されます。 show running-config ユーザ EXEC コマンドを使用して、適用されたコマンドおよびマクロ名を表示できます。

スイッチ ソフトウェアには、シスコのデフォルト設定で Smartport マクロが埋め込まれています。 show parser macro ユーザ EXEC コマンドを使用すると、Smartport マクロに含まれる次のマクロおよびコマンドが表示されます。

インターフェイスにシスコのデフォルトの Smartport マクロを適用する場合には、次の注意事項に従ってください。

スイッチのすべてのマクロを表示するには、 show parser macro ユーザ EXEC コマンドを使用します。特定のマクロの内容を表示するには、 show parser macro name macro-name ユーザ EXEC コマンドを使用します。

$ で始まるキーワードは、一意のパラメータ値が必要であることを意味します。シスコのデフォルトであるマクロに必要な値を使用して付加するには、 parameter value キーワードを使用します。

シスコのデフォルトのマクロでは、 $ 文字を使用して必要なキーワードを識別します。マクロの作成時、キーワードを定義する $ 文字の使用に制限はありません。

SmartPort マクロの作成

SmartPort マクロを作成するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します

ステップ 2

macro name macro-name

マクロの定義を作成し、マクロ名を入力します。マクロの定義には最大 3,000 文字まで使用できます。

各行にマクロ コマンドを 1 つ入力します。マクロの最後には @ を使用してください。開始行には # を使用して、マクロ内にコマンドの説明を入力してください。

(任意)ヘルプ ストリングを使用してキーワードを指定することにより、マクロ内のキーワードを定義できます。マクロで使用できるキーワードを定義するには、 # macro keywords word を入力します。マクロでは、スペースで区切って最大 3 つのヘルプ ストリング キーワードを入力できます。

マクロ名では、大文字と小文字が区別されます。たとえば、コマンド macro name Sample-Macro および macro name sample-macro は、2 つの別々のマクロとなります。

マクロでは、 exit コマンドまたは end コマンドを使用したり、または interface interface-id を使用してコマンド モードを変更したりしないことを推奨します。異なるコマンド モードで exit end 、または interface interface-id が実行される場合があります。最良の結果を出すには、マクロ内のすべてのコマンドを、同じコンフィギュレーション モードにしてください。

ステップ 3

end

イネーブル EXEC モードに戻ります

ステップ 4

show parser macro name macro-name

マクロが作成されたかどうかを確認します

macro name グローバル コンフィギュレーション コマンドの no 形式は、マクロの定義を削除するだけです。マクロがすでに適用されているインターフェイスの設定には、削除による影響はありません。

次に、スイッチポート アクセス VLAN およびセキュア MAC(メディア アクセス制御)アドレス数を定義し、さらに # macro keywords を使用することにより、2 つのヘルプ ストリング キーワードを含むマクロを作成する例を示します。

Switch(config)# macro name test
switchport access vlan $VLANID
switchport port-security maximum $MAX
#macro keywords $VLANID $MAX
@
 

SmartPort マクロの適用

SmartPort マクロを適用するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します

ステップ 2

macro global { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

macro global apply macro-name により、マクロに定義された各コマンドをスイッチに適用します。 macro global trace macro-name を指定して、マクロを適用およびデバッグし、任意の構文エラーまたはコンフィギュレーション エラーを検出します。

(任意)スイッチに固有の一意のパラメータ値を指定します。キーワード値のペアは、3 つまで入力できます。パラメータ キーワードの一致では、大文字と小文字が区別されます。キーワードがすべて一致すると、対応する値に交換されます。

マクロには、パラメータ値を必要とするキーワードを含むものもあります。 macro global apply macro-name ? コマンドを使用して、マクロで必要な任意の値のリストを表示できます。キーワード値を入力せずにマクロを適用する場合、コマンドは無効になり、適用されません。

ステップ 3

macro global description text

(任意)スイッチに適用するマクロの説明を入力します

ステップ 4

interface interface-id

(任意)インターフェイス コンフィギュレーション モードを開始し、マクロを適用するインターフェイスを指定します

ステップ 5

default interface interface-id

(任意)指定されたインターフェイスからすべての設定をクリアします

ステップ 6

macro { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

macro apply macro-name により、マクロに定義された各コマンドを、インターフェイスに適用します。 macro trace macro-name を指定して、マクロを適用およびデバッグし、構文エラーまたはコンフィギュレーション エラーを検出します。

(任意)インターフェイスに固有の一意のパラメータ値を指定します。キーワード値のペアは、3 つまで入力できます。パラメータ キーワードの一致では、大文字と小文字が区別されます。キーワードがすべて一致すると、対応する値に交換されます。

マクロには、パラメータ値を必要とするキーワードを含むものもあります。 macro apply macro-name ? コマンドを使用して、マクロで必要な任意の値のリストを表示できます。キーワード値を入力せずにマクロを適用する場合、コマンドは無効になり、適用されません。

ステップ 7

macro description text

(任意)インターフェイスに適用するマクロの説明を入力します

ステップ 8

end

イネーブル EXEC モードに戻ります

ステップ 9

show parser macro description [ interface interface-id ]

インターフェイスに適用されたマクロを確認します

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します

マクロ内の各コマンドの no バージョンを入力することによってのみ、スイッチ上に適用されたグローバルなマクロ設定を削除できます。 default interface interface-id インターフェイス コンフィギュレーション コマンドを入力すると、インターフェイス上に適用されたマクロ設定を削除できます。

次に、ユーザが作成した snmp という名前のマクロを適用し、ホスト名のアドレスを test-server と設定し、IP precedence 値を 7 に設定する例を示します。

Switch(config)# macro global apply snmp ADDRESS test-server VALUE 7
 

次に、 macro global trace グローバル コンフィギュレーション コマンドを使用して、ユーザが作成した snmp という名前のマクロをデバッグし、スイッチに適用される際に、マクロ内の構文エラーまたはコンフィギュレーション エラーを検出する例を示します。

Switch(config)# macro global trace snmp VALUE 7
Applying command...‘snmp-server enable traps port-security’
Applying command...‘snmp-server enable traps linkup’
Applying command...‘snmp-server enable traps linkdown’
Applying command...‘snmp-server host’
%Error Unknown error.
Applying command...‘snmp-server ip precedence 7’
 

次に、ユーザが作成した desktop-config という名前のマクロを適用し、その設定を確認する例を示します。

Switch(config)# interface fastethernet0/2
Switch(config-if)# macro apply desktop-config
Switch(config-if)# end
Switch# show parser macro description
Interface Macro Description
--------------------------------------------------------------
Gi0/2 desktop-config
--------------------------------------------------------------
 

次に、ユーザが作成した desktop-config という名前のマクロを適用し、すべての VLAN 1 を VLAN 25 に置き換える例を示します。

Switch(config-if)# macro apply desktop-config vlan 25
 

シスコのデフォルト設定の Smartport マクロの適用

SmartPort マクロを適用するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

show parser macro

スイッチ ソフトウェアに組み込まれたシスコのデフォルトの Smartport マクロを表示します

ステップ 2

show parser macro name macro-name

適用する特定のマクロを表示します

ステップ 3

configure terminal

グローバル コンフィギュレーション モードを開始します

ステップ 4

macro global { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

parameter value キーワードを使用して、シスコのデフォルトのマクロに必要な値を付加し、スイッチにマクロを適用します。 $ で始まるキーワードは、一意のパラメータ値が必要であることを意味します。

macro global apply macro-name ? コマンドを使用して、マクロで必要な任意の値のリストを表示できます。キーワード値を入力せずにマクロを適用する場合、コマンドは無効になり、適用されません。

ステップ 5

interface interface-id

(任意)インターフェイス コンフィギュレーション モードを開始し、マクロを適用するインターフェイスを指定します

ステップ 6

default interface interface-id

(任意)指定されたインターフェイスからすべての設定をクリアします

ステップ 7

macro { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

parameter value キーワードを使用して、シスコデフォルト マクロを必要な値を使用して付加し、インターフェイスにマクロを適用します。 $ で始まるキーワードは、一意のパラメータ値が必要であることを意味します。

macro apply macro-name ? コマンドを使用して、マクロで必要な任意の値のリストを表示できます。キーワード値を入力せずにマクロを適用する場合、コマンドは無効になり、適用されません。

ステップ 8

end

イネーブル EXEC モードに戻ります

ステップ 9

show running-config interface interface-id

インターフェイスに適用されたマクロを確認します

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します

マクロ内の各コマンドの no バージョンを入力することによってのみ、スイッチ上に適用されたグローバルなマクロ設定を削除できます。 default interface interface-id インターフェイス コンフィギュレーション コマンドを入力すると、インターフェイス上に適用されたマクロ設定を削除できます。

次に、 cisco-desktop マクロを表示してマクロを適用し、インターフェイス上のアクセス VLAN ID を 25 に設定する例を示します。

Switch# show parser macro cisco-desktop
--------------------------------------------------------------
Macro name : cisco-desktop
Macro type : default
 
# Basic interface - Enable data VLAN only
# Recommended value for access vlan (AVID) should not be 1
switchport access vlan $AVID
switchport mode access
 
# Enable port security limiting port to a single
# MAC address -- that of desktop
switchport port-security
switchport port-security maximum 1
 
# Ensure port-security age is greater than one minute
# and use inactivity timer
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
 
# Configure port as an edge network port
spanning-tree portfast
spanning-tree bpduguard enable
--------------------------------------------------------------
Switch#
Switch# configure terminal
Switch(config)# fastethernet0/4
Switch(config-if)# macro apply cisco-desktop $AVID 25
 

SmartPort マクロの表示

SmartPort マクロを表示するには、 表9-2 のイネーブル EXEC コマンドを 1 つまたは複数使用します。

 

表9-2 SmartPort マクロを表示するコマンド

コマンド
目的

show parser macro

設定されたすべてのマクロを表示します

show parser macro name macro-name

特定のマクロを表示します

show parser macro brief

設定されたマクロ名を表示します

show parser macro description [ interface interface-id ]

すべてのインターフェイスまたは特定のインターフェイスのマクロの説明を表示します