Cisco IOS IP ルーティング:OSPF コマンド リファ レンス
OSPF コマンド-2
ip ospf flood-reduction
発行日;2012/02/05 | 英語版ドキュメント(2011/04/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

ip ospf flood-reduction

ip ospf hello-interval

ip ospf lls

ip ospf message-digest-key md5

ip ospf mtu-ignore

ip ospf name-lookup

ip ospf network

ip ospf prefix-suppression

ip ospf priority

ip ospf resync-timeout

ip ospf retransmit-interval

ip ospf shutdown

ip ospf transmit-delay

ip ospf ttl-security

limit retransmissions

local-rib-criteria

log-adjacency-changes

max-lsa

max-metric router-lsa

neighbor (OSPF)

neighbor database-filter all out

network area

nsf (OSPF)

nsf cisco

nsf cisco helper disable

nsf ietf

nsf ietf helper disable

nsf ietf helper strict-lsa-checking

prefix-suppression

process-min-time percent

redistribute maximum-prefix

router ospf

router-id

ip ospf flood-reduction

安定したトポロジ内に不要なリンクステート アドバタイズメント(LSA)がフラッディングされるのを抑制するには、インターフェイス コンフィギュレーション モードで、 ip ospf flood-reduction コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ip ospf flood-reduction

no ip ospf flood-reduction

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.1(2)T

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

Open Shortest Path First(OSPF)デマンド回線をサポートするすべてのルータは、フラッド リダクションをサポートするルータと互換性があり、対話できます。

次に、シリアル インターフェイス 0 上の LSA の不要なフラッディングを削減する例を示します。

interface serial 0
ip ospf flood-reduction

 
関連コマンド

コマンド
説明

show ip ospf interface

OSPF 関連のインターフェイス情報を表示します。

show ip ospf neighbor

OSPF のネイバ情報をインターフェイス単位で表示します。

ip ospf hello-interval

Cisco IOS ソフトウェアがインターフェイスで送信する hello パケットの間隔を指定するには、インターフェイス コンフィギュレーション モードで ip ospf hello-interval コマンドを使用します。デフォルトの時間間隔に戻すには、このコマンドの no 形式を使用します。

ip ospf hello-interval seconds

no ip ospf hello-interval

 
シンタックスの説明

seconds

間隔(秒単位)を指定します。値は特定のネットワークのすべてのノードで同一にする必要があります。値の範囲は 1 ~ 65535 です。

 
デフォルト

10 秒(イーサネット)

30 秒(非ブロードキャスト)

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

この値は hello パケットでアドバタイズされます。hello 間隔が短いほどトポロジの変更が早く検出されますが、ルーティング トラフィックがその分多くなります。この値は、特定のネットワーク上のすべてのルータおよびアクセス サーバで同じにする必要があります。

次に、hello パケットの間隔を 15 秒に設定する例を示します。

interface ethernet 1
ip ospf hello-interval 15

 
関連コマンド

コマンド
説明

ip ospf dead-interval

hello パケットを表示できない、ルータがダウンしたとネイバが宣言するまでの期間を設定します。

ip ospf lls

インターフェイスで Link-Local Signaling(LLS)をイネーブルにするには、ルータレベルの LLS 設定にかかわらず、インターフェイス コンフィギュレーション モードで ip ospf lls コマンドを使用します。ルータレベルの LLS 設定を特定のインターフェイス上に再設定するには、このコマンドの no または default バージョンを使用します。

ip ospf lls [ disable ]

{ no | default } ip ospf lls [ disable ]

 
シンタックスの説明

no

ルータ レベルで設定済みである、インターフェイスのデフォルトの LLS 設定に戻します。

default

インターフェイスに指定済みである、グローバル(ルータ レベル)の LLS 設定を継承します。

disable

(任意)グローバル(ルータ レベル)の設定にかかわらず、指定されたインターフェイス上の LLS をディセーブルにします。

 
デフォルト

LLS はイネーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(27)S

このコマンドが追加されました。

12.3(7)T

このコマンドが、Cisco IOS Release 12.3(7)T に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(18)SXE

このコマンドが、Cisco IOS Release 12.2(18)SXE に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン

デフォルトでは、各 Open Shortest Path First(OSPF)インターフェイスは、ルータ レベルから LLS 設定を継承します。 ip ospf lls インターフェイスレベル コマンドは、 capability lls ルータレベル コマンドより優先されます。たとえば、 no capability lls コマンドを入力してルータ レベルで LLS をディセーブルにしている場合、 ip ospf lls コマンドを使用すると特定のインターフェイスの LLS を選択的にイネーブル化できます。これは、これら指定されたインターフェイスに限定した OSPF Nonstop Forwarding(NSF; ノンストップ フォワーディング)を認識する機能をルータでイネーブルにできるようにするためです。

インターフェイスの LLS 設定を取り消すには、ルータ レベルで設定済みのインターフェイスに対するデフォルトの LLS 設定に戻すための default ip ospf lls コマンドまたは no ip ospf lls コマンドを入力します。たとえば、ルータ レベルで capability lls コマンドがイネーブル(デフォルト)の場合、LLS を適切に処理しないルータが存在するネットワーク セグメントで相互運用するといった場合に、特定のインターフェイスの LLS に対して default ip ospf lls コマンドまたは no ip ospf lls コマンドを使用するとこれをディセーブルにできます。


) LLS 機能がデフォルトでイネーブルに設定されている OSPF を実行しているネットワークの場合、LLS はすべてのインターフェイスでグローバルにイネーブルです。ネットワークのルータが RFC 2328 非準拠のシスコ以外のデバイスに接続されている場合、OSPF ネイバの形成に関するネットワーク障害が発生する可能性があります。このような場合は、ip ospf lls コマンドに disable キーワードを指定して使用し、シスコ以外のデバイスに接続するルータの LLS をディセーブルにすることをお勧めします。


次に、イーサネット インターフェイス 2/0 上の LLS をディセーブルにする例を示します。

Router(config)# interface Ethernet2/0
Router(config-if)# ip address 10.1.145.2 255.255.0.0
Router(config-if)# no ip directed-broadcast
Router(config-if)# ip ospf message-digest-key 1 md5 testing
Router(config-if)# ip ospf lls disable

 
関連コマンド

コマンド
説明

capability lls

発信済み OSPF パケットの LLS データ ブロックの使用をイネーブルにし、OSPF NSF 認識を再びイネーブルにします。

show ip ospf interface

OSPF 関連のインターフェイス情報を表示します。

ip ospf message-digest-key md5

Open Shortest Path First(OSPF)Message Digest 5(MD5)認証をイネーブルにするには、インターフェイス コンフィギュレーション モードで ip ospf message-digest-key md5 コマンドを使用します。以前の MD5 キーを削除するには、このコマンドの no 形式を使用します。

ip ospf message-digest-key key-id encryption-type md5 key

no ip ospf message-digest-key key-id

 
シンタックスの説明

key-id

1 ~ 255 の範囲の識別子。

encryption-type

暗号化レベル。値の範囲は 0 ~ 7 です。0 は、暗号なしを指定します。7 は、シスコ独自の暗号化レベルを指定します。

key

最大 16 バイトの英数字パスワード。

 
デフォルト

OSPF MD5 認証はディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

11.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

通常、インターフェイスごとにキーを 1 つ使用してパケット送信時の認証情報を生成したり、着信パケットを認証したりします。同一のキー識別子を持つネイバ ルータ間では、 key 値を同一にする必要があります。

次に、キーの変更プロセスを示します。現在、次のように設定されていると想定します。

interface ethernet 1
ip ospf message-digest-key 100 md5 OLD
 

設定を変更するには次のようにします。

interface ethernet 1
ip ospf message-digest-key 101 md5 NEW
 

システムからはネイバにはまだ新しいキーがないと見なされるため、ロールオーバー プロセスが開始されます。同じパケットの複数のコピーが送信され、それぞれ異なるキーで認証されます。この例では、システムは同じパケットのコピーを 2 つ送信し、それぞれをキー 100 とキー 101 で認証します。

隣接するルータはロールオーバーにより、ネットワーク管理者が新しいキーで更新中も通信を継続できます。すべてのネイバが新しいキーを認識したことをローカル システムが検出すると、ロールオーバーは停止します。新しいキーで認証されたネイバからパケットをネイバが受信した時点で、このネイバに新しいキーが与えられたことが検出されます。

すべてのネイバが新しいキーで更新されたら、以前のキーを削除する必要があります。この例では、次のように入力します。

interface ethernet 1
no ip ospf message-digest-key 100
 

次に、イーサネット インターフェイス 1 の認証にキー 101 だけが使用されます。

インターフェイスごとに保持するキーは 1 つだけにすることをお勧めします。以前のキーを知っている不正なシステムとローカル システムが通信し続けるのを防ぐために、新しいキーを追加したらそのたびに以前のキーを削除する必要があります。以前のキーを削除すると、ロールオーバー中のオーバーヘッドも削減されます。


) OSPF MD5 認証を実装するときに service password-encryption コマンドを使用しないと、MD5 シークレットは NVRAM にプレーン テキストとして保存されます。


Release 12.2(33)SXH

Cisco IOS Release 12.2(33)SXH までは、ip ospf message-digest-key md5 コマンドとともに、key 引数として英数字パスワード値を入力すると、ルータはアカウンティング レコードとともにそのコマンドのクリア テキストを AAA サーバに送信していましたが、これは、パスワードがユーザ側に表示されることを意味していました。AAA アカウンティング サーバは、ルータから送信されるパスワードとともにレコードも表示しました。Cisco IOS Release 12.2(33)SXH では、この動作が変更された結果、syslog メッセージおよびアカウンティング レコードにパスワードが含まれなくなりました。

次に、新しいキー 19 にパスワード 8ry4222 を設定する例を示します。

interface ethernet 1
ip ospf message-digest-key 10 md5 xvv560qle
ip ospf message-digest-key 19 md5 8ry4222

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証をイネーブルにします。

ip ospf authentication

インターフェイスの認証タイプを指定します。

service password-encryption

パスワードを暗号化します。

ip ospf mtu-ignore

受信する Database Descriptor(DBD; データベース記述子)パケットに対する Open Shortest Path First(OSPF)Maximum Transmission Unit(MTU; 最大伝送ユニット)ミスマッチをディセーブルにするには、インターフェイス コンフィギュレーション モードで ip ospf mtu-ignore コマンドを使用します。デフォルトにリセットするには、このコマンドの no 形式を使用します。

ip ospf mtu-ignore

no ip ospf mtu-ignore

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

OSPF MTU ミスマッチ検出はイネーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(3)

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

OSPF は、ネイバが共通インターフェイスで同一の MTU を使用しているかどうかをチェックします。このチェックは、ネイバによる DBD パケットの交換時に行われます。DBD パケットに受信した MTU が着信インターフェイスに設定されている IP MTU より高い場合、OSPF の隣接性は確立されません。

次に、受信 DBD パケットでの MTU ミスマッチ検出をディセーブルにする例を示します。

interface serial 0/0
ip ospf mtu-ignore

 

ip ospf name-lookup

すべての OSPF show EXEC コマンドの表示で使用するために Domain Name System(DNS; ドメイン ネーム システム)を Open Shortest Path First(OSPF)で検索するように設定するには、グローバル コンフィギュレーション モードで ip ospf name-lookup コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

ip ospf name-lookup

no ip ospf name-lookup

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドを使用するとルータがルータ ID やネイバ ID ではなく名前で表示されるため、ルータを識別しやすくなります。

次に、すべての OSPF show EXEC コマンドの表示で使用する DNS 名を検索するように OSPF を設定する例を示します。

ip ospf name-lookup

 

ip ospf network

Open Shortest Path First(OSPF)ネットワーク タイプを指定メディアのデフォルト以外のタイプに設定するには、インターフェイス コンフィギュレーション モードで ip ospf network コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf network { broadcast | non-broadcast | { point-to-multipoint [ non-broadcast ] | point-to-point }}

no ip ospf network

 
シンタックスの説明

broadcast

ネットワーク タイプをブロードキャストに設定します。

non-broadcast

ネットワーク タイプを NonBroadcast MultiAccess(NBMA; 非ブロードキャスト マルチアクセス)に設定します。

point-to-multipoint [ non-broadcast ]

ネットワーク タイプをポイントツーマルチポイントに設定します。オプションのキーワード non-broadcast は、ポイントツーマルチポイント ネットワークを非ブロードキャストに設定します。キーワード non-broadcast を使用する場合は、 neighbor コマンドが必要です。

point-to-point

ネットワーク タイプをポイントツーポイントに設定します。

 
デフォルト

ネットワーク タイプによって異なります。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

10.3

キーワード point-to-multipoint が追加されました。

11.3AA

point-to-multipoint キーワードとともに使用する non-broadcast キーワードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

たとえば、ユーザのネットワーク内のルータがマルチキャスト アドレッシングをサポートしない場合に、この機能を使用してブロードキャスト ネットワークを NBMA ネットワークとして設定できます。非ブロードキャスト マルチアクセス ネットワーク(X.25、フレーム リレー、および Switched Multimegabit Data Service(SMDS; スイッチド マルチメガビット データ サービス)など)をブロードキャスト ネットワークとして設定することもできます。この機能により、ネイバを設定する必要がなくなります。

NBMA ネットワークをブロードキャストまたは非ブロードキャストとして設定する場合、ルータ間に仮想回線または完全メッシュ ネットワークがあることが前提となります。ただし、この前提が当てはまらないこれ以外の設定もあります。たとえば、部分メッシュ ネットワークが存在する場合です。この場合は、OSPF ネットワークのタイプをポイントツーマルチポイント ネットワークとして設定できます。直接接続していない 2 つのルータ間のルーティングでは、仮想回線を通過して両ルータに到達します。この機能を使用する場合は、ネイバを設定する必要はありません。

この機能を許可しないインターフェイス上でこのコマンドを発行した場合、コマンドは無視されます。

OSPF にはポイントツーマルチポイント ネットワークに関連する 2 つの機能があります。一つはブロードキャスト ネットワークに適用される機能で、もう一方は非ブロードキャスト ネットワークに適用される機能です。

ポイントツーマルチポイントのブロードキャスト ネットワークでは、 neighbor コマンドを使用できますが、当該ネイバまでのコストを指定する必要があります。

ポイントツーマルチポイントの非ブロードキャスト ネットワークでは、 neighbor コマンドを使用してネイバを識別する必要があります。ネイバへのコストの割り当てはオプションです。

次に、ユーザの OSPF ネットワークをブロードキャスト ネットワークとして設定する例を示します。

interface serial 0
ip address 192.168.77.17 255.255.255.0
ip ospf network broadcast
encapsulation frame-relay
 

次に、ブロードキャストを行うポイントツーマルチポイント ネットワークの例を示します。

interface serial 0
ip address 10.0.1.1 255.255.255.0
encapsulation frame-relay
ip ospf cost 100
ip ospf network point-to-multipoint
frame-relay map ip 10.0.1.3 202 broadcast
frame-relay map ip 10.0.1.4 203 broadcast
frame-relay map ip 10.0.1.5 204 broadcast
frame-relay local-dlci 200
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
neighbor 10.0.1.5 cost 5
neighbor 10.0.1.4 cost 10

 
関連コマンド

コマンド
説明

frame-relay map

宛先プロトコル アドレスと、宛先アドレスとの接続に使用される DLCI との間にマッピングを定義します。

neighbor(OSPF)

非ブロードキャスト ネットワーク間を相互接続する OSPF ルータを設定します。

x25 map

LAN プロトコルとリモート ホストとのマッピングをセットアップします。

ip ospf prefix-suppression

セカンダリ IP アドレスに関連付けられているプレフィクスを除き、OSPF が特定のインターフェイスに属するすべての IP プレフィクスをアドバタイズしないようにするには、インターフェイス コンフィギュレーション モードで、 ip ospf prefix -suppression コマンドを使用します。インターフェイス単位でインターフェイスから設定を削除し、そのインターフェイスがルータ コンフィギュレーションから IP プレフィクス抑制設定を継承できるようにするには、このコマンドの no 形式を使用します。

ip ospf prefix-suppression [ disable ]

no ip ospf prefix-suppression

 
シンタックスの説明

disable

(任意)IP プレフィクス抑制に対するルータ モード設定にかかわらず、OSPF がインターフェイスの IP プレフィクスをアドバタイズすることを指定します。

 
コマンドのデフォルト

このインターフェイスに関連するすべての IP プレフィクスがアドバタイズされます。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.4(15)T

このコマンドが追加されました。

 
使用上のガイドライン

インターフェイス コンフィギュレーション モードで ip ospf prefix-suppression コマンドを入力すると、すべてのインターフェイス タイプでインターフェイス単位で IP プレフィクスを抑制できます。

ip ospf prefix-suppression コマンドを設定した場合、このコマンドが prefix-suppression ルータ コンフィギュレーション コマンドより優先されます。 prefix-suppression ルータ コンフィギュレーション コマンドを入力している場合は、指定された OSPF プロセスのインターフェイスは、ルータ コンフィギュレーション コマンドからプレフィクス抑制設定を継承します。

ip ospf prefix-suppression コマンドを入力すると、ループバック インターフェイスおよびパッシブ インターフェイスなどのすべてのインターフェイス タイプのプレフィクス生成が抑制されます。セカンダリ IP アドレスに関連付けられているプレフィクスだけが影響を受けないままとなります。

次に、セカンダリ IP アドレスを除き、イーサネット インターフェイス 1/1 のすべての IP プレフィクスが抑制される例を示します。

interface ethernet 1/1
ip ospf prefix-suppression

 
関連コマンド

コマンド
説明

prefix-suppression

ループバック、セカンダリ IP アドレス、および、特定の OSPF プロセスのパッシブ インターフェイスに関連付けられているプレフィクスを除いたすべての IP プレフィクスを OSPF がアドバタイズするのを防ぎます。

ip ospf priority

このネットワークの代表ルータを判別するのに役立つ、ルータのプライオリティを設定するには、インターフェイス コンフィギュレーション モードで ip ospf priority コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf priority number-value

no ip ospf priority

 
シンタックスの説明

number-value

ルータのプライオリティを指定する数値。値の範囲は 0 ~ 255 です。

 
コマンドのデフォルト

プライオリティ 1

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

1 つのネットワークに接続する 2 つのルータが両者とも代表ルータになろうとしたときは、より上位のプライオリティを持つルータが優先されます。プライオリティが同じ場合、より高位のルータ ID を持つルータが優先されます。ルータ プライオリティがゼロに設定されたルータは、代表ルータまたはバックアップ代表ルータになることができません。ルータ プライオリティは、マルチアクセス ネットワークのインターフェイスに対してだけ設定されます(言い換えると、ポイントツーポイント ネットワークのインターフェイスには設定されません)。

このプライオリティ値は、Open Shortest Path First(OSPF)の neighbor ルータ コンフィギュレーション コマンドを使用して、非ブロードキャスト ネットワークの OSPF を設定するときに使用します。

次に、ルータ プライオリティ値を 4 に設定する例を示します。

interface ethernet 0
ip ospf priority 4

 
関連コマンド

コマンド
説明

ip ospf network

OSPF ネットワーク タイプを、指定メディアのデフォルト以外のタイプに設定します。

neighbor(OSPF)

非ブロードキャスト ネットワーク間を相互接続する OSPF ルータを設定します。

ip ospf resync-timeout

ネイバから再起動信号(RS ビットを設定した Open Shortest Path First [OSPF] hello パケット)を受信してからアウトオブバンドの再同期(oob-resync)が実行されないときに、ネイバ ルータとの隣接関係をダウンさせるまでにルータが待機する時間の長さを設定するには、インターフェイス コンフィギュレーション モードで ip ospf resync-timeout コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf resync-timeout seconds

no ip ospf resync-timeout

 
シンタックスの説明

seconds

ネイバから再起動信号(RS ビットを設定した OSPF hello パケット)を受信した時刻以降、アウトオブバンドの再同期(oob-resync)が実行されない場合、ネイバ ルータとの隣接関係をダウンさせるまでルータが待機する秒数です。値の範囲は 1 ~ 65535 秒です。デフォルト値は 40 秒または、インターフェイスの OSPF デッド インターバルに設定されている値のいずれか大きい方です。

 
コマンドのデフォルト

デフォルト値は 40 秒または、インターフェイスの OSPF デッド インターバルに設定されている値のいずれか大きい方です。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(15)T

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

OSPF ノンストップ フォワーディング(NSF)ルータが Route Processor(RP; ルート プロセッサ)スイッチオーバーを実行するときは、このルータは、特殊な hello パケットを通じてこの動作について自身のネイバに通知し、また、各ネイバがリンク ステート データベースの再同期を支援するように要求します。

ネイバ(NSF 認識)がこの特殊な hello パケットを NSF 対応ルータから受け取ると、ネイバは再同期タイムアウト タイマーを起動して自身のデータベースと NSF 対応ルータとを同期させるために待機します。再同期タイムアウト タイマーが期限切れになる前に NSF 対応ルータがデータベースの再同期プロセスを開始しないと、NSF 認識ネイバは NSF 対応ルータとの隣接関係をダウンさせます。

デフォルトでは、再同期タイムアウト タイマーは、40 秒かインターフェイスのデッド インターバルに設定されている時間のいずれか長い方に設定されます (デフォルトではデッド インターバルは hello インターバルの 4 倍の時間です。hello インターバルのデフォルトはイーサネットで 10 秒、非ブロードキャストで 30 秒に設定されます)。 ip ospf resync-timeout コマンドを使用すると、再同期タイムアウトを変更し、デッド インターバルまたはデフォルト値に依存しないようにできます。

次に、OSPF 再同期タイムアウト インターバルを 50 秒に設定する例を示します。

interface GigabitEthernet 6/0/0
ip ospf resync-timeout 50

 
関連コマンド

コマンド
説明

ip ospf dead-interval

ルータがダウンしたとネイバが宣言するまでの間、hello パケットを非表示にしなければならないインターバルを設定します。

ip ospf hello-interval

ソフトウェアがインターフェイス上で送信する各 hello パケット間のインターバルを設定します。

ip ospf retransmit-interval

インターフェイスに属する隣接関係について再送する link-state advertisement(LSA; リンクステート アドバイタイズメント)の時間間隔を指定するには、インターフェイス コンフィギュレーション モードで ip ospf retransmit-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf retransmit-interval seconds

no ip ospf retransmit-interval

 
シンタックスの説明

seconds

再送間の時間(秒単位)。値の範囲は 1 ~ 65535 秒です。デフォルト値は 5 秒です。

 
デフォルト

5 秒

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

ルータが自身のネイバに LSA を送信する場合、ルータは確認応答メッセージを受信するまでその LSA を保持します。ルータは、確認応答メッセージを受信しないと、LSA を再び送信します。

引数 seconds の設定は、接続するネットワークの任意の 2 ルータ間で予想されるラウンドトリップ遅延より大きい値にする必要があります。このパラメータの設定は慎重に行う必要があります。そうしないと、不必要な LSA の再送が発生する可能性があります。この値は、シリアル回線と仮想リンクでは大きくする必要があります。


) ネイバの OSPF ルータ間では、同一の引数 seconds の値を使用することをお勧めします。ネイバ ルータ間で矛盾する値を使用すると、不必要な LSA の再送の原因となる場合があります。


次に、再伝送の間隔値を 8 秒に設定する例を示します。

interface ethernet 2
ip ospf retransmit-interval 8

 

ip ospf shutdown

Open Shortest Path First(OSPF)プロトコルのグレースフル シャットダウンをインターフェイス レベルで開始するには、インターフェイス コンフィギュレーション モードで ip ospf shutdown を使用します。インターフェイスで OSPF プロトコルを再起動するには、このコマンドの no 形式を使用します。

ip ospf shutdown

no ip ospf shutdown

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

デフォルトの動作または値はありません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(33)SRC

このコマンドが追加されました。

15.0(1)M

このコマンドが、Cisco IOS Release 15.0(1)M に統合されました。

 
使用上のガイドライン

シャットダウン モードの特定のインターフェイスに OSPF を置くには、 ip ospf shutdown コマンドを使用します。

次に、イーサネット 0 インターフェイスで OSPF プロトコルのシャットダウンを開始する例を示します。

Router(config)# interface ethernet 0
Router(config-if)# ip ospf shutdown

 
関連コマンド

コマンド
説明

shutdown(router ospf)

現在のインスタンスで OSPF プロトコルのグレースフル シャットダウンを開始します。

ip ospf transmit-delay

インターフェイスでリンクステートのアップデート パケットを送信するための推定所要時間を設定するには、インターフェイス コンフィギュレーション モードで ip ospf transmit-delay コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf transmit-delay seconds

no ip ospf transmit-delay

 
シンタックスの説明

seconds

リンクステート アップデートを送信するための所要時間(秒単位)。値の範囲は 1 ~ 65535 秒です。デフォルトは 1 秒です。

 
デフォルト

1 秒

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

アップデート パケットのリンクステート アドバタイズメント(LSA)の伝送では、引数 seconds で指定された数値分の経過時間を事前に増分する必要があります。値を割り当てるときは、インターフェイスの伝送遅延と伝播遅延を考慮する必要があります。

リンクでの伝送前に遅延が追加されていない場合、LSA のリンク伝播の時間が考慮されなくなります。この設定は、非常に低速のリンクでより重要度が高くなります。

次に、再伝送時の遅延の値を 3 秒に設定する例を示します。

interface ethernet 0
ip ospf transmit-delay 3

 

ip ospf ttl-security

特定のインターフェイスでの Time-To-Live(TTL; 存続可能時間)セキュリティ チェック機能を設定するには、インターフェイス コンフィギュレーション モードで ip ospf ttl-security コマンドを使用します。インターフェイスでの TTL セキュリティをディセーブルにするには、このコマンドの no 形式を使用します。

ip ospf ttl-security [ hops hop-count | disable ]

no ip ospf ttl-security

 
シンタックスの説明

hops hop-count

(任意)IP ホップの最大数を設定します。引数 hop-count の範囲は 1 ~ 254 です。

disable

(任意)インターフェイスでの TTL セキュリティをディセーブルにします。

 
コマンドのデフォルト

すべての Open Shortest Path First(OSPF)インターフェイスで TTL セキュリティはディセーブルになっています。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(33)SRC

このコマンドが追加されました。

15.0(1)M

このコマンドが、Cisco IOS Release 15.0(1)M に統合されました。

 
使用上のガイドライン

特定のインターフェイスで ip ospf ttl-security コマンドを使用して TTL セキュリティを設定します。

キーワード disable を使用すると TTL セキュリティを特定のインターフェイスでディセーブルにできますが、これが有効なのは、 ttl-security all-interfaces コマンドをルータ モードで使用してすべての OSPF インターフェイスの TTL セキュリティを最初に設定したときだけです。この方法で、すべての OSPF インターフェイスの TTL セキュリティを設定してから、個々のインターフェイスをディセーブルにすることができます。このようにすると、最初からインターフェイスごとに 1 つずつ設定する方法よりも時間を短縮できます。

次の例では、最初にすべての OSPF インターフェイスで TTL セキュリティを設定後、キーワード disable を使用してイーサネット インターフェイス 0/0 でこの機能を効率的にディセーブルにする方法を示します。

Router# configure terminal
Router(config)# router ospf 1
Router(config-router)# ttl-security all-interfaces
Router(config-router)# exit
Router(config)# interface ethernet 0/0
Router(config-if)# ip ospf ttl-security disable

 
関連コマンド

コマンド
説明

ttl-security all-interfaces

すべての OSPF インターフェイスでの TTL セキュリティ チェックを設定します。

limit retransmissions

データベース交換パケットおよびアップデート パケットの再送数の制限を、デマンド回線および非デマンド回線の両方で変更または削除するには、ルータ コンフィギュレーション モードで limit retransmissions コマンドを使用します。再送の最大数をデフォルト値の 24 に戻すリセットを行うには、このコマンドの no 形式を使用します。

limit retransmissions [ dc { max-number | disable }] [ non-dc { max-number | disable }]

no limit transmissions [ dc | non-dc ]

 
シンタックスの説明

dc

デマンド回線の再送。

max-number

再送の最大数。有効な範囲は 1 ~ 255 です。

non-dc

非デマンド回線の再送。

disable

再送数の制限をディセーブルまたは削除します。

 
デフォルト

再送の最大数は 24 です。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(11)T

このコマンドが追加されました。

 
使用上のガイドライン

Cisco IOS Release 12.2(4)T から、デマンド回線および非デマンド回線の両方について、データベース交換パケットおよびアップデート パケットの再送数を制限する機能が追加されました。これらのパケットの再送は、いったんリトライ制限に到達すると停止します。これにより、ネイバが隣接関係の形成中に何らかの理由で応答しない場合に、パケット再送の繰り返しでリンクが不要に使用されることを防ぎます。

デマンド回線と非デマンド回線の再送の制限はいずれも 24 です。

limit-retransmissions コマンドを使用すると、再送数の制限を解除(ディセーブルに)するか、再送の最大数を 1 ~ 255 の範囲の値に変更できます。このコマンドを設定することで、Cisco IOS ソフトウェアの以前のリリースまたは他のリリース、あるいはこの機能を持たない他のルータとの下位互換性が確保されます。


) 再送数の制限は、非ブロードキャスト マルチアクセス(NBMA)ポイントツーマルチポイントの直接回線でのアップデート パケットには適用されません。この場合は、デッド タイマーを使用して応答しないネイバとの通信を終了することで再送を停止します。


次の例では、デマンド回線における最大再送数を 10 に設定する方法を示します。

limit retransmissions dc 10
 

次の例では、デマンド回線における再送数の制限を削除する方法を示します。

limit retransmissions dc disable
 

次の例では、デマンド回線における最大再送数を 10 に設定し、非デマンド回線における最大再送数を 20 に設定する方法を示します。

limit retransmissions dc 10 non-dc 20
 

次の例では、デマンド回線における最大再送数を 10 に設定し、非デマンド回線における再送数の制限を削除する方法を示します。

limit retransmissions dc 10 non-dc disable
 

次の例では、デマンド回線と非デマンド回線の両方について最大再送数をデフォルトの 24 に戻すためのリセット方法を示します。

no limit retransmissions

 
関連コマンド

コマンド
説明

router ospf

OSPF ルーティング プロセスを設定します。

local-rib-criteria

ルートの検証で使用する OSPF ローカル Routing Information Base(RIB; ルーティング情報ベース)を指定するには、ルータ コンフィギュレーション モードで local-rib-criteria コマンドを使用します。ローカル RIB ルート検証を削除するには、このコマンドの no 形式を使用します。

local-rib-criteria [ forwarding-address ] [ inter-area-summary ] [ nssa-translation ]

no local-rib-criteria [ forwarding-address ] [ inter-area-summary ] [ nssa-translation ]

 
シンタックスの説明

forwarding-address

(任意)外部アドレスまたは NSSA フォワーディング アドレスのルート検証条件でだけローカル RIB を使用するように指定します。

inter-area-summary

(任意)エリア間サマリーのルート検証条件でだけローカル RIB を使用するように指定します。

nssa-translation

(任意)NSSA 変換のルート検証条件でだけローカル RIB を使用するように指定します。

 
コマンドのデフォルト

ルート検証にはグローバル RIB(ローカル RIB ではない)が使用されます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.4(15)T

このコマンドが追加されました。

 
使用上のガイドライン

オプションのキーワードを指定せずに local-rib-criteria コマンドを入力すると、ローカル RIB は、すべてのオプション(フォワーディング アドレス、エリア間サマリー、NSSA 変換)の条件として使用されます。

1 つ以上のオプションのキーワードとともに local-rib-criteria コマンドを入力すると、フォワーディング アドレス、エリア間サマリー、または NSSA 変換のルート生成のうち、指定したオプションにだけローカル RIB を使用するように OSPF ルーティング プロセスが設定できます。


) デフォルトの動作(グローバル RIB はルート検証に使用されます)は維持することをお勧めします。場合によっては、local-rib-criteria コマンドを、単独か 1 つ以上のオプションのキーワードを指定して入力するとネットワークの収束が多少高速になることがありますが、ルーティング ループやブラック ホールといった問題の原因となる場合があります。



) キーワード forwarding-address を入力してローカル RIB を使用するようにフォワーディング アドレス検証の変更を指定しても、パケットの転送は引き続きグローバル RIB に依存します。グローバル RIB に、別のプロトコルからのより優先されるルートまたはさらに特定されたルートが含まれる場合でも、この優先されるルートがパケットの転送に引き続き使用されます。


次に、NSSA 変換の条件としてローカル RIB を使用する必要があることを指定する例を示します。

router ospf 23
local-rib-criteria nssa-translation
 

次に、すべてのローカル RIB 条件のオプションをイネーブルにする例を示します。

router ospf 1

local-rib-criteria

 

次に、ローカル RIB をエリア間サマリー ルート生成でだけ使用するように指定する例を示します。

router ospf 1

local-rib-criteria inter-area-summary

 

log-adjacency-changes

Open Shortest Path First(OSPF)ネイバが起動またはダウンしたときに syslog メッセージを送信するようにルータを設定するには、ルータ コンフィギュレーション モードで log-adjacency-changes コマンドを使用します。この機能をオフにするには、このコマンドの no 形式を使用します。

log-adjacency-changes [ detail ]

no log-adjacency-changes [ detail ]

 
シンタックスの説明

detail

(任意)ネイバが起動またはダウンしたときだけでなく、状態が変更したすべての場合に syslog メッセージを送信します。

 
コマンドのデフォルト

イネーブル

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

11.2

このコマンドが ospf log-adjacency-changes として追加されました。

12.1

キーワード ospf がなくなり、キーワード detail が追加されました。

12.2(15)T

IPv6 のサポートが追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドを使用すると、 debug ip ospf packet コマンドまたは debug ipv6 ospf adjacency コマンドをオンにしなくても、OSPF ネイバが起動またはダウンしたことをユーザに知らせることができます。 log-adjacency-changes コマンドは、ピアとの関係の変化について、 debug コマンドよりも高レベルのビューをより少ない出力で提供します。 log-adjacency-changes コマンドはデフォルトでオンに設定されていますが、キーワード detail を指定しない限り、起動/ダウン(フル/ダウン)のイベントだけがレポートされます。

次に、OSPF ネイバの状態が変更したときにルータから syslog メッセージが送信されるように設定する例を示します。

log-adjacency-changes detail

 
関連コマンド

コマンド
説明

debug ip ospf packet

IPv4 について各 OSPF パケットが受信した情報を表示します。

debug ipv6 ospf

IPv6 についての OSPF のデバッグ情報を表示します。

max-lsa

Open Shortest Path First(OSPF)ルーティング プロセスが OSPF link-state database(LSDB; リンクステート データベース)に保持できる非自己生成のリンクステート アドバタイズメント(LSA)の数を制限するには、ルータ コンフィギュレーション モードで max-lsa コマンドを使用します。OSPF ルーティング プロセスが OSPF LSDB に保持できる非自己生成 LSA 数の制限を削除するには、このコマンドの no 形式を使用します。

max-lsa maximum-number [ threshold-percentage ] [ warning-only ] [ ignore-time minutes ] [ ignore-count count-number ] [ reset-time minutes ]

no max-lsa maximum-number [ threshold-percentage ] [ warning-only ] [ ignore-time minutes ] [ ignore-count count-number ] [ reset-time minutes ]

 
シンタックスの説明

maximum-number

OSPF プロセスが OSPF LSBD に保持できる非自己生成 LSA の最大数。

threshold-percentage

(任意)引数 maximum-number で指定される LSA の最大数を表す %。この値になると警告メッセージのログが記録されます。デフォルト値は 75% です。

warning-only

(任意)LSA の最大制限数を超えたときに警告メッセージだけを送信するように指定します。デフォルトではディセーブルになっています。

ignore-time minutes

(任意)LSA の最大制限数の超過後、すべてのネイバを無視する時間を分単位で指定します。デフォルト値は 5 分です。

ignore-count count-number

(任意)OSPF プロセスを ignore 状態に連続して設定できる回数を指定します。デフォルト値は 5 回です。

reset-time minutes

(任意)ignore になったカウントをゼロにリセットしてからの時間を分単位で指定します。デフォルト値は 10 分です。

 
デフォルト

OSPF ルーティング プロセスが OSPF LSDB に保持できる非自己生成 LSA の数に制限はありません。

threshold-percentage :75%
warning-only warning message:ディセーブル
ignore-time minutes :5 分
ignore-count count-number: 5 回
reset-time minutes 10 分

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(27)S

このコマンドが追加されました。

12.3(7)T

このコマンドが、Cisco IOS Release 12.3(7)T に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(18)SXE

このコマンドが、Cisco IOS Release 12.2(18)SXE に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン

LSA カウントが設定された最大数を超過した場合に、OSPF プロセスの状態が通常の動作から ignore 状態に変更され、直後に ignore 状態から通常の動作に戻るという処理が際限なく繰り返されるのを防ぐために、OSPF プロセスには ignore 状態になったプロセスの回数を計算するカウンタがあります。このカウンタを ignore カウントと呼びます。キーワード ignore-count と引数 counter-number で指定された LSA の最大数を ignore カウントが超過した場合、OSPF プロセスは ignore 状態を永続的に維持します。OSPF プロセスを通常の動作状態に戻すには、 clear ip ospf コマンドを入力します。

ルータが永続的な ignore 状態に置かれた場合、LSA を生成している当該ルータの問題の原因を特定してこれを解決するか、可能な場合は、 max-lsa コマンドで制限数を増やす設定を行ってから、ルータを通常の動作に戻すように試みることをお勧めします。

大量の LSA を生成しているルータが見つからない場合は、OSPF エリアおよびドメインからこの LSA を削除できません。その結果、ignore 状態を脱して通常の動作に戻った他の任意のルータが再び ignore 状態になる可能性があります。ルータをネットワークに復帰させるために、次のいずれかの処置を取ることをお勧めします。

古い LSA を考慮して、LSA の制限数を一時的に増やす。

古い LSA が最大経過時間に達した結果、削除されるのを待つ。

大量の LSA を生成したルータがネットワークに接続していることと、このルータが今後は大量の LSA を生成しないことを確認する。

キーワード warning-only を使用している場合、OSPF プロセスが ignore 状態に入ることはありません。引数 maximum-number で指定された最大制限数を LSA カウントが超過した場合、エラー メッセージのログが記録されるだけで、OSPF プロセスは通常の動作を継続します。

初めて max-lsa コマンドを入力したとき、またはコマンドの任意のパラメータを変更したときは、OSPF プロセスはソフトリセットの手順に移行します。

次に、OSPF プロセスが ignore 状態に入るまでに受信できる LSA 数の制限を 12,000 に設定する例を示します。

Router(config)# router ospf 100
Router(config-router)# router-id 209.165.201.0
Router(config-router)# log-adjacency-changes
Router(config-router)# max-lsa 12000
Router(config-router)# network 209.165.201.1 255.255.255.255
 

次の例では、OSPF プロセスは永続的な ignore 状態を継続しています。 clear ip ospf コマンドを入力すると、OSPF プロセスは通常の動作状態に戻り、OSPF ルーティング プロセス ID に基づいて再配布をクリアします。

Router(config-router)# clear ip ospf 100 process

 
関連コマンド

コマンド
説明

clear ip ospf

OSPF ルーティング プロセス ID に基づいて再配布をクリアします。

max-metric router-lsa

Open Shortest Path First(OSPF)プロトコルを実行しているルータで、最大メトリックのアドバタイズによって他のルータがそのルータを Shortest Path First(SPF)計算の中間ホップとして優先的に使用しないように設定するには、ルータ アドレス ファミリ トポロジまたはルータ コンフィギュレーション モードで max-metric router-lsa コマンドを使用します。最大メトリックのアドバタイズをディセーブルにするには、このコマンドの no 形式を使用します。

max-metric router-lsa [ external-lsa [ max-metric-value ]] [ include-stub ] [ on-startup { seconds | wait-for-bgp }] [ summary-lsa [ max-metric-value ]]

no max-metric router-lsa [ external-lsa [ max-metric-value ]] [ include-stub ] [ on-startup { seconds | wait-for-bgp }] [ summary-lsa [ max-metric-value ]]

 
シンタックスの説明

external-lsa

(任意)外部の LSA メトリックを最大メトリック値で上書きするようにルータを設定します。

max-metric-value

(任意)LSA の最大メトリック値。設定可能な範囲は 1 ~ 16777215 です。デフォルト値は 16711680 です。

include-stub

(任意)ルータの LSA でスタブ リンクの最大メトリックをアドバタイズするようにルータを設定します。

on-startup

(任意)起動時にルータが最大メトリックをアドバタイズするように設定します。

seconds

(任意)指定の時間間隔における最大メトリック値。設定可能な範囲は 5 ~ 86400 秒です。この設定オプションにはデフォルトのタイマー値はありません。

wait-for-bgp

(任意)Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ルーティング テーブルが収束するまで、またはデフォルト タイマーが切れるまで最大メトリックをアドバタイズするようにルータを設定します。デフォルト タイマーは 600 秒です。

summary-lsa

(任意)サマリー LSA メトリックを最大メトリック値で上書きするようにルータを設定します。

 
コマンドのデフォルト

ルータのリンクステート アドバタイズメント(LSA)は、通常のリンク メトリックで発信されます。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.0(15)S

このコマンドが追加されました。

12.0(16)ST

このコマンドが、Cisco IOS Release 12.0(16)ST に統合されました。

12.2(4)T

このコマンドが、Cisco IOS Release 12.2(4)T に統合されました。

12.4(10)

ルータ コンフィギュレーション モードで、 include-stub summary-lsa および external-lsa の各キーワードと、引数 max-metric-value が使用可能になりました。

12.4(11)T

ルータ コンフィギュレーション モードで、 include-stub summary-lsa および external-lsa の各キーワードと、引数 max-metric-value が使用可能になりました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(31)SB2

ルータ コンフィギュレーション モードで、 include-stub summary-lsa および external-lsa の各キーワードと、引数 max-metric-value が使用可能になりました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。ルータ コンフィギュレーション モードで、 include-stub summary-lsa および external-lsa の各キーワードと、引数 max-metric-value が使用可能になりました。

 
使用上のガイドライン

max-metric router-lsa コマンドをイネーブルにすると、ルータは非スタブ リンク全体に最大メトリック(LSInfinity:0xFFFF)の LSA を発信します。これによって、BGP ルーティング テーブルは、通過するトラフィックを引き起こすことなく収束できます(そのルータへの低コストの代替パスがない場合)。設定されたタイマーまたはデフォルトのタイマーの期限切れ後、あるいは BGP によってルーティング テーブルの収束の通知が送信された後で、ルータは正確な(通常の)メトリックをアドバタイズします。


) スタブ リンクのコストは常に出力インターフェイス コストに設定されているため、最大または無限のメトリックを設定しても、スタブ ネットワーク内の直接接続リンクには影響しません。


max-metric router-lsa コマンドは、次の場合に使用すると有効です。

ルータのリロード時。ルータがリロードされると、Interior Gateway Protocol(IGP)はすばやく収束し、他のルータは新しくリロードされたこのルータを通じてトラフィックを転送しようとすることがあります。そのルータがまだ BGP ルーティング テーブルを構築中の場合は、ルータが BGP で学習していない他のネットワークを宛先とするパケットは廃棄される場合があります。インターネット バックボーン ルータの場合は、パケットが多数廃棄される場合があります。

ルータをネットワークに導入するが、そのルータでトラフィックを中継しない場合。ルータを OSPF ネットワークに接続するときに、より適切な代替パスが他にある場合は実際に流れるトラフィックをこのルータを通じて転送したくないことがあります。代替パスがないときは、このルータが以前のようにトラフィックが通過するのを引き続き受け入れます。

ネットワークからルータを正常に取り外す場合。この機能では、すべてのリンクに最大メトリックをアドバタイズすることにより、ルータをネットワークから正常に取り外すことができます。これによってルータがシャットダウンする前に、これ以外のルータがトラフィックの通過に代替パスを選択できるようになります。


) グレースフル シャットダウンを行うように設定している場合は、ルータの実行コンフィギュレーションを保存しないでください。保存すると、ルータはリロード後も最大メトリックのアドバタイズを続行します。



) 以前の OSPF 実装(RFC 1247 およびそれ以前の実装)では、LSInfinity のメトリックを持つ LSA を受信するときのルータのリンク コストは、SPF 計算中に使用されません。つまり、通過するトラフィックがこの LSA の発信元であるルータに送信されないことを意味します。


Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を設定予定の場合、この OSPF ルータ コンフィギュレーション コマンドがトポロジ認識になるために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで max-metric router-lsa コマンドを入力する必要があります。

次に、OSPF を実行しているルータに対し、最大メトリックを 100 秒間アドバタイズするように設定する例を示します。

Router(config)# router ospf 100
Router(config-router)# max-metric router-lsa on-startup 100
 

次に、BGP ルーティング テーブルが収束するまでの間、または、デフォルト タイマーが期限切れになる(600 秒後)までの間、最大メトリックをルータがアドバタイズするように設定する例を示します。

Router(config)# router ospf 100
Router(config-router)# max-metric router-lsa on-startup wait-for-bgp
 

次に、OSPF を実行しているルータに対し、最大メトリックをアドバタイズし、これによって、このルータがシャットダウンする前に、トラフィックが通過するための代替パスをネイバ ルータが選択するように設定する例を示します。

Router(config)# router ospf 100
Router(config-router)# max-metric router-lsa
Router(config-router)# end
 

次に、ルータの LSA によってスタブ リンクに最大メトリックがアドバタイズされるように設定する例を示します。

Router(config)# router ospf 1
Router(config-router)# router-id 10.1.1.1
Router(config-router)# max-metric router-lsa include-stub
Router(config-router)# end
 

show ip ospf max-metric コマンドにキーワード include-stub を指定して入力すると、スタブ リンクに最大メトリックがアドバタイズされたことを確認する出力が表示されます。

Router# show ip ospf max-metric
 
Routing Process “ospf 1” with ID 10.1.1.1
Start time: 00:00:03.524, Time elapsed: 01:02:28.292
Originating router-LSAs with maximum metric
Condition: always, State: active
Advertise stub links with maximum metric in router-LSAs

 
関連コマンド

コマンド
説明

show ip ospf

OSPF ルーティング プロセスに関する一般情報を表示します。

show ip ospf database

特定のルータの OSPF データベースに関する情報のリストが表示されます。

neighbor (OSPF)

非ブロードキャスト ネットワーク間で相互接続する Open Shortest Path First(OSPF)ルータを設定するには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで neighbor コマンドを使用します。設定を削除するには、このコマンドの no 形式を使用します。

neighbor ip-address [ priority number ] [ poll-interval seconds ] [ cost number ] [ database-filter all ]

no neighbor ip-address [ priority number ] [ poll-interval seconds ] [ cost number ] [ database-filter all ]

 
シンタックスの説明

ip-address

ネイバのインターフェイス IP アドレス。

priority number

(任意)指定の IP アドレスが関連付けられている非ブロードキャスト ネイバのルータ プライオリティ値を示す数。デフォルト値は 0 です。このキーワードはポイントツーマルチポイント インターフェイスには適用されません。

poll-interval seconds

(任意)ポーリングの時間間隔(秒)を表す数値。RFC 1247 では、これを hello 間隔よりかなり大きい値にすることを推奨しています。デフォルト値は 120 秒(2 分)です。このキーワードはポイントツーマルチポイント インターフェイスには適用されません。値の範囲は 0 ~ 4294967295 秒です。

cost number

(任意)ネイバに 1 ~ 65535 の整数を使用したコストを割り当てます。特定のコストが設定されていないネイバには、 ip ospf cost コマンドに基づいたインターフェイスのコストが想定されます。ポイントツーマルチポイント インターフェイスの場合は、適用可能なオプションはキーワード cost と引数 number だけです。このキーワードは非ブロードキャスト マルチアクセス(NBMA)ネットワークには適用されません。

database-filter all

(任意)OSPF ネイバに送出されるリンクステート アドバタイズメント(LSA)をフィルタリングします。

 
コマンドのデフォルト

このコマンドは、デフォルトでディセーブルになっています。指定されるコンフィギュレーションはありません。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

11.3AA

キーワード cost が追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

X.25 およびフレーム リレーは、マップに設定できるオプションのブロードキャスト機能を提供し、これによって OSPF をブロードキャスト ネットワークとして実行できます。OSPF レベルでは、ルータをブロードキャスト ネットワークとして設定できます。 x25 map コマンドおよび frame-relay map コマンドの詳細については、『 Cisco IOS Wide-Area Networking Command Reference 』の「X.25 Commands」の章および「Frame Relay Commands」の章をそれぞれ参照してください。

Cisco IOS ソフトウェア設定では、既知の非ブロードキャスト ネットワーク ネイバ 1 つにつきネイバ エントリを 1 つ含める必要があります。ネイバ アドレスは、インターフェイスのプライマリ アドレスに存在する必要があります。

隣接するルータが非アクティブになっても(Router Dead 間隔の間、hello パケットが未受信)、デッド ネイバに hello パケットを引き続き送信する必要があることがあります。これらの hello パケットは、 ポーリング間隔 と呼ばれる、低速化した速度で送信されます。

ルータが最初に起動すると、プライオリティがゼロ以外のルータに hello パケットだけを送信します。プライオリティがゼロ以外のルータは、Designated Router(DR; 代表ルータ)または Backup Designated Router(BDR; バックアップ代表ルータ)になる資格を持つルータです。次に、選択された DR および BDR は、隣接関係を形成するためにすべてのネイバに hello パケットの送信を開始します。


neighbor(OSPF)コマンドを使用して OSPF Virtual Private Network(VPN; 仮想プライベート ネットワーク)ルーティング インスタンス内の非ブロードキャスト ネットワークに Open Shortest Path First(OSPF)ネイバは指定できません。


Cisco IOS Release 12.0 までは、 neighbor コマンドは NBMA ネットワークにだけ適用されていました。Release 12.0 からは NBMA ネットワークとポイントツーマルチポイント ネットワークに neighbor コマンドが 適用されるようになりました。NBMA ネットワークでは、キーワード cost は使用できません。

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を設定予定の場合、この OSPF ルータ コンフィギュレーション コマンドがトポロジ認識になるために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで neighbor コマンドを入力する必要があります。

次に、非ブロードキャスト ネットワーク アドレスが 192.168.3.4、プライオリティが 1、ポーリング間隔が 180 秒とするルータを宣言する例を示します。

router ospf
neighbor 192.168.3.4 priority 1 poll-interval 180
 

次に、非ブロードキャストのポイントツーマルチポイント ネットワークの例を示します。

interface Serial0
ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no keepalive
frame-relay local-dlci 200
frame-relay map ip 10.0.1.3 202
frame-relay map ip 10.0.1.4 203
frame-relay map ip 10.0.1.5 204
no shut
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
neighbor 10.0.1.3 cost 5
neighbor 10.0.1.4 cost 10
neighbor 10.0.1.5 cost 15

 
関連コマンド

コマンド
説明

ip ospf priority

ルータ プライオリティを設定します。これにより、このネットワークにおける代表ルータの特定に役立ちます。

neighbor database-filter all out

Open Shortest Path First(OSPF)ネイバへの発信リンクステート アドバタイズメント(LSA)をフィルタリングするには、ルータ コンフィギュレーション モードで neighbor database-filter all out コマンドを使用します。ネイバへの LSA の転送を元に戻すには、このコマンドの no 形式を使用します。

neighbor ip-address database-filter all out [ cost metric ]

no neighbor ip-address database-filter all out

 
シンタックスの説明

ip-address

発信 LSA をブロックするネイバの IP アドレス。

cost metric

(任意)指定のネイバに対して設定するコスト メトリック。この値の範囲は 0 ~ 65535 です。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。すべての送出 LSA はネイバにフラッディングされます。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、インターフェイス単位で実行される ip ospf database-filter all out コマンドと同じ機能を実行します。

次に、ポイントツーマルチポイント ネットワークで IP アドレス 10.2.3.4 のネイバに OSPF LSA がフラッディングされるのを防止する例を示します。

router ospf 109
neighbor 10.2.3.4 database-filter all out

 
関連コマンド

コマンド
説明

ip ospf database-filter all out

OSPF インターフェイスへの発信 LSA をフィルタリングします。

network area

Open Shortest Path First(OSPF)を実行するインターフェイスおよびそのインターフェイスのエリア ID を定義するには、ルータ コンフィギュレーション モードで network area コマンドを使用します。 ip-address wildcard-mask ペアで定義されたインターフェイスの OSPF ルーティングをディセーブルにするには、このコマンドの no 形式を使用します。

network ip-address wildcard-mask area area-id

no network ip-address wildcard-mask area area-id

 
シンタックスの説明

ip-address

IP アドレス。

wildcard-mask

「don't care」(合致する必要がない)ビットを含む、IP アドレス タイプのマスク。

area-id

OSPF アドレス範囲に関連付けるエリア。10 進数値または IP アドレスのいずれかで指定できます。IP サブネットを持つエリアを関連付ける予定の場合、引数 area-id の値でサブネット アドレスを指定できます。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

引数 ip-address および引数 wildcard-mask を組み合わせると、1 つのコマンドを使用して 1 つ以上のインターフェイスを特定の OSPF エリアに関連付けることができます。引数 wildcard-mask を使用すると、1 つのコマンドを使用して 1 つ以上のインターフェイスを特定の OSPF エリアに関連付けることができます。IP サブネットを持つエリアを関連付ける予定の場合、引数 area-id の値でサブネット アドレスを指定できます。

インターフェイス上で動作する OSPF では、 network area コマンドでインターフェイスのプライマリ アドレスがカバーされなければなりません。 network area コマンドがセカンダリ アドレスだけをカバーしても、そのインターフェイスでの OSPF がイネーブルになりません。

Cisco IOS ソフトウェアは、各インターフェイスの ip-address wildcard-mask ペアを次のように順次評価します。

1. 引数 wildcard-mask は、インターフェイスの IP アドレスに対して論理和をとる。

2. 引数 wildcard-mask は、 network コマンドの引数 ip- address に対して論理和をとる。

3. ソフトウェアにより、この 2 種類の結果の値が比較されます。値が一致すれば OSPF は関連するインターフェイス上でイネーブルになり、このインターフェイスが指定の OSPF エリアに追加されます。

ルータで使用できる network area コマンドの数に制限はありません。


) 個々のインターフェイスはすべて単一のエリアにだけ追加できます。指定されたアドレス範囲が異なるエリアにオーバーラップした場合、ソフトウェアは、network コマンド リストにある最初のエリアを採用して残りのオーバーラップした部分は無視します。通常、アドレス範囲の不測の衝突を回避するために、オーバーラップしないように設定することが推奨されます。


より具体的な OSPF ネットワーク範囲が削除された場合、そのネットワークに属するインターフェイスの範囲は、それより具体的でないネットワーク範囲が存在するときに限り、維持され、アクティブな状態が継続します。

たとえば、次の設定があるとします。

router ospf 1
network 192.168.129.16 0.0.0.3 area 20
network 192.168.129.40 0.0.0.3 area 20
network 192.168.129.44 0.0.0.3 area 20
network 192.168.129.96 0.0.0.3 area 20
network 192.168.128.0 0.0.127.255 area 20
!
 

次のように入力してください。

no network 192.168.129.40 0.0.0.3 area 20
 

ネットワーク範囲 192.168.129.40/0.0.0.3 に相当するインターフェイスは引き続きアクティブになります。これは、エリア 20 のスーパーセット 192.168.128.0/0.0.127.255 が存在するためです。より具体的なネットワーク文は、より具体的でないネットワーク文(スーパーセット)が存在する場合に限り、その範囲に属するインターフェイスを別のエリアから削除させます。

次のような設定があるとします。

!
router ospf 1
network 192.168.128.0 0.0.127.255 area 20
!
 

次のネットワーク文が入力された場合、

network 192.168.129.96 0.0.0.3 area 40
 

範囲 192.168.129.96/0.0.0.3 に属するインターフェイスがある場合、このインターフェイスは、エリア 20 から削除され、エリア 40 に移されます。同一範囲でエリア ID が異なるネットワーク文は、エリアが変更した見なされます。たとえば、次のネットワーク文は、ネットワーク範囲 192.168.129.40/0.0.0.3 に属するインターフェイスをエリア 20 からエリア 40 に移動させます。

network 192.168.129.40 0.0.0.3 area 20
network 192.168.129.40 0.0.0.3 area 40

次に、OSPF ルーティング プロセス 109 を初期化し、10.9.50.0、2、3、および 0 という 4 種類の OSPF エリアを定義する例の一部を示します。エリア 10.9.50.0、2、および 3 では、特定のアドレス範囲をマスクし、エリア 0 は他のすべてのネットワークで OSPF をイネーブルにします。

interface ethernet 0
ip address 10.108.20.1 255.255.255.0
router ospf 109
network 10.108.20.0 0.0.0.255 area 10.9.50.0
network 10.108.0.0 0.0.255.255 area 2
network 10.109.10.0 0.0.0.255 area 3
network 0.0.0.0 255.255.255.255 area 0

 
関連コマンド

コマンド
説明

router ospf

OSPF ルーティング プロセスを設定します。

nsf (OSPF)


) Cisco IOS Release 12.0(32)S 以降、nsf(OSPF)コマンドは、nsf cisco [enforce global] コマンドに置き換わっています。詳細については、nsf cisco [enforce global] コマンドを参照してください。


Open Shortest Path First(OSPF)における Cisco ノンストップ フォワーディング(NSF)動作を設定するには、ルータ コンフィギュレーション モードで nsf コマンドを使用します。OSPF 用の Cisco NSF をディセーブルにするには、このコマンドの no 形式を使用します。

nsf [ enforce global ]

no nsf [ enforce global ]

 
シンタックスの説明

enforce global

(任意)隣接する NSF 認識でないネットワーク装置が検出されたときは、NSF の再起動をキャンセルします。

 
コマンドのデフォルト

デフォルトでこのコマンドはディセーブルになっているため、OSPF の NSF 動作は設定されません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(22)S

このコマンドが追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(20)S

このコマンドが、Cisco 7304 ルータに実装されました。

12.0(32)S

このコマンドは、 nsf cisco [ enforce global ] コマンドで置き換えられました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

ユーザは、再起動時にルータが NSF を実行することが予想されている場合に限り、OSPF の NSF 動作を設定する必要があります。ユーザがすべての NSF の利点を得るようにするには、指定されたルータのすべての OSPF ネイバは NSF 認識でなければなりません。

NSF 認識でないネイバがネットワーク インターフェイスで検出された場合、そのインターフェイスでの NSF の再起動は停止します。ただし、他のインターフェイスでの NSF の再起動は続行されます。この機能は、NSF が設定されている場合の NSF の動作モードのデフォルトに適用されます。

ユーザがオプションのキーワード enforce global を設定した場合、NSF 認識でないネイバが任意のネットワーク インターフェイスで再起動中に検出されると、NSF の再起動はプロセス全体でキャンセルされます。ネイバ ルータとの隣接関係のリセットが任意のインターフェイスで検出された場合、または、OSPF インターフェイスがダウンした場合も、プロセス全体で NSF の再起動がキャンセルされます。デフォルトの NSF モードに戻すには、 no nsf enforce global コマンドを入力します。

次に、ルータ コンフィギュレーション モードを開始し、任意のネットワーク インターフェイス上で再起動中に NSF 認識でないネイバが検出されたときに、OSPF プロセス全体で NSF の再起動がキャンセルされる例を示します。

Router(config)# router ospf 1
Router(config-router)# nsf enforce global

 
関連コマンド

コマンド
説明

debug ip ospf nsf

OSPF NSF コマンドに関するデバッグ メッセージが表示されます。

router ospf

OSPF ルーティングをイネーブルにし、ルータをルータ コンフィギュレーション モードに設定します。

nsf cisco

Open Shortest Path First(OSPF)を実行しているルータで Cisco ノンストップ フォワーディング(NSF)動作をイネーブルにするには、ルータ コンフィギュレーション モードで nsf cisco コマンドを使用します。Cisco NSF をディセーブルにするには、このコマンドの no 形式を使用します。

nsf cisco [ enforce global ]

no nsf cisco [ enforce global ]

 
シンタックスの説明

enforce global

(任意)隣接する NSF 認識でないネットワーク装置が検出されたときは、NSF の再起動をキャンセルします。

 
コマンドのデフォルト

このコマンドはデフォルトでディセーブルになっています。したがって、OSPF を実行しているルータでは Cisco NSF 動作はディセーブルになります。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(32)S

このコマンドが追加されました。このコマンドが、 nsf (OSPF)コマンドから置き換わっています。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

Cisco IOS Release 12.0(32)S およびそれ以降のリリースでは、 nsf cisco [ enforce global ] コマンドで、OSPF の nsf [ enforce global ] コマンドが置き換わっています。

OSPF ルータ上で Cisco NSF をイネーブルにするには、 nsf cisco コマンドを入力する必要があります。Cisco NSF をイネーブルにしているルータの場合、NSF 対応であると考えられ、グレースフル リスタート モードで動作します。OSPF ルータ プロセスは、ルート プロセッサ(RP)スイッチオーバーのため、ノンストップ フォワーディングの復帰を実行します。デフォルトでは、NSF 対応ルータのネイバ ルータは NSF 認識となり、NSF ヘルパー モードで動作します。NSF 対応ルータがグレースフル リスタートを実行しているときは、ネイバ ルータはノンストップ フォワーディングの復帰を支援します。

NSF の再起動プロセス中、NSF 認識でないネイバがネットワーク インターフェイスで検出された場合、そのインターフェイスでの NSF の再起動は停止します。ただし、他のインターフェイスでの NSF の再起動は続行されます。この機能は、Cisco NSF が設定されているときのデフォルトの NSF モードの動作に適用されます。ユーザが nsf cisco コマンドにオプションのキーワード enforce global を指定して設定している場合、NSF 認識でないネイバが任意のネットワーク インターフェイスで再起動中に検出されると、NSF の再起動はプロセス全体でキャンセルされます。ネイバとの隣接関係のリセットが任意のインターフェイスで検出された場合、または、OSPF インターフェイスがダウンした場合も、プロセス全体で NSF の再起動がキャンセルされます。デフォルトの NSF 動作に戻すには、 no nsf cisco enforce global コマンドを入力します。

次に、ルータでの Cisco NSF をイネーブルにし、これによって再起動時に任意のネットワーク インターフェイスで NSF 認識でないネイバが検出された場合に OSPF プロセス全体で NSF の再起動がキャンセルされる例を示します。

router ospf 24
nsf cisco enforce global

 
関連コマンド

コマンド
説明

nsf cisco helper disable

ルータでの NSF ヘルパー モードをディセーブルにします。

nsf ietf

ルータでの NSF(グレースフル リスタート)をイネーブルにします。

nsf ietf helper disable

ルータでの NSF ヘルパー モードをディセーブルにします。

nsf ietf helper strict-lsa-checking

ルータでの厳密な LSA チェックをイネーブルにします。

nsf cisco helper disable

Open Shortest Path First(OSPF)を実行しているシスコ ルータで Cisco ノンストップ フォワーディング(NSF)ヘルパー モードをディセーブルにするには、ルータ コンフィギュレーション モードで nsf cisco helper disable コマンドを使用します。Cisco NSF ヘルパー モードを再びイネーブルにするには、このコマンドの no 形式を使用します。

nsf cisco helper disable

no nsf cisco helper disable

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

このコマンドはデフォルトでイネーブルになっています。したがって、OSPF を実行しているシスコ ルータでは、NSF ヘルパー モードはディセーブルになります。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(32)S

このコマンドが追加されました。

12.4(6)T

このコマンドが、Cisco IOS Release 12.4(6)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

OSPF プロセスを実行するルータが NSF をイネーブルにしている場合、このルータは NSF 対応であると考えられ、グレースフル リスタート モードで動作します。OSPF ルータ プロセスは、ルート プロセッサ(RP)スイッチオーバーのため、ノンストップ フォワーディングの復帰を実行します。デフォルトでは、NSF 対応ルータに隣接するルータは NSF 認識となり、NSF ヘルパー モードで動作します。NSF 対応ルータがグレースフル リスタートを実行しているときは、ヘルパーのルータはそのノンストップ フォワーディングの復帰プロセスを支援します。ルータが再起動するネイバのノンストップ フォワーディングの復帰を支援しないようにするには、 nsf cisco helper disable コマンドを入力します。

次に、OSPF プロセス 3 のシスコ ルータに対し、NSF ヘルパー モードをディセーブルにする例を示します。

router ospf 3
nsf cisco helper disable

 
関連コマンド

コマンド
説明

nsf cisco

Cisco ルータの Cisco NSF をイネーブルにします。

nsf ietf

OSPF を実行しているルータでの IETF ノンストップ フォワーディング動作をイネーブルにします。

nsf ietf helper disable

ルータでの IETF NSF ヘルパー モードをディセーブルにします。

nsf ietf helper strict-lsa-checking

ルータでの厳密な LSA チェックをイネーブルにします。

nsf ietf

Open Shortest Path First(OSPF)を実行しているルータで IETF ノンストップ フォワーディング(NSF)動作をイネーブルにするには、ルータ コンフィギュレーション モードで nsf ietf コマンドを使用します。IETF NSF をディセーブルにするには、このコマンドの no 形式を使用します。

nsf ietf [ restart-interval seconds ]

no nsf ietf [ restart-interval seconds ]

 
シンタックスの説明

restart-interval seconds

(任意)グレースフル リスタートの間隔を秒数で指定します。値の範囲は 1 ~ 1800 です。デフォルトは 120 です。

 
コマンドのデフォルト

このコマンドはデフォルトではディセーブルになっています。したがって、OSPF を実行しているルータでの IETF NSF 動作はディセーブルです。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(32)S

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

OSPF ルータで IETF NSF をイネーブルにするには、 nsf ietf コマンドを入力します。ルータが NSF をイネーブルにしている場合、このルータは NSF 対応であると考えられ、グレースフル リスタート モードで動作します。OSPF ルータ プロセスは、ルート プロセッサ(RP)スイッチオーバーのため、ノンストップ フォワーディングの復帰を実行します。デフォルトでは、NSF 対応ルータのネイバ ルータは NSF 認識となり、NSF ヘルパー モードで動作します。NSF 対応ルータがグレースフル リスタートを実行しているときは、ネイバ ルータはノンストップ フォワーディングの復帰を支援します。

次に、ルータでの IETF NSF(グレースフル リスタート)をイネーブルにし、グレースフル リスタートの間隔を 200 秒に変更する例を示します。

router ospf 24
nsf ietf restart-interval 200

 
関連コマンド

コマンド
説明

nsf cisco

ルータでの Cisco NSF(グレースフル リスタート)をイネーブルにします。

nsf cisco helper disable

ルータでの Cisco NSF ヘルパー モードをディセーブルにします。

nsf ietf helper disable

ルータでの IETF NSF ヘルパー モードをディセーブルにします。

nsf ietf helper strict-lsa-checking

ルータでの厳密な LSA チェックをイネーブルにします。

nsf ietf helper disable

Open Shortest Path First(OSPF)を実行しているルータでの Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)のノンストップ フォワーディング(NSF)ヘルパー モードをディセーブルにするには、ルータ コンフィギュレーション モードで nsf ietf helper disable コマンドを使用します。IETF NSF ヘルパー モードを再びイネーブルにするには、このコマンドの no 形式を使用します。

nsf ietf helper disable

no nsf ietf helper disable

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

このコマンドはデフォルトではディセーブルになっています。したがって、OSPF を実行しているルータでは IETF NSF ヘルパー モードはイネーブルです。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(32)S

このコマンドが追加されました。

12.4(6)T

このコマンドが、Cisco IOS Release 12.4(6)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

OSPF プロセスを実行するルータが NSF をイネーブルにしている場合、このルータは NSF 対応であると考えられ、グレースフル リスタート モードで動作します。OSPF ルータ プロセスは、ルート プロセッサ(RP)スイッチオーバーのため、ノンストップ フォワーディングの復帰を実行します。デフォルトでは、NSF 対応ルータに隣接するルータは NSF 認識となり、NSF ヘルパー モードで動作します。NSF 対応ルータがグレースフル リスタートを実行しているときは、ヘルパーのルータはそのノンストップ フォワーディングの復帰プロセスを支援します。ルータが再起動するネイバのノンストップ フォワーディングの復帰を支援しないようにする場合は、 nsf ietf helper disable コマンドを入力します。

次に、OSPF プロセス 4 のルータに対し、IETF NSF ヘルパー モードをディセーブルにする例を示します。

router ospf 4
nsf ietf helper disable

 
関連コマンド

コマンド
説明

nsf cisco

ルータの Cisco NSF をイネーブルにします。

nsf cisco helper disable

ルータでの IETF NSF ヘルパー モードをディセーブルにします。

nsf ietf

OSPF を実行しているルータでの IETF ノンストップ フォワーディング動作をイネーブルにします。

nsf ietf helper strict-lsa-checking

ルータでの厳密な LSA チェックをイネーブルにします。

nsf ietf helper strict-lsa-checking

Open Shortest Path First(OSPF)プロセスを実行するルータでの厳密なリンクステート アドバタイズメント(LSA)チェックをイネーブルにするには、ルータ コンフィギュレーション モードで nsf ietf helper strict-lsa-checking コマンドを使用します。厳密な LSA チェックをディセーブルにするには、このコマンドの no 形式を使用します。

nsf ietf helper strict-lsa-checking

no nsf ietf helper strict-lsa-checking

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

このコマンドはデフォルトでディセーブルになっています。したがって、OSPF プロセスのルータでは厳密な LSA チェックは行われません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(32)S

このコマンドが追加されました。

12.4(6)T

このコマンドが、Cisco IOS Release 12.4(6)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

NSF 認識ルータおよび NSF 対応ルータの両方で厳密な LSA チェックをイネーブルにするには、 nsf ietf helper strict-lsa-checking コマンドを入力します。ただし、IETF グレースフル リスタート プロセス時にルータがヘルパー ルータになるまでは厳密な LSA チェックは有効になりません。厳密な LSA チェックをイネーブルにすると、ヘルパー ルータは、LSA の変更があるために再起動ルータにフラッディングされる場合、または、グレースフル リスタート プロセスが開始されたときに再起動ルータの再送リスト内の LSA に変更があると検出された場合、再起動ルータのプロセスの支援を終了します。

次に、OSPF プロセス 12 のルータに対し、厳密な LSA チェックをイネーブルにする例を示します。

router ospf 12
nsf ietf helper strict-lsa-checking

 
関連コマンド

コマンド
説明

nsf cisco

ルータの Cisco NSF をイネーブルにします。

nsf cisco helper disable

ルータでの Cisco NSF ヘルパー モードをディセーブルにします。

nsf ietf

OSPF を実行しているルータでの IETF ノンストップ フォワーディング動作をイネーブルにします。

nsf ietf helper disable

ルータでの IETF NSF ヘルパー モードをディセーブルにします。

prefix-suppression

ループバック、セカンダリ IP アドレス、パッシブ インターフェイスに関連付けられているプレフィクスを除き、OSPF が特定の OSPF プロセスについて、すべての IP プレフィクスをアドバタイズしないようにするには、ルータ コンフィギュレーション モードで、prefix -suppression コマンドを使用します。すべての IP プレフィクスをアドバタイズするには、このコマンドの no 形式を使用します。

prefix-suppression

no prefix-suppression

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

すべての IP プレフィクスがアドバタイズされます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.4(15)T

このコマンドが追加されました。

 
使用上のガイドライン

OSPF プロセス全体に対して、すべての IP プレフィクス(ループバック、セカンダリ IP アドレス、パッシブ インターフェイスに関連付けられているプレフィクスを除く)をグローバルに抑制できます。実行するには、ルータ コンフィギュレーション モードで prefix-suppression コマンドを使用します。また、インターフェイス コンフィギュレーション モードで ip ospf prefix-suppression コマンドを使用すると、インターフェイス単位で IP プレフィクスを抑制することもできます。 ip ospf prefix-suppression コマンドを設定した場合、このコマンドが prefix-suppression ルータ コンフィギュレーション コマンドより優先されます。

次に、OSPF プロセス 4 でループバック、セカンダリ IP アドレス、パッシブ インターフェイスに関連付けられているプレフィクスを除き、すべての IP プレフィクスをグローバルに抑制する例を示します。

router ospf 4
prefix-suppression

 
関連コマンド

コマンド
説明

ip ospf prefix-suppression

セカンダリ IP アドレスに関連付けられている IP プレフィクスを除き、特定のインターフェイスに属するすべての IP プレフィクスを OSPF がアドバタイズするのを防ぎます。

process-min-time percent

より高いプライオリティを持つプロセスに CPU が譲渡される前に、OSPF が取る CPU プロセス時間の最小%を指定するには、ルータ コンフィギュレーション モードで、 process-min-time percent コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

process-min-time percent percentage

no process-min-time percent

 
シンタックスの説明

percent

他のプロセスへの CPU の解放が試みられるまで使用されるべき CPU プロセス時間の割合。有効な値の範囲は 1 ~ 100 です。

 
コマンドのデフォルト

25%

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(18)SXF

このコマンドのサポートが Supervisor Engine 720 および Supervisor Engine 320 に追加されました。

12.4(4)T

IPv6 のサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン


) このコマンドは、シスコ TAC の指示がある場合に限り使用してください。


このコマンドは、OSPFv2 および OSPFv3 によってサポートされます。

process-min-time percent コマンドは、プロセスの最大時間の最小 % を設定するために使用します。プロセスで使用可能な CPU の使用最小 % を低くすると、状況によっては、複数のタスク間で CPU の公平な分配を確実にするために有効です。いったんこの割合を超過すると、CPU の制御は、よりプライオリティの高いプロセスに渡される場合があります。

プロセスの最大時間は process-max-time コマンドを使用して設定します。 process-min-time percent コマンドは、 process-max-time コマンドと組み合わせて使用します。

次の例で、CPU の解放までに使用される CPU のプロセス時間の割合を設定する方法を示します。

Router# configure terminal
Router(config)# router ospf
Router(config-router)# process-min-time percent 35
 

次の例では、IPv4 のデフォルト設定に戻る方法を示します。

Router# configure terminal
Router(config)# router rip
Router(config-router)# no process-min-time

 
関連コマンド

コマンド
説明

process-max-time

プロセスが自発的に別のプロセスに譲歩する必要が発生するまでの時間の長さを設定します。

redistribute maximum-prefix

Open Shortest Path First(OSPF)に再配布されるプレフィクスの数を制限したり、OSPF に再配布されたプレフィクスが最大数を超えたときに警告メッセージを生成したりするには、ルータ コンフィギュレーション モードで redistribute maximum-prefix コマンドを使用します。この値を削除するには、このコマンドの no 形式を使用します。

redistribute maximum-prefix maximum [ percentage ] [ warning-only | withdraw ]

no redistribute maximum-prefix

 
シンタックスの説明

maximum

OSPF に再配布できる IP プレフィクスの最大数を指定する 1 ~ 4294967295 の整数。

キーワード warning-only を設定すると、 maximum 値でシステムが警告メッセージのログを記録するまでに OSPF に再配布できるプレフィクスの数が指定されます。再配布数に制限はありません。

OSPF に再配布できる IP プレフィクスの最大数または、システムが警告メッセージのログを記録するまでに OSPF に再配布できるプレフィクス数の設定は、キーワード warning-only が指定されているかどうかで異なります。

引数 maximum のデフォルト値はありません。

キーワード warning-only も設定されている場合、この値は再配布を制限しません。この値は、到達すると警告メッセージのログが記録されるようになる、プレフィクスの再配布数になるだけです。

percentage

(任意)1 ~ 100 の整数で、警告メッセージが生成されるしきい値として % で指定します。

percentage のデフォルトは 75 です。

warning-only

(任意)引数 maximum で定義済みのプレフィクス数を超えたときに警告メッセージのログが記録されるようにします。追加の再配布が防止されることはありません。

withdraw

(任意)引数 maximum で定義済みのプレフィクス数を超えたときに追加の再配布が行われないようにします。

また、IS-IS が外部(再配布される)IP プレフィクスのないリンクステート PDU(LSP)を再構築します。

 
デフォルト

percentage のデフォルトは 75 です。

 
コマンド モード

ルータ コンフィギュレーション(config-router)#

 
コマンドの履歴

リリース
変更内容

12.0(25)S

このコマンドが追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.3(4)T

このコマンドが、Cisco IOS Release 12.3(4)T に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

ボーダー ゲートウェイ プロトコル(BGP)の IS-IS への再配布で発生すると思われる、大量の IP プレフィクスが IS-IS に誤って挿入されると、ネットワークで深刻なフラッディング状態になるおそれがあります。プレフィクスの再配布数を制限すると、この潜在的な問題を回避できます。

redistribute maximum-prefix コマンドを設定した場合は、プレフィクスの再配布数が設定の最大値に達したときに、これ以上のプレフィクスは再配布されません( warning-only キーワードが設定されている場合を除きます)。

再配布の制限は、外部 IP プレフィクスにだけ適用されます。デフォルトのプレフィクスおよびサマライズされたプレフィクスは制限されません。

Not-So-Stubby-Area(NSSA)のそれぞれについてこの制限が追跡されます。これは、NSSA への再配布が各 NSSA で独立して行われ、他のすべての標準エリアに依存していないためです。

ルータから OSPF プロセスにプレフィクスがいくつ再配布されるかを考慮して、 maximum 値を選択してください。

IS-IS プロトコルの例

次の例で、IS-IS に再配布できるプレフィクスの最大数を 600 に設定する方法を示します。再配布されたプレフィクス数が 600 の 75%(450 個のプレフィクス)に達すると、警告メッセージのログが記録されます。

router isis
redistribute maximum-prefix 600
 

次の例で、IS-IS に再配布できるプレフィクスの最大数を 1200 に設定する方法を示します。再配布されたプレフィクス数が 1200 の 80%(960 個のプレフィクス)に達すると、警告メッセージのログが記録されます。

router isis
redistribute maximum-prefix 1200 80
 

次の例で、2 種類の警告メッセージのログの記録を許可する方法を示します。最初のメッセージは、再配布されたプレフィクス数が 600 の 85%(510 個のプレフィクス)に達したときにログが記録され、2 番目のメッセージは、再配布されたプレフィクス数が 600 に達したときにログが記録されます。ただし、再配布されるプレフィクス数は制限されていません。

router isis
redistribute maximum-prefix 600 85 warning-only
 

次の例で、OSPF プロセス 1 に再配布できるプレフィクスの最大数を 2000 に設定する方法を示します。再配布されたプレフィクス数が 2000 の 75%(1500 個のプレフィクス)に達すると、警告メッセージのログが記録されます。制限に達すると、もう 1 種類の警告ログが記録され、これ以降、プレフィクスは再配布されなくなります。

OSPF ルーティング プロトコルの例

router ospf 1
network 10.0.0.0 0.0.0.255 area 0
redistribute eigrp 10 subnets
redistribute maximum-prefix 2000
 

次の例で、OSPF プロセス 1 に再配布できるプレフィクスの最大数を 1200 に設定する方法を示します。再配布されたプレフィクス数が 1200 の 80%(960 個のプレフィクス)に達すると、警告メッセージのログが記録されます。制限に達すると、もう 1 種類の警告ログが記録され、これ以降、プレフィクスは再配布されなくなります。

router ospf 1
network 10.0.0.0 0.0.0.255 area 0
redistribute eigrp 10 subnets
redistribute maximum-prefix 1200 80
 

次の例で、2 種類の警告メッセージのログの記録を許可する方法を示します。最初のメッセージは、再配布されたプレフィクス数が 600 の 85%(510 個のプレフィクス)に達したときにログが記録され、2 番目のメッセージは、再配布されたプレフィクス数が 600 に達したときにログが記録されます。ただし、再配布されるプレフィクス数は制限されていません。

router ospf 1
network 10.0.0.0 0.0.0.255 area 0
redistribute eigrp 10 subnets
redistribute maximum-prefix 600 85 warning-only

 

router ospf

Open Shortest Path First(OSPF)ルーティング プロセスを設定するには、グローバル コンフィギュレーション モードで router ospf コマンドを使用します。OSPF ルーティング プロセスを終了するには、このコマンドの no 形式を使用します。

router ospf process-id [ vrf vpn-name ]

no router ospf process-id [ vrf vpn-name ]

 
シンタックスの説明

process-id

OSPF ルーティング プロセスの内部で使用される識別パラメータ。ローカルで割り当てられ、任意の正の整数を使用できます。OSPF ルーティング プロセスごとに固有の値が割り当てられます。

vrf vpn-name

(任意)OSPF VRF プロセスに関連付ける VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスの名前を指定します。

 
デフォルト

OSPF ルーティング プロセスは定義されません。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(7)T

VPN を識別するためのキーワード vrf および引数 vpn-name が追加されました。

12.0(9)ST

キーワード vrf および引数 vpn-name が追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

1 ルータあたり複数の OSPF ルーティング プロセスを指定できます。

router ospf コマンドの入力後、パスの最大数を入力できます。1 ~ 32 のパスを指定できます。

次に、OSPF ルーティング プロセスを設定し、プロセス番号 109 を割り当てる例を示します。

Router(config)# router ospf 109
 

次の例で、 router ospf コマンドを使用して、VRF first、second、third の OSPF VRF インスタンス プロセスを設定する、基本的な OSPF 設定を示します。

Router> enable
Router# configure terminal
Router(config)# router ospf 12 vrf first
Router(config)# router ospf 13 vrf second
Router(config)# router ospf 14 vrf third
Router(config)# exit
 

次の例で、 maximum-paths オプションの使用方法を示します。

Router> enable
Router# configure terminal
Router(config)# router ospf
Router(config-router)# maximum-paths?
Router(config-router)# 20
Router(config-router)# exit

 
関連コマンド

コマンド
説明

network area

OSPF を実行するインターフェイスを定義し、それらのインターフェイスに対するエリア ID を定義します。

router-id

固定ルータ ID を使用するには、ルータ コンフィギュレーション モードで router-id コマンドを使用します。Open Shortest Path First(OSPF)で以前の OSPF ルータ ID の動作を強制するには、このコマンドの no 形式を使用します。

router-id ip-address

no router-id ip-address

 
シンタックスの説明

ip-address

IP アドレス形式のルータ ID。

 
デフォルト

OSPF ルーティング プロセスは定義されません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(1)T

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

IP アドレス形式で各ルータに任意の値を定義できます。ただし、それぞれ固有のルータ ID にする必要があります。

すでにアクティブになっている(ネイバが存在する)OSPF ルータ プロセスでこのコマンドを使用すると、次回のリロード時または手動の OSPF プロセスの再起動時に、新しいルータ ID が使用されます。OSPF プロセスを手動で再起動するには、 clear ip ospf コマンドを使用します。

次に、固定ルータ ID を指定する例を示します。

router-id 10.1.1.1

 
関連コマンド

コマンド
説明

clear ip ospf

OSPF ルーティング プロセス ID に基づいて再配布をクリアします。

router ospf

OSPF ルーティング プロセスを設定します。