Cisco IOS IP ルーティング:OSPF コマンド リファ レンス
OSPF コマンド-1
OSPF コマンド
発行日;2012/02/05 | 英語版ドキュメント(2011/04/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

OSPF コマンド

area authentication

area default-cost

area filter-list

area nssa

area nssa translate

area range

area sham-link

area stub

area virtual-link

auto-cost

capability lls

capability transit

capability vrf-lite

clear ip ospf

clear ip ospf traffic

clear ipv6 ospf traffic

compatible rfc1583

default-information originate (OSPF)

default-metric (OSPF)

discard-route

distance ospf

domain-id (OSPF)

domain-tag

ignore lsa mospf

interface-id snmp-if-index

ip ospf area

ip ospf authentication

ip ospf authentication-key

ip ospf bfd

ip ospf cost

ip ospf database-filter all out

ip ospf dead-interval

ip ospf demand-circuit

OSPF コマンド

area authentication

Open Shortest Path First(OSPF)エリアの認証をイネーブルにするには、ルータ コンフィギュレーション モードで area authentication コマンドを使用します。あるエリアまたは指定したエリアの認証指定を設定から削除するには、このコマンドの no 形式を使用します。

area area-id authentication [ message-digest ]

no area area-id authentication [ message-digest ]

 
シンタックスの説明

area-id

認証をイネーブルにするエリアの ID。ID は、10 進数値または IP アドレスで指定します。

message-digest

(任意)引数 area-id で指定したエリアに対し、Message Digest 5(MD5)認証をイネーブルにします。

 
デフォルト

タイプ 0 認証(認証なし)

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

11.0

キーワード message-digest が追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

エリアに対して認証を指定すると、認証が RFC 1247 で規定されているタイプ 1(単純なパスワード)に設定されます。このコマンドがコンフィギュレーション ファイルに含まれていない場合、タイプ 0(認証なし)の認証が使用されます。

認証タイプは、エリア内のすべてのルータとサーバで同じである必要があります。ネットワーク上のすべての OSPF ルータの認証パスワードは、ルータが OSPF を通じて互いに通信する場合、同じである必要があります。このパスワードを指定するには、 ip ospf authentication-key インターフェイス コマンドを使用します。

キーワード message-digest を使用して MD5 認証をイネーブルにする場合、 ip ospf message-digest-key インターフェイス コマンドを使用してパスワードを設定する必要があります。

エリアの認証指定を削除するには、このコマンドの no 形式を、キーワード authentication を指定して使用します。


) 指定したエリアをソフトウェア コンフィギュレーションから削除するには、no area area-id コマンドを使用します(他のキーワードは指定しません)。つまり、no area area-id コマンドを実行すると、area authenticationarea default-costarea nssaarea rangearea stubarea virtual-link などのすべてのエリア オプションが削除されます。


次に、OSPF ルーティング プロセス 201 のエリア 0 および 10.0.0.0 に対して認証を必須とする例を示します。認証キーも指定しています。

interface ethernet 0
ip address 192.168.251.201 255.255.255.0
ip ospf authentication-key adcdefgh
!
interface ethernet 1
ip address 10.56.0.201 255.255.0.0
ip ospf authentication-key ijklmnop
!
router ospf 201
network 10.0.0.0 0.255.255.255 area 10.0.0.0
network 192.168.0.0 0.0.255.255 area 0
area 10.0.0.0 authentication
area 0 authentication

 
関連コマンド

コマンド
説明

area default-cost

スタブ エリアに送信されるデフォルト サマリー ルートのコストを指定します。

area stub

エリアをスタブ エリアとして定義します。

ip ospf authentication-key

OSPF の単純パスワード認証を使用しているネイバ ルータが使用するパスワードを割り当てます。

ip ospf message-digest-key

OSPF MD5 認証をイネーブルにします。

area default-cost

スタブ エリアまたは Not-So-Stubby Area(NSSA)に送信されるデフォルト サマリー ルートのコストを指定するには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで area default-cost コマンドを使用します。割り当て済みのデフォルト ルート コストを削除するには、このコマンドの no 形式を使用します。

area area-id default-cost cost

no area area-id default-cost cost

 
シンタックスの説明

area-id

スタブ エリアまたは NSSA の ID。ID は、10 進数値または IP アドレスで指定します。

cost

スタブまたは NSSA に対して使用するデフォルト サマリー ルートのコスト。指定できる値は 24 ビット数値です。

 
コマンドのデフォルト

コスト:1

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、スタブ エリアまたは NSSA に接続された Area Border Router(ABR; エリア境界ルータ)だけで使用します。

スタブ エリア ルータ コンフィギュレーション コマンドには、 area コマンドの stub オプションと default-cost オプションの 2 つがあります。スタブ エリアに接続されたすべてのルータとアクセス サーバで、 area コマンドの stub オプションを使用して、エリアをスタブ エリアとして設定する必要があります。 default-cost オプションは、スタブ エリアに接続された ABR だけで使用します。 default-cost オプションは、ABR によってスタブ エリアに生成されるサマリー デフォルト ルートのメトリックを指定します。


) 指定したエリアをソフトウェア コンフィギュレーションから削除するには、no area area-id コマンドを使用します(他のキーワードは指定しません)。つまり、no area area-id コマンドを実行すると、area authenticationarea default-costarea nssaarea rangearea stubarea virtual-link などのすべてのエリア オプションが削除されます。


Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで area default-cost コマンドを実行する必要があります。

次に、デフォルトのコスト 20 をスタブ ネットワーク 10.0.0.0 に割り当てる例を示します。

interface ethernet 0
ip address 10.56.0.201 255.255.0.0
!
router ospf 201
network 10.0.0.0 0.255.255.255 area 10.0.0.0
area 10.0.0.0 stub
area 10.0.0.0 default-cost 20

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証をイネーブルにします。

area stub

エリアをスタブ エリアとして定義します。

area filter-list

エリア境界ルータ(ABR)の Open Shortest Path First(OSPF)エリア間でタイプ 3 Link-State Advertisements(LSA; リンクステート アドバタイズメント)でアドバタイズされるプレフィクスをフィルタするには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで area filter-list コマンドを使用します。フィルタを変更またはキャンセルするには、このコマンドの no 形式を使用します。

area area-id filter-list prefix prefix-list-name { in | out }

no area area-id filter-list prefix prefix-list-name { in | out }

 
シンタックスの説明

area-id

フィルタリングを設定するエリアの ID。ID は、10 進数値または IP アドレスで指定します。

prefix

プレフィクス リストを使用することを示します。

prefix-list-name

プレフィクス リストの名前。

in

プレフィクス リストは、他のエリアから指定したエリアにアドバタイズされるプレフィクスに適用されます。

out

プレフィクス リストは、指定したエリアから他のエリアにアドバタイズされるプレフィクスに適用されます。

 
コマンドのデフォルト

このコマンドは、デフォルトでディセーブルになっています。プレフィクスはフィルタされません。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.0(15)S

このコマンドが追加されました。

12.2(4)T

このコマンドが、Cisco IOS Release 12.2(4)T に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

 
使用上のガイドライン

この機能を「in」方向でイネーブルにした場合、その他すべてのエリアからの情報に基づく、ABR によってこのエリアに送信されるすべてのタイプ 3 LSA は、プレフィクス リストによってフィルタされます。別のエリアで area range コマンドの結果として送信されたタイプ 3 LSA は、個別に送信された他のタイプ 3 LSA と同様に処理されます。プレフィクス リストのエントリに一致しないプレフィクスは、暗黙的に拒否されます。

この機能を「out」方向でイネーブルにした場合、このエリアからその他すべてのエリアへの情報に基づく、ABR によって送信されるすべてのタイプ 3 LSA は、プレフィクス リストによってフィルタされます。 area range コマンドがこのエリアに対して設定されている場合、エリア範囲に対応するタイプ 3 LSA は、エリア範囲内の少なくとも 1 つのプレフィクスがプレフィクス リストのエントリに一致する場合にだけ、他のすべてのエリアに送信されます。

すべてのプレフィクスがプレフィクス リストで拒否される場合、 area range コマンドに対応するタイプ 3 LSA は、他のどのエリアにも送信されません。プレフィクス リストによって許可されないプレフィクスは、暗黙的に拒否されます。

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで area filter-list コマンドを実行する必要があります。

次に、他のすべてのエリアからエリア 1 に送信されるプレフィクスをフィルタする例を示します。

area 1 filter-list prefix AREA_1 in

 
関連コマンド

コマンド
説明

area range

エリア境界でルートを統合および集約します。

area nssa

Not-So-Stubby Area(NSSA)を設定するには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで area nssa コマンドを使用します。エリアから NSSA の区別を削除するには、このコマンドの no 形式を使用します。

area area-id nssa [ no-redistribution ] [ default-information-originate [ metric ] [ metric-type ]] [ no-summary ] [ nssa-only ]

no area area-id nssa [ no-redistribution ] [ default-information-originate [ metric ] [ metric-type ]] [ no-summary ] [ nssa-only ]

 
シンタックスの説明

area-id

スタブ エリアまたは NSSA の ID。ID は、10 進数値または IP アドレスで指定します。

no-redistribution

(任意)ルータが NSSA エリア境界ルータ(ABR)であり、 redistribute コマンドで、通常のエリアだけにルートをインポートし、NSSA エリアにインポートしない場合に使用します。

default-information-
originate

(任意)タイプ 7 デフォルトを NSSA エリアに生成するために使用します。このキーワードは、NSSA ABR または NSSA Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)だけで有効です。

metric

(任意)OSPF デフォルト メトリックを指定します。

metric-type

(任意)デフォルト ルートの OSPF メトリック タイプを指定します。

no-summary

(任意)エリアを NSSA にすることを許可しますが、サマリー ルートを注入しません。

nssa-only

(任意)タイプ 7 LSA の Propagate(P)ビットを 0 に設定することで、この NSSA エリアに対するデフォルト アドバタイズメントを制限します。

 
コマンドのデフォルト

NSSA エリアは定義されません。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。キーワード nssa-only が追加されました。

12.2(33)SRE

このコマンドが変更されました。キーワード nssa-only が追加されました。

 
使用上のガイドライン

指定したエリアをソフトウェア コンフィギュレーションから削除するには、 no area area-id コマンドを使用します(他のキーワードは指定しません)。つまり、 no area area-id コマンドを実行すると、 area authentication area default-cost area nssa area range area stub area virtual-link などのすべてのエリア オプションが削除されます。

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで area nssa コマンドを実行する必要があります。

次に、エリア 1 を NSSA エリアにする例を示します。

router ospf 1
redistribute rip subnets
network 172.19.92.0 0.0.0.255 area 1
area 1 nssa

 
関連コマンド

コマンド
説明

redistribute

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

area nssa translate

エリアを Not-So-Stubby Area(NSSA)として設定し、OSPF Forwarding Address Suppression in Translated Type-5 LSA 機能を設定するには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで use the area nssa translate コマンドを使用します。エリアから NSSA の区別を削除するには、このコマンドの no 形式を使用します。

area area-id nssa translate type7 suppress-fa

no area area-id nssa translate type7 suppress-fa

 
シンタックスの説明

area-id

スタブ エリアまたは NSSA の ID。ID は、10 進数値または IP アドレスで指定します。

translate

あるタイプの LSA を別のタイプの LSA に変換します。このキーワードは、NSSA エリア境界ルータ(ABR)または NSSA 自律システム境界ルータ(ASBR)だけで有効です。

type7

タイプ 7 LSA をタイプ 5 LSA に変換します。このキーワードは、NSSA ABR または NSSA ASBR だけで有効です。

suppress-fa

タイプ 7 LSA のフォワーディング アドレスのタイプ 5 LSA への設定を抑止します。このキーワードは、NSSA ABR または NSSA ASBR だけで有効です。

 
コマンドのデフォルト

変換は実行されません。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.2(15)T

このコマンドが追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

OSPF Forwarding Address Suppression in Translated Type-5 LSA 機能を設定するには、キーワード translate type7 suppress-fa を設定します。次の点に注意してください。


注意 OSPF Forwarding Address Suppression in Translated Type-5 LSA 機能を設定すると、ルータが RFC 1587 に準拠しなくなります。また、宛先のフォワーディング アドレスに到達するためのさらによいパスが存在する可能性があるため、次善ルーティングとなる可能性があります。この機能は、慎重に検討し、ネットワーク トポロジを理解するまでは設定しないことをお勧めします。

キーワード translate を、 no-redistribution または default-information-originate の各キーワードとともに使用する場合、読みやすさのために、2 行に分かれた area nssa コマンドがコンフィギュレーション ファイルに設定されます。たとえば、 area 6 nssa no-redistribution translate type7 suppress-fa コマンドを設定した場合、次の行がコンフィギュレーション ファイルに設定されます。

router ospf 1
area 6 nssa no-redistribution
area 6 nssa translate type7 suppress-fa
 

指定したエリアをソフトウェア コンフィギュレーションから削除するには、 no area area-id コマンドを使用します(他のキーワードは指定しません)。つまり、 no area area-id コマンドを実行すると、 area authentication area default-cost area nssa area range area stub area virtual-link などのすべてのエリア オプションが削除されます。

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで area nssa translate コマンドを実行する必要があります。

Release 12.2(33)SXH

Cisco IOS Release 12.2(33)SXH よりも前のリリースでは、NSSA ASBR は、常にフォワーディング アドレスが設定された状態でタイプ 7 LSA をアドバタイズしていました。これは、タイプ 7 が後でタイプ 5 LSA に変換されるときに必要になります。Cisco IOS Release 12.2(33)SXH では、タイプ 7 LSA がタイプ 5 LSA に変換されることを意図していない場合は、フォワーディング アドレスがゼロとなるように、この動作が変更されました。LSA を変換する必要がない場合、フォワーディング アドレスは、ネクストホップが OSPF ルート経由でアクセスできる場合にだけ設定されます。

次の例では、OSPF により、エリア 1 からのタイプ 7 LSA がタイプ 5 LSA に変換されますが、タイプ 7 フォワーディング アドレスはタイプ 5 LSA に設定されません。タイプ 5 LSA では、フォワーディング アドレスとして 0.0.0.0 が設定されます。

router ospf 2
network 172.19.92.0 0.0.0.255 area 1
area 1 nssa translate type7 suppress-fa

 
関連コマンド

コマンド
説明

redistribute

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

area range

エリア境界でルートを統合および集約するには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで area range コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

area area-id range ip-address ip-address-mask [ advertise | not-advertise ] [ cost cost ]

no area area-id range ip-address ip-address-mask [ advertise | not-advertise ] [ cost cost ]

 
シンタックスの説明

area-id

ルートを要約するエリアの ID。10 進数値または IPv6 プレフィクスで指定します。

ip-address

IP アドレス。

ip-address-mask

IP アドレス マスク。

advertise

(任意)アドバタイズするアドレス範囲ステータスを設定し、タイプ 3 サマリー リンクステート アドバタイズメント(LSA)を生成します。

not-advertise

(任意)アドレス範囲ステータスを DoNotAdvertise に設定します。タイプ 3 サマリー LSA は抑止され、コンポーネント ネットワークは、他のネットワークから隠されたままになります。

cost cost

(任意)このサマリー ルートのメトリックまたはコスト。宛先への最短パスを決定するための OSPF SPF 計算で使用します。値の範囲は 0 ~ 16777215 です。

 
コマンドのデフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(24)S

キーワード cost と引数 cost が追加されました。

12.2(15)T

キーワード cost と引数 cost が追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

area range コマンドは、エリア境界ルータ(ABR)だけで使用します。このコマンドは、あるエリアのルートを統合または集約するために使用します。その結果、1 つのサマリー ルートが ABR によって他のエリアにアドバタイズされます。ルーティング情報は、エリア境界で要約されます。エリアの外部では、各アドレス範囲に対して 1 つのルートがアドバタイズされます。この動作を ルート集約 と呼びます。

複数の area range ルータ コンフィギュレーション コマンドを設定できます。そのため、OSPF は、多数のアドレス範囲に対してアドレスを集約できます。


) 指定したエリアをソフトウェア コンフィギュレーションから削除するには、no area area-id コマンドを使用します(他のキーワードは指定しません)。つまり、no area area-id コマンドを実行すると、area default-costarea nssaarea rangearea stubarea virtual-link などのすべてのエリア オプションが削除されます。


Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで area range コマンドを実行する必要があります。

次に、ネットワーク 10.0.0.0 上のすべてのサブネットおよびネットワーク 192.168.110.0 上のすべてのホストに対し、ABR によって他のエリアに 1 つのサマリー ルートをアドバタイズするよう指定する例を示します。

interface ethernet 0
ip address 192.168.110.201 255.255.255.0
!
interface ethernet 1
ip address 192.168.120.201 255.255.255.0
!
router ospf 201
network 192.168.110.0 0.0.0.255 area 0
area 10.0.0.0 range 10.0.0.0 255.0.0.0
area 0 range 192.168.110.0 255.255.0.0

 
関連コマンド

コマンド
説明

area range (IPv6)

IPv6 ネットワークのエリア境界でルートを統合および集約します。

area sham-link

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)バックボーン内の Provider Edge(PE; プロバイダー エッジ)ルータ上で模造リンク インターフェイスを設定するには、ルータ コンフィギュレーション モードで area sham-link コマンドを使用します。模造リンクを削除するには、このコマンドの no 形式を使用します。

area area-id sham-link source-address destination-address [ cost number] [ ttl-security
hops hop-count]

no area area-id sham-link source-address destination-address

 
シンタックスの説明

area-id

模造リンクに割り当てられる Open Shortest Path First(OSPF)エリアの ID 番号。有効な値は、1 ~ 4294967295 の数値または A.B.C.D 形式の IP アドレスです。デフォルトはありません。

source-address

送信元 PE ルータの IP アドレス( ip-address [ mask ] 形式)。

destination-address

宛先 PE ルータの IP アドレス( ip-address [ mask ] 形式)。

cost number

(任意)模造リンク インターフェイス上で IP パケットを送信するための OSPF コストを指定します。引数 number の範囲は、1 ~ 65535 です。

ttl-security hops hop-count

(任意)模造リンク上で Time-to-Live(TTL; 存続可能時間)セキュリティを設定します。引数 hop-count の範囲は 1 ~ 254 です。

 
コマンドのデフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.2(8)T

このコマンドが追加されました。

12.0(21)ST

このコマンドが、Cisco IOS Release 12.0(21)ST に統合されました。Cisco 12000 シリーズ インターネット ルータのサポートが追加されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。Cisco 10000 シリーズ インターネット ルータのサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

12.2(33)SRC

ttl-security hops hop-count の各キーワードと引数が追加されました。

15.0(1)M

このコマンドが、Cisco IOS Release 15.0(1)M に統合されました。

 
使用上のガイドライン

MPLS VPN 環境では、複数の VPN クライアント サイトを同じ OSPF エリアで接続できます。これらのサイトが、VPN バックボーンに加えてバックドア リンクでも接続されている場合、すべてのトラフィックは、VPN バックボーンではなくバックドア リンクを経由します。OSPF は、常にエリア間(外部)ルートよりもエリア内ルートを優先的に選択します。

MPLS VPN でのこの OSPF のデフォルトの動作を修正するには、 area sham-link コマンドを使用して、2 つの PE 間に模造リンクを設定し、MPLS VPN バックボーンを通じてサイトを接続します。模造リンクは、PE 間のエリア内(番号なしのポイントツーポイント)接続を表します。エリア内のその他すべてのルートは、模造リンクを使用して、リモート サイトへのエリア内 Shortest Path First(SPF)ルートを計算します。

模造リンクのエンドポイントとして動作する PE ルータでは、模造リンクの送信元アドレスと宛先アドレスを、ホスト ルート マスク(255.255.255.255)として設定します。送信元および宛先 IP アドレスは、VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスに属し、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)によってリモート PE ルータにアドバタイズされる必要があります。模造リンク エンドポイント アドレスは、OSPF によってアドバタイズされないことが必要です。

ネイバからの OSPF パケット上の TTL 値のチェックをイネーブルにするか、ネイバに送信される TTL 値を設定するには、 ttl-security hops hop-count の各キーワードと引数を使用します。この機能により、OSPF にさらなる保護レイヤが追加されます。

次に、 area sham-link コマンドを MPLS VPN バックボーン内の 2 台の PE ルータで使用し、各ルータ間に模造リンクを設定する方法を示します。

Router1(config)# interface loopback 55
Router1(config-if)# ip vrf forwarding v1
Router1(config-if)# ip address 10.0.0.1 255.255.255.255
!
Router1(config)# router ospf 2 vrf v1
Router1(config-router)# log-adjacency-changes
Router1(config-router)# area 120 sham-link 10.0.0.1 10.44.0.1 cost 1
Router1(config-router)# redistribute bgp 1 subnets
Router1(config-router)# network 10.2.0.1 255.255.255.255 area 1
Router1(config-router)# network 10.120.0.0 0.255.255.255 area 120
Router1(config-router)# network 10.140.0.0 0.255.255.255 area 120
!
Router2(config)# interface loopback 44
Router2(config-if)# ip vrf forwarding v1
Router2(config-if)# ip address 172.16.0.1 255.255.255.255
!
Router2(config)# router ospf 2 vrf v1
Router2(config-router)# log-adjacency-changes
Router2(config-router)# area 120 sham-link 10.44.0.1 10.0.0.1 cost 1
Router2(config-router)# redistribute bgp 1 subnets
Router2(config-router)# network 10.2.0.1 255.255.255.255 area 1
Router2(config-router)# network 10.120.0.0 0.255.255.255 area 120
Router2(config-router)# network 10.140.0.0 0.255.255.255 area 120
!
 

 
関連コマンド

コマンド
説明

ttl-security hops

ネイバからの OSPF パケット上の TTL 値のチェックか、ネイバに送信される TTL 値の設定をイネーブルにします。

area stub

エリアをスタブ エリアとして定義するには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで、use the area stub コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

area area-id stub [ no-summary ]

no area area-id stub [ no-summary ]

 
シンタックスの説明

area-id

スタブ エリアの ID。10 進数値または IP アドレスで指定します。

no-summary

(任意)エリア境界ルータ(ABR)がサマリー リンク アドバタイズメントをスタブ エリアに送信しないようにします。

 
デフォルト

スタブ エリアは定義されていません。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

area stub コマンドは、スタブ エリア内のすべてのルータとアクセス サーバで設定する必要があります。 area ルータ コンフィギュレーション コマンドをキーワード default-cost を指定して使用し、ABR によってスタブ エリアに送信されるデフォルト内部ルートのコストを指定します。

スタブ エリア ルータ コンフィギュレーション コマンドには、 area ルータ コンフィギュレーション コマンドの stub オプションと default-cost オプションの 2 つがあります。スタブ エリアに接続されたすべてのルータで、 area コマンドをキーワード stub を指定して使用して、エリアをスタブ エリアとして設定する必要があります。キーワード default-cost は、スタブ エリアに接続された ABR だけで使用します。キーワード default-cost は、ABR によってスタブ エリアに生成されるサマリー デフォルト ルートのメトリックを指定します。

スタブ エリアに送信されるリンクステート アドバタイズメント(LSA)の数をさらに減らすには、ABR 上でキーワード no-summary を設定し、サマリー LSA(LSA タイプ 3)をスタブ エリアに送信しないようにします。


) 指定したエリアをソフトウェア コンフィギュレーションから削除するには、no area area-id コマンドを使用します(他のキーワードは指定しません)。つまり、no area area-id コマンドを実行すると、area authenticationarea default-costarea nssaarea rangearea stubarea virtual-link などのすべてのエリア オプションが削除されます。


Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで area stub コマンドを実行する必要があります。

次に、デフォルトのコスト 20 をスタブ ネットワーク 10.0.0.0 に割り当てる例を示します。

interface ethernet 0
ip address 10.56.0.201 255.255.0.0
!
router ospf 201
network 10.0.0.0 0.255.255.255 area 10.0.0.0
area 10.0.0.0 stub
area 10.0.0.0 default-cost 20

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証をイネーブルにします。

area default-cost

スタブ エリアに送信されるデフォルト サマリー ルートのコストを指定します。

area virtual-link

Open Shortest Path First(OSPF)仮想リンクを定義するには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで area virtual-link コマンドを使用します。仮想リンクを削除するには、このコマンドの no 形式を使用します。

area area-id virtual-link router-id [ hello-interval seconds ] [ retransmit-interval seconds ] [ transmit-delay seconds ] [ dead-interval seconds ] [ ttl-security hops hop-count]

no area area-id virtual-link router-id

 
シンタックスの説明

area-id

仮想リンクに割り当てるエリア ID。10 進数値または有効な IPv6 プレフィクスを指定します。デフォルトはありません。

router-id

仮想リンク ネイバに関連付けられるルータ ID。ルータ ID は、 show ip ospf コマンドまたは show ipv6 display コマンドで表示されます。デフォルトはありません。

hello-interval seconds

(任意)Cisco IOS ソフトウェアがインターフェイス上で送信する hello パケットの間隔(秒単位)を指定します。hello 間隔は、hello パケットでアドバタイズされる符号なし整数値です。この値は、共通のネットワークに接続されているすべてのルータおよびアクセス サーバで同じであることが必要です。値の範囲は 1 ~ 8192 です。デフォルト値は 10 です。

retransmit-interval seconds

(任意)インターフェイスに属する隣接に対するリンクステート アドバタイズメント(LSA)の再送信間隔(秒単位)を指定します。再送信間隔は、接続されているネットワーク上の任意の 2 台のルータ間の予想されるラウンドトリップ遅延です。この値は、予想されるラウンドトリップ遅延よりも大きいことが必要です。値の範囲は 1 ~ 8192 です。デフォルト値は 5 です。

transmit-delay seconds

(任意)インターフェイス上でリンクステート アップデート パケットを送信するために必要な推定される時間(秒単位)を指定します。ゼロよりも大きい整数値を指定します。アップデート パケット内の LSA の経過時間は、転送前にこの値の分だけ増分されます。値の範囲は 1 ~ 8192 です。デフォルト値は 1 です。

dead-interval seconds

(任意)hello パケットがどれだけの時間(秒単位)届かなかった場合にネイバがルータをダウンと見なすかを指定します。デッド インターバルは符号なし整数値です。デフォルトは hello 間隔の 4 倍または 40 秒です。hello 間隔と同様に、この値は、共通のネットワークに接続されているすべてのルータとアクセス サーバで同じでなければなりません。

ttl-security hops hop-count

(任意)仮想リンク上で存続可能時間(TTL)セキュリティを設定します。引数 hop-count の範囲は 1 ~ 254 です。

 
コマンドのデフォルト

OSPF 仮想リンクは定義されていません。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(24)S

IPv6 のサポートが追加されました。

12.2(15)T

IPv6 のサポートが追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

12.2(33)SRC

ttl-security hops hop-count の各キーワードと引数が追加されました。

15.0(1)M

このコマンドが、Cisco IOS Release 15.0(1)M に統合されました。

 
使用上のガイドライン

OSPF では、すべてのエリアが 1 つのバックボーン エリアに接続されている必要があります。バックボーンへの接続が失われた場合、仮想リンクを確立することで修復できます。

hello 間隔が短いほどトポロジの変更が早く検出されますが、ルーティング トラフィックがその分多くなります。再送信間隔は控えめに設定する必要があります。そうしないと、不必要な再送信が発生します。この値は、シリアル回線と仮想リンクでは大きくする必要があります。

送信遅延の値には、インターフェイスの送信遅延と伝搬遅延を考慮する必要があります。

IPv6 の OSPF で仮想リンクを設定するには、アドレスではなくルータ ID を使用する必要があります。IPv6 の OSPF では、仮想リンクはリモート ルータの IPv6 プレフィクスではなくルータ ID を使用します。

ネイバからの OSPF パケット上の TTL 値のチェックをイネーブルにするか、ネイバに送信される TTL 値を設定するには、 ttl-security hops hop-count の各キーワードと引数を使用します。この機能により、OSPF にさらなる保護レイヤが追加されます。


) 仮想リンクを正しく設定するには、各仮想リンク ネイバにトランジット エリア ID と対応する仮想リンク ネイバ ルータ ID が設定されている必要があります。ルータ ID を表示するには、特権 EXEC モードで show ip ospf コマンドまたは show ipv6 ospf コマンドを使用します。



) 指定したエリアをソフトウェア コンフィギュレーションから削除するには、no area area-id コマンドを使用します(他のキーワードは指定しません)。つまり、no area area-id コマンドを実行すると、area default-costarea nssaarea rangearea stubarea virtual-link などのすべてのエリア オプションが削除されます。


Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで area virtual-link コマンドを実行する必要があります。

次に、すべてのオプション パラメータでデフォルト値を使用して、仮想リンクを確立する例を示します。

ipv6 router ospf 1
log-adjacency-changes
area 1 virtual-link 192.168.255.1
 

次に、IPv6 の OSPF で仮想リンクを確立する例を示します。

ipv6 router ospf 1
log-adjacency-changes
area 1 virtual-link 192.168.255.1 hello-interval 5
 

 
関連コマンド

コマンド
説明

ttl-security hops

ネイバからの OSPF パケット上の TTL 値のチェックか、ネイバに送信される TTL 値の設定をイネーブルにします。

show ip ospf

Open Shortest Path First(OSPF)ルーティング プロセスに関する全般的な情報の表示をイネーブルにします。

show ipv6 ospf

Open Shortest Path First(OSPF)ルーティング プロセスに関する全般的な情報の表示をイネーブルにします。

auto-cost

Open Shortest Path First(OSPF)でインターフェイスのデフォルト メトリックを計算する方法を制御するには、ルータ コンフィギュレーション モードで auto-cost コマンドを使用します。インターフェイス タイプだけに基づいてコストを割り当てるには、このコマンドの no 形式を使用します。

auto-cost reference-bandwidth mbps

no auto-cost reference-bandwidth

 
シンタックスの説明

reference-bandwidth mbps

Mbps 単位の速度(帯域幅)。範囲は 1 ~ 4294967 で、デフォルトは 100 です。

 
デフォルト

100 Mbps

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

11.2

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

Cisco IOS Release 10.3 およびそれ以降のリリースでは、デフォルトでインターフェイスの帯域幅に従ってインターフェイスの OSPF メトリックが計算されます。たとえば、64K リンクのメトリックは 1562 となり、T1 リンクのメトリックは 64 となります。

OSPF メトリックは、 ref-bw の値を bandwidth で割ることで計算されます。 mbps はデフォルトで 108 に等しく、 bandwidth bandwidth (interface) コマンドで決定されます。この計算により FDDI のメトリックは 1 となります。

帯域幅が大きいリンク(FDDI や ATM など)が複数ある場合、これらのリンクのコストに差をつけるには、より大きい数値を使用する必要があります。

ip ospf cost コマンドで設定した値は、 auto-cost コマンドの結果得られたコストよりも優先されます。

次に、FDDI リンクのコストを 10 に変更し、ギガビット イーサネット リンクのコストを 1 のままにする例を示します。これにより、リンク コストに差がつきます。

router ospf 1
auto-cost reference-bandwidth 1000

 
関連コマンド

コマンド
説明

ip ospf cost

インターフェイス上でパケットを送信する際のコストを明示的に指定します。

capability lls

送信される Open Shortest Path First(OSPF)パケットの Link-Local Signalling(LLS)データ ブロックの使用をイネーブルにし、OSPF NonStop Forwarding(NSF; ノンストップ フォワーディング)認識を再度イネーブルにするには、ルータ コンフィギュレーション モードで capability lls コマンドを使用します。LLS と OSPF NSF 認識をディセーブルにするには、このコマンドの no 形式を使用します。

capability lls

no capability lls

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

LLS はイネーブルです。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(15)T

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(31)SXH に統合されました。

 
使用上のガイドライン

送信される OSPF パケットの LLS データ ブロックの使用をディセーブルにすることで、NSF 認識をディセーブルにすることが必要な場合があります。また、LLS を使用するアプリケーションがルータで動作していない場合に、NSF 認識をディセーブルにすることが必要な場合があります。

NSF が設定されている状態で LLS をディセーブルにしようとすると、「OSPF Non-Stop Forwarding (NSF) must be disabled first」というエラー メッセージが表示されます。

LLS がディセーブルになっている状態で、NSF を設定しようとすると、「OSPF Link-Local Signaling (LLS) capability must be enabled first」というエラー メッセージが表示されます。

次に、LLS のサポートと OSPF NSF 認識をディセーブルにする例を示します。

router ospf 2
no capability lls

 

capability transit

Open Shortest Path First(OSPF)エリア機能トランジットをいったんディセーブルにした後、再度イネーブルにするには、ルータ コンフィギュレーション モードで capability transit コマンドを使用します。OSPF エリア機能トランジットをルータ プロセスのすべてのエリアでディセーブルにするには、このコマンドの no 形式を使用します。

capability transit

no capability transit

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

OSPF エリア機能トランジットはイネーブルです。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(27)S

このコマンドが追加されました。

12.3(7)T

このコマンドが、Cisco IOS Release 12.3(7)T に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

OSPF エリア機能トランジットはデフォルトでイネーブルになっており、OSPF エリア境界ルータは、仮想リンクではなくトランジット エリアを経由するバックボーン エリアへのよりコストの小さいルートをインストールできます。仮想リンク パスを経由するトラフィック パターンを保持する必要がある場合は、 no capability transit コマンドを使用して、機能トランジットをディセーブルにできます。トランジット エリアを経由するパスが見つかった場合、仮想リンク パスよりも最適なパスであることが多く、少なくともそれと同等のパスになります。機能トランジットを再度イネーブルにするには、 capability transit コマンドを使用します。

特定のルーティング プロセスで OSPF エリア機能トランジットがイネーブルになっているかどうかを確認するには、 show ip ospf コマンドを使用します。

次に、ospf 1 という名前のルータ プロセスに対し、すべてのエリアで OSPF エリア機能トランジットをディセーブルにする例を示します。まず、現在エリア機能トランジットがイネーブルになっているエリアを表示するために、 show ip ospf コマンドを実行します。次に、 no capability transit コマンドを実行して、ルータ プロセス ospf 1 に対し、すべてのエリアで OSPF エリア機能トランジットをディセーブルにします。

Router# show ip ospf
 
Routing Process "ospf 1" with ID 10.1.1.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
!Supports area transit capability
It is an area border router
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 8. Checksum Sum 0x02853F
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
!Number of areas transit capable is 1
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 3
Area has no authentication
SPF algorithm last executed 00:02:21.524 ago
SPF algorithm executed 11 times
Area ranges are
Number of LSA 49. Checksum Sum 0x19B5FA
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 38
Flood list length 0
Area 1
Number of interfaces in this area is 3
!This area has transit capability: Virtual Link Endpoint
Area has no authentication
SPF algorithm last executed 00:02:36.544 ago
SPF algorithm executed 9 times
Area ranges are
Number of LSA 42. Checksum Sum 0x1756D5
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 
Router(config)# router ospf 1

Router(router-config)# no capability transit

 
関連コマンド

コマンド
説明

show ip ospf

OSPF ルーティング プロセスに関する一般情報を表示します。

capability vrf-lite

Open Shortest Path First(OSPF)プロセスが VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスに関連付けられている場合に、ルータでプロバイダー エッジ(PE)固有のチェックを抑止するには、ルータ コンフィギュレーション モードで capability vrf-lite コマンドを使用します。チェックを有効にするには、このコマンドの no 形式を使用します。

capability vrf-lite

no capability vrf-lite

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

ディセーブルです。PE 固有のチェックは、プロセスが VRF コマンド モードに関連付けられている場合に実行されます。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(21)ST

このコマンドが追加されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(8)B

このコマンドが、Cisco IOS Release 12.2(8)B に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、OSPF プロセスが VRF に関連付けられている場合にだけ機能します。

OSPF プロセスが VRF に関連付けられている場合、リンクステート アドバタイズメント(LSA)を受信すると、いくつかのチェックが実行されます。PE のチェックは、PE が、OSPF インターフェイスとボーダー ゲートウェイ プロトコル(BGP)インターフェイスの間で相互再配布を行っている場合に、ループを防ぐために必要です。

表 8 に、タイプ 3、タイプ 5、およびタイプ 7 LSA を受信した場合に実行される PE チェックを示します。

 

表 8 実行される PE チェック

タイプ 3 LSA を受信した場合

DN ビットがチェックされます。DN ビットがオンの場合、タイプ 3 LSA は、Shortest Path First(SPF)の計算で考慮されません。

タイプ 5 またはタイプ 7 LSA を受信した場合

LSA のタグが VPN タグと等しい場合、タイプ 5 またはタイプ 7 LSA は SPF の計算で考慮されません。

状況によっては、PE チェックの実行が望ましくない場合があります。VRF の概念は、PE ルータでない(つまり BGP を実行していない)ルータで使用できます。 capability vrf-lite コマンドを使用すると、チェックをオフにして、VRF ルーティング テーブルに IP プレフィクスへのルートを正しく設定できます。

次に、マルチ VRF を使用して設定したルータの例を示します。

router ospf 100 vrf grc
capability vrf-lite

 

clear ip ospf

Open Shortest Path First(OSPF)ルーティング プロセス ID に基づ再配布をクリアするには、特権 EXEC モードで clear ip ospf コマンドを使用します。

clear ip ospf [ pid ] { process | redistribution | counters [ neighbor [ neighbor-interface ] [ neighbor-id ]]}

 
シンタックスの説明

pid

(任意)プロセス ID。

process

OSPF プロセスをリセットします。

redistribution

OSPF ルート再配布をクリアします。

counters

OSPF カウンタ。

neighbor

(任意)インターフェイスごとのネイバ統計情報。

neighbor-interface

(任意)ネイバ インターフェイス。

neighbor-id

(任意)ネイバ ID。

 
コマンド モード

特権 EXEC

 
コマンドの履歴

リリース
変更内容

11.1

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

1 つの OSPF プロセスだけをクリアするには、引数 pid を使用します。引数 pid を指定しないと、すべての OSPF プロセスがクリアされます。

Cisco IOS Release 12.2(33)SXH よりも前のリリースでは、clear ip ospf process コマンドを実行すると、ローカル アドレスが使用できなくなっている場合でも、デフォルト ルータ ID は同じままになります。Cisco IOS Release 12.2(33)SXH では、clear ip ospf process コマンドを実行すると、現在使用中のルータ ID がローカル アドレスとしてまだ使用できるかどうかをチェックするように OSPF の動作が変更されました。ルータ ID がローカル アドレスとして使用できない場合、再選択が実行され、そのルータ ID が変更されます。

次に、すべての OSPF プロセスをクリアする例を示します。

Router# clear ip ospf process

 

clear ip ospf traffic

Open Shortest Path First(OSPF)トラフィック統計情報をクリアするには、ユーザ EXEC モードまたは特権 EXEC モードで clear ip ospf traffic コマンドを使用します。

clear ip ospf [ process-id ] traffic [ interface-type interface-number ]

 
シンタックスの説明

process-id

(任意)プロセス ID。引数 process-id を指定すると、指定したルーティング プロセスのトラフィック統計情報だけがクリアされます。

interface-type

(任意)インターフェイス タイプ。

interface-number

(任意)インターフェイス番号。

 
コマンド モード

ユーザ EXEC
特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.3(11)T

このコマンドが追加されました。

12.0(28)S

このコマンドが、Cisco IOS Release 12.0(28)S に統合されました。

次に、OSPF プロセス 100 の OSPF トラフィック統計情報をクリアする例を示します。

Router# clear ip ospf 100 traffic

 
関連コマンド

コマンド
説明

show ip ospf traffic statistics

OSPF トラフィック統計情報を表示します。

clear ipv6 ospf traffic

カウンタをリセットし IPv6 OSPFv3 トラフィック統計情報クリアするには、特権 EXEC モードで clear ipv6 ospf traffic コマンドを使用します。

clear ipv6 ospf traffic

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンド モード

特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.4(6)T

このコマンドが追加されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

次に、カウンタをリセットし、OSPFv3 トラフィック統計情報をクリアする例を示します。

Router# clear ipv6 ospf traffic

 
関連コマンド

コマンド
説明

clear ip ospf traffic

OSPFv2 トラフィック統計情報をクリアします。

show ip ospf traffic

OSPFv2 トラフィック統計情報を表示します。

show ipv6 ospf traffic

OSPFv3 トラフィック統計情報を表示します。

compatible rfc1583

RFC 1583 に従ったサマリー ルートのコストの計算方法に戻すには、ルータ コンフィギュレーション モードで compatible rfc1583 コマンドを使用します。RFC 1583 との互換性をディセーブルにするには、このコマンドの no 形式を使用します。

compatible rfc1583

no compatible rfc1583

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

RFC 1583 と互換性があります。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.1(2)T

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、Cisco IOS Release 12.0 と下位互換性があります。

ルーティング ループが発生する可能性を最小にするため、Open Shortest Path First(OSPF)ルーティング ドメイン内のすべての OSPF ルータで、RFC の互換性を同じ値に設定する必要があります。

RFC 2328(OSPF バージョン 2)の採用により、サマリー ルートのコストを計算するために使用する方法が変更されました。RFC 2328 に従った計算方法をイネーブルにするには no compatible rfc1583 コマンドを使用します。

次に、ルータ プロセスを RFC 1583 互換に指定する例を示します。

router ospf 1
compatible rfc1583
!

 

default-information originate (OSPF)

デフォルト外部ルートを Open Shortest Path First(OSPF)ルーティング ドメイン内に生成するには、ルータ コンフィギュレーション モードまたはルータ アドレス ファミリ トポロジ コンフィギュレーション モードで default-information originate コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

default-information originate [ always ] [ metric metric-value ] [ metric-type type-value ] [ route-map map-name ]

no default-information originate [ always ] [ metric metric-value ] [ metric-type type-value ] [ route-map map-name ]

 
シンタックスの説明

always

(任意)ソフトウェアにデフォルト ルートが存在するかどうかにかかわらず、常にデフォルト ルートをアドバタイズします。

には次の例外が含まれます。ルート マップを使用する場合、OSPF によるデフォルト ルートの送信は、ルーティング テーブル内にデフォルト ルートが存在するかどうかによって制限されません。

metric metric-value

(任意)デフォルト ルートを生成するために使用するメトリック。値を省略し、 default-metric ルータ コンフィギュレーション コマンドを使用して値を指定しない場合、デフォルトのメトリック値は 10 になります。使用される値はプロトコル固有です。

metric-type type-value

(任意)OSPF ルーティング ドメインにアドバタイズされる、デフォルト ルートに関連付けられた外部リンク タイプ 次のいずれかの値を指定できます。

タイプ 1 外部ルート

タイプ 2 外部ルート

デフォルトはタイプ 2 外部ルートです。

route-map map-name

(任意)ルーティング プロセスは、ルート マップが満たされている場合にデフォルト ルートを生成します。

 
コマンドのデフォルト

このコマンドは、デフォルトでディセーブルになっています。OSPF ルーティング ドメイン内にデフォルト外部ルートは生成されません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

redistribute または default-information ルータ コンフィギュレーション コマンドを使用して、OSPF ルーティング ドメインにルートを再配布する場合、Cisco IOS ソフトウェアは自動的に自律システム境界ルータ(ASBR)になります。ただし、ASBR は、デフォルトでは OSPF ルーティング ドメインにデフォルト ルートを生成しません。キーワード always を指定した場合を除き、ソフトウェアには、デフォルト ルートを生成する前に、自身のためにデフォルト ルートが設定されている必要があります。

ルート マップを使用する場合、OSPF によるデフォルト ルートの送信は、ルーティング テーブル内にデフォルト ルートが存在するかどうかによって制限されません。

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで default-information originate コマンドを実行する必要があります。

次に、OSPF ルーティング ドメインに再配布されるデフォルト ルートのメトリックを 100 に指定し、外部メトリック タイプをタイプ 1 に指定する例を示します。

router ospf 109
redistribute eigrp 108 metric 100 subnets
default-information originate metric 100 metric-type 1

 
関連コマンド

コマンド
説明

redistribute(IP)

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

default-metric

ルートのデフォルト メトリック値を設定します。

redistribute(IP)

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

default-metric (OSPF)

Open Shortest Path First(OSPF)ルーティング プロトコルのデフォルト メトリック値を設定するには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで use the default-metric コマンドを使用します。デフォルト状態に戻すには、このコマンドの no 形式を使用します。

default-metric metric-value

no default-metric metric-value

 
シンタックスの説明

metric-value

指定したルーティング プロトコルに適したデフォルト メトリック値。

 
デフォルト

各ルーティング プロトコルに適した、組み込みの自動的なメトリック変換。再配布される、接続されたルートとスタティック ルートのメトリックは、0 に設定されます。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

default-metric コマンドと redistribute ルータ コンフィギュレーション コマンドを組み合わせて使用すると、現在のルーティング プロトコルで、すべての再配布ルートで同じメトリック値が使用されます。デフォルト メトリックは、互換性のないメトリックを使用したルートの再配布という問題を解決するのに役立ちます。メトリックを変換しない場合、デフォルト メトリックの使用は妥当な代替手段で、再配布が可能となります。


default-metric コマンドをイネーブルにすると、再配布される接続されたルートにメトリック値 0 が適用されます。default-metric コマンドは、redistribute コマンドで適用されたメトリック値を上書きしません。


Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで default-metric コマンドを実行する必要があります。

次に、Routing Information Protocol(RIP)と OSPF ルーティング プロトコルの両方を使用した、Autonomous System(AS; 自律システム)109 内のルータの例を示します。この例では、OSPF から得たルートを RIP を使用してアドバタイズし、Internal Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)から得たルートに RIP メトリック 10 を割り当てます。

router rip
default-metric 10
redistribute ospf 109

 
関連コマンド

コマンド
説明

redistribute(IP)

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

discard-route

以前削除した外部廃棄ルートまたは内部廃棄ルートを再インストールするには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで discard -route コマンドを使用します。外部廃棄ルートまたは内部廃棄ルートを削除するには、このコマンドの no 形式を使用します。

discard-route [ external [ distance ]] [ internal [ distance ]]

no discard-route [ external [ distance ]] [ internal [ distance ]]

 
シンタックスの説明

external

(任意)自律システム境界ルータ(ASBR)上で再配布されるサマリー ルートの廃棄ルート エントリを指定します。

internal

(任意)エリア境界ルータ(ABR)上の集約された内部ルートの廃棄ルート エントリを指定します。

distance

(任意)管理ディスタンス。1 ~ 254 の範囲の値。外部および内部廃棄ルートのデフォルト管理ディスタンスは、それぞれ 254 および 110 です。

 
デフォルト

外部廃棄ルート エントリと内部廃棄ルート エントリがインストールされます。

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.1(1)T

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

12.4(15)T

引数 distance が追加されました。

 
使用上のガイドライン

外部廃棄ルート エントリおよび内部廃棄ルート エントリは、デフォルトでルーティング テーブルにインストールされます。ルート集約の際、集約に含まれていると思われる存在しないネットワークにデータが送信され、集約を実行しているルータのルーティング テーブルにこのネットワークの詳細でないルート(送信ルータに戻るルート)が含まれている場合、ルーティング ループが発生する可能性があります。ルーティング ループを防ぐために、廃棄ルート エントリが ABR または ASBR のルーティング テーブルにインストールされます。

何らかの理由で外部廃棄ルートまたは内部廃棄ルートを使用しない場合は、 no discard-route コマンドでキーワード external またはキーワード internal を使用し、廃棄ルートを削除します。

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで discard-route コマンドを実行する必要があります。

Release 12.4(15)T

Cisco IOS Release 12.4(15)T よりも前のリリースでは、外部廃棄ルートおよび内部廃棄ルートは、デフォルトの OSPF エリア内管理ディスタンス 110 を使用してインストールされていました。 discard-route コマンドの引数 distance に新しい管理ディスタンスを入力することにより、廃棄エントリのこのデフォルトの管理ディスタンスを変更できるようになりました。

次に、デフォルトでインストールされる廃棄ルート機能を示します。外部または内部ルートが集約される場合、Null0 へのサマリー ルートが show ip route コマンドのルータ出力で表示されます。太字で示されたルータ出力行を参照してください。

Router# show ip route
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
172.16.0.0/24 is variably subnetted, 3 subnets, 2 masks
C 172.16.0.128/25 is directly connected, Loopback1
O 172.16.0.0/24 is a summary, 00:00:14, Null0
C 172.16.0.0/25 is directly connected, Loopback0
172.31.0.0/24 is variably subnetted, 3 subnets, 2 masks
C 172.31.0.128/25 is directly connected, Loopback3
O 172.31.0.0/24 is a summary, 00:00:02, Null0
C 172.31.0.0/25 is directly connected, Loopback2
C 192.168.0.0/24 is directly connected, Ethernet0/0
 
Router# show ip route ospf
 
172.16.0.0/24 is variably subnetted, 3 subnets, 2 masks
O 172.16.0.0/24 is a summary, 00:00:29, Null0
172.16.0.0/24 is variably subnetted, 3 subnets, 2 masks
O 172.16.0.0/24 is a summary, 00:00:17, Null0
 

no discard-route コマンドを internal キーワードとともに入力した場合、ルータ出力行で太字で示す次のルート変更に注意してください。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# router ospf 1
Router(config-router)# no discard-route internal
Router(config-router)# end
 
Router# show ip route ospf
 
172.31.0.0/24 is variably subnetted, 3 subnets, 2 masks
O 172.16.0.0/24 is a summary, 00:04:14, Null0
 

次に、 no discard-route コマンドをキーワード external を指定して入力して、外部廃棄ルート エントリを削除します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# router ospf 1
Router(config-router)# no discard-route external
Router(config-router)# end
 

show running-config コマンドによる次のルータ出力では、外部廃棄ルートと内部廃棄ルートがルータのルーティング テーブルから削除されたことを確認しています。太字で示されたルータ出力行を参照してください。

Router# show running-config
 
Building configuration...
 
Current configuration : 1114 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
.
.
.
router ospf 1
log-adjacency-changes
no discard-route external
no discard-route internal
area 1 range 172.16.0.0 255.255.255.0
summary-address 172.31.0.0 255.255.255.0
redistribute rip subnets
network 192.168.0.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.255 area 1
!

 
関連コマンド

コマンド
説明

show ip route

ルーティング テーブルの現在のステータスを表示します。

show running-config

現在の実行コンフィギュレーション ファイルの内容、特定のインターフェイスの設定、またはマップ クラス情報を表示します。

distance ospf

ルート タイプに基づく Open Shortest Path First(OSPF)ルートの管理ディスタンスを定義するには、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで distance ospf コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

distance ospf { external dist1 | inter-area dist2 | intra-area dist3 }

no distance ospf

 
シンタックスの説明

external dist1

(任意)再配布によって学習した、他のルーティング ドメインからのルートの距離を設定します。値の範囲は 1 ~ 255 です。デフォルト値は 110 です。

inter-area dist2

(任意)あるエリアから別のエリアへのすべてのルートの距離を設定します。値の範囲は 1 ~ 255 です。デフォルト値は 110 です。

intra-area dist3

(任意)あるエリア内のすべてのルートの距離を設定します。値の範囲は 1 ~ 255 です。デフォルト値は 110 です。

 
コマンドのデフォルト

dist1 :110

dist2 :110

dist3 :110

 
コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)
ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

11.1(14)

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

キーワードを少なくとも 1 つ指定する必要があります。

このコマンドは、 distance コマンドをアクセス リストとともに使用した場合と同じ機能を実行します。ただし、 distance ospf コマンドでは、アクセス リストに一致する特定のルートではなく、ルート グループ全体の距離を設定できます。

distance ospf コマンドを使用する一般的な理由は、相互に再配布する複数の OSPF プロセスがあり、あるプロセスからの内部ルートを、他のプロセスからの外部ルートよりも優先させる場合です。

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を使用する予定の場合は、この OSPF ルータ コンフィギュレーション コマンドをトポロジ対応にするために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで distance ospf コマンドを実行する必要があります。

次に、外部距離を 200 に変更し、ルートをより信頼できないものとして指定する例を示します。

ルータ A の設定

router ospf 1
redistribute ospf 2 subnet
distance ospf external 200
!
router ospf 2
redistribute ospf 1 subnet
distance ospf external 200

ルータ B の設定

router ospf 1
redistribute ospf 2 subnet
distance ospf external 200
!
router ospf 2
redistribute ospf 1 subnet
distance ospf external 200

 
関連コマンド

コマンド
説明

distance (IP)

管理ディスタンスを定義します。

domain-id (OSPF)

BGP VPNv4 ルートの OSPF への再配布時に使用する OSPF ドメイン ID を変更するには、ルータ コンフィギュレーション モードで domain-id コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

domain-id { ip-address [ secondary ] | null | type type-value value hex-value [ secondary ]}

no domain-id [ ip-address [ secondary ] | null | type type-value value hex-value [ secondary ]]

 
シンタックスの説明

ip-address

IP アドレス形式の OSPF ドメイン ID。

secondary

(任意)IP アドレス形式のセカンダリ ドメイン ID を指定します。

null

ドメイン ID はプロセスに関連付けられません。

type type-value

16 進形式の OSPF ドメイン ID タイプ。

value hex-value

16 進形式の OSPF ドメイン ID の値。

secondary

(任意)16 進形式のセカンダリ ドメイン ID タイプを指定します。

 
コマンドのデフォルト

domain-id コマンドのデフォルト値は、OSPF プロセス ID と同じです。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.3(2)

このコマンドが追加されました。

 
使用上のガイドライン

ドメイン ID は、プレフィクスの OSPF ドメインを示す 8 バイトの値です。OSPF ルートが BGP VPNv4 ルートに MPLS VPN コンテキストで再配布される場合、ドメイン ID の拡張コミュニティが BGP アップデートに添付されます。ドメイン ID は、BGP VPNv4 ルートの再配布の結果、どのタイプのリンクステート アドバタイズメント(LSA)を生成するかを決定するため、BGP VPNv4 ルートが OSPF に再配布される場合に、出力プロバイダー エッジ(PE)ルータで使用されます。

次に、 domain-id コマンドを使用して OSPF ドメイン ID を変更する例を示します。ここで、プライマリ ドメイン ID は有効な IP アドレスで、セカンダリ ドメイン ID は有効な 16 進数値です。

Router(config)# router ospf 100 vrf abcd
Router(config-router)# domain-id 10.2.3.4
Router(config-router)# domain-id type 0005 value CAFECAFECAFE secondary

domain-tag

プロバイダー エッジ(PE)ルータとカスタマー エッジ(CE)ルータの間のプロトコルとして OSPF を使用する場合に、タイプ 5 またはタイプ 7 リンクステート アドバタイズメント(LSA)の Open Shortest Path First(OSPF)ドメインタグ値を設定するには、ルータ コンフィギュレーション モードで domain-tag コマンドを使用します。デフォルトのタグ値に戻すには、このコマンドの no 形式を使用します。

domain-tag tag-value

no domain-tag tag-value

 
シンタックスの説明

tag-value

タグ値。32 ビット値を 16 進形式で入力します。デフォルト値は、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)バーチャル プライベート ネットワーク(VPN)バックボーンのボーダー ゲートウェイ プロトコル(BGP)自律システム番号に基づいて計算されます。上位 4 ビットは、RFC 1745 に従って 1101 に設定されます。下位 16 ビットには、MPLS VPN バックボーンの BGP 自律システム(AS)番号がマッピングされます。ユーザが tag-value を指定した場合、値は特定の形式に従う必要はありません。

 
デフォルト

デフォルト値は、MPLS VPN バックボーンの BGP 自律システム番号に基づいて計算されます。上位 4 ビットは、RFC 1745 に従って 1101 に設定されます。下位 16 ビットには、MPLS VPN バックボーンの BGP 自律システム番号がマッピングされます。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.1(7)

このコマンドが追加されました。

12.1(7)E

このコマンドが、Cisco IOS Release 12.1(7)E に統合されました。

12.1(7)EC

このコマンドが、Cisco IOS Release 12.1(7)EC に統合されました。

12.0(17)ST

このコマンドが、Cisco IOS Release 12.0(17)ST に統合されました。

12.2(2)B

このコマンドが、Cisco IOS Release 12.2(4)B に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

OSPF を PE ルータと CE ルータの間で使用する場合、MPLS バックボーンから受信した BGP ルートが OSPF に再配布されます。これらの再配布ルートは、タイプ 3、タイプ 5、タイプ 7 LSA のいずれかでアナウンスされます。BGP ルートの再配布がタイプ 5 またはタイプ 7 LSA になる場合、外部ルート タグはタグの値に設定されます。別の PE ルータが、設定されたタグ値と等しい外部ルート タグを持つタイプ 5 またはタイプ 7 LSA を受信した場合、その LSA は無視されます。これにより、MPLS バックボーンから送信され再配布されるルートが、MPLS バックボーンの別の場所を通じて戻らないようになっています。

次に、タグ値 777 を設定する例を示します。

Router(config)# router ospf 10 vrf grc
Router(config-router)# domain-tag 777
 

show ip ospf database コマンドは、タグ値 777 が外部ルート タグに適用されたことを確認するために使用しています。

Router# show ospf database external 192.168.50.1
 
OSPF Router with ID (192.168.239.66) (Process ID 10)
 
Type-5 AS External Link States
 
LS age: 18
Options: (No TOS-capability, DC)
S Type: AS External Link
Link State ID: 192.168.238.1 (External Network Number)
Advertising Router: 192.168.239.66
LS Seq Number: 80000002
Checksum: 0xDAB0
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
TOS: 0
Metric: 1
Forward Address: 0.0.0.0
External Route Tag: 777
.
.
.
OSPF Router with ID (198.168.237.56) (Process ID 1)

 
関連コマンド

コマンド
説明

show ospf database

特定のルータの OSPF データベースに関する情報のリストが表示されます。

ignore lsa mospf

ルータが、サポートされていないリンクステート アドバタイズメント(LSA)タイプ 6 Multicast OSPF(MOSPF)パケットを受信したときに syslog メッセージの送信を抑止するには、ルータ コンフィギュレーション モードで ignore lsa mospf コマンドを使用します。syslog メッセージの送信を元に戻すには、このコマンドの no 形式を使用します。

ignore lsa mospf

no ignore lsa mospf

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。MOSPF パケットを受信するたびに、ルータは syslog メッセージを送信します。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

11.1

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

シスコのルータでは LSA タイプ 6 MOSPF パケットがサポートされておらず、そのようなパケットを受信すると syslog メッセージが生成されます。ルータが多数の MOSPF パケットを受信している場合、パケットを無視するようにルータを設定して、大量の syslog メッセージが生成されないようにすることが必要な場合があります。

次に、ルータが MOSPF パケットを受信したときに syslog メッセージの送信を抑止する例を示します。

router ospf 109
ignore lsa mospf

 

interface-id snmp-if-index

Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)MIB-II ifIndex(インターフェイス インデックス)ID 番号を使用して Open Shortest Path First(OSPF)インターフェイスを設定するには、ルータ コンフィギュレーション モードで interface-id snmp-if-index コマンドを使用します。元のインターフェイス番号付けに戻すには、このコマンドの no 形式を使用します。

interface-id snmp-if-index

no interface-id snmp-if-index

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

インターフェイスの SNMP MIB-II ifIndex による番号付けはディセーブルです。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.4(6)T

このコマンドが追加されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

 
使用上のガイドライン

SNMP MIB-II ifIndex 番号を使用して OSPF インターフェイスを識別する利点は、ifIndex 番号が、簡易ネットワーク管理プロトコル(SNMP)で報告された、ユーザに見える番号に対応している点です。SNMP MIB-II ifIndex の使用は、OSPFv2 に対しては RFC 2328 で、OSPFv3 に対しては RFC 2740 で推奨されています(必須ではありません)。

SNMP MIB-II ifIndex 番号を使用する場合、OSPF がイネーブルになっているすべてのインターフェイスに SNMP ifIndex 番号を割り当てます。そうしないと、それらのインターフェイスで OSPF がイネーブルになりません。


) ユーザは、アップグレードの前後や、Cisco IOS Release 12.4(6)T およびそれ以降のリリースで提供されている機能を備えていないルータ間で一貫した動作を維持するために、SNMP MIB-II ifIndex 番号を設定しないことを選択する場合があります。


次に、SNMP MIB-II ifIndex ID 番号を使用するように OSPF インターフェイスを設定する例を示します。 show snmp mib ifmib ifindex コマンドの出力で設定を確認します。

Router> enable
Router# configure terminal
Router(config)# router ospf 1
Router(config-router)# interface-id snmp-if-index
Router(config-router)# end
Router# show snmp mib ifmib ifindex serial13/0
 
Serial13/0: Ifindex = 53
Router# show ip ospf 1 1 data router self
 
OSPF Router with ID (10.0.0.1) (Process ID 1)
 
Router Link States (Area 1)
 
LS age: 245
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 10.0.0.3
Advertising Router: 10.0.0.3
LS Seq Number: 80000006
Checksum: 0x739F
Length: 48
Area Border Router
Number of Links: 2
 
Link connected to: another Router (point-to-point)
(Link ID) Neighboring Router ID: 10.1.0.1
(Link Data) Router Interface address: 10.1.1.25
Number of TOS metrics: 0
TOS 0 Metrics: 64
 
Link connected to: a Stub Network
(Link ID) Network/subnet number: 192.168.0.11
(Link Data) Network Mask: 255.255.255.255
Number of TOS metrics: 0
TOS 0 Metrics: 1

 
関連コマンド

コマンド
説明

show snmp mib ifmib ifindex

すべてのシステム インターフェイスまたは指定したシステム インターフェイスに対し、SNMP インターフェイス インデックス ID 番号(ifIndex 値)を表示します。

ip ospf area

インターフェイスで Open Shortest Path First version 2(OSPFv2)をイネーブルにするには、インターフェイス コンフィギュレーション モードで ip ospf area コマンドを使用します。インターフェイスで OSPFv2 をディセーブルにするには、このコマンドの no 形式を使用します。

ip ospf process-id area area-id [ secondaries none ]

no ip ospf process-id area [ secondaries none ]

 
シンタックスの説明

process-id

プロセス ID を示す 1 ~ 65535 の範囲の 10 進数値。

area-id

0 ~ 4294967295 の範囲の 10 進数値または IP アドレス。

secondaries none

(任意)インターフェイス上のセカンダリ IP アドレスがアドバタイズされないようにします。

 
コマンドのデフォルト

キーワード secondaries none をこのコマンドの no 形式で指定した場合、セカンダリ IP アドレスがアドバタイズされます。キーワード secondaries none を指定しない場合、OSPFv2 はディセーブルになります。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(29)S

このコマンドが追加されました。

12.3(11)T

このコマンドが、Cisco IOS Release 12.3(11)T に統合されました。

12.2(1)SB

このコマンドが、Cisco IOS Release 12.2(1)SB に統合されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

 
使用上のガイドライン

インターフェイスのネットワーク アドレスが、ルータ コンフィギュレーション モードで実行した network area コマンドで指定したアドレス範囲と一致する場合、そのインターフェイスで OSPF がイネーブルになります。OSPFv2 をインターフェイスで明示的にイネーブルにするには、インターフェイス コンフィギュレーション モードで ip ospf area コマンドを使用します。この機能により、番号が付いていないインターフェイスをさまざまなエリアで簡単に設定できるようになります。

インターフェイス コンフィギュレーション モードで ip ospf area コマンドを実実行すると network area コマンドの効果よりも優先されます。そのため、インターフェイス コンフィギュレーション モードで ip ospf area コマンドで設定したインターフェイスは、 network area コマンドの影響を受けません。


) 後で ip ospf area コマンドをディセーブルにしても、インターフェイスのネットワーク アドレスが、network area コマンドで指定したアドレス範囲に一致する限り、そのインターフェイスは OSPFv2 を実行し続けます。


次に、イーサネット インターフェイス 0/0/2 で OSPFv2 をイネーブルにし、セカンダリ IP アドレスがアドバタイズされないようにする例を示します。

Router(config)# interface Ethernet0/0/2
Router(config-if)# ip ospf 10 area 0 secondaries none

 
関連コマンド

コマンド
説明

interface

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

network area

OSPF を実行するインターフェイスを定義し、それらのインターフェイスに対するエリア ID を定義します。

show ip ospf interface

OSPF 関連のインターフェイス情報を表示します。

ip ospf authentication

インターフェイスの認証タイプを指定するには、インターフェイス コンフィギュレーション モードで ip ospf authentication コマンドを使用します。インターフェイスの認証タイプを削除するには、このコマンドの no 形式を使用します。

ip ospf authentication [ message-digest | null ]

no ip ospf authentication

 
シンタックスの説明

message-digest

(任意)メッセージ ダイジェスト認証を使用することを指定します。

null

(任意)認証を使用しません。エリアでパスワード認証またはメッセージ ダイジェスト認証が設定されている場合に、それを上書きするのに便利です。

 
デフォルト

エリアのデフォルトは認証なし(ヌル認証)です。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

ip ospf authentication コマンドを使用する前に、 ip ospf authentication-key コマンドを使用してインターフェイスのパスワードを設定します。 ip ospf authentication message-digest コマンドを使用する場合は、 ip ospf message-digest-key コマンドでインターフェイスのメッセージ ダイジェスト キーを設定します。

下位互換性のために、エリアに対する認証タイプも引き続きサポートされています。インターフェイスの認証タイプが指定されない場合、エリアの認証タイプが使用されます(エリアのデフォルトはヌル認証です)。

次に、メッセージ ダイジェスト認証をイネーブルにする例を示します。

ip ospf authentication message-digest

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証をイネーブルにします。

ip ospf authentication-key

OSPF の単純パスワード認証を使用しているネイバ ルータが使用するパスワードを割り当てます。

ip ospf message-digest-key

OSPF MD5 認証をイネーブルにします。

ip ospf authentication-key

Open Shortest Path First(OSPF)単純パスワード認証を使用しているネイバ ルータで使用するパスワードを割り当てるには、インターフェイス コンフィギュレーション モードで ip ospf authentication-key コマンドを使用します。以前割り当てた OSPF パスワードを削除するには、このコマンドの no 形式を使用します。

ip ospf authentication-key password

no ip ospf authentication-key

 
シンタックスの説明

password

キーボードから入力可能な最大 8 バイトの文字列。

 
デフォルト

パスワードは指定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドによって作成されたパスワードは、Cisco IOS ソフトウェアがルーティング プロトコル パケットを送信するときに、OSPF ヘッダーに直接挿入される「キー」として使用されます。各ネットワークに、インターフェイスごとに個別のパスワードを割り当てることができます。同じネットワーク上のネイバ ルータが OSPF 情報を交換するためには、同じパスワードが設定されている必要があります。


) Cisco IOS ソフトウェアは、area authentication ルータ コンフィギュレーション コマンドでエリアに対して認証がイネーブルになっている場合にだけこのキーを使用します。


次に、文字列 yourpass を使用して認証キーをイネーブルにする例を示します。

ip ospf authentication-key yourpass

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証をイネーブルにします。

ip ospf authentication

インターフェイスの認証タイプを指定します。

ip ospf bfd

Open Shortest Path First(OSPF)が設定された特定のインターフェイスで Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)をイネーブルにするには、インターフェイス コンフィギュレーション モードで ip ospf bfd コマンドを使用します。OSPF インターフェイスで BFD をディセーブルにするには、キーワード disable を使用します。 ip ospf bfd コマンドを削除するには、このコマンドの no 形式を使用します。

ip ospf bfd [ disable ]

no ip ospf bfd

 
シンタックスの説明

disable

(任意)指定したインターフェイスで OSPF の BFD をディセーブルにします。

 
デフォルト

キーワード disable を使用しなかった場合、デフォルトでは、インターフェイスで OSPF の BFD のサポートがイネーブルになります。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(18)SXE

このコマンドが追加されました。

12.0(31)S

このコマンドが、Cisco IOS Release 12.0(31)S に統合されました。

12.4(4)T

このコマンドが、Cisco IOS Release 12.4(4)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合されました。

 
使用上のガイドライン

障害検出のために BFD を使用する OSPF インターフェイスを設定するには、 ip ospf bfd コマンドを実行します。ルータ コンフィギュレーション モードで bfd-all interfaces コマンドを使用し、すべての OSPF インターフェイスで、OSPF プロセスで BFD を使用するようにグローバルに設定した場合は、インターフェイス コンフィギュレーション モードで ip ospf bfd コマンドをキーワード disable を指定して使用することで、特定の OSPF インターフェイスで BFD をディセーブルにできます。

次に、OSPF に関連付けられているファスト イーサネット インターフェイス 3/0 で BFD を設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# interface fastethernet 3/0
Router(config-if)# ip ospf bfd
Router(config-if)# end

 
関連コマンド

コマンド
説明

bfd all-interfaces

BFD ピアのすべてのインターフェイスで BFD をイネーブルにします。

ip ospf cost

インターフェイスでパケットを送信するコストを明示的に指定するには、インターフェイス コンフィギュレーション モードで ip ospf cost コマンドを使用します。パス コストをデフォルト値にリセットするには、このコマンドの no 形式を使用します。

ip ospf cost interface-cost

no ip ospf cost interface-cost

 
シンタックスの説明

interface-cost

リンクステート メトリックとして表現された符号なし整数値。値の範囲は 1 ~ 65535 です。

 
デフォルト

デフォルトのコストは定義されていません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

デフォルト値を変更する必要がある場合は、このコマンドを使用してメトリックを手動で設定できます。 bandwidth コマンドを使用すると、このコマンドを使用していない限り、リンク コストが変更されます。

リンクステート メトリックは、ルータ リンク アドバタイズメントでリンク コストとしてアドバタイズされます。Type of Service(ToS; サービス タイプ)はサポートされていないため、インターフェイスあたり 1 つのコストだけを割り当てることができます。

一般に、パス コストは次の式を使用して計算されます。

108 / 帯域幅

この式を使用して、次のリストに示すようにデフォルトのパス コストが計算されます。これらの値が使用しているネットワークに適していない場合は、独自のパス コストの計算方法を使用できます。

56-kbps シリアル リンク:デフォルトのコストは 1785

64-kbps シリアル リンク:デフォルトのコストは 1562

T1(1.544-Mbps シリアル リンク):デフォルトのコストは 64

E1(2.048-Mbps シリアル リンク):デフォルトのコストは 48

4-Mbps トークン リング:デフォルトのコストは 25

イーサネット:デフォルトのコストは 10

16-Mbps トークン リング:デフォルトのコストは 6

FDDI:デフォルトのコストは 1

X25:デフォルトのコストは 5208

非同期:デフォルトのコストは 10,000

ATM:デフォルトのコストは 1

次に、インターフェイスのコスト値を 65 に設定する例を示します。

ip ospf cost 65

 

ip ospf database-filter all out

Open Shortest Path First(OSPF)インターフェイスへの発信リンクステート アドバタイズメント(LSA)をフィルタするには、インターフェイス コンフィギュレーション モードで ip ospf database-filter all out コマンドを使用します。インターフェイスへの LSA のフォワーディングを元に戻すには、このコマンドの no 形式を使用します。

ip ospf database-filter all out

no ip ospf database-filter all out

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。すべての発信 LSA がインターフェイスにフラッディングされます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、 neighbor database-filter コマンドがネイバ ベースで実行する機能と同じ機能を実行します。

次に、イーサネット インターフェイス 0 経由で到達可能なブロードキャスト、非ブロードキャスト、ポイントツーポイント ネットワークに OSPF LSA がフラッディングされないようにする例を示します。

interface ethernet 0
ip ospf database-filter all out

 
関連コマンド

コマンド
説明

neighbor database-filter

OSPF ネイバへの発信 LSA をフィルタします。

ip ospf dead-interval

ネイバからどれだけの期間 1 つも hello パケットを受信しなかったらルータがそのネイバがダウンしていると見なすかを指定するには、インターフェイス コンフィギュレーション モードで ip ospf dead-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf dead-interval { seconds | minimal hello-multiplier multiplier }

no ip ospf dead-interval

 
シンタックスの説明

seconds

ルータがネイバからどれだけの期間(秒単位)1 つも hello パケットを受信しなかったら、そのネイバがピア リストから削除され、ルーティングに参加しなくなるかを指定します。値の範囲は 1 ~ 65535 です。この値は、ネットワーク上のすべてのノードで同じであることが必要です。

minimal

デッド インターバルを 1 秒に設定します。このキーワードを使用するには、キーワード hello-multiplier と引数 multiplier も設定する必要があります。

hello-multiplier multiplier

1 秒間に送信する hello パケットの個数を表す 3 ~ 20 の範囲の整数値。

 
デフォルト

seconds ip ospf hello-interval コマンドで設定した間隔の 4 倍になります。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(23)S

fast hello パケットの Open Shortest Path First(OSPF)サポートを追加するため、キーワード minimal 、キーワード hello-multiplier 、および引数 multiplier が追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

デッド インターバルは、OSPF hello パケットでアドバタイズされます。この値は、特定のネットワーク上のすべてのネットワーキング デバイスで同じであることが必要です。

小さいデッド インターバル( seconds )を指定すると、ネイバのダウンがより早く検出され、収束効率が高まりますが、ルーティングが不安定になる可能性があります。

fast hello パケットに対する OSPF のサポート

キーワード minimal とキーワード hello-multiplier を引数 multiplier とともに指定することで、OSPF fast hello パケットがイネーブルになります。キーワード minimal は、デッド インターバルを 1 秒に設定し、hello-multiplier の値は、その 1 秒間に送信される hello パケットの数を設定します。これにより、1 秒未満の「fast(高速な)」hello パケットの送信が可能になります。

インターフェイスで fast hello パケットが設定されている場合、このインターフェイスから送出される hello パケットでアドバタイズされる hello 間隔は 0 に設定されます。このインターフェイス経由で受信した hello パケットの hello 間隔は無視されます。

デッド インターバルは、1 つのセグメント上で一貫している必要があり、1 秒に設定するか(fast hello パケットの場合)、他の任意の値を設定します。デッド インターバル内に少なくとも 1 つの hello パケットが送信される限り、hello multiplier がセグメント全体で同じである必要はありません。

デッド インターバルと fast hello 間隔を確認するには、 show ip ospf interface コマンドを使用します。

次に、OSPF デッド インターバルを 20 秒に設定する例を示します。

interface ethernet 1
ip ospf dead-interval 20
 

次に、OSPF fast hello パケットを設定する例を示します。デッド インターバルは 1 秒に設定され、毎秒 5 個の hello パケットが送信されます。

interface ethernet 1
ip ospf dead-interval minimal hello-multiplier 5

 
関連コマンド

コマンド
説明

ip ospf hello-interval

Cisco IOS ソフトウェアがインターフェイス上で送信する hello パケットの間隔。

show ip ospf interface

OSPF 関連の情報を表示します。

ip ospf demand-circuit

インターフェイスを Open Shortest Path First(OSPF)デマンド回線として扱うように OSPF を設定するには、インターフェイス コンフィギュレーション モードで ip ospf demand-circuit コマンドを使用します。インターフェイスからデマンド回線の指定を削除するには、このコマンドの no 形式を使用します。

ip ospf demand-circuit

no ip ospf demand-circuit

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

回線はデマンド回線ではありません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

11.2

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

ポイントツーポイント インターフェイスでは、デマンド回線の 1 つの側だけをこのコマンドで設定する必要があります。定期的な hello メッセージが抑止され、リンクステート アドバタイズメント(LSA)の定期的な更新によってデマンド回線がフラッディングされません。このコマンドを使用すると、トポロジが安定している場合に、下位のデータリンク層を閉じることができます。ポイントツーマルチポイント トポロジでは、マルチポイント側だけをこのコマンドで設定する必要があります。

次に、ISDN オンデマンド回線を設定する例を示します。

router ospf 1
network 10.0.3.0 255.255.255.0 area 0
interface BRI0
ip ospf demand-circuit