Cisco IOS と NX-OS ソフトウェア : Cisco IOS ソフトウェア リリース 12.0 S

Cisco 12000 シリーズ Integrated Services Engine(ISE)ライン カードのマルチキャス ト出力 QoS サポート

Cisco 12000 シリーズ Integrated Services Engine(ISE)ライン カードのマルチキャスト出力 QoS サポート
発行日;2012/01/21 | 英語版ドキュメント(2009/08/18 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco 12000 シリーズ Integrated Services Engine(ISE)ライン カードのマルチキャスト出力 QoS サポート

マルチキャスト機能の概要

マルチキャスト出力 QoS 機能の概要

マルチキャスト出力 QoS の重み付けランダム早期検出

メリット

制約事項

関連機能とテクノロジー

関連資料

サポート対象のプラットフォーム

サポート対象の規格、MIB、および RFC

前提条件

設定タスク

マルチキャスト出力 QoS のイネーブル化

プライオリティ キューでのマルチキャスト出トラフィックのディセーブル化

マルチキャスト出力 QoS の確認、モニタ、およびトラブルシューティング

設定例

マルチキャスト出力 QoS のイネーブル化

OC-192 クロック スケジューラ カードのマルチキャスト パケットの優先順位付け

問題の説明

ソリューション

マルチキャスト プライオリティの設定

コマンド リファレンス

hw-module slot <n> ip multicast egress-qos enable

hw-module slot <n> ip multicast egress-qos no-priority-queue

show mcast-qos queue-info [if number]

show mcast-qos group-info [if number]

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

hw-module fabric multicast-priority

用語集

Cisco 12000 シリーズ Integrated Services Engine(ISE)ライン カードのマルチキャスト出力 QoS サポート

OL-8678-01-J(Rev.A0)

機能の履歴

リリース
変更点

12.0(32)S

Cisco 12000 シリーズ Integrated Services Engine(ISE)にこの機能が追加されました。

12.0(31.04)SY01、12.0(31)S06、12.0(31)s、12.0(32)S03、および 12.0(32.01)S12

新規コマンド hw-module fabric multicast-priority の追加に関するドキュメント不具合 ID CSCsr06355 およびエンジニアリング不具合 ID CSCsd83355 のため、この機能が追加されました。このコマンドは、特にマルチキャスト パケットにユニキャスト パケットより高いプライオリティを割り当てるときに使用します。マルチキャスト パケットのプライオリティをユニキャスト パケットより高く設定すると、マルチキャスト パケットのドロップを回避できます。このコマンドは、OC-192 タイプの Clock Scheduler Card(CSC; クロック スケジューラ カード)専用です。

このマニュアルの構成は、次のとおりです。

マルチキャスト機能の概要

マルチキャスト出力 QoS 機能の概要

サポート対象のプラットフォーム

サポート対象の規格、MIB、および RFC

前提条件

設定タスク

コマンド リファレンス

OC-192 クロック スケジューラ カードのマルチキャスト パケットの優先順位付け

コマンド リファレンス

マルチキャスト機能の概要

インターネットは、データ、音声、ビデオなどの形式で情報を送信するための重要な通信手段となっています。音声およびビデオの送信には遅延が許されません。音声またはビデオを多数の受信者に同時に配信することが、大きな課題となっています。複数の受信者への送信を含め、あらゆる形式のネットワーク通信にとって、マルチキャスト テクノロジーの帯域幅効率は非常に有効です。マルチキャスト機能には、マルチキャスト グループに対する情報の送信が含まれますが、これはグループ内のクライアント メンバの数とは無関係です。マルチキャスト テクノロジーの利点は帯域幅の消費が少ないことで、情報は受信者グループのすべてのメンバにほとんど同時に配信されます。ユニキャストの代わりにマルチキャストを使用して帯域幅を節約し、音声、ビデオなどのプライオリティの高いアプリケーションを遅延なく配信する必要があります。

マルチキャスト出力 QoS 機能の概要

マルチキャスト出力 QoS 機能には、マルチキャスト トラフィックのために次のような出力 QoS 機能が用意されています。

precedence/Differentiated Services Code Point(DSCP; DiffServ コード ポイント)に基づく分類

キュー選択

最大/最小帯域幅保証

残存帯域幅の検出

プライオリティ キューイング

キュー制限

ランダム早期検出(RED)

トラフィック シェーピング

ATM およびイーサネットのレイヤ 2 セット

マルチキャスト出力 QoS では、Modular QoS CLI(MQC)を使用して QoS 機能をイネーブルにします。Modular QoS CLI(MQC)は、シスコのプラットフォーム上で QoS を設定するためのプラットフォーム非依存のインターフェイスです。マルチキャスト出力 QoS では、次のタスクを実行するために Modular QoS CLI(MQC)を前提としています。

キューの選択

最小および最大の帯域幅保証の適用

残存帯域幅の検出

キュー制限の設定

トラフィック シェーピングの定義

キューに対する Weighted Random Early Detection(WRED; 重み付けランダム早期検出)の適用

マルチキャスト出力 QoS の重み付けランダム早期検出

マルチキャスト出力 QoS の重み付けランダム早期検出(WRED)は、すべての Integrated Services Engine(ISE)ラインカードでサポートされています。

ランダム早期検出(RED)を使用するポリシーマップ設定は、次の要件を満たす必要があります。

すべてのポリシーマップで同じクラスマップを使用する。

すべてのポリシーマップでクラスマップを同じ順序で設定する。

すべてのポリシーマップ全体でクラスマップに同じランダム早期検出(RED)文を設定する。ただし、ポリシーマップごとに最小しきい値および最大しきい値が異なっても構いません。

クラス内の複数の優先順位(DSCP)でランダム早期検出(RED)プロファイルを使用する場合、その優先順位はすべてのポリシーマップ内で同じランダム早期検出(RED)プロファイルを使用する必要があります。

ポリシーマップ設定要件は、出力ラインカード上の VPN ルーティング/転送インスタンス(VRF)のすべてのインターフェイス全体で満たされている必要があります。ラインカードで VPN ルーティング/転送インスタンス(VRF)が設定されていない場合は、出力ラインカード上のすべてのインターフェイス全体でこれらの要件が満たされている必要があります。

ポリシーマップ設定要件が満たされると、時間ベースの重み付けランダム早期検出(WRED)がサポートされます。

インターフェイスは、ポリシーマップがなくてもランダム早期検出(RED)機能を使用しないポリシーマップがあっても正常に機能します。

ポリシーマップ設定要件を満たさない VPN ルーティング/転送インスタンス(VRF)インターフェイス上のマルチキャスト トラフィックは、キュー制限を超過するとドロップされます。

重み付けランダム早期検出(WRED)を使用する階層ポリシーマップの場合、ポリシーマップ設定要件に従う必要があるのは子ポリシーだけです。

ポリシーマップ設定に従う例

次に、マルチキャスト出力 QoS の重み付けランダム早期検出(WRED)をイネーブルにする適切なポリシーマップの例を示します。この例で、インターフェイス A および B は同じ VPN ルーティング/転送インスタンス(VRF)に属し、同じクラスおよびランダム早期検出(RED)文を使用して設定されています。

優先順位 2 および 3 は、P1 と P2(これは要件)内の同じランダム早期検出(RED)プロファイルにマップされますが、最小および最大のランダム早期検出(RED)しきい値が異なります。インターフェイス C は別の VPN ルーティング/転送インスタンス(VRF)に属し、インターフェイス A および B とは異なる設定が行われます。

インターフェイス A:VRF 1

Router#config t
Router(config)#policy-map P1
Router(config-pmap)#class class123
Router(config-pmap-c)#bandwidth 10M
Router(config-pmap-c)#random-detect
Router(config-pmap-c)#random-detect precedence 1 50 100 1
Router(config-pmap-c)#random-detect precedence 2 150 300 1
Router(config-pmap-c)#random-detect precedence 3 150 300 1
Router(config-pmap)#class class45
Router(config-pmap-c)#bandwidth 20M
Router(config-pmap-c)#random-detect
Router(config-pmap-c)#random-detect precedence 4 70 130 1
Router(config-pmap-c)#random-detect precedence 5 180 400 1

インターフェイス B:VRF 1

Router#config t
Router(config)#policy-map P2
Router(config-pmap)#class class123
Router(config-pmap-c)#bandwidth 30M
Router(config-pmap-c)#random-detect
Router(config-pmap-c)#random-detect precedence 1 60 120 1
Router(config-pmap-c)#random-detect precedence 2 160 320 1
Router(config-pmap-c)#random-detect precedence 3 160 320 1
Router(config-pmap-c)#exit
Router(config-pmap)#class class45
Router(config-pmap-c)#bandwidth 10M
Router(config-pmap-c)#random-detect
Router(config-pmap-c)#random-detect precedence 4 90 180 1
Router(config-pmap-c)#random-detect precedence 5 180 250 1
Router(config-pmap-c)#exit

インターフェイス C:VRF 2

Router#config t
Router(config)#policy-map P3
Router(config-pmap)#class class234
Router(config-pmap-c)#bandwidth 3M
Router(config-pmap-c)#random-detect
Router(config-pmap-c)#random-detect precedence 2 40 200 1
Router(config-pmap-c)#random-detect precedence 3 50 400 1
Router(config-pmap-c)#exit
Router(config-pmap)#class class56
Router(config-pmap-c)#bandwidth 10M
Router(config-pmap-c)#random-detect
Router(config-pmap-c)#random-detect precedence 5 100 200 1
Router(config-pmap-c)#random-detect precedence 6 200 300 1
Router(config-pmap-c)#exit

適合していないポリシーマップ設定:例

次に、マルチキャスト出力 QoS の重み付けランダム早期検出(WRED)をイネーブルに しない ポリシーマップ設定の例を示します。インターフェイス A および B はテール ドロップされます。ポリシー p1 および p2 は、同じ VPN ルーティング/転送インスタンス(VRF)内の異なる 2 つのインターフェイスにアタッチされ、異なるクラスを使用して設定されます。

Router#config t
Router(config)#policy-map p1
Router(config-pmap)#class prec23
Router(config-pmap-c)#band 10M
Router(config-pmap-c)#random-detect 2 40 100 1
Router(config-pmap-c)#random-detect 3 60 200 1
Router(config-pmap-c)exit
Router(config-pmap)class prec45
Router(config-pmap-c)#band 20M
Router(config-pmap-c)#random-detect 4 30 200 1
Router(config-pmap-c)#random-detect 5 70 300 1
Router(config-pmap-c)exit
Router(config)#policy-map p2
Router(config-pmap)class prec 3
Router(config-pmap-c)#band 20M
Router(config-pmap-c)#random-detect 3 30 200 1
Router(config-pmap-c)exit

メリット

マルチキャスト出力 QoS は Cisco IOS ソフトウェア上で動作します。IP マルチキャストは、複数の受信者に単一ストリームの情報を同時配信することによってトラフィックを軽減し、帯域幅を節約するテクノロジーです。

Cisco 12000 シリーズ ルータの Integrated Services Engine(ISE)ラインカード上の マルチキャスト出力 QoS サポートには、キューを選択し、そのキューに次のような設定機能を適用する機能が用意されています。

最大および最小の帯域幅保証

残存帯域幅

キュー制限

トラフィック シェーピング

重み付けランダム早期検出(WRED)
ATM ラインカードに限り完全サポート
Packet over SONET(POS)、イーサネット、およびチャネライズド ラインカードでは一部サポート

ATM およびイーサネットのレイヤ 2 セット

制約事項

マルチキャスト出力 QoS では、Release 12.0(32)S の次の機能がサポートされていません。

discard-class ベースの Random Early Detection(RED; ランダム早期検出)はサポートされていません。重み付けランダム早期検出(WRED)は ATM ラインカードで完全サポートされています。POS、イーサネット、およびチャネライズド ラインカードでは制限付きでサポートされています。

DSCP/precedence 以外の分類はサポートされていません。

レイヤ 3 セットはサポートされていません。

遅いパスにパケットが送信される場合、QoS はアクティブではありません。すべてのパケットはデフォルト キューに入ります。

IPv6 マルチキャストはサポートされていません。

Cisco 12000 SIP-400 はサポートされていません。

トラフィックのポリシングはサポートされていません。このため、 hw-module slot 1 ip multicast egress-qos no-priority-queue コマンドを使用すると、トラフィックがプライオリティ キューに到達しなくなります。

関連機能とテクノロジー

Cisco 12000 シリーズ ルータ向けの Cisco IOS Quality of Service(QoS)。

関連資料

Cisco 12000 シリーズ ルータの設定の詳細については、次のマニュアルを参照してください。

Multicast Quick-Start Configuration Guide

Cisco 12000 Series Router Configuration Guide for Cisco IOS

『Cisco IOS Release 12.0S Features for Cisco 12000 Series Internet Router』

『Cisco IOS Quality of Service Solutions Configuration Guide』

『Cisco IOS Quality of Service Solutions Command Reference』

特定のルータのインストールおよび設定ガイド

サポート対象のプラットフォーム

マルチキャスト出力 QoS は、Cisco 12000 シリーズ Integrated Services Engine(ISE)ラインカードの Cisco IOS Release 12.0(32)S でサポートされています。含まれるラインカードは次のとおりです。

POS ラインカード

1 ポート OC48c/STM16c POS

1 ポート CHOC48/STM16>OC12/STM4>OC3/STM1>DS3/E3

4 ポート OC12c/STM16c POS

4 ポート CHOC12/STM4>OC3/STM1>DS3/E3

16 ポート OC3c/STM1c POS

4 ポート OC3c/STM1c POS

8 ポート OC3c/STM1c POS

イーサネット ラインカード

4 ポート ギガビット イーサネット ISE ラインカード

ATM ラインカード

4 ポート OC12/STM4 ATM LC

8 ポート OC3/STM1 ATM LC

4 ポート OC-3/STM-1 ATM LC

チャネライズド ラインカード

1 ポート OC12 DS1

サポート対象の規格、MIB、および RFC

マルチキャスト出力 QoS では、IP マルチキャスト MIB および次の MIB を使用します。

MIB

CISCO-CLASS-BASED-QOS-MIB

前提条件

マルチキャスト出力 QoS を設定できるのは、Cisco IP Multicast IOS 用に設定されているインターフェイスだけです。

設定タスク

マルチキャスト出力 QoS 機能の設定タスクについては、次の項を参照してください。

マルチキャスト出力 QoS のイネーブル化

プライオリティ キューでのマルチキャスト出トラフィックのディセーブル化

マルチキャスト出力 QoS の確認、モニタ、およびトラブルシューティング

マルチキャスト出力 QoS のイネーブル化

ISE ラインカード上で マルチキャスト出力 QoS 機能をイネーブルにするには、グローバル コンフィギュレーション モードで hw-module slot < n > ip multicast egress-qos enable コマンドを使用します。

 

コマンド
目的

ステップ 1

Router# config t

コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# hw-module slot 1 ip multicast egress-qos enable

マルチキャスト出力 QoS をイネーブルにします。

プライオリティ キューでのマルチキャスト出トラフィックのディセーブル化

マルチキャスト出トラフィックがプライオリティ キューに送信されないようにするには、グローバル コンフィギュレーション モードで hw-module slot < n > ip multicast egress-qos no-priority-queue コマンドを使用します。マルチキャスト出トラフィックがプライオリティ キューに送信されるようにするには、このコマンドの no 形式を使用します。

 

コマンド
目的

ステップ 1

Router# config t

コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# hw-module slot 1 ip multicast egress-qos no-priority-queue

マルチキャスト トラフィックがプライオリティ キューに送信されないようにします。

マルチキャスト出力 QoS の確認、モニタ、およびトラブルシューティング

マルチキャスト出力 QoS を確認、モニタ、およびトラブルシューティングするには、次の show コマンドを使用します。

 

コマンド
目的
Router# show running-config

ルータの現在の設定を表示します。このコマンドを使用して、マルチキャスト出力 QoS が実行されていることを確認します。

LC-Slot1# show mcast-qos queue-info

キュー情報を表示します。このコマンド使用して、キューの設定が正しいことを確認します。

LC-Slot1# show mcast-qos group-info

グループ情報を表示します。

LC-Slot1# show ip hardware-mdfs egress-qos conga

Multicast Group Identifier(MGID)番号を表示します。

LC-Slot1# show ip hardware-mdfs egress-qos wred-alpha

Random Early Detection Class of Service(REDCOS)ビットを表示します。

LC-Slot1# show ip hardware-mdfs egress-qos alpha

DSCP マッピング テーブルおよびローカル MGID/カウンティング情報を表示します。

Router# show policy interface <intf>

インターフェイスに設定されているポリシーを表示します。

設定例

ここでは、次の設定例について説明します。

「マルチキャスト出力 QoS のイネーブル化」

マルチキャスト出力 QoS のイネーブル化

この例は、マルチキャスト出力 QoS をイネーブルにする方法を示しています。

Router#config t
Router(config)#hostname Router 12000
Router(config)#
Router(config)#enable password cisco
Router(config)#
Router(config)#monitor event-trace rlc all enable
Router(config)#power-mgr additive
Router(config)#hw-module slot 0 ip multicast hw-accelerate source-table size 16 offset 0
Router(config)#hw-module slot 0 ip multicast raw-queue limit 2048
Router(config)#hw-module slot 0 ip multicast egress-qos enable
Router(config)#ip subnet-zero
Router(config)#ip cef table hardware resource-failure action punt
Router(config)#no ip domain-lookup
Router(config)#ip multicast-routing distributed
Router(config)#
Router(config)#class-map match-all prec1
Router(config-cmap)#match ip precedence 1
Router(config-cmap)#exit
Router(config)#class-map match-all prec2
Router(config-cmap)#match ip precedence 2
Router(config-cmap)#exit
Router(config)#
Router(config)#policy-map policy1
Router(config-pmap)#class prec1
Router(config-pmap-c)#bandwidth percent 20
Router(config-pmap-c)#random-detect
Router(config-pmap-c)#random-detect precedence 1 50 packets 100 packets 1
Router(config-pmap)#class prec2
Router(config-pmap-c)#bandwidth percent 10
Router(config-pmap-c)#exit
Router(config-pmap)#class class-default
Router(config-pmap-c)#queue-limit 300 ms
Router(config-pmap-c)#random-detect
Router(config-pmap-c)#random-detect precedence 3 200 packets 400 packets 1
Router(config-pmap-c)#exit
Router(config-pmap)#exit
Router(config)#
Router(config)#controller SYSCLOCK 0
Router(config-controller)#exit
Router(config)#controller T1 9/0
Router(config-controller)#exit
Router(config)#controller E1 9/1
Router(config-controller)#exit
Router(config)#
Router(config)#interface Loopback0
Router(config-if)#ip address 192.168.100.5 255.255.255.255
Router(config-if)#no ip directed-broadcast
Router(config-if)#ip pim sparse-dense-mode
Router(config-if)#exit
Router(config)#
Router(config)#interface POS0/0
Router(config-if)#description Connected to C12406_CH POS 1/0
Router(config-if)#ip address 40.0.0.1 255.255.255.252
Router(config-if)#no ip directed-broadcast
Router(config-if)#ip pim sparse-dense-mode
Router(config-if)#ip igmp static-group 224.1.1.1
Router(config-if)#crc 32
Router(config-if)#clock source internal
Router(config-if)#service-policy output policy1
Router(config-if)#exit
Router(config)#
Router(config)#interface POS0/1
Router(config-if)#description Connected to M8850_LA RPM-XF Slot 10 POS 1/0
Router(config-if)#ip address 60.0.0.2 255.255.255.252
Router(config-if)#no ip directed-broadcast
Router(config-if)#ip pim sparse-dense-mode
Router(config-if)#ip igmp static-group 224.1.1.1
Router(config-if)#crc 32
Router(config-if)#clock source internal
Router(config-if)#exit
Router(config)#
Router(config)#router ospf 1
Router(config-if)#log-adjacency-changes
Router(config-if)#network 40.0.0.0 0.0.0.255 area 0
Router(config-if)#network 60.0.0.0 0.0.0.255 area 0
Router(config-if)#network 192.168.100.5 0.0.0.0 area 0
Router(config-if)#ip classless
Router(config-if)#ip route 0.0.0.0 0.0.0.0 172.29.52.1
Router(config-if)#ip pim send-rp-announce Loopback0 scope 16
Router(config-if)#ip pim send-rp-discovery scope 16
Router(config-if)#exit
Router(config)#
Router(config)#slot-table-cos 1
Router(config-if)#exit
Router(config)#
Router(config)#control-plane
Router(config-cp)#exit
Router(config)#
Router(config)#line con 0
Router(config-line)#exec-timeout 0 0
Router(config-line)#exit
Router(config)#
Router(config)#line aux 0
Router(config-line)#exit
Router(config)#
Router(config)#line vty 0 4
Router(config-line)#exec-timeout 0 0
Router(config-line)#password cisco
Router(config-line)#login
Router(config-line)#exit
Router(config)#
Router(config)#exception warmstart 60 5
Router(config)#no cns aaa enable
Router(config)#exit
Router#

OC-192 クロック スケジューラ カードのマルチキャスト パケットの優先順位付け

ここでは、OC-192 CSC のマルチキャスト パケット ドロップが発生する理由、マルチキャスト パケット ドロップを防止する方法、その設定手順、および新しいコマンド hw-module fabric multicast-priority の使用方法について説明します。

問題の説明

ファブリックに送信されるトラフィックがユニキャストとマルチキャストの両方の場合、OC-192 タイプのクロック スケジューラ カード用の Cisco 12410 または 12416 ルータ シャーシではマルチキャスト パケットのドロップが発生します。パケット ドロップは、ユニキャスト パケットのプライオリティがマルチキャスト パケットのプライオリティ以上である場合に発生します。このようなドロップは、パケット ロスまたはジッタを把握していないビデオ トラフィックに影響を与える可能性があります。

ソリューション

SCA 192 スケジューラ上のスイッチ ファブリックを使用するユニットの場合、コマンド hw-module fabric multicast-priority を使用して、マルチキャストをユニキャストより高いプライオリティに設定する必要があります。また、マルチキャスト トラフィックを伝送するリンクは、オーバーサブスクライブしないようにする必要があります。マルチキャスト パケットのドロップを解決するには、コマンド「 hw-module fabric multicast-priority 」を設定するか、または OC-192 クロック スケジューラ カードを OC-768 タイプに置き換えます。

マルチキャスト プライオリティの設定

ユニキャスト パケットより高いマルチキャスト プライオリティを設定するには、グローバル コンフィギュレーション モードで hw-module fabric multicast-priority コマンドを使用します。このコマンドを実行する前に、コマンド show controllers sca を使用して、プライオリティがマルチキャストまたはユニキャストに設定されているかどうかを確認します。

コマンド
目的

ステップ 1

Router# show controllers sca

プライオリティがマルチキャストまたはユニキャストに設定されているかどうかを確認します。プライオリティがマルチキャストに設定されている場合は、コマンド出力に「Config 0x00 pri-mcast」と表示されます。プライオリティがユニキャストに設定されている場合は、コマンド出力に「Config 0xC0 unicast-accept-mode pri-alternating」と表示されます。

ステップ 2

Router# config t

コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# hw-module fabric multicast-priority

ユニキャスト パケットより高いプライオリティをマルチキャスト パケットに割り当てます。コマンドの使用方法の詳細については、「hw-module fabric multicast-priority」を参照してください。

コマンド リファレンス

ここでは、新規コマンドについて説明します。この機能で使用する他のすべてのコマンドは、Cisco IOS Release 12.0(32)S コマンド リファレンスに記載されています。

ここでは、次のコマンドの詳細について説明します。

hw-module slot <n> ip multicast egress-qos enable

hw-module slot <n> ip multicast egress-qos no-priority-queue

show mcast-qos queue-info [if number]

show mcast-qos group-info [if number]

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

hw-module fabric multicast-priority

hw-module slot <n> ip multicast egress-qos enable

ISE ラインカード上で マルチキャスト出力 QoS 機能をイネーブルにするには、グローバル コンフィギュレーション モードで hw-module slot < n > ip multicast egress-qos enable コマンドを使用します。

ISE ラインカード上で マルチキャスト出力 QoS 機能をディセーブルにするには、このコマンドの no 形式を使用します。

Cisco IOS

hw-module slot < n > ip multicast egress-qos enable

[no] hw-module slot < n > ip multicast egress-qos enable

 
シンタックスの説明

n

出力ラインカードのスロット番号を指定する変数。

ip

IP 固有の機能を指定するキーワード。

multicast

マルチキャスト設定機能を指定するキーワード。

egress-qos

マルチキャスト出力 QoS を指定するキーワード。

enable

マルチキャスト出力 QoS 機能をイネーブルにするキーワード。

 
デフォルト

マルチキャスト出力 QoS 機能のデフォルト状態はディセーブルです。

 
コマンドのデフォルト

[no] hw-module slot <n> ip multicast egress-qos enable

 
コマンド モード

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更点

12.0(32)S

このコマンドが導入されました。

 
使用上のガイドライン

マルチキャスト出力 QoS 機能がディセーブルの場合、すべてのマルチキャスト トラフィックはデフォルト キューで送信されます。

マルチキャスト パケットはポリシーマップ カウンタには含まれません。

この機能がイネーブルの場合は次のメッセージが表示されます。

Multicast traffic cannot be policed. Use "hw-module slot <slot> ip multicast egress-cos no-priority-queue" to disable multicast traffic from reaching the priority queue.

次に、スロット 1 で マルチキャスト出力 QoS 機能をイネーブルにする方法の例を示します。

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#hw-module slot 1 ip multicast egress-qos enable
Router(config)#

 
関連コマンド

コマンド
説明

hw-module slot <n> ip multicast egress-qos no-priority-queue

マルチキャスト トラフィックがプライオリティ キューに到達しないようにします。

show mcast-qos queue-info [if number]

マルチキャスト出力 QoS に設定したラインカード上のインターフェイスのデータベース キュー情報を表示します。

show mcast-qos group-info [if number]

nCmD/1CnD モデルを設定する場合、マルチキャスト出力 QoS に設定したラインカード上のインターフェイスに関する QoS データベース グループ情報を表示します。

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

グループ アドレスまたは特定の mroute のクラス セットに関連付けられたローカル MGID を表示します。

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

特定のローカル MGID に関連付けられたインターフェイスのリストを表示します。

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

実際の DSCP マッピング テーブルおよびそのローカル MGID/カウンティング情報を表示します。

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

すべての DSCP または特定の DSCP についての Random Early Detection Class of Service Bit(REDCOS ビット)を表示します。

hw-module slot <n> ip multicast egress-qos no-priority-queue

マルチキャスト出力 QoS トラフィックがプライオリティ キューに送信されないようにするには、グローバル コンフィギュレーション モードで hw-module slot < n > ip multicast egress-qos no-priority-queue コマンドを使用します。マルチキャスト出力 QoS トラフィックがプライオリティ キューに送信されるようにするには、このコマンドの no 形式を使用します。

Cisco IOS

hw-module slot < n > ip multicast egress-qos no-priority-queue

[no] hw-module slot < n > ip multicast egress-qos no-priority-queue

 
シンタックスの説明

n

出力ラインカードのスロット番号を指定する変数。

ip

IP 固有の機能を指定するキーワード。

multicast

マルチキャスト設定機能を指定するキーワード。

egress-qos

マルチキャスト出力 QoS を指定するキーワード。

no-priority-queue

マルチキャスト出力 QoS トラフィックがプライオリティ キューに送信されないことを指定するキーワード。

 
デフォルト

マルチキャスト出力 QoS はプライオリティ キューに送信されます。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更点

12.0(32)S

このコマンドが導入されました。

 
使用上のガイドライン

マルチキャスト出力 QoS トラフィックがプライオリティ キューに到達しないようにすると、このトラフィックはデフォルト キューに送信されます。

hw-module slot < n > ip multicast egress-qos no-priority-queue コマンドは、 hw-module slot <n> ip multicast egress-qos enable コマンドを使用して マルチキャスト出力 QoS 機能がイネーブルにされている場合にだけ使用できます。

次に、マルチキャスト出力 QoS トラフィックがスロット 1 のプライオリティ キューに送信されないようにする方法の例を示します。

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hw-module slot 1 ip multicast egress-qos no-priority-queue
Router(config)#

 
関連コマンド

コマンド
説明

hw-module slot <n> ip multicast egress-qos enable

ISE ラインカード上で マルチキャスト出力 QoS 機能をイネーブルにします。

show mcast-qos queue-info [if number]

マルチキャスト出力 QoS に設定したラインカード上のインターフェイスのデータベース キュー情報を表示します。

show mcast-qos group-info [if number]

nCmD/1CnD モデルを設定する場合、マルチキャスト出力 QoS に設定したラインカード上のインターフェイスに関する QoS データベース グループ情報を表示します。

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

グループ アドレスまたは特定の mroute のクラス セットに関連付けられたローカル MGID を表示します。

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

特定のローカル MGID に関連付けられたインターフェイスのリストを表示します。

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

DSCP マッピング テーブルおよびそのローカル MGID/カウンティング情報を表示します。

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

すべての DSCP または特定の DSCP についての Random Early Detection Class of Service Bit(REDCOS ビット)を表示します。

show mcast-qos queue-info [if number]

マルチキャスト出力 QoS に設定されたラインカード上のインターフェイスのデータベース キュー情報を表示するには、EXEC モードで show mcast-qos queue-info [ if number ] コマンドを使用します。

Cisco IOS

show mcast-qos queue-info [ if number ]

 
シンタックスの説明

mcast-qos

マルチキャスト QoS を指定するキーワード。

queue-info

データベースからのキュー情報を要求するキーワード。

if number

インターフェイス番号を指定する変数。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更点

12.0(32)S

このコマンドが導入されました。

 
使用上のガイドライン

トラブルシューティングには show mcast-qos queue-info [ if number ] コマンドを使用します。 show mcast-qos queue-info [ if number ] コマンドを実行すると、現在の マルチキャスト出力 QoS 設定およびその設定で認識されるクラスが表示されます。また、次の情報も表示されます。

キュー:キュー番号

レベル:階層ポリシーの場合

タイプ:出力キューまたは出力情報

セット:クラスに L2 セット コマンドが存在する場合

クラス:クラスマップの数

DSCP:このクラスに関連する DSCP 値

次に、インターフェイス番号 2/1 の QoS データベースから マルチキャスト出力 QoS キュー情報を取得する方法の例を示します。

LC-Slot1#
LC-Slot1#show mcast-qos queue-info 15
Interface GigabitEthernet2/1
----------------------------------------
Index Queue # level type Set Class DSCPs
1 Default 0 OUTPUT QUEUE 0 0 0-7, 24-63
2 5 0 OUTPUT QUEUE 0 7 8-15
3 6 0 OUTPUT QUEUE 0 8 16-23
 

 
関連コマンド

コマンド
説明

hw-module slot <n> ip multicast egress-qos enable

ISE ラインカード上で マルチキャスト出力 QoS 機能をイネーブルにします。

hw-module slot <n> ip multicast egress-qos no-priority-queue

マルチキャスト トラフィックがプライオリティ キューに到達しないようにします。

show mcast-qos group-info [if number]

nCmD/1CnD モデルを設定する場合、マルチキャスト出力 QoS に設定したラインカード上のインターフェイスに関する QoS データベース グループ情報を表示します。

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

グループ アドレスまたは特定の mroute のクラス セットに関連付けられたローカル MGID を表示します。

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

特定のローカル MGID に関連付けられたインターフェイスのリストを表示します。

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

実際の DSCP マッピング テーブルおよびそのローカル MGID/カウンティング情報を表示します。

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

すべての DSCP または特定の DSCP についての Random Early Detection Class of Service Bit(REDCOS ビット)を表示します。

show mcast-qos group-info [if number]

nCmD/1CnD モデルが設定されている場合、マルチキャスト出力 QoS に設定されたラインカード上のインターフェイスに関する QoS データベース グループ情報を表示するには、EXEC モードで show mcast-qos group-info [ if number ] コマンドを使用します。

Cisco IOS

show mcast-qos group-info [ if number ]

 
シンタックスの説明

mcast-qos

マルチキャスト QoS を指定するキーワード。

group-info

データベースからのグループ情報を要求するキーワード。

if number

インターフェイス番号を指定する変数。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更点

12.0(32)S

このコマンドが導入されました。

 
使用上のガイドライン

トラブルシューティングには show mcast-qos group-info [ if number ] コマンドを使用します。 show mcast-qos group-info [ if number ] コマンドを実行すると、現在の マルチキャスト出力 QoS 設定およびその設定で認識されるクラスが表示されます。また、次の項目も表示されます。

キュー:キュー番号

レベル:階層ポリシーの場合

タイプ:出力キューまたは出力情報

セット:クラスにレイヤ 2 セット コマンドが存在する場合

クラス:クラスマップの数

DSCP:このクラスに関連する DSCP 値

次の例で、VGL はサブインターフェイスです。

次に、インターフェイス番号 1 の QoS データベースから マルチキャスト出力 QoS グループ情報を取得する方法の例を示します。

LC-Slot1#
LC-Slot1#show mcast-qos group-info 15
Parent Policy-map for interface GigabitEthernet2/1
VGL: 1
Qeueue Queue # level type Set Class DSCPs
1 Default 1 OUTPUT QUEUE 0 0 0-7, 24-63
2 17 1 OUTPUT QUEUE 0 7 8-15
3 18 1 OUTPUT QUEUE 0 8 16-23
VGL: 10
Qeueue Queue # level type Set Class DSCPs
1 Default 1 OUTPUT QUEUE 0 0 0-7, 16-63
2 21 1 OUTPUT QUEUE 0 7 8-15
 

 
関連コマンド

コマンド
説明

hw-module slot <n> ip multicast egress-qos enable

ISE ラインカード上で マルチキャスト出力 QoS 機能をイネーブルにします。

hw-module slot <n> ip multicast egress-qos no-priority-queue

マルチキャスト トラフィックがプライオリティ キューに到達しないようにします。

show mcast-qos queue-info [if number]

マルチキャスト出力 QoS に設定したラインカード上のインターフェイスのデータベース キュー情報を表示します。

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

グループ アドレスまたは特定の mroute のクラス セットに関連付けられたローカル MGID を表示します。

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

特定のローカル MGID に関連付けられたインターフェイスのリストを表示します。

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

実際の DSCP マッピング テーブルおよびそのローカル MGID/カウンティング情報を表示します。

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

すべての DSCP または特定の DSCP についての Random Early Detection Class of Service Bit(REDCOS ビット)を表示します。

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

グループ アドレスまたは特定の mroute のクラス セットに関連付けられたローカル MGID を表示するには、EXEC モードで show ip hardware-mdfs egress-qos conga local-mgids コマンドを使用します。

Cisco IOS

show ip hardware-mdfs egress-qos conga local-mgids | < group addr > [< src addr >] | vrf < VRF name > < group addr > [< src addr >]

 
シンタックスの説明

local-mgids

すべてのローカル Multicast Group Identifier(MGID)を指定するキーワード。

group addr

マルチキャスト ストリームの送信先 IP アドレスを指定する変数。たとえば、224.1.1.1 などです。

src addr

マルチキャスト ストリームの送信元 IP アドレスを指定する変数。

vrf

VPN ルーティング/転送インスタンス(VRF) を指定するキーワード。

VRF name

VPN Routing/Forwarding Instance(VRF; VPN ルーティング/転送インスタンス)の名前を指定する変数。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更点

12.0(32)S

このコマンドが導入されました。

 
使用上のガイドライン

Multicast Identifier(MGID)は、マルチキャスト ストリームの複製先インターフェイスのデフォルト キューのリストを保持するマルチキャスト グループ識別番号(ID)です。

ローカル MGID は、ストリームの複製先であるさまざまなキュー(デフォルトまたはデフォルト以外)のリストを保持する ID です。各 MGID は DSCP 値に関連付けられています。

次に、グループ アドレス 224.1.1.1 および送信元アドレス 1.1.1.2 に関連付けられたローカル MGID の例を示します。

LC-Slot1#
LC-Slot1#show ip hardware-mdfs egress-qos conga local-mgids 224.1.1.1 1.1.1.2
The Local MGIDs are:
3FFFA
3FFFC
LC-Slot1#

 
関連コマンド

コマンド
説明

hw-module slot <n> ip multicast egress-qos enable

ISE ラインカード上で マルチキャスト出力 QoS 機能をイネーブルにします。

hw-module slot <n> ip multicast egress-qos no-priority-queue

マルチキャスト トラフィックがプライオリティ キューに到達しないようにします。

show mcast-qos queue-info [if number]

マルチキャスト出力 QoS に設定したラインカード上のインターフェイスのデータベース キュー情報を表示します。

show mcast-qos group-info [if number]

nCmD/1CnD モデルを設定する場合、マルチキャスト出力 QoS に設定したラインカード上のインターフェイスに関する QoS データベース グループ情報を表示します。

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

特定のローカル MGID に関連付けられたインターフェイスのリストを表示します。

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

実際の DSCP マッピング テーブルおよびそのローカル MGID/カウンティング情報を表示します。

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

すべての DSCP または特定の DSCP についての Random Early Detection Class of Service Bit(REDCOS ビット)を表示します。

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

特定のローカル MGID に関連付けられたインターフェイスのリストを表示するには、EXEC モードで show ip hardware-mdfs egress-qos conga hw-midbs コマンドを使用します。

Cisco IOS

show ip hardware-mdfs egress-qos conga hw-midbs | < Local MGID > | < Local MGID > vrf < VRF name > | all-mgids < group addr > [< src addr ] | vrf < VRF name > < group addr > [ < src addr >]

 
シンタックスの説明

hw-midbs

mroute に関連付けられたすべてのインターフェイスを指定するキーワード。

Local MGID

ローカル マルチキャスト グループ ID(MGID)を指定する変数。

all-mgids

すべてのマルチキャスト グループ ID(MGID)を指定するキーワード。

src addr

マルチキャスト ストリームの送信元 IP アドレスを指定する変数。

group addr

マルチキャスト ストリームの送信先 IP アドレスを指定する変数。たとえば、224.1.1.1 などです。

vrf

VPN ルーティング/転送インスタンス(VRF) を指定するキーワード。

VRF name

VPN ルーティング/転送インスタンス(VRF)の名前を指定する変数。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更点

12.0(32)S

このコマンドが導入されました。

 
使用上のガイドライン

Multicast Identifier(MGID)は、マルチキャスト ストリームの複製先インターフェイスのデフォルト キューのリストを保持するマルチキャスト グループ識別番号(ID)です。

ローカル MGID は、ストリームの複製先であるさまざまなキュー(デフォルトまたはデフォルト以外)のリストを保持する ID です。各 MGID は DSCP 値に関連付けられています。

次に、アドレス 1.1.1.2 からのストリームで、IP アドレスが 224.1.1.1 の all-mgids のインターフェイスのリストを取得する方法の例を示します。

LC-Slot2#show ip hardware-mdfs egress-qos conga hw-midb all-mgids 224.1.1.1 1.1.1.2
The Local MGIDs are:
3FFFD
MGID:3FFFD,
Entry 0: index:0, if_number:4
Entry 1: index:1, if_number:33
Entry 2: index:2, if_number:34
3FFFE
MGID:3FFFE,
Entry 0: index:0, if_number:4
Entry 1: index:1, if_number:33
Entry 2: index:2, if_number:34

 
関連コマンド

コマンド
説明

hw-module slot <n> ip multicast egress-qos enable

ISE ラインカード上で マルチキャスト出力 QoS 機能をイネーブルにします。

hw-module slot <n> ip multicast egress-qos no-priority-queue

マルチキャスト トラフィックがプライオリティ キューに到達しないようにします。

show mcast-qos queue-info [if number]

マルチキャスト出力 QoS に設定したラインカード上のインターフェイスのデータベース キュー情報を表示します。

show mcast-qos group-info [if number]

nCmD/1CnD モデルを設定する場合、マルチキャスト出力 QoS に設定したラインカード上のインターフェイスに関する QoS データベース グループ情報を表示します。

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

グループ アドレスまたは特定の mroute のクラス セットに関連付けられたローカル MGID を表示します。

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

実際の DSCP マッピング テーブルおよびそのローカル MGID/カウンティング情報を表示します。

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

すべての DSCP または特定の DSCP についての Random Early Detection Class of Service Bit(REDCOS ビット)を表示します。

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

DSCP マッピング テーブルおよびそのローカル MGID/カウンティング情報を表示するには、EXEC コンフィギュレーション モードで show ip hardware-mdfs egress-qos alpha コマンドを使用します。

Cisco IOS

show ip hardware-mdfs egress-qos alpha [< group addr > < src addr > | vrf < VRF name > < group addr > < src addr >]

 
シンタックスの説明

group addr

マルチキャスト ストリームの送信先 IP アドレスを指定する変数。たとえば、224.1.1.1 などです。

src addr

マルチキャスト ストリームの送信元 IP アドレスを指定する変数。

vrf

VPN ルーティング/転送インスタンス(VRF)を指定するキーワード。

VRF name

VPN ルーティング/転送インスタンス(VRF)の名前を指定する変数。

src addr

VRF の送信元 IP アドレスを指定する変数。

group addr

VRF の送信先 IP アドレスを指定する変数。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更点

12.0(32)S

このコマンドが導入されました。

 
使用上のガイドライン

Multicast Identifier(MGID)は、マルチキャスト ストリームの複製先インターフェイスのデフォルト キューのリストを保持するマルチキャスト グループ識別番号(ID)です。

ローカル MGID は、ストリームの複製先であるさまざまなキュー(デフォルトまたはデフォルト以外)のリストを保持する ID です。各 MGID は DSCP 値に関連付けられています。

次に、DSCP マッピング テーブルおよびその MGID/カウンティング情報を表示する方法の例を示します。

LC-Slot1#
LC-Slot1#show ip hardware-mdfs egress-qos alpha 224.1.1.1 1.1.1.2
The vrf is Default
TX side
(S=1.1.1.2, G=224.1.1.1), Global MGID: 7E
There are 3 different tx qos group for this (S,G):
0 .COS[def]: 0,1,2,3,4,5,6,7,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58,59,60,61,62,63,
Local MGID: 0000007E
1 .COS : 8,9,10,11,12,13,14,15,
Local MGID: 0003FFFA
2 .COS : 16,17,18,19,20,21,22,23,
Local MGID: 0003FFFC
LC-Slot1#

 
関連コマンド

コマンド
説明

hw-module slot <n> ip multicast egress-qos enable

ISE ラインカード上で マルチキャスト出力 QoS 機能をイネーブルにします。

hw-module slot <n> ip multicast egress-qos no-priority-queue

マルチキャスト トラフィックがプライオリティ キューに到達しないようにします。

show mcast-qos queue-info [if number]

マルチキャスト出力 QoS に設定したラインカード上のインターフェイスのデータベース キュー情報を表示します。

show mcast-qos group-info [if number]

nCmD/1CnD モデルを設定する場合、マルチキャスト出力 QoS に設定したラインカード上のインターフェイスに関する QoS データベース グループ情報を表示します。

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

グループ アドレスまたは特定の mroute のクラス セットに関連付けられたローカル MGID を表示します。

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

特定のローカル MGID に関連付けられたインターフェイスのリストを表示します。

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

すべての DSCP または特定の DSCP についての Random Early Detection Class of Service Bit(REDCOS ビット)を表示します。

show ip hardware-mdfs egress-qos wred-alpha [vrf <VRF name> | DSCP <dscp>]

すべての DSCP または特定の DSCP についての Random Early Detection Class of Service Bit(REDCOS ビット)を表示するには、EXEC コンフィギュレーションモードで show ip hardware-mdfs egress-qos wred-alpha [ vrf < VRF name > | DSCP < dscp > ] コマンドを使用します。

Cisco IOS

show ip hardware-mdfs egress-qos wred-alpha [ vrf < VRF name > | DSCP < dscp > ]

 
シンタックスの説明

vrf

VPN ルーティング/転送インスタンス(VRF)を指定するキーワード。

VRF name

VPN ルーティング/転送インスタンス(VRF)の名前を指定する変数。

DSCP

次の変数が DiffServ コード ポイント(DSCP)値であることを指定するキーワード。

dscp

DiffServ コード ポイント(DSCP)の値を 0 ~ 63 で指定する変数。マルチキャスト出力 QoS では、DSCP 値で QoS を指定します。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更点

12.0(32)S

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドを実行すると、指定された VRF のコンテキストで REDCOS ビットが表示されます。VRF が指定されていない場合は、グローバル VRF 値が表示されます。このコマンドは、マルチキャスト出力 QoS をサポートするラインカード上のアルファ送信だけに適用可能です。

このコマンドは ATM ラインカードではサポートされていません。

次に、グローバル VRF(特定の VRF に属さないインターフェイス)の各 DSCP 値に関連付けられた REDCOS ビットの例を示します。

Router#
Router#show ip hardware-mdfs egress-qos wred-alpha 224.1.1.1 1.1.1.2
DSCP REDCOS DSCP REDCOS DSCP REDCOS DSCP REDCOS
0 0 1 0 2 0 3 0
4 0 5 0 6 0 7 0
8 1 9 1 10 1 11 1
12 1 13 1 14 1 15 1
16 0 17 0 18 0 19 0
20 0 21 0 22 0 23 0
24 1 25 1 26 1 27 1
28 1 29 1 30 1 31 1
32 0 33 0 34 0 35 0
36 0 37 0 38 0 39 0
40 0 41 0 42 0 43 0
44 0 45 0 46 0 47 0
48 0 49 0 50 0 51 0
52 0 53 0 54 0 55 0
56 0 57 0 58 0 59 0
60 0 61 0 62 0 63 0

 
関連コマンド

コマンド
説明

hw-module slot <n> ip multicast egress-qos enable

ISE ラインカード上で マルチキャスト出力 QoS 機能をイネーブルにします。

hw-module slot <n> ip multicast egress-qos no-priority-queue

マルチキャスト トラフィックがプライオリティ キューに到達しないようにします。

show mcast-qos queue-info [if number]

マルチキャスト出力 QoS に設定したラインカード上のインターフェイスのデータベース キュー情報を表示します。

show mcast-qos group-info [if number]

nCmD/1CnD モデルを設定する場合、マルチキャスト出力 QoS に設定したラインカード上のインターフェイスに関する QoS データベース グループ情報を表示します。

show ip hardware-mdfs egress-qos conga local-mgids | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

グループ アドレスまたは特定の mroute のクラス セットに関連付けられたローカル MGID を表示します。

show ip hardware-mdfs egress-qos conga hw-midbs | <Local MGID> | <Local MGID> vrf <VRF name> | all-mgids <group addr> [<src addr] | vrf <VRF name> <group addr> [<src addr>]

特定のローカル MGID に関連付けられたインターフェイスのリストを表示します。

show ip hardware-mdfs egress-qos alpha | <group addr> [<src addr>] | vrf <VRF name> <group addr> [<src addr>]

実際の DSCP マッピング テーブルおよびそのローカル MGID/カウンティング情報を表示します。

hw-module fabric multicast-priority

OC-192 タイプのクロック スケジューラ カードのマルチキャスト パケット ドロップを防止するには、グローバル コンフィギュレーション モードで hw-module fabric multicast-priority コマンドを使用して、マルチキャスト パケットのプライオリティをユニキャスト パケットより高い値に変更します。

Cisco IOS

hw-module fabric multicast-priority

 
シンタックスの説明

適用されません。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更点

12.0(31.04)SY01、12.0(31)S06、12.0(31)s、12.0(32)S03、および 12.0(32.01)S12

このコマンドが導入されました。

 
使用上のガイドライン

マルチキャスト パケットのドロップは、CSC が OC-192 タイプで、通過するトラフィックがユニキャストおよびマルチキャストの場合に発生します。ユニキャスト パケットのプライオリティがマルチキャスト パケットのプライオリティ以上である場合、パケットがドロップされます。このため、送信遅延に左右されやすい音声またはビデオのトラフィックが影響を受けます。

このようなシナリオでは、コマンド hw-module fabric multicast-priority を使用して、ユニキャスト パケットのプライオリティより高いプライオリティをマルチキャスト パケットに設定します。このコマンドは、ユニキャスト トラフィックのパケット損失がない場合に設定するのが安全です。 show controllers sca コマンドを使用すると、プライオリティがユニキャストまたはマルチキャストに設定されているかどうかを確認できます。マルチキャストにプライオリティが設定されている場合、show controllers sca の出力には「Config 0x00 pri-mcast」と表示され、ユニキャストにプライオリティが設定されている場合はコマンド出力に「Config 0xC0 unicast-accept-mode pri-alternating」と表示されます。

次に、パケットのプライオリティをユニキャストに設定する例を示します。

Router# show controllers sca
Glad0934#sh controllers sca
SCA (Scheduler Control ASIC) Registers:
 
Slot # 16 (CSC_0)
Register Value
26000 11 4E 00 03 C0 00 00 00
26008 00 00 00 00 00 00 00 00
26010 00 00 02 02 05 05 00 00
26018 00 00 FF 00 00 01 01 00
26020 50 00 00 00 00 00 00
SCA identifier 114E Rev 1 of part number 334
Interrupt status 0x00
Interrupt enable 0x03 parity-error overflow
Config 0xC0 unicast-accept-mode pri-alternating
Rotation Period 0x00
Parity error log 0x0000
Parity error disabled 0x0000
Parity error enabled 0x0000
FIFO overflow log 0x0000
FIFO overflow disbled 0x0000
FIFO overflow enabled 0x0000
Line card enable 0x0205 Slots 0 2 9
Forced back pressure 0x0000
SW reset 0xFF
Line Cards Type OC192 0x0001 Slots 0
Line Cards Type OC48 and below
0xFFFE Slots 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
Line Card Priority 0x00 oc192-low-priority
legacy-line-card-priority-00
SLI Control 0x50 sli-tdelay-10 remote-card-present
0x00
Disable Grants 0x0000
Diag Control 0x00
Diag Address 0x00
Diag Data 0x00
 

次に、コマンド hw-module fabric multicast-priority を使用して、ユニキャストより高いマルチキャストのプライオリティを設定する方法の例を示します。

Router# config t
Router(config)# hw-module fabric multicast-priority


次に、パケットのプライオリティをマルチキャストに設定する例を示します。

Router# show controllers sca
SCA (Scheduler Control ASIC) Registers:
 
Slot # 16 (CSC_0)
Register Value
26000 11 4E 00 03 00 00 00 00
26008 00 00 00 00 00 00 00 00
26010 00 00 02 02 05 05 00 00
26018 00 00 FF 00 00 01 01 00
26020 50 00 00 00 00 00 00
SCA identifier 114E Rev 1 of part number 334
Interrupt status 0x00
Interrupt enable 0x03 parity-error overflow
Config 0x00 pri-mcast
Rotation Period 0x00
Parity error log 0x0000
Parity error disabled 0x0000
Parity error enabled 0x0000
FIFO overflow log 0x0000
FIFO overflow disbled 0x0000
FIFO overflow enabled 0x0000
Line card enable 0x0205 Slots 0 2 9
Forced back pressure 0x0000
SW reset 0xFF
Line Cards Type OC192 0x0001 Slots 0
Line Cards Type OC48 and below
0xFFFE Slots 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
Line Card Priority 0x00 oc192-low-priority
legacy-line-card-priority-00
SLI Control 0x50 sli-tdelay-10 remote-card-present
0x00
Disable Grants 0x0000
Diag Control 0x00
Diag Address 0x00
Diag Data 0x00

 
関連コマンド

コマンド
説明

show controllers sca

パケットのプライオリティがユニキャストまたはマルチキャストに設定されているかどうかを表示します。プライオリティがマルチキャストに設定されている場合、 show controllers sca コマンドの出力には「Config 0x00 pri-mcast」と表示され、プライオリティがユニキャストに設定されている場合は、コマンド出力に「Config 0xC0 unicast-accept-mode pri-alternating」と表示されます。

用語集

 

DSCP

DiffServ コード ポイント。マルチキャスト出力 QoS では、DSCP 値で QoS を指定します。IP パケットの Type of Service(TOS; タイプ オブ サービス)フィールドの先頭 3 ビットで precedence 値を指定します。値の範囲は 0 ~ 7 です。IP パケットのタイプ オブ サービス(TOS)フィールドの先頭 6 ビットで DSCP 値を指定します。値の範囲は 0 ~ 63 です。DSCP フィールドと precedence フィールドが重複するのは 3 ビットであるため、precedence 値と一致する DSCP 値は少ししかありません。たとえば、DSCP 値 8 ~ 15 は precedence 値 1(001XXX)に相当します。

MGID

Multicast Identifier(MGID)は、マルチキャスト ストリームの複製先インターフェイスのデフォルト キューのリストを保持するマルチキャスト グループ識別番号(ID)です。ローカル MGID は、ストリームの複製先であるさまざまなキュー(デフォルトまたはデフォルト以外)のリストを保持する ID です。各 MGID は DSCP 値に関連付けられています。

midb

マルチキャスト ID 記述子ブロック。

mroute

マルチキャスト ルート。

precedence

IP パケットのタイプ オブ サービス(TOS)フィールドの先頭 3 ビットで precedence 値を指定します。値の範囲は 0 ~ 7 です。precedence はパケットのプライオリティ レベルを示します。

VGL

VLAN グループ レベル。

VRF

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)ルーティング/フォワーディング インスタンス。

WRED

重み付けランダム早期検出。輻輳時に、優先順位の高いトラフィックの損失割合が他のトラフィックよりも低くなることを保証するキューイング方式。