Cisco Nexus 9000 シリーズ NX-OS ユニキャストルーティングコンフィギュレーションガイド、リリース 6.x
IS-IS の設定
IS-IS の設定
発行日;2015/03/18 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

IS-IS の設定

IS-IS について

IS-IS の概要

IS-IS エリア

NET およびシステム ID

DIS

IS-IS 認証

メッシュ グループ

過負荷ビット

ルート集約

ルートの再配布

ロード バランシング

BFD

仮想化のサポート

ハイ アベイラビリティおよびグレースフル リスタート

複数の IS-IS インスタンス

IS-IS のライセンス要件

IS-IS の前提条件

IS-IS に関する注意事項および制限事項

デフォルト設定

IS-IS の設定

IS-IS コンフィギュレーション モード

ルータ コンフィギュレーション モード

ルータ アドレス ファミリ コンフィギュレーション モード

IS-IS 機能のイネーブル化

IS-IS インスタンスの作成

IS-IS インスタンスの再起動

IS-IS のシャットダウン

インターフェイス上での IS-IS の設定

インターフェイスでの IS-IS のシャットダウン

エリアでの IS-IS 認証の設定

インターフェイス上での IS-IS 認証の設定

メッシュ グループの設定

DIS の設定

ダイナミック ホスト交換の設定

過負荷ビットの設定

Attached ビットの設定

hello パディングの一時モードの設定

サマリー アドレスの設定

再配布の設定

再配布されるルート数の制限

厳密な隣接モードのディセーブル化

グレースフル リスタートの設定

仮想化の設定

IS-IS の調整

IS-IS 設定の確認

IS-IS のモニタリング

IS-IS の設定例

関連項目

IS-IS の設定

この章では、Cisco NX-OS デバイスの Integrated Intermediate System-to-Intermediate System(IS-IS)を設定する方法について説明します。

この章は、次の項で構成されています。

「IS-IS について」

「IS-IS のライセンス要件」

「IS-IS の前提条件」

「IS-IS に関する注意事項および制限事項」

「デフォルト設定」

「IS-IS の設定」

「IS-IS 設定の確認」

「IS-IS のモニタリング」

「IS-IS の設定例」

「関連項目」

IS-IS について

IS-IS は、ISO(国際標準化機構)/IEC(国際電気標準化会議)10589 に基づく IGP です。Cisco NX-OS は、インターネット プロトコル バージョン 4(IPv4)および IPv6 をサポートします。IS-IS はネットワーク トポロジの変化を検出し、ネットワーク上の他のノードへのループフリー ルートを計算できる、ダイナミック リンクステート ルーティング プロトコルです。各ルータは、ネットワークの状態を記述するリンクステート データベースを維持し、設定された各リンクにパケットを送信してネイバーを検出します。IS-IS はネットワークを介して各ネイバーにリンクステート情報をフラッディングします。ルータもすべての既存ネイバーを通じて、リンクステート データベースのアドバタイズメントおよびアップデートを送信します。

この項では、次のトピックについて取り上げます。

「IS-IS の概要」

「IS-IS 認証」

「メッシュ グループ」

「過負荷ビット」

「ルート集約」

「ルートの再配布」

「ロード バランシング」

「BFD」

「仮想化のサポート」

「ハイ アベイラビリティおよびグレースフル リスタート」

「複数の IS-IS インスタンス」

IS-IS の概要

IS-IS は、設定されている各インターフェイスに hello パケットを送信し、IS-IS ネイバー ルータを検出します。hello パケットには認証、エリア、サポート対象プロトコルなど、受信側インターフェイスが発信側インターフェイスとの互換性を判別するために使用する情報が含まれます。また、一致する最大転送ユニット(MTU)設定を持つインターフェイスだけを使用して IS-IS が隣接関係を確立できるように、hello パケットがパディングされます。互換インターフェイスは隣接関係を形成し、リンクステート アップデート メッセージ(LSP)を使用して、リンクステート データベースのルーティング情報をアップデートします。ルータはデフォルトで、10 分間隔で定期的に LSP リフレッシュを送信し、LSP は 20 分間(LSP ライフタイム)リンクステート データベースに残ります。LSP ライフタイムが終了するまでにルータが LSP リフレッシュを受信しなかった場合、ルータはデータベースから LSP を削除します。

LSP 間隔は、LSP ライフタイムより短くする必要があります。そうしないと、リフレッシュ前に LSP がタイムアウトします。

IS-IS は、隣接ルータに定期的に hello パケットを送信します。hello パケットに対して一時モードを設定すると、IS-IS が隣接関係を確立する前に使用された余分なパディングがこれらの hello パケットに含まれなくなります。隣接ルータの MTU 値が変更された場合、IS-IS はこの変更を検出し、パディングされた hello パケットを一定期間送信できます。IS-IS はこの機能を使用して、隣接ルータ上の一致しない MTU 値を検出します。詳細については、「hello パディングの一時モードの設定」を参照してください。

IS-IS エリア

IS-IS ネットワークは、ネットワーク内のすべてのルータが含まれるシングル エリアとして設計することも、バックボーンまたはレベル 2 エリアに接続する複数のエリアとして設計することもできます。非バックボーン エリアのルータはレベル 1 ルータで、ローカル エリア内で隣接関係を確立します(エリア内ルーティング)。レベル 2 エリアのルータは、他のレベル 2 ルータと隣接関係を確立し、レベル 1 エリア間のルーティングを実行します(エリア間ルーティング)。1 つのルータにレベル 1 エリアとレベル 2 エリアの両方を設定できます。これらのレベル 1/レベル 2 ルータは、エリア境界ルータとして動作し、ローカル エリアからレベル 2 バックボーン エリアに情報をルーティングします(図 8-1を参照)。

レベル 1 エリア内のルータは、そのエリア内の他のすべてのルータに対する到達方法を認識します。レベル 2 ルータは、他のエリア境界ルータおよび他のレベル 2 ルータへの到達方法を認識します。レベル 1/レベル 2 ルータは 2 つのエリアの境界にまたがり、レベル 2 バックボーン エリアとの間で双方向にトラフィックをルーティングします。レベル 1/レベル 2 ルータはレベル 1 ルータの Attached(ATT)ビット信号を使用して、レベル 2 エリアに接続するため、このレベル 1/レベル 2 ルータへのデフォルト ルートを設定します。

エリア内に 2 台以上のレベル 1/レベル 2 ルータがある場合など、場合によっては、レベル 1 ルータがレベル 2 エリアへのデフォルト ルートとして使用するレベル 1/レベル 2 ルータを制御することもできます。Attached ビットを設定するレベル 1/レベル 2 ルータを設定できます。詳細については、「IS-IS 設定の確認」を参照してください。

Cisco NX-OS の IS-IS インスタンスは、レベル 1 またはレベル 2 エリアを 1 つだけサポートするか、またはそれぞれのエリアを 1 つずつサポートします。デフォルトでは、すべての IS-IS インスタンスが自動的にレベル 1 およびレベル 2 ルーティングをサポートします。

図 8-1 エリアに分割された IS-IS ネットワーク

 

ASBR(自律システム境界ルータ)は、IS-IS AS(自律システム)全体に外部宛先をアドバタイズします。外部ルートは、他のプロトコルから IS-IS に再配布されたルートです。

NET およびシステム ID

IS-IS インスタンスごとに NET が関連付けられています。NET は、その IS-IS インスタンスをエリア内で一意に特定する IS-IS システム ID とエリア ID からなります。たとえば、NET が 47.0004.004d.0001.0001.0c11.1111.00 の場合、システム ID は 0000.0c11.1111.00、エリア ID は 47.0004.004d.0001 です。

DIS

IS-IS はブロードキャスト ネットワーク内で代表中継システム(designated intermediate system)を使用し、各ルータがブロードキャスト ネットワーク上の他のすべてのルータと不要なリンクを形成することがないようにします。IS-IS ルータは DIS に LSP を送信し、DIS がブロードキャスト ネットワークのあらゆるリンクステート情報を管理します。エリア内で DIS を選択するために IS-IS に使用させる IS-IS プライオリティをユーザ側で設定できます。


) ポイントツーポイント ネットワークでは DIS は不要です。


IS-IS 認証

隣接関係および LSP 交換を制御するために、認証を設定できます。ネイバーになろうとするルータは、設定されている認証レベルの同じパスワードを交換する必要があります。パスワードが無効なルータは、IS-IS によってブロックされます。IS-IS 認証はグローバルに設定することも、レベル 1、レベル 2、またはレベル 1/レベル 2 両方のルーティングに対応する個々のインターフェイスに設定することもできます。

IS-IS がサポートする認証方式は、次のとおりです。

クリア テキスト:交換するすべてのパケットで、クリアテキストの 128 ビット パスワードが伝送されます。

MD5 ダイジェスト:交換するすべてのパケットで、128 ビット キーに基づくメッセージ ダイジェストが伝送されます。

受動的攻撃から保護するために、IS-IS はネットワークを介してクリア テキストとして MD5 秘密キーを送信します。また、リプレイ アタックから保護するために、IS-IS は各パケットにシーケンス番号を組み込みます。

hello および LSP 認証用のキーチェーンも使用できます。キーチェーン管理の詳細については、『 Cisco Nexus 9000 Series NX-OS Security Configuration Guide 』を参照してください。

メッシュ グループ

メッシュ グループ は、一連のインターフェイスであり、それらのインターフェイスを介して到達可能なすべてのルータは、他の各ルータとの間に 1 つ以上のリンクがあります。多数のリンクで障害が発生しても、ネットワークから 1 つまたは複数のルータが切り離されることはありません。

通常のフラッディングでは、新しい LSP を受信したインターフェイスは、その LSP をルータ上の他のすべてのインターフェイスにフラッディングします。メッシュ グループを使用する場合、メッシュ グループに含まれているインターフェイスは新しい LSP を受信しても、メッシュ グループ内の他のインターフェイスには、新しい LSP をフラッディングしません。


) 特定のメッシュ ネットワーク トポロジーで、ネットワークのスケーラビリティを向上させるために、LSP を制限しなければならない場合があります。LSP フラッディングを制限すると、ネットワークの信頼性も下がります(障害発生時)。したがって、メッシュ グループはどうしても必要な場合に限り、慎重にネットワークを設計したうえで使用することを推奨します。


ルータ間のパラレル リンクに、ブロック モードでメッシュ グループを設定することもできます。このモードでは、各ルータがそれぞれリンクステート情報を最初に交換すると、それ以後はメッシュ グループのそのインターフェイスですべての LSP がブロックされます。

過負荷ビット

IS-IS は過負荷ビットを使用して、トラフィックの転送にはローカル ルータを使用しないが、引き続き、そのローカル ルータ宛てのトラフィックをルーティングすることを他のルータに指示します。

過負荷ビットを使用する状況は、次のとおりです。

ルータがクリティカル条件下にある。

ネットワークに対して通常手順でルータの追加および除去を行う。

その他(管理上またはトラフィック エンジニアリング上)の理由。BGP コンバージェンスの待機中など。

ルート集約

サマリー集約アドレスを設定できます。ルート集約を使用すると、固有性の強い一連のアドレスをすべての固有アドレスを代表する 1 つのアドレスに置き換えることによって、ルート テーブルを簡素化できます。たとえば、10.1.1.0/24、10.1.2.0/24、および 10.1.3.0/24 というアドレスを 1 つの集約アドレス 10.1.0.0/16 に置き換えることができます。

IS-IS はルーティング テーブルに含まれている固有性の強いルートが多いほど、固有性の強いルートの最小メトリックと同じメトリックを指定して、サマリー アドレスをアドバタイズします。


) Cisco NX-OS は、自動ルート集約をサポートしていません。


ルートの再配布

IS-IS を使用すると、スタティック ルート、他の IS-IS AS が学習したルート、またはほかのプロトコルからのルートを再配布できます。再配布を指定したルート マップを設定して、どのルートが IS-IS に渡されるかを制御する必要があります。ルート マップを使用すると、宛先、送信元プロトコル、ルート タイプ、ルート タグなどの属性に基づいて、ルートをフィルタリングできます。詳細については、「Route Policy Manager の設定」 を参照してください。

IS-IS ルーティング ドメインにルートを再配布しても、デフォルトでは Cisco NX-OS がそのつど、IS-IS ルーティング ドメインにデフォルト ルートを再配布することはありません。IS-IS で デフォルト ルート を発生させ、ルート ポリシーでそのルートを制御できます。

IS-IS にインポートされたすべてのルートに使用する、デフォルトのメトリックも設定できます。

ロード バランシング

ロード バランシングを使用すると、ルータによって、宛先アドレスから同じ距離にあるすべてのルータ ネットワーク ポートにトラフィックが分散されます。ロード バランシングは、ネットワーク セグメントの使用率を向上させ、有効ネットワーク帯域幅を増加させます。

Cisco NX-OS は、ECMP(等コスト マルチパス)機能をサポートします。IS-IS ルート テーブルおよびユニキャスト RIB の等コスト パスは最大 16 です。これらのパスの一部または全部でトラフィックのロード バランシングが行われるように、IS-IS を設定できます。

BFD

この機能では、双方向フォワーディング検出(BFD)をサポートします。BFD は、転送パスの障害を高速で検出することを目的にした検出プロトコルです。BFD は 2 台の隣接デバイス間のサブセカンド障害を検出し、BFD の負荷の一部を、サポートされるモジュール上のデータ プレーンに分散できるため、プロトコル hello メッセージよりも CPU を使いません。詳細については、『 Cisco Nexus 9000 Series NX-OS Interfaces Configuration Guide 』を参照してください。

仮想化のサポート

Cisco NX-OS は、IS-IS の複数のプロセス インスタンスをサポートします。各 IS-IS インスタンスは、システム制限まで複数の仮想ルーティングおよび転送(VRF)インスタンスをサポートできます。サポートされる IS-IS インスタンスの数については、 Cisco Nexus 9000 Series NX-OS Verified Scalability Guide を参照してください。

ハイ アベイラビリティおよびグレースフル リスタート

Cisco NX-OS では、複数レベルのハイ アベイラビリティ アーキテクチャを提供します。IS-IS は、ステートフル リスタートをサポートしています。これは、ノンストップ ルーティング(NSR)とも呼ばれます。IS-IS で問題が発生した場合は、以前の実行時状態からの再起動を試みます。この場合、ネイバーはいずれのネイバー イベントも登録しません。最初の再起動が正常ではなく、別の問題が発生した場合、RFC 3847 のとおり、IS-IS はグレースフル リスタートを試みます。グレースフル リスタート、つまり、Nonstop Forwarding(NSF)では、処理の再起動中も IS-IS がデータ転送パス上に存在し続けます。再起動中の IS-IS インターフェイスが稼働を再開すると、ネイバーを再探索して隣接関係を確立し、更新情報の送信を再開します。この時点で、NSF ヘルパーは、グレースフル リスタートが完了したと認識します。

ステートフル リスタートは次のシナリオで使用されます。

プロセスでの問題発生後の最初の回復試行

system switchover コマンドによる手動でのスイッチオーバー

グレースフル リスタートは次のシナリオで使用されます。

プロセスでの問題発生後の 2 回目の回復試行(4 分以内)

restart isis コマンドによるプロセスの手動での再開

アクティブ スーパーバイザの削除

reload module active-sup コマンドによるアクティブ スーパーバイザのリロード


) グレースフル リスタートがデフォルトとなっており、ディセーブルにしないことを強く推奨します。


複数の IS-IS インスタンス

Cisco NX-OS は、同じノード上で動作する、IS-IS プロトコルの複数インスタンスをサポートしています。同一インターフェイスには複数のインスタンスを設定できません。すべてのインスタンスで同じシステム ルータ ID を使用します。サポートされる IS-IS インスタンスの数については、 Cisco Nexus 9000 Series NX-OS Verified Scalability Guide を参照してください。

IS-IS のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

IS-IS には Enterprise Services ライセンスが必要です。Cisco NX-OS ライセンス方式について、およびライセンスの取得方法と適用方法の詳細については、 『Cisco NX-OS Licensing Guide を参照してください。

IS-IS の前提条件

IS-IS の前提条件は、次のとおりです。

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

IS-IS に関する注意事項および制限事項

IS-IS 設定時の注意事項および制約事項は、次のとおりです。

デフォルトの参照帯域幅が Cisco NX-OS と Cisco IOS では異なるため、アドバタイズされたトンネル IS-IS メトリックは、これら 2 つのオペレーティング システムによって異なります。

デフォルト設定

表 8-1 に、IS-IS パラメータのデフォルト設定を示します。

 

表 8-1 デフォルトの IS-IS パラメータ

パラメータ(Parameters)
デフォルト

アドミニストレーティブ ディスタンス

115

エリア レベル

Level-1-2

DIS プライオリティ

64

グレースフル リスタート

イネーブル

hello 乗数

3

hello パディング

イネーブル

hello タイム

10 秒

IS-IS 機能

ディセーブル

LSP 間隔

33

LSP MTU

1492

最大 LSP ライフタイム

1200 秒

最大パス

8

メトリック

40

参照帯域幅

40 Gbps

IS-IS の設定

IS-IS を設定する手順は、次のとおりです。


ステップ 1 IS-IS 機能をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

ステップ 2 IS-IS インスタンスを作成します(「IS-IS インスタンスの作成」を参照)。

ステップ 3 IS-IS インスタンスにインターフェイスを追加します(「インターフェイス上での IS-IS の設定」を参照)。

ステップ 4 認証、メッシュ グループ、ダイナミック ホスト交換などのオプション機能を設定します。


 

ここでは、次の内容について説明します。

「IS-IS コンフィギュレーション モード」

「IS-IS 機能のイネーブル化」

「IS-IS インスタンスの作成」

「IS-IS インスタンスの再起動」

「IS-IS のシャットダウン」

「インターフェイス上での IS-IS の設定」

「インターフェイスでの IS-IS のシャットダウン」

「エリアでの IS-IS 認証の設定」

「インターフェイス上での IS-IS 認証の設定」

「メッシュ グループの設定」

「DIS の設定」

「ダイナミック ホスト交換の設定」

「過負荷ビットの設定」

「Attached ビットの設定」

「hello パディングの一時モードの設定」

「サマリー アドレスの設定」

「再配布の設定」

「再配布されるルート数の制限」

「厳密な隣接モードのディセーブル化」

「グレースフル リスタートの設定」

「仮想化の設定」

「IS-IS の調整」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


IS-IS コンフィギュレーション モード

ここでは各コンフィギュレーション モードの開始方法について説明します。各モードから、 ? コマンドを入力すると、そのモードで使用できるコマンドが表示されます。

この項では、次のトピックについて取り上げます。

「ルータ コンフィギュレーション モード」

「ルータ アドレス ファミリ コンフィギュレーション モード」

ルータ コンフィギュレーション モード

次に、ルータ コンフィギュレーション モードを開始する例を示します。

switch#: configure terminal
switch(config)# router isis isp
switch(config-router)#

ルータ アドレス ファミリ コンフィギュレーション モード

次に、ルータ アドレス ファミリ コンフィギュレーション モードを開始する例を示します。

switch(config)# router isis isp
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)#
 

IS-IS 機能のイネーブル化

IS-IS を設定する前に、IS-IS 機能をイネーブルにする必要があります。

手順の概要

1. configure terminal

2. feature isis

3. (任意)show feature

4. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature isis

 

例:

switch(config)# feature isis

IS-IS 機能をイネーブルにします。

ステップ 3

show feature

 

例:

switch(config)# show feature

(任意)イネーブルおよびディセーブルにされた機能を表示します。

ステップ 4

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

IS-IS機能をディセーブルにして、関連付けられている設定をすべて削除するには、コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

no feature isis

 

例:

switch(config)# no feature isis

IS-IS 機能をディセーブルにし、関連付けられたすべての設定を削除します。

IS-IS インスタンスの作成

IS-IS インスタンスを作成し、そのインスタンスのエリア レベルを設定できます。

はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. router isis instance-tag

3. net network-entity-title

4. (任意)is-type {l evel-1 | level-2 | level-1-2 }

5. (任意)show isis [ vrf vrf-name ] process

6. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

net network-entity-title

 

例:

switch(config-router)# net 47.0004.004d.0001.0001.0c11.1111.00

この IS-IS インスタンスに対応する NET を設定します。

ステップ 4

is-type { level-1 | level-2 | level-1-2 }

 

例:

switch(config-router)# is-type level-2

(任意)この IS-IS インスタンスのエリア レベルを設定します。デフォルトは level-1-2 です。

ステップ 5

show isis [ vrf vrf-name ] process

 

switch(config)# show isis process

(任意)すべての IS-IS インスタンスについて、IS-IS 要約情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

IS-IS インスタンスおよび関連する設定を削除するには、コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

no router isis instance-tag

 

例:

switch(config)# no router isis Enterprise

IS-IS インスタンスおよび関連するすべての設定を削除します。


) IS-IS インスタンスに関するすべての設定を完全に削除するには、インターフェイス モードで設定した IS-IS コマンドも削除する必要があります。


IS-IS には次のオプション パラメータを設定できます。

 

コマンド
目的

distance value

 

例:

switch(config-router)# distance 30

IS-IS のアドミニストレーティブ ディスタンスを設定します。指定できる範囲は 1 ~ 255 です。デフォルトは 115 です。

log-adjacency-changes

 

例:

switch(config-router)# log-adjacency-changes

IS-IS ネイバーのステートが変化するたびに、システム メッセージを送信します。

lsp-mtu size

 

例:

switch(config-router)# lsp-mtu 600

この IS-IS インスタンスにおける LSP の MTU を設定します。指定できる範囲は 128 ~ 4352 バイトです。デフォルトは 1492 です。

maximum-paths number

 

例:

switch(config-router)# maximum-paths 6

IS-IS がルート テーブルで維持する等コスト パスの最大数を設定します。範囲は 1 ~ 64 です。デフォルトは 8 です。

reference-bandwidth bandwidth-value { Mbps | Gbps }

 

例:

switch(config-router)# reference-bandwidth 100 Gbps

IS-IS コスト メトリックの計算に使用する、デフォルトの基準帯域幅を設定します。指定できる範囲は 1 ~ 4000 Gbps です。デフォルトは 40 Gbps です。

レベル 2 エリアで IS-IS インスタンスを作成する例を示します。

switch# configure terminal

switch(config)# router isis Enterprise

switch(config-router)# net 47.0004.004d.0001.0001.0c11.1111.00

switch(config-router)# is-type level 2

switch(config-router)# copy running-config startup-config

 

ネイバーの統計情報を消去し、隣接関係を削除するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

clear isis [ instance-tag ] adjacency [ * | system-id | interface ]

switch(config-if)# clear isis adjacency *

ネイバーの統計情報を消去し、この IS-IS インスタンスの隣接関係を削除します。

IS-IS インスタンスの再起動

IS-IS インスタンスは再起動が可能です。この処理では、インスタンスのすべてのネイバーが消去されます。

IS-IS インスタンスを再起動し、関連付けられたすべてのネイバーを削除するには、次のコマンドを使用します。

 

コマンド
目的

restart isis instance-tag

 

例:

switch(config)# restart isis Enterprise

IS-IS インスタンスを再起動し、すべてのネイバーを削除します。

IS-IS のシャットダウン

IS-IS インスタンスをシャットダウンできます。シャットダウンすると、その IS-IS インスタンスがディセーブルになり、設定が保持されます。

IS-IS インスタンスをシャットダウンするには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

shutdown

 

例:

switch(config-router)# shutdown

IS-IS インスタンスをディセーブルにします。

インターフェイス上での IS-IS の設定

IS-IS インスタンスにインターフェイスを追加できます。

はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. (任意) medium { broadcast | p2p }

4. {ip | ipv6} router isis instance-tag

5. (任意) show isis [ vrf vrf-name ] [ instance-tag ] interface [ interface-type slot/port ]

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

medium { broadcast | p2p }

 

switch(config-if)# medium p2p

(任意)インターフェイスのブロードキャスト モードまたはポイントツーポイント モードを設定します。IS-IS はこのモードを継承します。

ステップ 4

{ip | ipv6} router isis instance-tag

 

switch(config-if)# ip router isis Enterprise

この IPv4 または IPv6 インターフェイスを IS-IS インスタンスに関連付けます。

ステップ 5

show isis [ vrf vrf-name ] [ instance-tag ] interface [ interface-type slot/port ]

 

switch(config)# show isis Enterprise ethernet 1/2

(任意)VRF のインターフェイスの IS-IS 情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

インターフェイス モードでは、IS-IS に次のオプション パラメータを設定できます。

 

コマンド
目的

isis circuit-type { level-1 | level-2 | level-1-2 }

 

switch(config-if)# isis circuit-type level-2

このインターフェイスが関与する隣接関係のタイプを設定します。このコマンドを使用するのは、レベル 1 とレベル 2 の両方のエリアにルータが関係する場合だけです。

isis metric value { level-1 | level-2 }

 

例:

switch(config-if)# isis metric 30

このインターフェイスの IS-IS メトリックを設定します。指定できる範囲は 1 ~ 16777214 です。デフォルトは 10 です。

isis passive { level-1 | level-2 | level-1-2 }

 

例:

switch(config-if)# isis passive level-2

インターフェイスが隣接関係を形成しないようにしながら、なおかつ、インターフェイスに関連付けられたプレフィックスをアドバタイズするようにします。

次に、IS-IS インスタンスに Ethernet 1/2 インターフェイスを追加する例を示します。

switch# configure terminal

switch(config)# interface ethernet 1/2

switch(config-if)# ip router isis Enterprise

switch(config-if)# copy running-config startup-config

インターフェイスでの IS-IS のシャットダウン

インターフェイス上で IS-IS を正常にシャットダウンできます。これにより、すべての隣接関係が削除され、このインターフェイスで IS-IS トラフィックが停止しますが、IS-IS 設定は保持されます。

インターフェイス上で IS-IS をディセーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

switch(config-if)# isis shutdown

 

例:

switch(config-router)# isis shutdown

このインターフェイスで IS-IS をディセーブルにします。IS-IS インターフェイスの設定は保持されます。

エリアでの IS-IS 認証の設定

エリアで LSP を認証するように IS-IS を設定できます。

はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. router isis instance-tag

3. authentication-type { cleartext | md5 } {l evel-1 | level-2 }

4. authentication key-chain key { level-1 | level-2 }

5. (任意) authentication-check { level-1 | level-2 }

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

authentication-type { cleartext | md5 } { level-1 | level-2 }

 

switch(config-router)# authentication-type cleartext level-2

クリアテキストまたは MD5 認証ダイジェストとして、レベル 1 またはレベル 2 エリアに使用する認証方式を設定します。

ステップ 4

authentication key-chain key { level-1 | level-2 }

 

switch(config-router)# authentication key-chain ISISKey level-2

IS-IS エリアレベル認証に使用する認証キーを設定します。

ステップ 5

authentication-check { level-1 | level-2 }

 

switch(config-router)# authentication-check level-2

(任意)受信パケットの認証パラメータ チェックをイネーブルにします。

ステップ 6

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)この設定の変更を保存します。

IS-IS インスタンスにクリアテキスト認証を設定する例を示します。

switch# configure terminal

switch(config)# router isis Enterprise

switch(config-router)# authentication-type cleartext level-2

switch(config-router)# authentication key-chain ISISKey level-2

switch(config-router)# copy running-config startup-config

インターフェイス上での IS-IS 認証の設定

インターフェイス上で hello パケットを認証するように IS-IS を設定できます。

はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. isis authentication-type { cleartext | md5 } { level-1 | level-2 }

4. isis authentication key-chain key { level-1 | level-2 }

5. (任意) isis authentication-check { level-1 | level-2 }

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

例:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

isis authentication-type { cleartext | md5 } { level-1 | level-2 }

 

switch(config-if)# isis authentication-type cleartext level-2

クリアテキストまたは MD5 認証ダイジェストとして、このインターフェイスにおける IS-IS 認証タイプを設定します。

ステップ 4

isis authentication key-chain key { level-1 | level-2 }

 

switch(config-if)# isis authentication-key ISISKey level-2

このインターフェイス上で IS-IS に使用する認証キーを設定します。

ステップ 5

isis authentication-check { level-1 | level-2 }

 

switch(config-if)# isis authentication-check

(任意)受信パケットの認証パラメータ チェックをイネーブルにします。

ステップ 6

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

IS-IS インスタンスにクリアテキスト認証を設定する例を示します。

switch# configure terminal

switch(config)# interface ethernet 1/2

switch(config-if)# isis authentication-type cleartext level-2

switch(config-if)# isis authentication key-chain ISISKey

switch(config-if)# copy running-config startup-config

 

メッシュ グループの設定

メッシュ グループにインターフェイスを追加することによって、そのメッシュ グループ内のインターフェイスに対する LSP フラッディング量を制限できます。任意で、メッシュ グループ内のインターフェイスに対して、すべての LSP フラッディングをブロックすることもできます。

メッシュ グループにインターフェイスを追加するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

isis mesh-group { blocked | mesh-id }

 

switch(config-if)# isis mesh-group 1

メッシュ グループにこのインターフェイスを追加します。指定できる範囲は 1 ~ 4294967295 です。

DIS の設定

インターフェイス プライオリティを設定することによって、ルータがマルチアクセス ネットワークの DIS(代表中継システム)になるように設定できます。

DIS を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

isis priority number { level-1 | level-2 }

 

switch(config-if)# isis priority 100 level-1

DIS 選択のためのプライオリティを設定します。範囲は 0 ~ 127 です。デフォルトは 64 です。

ダイナミック ホスト交換の設定

ダイナミック ホスト交換を使用することによって、システム ID とルータのホスト名がマッピングされるように IS-IS を設定できます。

ダイナミック ホスト交換を設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

hostname dynamic

 

switch(config-router)# hostname dynamic

ダイナミック ホスト交換をイネーブルにします。

過負荷ビットの設定

最短パス優先(SPF)を計算するときの中間ホップとしてこのルータを使用しないことを他のルータに伝えるように、ルータを設定できます。任意で、起動時に BGP がコンバージェンスするまで、一時的に過負荷ビットを設定することもできます。

過負荷ビットを設定する以外に、レベル 1 またはレベル 2 トラフィックに関して、LSP からの特定タイプの IP プレフィックス アドバタイズメントを抑制することが必要な場合もあります。

過負荷ビットを設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

set-overload-bit { always | on-startup { seconds | wait-for bgp as-number }} [ suppress [ interlevel | external ]]

 

switch(config-router)# set-overload-bit on-startup 30

IS-IS に過負荷ビットを設定します。 seconds の範囲は 5 ~ 86400 です。

Attached ビットの設定

Attached ビットを設定すると、レベル 1 ルータがレベル 2 エリアへのデフォルト ルートとして使用するレベル 1/レベル 2 ルータを制御できます。Attached ビットの設定をディセーブルにすると、レベル 1 ルータはこのレベル 1/レベル 2 ルータを使用してレベル 2 エリアに接続しなくなります。

レベル 1/レベル 2 ルータの Attached ビットを設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

[ no ] attached-bit

switch(config-router)# no attached-bit

Attached ビットを設定するようにレベル 1/レベル 2 ルータを設定します。この機能は、デフォルトでイネーブルにされています。

hello パディングの一時モードの設定

hello パディングの一時モードを設定すると、IS-IS が隣接関係を確立するときに hello パケットをパディングし、IS-IS が隣接関係を確立したあとでそのパディングを削除できます。

hello パディングのモードを設定するには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

[ no ] isis hello-padding

 

switch(config-if)# no isis hello-padding

完全な最大伝送単位(MTU)に hello パケットをパディングします。デフォルトではイネーブルになっています。hello パディングの一時モードを設定するには、このコマンドの no 形式を使用します。

サマリー アドレスの設定

ルーティング テーブルでサマリー アドレスによって表される集約アドレスを作成できます。1 つのサマリー アドレスに、特定のレベルのアドレス グループを複数含めることができます。Cisco NX-OS は固有性の強いすべてのルートのうち、最小メトリックをアドバタイズします。

はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. router isis instance-tag

3. address-family {ipv4 | ipv6} unicast

4. summary-address ip-prefix/mask-len { level-1 | level-2 | level-1-2 }

5. (任意) show isis [ vrf vrf-name ] { ip | ipv6} summary-address ip-prefix [ longer-prefixes ]

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

address-family {ipv4 | ipv6} unicast

 

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 4

summary-address ip-prefix/mask-len { level-1 | level-2 | level-1-2 }

 

switch(config-router-af)# summary-address 192.0.2.0/24 level-2

IPv4 アドレスまたは IPv6 アドレスに対応する、IS-IS エリア用のサマリー アドレスを設定します。

ステップ 5

show isis [ vrf vrf-name ] { ip | ipv6} summary-address ip-prefix [ longer-prefixes ]

 

switch(config-if)# show isis ip summary-address

(任意)IS-IS IPv4 または IPv6 サマリー アドレス情報を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、IS-IS の IPv4 ユニキャスト サマリー アドレスを設定する例を示します。

switch# configure terminal

switch(config)# router isis Enterprise

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# summary-address 192.0.2.0/24 level-2

switch(config-router-af)# copy running-config startup-config

再配布の設定

別のルーティング プロトコルからのルーティング情報を受け入れて、IS-IS ネットワークを通じてその情報を再配布するように、IS-IS を設定できます。任意で、再配布ルートのためのデフォルト ルートを割り当てることができます。

はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. router isis instance-tag

3. address-family { ipv4 | ipv6} unicast

4. redistribute { bgp as | direct |{ eigrp | isis | ospf | ospfv3 | rip } instance-tag | static } route-map map-name

5. (任意) default-information originate [ always ] [ route-map map-name ]

6. (任意) distribute { level-1 | level-2 } into { level-1 | level-2 } { route-map route-map | all }

7. (任意) show isis [ vrf vrf-name ] { ip | ipv6} route ip-prefix [ detail | longer-prefixes [ summary | detail ]]

8. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

address-family {ipv4 | ipv6} unicast

 

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 4

redistribute { bgp as | { eigrp | isis | ospf | ospfv3 | rip } instance-tag | static | direct } route-map map-name

 

switch(config-router-af)# redistribute eigrp 201 route-map ISISmap

他のプロトコルからのルートを IS-IS に再配布します。ルート マップの詳細については、「ルート マップの設定」を参照してください。

ステップ 5

default-information originate [ always ] [ route-map map-name ]

 

switch(config-router-af)# default-information originate always

(任意)IS-IS へのデフォルト ルートを作成します。

ステップ 6

distribute { level-1 | level-2 } into { level-1 | level-2 } { route-map route-map | all }

 

switch(config-router-af)# distribute level-1 into level-2 all

(任意)一方の IS-IS レベルから他方の IS-IS レベルへ、ルートを再配布します。

ステップ 7

show isis [ vrf vrf-name ] { ip | ipv6} route ip-prefix [ detail | longer-prefixes [ summary | detail ]]

 

例:

switch(config-router-af)# show isis ip route

(任意)IS-IS ルートを示します。

ステップ 8

copy running-config startup-config

 

例:

switch(config-router-af)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、EIGRP を IS-IS に再配布する例を示します。

switch# configure terminal

switch(config)# router isis Enterprise

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# redistribute eigrp 201 route-map ISISmap

switch(config-router-af)# copy running-config startup-config

再配布されるルート数の制限

ルートの再配布によって、IS-IS ルート テーブルに多くのルートが追加される可能性があります。外部プロトコルから受け取るルートの数に最大制限を設定できます。IS-IS には、再配布ルートの制限を設定するために次のオプションが用意されています。

上限固定:IS-IS が設定された最大値に達すると、メッセージをログに記録します。IS-IS は以降の再配布ルートを受け取りません。任意で、最大値のしきい値パーセンテージを設定して、IS-IS がこのしきい値を超えたときに警告を記録するようにすることもできます。

警告のみ:IS-IS が最大値に達したときのみ、警告のログを記録します。IS-IS は引き続き再配布ルートを受け取ります。

取り消し:IS-IS が最大値に達したときにタイムアウト期間を開始します。タイムアウト期間の経過後、現在の再配布ルートの数が最大制限より少ない場合、IS-IS はすべての再配布ルートを要求します。現在の再配布ルートの数が最大制限に達している場合、IS-IS はすべての再配布ルートを取り消します。IS-IS が以降の再配布ルートを受け取るには、この状態を解消する必要があります。任意で、タイムアウト期間を設定できます。

はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. router isis instance-tag

3. redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

4. redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]]

5. (任意) show running-config isis

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

redistribute { bgp id | direct | eigrp id | isis id | ospf id | rip id | static } route-map map-name

 

例:

switch(config-router)# redistribute bgp route-map FilterExternalBGP

設定したルート マップ経由で、選択したプロトコルを IS-IS に再配布します。

ステップ 4

redistribute maximum-prefix max [ threshold ] [ warning-only | withdraw [ num-retries timeout ]]

 

例:

switch(config-router)# redistribute maximum-prefix 1000 75 warning-only

IS-IS が配布するプレフィックスの最大数を指定します。範囲は 1 ~ 65535 です。次の項目を任意で指定できます。

threshold :警告メッセージをトリガーする最大プレフィックス数のパーセンテージ。

warning-only :プレフィックスの最大数を超えたときに警告メッセージを記録します。

withdraw :再配布されたすべてのルートを取り消します。オプション選択で、再配布されたルートの取得を試みることができます。 num-retries の範囲は 1 ~ 12 です。 timeout は 60 ~ 600 秒です。デフォルトは 300 秒です。 clear isis redistribution コマンドは、すべてのルートが取り消された場合に使用します。

ステップ 5

show running-config isis

 

例:

switch(config-router)# show running-config isis

(任意)IS-IS の設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、IS-IS に再配布されるルートの数を制限する例を示します。

switch# configure terminal

switch(config)# router eigrp isis Enterprise

switch(config-router)# redistribute bgp route-map FilterExternalBGP

switch(config-router)# redistribute maximum-prefix 1000 75

厳密な隣接モードのディセーブル化

IPv4 と IPv6 の両方のアドレス ファミリがイネーブルの場合、厳格な隣接モードはデフォルトでイネーブルです。このモードでは、デバイスが両方のアドレス ファミリにイネーブルでない任意のルータとの隣接関係を形成しません。厳格な隣接モードは、no adjacency-check コマンドを使用してディセーブルにできます。

はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. router isis instance-tag

3. address-family ipv4 unicast

4. no adjacency-check

5. exit

6. address-family ipv6 unicast

7. no adjacency-check

8. (任意) show running-config isis

9. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 3

address-family ipv4 unicast

 

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 4

no adjacency-check

 

例:

switch(config-router-af)# no adjacency-check

IPv4 アドレス ファミリに関する厳格な隣接モードをディセーブルにします。

ステップ 5

exit

 

例:

switch(config-router-af)# exit

switch(config-router)#

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 6

address-family ipv6 unicast

 

switch(config-router)# address-family ipv6 unicast

switch(config-router-af)#

アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 7

no adjacency-check

 

例:

switch(config-router-af)# no adjacency-check

IPv6 アドレス ファミリに関する厳格な隣接モードをディセーブルにします。

ステップ 8

show running-config isis

 

例:

switch(config-router-af)# show running-config isis

(任意)IS-IS の設定を表示します。

ステップ 9

copy running-config startup-config

 

例:

switch(config-router-af)# copy running-config startup-config

(任意)この設定の変更を保存します。

グレースフル リスタートの設定

IS-IS にグレースフル リスタートを設定できます。

はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

VRF を作成します。

手順の概要

1. configure terminal

2. router isis instance-tag

3. graceful-restart

4. graceful-restart t3 manual time

5. (任意) show running-config isis

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

名前を設定して、新しい IS-IS プロセスを作成します。

ステップ 3

graceful-restart

 

例:

switch(config-router)# graceful-restart

グレースフル リスタートおよびグレースフル リスタート ヘルパー機能をイネーブルにします。デフォルトでは、イネーブルです。

ステップ 4

graceful-restart t3 manual time

 

例:

switch(config-router)# graceful-restart t3 manual 300

グレースフル リスタート T3 タイマーを設定します。有効な範囲は 30 ~ 65535 秒です。デフォルト値は 60 です。

ステップ 5

show running-config isis

 

例:

switch(config-router)# show running-config isis

(任意)IS-IS の設定を表示します。

ステップ 6

copy running-config startup-config

 

例:

switch(config-router)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、グレースフル リスタートをイネーブルにする例を示します。

switch# configure terminal

switch(config)# router isis Enterprise

switch(config-router)# graceful-restart

switch(config-router)# copy running-config startup-config

仮想化の設定

複数の IS-IS インスタンスと複数の VRF を設定できます。また、各 VRF で同じまたは複数の IS-IS インスタンスを使用することもできます。VRF に IS-IS インターフェイスを割り当てます。

設定した VRF に NET を設定する必要があります。


) インターフェイスの VRF を設定した後に、インターフェイスの他のすべてのパラメータを設定します。インターフェイスの VRF を設定すると、そのインターフェイスのすべての設定が削除されます。


はじめる前に

IS-IS をイネーブルにします(「IS-IS 機能のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. vrf context vrf_name

3. exit

4. router isis instance-tag

5. (任意) vrf vrf_name

6. net network-entity-title

7. exit

8. interface type slot/port

9. vrf member vrf-name

10. { ip | ipv6 } address ip-prefix / length

11. { ip | ipv6 } router isis instance-tag

12. (任意) show isis [ vrf vrf-name ] [ instance-tag ] interface [ interface-type slot/port ]

13. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

例:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vrf context vrf-name

 

例:

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。

ステップ 3

exit

 

例:

switch(config-vrf)# exit

switch(config)#

VRF コンフィギュレーション モードを終了します。

ステップ 4

router isis instance-tag

 

例:

switch(config)# router isis Enterprise

switch(config-router)#

instance tag を設定して、新しい IS-IS インスタンスを作成します。

ステップ 5

vrf vrf-name

 

例:

switch(config-router)# vrf RemoteOfficeVRF

switch(config-router-vrf)#

(任意)VRF コンフィギュレーション モードを開始します。

ステップ 6

net network-entity-title

 

例:

switch(config-router-vrf)# net 47.0004.004d.0001.0001.0c11.1111.00

この IS-IS インスタンスに対応する NET を設定します。

ステップ 7

exit

 

例:

switch(config-router-vrf)# exit

switch(config-router)#

ルータ VRF コンフィギュレーション モードを終了します。

ステップ 8

interface ethernet slot/port

 

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

vrf member vrf-name

 

例:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 10

{ip | ipv6} address ip-prefix/length

 

例:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 11

{ip | ipv6} router isis instance-tag

 

switch(config-if)# ip router isis Enterprise

この IPv4 または IPv6 インターフェイスを IS-IS インスタンスに関連付けます。

ステップ 12

show isis [ vrf vrf-name ] [ instance-tag ] interface [ interface-type slot/port ]

 

switch(config-if)# show isis Enterprise ethernet 1/2

(任意)VRF のインターフェイスの IS-IS 情報を表示します。

ステップ 13

copy running-config startup-config

 

例:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF を作成して、その VRF にインターフェイスを追加する例を示します。

switch# configure terminal

switch(config)# vrf context NewVRF

switch(config-vrf)# exit

switch(config)# router isis Enterprise

switch(config-router)# vrf NewVRF

switch(config-router-vrf)# net 47.0004.004d.0001.0001.0c11.1111.00

switch(config-router-vrf)# interface ethernet 1/2

switch(config-if)# vrf member NewVRF

switch(config-if)# ip address 192.0.2.1/16

switch(config-if)# ip router isis Enterprise

switch(config-if)# copy running-config startup-config

 

IS-IS の調整

ネットワーク要件に合わせて IS-IS を調整できます。

IS-IS を調整するには、ルータ コンフィギュレーション モードで次のオプション コマンドを使用します。

 

コマンド
目的

lsp-gen-interval [ level-1 | level-2 ] lsp-max-wait [ lsp-initial-wait lsp-second-wait ]

 

switch(config-router)# lsp-gen-interval level-1 500 500 500

LSP 発生に関する IS-IS スロットルを設定します。オプション パラメータは次のとおりです。

lsp-max-wait:トリガーから LSP 発生までの最大待ち時間。指定できる範囲は 500 ~ 65535 ミリ秒です。

lsp-initial-wait:トリガーから LSP 発生までの初期待ち時間。指定できる範囲は 50 ~ 65535 ミリ秒です。

lsp-second-wait:バックオフ時の LSP スロットルに使用する第 2 待ち時間。指定できる範囲は 50 ~ 65535 ミリ秒です。

max-lsp-lifetime lifetime

 

例:

switch(config-router)# max-lsp-lifetime 500

LSP の最大ライフタイムを秒数で設定します。範囲は 1 ~ 65535 です。デフォルトは 1200 です。

metric-style transition

 

例:

switch(config-router)# metric-style transition

IS-IS がナロー メトリック スタイルのタイプ、長さ、値(TLV)オブジェクトとワイドメトリック スタイルの TLV オブジェクトの両方を生成して受け取ることができるようにします。デフォルトではディセーブルになっています。

spf-interval [ level-1 | level-2 ] spf-max-wait [ spf-initial-wait spf-second-wait ]

 

switch(config-router)# spf-interval level-2 500 500 500

 

LSA 到着までのインターバルを設定します。オプション パラメータは次のとおりです。

lsp-max-wait:トリガーから SPF 計算までの最大待ち時間。指定できる範囲は 500 ~ 65535 ミリ秒です。

lsp-initial-wait:トリガーから SPF 計算までの初期待ち時間。指定できる範囲は 50 ~ 65535 ミリ秒です。

lsp-second-wait:バックオフ時の SPF 計算に使用する第 2 待ち時間。指定できる範囲は 50 ~ 65535 ミリ秒です。

ルータ アドレス コンフィギュレーション モードで次のオプション コマンドを使用できます。

 

コマンド
目的

adjacency-check

 

switch(config-router-af)# adjacency-check

隣接関係チェックを実行し、IS-IS インスタンスが同じアドレス ファミリをサポートするリモート IS-IS エンティティに限って隣接関係を形成していることを確認します。このコマンドは、デフォルトでイネーブルになっています。

IS-IS を調整するには、インターフェイス コンフィギュレーション モードで次のオプション コマンドを使用します。

 

コマンド
目的

isis csnp-interval seconds [ level-1 | level-2 ]

 

switch(config-if)# isis csnp-interval 20

IS-IS に Complete Sequence Number PDU(CNSP)インターバルを秒数で設定します。範囲は 1 ~ 65535 です。デフォルトは 10 です。

isis hello-interval seconds [ level-1 | level-2 ]

 

switch(config-if)# isis hello-interval 20

IS-IS に hello 間隔を秒数で設定します。範囲は 1 ~ 65535 です。デフォルトは 10 です。

isis hello-multiplier num [ level-1 | level-2 ]

 

switch(config-if)# isis hello-multiplier 20

ルータが隣接関係を破棄するまでに、ネイバーが見逃さなければならない IS-IS hello パケットの数を指定します。指定できる範囲は 3 ~ 1000 です。デフォルトは 3 です。

isis lsp-interval milliseconds

 

例:

switch(config-if)# isis lsp-interval 20

フラッディング時にこのインターフェイスで LSP が送信される間隔をミリ秒数で設定します。指定できる範囲は 10 ~ 65535 です。デフォルトは 33 です。

IS-IS 設定の確認

IS-IS の設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show isis [ instance-tag ] adjacency [interface] [detail | summary] [vrf vrf-name]

IS-IS の隣接関係を表示します。これらの統計情報を消去するには、 clear isis adjacency コマンドを使用します。

show isis [ instance-tag ] database [level-1 | level-2] [detail | summary] [LSP ID] [{ip | ipv6} prefix ip-prefix] | | [router-id router-id] | [adjacency node-id] | [ zero-sequence ]} [vrf vrf-name]

IS-IS LSP データベースを表示します。

show isis [ instance-tag ] hostname [vrf vrf-name]

ダイナミック ホスト交換情報を表示します。

show isis [instance-tag] interface [ brief | interface] [level-1 | level-2] [vrf vrf-name]

IS-IS インターフェイス情報を表示します。

show isis [instance-tag] mesh-group [ mesh-id ] [vrf vrf-name]

メッシュ グループ情報を表示します。

show isis [instance-tag] protocol [vrf vrf-name]

IS-IS プロトコルに関する情報を表示します。

show isis [instance-tag] {ip | ipv6 } redistribute route [ ip-address | summary ] [[ ip-prefix ] [longer-prefixes [summary]] [vrf vrf-name]

IS-IS のルート再配布情報を表示します。

show isis [instance-tag] {ip | ipv6 } route [ ip-address | summary ] [ ip-prefix [longer-prefixes [summary]] [ detail ] [vrf vrf-name]

IS-IS ルート テーブルを表示します。

show isis [instance-tag] rrm [ interface ] [vrf vrf-name]

IS-IS インターフェイスの再送信情報を表示します。

show isis [instance-tag] srm [ interface ] [vrf vrf-name]

IS-IS インターフェイスのフラッディング情報を表示します。

show isis [instance-tag] ssn [ interface ] [vrf vrf-name]

IS-IS インターフェイスの PSNP 情報を表示します。

show isis [instance-tag] {ip | ipv6 } summary-address [ ip-address ] | [ip-prefix] [vrf vrf-name]

IS-IS のサマリー アドレス情報を表示します。

show running-configuration isis

現在の実行中の IS-IS 設定を表示します。

show tech-support isis [ detail ]

IS-IS のテクニカル サポートの詳細情報を表示します。

IS-IS のモニタリング

IS-IS の統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show isis [ instance-tag ] adjacency [interface] [system-ID] [ detail ] [ summary ] [vrf vrf-name]

IS-IS 隣接関係の統計情報を表示します。

show isis [ instance-tag ] database [ level-1 | level-2 ] [ detail | summary ] [ lsip ] {[ adjacency id ] {ip | ipv6 } prefix prefix ] [ router-id id ] [zero-sequence]} [vrf vrf-name]

IS-IS データベースの統計情報を表示します。

show isis [instance-tag] statistics [interface] [vrf vrf-name]

IS-IS インターフェイスの統計情報を表示します。

show isis {ip | ipv6 } route-map statistics redistribute {bgp id | eigrp id | isis id | ospf id | rip id | static} [vrf vrf-name]

IS-IS 再配布の統計情報を表示します。

show isis route-map statistics distribute {level-1 | level-2} into {level-1 | level-2}} [vrf vrf-name]

レベル間で配布されたルートに関する、IS-IS 配布統計情報を表示します。

show isis [instance-tag] spf-log [detail] [vrf vrf-name]

IS-IS SPF 計算の統計情報を表示します。

show isis [instance-tag] traffic [ interface ] [vrf vrf-name]

IS-IS トラフィックの統計情報を表示します。

IS-IS 設定の統計情報を消去するには、次のいずれかの作業を行います。

 

コマンド
目的

clear isis [ instance-tag ] adjacency [ * | [interface] [system-id id ]] [vrf vrf-name]

IS-IS 隣接関係の統計情報を消去します。

clear isis {ip | ipv6 } route-map statistics redistribute {bgp id | direct | eigrp id | isis id | ospf id | rip id | static} [vrf vrf-name]

IS-IS 再配布の統計情報を消去します。

clear isis route-map statistics distribute {level-1 | level-2} into {level-1 | level-2} [vrf vrf-name]

レベル間で配布されたルートに関する、IS-IS 配布統計情報を消去します。

clear isis [instance-tag] statistics [ * | interface] [vrf vrf-name]

IS-IS インターフェイスの統計情報を消去します。

clear isis [instance-tag] traffic [ * | interface] [vrf vrf-name]

IS-IS トラフィックの統計情報を消去します。

IS-IS の設定例

IS-IS を設定する例を示します。

router isis Enterprise
 is-type level-1
 net 49.0001.0000.0000.0003.00
 graceful-restart
 address-family ipv4 unicast
  default-information originate
 
interface ethernet 2/1
 ip address 192.0.2.1/24
 isis circuit-type level-1
 ip router isis Enterprise

関連項目

ルート マップの詳細については、「Route Policy Manager の設定」 を参照してください。