Cisco Nexus 9000 シリーズ NX-OS VXLAN コンフィギュレーション ガイド リリース 6.x
VXLAN の設定
VXLAN の設定

VXLAN の設定

この章の内容は、次のとおりです。

VXLAN に関する情報

VXLAN の注意事項と制約事項

VXLAN には、次の注意事項と制限事項があります。

  • IGMP スヌーピングは VXLAN VLAN ではサポートされません。

  • デバイスは、同じ VXLAN または同じ転送マルチキャスト グループを共有する複数の VXLAN に対して、IP 一時デバイスかつ VXLAN 終端デバイスにすることはできません。

  • VXLAN に対する SPAN TX のカプセル化されたトラフィックは、レイヤ 3 アップリンク インターフェイスではサポートされません。

  • RACL は VXLAN トラフィックのレイヤ 3 のアップリンクでサポートされません。 出力 VACL のサポートは、ネットワークのカプセル化解除されたパケットが内部ペイロードでディレクションにアクセスするためには使用できません。

    ベスト プラクティスとして、ネットワーク ディレクションへのアクセスに対して、PACL/VACL を使用します。

  • QoS 分類は、レイヤ 3 アップリンク インターフェイス上でディレクションにアクセスするための、ネットワーク内の VXLAN トラフィックではサポートされません。

  • QoS バッファ ブースト機能は、VXLAN トラフィックには適用できません。

  • アップリンクは SVI インターフェイスにすることはできません。

    ベスト プラクティスとして、代わりにレイヤ 3 ポート/ポートチャネル アップリンク/ECMP アップリンクを使用してください。

  • SVI は、VXLAN 対応 VLAN ではサポートされません。

  • 1 つのスイッチには 1 つの NVE(Network Virtualization Edge)インターフェイスのみです。

  • SNMP は NVE インターフェイスではサポートされません。

VXLAN 展開の考慮事項

  • source-interface config コマンドを使用する場合は、ループバック アドレスが必要です。 ループバック アドレスは、ローカル VTEP IP を表します。

  • コアで IP マルチキャストのルーティングを確立するには、IP マルチキャストの設定、PIM の設定、および RP の設定が必要です。

  • VTEP to VTEP ユニキャストの到達可能性は、いずれかの IGP プロトコルを介して設定できます。

  • VPC の場合、ループバック インターフェイスには、プライマリ IP アドレスとセカンダリ IP アドレスの 2 つの IP アドレスがあります。

    プライマリ IP アドレスは一意で、レイヤ 3 プロトコルで使用されます。

    インターフェイス NVE は VTEP IP アドレスにセカンダリ IP アドレスを使用するため、ループバック上のセカンダリ IP アドレスは必須です。 セカンダリ IP アドレスは、vPC の両方のピアで同じにする必要があります。

  • VPC ピアで NVE(オーバーレイ)の設定が同じであることを確認するために、VPC の整合性チェックが行われます。

  • VPC ピアゲートウェイ機能は、両方のピアで有効にする必要があります。

  • VXLAN VLAN のデフォルト ゲートウェイは、別のアップストリーム ルータ デバイスでプロビジョニングする必要があります。

  • VXLAN のマルチキャスト トラフィックは、常に RPT 共有ツリーを使用する必要があります。


    (注)  


    ip pim spt-threshold infinity コマンドで VXLAN マルチキャスト グループを設定する必要があります。



    (注)  


    SPT スイッチオーバーは、VXLAN マルチキャスト トラフィックではサポートされません。


  • VXLAN 機能にはライセンスは必要ありません。

  • VTEP のマルチキャスト グループに対するランデブー ポイント(RP)は、サポート対象の設定です。 ただしベスト プラクティスとして、マルチキャスト グループの RP は、スパイン レイヤ/アップストリーム デバイス上で設定する必要があります。 すべてのマルチキャスト トラフィックは RP を通過するため、このトラフィックをスパイン レイヤ/アップストリーム デバイスへダイレクトすると、より効率的です。

VXLAN 展開に対する VPC の考慮事項

  • NVE を、レイヤ 3 プロトコルで必要な他のループバック アドレスとは別のループバック アドレスにバインドします。 VXLAN に対して専用のループバック アドレスを使用することがベスト プラクティスです。

  • NVE で使用されるループバック アドレスは、プライマリ IP アドレスとセカンダリ IP アドレスを持つように設定する必要があります。

    セカンダリ IP アドレスは、VxLAN のすべてのトラフィック、マルチキャスト SIP、およびユニキャスト SIP に対して使用されます。

  • VPC ピアは同じ設定にする必要があります。

    • VLAN から VN-segment への一貫したマッピング。

    • 同じループバック インターフェイスへの一貫した NVE1 バインディング

      • 同じセカンダリ IP アドレスを使用する。

      • 異なるプライマリ IP アドレスを使用する。

    • グループへの一貫した VNI マッピング。

  • マルチキャストでは、RP(ランデブー ポイント)から(S, G)join を受け取る VPC ノードが DF(指定フォワーダ)になります。 DF のノードでは、マルチキャストに対して encap および decap の両方のルートがインストールされます。

  • 非 DF スイッチへハッシュされる VPC 上のマルチキャスト トラフィックは MCT(マルチシャーシ EtherChannel トランク)を通過し、DF ノードでカプセル化されます。

  • MCT が shut の場合、VPC セカンダリのループバック アドレスは停止し、ステータスは Admin Shut になります。 これは、アップストリーム上でループバックへのルートが取り消され、アップストリームがすべてのトラフィックを VPC プライマリへ転送できるようにするために行われます。

    VPC セカンダリに接続されているオーファンでは、MCT が shut である間にトラフィックの損失が発生することに注意してください。 これは、従来の VPC セットアップのセカンダリ VPC におけるレイヤ 2 オーファンに類似しています。

  • MCT が no-shut の場合、NVE ループバック アドレスが再度提示されます。ルートはアドバタイズされたアップストリームとなり、トラフィックを誘導します。

VXLAN 展開に対するネットワークの考慮事項

  • 転送ネットワークの MTU サイズ

    MAC-to-UDP のカプセル化に起因して、VXLAN は元のフレームに 50 バイトのオーバーヘッドを導入しています。 このため、転送ネットワークの最大転送単位(MTU)は 50 バイト増やす必要があります。 オーバーレイで 1500 バイトの MTU を使用する場合、転送ネットワークは、最低でも 1550 バイトのパケットに対応できるように設定する必要があります。 オーバーレイ アプリケーションで 1500 バイトを超える フレーム サイズを頻繁に使用する場合は、転送ネットワークでジャンボ フレームのサポートが必要になります。

  • 転送ネットワークの ECMP および LACP ハッシュ アルゴリズム

    前のセクションで説明したように、Cisco Nexus 9000 シリーズ スイッチは、転送ネットワークの ECMP および LACP ハッシュに対する送信元 UDP ポートのエントロピー レベルを導入しています。 この実装を強化する方法として、転送ネットワークは ECMP または LACP のハッシュ アルゴリズムを使用します。これらのアルゴリズムはハッシュの入力として UDP 送信元ポートを使用し、これにより VXLAN のカプセル化されたトラフィックに対して最適なロード シェアリングを実現します。

  • マルチキャスト グループの拡張

    Cisco Nexus 9000 シリーズ スイッチの VXLAN の実装では、ブロードキャスト、未知のユニキャスト、およびマルチキャスト トラフィックの転送に対してマルチキャスト トンネルを使用します。 マルチキャスト転送を提供するには、1 つの VXLAN セグメントを 1 つの IP マルチキャスト グループにマッピングする方法が理想的です。 ただし、複数の VXLAN セグメントは、コア ネットワーク内で 1 つの IP マルチキャスト グループを共有することが可能です。 VXLAN は、ヘッダーの 24 ビット VNID フィールドを使用して最大 1600 万個の論理レイヤ 2 セグメントをサポートできます。 VXLAN セグメントと IP マルチキャスト グループ間の 1 対 1 マッピングにより、VXLAN のセグメント数の増加に起因して、必要なマルチキャスト アドレス空間とコア ネットワーク デバイスのフォワーディング ステートの量がパラレルに増加します。 ある時点で、転送ネットワークにおけるマルチキャスト スケーラビリティが問題になることがあります。 この場合には、複数の VXLAN セグメントを 1 つのマルチキャスト グループにマッピングすると、コア デバイス上のマルチキャスト コントロール プレーンのリソースが節約され、目的の VXLAN のスケーラビリティを実現できるようになります。 ただしこのマッピングは、次善のマルチキャスト転送を犠牲にして実現されます。 1 つのテナントのマルチキャスト グループに転送されたパケットは、同じマルチキャスト グループを共有する他のテナントの VTEP に送信されます。 このため、マルチキャスト データのプレーン リソースの使用が非効率的になります。 したがってこのソリューションは、コントロール プレーンのスケーラビリティとデータ プレーンの効率性との二者択一になります。

    次善のマルチキャスト複製と転送を実現しているにも関わらず、複数テナントの VXLAN ネットワークで 1 つのマルチキャスト グループを共有することで、テナント ネットワーク間のレイヤ 2 分離に影響をもたらすことはありません。 マルチキャスト グループからカプセル化されたパケットを受信すると、VTEP はパケットの VXLAN ヘッダー内の VNID をチェックし、検証します。 VTEP は、不明な VNID が見つかるとパケットを廃棄します。 VNID が VTEP のローカル VXLAN VNID のいずれかに一致する場合のみ、パケットを VXLAN セグメントに転送します。 別のテナントのネットワークはパケットを受信しません。 したがって、VXLAN セグメント間の分離は低下しません。

転送ネットワークの考慮事項

転送ネットワークの設定に関する考慮事項は次のとおりです。

  • VTEP デバイス:

    • IP マルチキャストを有効にして、設定します。

    • /32 IP アドレスで、ループバック インターフェイスを作成および設定します。

      (vPC VTEP では、プライマリおよびセカンダリの /32 IP アドレスを設定する必要があります)

    • ループバック インターフェイスで IP マルチキャストを有効にします。

    • 転送ネットワークで実行されるルーティング プロトコルを通じて、ループバック インターフェイス /32 アドレスをアドバタイズします。

    • アップリンクの出力物理インターフェイス上で IP マルチキャストを有効にします。

  • 転送ネットワーク全体:

    • IP マルチキャストを有効にして、設定します。

VXLAN の設定

VXLAN のイネーブル化

手順の概要

    1.    switch# configure terminal

    2.    switch(config)# [no] feature nv overlay

    3.    switch (config)# [no] feature vn-segment-vlan-based

    4.    (任意) switch(config)# copy running-config startup-config


手順の詳細
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal 

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2switch(config)# [no] feature nv overlay 

    VXLAN 機能をイネーブルにします。

     
    ステップ 3 switch (config)# [no] feature vn-segment-vlan-based  

    すべての VXLAN ブリッジ ドメインにグローバル モードを設定します。

     
    ステップ 4switch(config)# copy running-config startup-config  (任意)

    リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

     

    VLAN から VXLAN VNI へのマッピング

    手順の概要

      1.    switch# configure terminal

      2.    switch(config)# vlan vlan-id

      3.    switch(config-vlan)# vn-segment vnid

      4.    switch(config-vlan)# exit


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal 

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2switch(config)# vlan vlan-id  

      VLAN を指定します。

       
      ステップ 3switch(config-vlan)# vn-segment vnid  

      VXLAN VNID(仮想ネットワーク ID)を指定します

       
      ステップ 4switch(config-vlan)# exit  

      コンフィギュレーション モードを終了します。

       

      NVE インターフェイスと関連 VNI の作成および設定

      NVE インターフェイスは、VXLAN トンネルの終端となるオーバーレイ インターフェイスです。

      次のように、NVE(オーバーレイ)インターフェイスを作成および設定できます。

      手順の概要

        1.    switch# configure terminal

        2.    switch(config)# interface nve x

        3.    switch(config-if-nve)# source-interface src-if

        4.    switch(config-if-nve-si)# member vni [range] [mcast-group start-addr [end addr]]


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1switch# configure terminal 

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2switch(config)# interface nve x  

        VXLAN トンネルの終端となる VXLAN オーバーレイ インターフェイスを作成します。

        (注)     

        スイッチでは 1 つの NVE インターフェイスのみ使用できます。

         
        ステップ 3switch(config-if-nve)# source-interface src-if  

        送信元インターフェイスは、有効な /32 IP アドレスを持つスイッチ上に設定されているループバック インターフェイスにする必要があります。 この /32 IP アドレスは、転送ネットワークの一時デバイスおよびリモート VTEP によって認識される必要があります。 これは、転送ネットワークのダイナミック ルーティング プロトコルを介してアドレスを通知することによって、実現されます。

         
        ステップ 4switch(config-if-nve-si)# member vni [range] [mcast-group start-addr [end addr]]  

        VXLAN VNI (仮想ネットワーク ID)を NVE インターフェイスに関連付け、マルチキャスト グループを VNI に割り当てます。

         

        VXLANs のディセーブル化

        手順の概要

          1.    switch# configure terminal

          2.    switch (config)# no feature vn-segment-vlan-based

          3.    switch(config)# no feature nv overlay

          4.    (任意) switch(config)# copy running-config startup-config


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1switch# configure terminal 

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2 switch (config)# no feature vn-segment-vlan-based  

          すべての VXLAN ブリッジ ドメインのグローバル モードをディセーブルにします。

           
          ステップ 3switch(config)# no feature nv overlay 

          VXLAN 機能をディセーブルにします。

           
          ステップ 4switch(config)# copy running-config startup-config  (任意)

          リブートおよびリスタート時に実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして、変更を永続的に保存します。

           

          VXLAN 設定の確認

          VXLAN の設定情報を表示するには、次のいずれかのコマンドを入力します。

          コマンド

          目的

          show tech-support vxlan

          関連する VXLAN のテクニカル サポート情報を表示します。

          show logging level nve

          ロギング レベルを表示します。

          show tech-support nve

          関連する NVE のテクニカル サポート情報を表示します。

          show run interface nve

          NVE オーバーレイ インターフェイス コンフィギュレーションを表示します。

          show nve interface

          NVE オーバーレイ インターフェイス ステータスを表示します。

          show nve peers

          NVE ピアのステータスを表示します。

          show nve peers peer_IP_address interface interface_ID counters

          NVE ピアごとの統計情報を表示します。

          clear nve peers peer_IP_address interface interface_ID counters

          NVE ピアごとの統計情報をクリアします。

          show nve vni

          VXLAN VNI ステータスを表示します。

          show nve vni vni_number counters

          VNI ごとの統計情報を表示します。

          clear nve vni vni_number counters

          VNI ごとの統計情報をクリアします。

          show nve vxlan-params

          VXLAN の宛先や UDP ポートなどの VXLAN パラメータを表示します。

          show nve internal

          NVE オーバーレイ内部情報を表示します。

          show nve internal platform interface nve 1 detail

          NVE オーバーレイの内部詳細情報を表示します。

          VXLAN ブリッジングの設定の例

          • ループバック インターフェイスの設定およびルーティング プロトコルの設定の例

            図 1. VTEP 用 VXLAN トポロジ



            • Nexus 9000 VTEP-1 の設定:

              switch-vtep-1(config)# feature ospf 
              switch-vtep-1(config)# feature pim 
              switch-vtep-1(config)# router ospf 1 
              switch-vtep-1(config-router)# router-id 100.100.100.1 
              switch-vtep-1(config)# ip pim rp-address 10.1.1.1 group-list 224.0.0.0/4 
              switch-vtep-1(config)# interface loopback0 
              switch-vtep-1(config-if)# ip address 100.100.100.1/32 
              switch-vtep-1(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-1(config-if)# ip pim sparse-mode 
              switch-vtep-1(config)# interface e2/1 
              switch-vtep-1(config-if)# ip address 20.1.1.1/30 
              switch-vtep-1(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-1(config-if)# ip pim sparse-mode 
              
              switch-vtep-1(config)# feature nv overlay
              switch-vtep-1(config)# feature vn-segment-vlan-based 
              switch-vtep-1(config)# interface e1/1
              switch-vtep-1(config-if)# switchport
              switch-vtep-1(config-if)# switchport access vlan 10
              switch-vtep-1(config-if)# no shutdown
              switch-vtep-1(config)# interface nve1
              switch-vtep-1(config-if)# no shutdown
              switch-vtep-1(config-if)# source-interface loopback0 
               
              switch-vtep-1(config-if)# member vni 10000 mcast-group 230.1.1.1 
              switch-vtep-1(config)# vlan 10
              switch-vtep-1(config-vlan)# vn-segment 10000 
              switch-vtep-1(config-vlan)# exit
              
            • Nexus 9000 VTEP-2 の設定:

              switch-vtep-2(config)# feature ospf 
              switch-vtep-2(config)# feature pim 
              switch-vtep-2(config)# router ospf 1 
              switch-vtep-2(config-router)# router-id 100.100.100.2
              switch-vtep-2(config)# ip pim rp-address 10.1.1.1 group-list 224.0.0.0/4 
              switch-vtep-2(config)# interface loopback0 
              switch-vtep-2(config-if)# ip address 100.100.100.2/32 
              switch-vtep-2(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-2(config-if)# ip pim sparse-mode 
              switch-vtep-2(config)# interface e2/1 
              switch-vtep-2(config-if)# ip address 30.1.1.1/30 
              switch-vtep-2(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-2(config-if)# ip pim sparse-mode 
              
              switch-vtep-2(config)# feature nv overlay
              switch-vtep-2(config)# feature vn-segment-vlan-based 
              switch-vtep-2(config)# interface e1/1
              switch-vtep-2(config-if)# switchport
              switch-vtep-2(config-if)# switchport access vlan 10
              switch-vtep-2(config-if)# no shutdown
              switch-vtep-2(config)# interface nve1
              switch-vtep-2(config-if)# no shutdown
              switch-vtep-2(config-if)# source-interface loopback0 
               
              switch-vtep-2(config-if)# member vni 10000 mcast-group 230.1.1.1 
              switch-vtep-2(config)# vlan 10
              switch-vtep-2(config-vlan)# vn-segment 10000 
              switch-vtep-2(config-vlan)# exit
          • VXLAN の設定結果の例:

            switch(config)# show nve vni 
            Interface          VNI        Multicast-group   VNI State
            ----------------   --------   ---------------   ---------
            nve1               10000      230.1.1.1          up      
             
            switch(config)# show nve peers 
            Interface          Peer-IP           VNI        Up Time
            ----------------   ---------------   --------   -----------
            nve1               100.100.100.2     10000      06:13:07   
             
            switch(config)# show mac address-table 
            Legend: 
                    * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
                    age - seconds since last seen,+ - primary entry using vPC Peer-Link,
                    (T) - True, (F) - False
               VLAN     MAC Address      Type      age     Secure NTFY Ports
            ---------+-----------------+--------+---------+------+----+------------------
            *  100     0000.bb01.0001   dynamic  0         F      F    nve1
            *  100     0000.bb01.0002   dynamic  0         F      F    nve1
            *  100     0000.bb01.0003   dynamic  0         F      F    nve1
            *  100     0000.bb01.0004   dynamic  0         F      F    nve1
            *  100     0000.bb01.0005   dynamic  0         F      F    nve1
            *  100     0000.bb01.0006   dynamic  0         F      F    nve1
            
            
            
          • vPC VTEP の設定では、ループバック アドレスでセカンダリ IP が必要です。

            vPC VTEP の設定例:

            図 2. vPC VTEP 用 VXLAN トポロジ



            • Nexus 9000 VTEP-1 の設定:

              switch-vtep-1(config)# feature nv overlay
              switch-vtep-1(config)# feature vn-segment-vlan-based 
              
              switch-vtep-1(config)# feature ospf 
              switch-vtep-1(config)# feature pim 
              switch-vtep-1(config)# router ospf 1 
              switch-vtep-1(config-router)# router-id 200.200.200.1
              switch-vtep-1(config)# ip pim rp-address 10.1.1.1 group-list 224.0.0.0/4 
              switch-vtep-1(config)# interface loopback0 
              switch-vtep-1(config-if)# ip address 200.200.200.1/32
              switch-vtep-1(config-if)# ip address 100.100.100.1/32 secondary
              switch-vtep-1(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-1(config-if)# ip pim sparse-mode 
              switch-vtep-1(config)# interface e2/1 
              switch-vtep-1(config-if)# ip address 20.1.1.1/30 
              switch-vtep-1(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-1(config-if)# ip pim sparse-mode 
              
              switch-vtep-1(config)# interface port-channel 10
              switch-vtep-1(config-if)# vpc 10
              switch-vtep-1(config-if)# switchport
              switch-vtep-1(config-if)# switchport mode access
              switch-vtep-1(config-if)# switchport access vlan 10
              switch-vtep-1(config-if)# no shutdown
              switch-vtep-1(config)# interface e1/1
              switch-vtep-1(config-if)# channel-group 10 mode active
              switch-vtep-1(config-if)# no shutdown
              
              switch-vtep-1(config)# interface nve1
              switch-vtep-1(config-if)# no shutdown
              switch-vtep-1(config-if)# source-interface loopback0 
               
              switch-vtep-1(config-if)# member vni 10000 mcast-group 230.1.1.1 
              switch-vtep-1(config)# vlan 10
              switch-vtep-1(config-vlan)# vn-segment 10000
              switch-vtep-1(config-vlan)# exit 
            • Nexus 9000 VTEP-2 の設定:

              switch-vtep-2(config)# feature nv overlay
              switch-vtep-2(config)# feature vn-segment-vlan-based 
              
              switch-vtep-2(config)# feature ospf 
              switch-vtep-2(config)# feature pim 
              switch-vtep-2(config)# router ospf 1 
              switch-vtep-2(config-router)# router-id 200.200.200.2 
              switch-vtep-2(config)# ip pim rp-address 10.1.1.1 group-list 224.0.0.0/4 
              switch-vtep-2(config)# interface loopback0 
              switch-vtep-2(config-if)# ip address 200.200.200.2/32
              switch-vtep-2(config-if)# ip address 100.100.100.1/32 secondary
              switch-vtep-2(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-2(config-if)# ip pim sparse-mode 
              switch-vtep-2(config)# interface e2/1 
              switch-vtep-2(config-if)# ip address 20.1.1.5/30 
              switch-vtep-2(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-2(config-if)# ip pim sparse-mode 
              
              switch-vtep-2(config)# interface port-channel 10
              switch-vtep-2(config-if)# vpc 10
              switch-vtep-2(config-if)# switchport
              switch-vtep-2(config-if)# switchport mode access
              switch-vtep-2(config-if)# switchport access vlan 10
              switch-vtep-2(config-if)# no shutdown
              switch-vtep-2(config)# interface e1/1
              switch-vtep-2(config-if)# channel-group 10 mode active
              switch-vtep-2(config-if)# no shutdown
              switch-vtep-2(config)# interface nve1
              switch-vtep-2(config-if)# no shutdown
              switch-vtep-2(config-if)# source-interface loopback0 
               
              switch-vtep-2(config-if)# member vni 10000 mcast-group 230.1.1.1 
              switch-vtep-2(config)# vlan 10
              switch-vtep-2(config-vlan)# vn-segment 10000
              switch-vtep-2(config-vlan)# exit 
            • Nexus 9000 VTEP-3 の設定:

              switch-vtep-3(config)# feature nv overlay
              switch-vtep-3(config)# feature vn-segment-vlan-based 
              
              switch-vtep-3(config)# feature ospf 
              switch-vtep-3(config)# feature pim 
              switch-vtep-3(config)# router ospf 1 
              switch-vtep-3(config-router)# router-id 100.100.100.2 
              switch-vtep-3(config)# ip pim rp-address 10.1.1.1 group-list 224.0.0.0/4 
              switch-vtep-3(config)# interface loopback0 
              switch-vtep-3(config-if)# ip address 100.100.100.2/32
              switch-vtep-3(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-3(config-if)# ip pim sparse-mode 
              switch-vtep-3(config)# interface e2/1 
              switch-vtep-3(config-if)# ip address 30.1.1.1/30 
              switch-vtep-3(config-if)# ip router ospf 1 area 0.0.0.0 
              switch-vtep-3(config-if)# ip pim sparse-mode 
              
               
              switch-vtep-3(config)# interface e1/1
              switch-vtep-3(config-if)# switchport
              switch-vtep-3(config-if)# switchport access vlan 10
              switch-vtep-3(config-if)# no shutdown
              switch-vtep-3(config)# interface nve1
              switch-vtep-3(config-if)# no shutdown
              switch-vtep-3(config-if)# source-interface loopback0 
               
              switch-vtep-3(config-if)# member vni 10000 mcast-group 230.1.1.1 
              switch-vtep-3(config)# vlan 10
              switch-vtep-3(config-vlan)# vn-segment 10000
              switch-vtep-3(config-vlan)# exit 

            (注)  


            セカンダリ IP は、VXLAN 用にエミュレートされた VTEP で使用されます。



            (注)  


            VPC プライマリと VPC セカンダリの間ですべての設定が同じであることを確認します。