Cisco Nexus 9000 シリーズ NX-OS システム管理コンフィギュレーション ガイド リリース 6.x
Session Manager の設定
Session Manager の設定

Session Manager の設定

この章では、Cisco NX-OS デバイスで Session Manager を設定する方法について説明します。

この章の内容は、次のとおりです。

Session Manager について

Session Manager を使用すると、バッチ モードで設定変更を実装できます。 Session Manager は次のフェーズで機能します。

  • コンフィギュレーション セッション:Session Manager モードで実行するコマンドのリストを作成します。
  • 検証:設定の基本的なセマンティクス検査を行います。 Cisco NX-OS は、設定の一部でセマンティクス検査が失敗した場合にエラーを返します。
  • 確認:既存のハードウェア/ソフトウェア構成およびリソースに基づいて、設定を全体として確認します。 Cisco NX-OS は、設定がこの確認フェーズで合格しなかった場合にエラーを返します。
  • コミット:Cisco NX-OS はコンフィギュレーション全体を確認して、デバイスに対する変更を実行します。 障害が発生した場合、Cisco NX-OS は元の設定に戻ります。
  • 打ち切り:実装しないで設定の変更を破棄します。

任意で、変更をコミットしないでコンフィギュレーション セッションを終了できます。 また、コンフィギュレーション セッションを保存することもできます。

High Availability(高可用性)

Session Manager セッションは、スーパーバイザのスイッチオーバー後も引き続き使用できます。 セッションはソフトウェア リロード後までは維持されません。

Session Manager のライセンス要件

製品

ライセンス要件

Cisco NX-OS

Session Manager にライセンスは不要です。 ライセンス パッケージに含まれていない機能は nx-os イメージにバンドルされており、無料で提供されます。 Cisco NX-OS ライセンス方式の詳細については、Cisco NX-OS Licensing Guide』を参照してください。

Session Manager の前提条件

使用する予定の Session Manager コマンドをサポートする権限があることを確認してください。

Session Manager の注意事項および制約事項

Session Manager には、次の注意事項および制限事項があります。

  • Session Manager は、アクセス コントロール リスト(ACL)および Quality of Service(QoS)機能だけをサポートします。
  • 作成できるコンフィギュレーション セッションの最大数は 32 です。
  • すべてのセッションで設定できるコマンドの最大数は 20,000 です。
  • 複数のコンフィギュレーション セッションまたはコンフィギュレーション ターミナル モードで、コンフィギュレーション コマンドを同時に実行することはできません。 パラレル コンフィギュレーション(1 つのコンフィギュレーション セッションと 1 つのコンフィギュレーション ターミナルのようなもの)は、コンフィギュレーション セッションで確認または検証が失敗する原因になることがあります。
  • コンフィギュレーション セッションであるインターフェイスを設定中に、そのインターフェイスをリロードすると、そのときにインターフェイスがデバイス上になくても Session Manager コマンドを受け取ることができます。

Session Manager の設定


(注)  


Cisco NX-OS コマンドは Cisco IOS コマンドと異なる場合があるので注意してください。

セッションの作成

作成できるコンフィギュレーション セッションの最大数は 32 です。

手順
     コマンドまたはアクション目的
    ステップ 1 configure session name


    例:
    switch# configure session myACLs
    switch(config-s)#
     

    コンフィギュレーション セッションを作成し、セッション コンフィギュレーション モードを開始します。 名前は任意の英数字ストリングです。

    セッションの内容を表示します。

     
    ステップ 2 show configuration session [name]


    例:
    switch(config-s)# show configuration session myACLs
     
    (任意)

    セッションの内容を表示します。

     
    ステップ 3 save location


    例:
    switch(config-s)# save bootflash:sessions/myACLs
    
     
    (任意)

    セッションをファイルに保存します。 保管場所には bootflash:、slot0:、または volatile: を指定できます。

     

    セッションでの ACL の設定

    コンフィギュレーション セッションで ACL を設定できます。

    手順
       コマンドまたはアクション目的
      ステップ 1 configure session name


      例:
      switch# configure session myacls
      switch(config-s)#
       

      コンフィギュレーション セッションを作成し、セッション コンフィギュレーション モードを開始します。 名前は任意の英数字ストリングです。

       
      ステップ 2 ip access-list name


      例:
      switch(config-s)# ip access-list acl1
      switch(config-s-acl)#
       

      ACL を作成し、その ACL のコンフィギュレーション モードを開始します。

       
      ステップ 3 permit protocol source destination


      例:
      switch(config-s-acl)# permit tcp any any
       
      (任意)

      ACL に許可文を追加します。

       
      ステップ 4 interface interface-type number


      例:
      switch(config-s-acl)# interface e 2/1
      switch(config-s-if)#
       

      インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 5 ip access-group name {in | out}


      例:
      switch(config-s-acl)# interface e 2/1
      switch(config-s-if)#
       

      アクセス グループを適用するトラフィックの方向を指定します。

       
      ステップ 6 show configuration session [name]


      例:
      switch(config-s)# show configuration session myacls
       
      (任意)

      セッションの内容を表示します。

       

      セッションの確認

      セッション モードで次のコマンドを使用して、セッションを確認します。

      コマンド

      目的

      verify [verbose]

      例:

      switch(config-s)# verify

      既存のハードウェアおよびソフトウェアのコンフィギュレーションおよびリソースに基づいて、コンフィギュレーション全体を確認します。 Cisco NX-OS は、設定がこの確認で合格しなかった場合にエラーを返します。

      セッションのコミット

      セッション モードで次のコマンドを使用して、セッションをコミットします。

      コマンド

      目的

      commit [verbose]

      例:

      switch(config-s)# commit

      現在のセッションで行われたコンフィギュレーションの変更を検証し、有効な変更をデバイスに適用します。 検証に失敗した場合、Cisco NX-OS は元の設定に戻ります。

      セッションの保存

      セッション モードで次のコマンドを使用して、セッションを保存します。

      コマンド

      目的

      save location

      例:

      switch(config-s)# save bootflash:sessions/myACLs

      (任意)セッションをファイルに保存します。 保管場所には bootflash:、slot0:、または volatile: を指定できます。

      セッションの廃棄

      セッション モードで次のコマンドを使用して、セッションを廃棄します。

      コマンド

      目的

      abort

      例:

      switch(config-s)# abort
      switch#

      コマンドを適用しないで、コンフィギュレーション セッションを廃棄します。

      Session Manager 設定の確認

      Session Manager のコンフィギュレーション情報を表示するには、次の作業のいずれかを行います。

      コマンド

      目的

      show configuration session [name]

      コンフィギュレーション ファイルの内容を表示します。

      show configuration session status [name]

      コンフィギュレーション セッションのステータスを表示します。

      show configuration session summary

      すべてのコンフィギュレーション セッションのサマリーを表示します。

      Session Manager のコンフィギュレーション例

      Session Manager を使用して ACL コンフィギュレーションを作成し、コミットする例を示します。

      switch# configure session ACL_tcp_in
      Config Session started, Session ID is 1
      Enter configuration commands, one per line. End with CNTL/Z.
      switch(config-s)# ip access-list ACL1
      switch(config-s-acl)# permit tcp any any
      switch(config)# interface e 7/1
      switch(config-if)# ip access-group ACL1 in
      switch(config-if)# exit
      switch(config)# exit
      switch# config session ACL_tcp_in
      Config Session started, Session ID is 1
      Enter configuration commands, one per line. End with CNTL/Z.
      switch(config-s)# verify
      Verification Successful
      switch(config-s)# commit
      Commit Successful
      switch#
      
      

      その他の関連資料

      関連資料

      関連項目 参照先
      コンフィギュレーション ファイル 『Cisco Nexus 9000 Series NX-OS Fundamentals Configuration Guide』