Cisco Nexus 9000 シリーズ NX-OS ユニキャスト ルーティング コンフィギュレーション ガイド リリース 6.x
RIP の設定
RIP の設定
発行日;2014/01/22 | 英語版ドキュメント(2013/11/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

RIP の設定

RIP について

RIP の概要

RIPv2 の認証

Split Horizon

ルート フィルタリング

ルート集約

ルートの再配布

ロード バランシング

ハイ アベイラビリティ

仮想化のサポート

RIP のライセンス要件

RIP の前提条件

注意事項と制約事項

デフォルト設定

RIP の設定

RIP のイネーブル化

RIP インスタンスの作成

RIP インスタンスの再起動

インターフェイス上での RIP の設定

RIP 認証の設定

パッシブ インターフェイスの設定

ポイズン リバースを指定したスプリット ホライズンの設定

ルート集約の設定

ルートの再配布の設定

Cisco IOS RIP との互換性のため、Cisco NX-OS RIP を設定

仮想化の設定

RIP の調整

RIP コンフィギュレーションの確認

RIP 統計情報の表示

RIP の設定例

関連項目

RIP の設定

この章では、Cisco NX-OS デバイスで Routing Information Protocol(RIP)を設定する方法について説明します。

この章は、次の項で構成されています。

「RIP について」

「RIP のライセンス要件」

「RIP の前提条件」

「注意事項と制約事項」

「デフォルト設定」

「RIP の設定」

「RIP コンフィギュレーションの確認」

「RIP 統計情報の表示」

「RIP の設定例」

「関連項目」

RIP について

この項では、次のトピックについて取り上げます。

「RIP の概要」

「RIPv2 の認証」

「Split Horizon」

「ルート フィルタリング」

「ルート集約」

「ルートの再配布」

「ロード バランシング」

「ハイ アベイラビリティ」

「仮想化のサポート」

RIP の概要

RIP は ユーザ データグラム プロトコル(UDP)データ パケットを使用して、小規模なインターネットワークでルーティング情報を交換します。RIPv2 は IPv4 をサポートしています。RIPv2 は RIPv2 プロトコルがサポートするオプションの認証機能を使用します(「RIPv2 の認証」を参照)。


) Cisco NX-OS では RIP 用に IPv6 をサポートしていません。


RIP では次の 2 種類のメッセージを使用します。

要求:他の RIP 対応ルータからのルート アップデートを要求するためにマルチキャスト アドレス 224.0.0.9 に送信されます。

応答:デフォルトでは 30 秒間隔で送信されます(「RIP コンフィギュレーションの確認」を参照)。ルータも、要求メッセージの受信後に応答メッセージを送信します。応答メッセージには、RIP ルート テーブル全体が含まれます。RIP ルーティング テーブルが 1 つの応答パケットに収まらない場合、RIP は 1 つの要求に対して複数の応答パケットを送信します。

RIP はルーティング メトリックとして、 ホップ カウント を使用します ホップ カウントは、パケットが宛先に到達するまでに、通過できるルータの数です。直接接続されたネットワークのメトリックは 1 です。到達不能なネットワークのメトリックは 16 です。RIP はこのようにメトリックの範囲が小さいので、大規模なネットワークに適したルーティング プロトコルではありません。

RIPv2 の認証

RIP メッセージに認証を設定して、ネットワークでの不正な、または無効なルーティング更新を防止できます。Cisco NX-OS は簡易パスワードまたは MD5 認証ダイジェストをサポートしています。

認証キーのキーチェーン管理を使用することによって、インターフェイスごとに RIP 認証を設定できます。キーチェーン管理によって、MD5 認証ダイジェストまたは単純テキスト パスワード認証で使用される認証キーの変更を制御できます。キーチェーン作成の詳細については、『 Cisco Nexus 9000 Series NX-OS Security Configuration Guide 』を参照してください。

MD5 認証ダイジェストを使用するには、ローカル ルータとすべてのリモート RIP ネイバーが共有するパスワードを設定します。Cisco NX-OS は、そのメッセージ自体と暗号化されたパスワードに基づいて MD5 一方向メッセージ ダイジェストを作成し、このダイジェストを RIP メッセージ(要求または応答)とともに送信します。受信側の RIP ネイバーは、同じ暗号パスワードを使用して、ダイジェストを検証します。メッセージが変更されていない場合は、計算が一致し、RIP メッセージは有効と見なされます。

MD5 認証ダイジェストの場合はさらに、ネットワークでメッセージが再送されないように、各 RIP メッセージにシーケンス番号が組み込まれます。

Split Horizon

スプリット ホライズンを使用すると、ルートを学習したインターフェイスからは、RIP がルートをアドバタイズしないようにできます。

スプリット ホライズンは、RIP アップデートおよびクエリー パケットの送信を制御する方法です。インターフェイス上でスプリット ホライズンがイネーブルの場合、Cisco NX-OS はそのインターフェイスから学習した宛先にはアップデート パケットを送信しません。この方法でアップデート パケットを制御すると、ルーティング ループの発生する可能性が小さくなります。

ポイズン リバースを指定してスプリット ホライズンを使用すると、ルートを学習したインターフェイス経由では到達不能であると RIP が学習したルートをアドバタイズするように、インターフェイスを設定できます。図 11-1 に、ポイズン リバースをイネーブルにしてスプリット ホライズンを指定した、RIP ネットワークの例を示します。

図 11-1 スプリット ホライズン ポイズン リバースを指定した RIP

 

ルータ C はルート X について学習し、そのルートをルータ B にアドバタイズします。Router B は次に、ルート X を Router A にアドバタイズしますが、Router C には、ルート X 到達不能アップデートを戻します。

デフォルトでは、スプリット ホライズンはすべてのインターフェイスでイネーブルになっています。

ルート フィルタリング

RIP 対応インターフェイス上でルート ポリシーを設定すると、RIP アップデートをフィルタリングできます。Cisco NX-OS は、ルート ポリシーで許可されたルートだけを使用して、ルート テーブルをアップデートします。

ルート集約

指定したインターフェイスに、複数のサマリー集約アドレスを設定できます。ルート集約を使用すると、固有性の強い一連のアドレスをすべての固有アドレスを代表する 1 つのアドレスに置き換えることによって、ルート テーブルを簡素化できます。たとえば、10.1.1.0/24、10.1.2.0/24、および 10.1.3.0/24 というアドレスを 1 つの集約アドレス 10.1.0.0/16 に置き換えることができます。

RIP はルーティング テーブルに含まれている固有性の強いルートが多いほど、固有性の強いルートの最大メトリックと同じメトリックのインターフェイスからのサマリー アドレスをアドバタイズします。


) Cisco NX-OS は、自動ルート集約をサポートしていません。


ルートの再配布

RIP を使用すると、スタティック ルートまたは他のプロトコルからのルートを再配布できます。再配布を指定したルート マップを設定して、どのルートが RIP に渡されるかを制御する必要があります。ルート ポリシーを使用すると、宛先、送信元プロトコル、ルート タイプ、ルート タグなどの属性に基づいて、ルートをフィルタリングできます。詳細については、「Route Policy Manager の設定」 を参照してください。

RIP ルーティング ドメインにルートを再配布しても、デフォルトでは Cisco NX-OS がそのつど、RIP ルーティング ドメインにデフォルト ルートを再配布することはありません。RIP への デフォルト ルート を発生させ、ルート ポリシーでそのルートを制御できます。

RIP にインポートされたすべてのルートに使用する、デフォルトのメトリックも設定できます。

ロード バランシング

ロード バランシングを使用すると、ルータによって、宛先アドレスから同じ距離にあるすべてのルータ ネットワーク ポートにトラフィックが分散されます。ロード バランシングは、ネットワーク セグメントの使用率を向上させ、有効ネットワーク帯域幅を増加させます。

Cisco NX-OS は、RIP ルート テーブルおよびユニキャスト RIB 中の 16 までの等コスト パスを使用する等コスト マルチパス(ECMP)機能をサポートしています。これらのパスの一部または全部でトラフィックのロード バランシングが行われるように、RIP を設定できます。

ハイ アベイラビリティ

Cisco NX-OS は、RIP のステートレス リスタートをサポートします。リブートまたはスーパーバイザ スイッチオーバー後に、Cisco NX-OS が実行コンフィギュレーションを適用し、RIP がただちに要求パケットを送信して、ルーティング テーブルに再入力します。

仮想化のサポート

Cisco NX-OS は、同一システム上で動作する複数の RIP プロトコル インスタンスをサポートします。RIP は、仮想ルーティングおよび転送(VRF)インスタンスをサポートします。

RIP のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

RIP にライセンスは不要です。ライセンス パッケージに含まれていない機能は NX-OS イメージにバンドルされており、無料で提供されます。NX-OS ライセンス方式の詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

RIP の前提条件

RIP を使用するには、次の前提条件を満たしている必要があります。

RIP をイネーブルにします(「RIP のイネーブル化」を参照)。

注意事項と制約事項

RIP には、次の注意事項および制限事項があります。

Cisco NX-OS は、RIPv1 をサポートしません。RIPv1 パケットを受信した Cisco NX-OS は、メッセージを記録してパケットをドロップします。

Cisco NX-OS は、RIPv1 ルータとの隣接関係を確立しません。

デフォルト設定

表 11-1 は、各 RIP パラメータに対するデフォルト設定を示します。

 

表 11-1 デフォルトの RIP パラメータ

パラメータ
デフォルト

ロード バランシングを行う最大パス数

8

RIP 機能

ディセーブル

スプリット ホライズン

イネーブル

RIP の設定

この項では、次のトピックについて取り上げます。

「RIP のイネーブル化」

「RIP インスタンスの作成」

「RIP インスタンスの再起動」

「インターフェイス上での RIP の設定」

「RIP 認証の設定」

「パッシブ インターフェイスの設定」

「ポイズン リバースを指定したスプリット ホライズンの設定」

「ルート集約の設定」

「ルートの再配布の設定」

「Cisco IOS RIP との互換性のため、Cisco NX-OS RIP を設定」

「仮想化の設定」

「RIP の調整」


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


RIP のイネーブル化

RIP を設定する前に、RIP をイネーブルにする必要があります。

手順の概要

1. configure terminal

2. feature rip

3. (任意)show feature

4. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature rip

 

Example:

switch(config)# feature rip

RIP 機能をイネーブルにします。

ステップ 3

show feature

 

Example:

switch(config)# show feature

(任意)イネーブルおよびディセーブルにされた機能を表示します。

ステップ 4

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

RIP 機能をディセーブルにして、関連付けられている設定をすべて削除するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

no feature rip

 

Example:

switch(config)# no feature rip

RIP 機能をディセーブルにし、関連付けられたすべての設定を削除します。

RIP インスタンスの作成

RIP インスタンスを作成し、そのインスタンス用のアドレス ファミリを設定できます。

はじめる前に

RIP をイネーブルにします(「RIP のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. router rip instance-tag

3. address-family ip unicast

4. (任意) show ip rip [ instance instance-tag ] [ vrf vrf-name ]

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router rip instance-tag

 

Example:

switch(config)# router RIP Enterprise

switch(config-router)#

instance tag を設定して、新しい RIP インスタンスを作成します。

ステップ 3

address-family ipv4 unicast

Example:

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

この RIP インスタンスのアドレス ファミリを設定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 4

show ip rip [ instance instance-tag ] [ vrf vrf-name ]

 

Example :

switch(config-router-af)# show ip rip

(任意)すべての RIP インスタンスについて、RIP 要約情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-router-af)# copy running-config startup-config

(任意)この設定の変更を保存します。

RIP インスタンスおよび関連する設定を削除するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

no router rip instance-tag

 

Example:

switch(config)# no router rip Enterprise

RIP インスタンスおよび関連するすべての設定を削除します。


) インターフェイス モードで設定した RIP コマンドを削除することも必要です。


アドレス ファミリ コンフィギュレーション モードでは、RIP に次のオプション パラメータを設定できます。

 

コマンド
目的

distance value

 

Example:

switch(config-router-af)# distance 30

RIP のアドミニストレーティブ ディスタンスを設定します。範囲は 1 ~ 255 です。デフォルト値は 120 です。「アドミニストレーティブ ディスタンス」を参照してください。

maximum-paths number

 

Example:

switch(config-router-af)# maximum-paths 6

RIP がルート テーブルで維持する等コスト パスの最大数を設定します。指定できる範囲は 1 ~ 16 です。

次に、IPv4 に対応する RIP インスタンスを作成し、ロード バランシングのための等コスト パス数を設定する例を示します。

switch# configure terminal

switch(config)# router rip Enterprise

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# max-paths 10

switch(config-router-af)# copy running-config startup-config

 

RIP インスタンスの再起動

RIP インスタンスの再起動が可能です。再起動すると、インスタンスのすべてのネイバーが消去されます。

RIP インスタンスを再起動し、関連付けられたすべてのネイバーを削除するには、次のコマンドを使用します。

 

コマンド
目的

restart rip instance-tag

 

Example:

switch(config)# restart rip Enterprise

RIP インスタンスを再起動し、すべてのネイバーを削除します。

インターフェイス上での RIP の設定

RIP インスタンスにインターフェイスを追加できます。

はじめる前に

RIP をイネーブルにします(「RIP のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. ip router rip instance-tag

4. (任意)show ip rip [ instance instance-tag ] interface [ interface-type slot/port ] [ vrf vrf-name ] [ detail ]

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

Example:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

i p router rip instance-tag

 

Example :

switch(config-if)# ip router rip Enterprise

このインターフェイスを RIP インスタンスに関連付けます。

ステップ 4

show ip rip [ instance instance-tag ] interface [ interface-type slot/port ] [ vrf vrf-name ] [ detail ]

 

Example :

switch(config-if)# show ip rip Enterprise tethernet 1/2

(任意)インターフェイスの RIP 情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、RIP インスタンスに Ethernet 1/2 インターフェイスを追加する例を示します。

switch# configure terminal

switch(config)# interface ethernet 1/2

switch(config-if)# ip router rip Enterprise

switch(config)# copy running-config startup-config

 

RIP 認証の設定

インターフェイス上で RIP パケットの認証を設定できます。

はじめる前に

RIP をイネーブルにします(「RIP のイネーブル化」を参照)。

認証をイネーブルにする前に、必要に応じてキーチェーンを設定します。キーチェーン実装の詳細については、『 Cisco Nexus 9000 Series NX-OS Security Configuration Guide 』を参照してください。

手順の概要

1. configure terminal

2. interface interface-type slot/port

3. ip rip authentication mode { text | md5 }

4. ip rip authentication keychain key

5. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type slot/port

 

Example:

switch(config)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

ip rip authentication mode { text | md5 }

 

Example :

switch(config-if)# ip rip authentication mode md5

クリアテキストまたは MD5 認証ダイジェストとして、このインターフェイスにおける RIP 認証タイプを設定します。

ステップ 4

ip rip authentication keychain key

 

Example :

switch(config-if)# ip rip authentication keychain RIPKey

このインターフェイス上で RIP に使用する認証キーを設定します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、キーチェーンを作成し、RIP インターフェイス上で MD5 認証を設定する例を示します。

switch# configure terminal

switch(config)# key chain RIPKey

switch(config)# key-string myrip

switch(config)# accept-lifetime 00:00:00 Jan 01 2000 infinite

switch(config)# send-lifetime 00:00:00 Jan 01 2000 infinite

switch(config)# interface ethernet 1/2

switch(config-if)# ip rip authentication mode md5

switch(config-if)# ip rip authentication keychain RIPKey

switch(config-if)# copy running-config startup-config

パッシブ インターフェイスの設定

インターフェイスを受動モードに設定することによって、ルートを受信するが、ルート アップデートの送信は行わないように RIP インターフェイスを設定できます。

受動モードで RIP インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ip rip passive-interface

 

Example :

switch(config-if)# ip rip passive-interface

インターフェイスを受動モードに設定します。

ポイズン リバースを指定したスプリット ホライズンの設定

ポイズン リバースをイネーブルにすることによって、ルートを学習したインターフェイス経由では到達不能であると RIP が学習したルートをアドバタイズするように、インターフェイスを設定できます。

インターフェイス上で、ポイズン リバースを指定してスプリット ホライズンを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ip rip poison-reverse

 

Example :

switch(config-if)# ip rip poison-reverse

ポイズン リバースを指定してスプリット ホライズンをイネーブルにします。ポイズン リバースを指定したスプリット ホライズンは、デフォルトでディセーブルです。

ルート集約の設定

ルーティング テーブルでサマリー アドレスによって表される集約アドレスを作成できます。Cisco NX-OS は、固有性の強いすべてのルートの中でメトリックが最小のサマリー アドレス メトリックをアドバタイズします。

インターフェイス上でサマリー アドレスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ip rip summary-address ip-prefix/mask-len

 

Example :

switch(config-if)# ip router rip summary-address 192.0.2.0/24

IPv4 アドレスに対応する、RIP 用のサマリー アドレスを設定します。

ルートの再配布の設定

別のルーティング プロトコルからのルーティング情報を受け入れて、RIP ネットワークを通じてその情報を再配布するように、RIP を設定できます。再配布されたルートを任意で、デフォルト ルートとして割り当てることができます。

はじめる前に

RIP をイネーブルにします(「RIP のイネーブル化」を参照)。

再配布を設定する前に、ルート マップを設定します。ルート マップ設定の詳細については、「ルート マップの設定」を参照してください。

手順の概要

1. configure terminal

2. router rip instance-tag

3. address-family ipv4 unicast

4. redistribute { bgp as | direct | eigrp | isis | ospf | ospfv3 | rip } instance-tag | static } route-map map-name

5. (任意)default-information originate [ always ] [ route-map map-name ]

6. (任意)default-metric value

7. (任意)show ip rip route [{ ip-prefix [ longer -prefixes | shorter-prefixes]] [ vrf vrf-name ] [ summary ]

8. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router rip instance-tag

 

Example:

switch(config)# router rip Enterprise

switch(config-router)#

instance tag を設定して、新しい RIP インスタンスを作成します。

ステップ 3

address-family ipv4 unicast

 

Example :

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)#

アドレスファミリ コンフィギュレーション モードに入ります。

ステップ 4

redistribute { bgp as | direct |{ eigrp | isis | ospf | ospfv3 | rip } instance-tag | static } route-map map-name

 

Example :

switch(config-router-af)# redistribute eigrp 201 route-map RIPmap

他のプロトコルからのルートを RIP に再配布します。ルート マップの詳細については、「ルート マップの設定」を参照してください。

ステップ 5

default-information originate [ always ] [ route-map map-name ]

 

Example :

switch(config-router-af)# default-information originate always

(任意)RIP へのデフォルト ルートを作成し、任意でルート マップで制御します。

ステップ 6

default-metric value

 

Example :

switch(config-router-af)# default-metric 2

(任意)再配布されたすべてのルートにデフォルト メトリックを設定します。範囲は 1 ~ 15 です。デフォルトは 1 です。

ステップ 7

show ip rip route [ ip-prefix [ longer-prefixes | shorter-prefixes ] [ vrf vrf-name] [summary ]

 

Example:

switch(config-router-af)# show ip rip route

(任意)RIP のルートを表示します。

ステップ 8

copy running-config startup-config

 

Example:

switch(config-router-af)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、EIGRP を RIP に再配布する例を示します。

switch# configure terminal

switch(config)# router rip Enterprise

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# redistribute eigrp 201 route-map RIPmap

switch(config-router-af)# copy running-config startup-config

Cisco IOS RIP との互換性のため、Cisco NX-OS RIP を設定

Cisco NX-OS RIP を、ルートがアドバタイズされ、処理される方法で Cisco IOS RIP のように動作するよう設定できます。

直接接続されたルートが、Cisco NX-OS RIP ではコスト 1 として処理され、Cisco IOS RIP ではコスト 0 として処理されます。ルートが Cisco NX-OS RIP でアドバタイズされる場合、受信デバイスはすべての受信ルートに +1 の最小のコストを増加し、ルーティング テーブルにルートをインストールします。Cisco IOS RIP において、このコストの増加は送信側ルータで実行され、受信側ルータは変更なしでルートをインストールします。Cisco NX-OS および Cisco IOS デバイスの両方が連携しているときに、この動作の違いにより問題が発生する可能性があります。Cisco IOS RIP など、ルートをアドバタイズし、処理するために、Cisco NX-OS RIP の設定に応じて、次の互換性の問題を回避できます。

はじめる前に

RIP をイネーブルにします(「RIP のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. router rip instance-tag

3. [ no ] metric direct 0

4. (任意) show running-config rip

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router rip instance-tag

 

Example:

switch(config)# router rip 100

switch(config-router)#

instance tag を設定して、新しい RIP インスタンスを作成します。インスタンス タグには 100、201、または 20 文字までの英数字を入力できます。

ステップ 3

[no] metric direct 0

 

Example:

switch(config-router)# metric direct 0

ルートがアドバタイズされ、処理される方法で Cisco IOS RIP と Cisco NX-OS RIP が互換性を持つようにするため、直接接続するルータすべてをデフォルトであるコスト 1 の代わりにコスト 0 で設定します。

(注) このコマンドは、Cisco IOS デバイスを含む RIP ネットワークに存在するすべての Cisco NX-OS デバイスで設定する必要があります。

ステップ 4

show running-config rip

 

Example :

switch(config-router)# show running-config rip

(任意)現在実行中の RIP の設定を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-router)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、すべての直接ルートをコスト 0 からコスト 1 に返すことによって、Cisco IOS RIP と Cisco NX-OS RIP の互換性をディセーブルにする例を示します。

switch# configure terminal

switch(config)# router rip 100

switch(config-router)# no metric direct 0

switch(config-router)# show running-config rip

switch(config-router)# copy running-config startup-config

仮想化の設定

複数の RIP インスタンスを設定し、複数の VRF を作成し、同じまたは複数の RIP インスタンスを各 VRF で使用するようにできます。VRF に RIP インターフェイスを割り当てます。


) インターフェイスの VRF を設定した後に、インターフェイスの他のすべてのパラメータを設定します。インターフェイスの VRF を設定すると、そのインターフェイスのすべての設定が削除されます。


はじめる前に

RIP をイネーブルにします(「RIP のイネーブル化」を参照)。

手順の概要

1. configure terminal

2. vrf context vrf_name

3. exit

4. router rip instance-tag

5. vrf vrf-name

6. (任意) address-family ipv4 unicast

7. (任意)redistribute {bgp as | direct | {eigrp | isis | ospf | ospfv3 | rip} instance-tag | static} route-map map-name

8. interface ethernet slot/port

9. vrf member vrf-name

10. ip-address ip-prefix/length

11. ip router rip instance-tag

12. (任意)show ip rip [ instance instance-tag ] interface [ interface-type slot/port ] [ vrf vrf-name ]

13. (任意)copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vrf vrf-name

 

Example:

switch(config)# vrf RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成します。

ステップ 3

exit

 

Example:

switch(config-vrf)# exit

switch(config)#

VRF コンフィギュレーション モードを終了します。

ステップ 4

router rip instance-tag

 

Example:

switch(config)# router rip Enterprise

switch(config-router)#

instance tag を設定して、新しい RIP インスタンスを作成します。

ステップ 5

vrf context vrf-name

 

Example:

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)#

新しい VRF を作成し、VRF コンフィギュレーション モードを開始します。

ステップ 6

address-family ipv4 unicast

 

Example :

switch(config-router-vrf)# address-family ipv4 unicast

switch(config-router-vrf-af)#

(任意)この RIP インスタンスの VRF アドレス ファミリを設定します。

ステップ 7

redistribute { bgp as | direct | { eigrp | isis | ospf | ospfv3 | rip } instance-tag | static } route-map map-name

 

Example :

switch(config-router-vrf-af)# redistribute eigrp 201 route-map RIPmap

(任意)他のプロトコルからのルートを RIP に再配布します。ルート マップの詳細については、「ルート マップの設定」を参照してください。

ステップ 8

interface ethernet slot/port

 

Example :

switch(config-router-vrf-af)# interface ethernet 1/2

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

vrf member vrf-name

 

Example:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 10

ip address ip-prefix/length

 

Example:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 11

ip router rip instance-tag

 

Example :

switch(config-if)# ip router rip Enterprise

このインターフェイスを RIP インスタンスに関連付けます。

ステップ 12

show ip rip [ instance instance -tag ] interface [ interface-type slot/port ] [ vrf vrf-name ]

 

Example :

switch(config-if)# show ip rip Enterprise ethernet 1/2

(任意)VRF のインターフェイスに関する RIP 情報を表示します。

ステップ 13

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF を作成して、その VRF にインターフェイスを追加する例を示します。

switch# configure terminal

switch(config)# vrf context RemoteOfficeVRF

switch(config-vrf)# exit

switch(config)# router rip Enterprise

switch(config-router)# vrf RemoteOfficeVRF

switch(config-router-vrf)# address-family ipv4 unicast

switch(config-router-vrf-af)# redistribute eigrp 201 route-map RIPmap

switch(config-router-vrf-af)# interface ethernet 1/2

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 192.0.2.1/16

switch(config-if)# ip router rip Enterprise

switch(config-if)# copy running-config startup-config

RIP の調整

ネットワーク要件に合わせて RIP を調整できます。RIP では複数のタイマーを使用して、ルーティング アップデート間隔、ルートが無効になるまでの時間の長さ、およびその他のパラメータを決定します。これらのタイマーを調整すると、インターネットワークのニーズに適合するように、ルーティング プロトコルのパフォーマンスを調整できます。


) ネットワーク上のすべての RIP 対応ルータで、RIP タイマーに同じ値を設定する必要があります。


RIP を調整するには、アドレス ファミリ コンフィギュレーション モードで次のオプション コマンドを使用します。

 

コマンド
目的

timers basic update timeout holddown garbage-collection

 

Example:

switch(config-router-af)# timers basic 40 120 120 100

RIP タイマーを秒数で設定します。パラメータは次のとおりです。

update:指定できる範囲は 5 ~任意の正の整数。デフォルトは 30 です。

timeout:ルートの無効を宣言するまでに、Cisco NX-OS が待機する時間。タイムアウト インターバルが終了するまでに、このルートのアップデート情報を Cisco NX-OS が受信しなかった場合、Cisco NX-OS はルートの無効を宣言します。指定できる範囲は 1 ~任意の正の整数です。デフォルトは 180 です。

holddown:無効ルートに関するよりよいルート情報を Cisco NX-OS が無視する時間。指定できる範囲は 0 ~任意の正の整数です。デフォルトは 180 です。

garbage-collection:Cisco NX-OS がルートを無効として表示してから、Cisco NX-OS がそのルートをルーティング テーブルから削除するまでの時間。指定できる範囲は 1 ~任意の正の整数です。デフォルト値は 120 です。

RIP を調整するには、インターフェイス コンフィギュレーション モードで次のオプション コマンドを使用します。

 

コマンド
目的

ip rip metric-offset value

 

Example :

switch(config-if)# ip rip metric-offset 10

このインターフェイスで受信する各ルータのメトリックに値を追加します。範囲は 1 ~ 15 です。デフォルトは 1 です。

ip rip route-filter {prefix-list list-name | route-map map-name | [ in | out ]

 

Example :

switch(config-if)# ip rip route-filter route-map InputMap in

着信または発信 RIP アップデートをフィルタリングするための、ルート マップを指定します。

RIP コンフィギュレーションの確認

RIP の設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show ip rip instance [instance-tag] [vrf vrf-name]

RIP インスタンスの状態を表示します。

show ip rip [instance instance-tag] interface slot/port detail [vrf vrf-name]

インターフェイスの RIP ステータスを表示します。

show ip rip [instance instance-tag] neighbor [interface-type number] [vrf vrf-name]

RIP ネイバー テーブルを表示します。

show ip rip [instance instance-tag] route [ip-prefix/lengh [longer-prefixes | shorter--prefixes]] [summary] [vrf vrf-name]

RIP ルート テーブルを表示します。

show running-configuration rip

現在実行中の RIP コンフィギュレーションを表示します。

RIP 統計情報の表示

RIP の統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

show ip rip [instance instance-tag] policy statistics redistribute {bgp as | direct | { eigrp | isis | ospf | ospfv3 | rip } instance-tag | static} [vrf vrf-name]

RIP ポリシー ステータスを表示します。

show ip rip [instance instance-tag] statistics interface-type number] [vrf vrf-name]

RIP の統計情報を表示します。

ポリシーの統計情報を消去するには、 clear ip rip policy コマンドを使用します。

RIP の統計情報を消去するには、 clear ip rip statistics コマンドを使用します。

RIP の設定例

VRF で Enterprise RIP インスタンスを作成し、その RIP インスタンスにイーサネット インターフェイス 1/2 を追加する例を示します。さらに、enthernet interface 1/2 の認証を設定し、この RIP ドメインに EIGRP を再配布します。

vrf context NewVRF

!

feature rip

router rip Enterprise

vrf NewVRF

address-family ip unicast

redistribute eigrp 201 route-map RIPmap

max-paths 10

!

interface ethernet 1/2

vrf NewVRF

ip address 192.0.2.1/16

ip router rip Enterprise

ip rip authentication mode md5

ip rip authentication keychain RIPKey

 

関連項目

ルート マップの詳細については、「Route Policy Manager の設定」を参照してください。