Cisco Nexus 9000 Series NX-OS インターフェイス コンフィギュレーション ガイド リリース 6.x
ポート チャネルの設定
ポート チャネルの設定
発行日;2014/01/20 | 英語版ドキュメント(2013/12/30 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

ポート チャネルの設定

ポート チャネルについて

ポート チャネル

ポートチャネル インターフェイス

基本設定

互換性要件

ポート チャネルを使ったロード バランシング

LACP

LACP の概要

ポート チャネル モード

LACP ID パラメータ

LACP マーカー レスポンダ

LACP がイネーブルのポート チャネルとスタティック ポート チャネルの相違点

LACP 互換性の拡張

LACP ポート チャネルの最小リンクおよび MaxBundle

仮想化のサポート

ハイ アベイラビリティ

ポート チャネリングのライセンス要件

ポート チャネリングの前提条件

注意事項と制約事項

デフォルト設定

ポート チャネルの設定

ポート チャネルの作成

レイヤ 3 ポートをポート チャネルに追加

情報目的としての帯域幅および遅延の設定

ポート チャネル インターフェイスのシャットダウンと再起動

ポート チャネルの説明の設定

フロー制御の設定

ポート チャネルを使ったロード バランシングの設定

LACP のイネーブル化

LACP ポート チャネル ポート モードの設定

LACP ポート チャネルの最小リンクの設定

LACP ポートチャネル MaxBundle の設定

LACP システム プライオリティの設定

LACP ポート プライオリティの設定

LACP グレースフル コンバージェンス

LACP グレースフル コンバージェンスの再イネーブル化

LACP の個別一時停止のディセーブル化

LACP の個別一時停止の再イネーブル化

ポート チャネル ハッシュ分散の設定

グローバル レベルでのポート チャネル ハッシュ分散の設定

ポート チャネル レベルでのポートチャネル ハッシュ分散の設定

RBH モジュロ モードの設定

Port-Channel の設定確認

ポート チャネル インターフェイス コンフィギュレーションのモニタリング

その他の関連資料

関連資料

標準

管理情報ベース(MIB)

ポート チャネルの設定

この章では、ポート チャネルを設定し、Cisco NX-OS デバイスでポート チャネルをより有効に利用するために Link Aggregation Control Protocol(LACP)を適用して設定する手順を説明します。

単一のスイッチでは、物理スイッチ上のすべてのポート チャネル メンバー間で、ポートチャネルの互換性パラメータが同一である必要があります。

この章は、次の項で構成されています。

「ポート チャネルについて」

「ポート チャネリングのライセンス要件」

「ポート チャネリングの前提条件」

「注意事項と制約事項」

「デフォルト設定」

「ポート チャネルの設定」

「Port-Channel の設定確認」

「ポート チャネル インターフェイス コンフィギュレーションのモニタリング」

「その他の関連資料」

ポート チャネルについて

ポート チャネルは複数の物理インターフェイスの集合体で、論理インターフェイスを作成します。1 つのポート チャネルに最大 8 つの個別アクティブ リンクをバンドルして、帯域幅と冗長性を向上させることができます。ポート チャネルの物理インターフェイスが少なくとも 1 つ動作していれば、そのポート チャネルは動作しています。

レイヤ 3 ポート チャネルに適合するレイヤ 3 インターフェイスをバンドルすれば、レイヤ 3 ポート チャネルを作成できます。レイヤ 3 ポート チャネルを作成したら、ポート チャネル インターフェイスに IP アドレスを追加することができます。

変更した設定をポート チャネルに適用すると、そのポート チャネルのメンバ インターフェイスにもそれぞれ変更が適用されます。

集約プロトコルが関連付けられていない場合でもスタティック ポート チャネルを使用して設定を簡略化できます。

柔軟性を高めたい場合は LACP を使用できます。Link Aggregation Control Protocol(LACP)は IEEE 802.3ad で定義されています。LACP を使用すると、リンクによってプロトコル パケットが渡されます。

LACP については、「LACP の概要」 を参照してください。

この項では、次のトピックについて取り上げます。

「ポート チャネル」

「ポートチャネル インターフェイス」

「基本設定」

「互換性要件」

「ポート チャネルを使ったロード バランシング」

「LACP」

「仮想化のサポート」

「ハイ アベイラビリティ」

ポート チャネル

ポート チャネル内のメンバー ポートに障害が発生すると、障害が発生したリンクで伝送されていたトラフィックはポート チャネル内のその他のメンバー ポートに切り替わります。

ただし、LACP をイネーブルにすればポート チャネルをより柔軟に使用できます。LACP を使ってポート チャネルを設定する場合とスタティック ポート チャネルを使って設定する場合では、手順が多少異なります(「ポート チャネルの設定」 を参照)。


) デバイスのポート チャネルはポート集約プロトコル(PAgP)をサポートしません。


各ポートにはポート チャネルが 1 つだけあります。ポート チャネルのすべてのポートには互換性があり、同じ速度とデュプレックス モードを使用します(「互換性要件」を参照)。集約プロトコルを使わずにスタティック ポート チャネルを実行する場合、物理リンクはすべて on チャネル モードです。このモードは、LACP をイネーブルにしない限り変更できません(「ポート チャネル モード」を参照)。

ポート チャネル インターフェイスを作成すると、ポート チャネルを直接作成できます。またはチャネル グループを作成して個別ポートをバンドルに集約させることができます。インターフェイスをチャネル グループに関連付けると、ポート チャネルがない場合は対応するポート チャネルが自動的に作成されます。この場合、ポート チャネルは最初のインターフェイスのレイヤ 3 設定を行います。最初にポート チャネルを作成することもできます。この場合は、Cisco NX-OS ソフトウェアがポート チャネルと同じチャネル番号の空のチャネル グループを作成してデフォルト レイヤ 3 設定を行い、互換性も設定します(「互換性要件」 を参照)。


) 少なくともメンバ ポートの 1 つがアップしており、そのポートのチャネルが有効であれば、ポート チャネルはアップしています。メンバ ポートがすべてダウンしていれば、ポート チャネルはダウンしています。


ポートチャネル インターフェイス

ポート チャネル インターフェイスは、レイヤ 3 インターフェイスとして分類できます。レイヤ 3 ポート チャネル インターフェイスのチャネル メンバにはルーテッド ポートがあます。

レイヤ 3 ポート チャネルにスタティック MAC アドレスを設定できます。この値を設定しない場合、レイヤ 3 ポート チャネルは、最初にアップになるチャネル メンバのルータ MAC を使用します。

レイヤ 3 インターフェイスを設定する方法については、「レイヤ 3 インターフェイスの設定」を参照してください。

基本設定

ポート チャネル インターフェイスには次の基本設定ができます。

帯域幅:この設定は情報目的で使用します。上位レベルプロトコルで使用されます。

遅延:この設定は情報目的で使用します。上位レベルプロトコルで使用されます。

説明

デュプレックス

フロー制御

IP アドレス:IPv4 および IPv6

最大伝送単位(MTU)

シャットダウン

速度

互換性要件

チャネル グループにインターフェイスを追加する場合、ソフトウェアは特定のインターフェイス属性をチェックし、インターフェイスがチャネル グループと互換性があることを確認します。また、Cisco NX-OS ソフトウェアはインターフェイスの多数の動作属性をチェックしてから、そのインターフェイスがポート チャネル集約に参加することを許容します。

互換性チェックの対象となる動作属性は次のとおりです。

ネットワーク層

(リンク)速度性能

速度設定

デュプレックス性能

デュプレックス設定

ポート モード

タグ付きまたは非タグ付き

MTU サイズ

SPAN:SPAN の始点または宛先ポートは不可

レイヤ 3 ポート:サブインターフェイスは不可

フロー制御性能

フロー制御設定

メディア タイプ、銅線またはファイバ

Cisco NX-OS で使用される完全な互換性チェック リストを確認するには、 show port-channel compatibility-parameters コマンドを使用します。

チャネル モードが on に設定されているインターフェイスは、スタティックなポート チャネルにだけ追加できます。また、チャネル モードが active または passive に設定されているインターフェイスは、LACP が実行されているポート チャネルにだけ追加できます。これらの属性は個別のメンバ ポートに設定できます。設定するメンバ ポートの属性に互換性がない場合、ソフトウェアはこのポートをポート チャネルで一時停止させます。

または、次のパラメータが同じ場合、パラメータに互換性がないポートを強制的にポート チャネルに参加させることもできます。

(リンク)速度性能

速度設定

デュプレックス性能

デュプレックス設定

フロー制御性能

フロー制御設定

インターフェイスがポート チャネルに加入すると、個々のパラメータの一部が削除され、次のようなポート チャネルの値に置き換えられます。

帯域幅

遅延

UDP の拡張認証プロトコル

VRF

IP アドレス(v4 および v6)

MAC アドレス

サービス ポリシー

アクセス コントロール リスト(ACL)

インターフェイスがポート チャネルに参加または脱退しても、次に示す多くのインターフェイス パラメータは影響を受けません。

ビーコン

説明

CDP

LACP ポート プライオリティ

UDLD

MDIX

シャットダウン

SNMP トラップ


) ポート チャネルを削除すると、すべてのメンバ インターフェイスはポート チャネルから削除されたかのように設定されます。


ポート チャネル モードについては、「LACP マーカー レスポンダ」 を参照してください。

ポート チャネルを使ったロード バランシング

Cisco NX-OS ソフトウェアは、フレームのアドレスを数値にハッシュしてチャネルのリンクを 1 つ選択することで、ポート チャネルのすべての動作インターフェイス間のトラフィックをロード バランシングします。ポート チャネルはデフォルトでロード バランシングを備えています。ポート チャネル ロード バランシングでは、MAC アドレス、IP アドレス、またはレイヤ 4 ポート番号を使用してリンクを選択します。ポート チャネル ロード バランシングは、送信元または宛先アドレスおよびポートの両方またはどちらか一方を使用します。

ロード バランシング モードを設定して、デバイス全体または指定したモジュールに設定したすべてのポート チャネルに適用することができます。モジュールごとの設定は、デバイス全体のロード バランシング設定よりも優先されます。デバイス全体に 1 つのロード バランシング モードを、指定したモジュールに別のモードを、さらに別の指定したモジュールに別のモードを設定できます。ポート チャネルごとにロード バランシング方式を設定することはできません。

使用するロード バランシング アルゴリズムのタイプを設定できます。ロード バランシング アルゴリズムを指定し、フレームのフィールドを見て出力トラフィックに選択するメンバ ポートを決定します。


) レイヤ 3 インターフェイスのデフォルト ロード バランシング モードは、発信元および宛先 IP アドレスです。非 IP トラフィックのデフォルト ロード バランシング モードは、送信元および宛先 MAC アドレスです。チャネルグループ バンドルのインターフェイス間でロード バランシング方式を設定するには、port-channel load-balance コマンドを使用します。レイヤ 3 パケットのデフォルトの方式は src-dst-ip + l4 です。


次のいずれかの方式を使用するデバイスを設定し、ポート チャネル全体をロード バランシングできます。

宛先 MAC アドレス

送信元 MAC アドレス

送信元および宛先 MAC アドレス

宛先 IP アドレス

送信元 IP アドレス

送信元および宛先 IP アドレス

送信元 TCP/UDP ポート番号

宛先 TCP/UDP ポート番号

送信元および宛先 TCP/UDP ポート番号

非 IP およびレイヤ 3 ポート チャネルはどちらも設定したロード バランシング方式に従い、発信元、宛先、または発信元および宛先パラメータを使用します。たとえば、発信元 IP アドレスを使用するロード バランシングを設定すると、すべての非 IP トラフィックは発信元 MAC アドレスを使用してトラフィックをロード バランシングしますが、レイヤ 3 トラフィックは発信元 IP アドレスを使用してトラフィックをロード バランシングします。同様に、宛先 MAC アドレスをロード バランシング方式として設定すると、すべてのレイヤ 3 トラフィックは宛先 IP アドレスを使用しますが、非 IP トラフィックは宛先 MAC アドレスを使用してロード バランシングします。

ポート チャネルを使用するロード バランシング アルゴリズムは、マルチキャスト トラフィックには適用されません。設定したロード バランシング アルゴリズムにかかわらず、マルチキャスト トラフィックは次の方式を使用してポート チャネルのロード バランシングを行います。

レイヤ 4 情報を持つマルチキャスト トラフィック:送信元 IP アドレス、送信元ポート、宛先 IP アドレス、宛先ポート

レイヤ 4 情報を持たないマルチキャスト トラフィック:発信元 IP アドレス、宛先 IP アドレス

非 IP マルチキャスト トラフィック:発信元 MAC アドレス、宛先 MAC アドレス

LACP の概要


) LCAP は、使用する前にイネーブルにする必要があります。デフォルトでは、LACP はディセーブルです。


LACP をイネーブルにする手順については、「LACP のイネーブル化」 を参照してください。

システムはこの機能をディセーブルにする前のチェックポイントを自動的に取得するため、このチェックポイントにロールバックできます。ロールバックとチェックポイントについては、『 Cisco Nexus 9000 Series NX-OS System Management Configuration Guide 』を参照してください。

図 5-1 に、個別リンクを LACP ポート チャネルおよびチャネル グループに組み込み、個別リンクとして機能させる方法を示します。

図 5-1 個別リンクをポート チャネルに組み込む

 


) ポート チャネルを削除すると、ソフトウェアは関連付けられたチャネル グループを自動的に削除します。すべてのメンバ インターフェイスはオリジナルの設定に戻ります。


LACP 設定が 1 つでも存在する限り、LACP をディセーブルにはできません。

ポート チャネル モード

ポート チャネルの個別インターフェイスは、チャネル モードで設定します。スタティック ポート チャネルを集約プロトコルを使用せずに実行すると、チャネル モードは常に on に設定されます。

デバイス上で LACP をグローバルにイネーブルにした後、各チャネルの LACP をイネーブルにします。それには、各インターフェイスのチャネル モードを active または passive に設定します。チャネル グループにリンクを追加すると、LACP チャネル グループの個別リンクにいずれかのチャネル モードを設定できます。


active または passive のチャネル モードで、個々のインターフェイスを設定するには、まず、LACP をグローバルにイネーブルにする必要があります。


表 5-1 で、各チャネル モードについて説明します。

 

表 5-1 ポート チャネルの個別リンクのチャネル モード

チャネル モード
説明

passive

LACP モード。ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した LACP パケットには応答しますが、LACP ネゴシエーションは開始しません。

active

LACP モード。ポートをアクティブ ネゴシエーション ステートにします。ポートは LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

on

すべてのスタティック ポート チャネル(LACP を実行していない)がこのモードです。LACP をイネーブルにする前にチャネル モードをアクティブまたはパッシブにしようとすると、デバイス表示はエラー メッセージを表示します。

チャネルで LACP をイネーブルにするには、そのチャネルのインターフェイスでチャネル モードを active または passive に設定します。LACP は、on 状態のインターフェイスとネゴシエートする場合、LACP パケットを受信しないため、そのインターフェイスと個別のリンクを形成します。つまり、LACP チャネル グループには参加しません。

デフォルト ポート チャネル モードは on です。

LACP は、パッシブおよびアクティブ モードの両方でポート間をネゴシエートして、ポート速度やトランキング ステートなどを基準にしてポート チャネルを形成できるかどうかを決定します。パッシブ モードは、リモート システムやパートナーが LACP をサポートするかどうか不明の場合に役に立ちます。

次の例のようにモードに互換性がある場合、ポートの LACP モードが異なれば、ポートは LACP ポート チャネルを形成できます。

active モードのポートは、 active モードの別のポートとともにポート チャネルを正しく形成できます。

active モードのポートは、 passive モードの別のポートとともにポート チャネルを形成できます。

passive モードのポートは、どちらのポートもネゴシエーションを開始しないため、 passive モードの別のポートとともにポート チャネルを形成できません。

on モードのポートは LACP を実行しておらず、 active または passive モードの別のポートとともにポート チャネルを形成できません。

LACP ID パラメータ

ここでは、LACP パラメータについて次の内容を説明します。

「LACP システム プライオリティ」

「LCAP ポート プライオリティ」

「LACP 管理キー」

LACP システム プライオリティ

LACP を実行するどのシステムにも LACP システム プライオリティ値があります。このパラメータのデフォルト値である 32768 をそのまま使用するか、1 ~ 65535 の範囲で値を設定できます。LACP は、このシステム プライオリティと MAC アドレスを組み合わせてシステム ID を生成します。また、システム プライオリティを他のデバイスとのネゴシエーションにも使用します。システム プライオリティ値が大きいほど、プライオリティは低くなります。


) LACP システム ID は、LACP システム プライオリティ値と MAC アドレスを組み合わせたものです。


LCAP ポート プライオリティ

LACP を使用するように設定されたポートにはそれぞれ LACP ポート プライオリティがあります。デフォルト値である 32768 をそのまま使用するか、1 ~ 65535 の範囲で値を設定できます。LACP では、ポート プライオリティおよびポート番号によりポート ID が構成されます。

また、互換性のあるポートのうち一部を束ねることができない場合に、どのポートをスタンバイ モードにし、どのポートをアクティブ モードにするかを決定するのに、ポート プライオリティを使用します。LACP では、ポート プライオリティ値が大きいほど、プライオリティは低くなります。指定ポートが、より低い LACP プライオリティを持ち、ホット スタンバイ リンクではなくアクティブ リンクとして選択される可能性が最も高くなるように、ポート プライオリティを設定できます。

LACP 管理キー

LACP は、LACP を使用するように設定されたポートごとに、チャネルグループ番号と同じ管理キー値を自動的に設定します。管理キーにより、他のポートとともに集約されるポートの機能が定義されます。他のポートとの集約を行うポートの能力は、次の要因によって決まります。

ポートの物理特性。データ レートやデュプレックス性能などです。

ユーザが作成した設定に関する制約事項

LACP マーカー レスポンダ

ポート チャネルを使用すればデータ トラフィックを動的に再配布できます。この再配布により、リンクが削除または追加されたり、ロード バランシング スキームが変更されることもあります。トラフィック フローの途中でトラフィックが再配布されると、フレームの秩序が乱れる可能性があります。

LACP は Marker Protocol を使って、再配布によってフレームが重複したり順番が入れ替わらないようにします。Marker Protocol は、所定のトラフィック フローのすべてのフレームがリモート エンドで正しく受信すると検出します。LACP は、ポート チャネル リンクごとに Marker PDUS を送信します。リモート システムは、Marker PDU よりも先にこのリンクで受信されたすべてのフレームを受信すると、Marker PDU に応答します。リモート システムは次に Marker Responder を送信します。ポート チャネルのすべてのメンバ リンクの Marker Responder を受信したローカル システムは、トラフィック フローのフレームを正しい順序で再配分します。ソフトウェアは Marker Responder だけをサポートします。

LACP がイネーブルのポート チャネルとスタティック ポート チャネルの相違点

表 5-2 に、LACP がイネーブルのポート チャネルとスタティック ポート チャネルの主な相違点を示します。

 

表 5-2 LACP がイネーブルのポート チャネルとスタティック ポート チャネル

構成
LACP がイネーブルのポート チャネル
スタティック ポート チャネル

適用されるプロトコル

グローバルにイネーブル

N/A

リンクのチャネル モード

次のいずれか。

Active

Passive

On だけ

チャネルを構成する最大リンク数

16

8

LACP 互換性の拡張

Cisco Nexus 9000 シリーズのデバイスが非 Nexus ピアに接続されている場合、そのグレースフル フェールオーバーのデフォルトが、ディセーブルにされたポートがダウンになるための時間を遅らせる可能性があります。また、ピアからのトラフィックを喪失する原因にもなります。これらの状況を解決するために、 lacp graceful-convergence コマンドが追加されました。

デフォルトで、ポートがピアから LACP PDU を受信しない場合、LACP はポートを中断ステートに設定します。場合によっては、この機能は誤設定によって作成されるループの防止に役立ちますが、サーバが LACP にポートを論理的アップにするように要求するため、サーバの起動に失敗する原因になることがあります。 lacp suspend-individual コマンドを使用して、ポートを個別の状態に設定できます。

LACP ポート チャネルの最小リンクおよび MaxBundle

ポート チャネルは、同様のポートを集約し、単一の管理可能なインターフェイスの帯域幅を増加させます。

最小リンクおよび maxbundle 機能の導入により、LACP ポート チャネル動作を改善し、単一の管理可能なインターフェイスの帯域幅を増加させます。

LACP ポート チャネルの最小リンク機能は次の処理を実行します。

LACP ポート チャネルにリンク アップし、バンドルする必要があるポートの最小数を設定します。

低帯域幅の LACP ポート チャネルがアクティブにならないようにします。

必要な最小帯域幅を提供するアクティブ メンバ ポートが少数の場合、LACP ポート チャネルが非アクティブになります。

LACP MaxBundle は、LACP ポート チャネルで許可されるバンドル ポートの最大数を定義します。

LACP MaxBundle 機能では、次の処理が行われます。

LACP ポート チャネルのバンドル ポート数の上限を定義します。

より少ないバンドル ポートを含むホット スタンバイ ポートを許可します。(たとえば、5 つのポートを含む LACP ポート チャネルにおいて、ホット スタンバイ ポートとしてそれらのポートの 2 つを指定できます)。


) 最小リンクおよび maxbundle 機能は、LACP ポート チャネルだけで動作します。ただし、デバイスでは非 LACP ポート チャネルでこの機能を設定できますが、機能は動作しません。


仮想化のサポート

1 ~ 4096 の番号を使用して、ポート チャネルに番号を付けることができます。

ハイ アベイラビリティ

ポート チャネルは、複数のポートのトラフィックをロード バランシングすることでハイ アベイラビリティを実現します。物理ポートが故障した場合、ポート チャネルのメンバがアクティブであればポート チャネルは引き続き動作します。モジュール間の設定が共通しているため、異なるモジュールのポートをバンドルして、モジュール故障時にも動作するポート チャネルを作成できます。

ポート チャネルは、ステートフル再起動とステートレス再起動をサポートします。ステートフル再起動はスーパーバイザ切り替え時に発生します。切り替え後、Cisco NX-OS ソフトウェアは実行時の設定を適用します。

動作しているポート数が設定された最小リンク数を下回った場合、ポート チャネルはダウンします。


) ハイ アベイラビリティ機能の詳細については、『Cisco Nexus 9000 Series NX-OS High Availability and Redundancy Guide を参照してください。


ポート チャネリングのライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

ポート チャネリングにライセンスは必要ありません。ライセンス パッケージに含まれていない機能は Cisco NX-OS イメージにバンドルされており、無料で提供されます。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

ポート チャネリングの前提条件

ポート チャネリングには次の前提条件があります。

デバイスにログインしていること。

シングル ポート チャネルのすべてのポートは、レイヤ 3 ポートであること。

シングル ポート チャネルのすべてのポートが、互換性の要件を満たしていること。互換性の要件の詳細については、「互換性要件」を参照してください。

注意事項と制約事項

ポート チャネリング設定時の注意事項および制約事項は、次のとおりです。

この機能を使用する前に LACP をイネーブルにする必要があります。

デバイスに複数のポート チャネルを設定できます。

ポート チャネルを設定した場合、ポート チャネル インターフェイスに適用した設定はポート チャネル メンバ ポートに影響を与えます。メンバ ポートに適用した設定は、設定を適用したメンバ ポートにだけ影響します。

LACP は半二重モードをサポートしません。LACP ポート チャネルの半二重ポートは中断ステートになります。

チャネル メンバ ポートを発信元または宛先 SPAN ポートにできません。

このリリースでは、LACP 高速タイマー機能はサポートされません。

デフォルト設定

表 5-3 に、ポート チャネル パラメータのデフォルト設定を示します。

 

表 5-3 デフォルト ポート チャネル パラメータ

パラメータ
デフォルト

ポート チャネル

管理アップ

レイヤ 3 インターフェイスのロード バランシング方式

送信元および宛先 IP アドレス

モジュールごとのロード バランシング

ディセーブル

RBH モジュロ モード

ディセーブル

LACP

ディセーブル

チャネル モード

on

LACP システム プライオリティ

32768

LACP ポート プライオリティ

32768

LACP の最小リンク

1

Maxbundle

16

ポート チャネルの設定

この項では、次のトピックについて取り上げます。

「ポート チャネルの作成」

「レイヤ 3 ポートをポート チャネルに追加」

「情報目的としての帯域幅および遅延の設定」

「ポート チャネル インターフェイスのシャットダウンと再起動」

「ポート チャネルの説明の設定」

「フロー制御の設定」

「ポート チャネルを使ったロード バランシングの設定」

「LACP のイネーブル化」

「LACP ポート チャネル ポート モードの設定」

「LACP ポート チャネルの最小リンクの設定」

「LACP ポートチャネル MaxBundle の設定」

「LACP システム プライオリティの設定」

「LACP ポート プライオリティの設定」

「LACP グレースフル コンバージェンス」

「LACP の個別一時停止のディセーブル化」

「LACP の個別一時停止の再イネーブル化」

「ポート チャネル ハッシュ分散の設定」

「RBH モジュロ モードの設定」


ポート チャネル インターフェイスに最大伝送単位(MTU)を設定する手順については、「基本インターフェイス パラメータの設定」を参照してください。ポート チャネル インターフェイスに IPv4 および IPv6 アドレスを設定する手順については、「レイヤ 3 インターフェイスの設定」を参照してください。



) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


ポート チャネルの作成

チャネル グループを作成する前に、ポート チャネルを作成します。関連するチャネル グループは自動的に作成されます。

はじめる前に

LACP ベースのポート チャネルにする場合は LACP をイネーブルにします。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. (任意) show port-channel summary

4. (任意)no shutdown

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

Example:

switch(config)# interface port-channel 1

switch(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。指定できる範囲は 1 ~ 4096 です。Cisco NX-OS ソフトウェアは、チャネル グループがない場合はそれを自動的に作成します。

ステップ 3

show port-channel summary

 

Example :

switch(config-router)# show port-channel summary

(任意)ポート チャネルに関する情報を表示します。

ステップ 4

no shutdown

 

Example:

switch# configure terminal

switch(config)# int e3/1

switch(config-if)# no shutdown

(任意)ポリシーがハードウェア ポリシーに対応するインターフェイスのエラーをクリアします。このコマンドにより、ポリシー プログラミングが続行でき、ポートがアップできます。ポリシーが対応していない場合は、エラーは error-disabled ポリシー状態になります。

ステップ 5

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

no interface port-channel コマンドを使用して、ポート チャネルを削除し、関連するチャネルグループを削除します。

 

コマンド
目的

no interface port-channel channel-number

 

Example:

switch(config)# no interface port-channel 1

ポート チャネルを削除し、関連するチャネル グループを削除します。

次の例は、ポート チャネルの作成方法を示しています。

switch# configure terminal
switch (config)# interface port-channel 1
 

ポート チャネルを削除したときのインターフェイス コンフィギュレーションの変化について詳しくは、「互換性要件」を参照してください。

レイヤ 3 ポートをポート チャネルに追加

新しいチャネル グループまたはすでにレイヤ 3 ポートが設定されているチャネル グループにレイヤ 3 ポートを追加できます。ポート チャネルがない場合は、このチャネル グループに関連付けられたポート チャネルが作成されます。

追加するレイヤ 3 ポートに IP アドレスが設定されている場合、ポートがポート チャネルに追加される前にその IP アドレスは削除されます。レイヤ 3 ポート チャネルを作成したら、ポート チャネル インターフェイスに IP アドレスを割り当てることができます。

はじめる前に

LACP ベースのポート チャネルにする場合は LACP をイネーブルにします。

レイヤ 3 インターフェイスに設定した IP アドレスがあれば、この IP アドレスを削除します。

手順の概要

1. configure terminal

2. interface type slot/port

3. no switchport

4. channel-group channel- number [ force ] [ mode { on | active | passive }]

5. (任意) show interface type slot/port

6. (任意)no shutdown

7. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type slot/port

 

Example:

switch(config)# interface ethernet 1/4

switch(config-if)

チャネル グループに追加するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no switchport

 

Example:

switch(config-if)# no switchport

インターフェイスをレイヤ 3 ポートとして設定します。

ステップ 4

channel-group channel-number [ force] [ mode { on | active | passive }]

 

Example:

switch(config-if)# channel-group 5

 

 

Example :

switch(config-if)# channel-group 5 force

 

チャネル グループ内にポートを設定し、モードを設定します。channel-number の指定できる範囲は 1 ~ 4096 です。ポート チャネルがない場合は、Cisco NX-OS ソフトウェアによってこのチャネル グループに関連付けられたポート チャネルが作成されます。

(任意)互換性のない設定を持つインターフェイスを強制的にチャネルに追加するには、このコマンドを使用します。強制されるインターフェイスは、チャネル グループと同じ速度、デュプレックス、およびフロー制御設定を持っている必要があります。

ステップ 5

show interface type slot/port

 

Example :

switch(config-router)# show interface ethernet 1/4

(任意)インターフェイスの内容を表示します。

ステップ 6

no shutdown

 

Example:

switch# configure terminal

switch(config)# int e3/1

switch(config-if)# no shutdown

(任意)ポリシーがハードウェア ポリシーに対応するインターフェイスのエラーをクリアします。このコマンドにより、ポリシー プログラミングが続行でき、ポートがアップできます。ポリシーが対応していない場合は、エラーは error-disabled ポリシー状態になります。

ステップ 7

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

no channel-group コマンドを使用して、チャネル グループからポートを削除します。チャネル グループから削除されたポートは元の設定に戻ります。このポートの IP アドレスを再設定する必要があります。

 

コマンド
目的

no channel-group

 

Example:

switch(config)# no channel-group

チャネル グループからポートを削除します。

次に、レイヤ 3 イーサネット インターフェイス 1/5 を on モードのチャネル グループ 6 に追加する例を示します。

switch# configure terminal
switch (config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# channel-group 6

 

次の例では、レイヤ 3 ポート チャネル インターフェイスを作成し、IP アドレスを割り当てる方法を示します。

switch# configure terminal
switch(config)# interface port-channel 4
switch(config-if)# ip address 192.0.2.1/8

情報目的としての帯域幅および遅延の設定

ポート チャネルの帯域幅は、チャネル内のアクティブ リンクの合計数によって決定されます。

情報目的でポート チャネル インターフェイスに帯域幅および遅延を設定します。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. bandwidth value

4. delay value

5. exit

6. (任意) show interface port-channel channel-number

7. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

Example:

switch(config)# interface port-channel 2

switch(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

bandwidth value

 

Example:

switch(config-if)# bandwidth 60000000

switch(config-if)#

情報目的で使用される帯域幅を指定します。有効な範囲は 1 ~ 80,000,000 kbs です。デフォルト値はチャネル グループのアクティブ インターフェイスの合計によって異なります。

ステップ 4

delay value

 

Example:

switch(config-if)# delay 10000

switch(config-if)#

情報目的で使用されるスループット遅延を指定します。範囲は、1 ~ 16,777,215(10 マイクロ秒単位)です。デフォルト値は 10 マイクロ秒です。

ステップ 5

exit

 

Example:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了し、コンフィギュレーション モードに戻ります。

ステップ 6

show interface port-channel channel-number

 

Example :

switch(config-router)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 7

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート チャネル 5 の帯域幅および遅延の情報パラメータを設定する例を示します。

switch# configure terminal
switch (config)# interface port-channel 5
switch(config-if)# bandwidth 60000000
switch(config-if)# delay 10000
switch(config-if)#

ポート チャネル インターフェイスのシャットダウンと再起動

ポート チャネル インターフェイスをシャットダウンして再起動できます。ポート チャネル インターフェイスをシャットダウンすると、トラフィックは通過しなくなりインターフェイスは管理上ダウンします。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. shutdown | no shutdown

4. exit

5. (任意) show interface port-channel channel-number

6. (任意)no shutdown

7. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

Example:

switch(config)# interface port-channel 2

switch(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

shutdown

 

Example:

switch(config-if)# shutdown

switch(config-if)#

インターフェイスをシャットダウンします。トラフィックは通過せず、インターフェイスは管理ダウン状態になります。デフォルトは no shutdown です。

no shutdown

 

Example:

switch(config-if)# no shutdown

switch(config-if)#

インターフェイスを開きます。インターフェイスは管理的にアップとなります。操作上の問題がなければ、トラフィックが通過します。デフォルトは no shutdown です。

ステップ 4

exit

 

Example:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了し、コンフィギュレーション モードに戻ります。

ステップ 5

show interface port-channel channel-number

 

Example :

switch(config-router)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 6

no shutdown

 

Example:

switch# configure terminal

switch(config)# int e3/1

switch(config-if)# no shutdown

(任意)ポリシーがハードウェア ポリシーに対応するインターフェイスのエラーをクリアします。このコマンドにより、ポリシー プログラミングが続行でき、ポートがアップできます。ポリシーが対応していない場合は、エラーは error-disabled ポリシー状態になります。

ステップ 7

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート チャネル 2 のインターフェイスをアップする例を示します。

switch# configure terminal
switch (config)# interface port-channel 2
switch(config-if)# no shutdown

ポート チャネルの説明の設定

ポート チャネルの説明を設定できます。

手順の概要

1. configure terminal

2. interface port-channel channel-number

3. description

4. exit

5. (任意) show interface port-channel channel-number

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

Example:

switch(config)# interface port-channel 2

switch(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

description

 

Example:

switch(config-if)# description engineering

switch(config-if)#

ポート チャネル インターフェイスに説明を追加できます。説明に 80 文字まで使用できます。デフォルトでは、説明は表示されません。このパラメータを設定してから、出力に説明を表示する必要があります。

ステップ 4

exit

 

Example:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了し、コンフィギュレーション モードに戻ります。

ステップ 5

show interface port-channel channel-number

 

Example :

switch(config-router)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート チャネル 2 に説明を追加する例を示します。

switch# configure terminal
switch (config)# interface port-channel 2
switch(config-if)# description engineering

 

フロー制御の設定

1 Gb 以上で動作するポート チャネル インターフェイスのフロー制御ポーズ パケットの送信および受信機能をイネーブルまたはディセーブルにできます。より低速で動作するポート チャネル インターフェイスでは、ポート チャネル インターフェイスのポーズ パケット受信機能だけをイネーブルまたはディセーブルにできます。


) この設定が正しく動作するには、フロー制御リンクのローカルおよびリモート エンドの両方で一致する必要があります。


手順の概要

1. configure terminal

2. interface port-channel channel-number

3. flowcontrol { receive | send } { desired | off | on }

4. exit

5. (任意) show interface port-channel channel-number

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel channel-number

 

Example:

switch(config)# interface port-channel 2

switch(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

flowcontrol { receive | send } { desired | off | on }

 

Example:

switch(config-if)# flowcontrol send desired

switch(config-if)#

フロー制御パラメータを設定して、ポート チャネル インターフェイスのポーズ パケットを送信および受信します。デフォルトは [desired] です。

ステップ 4

exit

 

Example:

switch(config-if)# exit

switch(config)#

インターフェイス モードを終了し、コンフィギュレーション モードに戻ります。

ステップ 5

show interface port-channel channel-number

 

Example :

switch(config-router)# show interface port-channel 2

(任意)指定したポート チャネルのインターフェイス情報を表示します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート チャネル グループ 2 にポート チャネル インターフェイスを設定してポーズ パケットを送信および受信する例を示します。

switch# configure terminal
switch (config)# interface port-channel 2
switch(config-if)# flowcontrol receive on
switch(config-if)# flowcontrol send on

ポート チャネルを使ったロード バランシングの設定

ポート チャネルのロード バランシング アルゴリズムを設定し、デバイス全体または 1 のモジュールだけに適用します。モジュールベースのロード バランシングは、デバイスベースのロード バランシングに優先します。

はじめる前に

LACP ベースのポート チャネルにする場合は LACP をイネーブルにします。

手順の概要

1. configure terminal

2. [no] port-channel load-balance method { dst ip | dst mac | dst port | src- dst ip | source-dst mac | source-dst port | src-ip port | src mac | src-port | hash-modulo [force] } [module module - number] [rotate rotate]

3. (任意) show port-channel load-balance

4. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-channel load-balance method { dst ip | dst mac | dst port | src- dst ip | source-dst mac | source-dst port | src-ip port | src mac | src-port | hash-modulo [force] } [module module-number ] [rotate rotate]
 

Example:

switch(config)# port-channel load-balance src-dst mac

switch(config)#

 

Example:

switch(config)# no port-channel load-balance src-dst mac

switch(config)#

 

Example:

switch(config)# no port-channel load-balance src-dst mac module 1

switch(config)#

デバイスまたはモジュールのロード バランシング アルゴリズムを指定します。指定可能なアルゴリズムはデバイスによって異なります。レイヤ 3 のデフォルトは IPv4 と IPv6 の両方で src-dest-ip で、非 IP のデフォルトは src-dest-mac です。

ステップ 3

show port-channel load-balance

 

Example :

switch(config-router)# show port-channel load-balance

(任意)ポート チャネル ロード バランシング アルゴリズムを表示します。

ステップ 4

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

デフォルトのロード バランシング アルゴリズムである、非 IP トラフィック用の source-dest-mac、および IP トラフィック用の source-dest-ip を復元するには、 no port-channel load-balance コマンドを使用します。

 

コマンド
目的

no port-channel load-balance

 

Example:

switch(config)# no port-channel load-balance

デフォルトのロード バランシング アルゴリズムを復元します。

次に、モジュール 5 のポート チャネルに発信元 IP ロード バランシングを設定する例を示します。

switch# configure terminal
switch (config)# port-channel load-balance src-ip-port module 5
 

LACP のイネーブル化

LACP はデフォルトではディセーブルです。LACP の設定を開始するには、LACP をイネーブルにする必要があります。LACP 設定が 1 つでも存在する限り、LACP をディセーブルにはできません。

LACP は、LAN ポート グループの機能を動的に学習し、残りの LAN ポートに通知します。LACP は、正確に一致しているイーサネット リンクを識別すると、リンクを 1 つのポート チャネルとしてまとめます。

LACP を設定する手順は次のとおりです。

LACP をグローバルにイネーブルにするには、 feature lacp コマンドを使用します。

LACP をイネーブルにした同一ポート チャネルでは、異なるインターフェイスに異なるモードを使用します。 指定したチャネル グループに割り当てられた唯一のインターフェイスである場合に限り、モードを active と passive で切り替えることができます。

手順の概要

1. configure terminal

2. feature lacp

3. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

feature lacp

 

Example:

switch(config)# feature lacp

デバイスの LACP をイネーブルにします。

ステップ 3

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、LACP をイネーブルにする例を示します。

switch# configure terminal
switch (config)# feature lacp
 

LACP ポート チャネル ポート モードの設定

LACP をイネーブルにしたら、LACP ポート チャネルのそれぞれのリンクのチャネル モードを active または passive に設定できます。このチャネル コンフィギュレーション モードを使用すると、リンクは LACP で動作可能になります。

関連する集約プロトコルを使用せずにポート チャネルを設定すると、リンク両端のすべてのインターフェイスは on チャネル モードを維持します。

手順の概要

1. configure terminal

2. interface type slot/port

3. channel-group number mode { active | on | passive }

4. (任意) show port-channel summary

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type slot/port

 

Example:

switch(config)# interface ethernet 1/4

switch(config-if)

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

channel-group number mode { active | on | passive }

 

Example:

switch(config-if)# channel-group 5 mode active

 

ポート チャネルのリンクのポート モードを指定します。LACP をイネーブルにしたら、各リンクまたはチャネル全体を active または passive に設定します。

関連する集約プロトコルを使用せずにポート チャネルを実行する場合、ポートチャネル モードは常に on です。

デフォルト ポート チャネル モードは on です。

ステップ 4

show port-channel summary

 

Example:

switch(config-if)# show port-channel summary

(任意)ポート チャネルの概要を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、LACP をイネーブルにしたインターフェイスを、チャネル グループ 5 のイーサネット インターフェイス 1/4 のアクティブ ポートチャネル モードに設定する例を示します。

switch# configure terminal
switch (config)# interface ethernet 1/4
switch(config-if)# channel-group 5 mode active

LACP ポート チャネルの最小リンクの設定

LACP の最小リンク機能を設定できます。最小リンクと maxbundles は LACP でのみ動作します。ただし、非 LACP ポート チャネルに対してこれらの機能の CLI コマンドを入力できますが、これらのコマンドは動作不能です。

はじめる前に

適切なポートチャネル インターフェイスであることを確認します。

手順の概要

1. configure terminal

2. interface port-channel number

3. lacp min-links number

4. (任意)show running-config interface port-channel number

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel number

 

Example:

switch(config)# interface port-channel 3

switch(config-if)

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

lacp min-links number

 

Example:

switch(config-if)# lacp min-links 3

 

ポート チャネル インターフェイスを指定して、最小リンクの数を設定し、インターフェイス コンフィギュレーション モードを開始します。指定できる範囲は 1 ~ 16 です。

ステップ 4

show running-config interface port-channel number

 

Example:

switch(config-if)# show running-config interface port-channel 3

(任意)ポート チャネル最小リンク設定を表示します。

デフォルトのポートチャネル最小リンク設定を復元するには、 no lacp min-links コマンド を使用します。

 

コマンド
目的

no lacp min-links

 

Example:

switch(config)# no lacp min-links

デフォルトのポートチャネル最小リンク設定を復元します。

次に、モジュール 3 のポート チャネル インターフェイスの最小数を設定する例を示します。

switch# configure terminal
switch (config)# lacp min-links 3

LACP ポートチャネル MaxBundle の設定

LACP の maxbundle 機能を設定できます。最小リンクと maxbundles は LACP でのみ動作します。ただし、非 LACP ポート チャネルに対してこれらの機能の CLI コマンドを入力できますが、これらのコマンドは動作不能です。

はじめる前に

適切なポートチャネル インターフェイスであることを確認します。

手順の概要

1. configure terminal

2. interface port-channel number

3. lacp max-bundle number

4. (任意) show running-config interface port-channel number

手順の詳細

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel number

 

Example:

switch(config)# interface port-channel 3

switch(config-if)

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

lacp max-bundle number

 

Example:

switch(config-if)# lacp max-bundle

 

ポート チャネル インターフェイスを指定して、max-bundle を設定し、インターフェイス コンフィギュレーション モードを開始します。

ポート チャネルの max-bundle のデフォルト値は 16 です。指定できる範囲は 1 ~ 16 です。

(注) デフォルト値は 16 ですが、ポート チャネルのアクティブ メンバ数は、pc_max_links_config およびポートチャネルで許可されている pc_max_active_members の最小数です。

ステップ 4

show running-config interface port-channel number

 

Example:

switch(config-if)# show running-config interface port-channel 3

(任意)ポートチャネル max-bundle 設定を表示します。

デフォルトのポートチャネル max-bundle 設定を復元するには、 no lacp max-bundle コマンドを使用します。

 

コマンド
目的

no lacp max-bundle

 

Example:

switch(config)# no lacp max-bundle

デフォルトのポートチャネル max-bundle 設定を復元します。

次に、モジュール 3 のポート チャネル インターフェイスの max-bundle を設定する例を示します。

switch# configure terminal
switch (config)# lacp max-bundle 3

LACP システム プライオリティの設定

LACP システム ID は、LACP システム プライオリティ値と MAC アドレスを組み合わせたものです。

はじめる前に

LACP をイネーブルにします。

手順の概要

1. configure terminal

2. lacp system-priority priority

3. (任意) show lacp system-identifier

4. (任意) copy running-config startup-confi g

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

lacp system-priority priority

 

 

Example:

switch(config)# lacp system-priority 40000

LACP で使用するシステム プライオリティを設定します。指定できる範囲は 1 ~ 65535 で、値が大きいほどプライオリティは低くなります。デフォルト値は 32768 です。

ステップ 3

show lacp system-identifier

 

Example:

switch(config-if)# show lacp system-identifier

(任意)LACP システム識別子を表示します。

ステップ 4

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、LACP システム プライオリティを 2500 に設定する例を示します。

switch# configure terminal
switch(config)# lacp system-priority 2500

 

LACP ポート プライオリティの設定

LACP をイネーブルにしたら、ポート プライオリティの LACP ポート チャネルにそれぞれのリンクを設定できます。

はじめる前に

LACP をイネーブルにします。

手順の概要

1. configure terminal

2. interface type slot/port

3. lacp port-priority priority

4. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type slot/port

 

Example:

switch(config)# interface ethernet 1/4

switch(config-if)

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

lacp port-priority priority

 

Example:

switch(config-if)# lacp port-priority 40000.

LACP で使用するポート プライオリティを設定します。指定できる範囲は 1 ~ 65535 で、値が大きいほどプライオリティは低くなります。デフォルト値は 32768 です。

ステップ 4

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、イーサネット インターフェイス 1/4 の LACP ポート プライオリティを 40000 に設定する例を示します。

switch# configure terminal
switch (config)# interface ethernet 1/4
switch(config-if)# lacp port-priority 40000
 

LACP グレースフル コンバージェンス

デフォルトで、LACP グレースフル コンバージェンスはイネーブルになっています。あるデバイスとの LACP 相互運用性をサポートする必要がある場合、コンバージェンスをディセーブルにできます。そのデバイスとは、グレースフル フェールオーバーのデフォルトが、ディセーブルにされたポートがダウンになるための時間を遅らせる可能性がある、または、ピアからのトラフィックを喪失する原因にもなるデバイスです。ダウンストリーム アクセス スイッチが Cisco Nexus デバイスでない場合は、LACP グレースフル コンバージェンス オプションをディセーブルにします。


) コマンドが実行される前に、ポート チャネルが管理上のダウン状態である必要があります。


はじめる前に

LACP をイネーブルにします。

手順の概要

1. configure terminal

2. interface port-channel number

3. shutdown

4. no lacp graceful-convergence

5. no shutdown

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel number

 

Example:

switch(config)# interface port-channel 1

switch(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

shutdown

 

Example:

switch(config-if) shutdown

ポート チャネルを管理シャットダウンします。

ステップ 4

no lacp graceful-convergence

 

Example:

switch(config-if)# no lacp graceful-convergence

ポート チャネルの LACP グレースフル コンバージェンスをディセーブルにします。

ステップ 5

no shutdown

 

Example:

switch(config-if) no shutdown

ポート チャネルを管理的にアップします。

ステップ 6

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート チャネルの LACP グレースフル コンバージェンスをディセーブルにする方法を示します。

switch# configure terminal
switch (config)# interface port-channel 1
switch(config-if)# shutdown
switch(config-if)# no lacp graceful-convergence
switch(config-if)# no shutdown

LACP グレースフル コンバージェンスの再イネーブル化

デフォルトの LACP グレースフル コンバージェンスが再度必要になった場合、コンバージェンスを再度イネーブルにできます。

手順の概要

1. configure terminal

2. interface port-channel number

3. shutdown

4. lacp graceful-convergence

5. no shutdown

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel number

 

Example:

switch(config)# interface port-channel 1

switch(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

shutdown

 

Example:

switch(config-if) shutdown

ポート チャネルを管理シャットダウンします。

ステップ 4

lacp graceful-convergence

 

Example:

switch(config-if)# lacp graceful-convergence

ポート チャネルの LACP グレースフル コンバージェンスをイネーブルにします。

ステップ 5

no shutdown

 

Example:

switch(config-if) no shutdown

ポート チャネルを管理的にアップします。

ステップ 6

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート チャネルの LACP グレースフル コンバージェンスをイネーブルにする方法を示します。

switch# configure terminal
switch (config)# interface port-channel 1
switch(config-if)# shutdown
switch(config-if)# lacp graceful-convergence
switch(config-if)# no shutdown

LACP の個別一時停止のディセーブル化

ポートがピアから LACP PDU を受信しない場合、LACP はポートを中断ステートに設定します。このプロセスによって、サーバの中には起動に失敗するものがあります。そのようなサーバは、LACP が論理的にポートを稼働状態にしていることを必要とするからです。


) エッジ ポートで lacp suspend-individual コマンドを入力するだけです。このコマンドを使用する前に、ポート チャネルが管理上のダウン状態である必要があります。


はじめる前に

LACP をイネーブルにします。

手順の概要

1. configure terminal

2. interface port-channel number

3. shutdown

4. no lacp suspend-individual

5. no shutdown

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel number

 

Example:

switch(config)# interface port-channel 1

switch(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

shutdown

 

Example:

switch(config-if) shutdown

ポート チャネルを管理シャットダウンします。

ステップ 4

no lacp suspend-individual

 

Example:

switch(config-if)# no lacp suspend-individual

ポート チャネルで LACP 個別ポートの一時停止動作をディセーブルにします。

ステップ 5

no shutdown

 

Example:

switch(config-if) no shutdown

ポート チャネルを管理的にアップします。

ステップ 6

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート チャネルで LACP 個別ポートの一時停止をディセーブルにする方法を示します。

switch# configure terminal
switch (config)# interface port-channel 1
switch(config-if)# shutdown
switch(config-if)# no lacp suspend-individual
switch(config-if)# no shutdown

LACP の個別一時停止の再イネーブル化

デフォルトの LACP 個別ポートの一時停止を再度イネーブルにできます。

手順の概要

1. configure terminal

2. interface port-channel number

3. shutdown

4. lacp suspend-individual

5. no shutdown

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel number

 

Example:

switch(config)# interface port-channel 1

switch(config-if)

設定するポート チャネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

shutdown

 

Example:

switch(config-if) shutdown

ポート チャネルを管理シャットダウンします。

ステップ 4

lacp suspend-individual

 

Example:

switch(config-if)# lacp suspend-individual

ポート チャネルで LACP 個別ポートの一時停止動作をイネーブルにします。

ステップ 5

no shutdown

 

Example:

switch(config-if) no shutdown

ポート チャネルを管理的にアップします。

ステップ 6

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、ポート チャネルで LACP 個別ポートの一時停止を再度イネーブルにする方法を示します。

switch# configure terminal
switch (config)# interface port-channel 1
switch(config-if)# shutdown
switch(config-if)# lacp suspend-individual
switch(config-if)# no shutdown

ポート チャネル ハッシュ分散の設定

アダプティブおよび固定のハッシュ分散の設定は、グローバル レベルおよびポートチャネル レベルでサポートされます。このオプションは、メンバがアップまたはダウンしたときに Result Bundle Hash(RBH)分散の変化を最小限に抑えることにより、トラフィックの中断を最小限に抑えます。このため、変化のない RBH 値にマッピングされているフローが同じリンクを流れ続けるようになります。ポート チャネル レベルの設定はグローバル設定よりも優先されます。デフォルトの設定はグローバルにアダプティブで、各ポート チャネルの設定はありません。コマンドが適用されたときにポートはフラップされず、設定は次のメンバー リンクの変更イベントで有効になります。どちらのモードも RBH モジュールまたは非モジュール スキームで動作します。

グローバル レベルでのポート チャネル ハッシュ分散の設定

手順の概要

1. configure terminal

2. no port-channel hash-distribution { adaptive | fixed }

3. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no port-channel hash-distribution {adaptive | fixed}

 

Example:

switch(config)# port-channel hash-distribution adaptive

switch(config)

グローバル レベルでポート チャネル ハッシュ分散を指定します。

デフォルトはアダプティブ モードです。

コマンドは、次のメンバー リンク イベント(link down/up/no shutdown/shutdown)まで有効になりません。Do you want to continue (y/n) ?[yes]

ステップ 3

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、グローバル レベルでハッシュ分散を設定する例を示します。

switch# configure terminal
switch(config)# no port-channel hash-distribution fixed

ポート チャネル レベルでのポートチャネル ハッシュ分散の設定

手順の概要

1. configure terminal

2. interface port-channel { channel-number | range }

3. no port -channel port hash-distribution { adaptive | fixed }

4. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 1

interface port-channel { channel-number | range }

 

Example:

switch# interface port-channel 4

switch(config-if)#

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

no port-channel port hash-distribution {adaptive | fixed}

 

Example:

switch(config-if)# port-channel port hash-distribution adaptive

switch(config-if)

ポート チャネル レベルでポート チャネル ハッシュ分散を指定します。

デフォルトはありません。

コマンドは、次のメンバー リンク イベント(link down/up/no shutdown/shutdown)まで有効になりません。Do you want to continue (y/n) ?[yes]

ステップ 3

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、グローバル レベル コマンドとしてハッシュ分散を設定する例を示します。

switch# configure terminal
switch(config)# no port-channel hash-distribution fixed

RBH モジュロ モードの設定

RBH モジュロ モードをイネーブルにすると、すべてのポート チャネルがフラップされます。

手順の概要

1. configure terminal

2. port-channel load-balance hash-modulo

3. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-channel load-balance hash-modulo

 

Example:

switch(config)# port-channel load-balance hash-modulo

switch(config)

RBH モジュロ モードをイネーブルにします。このコマンドはすべてのポート チャネルを再初期化するため、続行するか、続行しないかのオプションがあります。

ステップ 3

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。

次に、RBH モジュロ モードをイネーブルにする例を示します。

switch# configure terminal
switch(config)# port-channel load-balance hash-modulo

Port-Channel の設定確認

ポート チャネルの設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

show interface port-channel channel-number

ポート チャネル インターフェイスのステータスを表示します。

show feature

イネーブルにされた機能を表示します。

load- interval {interval seconds {1 | 2 | 3 }}

ビットレートとパケットレートの統計情報に対して 3 つの異なるサンプリング間隔を設定します。

show port-channel compatibility-parameters

ポート チャネルに追加するためにメンバ ポート間で同じにするパラメータを表示します。

show port-channel database [ interface port-channel channel-number]

1 つ以上のポート チャネル インターフェイスの集約状態を表示します。

show port-channel load-balance

ポート チャネルで使用するロード バランシングのタイプを表示します。

show port-channel summary

ポート チャネル インターフェイスのサマリーを表示します。

show port-channel traffic

ポート チャネルのトラフィック統計情報を表示します。

show port-channel usage

使用済みおよび未使用のチャネル番号の範囲を表示します。

show lacp { counters [interface port-channel channel-number] | [interface type/slot] | neighbor [interface port-channel channel-number] | port-channel [interface port-channel channel-number] | system-identifier ]]}

LACP に関する情報を表示します。

show running-config interface port-channel channel-number

ポート チャネルの実行コンフィギュレーションに関する情報を表示します。

ポート チャネル インターフェイス コンフィギュレーションのモニタリング

次のコマンドを使用すると、ポート チャネル インターフェイス構成情報を表示することができます。

 

コマンド
目的

clear counters interface port-channel channel-number

カウンタをクリアします。

clear lacp counters [ interface port-channel channel-number ]

LACP カウンタをクリアします。

load- interval {interval seconds {1 | 2 | 3 }}

ビットレートとパケットレートの統計情報に対して 3 つの異なるサンプリング間隔を設定します。

show interface counters [module module ]

入力および出力オクテット ユニキャスト パケット、マルチキャスト パケット、ブロードキャスト パケットを表示します。

show interface counters detailed [all]

入力パケット、バイト、マルチキャストおよび出力パケット、バイトを表示します。

show interface counters errors [module module ]

エラー パケットの数を表示します。

show lacp counters

LACP の統計情報を表示します。

その他の関連資料

ポート チャネルの実装に関する追加情報については、次の項を参照してください。

「関連資料」

「標準」

「管理情報ベース(MIB)」

関連資料

関連項目
マニュアル タイトル

システム管理

『Cisco Nexus 9000 Series NX-OS System Management Configuration Guide

ハイ アベイラビリティ

『Cisco Nexus 9000 Series NX-OS High Availability and Redundancy Guide

ライセンス

『Cisco NX-OS Licensing Guide

標準

標準
タイトル

IEEE 802.3ad

--

管理情報ベース(MIB)

MIB
MIB のリンク

ポート チャネルに関連する MIB

サポートされている MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

ftp://ftp.cisco.com/pub/mibs/supportlists/nexus9000/Nexus9000MIBSupportList.html