Cisco Nexus 9000 Series NX-OS インターフェイス コンフィギュレーション ガイド リリース 6.x
レイヤ 3 インターフェイスの設定
レイヤ 3 インターフェイスの設定
発行日;2014/01/20 | 英語版ドキュメント(2013/12/30 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

レイヤ 3 インターフェイスの設定

レイヤ 3 インターフェイスについて

ルーテッド インターフェイス

サブインターフェイス

ループバック インターフェイス

ハイ アベイラビリティ

仮想化のサポート

レイヤ 3 インターフェイスのライセンス要件

ライセンス 3 インターフェイスの前提条件

注意事項と制約事項

デフォルト設定値

レイヤ 3 インターフェイスの設定

ルーテッド インターフェイスの設定

サブインターフェイスの設定

インターフェイスでの帯域幅の設定

ループバック インターフェイスの設定

VRF へのインターフェイスの割り当て

レイヤ 3 インターフェイス設定の確認

レイヤ 3 インターフェイスのモニタリング

レイヤ 3 インターフェイスの設定例

関連項目

その他の参考資料

関連資料

管理情報ベース(MIB)

標準

レイヤ 3 インターフェイスの設定

この章では、Cisco NX-OS デバイスにレイヤ 3 インターフェイスを設定する方法について説明します。この章は、次の項で構成されています。

「レイヤ 3 インターフェイスについて」

「レイヤ 3 インターフェイスのライセンス要件」

「ライセンス 3 インターフェイスの前提条件」

「注意事項と制約事項」

「デフォルト設定値」

「レイヤ 3 インターフェイスの設定」

「レイヤ 3 インターフェイス設定の確認」

「レイヤ 3 インターフェイスのモニタリング」

「レイヤ 3 インターフェイスの設定例」

「関連項目」

「その他の参考資料」

レイヤ 3 インターフェイスについて

レイヤ 3 インターフェイスは、IPv4 および IPv6 パケットをスタティックまたはダイナミック ルーティング プロトコルを使って別のデバイスに転送します。

この項では、次のトピックについて取り上げます。

「ルーテッド インターフェイス」

「サブインターフェイス」

「ループバック インターフェイス」

「ハイ アベイラビリティ」

「仮想化のサポート」

ルーテッド インターフェイス

レイヤ 3 インターフェイスとしてポートを設定できます。ルーテッド インターフェイスは、IP トラフィックを他のデバイスにルーティングできる物理ポートです。ルーテッド インターフェイスはレイヤ 3 インターフェイスだけです。

すべてのイーサネット ポートは、デフォルトでルーテッド インターフェイスです。CLI セットアップ スクリプトでこのデフォルトの動作を変更できます。

ポートに IP アドレスを割り当て、ルーティングをイネーブルにし、このルーテッド インターフェイスにルーティング プロトコル特性を割り当てることができます。

ルーテッド インターフェイスからレイヤ 3 ポート チャネルも作成できます。ポート チャネルの詳細については、「ポート チャネルの設定」を参照してください。

ルーテッド インターフェイスおよびサブインターフェイスは、指数関数的に減少するレート カウンタをサポートします。Cisco NX-OS はこれらの平均カウンタを用いて次の統計情報を追跡します。

入力パケット数/秒

出力パケット数/秒

入力バイト数/秒

出力バイト数/秒

サブインターフェイス

レイヤ 3 インターフェイスとして設定した親インターフェイスに仮想サブインターフェイスを作成できます。親インターフェイスは物理ポートでかまいません。

親インターフェイスはサブインターフェイスによって複数の仮想インターフェイスに分割されます。これらの仮想インターフェイスに IP アドレスやダイナミック ルーティング プロトコルなど固有のレイヤ 3 パラメータを割り当てることができます。各サブインターフェイスの IP アドレスは、親インターフェイスの他のサブインターフェイスのサブネットとは異なります。

サブインターフェイスの名前は、親インターフェイスの名前(たとえば Ethernet 2/1)+ ピリオド(.)+そのインターフェイス独自の番号です。たとえば、イーサネット インターフェイス 2/1 に Ethernet 2/1.1 というサブインターフェイスを作成できます。この場合、.1 はそのサブインターフェイスを表します。

Cisco NX-OS では、親インターフェイスがイネーブルの場合にサブインターフェイスがイネーブルになります。サブインターフェイスは、親インターフェイスには関係なくシャットダウンできます。親インターフェイスをシャットダウンすると、関連するサブインターフェイスもすべてシャットダウンされます。

ループバック インターフェイス

ループバック インターフェイスは、常にアップ状態にある単独のエンドポイントを持つ仮想インターフェイスです。ループバック インターフェイスを通過するパケットはこのインターフェイスでただちに受信されます。ループバック インターフェイスは物理インターフェイスをエミュレートします。0 ~ 1023 の番号のループバック インターフェイスを最大 1024 個の設定できます。

ループバック インターフェイスを使用すると、パフォーマンスの分析、テスト、ローカル通信が実行できます。ループバック インターフェイスは、ルーティング プロトコル セッションの終端アドレスとして設定することができます。ループバックをこのように設定すると、アウトバウンド インターフェイスの一部がダウンしている場合でもルーティング プロトコル セッションはアップしたままです。

ハイ アベイラビリティ

レイヤ 3 インターフェイスは、ステートフル再起動とステートレス再起動をサポートします。切り替え後、Cisco NX-OS は実行時の設定を適用します。

ハイ アベイラビリティの詳細については、『 Cisco Nexus 9000 Series NX-OS High Availability and Redundancy Guide 』を参照してください。

仮想化のサポート

レイヤ 3 インターフェイスは、仮想ルーティング/転送(VRF)インスタンスをサポートします。このインターフェイスは VRF に関連付けることができます。

VRF でのインターフェイスの設定については、 『Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide を参照してください。


) そのインターフェイスに IP アドレスを設定する前に、インターフェイスを VRF に割り当てる必要があります。


レイヤ 3 インターフェイスのライセンス要件

次の表に、この機能のライセンス要件を示します。

 

製品
ライセンス要件

Cisco NX-OS

レイヤ 3 インターフェイスにライセンスは必要ありません。ライセンス パッケージに含まれていない機能は nx-os イメージにバンドルされており、無料で提供されます。Cisco NX-OS のライセンス スキームの詳細については、『 Cisco NX-OS Licensing Guide 』を参照してください。

ライセンス 3 インターフェイスの前提条件

ライセンス 3 インターフェイスには次の前提条件があります。

IP アドレッシングおよび基本設定を熟知している。IP アドレッシングの詳細については、 『Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide を参照してください。

注意事項と制約事項


) Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


デフォルト設定値

表 3-1 は、レイヤ 3 インターフェイス パラメータのデフォルト設定です。

 

表 3-1 レイヤ 3 インターフェイスのデフォルト パラメータ

パラメータ
デフォルト

管理ステート

閉じる

レイヤ 3 インターフェイスの設定

この項では、次のトピックについて取り上げます。

「ルーテッド インターフェイスの設定」

「サブインターフェイスの設定」

「インターフェイスでの帯域幅の設定」

「ループバック インターフェイスの設定」

「VRF へのインターフェイスの割り当て」

ルーテッド インターフェイスの設定

任意のイーサネット ポートをルーテッド インターフェイスとして設定できます。

手順の概要

1. configure terminal

2. interface ethernet slot/port

3. no switchport

4. ip address ip-address/length
または
ipv6 address ipv6-address/length

5. (任意) show interfaces

6. (任意)no shutdown

7. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port

 

Example:

switch(config)# interface ethernet 2/1

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no switchport

 

Example:

switch(config-if)# no switchport

そのインターフェイスを、レイヤ 3 インターフェイスとして設定します。

ステップ 4

ip address ip-address/length

 

Example:

switch(config-if)# ip address 192.0.2.1/8

このインターフェイスの IP アドレスを設定します。IP アドレッシングの詳細については、『 Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide 』を参照してください。

ipv6 address ipv6-address/length

 

Example:

switch(config-if)# ipv6 address 2001:0DB8::1/8

このインターフェイスの IPv6 アドレスを設定します。IPv6 アドレッシングの詳細については、『 Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide 』を参照してください。

ステップ 5

show interfaces

 

Example :

switch(config-if)# show interfaces ethernet 2/1

(任意)レイヤ 3 インターフェイスの統計情報を表示します。

ステップ 6

no shutdown

 

Example:

switch#

switch(config-if)# int e2/1

switch(config-if)# no shutdown

(任意)ポリシーがハードウェア ポリシーに対応するインターフェイスのエラーをクリアします。このコマンドにより、ポリシー プログラミングが続行でき、ポートがアップできます。ポリシーが対応していない場合は、エラーは error-disabled ポリシー状態になります。

ステップ 7

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

 

インターフェイス メディアをポイント ツー ポイントまたはブロードキャストのどちらかとして設定するには、 medium コマンドを使用します。

 

コマンド
目的

medium { broadcast | p2p }

 

Example:

switch(config-if)# medium p2p

インターフェイス メディアをポイント ツー ポイントまたはブロードキャストのどちらかとして設定します。


) デフォルト設定は broadcast であり、この設定はどの show コマンドにも表示されません。ただし、p2p に設定を変更した場合、show running config コマンドを入力すると、この設定が表示されます。


 

サブインターフェイスの設定

ルーテッド インターフェイスで構成されるルーテッド インターフェイスに 1 つまたは複数のサブインターフェイスを設定できます。

はじめる前に

親インターフェイスをルーテッド インターフェイスとして設定します。

「ルーテッド インターフェイスの設定」を参照してください。

このポート チャネル上にサブインターフェイスを作成するには、ポート チャネル インターフェイスを作成します。

手順の概要

1. configure terminal

2. interface ethernet slot/port.number

3. ip address ip-address/length
または
ipv6 address ipv6-address/length

4. (任意) show interfaces

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface ethernet slot/port.number

 

Example:

switch(config)# interface ethernet 2/1.1

switch(config-subif)#

サブインターフェイスを作成し、サブインターフェイス コンフィギュレーション モードを開始します number の範囲は 1 ~ 4094 です。

ステップ 3

ip address ip-address/length

 

Example:

switch(config-subif)# ip address 192.0.2.1/8

このサブインターフェイスの IP アドレスを設定します。IP アドレッシングの詳細については、『 Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide 』を参照してください。

ipv6 address ipv6-address/length

 

Example:

switch(config-subif)# ipv6 address 2001:0DB8::1/8

このサブインターフェイスの IPv6 アドレスを設定します。IPv6 アドレッシングの詳細については、『 Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide 』を参照してください。

ステップ 4

show interfaces

 

Example :

switch(config-subif)# show interfaces ethernet 2/1.1

(任意)レイヤ 3 インターフェイスの統計情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-subif)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、サブインターフェイスを作成する例を示します。

switch# configure terminal

switch(config)# i nterface ethernet 2/1.1

switch(config-if)# ip address 192.0.2.1/8

switch(config-if)# copy running-config startup-config

 

show interface eth コマンドの出力は、次の例に示すように、サブインターフェイス用に拡張されました。

switch# show interface ethernet 1/2.1
Ethernet1/2.1 is down (Parent Interface Admin down)
admin state is down, Dedicated Interface, [parent interface is Ethernet1/2]
Hardware: 40000 Ethernet, address: 0023.ac67.9bc1 (bia 4055.3926.61d4)
Internet Address is 10.10.10.1/24
MTU 1500 bytes, BW 40000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Auto-mdix is turned off
EtherType is 0x8100
L3 in Switched:
ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes
L3 out Switched:
ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes

インターフェイスでの帯域幅の設定

ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅を設定できます。上位層プロトコルは帯域幅パラメータを使用してパス コストを計算します。サブインターフェイスの帯域幅は、次のいずれかの方法で設定できます。

明示的:サブインターフェイスの帯域幅を直接設定します。

継承:サブインターフェイスが固有の値として、つまり親インターフェイスの帯域幅を親インターフェイスから継承するように帯域幅を設定します。

サブインターフェイスの帯域幅を設定しない場合、または親インターフェイスの帯域幅を継承しない場合、サブインターフェイスの帯域幅は次の方法で決定されます。

親インターフェイスがアップしている場合、サブインターフェイスの帯域幅は親インターフェイスの動作速度と同じです。ポートの場合、サブインターフェイスの帯域幅は設定されているリンク速度またはネゴシエート対象のリンク速度です。ポート チャネルの場合、サブインターフェイスの帯域幅は、ポート チャネルの各メンバのリンク速度の集合です。

親インターフェイスがダウンしている場合、サブインターフェイスの帯域幅は親インターフェイスのタイプによって異なります。

1 Gb/s イーサネット ポートの場合、サブインターフェイスの帯域幅は 1 Gb/s です。

10 Gb/s イーサネット ポートの場合、サブインターフェイスの帯域幅は 10 Gb/s です。

インターフェイスの帯域幅を設定するには、インターフェイス モードで次のコマンドを使用します。

 

コマンド
目的

bandwidth

 

Example:

switch(config-if)# bandwidth 100000

ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅パラメータを設定します。

親インターフェイスから帯域幅を継承するようにサブインターフェイスを設定するには、インターフェイス モードで次のコマンドを使用します。

 

コマンド
目的

bandwidth inherit [ value ]

 

Example:

switch(config-if)# bandwidth inherit 100000

設定された帯域幅の値を継承するように、このインターフェイスのすべてのサブインターフェイスを設定します。値を設定しない場合、サブインターフェイスは親インターフェイスの帯域幅を継承します。指定できる範囲は 1 ~ 10000000(KB 単位)です。

ループバック インターフェイスの設定

ループバック インターフェイスを設定して、常にアップ状態にある仮想インターフェイスを作成できます。

はじめる前に

ループバック インターフェイスの IP アドレスが、ネットワークの全ルータで一意であることを確認します。

手順の概要

1. configure terminal

2. interface loopback instance

3. ipv4 address ip-address
または
ipv6 address ip-address

4. (任意) show interfaces loopback instance

5. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface loopback instance

 

Example:

switch(config)# interface loopback 0

switch(config-if)#

ループバック インターフェイスを作成します。指定できる範囲は 0 ~ 1023 です。

ステップ 3

ip address ip-address/length

 

Example:

switch(config-if)# ip address 192.0.2.100/8

このインターフェイスの IP アドレスを設定します。IP アドレッシングの詳細については、『 Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide 』を参照してください。

ipv6 address ipv6-address/length

 

Example:

switch(config-if)# ipv6 address 2001:0DB8::18/8

このインターフェイスの IPv6 アドレスを設定します。IPv6 アドレッシングの詳細については、『 Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide 』を参照してください。

ステップ 4

show interfaces loopback instance

 

Example :

switch(config-if)# show interfaces loopback 0

(任意)ループバック インターフェイスの統計情報を表示します。

ステップ 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、ループバック インターフェイスを作成する例を示します。

switch# configure terminal

switch(config)# in terface loopback 0

switch(config-if)# ip address 192.0.2.100/8

switch(config-if)# copy running-config startup-config

VRF へのインターフェイスの割り当て

VRF にレイヤ 3 インターフェイスを追加できます。

手順の概要

1. configure terminal

2. interface interface-type number

3. vrf member vrf-name

4. ip-address ip-prefix/length

5. (任意) show vrf [ vrf-name ] interface interface-type number

6. (任意) copy running-config startup-config

手順の詳細

 

コマンド
目的

ステップ 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-type number

 

Example :

switch(config)# interface loopback 0

switch(config-if)#

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

vrf member vrf-name

 

Example:

switch(config-if)# vrf member RemoteOfficeVRF

このインターフェイスを VRF に追加します。

ステップ 4

ip address ip-prefix/length

 

Example:

switch(config-if)# ip address 192.0.2.1/16

このインターフェイスの IP アドレスを設定します。このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

ステップ 5

show vrf [ vrf-name ] interface interface-type number

 

Example :

switch(config-vrf)# show vrf Enterprise interface loopback 0

(任意)VRF 情報を表示します。

ステップ 6

copy running-config startup-config

 

Example:

switch(config)# copy running-config startup-config

(任意)この設定の変更を保存します。

次に、VRF にレイヤ 3 インターフェイスを追加する例を示します。

switch# configure terminal

switch(config)# interface loopback 0

switch(config-if)# vrf member RemoteOfficeVRF

switch(config-if)# ip address 209.0.2.1/16

switch(config-if)# copy running-config startup-config

レイヤ 3 インターフェイス設定の確認

レイヤ 3 の設定を表示するには、次のいずれかの作業を行います。

 

コマンド
目的

show interface ethernet slot/port

レイヤ 3 インターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

show interface ethernet slot/port brief

レイヤ 3 インターフェイスの動作ステータスを表示します。

show interface ethernet slot/port capabilities

レイヤ 3 インターフェイスの機能(ポート タイプ、速度、およびデュプレックスを含む)を表示します。

show interface ethernet slot/port description

レイヤ 3 インターフェイスの説明を表示します。

show interface ethernet slot/port status

レイヤ 3 インターフェイスの管理ステータス、ポート モード、速度、およびデュプレックスを表示します。

show interface ethernet slot/port.number

サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

show interface port-channel channel-id.number

ポート チャネル サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

show interface loopback number

ループバック インターフェイスの設定情報、ステータス、カウンタを表示します。

show interface loopback number brief

ループバック インターフェイスの動作ステータスを表示します。

show interface loopback number description

ループバック インターフェイスの説明を表示します。

show interface loopback number status

ループバック インターフェイスの管理ステータスおよびプロトコル ステータスを表示します。

レイヤ 3 インターフェイスのモニタリング

レイヤ 3 統計情報を表示するには、次のコマンドを使用します。

 

コマンド
目的

load- interval {interval seconds {1 | 2 | 3 }}

ビットレートとパケットレートの統計情報に対して 3 つの異なるサンプリング間隔を設定します。レイヤ インターフェイスの範囲は 30 ~ 300 秒です。

show interface ethernet slot/port counters

レイヤ 3 インターフェイスの統計情報を表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

show interface ethernet slot/port counters brief

レイヤ 3 インターフェイスの入力および出力カウンタを表示します。

show interface ethernet slot/port counters detailed [ all ]

レイヤ 3 インターフェイスの統計情報を表示します。オプションとして、32 ビットと 64 ビットのパケットおよびバイト カウンタ(エラーを含む)をすべて含めることができます。

show interface ethernet slot/port counters errors

レイヤ 3 インターフェイスの入力および出力エラーを表示します。

show interface ethernet slot/port counters snmp

SNMP MIB から報告されたレイヤ 3 インターフェイス カウンタを表示します。

show interface ethernet slot/port.number counters

サブインターフェイスの統計情報(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

show interface port-channel channel-id.number counters

ポート チャネル サブインターフェイスの統計情報(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

show interface loopback number counters

ループバック インターフェイスの入力および出力カウンタ(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

show interface loopback number counters detailed [ all ]

ループバック インターフェイスの統計情報を表示します。オプションとして、32 ビットと 64 ビットのパケットおよびバイト カウンタ(エラーを含む)をすべて含めることができます。

show interface loopback number counters errors

ループバック インターフェイスの入力および出力エラーを表示します。

レイヤ 3 インターフェイスの設定例

次に、イーサネット サブインターフェイスを設定する例を示します。

interface ethernet 2/1.10

description Layer 3

ip address 192.0.2.1/8

次に、ループバック インターフェイスを設定する例を示します。

interface loopback 3
ip address 192.0.2.2/32

関連項目

レイヤ 3 インターフェイスの詳細については、次の項目を参照してください。

「ポート チャネルの設定」

『Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide

その他の参考資料

レイヤ 3 インターフェイスの実装に関する追加情報については、次の項を参照してください。

「関連資料」

「管理情報ベース(MIB)」

「標準」

関連資料

関連項目
マニュアル タイトル

IP

『Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide

管理情報ベース(MIB)

MIB
MIB のリンク

レイヤ 3 インターフェイスに関連する MIB

サポートされている MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

ftp://ftp.cisco.com/pub/mibs/supportlists/nexus9000/Nexus9000MIBSupportList.html

標準

標準
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--