Cisco Nexus 9000 シリーズ NX-OS マルチキャスト ルーティング コンフィギュレーション ガイド リリース 6.x
PIM の設定
PIM の設定
発行日;2014/01/14   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

PIM の設定

この章では、IPv4 ネットワークの Cisco NX-OS デバイスに Protocol Independent Multicast(PIM)機能を設定する方法を説明します。

PIM について

マルチキャスト対応ルータ間で使用される PIM は、マルチキャスト配信ツリーを構築して、ルーティング ドメイン内にグループ メンバーシップをアドバタイズします。 PIM は、複数の送信元からのパケットが転送される共有配信ツリーと、単一の送信元からのパケットが転送される送信元配信ツリーを構築します。

Cisco NX-OS は、IPv4 ネットワーク(PIM)で、PIM スパース モードをサポートしています PIM スパース モードでは、ネットワーク上の要求元だけにマルチキャスト トラフィックが伝送されます。 PIM は、ルータ上で同時に実行するように設定できます。 PIM のグローバル パラメータを使用すると、ランデブー ポイント(RP)、メッセージ パケット フィルタリング、および統計情報を設定できます。 PIM インターフェイス パラメータを使用すると、マルチキャスト機能のイネーブル化、PIM の境界の識別、PIM hello メッセージ インターバルの設定、および指定ルータ(DR)のプライオリティ設定を実行できます。


(注)  


Cisco NX-OS は、PIM デンス モードをサポートしていません。


Cisco NX-OS でマルチキャスト機能をイネーブルにするには、各ルータで PIM 機能をイネーブルにしてから、マルチキャストに参加する各インターフェイスで、PIM スパース モードをイネーブルにする必要があります。 IPv4 ネットワークの場合は PIM を設定できます。 IPv4 ネットワーク上のルータで IGMP がイネーブルになっていない場合は、PIM によって自動的にイネーブルにされます。

PIM グローバル コンフィギュレーション パラメータを使用すると、次のツリー配信モードで処理するマルチキャスト グループ アドレスの範囲を設定できます。

  • Any Source Multicast(ASM):マルチキャスト送信元の検出機能を提供します。 ASM では、マルチキャスト グループの送信元と受信者間に共有ツリーを構築し、新しい受信者がグループに追加された場合は、送信元ツリーに切り替えることができます。 ASM モードを利用するには、RP を設定する必要があります。

hello メッセージ

ルータがマルチキャスト アドレス 224.0.0.13 に PIM hello メッセージを送信して、PIM 隣接ルータとの隣接関係を確立すると、PIM プロセスが開始されます。 hello メッセージは 30 秒間隔で定期的に送信されます。 PIM ソフトウェアはすべてのネイバーからの応答を確認すると、各 LAN セグメント内でプライオリティが最大のルータを指定ルータ(DR)として選択します。 DR プライオリティは、PIM hello メッセージの DR プライオリティ値に基づいて決まります。 全ルータの DR プライオリティ値が不明、またはプライオリティが等しい場合は、IP アドレスが最上位のルータが DR として選定されます。

hello メッセージには保持時間の値も含まれています。通常、この値は hello インターバルの 3.5 倍です。 ネイバーから後続の hello メッセージがないまま保持時間を経過すると、デバイスはそのリンクで PIM エラーを検出します。

PIM ソフトウェアで、PIM ネイバーとの PIM hello メッセージの認証に MD5 ハッシュ値を使用するよう設定すると、セキュリティを高めることができます。

Join/Prune メッセージ

受信者から送信された、新しいグループまたは送信元に対する IGMP メンバーシップ レポート メッセージを受信すると、DR は、インターフェイスからランデブー ポイント方向(ASM モード)に PIM Join メッセージを送信して、受信者と送信元を接続するツリーを作成します。ランデブー ポイント(RP)は共有ツリーのルートであり、ASM モードで、PIM ドメイン内のすべての送信元およびホストによって使用されます。

DR はグループまたは送信元から最後のホストが脱退したことを認識すると、PIM Prune メッセージを送信して、配信ツリーから該当するパスを削除します。

各ルータは、マルチキャスト配信ツリーの上流方向のホップに Join または Prune アクションを次々と転送し、パスを作成(Join)または削除(Prune)します。


(注)  


このマニュアル内の「PIM Join メッセージ」および「PIM Prune メッセージ」という用語は、PIM Join/Prune メッセージに関して、Join または Prune アクションのうち実行されるアクションをわかりやすく示すために使用しています。


Join/Prune メッセージは、ソフトウェアからできるだけ短時間で送信されます。 Join/Prune メッセージをフィルタリングするには、ルーティング ポリシーを定義します。

ステートのリフレッシュ

PIM では、3.5 分の間隔でマルチキャスト エントリをリフレッシュする必要があります。 ステートをリフレッシュすると、トラフィックがアクティブなリスナーだけに配信されるため、ルータで不要なリソースが使用されなくなります。

PIM ステートを維持するために、最終ホップである DR は、Join/Prune メッセージを 1 分に 1 回送信します。 次に、(*, G) ステートおよび (S, G) ステートの構築例を示します。

  • (*, G) ステートの構築例:IGMP (*, G) レポートを受信すると、DR は (*, G) PIM Join メッセージを RP 方向に送信します。
  • (S, G) ステートの構築例:IGMP (S, G) レポートを受信すると、DR は (S, G) PIM Join メッセージを送信元方向に送信します。

ステートがリフレッシュされていない場合、PIM ソフトウェアは、上流ルータのマルチキャスト発信インターフェイス リストから転送パスを削除し、配信ツリーを再構築します。

ランデブー ポイント

Rendezvous Point(RP; ランデブー ポイント)は、マルチキャスト ネットワーク ドメイン内にあるユーザが指定したルータで、マルチキャスト共有ツリーの共有ルートとして動作します。 必要に応じて複数の RP を設定し、さまざまなグループ範囲をカバーすることができます。

スタティック RP

マルチキャスト グループ範囲の RP を静的に設定できます。 この場合、ドメイン内のすべてのルータに RP のアドレスを設定する必要があります。

スタティック RP を定義するのは、次のような場合です。

  • ルータに Anycast RP アドレスを設定する場合
  • デバイスに RP を手動で設定する場合

BSR

Bootstrap Router(BSR; ブートストラップ ルータ)を使用すると、PIM ドメイン内のすべてのルータで、BSR と同じ RP キャッシュが保持されるようになります。 BSR では、BSR 候補 RP から RP セットを選択するよう設定できます。 BSR は、ドメイン内のすべてのルータに RP セットをブロードキャストする役割を果たします。 ドメイン内の RP を管理するには、1 つまたは複数の候補 BSR を選択します。 候補 BSR の 1 つが、ドメインの BSR として選定されます。


注意    


同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。


次の図に、BSR メカニズムを示します。 ルータ A(ソフトウェアによって選定された BSR)は、すべての有効なインターフェイスから BSR メッセージを送信しています(図の実線部分)。 このメッセージには RP セットが含まれており、ネットワーク内のすべてのルータに次々とフラッディングされます。 ルータ B および C は候補 RP であり、選定された BSR に候補 RP アドバタイズメントを直接送信しています(図の破線部分)。

選定された BSR は、ドメイン内のすべての候補 RP から候補 RP メッセージを受信します。 BSR から送信されるブートストラップ メッセージには、すべての候補 RP に関する情報が格納されています。 各ルータでは共通のアルゴリズムを使用することにより、各マルチキャスト グループに対応する同一の RP アドレスが選択されます。

図 1. BSR メカニズム

RP 選択プロセスの実行中、ソフトウェアは最もプライオリティが高い RP アドレスを特定します。 2 つ以上の RP アドレスのプライオリティが等しい場合は、選択プロセスで RP ハッシュを使用することがあります。 1 つのグループに割り当てられる RP アドレスは 1 つだけです。

デフォルトでは、ルータは BSR メッセージの受信や転送を行いません。 BSR メカニズムによって、PIM ドメイン内のすべてのルータに対して、マルチキャスト グループ範囲に割り当てられた RP セットが動的に通知されるようにするには、BSR リスニング機能および転送機能をイネーブルにする必要があります。

ブートストラップ ルータの詳細については、RFC 5059 を参照してください。


(注)  


BSR メカニズムは、サードパーティ製ルータで使用可能な、ベンダー共通の RP 定義方式です。


Auto-RP

Auto-RP は、インターネット標準であるブートストラップ ルータ メカニズムの前身として導入されたシスコのプロトコルです。 Auto-RP を設定するには、候補マッピング エージェントおよび候補 RP を選択します。 候補 RP は、サポート対象グループ範囲を含んだ RP-Announce メッセージを Cisco RP-Announce マルチキャスト グループ 224.0.1.39 に送信します。 Auto-RP マッピング エージェントは候補 RP からの RP-Announce メッセージを受信して、グループと RP 間のマッピング テーブルを形成します。 マッピング エージェントは、このグループと RP 間のマッピング テーブルを RP-Discovery メッセージに格納して、Cisco RP-Discovery マルチキャスト グループ 224.0.1.40 にマルチキャストします。


注意    


同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。


次の図に、Auto-RP メカニズムを示します。 RP マッピング エージェントは、受信した RP 情報を、定期的に Cisco RP-Discovery グループ 224.0.1.40 にマルチキャストします(図の実線部分)。

図 2. Auto-RP のメカニズム

デフォルトでは、ルータは Auto-RP メッセージの受信や転送を行いません。 Auto-RP メカニズムによって、PIM ドメイン内のルータに対して、グループと RP 間のマッピング情報が動的に通知されるようにするには、Auto-RP リスニング機能および転送機能をイネーブルにする必要があります。

1 つの PIM ドメイン内の複数の RP

この項では、1 つの PIM ドメイン内に複数の RP が設定されている場合の選定プロセスのルールについて説明します。

Anycast-RP

Anycast-RP の実装方式には、Multicast Source Discovery Protocol(MSDP)を使用する場合と、RFC 4610(『Anycast-RP Using Protocol Independent Multicast (PIM)』)に基づく場合の 2 種類があります。 ここでは、PIM Anycast-RP の設定方法について説明します。

PIM Anycast-RP を使用すると、Anycast-RP セットというルータ グループを、複数のルータに設定された単一の RP アドレスに割り当てることができます。 Anycast-RP セットとは、Anycast-RP として設定された一連のルータを表します。 各マルチキャスト グループで複数の RP をサポートし、セット内のすべての RP に負荷を分散させることができるのは、この RP 方式だけです。 Anycast-RP はすべてのマルチキャスト グループをサポートします。

ユニキャスト ルーティング プロトコルの機能に基づいて、PIM Register メッセージが最も近い RP に送信され、PIM Join/Prune メッセージが最も近い RP の方向に送信されます。 いずれかの RP がダウンすると、これらのメッセージは、ユニキャスト ルーティングを使用して次に最も近い RP の方向へと送信されます。

PIM は、PIM Anycast RP に使用されるループバック インターフェイス上に設定する必要があります。

PIM Anycast-RP の詳細については、RFC 4610 を参照してください。

PIM Register メッセージ

PIM Register メッセージは、マルチキャスト送信元に直接接続された Designated Router(DR; 指定ルータ)から RP にユニキャストされます。 PIM Register メッセージには次の機能があります。

  • マルチキャスト グループに対する送信元からの送信がアクティブであることを RP に通知する
  • 送信元から送られたマルチキャスト パケットを RP に配信し、共有ツリーの下流に転送する

DR は RP から Register-Stop メッセージを受信するまで、PIM Register メッセージを RP 宛に送信し続けます。 RP が Register-Stop メッセージを送信するのは、次のいずれかの場合です。

  • RP が送信中のマルチキャスト グループに、受信者が存在しない場合
  • RP が送信元への SPT に加入しているにもかかわらず、送信元からのトラフィックの受信が開始されていない場合

登録メッセージの送信元 IP アドレスが、RP がパケットを送信できる一意のルーテッド アドレスではない場合に、登録メッセージの送信元 IP アドレスを設定するには、ip pim register-source コマンドを使用します。 このような状況は、受信したパケットが転送されないように送信元アドレスがフィルタリングされる場合、または送信元アドレスがネットワークに対して一意でない場合に発生します。 このような場合、RP から送信元アドレスへ送信される応答は DR に到達せず、Protocol Independent Multicast Sparse Mode(PIM-SM)プロトコル障害が発生します。

次に、登録メッセージの IP 送信元アドレスを DR のループバック 3 インターフェイスに設定する例を示します。


ip pim register-source loopback 3

(注)  


Cisco NX-OS では RP の処理の停滞を防ぐため、PIM Register メッセージのレート制限が行われます。


PIM Register メッセージをフィルタリングするには、ルーティング ポリシーを定義します。

指定ルータ

PIM の ASM モードでは、各ネットワーク セグメント上のルータの中から指定ルータ(DR)が選択されます。 DR は、セグメント上の指定グループおよび送信元にマルチキャスト データを転送します。

各 LAN セグメントの DR は、「hello メッセージ」に記載された手順で決定されます。

ASM モードの場合、DR は RP に PIM Register パケットをユニキャストします。 DR が、直接接続された受信者からの IGMP メンバーシップ レポートを受信すると、DR を経由するかどうかに関係なく、RP への最短パスが形成されます。 これにより、同じマルチキャスト グループ上で送信を行うすべての送信元と、そのグループのすべての受信者を接続する共有ツリーが作成されます。

ASM モードにおける共有ツリーから送信元ツリーへのスイッチオーバー


(注)  


Cisco NX-OS では、RPF インターフェイスを MRIB の OIF リストに追加しますが、MFIB の OIF リストには追加しません。


ASM モードでは、共有ツリーだけを使用するように PIM パラメータを設定しないかぎり、受信者に接続された DR が、共有ツリーから送信元への Shortest-Path Tree(SPT; 最短パス ツリー)に切り替わります。

このスイッチオーバーの間、SPT および共有ツリーのメッセージが両方とも表示されることがあります。 これらのメッセージの意味は異なります。 共有ツリー メッセージは上流の RP に向かって伝播されますが、SPT メッセージは送信元に向かって送信されます。

SPT スイッチオーバーについては、RFC 4601 の「Last-Hop Switchover to the SPT」の項を参照してください。

管理用スコープの IP マルチキャスト

管理用スコープの IP マルチキャスト方式を使用すると、マルチキャスト データの配信先を制限できます。 詳細については、RFC 2365 を参照してください。

インターフェイスを PIM 境界として設定し、PIM メッセージがこのインターフェイスから送信されないようにできます。

Auto-RP スコープ パラメータを使用すると、存続可能時間(TTL)値を設定できます。

PIM グレースフル リスタート

Protocol Independent Multicast(PIM)のグレースフル リスタートは、ルート プロセッサ(RP)スイッチオーバー後のマルチキャスト ルート(mroute)のコンバージェンスを向上するマルチキャスト ハイ アベイラビリティ(HA)の拡張です。 PIM のグレースフル リスタート機能では、RP スイッチオーバー時に、インターフェイス上の PIM ネイバーに、このインターフェイスをリバース パス転送(RPF)インターフェイスとして使用するすべての (*, G) および (S, G) 状態に対する PIM Join メッセージの送信をトリガーするためのメカニズムとして生成 ID(GenID)の値(RFC 4601 で規定)を使用します。 このメカニズムにより、PIM ネイバーでは、新しくアクティブになった RP 上でこれらの状態を即座に再確立できます。

生成 ID

生成 ID(GenID)は、インターフェイスで Protocol Independent Multicast(PIM)転送が開始または再開されるたびに生成し直される、ランダムに生成された 32 ビット値です。 PIM hello メッセージ内の GenID 値を処理するために、PIM ネイバーでは、RFC 4601 に準拠する PIM を実装した Cisco ソフトウェアを実行している必要があります。


(注)  


RFC 4601 に準拠しておらず、PIM hello メッセージ内の GenID の差異を処理できない PIM ネイバーは GenID を無視します。

PIM グレースフル リスタート動作

この図は、PIM グレースフル リスタート機能をサポートするデバイスのルート プロセッサ(RP)のスイッチオーバー後に実行される動作を示します。

図 3. RP スイッチオーバー中の PIM グレースフル リスタート動作

PIM グレースフル リスタート動作は次のとおりです。

  • 安定した状態で、PIM ネイバーは定期的に PIM ハロー メッセージをやりとりします。
  • アクティブ RP は、マルチキャスト ルート(mroute)の状態をリフレッシュするために PIM join を定期的に受信します。
  • アクティブ RP に障害が発生すると、スタンバイ RP が代わって新しいアクティブ RP になります。
  • 新しいアクティブ RP は生成 ID(GenID)値を変更して、PIM ハロー メッセージで新しい GenID を隣接する PIM ネイバーに送信します。
  • 新しい GenID を持つインターフェイスで PIM hello メッセージを受信する隣接 PIM ネイバーは、このインターフェイスを RPF インターフェイスとして使用するすべての (*, G) および (S, G) mroute に PIM グレースフル リスタートを送信します。
  • これらの mroute 状態は、新しくアクティブになった RP 上でただちに再確立されます。

PIM のグレースフル リスタートおよびマルチキャスト トラフィック フロー

PIM ネイバーのマルチキャスト トラフィック フローは、マルチキャスト トラフィックで PIM グレースフル リスタート PIM のサポートを検出するか、デフォルトの PIM hello 保持時間間隔内に、障害が発生した RP ノードからの PIM hello メッセージを検出した場合に影響を受けません。 障害が発生した RP のマルチキャスト トラフィック フローは、Non-Stop Forwarding(NSF)対応かどうかに影響されません。


注意    


デフォルトの PIM hello 保持時間間隔は PIM hello 期間の 3.5 倍です。 デフォルト値の 30 秒のよりも小さい値で PIM hello 間隔を設定すると、マルチキャスト ハイ アベイラビリティ(HA)動作が設計どおりに機能しないことがあります。

ハイ アベイラビリティ

ハイ アベイラビリティの詳細については、『Cisco Nexus 9000 Series NX-OS High Availability and Redundancy Guide』を参照してください。

PIM のライセンス要件

製品

ライセンス要件

Cisco NX-OS

PIM には Enterprise Services ライセンスが必要です。 Cisco NX-OS ライセンス方式の詳細と、ライセンスの取得および適用の方法については、Cisco NX-OS Licensing Guide』を参照してください。

PIM の前提条件

PIM の前提条件は次のとおりです。

  • デバイスにログインしている。
  • 現在の Virtual Routing and Forwarding(VRF; 仮想ルーティングおよびフォワーディング)モードが正しい(グローバル コマンドの場合)。 この章の例で示すデフォルトのコンフィギュレーション モードは、デフォルト VRF に適用されます。

PIM に関する注意事項と制限事項

PIM に関する注意事項および制限事項は次のとおりです。

  • ほとんどの Cisco Nexus デバイスでは、RPF 障害トラフィックはドロップされ、PIM アサートを発生するために非常に低レートで CPU に送信されます。 Cisco Nexus 9000 シリーズ スイッチの場合、RPF 障害のトラフィックは、マルチキャスト送信元を学習するために、常に CPU にコピーされます。
  • ほとんどの Cisco Nexus デバイスのファーストホップ ソース検出では、ファースト ホップからのトラフィックは送信元サブネット チェックに基づいて検出され、送信元がローカル サブネットに属する場合に限り、マルチキャスト パケットが CPU にコピーされます。 Cisco Nexus 9000 シリーズ スイッチではローカル送信元を検出できないため、マルチキャスト パケットは、ローカル マルチキャスト送信元を学習するためにスーパーバイザに送信されます。
  • Cisco NX-OS PIM は、PIM デンス モードのすべてのバージョンおよび PIM スパース モードのバージョン 1 と相互運用しません。
  • 同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。
  • 候補 RP インターバルを 15 秒以上に設定してください。
  • デバイスに BSR ポリシーが適用されており、BSR として選定されないように設定されている場合、このポリシーは無視されます。 これにより、次のようなデメリットが発生します。
    • ポリシーで許可されている BSM をデバイスが受信した場合、意図に反してこのデバイスが BSR に選定されていると、対象の BSM がドロップされるために下流のルータではその BSM を受信できなくなります。 また、下流のデバイスでは、不正な BSR から送信された BSM が正しくフィルタリングされるため、これらのデバイスでは RP 情報を受信できなくなります。
    • BSR に異なるデバイスから送られた BSM が着信すると、新しい BSM が送信されますが、その正規の BSM は下流のデバイスでは受信されません。
  • PIM hello 間隔のデフォルト値が推奨されます。この値は変更しないでください。

デフォルト設定

次の表に、PIM パラメータのデフォルト設定を示します。

表 1 PIM のデフォルト パラメータ

パラメータ

デフォルト

共有ツリーだけを使用

ディセーブル

再起動時にルートをフラッシュ

ディセーブル

ログ ネイバーの変更

ディセーブル

Auto-RP メッセージ アクション

ディセーブル

BSR メッセージ アクション

ディセーブル

PIM スパース モード

ディセーブル

DR プライオリティ

0

hello 認証モード

ディセーブル

ドメイン境界

ディセーブル

RP アドレス ポリシー

メッセージをフィルタリングしない

PIM Register メッセージ ポリシー

メッセージをフィルタリングしない

BSR 候補 RP ポリシー

メッセージをフィルタリングしない

BSR ポリシー

メッセージをフィルタリングしない

Auto-RP マッピング エージェント ポリシー

メッセージをフィルタリングしない

Auto-RP 候補 RP ポリシー

メッセージをフィルタリングしない

Join/Prune ポリシー

メッセージをフィルタリングしない

ネイバーとの隣接関係ポリシー

すべての PIM ネイバーと隣接関係を確立

BFD

ディセーブル

PIM の設定

インターフェイスごとに PIM を設定できます。


(注)  


Cisco NX-OS は、PIM スパース モード バージョン 2 のみをサポートします。 このマニュアルで「PIM」と記載されている場合は、PIM スパース モードのバージョン 2 を意味しています。


マルチキャスト配信モードを使用すると、PIM ドメインに、それぞれ独立したアドレス範囲を設定できます(次の表を参照)。

マルチキャスト配信モード

RP 設定の必要性

説明

ASM

Yes

任意の送信元のマルチキャスト

マルチキャスト用 RPF ルート

No

マルチキャスト用 RPF ルート

PIM の設定作業

次の手順では、PIM を設定します。

  1. 各マルチキャスト配信モードで設定するマルチキャスト グループの範囲を選択します。
  2. PIM をイネーブルにします。
  3. ステップ 1 で選択したマルチキャスト配信モードについて、次の設定作業を行います。
    • ASM モードまたは Bidir モードについては、を参照してください。。
    • マルチキャスト用 RPF ルートについては、「マルチキャスト用 RPF ルートの設定」を参照してください。
  4. メッセージ フィルタリングを設定します。

(注)  


次に、PIM の設定に使用される CLI コマンドを示します。

  • PIM のコンフィギュレーション コマンドは ip pim で始まります。
  • 表示コマンドは show ip pim


(注)  


Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


PIM 機能のイネーブル化

PIM コマンドにアクセスするには、PIM 機能をイネーブルにしておく必要があります。

はじめる前に

Enterprise Services ライセンスがインストールされていることを確認してください。

手順
     コマンドまたはアクション目的
    ステップ 1configure terminal


    例:
    switch# configure terminal
    switch(config)#
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2feature pim


    例:
    switch(config)# feature pim
     

    PIM をイネーブルにします。 デフォルトでは PIM はディセーブルになっています。

     
    ステップ 3show running-configuration pim


    例:
    switch(config)# show running-configuration pim
     
    (任意)

    PIM の実行コンフィギュレーション情報を示します。

     
    ステップ 4copy running-config startup-config


    例:
    switch(config)# copy running-config startup-config
     
    (任意)

    実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

     

    PIM スパース モード パラメータの設定

    スパース モード ドメインに参加させる各デバイス インターフェイスで、PIM スパース モードを設定します。 次の表に、設定可能なスパース モード パラメータを示します。

    表 2 PIM スパース モードのパラメータ

    パラメータ

    説明

    デバイスにグローバルに適用

    Auto-RP メッセージ アクション

    Auto-RP メッセージの待ち受けと転送をイネーブルにします。 これらの機能はデフォルトではディセーブルになっているため、候補 RP またはマッピング エージェントとして設定されていないルータは、Auto-RP メッセージの受信と転送を行いません。

    BSR メッセージ アクション

    BSR メッセージの待ち受けと転送をイネーブルにします。 これらの機能はデフォルトではディセーブルになっているため、候補 RP または BSR 候補として設定されていないルータは、BSR メッセージの受信と転送を行いません。

    Register のレート制限

    IPv4 Register のレート制限を毎秒のパケット数で設定します。 有効な範囲は 1 ~ 65,535 です。 デフォルト設定は無制限です。

    初期ホールドダウン期間

    IPv4 の初期ホールドダウン期間を秒単位で設定します。 このホールドダウン期間は、MRIB が最初に起動するのにかかる時間です。 コンバージェンスを高速化するには、小さい値を入力します。 指定できる範囲は 90 ~ 210 です。 ホールドダウン期間をディセーブルにするには、0 を指定します。 デフォルト値は 210 です。

    デバイスの各インターフェイスに適用

    PIM スパース モード

    インターフェイスで PIM をイネーブルにします。

    指定ルータのプライオリティ

    現在のインターフェイスに、PIM hello メッセージの一部としてアドバタイズされる指定ルータ(DR)プライオリティを設定します。 複数の PIM 対応ルータが存在するマルチアクセス ネットワークでは、DR プライオリティの最も高いルータが DR ルータとして選定されます。 プライオリティが等しい場合は、IP アドレスが最上位のルータが DR に選定されます。 DR は、直接接続されたマルチキャスト送信元に PIM Register メッセージを送信するとともに、直接接続された受信者に代わって、ランデブー ポイント(RP)方向に PIM Join メッセージを送信します。 有効範囲は 1 ~ 4294967295 です。 デフォルトは、1 です。

    hello 認証モード

    インターフェイスで、PIM hello メッセージ内の MD5 ハッシュ認証キー(パスワード)をイネーブルにして、直接接続されたネイバーによる相互認証を可能にします。 PIM hello メッセージは、認証ヘッダー(AH)オプションを使用して符号化された IP セキュリティです。 暗号化されていない(クリアテキストの)キーか、または次に示す値のいずれかを入力したあと、スペースと MD5 認証キーを入力します。

    • 0:暗号化されていない(クリアテキストの)キーを指定します。
    • 3:3-DES 暗号化キーを指定します。
    • 7:Cisco Type 7 暗号化キーを指定します。

    認証キーの文字数は最大 16 文字です。 デフォルトでは無効になっています。

    hello 間隔

    hello メッセージの送信インターバルを、ミリ秒単位で設定します。 指定できる範囲は 1000 ~ 18724286 です。 デフォルト値は 30000 です。

    (注)     

    このパラメータの確認された範囲および関連付けられた PIM ネイバー スケールについては、『Cisco Nexus 9000 Series NX-OS Verified Scalability Guide』を参照してください。

    ドメイン境界

    インターフェイスを PIM ドメインの境界として設定し、対象のインターフェイスで、ブートストラップ、候補 RP、または Auto-RP の各メッセージが送受信されないようにします。 デフォルトでは無効になっています。

    ネイバー ポリシー

    ルートマップ ポリシーに基づいて PIM ネイバーの隣接関係を設定します。1 隣接関係は、match ip address コマンドを使用して IP アドレスで指定できます。 指定したポリシー名が存在しない場合、または IP アドレスがポリシー内で設定されていない場合は、すべてのネイバーとの隣接関係が確立されます。 デフォルトでは、すべての PIM ネイバーと隣接関係が確立されます。

    (注)     

    この機能の設定は、経験を積んだネットワーク管理者が行うことを推奨します。

    1 ルートマップ ポリシーの設定方法については、『Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

    PIM スパース モード パラメータの設定

    手順
       コマンドまたはアクション目的
      ステップ 1configure terminal


      例:
      switch# configure terminal
      switch(config)#
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2ip pim auto-rp {listen [forward] | forward [listen]}


      例:
      switch(config)# ip pim auto-rp listen
       
      (任意)

      Auto-RP メッセージの待ち受けまたは転送をイネーブルにします。 デフォルトではこれらの機能がディセーブルになっているため、Auto-RP メッセージの受信または転送は行われません。

       
      ステップ 3ip pim bsr {listen [forward] | forward [listen]}


      例:
      switch(config)# ip pim bsr forward
       
      (任意)

      BSR メッセージの待ち受けまたは転送をイネーブルにします。 デフォルトではこれらの機能がディセーブルになっているため、BSR メッセージの受信または転送は行われません。

       
      ステップ 4 ip pim register-rate-limit rate


      例:
      switch(config)# ip pim register-rate-limit 1000
       
      (任意)

      レート制限を毎秒のパケット数で設定します。 有効な範囲は 1 ~ 65,535 です。 デフォルト設定は無制限です。

       
      ステップ 5[ip | ipv4] routing multicast holddown holddown-period


      例:
      switch(config)# ip routing multicast holddown 100
       
      (任意)

      初期ホールドダウン期間を秒単位で設定します。 指定できる範囲は 90 ~ 210 です。 ホールドダウン期間をディセーブルにするには、0 を指定します。 デフォルト値は 210 です。

       
      ステップ 6show running-configuration pim


      例:
      switch(config)# show running-configuration pim
       
      (任意)

      PIM 実行コンフィギュレーション情報を表示します。

       
      ステップ 7interface interface


      例:
      switch(config)# interface ethernet 2/1
      switch(config-if)#
       

      インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 8ip pim sparse-mode


      例:
      switch(config-if)# ip pim sparse-mode
       

      現在のインターフェイスで PIM スパース モードをイネーブルにします。 デフォルトでは無効になっています。

       
      ステップ 9ip pim dr-priority priority


      例:
      switch(config-if)# ip pim dr-priority 192
       
      (任意)

      PIM hello メッセージの一部としてアドバタイズされる指定ルータ(DR)プライオリティを設定します。 有効範囲は 1 ~ 4294967295 です。 デフォルトは、1 です。

       
      ステップ 10ip pim hello-authentication ah-md5 auth-key


      例:
      switch(config-if)# ip pim hello-authentication ah-md5 my_key
       
      (任意)
      PIM hello メッセージ内の MD5 ハッシュ認証キーをイネーブルにします。 暗号化されていない(クリアテキストの)キーか、または次に示す値のいずれかを入力したあと、スペースと MD5 認証キーを入力します。
      • 0:暗号化されていない(クリアテキストの)キーを指定します。
      • 3:3-DES 暗号化キーを指定します。
      • 7:Cisco Type 7 暗号化キーを指定します。

      キーの文字数は最大 16 文字です。 デフォルトでは無効になっています。

       
      ステップ 11ip pim hello-interval interval


      例:
      switch(config-if)# ip pim hello-interval 25000
       
      (任意)

      hello メッセージの送信インターバルを、ミリ秒単位で設定します。 指定できる範囲は 1000 ~ 18724286 です。 デフォルト値は 30000 です。

      (注)     

      最小値は 1 ミリ秒です。

       
      ステップ 12ip pim border


      例:
      switch(config-if)# ip pim border
       
      (任意)

      インターフェイスを PIM ドメインの境界として設定し、対象のインターフェイスで、ブートストラップ、候補 RP、または Auto-RP の各メッセージが送受信されないようにします。 デフォルトでは無効になっています。

       
      ステップ 13ip pim neighbor-policy policy-name


      例:
      switch(config-if)# ip pim neighbor-policy my_neighbor_policy
       
      (任意)

      インターフェイスを PIM ドメインの境界として設定し、対象のインターフェイスで、ブートストラップ、候補 RP、または Auto-RP の各メッセージが送受信されないようにします。 デフォルトでは無効になっています。

      match ip address コマンドを使用し、ルートマップ ポリシーに基づいて PIM ネイバーの隣接関係も設定します。 ポリシー名の文字数は最大 63 文字です。 デフォルトでは、すべての PIM ネイバーと隣接関係が確立されます。

      (注)     

      この機能の設定は、経験を積んだネットワーク管理者のみが行うことを推奨します。

       
      ステップ 14show ip pim interface [interface | brief] [vrf vrf-name | all]


      例:
      switch(config-if)# show ip pim interface
       
      (任意)

      PIM インターフェイスの情報を表示します。

       
      ステップ 15copy running-config startup-config


      例:
      switch(config-if)# copy running-config startup-config
       
      (任意)

      実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

       

      ASM の設定

      Any Source Multicast(ASM)のマルチキャスト配信モードでは、マルチキャスト データの送信元と受信者の間に、共通のルートとして動作する RP を設定する必要があります。

      ASM モードを有効にするには、スパース モードおよび RP の選択方式を設定します。RP の選択方式では、配信モードを指定して、マルチキャスト グループの範囲を割り当てます。

      スタティック RP の設定

      RP を静的に設定するには、PIM ドメインに参加するルータのそれぞれに RP アドレスを設定します。

      match ip multicast コマンドで、使用するグループ プレフィックスを示すルートマップ ポリシー名を指定できます。

      ip pim rp-address コマンドは、次の機能を追加して拡張されました。

      • 既存のルート マップ方式の他に設定のプレフィックス リスト方式が追加されました。
      • ポリシー アクションのサポートが追加されました(ルート マップまたはプレフィックス リスト)。

        (注)  


        Cisco NX-OS は RP を検索するには、最長一致プレフィックスを常に使用します。そのため、動作はルート マップまたはプレフィックス リストのグループ プレフィックスの位置にかかわらず同じです。


      次の設定例は、Cisco NX-OS を使用して同じ出力を生成します(231.1.1.0/24 はシーケンス番号に関係なく常に拒否されます)。

      
      ip prefix-list plist seq 10 deny 231.1.1.0/24
      ip prefix-list plist seq 20 permit 231.1.0.0/16
      ip prefix-list plist seq 10 permit 231.1.0.0/16
      ip prefix-list plist seq 20 deny 231.1.1.0/24
      
      スタティック RP の設定
      はじめる前に

      Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

      手順
         コマンドまたはアクション目的
        ステップ 1configure terminal


        例:
        switch# configure terminal
        switch(config)#
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2ip pim rp-address rp-address [group-list ip-prefix | route-map policy-name]


        例:
        switch(config)# ip pim rp-address 192.0.2.33 group-list 224.0.0.0/9
         

        マルチキャスト グループ範囲に、PIM スタティック RP アドレスを設定します。 match ip multicast コマンドで、使用するグループ プレフィックスを示すルートマップ ポリシー名を指定できます。 モードは ASM です。 デフォルトのグループ範囲は ff00::0/8 です。

        この例では、指定したグループ範囲に PIM ASM モードを設定しています。

         
        ステップ 3show ip pim group-range [ip-prefix | vrf vrf-name]


        例:
        switch(config)# show ip pim group-range
         
        (任意)

        BSR の受信/転送ステートなど、PIM RP 情報を表示します。

         
        ステップ 4copy running-config startup-config


        例:
        switch(config)# copy running-config startup-config
         
        (任意)

        実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

         

        BSR の設定

        BSR を設定するには、候補 BSR および候補 RP を選択します。


        注意    


        同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。


        候補 BSR の設定では、引数を指定できます(次の表を参照)。

        表 3 候補 BSR の引数

        引数

        説明

        interface

        ブートストラップ メッセージで使用する、BSR 送信元 IP アドレスを取得するためのインターフェイス タイプおよび番号。

        hash-length

        マスクを適用するために使用される上位桁の 1 の個数です。マスクでは、候補 RP のグループ アドレス範囲の論理積をとることにより、ハッシュ値を算出します。 マスクは、グループ範囲が等しい一連の RP に割り当てられる連続アドレスの個数を決定します。 この値の範囲は 0 ~ 32 であり、デフォルトは 30 です。

        priority

        現在の BSR に割り当てられたプライオリティ。 ソフトウェアにより、プライオリティが最も高い BSR が選定されます。BSR プライオリティが等しい場合は、IP アドレスが最上位の BSR が選定されます。 この値の範囲は 0(プライオリティが最小)~ 255 であり、デフォルト値は 64 です。

        BSR 候補 RP の引数およびキーワードの設定

        候補 RP の設定では、引数およびキーワードを指定できます(次の表を参照)。

        表 4 BSR 候補 RP の引数およびキーワード

        引数またはキーワード

        説明

        interface

        ブートストラップ メッセージで使用する、BSR 送信元 IP アドレスを取得するためのインターフェイス タイプおよび番号。

        group-list ip-prefix

        プレフィックス形式で指定された、この RP によって処理されるマルチキャスト グループ。

        interval

        候補 RP メッセージの送信間隔(秒)。 この値の範囲は 1 ~ 65,535 であり、デフォルト値は 60 秒です。

        (注)     

        候補 RP インターバルは 15 秒以上に設定することを推奨します。

        priority

        現在の RP に割り当てられたプライオリティ。 ソフトウェアにより、グループ範囲内でプライオリティが最も高い RP が選定されます。プライオリティが等しい場合は、IP アドレスが最上位の RP が選定されます。 (最も小さい数値が最も高いプライオリティになります)。この値の範囲は 0(最も高いプライオリティ)~ 255 で、デフォルトは 192 です。

        (注)     

        このプライオリティは BSR 候補プライオリティとは異なります。BSR 候補プライオリティは、0 ~ 255 の間で、高い値ほどプライオリティが高くなります。

        route-map policy-name

        この機能を適用するグループ プレフィックスを定義するルート マップ ポリシー名です。


        ヒント


        候補 BSR および候補 RP は、PIM ドメインのすべての箇所と適切に接続されている必要があります。


        BSR および候補 RP には同じルータを指定できます。 多数のルータが設置されたドメインでは、複数の候補 BSR および候補 RP を選択することにより、BSR または RP に障害が発生した場合に、自動的に代替 BSR または代替 RP へとフェールオーバーすることができます。

        候補 BSR および候補 RP を設定する手順は、次のとおりです。

        1. PIM ドメインの各ルータで BSR メッセージの受信と転送を行うかどうかを設定します。 候補 RP または候補 BSR として設定されたルータは、インターフェイスにドメイン境界機能が設定されていない場合、すべてのブートストラップ ルータ プロトコル メッセージの受信と転送を自動的に実行します。
        2. 候補 BSR および候補 RP として動作するルータを選択します。
        3. 後述の手順に従い、候補 BSR および候補 RP をそれぞれ設定します。
        4. BSR メッセージ フィルタリングを設定します。
        BSR の設定
        はじめる前に

        Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

        手順
           コマンドまたはアクション目的
          ステップ 1configure terminal


          例:
          switch# configure terminal
          switch(config)#
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2ip pim bsr {forward [listen] | listen [forward]}


          例:
          switch(config)# ip pim bsr listen forward
           

          リッスンと転送を設定します。

          リモート PE 上の各 VRF で確実にこのコマンドを入力してください。

           
          ステップ 3ip pim bsr [bsr-candidate] interface [hash-len hash-length] [priority priority]


          例:
          switch(config)# ip pim bsr-candidate ethernet 2/1 hash-len 24
           

          候補ブートストラップ ルータ(BSP)を設定します。 ブートストラップ メッセージで使用される送信元 IP アドレスは、インターフェイスの IP アドレスです。 ハッシュ長は 0 ~ 32 であり、デフォルト値は 30 です。 プライオリティは 0 ~ 255 であり、デフォルト値は 64 です。

           
          ステップ 4ip [bsr] rp-candidate interface group-list ip-prefix route-map policy-name priority priority interval interval


          例:
          switch(config)# ip pim rp-candidate ethernet 2/1 group-list 239.0.0.0/24
           
          (任意)

          BSR の候補 RP を設定します。 プライオリティは 0(プライオリティが最大)~ 65,535 であり、デフォルト値は 192 です。 インターバルは 1 ~ 65,535 秒であり、デフォルト値は 60 秒です。

          (注)     

          候補 RP インターバルは 15 秒以上に設定することを推奨します。

          この例では、ASM の候補 RP を設定しています。

           
          ステップ 5show ip pim group-range [ip-prefix | vrf vrf-name]


          例:
          switch(config)# show ip pim group-range
           
          (任意)

          PIM モードおよびグループ範囲を表示します。

           
          ステップ 6 copy running-config startup-config


          例:
          switch(config)# copy running-config startup-config
           
          (任意)

          実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

           

          Auto-RP の設定

          Auto-RP を設定するには、候補マッピング エージェントおよび候補 RP を選択します。 マッピング エージェントおよび候補 RP には同じルータを指定できます。


          注意    


          同じネットワーク内では、Auto-RP プロトコルと BSR プロトコルを同時に設定できません。


          Auto-RP マッピング エージェントの設定では、引数を指定できます(次の表を参照)。

          表 5 Auto-RP マッピング エージェントの引数

          引数

          説明

          interface

          ブートストラップ メッセージで使用する、Auto-RP マッピング エージェントの IP アドレスを取得するためのインターフェイス タイプおよび番号。

          scope ttl

          RP-Discovery メッセージが転送される最大ホップ数を表す存続可能時間(TTL)値。 この値の範囲は 1 ~ 255 であり、デフォルト値は 32 です。

          複数の Auto-RP マッピング エージェントを設定した場合、1 つだけがドメインのマッピング エージェントとして選定されます。 選定されたマッピング エージェントは、すべての候補 RP メッセージを配信します。 すべてのマッピング エージェントが配信された候補 RP メッセージを受信し、受信した RP キャッシュを、RP-Discovery メッセージの一部としてアドバタイズします。

          候補 RP の設定では、引数およびキーワードを指定できます(次の表を参照)。

          表 6 Auto-RP 候補 RP の引数およびキーワード

          引数またはキーワード

          説明

          interface

          ブートストラップ メッセージで使用する、候補 RP の IP アドレスを取得するためのインターフェイス タイプおよび番号。

          group-list ip-prefix

          現在の RP で処理されるマルチキャスト グループ。 プレフィックス形式で指定します。

          scope ttl

          RP-Discovery メッセージが転送される最大ホップ数を表す存続可能時間(TTL)値。 この値の範囲は 1 ~ 255 であり、デフォルト値は 32 です。

          interval

          RP-Announce メッセージの送信間隔(秒)。 この値の範囲は 1 ~ 65,535 であり、デフォルト値は 60 です。

          (注)     

          候補 RP インターバルは 15 秒以上に設定することを推奨します。

          route-map policy-name

          この機能を適用するグループ プレフィックスを定義するルート マップ ポリシー名です。


          ヒント


          マッピング エージェントおよび候補 RP は、PIM ドメインのすべての箇所と適切に接続されている必要があります。


          Auto-RP マッピング エージェントおよび候補 RP を設定する手順は、次のとおりです。

          1. PIM ドメインの各ルータで、Auto-RP メッセージの受信と転送を行うかどうかを設定します。 候補 RP または Auto-RP マッピング エージェントとして設定されたルータは、インターフェイスにドメイン境界機能が設定されていない場合、すべての Auto-RP プロトコル メッセージの受信と転送を自動的に実行します。
          2. マッピング エージェントおよび候補 RP として動作するルータを選択します。
          3. 後述の手順に従い、マッピング エージェントおよび候補 RP をそれぞれ設定します。
          4. Auto-RP メッセージ フィルタリングを設定します。

          Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

          Auto RP の設定
          はじめる前に

          Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

          手順
             コマンドまたはアクション目的
            ステップ 1configure terminal


            例:
            switch# configure terminal
            switch(config)#
             

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 2ip pim {send-rp-discovery | auto-rp mapping-agent} interface [scope ttl]


            例:
            switch(config)# ip pim auto-rp mapping-agent ethernet 2/1
             
            Auto-RP マッピング エージェントを設定します。 Auto-RP Discovery メッセージで使用される送信元 IP アドレスは、インターフェイスの IP アドレスです。 デフォルト スコープは 32 です。  
            ステップ 3ip pim {send-rp-announce | auto-rp rp-candidate} interface {group-list ip-prefix | route_map policy-name} [scope ttl] interval interval]


            例:
            switch(config)# ip pim auto-rp rp-candidate ethernet 2/1 group-list 239.0.0.0/24
             

            Auto-RP の候補 RP を設定します。 デフォルト スコープは 32 です。 デフォルト インターバルは 60 秒です。 デフォルトでは、ASM の候補 RP が作成されます。

            (注)     

            候補 RP インターバルは 15 秒以上に設定することを推奨します。

            この例では、ASM の候補 RP を設定しています。

             
            ステップ 4show ip pim group-range [ip-prefix | vrf vrf-name]


            例:
            switch(config)# show ip pim group-range
             
            (任意)

            PIM モードおよびグループ範囲を表示します。

             
            ステップ 5copy running-config startup-config


            例:
            switch(config)# copy running-config startup-config
             
            (任意)

            実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

             

            PIM Anycast-RP セットの設定

            PIM Anycast-RP セットを設定する手順は、次のとおりです。

            1. PIM Anycast-RP セットに属するルータを選択します。
            2. PIM Anycast-RP セットの IP アドレスを選択します。
            3. 後述の手順に従い、PIM Anycast-RP セットに属するそれぞれのピア RP を設定します。
            PIM Anycast RP セットの設定
            はじめる前に

            Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

            手順
               コマンドまたはアクション目的
              ステップ 1configure terminal


              例:
              switch# configure terminal
              switch(config)#
               

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2interface loopback number


              例:
              switch(config)# interface loopback 0
               

              インターフェイス ループバックを設定します。

              この例では、インターフェイス ループバックを 0 に設定しています。

               
              ステップ 3ip address ip-prefix


              例:
              switch(config-if)# ip address 192.0.2.3/32
               

              このインターフェイスの IP アドレスを設定します。

              この例では、Anycast-RP の IP アドレスを設定しています。

               
              ステップ 4ip pim sparse-mode


              例:
              switch(config)# ip pim sparse-mode
               

              PIM をイネーブルにします。

               
              ステップ 5 ip pim anycast-rp anycast-rp-address anycast-rp-peer-address


              例:
              switch(config)# ip pim anycast-rp 192.0.2.3 192.0.2.31
               

              指定した Anycast-RP アドレスに対応する PIM Anycast-RP ピア アドレスを設定します。 各コマンドで同じ Anycast-RP アドレスを指定して実行すると、Anycast-RP セットが作成されます。 RP の IP アドレスは、同一セット内の RP との通信に使用されます。

               
              ステップ 6RP セットに属する各 RP(ローカル ルータを含む)で、同じ Anycast-RP アドレスを使用してステップ 5 を繰り返します。  

               
              ステップ 7 show ip pim group-range [ip-prefix | vrf vrf-name]


              例:
              switch(config)# show ip pim group-range
               
              (任意)

              指定した Anycast-RP アドレスに対応する PIM Anycast-RP ピア アドレスを設定します。 各コマンドで同じ Anycast-RP アドレスを指定して実行すると、Anycast-RP セットが作成されます。 RP の IP アドレスは、同一セット内の RP との通信に使用されます。

               
              ステップ 8 copy running-config startup-config


              例:
              switch(config)# copy running-config startup-config
               
              (任意)

              実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

               

              ASM 専用の共有ツリーの設定

              共有ツリーを設定できるのは、Any Source Multicast(ASM)グループの最終ホップ ルータだけです。この場合、新たな受信者がアクティブ グループに加入した場合、このルータでは共有ツリーから SPT へのスイッチオーバーは実行されません。 match ip multicast コマンドで、共有ツリーを適用するグループ範囲を指定できます。 このオプションは、送信元ツリーに対する Join/Prune メッセージを受信した場合の、ルータの標準動作には影響を与えません。

              デフォルトではこの機能がディセーブルになっているため、ソフトウェアは送信元ツリーへのスイッチオーバーを行います。


              (注)  


              ASM モードでは、最終ホップ ルータだけが共有ツリーから SPT に切り替わります。
              ASM 専用の共有ツリーの設定
              はじめる前に

              Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

              手順
                 コマンドまたはアクション目的
                ステップ 1configure terminal


                例:
                switch# configure terminal
                switch(config)#
                 

                グローバル コンフィギュレーション モードを開始します。

                 
                ステップ 2ip pim use-shared-tree-only group-list policy-name


                例:
                switch(config)# ip pim use-shared-tree-only group-list my_group_policy
                 
                共有ツリーだけを構築します。共有ツリーから SPT へのスイッチオーバーは実行されません。 match ip multicast コマンドで、使用するグループを示すルートマップ ポリシー名を指定します。 デフォルトでは、送信元に対する (*, G) ステートのマルチキャスト パケットを受信すると、ソフトウェアは PIM (S, G) Join メッセージを送信元方向に発信します。  
                ステップ 3show ip pim group-range [ip-prefix | vrf vrf-name]


                例:
                switch(config)# show ip pim group-range
                 
                (任意)

                PIM モードおよびグループ範囲を表示します。

                 
                ステップ 4copy running-config startup-config


                例:
                switch(config-if)# copy running-config startup-config
                 
                (任意)

                実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                 

                マルチキャスト用 RPF ルートの設定

                ユニキャスト トラフィック パスを分岐させてマルチキャスト データを配信するには、マルチキャスト用 RPF ルートを定義します。 境界ルータにマルチキャスト用 RPF ルートを定義すると、外部ネットワークへの Reverse Path Forwarding(RPF)がイネーブルになります。

                マルチキャスト ルートはトラフィック転送に直接使用されるわけではなく、RPF チェックのために使用されます。 マルチキャスト用 RPF ルートは再配布できません。


                (注)  


                IPv6 ではスタティック マルチキャスト ルートはサポートされていません。


                はじめる前に

                Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

                手順
                   コマンドまたはアクション目的
                  ステップ 1configure terminal


                  例:
                  switch# configure terminal
                  switch(config)#
                   

                  グローバル コンフィギュレーション モードを開始します。

                   
                  ステップ 2ip mroute {ip-addr mask | ip-prefix} {next-hop | nh-prefix | interface} [route-preference] [vrf vrf-name]


                  例:
                  switch(config)# ip mroute 192.0.2.33/1 224.0.0.0/1
                   
                  RPF 計算で使用するマルチキャスト用 RPF ルートを設定します。 ルート プリファレンスは 1 ~ 255 です。 デフォルト プリファレンスは 1 です。  
                  ステップ 3show ip static-route [multicast] [vrf vrf-name]


                  例:
                  switch(config)# show ip static-route multicast
                   
                  (任意) 設定されているスタティック ルートを表示します。  
                  ステップ 4copy running-config startup-config
                   
                  (任意)

                  実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                   

                  マルチキャスト マルチパスのディセーブル化

                  デフォルトでは、使用可能な複数の ECMP パスがある場合、マルチキャストの RPF インターフェイスが自動的に選択されます。 自動選択をディセーブルにすると、マルチキャストに単一の RPF インターフェイスを指定することができます。

                  手順
                     コマンドまたはアクション目的
                    ステップ 1configure terminal


                    例:
                    switch# configure terminal
                    switch(config)#
                     

                    グローバル コンフィギュレーション モードを開始します。

                     
                    ステップ 2 ip multicast multipath {none | s-g-hash next-hop-based}


                    例:
                    switch(config)# ip multicast multipath none
                     

                    マルチキャスト マルチパスをディセーブルにするか、デフォルトの (S/RP G) ベースのハッシュの代わりに (S, G, Nexthop) に基づいてハッシュを開始します。

                     
                    ステップ 3clear ip mroute *


                    例:
                    switch(config)# clear ip mroute *
                    
                     

                    マルチパス ルートをクリアし、マルチキャスト マルチパス抑制をアクティブにします。

                     

                    RP 情報配信を制御するルート マップの設定

                    ルート マップは、一部の RP 設定のミスや悪意のある攻撃に対する保護機能を提供します。

                    ルート マップを設定すると、ネットワーク全体について RP 情報の配信を制御できます。 各クライアント ルータで発信元の BSR またはマッピング エージェントを指定したり、各 BSR およびマッピング エージェントで、アドバタイズされる(発信元の)候補 RP のリストを指定したりできるため、目的の情報だけが配信されるようになります。

                    Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

                    RP 情報配信を制御するルート マップの設定

                    手順
                       コマンドまたはアクション目的
                      ステップ 1configure terminal


                      例:
                      switch# configure terminal
                      switch(config)#
                       

                      グローバル コンフィギュレーション モードを開始します。

                       
                      ステップ 2route-map map-name [permit | deny] [sequence-number]


                      例:
                      switch(config)# route-map ASM_only permit 10
                      switch(config-route-map)#
                       

                      ルートマップ コンフィギュレーション モードを開始します。

                       
                      ステップ 3match ip multicast {rp ip-address [rp-type rp-type]} {{group-range {gadrr_start to gadrr_end} | {group ip-prefix}} {source source-ip-address}


                      例:
                      switch(config-route-map)# match ip multicast group 224.0.0.0/4 rp 0.0.0.0/0 rp-type ASM
                       

                      指定したグループ、RP、および RP タイプを関連付けます。 ユーザは RP のタイプ(ASM)を指定できます。 例で示すとおり、このコンフィギュレーション方式では、グループおよび RP を指定する必要があります。

                      (注)     

                      BSR RP、Auto-RP、およびスタティック RP では、group-range キーワードは使用できません。 このコマンドは、permit または deny を許可します。 一部の match mask コマンドは、permit または deny を許可しません。

                       
                      ステップ 4show route-map


                      例:
                      switch(config-route-map)# show route-map
                       
                      (任意)

                      設定されたルート マップを表示します。

                       
                      ステップ 5copy running-config startup-config


                      例:
                      switch(config-route-map)# copy running-config startup-config
                       
                      (任意)

                      実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                       

                      メッセージ フィルタリングの設定


                      (注)  


                      rp-candidate-policy でのプレフィックスの照合では、プレフィックスが c-rp によるアドバタイズの内容と比較して完全に一致する必要があります。 部分一致は許容されません。


                      次の表に、PIM でのメッセージ フィルタリングの設定方法を示します。

                      表 7 PIM でのメッセージ フィルタリング

                      メッセージの種類

                      説明

                      デバイスにグローバルに適用

                      ネイバーの変更の記録

                      ネイバーのステート変更を通知する Syslog メッセージをイネーブルにします。 デフォルトでは無効になっています。

                      PIM Register ポリシー

                      ルートマップ ポリシーに基づく、PIM Register メッセージのフィルタリングをイネーブルにします。2 match ip multicast コマンドで、グループ アドレスまたはグループと送信元アドレスを指定できます。 このポリシーは、RP として動作するルータに適用されます。 デフォルトではこの機能がディセーブルになっているため、PIM Register メッセージのフィルタリングは行われません。

                      BSR 候補 RP ポリシー

                      ルートマップ ポリシーに基づいてルータが BSR 候補 RP メッセージをフィルタリングできるようにします。match ipコマンドで、RP、グループ アドレスを指定できます。 このコマンドは、BSR の選定対象のルータで使用できます。 デフォルトでは、BSR メッセージはフィルタリングされません。

                      BSR ポリシー

                      ルートマップ ポリシーに基づく、BSR クライアント ルータによる BSR メッセージのフィルタリングをイネーブルにします。match ip コマンドで、BSR 送信元アドレスを指定できます。 このコマンドは、BSR メッセージを受信するクライアント ルータで使用できます。 デフォルトでは、BSR メッセージはフィルタリングされません。

                      Auto-RP 候補 RP ポリシー

                      ルートマップ ポリシーに基づく、Auto-RP マッピング エージェントによる Auto-RP Announce メッセージのフィルタリングをイネーブルにします。match ip multicast コマンドで、RP、グループ アドレスを指定できます。 このコマンドは、マッピング エージェントで使用できます。 デフォルトでは、Auto-RP メッセージはフィルタリングされません。

                      Auto-RP マッピング エージェント ポリシー

                      ルートマップ ポリシーに基づく、クライアント ルータによる Auto-RP Discovery メッセージのフィルタリングをイネーブルにします。match ip multicast コマンドで、マッピング エージェント送信元アドレスを指定できます。 このコマンドは、Discovery メッセージを受信するクライアント ルータで使用できます。 デフォルトでは、Auto-RP メッセージはフィルタリングされません。

                      デバイスの各インターフェイスに適用

                      Join/Prune ポリシー

                      ルートマップ ポリシーに基づく、Join/Prune メッセージのフィルタリングをイネーブルにします。match ipコマンドで、グループ、グループと送信元、またはグループと RP アドレスを指定できます。 デフォルトでは、Join/Prune メッセージはフィルタリングされません。

                      2 ルート マップ ポリシーの設定方法については、『Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

                      次のコマンドでは、ルート マップをフィルタリング ポリシーとして使用できます(各ステートメントについて permit または deny のいずれか)。

                      • jp-policy コマンドでは (S,G)、(*,G)、または (RP,G) を使用できます。
                      • register-policy コマンドでは (S,G) または (*,G) を使用できます。
                      • igmp report-policy コマンドでは (*,G) または (S,G) を使用できます。
                      • state-limit reserver-policy コマンドでは (*,G) または (S,G) を使用できます。
                      • auto-rp rp-candidate-policy コマンドでは (RP,G) を使用できます。
                      • bsr rp-candidate-policy コマンドでは (RP,G) を使用できます。
                      • autorp mapping-agent policy コマンドでは (S) を使用できます。
                      • bsr bsr-policy コマンドでは (S) を使用できます。

                      次のコマンドでは、ルート マップ アクション(permit または deny)が無視された場合に、ルート マップをコンテナとして使用できます。

                      • ip pim rp-address route map コマンドでは G のみを使用できます。
                      • ip igmp static-oif route map コマンドでは (S,G)、(*,G)、(S,G-range)、(*,G-range) を使用できます。
                      • ip igmp join-group route map コマンドでは (S,G)、(*,G)、(S,G-range)、(*,G-range) を使用できます。

                      メッセージ フィルタリング(PIM)の設定

                      はじめる前に

                      Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

                      手順
                         コマンドまたはアクション目的
                        ステップ 1configure terminal


                        例:
                        switch# configure terminal
                        switch(config)#
                         

                        グローバル コンフィギュレーション モードを開始します。

                         
                        ステップ 2ip pim log-neighbor-changes


                        例:
                        switch(config)# ip pim log-neighbor-changes
                         
                        (任意) ネイバーのステート変更を通知する Syslog メッセージをイネーブルにします。 デフォルトではディセーブルになっています。  
                        ステップ 3ip pim register-policy policy-name


                        例:
                        switch(config)# ip pim register-policy my_register_policy
                         
                        (任意)

                        ルートマップ ポリシーに基づく、PIM Register メッセージのフィルタリングをイネーブルにします。 match ip multicast コマンドで、グループ アドレスまたはグループと送信元アドレスを指定できます。

                         
                        ステップ 4ip pim bsr rp-candidate-policy policy-name


                        例:
                        switch(config)# ip pim bsr rp-candidate-policy my_bsr_rp_candidate_policy
                         
                        (任意)

                        ルートマップ ポリシーに基づいてルータが BSR 候補 RP メッセージをフィルタリングできるようにします。match ip multicast コマンドで、RP、グループ アドレスを指定できます。 このコマンドは、BSR の選定対象のルータで使用できます。 デフォルトでは、BSR メッセージはフィルタリングされません。

                         
                        ステップ 5ip pim bsr bsr-policy policy-name


                        例:
                        switch(config)# ip pim bsr bsr-policy my_bsr_policy
                         
                        (任意)

                        ルートマップ ポリシーに基づく、BSR クライアント ルータによる BSR メッセージのフィルタリングをイネーブルにします。match ip multicast コマンドで、BSR 送信元アドレスを指定できます。 このコマンドは、BSR メッセージを受信するクライアント ルータで使用できます。 デフォルトでは、BSR メッセージはフィルタリングされません。

                         
                        ステップ 6 ip pim auto-rp rp-candidate-policy policy-name


                        例:
                        switch(config)# ip pim auto-rp rp-candidate-policy my_auto_rp_candidate_policy
                         
                        (任意)

                        ルートマップ ポリシーに基づく、Auto-RP マッピング エージェントによる Auto-RP Announce メッセージのフィルタリングをイネーブルにします。match ip multicast コマンドで、RP、グループ アドレスを指定できます。 このコマンドは、マッピング エージェントで使用できます。 デフォルトでは、Auto-RP メッセージはフィルタリングされません。

                         
                        ステップ 7ip pim auto-rp mapping-agent-policy policy-name


                        例:
                        switch(config)# ip pim auto-rp mapping-agent-policy my_auto_rp_mapping_policy
                         
                        (任意)

                        ルートマップ ポリシーに基づく、クライアント ルータによる Auto-RP Discovery メッセージのフィルタリングをイネーブルにします。match ip multicast コマンドで、マッピング エージェント送信元アドレスを指定できます。 このコマンドは、Discovery メッセージを受信するクライアント ルータで使用できます。 デフォルトでは、Auto-RP メッセージはフィルタリングされません。

                         
                        ステップ 8interface interface


                        例:
                        switch(config)# interface ethernet 2/1
                        switch(config-if)#
                         

                        指定したインターフェイスでインターフェイス モードを開始します。

                         
                        ステップ 9ip pim jp-policy policy-name [in | out]


                        例:
                        switch(config-if)# ip pim jp-policy my_jp_policy
                         
                        (任意)

                        ルートマップ ポリシーに基づく、Join/Prune メッセージのフィルタリングをイネーブルにします。match ip multicast コマンドで、グループ、グループと送信元、またはグループと RP アドレスを指定できます。 デフォルトでは、Join/Prune メッセージはフィルタリングされません。

                         
                        ステップ 10show run pim


                        例:
                        switch(config-if)# show run pim
                         
                        (任意)

                        PIM コンフィギュレーション コマンドを表示します。

                         
                        ステップ 11copy running-config startup-config


                        例:
                        switch(config-if)# copy running-config startup-config
                         
                        (任意)

                        実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                         

                        PIM プロセスの再起動

                        PIM プロセスを再起動し、オプションとして、すべてのルートをフラッシュすることができます。 デフォルトでは、ルートはフラッシュされません。

                        フラッシュされたルートは、Multicast Routing Information Base(MRIB)および Multicast Forwarding Information Base(MFIB)から削除されます。

                        PIM を再起動すると、次の処理が実行されます。

                        • PIM データベースが削除されます。
                        • MRIB および MFIB は影響を受けず、トラフィックは引き続き転送されます。
                        • マルチキャスト ルートの所有権が MRIB 経由で検証されます。
                        • ネイバーから定期的に送信される PIM Join メッセージおよび Prune メッセージを使用して、データベースにデータが再度読み込まれます。

                        PIM プロセスの再起動

                        はじめる前に

                        Enterprise Services ライセンスがインストールされていること、および PIM がイネーブルになっていることを確認してください。

                        手順
                           コマンドまたはアクション目的
                          ステップ 1restart pim


                          例:
                          switch# restart pim
                           

                          PIM プロセスを再起動します。

                           
                          ステップ 2configure terminal


                          例:
                          switch# configure terminal
                          switch(config)#
                           

                          グローバル コンフィギュレーション モードを開始します。

                           
                          ステップ 3ip pim flush-routes


                          例:
                          switch(config)# ip pim flush-routes
                           
                          PIM プロセスの再起動時に、ルートを削除します。 デフォルトでは、ルートはフラッシュされません。  
                          ステップ 4show running-configuration pim


                          例:
                          switch(config)# show running-configuration pim
                           
                          (任意)

                          flush-routes コマンドを含む、PIM 実行コンフィギュレーション情報を示します。

                           
                          ステップ 5copy running-config startup-config


                          例:
                          switch(config)# copy running-config startup-config
                           
                          (任意)

                          実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                           

                          VRF モードでの PIM の BFD の設定


                          (注)  


                          VRF またはインターフェイスを使用して PIM の双方向フォワーディング検出(BFD)を設定できます。


                          はじめる前に

                          Enterprise Services ライセンスがインストールされていること、PIM がイネーブルになっていること、および BFD がイネーブルになっていることを確認してください。

                          手順
                             コマンドまたはアクション目的
                            ステップ 1configure terminal


                            例:
                            switch# configure terminal
                            switch(config)#
                             

                            グローバル コンフィギュレーション モードを開始します。

                             
                            ステップ 2vrf context vrf-name


                            例:
                            switch# vrf context test
                            switch(config-vrf)#
                             

                            VRF コンフィギュレーション モードを開始します。

                             
                            ステップ 3ip pim bfd


                            例:
                            switch(config-vrf)# ip pim bfd
                             

                            指定された VRF で BFD をイネーブルにします。

                            (注)     

                            コンフィギュレーション モードで ip pim bfd コマンドを入力して、VRF インスタンス上の BFD をイネーブルにすることもできます。

                             

                            インターフェイス モードでの PIM の BFD の設定

                            はじめる前に

                            Enterprise Services ライセンスがインストールされていること、PIM がイネーブルになっていること、および BFD がイネーブルになっていることを確認してください。

                            手順
                               コマンドまたはアクション目的
                              ステップ 1configure terminal


                              例:
                              switch# configure terminal
                              switch(config)#
                               

                              グローバル コンフィギュレーション モードを開始します。

                               
                              ステップ 2interface interface-type


                              例:
                              switch(config)# interface ethernet 7/40
                              switch(config-if)#
                               

                              インターフェイス コンフィギュレーション モードを開始します。

                               
                              ステップ 3ip pim bfd instance


                              例:
                              switch(config-if)# ip pim bfd instance
                               

                              指定したインターフェイスの BFD をイネーブルにします。 VRF の BFD をイネーブルにするかどうかに関係なく、PIM インターフェイスの BFD をイネーブルまたはディセーブルにすることができます。

                               
                              ステップ 4show running-configuration pim


                              例:
                              switch(config-if)# show running-configuration pim
                               
                              (任意)

                              PIM 実行コンフィギュレーション情報を表示します。

                               
                              ステップ 5copy running-config startup-config


                              例:
                              switch(config-if)# copy running-config startup-config
                               
                              (任意)

                              実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

                               

                              PIM の設定の確認

                              PIM の設定情報を表示するには、次のいずれかの作業を行います。

                              コマンド

                              説明

                              show ip mroute

                              IP マルチキャスト ルーティング テーブルを表示します。

                              show ip pim df [vrf vrf-name]

                              各 RP の Designated Forwarder(DF)情報をインターフェイス別に表示します。

                              show ip pim group-range [vrf vrf-name]

                              学習済みまたは設定済みのグループ範囲およびモードを表示します。 同様の情報については、show ip pim rp コマンドを参照してください。

                              show ip pim interface [interface | brief] [vrf vrf-name]

                              情報をインターフェイス別に表示します。

                              show ip pim neighbor [vrf vrf-name]

                              ネイバーをインターフェイス別に表示します。

                              show ip pim oif-list group [source] [vrf vrf-name]

                              発信インターフェイス(OIF)リスト内のすべてのインターフェイスを表示します。

                              show ip pim route [source group | group [source]][vrf vrf-name]

                              各マルチキャスト ルートの情報を表示します。指定した (S, G) に対して、PIM Join メッセージを受信したインターフェイスなどを表示できます。

                              show ip pim rp [vrf vrf-name]

                              ソフトウェアの既知の Rendezvous Point(RP; ランデブー ポイント)およびその学習方法と、それらのグループ範囲を表示します。 同様の情報については、show ip pim group-range コマンドを参照してください。

                              show ip pim rp-hash group-address

                              ブートストラップ ルータ(BSP)RP ハッシュ情報を表示します。 RP ハッシュの詳細については、RFC 5059 を参照してください。

                              show running-configuration pim

                              実行コンフィギュレーション情報を表示します。

                              show startup-configuration pim

                              スタートアップ コンフィギュレーション情報を表示します。

                              show ip pim vrf [vrf-name | all] [detail]

                              各 VRF の情報を表示します。

                              統計情報の表示

                              次に、PIM の統計情報を、表示およびクリアするためのコマンドについて説明します。

                              PIM の統計情報の表示

                              これらのコマンドを使用すると、PIM の統計情報とメモリ使用状況を表示できます。

                              コマンド

                              説明

                              show ip pim policy statistics

                              Register、RP、および Join/Prune メッセージのポリシーについて、ポリシー統計情報を表示します。

                              show ip pim statistics [vrf vrf-name]

                              グローバル統計情報を表示します。

                              PIM の統計情報のクリア

                              これらのコマンドを使用すると、PIM 統計情報をクリアできます。

                              コマンド

                              説明

                              clear ip pim interface statistics interface

                              指定したインターフェイスのカウンタをクリアします。

                              clear ip pim policy statistics

                              Register、RP、および Join/Prune メッセージのポリシーについて、ポリシー カウンタをクリアします。

                              clear ip pim statistics [vrf vrf-name]

                              PIM プロセスで使用されるグローバル カウンタをクリアします。

                              PIM の設定例

                              ここでは、さまざまなデータ配信モードおよび RP 選択方式を使用し、PIM を設定する方法について説明します。

                              BSR の設定例

                              BSR メカニズムを使用して ASM モードで PIM を設定するには、PIM ドメイン内の各ルータで、次の手順を実行します。

                              1. ドメインに参加させるインターフェイスで PIM スパース モード パラメータを設定します。 すべてのインターフェイスで PIM をイネーブルにすることを推奨します。
                                
                                switch# configure terminal
                                switch(config)# interface ethernet 2/1
                                switch(config-if)# ip pim sparse-mode
                                
                                
                              2. ルータが BSR メッセージの受信と転送を行うかどうかを設定します。
                                
                                switch# configure terminal
                                switch(config)# ip pim bsr forward listen
                                
                                
                              3. BSR として動作させるルータのそれぞれに、BSR パラメータを設定します。
                                switch# configure terminal
                                switch(config)# ip pim bsr-candidate ethernet 2/1 hash-len 30
                                
                                
                              4. 候補 RP として動作させるルータのそれぞれに、RP パラメータを設定します。
                                switch# configure terminal
                                switch(config)# ip pim rp-candidate ethernet 2/1 group-list 239.0.0.0/24
                                
                                
                              5. メッセージ フィルタリングを設定します。
                                switch# configure terminal
                                switch(config)# ip pim log-neighbor-changes
                                
                                

                              次に、BSR メカニズムを使用して PIM ASM モードを設定し、同一のルータに BSR と RP を設定する場合の例を示します。

                              
                              configure terminal
                                interface ethernet 2/1
                                  ip pim sparse-mode
                                  exit
                                ip pim bsr forward listen
                              ip pim bsr-candidate ethernet 2/1 hash-len 30
                                ip pim rp-candidate ethernet 2/1 group-list 239.0.0.0/24
                                ip pim log-neighbor-changes
                              
                              

                              PIM Anycast RP の設定例

                              PIM Anycast-RP 方式を使用して ASM モードを設定するには、PIM ドメイン内の各ルータで、次の手順を実行します。

                              1. ドメインに参加させるインターフェイスで PIM スパース モード パラメータを設定します。 すべてのインターフェイスで PIM をイネーブルにすることを推奨します。
                                switch# configure terminal
                                switch(config)# interface ethernet 2/1
                                switch(config-if)# ip pim sparse-mode
                                
                                
                              2. Anycast-RP セット内のすべてのルータに適用する RP アドレスを設定します。
                                switch# configure terminal
                                switch(config)# interface loopback 0
                                switch(config-if)# ip address 192.0.2.3/32
                                
                                
                              3. Anycast-RP セットに加える各ルータで、その Anycast-RP セットに属するルータ間で通信に使用するアドレスを指定し、ループバックを設定します。
                                switch# configure terminal
                                switch(config)# interface loopback 1
                                switch(config-if)# ip address 192.0.2.31/32
                                
                                
                              4. Anycast-RP セットに加える各ルータについて、Anycast-RP パラメータとして Anycast-RP の IP アドレスを指定します。同じ作業を、Anycast-RP の各 IP アドレスで繰り返します。 この例では、2 つの Anycast-RP を指定しています。
                                switch# configure terminal
                                switch(config)# ip pim anycast-rp 192.0.2.3 193.0.2.31
                                switch(config)# ip pim anycast-rp 192.0.2.3 193.0.2.32
                                
                                
                              5. メッセージ フィルタリングを設定します。
                                switch# configure terminal
                                switch(config)# ip pim log-neighbor-changes
                                
                                

                              次に、2 つの Anycast-RP を使用し、PIM ASM モードを設定する場合の例を示します。

                              configure terminal
                              interface ethernet 2/1
                              ip pim sparse-mode
                              exit
                              interface loopback 0
                              ip address 192.0.2.3/32
                              exit
                              ip pim anycast-rp 192.0.2.3 192.0.2.31
                              ip pim anycast-rp 192.0.2.3 192.0.2.32
                              ip pim log-neighbor-changes
                              
                              

                              Prefix-Based および Route-Map-Based の設定

                              
                              ip prefix-list plist11 seq 10 deny 231.129.128.0/17
                              ip prefix-list plist11 seq 20 deny 231.129.0.0/16
                              ip prefix-list plist11 seq 30 deny 231.128.0.0/9
                              ip prefix-list plist11 seq 40 permit 231.0.0.0/8
                              
                              ip prefix-list plist22 seq 10 deny 231.129.128.0/17
                              ip prefix-list plist22 seq 20 deny 231.129.0.0/16
                              ip prefix-list plist22 seq 30 permit 231.128.0.0/9
                              ip prefix-list plist22 seq 40 deny 231.0.0.0/8
                              
                              ip prefix-list plist33 seq 10 deny 231.129.128.0/17
                              ip prefix-list plist33 seq 20 permit 231.129.0.0/16
                              ip prefix-list plist33 seq 30 deny 231.128.0.0/9
                              ip prefix-list plist33 seq 40 deny 231.0.0.0/8
                              
                              ip pim rp-address 172.21.0.11 prefix-list plist11
                              ip pim rp-address 172.21.0.22 prefix-list plist22
                              ip pim rp-address 172.21.0.33 prefix-list plist33
                              route-map rmap11 deny 10
                               match ip multicast group 231.129.128.0/17
                              route-map rmap11 deny 20
                               match ip multicast group 231.129.0.0/16
                              route-map rmap11 deny 30
                               match ip multicast group 231.128.0.0/9
                              route-map rmap11 permit 40
                               match ip multicast group 231.0.0.0/8
                              
                              route-map rmap22 deny 10
                               match ip multicast group 231.129.128.0/17
                              route-map rmap22 deny 20
                               match ip multicast group 231.129.0.0/16
                              route-map rmap22 permit 30
                               match ip multicast group 231.128.0.0/9
                              route-map rmap22 deny 40
                               match ip multicast group 231.0.0.0/8
                              
                              route-map rmap33 deny 10
                               match ip multicast group 231.129.128.0/17
                              route-map rmap33 permit 20
                               match ip multicast group 231.129.0.0/16
                              route-map rmap33 deny 30
                               match ip multicast group 231.128.0.0/9
                              route-map rmap33 deny 40
                               match ip multicast group 231.0.0.0/8
                              
                              ip pim rp-address 172.21.0.11 route-map rmap11
                              ip pim rp-address 172.21.0.22 route-map rmap22
                              ip pim rp-address 172.21.0.33 route-map rmap33
                              

                              出力

                              
                              dc3rtg-d2(config-if)# show ip pim rp
                              PIM RP Status Information for VRF "default"
                              BSR disabled
                              Auto-RP disabled
                              BSR RP Candidate policy: None
                              BSR RP policy: None
                              Auto-RP Announce policy: None
                              Auto-RP Discovery policy: None
                              
                              RP: 172.21.0.11, (0), uptime: 00:12:36, expires: never,
                                priority: 0, RP-source: (local), group-map: rmap11, group ranges:
                                    231.0.0.0/8  231.128.0.0/9 (deny)
                                    231.129.0.0/16 (deny) 231.129.128.0/17 (deny)
                              RP: 172.21.0.22, (0), uptime: 00:12:36, expires: never,
                                priority: 0, RP-source: (local), group-map: rmap22, group ranges:
                                    231.0.0.0/8 (deny) 231.128.0.0/9
                                    231.129.0.0/16 (deny) 231.129.128.0/17 (deny)
                              RP: 172.21.0.33, (0), uptime: 00:12:36, expires: never,
                                priority: 0, RP-source: (local), group-map: rmap33, group ranges:
                                    231.0.0.0/8 (deny) 231.128.0.0/9 (deny)
                                    231.129.0.0/16  231.129.128.0/17 (deny)
                              
                              dc3rtg-d2(config-if)# show ip mroute
                              IP Multicast Routing Table for VRF "default"
                              
                              (*, 231.1.1.1/32), uptime: 00:07:20, igmp pim ip
                                Incoming interface: Ethernet2/1, RPF nbr: 10.165.20.1
                                Outgoing interface list: (count: 1)
                                  loopback1, uptime: 00:07:20, igmp
                              
                              (*, 231.128.1.1/32), uptime: 00:14:27, igmp pim ip
                                Incoming interface: Ethernet2/1, RPF nbr: 10.165.20.1
                                Outgoing interface list: (count: 1)
                                  loopback1, uptime: 00:14:27, igmp
                              
                              (*, 231.129.1.1/32), uptime: 00:14:25, igmp pim ip
                                Incoming interface: Ethernet2/1, RPF nbr: 10.165.20.1
                                Outgoing interface list: (count: 1)
                                  loopback1, uptime: 00:14:25, igmp
                              
                              (*, 231.129.128.1/32), uptime: 00:14:26, igmp pim ip
                                Incoming interface: Null, RPF nbr: 10.0.0.1
                                Outgoing interface list: (count: 1)
                                  loopback1, uptime: 00:14:26, igmp
                              
                              (*, 232.0.0.0/8), uptime: 1d20h, pim ip
                                Incoming interface: Null, RPF nbr: 10.0.0.1
                                Outgoing interface list: (count: 0)
                              
                              dc3rtg-d2(config-if)# show ip pim group-range
                              PIM Group-Range Configuration for VRF "default"
                              Group-range        Mode      RP-address       Shared-tree-only range
                              231.0.0.0/8        ASM       172.21.0.11       -
                              231.128.0.0/9      ASM       172.21.0.22       -
                              231.129.0.0/16     ASM       172.21.0.33       -
                              231.129.128.0/17   Unknown   -                -
                              

                              関連資料

                              関連項目

                              参照先

                              VRFの設定

                              『Cisco Nexus 9000 Series NX-OS Unicast Routing Configuration Guide』

                              標準

                              標準

                              タイトル

                              この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

                              MIB

                              MIB

                              MIB リンク

                              PIM に関連した MIB

                              サポートされている MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

                              ftp:/​/​ftp.cisco.com/​pub/​mibs/​supportlists/​nexus9000/​Nexus9000MIBSupportList.html