Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス リリース 5.x
V コマンド
V コマンド
発行日;2012/05/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

V コマンド

vrf

vrf context

vrf member

vrrp

V コマンド

この章では、V で始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

vrf

VPN Routing and Forwarding instance(VRF)を作成したり、VRF コンフィギュレーション モードに入って Intermediate System-to-Intermediate System Intradomain Routing Protoco(IS-IS)のサブモード コマンドを設定したりするには、 vrf コマンドを使用します。VRF インスタンスの削除または VRF コンフィギュレーション モードをディセーブルにするには、このコマンドの no 形式を使用します。

vrf name | management

no vrf name | management

 
構文の説明

name

VRF の名前。

management

設定可能な VRF 名を指定します。

 
コマンド デフォルト

なし

 
コマンド モード

アドレスファミリ コンフィギュレーション
ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

各 VRF モードは、IS-IS プロセス内で独立したインスタンスとして機能します。グローバル コンフィギュレーション モードで使用できるすべてのコンフィギュレーション コマンドが、新しい VRF モードで使用できます。たとえば、各 VRF モードには専用の NET が設定されており、モード特有のインスタンスが機能するようになっています。すべての EXEC コマンドを VRF 単位に指定することが可能で、引数を使用しないものはデフォルトの VRF に適用されます。インターフェイスは特定の VRF に所属し、ip/ipv6 router isis コマンドを使用して適切なインターフェイスが特定のインターフェイスだけに適用されることに注意してください。

VRF は、グローバル コンフィギュレーション モードで同じ名前の VRF が作成されるまでアクティブになりません。

VRF コンフィギュレーション モードを開始すると、次のコマンドが使用可能になります。

address-family :アドレス ファミリを設定します。詳細については、 address-family(BGP) コマンドを参照してください。

authentication key-chain :認証キー チェーン文字列を設定します。詳細については、 authentication key-chain コマンドを参照してください。

authentication-check :認証をチェックします。詳細については、 authentication-check コマンドを参照してください。

authentication-type :認証タイプをチェックします。詳細については、 authentication-type コマンドを参照してください。

default-information :デフォルト ルートの発信側を制御します。詳細については、 default-information originate(IS-IS) コマンドを参照してください。

distance :アドミニストレーティブ ディスタンスを設定します。詳細については、 distance(IS-IS) コマンドを参照してください。

distribute :IS-IS レベル間でルートを配布します。詳細については、 distribute コマンドを参照してください。

exit :現在のコマンド モードを終了します。

graceful-restart :IS-IS プロセスのグレースフル リスタートをイネーブルにします。詳細については、 graceful-restart(BGP) コマンドを参照してください。

hostname :IS-IS のダイナミック ホスト名を設定します。詳細については、 hostname dynamic コマンドを参照してください。

is-type :この IS-IS プロセスの IS タイプを設定します。詳細については、 is-type コマンドを参照してください。

log-adjacency-changes :隣接関係ステートの変更を記録します。詳細については、 log-adjacency-changes(IS-IS コマンドを参照してください。

lsp-gen-interval :LSP の生成インターバルを設定します。詳細については、 lsp-gen-interval コマンドを参照してください。

lsp-mtu :LSP MTU を設定します。詳細については、 lsp-mtu コマンドを参照してください。

max‐lsp‐lifetime :最大 LSP ライフタイムを設定します。詳細については、 max-lsp-lifetime コマンドを参照してください。

maximum-paths :宛先当たりの最大パス数を設定します。詳細については、 maximum-paths(IS-IS) コマンドを参照してください。

net :この IS-IS プロセスの Network Entity Title(NET)を設定します。詳細については、 net コマンドを参照してください。

no :コマンドを無効にするか、そのデフォルトに設定します。

redistribute :別のルーティング プロトコルからの情報を再配布します。詳細については、 redistribute(IS-IS コマンドを参照してください。

reference-bandwidth :インターフェイス メトリックの設定に使用される基準帯域幅を変更します。詳細については、 reference-bandwidth コマンドを参照してください。

set-overload-bit :このルータを中継に使用しないよう他のルータに通知します。詳細については、 set-overload-bit コマンドを参照してください。

shutdown :この IS-IS プロセスをシャットダウンします。詳細については、 shutdown(IS-IS) コマンドを参照してください。

spf-interval :SPF インターバルを設定します。詳細については、 spf-interval コマンドを参照してください。

summary-address :IP アドレス サマリーを設定します。詳細については、 summary-address コマンドを参照してください。

wide-metric-only :ワイド メトリックのみをアドバタイズします。詳細については、 wide-metric-only コマンドを参照してください。

次に、VRF コンフィギュレーション モードを開始する例を示します。

switch(config)# router isis 100
switch(config-router)# vrf management
switch(config-router-vrf)#

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ モードまたは VRF アドレスファミリ モードを開始します。

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

vrf context

Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)インスタンスを作成し、VRF コンフィギュレーション モードを開始するには、 VRF ルータ BGP コンフィギュレーション コマンドを使用します。VRF エントリを削除するには、このコマンドの no 形式を使用します。

vrf context { name | management }

no vrf contex t { name | management }

 
構文の説明

name

VRF の名前。 name には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

management

設定可能な VRF 名を指定します。

 
コマンド デフォルト

このコマンドには、デフォルト設定はありません。

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション
ルータ BGP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

VRF は、グローバル コンフィギュレーション モードで同じ名前の VRF が作成されるまでアクティブになりません。

VRF コンフィギュレーション モードを開始すると、次のコマンドが使用可能になります。

address-family :アドレスファミリを設定します。詳細については、 address-family(BGP) コマンドを参照してください。

cluster-id { cluster-id | cluster-ip-addr } :ルート リフレクタのクラスタ ID(ルータ、VRF)を設定します。範囲は 1 ~ 4294967295 です。クラスタ ID は、32 ビットの数値または IP アドレスとして入力できます。クラスタ ID を削除するには、このコマンドの no 形式を使用します。ルート リフレクタとそのクライアントがともにクラスタを形成します。クラスタ内のルート リフレクタが 1 つの場合、クラスタはルート リフレクタのルータ ID で識別されます。

cluster-id コマンドは、クラスタ内に 1 つまたは複数のルート リフレクタがある場合に、ルート リフレクタにクラスタ ID を割り当てるために使用します。クラスタに複数のルート リフレクタを導入することで、冗長性が向上し単一障害ポイントを避けることができます。クラスタ内に複数のルート リフレクタを設定する際は、すべてのルート リフレクタに同じクラスタ ID を割り当てます。これにより、クラスタ内のすべてのルート リフレクタが同じクラスタ内のピアからのアップデートを認識でき、BGP ルーティング テーブルに格納されるアップデートの数が減ります。


) すべてのルート リフレクタは、クラスタ内のすべてのピア間で安定したセッションを維持する必要があります。安定したセッションを維持できない場合は、代わりにオーバーレイ ルート リフレクタ クラスタ(異なるクラスタ ID を持つルート リフレクタ)を使用するようにしてください。


exit :現在のコマンド モードを終了します。

graceful-restart :グレースフル リスタート機能を設定します。詳細については、 graceful-restart(BGP) コマンドを参照してください。

graceful-restart-helper :グレースフル リスタート ヘルパー モード機能を設定します。詳細については、 graceful-restart(BGP) コマンドを参照してください。

log-neighbor-changes :BGP ネイバー リセットのロギングをイネーブルにします。BGP ネイバールータとの隣接関係の変化に関するロギングをディセーブルにするには、このコマンドの no 形式を使用します。 log-neighbor-changes コマンドは、BGP ネイバー ステータスの変化(アップまたはダウン)およびリセットに関するロギングをイネーブルにします。ログはネットワークの接続問題のトラブルシューティングおよびネットワークの安定性の評価に使用します。ネイバーが突然リセットする場合は、ネットワークのエラー率の高いことやパケット損失の多いことが考えられるので、調査するようにしてください。

ステータスの変化に関するメッセージをロギングするために log-neighbor-changes コマンドを使用しても、BPG アップデート デバッグをイネーブルにする場合などと異なり、パフォーマンスに大きな影響を与えることはありません。UNIX の syslog ファシリティがイネーブルの場合、メッセージは syslog デーモンを実行している UNIX ホストに送信され、保存およびアーカイブされます。UNIX の syslog ファシリティがイネーブルでない場合、ステータスの変化に関するメッセージはディスクではなくルータの内部バッファに保持されます。このバッファのサイズは logging buffered コマンドで設定できますが、利用可能なメモリのサイズに依存します。

BGP log-neighbor-changes コマンドがディセーブルの場合、ネイバー ステータスの変化に関するメッセージはリセットの理由に関するものを除いて記録されません。リセットの理由は show ip bgp neighbors および show bgp ipv6 neighbors コマンドの出力として常に利用可能です。

eigrp log-neighbor-changes コマンドは、Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバールータとの隣接関係のロギングをイネーブルにしますが、BGP ネイバーに関するメッセージは BGP log-neighbor-changes コマンドで明確にイネーブルにされた場合にのみ記録されます。

BGP ネイバーの変化に関するログを表示するには、 show logging コマンドを使用します。

neighbor :BGP ネイバーを設定します。詳細については、 neighbor コマンドを参照してください。

no :コマンドを無効にするか、またはデフォルト設定にします。

router-id ip-addr :ルータ ID として使用する IP アドレスを指定します。

timers bestpath-timeout :ベストパス タイムアウトを秒単位で設定します。範囲は 1 ~ 3600 です。デフォルトは 300 です。

次に、VRF コンフィギュレーション モードを開始する例を示します。

switch(config)# router bgp 64496
switch(config-router)# vrf context management
switch(config-router-vrf)#
 

次に、ローカル ルータをクラスタで使用するルート リフレクタの 1 つとして設定する例を示します。クラスタ ID を設定してクラスタを定義します。

switch(config)# router bgp 64496
switch(config-router)# neighbor 192.168.70.24 route-reflector-client
switch(config-router)# cluster-id 10.0.1.2

 

vrf member

Virtual Routing and Forwarding(VRF)インスタンスによるオブジェクト トラッキングを設定するには、 vrf member コマンドを使用します。このルートのオブジェクト トラッキングを削除するには、このコマンドの no 形式を使用します。

vrf member vrf-name

no vrf member vrf-name

 
構文の説明

vrf-name

VRF 名。名称は 64 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

デフォルト VRF 以外のオブジェクトを追跡するには、オブジェクト トラッキング コンフィギュレーション モードで vrf member コマンドを使用します。

このコマンドには、ライセンスは必要ありません。

次に、vrf RED の IP ルートを追跡する例を示します。

switch(config)# track 1 ip route 10.10.10.0/8 reachability
switch(config-track)# vrf member Red
 

 
関連コマンド

コマンド
説明

show track

オブジェクト トラッキングに関する情報を表示します。

track ip route

インターフェイスを追跡します。

vrrp

特定のイーサネット インターフェイス上で Virtual Router Redundancy Protocol(VRRP; 仮想ルータ冗長プロトコル)グループを作成し、VRRP グループに番号を割り当て、VRRP コンフィギュレーション モードを開始するには、 vrrp コマンドを使用します。VRRP グループを削除するには、このコマンドの no 形式を使用します。

vrrp number

no vrrp number

 
構文の説明

number

VRRP グループ番号。メイン インターフェイスおよびサブインターフェイスを含むギガビット イーサネット ポートに設定できます。範囲は 1 ~ 255 です。

 
デフォルト

なし

 
コマンド モード

VRRP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更あり

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

VRRP は VRRP ステートがディセーブルの場合にのみ設定されます。仮想ルータをイネーブルにする前に少なくとも 1 つの IP アドレスを設定するようにしてください。

このコマンドには、ライセンスは必要ありません。

次に、VRRP グループを作成する例を示します。

switch(config-if-vrrp)# vrrp 7
 

次に、VRRP グループを作成し、そのグループに IPv4 アドレスを設定する例を示します。

switch# config terminal
switch(config)# interface ethernet 2/1
switch(config-if)# vrrp 7
switch(config-if-vrrp)# address 10.0.0.10
switch(config-if-vrrp)# no shutdown

 
関連コマンド

コマンド
説明

feature vrrp

VRRP をイネーブルにします。

show vrrp

VRRP 設定情報を表示します。

clear vrrp

指定の仮想ルータの全ソフトウェア カウンタを消去します。