Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス リリース 5.x
T コマンド
T コマンド
発行日;2012/05/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

T コマンド

template(BGP)

test forwarding distribution perf

test forwarding inconsistency

threshold percentage

threshold weight

timers(GLBP)

timers active-time

timers basic

timers lsa-arrival(OSPF)

timers lsa-arrival(OSPFv3)

timers lsa-group-pacing(OSPF)

timers lsa-group-pacing(OSPFv3)

timers nsf converge

timers nsf route-hold

timers nsf signal

timers redirect

timers throttle lsa(OSPF)

timers throttle lsa(OSPFv3)

timers throttle spf(OSPF)

timers throttle spf(OSPFv3)

track(VRRP)

track interface

track interface(VRRP)

track ip route

track ipv6 route

track list

transmit-delay(OSPF 仮想リンク)

transmit-delay(OSPFv3 仮想リンク)

T コマンド

この章では、T で始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

template(BGP)

ピア テンプレートを作成し、ピア テンプレート コンフィギュレーション モードを開始するには、 template コマンドを使用します。ピア テンプレートを削除するには、このコマンドの no 形式を使用します。

template { peer name | peer-policy name | peer-session name }

no template { peer name | peer-policy name | peer-session name }

 
構文の説明

peer name

ネイバー テンプレート名を指定します。

peer-policy name

ピア ポリシー テンプレート名を指定します。

peer-session name

ピア セッション テンプレート名を指定します。

 
デフォルト

このコマンドには、デフォルト設定はありません。

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション
ルータ BGP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

template コマンドを使用すると、ネイバーが継承する一連の定義済み属性をイネーブルにできます。


) BGP ネイバーを、ピア グループとピア テンプレートの両方と連動するようには設定できません。BGP ネイバーは、ピア グループに属するか、ポリシーをピア テンプレートから継承するようにしか設定できません。


ピア テンプレートでは、基本ポリシー コマンドのみサポートされます。特定のアドレス ファミリまたは NLRI コンフィギュレーション モードに限定して設定される BGP ポリシー コンフィギュレーション コマンドを、ピア テンプレートを使用して設定します。

ピア テンプレート

ピア テンプレートでは、ピア セッション テンプレートとピア ポリシー テンプレートを組み合わせてネイバーの基本的な定義を行います。ネイバー テンプレートを使用するのは必須ではありませんが、使用すれば BGP の設定が簡略化できます。

ピア ポリシー テンプレート

ピア ポリシー テンプレートは、複数のコマンド設定をグループ化し、それを特定のアドレスファミリ内および NLRI コンフィギュレーション モード内で適用するために使用します。ピア ポリシー テンプレートの作成および設定は、ピア ポリシー コンフィギュレーション モードで行います。特定のアドレス ファミリまたは NLRI コンフィギュレーション モードに対して設定する BGP ポリシー コマンドは、ピア テンプレートに設定します。ピア ポリシー テンプレート コンフィギュレーション モードを開始すると、次のコマンドが使用できます。

suppress-inactive :アクティブ ルートをピアのみにアドバタイズします。追加情報については、 suppress-inactive コマンドを参照してください。

exit :現在のコンフィギュレーション モードを終了します。

filter-list name { in | out }:インバウンドおよびアウトバウンド BGP ルートに関する AS-PATH フィルタリスト を作成します 。エントリを削除するには、このコマンドの no 形式を使用します。

in :アクセス リストを着信ルートに適用します。

out :アクセス リストを発信ルートに適用します。

inherit peer-policy policy-name seq-num :別のピア ポリシー テンプレートの設定を継承するようにピア ポリシー テンプレートを設定します。ピア ポリシー テンプレートから、継承文を削除するには、このコマンドの no 形式を使用します。範囲:1 ~ 65535。デフォルトで、継承文は設定されていません。

ピア ポリシー テンプレートを評価する順序は、シーケンス番号で決まります。ルート マップのシーケンス番号と同じように、最も低いシーケンス番号が最初に評価されます。ピア ポリシー テンプレートでは継承がサポートされており、ピアはピア ポリシー テンプレートを 7 つまで直接または間接的に継承できます。ルート マップと同じように、継承されたピア ポリシー テンプレートにはシーケンス番号が設定されます。ルート マップと同じように、継承したピア ポリシー テンプレートは最も低いシーケンス番号を持つ継承文が最初に評価されます。ただし、ピア ポリシー テンプレートが抜けることはありません。すべてのシーケンスが評価されます。BGP ポリシー コマンドが異なる値で再び適用された場合は、より低いシーケンス番号による以前の値が上書きされます。


) BGP ルーティング プロセスをピア グループのメンバーにすると同時に、ピア テンプレートをグループ設定に使用するようには設定できません。どちらか一方の設定を使用する必要があります。パフォーマンスとスケーラビリティが向上するため、ピア テンプレートを推奨します。


maximum-prefix max :このネイバーからの最大プレフィクス数を指定します。範囲は 1 ~ 300000 です。デフォルトで、このコマンドはディセーブルになっています。最大プレフィクス数を超えると、ピアリング セッションはディセーブルになります。詳しくは maximum-prefix コマンドを参照してください。

next-hop-self :ルータを BGP ネイバーまたはピア グループのネクスト ホップとして設定します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。デフォルトで、ディセーブルになっています。

next-hop-third-party :可能であればサードパーティ ネクスト ホップを計算します。

no :コマンドを無効にするか、そのデフォルトに設定します。

prefix-list name { in | out } :プレフィクス リストを適用するルート タイプを指定します。エントリを削除するには、このコマンドの no 形式を使用します。

in :プレフィクス リストを着信ルートに適用します。

out :プレフィクス リストを発信ルートに適用します。

route-map name { in | out }:ネイバーに適用するルート タイプを適用するルート マップ名を指定します。

in :ルート マップを着信ルートに適用します。

out :ルート マップを発信ルートに適用します。

route-reflector-client :ルータを BGP ルート リフレクタとして設定し、指定のネイバーをそのクライアントとして設定します。ネイバーがクライアントでないことを示すには、このコマンドの no 形式を使用します。自律システムにルート リフレクタは存在しません。

デフォルトでは、AS 内のすべての internal BGP(iBGP)スピーカーを完全なメッシュ型にする必要があります。またネイバーは iBGP で学習したルートを再度ネイバーにアドバタイズすることはしません。これにより、ルーティング情報のループを防いでいます。すべてのクライアントがディセーブルになると、ローカル ルータはルート リフレクタでなくなります。

ルート リフレクタを使用する場合は、すべての iBGP スピーカーを完全なメッシュ型にする必要はありません。ルート リフレクタ モデルでは、1 つの iBGP ピアをルート リフレクタに設定します。このルート リフレクタは iBGP で学習したルートを iBGP ネイバーに渡す役割があります。この方式を使用することで、各ルータが他のすべてのルータと通信する必要がなくなります。

このコマンドで設定されたネイバーはすべてがクライアント グループのメンバーになり、残りの iBGP ピアはローカル ルート リフレクタの非クライアント グループのメンバーになります。

send-community :コミュニティ属性を BGP ネイバーに送信するように指定します。エントリを削除するには、このコマンドの no 形式を使用します。

soft-reconfiguration :アップデートの保存を開始するように Cisco NX-OS ソフトウェアを設定します。受信したアップデートを格納しないようにするには、このコマンドの no 形式を使用します。デフォルトで、ディセーブルになっています。このコマンドを入力すると、アップデートの格納が開始されます。これは着信ソフト再設定を行うために必要です。BGP 発信ソフト再設定では、着信ソフト再設定をイネーブルにする必要はありません。

事前設定ではなく、ソフト再設定(ソフト リセット)を使用するには、両方の BGP ピアがソフト ルート リフレッシュ機能をサポートしている必要があります。この機能は、ピアが TCP セッションを確立する際に送信する OPEN メッセージに格納され、アドバタイズされます。 soft-reconfiguration コマンドを使用して BGP セッションをクリアするとネットワーク動作に悪影響が及ぶため、最終手段として使用してください。

BGP ルータがこの機能をサポートしているかどうかを確認するには、 show ip bgp neighbors コマンドを使用します。ルータがルータ リフレッシュ機能をサポートしている場合は、次のメッセージが表示されます。

Received route refresh capability from peer

peer-group-name 引数を使用して BGP ピア グループを指定すると、ピア グループのすべてのメンバーが、このコマンドで設定される特性を継承します。

ピア セッション テンプレートと同じように、ピア ポリシー テンプレートを一度設定してから、ピア ポリシー テンプレートを直接適用する方法か、ピア ポリシー テンプレートから継承する方法で多くのネイバーに適用します。ピア ポリシー テンプレートを設定すると、AS 内のすべてのネイバーに適用する BGP ポリシー コマンドの設定を簡略化できます。

ピア ポリシー テンプレートでは、8 つまでのピア ポリシー テンプレートからの直接および間接的な継承がサポートされます。継承されたピア ポリシー テンプレートには、ルート マップと同じようにシーケンス番号が設定されます。ルート マップと同じように、継承したピア ポリシー テンプレートは最も低いシーケンス番号を持つ継承文が最初に評価され、最も高いシーケンス番号の継承文が最後に評価されます。ただし、ピア ポリシー テンプレートが抜けることのない点がルート マップと異なります。すべてのシーケンスが評価され、BGP ポリシー コマンドが異なる値で再び適用された場合は、より低いシーケンス番号による以前の値が上書きされます。

ピア ポリシー テンプレートでは、基本ポリシー コマンドのみサポートされます。特定のアドレス ファミリまたは NLRI コンフィギュレーション モードに限定して設定される BGP ポリシー コンフィギュレーション コマンドを、ピア ポリシー テンプレートを使用して設定します。


) BGP ネイバーを、ピア グループとピア テンプレートの両方と連動するようには設定できません。BGP ネイバーは、ピア グループに属するか、ピア テンプレートからポリシーを継承するようにしか設定できません。


ピア セッション テンプレート

ピア セッション テンプレートは、複数の基本セッション コマンドの設定をグループ化し、それを同じセッション設定要素を持つネイバー グループに適用するために使用します。異なるアドレス ファミリ内に設定されているネイバーに共通する基本セッション コマンドは、同じピア セッション テンプレート内に設定できます。ピア セッション テンプレートの作成および設定は、ピア セッション コンフィギュレーション モードで行います。ピア セッション テンプレートには、基本セッション コマンドのみ設定できます。

ピア セッション テンプレート コンフィギュレーション モードを開始すると、次のコマンドが使用できます。

description description :ローカルまたはピア ルータに表示される説明を設定します。スペースを含めて 80 文字まで入力できます。

disable-connected-check :eBGP ピアにループバック インターフェイスが設定されているときは、1 ホップだけ離れた eBGP ピアの接続検証をディセーブルにします。

ebgp-multihop :直接接続されていないネットワーク上に存在する外部ピアとの BGP による接続を受け入れたり、接続を試行したりします。


) このコマンドを使用する場合は、必ずシスコのテクニカルサポート担当者の指示に従ってください。


exit :現在のコンフィギュレーション モードを終了します。

inherit peer-session session-name :別のピア セッション テンプレートの設定を継承するようにピア セッション テンプレートを設定するには、 peer-session キーワードを使用します。ピア セッション テンプレートから継承文を削除するには、このコマンドの no 形式を使用します。

local-as :eBGP ピア グループの AS 番号のカスタマイズを可能にします。

neighbor inherit peer-session :ネイバーで設定が継承できるようにするためのピア セッション テンプレートを送信するようにルータを設定します。

neighbor translate-update :NLRI 形式で BGP を実行しているルータをマルチプロトコル BGP をサポートするようにアップグレードします。

password :2 つの BGP ピア間の TCP 接続において MD5 認証をイネーブルにします。次の設定ツールを使用できます。

0 password :非暗号化ネイバー パスワードを指定します。

3 password :3DES 暗号化ネイバー パスワードを指定します。

password :非暗号化(クリアテキスト)ネイバー パスワードを指定します。

remote-private-as :プライベート AS 番号を発信アップデートから削除します。

show ip bgp template peer-policy :ローカルで設定されたピア ポリシー テンプレートを表示します。

show ip bgp template peer-session :ローカルで設定されたピア セッション テンプレートを表示します。

shutdown :ネイバーまたはピア グループをディセーブルにします。

timers keepalive-time :キープアライブ タイマーおよびホールド タイマーの値を秒数で設定します。範囲は 0 ~ 3600 です。デフォルトは 60 です。

update-source { ethernet mod / port | loopback virtual-interface | port-channel number [ . sub-interface ]} :BGP セッションおよびアップデートの発信元を指定します。 virtual-interface の範囲は 0 ~ 1023 で、 number の範囲は 0 ~ 4096 です。(任意) sub-interface の範囲は 1 ~ 4093 です

基本セッション コマンドをピア セッション テンプレートに一度設定してから、ピア セッション テンプレートを直接適用する方法か、ピア セッション テンプレートから間接的に継承する方法で多くのネイバーに適用できます。ピア セッション テンプレートを設定すると、AS 内のすべてのネイバーに通常適用される基本セッション コマンドの設定を簡略化できます。

ピア セッション テンプレートでは、直接および間接的な継承がサポートされます。ピアを設定する場合は、1 回に 1 つのピア セッション テンプレートしか使用できません。また、そのピア セッション テンプレートは、間接的に継承されたピア セッション テンプレートを 1 つしか含むことができません。ただし、継承された各セッション テンプレートも、間接的に継承されたピア セッション テンプレートを 1 つ含むことができます。したがって、直接的に適用されるピア セッション テンプレートは 1 つしか適用できませんが、その他の間接的に継承されるピア セッション テンプレートは 7 つまで適用できるため、直接的に継承されるピア セッション テンプレートからの設定と、最大 7 つの間接的に継承されるピア セッション テンプレートからの設定を加えて、最大 8 つのピア セッション設定を 1 つのネイバーに適用できます。継承されたピア セッション テンプレートが最初に評価され、直接適用されるテンプレートは最後に評価され、適用されます。したがって、基本セッション コマンドが異なる値で再び適用される場合は、後の値が優先され、間接的に継承されたテンプレートに設定されていた前の値は上書きされます。

ピア セッション テンプレートでは、基本セッション コマンドのみサポートされます。特定のアドレス ファミリまたは NLRI コンフィギュレーション モードに限定して設定される BGP ポリシー コンフィギュレーション コマンドを、ピア ポリシー テンプレートを使用して設定します。

このコマンドには、Enterprise Services ライセンスが必要です。

この例では、CORE1 という名前のピア セッション テンプレートを作成します。この例では、INTERNAL-BGP という名前のピア セッション テンプレートの設定が継承されます。

switch(config-router)# template peer-session CORE1
switch(config-router-stmp)#
 

次に、CUSTOMER-A という名前のピア ポリシー テンプレートを作成および設定する例を示します。

switch(config-router)# template peer-policy CUSTOMER-A
switch(config-router-ptmp)# exit
switch(config-router)# route-map SET-COMMUNITY in
switch(config-router)# filter-list 20 in
switch(config-router)# inherit peer-policy PRIMARY-IN 20
switch(config-router)# inherit peer-policy GLOBAL 10
switch(config-router)# exit-peer-policy
switch(config-router)#
 

この例では、192.168.1.1 ネイバーから受け入れられる最大プレフィクス数が 1000 に設定されます。

switch(config)# router bgp 64496
switch(config-router) network 192.168.0.0
switch(config-router)# maximum-prefix 1000
 

この例では、192.168.2.2 ネイバーから受け入れられるプレフィクスの最大数が 5000 に設定されます。ルータは、最大プレフィクス リミット(2500 プレフィクス)の 50% に到達した段階で警告メッセージを表示するようにも設定されます。

switch(config)# router bgp 64496
switch(config-router) network 192.168.0.0
switch(config-router)# maximum-prefix 5000 50
 

この例では、192.168.3.3 ネイバーから受け入れられるプレフィクスの最大数が 2000 に設定されます。ルータは、30 分後にディセーブルにされたピアリング セッションを再確立するようにも設定されます。

switch(config)# router bgp 64496
switch(config-router) network 192.168.0.0
switch(config-router)# neighbor 192.168.3.3 maximum-prefix 2000 restart 30
 

この例では、192.168.4.4 ネイバーの最大プレフィクス数の制限値(500)を超えると警告メッセージが表示されます。

switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 500 warning-only
 

この例では、10.108.1.1 宛てのすべてのアップデートで、このルータを強制的にネクスト ホップとしてアドバタイズするように設定されます。

switch(config)# router bgp 64496
switch(config-router)# next-hop-self
 

次に示すルータ コンフィギュレーション モードの例では、ルータが AS 109 に属しており、IP アドレス 172.16.70.23 のネイバーにコミュニティ属性を送信するように設定します。

switch(config)# router bgp 64496
switch(config-router)# send-community
 

次に示すアドレス ファミリ コンフィギュレーション モードの例では、ルータが AS 109 に属しており、IP アドレス 172.16.70.23 のネイバーにコミュニティ属性を送信するように設定します。

switch(config)# router bgp 64496
switch(config-router)# address-family ipv4 multicast
switch(config-router-af)# send-community
 

この例では、ネイバー 10.108.1.1 の着信ソフト再設定をイネーブルにします。このネイバーから受信されるすべてのアップデートは、着信ポリシーを無視してそのまま格納されます。後になって着信ソフト再設定が行われるときは、格納されている情報を使用して新しい着信アップデートのセットが生成されます。

switch(config)# router bgp 64496
switch(config-router)# soft-reconfiguration inbound

 
関連コマンド

コマンド
説明

router bgp

ルータに割り当てる AS 番号を入力し、ルータ BGP コンフィギュレーション モードを開始します。

address-family

BGP のアドレス ファミリ モードを開始します。

test forwarding distribution perf

転送情報ベース(FIB)転送分散のパフォーマンスをテストするには、 test forwarding distribution perf コマンドを使用します。

test forwarding distribution perf

 
構文の説明

このコマンドには、キーワードと引数はありません。

 
デフォルト

なし

 
コマンド モード

任意

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、転送分散のパフォーマンスをテストする例を示します。

switch# test forwarding distribution perf
 

 
関連コマンド

コマンド
説明

show forwarding distribution

FIB に関する情報を表示します。

test forwarding inconsistency

Forwarding Information Base(FIB)のレイヤ 3 整合性チェッカーをトリガーするには、 test forwarding inconsistency コマンドを使用します。

test forwarding inconsistency [ ip | ipv4 | ipv6 ] [ unicast ] [ vrf vrf-name ] [ module { slot | all }] [ stop ]

 
構文の説明

ip

(任意)IPv4 ルートの不一致チェックを指定します。

ipv4

(任意)IPv4 ルートの不一致チェックを指定します。

ipv6

(任意)IPv6 ルートの不一致チェックを指定します。

unicast

(任意)ユニキャスト ルートの不一致チェックを指定します。

module

(任意)1 つまたは複数のモジュールの不一致チェックを指定します。

slot

モジュール番号。範囲はプラットフォームに依存します。

all

(任意)すべてのモジュールの不一致チェックを指定します。

stop

(任意)不一致チェックを停止します。

 
デフォルト

なし

 
コマンド モード

任意

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

4.2(1)

ipv6 キーワードのサポートが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、すべてのモジュールのレイヤ 3 整合性チェッカーをトリガーする例を示します。

switch# test forwarding inconsistency module all
 

次に、すべてのモジュールのレイヤ 3 整合性チェッカーを停止する例を示します。

switch# test forwarding inconsistency module all stop
 

 
関連コマンド

コマンド
説明

clear forwarding inconsistency

FIB 不一致をクリアします。

show forwarding inconsistency

FIB 不一致に関する情報を表示します。

threshold percentage

オブジェクト リスト内の追跡対象オブジェクトのしきい値パーセンテージを設定するには、 threshold percentage コマンドを使用します。しきい値パーセンテージをディセーブルにするには、このコマンドの no 形式を使用します。

threshold percentage { up number [ down number ] | down number [ up number ]}

no threshold percentage

 
構文の説明

up

アップしきい値を指定します。

down

ダウンしきい値を指定します。

number

しきい値。範囲は 0 ~ 100 です。

 
デフォルト

なし

 
コマンド モード

トラッキング コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

track object-number list コマンドを使用して追跡対象リストを設定するときに、 boolean キーワードと threshold キーワードを使用できます。 threshold キーワードを指定した場合は、 percentage キーワードと weight キーワードのどちらかを指定できます。 percentage キーワードを指定した場合は、 weight キーワードが使用できません。 weight キーワードを指定した場合は、 prcentage キーワードが使用できません。

アップ パーセンテージを先に設定する必要があります。有効な範囲は 1 ~ 100 です。ダウン パーセンテージはアップに対して設定された値に依存します。たとえば、アップを 50% に設定した場合は、ダウンの範囲が 0 ~ 49% になります。このコマンドには、ライセンスは必要ありません。

この例では、追跡対象リスト 11 が、50 のアップ パーセンテージと 32 のダウン パーセンテージを使用してしきい値を測定するように設定されます。

switch(config)# track 11 list threshold percentage
switch(config-track)# object 1
switch(config-track)# object 2
switch(config-track)# threshold percentage up 50 down 32
 

 
関連コマンド

コマンド
説明

threshold weight

オブジェクト リスト内の追跡対象オブジェクトのしきい値重みを設定します。

track list

追跡対象オブジェクトのリストと、比較に使用するしきい値を指定します。

threshold weight

オブジェクト リスト内の追跡対象オブジェクトのしきい値重みを設定するには、 threshold weight コマンドを使用します。しきい値重みをディセーブルにするには、このコマンドの no 形式を使用します。

threshold weight { up number [ down number ] | down number [ up number ]}

no threshold weight

 
構文の説明

up

アップしきい値を指定します。

down

ダウンしきい値を指定します。

number

しきい値。範囲は 1 ~ 255 です。

 
デフォルト

なし

 
コマンド モード

トラッキング コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

track object-number list コマンドを使用して追跡対象リストを設定するときに、 boolean キーワードと threshold キーワードを使用できます。 threshold キーワードを指定した場合は、 percentage キーワードと weight キーワードのどちらかを指定できます。 percentage キーワードを指定した場合は、 weight キーワードが使用できません。 weight キーワードを指定した場合は、 prcentage キーワードが使用できません。

アップ重みを先に設定する必要があります。有効な範囲は 1 ~ 255 です。使用可能なダウン重みは、アップ重みに対して設定された値に依存します。たとえば、アップを 25 に設定した場合は、ダウンの範囲が 0 ~ 24 になります。

この例では、追跡対象リスト 12 が、指定された重みを使用してしきい値を測定するように設定されます。

switch(config)# track 11 list threshold weight
switch(config-track)# object 1
switch(config-track)# object 2
switch(config-track)# threshold weight up 35 down 22
 

 
関連コマンド

コマンド
説明

threshold percentage

オブジェクト リスト内の追跡対象オブジェクトのしきい値パーセンテージを設定します。

track list

追跡対象オブジェクトのリストと、比較に使用するしきい値を指定します。

timers(GLBP)

Gateway Load Balancing Protocol(GLBP; ゲートウェイ ロード バランシング プロトコル)ゲートウェイにより送信される hello パケットの間隔、および仮想ゲートウェイと仮想フォワーダ情報が有効と見なされる時間を設定するには、 timers コマンドを使用します。各タイマーをデフォルト値に戻すには、このコマンドの no 形式を使用します。

timers [ msec ] hellotime [ msec ] holdtime

no timers

 
構文の説明

msec

(任意)下記の( hellotime または holdtime )引数値をミリ秒で表すことを指定します。

hellotime

hello インターバル。有効な範囲は 1 ~ 60 秒です。デフォルトは 3 秒(3000 ミリ秒)です。

holdtime

hello パケットに含まれる仮想ゲートウェイおよび仮想フォワーダの情報が無効と見なされるまでの時間。範囲は 2 ~ 180 秒です。デフォルトは 10 秒(10,000 ミリ秒)です。

 
デフォルト

hellotime : 3 秒
holdtime : 10 秒

 
コマンド モード

GLBP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

タイマーをゲートウェイに設定しなかった場合、ゲートウェイはタイマー値を Active Virtual Gateway(AVG; アクティブ仮想ゲートウェイ)から学習します。AVG 上に設定されているタイマーは、他のすべてのタイマー設定を常に上書きします。GLBP グループ内のすべてのゲートウェイが同じタイマー値を使用するようにしてください。GLBP ゲートウェイが hello メッセージを送信した場合、その情報は 1 ホールドタイムの間有効と見なされます。通常、ホールドタイムは hello タイムの値の 3 倍より大きくします( holdtime > 3 × hellotime )。ホールドタイムの値範囲は、ホールドタイムを強制的に hello タイムより大きくします。

このコマンドには、ライセンスは必要ありません。

次に、イーサネット インターフェイス 1/1 上で GBLP グループ 10 のタイマーを設定する例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# glbp 10
switch(config-glbp)# timers 5 18

 
関連コマンド

コマンド
説明

glbp

GLBP コンフィギュレーション モードに入って、GLBP グループを作成します。

timers redirect

GBLP グループのリダイレクト値およびタイムアウト値を設定します。

timers active-time

アクティブ状態に対する Enhanced Interior Gateway Routing Protocol(EIGRP)制限時間を調整するには、 timers active-time コマンドを使用します。この機能をディセーブルにするには、コマンドの no 形式を使用します。

timers active-time [ time-limit | disabled ]

no timers active-time

 
構文の説明

time-limit

(任意)アクティブ制限時間(分)。範囲は 1 ~ 65535 分です。デフォルト値は 3 です。

disabled

(任意)タイマーをディセーブルにし、ルーティング待機時間を無制限にアクティブのままにします。

 
デフォルト

ディセーブル

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

ルートが Stack in Active(SIA)状態であると宣言するまでに、ルータが(クエリー送信後の応答を)待機する時間を制御するには、 timers active-time コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、指定された EIGRP ルートに対して無制限のルーティング待機時間を設定する例を示します。

switch(config)# router eigrp 1
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# timers active-time disabled
 

timers basic

Routing Information Protocol(RIP)のネットワーク タイマーを調整するには、ルータ アドレスファミリ コンフィギュレーション モードで timers basic コマンドを使用します。デフォルト タイマーに戻すには、このコマンドの no 形式を使用します。

timers basic update invalid holddown flush

no timers basic

 
構文の説明

update

アップデートが送信されるレート(秒)。デフォルトは 30 秒です。

invalid

ルートが無効として宣言されるまでの時間(秒)。 update 引数の値の少なくとも 3 倍に設定します。アップデートでルートがリフレッシュされないと、ルートは無効になります。その後ルートはホールドダウン(holddown)状態に入り、アクセス不能としてマーク付けされ到達不能としてアドバタイズされます。ただし、このルートはパケットの転送には引き続いて使用されます。デフォルト値は 180 秒です。

holddown

より適切なパスに関するルーティング情報が抑制される時間(秒)。 update 引数の値の少なくとも 3 倍にします。ルートが到達不能であることを示すアップデート パケットを受信すると、そのルートはホールドダウン(holddown)状態に入ります。ルートはアクセス不能としてマーク付けされ、到達不能としてアドバタイズされます。ただし、このルートはパケットの転送には引き続いて使用されます。ホールドダウンの期限が切れると、他の発信元によりアドバタイズされるルートが受け入れられ、ルートはアクセス不能でなくなります。デフォルト値は 180 秒です。

flush

この時間(秒)が経過すると、ルートはルーティング テーブルから削除されます。指定する時間は、 invalid 引数と holddown 引数を加えた合計値より大きな値にします。値が合計値より少ないと holddown の時間が正しく経過できないため、holddown の期限が切れる前に新しいルートが受け入れられる結果になります。デフォルトは 240 秒です。

 
デフォルト

update : 30 秒
invalid : 180 秒
holddown : 180 秒
flush : 240 秒

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

RIP の基本タイミング パラメータは変更できます。これらのタイマーは、ネットワーク内のすべてのルータおよびサーバで同じ値にする必要があります。


show ip protocols コマンドを使用すると、現在およびデフォルトのタイマー値を表示できます。


このコマンドには、ライセンスは必要ありません。

次に、アップデートを 5 秒ごとにブロードキャストするように設定する例を示します。ルータから Cisco NX-OS に 15 秒間(無効時間)応答がなかった場合は、そのルータが使用不可として宣言されます。 Cisco NX-OS は、さらに 15 秒間(ホールドダウン時間)情報を抑制します。抑制時間が終了すると、Cisco NX-OS はルーティング テーブルからルートを削除します。

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# timers basic 5 15 15 30
 

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ コンフィギュレーション モードに入ります。

 

timers lsa-arrival(OSPF)

ソフトウェアが Open Shortest Path First(OSPF)ネイバーから同一の Link-State Advertisement(LSA; リンクステート アドバタイズメント)を受け入れる最小間隔を設定するには、 timers lsa-arrival コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

timers lsa-arrival milliseconds

no timers lsa-arrival

 
構文の説明

milliseconds

ネイバーから到着する同じ LSA の受け入れと受け入れの間で経過する必要のある最小遅延時間(ミリ秒)。範囲は 10 ~ 600,000 ミリ秒です。デフォルトは 1000 ミリ秒です。

 
デフォルト

1000 ミリ秒

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

同一の LSA を受け入れる最小間隔を設定するには、 timers lsa arrival コマンドを使用します。同じ LSA とは、LSA ID 番号、LSA タイプ、およびアドバタイジング ルータ ID が同じ LSA インスタンスを意味します。同じ LSA のインスタンスが、設定されたインターバルよりも早く到着した場合は、ソフトウェアによってその LSA が破棄されます。

timers lsa-arrival コマンドの milliseconds 値は、ネイバーの timers throttle lsa コマンドの hold-interval 値以下に維持することを推奨します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、同一の LSA を受け入れる最小間隔を 2000 ミリ秒に設定する例を示します。

switch(config)# router ospf 1
switch(config-router)# timers lsa-arrival 2000

 
関連コマンド

コマンド
説明

show ip ospf timers rate-limit

レート制限キュー内のすべての LSA を表示します。

timers throttle lsa

生成されている LSA のレート制限値を設定します。

timers lsa-arrival(OSPFv3)

ソフトウェアが Open Shortest Path First version 3(OSPFv3)ネイバーから同一の Link-State Advertisement(LSA; リンクステート アドバタイズメント)を受け入れる最小間隔を設定するには、 timers lsa-arrival コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

timers lsa-arrival milliseconds

no timers lsa-arrival

 
構文の説明

milliseconds

ネイバーから到着する同じ LSA の受け入れと受け入れの間で経過する必要のある最小遅延時間(ミリ秒)。範囲は 10 ~ 600,000 ミリ秒です。デフォルトは 1000 ミリ秒です。

 
デフォルト

1000 ミリ秒

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

同一の LSA を受け入れる最小間隔を設定するには、 timers lsa arrival コマンドを使用します。同じ LSA とは、LSA ID 番号、LSA タイプ、およびアドバタイジング ルータ ID が同じ LSA インスタンスを意味します。同じ LSA のインスタンスが、設定されたインターバルよりも早く到着した場合は、ソフトウェアによってその LSA が破棄されます。

timers lsa-arrival コマンドの milliseconds 値は、ネイバーの timers throttle lsa コマンドの hold-interval 値以下に維持することを推奨します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、同一の LSA を受け入れる最小間隔を 2000 ミリ秒に設定する例を示します。

switch(config)# router ospfv3 1
switch(config-router)# timers lsa-arrival 2000

 
関連コマンド

コマンド
説明

show ospfv3 timers rate-limit

レート制限キュー内のすべての LSA を表示します。

timers throttle lsa

生成されている LSA のレート制限値を設定します。

timers lsa-group-pacing(OSPF)

Open Shortest Path First(OSPF)Link-State Advertisement(LSA; リンクステート アドバタイズメント)を収集してグループ化し、リフレッシュ、チェックサム、またはエージングを行う間隔を変更するには、 timers lsa-group-pacing コマンドを実行します。デフォルトに戻すには、このコマンドの no 形式を使用します。

timers lsa-group-pacing seconds

no timers lsa-group-pacing

 
構文の説明

seconds

LSA のグループ化、リフレッシュ、チェックサム、またはエージングを行う間隔(秒)。有効範囲は 1 ~ 1800 秒です。デフォルト値は 10 秒です。

 
デフォルト

このコマンドのデフォルト間隔は 10 秒です。OSPF の LSA グループ ペーシングはデフォルトでイネーブルです。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

LSA アップデートの発生レートを制御し、大量の LSA でエリアがフラッディングされたときに発生する可能性のある高い CPU 利用率またはバッファ利用率を低減するには、 timers lsa-group-pacing コマンドを使用します。大部分の OSPF 展開では、OSPF パケット ペーシング タイマーのデフォルト設定で十分です。OSPF パケット フラッディングの要件を満たす他のすべてのオプションを試みた後でなければ、このパケット ペーシング タイマーを変更しないでください。集約、スタブ エリアの使用、キューの調整、およびバッファの調整を試した後で、デフォルトのフラッディング タイマーを変更するようにしてください。タイマー値を変更する際のガイドラインはありません。OSPF の導入に同じものはなく、状況ごとに検討する必要があります。

Cisco NX-OS は LSA の定期リフレッシュをグループ化して、大規模トポロジにおけるリフレッシュの LSA パッキング密度を向上させています。グループ タイマーは LSA をグループ リフレッシュする間隔を制御しますが、このタイマーでは個々の LSA をリフレッシュする頻度(デフォルトのリフレッシュ レートは 30 分)は変わりません。

LSA グループ ペーシングの時間は、ルータが処理する LSA 数に反比例します。たとえば、約 10,000 個の LSA が存在する場合は、ペーシング間隔を減らすようにしてください。データベースが非常に小さい(40 ~ 100 個の LSA)場合は、ペーシング間隔を 10 ~ 20 分に増やすようにしてください。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPF ルーティング プロセス 1 で、LSA グループ間の OSPF グループ パケットペーシング アップデートを 60 秒間隔で行うように設定する例を示します。

switch(config)# router ospf 1
switch(config-router)# timers lsa-group-pacing 60

 
関連コマンド

コマンド
説明

show ip ospf

OSPF ルーティング プロセスに関する一般的な情報を表示します。

timers lsa-group-pacing(OSPFv3)

Open Shortest Path First version 3(OSPFv3)Link-State Advertisement(LSA; リンクステート アドバタイズメント)を収集してグループ化し、リフレッシュ、チェックサム、またはエージングを行う間隔を変更するには、 timers lsa-group-pacing コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

timers lsa-group-pacing seconds

no timers lsa-group-pacing

 
構文の説明

seconds

LSA のグループ化、リフレッシュ、チェックサム、またはエージングを行う間隔(秒)。有効範囲は 1 ~ 1800 秒です。デフォルト値は 240 秒です。

 
デフォルト

このコマンドのデフォルト間隔は 240 秒です。OSPFv3 の LSA グループ ペーシングはデフォルトでイネーブルです。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

LSA アップデートの発生レートを制御し、大量の LSA でエリアがフラッディングされたときに発生する可能性のある高い CPU 利用率またはバッファ利用率を低減するには、 timers lsa-group-pacing コマンドを使用します。大部分の OSPFv3 展開では、OSPFv3 パケット ペーシング タイマーのデフォルト設定で十分です。OSPFv3 パケット フラッディングの要件を満たす他のすべてのオプションを試みた後でなければ、このパケット ペーシング タイマーを変更しないでください。集約、スタブ エリアの使用、キューの調整、およびバッファの調整を試した後で、デフォルトのフラッディング タイマーを変更するようにしてください。タイマー値を変更する際のガイドラインはありません。OSPFv3 の導入に同じものはなく、状況ごとに検討する必要があります。

Cisco NX-OS は LSA の定期リフレッシュをグループ化して、大規模トポロジにおけるリフレッシュの LSA パッキング密度を向上させています。グループ タイマーは LSA をグループ リフレッシュする間隔を制御しますが、このタイマーでは個々の LSA をリフレッシュする頻度(デフォルトのリフレッシュ レートは 30 分)は変わりません。

LSA グループ ペーシングの時間は、ルータが処理する LSA 数に反比例します。たとえば、約 10,000 個の LSA が存在する場合は、ペーシング間隔を減らすようにしてください。データベースが非常に小さい(40 ~ 100 個の LSA)場合は、ペーシング間隔を 10 ~ 20 分に増やすようにしてください。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3 ルーティング プロセス 1 で、LSA グループ間の OSPFv3 グループ パケットペーシング アップデートを 60 秒間隔で行うように設定する例を示します。

switch(config)# router ospfv3 1
switch(config-router)# timers lsa-group-pacing 60

 
関連コマンド

コマンド
説明

show ospfv3

OSPFv3 ルーティング プロセスに関する一般的な情報を表示します。

timers nsf converge

Enhanced Interior Gateway Routing Protocol(EIGRP)の Nonstop Forwarding(NSF)コンバージェンスの制限時間を調整するには、 timers nsf converge コマンドを使用します。この機能をディセーブルにするには、コマンドの no 形式を使用します。

timers nsf converge seconds

no timers nsf converge

 
構文の説明

seconds

NSF スイッチオーバー後のコンバージェンスの制限時間(秒)。範囲は 60 ~ 180 秒です。デフォルト値は 120 です。

 
デフォルト

120 秒

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

スイッチオーバー後のコンバージェンスをルータが待機する時間を制御するには、 timers nsf converge コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、EIGRP の NSF コンバージェンス時間を設定する例を示します。

switch(config)# router eigrp 1
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# timers nsf converge 100
 

timers nsf route-hold

NSF 認識 Enhanced Interior Gateway Routing Protocol(EIGRP)ルータが非アクティブ ピアのルートを保持する時間を決定しているタイマーを設定するには、 timers nsf route-hold コマンドを使用します。このルート ホールド タイマーをデフォルト値に戻すには、このコマンドの no 形式を使用します。

timers nsf route-hold seconds

no timers nsf route-hold

 
構文の説明

seconds

EIGRP が非アクティブ ピアのルートを保持する時間(秒)。範囲は 20 ~ 300 秒です。デフォルトは 240 です。

 
デフォルト

EIGRP NSF 認識がイネーブルになっています。
seconds : 240

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

timers nsf route-hold コマンドは、スイッチオーバーの動作中または既知のエラー状態にある間、NSF 認識ルータが NSF 対応ネイバーの既知のルートを保持する最大時間を設定するために使用します。ルート ホールド タイマーは設定可能なため、ネットワーク パフォーマンスの調整をし、スイッチオーバー動作に時間がかかりすぎた場合に「ブラック ホール」ルート(無効ルートのアドバタイズ)などの望ましくない影響を避けることができます。このタイマーの期限が切れると、NSF 認識ルータはトポロジ テーブルをスキャンし無効なルートを破棄します。これにより EIGRP ピアは、スイッチオーバー動作中に長い時間待機せずに代替ルートを探すことができます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、NSF 認識ルータのルート ホールド タイマー値を 2 分(120 秒)に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# timers nsf route-hold 120

timers nsf signal

Nonstop Forwarding(NSF)再起動の信号を Enhanced Interior Gateway Routing Protocol(EIGRP)が待つ制限時間を設定するには、 timers nsf signal コマンドを使用します。このルート ホールド タイマーをデフォルトに戻すには、このコマンドの no 形式を使用します。

timers nsf signal seconds

no timers nsf signal

 
構文の説明

seconds

EIGRP がピアからの NSF 再起動の信号を待機する時間(秒)。範囲は 10 ~ 30 秒です。デフォルトは 20 です。

 
デフォルト

EIGRP NSF 認識がイネーブルになっています。
seconds : 20

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

NSF 認識ルータが NSF 対応ネイバーからの再起動の信号を待機する最大時間を設定するには、 timers nsf signal コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、NSF 認識ルータの信号タイマー値を最大値(30 秒)に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# timers nsf signal 30
 

 

timers redirect

Gateway Load Balancing Protocol(GLBP; ゲートウェイ ロード バランシング プロトコル)グループの Active Virtual Gateway(AVG; アクティブ仮想ゲートウェイ)が継続してクライアントをセカンダリ Active Virtual Forwarder(AVF; アクティブ仮想フォワーダ)にリダイレクトする時間を設定するには、 timers redirect コマンドを使用します。リダイレクト タイマーをデフォルト値に戻すには、このコマンドの no 形式を使用します。

timers redirect redirect timeout

no timers redirect redirect timeout

 
構文の説明

redirect

リダイレクト タイマー時間(秒)。指定できる範囲は 0 ~ 3600 秒です。デフォルトは 300 秒(5 分)です。

timeout

セカンダリ仮想フォワーダが使用できなくなるまでの時間(秒)。指定できる範囲は 610 ~ 64800 秒です。デフォルトは 14,400 秒(4 時間)です。

 
デフォルト

redirect : 300 秒
timeout : 14,400 秒

 
コマンド モード

GLBP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

AVG によって仮想 MAC アドレスが割り当てられた仮想フォワーダのことを、プライマリ仮想フォワーダと呼びます。また、hello メッセージから仮想 MAC アドレスを学習した仮想フォワーダのことを、セカンダリ仮想フォワーダと呼びます。

リダイレクト(redirect)タイマーには、ネットワーク上のフォワーダに障害が発生し AVG によりそのフォワーダが復旧しないと見なされた時点に開始される遅延時間を設定できます。遅延時間を設定した場合、フォワーダが応答する仮想 MAC アドレスはアドレス解決プロトコル(ARP)応答の中にまだ存在していますが、実際のフォワーディング タスクは GLBP グループ内の別のグループにより処理されます。

タイムアウト(timeout)時間は、ネットワーク上のフォワーダに障害が発生し、フォワーダが扱っていた MAC アドレスが GLBP グループ内のすべてのルータで非アクティブになった時点に開始される遅延時間です。タイムアウト時間が経過すると、この仮想 MAC アドレスに送信されるパケットは廃棄されます。タイムアウト時間には、仮想 MAC アドレスを含んだ ARP キャッシュ エントリをすべてのホストがリフレッシュできるだけの十分長い時間を設定する必要があります。

このコマンドには、ライセンスは必要ありません。

次に、イーサネット インターフェイス 1/1 上で GBLP グループ 1 のリダイレクトおよびタイムアウト値を設定する例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# glbp 10
switch(config-glbp)# timers redirect 600 7200
switch(config-glbp)# ip
 

 
関連コマンド

コマンド
説明

glbp

GLBP コンフィギュレーション モードに入って、GLBP グループを作成します。

timers

GLBP の hello タイマーおよびホールド タイマーを設定します。

timers throttle lsa(OSPF)

Open Shortest Path First(OSPF)の Link-State Advertisement(LSA; リンクステート アドバタイズメント)生成に対するレート制限値を設定するには、 timers throttle lsa コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

timers throttle lsa start-time hold-interval max-time

no timers throttle lsa

 
構文の説明

start-time

LSA 生成に必要な後続レート制限時間の計算に使用される開始時間(ミリ秒単位)。有効な範囲は 0 ~ 5000 ミリ秒です。デフォルト値は 0 ミリ秒です。

hold-interval

LSA 生成に必要な後続レート制限時間の計算に使用される増分時間(ミリ秒単位)。範囲は 50 ~ 30,000 ミリ秒です。デフォルト値は 5000 ミリ秒です。

max-time

LSA 生成に必要な後続レート制限時間の計算に使用される最大時間(ミリ秒単位)。範囲は 50 ~ 30,000 ミリ秒です。デフォルト値は 5000 ミリ秒です。

 
デフォルト

start-time: 0 ミリ秒
hold-interval: 5000 ミリ秒
max-time: 5000 ミリ秒

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

4.2(1)

start-time 引数と max-time 引数が追加されました。

 
使用上のガイドライン

LSA の生成にレート制限を適用するには、 timers throttle lsa コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPF LSA スロットリングをカスタマイズする例を示します。

switch(config)# router ospf 1
switch(config-router)# timers throttle lsa 50 5000 6000

 
関連コマンド

コマンド
説明

show ip ospf

OSPF ルーティング プロセスに関する情報を表示します。

timers lsa arrival

ソフトウェアが OSPF ネイバーから同一の LSA を受け入れる最小間隔を設定します。

timers throttle lsa(OSPFv3)

Open Shortest Path First version 3(OSPFv3)の Link-State Advertisement(LSA; リンクステート アドバタイズメント)生成に対するレート制限値を設定するには、 timers throttle lsa コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

timers throttle lsa start-time hold-interval max-time

no timers throttle lsa

 
構文の説明

start-time

LSA 生成に必要な後続レート制限時間の計算に使用される開始時間(ミリ秒単位)。範囲は 50 ~ 5000 ミリ秒です。デフォルト値は 50 ミリ秒です。

hold-interval

LSA 生成に必要な後続レート制限時間の計算に使用される増分時間(ミリ秒単位)。範囲は 50 ~ 30,000 ミリ秒です。デフォルト値は 5000 ミリ秒です。

max-time

LSA 生成に必要な後続レート制限時間の計算に使用される最大時間(ミリ秒単位)。範囲は 50 ~ 30,000 ミリ秒です。デフォルト値は 5000 ミリ秒です。

 
デフォルト

hold-interval: 5000 ミリ秒

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

4.2(1)

start-time 引数と max-time 引数が追加されました。

 
使用上のガイドライン

LSA の生成にレート制限を適用するには、 timers throttle lsa コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3 LSA スロットリングをカスタマイズする例を示します。

switch(config)# router ospfv3 1
switch(config-router)# timers throttle lsa 50 10000 5000

 
関連コマンド

コマンド
説明

show ospfv3

OSPFv3 ルーティング プロセスに関する情報を表示します。

timers lsa arrival

ソフトウェアが OSPFv3 ネイバーから同じ LSA を受け入れる最小間隔を設定します。

timers throttle spf(OSPF)

Shortest-Path First(SPF)最適パスの最初のスケジュール遅延時間および OSPF の SPF 最適パス計算間の最小保持時間を設定するには、 timers throttle spf コマンドを使用します。SPF スロットリングをオフにするには、このコマンドの no 形式を使用します。

timers throttle spf spf-start spf-hold spf-max-wait

no timers throttle spf spf-start spf-hold spf-max-wait

 
構文の説明

spf-start

初回 SPF スケジュール遅延(ミリ秒)。範囲は 1 ~ 600000 ミリ秒です。

spf-hold

連続する 2 つの SPF 計算間の最小保持時間。範囲は 1 ~ 600000 ミリ秒です。

spf-max-wait

連続する 2 つの SPF 計算間の最大待機時間。範囲は 1 ~ 600000 ミリ秒です。

 
デフォルト

SPF スロットリングは設定されていません。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

SPF タイマーを設定するには、 timers throttle spf コマンドを使用します。

SPF 計算間の初回待機時間は、 spf-start 引数で指定される時間(ミリ秒)です。続いて適用される各待機時間は、待機時間が spf-maximum 引数で指定される最大時間(ミリ秒)に達するまで、現在の保持時間(ミリ秒)を 2 倍した値になります。それ以降の待機時間は、値がリセットされるか SPF 計算間に LSA を受信するまで最大値のままです。

次に、ルータで、 timers throttle spf コマンドの初期時間、保持時間、および最大時間の値をそれぞれ 5、1,000、および 90,000 ミリ秒に設定する例を示します。

switch(config)# router ospf 1
switch(config-router)# timers throttle spf 5 1000 90000
 

 

timers throttle spf(OSPFv3)

Shortest-Path First(SPF)最適パスの最初のスケジュール遅延時間および Open Shortest Path First version 3(OSPFv3)の SPF 最適パス計算間の最小保持時間を設定するには、 timers throttle spf コマンドを使用します。SPF スロットリングをオフにするには、このコマンドの no 形式を使用します。

timers throttle spf spf-start spf-hold spf-max-wait

no timers throttle spf spf-start spf-hold spf-max-wait

 
構文の説明

spf-start

初回 SPF スケジュール遅延(ミリ秒)。範囲は 1 ~ 600000 ミリ秒です。

spf-hold

連続する 2 つの SPF 計算間の最小保持時間。範囲は 1 ~ 600000 ミリ秒です。

spf-max-wait

連続する 2 つの SPF 計算間の最大待機時間。範囲は 1 ~ 600000 ミリ秒です。

 
デフォルト

SPF スロットリングは設定されていません。

 
コマンド モード

アドレスファミリ コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

SPF タイマーを設定するには、 timers throttle spf コマンドを使用します。

SPF 計算間の初回待機時間は、 spf-start 引数で指定される時間(ミリ秒)です。続いて適用される各待機時間は、待機時間が spf-maximum 引数で指定される最大時間(ミリ秒)に達するまで、現在の保持時間(ミリ秒)を 2 倍した値になります。それ以降の待機時間は、値がリセットされるか SPF 計算間に LSA を受信するまで最大値のままです。

次に、ルータで、 timers throttle spf コマンドの初期時間、保持時間、および最大時間の値をそれぞれ 5、1,000、および 90,000 ミリ秒に設定する例を示します。

switch(config)# router ospfv3 1
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# timers throttle spf 5 1000 90000
 

 

track(VRRP)

追跡対象オブジェクトに基づいて仮想ルータのプライオリティを変更するには、 track コマンドを使用します。仮想ルータのためのプライオリティ トラッキングをディセーブルにするには、このコマンドの no 形式を使用します。

track object-number [ decrement value ]

no track track object-number [ decrement value ]

 
構文の説明

object-number

設定済みの追跡対象オブジェクトの番号。範囲は 1 ~ 500 です。

decrement value

(任意)追跡対象オブジェクトがダウンした場合に、VRRP プライオリティをデクリメントします。範囲は 1 ~ 254 です。

 
デフォルト

なし

 
コマンド モード

VRRP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更あり

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

track(VRRP) コマンドは、設定された追跡対象オブジェクトのステートに基づいて仮想ルータのプライオリティを変更するために使用します。追跡対象オブジェクトを設定するには、track コマンドを使用します。追跡対象オブジェクトがダウンすると、そのプライオリティが仮想ルータのプライオリティ値に戻ります。追跡対象オブジェクトがアップすると、仮想ルータのプライオリティが元の値に戻ります。

このコマンドには、ライセンスは必要ありません。

次に、仮想ルータのオブジェクト トラッキングをイネーブルにする例を示します。

switch# config t
switch(config)# track 33 ip route 192.0.2.0/24 reachability
switch(config)# interface ethernet 2/1
switch(config-if)# vrrp 250
switch(config-if-vrrp)# track 33 priority 2
 

 
関連コマンド I

コマンド
説明

feature vrrp

VRRP をイネーブルにします。

show vrrp

VRRP 設定情報を表示します。

track interfave(VRRP)

インターフェイスのステートを追跡して、インターフェイス ステートがダウンした場合に VRRP プライオリティを変更します。

track interface

インターフェイス上にオブジェクト トラッキングを設定するには、 track interface コマンドを使用します。このインターフェイスに対するオブジェクト トラッキングを削除するには、このコマンドの no 形式を使用します。

track object-id interface interface-type number {{ ip | ipv6 } routing | line-protocol }

no track object-id [ force ]

 
構文の説明

object-id

トラッキング ID。範囲は 1 ~ 500 です。

interface interface-type number

追跡対象のインターフェイスを指定します。オンライン ? ヘルプを使用して 使用可能なインターフェイス タイプのリストを表示します。

ip routing

インターフェイスの IP ルーティング ステートを追跡します。

ipv6 routing

インターフェイスの IPv6 ルーティング ステートを追跡します。

line-protocol

インターフェイスのライン プロトコル ステートを追跡します。

force

(任意)オブジェクト トラッキング インスタンスを完全に削除します。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.1(2)

ipv6 キーワードが追加されました。

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

track interface コマンドは、ライン プロトコル ステータス、あるいは、インターフェイスの IPv4 または IPv6 ルーティング ステートを追跡するために使用します。このコマンドを使用すると、オブジェクト トラッキング コマンド モードが開始されます。デフォルト VRF 以外のオブジェクトを追跡するには、オブジェクト トラッキング コンフィギュレーション モードで vrf member コマンドを使用します。

このコマンドには、ライセンスは必要ありません。

次に、イーサネット インターフェイス 1/2 上の IP ルーティングの状態を追跡する例を示します。

switch(config)# track 1 interface ethernet 1/2 ip routing
switch(config-track)#
 

 
関連コマンド

コマンド
説明

show track

オブジェクト トラッキングに関する情報を表示します。

track { ip | ipv6 } route reachability

IPv4 または IPv6 ルート到達可能性のステートを追跡します。

vrf member

非デフォルト VRF 内のオブジェクトを追跡します。

track interface(VRRP)

インターフェイスに基づいて仮想ルータのプライオリティを追跡するには、 track interface コマンドを使用します。仮想ルータのためのプライオリティ トラッキングをディセーブルにするには、このコマンドの no 形式を使用します。

track interface {ethernet interface-num | vlan vlan-num | port-channel channel-group-num } priority value

no track interface

 
構文の説明

ethernet interface-num

プライオリティを追跡する対象の仮想ルータ インターフェイスを指定します。範囲は 1 ~ 255 です。

vlan vlan-num

プライオリティを追跡する対象の VLAN を指定します。

port-channel channel-group-num

プライオリティを追跡する対象のポートチャネル グループを指定します。

priority value

仮想ルータのインターフェイス プライオリティ。値の範囲は 1 ~ 255 です。このルータが IP アドレスのオーナーの場合は、自動的に 255 の値に設定されます。

 
デフォルト

ディセーブル

 
コマンド モード

VRRP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更あり

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

track コマンドは、仮想ルータのプライオリティをスイッチ内の別のインターフェイスのステートに基づいて変更するために使用します。追跡対象インターフェイスがダウンすると、プライオリティは仮想ルータのプライオリティ値に戻ります。追跡対象インターフェイスがアップすると、仮想ルータのプライオリティはインターフェイス ステートを追跡する値に戻ります。

このコマンドには、ライセンスは必要ありません。


) インターフェイス上でプリエンプションをイネーブルにしなければ、インターフェイス ステート トラッキングを起動できません。


次に、仮想ルータのインターフェイス ステート トラッキングをイネーブルにする例を示します。

switch# config t
switch(config)# interface ethernet 2/1
switch(config-if)# vrrp 250
switch(config-if-vrrp)# track interface ethernet 2/2 priority 2
 

 
関連コマンド I

コマンド
説明

feature vrrp

VRRP をイネーブルにします。

show vrrp

VRRP 設定情報を表示します。

track(VRRP)

オブジェクトを追跡して VRRP プライオリティを変更します。

track ip route

IP ルート上にオブジェクト トラッキングを設定するには、 track ip route コマンドを使用します。このルートのオブジェクト トラッキングを削除するには、このコマンドの no 形式を使用します。

track object-id ip route ip-prefix/length reachability

no track object-id [ force ]

 
構文の説明

object-id

トラッキング ID。範囲は 1 ~ 500 です。

ip-prefix/length

追跡対象のルートのプレフィクス。IP プレフィクスはドット付き 10 進表記(X.X.X.X)です。長さは 1 ~ 32 です。

reachability

IP ルートの到達可能性を追跡します。

force

(任意)オブジェクト トラッキング インスタンスを完全に削除します。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

track ip route コマンドは、IP ルート到達可能性を追跡するために使用します。このコマンドを使用すると、オブジェクト トラッキング コマンド モードが開始されます。デフォルト VRF 以外のオブジェクトを追跡するには、オブジェクト トラッキング コンフィギュレーション モードで vrf member コマンドを使用します。

このコマンドには、ライセンスは必要ありません。

次に、IP ルートを追跡する例を示します。

switch(config)# track 1 ip route 10.10.10.0/8 reachability
switch(config-track)#
 

 
関連コマンド

コマンド
説明

show track

オブジェクト トラッキングに関する情報を表示します。

track interface

インターフェイスを追跡します。

track ipv6 route reachability

IPv6 ルート追跡可能性を追跡します。

vrf member

非デフォルト VRF 内のオブジェクトを追跡します。

track ipv6 route

IPv6 ルートに対してオブジェクト トラッキングを設定するには、 track ipv6 route コマンドを使用します。このルートのオブジェクト トラッキングを削除するには、このコマンドの no 形式を使用します。

track object-id ipv6 route ipv6-prefix/length reachability

no track object-id [ force ]

 
構文の説明

object-id

トラッキング ID。範囲は 1 ~ 500 です。

ipv6-prefix/length

追跡対象のルートのプレフィクス。IPv6 プレフィクスの形式は A:B:C:D/length です。length は 1 ~ 128 です。

reachability

IPv6 ルートの到達可能性ステートを追跡します。

force

(任意)オブジェクト トラッキング インスタンスを完全に削除します。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.1(2)

このコマンドが追加されました。

 
使用上のガイドライン

track ipv6 route コマンドは、IPv6 ルートのステータスを追跡するために使用します。このコマンドを使用すると、オブジェクト トラッキング コマンド モードが開始されます。デフォルト VRF 以外のオブジェクトを追跡するには、オブジェクト トラッキング コンフィギュレーション モードで vrf member コマンドを使用します。

このコマンドには、ライセンスは必要ありません。

次に、IPv6 ルートを追跡する例を示します。

switch(config)# track 1 ipv6 route 2001:0DB8::/8 reachability
switch(config-track)#
 

 
関連コマンド

コマンド
説明

show track

オブジェクト トラッキングに関する情報を表示します。

track ip route

インターフェイスを追跡します。

vrf member

非デフォルト VRF 内のオブジェクトを追跡します。

track list

オブジェクト リストに対してオブジェクト トラッキングを設定するには、 track list コマンドを使用します。このオブジェクト リストのオブジェクト トラッキングを削除するには、このコマンドの no 形式を使用します。

track object-id list boolean { and | or }

track object-id list threshold { percentage | weight }

no track object-id [ force ]

 
構文の説明

object-id

トラッキング ID。範囲は 1 ~ 500 です。

boolean

追跡対象オブジェクトのステートをブールの組み合わせとして結合します。

and

追跡対象オブジェクトのステートをブール AND として結合します。

or

追跡対象オブジェクトのステートをブール OR として結合します。

threshold

追跡対象オブジェクトのステートを割合または重みの組み合わせとして結合します。

percentage

追跡対象オブジェクトのステートをリスト内の追跡対象オブジェクト総数の割合として結合します。

weight

追跡対象オブジェクトのステートを設定された重みの組み合わせとして結合します。

force

(任意)オブジェクト トラッキング インスタンスを完全に削除します。

 
コマンド デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

track list コマンドは、1 つの追跡対象ステートに結合するオブジェクトのリストを作成するために使用します。 boolean and キーワードは、追跡対象オブジェクトを AND 関数のように結合するために使用します(つまり、すべてのオブジェクトがアップしなければ、追跡対象リストがアップしません)。 boolean or キーワードは、追跡対象オブジェクトを OR 機能として結合するために使用します(つまり、任意のオブジェクトがアップしていれば、追跡対象ステートもアップします)。

track list コマンドは、追跡コマンド モードに入ります。このモードでは、次のコマンドを設定できます。

object :追跡リスト内で追跡する 1 つ以上のオブジェクトを設定します。オプションで、 not キーワードを使用して、オブジェクト追跡ステートを無効にできます (つまり、ブール追跡対象リストに対して not キーワードを使用した場合は、アップ ステートがダウン ステートになります)。オプションで、 weight キーワードを使用して、しきい値重み追跡対象リストのオブジェクトに重みを割り当てることができます。デフォルト値は 10 です。

vrf :追跡リストを VRF に割り当てます。

このコマンドには、ライセンスは必要ありません。

次に、2 つのオブジェクトの追跡リストとそれらの AND ステートを作成する例を示します。

switch(config)# track 1 boolean and
switch(config-track)#object 33
switch(config-track)#object 30
 

次に、トラッキング リストのアップしきい値を 70%、ダウンしきい値を 30% にそれぞれ設定する例を示します。

switch# config t

switch(config)# track 1 list threshold percentage

switch(config-track)# threshold percentage up 70 down 30

switch(config-track)# object 10

switch(config-track)# object 20

switch(config-track)# object 30

 

次に、トラッキング リストのアップ重みしきい値を 30、ダウンしきい値を 10 にそれぞれ設定する例を示します。

switch# config t

switch(config)# track 1 list threshold weight

switch(config-track)# threshold weight up 30 down 10

switch(config-track)# object 10 weight 15

switch(config-track)# object 20 weight 15

switch(config-track)# object 30

 

この例では、オブジェクト 10 とオブジェクト 20 がアップの場合にトラッキング リストがアップになり、3 つのオブジェクトがすべてダウンの場合にトラッキング リストがダウンになります。

 

 
関連コマンド

コマンド
説明

show track

オブジェクト トラッキングに関する情報を表示します。

track ip route

インターフェイスを追跡します。

transmit-delay(OSPF 仮想リンク)

インターフェイス上のリンクステート アップデート パケットの終了に必要な推定時間を設定するには、 transmit-delay コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

transmit-delay seconds

no transmit-delay

 
構文の説明

seconds

リンクステート アップデートの送信に必要な時間(秒)。指定できる範囲は 1 ~ 65535 秒です。デフォルトは 1 秒です。

 
デフォルト

1 秒

 
コマンド モード

仮想インターフェイス コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

仮想リンクの送信および伝搬遅延を設定するには、仮想リンク コンフィギュレーションで transmit-delay コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、再送信遅延値を 3 秒に設定する例を示します。

switch(config)# router ospf 201
switch(config-router)# area 22 virtual-link 192.0.2.1
switch(config-router-vlink)# transmit-delay 3

transmit-delay(OSPFv3 仮想リンク)

インターフェイス上のリンクステート アップデート パケットの終了に必要な推定時間を設定するには、 transmit-delay コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

transmit-delay seconds

no transmit-delay

 
構文の説明

seconds

リンクステート アップデートの送信に必要な時間(秒)。指定できる範囲は 1 ~ 65535 秒です。デフォルトは 1 秒です。

 
デフォルト

1 秒

 
コマンド モード

仮想インターフェイス コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

仮想リンクの送信および伝搬遅延を設定するには、仮想リンク コンフィギュレーションで transmit-delay コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、再送信遅延値を 3 秒に設定する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# area 22 virtual-link 192.0.2.1
switch(config-router-vlink)# transmit-delay 3