Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス リリース 5.x
N コマンド
N コマンド
発行日;2012/05/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

N コマンド

neighbor

net

network

nexthop route-map

nexthop trigger-delay

N コマンド

この章では、N で始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

neighbor

BGP ネイバー(ルータ、VRF)を設定し、ネイバー コンフィギュレーション モードを開始するには、 neighbor コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

neighbor { ip-addr | ip-prefix / length | ipv6-addr | ipv6-prefix / length } [ remote-as { as-num [ . as-num ] | route-map name }

no neighbor { ip-addr | ip-prefix / length | ipv6-addr | ipv6-prefix / length } [ remote-as { as-num [ . as-num ] | route-map name }]

 
構文の説明

ip-addr

ネイバーの IP アドレス(A.B.C.D 形式)。

ip-prefix / length

IP プレフィクスおよび IP プレフィクス長。形式は x.x.x.x/ length です。 length の範囲は 1 ~ 32 です。

ipv6-addr

ネイバーの IPv6 アドレス。形式は、A:B::C:D です。

ipv6-prefix / length

ネイバーの IPv6 プレフィクスおよび IPv6 プレフィクスの長さ。形式は A:B::C:D/ length です。 length の範囲は 1 ~ 128 です。

remote-as

(任意)ネイバーの自律システム番号を指定します。

as-num

ルータと他の BGP ルータを区別し、渡されたルーティング情報にタグを付ける自律システムの番号。有効な範囲は 1 ~ 65535 です。

. as-num

(任意)ルータと他の BGP ルータを区別し、渡されたルーティング情報にタグを付ける自律システムの番号。有効な範囲は 1 ~ 65535 です。

route-map name

(任意)AS 番号のリストまたは正規表現に照らして BGP ピア AS 番号を照合するルート マップを指定します。63 文字以内の英数字のストリング(大文字と小文字を区別)で指定します。

 
デフォルト

このコマンドには、デフォルト設定はありません。

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション
ルータ BGP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.1(2)

route-map キーワードのサポートが追加されました。

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

BGP ネイバー コンフィギュレーション モードを開始するには、 neighbor コマンドを使用します。 neighbor コマンドを入力すると、プロンプトが switch(config-router-neighbor)# に変わります。

BGP ネイバー コンフィギュレーション モードから、次の操作を実行できます。

address-family :アドレスファミリ(ルータ、ネイバー、VRF)を設定します。詳細については、 address-family(BGP) コマンドを参照してください。

description description ネイバーの説明を記述します。スペースを含めて 80 文字まで入力できます。

disable-connected-check :直接接続されているピアに対する接続検証をディセーブルにします。 disable-connected-check コマンドは、ローカル ルータに直接接続された eBGP ピアに対するチェックをディセーブルにするために使用します。BGP は、 disable-connected-check コマンドを使用してチェックがディセーブルにされていない限り、1 ホップ離れていることがわかっているすべての eBGP ピアに対する接続チェックを自動的にトリガーします。チェックが失敗した場合、BGP はセッションを開始しません。eBGP ピアに対して ebgp-multihop コマンドが設定されていない場合(つまり、Time-to-Live(TTL; 存続可能時間)が 1 の場合)、BGP はその eBGP ピアが 1 ホップ離れていると見なします。

このコマンドは、 neighbor コマンドで route-map キーワードが使用されている場合に無視されます。

dont-capability-negotiate :このネイバーのネゴシエーション機能をオフにします。

dynamic-capability :ダイナミック機能をイネーブルにします。

ebgp-multihop :直接接続されていないネットワーク上に存在する外部ピアとの BGP による接続を受け入れたり、接続を試行したりします。このコマンドは、 neighbor コマンドで route-map キーワードが使用されている場合に無視されます。


) このコマンドを使用する場合は、必ずシスコのテクニカルサポート担当者の指示に従ってください。


exit :現在のコマンド モードを終了します。

inherit peer-session session-name :他のピア セッション テンプレートから設定を継承するようにピアを設定します。ピア セッション テンプレートから継承文を削除するには、このコマンドの no 形式を使用します。

no :コマンドを無効にするか、デフォルト設定にします。

transport connection-mode passive :受動接続設定のみを許可します。制限を削除するには、このコマンドの no 形式を使用します。

remove-private-as :プライベート AS 番号を発信アップデートから削除します。

shutdown :このネイバーを管理上のシャットダウンにします。

timers keepalive-time :キープアライブ タイマーおよびホールド タイマーの値を秒数で設定します。範囲は 0 ~ 3600 です。デフォルトは 60 です。

update-source { ethernet mod / port | loopback virtual-interface | port-channel number [ . sub-interface ]} :BGP セッションおよびアップデートの発信元を指定します。 virtual-interface の範囲は 0 ~ 1023 です。 number の範囲は 0 ~ 4096 です。 sub-interface の範囲は 1 ~ 4093 です。

Cisco NX-OS ソフトウェアは、ネイバー コンフィギュレーション モードで update-source コマンドが入力された場合に、BGP セッションで TCP 接続に対して任意の動作可能インターフェイスを使用できるようにします。インターフェイスの割り当てを最も近いインターフェイス(最適ローカル アドレス)に復元するには、このコマンドの no 形式を使用します。

内部または外部 BGP セッションの IPv6 リンクローカル ピアリングをイネーブルにするには、 update-source コマンドを使用する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、各ルータ上のローカル ループバック インターフェイスを経由して同じネットワーク セグメント上で到達可能な 2 つの BGP ピア間に 1 ホップ eBGP ピアリング セッションを設定する例を示します。

BGP ピア 1

switch(config)# interface loopback 1
switch(config-if)# ip address 10.0.0.100 255.255.255
switch(config-if)# exit
switch(config)# router bgp 64497
switch(config-router)# neighbor 192.168.0.200 remote-as 64496
switch(config-router-neighbor)# update-source loopback 2
switch(config-router-neighbor)# disable-connected-check

BGP ピア 2

switch(config)# interface loopback 2
switch(config-if)# ip address 192.168.0.200 255.255.255
switch(config-if)# exit
switch(config)# router bgp 64496
switch(config-router)# neighbor 10.0.0.100 remote-as 64497
switch(config-router-neighbor)# update-source loopback 1
switch(config-router-neighbor)# disable-connected-check
 

次に、指定されたネイバーの BGP TCP 接続に、ベスト ローカル アドレスではなく、ループバック インターフェイスの IP アドレスを供給する例を示します。

switch(config)# router bgp 64496
switch(config-router)# neighbor 172.16.0.0 remote-as 64496
switch(config-router-neighbor)# update-source Loopback0
 

次に、自律システム 64496 内の指定されたネイバーの IPv6 BGP TCP 接続にループバック インターフェイス 0 のグローバル IPv6 アドレスを供給し、自律システム 64498 内の指定されたネイバーにイーサネット インターフェイス 2/1 のリンクローカル IPv6 アドレスを供給する例を示します。

switch(config)# router bgp 64497
switch(config-router)# neighbor 3ffe::3 remote-as 64496
switch(config-router-neighbor)# update-source Loopback0
switch(config-router-neighbor)# neighbor fe80::2 remote-as 64498
switch(config-router-neighbor)# update-source Ethernet 2/1

 

 
関連コマンド

コマンド
説明

feature bgp

ルータ上で BGP をイネーブルにします。

route-map

ルート マップを作成します。

net

ルーティング プロセスの Intermediate System-to-Intermediate System(IS-IS)ネットワーク エンティティ(NET)を設定するには、 net コマンドを使用します。NET を削除するには、このコマンドの no 形式を使用します。

net net

no net net

 
構文の説明

net

IS-IS ルーティング プロセスの NET ネットワーク サービス アクセス ポイント(NSAP)名またはアドレス。有効な値に関する詳細については、「使用上のガイドライン」を参照してください。

 
デフォルト

デフォルトの設定は次のとおりです。

NET は設定されていません。

IS-IS プロセスはディセーブルです。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

IS(intermediate system; 中継システム)は NSAP と呼ばれるアドレスで識別されます。NSAP は ISO/AI 10589 の規定に従い、次の 3 つの部分にわかれています。

エリア アドレス:このフィールドは上位のオクテットで構成された可変長フィールドです(システム ID および N セレクタ(NSEL)フィールドを除きます)。エリア アドレスは、ルーティング ドメイン内の 1 つのエリアに関連付けられます。

システム ID:このフィールドは、6 オクテット長で、レベル 1 とレベル 2 で一意の値にする必要があります。システム ID は、エリア内の End System(ES; エンド システム)または IS を定義します。エリア アドレスおよびシステム ID は NET コマンドを使用して設定します。システム ID は show isis topology コマンドを使用して表示できます。

NSEL:このフィールドは N セレクタまたは NSAP とも呼ばれます。ここには上位層プロトコルを指定します。NSEL は NSAP の最後のバイトであり、NSEL でネットワーク サービス ユーザを識別します。ネットワーク サービス ユーザは、トランスポート エンティティまたは IS ネットワーク エンティティ自身です。NSEL をゼロに設定すると、NSAP 全体が NET と呼ばれます。

NET は、最後のバイトが必ず N セレクタで、値がゼロである NSAP のことです。NET の長さは 8 ~ 20 バイトです。NET は XX.AAAA.AAAA.AAAA[.AAAA].XX のようにフォーマットされます。

ほとんどの場合、NET を 1 つだけ設定します。NET を 2 つまたは 3 つ設定することは可能ですが、次のまれな場合を除いて、通常は NET を 1 つだけ設定するようにしてください。

統合される複数のエリアを持ったネットワーク構成

IS-IS プロセス内の 1 つのエリアを複数のエリアに分割

複数のエリア アドレスがあるとエリアの番号を必要に応じて個別に振り直すことができるので、上記 2 つの場合で複数の NET を設定することは一時的に有効な方法と言えます。

IS-IS を使用して IP ルーティングのみを実行する場合(Connectionless Network Service [CLNS; コネクションレス型ネットワーク サービス] がイネーブルになっていない)、NET を設定してルータ ID およびエリア ID を定義する必要があります。

次に、システム ID 0000.0c11.1110 およびエリア アドレス 47.0004.0(1)04d.0001 で構成される NET を使用してルータを設定する例を示します。

switch(config)# router isis firstcompany

switch(config-router)# net 47.0004.0(1)04d.0001.00

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

network

IP プレフィクスをアドバタイズするように設定するには、 network コマンドを使用します。アドバタイズする IP プレフィクスを削除するには、このコマンドの no 形式を使用します。

network ip-addr | ip-prefix / length mask mask-num [ route-map name ]

no network ip-network | ip-prefix / length mask mask-num [ route-map name ]

 
構文の説明

ip-addr

アドバタイズする IP ネットワーク アドレス。A.B.C.D の形式を使用します。

ip-prefix / length

IP プレフィクスおよび IP プレフィクス長。IPv6 プレフィクス長は、アドレスの連続する上位何ビットがプレフィクス(アドレスのネットワーク部分)を構成するかを示す 10 進値です。10 進数値の前にスラッシュ記号が必要です。A.B.C.D/length の形式を使用します。

mask mask-num

アドバタイズする IP プレフィクスのマスクをドット付き 4 オクテット形式で設定します。

route-map name

(任意)属性を変更するルート マップの名前を指定します。

 
デフォルト

このコマンドには、デフォルト設定はありません。

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション
ルータ BGP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

アドバタイズする IP プレフィクスは、ルーティング テーブル内に同等またはより特異性の高いルートが存在する場合にのみ、ピアへの最適パスおよびアドバタイズメントに適していると考えられます。

次に、アドバタイズする IP プレフィクスを設定する例を示します。

switch(config-router-af)# network 2.2.2.2 mask 3.3.3.3 route-map test
switch(config-router-af)#

nexthop route-map

ルートが特定の特性と一致するネクスト ホップのみを使用して解決されるように BGP ルータを指定するには、 nexthop route-map コマンドを使用します。ルート マップを削除するには、このコマンドの no 形式を使用します。

nexthop route-map name

no nexthop route-map name

 
構文の説明

name

ルート マップ名 名前は、63 文字以下の任意の英数字文字列で指定します。

 
デフォルト

なし

 
コマンド モード

アドレスファミリ コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

nexthop route-map コマンドは、ネクスト ホップに対するルート ポリシー フィルタリングを設定するために使用します。

BGP ネクスト ホップ フィルタリングを使用すると、RIB でネクスト ホップ アドレスがチェックされるときにそのネクスト ホップ アドレスの基盤となるルートがルート マップを経由します。ルート マップでそのルートが拒否されると、ネクスト ホップ アドレスは到達不能として扱われます。

BGP は、ルート ポリシーによって拒否されたすべてのネクスト ホップを無効であるとマークし、無効なネクスト ホップ アドレスを使用するルートについてベスト パスを計算しません。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、ネクスト ホップ アドレスをフィルタリングするようにルート マップを設定する例を示します。

switch# config t

switch(config)# route-map CHECK-BGP25 deny 10

switch(config-route-map)# match ip address prefix-list FILTER25

switch(config-route-map)# match source-protocol ospf-o1

switch(config-route-map)# exit

switch(config)# ip prefix-list FILTER25 seq 5 permit 0.0.0.0/0 le 25

switch(config)# router bgp 1.0

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# nexthop route-map CHECK-BGP25

 

 
関連コマンド

コマンド
説明

feature bgp

BGP をイネーブルにします。

nexthop trigger-delay

BGP ネクスト ホップ アドレス トラッキング用の遅延時間を設定します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

nexthop trigger-delay

ネクスト ホップ計算をトリガーするための BGP 遅延を指定するには、 nexthop trigger-delay コマンドを使用します。トリガー遅延をデフォルト値に設定するには、このコマンドの no 形式を使用します。

nexthop trigger-delay { critical delay | non-critical delay }

no nexthop trigger-delay { critical delay | non-critical delay }

 
構文の説明

critical delay

致命的ネクスト ホップ トリガー遅延をミリ秒単位で指定します。範囲は 0 ~ 4294967295 です。デフォルトは 3000 です。

non-critical delay

非致命的ネクスト ホップ トリガー遅延をミリ秒単位で指定します。範囲は 0 ~ 4294967295 です。デフォルトは 10000 です。

 
デフォルト

critical delay:3000 ミリ秒
noncritical delay:10000 ミリ秒

 
コマンド モード

アドレスファミリ コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

nexthop trigger-delay コマンドは、BGP がネクスト ホップ アドレス トラッキング イベントを処理するタイミングを変更するために使用します。

non-critical delay の値は、必ず、 critical delay の値以上に設定する必要があります。

遅延は、Interior Gateway Protocol(IGP)の場合に要する時間よりも少しだけ長く設定して、イベント後に安定状態になるようにする必要があります(IGP コンバージェンス時間)。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、ネクスト ホップ アドレス トラッキング遅延を変更する例を示します。

switch# config t

switch(config)# router bgp 1.0

switch(config-router)# address-family ipv4 unicast

switch(config-router-af)# nexthop trigger-delay critical 5000 non-critical 20000

 

 
関連コマンド

コマンド
説明

feature bgp

BGP をイネーブルにします。

nexthop route-map

BGP ネクスト ホップ アドレス トラッキング用のルート マップを設定します。