Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス リリース 5.x
M コマンド
M コマンド
発行日;2012/05/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

M コマンド

mac-list

match as-number

match as-path

match community

match extcommunity

match interface

match ip address

match ip multicast

match ip next-hop prefix-list

match ip route-source prefix-list

match ipv6 address

match ipv6 multicast

match ipv6 next-hop prefix-list

match ipv6 route-source prefix-list

match length

match metric

match mac-list

match route-type

match tag

match vlan

max-metric router-lsa(OSPF)

max-lsp-lifetime

maxas-limit

maximum-paths(BGP)

maximum-paths(EIGRP)

maximum-paths(IS-IS)

maximum-paths(RIP)

maximum-paths(OSPF)

maximum-paths(OSPFv3)

maximum-prefix

message-digest-key(OSPF 仮想リンク)

metric maximum-hops

metricrib-scale

metric weights

metric-style transition

metricversion

M コマンド

この章では、M で始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

mac-list

MAC アドレスに基づいてフィルタするには、 mac-list コマンドを使用します。MAC リスト エントリを削除するには、このコマンドの no 形式を使用します。

mac-lis t name [ seq number ] { permit | deny } mac-address [ mac-mask ]

mac-list name [ seq number ] { permit | deny } mac-address [ mac-mask ]

 
構文の説明

name

MAC リスト名。name には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

seq number

MAC リスト内のエントリを作成します。 seq の範囲は 1 ~ 4294967294 です。

permit

MAC リスト内の MAC アドレスと一致するパケットまたはルートを許可します。

deny

MAC リスト内の MAC アドレスと一致するパケットまたはルートをブロックします。

mac-address

フィルタ対象の MAC アドレス。

mac-mask

照合する MAC アドレスの部分(MAC アドレス形式)。

 
デフォルト

match の値は定義されません。

 
コマンド モード

グローバル コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

5.0(2)

このコマンドが追加されました。

 
使用上のガイドライン

MAC アドレスに基づいてをフィルタするには、mac-list コマンドを使用します。ルート マップ内のこの MAC リストに対して照合できます。

このコマンドには LAN Enterprise ライセンスが必要です。

次に、Red MAC リストを作成する例を示します。

switch(config)# mac-list Red seq 1 permit 0022.5579.a4c1 ffff.ffff.0000

 
関連コマンド

コマンド
説明

match mac-list

MAC リスト内の MAC アドレスを照合します。

show mac-list

MAC リストに関する情報を表示します。

match as-number

ボーダー ゲートウェイ プロトコル(BGP)自律システム(AS)番号と照合するには、 match as-number コマンドを使用します。AS 番号リスト エントリを削除するには、このコマンドの no 形式を使用します。

match as-number { number [, number ...] | as-path-access-list name [... name ]}

no match as-number { number [, number ...] | as-path-access-list name [... name ]}]

 
構文の説明

number

AS 番号。有効な範囲は 1 ~ 65535 です。

...number

(任意)AS 番号。有効な範囲は 1 ~ 65535 です。

as-path-access-list name

AS 番号を照合する AS-path アクセス リストを指定します。名前は、63 文字以下の任意の英数字文字列で指定します。

...name

(任意)AS-path アクセス リスト。名前は、63 文字以下の任意の英数字文字列で指定します。

 
デフォルト

なし

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.1(2)

このコマンドが追加されました。

 
使用上のガイドライン

match as-number コマンドは、正規表現を使用して AS 番号のリストまたは AS-path アクセス リストを生成するために使用します。BGP は、この一致基準を使用して、BGP セッションを構築する BGP ピアを特定します。

ルート マップは、ピアがプレフィクス ピアリングを通してローカル BGP とのセッションを確立可能な AS 番号の範囲を使用するために使用します。Cisco NX-OS は、 match as-number コマンドがルート マップ内に存在する場合に他の match コマンドを無視します。

このコマンドには、ライセンスは必要ありません。

次に、AS 番号のリストを設定する例を示します。

switch(config)# route-map IGP2BGP
switch(config-route-map)# match as-number 64496, 64498-64510

 
関連コマンド

コマンド
説明

ip as-path access-list

AS-path リストを作成します。

neighbor

BGP ピアを設定します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

match as-path

BGP 自律システム パス アクセス リストを照合するには、ルートマップ コンフィギュレーション モードで match as-path コマンドを使用します。パス リスト エントリを削除するには、このコマンドの no 形式を使用します。

match as-path name [... name ]

no match as-path name [... name ]

 
構文の説明

name

自律システム パス アクセス リスト。名前は、63 文字以下の任意の英数字文字列で指定します。

...name

(任意)自律システム パス アクセス リスト。最大 32 個のアクセス リスト名を設定できます

 
デフォルト

パス リストは定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

match as-path コマンドを使用して値を設定すると、グローバル値が上書きされます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、別のルート マップ セクションに明示的に match を指定する必要があります。

このコマンドには、ライセンスは必要ありません。

次に、自律システム パスと BGP AS パス アクセス リスト 20 を照合する設定の例を示します。

switch(config)# route-map IGP2BGP
switch(config-route-map)# match as-path 20

 
関連コマンド

コマンド
説明

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set comm-list

ルート マップの設定におけるタグ値を自動計算します。

set community

BGP コミュニティ リストを設定します(削除用)。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set origin(BGP)

BGP 送信元コードを設定します。

set tag

宛先ルーティング プロトコルの値を設定します。

set vrf

ネクスト ホップ解決用の Virtual Routing and Forwarding(VRF)を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match community

BGP コミュニティを照合するには、 match community コマンドを使用します。コンフィギュレーション ファイルから match community コマンドを削除し、システムをデフォルトの条件(BGP コミュニティ リスト エントリを削除)に戻すには、このコマンドの no 形式を使用します。

community name [... name ] [ exact-match ]

no community name [... name ] [ exact-match ]

 
構文の説明

name

1 つ以上のコミュニティ リスト名。名前は、63 文字以下の任意の英数字文字列で指定します。最大 32 のコミュニティ リストを設定できます。

exact-match

(任意)完全一致が必要であることを示します。指定されたすべてのコミュニティのみが存在する必要があります。

 
デフォルト

ルート マップではコミュニティ リストの照合は行われません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連した match コマンドと 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、別のルート マップ セクションに明示的に match を指定する必要があります。

コミュニティ リスト番号に基づく照合は、BGP に適用できる match コマンドのタイプの 1 つです。

このコマンドには、ライセンスは必要ありません。

次に、2 つの BGP コミュニティを照合する例を示します。

switch(config)# route-map test2
switch(config-route-map)# match community bgpLow bgpHigh
 

この例では、コミュニティ リスト 1 に一致するルートの重みが 200 に設定されています。標準コミュニティ 109 のみが含まれるルートに 200 の重みが設定されます。

switch(config)# ip community-list standard bgpLow permit 109
switch(config)# route-map set_weight
switch(config-route-map)# match community bgpLow exact-match
switch(config-route-map)# set weight 200
 

この例では、コミュニティ リスト 500 に一致するルートを示します。拡張コミュニティ 1 が含まれるルートに 150 の重みが設定されます。

switch(config)# ip community-list expanded 500 permit [0-9]*
switch(config)# route-map MAP_NAME permit 10
switch(config-route-map)# match community 500
switch(config-route-map)# set weight 150

 
関連コマンド

コマンド
説明

ip community-list

BGP のコミュニティ リストを作成し、アクセスを制御します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

 

match extcommunity

ルート マップ内の BGP 拡張コミュニティを照合するには、 match extcommunity コマンドを使用します。ルート マップから match を削除するには、このコマンドの no 形式を使用します。

extcommunity name [... name ] [ exact-match ]

no extommunity name [... name ] [ exact-match ]

 
構文の説明 ]

name

1 つ以上の拡張コミュニティ リスト名。名前は、63 文字以下の任意の英数字文字列で指定します。最大 32 のコミュニティ リストを設定できます。

exact-match

(任意)完全一致が必要であることを示します。指定されたすべてのコミュニティとそれらの拡張コミュニティのみが存在する必要があります。

 
デフォルト

ルート マップではコミュニティ リストの照合は行われません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

ルート マップは、いくつかの部分にわかれている可能性があります。ルート マップ内の 1 つ以上の match コマンドと一致しないルートは無視されます。つまり、ルートは、アウトバウンド ルート マップに対してアドバタイズされず、インバウンド ルート マップに対して受け入れられません。一部のデータのみを変更したい場合は、別のルート マップ セクションに明示的に match を指定する必要があります。

コミュニティ リスト番号に基づく照合は、BGP に適用可能な match コマンドのタイプのいずれかです。

このコマンドには、ライセンスは必要ありません。

次に、2 つの BGP 拡張コミュニティ リストを照合する例を示します。

switch(config)# route-map test2
switch(config-route-map)# match extcommunity bgpLocal bgpRemote
 

次に、拡張コミュニティ リスト bgpLocal に一致するルートが非推移的から推移的に変化する例を示します。

switch(config)# ip extcommunity-list standard bgpLocal permit generic nontransitive 1.9
switch(config)# route-map deletCommunity
switch(config-route-map)# match extcommunity bgpLocal exact-match
switch(config-route-map)# set extcommunity generic transitive 1.9
 

 
関連コマンド

コマンド
説明

ip extcommunity-list

BGP のコミュニティ リストを作成し、アクセスを制御します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

send-community

コミュニティ属性を BGP ピアに伝搬するように BGP を設定します。

set extcommunity

ルート マップ内の拡張コミュニティを設定します。

match interface

ルート マップ内のインターフェイスを照合するには、 match interface コマンドを使用します。この match 設定を削除するには、このコマンドの no 形式を使用します。

match interface { interface-typ e number [, interface-type number ...] }

no interface { interface-typ e number [, interface-type number ...] }

 
構文の説明

interface-type

インターフェイス タイプ。 ? を使用してサポートされているインターフェイスのリストを表示します。

number

(任意)インターフェイス番号。 ? を使用して範囲を表示します。

 
デフォルト

なし

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.1(2)

このコマンドが追加されました。

 
使用上のガイドライン

match interface コマンドは、ルートを照合するインターフェイスのリストを提供するために使用します。これらのインターフェイスのいずれかによって到達されるルート ネクスト ホップ アドレスは、ルート マップと一致します。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、別のルート マップ セクションに明示的に match を指定する必要があります。

このコマンドには、ライセンスは必要ありません。

次に、インターフェイスのリストを設定する例を示します。

switch(config)# route-map test1
switch(config-route-map)# match interface ethernet 2/1, ethernet 4/3

 
関連コマンド

コマンド
説明

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

match ip address

宛先 IP ネットワーク番号アドレスが標準アクセス リスト、拡張アクセス リスト、またはプレフィクス リストで許可されているルートを配布する場合、またはパケットでポリシー ルーティングを実行する場合は、ルート マップ コンフィギュレーション モードで match ip address コマンドを使用します。 match ip address エントリを削除するには、このコマンドの no 形式を使用します。

match ip address { access-list-name [ access-list-name... ] | prefix-list prefix-list-name [ prefix-list-name... ]}

no match ip address { access-list-name [ access-list-name... ] | prefix-list prefix-list-name [ prefix-list-name... ]}

 
構文の説明

access-list-name...

標準アクセス リストまたは拡張アクセス リストの名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

prefix-list prefix-list-name...

プレフィクス リストに基づいてルートを配布します。プレフィクス リストには最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
デフォルト

アクセス リスト名もプレフィクス リストも指定されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

access-list-name 引数がサポートされるのは、PBR のルート マップに限定されます。

このコマンド構文内の省略符号(...)は、 access-list-name 引数または prefix-list-name 引数に複数の値を入力できることを示します

同じルート マップ サブブロック内の類似 match は、「OR」(論理和)でフィルタリングされます。ルート マップ サブブロック全体の中に一致する match 句が 1 つあれば、照合の成功として処理されます。非類似 match 句は、「AND」(論理積)でフィルタリングされます。したがって、非類似照合は論理的にフィルタリングされます。最初の条件セットが満たされない場合、2 つ目の match 句がフィルタリングされます。このプロセスは一致するものが見つかるまで、または match 句がなくなるまで続きます。

ルートの再配布またはパケットのポリシー ルーティングを実行するには、ルート マップを使用します。両方の用途について、ここで説明します。

再分配

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップを使用してルートを渡す場合、ルート マップの複数のセクションに特定の match 句を入力できます。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

ポリシー ルーティング

ルート マップには、ポリシー ルーティングをイネーブルにするというもう 1 つの用途があります。match ip address コマンドは、拡張アクセス リスト(プロトコル、プロトコル サービス、送信元または宛先の IP アドレスなど)による一致基準に基づいたパケットのポリシー ルーティングを可能にします。パケットのポリシー ルーティング条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドに加えて、 ip policy route-map インターフェイス コンフィギュレーション コマンドも使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。送信元に基づくパケットのポリシー ルーティングを、たとえばアクセス リストを使用して実行できます。

このコマンドには、ライセンスは必要ありません。

次に、アクセス リスト test で指定されたアドレスを持つルートを照合する例を示します。

switch(config)# feature pbr
switch(config)# interface ethernet 2/10
switch(config-if)# ip policy route-map chicago
switch(config-if)# exit
switch(config)# route-map chicago
switch(config-route-map)# match ip address test

 
関連コマンド

コマンド
説明

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match metric

指定されたメトリックを持つルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 句を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ip multicast

ルート マップの照合に IPv4 マルチキャスト機能を設定するには、 match ip multicast ルート マップ コンフィギュレーション コマンドを使用します。この match 設定を削除するには、このコマンドの no 形式を使用します。

match ip multicast { group address/length | source address/length | rp address/length [ rp-type { asm | bidir} ]}

no match ip multicast

 
構文の説明

group address/length

グループ アドレスと、ネットワーク マスクの長さ(ビット単位)を A . B . C . D / length の形式で指定します。ネットワーク番号には、任意の有効な IP アドレスまたはプレフィクスを指定できます。ビット マスクは、0 ~ 32 の数値にできます。

group、source、および rp オプションを設定できます。

source address/length

ソース アドレスと、ネットワーク マスクの長さ(ビット単位)を A . B . C . D / length の形式で指定します。ネットワーク番号には、任意の有効な IP アドレスまたはプレフィクスを指定できます。ビット マスクは、0 ~ 32 の数値にできます。

group、source、および rp オプションを設定できます。

rp address/length

IPv4 Rendezvous Prefix(RP)と、 IPv4 プレフィクス マスクの長さ(ビット単位)を A . B . C . D / length の形式で指定します。ネットワーク番号には、任意の有効な IPv4 アドレスまたはプレフィクスを指定できます。ビット マスクは、0 ~ 32 の数値にできます。

group、source、および rp オプションを設定できます。

rp-type

(任意)マルチキャスト Rendezvous Point(RP; ランデブー ポイント)タイプを指定します。

asm

Any-Source Multicast(ASM)RP タイプを指定します。

bidir

双方向(bidir)マルチキャスト RP タイプを指定します。

 
デフォルト

なし

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

4.1(2)

source キーワードが追加されました。

 
使用上のガイドライン

照合するマルチキャスト属性を指定するには、 match ip multicast コマンドを使用します。

route-map コマンドを使用して、ルート マップ コンフィギュレーション モードを開始します。 route-map コマンドを入力すると、プロンプトが次のように変わります。

switch(config-route-map)#
 

ルート マップ コンフィギュレーション モードになると、 match ip multicast コマンドを入力できます。

group と rp の両方のオプションを設定できます。

このコマンドには、ライセンスは必要ありません。

次に、照合するネイバーの group IPv4 プレフィクスと、IPv4 プレフィクスの長さを指定する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match ip multicast group 192.0.0.0/19
switch(config-route-map)#
 

次に、照合するネイバーの group IPv4 プレフィクスと、ランデブー ポイント IPv4 プレフィクスを両方指定する例を示します。

switch(config)# route-map raspberry
switch(config-route-map)# match ip multicast group 192.0.0.0/19 rp 209.165.201.0/27
switch(config-route-map)#

 
関連コマンド

コマンド
説明

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match metric

指定されたメトリックを持つルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 句を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ip next-hop prefix-list

指定のアクセス リストの 1 つとネクスト ホップ ルータ アドレスが一致した IPv4 ルートを再配布するには、ルート マップ コンフィギュレーション モードで、 match ip next-hop prefix-list コマンドを使用します。ネクスト ホップ エントリを削除するには、このコマンドの no 形式を使用します。

match ip next-hop prefix-list prefix-list-name [ ...prefix-list-name ]

no match ip next-hop prefix-list prefix-list-name [ ...prefix-list-name ]

 
構文の説明

prefix-list-name

プレフィクス リストの番号または名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
デフォルト

ネクスト ホップ アドレスの一致を必要とせず、自由にルートが再配布されます。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 prefix-list-name 引数に複数の値を入力できることを示します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルートがルート マップを通過するようにするときには、ルート マップに複数の要素を持たせることができます。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

このコマンドには、ライセンスは必要ありません。

次に、プレフィクス リスト test を通過したネクスト ホップ ルータ アドレスを持つルートを配布する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match ip next-hop prefix-list test

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ip route-source prefix-list

アクセス リストに指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされた IPv4 ルートを再配布するには、ルート マップ コンフィギュレーション モードで、 match ip route-source prefix-list コマンドを使用します。ルート ソース エントリを削除するには、このコマンドの no 形式を使用します。

match ip route-source prefix-list prefix-list-name [ ...prefix-list-name ]

no match ip route-source prefix-list prefix-list-name [ ...prefix-list-name ]

 
構文の説明

prefix-list-name

プレフィクス リストの番号または名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
デフォルト

ルート ソースに対するフィルタリングは実行されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 prefix-list-name 引数に複数の値を入力できることを示します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

ルートのネクスト ホップとソース ルータ アドレスが同じではない場合もあります。

このコマンドには、ライセンスは必要ありません。

次に、アクセス リスト 5 および 80 で指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを配布する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match ip route-source prefix-list 5 80

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match route-type

指定されたタイプのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ipv6 address

宛先 IPv6 ネットワーク番号アドレスが標準アクセス リスト、拡張アクセス リスト、またはプレフィクス リストで許可されているルートを配布する場合、またはパケットにポリシー ルーティングを実行する場合は、ルート マップ コンフィギュレーション モードで match ipv6 address コマンドを使用します。 match 文をルート マップから削除するには、このコマンドの no 形式を使用します。

match ipv6 address { prefix-list prefix-list-name [ prefix-list-name... ] | access-list-name

no match ipv6 address { prefix-list prefix-list-name [ prefix-list-name... ] | access-list-name }

 
構文の説明

prefix-list prefix-list-name...

プレフィクス リストに基づいてルートを配布します。プレフィクス リストには最大 63 文字の英数字を使用できます。省略符号は、複数の値を入力可能であることを示します。最大 32 のプレフィクス リストを設定できます。

access-list-name...

標準アクセス リストまたは拡張アクセス リストの名前。最大 63 文字の英数字を使用できます。

使用できるのは、ポリシーベース ルーティング用のアクセス リストだけです。

 
デフォルト

アクセス リスト名もプレフィクス リストも指定されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

access-list-name 引数がサポートされるのは、PBR のルート マップに限定されます。

このコマンド構文内の省略符号(...)は、 prefix-list-name 引数に複数の値を入力できることを示します

同じルート マップ サブブロック内の類似 match は、「OR」(論理和)でフィルタリングされます。ルート マップ サブブロック全体の中に一致する match 句が 1 つあれば、照合の成功として処理されます。非類似 match 句は、「AND」(論理積)でフィルタリングされます。したがって、非類似照合は論理的にフィルタリングされます。最初の条件セットが満たされない場合、2 つ目の match 句がフィルタリングされます。このプロセスは一致するものが見つかるまで、または match 句がなくなるまで続きます。

ルートの再配布またはパケットのポリシー ルーティングを実行するには、ルート マップを使用します。両方の用途について、ここで説明します。

再分配

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理( match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップを使用してルートを渡す場合、ルート マップの複数のセクションに特定の match 句を入力できます。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

このコマンドには、ライセンスは必要ありません。

次に、red というアクセス リストで指定されたアドレスを持つルートを照合する例を示します。

switch(config)# feature pbr
switch(config)# route-map blue
switch(config-route-map)# match ipv6 address red
 

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match metric

指定されたメトリックを持つルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 句を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ipv6 multicast

ルート マップの照合に IPv6 マルチキャスト機能を設定するには、 match ipv6 multicast ルート マップ コンフィギュレーション コマンドを使用します。この match 設定を削除するには、このコマンドの no 形式を使用します。

ip multicast { group address/length | source address/length | rp address/length [rp -type { asm | bidir }]}

 
構文の説明

group address/length

グループ アドレスと、ネットワーク マスクの長さ(ビット単位)を A : B :: C : D / length の形式で指定します。ネットワーク番号には、任意の有効な IPv6 アドレスまたはプレフィクスを指定できます。 length の範囲は、 0 ~ 0x7FFFFFFF です

group source 、および rp オプションを指定できます。

source address/length

ソース アドレスと、ネットワーク マスクの長さ(ビット単位)を A : B :: C : D / length の形式で指定します。ネットワーク番号には、任意の有効な IPv6 アドレスまたはプレフィクスを指定できます。 length の範囲は、 0 ~ 0x7FFFFFFF です

group source 、および rp オプションを指定できます。

rp address/length

IPv6 RP と、 IPv6 プレフィクス マスクの長さ(ビット単位)を A : B :: C : D / length の形式で指定します。ネットワーク番号には、任意の有効な IPv6 アドレスまたはプレフィクスを指定できます。ビット マスクは、0 ~ 32 の数値にできます。

group source 、および rp オプションを指定できます。

rp-type

(任意)マルチキャスト Rendezvous Point(RP; ランデブー ポイント)タイプを指定します。

asm

Any-Source Multicast(ASM)RP タイプを指定します。

bidir

双方向(bidir)マルチキャスト RP タイプを指定します。

 
デフォルト

なし

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

4.1(2)

source キーワードが追加されました。

 
使用上のガイドライン

照合するマルチキャスト属性を指定するには、 match ipv6 multicast ルート マップ コンフィギュレーション コマンドを使用します。 route-map コマンドをイネーブルにする前に PBR をイネーブルにするには、 feature pbr グローバル コンフィギュレーション モード コマンドを入力する必要があります。

route-map コマンドを使用して、ルート マップ コンフィギュレーション モードを開始します。 route-map コマンドを入力すると、プロンプトが次のように変わります。

switch(config-route-map)#
 

ルート マップ コンフィギュレーション モードになると、 match ipv6 multicast コマンドを入力できます。

group、source、 および rp オプションを指定できます。

このコマンドには、ライセンスは必要ありません。

次に、照合するネイバーの group IPv6 プレフィクスと、IPv6 プレフィクスの長さを指定する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match ipv6 multicast group 30:0::0:0/12
switch(config-route-map)#
 

次に、照合するネイバーの group IPv6 プレフィクスと、ランデブー ポイント IPv6 プレフィクスを両方指定する例を示します。

switch(config)# route-map red
switch(config-route-map)# match ipv6 multicast group 30:0::0:0/12 rp 2001:0DB8::/48
switch(config-route-map)#

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ipv6 next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ipv6 route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ属性を設定します。

set ipv6 default next-hop

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ipv6 next-hop

ポリシー ルーティング用のルート マップの match 句を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ipv6 next-hop prefix-list

指定されたアクセス リストの 1 つにより渡されたネクスト ホップ ルータ アドレスを持つ IPv6 ルートを再配布するには、 match ipv6 next-hop prefix-list コマンドを使用します。ネクスト ホップ エントリを削除するには、このコマンドの no 形式を使用します。

match ipv6 next-hop prefix-list name [ ...name ]

no match ipv6 next-hop prefix-list name [ ...name ]

 
構文の説明

name...

プレフィクス リストの名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
デフォルト

ネクスト ホップ アドレスの一致を必要とせず、自由にルートが再配布されます。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 name 引数に複数の値を入力できることを意味します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。


match コマンドがなく、set コマンドだけの許可ルート マップでは、すべてのルートが許可されます。


ルートがルート マップを通過するようにするときには、ルート マップに複数の要素を持たせることができます。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

このコマンドには、ライセンスは必要ありません。

次に、プレフィクス リスト 5 を通過したネクスト ホップ ルータ アドレスを持つルートを配布する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match ipv6 next-hop prefix-list test

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ipv6 next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ属性を設定します。

set ipv6 default next-hop

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ipv6 next-hop

ポリシー ルーティング用のルート マップの match 句を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ipv6 route-source prefix-list

アクセス リストに指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされた IPv6 ルートを再配布するには、ルート マップ コンフィギュレーション モードで、 match ipv6 route-source prefix-list コマンドを使用します。ルート ソース エントリを削除するには、このコマンドの no 形式を使用します。

match ipv6 route-source prefix-list name [ ...name ]

no match ipv6 route-source prefix-list name [ ...name ]

 
構文の説明

name...

プレフィクス リストの名前。最大 63 文字の英数字を使用できます。省略符号は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
デフォルト

ルート ソースに対するフィルタリングは実行されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 name 引数に複数の値を入力できることを意味します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

ルートのネクスト ホップとソース ルータ アドレスが同じではない場合もあります。

このコマンドには、ライセンスは必要ありません。

次に、プレフィクス リスト test で指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを配布する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match ipv6 route-source prefix-list test

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match route-type

指定されたタイプのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match length

レベル 3 パケット長に基づくポリシー ルーティングを実行するには、 match length コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

match length minimum-length maximum-length

no match length minimum-length maximum-length

 
構文の説明

minimum-length

一致として許容されるレベル 3 パケット長の最小値(この値を範囲に含む)。有効な範囲は、0 ~ 2147483647 です。

maximum-length

一致として許容されるレベル 3 パケット長の最大値(この値を範囲に含む)。有効な範囲は、0 ~ 2147483647 です。

 
デフォルト

パケット長に基づくポリシー ルーティングは実行されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

IPv4 でパケットのポリシー ルーティング条件を定義するには、 ip policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、および match set のルート マップ コンフィギュレーション コマンドを使用します。 ip policy route-map コマンドは、名前でルート マップを識別します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドは、 一致基準ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

IPv4 の match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってパケットのルーティングが行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

IPv4 では、パケット長に基づくポリシー ルーティングが可能なため、インタラクティブ トラフィックとバルク トラフィックを異なるルータに送信できます。

このコマンドには、ライセンスは必要ありません。

パケット長を 3 ~ 200 バイトに設定する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match length 3 200

 
関連コマンド

コマンド
説明

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ipv6 address

IPv6 の PBR でパケットの照合に使用する IPv6 アクセス リストを指定します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ipv6 default next-hop

一致パケットが転送されるデフォルトの IPv6 ネクスト ホップを指定します。

set ipv6 next-hop

ポリシー ルーティング用のルート マップの match 句を通過したパケットの送出先を示します。

set ipv6 precedence

IPv6 パケット ヘッダーのプリファレンス値を設定します。

match metric

ルーティング メトリック値と一致するルーティング テーブル内のルートを再配布するには、 match metric コマンドを使用します。タグ エントリを削除するには、このコマンドの no 形式を使用します。

match metric metric-value [ +- deviation-number ] [... metric-value [ +- deviation-number ]]

no match metric metric-value [ +- deviation-number ] [... metric-value [ +- deviation-number ]]

 
構文の説明

metric-value

内部ルート メトリック。範囲は 1 ~ 4294967295 です。

+ -

メトリックの標準偏差範囲を指定します。ルータは、その範囲内に収まるすべてのメトリックを照合します。

deviation-number

(任意) metric-value 引数に対して設定された数値をオフセットする標準偏差値。 deviation-number 引数は任意の数値にできます。デフォルト設定はありません。

 
デフォルト

match の値は定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

5.0(2)

このコマンドが追加されました。

 
使用上のガイドライン

メトリックが指定されたルートを再配布するには、ルート マップ コンフィギュレーション モードで match metric コマンドを使用します。ルーティング テーブルから再配布されたルートに関するエントリを削除するには、このコマンドの no 形式を使用します。

deviation-number 引数を使用して、1 つ以上のメトリックまたはメトリックの範囲を指定できます。指定されたメトリックのうち少なくとも 1 つが一致しなければ、コマンドが「通過」しません。

このコマンド構文内の省略符号(...)は、コマンド入力に複数の引数の値を含めることができることを意味します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

このコマンドには LAN Enterprise ライセンスが必要です。

次に、ルーティング テーブルにメトリック 5 で保存されたルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match metric 5

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match mac-list

MAC リスト内の MAC アドレスと一致するルーティング テーブル内のルートを再配布するには、ルート マップ コンフィギュレーション モードで match mac-list コマンドを使用します。タグ エントリを削除するには、このコマンドの no 形式を使用します。

match mac-list listname

no match mac-list listname

 
構文の説明

listnam

MAC リスト名。name には最大 32 文字の英数字を使用できます。大文字と小文字は区別されます。

 
デフォルト

match の値は定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

5.0(2)

このコマンドが追加されました。

 
使用上のガイドライン

MAC アドレスが指定されたルートをネットワークに再配布するには、ルート マップ コンフィギュレーション モードで match mac-list コマンドを使用します。ルーティング テーブルから再配布されたルートに関するエントリを削除するには、このコマンドの no 形式を使用します。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

このコマンドには LAN Enterprise ライセンスが必要です。

次に、Red MAC リスト内のエントリに一致するルーティング テーブルに保存されているルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match mac-list Red

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match route-type

指定タイプのルートを再配布するには、ルート マップ コンフィギュレーション モードで match route-type コマンドを使用します。ルート タイプ エントリを削除するには、このコマンドの no 形式を使用します。

match route-type { external | internal | level-1 | level-2 | local | nssa-external | type-1 | type-2 }

no match route-type { external | internal | level-1 | level-2 | local | nssa-external | type-1 | type-2 }

 
構文の説明

external

外部ルートを指定します(ボーダー ゲートウェイ プロトコル(BGP)、Enhanced Interior Gateway Routing Protocol(EIGRP)、および Open Shortest Path First(OSPF)タイプ 1/2)。

複数のキーワードを指定できます。

internal

内部ルートを指定します(OSPF エリア内/エリア間)

複数のキーワードを指定できます。

level-1

Intermediate System-to-Intermediate System(IS-IS)レベル 1 ルートを指定します。

複数のキーワードを指定できます。

level-2

IS-IS レベル 2 ルートを指定します。

複数のキーワードを指定できます。

local

ローカル生成ルートを指定します。

複数のキーワードを指定できます。

nssa-external

NSSA 外部ルートを指定します(OSPF タイプ 1/2)。

複数のキーワードを指定できます。

type-1

OSPF 外部タイプ 1 ルートを指定します。

複数のキーワードを指定できます。

type-2

OSPF 外部タイプ 2 ルートを指定します。

複数のキーワードを指定できます。

 
デフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

複数のキーワードを指定できます。

このコマンドには、ライセンスは必要ありません。

次に、内部ルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match route-type internal
 

次に、内部ルートと type-1 OSPF ルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match route-type internal type-1
 

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布するには、 match tag コマンドを使用します。タグ エントリを削除するには、このコマンドの no 形式を使用します。

match tag tag-value [ ...tag-value ]

no match tag tag-value [ ...tag-value ]

 
構文の説明

tag-value

1 つ以上のルート タグ値のリスト。0 ~ 4294967295 の整数を指定できます。最大 32 個のタグを設定できます。

 
デフォルト

match tag の値は定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 tag-value 引数に複数の値を入力できることを示します

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

このコマンドには、ライセンスは必要ありません。

次に、ルーティング テーブルにタグ 5 で保存されたルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match tag 5

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match vlan

指定された VLAN を使用してルートをフィルタするには、 match vlan コマンドを使用します。ルーティング テーブルから再配布されたルートに関するエントリを削除するには、このコマンドの no 形式を使用します。

match vlan vlan-range

no match vlan vlan-range

 
構文の説明

vlan-range

このコマンドで照合される VLAN の範囲。範囲は 1 ~ 4094 です。

 
デフォルト

match vlan の値は定義されません。

 
コマンド モード

ルート マップ コンフィギュレーション(config-route-map)

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

5.0(2)

このコマンドが追加されました。

 
使用上のガイドライン

指定された VLAN を使用してルートをフィルタするには、 match vlan コマンドを使用します。1 つ以上の VLAN または VLAN の範囲を指定できます。コマンドが通過するには、指定された VLAN のうち少なくとも 1 つが一致する必要があります。このコマンドは、範囲内に収まるすべての VLAN を照合します。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、 set コマンドで指定した set 処理 に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

このコマンドには、ライセンスは必要ありません。

この例では、VLAN 5-10 に一致するルートを再配布します。

switch(config)# route-map blueberry
switch(config-route-map)# match vlan 5-10

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ属性を設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

max-metric router-lsa(OSPF)

最大メトリックのアドバタイズによって、他のルータがそのルータを Shortest Path First(SPF; 最短パス優先)計算の中間ホップとして優先的に使用しないように Open Shortest Path First(OSPF)プロトコルを設定するには、 max-metric router-lsa コマンドを使用します。最大メトリックのアドバタイズをディセーブルにするには、このコマンドの no 形式を使用します。

max-metric router-lsa [external-lsa [max-metric-value]] [include-stub]] [ on-startup [seconds | wait-for bgp tag ]] [summary-lsa [max-metric-value]]

no max-metric router-lsa [external-lsa [max-metric-value]] [include-stub]] [ on-startup [seconds | wait-for bgp tag ]] [summary-lsa [max-metric-value]]]

external-lsa

外部 LSA を指定します。

max-metric-value

(任意)外部 LSA の最大メトリック値を指定します。範囲は 1 ~ 65535 です。

inlcude-stub

スタブ リンクの最大メトリックをアドバタイズします。

on-startup

(任意)起動時にルータが最大メトリックをアドバタイズするように設定します。

seconds

(任意)指定の時間間隔でアドバタイズされる最大メトリック(秒)。設定範囲は 5 ~ 86400 秒です。デフォルト値は 600 秒です。

wait-for bgp tag

ボーダー ゲートウェイ プロトコル(BGP)ルーティング テーブルがコンバージするまで、またはデフォルト タイマーが切れるまで、最大メトリックをアドバタイズします。デフォルト タイマーは 600 秒です。

summary-lsa

サマリー LSA を指定します。

max-metric-value

(任意)サマリー LSA の最大メトリック値を指定します。範囲は 1 ~ 65535 です。

 
デフォルト

通常のリンク メトリックでルータの Link-State Advertisement(LSA; リンクステート アドバタイズメント)を開始します。

 
コマンド モード

ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

max-metric router-lsa コマンドは、非スタブ リンクを通して、最大メトリック(LSInfinity: 0xFFFF)の LSA を開始するために使用します。これによって、通過トラフィックを引き込むことなく、BGP ルーティング テーブルのコンバージが可能になります(より安価なルータへの代替パスがない場合)。設定されたタイマーまたはデフォルト タイマーの満了後、あるいは BGB によってルーティング テーブルのコンバージェンス終了が通知された後は、ルータは正確な(通常の)メトリックをアドバタイズします。


) スタブ リンクのコストは常に出力インターフェイス コストに設定されているので、最大または無限のメトリックを設定しても、スタブ ネットワーク内の直接接続リンクには影響しません。


max-metric router-lsa コマンドは次の場合に使用できます。

ルータのリロード時。ルータのリロード後、Interioir Gateway Protocol(IGP)はすぐにコンバージするので、他のルータは新しくリロードされたルータを通じてトラフィックを転送しようとする可能性があります。そのルータがまだ BGP ルーティング テーブルを確立中の場合、そのルータが BGP を通じて学習していない他のネットワークを宛先とするパケットはドロップされます。

ルータをネットワークに導入するが、そのルータがトラフィックを中継しないようにする場合。OSPF ネットワークにルータを接続したいが、他にも良い代替パスがある場合は、そのルータを通じて実際のトラフィックを転送したくない場合もあります。代替パスがない場合は、このルータがトラフィックの中継を受け入れます。

ネットワークからルータを正常に取り外す場合。この機能を使用して、すべてのリンクに最大メトリックをアドバタイズすると、ルータのシャットダウン前に他のルータはトラフィック伝送に代替パスを選択できるようになるため、ルータを正常終了させて取り外すことができます。


) ルータにグレースフル シャットダウンが設定されている場合は実行コンフィギュレーションを保存しないでください。保存すると、リロード後にもルータは最大メトリックのアドバタイズを続行します。


このコマンドには、Enterprise Services ライセンスが必要です。

次に、100 秒の最大メトリックをアドバタイズするように OSPF 実行ルータを設定する例を示します。

switch(config)# router ospf 100
switch(config-router)# max-metric router-lsa on-startup 100
 

次に、BGP ルーティング テーブルがコンバージするまで、またはデフォルト タイマーが満了する(600 秒)まで、最大メトリックをアドバタイズするようにルータを設定する例を示します。

switch(config)# router ospf 100
switch(config-router)# max-metric router-lsa on-startup wait-for bgp bgpTag
 

 
関連コマンド

コマンド
説明

show ip ospf

OSPF ルーティング プロセスに関する一般的な情報を表示します。

max-lsp-lifetime

Link-State Packet(LSP; リンクステート パケット)がリフレッシュされずに維持される最大時間を設定するには、 max-lsp-lifetime コマンドを使用します。デフォルトの時間に戻すには、このコマンドの no 形式を使用します。

max-lsp-lifetime value

no max-lsp-lifetime

 
構文の説明

value

(任意)最大 LSP ライフタイム(秒単位)。範囲:1 ~ 65535。デフォルトは 1200 です。

 
デフォルト

デフォルトは 1200 秒です。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

LSP の最大ライフタイムは、LSP のリフレッシュ間隔よりも大きな値にする必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

 
コマンド デフォルト

次に、LSP が維持する最長時間を 11,000 秒(3 時間以上)に設定する例を示します。

switch(config)# router isis

switch(config-router)# max-lsp-lifetime 11000

 
関連コマンド

コマンド
説明

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータ上の IS-IS をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

maxas-limit

AS-path 属性内の AS 番号が大きいルートを破棄するように external Border Gateway Protocol(eBGP)を設定するには、 maxas-limit コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

maxas-limit [ number ]

no maxas-limit

 
構文の説明

number

(任意)AS-path 属性内で許可された AS 番号の最大値。範囲は 1 ~ 2000 です。

 
デフォルト

制限なし

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.1(2)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

 
コマンド デフォルト

次に、AS 番号の最大数を 50 に設定する例を示します。

switch(config)# router bgp 64496

switch(config-router)# maxas-limit 50

 
関連コマンド

コマンド
説明

feature bgp

BGP 機能をイネーブルにします。

router bgp

BGP インスタンスを作成します。

maximum-paths(BGP)

ボーダー ゲートウェイ プロトコル(BGP)がサポートするパラレル ルートの最大数を制御するには、 maximum-paths コマンドを使用します。デフォルトのパラレル ルート数に戻すには、このコマンドの no 形式を使用します。

maximum-paths [ ibgp ] number-paths

no maximum-paths [ ibgp ] number-paths

 
構文の説明

ibgp

interior BGP(iBGP)パスの最大数を設定します。

number-paths

IP ルーティング プロトコルがルーティング テーブルにインストールするパラレル ルートの最大数。範囲は 1 ~ 8 です。

 
デフォルト

1 パス

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには使用上のガイドラインはありません。

次に、BGP ルーティング プロセスで、1 つの宛先に最大 16 のパスを許可する例を示します。

switch(config)# router bgp 64496
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# maximum-paths 16

 
関連コマンド

コマンド
説明

feature bgp

ルータの BGP 機能をイネーブルにします。

router bgp

BGP をイネーブルにします。

 

maximum-paths(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)がサポートするパラレル ルータの最大数を制御するには、 maximum-paths コマンドを使用します。コンフィギュレーション ファイルから maximum-paths コマンドを削除し、デフォルトに戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum- paths

 
構文の説明

maximum

EIGRP がルーティング テーブル内にインストールできるパラレル ルートの最大数。範囲は 1 ~ 16 ルートです。

 
デフォルト

8 パス

 
コマンド モード

アドレスファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

4.0(2)

デフォルトの最大パスが 16 から 8 に変更されました。

 
使用上のガイドライン

EIGRP がルーティング テーブルに各プレフィクスに対して複数のパスをインストールできるようにするには、 maximum-paths コマンドを使用します。内部ルートと外部ルートの両方について、同じ自律システムで学習され、等コスト(EIGRP 最適パス アルゴリズムに基づいて)である複数のパスがインストールされます。

このコマンドには、Enterprise Services ライセンスが必要です。

次の例では、1 つの宛先に最大 10 のパスが許可されます。

switch(config)# router eigrp 1
switch(config-router)# maximum-paths 10

maximum-paths(IS-IS)

IP ルーティング プロトコルがサポートするパラレル ルートの最大数を制御するには、 maximum-paths コンフィギュレーション モード コマンドを使用します。デフォルトのパラレル ルート数に戻すには、このコマンドの no 形式を使用します。

maximum-paths number-paths

no maximum-paths

 
構文の説明

number-paths

IP ルーティング プロトコルがルーティング テーブルにインストールするパラレル ルートの最大数。範囲は 1 ~ 16 です。

 
デフォルト

8 パス

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには使用上のガイドラインはありません。

次に、IS-IS ルーティング プロセスで、1 つの宛先に最大 16 のパスを許可する例を示します。

switch(config)# router isis 3
switch(config-router)# maximum-paths 16

 
関連コマンド

コマンド
説明

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータ上の IS-IS をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

maximum-paths(RIP)

Routing Information Protocol(RIP)がルーティング テーブルにインストールする等価コスト パラレル ルートの最大数を設定するには、 maximum-paths コマンドを使用します。 maximum-paths コマンドを削除し、RIP に関してシステムをデフォルトの条件に戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum-paths

 
構文の説明

maximum

RP がルーティング テーブル内にインストールできるパラレル ルートの最大数。範囲は 1 ~ 16 です。

 
デフォルト

8 パス

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、1 つの宛先に最大 16 の等価コスト パスを許可する例を示します。

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# maximum-paths 16
 

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ コンフィギュレーション モードに入ります。

maximum-paths(OSPF)

Open Shortest Path First(OSPF)がサポートするパラレル ルートの最大数を制御するには、 maximum-paths コマンドを使用します。コンフィギュレーション ファイルから maximum-paths コマンドを削除し、デフォルトに戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum- paths

 
構文の説明

maximum

OSPF がルーティング テーブル内にインストールできるパラレル ルートの最大数。範囲は 1 ~ 16 ルートです。

 
デフォルト

8 パス

 
コマンド モード

ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

OSPF がルーティング テーブルに各プレフィクスに対して複数のパスをインストールできるようにするには、 maximum-paths コマンドを使用します。内部ルートと外部ルートの両方について、同じ自律システムで学習され、等コスト(OSPF 最短パス優先アルゴリズムに基づいて)である複数のパスがインストールされます。

このコマンドには、Enterprise Services ライセンスが必要です。

次の例では、1 つの宛先に最大 10 のパスが許可されます。

switch(config)# router ospf 1
switch(config-router)# maximum-paths 10

maximum-paths(OSPFv3)

Open Shortest Path First version 3(OSPFv3)がサポートするパラレル ルートの最大数を制御するには、 maximum-paths コマンドを使用します。コンフィギュレーション ファイルから maximum-paths コマンドを削除し、デフォルトに戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum- paths

 
構文の説明

maximum

OSPFv3 がルーティング テーブル内にインストールできるパラレル ルートの最大数。範囲は 1 ~ 16 ルートです。

 
デフォルト

8 パス

 
コマンド モード

アドレスファミリ コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

OSPFv3 がルーティング テーブルに各プレフィクスに対して複数のパスをインストールできるようにするには、 maximum-paths コマンドを使用します。内部ルートと外部ルートの両方について、同じ自律システムで学習され、等コスト(OSPFv3 最短パス優先アルゴリズムに基づいて)である複数のパスがインストールされます。

このコマンドには、Enterprise Services ライセンスが必要です。

次の例では、1 つの宛先に最大 10 のパスが許可されます。

switch(config)# router ospfv3 1
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# maximum-paths 10

maximum-prefix

ネイバーから受信可能なプレフィクスの数を設定するには、 maximum-prefix コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

maximum-prefix maximum [ threshold ] [ restart restart-interval ] [ warning-only ]

no maximum-prefix

 
構文の説明

maximum

指定ネイバーから受信できるプレフィクスの最大数。設定可能なプレフィクス数は、ルータ上の使用可能なシステム リソースのみによって制限されます。範囲は 1 ~ 300000 です。

threshold

(任意)ルータが警告メッセージの生成を開始する最大プレフィクス数の制限値に対するパーセンテージを指定します。範囲は 1 ~ 100 です。デフォルトは 75 です。

restart interval

(任意)ピアリング セッションが再確立される時間間隔(分)。範囲:1 ~ 65535。

warning-only

(任意)最大プレフィクス数の制限値を超えた場合、ピアリング セッションを終了せずに、ルータが syslog メッセージを生成できるようにします。

 
デフォルト

このコマンドは、デフォルトではディセーブルです。最大プレフィクス数を超えると、ピアリング セッションはディセーブルになります。再起動間隔(restart interval)を設定しないと、最大プレフィクス数の制限値超過後、ディセーブルになったセッションはダウン状態のままになります。

 
コマンド モード

Peer template configuration
ルータ BGP コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

設定可能なプレフィクス数は、ルータ上の使用可能なシステム リソースのみによって制限されます。

maximum-prefix コマンドを使用すると、ボーダー ゲートウェイ プロトコル(BGP)ルーティング プロセスが指定ピアから受け入れるプレフィクスの最大数を設定できます。この機能は、ピアから受信されるプレフィクスの制御メカニズムを提供します(配布リスト、フィルタ リスト、ルート マップに加えて)。

受信プレフィクスの数が設定されている最大数を超えると、BGP はピアリング セッションをディセーブルにします(デフォルト)。 restart キーワードが設定されている場合、BGP は設定されている時間間隔でピアリング セッションを自動的に再確立します。 restart キーワードが設定されていないと、最大プレフィクス数の制限値を超えたためにピアリング セッションが終了した場合、そのピアリング セッションは clear ip bgp コマンドが入力されるまで再確立されません。 warning-only キーワードが設定されていれば、BGP はログ メッセージだけを送信し、送信側とピアを保ちます。

このコマンドで設定できるプレフィクス数には、デフォルトの制限値はありません。設定可能なプレフィクス数の制限は、システム リソースの容量によって決まります。

この例では、192.168.1.1 ネイバーから受け入れられる最大プレフィクス数が 1000 に設定されます。

switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 1000
 

次に、192.168.2.2 ネイバーから受け入れられる最大プレフィクス数が 5000 に設定される例を示します。ルータは、最大プレフィクス リミット(2500 プレフィクス)の 50% に到達した段階で警告メッセージを表示するようにも設定されます。

switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 5000 50

 

次に、192.168.3.3 ネイバーから受け入れられる最大プレフィクス数が 2000 に設定される例を示します。ルータは、30 分後にディセーブルにされたピアリング セッションを再確立するようにも設定されます。

switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 2000 restart 30
 

次に、192.168.4.4 ネイバーの最大プレフィクス数の制限値(500)を超えると表示される警告メッセージの例を示します。

switch(config)# router bgp 64496
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 500 warning-only
 

message-digest-key(OSPF 仮想リンク)

仮想リンクの Open Shortest Path First(OSPF)Message Digest 5(MD5)認証をイネーブルにするには、 message-digest-key コマンドを使用します。古い MD5 キーを削除するには、このコマンドの no 形式を使用します。

message-digest-key key-id md5 [ 0 | 3 ] key

no message-digest-key key-id

 
構文の説明

key-id

1 ~ 255 の範囲の識別子

0

MD5 キーを生成するための非暗号化パスワードの使用を指定します。

3

MD5 キーを生成するための暗号化 3DES パスワードの使用を指定します。

key

最大 16 バイトの英数字のパスワード。

 
デフォルト

非暗号化

 
コマンド モード

仮想リンク コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

MD5 認証モードを設定する場合は message-digest-key コマンドを使用します。仮想リンク上の両方のインターフェイスで key 値を同じにする必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、キー 19 をパスワード 8ry4222 で設定する例を示します。

switch(config-router)# area 22 virtual-link 192.0.2.2
switch(config-router-vlink)# message-digest-key 19 md5 8ry4222

 
関連コマンド

コマンド
説明

authentication(仮想リンク)

仮想リンク上に認証モードを設定します。

metric maximum-hops

指定した値よりも高いホップ カウントの Enhanced Interior Gateway Routing Protocol(EIGRP)が到達不能であることをアドバタイズするには、 metric maximum-hops コマンドを使用します。値を デフォルトにリセットするには、このコマンドの no 形式を使用します。

metric maximum-hops hops-number

no metric maximum-hops

 
構文の説明

hops-number

最大ホップ カウント。有効な範囲は 1 ~ 255 ホップです。

 
デフォルト

hops-number : 100

 
コマンド モード

アドレスファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

metric maximum-hops コマンドは、 hops-number 引数に指定された値よりも大きいホップ カウントのルートを到達不能として EIGRP にアドバタイズさせる安全メカニズムを提供します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、ホップ カウントを 200 に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# metric maximum-hops 200

 
関連コマンド

コマンド
説明

metric weights

EIGRP メトリック計算を調整します。

metric rib-scale

Enhanced Interior Gateway Routing Protocol(EIGRP)のデフォルト メトリックを設定するには、metric rib-scale コマンドを使用します。デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

metric rib-scale scale-value

no metric rib-scale scale-value

 
構文の説明

scale-value

EIGRP ワイド メトリックを変換することによって 4 バイト RIB メトリックに分割するためのスケール値。有効な範囲は 1 ~ 256 です。

 
デフォルト

128

 
コマンド モード

ルータ eigrp サブモード

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

5.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

rib スケール値を設定または変更できるのは、64 ビット メトリック モードの場合のみです。

このコマンドには、ライセンスは必要ありません。

次に、EIGRP の rib スケール係数を設定する例を示します。

switch# configure terminal
switch(config)# router eigrp csco123
switch(config-router)# metric rib-scale 130
switch(config-router)#
 

次に、EIGRP の rib スケール係数を削除し、デフォルトの状態に戻す例を示します。

switch(config)# router eigrp csco123
switch(config-router)# no metric rib-scale 130
switch(config-router)#

 
関連コマンド

コマンド
説明

metric version

メトリック バージョンを 64 ビット モードに変更します。

metric weights

Enhanced Interior Gateway Routing Protocol(EIGRP)メトリック計算を調整します。

metric weights

Enhanced Interior Gateway Routing Protocol(EIGRP)メトリック計算を調整するには、 metric weightsコマンドを使用します。デフォルト値にリセットするには、このコマンドの no 形式を使用します。

metric weights tos k1 k2 k3 k4 k5 k6

no metric weights

 
構文の説明

tos

常にゼロにする必要のある Type of service(ToS; タイプ オブ サービス)

k1 k2 k3 k4 k5 k6

EIGRP メトリック ベクトルをスカラー量に変換する定数。引数は次のとおりです。

k1:範囲は 0 ~ 255 です。デフォルトは 1 です。

k2:範囲は 0 ~ 255 です。デフォルトは 0 です。

k3:範囲は 1 ~ 255 です。デフォルトは 1 です。

k4:範囲は 0 ~ 255 です。デフォルトは 0 です。

k5:範囲は 0 ~ 255 です。デフォルトは 0 です。

k6:範囲は 0 ~ 255 です。デフォルトは 0 です。

 
デフォルト

tos: 0

k1: 1

k2: 0

k3: 1

k4: 0

k5: 0

k:6 0

 
コマンド モード

アドレスファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

5.2(1)

k6 キーワードが追加されました。

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

EIGRP のルーティングおよびメトリック計算のデフォルト動作を変更し、特定の ToS の EIGRP メトリック計算の調整を可能にするには、 metric weights コマンドを使用します。

k5 が 0 の場合、Cisco NX-OS は複合 EIGRP メトリックの計算を次の式に従って行います。

メトリック = [k1 × 帯域幅 +(k2 × 帯域幅)/(256 - 負荷)+ k3 × 遅延]

k5 が 0 でない場合、Cisco NX-OS は次の計算を追加します。

メトリック = メトリック × [k5/(信頼性 + k4)]

帯域幅メトリックの設定には、インターフェイス コンフィギュレーション モードで bandwidth コマンドを使用します。

遅延の設定には、インターフェイス コンフィギュレーション モードで delay コマンドを使用します。

255 は 100 %の信頼性または完全に安定したリンクを表します。負荷 255 は、完全に飽和状態のリンクを表します。

k6 の設定は、64 ビット メトリック バージョン モードでのみサポートされます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、metric weights のデフォルト値の変更例を示します。

switch# configure terminal
switch(config)# router eigrp 1
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# metric weights 0 2 0 2 0 2

 
関連コマンド

コマンド
説明

bandwidth

インターフェイス コンフィギュレーション モードで EIGRP 帯域幅メトリックを設定します。

delay

インターフェイス コンフィギュレーション モードで EIGRP 遅延メトリックを設定します。

metric-style transition

アドバタイズされた LSP 内で IS-IS によって使用されるメトリック スタイルを設定するには、 metric-style transition コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

metric-style transition

no metric-style transition

 
構文の説明

このコマンドには、キーワードと引数はありません。

 
デフォルト

ワイド メトリック スタイル

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

4.1(2)

このコマンドが追加されました。

 
使用上のガイドライン

metric-style transition コマンドは、ナロー メトリック スタイルとワイド メトリック スタイルの両方の Type Length Value(TLV)オブジェクトを生成して受け入れるように IS-IS を設定するために使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、メトリック スタイルを設定する例を示します。

switch(config-router)# metric-style transition
switch(config-router)#

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS インスタンスを作成します。

 

metric version

スイッチを 64 ビット メトリック バージョンで動作するように設定するには、metric version コマンドを使用します。デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

metric version 64bit

no metric version 64bit

 
構文の説明

64-bit

64 ビット メトリック バージョン。

 
デフォルト

32 ビット モード

 
コマンド モード

ルータ eigrp サブモード
VRF サブモード

 
サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更箇所

5.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、ライセンスは必要ありません。

次に、 スイッチを 64 ビット メトリック バージョンで動作するように設定する 例を示します。

switch# configure terminal
switch(config)# router eigrp csco123
switch(config-router)# metric version 64bits
switch(config-router)#
 

次に、スイッチから 64 ビット メトリック バージョン 設定を削除する例を示します。

switch(config-router)# no metric version 64bits
switch(config-router)#

 
関連コマンド

コマンド
説明

metric rib-scale

Enhanced Interior Gateway Routing Protocol(EIGRP)のデフォルト メトリックを設定します

metric weights

Enhanced Interior Gateway Routing Protocol(EIGRP)メトリック計算を調整します。