Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス リリース 5.x
S コマンド
S コマンド
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

S コマンド

set as-path

set comm-list delete

set community

set dampening

set etxcommunity

set extcomm-list delete

set forwarding-address

set ip default next-hop

set ip next-hop

set ipv6 default next-hop

set ipv6 next-hop

set level

set local-preference

set metric

set metric-type

set origin

set tag

set vrf

set weight

set-attached-bit

set-overload-bit

shutdown (BGP)

shutdown (EIGRP)

shutdown (IS-IS)

shutdown (OSPF)

shutdown (OSPFv3)

shutdown (VRRP)

spf-interval

stub

summary-address

summary-address (OSPF)

summary-address (OSPFv3)

suppress-inactive

S コマンド

この章では、 show コマンド以外の S で始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

set as-path

BGP ルータの Autonomous System(AS; 自律システム)パス(as-path)を変更するには、ルートマップ コンフィギュレーション モードで set as-path コマンドを使用します。AS パスを変更しないようにするには、このコマンドの no 形式を使用します。

set as-path { tag | { prepend as-num [ ... as-num ] | last-as num }}

no as-path { tag | { prepend as-num [.. . as-num ] | last-as num }}

 
シンタックスの説明

tag

ルートのタグを AS パスに変換します。BGP にルートを再配布するときのみ適用されます。

prepend as-num

指定された AS 番号を、ルート マップと一致するルートの AS パスに付加します。インバウンドおよびアウトバウンド BGP ルート マップ両方に適用します。範囲は 1 ~ 65535 です。1 つ以上の AS 番号を設定できます。

last-as num

最後の AS 番号を as-path に付加します。範囲は 1 ~ 10 です。

 
デフォルト

AS パスは変更されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

route-map コマンドをイネーブルにする前に PBR をイネーブルにするには、 feature pbr グローバル コンフィギュレーション モード コマンドを入力する必要があります。

ルートマップ コンフィギュレーション モードを開始するには、 route-map コマンドを使用します。 route-map コマンドを入力すると、プロンプトが次のように変わります。

switch(config-route-map)#
 

ルートマップ コンフィギュレーション モードを開始すると、 set コマンドを入力できます。

最適なパス選択に影響を与える唯一のグローバル BGP メトリックは、AS パス長です。AS パスの長さを変えることで、BGP スピーカーは遠くのピアによる最適なパス選択に影響を与えます。

タグを AS パスに変換することで、このコマンドの set as-path tag が変わり AS 長を変更できます。 set as-path prepend のバリエーションを使用すれば、任意の自律システム パス文字列を BGP ルートに「付加」できます。通常、ローカルな AS 番号は複数回追加され、AS パス長が増します。

次に、再配布されたルートのタグを AS パスに変換する例を示します。

switch(config)# route-map test1
switch(config-route-map)# set as-path tag
 

次に、10.108.1.1 にアドバタイズされたすべてのルートに 100 を追加する例を示します。

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set as-path prepend 100
!
 
switch(config)# router bgp 64496
switch(config-router)# neighbor 10.108.1.1 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# route-map set-as-path test1 out

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set comm-list delete

インバウンドまたはアウトバウンド アップデートのコミュニティ アトリビュートからコミュニティを削除するには、ルートマップ コンフィギュレーション モードで set comm-list delete コマンドを使用します。以前の set comm-list delete コマンドを削除するには、このコマンドの no 形式を使用します。

set comm-list community-list-name delete

no set comm-list

 
シンタックスの説明

community-list-name

標準または拡張コミュニティ リスト名。名前は 63 文字以下の任意の英数字文字列です。

 
コマンドのデフォルト

コミュニティは削除されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

この set route-map コンフィギュレーション コマンドの場合、削除するコミュニティをフィルタリングおよび決定するルート マップを使用して、インバウンドまたはアウトバウンド アップデートのコミュニティ アトリビュートからコミュニティを削除します。ルート マップがネイバーのインバウンドまたはアウトバウンド アップデートに適用されたかどうかによって、ルート マップ permit 句を通過し、特定のコミュニティ リストを照合する各コミュニティは、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ネイバーの間で送受信されるコミュニティ アトリビュートから削除されます。

標準コミュニティ リストの各エントリは、 set comm-list delete コマンドで使用した場合に、1 つのコミュニティのみを表示します。たとえば、コミュニティ 10:10 と 10:20 を削除できるようにするには、次の形式を使用してエントリを作成する必要があります。

switch(config)# ip community-list 500 permit 10:10
switch(config)# ip community-list 500 permit 10:20
 

コミュニティ リスト エントリの次の形式では、 set comm-list delete コマンドは実行されません。別の方法を実行してください。

switch(config)# ip community-list 500 permit 10:10 10:20
 

set community community-number コマンドと set comm-lis t delete コマンド両方がルート マップ アトリビュートの同じシーケンスに設定されている場合、削除操作( set comm-list delete )は設定操作( set community community-number )の前に実行されます。

このコマンドにはライセンスは必要ありません。

次に、インバウンドまたはアウトバウンド アップデートのコミュニティ アトリビュートからコミュニティを削除する例を示します。

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set comm-list list1 delete
 

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set community

BGP コミュニティ アトリビュートを設定するには、 set community ルートマップ コンフィギュレーション コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set community { none | { aa : nn [... aa:nn ] | additive | local-as | no-advertise | no-export }}

no set community { none | { aa : nn | additive | local-as | no-advertise | no-export }}

 
シンタックスの説明

aa : nn

(任意)4 バイトの新しいコミュニティ形式で入力された Autonomous System(AS; 自律システム)番号およびネットワーク番号。この値は、コロンで区切られた 2 バイトの数 2 つで設定されます。2 バイトの数ごとに 1 ~ 65535 の数を入力できます。1 つのコミュニティ、または複数のコミュニティをそれぞれスペースで区切って入力できます。

1 つまたは複数の AS 番号を設定できます。

1 つまたは複数のキーワードを設定できます。

additive

(任意)既存のコミュニティに追加します。

1 つまたは複数のキーワードを設定できます。

local-AS

(任意)local-as コミュニティを指定します(well-known コミュニティ)。コミュニティのあるルートは、ローカル AS の一部であるピアへのみ、または連合のサブ AS 内のピアへのみアドバタイズされます。これらのルートは、外部ピア、または連合内の別のサブ AS にアドバタイズされません。

1 つまたは複数のキーワードを設定できます。

no-advertise

(任意)no-advertise コミュニティを指定します(well-known コミュニティ)。このコミュニティのあるルートはピア(内部または外部)にはアドバタイズされません。

1 つまたは複数のキーワードを設定できます。

no-export

(任意)no-export コミュニティを指定します(well-known コミュニティ)。このコミュニティのあるルートは、同じ AS 内のピアへのみ、または連合内の他のサブ AS へのみアドバタイズされます。これらのルートは外部ピアにはアドバタイズされません。

1 つまたは複数のキーワードを設定できます。

none

(任意)コミュニティ アトリビュートは指定しません。

none キーワードを設定している場合、他のキーワードは設定できません。

 
コマンドのデフォルト

BGP コミュニティ アトリビュートは存在しません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

タグを設定する場合は、match 句を使用する必要があります(「permit everything」リストを指している場合でも)。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドを使用すると、ルート マップのすべての一致基準を満たした場合に実行する再配布 set 処理 を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

このコマンドにはライセンスは必要ありません。

次の例では、自律システム パス アクセス リスト 1 を通過するルートのコミュニティが 109:02 と 33:40 に設定されます。自律システム パス アクセス リスト 2 を通過するルートのコミュニティは、no-export(これらのルートがどの eBGP ピアにもアドバタイズされない)に設定されます。

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set community 109:02 33:40
switch(config-route-map)# exit
switch(config)# route-map test1 20 permit
switch(config-route-map)# match as-path 2
switch(config-route-map)# set community no-export
 

次の同様の例では、自律システム パス アクセス リスト 1 を通過するルートのコミュニティが 109:30 に設定されます。自律システム パス アクセス リスト 2 を通過するルートのコミュニティは、local-as(ルータが ローカル自律システムの外部のピアにこのルートをアドバタイズしない )に設定されます。

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set community 109:30 additive
switch(config-route-map)# exit
switch(config)# route-map test1 20 permit
switch(config-route-map)# match as-path 2
switch(config-route-map)# set community local-as

 
関連コマンド

コマンド
説明

ip community-list

BGP 用のコミュニティ リストを作成し、このリストへのコントロール アクセスを作成します。

match community

BGP コミュニティを照合します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set comm-list delete

インバウンドまたはアウトバウンド アップデートのコミュニティ アトリビュートからコミュニティを削除します。

show ip bgp community

指定された BGP コミュニティに属するルートを示します。

set dampening

BGP ルート ダンプニング係数を設定するには、 set dampening ルートマップ コンフィギュレーション コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

set dampening half-life reuse suppress max-suppress-time

no set dampening

 
シンタックスの説明

half-life

ペナルティが小さくなるまでの時間(分単位)。ルートにペナルティが割り当てられると、ペナルティは半減期で半分まで小さくなります(デフォルトでは 15 分です)。ペナルティを小さくするプロセスは 5 秒ごとに発生します。範囲は 1 ~ 45 です。デフォルトは 15 です。

reuse

フラッピング ルートがこの値を下回るまで減少すると、ルートの抑制を中止します。ルートの抑制中止プロセスは、10 秒経過ごとに発生します。範囲は 1 ~ 20000 です。デフォルトは 750 です。

suppress

ペナルティがこの限度を超えると、ルートを抑制します。範囲は 1 ~ 20000 です。デフォルトは 2000 です。

max-suppress-time

ルートを抑制できる最大時間(分単位)。範囲は 1 ~ 255 です。デフォルトは、 half-life の値の 4 倍です。 half-life の値がデフォルトに設定されている場合、最大抑制時間はデフォルトの 60 分になります。

 
コマンドのデフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

BGP ピアがリセットされた場合、ルートは廃止され、フラップ統計情報は消去されます。この場合、ルート フラップ ダンプニングがイネーブルの場合でも、withdrawal(取り消し)によるペナルティが生じません。

このコマンドにはライセンスは必要ありません。

次に、半減期を 30 分に、再使用値を 1500 に、抑制値を 10000 に、最大抑制時間を 120 分に設定する例を示します。

switch(config)# route-map test1 10 permit
switch(config-route-map)# set dampening 30 1500 10000 120

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set etxcommunity

BGP 拡張コミュニティ アトリビュートを設定するには、 set extcommunity コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set extcommunity { none | { generic { transitive | nontransitive } aa4 : nn [... aa4:nn ] } | additive }

no set extcommunity { none | { generic { transitive | nontransitive } aa4 : nn [... aa4:nn ] } | additive }

 
シンタックスの説明

none

(任意)コミュニティ アトリビュートは指定しません。

generic

汎用特定拡張コミュニティ タイプを指定します。

transitive

拡張コミュニティ アトリビュートを他の自律システムに伝搬するように BGP を設定します。

nontransitive

拡張コミュニティ アトリビュートを他の自律システムに伝搬するように BGP を設定します。

aa4 : nn

(任意)自律システム番号とネットワーク番号。この値は、コロンで区切られた 4 バイトの AS 番号と 2 バイトのネットワーク番号を使用して設定されます。4 バイトの AS 番号の範囲は 1 ~ 4294967295(プレーンテキスト表記)または 1.0 ~ 56636.65535(AS.dot 表記)です。単一のコミュニティまたはスペースで区切られた複数のコミュニティを入力できます。

additive

(任意)既存のコミュニティに追加します。

 
コマンドのデフォルト

BGP コミュニティ アトリビュートは存在しません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

set extcommunity コマンドは、ルート マップ内で BGP ルート内の拡張コミュニティ アトリビュートを設定するために使用します。

set コマンドを使用する場合は、ルート マップ内に match 節を入力する必要があります(「permit everything」リストを指している場合でも)。

set コマンドは、ルート マップのすべての一致基準が満された場合に実行される set 処理 を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

このコマンドにはライセンスは必要ありません。

次に、拡張コミュニティが 1.5 に設定されるルート マップを設定する例を示します。

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set extcommunity generic transitive 1.5
switch(config-route-map)# exit

 
関連コマンド

コマンド
説明

ip extcommunity-list

BGP のコミュニティ リストを作成し、アクセスを制御します。

route-map

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義します。

send-community

コミュニティ アトリビュートを BGP ピアに伝搬するように BGP を設定します。

match extcommunity

ルート マップ内の拡張コミュニティを照合します。

ip extcommunity-list

BGP のコミュニティ リストを作成し、アクセスを制御します。

set extcomm-list delete

インバウンドまたはアウトバウンド BGP アップデートの拡張コミュニティ アトリビュートから拡張コミュニティを削除するには、 set extcomm-list delete コマンドを使用します。以前の set comm-list delete コマンドを削除するには、このコマンドの no 形式を使用します。

set extcomm-list community-list-name delete

no set extcomm-list

 
シンタックスの説明

community-list-name

標準または詳細拡張コミュニティ リスト名。名前は 63 文字以下の任意の英数字文字列です。

 
コマンドのデフォルト

コミュニティは削除されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

set extcomm-list コマンドは、ルート マップ内で BGP ルート内の拡張コミュニティ アトリビュートを削除するために使用します。

set コマンドを使用する場合は、ルート マップ内に match 節を入力する必要があります(「permit everything」リストを指している場合でも)。

set コマンドは、ルート マップのすべての一致基準が満された場合に実行される set 処理 を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

set extcommunity community-number コマンドと set ext comm-lis t delete コマンドの両方をルート マップ アトリビュートの同じシーケンスで設定した場合は、set 処理( set extcommunity community-number )の前に deletion 処理( set extcomm-list delete )が実行されます。

このコマンドにはライセンスは必要ありません。

次に、インバウンドまたはアウトバウンド アップデートの拡張コミュニティ アトリビュートから拡張コミュニティを削除する例を示します。

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set extcomm-list list1 delete
 

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match extcommunity

BGP 拡張コミュニティを照合します。

set extcommunity

BGP 拡張コミュニティ アトリビュートを設定します。

set forwarding-address

再配布されたタイプ 5 LSA に OSPF 転送アドレスを設定するには、 set forwarding-address ルートマップ コンフィギュレーション モード コマンドを使用します。アドレスを削除するには、このコマンドの no 形式を使用します。

set forwarding-address

no forwarding-address

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト

転送アドレスはデフォルトとして設定されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドは、再配布されたタイプ 5 LSA に転送アドレスを設定する OSPF によって使用されます。Autonomous System(AS; 自律システム)によって指定された転送アドレスの値は 0.0.0.0 またはゼロ以外です。0.0.0.0 アドレスは、ネクストホップの発信ルータ(ASBR)を示します。転送アドレスは次の条件によって決定されます。

ASBR がルートを再配布し、OSPF がこれらのルートのネクストホップ インターフェイスでイネーブルでない場合、転送アドレスは 0.0.0.0 に設定されます。ルータ 1 では OSPF がイーサネット インターフェイスでイネーブルではない場合、この数字が当てはまります。

forwarding address フィールドをゼロ以外のアドレスに設定するには、次のすべての条件を満たす必要があります。

OSPF は、ASBR のネクストホップ インターフェイスでイネーブルです。

ASBR のネクストホップ インターフェイスは、OSPF では非パッシブです。

ASBR のネクストホップ インターフェイスは point-to-point(p2p; ポイントツーポイント)ではありません。

ASBR のネクストホップ インターフェイスは point-to-multipoint(p2mp; ポイントツーマルチポイント)ではありません。

上記の条件以外に、転送アドレスを 0.0.0.0 に設定する必要があります。

このコマンドにはライセンスは必要ありません。

次に、転送アドレスを設定する例を示します。

switch(config)# route-map test1 10 permit
switch(config-route-map)# set forwarding-address

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set ip default next-hop

ポリシー ルーティングのルート マップの match 句を満たしたパケットのうち、Cisco NX-OS ソフトウェアが宛先に対する明示ルートを持っていないパケットの出力先を指定するには、ルートマップ コンフィギュレーション モードで set ip default next-hop コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set ip default next-hop ip-address [ ...ip-address ] [ load-share ]

no set ip default next-hop ip-address [ ...ip-address ]

 
シンタックスの説明

ip-address

パケットが出力される出力先ネクストホップの IP アドレス。ネクストホップは隣接ルータである必要があります。最大 32 の IP アドレスを設定できます。

load-share

(任意)ロード シェアリングをイネーブルにします。

 
コマンドのデフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ip-address 引数 に複数の値を含めることができることを示します。

このコマンドを使用すると、特定のユーザに異なるデフォルト ルートを提供します。ソフトウェアがパケットの宛先への明示ルートを持たない場合、パケットは次のネクストホップにルーティングされます。 set ip default next-hop コマンドで指定された最初のネクストホップはルータに隣接している必要があります。次に、オプションの IP アドレスが使用されます。

ポリシー ルーティング パケットに関する条件を定義するには、 ip policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set route-map コンフィギュレーション コマンドを使用します。 ip policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。match コマンドは、 一致基準ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

set 句は互いに組み合せて使用できます。set 句は次の順で評価されます。

1. set ip next-hop

2. set ip default next-hop


) set ip next-hop と set ip default next-hop は類似のコマンドですが、操作順が異なります。set ip next-hop コマンドを設定すると、最初にポリシー ルーティングを使用してからルーティング テーブルを使用します。set ip default next-hop コマンドを設定すると、最初にルーティング テーブルを使用してから指定のネクストホップをポリシー ルーティングします。


このコマンドにはライセンスは必要ありません。

次に、IPv6 デフォルト ネクストホップ アドレスが設定されたルート マップを設定する例を示します。

switch(config)# ip access-list test
switch(config-ip-acl)# permit ip 192.0.2.0/24 any
switch(config-ip-acl)# exit
switch(config)# route-map equal-access
switch(config-route-map)# match ip address test
switch(config-route-map)# set ip default next-hop ip 192.0.2.3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ip policy route-map equal-access
 
 

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set ip next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの出力先を示すには、ルートマップ コンフィギュレーション モードで set ip next-hop コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set ip next-hop { ip-address [ ... ip-address ] [ load-share] | peer-address }

no set ip next-hop { ip-address [ ... ip-address ] [ load-share] | peer-address }

 
シンタックスの説明

ip-address

パケットが出力される出力先ネクストホップの IP アドレス。隣接ルータである必要はありません。1 つまたは複数の IP アドレスを設定できます。

load-share

(任意)ロード シェアリングをイネーブルにします。

peer-address

ネクストホップを BGP ピア アドレスに設定します。

 
コマンドのデフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ip-address 引数 に複数の値を含めることができることを示します。

ポリシー ルーティング パケットに関する条件を定義するには、 ip policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set route-map コンフィギュレーション コマンドを使用します。 ip policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

set ip next-hop コマンドで指定された最初のネクストホップがダウン状態になると、任意で指定された IP アドレスが使用されます。

BGP ピアのインバウンド ルート マップで peer-address キーワードを指定し、 set ip next-hop コマンドを使用すると、受信した一致するルートのネクストホップをネイバー ピア アドレスに設定し、サードパーティのネクストホップを上書きします。したがって、同じルート マップを複数の BGP ピアに適用すると、サードパーティのネクストホップを上書きできます。

BGP ピアのアウトバウンド ルート マップで peer-address キーワードを指定し、 set ip next-hop コマンドを使用すると、アドバタイズされた一致するルートのネクストホップをローカル ルータのピア アドレスに設定し、ネクストホップ計算をディセーブルにします。他のルートではなく、一部のルートにネクストホップを設定できるので、 set ip next-hop コマンドは、(ネイバー単位の) neighbor next-hop-self コマンドよりも詳細に設定できます。 neighbor next-hop-sel f コマンドを使用すると、ネクストホップをネイバーに送信されたすべてのルートに設定します。

set 句は互いに組み合せて使用できます。set 句は次の順で評価されます。

1. set ip next-hop

2. set ip default next-hop

このコマンドにはライセンスは必要ありません。

次の例では、3 台のルータが同じ LAN 上にあります(IP アドレス 10.1.1.1, 10.1.1.2 および 10.1.1.3)。それぞれが異なる Autonomous System(AS; 自律システム)です。 set ip next-hop peer-address コマンドは、ルート マップと一致する、リモート自律システム 64496 内のルータ(10.1.1.3)からリモート自律システム 64497 内のルータ(10.1.1.1)へのトラフィックが、LAN への相互接続上で自律システム 100 内のルータ(10.1.1.1)に直接送信されるのではなく、ルータ bgp 64498 を通過するように指定します。

switch(config)# router bgp 64498
switch(config-router)# neighbor 10.1.1.3 remote-as 64496
switch(config-router)# neighbor 10.1.1.3 route-map set-peer-address out
switch(config-router)# neighbor 10.1.1.1 remote-as 64497
!
switch(config)# route-map set-peer-address permit 10
switch(config-route-map)# set ip next-hop peer-address

 
関連コマンド

コマンド
説明

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set ipv6 default next-hop

ポリシー ルーティングのルート マップの match 句を満たすパケットのうち、Cisco NX-OS ソフトウェアが宛先への明示的なルートを認識していないパケットの出力先を指定するには、ルートマップ コンフィギュレーション モードで set ipv6 default next-hop コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set ipv6 default next-hop ipv6-address [ ...ipv6-address ] [ load-share ]

no set ipv6 default next-hop ipv6-address [ ...ipv6-address ]

 
シンタックスの説明

ipv6-address

パケットが出力されるネクストホップの IPv6 アドレス。ネクストホップは隣接ルータである必要があります。最大 32 個の IPv6 アドレスを設定できます。

load-share

(任意)ロード シェアリングをイネーブルにします。

 
コマンドのデフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ipv6-address 引数に複数の値を含めることができることを意味します

このコマンドを使用すると、特定のユーザに異なるデフォルト ルートを提供します。ソフトウェアがパケットの宛先への明示ルートを持たない場合、パケットは次のネクストホップにルーティングされます。 set ipv6 default next-hop コマンドで指定された最初のネクストホップはルータに隣接している必要があります。次に、オプションの IP アドレスが使用されます。

ポリシー ルーティング パケットに関する条件を定義するには、 ipv6 policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set route-map コンフィギュレーション コマンドを使用します。 ipv6 policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。match コマンドは、 一致基準ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

set 句は互いに組み合せて使用できます。set 句は次の順で評価されます。

1. set ipv6 next-hop

2. set ipv6 default next-hop


) set ipv6 next-hop と set ipv6 default next-hop は類似のコマンドですが、操作順が異なります。set ipv6 next-hop コマンドを設定すると、システムで最初にポリシー ルーティングが使用されてから、ルーティング テーブルが使用されます。set ipv6 default next-hop コマンドを設定すると、システムで最初にルーティング テーブルが使用されてから、指定されたネクストホップがポリシー ルーティングされます。


このコマンドにはライセンスは必要ありません。

次に、IPv6 デフォルト ネクストホップ アドレスが設定されたルート マップを設定する例を示します。

switch(config)# ipv6 access-list test
switch(config-ipv6-acl)# permit ipv6 2001:0DB8::/48 any
switch(config-ipv6-acl)# exit
switch(config)# route-map equal-access
switch(config-route-map)# match ipv6 address test
switch(config-route-map)# set ipv6 default next-hop 2001:0DB8::3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ipv6 policy route-map equal-access
 

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ipv6 address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ipv6 next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ipv6 route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの AS パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

set ipv6 next-hop

ポリシー ルーティング用のルート マップの match 節を通過するパケットの出力先を示すには、ルートマップ コンフィギュレーション モードで set ipv6 next-hop コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

sset ipv6 next-hop { ipv6-address [ ... ipv6-address ] [ load-share] | peer-address }

no set ipv6 next-hop { ipv6-address [ ... ipv6-address ] [ load-share] | peer-address }

 
シンタックスの説明

ipv6-address

パケットが出力されるネクストホップの IPv6 アドレス。隣接ルータである必要はありません。1 つまたは複数の IP アドレスを設定できます。

load-share

(任意)ロード シェアリングをイネーブルにします。

peer-address

ネクストホップを BGP ピア アドレスに設定します。

 
コマンドのデフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ipv6-address 引数に複数の値を含めることができることを意味します

このコマンドを使用すると、特定のユーザに異なるデフォルト ルートを提供します。ソフトウェアがパケットの宛先への明示ルートを持たない場合、パケットは次のネクストホップにルーティングされます。 set ipv6 default next-hop コマンドで指定された最初のネクストホップはルータに隣接している必要があります。次に、オプションの IP アドレスが使用されます。

ポリシー ルーティング パケットに関する条件を定義するには、 ipv6 policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、 match および set route-map コンフィギュレーション コマンドを使用します。 ipv6 policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。match コマンドは、 一致基準ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

set 句は互いに組み合せて使用できます。set 句は次の順で評価されます。

1. set ipv6 next-hop

2. set ipv6 default next-hop


) set ipv6 next-hop と set ipv6 default next-hop は類似のコマンドですが、操作順が異なります。set ipv6 next-hop コマンドを設定すると、システムで最初にポリシー ルーティングが使用されてから、ルーティング テーブルが使用されます。set ipv6 default next-hop コマンドを設定すると、システムで最初にルーティング テーブルが使用されてから、指定されたネクストホップがポリシー ルーティングされます。


このコマンドにはライセンスは必要ありません。

次に、IPv6 ネクストホップ アドレスが設定されたルート マップを設定する例を示します。

switch(config)# ipv6 access-list test
switch(config-ipv6-acl)# permit ipv6 2001:0DB8::/48 any
switch(config-ipv6-acl)# exit
switch(config)# route-map equal-access
switch(config-route-map)# match ipv6 address test
switch(config-route-map)# set ipv6 next-hop 2001:0DB8::3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ipv6 policy route-map equal-access
 

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ipv6 address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ipv6 next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ipv6 route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set ipv6 default next-hop

ネクストホップのアドレスを指定します。

set level

ルートのインポート先を示すには、ルートマップ コンフィギュレーション モードで set level コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set level { level-1 | level-2 | level-1-2 }

no set level { level-1 | level-2 | level-1-2 }

 
シンタックスの説明

level-1

ルートをレベル 1 エリアにインポートします。

level-2

ルートをレベル 2 サブドメインにインポートします。

level-1-2

ルートをレベル 1 とレベル 2 にインポートします。

 
コマンドのデフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドを使用すると、ルート マップのすべての一致基準を満たした場合に実行する再配布 set 処理 を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

このコマンドにはライセンスは必要ありません。

次に、ルートをレベル 1 エリアにインポートする例を示します。

switch(config-router)# route-map testcase
switch(config-route-map)# set level level-l

 
関連コマンド

コマンド
説明

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

neighbor next-hop-self

ルータ上で BGP アップデートのネクストホップ処理をディセーブルにします。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの宛先への明示ルートを Cisco NX-OS ソフトウェアが持たない場合の出力先を示します。

set local-preference

Autonomous System(AS; 自律システム)パスにプリファレンス値を指定するには、ルートマップ コンフィギュレーション モードで set local-preference コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set local-preference number-value

no set local-preference number-value

 
シンタックスの説明

number-value

プリファレンス値。範囲は 0 ~ 4294967295 です。デフォルトは 100 です。

 
コマンドのデフォルト

デフォルトでは、プリファレンス値は 100 です。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

プリファレンスは、ローカル AS 内のすべてのルータにのみ送信されます。

タグを設定する場合は、match 句を使用する必要があります(「permit everything」リストを指している場合でも)。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドを使用すると、ルート マップのすべての一致基準を満たした場合に実行する再配布 set 処理 を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

bgp default local-preference コマンドを使用して、デフォルトのプリファレンス値を変更できます。

このコマンドにはライセンスは必要ありません。

次に、アクセス リスト 1 に含まれるすべてのルートに対して、ローカル プリファレンスを 100 に設定する例を示します。

switch(config-router)# route-map map-preference
switch(config-route-map)# match as-path 1
switch(config-route-map)# set local-preference 100

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定のインターフェイスの 1 つのネクストホップを持つルートを配布します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric(IP)

指定されたメトリックによりルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ アトリビュートを設定します。

set ip next-hop

ネクストホップのアドレスを指定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set origin(BGP)

BGP 送信元コードを設定します。

set tag(IP)

宛先ルーティング プロトコルの値を設定します。

set metric

ルーティング プロトコルのメトリック値を設定するには、ルートマップ コンフィギュレーション モードで set metric コマンドを使用します。デフォルトのメトリック値に戻すには、このコマンドの no 形式を使用します。

set metric [ + | - ] bandwidth-metric

set metric bandwidth-metric [d elay-metric reliability-metric load-metric mtu ]

no set metric

 
シンタックスの説明

+

(任意)既存の遅延メトリック値に加算します。

-

(任意)既存の遅延メトリック値から減算します。

bandwidth-metric

Interior Gateway Routing Protocol(IGRP)帯域幅(Kb/s 単位)。範囲は 0 ~ 4294967295 です。

delay-metric

(任意)IGRP 遅延メトリック(10 マイクロ秒単位)。範囲は 1 ~ 4294967295 です。

reliability-metric

(任意)IGRP 信頼性メトリック。指定できる範囲は 0 ~ 255 です。

load-metric

(任意)IGRP 負荷メトリック。範囲は 1 ~ 255 です。

mtu

(任意)パスの IGRP Maximum Transmission Unit(MTU; 最大伝送ユニット)。範囲は 1 ~ 4294967295 です。

 
コマンドのデフォルト

なし

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

4.1(2)

+ キーワードと - キーワードが追加されました。

 
使用上のガイドライン

set metric コマンドは、IGRP メトリック値を変更するために使用します。


) デフォルト値を変更する前に、シスコのテクニカル サポート担当者に問い合せてください。


r eliability-metric 引数と load-metric 引数を設定する場合、255 は 100% の信頼性を意味します。

+ キーワードまたは - キーワードは、既存の遅延メトリック値を変更するために使用します。これらのキーワードを使用する場合は、遅延メトリックしか変更できません。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドを使用すると、ルート マップのすべての一致基準を満たした場合に実行する再配布 set 処理 を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

このコマンドにはライセンスは必要ありません。

次に、ルーティング プロトコルの帯域幅メトリック値を 100 に設定する例を示します。

switch(config)# route-map set-metric
switch(config-route-map)# set metric 100
 

次に、ルーティング プロトコルの帯域幅メトリック値を 100 増やす例を示します。

switch(config)# route-map set-metric
switch(config-route-map)# set metric +100
 

 
関連コマンド

コマンド
説明

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set metric-type

宛先ルーティング プロトコルのメトリック値を設定するには、ルートマップ コンフィギュレーション モードで set metric-type コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

set metric-type { internal | external | type-1 | type-2 }

no set metric-type { internal | external | type-1 | type-2 }

 
シンタックスの説明

internal

IS-IS 内部メトリックまたは IGP メトリックを BGP の multi-exit discriminator(MED)として指定します。

external

IS-IS 外部メトリックを指定します。

type-1

OSPF 外部タイプ 1 メトリックを指定します。

type-2

OSPF 外部タイプ 2 メトリックを指定します。

 
コマンドのデフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドを使用すると、ルート マップのすべての一致基準を満たした場合に実行する再配布 set 処理 を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。


) このコマンドは、BGP へのルートの再配送ではサポートされていません。


このコマンドにはライセンスは必要ありません。

次に、宛先プロトコルのメトリック タイプを OSPF 外部タイプ 1 に設定する例を示します。

switch(config)# route-map map-type
switch(config-route-map)# set metric-type type-1

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP AS パス アクセス リストを設定します。

set community

BGP コミュニティ アトリビュートを設定します。

set ip next-hop

ネクストホップのアドレスを指定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set origin

BGP 送信元コードを設定します。

set tag

宛先ルーティング プロトコルの値を設定します。

set origin

BGP 送信元コードを設定するには、 set origin ルートマップ コンフィギュレーション モード コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set origin { egp as-num [: as-num ] | igp | incomplete }

no set origin

 
シンタックスの説明

egp as-num [ :as-num ]

リモート exterior gateway protocol(EGP; エクステリア ゲートウェイ プロトコル)システムの AS 番号を指定します。AS 番号を 2 バイトの整数または 4 バイトの整数として aa:nn 形式で設定できます。範囲は 1 ~ 65535 です。

igp

ローカル IGP システムを指定します。

incomplete

未知の継承を指定します。

 
コマンドのデフォルト

主な IP ルーティング テーブルのルートに基づいた、デフォルトの送信元

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

タグを設定する場合は、match 句を使用する必要があります(「permit everything」リストを指している場合でも)。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、set 処理(match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドを使用すると、ルート マップのすべての一致基準を満たした場合に実行する再配布 set 処理を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

このコマンドにはライセンスは必要ありません。

次に、ルート マップを IGP に送信するルートの発信を設定する例を示します。

switch(config)# route-map set_origin
switch(config-route-map)# match as-path 10
switch(config-route-map)# set origin igp

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP AS パス アクセス リストを設定します。

set community

BGP コミュニティ アトリビュートを設定します。

set ip next-hop

ネクストホップのアドレスを指定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set origin

BGP 送信元コードを設定します。

set tag

宛先ルーティング プロトコルの値を設定します。

 

 

set tag

宛先ルーティング プロトコルのタグ値を設定するには、ルートマップ コンフィギュレーション モードで set tag コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set tag tag-value

no set tag tag-value

 
シンタックスの説明

tag-value

タグの名前。0 ~ 4294967295 の整数。

 
コマンドのデフォルト

指定されていないと、デフォルトのアクションは、送信元ルーティング プロトコルのタグを新しい宛先プロトコルに 転送 します。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、 一致基準 (現在の route-map コマンドに許可された再配布の条件)を指定します。 set コマンドは、 set 処理 match コマンドによって強制される基準が満たされた場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドは、ルート マップを削除します。

set route-map コンフィギュレーション コマンドを使用すると、ルート マップのすべての一致基準を満たした場合に実行する再配布 set 処理 を指定します。すべての一致基準を満たすと、すべての set 処理が実行されます。

このコマンドにはライセンスは必要ありません。

次に、宛先ルーティング プロトコルのタグ値を 5 に設定する例を示します。

switch(config)# route-map test
switch(config-route-map)# set tag 5

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP AS パス アクセス リストを設定します。

set community

BGP コミュニティ アトリビュートを設定します。

set ip next-hop

ネクストホップのアドレスを指定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set origin

BGP 送信元コードを設定します。

set tag

宛先ルーティング プロトコルの値を設定します。

set vrf

ポリシーベース ルーティング Virtual Routing and Forwarding(VRF)選択のため、ルート マップ内で VRF 選択をイネーブルにするには、ルートマップ コンフィギュレーション モードで set vrf コマンドを使用します。ルート マップ内で VRF 選択ディセーブルにするには、このコマンドの no 形式を使用します。

set vrf { vrf-name | default | management }

no set vrf [ vrf-name | default | management ]

 
シンタックスの説明

vrf-name

VRF に割り当てられた名前。

default

VRF をデフォルトの VRF に設定します。

management

VRF を管理 VRF に設定します。

 
コマンドのデフォルト

デフォルトの動作または値はありません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

set vrf ルートマップ コンフィギュレーション コマンドが、MPLS VPN とともに導入されました(ポリシー ベース ルーティング機能を使用した VRF 選択により、VRF 選択の PBR メカニズムを提供)。このコマンドは、ルート マップ経由でパケットをポリシー ルーティングすることで VRF 選択をイネーブルにするのに使用されます。ルート マップは着信インターフェイスに接続されます。一致基準は IP アクセス リストまたは IP プレフィクス リストで定義されます。match length ルート マップ コマンドを使用し、パケット長に基づいて一致基準を定義することもできます。このコマンドを設定する前に VRF を定義する必要があります。インターフェイスまたはサブインターフェイスでポリシー ルーティングをイネーブルにするには、ip policy route-map インターフェイス コンフィギュレーション コマンドを設定する必要があります。VRF が定義されていない、またはポリシー ルーティングがイネーブルでない場合に set vrf コマンドを設定しようとすると、エラー メッセージがコンソールに表示されます。


) VRF を指定するときに、パケットをインターフェイスに設定したり、ネクストホップを変更したりできないため、set vrf コマンドは set ip default next-hop および set ip next-hop ポリシー ルーティング コマンドと一緒に設定できません。これは、設計された動作です。これらの set 句のいずれかで set vrf コマンドを設定しようとすると、エラー メッセージがコンソールに表示されます。


このコマンドにはライセンスは必要ありません。

次の例では、3 つの異なるアクセス リストで定義された一致基準に基づいて、VRF を選択および設定するルート マップ シーケンスを示します (アクセス リストの設定については、この例では示しません)。ルート マップを通して一致が見つからなかった場合は、宛先がローカルになっているパケットが破棄されます。

switch(config)# route-map PBR-VRF-Selection permit 10
switch(config-route-map)# match ip address 40
switch(config-route-map)# set vrf VRF_1
!
switch(config)# route-map PBR-VRF-Selection permit 20
switch(config-route-map)# match ip address 50
switch(config-route-map)# set vrf VRF_2
!
switch(config)# route-map PBR-VRF-Selection permit 30
switch(config-route-map)# match ip address 60
switch(config-route-map)# set vrf VRF_3

 
関連コマンド

コマンド
説明

access-list(IP 標準)

標準 IP アクセス リストを定義します。

debug ip policy

IP ポリシー ルーティング パケットのアクティビティを示します。

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

ip vrf

VRF ルーティング テーブルを設定します。

ip vrf receive

インターフェイスの IP アドレスを接続ルート エントリとして VRF ルーティング テーブルに挿入します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスのあるルートを配布する、またはパケットでポリシー ルーティングを実行します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set weight

ルーティング テーブルの BGP 重みを指定するには、ルートマップ コンフィギュレーション モードで set weight コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

set weight number

no set weight [ number ]

 
シンタックスの説明

number

重み値。範囲は 0 ~ 65535 です。

 
デフォルト

重みは指定のルート マップによって変更されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

実行された重みは、最初に一致した Autonomous System(AS; 自律システム)パスに基づいています。AS パスが一致したときに表示された重みは、global neighbor コマンドによって割り当てられた重みを無効にします。つまり、 set weight ルートマップ コンフィギュレーション コマンドで割り当てられた重みは、 neighbor weight コマンドを使用して割り当てられた重みを無効にします。

このコマンドにはライセンスは必要ありません。

次に、AS パス アクセス リストと一致するルートの BGP 重みを 200 に設定する例を示します。

switch(config)# route-map set-weight
switch(config-route-map)# match as-path 10
switch(config-route-map)# set weight 200

 
関連コマンド

コマンド
説明

match as-path

BGP AS パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクストホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定されたメトリックによりルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP AS パス アクセス リストを設定します。

set community

BGP コミュニティ アトリビュートを設定します。

set ip next-hop

ネクストホップのアドレスを指定します。

set level

ルートのインポート先を示します。

set local-preference

AS パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルにメトリック タイプを設定します。

set origin

BGP 送信元コードを設定します。

set tag

宛先ルーティング プロトコルの値を設定します。

set-attached-bit

IS-IS 用の attached(ATT; 接続)ビットを設定するには、 set-attached-bit コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

set-attached-bit

no set-attached-bit

 
シンタックスの説明

このコマンドには、キーワードと引数はありません。

 
デフォルト

イネーブル

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.1(2)

このコマンドが追加されました。

 
使用上のガイドライン

set-attached-bit コマンドは、レベル 1/レベル 2 IS-IS ルータを同じエリア内のレベル 1 ルータのデフォルト ルータとして使用するかどうかを設定するために使用します。 set-attached-bit コマンドがディセーブルになっている場合は、「接続ビット」がそのレベル 1 LSP 内のルータによってアドバタイズされず、そのエリア内の他のレベル 1 ルータはこのルータをエリア外部のデフォルト ルータとして使用しません。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、接続ビットをリセットする例を示します。

switch(config)# router isis Border1
switch(config-router)# no set-attached-bit
 

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

set-overload-bit

他のルータに Shortest Path First(SPF)の計算時にルータを中間ホップとして使用しないように通知するためにこのルータを設定するには、 set-overload-bit コマンドを使用します。指定を削除するには、このコマンドの no 形式を使用します。

set-overload-bit { always | { on-startup { seconds | wait-for bgp as-num [. as-num ]}} [ suppress [[ interlevel ] [ external ]]]

no set-overload-bit

 
シンタックスの説明

always

無条件に過負荷ビットを設定します。

on-startup seconds

システムの起動時に過負荷ビットを設定します。過負荷ビットは、設定された秒数に設定されたままになります。範囲は 5 ~ 86400 です。

on-startup wait-for bgp

システム起動時に過負荷ビットが設定され、BGP が収束するまで設定されたままになります。

as-num

AS 番号。範囲は 1 ~ 65535 です。

.as-num

(任意)AS 番号。範囲は 0 ~ 65535 です。

suppress

(任意)後続のキーワードが識別したプレフィクスを抑制します。

interlevel

(任意)別の IS-IS レベルから学習した IP プレフィクスがアドバタイズされるのを防ぎます。

external

(任意)他のプロトコルから学習した IP プレフィクスがアドバタイズされるのを防ぎます。

 
コマンドのデフォルト

デフォルトでは、過負荷ビットは設定されていません。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

set-overload-bit コマンドを使用すると、ルータは非擬似ノード link-state packet(LSP; リンクステート パケット)に過負荷ビットを設定します。通常、過負荷ビットの設定は、ルータに問題が発生した場合にのみ許可されます。たとえば、ルータのメモリが不足した場合、リンクステート データベースは完全ではなくなり、ルーティング テーブルが不完全または不正確になります。LSP に過負荷ビットを設定すると、ルータが障害から回復するまで、他のルータは SPF 計算中に信頼できないルータを無視できます。

その結果、このルータを経由するパスは、IS-IS エリア内の他のルータによって検出されません。ただし、このルータに直接接続された IP プレフィクスおよび Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)プレフィクスは到達可能です。

ルータを IS-IS ネットワークに接続しますが、どのような状況でも実際のトラフィックをネットワークに流したくない場合にこのコマンドは便利です。状況の例は次のとおりです。

実稼動ネットワークに接続されたラボ内のテスト ルータ

メッシュ グループ機能と組み合せた、Nonbroadcast Multiaccess(NBMA; 非ブロードキャスト マルチアクセス)ネットワークなどで LSP フラッディング サーバとして設定されたルータ

ネットワーク管理専用の virtual circuit(VC; 仮想回線)を集約するルータ。この場合、ネットワーク管理ステーションは、set-overload-bit コマンドで設定されたルータに直接接続されたネットワーク上にある必要があります。

on-startup キーワードを指定しないと、このコマンドはただちに過負荷ビットを設定します。

過負荷ビットの設定のほかに、LSP からの特定の IP プレフィクス アドバタイズメント タイプを抑制します。たとえば、レベル 1 とレベル 2 の間の IP プレフィクスの伝播により、実際にノードを IP トラフィックの中継ノードにします。これは適切ではありません。レベル間または外部キーワード(または両方)を指定して使用する抑制キーワードは、過負荷ビットの設定中に抑制を実行します。

このコマンドにはライセンスは必要ありません。

次に、起動時に、また BGP が収束するまで過負荷ビットを設定する例を示します。

switch(config)# router isis firstcompany

switch(config-router)# set-overload-bit on-startup wait for-bgp suppress interlevel external

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

shutdown (BGP)

BGP のインスタンスをシャットダウンするには、 shutdown コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
シンタックスの説明

このコマンドには、キーワードと引数はありません。

 
デフォルト

イネーブル

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.1(2)

このコマンドが追加されました。

 
使用上のガイドライン

設定を削除することなく BGP のインスタンスをディセーブルにするには、 shutdown コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、BGP 64496 をディセーブルにする例を示します。

switch(config)# router BGP 64496
switch(config-router)# shutdown

shutdown (EIGRP)

Enhanced IGRP(EIGRP)のインスタンスをシャットダウンするには、 shutdown コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
シンタックスの説明

このコマンドには、キーワードと引数はありません。

 
デフォルト

イネーブル

 
コマンド モード

アドレスファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

設定を削除することなく EIGRP のインスタンスをディセーブルにするには、 shutdown コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、eigrp 209 をディセーブルにする例を示します。

switch(config)# router eigrp 209
switch(config-router)# shutdown

shutdown (IS-IS)

プロセス設定を削除することなく IS-IS ルータ プロセスを停止するには、 shutdown コマンドを使用します。停止した IS-IS プロセスを開始するには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト

プロセスは停止していません。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

shutdown コマンドを入力すると、ルータ プロセスを停止しますが、設定パラメータは削除しません。イネーブルの場合、 shutdown コマンドは実行コンフィギュレーション ファイルに表示されます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、アクティブ IS-IS プロセスを停止する例を示します。

switch(config)# router isis firstcompany
switch(config-router)# shutdown
 

次に、停止した IS-IS プロセスを開始する例を示します。

switch(config)# router isis firstcompany
switch(config-router)# no shutdown

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

shutdown (OSPF)

設定を削除することなく OSPF インスタンスを停止するには、 shutdown コマンドを使用します。停止した OSPF インスタンスを開始するには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト

プロセスは停止していません。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

shutdown コマンドを入力すると、ルータ プロセスを停止しますが、設定パラメータは削除しません。イネーブルの場合、 shutdown コマンドは実行コンフィギュレーション ファイルに表示されます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、アクティブ OSPF インスタンスを停止する例を示します。

switch(config)# router ospf firstcompany
switch(config-router)# shutdown
 

 
関連コマンド

コマンド
説明

feature ospf

ルータで OSPF をイネーブルにします。

router ospf

OSPF インスタンスを設定します。

shutdown (OSPFv3)

設定を削除することなく OSPF(OSPFv3)インスタンスを停止するには、 shutdown コマンドを使用します。停止した OSPF インスタンスを開始するには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト

プロセスは停止していません。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

shutdown コマンドを入力すると、ルータ プロセスを停止しますが、設定パラメータは削除しません。イネーブルの場合、 shutdown コマンドは実行コンフィギュレーション ファイルに表示されます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、アクティブ OSPFv3 インスタンスを停止する例を示します。

switch(config)# router ospfv3 firstcompany
switch(config-router)# shutdown
 

 
関連コマンド

コマンド
説明

feature ospfv3

ルータで OSPFv3 をイネーブルにします。

router ospv3f

OSPFv3 インスタンスを設定します。

shutdown (VRRP)

Virtual Router Redundancy Protocol(VRRP; 仮想ルータ冗長プロトコル)設定をディセーブルにするには、 shutdown コマンドを使用します。VRRP 設定をイネーブルにするには、このコマンドの no 形式を使用します。

shutdown

no shutdown

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ディセーブル

 
コマンド モード

VRRP コンフィギュレーション モード

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

仮想ルータ パラメータを設定する前に仮想ルータをシャットダウンします。仮想ルータが管理上のシャットダウン ステートになったあとでのみ、仮想ルータを設定できます。設定の完了後に仮想ルータの状態をアップデートするには、 no shutdown コマンドを入力します。

このコマンドにはライセンスは必要ありません。

次に、VRRP グループをシャットダウンする例を示します。

switch(config-if)# vrrp 45
switch(config-if-vrrp)# shutdown
switch(config-if-vrrp)# address 6.6.6.45
switch(config-if-vrrp)# no shutdown

 
関連コマンド

コマンド
説明

feature vrrp

VRRP をイネーブルにします。

show vrrp

VRRP 設定情報を表示します。

clear vrrp

指定の仮想ルータの全ソフトウェア カウンタを消去します。

spf-interval

Link-State Advertisement(LSA; リンクステート アドバタイズメント)到着までの最小時間を設定するには、 spf-interval コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spf-interval [ level-1 | level-2 ] spf-max-wait [ spf-initial-wait spf-second-wait ]

no spf-interval

 
シンタックスの説明

level-1

shortest path first(SPF)レベル 1 時間を指定します。

level-2

SPF レベル 2 時間を指定します。

spf-max-wait

2 つの 連続した SPF 計算の間の最小時間(ミリ秒単位)。範囲は 500 ~ 65535 です。

spf-initial-wait

トポロジが変更されたあとの初期 SPF 計算遅延(ミリ秒単位)。範囲は 50 ~ 65535 です。

spf-second-wait

最初と 2 つ目の SPF 計算の間のホールド時間(ミリ秒単位)。範囲は 50 ~ 65535 です。

 
コマンドのデフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

LSA は、接続されたネットワークをアドバタイズするのに使用されます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、LSA の到着までの最小時間を設定する例を示します。

switch(config)# router isis firstcompany
switch(config-router)# spf-interval level-1 500 500 500

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

 

stub

Enhanced IGRP(EIGRP)を使用して、ルータをスタブとして設定するには、 stub コマンドを使用します。EIGRP スタブ ルーティングをディセーブルにするには、コマンドの no 形式を使用します。

stub [ direct | leak-map map-name | receive-only | redistributed ]

no stub [ direct | leak-map map-name | receive-only | redistributed ]]

 
シンタックスの説明

direct

(任意)直接接続されたルートをアドバタイズします。

leak-map map-name

(任意)リーク マップに基づいて、ダイナミック プレフィクスを許可します。

receive-only

(任意)ルータを受信専用ネイバーとして設定します。

redistributed

(任意)他のプロトコルと Autonomous System(AS; 自律システム)から再配布されたルートをアドバタイズします。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

すべての IP トラフィックを配信ルータに送信するスタブとしてルータを設定するには、 stub コマンドを使用します。

direct キーワードを指定すると、EIGRP スタブ ルーティングは接続されたルートをアドバタイズできます。このオプションは、デフォルトではイネーブルです。

receive-only キーワードは、ルータが EIGRP AS 内の他のルータとルートを共有しないように制限します。 receive-only キーワードは、あらゆるルート タイプを送信しないようにするため、他のオプションを指定できません。

redistributed キーワードを指定すると EIGRP スタブ ルーティング機能は他のルーティング プロトコルと AS を送信できます。このオプションを設定しないと、EIGRP は再配布されたルートをアドバタイズしません。

stub コマンドとともに 4 つのキーワード( direct leak-map receive-only redistributed )のいずれかを使用すると、特定のキーワードで指定された他のルート タイプのみがアドバタイズされます。

このコマンドには、Enterprise Services ライセンスが必要です。

 
使用上のガイドライン

次に、ルータを受信専用ネイバーとして設定する例を示します。

switch(config)# router eigrp 1
switch(config-router)# stub receive-only

summary-address

IS-IS 集約アドレスを作成するには、 summary-address コマンドを使用します。集約アドレスを削除するには、このコマンドの no 形式を使用します。

summary-address { ip-addr | ip-prefix / length | ipv6-addr | ipv6-prefix / length } level

 
シンタックスの説明

ip-addr

ネイバーの IP アドレス(A.B.C.D 形式)。

ip-prefix / length

IP プレフィクスおよび IP プレフィクス長。IPv6 プレフィクス長は、アドレスの連続する上位何ビットがプレフィクス(アドレスのネットワーク部分)を構成するかを示す 10 進値です。スラッシュ記号を 10 進値の前に付ける必要があります。A.B.C.D/length の形式を使用します。

ipv6-addr

ネイバーの IPv6 アドレス(A:B::C:D 形式)。

ipv6-prefix / length

ネイバーの IPv6 プレフィクスおよび IPv6 プレフィクス長(A:B::C:D/ length の形式)

level

レベル番号。デフォルトでは、すべてのルートが個別にアドバタイズされます。有効な値は次のとおりです。

level-1 :IP アドレスをレベル 1 エリアに集約します。設定済みアドレスとマスク値を使用して、レベル 1 に再配布されたルートのみが集約されます。

level-1-2 :IP アドレスをレベル 1 およびレベル 2 エリアに集約します。ルートをレベル 1 およびレベル 2 IS-IS に再配布したとき、レベル 2 IS-IS がレベル 1 ルートをエリアで到達可能なものとしてアドバタイズするとき、集約経路が適用されます。

level-2 :IP アドレスをレベル 2 エリアに集約します。設定済みアドレスとマスク値を使用して、レベル 1 ルーティングが学習したルートはレベル 2 バックボーンに集約されます。レベル 2 IS-IS に再配布されたルートも集約されます。

 
コマンドのデフォルト

なし

 
コマンド モード

アドレスファミリ コンフィギュレーション
ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

複数のアドレス グループを特定のレベルに集約できます。他のルーティング プロトコルから学習したルートも集約できます。要約をアドバタイズするのに使用するメトリックは、特定ルートの最小メトリックです。このコマンドは、ルーティング テーブルの容量縮小に有効です。

link-state packet(LSP; リンクステート パケット)とリンクステート データベース(LSDB)のサイズも小さくします。また、要約アドバタイズメントは多くの特定ルートによって異なるので、ネットワークの安定にも役立ちます。たいていの場合、1 つのルート フラップが原因で要約アドバタイズメントはフラップしません。

サマリー アドレスを使用する場合、他のルートには、使用する個々の宛先すべてに最適なルーティング テーブルを計算するための情報が少なくなります。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、IS-IS に直接接続されたルートを再配布する例を示します。次に、10.1.0.0 のみを IS-IS レベル 1 リンクステート Protocol Data Unit(PDU; プロトコル データ ユニット)にアドバタイズする例を示します。サマリー アドレスに 100 のタグが付けられます。

switch(config)# router isis 100
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# redistribute direct route-map CORE1
switch(config-router-af)# summary-address 10.1.0.0 255.255.0.0

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ モードまたは VRF アドレスファミリ モードを開始します。

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

summary-address (OSPF)

OSPF プロトコルの集約アドレスを作成するには、 summary-address コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

summary-address ip-prefix/length [ not-advertise ] [ tag tag ]

no summary-address ip-prefix/length [ not-advertise ] [ tag tag ]

 
シンタックスの説明

ip-prefix/length

アドレス範囲に指定された IP プレフィクス(プレフィクス長を含む)。 ip-prefix に IP アドレスを指定します。 length に 1 ~ 31 の数を指定します。

not-advertise

(任意)指定の prefix/length のペアと一致するルートを抑制します。

tag tag

(任意)ルート マップを使用して再配布を制御する「match」値として使用できるタグ値。有効範囲は 1 ~ 65535 です。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

集約アドレスを作成して特定のアドレス シリーズを交換するには、 summary-address コマンドを使用します。要約をアドバタイズするのに使用するメトリックは、特定ルートの最小メトリックです。

このコマンドを使用すると、ルーティング テーブルのサイズを小さくします。OSPF Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)は、アドレスがカバーする再配布ルートすべての集約として 1 つの外部ルートをアドバタイズできます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、アドレス 192.0.1.0、192.0.2.0、192.0.3.0 などを含めるようサマリー アドレス 192.0.0.0 を設定する例を示します。アドレス 192.0.0.0 のみが外部 Link-State Advertisement(LSA; リンクステート アドバタイズメント)でアドバタイズされます。

switch(config)# router ospf 201
switch(config-router)# summary-address 192.0.0.0/16
 

 
関連コマンド

コマンド
説明

redistribute(OSPF)

外部ルーティング プロトコル ルートを OSPF に再配布します。

summary-address (OSPFv3)

OSPF バージョン 3(OSPFv3)プロトコルの集約アドレスを作成するには、 summary-address コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

summary-address ipv6-prefix/length [ not-advertise ] [ tag tag ]

no summary-address ipv6-prefix/length [ not-advertise ] [ tag tag ]

 
シンタックスの説明

ipv6-prefix/length

アドレス範囲に指定された IP プレフィクス(プレフィクス長を含む)。 ip-prefix を IPv6 アドレスとして指定します。 length を 1 ~ 128 の数値として指定します。

not-advertise

(任意)指定の prefix/length のペアと一致するルートを抑制します。

tag tag

(任意)ルート マップを使用して再配布を制御する「match」値として使用できるタグ値。有効範囲は 1 ~ 65535 です。

 
デフォルト

なし

 
コマンド モード

アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

集約アドレスを作成して特定のアドレス シリーズを交換するには、 summary-address コマンドを使用します。要約をアドバタイズするのに使用するメトリックは、特定ルートの最小メトリックです。

このコマンドを使用すると、ルーティング テーブルのサイズを小さくします。OSPFv3 Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)は、アドレスがカバーする再配布ルートすべての集約として 1 つの外部ルートをアドバタイズできます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、アドレス 192.0.1.0、192.0.2.0、192.0.3.0 などを含めるようサマリー アドレス 192.0.0.0 を設定する例を示します。アドレス 192.0.0.0 のみが外部 Link-State Advertisement(LSA; リンクステート アドバタイズメント)でアドバタイズされます。

switch(config)# router ospfv3 201
switch(config-router)# address-family ipv6 unicast
switch(config-router)# summary-address 2001:0DB8::0/16
 

 
関連コマンド

コマンド
説明

redistribute(OSPFv3)

外部ルーティング プロトコル ルートを OSPFv3 に再配布します。

suppress-inactive

アクティブ ルートを Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ピアへのみアドバタイズするには、 suppress-inactive コマンドを使用します。制限を削除するには、このコマンドの no 形式を使用します。デフォルトの設定に戻すには、このコマンドの default 形式を使用します。

suppress-inactive

no | default suppress-inactive

 
シンタックスの説明

このコマンドには、キーワードと引数はありません。

 
コマンドのデフォルト

ルートがテーブル内でアクティブ ルートでなくても、ルートがローカル ルーティング テーブルにインストールされるとすぐに BGP はルートをピアにアドバタイズします。

 
コマンド モード

ネイバー アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

アクティブ ルートのみを BGP ピアにアドバタイズするには、 suppress-inactive コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、サマリー アドレスを作成する例を示します。このルートにアドバタイズされたパスは、集約されるすべてのパスに含まれるすべての要素で構成された Autonomous System(AS; 自律システム)セットです。

switch(config)# router bgp 64496
switch(config-router)# neighbor 192.0.2.1/8 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor af)# suppress-inactive

 
関連コマンド

コマンド
説明

route-map map-name

ルート マップを作成します。