Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス リリース 5.x
L コマンド
L コマンド
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

L コマンド

load-balancing

local-as

log-adjacency-changes (EIGRP)

log-adjacency-changes (IS-IS)

log-adjacency-changes (OSPF)

log-adjacency-changes (OSPFv3)

log-neighbor-warnings

low-memory exempt

lsp-gen-interval

lsp-mtu

L コマンド

この章では、L で始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

load-balancing

Gateway Load Balancing Protocol(GLBP)の Active Virtual Gateway(AVG; アクティブ仮想ゲートウェイ)で使用されるロード バランシング方式を指定するには、 load-balancing コマンドを使用します。ロード バランシングをディセーブルにするには、このコマンドの no 形式を使用します。

load-balancing [ host-dependent | round-robin | weighted ]

no load-balancing

 
シンタックスの説明

host-dependent

(任意)ホストの MAC アドレスに基づくロードバランシング方式(GLBP グループ メンバーの数を一定に保ったまま、特定のホストに常に同じフォワーダが使用される)を指定します。

round-robin

(任意)各仮想フォワーダが仮想 IP アドレスの Address Resolution Protocol(ARP; アドレス解決プロトコル)応答に含まれるようなロード バランシング方式を指定します。この方式がデフォルトです。

weighted

(任意)ゲートウェイによってアドバタイズされる重み値に基づくロード バランシング方式を指定します。

 
デフォルト

ラウンドロビン方式がデフォルトです。

 
コマンド モード

GLBP コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

各ホストが常に同じルータを使用する必要がある場合は、ホスト依存方式の GLBP ロード バランシングを使用します。GLBP グループ内のゲートウェイの転送能力が異なるために不均等なロード バランシングを必要とする場合は、重み値方式の GLBP ロード バランシングを使用します。

このコマンドにはライセンスは必要ありません。

GLBP グループ 10 の AVG にホスト依存ロード バランシング方式を設定する例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# glbp 10
switch(config-glbp)# load-balancing host-dependent

 
関連コマンド

コマンド
説明

glbp

GLBP コンフィギュレーション モードに入って、GLBP グループを作成します。

show glbp

GLBP の情報を表示します。

weighting

重み値ロード バランシング方式の重み値としきい値を設定します。

weighting track

重み値ロード バランシング方式のオブジェクト トラッキングを設定します。

local-as

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)のローカル AS 番号を設定するには、 local-as コマンドを使用します。

local-as as-number

 
シンタックスの説明

as-number

(任意)自律システム番号。AS 番号は、<上位 16 ビットの 10 進数>.<下位 16 ビットの 10 進数> 形式の 16 ビットの整数または 32 ビットの整数です。

 
デフォルト

なし

 
コマンド モード

ルータ VRF モード

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

リリース
変更内容

4.0(3)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

BGP のローカル AS 番号を設定する例を示します。

switch# config t
switch(config)# router bgp 65536.33
switch(config-router)# vrf red
switch(config-router-vrf)# local-as 65536.33
 

 
関連コマンド

コマンド
説明

show bgp

BGP に関する情報を表示します。

log-adjacency-changes (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)隣接状態変更のロギングをイネーブルにするには、 log-adjacency-changes コマンドを使用します。EIGRP 隣接状態変更のロギングをディセーブルにするには、このコマンドの no 形式を使用します。

log-adjacency-changes

no log-adjacency-changes

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

隣接の変更はロギングされません。

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

EIGRP 1 に関して、隣接状態変更のロギングをイネーブルにする例を示します。

switch(config)# router eigrp 1
switch(config-router)# address-family ipv6
switch(config-router-af)# log-adjacency-changes

 
関連コマンド

コマンド
説明

ip eigrp log-neighbor-changes

特定のインターフェイスのネイバーに対する変更をロギングします。

ip eigrp log-neighbor-warnings

特定のインターフェイスのネイバー警告メッセージをロギングします。

log-adjacency-changes (IS-IS)

Intermediate System-to-Intermediate System Intradomain Routing Protocol(IS-IS)ネイバーのアップ時またはダウン時のルータによる syslog メッセージ送信をイネーブルにするには、 log-adjacency-changes コンフィギュレーション モード コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

log-adjacency-changes

no log-adjacency-changes

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト

このコマンドは、デフォルトでイネーブルにされています。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

log-adjacency-changes コマンドはデフォルトでオンになりますが、レポートされるのは up/down(full/down)イベントだけです。

IS-IS ネイバーの状態変更時にルータが syslog メッセージを送信するように設定する例を示します。

switch(config)# router isis
switch(config-router)# log-adjacency-changes

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

log-adjacency-changes (OSPF)

Open Shortest Path First(OSPF)ネイバーの状態が変更された場合にルータが syslog メッセージを送信するように設定するには、 log-adjacency-changes コマンドを使用します。この機能をオフにするには、このコマンドの no 形式を使用します。

log adjacency changes [ detail ]

 
シンタックスの説明

detail

すべての隣接状態の変更を表示します(DOWN、INIT、2WAY、EXSTART、EXCHANGE、LOADING、FULL)。

 
デフォルト

OSPF ネイバーの状態が変更された場合、ルータはシステム メッセージを送信します。

 
コマンド モード

ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

OSPF ネイバー関係の状態の高レベルの変更を表示するには、 log-adjacency-changes コマンドを使用します。このコマンドは、デフォルトでオンになりますが、 detail キーワードを使用しない場合、レポートされるのは up/down(full/down)イベントだけです。

このコマンドには、Enterprise Services ライセンスが必要です。

OSPF ネイバーの状態変更時にルータがシステム メッセージを送信するように設定する例を示します。

switch(config)# router ospf 209
switch(config-router)# log-adjacency-changes detail

 

log-adjacency-changes (OSPFv3)

Open Shortest Path First version 3(OSPFv3)ネイバーの状態が変更された場合にルータがシステム メッセージを送信するように設定するには、 log-adjacency-changes コマンドを使用します。この機能をオフにするには、このコマンドの no 形式を使用します。

log adjacency changes [ detail ]

 
シンタックスの説明

detail

すべての隣接状態の変更を表示します(DOWN、INIT、2WAY、EXSTART、EXCHANGE、LOADING、FULL)。

 
デフォルト

OSPFv3 ネイバーの状態が変更された場合、ルータはシステム メッセージを送信します。

 
コマンド モード

ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

OSPFv3 ネイバー関係の状態の高レベルの変更を表示するには、 log-adjacency-changes コマンドを使用します。このコマンドは、デフォルトでオンになりますが、 detail キーワードを使用しない場合、レポートされるのは up/down(full/down)イベントだけです。

このコマンドには、Enterprise Services ライセンスが必要です。

OSPFv3 ネイバーの状態変更時にルータがシステム メッセージを送信するように設定する例を示します。

switch(config)# router ospfv3 209
switch(config-router)# log-adjacency-changes detail

 

log-neighbor-warnings

Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバー警告メッセージのロギングをイネーブルにするには、 log-neighbor-warnings コマンドを使用します。EIGRP ネイバーの警告メッセージのロギングをディセーブルにするには、このコマンドの no 形式を使用します。

log-neighbor-warnings [ seconds ]

no log-neighbor-warnings

 
シンタックスの説明

seconds

(任意)ネイバー警告メッセージの反復間隔。有効範囲は 1 ~ 65535 です。

 
コマンドのデフォルト

ネイバー警告メッセージはログに記録されます。

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(3)

このコマンドが追加されました。

 
使用上のガイドライン

ネイバー警告メッセージをイネーブルにして、ネイバー警告メッセージの反復間隔を設定するには、 log-neighbor-warnings コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次の例では、EIGRP プロセス 209 のネイバー警告メッセージがログに記録され、5 分(300 秒)間隔で警告メッセージが反復されます。

switch(config)# router eigrp 209
switch(config-router)# log-neighbor-warnings 30

 
関連コマンド

コマンド
説明

log-adjacency-changes

EIGRP 隣接状態変更のロギングをイネーブルにします。

low-memory exempt

下位メモリ シャットダウンから BGP ネイバーを除外するには、 low-memory exempt コマンドを使用します。BGP ネイバーを下位メモリ シャットダウンの対象にするには、このコマンドの no 形式を使用します。

low-memory exempt

no low-memory exempt

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

eBGP ピアによっては、重大なメモリ アラートでシャットダウンする場合があります。

 
コマンド モード

ネイバー コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

次に、下位メモリ シャットダウンからネイバーを除外する例を示します。

switch(config)# router bgp 1.0
switch(config-router)# neighbor 192.0.2.0/24 remote-as 1.5
switch(config-router-af)# low-memory exempt
 

 
関連コマンド

コマンド
説明

feature bgp

BGP をイネーブルにします。

lsp-gen-interval

LSP 生成の IS-IS スロットリングをカスタマイズするには、 lsp-gen-interval コンフィギュレーション モード コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

lsp-gen-interval { level-1 | level-2 } lsp-max-wait [ lsp-initial-wait lsp-second-wait ]

no lsp-gen-interval

 
シンタックスの説明

level-1

レベル 1 エリアのみに対してインターバルを適用します。

level-2

レベル 2 エリアのみに対してインターバルを適用します。

lsp-max-wait

生成される LSP の連続した 2 つのオカレンス間の最大間隔(秒)。範囲は 500 ~ 65535 です。デフォルトは 5 です。

lsp-initial-wait

(任意)初期 LSP 生成遅延(ミリ秒)。範囲は 50 ~ 65535 です。デフォルトは 50 です。

lsp-second-wait

最初と 2 番目の LSP 生成の間のホールドタイム(ミリ秒)。範囲は 50 ~ 65535 です。デフォルトは 50 です。

 
コマンドのデフォルト

デフォルトの設定は次のとおりです。

lsp-max-wait :500

lsp-initial-wait :50

lsp-second-wait :50

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドのデフォルト値を変更する際には、次のガイドラインに留意してください。

lsp-initial-wait 引数は、最初の LSP を生成する前の初期待機時間(ミリ秒)を表します。

lsp-second-wait 引数は、最初の LSP と次の LSP の生成間の待機時間(ミリ秒)を表します。

後続の各待機時間は、 lsp-max-wait 時間の指定値に到達するまで、直前の間隔の 2 倍になります。したがって、初回および 2 回目の間隔後に LSP の生成は減速されます。最大時間に到達すると、ネットワークが安定するまで、待機時間は最大値のままとなります。

ネットワークが安定し、 lsp-max-wait 時間 2 回のあいだトリガーがなければ、高速動作(最初の待機時間)に戻ります。

lsp-mtu コマンドは送信される後続の LSP との間の遅延時間(ミリ秒)を設定します(別のシステムで生成され、ローカル システムで転送される LSP を含みます)。

これらのコマンドを組み合せて使用することにより、LSP パケットの生成、送信、再送信のレートを制御できます。

LSP 生成時間の設定例を示します。

switch(config)# router isis
switch(config-router)# lsp-gen-interval 2 50 100

 
関連コマンド

コマンド
説明

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータ上の IS-IS をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

lsp-mtu

Cisco NX-OS ソフトウェアによって生成される Link-State Packet(LSP; リンクステート パケット)の最大サイズを設定するには、 lsp-mtu コンフィギュレーション モード コマンドを使用します。デフォルトの Maximum Transmission Unit(MTU; 最大伝送ユニット)に戻すには、このコマンドの no 形式を使用します。

lsp-mtu bytes

no lsp-mtu

 
シンタックスの説明

bytes

最大 LSP サイズ(バイト)。範囲は 128 ~ 4352 です。デフォルトは 1492 です。

 
コマンドのデフォルト

デフォルト MTU サイズは 1492 バイトです。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

各デバイスの LSP 数は約 250 に制限されているので、単一のルータで大量の情報が生成される場合は、LSP MTU を増やすことができます。実際には、この設定は必要とは限りません。

LSP MTU は、エリア内のリンクの最小 MTU より大きくできません。これは、LSP がエリア全体にフラッディングされるためです。

lsp-mtu コマンドで制限されるのは、そのルータで生成される LSP のサイズだけです。

最大 LSP サイズを 1500 バイトに設定する例を示します。

switch(config)# router isis

switch(config-router)# lsp-mtu 1500

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。