Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス リリース 5.x
D コマンド
D コマンド
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

D コマンド

dead-interval (OSPF virtual link)

dead-interval (OSPFv3 virtual link)

default-information originate (EIGRP)

default-information originate (IS-IS)

default-information originate (OSPF)

default-information originate (OSPFv3)

default-information originate (RIP)

default-metric (EIGRP)

default-metric (OSPF)

default-metric (OSPFv3)

default-metric (RIP)

delay minimum

delay

distance (EIGRP)

distance (IS-IS)

distance (OSPF)

distance (OSPFv3)

distance (RIP)

distribute

D コマンド

この章では、D で始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

dead-interval (OSPF virtual link)

ネイバーがダウンしていることをルータが宣言する前に、OSPF(Open Shortest Path First)仮想リンク上のネイバーから少なくとも 1 つの hello パケットを受信する必要がある間隔を設定するには、 dead interval コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

dead-interval seconds

no dead-interval

 
シンタックスの説明

seconds

ルータがネイバーから少なくとも 1 つの hello パケットを受信する必要があるか、またはそのネイバーがピア リストから削除され、ルーティングに参加しない間隔(秒単位)。有効範囲は 1 ~ 65535 です。値は仮想リンク上のすべてのノードで同じである必要があります。

 
デフォルト

seconds のデフォルト値は、 hello-interval コマンドによって設定された間隔の 4 倍です。

 
コマンド モード

仮想リンク コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

dead interval コマンドは、仮想リンク コンフィギュレーション モードで、OSPF hello パケット内でアドバタイズするデッド インターバルを設定するために使用します。この値は、仮想リンク上のすべてのネットワーキング デバイスで同じである必要があります。

より短いデッド間隔( seconds )を設定することにより、ダウンしているネイバーを早く検出し、収束を改善することができます。デッド間隔を短くすると、動作の遅いネイバーを誤ってダウンしていると宣言することにより、仮想リンクが不安定になる可能性があります。

show ip ospf virtual-links コマンドを使用し、デッド間隔を確認します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPF のデッド間隔を 20 秒に設定する例を示します。

switch(config)# ospf 201
switch(config-router)# area 99 virtual-link 192.0.2.4
switch(config-router-vlink)# dead-interval 20
 

 
関連コマンド

コマンド
説明

hello-interval(OSPF 仮想リンク)

Cisco NX-OS が仮想リンク上で送信する hello パケット間の間隔

show ip ospf virtual-link

仮想リンクの OSPF 関連の情報を表示します。

dead-interval (OSPFv3 virtual link)

ネイバーがダウンしていることをルータが宣言する前に、OSPFv3(Open Shortest Path First version 3)仮想リンク上のネイバーから少なくとも 1 つの hello パケットを受信する必要がある間隔を設定するには、 dead interval コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

dead-interval seconds

no dead-interval

 
シンタックスの説明

seconds

ルータがネイバーから少なくとも 1 つの hello パケットを受信する必要があるか、またはそのネイバーがピア リストから削除され、ルーティングに参加しない間隔(秒単位)。有効範囲は 1 ~ 65535 です。値は仮想リンク上のすべてのノードで同じである必要があります。

 
デフォルト

seconds のデフォルト値は、 hello-interval コマンドによって設定された間隔の 4 倍です。

 
コマンド モード

仮想リンク コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

dead interval コマンドは、仮想リンク コンフィギュレーション モードで、OSPFv3 hello パケット内でアドバタイズするデッド インターバルを設定するために使用します。この値は、仮想リンク上のすべてのネットワーキング デバイスで同じである必要があります。

より短いデッド間隔( seconds )を設定することにより、ダウンしているネイバーを早く検出し、収束を改善することができます。デッド間隔を短くすると、動作の遅いネイバーを誤ってダウンしていると宣言することにより、仮想リンクが不安定になる可能性があります。

show ospfv3 virtual-links コマンドを使用し、デッド間隔を確認します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3 のデッド間隔を 20 秒に設定する例を示します。

switch(config)# ospfv3 201
switch(config-router)# area 99 virtual-link 192.0.2.4
switch(config-router-vlink)# dead-interval 20
 

 
関連コマンド

コマンド
説明

hello-interval(OSPFv3 仮想リンク)

Cisco NX-OS が仮想リンク上で送信する hello パケット間の間隔

show ospfv3 virtual-link

仮想リンクの OSPFv3 関連の情報を表示します。

default-information originate (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)にデフォルト ルートを生成するには、該当するコンフィギュレーション モードで default-information originate コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

default-information originate [ always ] [ route-map map-name ]

no default-information originate

 
シンタックスの説明

always

(任意)ルートが EIGRP ルーティング情報ベースにない場合、デフォルト ルートを生成します。

route-map map-name

(任意)ルートがルート マップによって許可されている場合にのみデフォルト ルートを生成します。マップ名は、英数字で最大 63 文字のストリングです。

 
デフォルト

ディセーブル

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

次に、条件ルート マップに合格したすべてのルートに対して、デフォルト ルート(0.0.0.0/0)を生成する例を示します。

switch(config)# router eigrp 201
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# default-information originate route-map Condition
 

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ コンフィギュレーション モードに入ります。

default-metric

EIGRP に再配布されたルートにメトリックを設定します。

redistribute

ルートをほかのルーティング プロトコルから EIGRP に再配布します。

default-information originate (IS-IS)

デフォルト ルートの生成を制御するには、 default-information originate コマンドを使用します。

default-information originate [ always ] [ route-map name ]

 
シンタックスの説明

always

デフォルト ルートを常にアドバタイズします。

route-map name

デフォルト ルートを通知するルーティング ルールのルート マップの名前を指定します。名前は最大 63 文字です。

 
コマンドのデフォルト

デフォルト ルートは 、Intermediate System-to-Intermediate System Intradomain Routing Protocol(IS-IS)ルーティング ドメインに再配布されません。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

デフォルト ルートを IS-IS ルーティング ドメインに強制的に配置することができます。特別に IS-IS ルーティング ドメインへのルートの再配布を設定すると、デフォルトで、デフォルト ルートが IS-IS ルーティング ドメインに再配布されません。 default-information originate route-map コマンドを使用すると、IS-IS にデフォルト ルートが生成され、ルート マップで制御できます。ルート マップを使用し、デフォルト ルートが通知されるレベルを識別できます。また、ルート マップによって設定できるほかのフィルタリング オプションを指定できます。ルート マップを使用することにより、ルータのルーティング テーブル内でのほかのルータの存在に応じて、デフォルト ルートを条件付きでアドバタイズできます。

次に、デフォルト ルートを常にアドバタイズする例を示します。

switch(config)# router isis TEST1
switch(config-router)# default-information originate always
switch(config-router)#
 

次に、デフォルト ルートを条件付きでアドバタイズするルート マップを指定する例を示します。

switch(config)# router isis TEST1
switch(config-router)# default-information originate route-map CORE1
switch(config-router)#

 
関連コマンド

コマンド
説明

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータ上の IS-IS をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

default-information originate (OSPF)

OSPF ルーティング ドメインにデフォルト外部ルートを生成するには、default-information originate コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

default-information originate [ always ] [ route-map map-name ]

no default-information originate [ always ] [ route-map map-name ]

 
シンタックスの説明

always

(任意)ルート テーブルにデフォルト ルートがあるかどうかに関係なく、常にデフォルト ルートをアドバタイズするように指定します。

route-map map-name

(任意)ルート マップが満たされていない場合に、デフォルト ルートをアドバタイズするように指定します。 map-name 引数は、63 文字以下の任意の英数字文字列にできます。

 
デフォルト

ルートがルート テーブルにある場合に、デフォルト ルートをアドバタイズします。

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

default-information originate コマンドを使用し、再配布されたルートにデフォルト ルートを割り当てます。 redistribute コマンドを使用し、ルートを OSPF ルーティング ドメインに再配布すると、Cisco NX-OS は自動的に Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)になります。ただし、デフォルトでは、ASBR はデフォルト ルートを OSPF ルーティング ドメインに生成しません。

route-map キーワードを使用し、Cisco NX-OS がルート マップに合格したルートにのみデフォルト ルートを生成するように、再配布されたルートをフィルタ処理します。 always キーワードを使用し、ルート テーブルにデフォルト ルートがあるかどうかに関係なく、デフォルト ルートを生成します。


default-information originate コマンドは、オプションのルート マップ内の match ステートメントを無視します。


このコマンドには、Enterprise Services ライセンスが必要です。

次に、Enhanced IGRP(EIGRP)の OSPF ルーティング ドメインに再配布されるデフォルト ルートを設定する例を示します。

switch(config)# router ospf 109
switch(config-router)# redistribute eigrp 108 route-map EigrpPolicy
switch(config-router)# default-information originate always

 
関連コマンド

コマンド
説明

redistribute(OSPF)

ルートを 1 つのルーティング ドメインから OSPF に再配布します。

route-map

ルートのフィルタ ポリシーを定義します。

default-information originate (OSPFv3)

OSPFv3 ルーティング ドメインにデフォルト外部ルートを生成するには、default-information originate コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

default-information originate [ always ] [ route-map map-name ]

no default-information originate [ always ] [ route-map map-name ]

 
シンタックスの説明

always

(任意)ルート テーブルにデフォルト ルートがあるかどうかに関係なく、常にデフォルト ルートをアドバタイズするように指定します。

route-map map-name

(任意)ルート マップが満たされていない場合に、デフォルト ルートをアドバタイズするように指定します。 map-name 引数は、63 文字以下の任意の英数字文字列にできます。

 
デフォルト

ルートがルート テーブルにある場合に、デフォルト ルートをアドバタイズします。

 
コマンド モード

アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

default-information originate コマンドを使用し、再配布されたルートにデフォルト ルートを割り当てます。 redistribute コマンドを使用し、ルートを OSPFv3 ルーティング ドメインに再配布すると、Cisco NX-OS は自動的に Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)になります。ただし、デフォルトでは、ASBR はデフォルト ルートを OSPFv3 ルーティング ドメインに生成しません。

route-map キーワードを使用し、Cisco NX-OS がルート マップに合格したルートにのみデフォルト ルートを生成するように、再配布されたルートをフィルタ処理します。 always キーワードを使用し、ルート テーブルにデフォルト ルートがあるかどうかに関係なく、デフォルト ルートを生成します。


default-information originate コマンドは、オプションのルート マップ内の match ステートメントを無視します。


このコマンドには、Enterprise Services ライセンスが必要です。

次に、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)の OSPFv3 ルーティング ドメインに再配布されるデフォルト ルートを設定する例を示します。

switch(config)# router ospfv3 109
switch(config-router)# redistribute bgp 108 route-map bgpPolicy
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# default-information originate always

 
関連コマンド

コマンド
説明

redistribute(OSPFv3)

ルートを 1 つのルーティング ドメインから OSPFv3 に再配布します。

route-map

ルートのフィルタ ポリシーを定義します。

default-information originate (RIP)

デフォルト ルートを Routing Information Protocol(RIP)に生成するには、ルータ アドレスファミリ コンフィギュレーション モードで default-information originate コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

default-information originate [ always ] [ route-map map-name ]

no default-information originate

 
シンタックスの説明

always

(任意)ルートが RIP ルーティング情報ベースにない場合、デフォルト ルートを生成します。

route-map map-name

(任意)ルートがルート マップによって許可されている場合にのみデフォルト ルートを生成します。マップ名は、63 文字以下の任意の英数字文字列です。

 
デフォルト

このコマンドは、デフォルトではディセーブルです。

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドにはライセンスは必要ありません。

次に、条件ルート マップに合格したすべてのルートに対して、デフォルト ルート(0.0.0.0/0)を生成する例を示します。

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# default-information originate route-map Condition
 

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ コンフィギュレーション モードに入ります。

default-metric

RIP に再配布されたルートにメトリックを設定します。

redistribute

ルートをほかのルーティング プロトコルから RIP に再配布します。

default-metric (EIGRP)

EIGRP のメトリックを設定するには、default-metric コマンドを使用します。メトリック値を削除し、デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

default-metric bandwidth delay reliability loading mtu

no default-metric

 
シンタックスの説明

bandwidth

ルートの最小帯域幅(キロビット/秒)。範囲は 1 ~ 16777215 です。デフォルト値は 100000 です。

delay

ルートの遅延(数十マイクロ秒)。範囲は 1 ~ 16777215 です。デフォルト値は 100(マイクロ秒の 10 倍)です。

reliability

パケット送信が成功する可能性(0 ~ 255 の数字で表す)。255 という値は 100% の信頼性を意味し、0 はまったく信頼性がないことを意味します。デフォルト値は 255 です。

loading

ルートの有効な帯域幅(1 ~ 255 の数字で表す、255 は 100% のローディング)。デフォルト値は 1 です。

mtu

ルートの最大伝送ユニット(maximum transmission unit; MTU)のサイズ(バイト)。範囲は 1 ~ 4294967295 です。デフォルト値は 1492 です。

 
デフォルト

bandwidth:100000
delay:100(マイクロ秒の 10 倍)
reliability:255
loading:1
MTU:1500

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

4.0(3)

最大伝送ユニットのデフォルト値を 1492 に変更しました。

 
使用上のガイドライン

default-metric コマンドを redistribute コマンドと同時に使用し、すべての再配布されたルートに同じメトリック値を使用します。デフォルトのメトリックは、互換性のないメトリックをもつルートを再配布するという問題を解決するために役立ちます。外部メトリックが EIGRP メトリックに変換されない場合、デフォルト メトリックを使用することにより、常に妥当な代替メトリックを外部メトリックに提供し、再配布を続行することができます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、RIP メトリックを取得して、値が、bandwidth = 1000、delay = 100、reliability = 250、loading = 100、および MTU = 1500 の EIGRP メトリックに変換する例を示します。

switch(config)# router eigrp 1
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# redistribute rip 100 route-map FilterRIP
switch(config-router-af)# default-metric 1000 100 250 100 1500

 
関連コマンド

コマンド
説明

redistribute

ルートを 1 つのルーティング ドメインからほかのルーティング ドメインに再配布します。

default-metric (OSPF)

OSPF ルーティング プロトコルのデフォルト メトリック値を設定するには、default-metric コマンドを使用します。デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

default-metric metric-value

no default-metric metric-value

 
シンタックスの説明

metric-value

指定されたルーティング プロトコルに適したデフォルト メトリック値。範囲は 1 ~ 1677214 です。

 
デフォルト

再配布されたルート、接続されたルート、およびスタティック ルートのメトリックは 25 に設定されます。

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

default-metric コマンドは、 redistribute コマンドと組み合せて、スタティック ルートと直接接続されたルートを除く、すべての再配布されたルートに対して同じメトリック値を設定するために使用します。デフォルト メトリックは、互換性のないメトリックをもつルートを再配布するために役立ちます。外部ルート メトリックが OSPF メトリックに変換されない場合、常にデフォルト メトリックを使用して再配布を続行できるようにします。


default-metric コマンドは、OSPF に直接接続されたルートの再配布には適用されません。直接接続されたルートのデフォルト メトリックは、ルート マップを使用して変更します。


このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPF が Routing Information Protocol(RIP)と Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を再配布するように設定し、デフォルト メトリックを 10 に設定する例を示します。

switch(config)# router ospf 201
switch(config-router)# default-metric 10
switch(config-router)# redistribute rip 109 route-map FilterRip
switch(config-router)# redistribute bgp 4 route-map FilterBgp

 
関連コマンド

コマンド
説明

redistribute(OSPF)

ルートをほかのルーティング ドメインから OSPF に再配布します。

default-metric (OSPFv3)

OSPFv3 ルーティング プロトコルのデフォルト メトリック値を設定するには、default-metric コマンドを使用します。デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

default-metric metric-value

no default-metric metric-value

 
シンタックスの説明

metric-value

指定されたルーティング プロトコルに適したデフォルト メトリック値。範囲は 1 ~ 1677214 です。

 
デフォルト

再配布されたルート、接続されたルート、およびスタティック ルートのメトリックは 25 に設定されます。

 
コマンド モード

アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

default-metric コマンドは、 redistribute コマンドと組み合せて、直接接続されたルートを除く、すべての再配布されたルートに対して同じメトリック値を設定するために使用します。デフォルト メトリックは、互換性のないメトリックをもつルートを再配布するために役立ちます。外部ルート メトリックが OSPFv3 メトリックに変換されない場合、常にデフォルト メトリックを使用して再配布を続行できるようにします。


default-metric コマンドは、OSPF に直接接続されたルートの再配布には適用されません。直接接続されたルートのデフォルト メトリックは、ルート マップを使用して変更します。


このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3 が Routing Information Protocol(RIP)と Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を再配布するように設定し、デフォルト メトリックを 10 に設定する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# default-metric 10
switch(config-router-af)# exit
switch(config-router)# redistribute rip 109 route-map FilterRip
switch(config-router)# redistribute bgp 4 route-map FilterBgp

 
関連コマンド

コマンド
説明

redistribute(OSPFv3)

ルートをほかのルーティング ドメインから OSPFv3 に再配布します。

default-metric (RIP)

RIP 用のデフォルト メトリック値を設定するには、ルータ アドレスファミリ コンフィギュレーション モードで default-metric コマンドを使用します。デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

default-metric value

no default-metric [ value ]

 
シンタックスの説明

value

デフォルトのメトリック値。範囲は 1 ~ 15 です。

 
デフォルト

value :1

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

default-metric コマンドを redistribute コマンドと同時に使用し、すべての再配布されたルートに同じメトリック値を使用します。デフォルトのメトリックは、互換性のないメトリックをもつルートを再配布するという問題を解決するために役立ちます。外部メトリックが RIP メトリックに変換されない場合、デフォルト メトリックを使用することにより、常に妥当な代替メトリックを外部メトリックに提供し、再配布を続行することができます。

このコマンドにはライセンスは必要ありません。

次に、RIP を使用する OSPF(Open Shortest Path First)をアドバタイズし、OSPF から発生した 10 の RIP メトリックをもつルートを割り当てる例を示します。

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# default-metric 10
switch(config-router-af)# redistribute ospf 109 route-map FilterOSPF

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ コンフィギュレーション モードに入ります。

default-information originate

RIP に再配布されるルートのデフォルト ルートを生成します。

redistribute

ルートを 1 つのルーティング ドメインからほかのルーティング ドメインに再配布します。

delay minimum

リロード後またはインターフェイス起動後の Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)の開始を遅らせるには、 forwarder preempt コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

delay minimum [ min-delay] reload [reload-delay ]

no delay minimum [ min-delay] reload [reload-delay ]

 
シンタックスの説明

delay minimum min-delay

インターフェイス起動後の HSRP グループの開始を遅らせる最小時間(秒)。この時間は、その後発生するすべてのインターフェイス イベントに適用されます。デフォルトは 0 秒です。

reload reload-delay

ルータがリロードしたあとに HSRP グループの開始を遅らせる時間。この時間は、ルータ リロード後の最初のインターフェイス起動イベントにのみ適用されます。デフォルトは 0 秒です。

 
コマンドのデフォルト

HSRP 遅延のデフォルトは 0 秒です。

 
コマンド モード

インターフェイス モード

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

delay hsrp コマンドを使用し、リロード後またはインターフェイス起動後の HSRP の開始を遅らせます。この設定を使用すると、インターフェイスとルータはインターフェイス起動後に安定し、HSRP の状態が不安定になるのを防ぐために役立ちます。

このコマンドにはライセンスは必要ありません。

次に、3 秒の最小遅延と 10 秒のグループ開始遅延を設定する例を示します。

switch(config)# configure terminal
switch(config)# interface ethernet 0
switch(config)# ip address 172.16.6.5 255.255.255.0
switch(config)# hsrp 1
switch(config)# delay minimum 3 reload 10
switch(config)# ip 172.16.6.100

 
関連コマンド

コマンド
説明

feature hsrp

HSRP コンフィギュレーションをイネーブルにします。

delay

オブジェクト トラッキングのステート変更を遅らせるには、 delay コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

delay { up up-time [ down down-time] | down down-time [ up up-time ]}

no delay

 
シンタックスの説明

up up-time

アップ状態のオブジェクト追跡ステート変更を遅らせます。範囲は 0 ~ 180 秒です。

down down-time

ダウン状態のオブジェクト追跡ステート変更を遅らせます。範囲は 0 ~ 180 秒です。

 
コマンドのデフォルト

なし

 
コマンド モード

オブジェクト トラック モード

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.2(4))

このコマンドが追加されました。

 
使用上のガイドライン

delay コマンドは、オブジェクト トラッキングで追跡対象オブジェクトまたは追跡リストのアップまたはダウン ステート変更が検出されるタイミングを遅らせるために使用します。この遅延によって、ステート フラッピングが起こりにくくなります。

このコマンドにはライセンスは必要ありません。

次に、追跡対象オブジェクトの遅延タイマーを設定する例を示します。

switch(config)# configure terminal

switch(config)# track 1 interface ethernet 1/2 line-protocol

switch(config-track)# delay up 30 down 30
 

 
関連コマンド

コマンド
説明

track

追跡対象オブジェクトまたは追跡リストを設定します。

distance (EIGRP)

ノードにより良いルートを提供できる EIGRP で 2 つの管理ディスタンス(内部と外部)を使用できるようにするには、distance コマンドを使用します。デフォルトの設定にリセットするには、このコマンドの no 形式を使用します。

distance internal-distance external-distance

no distance

 
シンタックスの説明

internal-distance

EIGRP 内部ルートの管理ディスタンス。内部ルートは、同じ Autonomous System(AS; 自律システム)内のほかのエンティティから学習されるルートです。ディスタンスは、1 ~ 255 の値です。デフォルトは 90 です。

external-distance

EIGRP 外部ルートの管理ディスタンス。外部ルートは、ベストパスがこの AS の外部にある発信元から学習されるルートです。ディスタンスは、1 ~ 255 の値です。デフォルト値は 170 です。

 
デフォルト

internal-distance :90
external-distance :170

 
コマンド モード

アドレス ファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

管理ディスタンスは、個々のルータやルータ グループなどのルーティング情報源の信頼性格付けです。数値的には、管理ディスタンスは 0 ~ 255 の整数です。一般的に、値が高いほど信頼性のランク付けは低くなります。255 の管理ディスタンスは、ルーティング情報源がまったく信頼できないため、無視すべきであることを意味します。

ほかのプロトコルが外部 EIGRP を通して実際に学習されたルートよりもよいルートをノードに提供できることがわかっている場合、または一部の内部ルートが EIGRP によって優先されるべきである場合、 distance コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、すべての EIGRP 1 内部ルートの管理ディスタンスを 80 に、すべての EIGRP 外部ルートの管理ディスタンスを 130 に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router)# distance 80 130

 
関連コマンド

コマンド
説明

show ip eigrp

ルータで動作している EIGRP に関する情報を表示します。

distance (IS-IS)

ルーティング テーブルに挿入されるルートの管理ディスタンスを定義するには、 distance コンフィギュレーション モード コマンドを使用します。管理ディスタンスをデフォルトのディスタンス定義に戻すには、このコマンドの no 形式を使用します。

distance value

no distance

 
シンタックスの説明

value

管理ディスタンス。範囲は 1 ~ 255 です。デフォルトは 115 です。

 
コマンドのデフォルト

デフォルト ルートは 、Intermediate System-to-Intermediate System Intradomain Routing Protocol(IS-IS)ルーティング ドメインに再配布されません。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

管理ディスタンスは、個々のルータやルータ グループなどのルーティング情報源の信頼性格付けです。数値的には、管理ディスタンスは 0 ~ 255 の整数です。一般的に、値が高いほど信頼性のランク付けは低くなります。255 の管理ディスタンスは、ルーティング情報源がまったく信頼できないため、無視すべきであることを意味します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、管理ディスタンスを 90 に設定する例を示します。

switch(config)# router isis TEST1
switch(config-router)# distance 90
 

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

net

IS-IS プロセスの Network Entity Title(NET)を指定します。

router isis

IS-IS をイネーブルにします。

distance (OSPF)

OSPF ルートの管理ディスタンスを定義するには、 distance コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

distance distance

no distance

 
シンタックスの説明

distance

この OSPF プロセスに対してローカルであるすべてのルートの管理ディスタンス。範囲は 1 ~ 255 です。

 
デフォルト

110

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

distance コマンドを使用し、ルートのグループ全体にディスタンスを設定します。複数のルーティング プロトコルを設定し、その中から 1 つのルートのセットを選択したい場合に、 distance コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、ディスタンスを 200 に設定する(ルートの信頼性が低くなる)例を示します。

switch(config)# router ospf 1
switch(config-router)# distance 200
switch(config-router)# router ospf 2
switch(config-router)# distance 20

distance (OSPFv3)

OSPFv3 ルートの管理ディスタンスを定義するには、 distance コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

distance distance

no distance

 
シンタックスの説明

distance

この OSPFv3 プロセスに対してローカルであるすべてのルートの管理ディスタンス。範囲は 1 ~ 255 です。

 
デフォルト

110

 
コマンド モード

アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

distance コマンドを使用し、ルートのグループ全体にディスタンスを設定します。複数のルーティング プロトコルを設定し、その中から 1 つのルートのセットを選択したい場合に、 distance コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、ディスタンスを 200 に設定する(ルートの信頼性が低くなる)例を示します。

switch(config)# router ospfv3 1
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# distance 200

distance (RIP)

RIP によって検出されたルートに割り当てられる管理ディスタンスを定義するには、ルータ アドレスファミリ コンフィギュレーション モードで distance コマンドを使用します。ディスタンスを削除し、システムをデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

distance admin-distance

no distance admin-distance

 
シンタックスの説明

admin-distance

RIP ルートに割り当てる管理ディスタンス。指定できる範囲は 0 ~ 255 です。

 
デフォルト

admin-distance :120

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

distance コマンドを使用し、ほかのプロトコル ルートに対する RIP ルートのプリファレンスを変更します。数値的には、管理ディスタンスは 0 ~ 255 の整数です。一般的に、値が高いほど信頼性のランク付けは低くなります。255 の管理ディスタンスは、ルーティング情報源がまったく信頼できないため、無視すべきであることを意味します。

表 1-1 に、デフォルト管理ディスタンスを示します。

 

表 1-1 ルーティング プロトコルのデフォルト管理ディスタンス

ルーティング プロトコル
管理ディスタンス値

接続されているインターフェイス

0

インターフェイス外部のスタティック ルート

0

ネクストホップへのスタティック ルート

1

EIGRP サマリー ルート

5

外部 BGP

20

内部 EIGRP

90

OSPF

110

IS-IS

115

RIP

120

外部 EIGRP

170

内部 BGP

200

不明

255

このコマンドにはライセンスは必要ありません。

次に、RIP の管理ディスタンスを設定する例を示します。

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# distance 85

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ コンフィギュレーション モードに入ります。

redistribute

ルートを 1 つのルーティング ドメインから RIP に再配布します。

distribute

特定の Intermediate System-to-Intermediate System Intradomain Routing Protocol(IS-IS)レベル間にルートを配布するには、 distribute コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

distribute { level-1 | level-2 } into { level-1 | level-2 } { all | route-map name }

 
シンタックスの説明

level-1

エリア間のルートをこの IS-IS インスタンスのレベル 1 に配布します。

level-2

エリア間のルートをこの IS-IS インスタンスのレベル 2 に配布します。

into

1 つのレベルからほかのレベルに指定します。

all

すべてのルート レベルを配布します。

route-map name

特定のルート マップの配布を阻止します。名前は、63 文字以下の任意の英数字文字列にできます。

 
コマンドのデフォルト

デフォルト ルートは、IS-IS ルーティング ドメインに配布されません。イネーブルの場合、IS-IS によってレベル 1 とレベル 2 の間でルートを配布できるようになり、最適のエリア間ルーティングを取得できます。

このコマンドには、Enterprise Services ライセンスが必要です。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

level-1 :IP アドレスをレベル 1 エリアに集約します。設定済みアドレスとマスク値を使用して、レベル 1 に再配布されたルートのみが集約されます。

level-2 :IP アドレスをレベル 2 エリアに集約します。設定済みアドレスとマスク値を使用して、レベル 1 ルーティングが学習したルートはレベル 2 バックボーンに集約されます。レベル 2 IS-IS に再配布されたルートも集約されます。

IS-IS では、すべてのエリアはスタブ エリアです。これは、バックボーン(レベル 2)からエリア(レベル 1)にルーティング情報がリークされないことを意味します。レベル 1 のみのルータは、エリア内にある最も近いレベル 1 とレベル 2 間のルータに対して、デフォルト ルーティングを使用します。このコマンドを使用すると、レベル 2 IP ルートをレベル 1 エリアに再配布できます。この再配布によって、レベル 1 のみのルータは、IP プレフィクスがエリアから出るためのベストパスを選択できるようになります。これは IP のみの機能であり、CLNS ルーティングはまだスタブ ルーティングです。

さらに制御とスケーラビリティを高めるために、配布リストまたはルート マップは、どのレベル 2 IP ルートをレベル 1 に再配布できるかを制御することができます。このコマンドを使用すると、大規模な IS-IS-IP ネットワークは、スケーラビリティを向上させるためにエリアを使用できます。

次に、レベル 1 ルートをレベル 2 ネットワークに配布する例を示します。

switch(config)# distribute level-1 into level-2