Cisco Nexus 7000 シリーズ NX-OS ユニキャスト ルーティング コマンド リファレンス リリース 5.x
A コマンド
A コマンド
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

A コマンド

address (VRRP)

address-family (BGP)

address-family (EIGRP)

address-family (IS-IS)

address-family (OSPFv3)

address-family (RIP)

advertise-map

advertisement-interval (VRRP)

aggregate-address

area authentication (OSPF)

area default-cost (OSPF)

area default-cost (OSPFv3)

area filter-list (OSPF)

area filter-list (OSPFv3)

area nssa (OSPF)

area nssa (OSPFv3)

area range (OSPF)

area range (OSPFv3)

area stub (OSPF)

area stub (OSPFv3)

area virtual-link (OSPF)

area virtual-link (OSPFv3)

authentication (GLBP)

authentication (HSRP)

authentication (OSPF virtual link)

authentication (VRRP)

authentication key-chain (EIGRP)

authentication key-chain (IS-IS)

authentication mode (EIGRP)

authentication-check

authentication-key (OSPF virtual link)

authentication-type

auto-cost (OSPF)

auto-cost (OSPFv3)

autonomous-system

A コマンド

この章では、A で始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

address (VRRP)

仮想ルータに 1 つのプライマリ IP アドレスを追加するには、 address コマンドを使用します。仮想ルータから IP アドレスを削除するには、このコマンドの no 形式を使用します。

address ip-address [secondary]

no address

 
シンタックスの説明

ip-address

仮想ルータのアドレス(IPv4)。このアドレスは、インターフェイス IP アドレスと同じサブネット内になければなりません。

secondary

(任意)セカンダリ仮想ルータのアドレスを指定します。

 
デフォルト

なし

 
コマンド モード

VRRP コンフィギュレーション モード

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

仮想ルータごとに 1 つずつの仮想ルータ IP アドレスを設定できます。設定された IP アドレスがインターフェイス IP アドレスと同じである場合、このスイッチは自動的にその IP アドレスを所有します。設定できるのは IPv4 アドレスのみです。

仮想ルータはパケットを転送するネクストホップ ルータとしての役割のみを目的としているため、マスター Virtual Router Redundancy Protocol(VRRP; 仮想ルータ冗長プロトコル)ルータは仮想ルータの IP アドレスに宛てられたパケットをドロップします。NX-OS デバイスでは、一部のアプリケーションは、仮想ルータの IP アドレスに宛てられたパケットを受け入れて配送することを要求します。仮想ルータ IPv4 アドレスに対して secondary オプションを使用することによって、VRRP ルータは、マスターの場合、これらのパケットを受け入れます。

このコマンドにはライセンスは必要ありません。

次に、仮想ルータの IP アドレスを設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# vrrp 250
switch(config-if-vrrp)# address 10.0.0.10
 

次に、1 つのコマンドを使用してすべての IP アドレス(プライマリおよびセカンダリ)を削除する例を示します。

switch(config-if-vrrp)# show run interface ethernet 9/10
version 4.0(1)
 
interface Ethernet9/10
vrrp 1
address 10.10.10.10
address 10.10.10.11 secondary
ip address 10.10.10.1/24
no shutdown
 
switch(config-if-vrrp)# no address
switch(config-if-vrrp)# sh run int e9/10
version 4.0(1)
 
interface Ethernet9/10
vrrp 1
ip address 10.10.10.1/24
no shutdown
 
switch(config-if-vrrp)#
 

 

 

 
関連コマンド

コマンド
説明

show vrrp

VRRP 設定情報を表示します。

clear vrrp

指定の仮想ルータの全ソフトウェア カウンタを消去します。

address-family (BGP)

アドレス ファミリ モードまたは VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)アドレス ファミリ モードを開始し、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)にサブモード コマンドを設定するには、 address-family コマンドを使用します。ルーティング プロトコルを設定するためのアドレス ファミリ サブモードをディセーブルにするには、このコマンドの no 形式を使用します。

address-family { ipv4 | ipv6 } { multicast | unicast }

no address-family { ipv4 | ipv6 } { multicast | unicast }

 
シンタックスの説明

ipv4

IPv4 アドレス ファミリを指定します。

ipv6

IPv6 アドレス ファミリを指定します。

multicast

マルチキャスト アドレス サポートを指定します。

unicast

ユニキャスト アドレス サポートを指定します。

 
コマンドのデフォルト

このコマンドには、デフォルト設定はありません。

 
コマンド モード

ルータ コンフィギュレーション
ネイバー コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

address-family コマンドを使用し、BGP ルーティングを設定中にさまざまなアドレス ファミリ コンフィギュレーション モードを開始します。ルータ コンフィギュレーション モードから address-family コマンドを入力する場合、アドレス ファミリをイネーブルにし、グローバル アドレス ファミリ コンフィギュレーション モードを開始します。プロンプトが switch(config-router-af)# に変わります。

経路再配布、アドレス集約、ロード バランシング、およびその他の高度な機能を使用している場合、アドレス ファミリを設定する必要があります。IPv4 ネイバー セッションは、IPv4 ユニキャストおよびマルチキャスト アドレス ファミリをサポートしています。IPv6 ネイバー セッションは、IPv6 ユニキャストおよびマルチキャスト アドレス ファミリをサポートしています。

アドレス ファミリ コンフィギュレーション モードから次のパラメータが使用できます。


) これは IPv4 マルチキャストまたはユニキャストと IPv6 マルチキャストまたはユニキャストに適用されます。


suppress-inactive :アクティブなルートのみをピアにアドバタイズします。追加情報については、 suppress-inactive コマンドを参照してください。

aggregate-address :BGP 集約プレフィクスを設定します。追加情報については、 aggregate-address コマンドを参照してください。

client-to-client reflection :クライアント間のルート リフレクションをイネーブルにします。ルート リフレクションを使用すると、BGP スピーカー(ルート リフレクタ)は IBGP で学習したルートを特定の IBGP ピアにアドバタイズできます。クライアント間のルート リフレクションをディセーブルにするには、このコマンドの no 形式を使用します。デフォルトで、イネーブルになっています。

dampening [ half-life | route-map name ] :ルート フラップ ダンプニングを設定します。オプションで、ペナルティ減少後の時間(分単位)を設定することができます。いったんルートにペナルティが割り当てられると、ペナルティは半減期(デフォルトでは 15 分)後に半分に減少します。ペナルティを小さくするプロセスは 5 秒ごとに発生します。デフォルトの半減期は 15 分です。範囲は 1 ~ 45 です。デフォルトで、ディセーブルになっています。

default-metric metric :再配布されたルートのデフォルトのフラップ メトリックを設定します。 default-metric コマンドは、 redistribute コマンドによって BGP に再配布されたルートにメトリック値を設定するために使用されます。デフォルトのメトリックは、互換性のないメトリックをもつルートを再配布するという問題を解決するために設定することができます。デフォルトのメトリックを割り当てることにより、再配布を行うことができます。この値は、ベストパス選択プロセス中に BGP によって評価される Multi Exit Discriminator(MED)です。MED は、ローカル Autonomous System(AS; 自律システム)および隣接 AS 内でのみ処理される非推移的な値です。デフォルトのメトリックは、受信したルートに MED 値がある場合には設定されません。範囲は 0 ~ 4294967295 です。


) イネーブルの場合、default-metric コマンドは、再配布された接続ルートに 0 のメトリック値を適用します。default-metric コマンドは、redistribute コマンドによって適用されたメトリック値を上書きしません。


default-originate :このピアに対してデフォルトを生成します。

distance ebgp-route ibgp-route local-route :ルーティング情報源(個々のルータまたはルータのグループなど)の信頼性のランク付けを設定します。BGP はネクストホップの解決に廃棄ルートを使用しません。一般的に、値が高いほど信頼性のランク付けは低くなります。255 の管理ディスタンスは、ルーティング情報源がまったく信頼できないため、無視すべきであることを意味します。ほかのプロトコルが外部 BGP(eBGP)によって実際に学習されたルートよりもよいルートをノードに提供できることがわかっている場合、または一部の内部ルートが BGP によって優先されるべきである場合、このコマンドを使用します。範囲は 1 ~ 255 です。デフォルトは、EBGP -- 20、IBGP--200 です。


注意 内部 BGP ルートの管理ディスタンスを変更することは危険と見なされており、推奨されません。不適切な設定により、ルーティング テーブルの不整合性やルーティングの中断が発生する可能性があります。

exit :現在のコマンド モードを終了します。

maximum-paths [ ibgp ] parallel-paths :パケットを転送する並列パスの数を設定します。 maximum-paths ibgp コマンドは、iBGP ピアリング セッションに等価コストまたは非等価コスト マルチパス ロード シェアリングを設定するために使用されます。ルートを BGP ルーティング テーブル内のマルチパスとして導入する場合、ルートはすでにあるほかのルートと同じネクストホップをもつことはできません。BGP ルーティング プロセスは、iBGP マルチパス ロード シェアリングが設定されている場合、iBGP ピアにベストパスをアドバタイズします。等価コスト ルートの場合、最下位のルータ ID をもつネイバーからのパスは、ベストパスとしてアドバタイズされます。等価コスト マルチパス ロード シェアリングを設定するには、すべてのパス アトリビュートを同じにする必要があります。パスのアトリビュートには、重み値、ローカル プリファレンス、AS パス(長さだけでなく、アトリビュート全体)、オリジン コード、MED、および Interior Gateway Protocol(IGP)のディスタンスが含まれます。オプションの ibgp キーワードを使用すると、IBGP パスにマルチパスを設定できます。デフォルトに戻すには、このコマンドの no 形式を使用します。範囲は 1 ~ 16 です。

network :アドバタイズする IP プレフィクスを設定します。追加情報については、 network コマンドを参照してください。

no :コマンドを無効にするか、またはデフォルト設定にします。

redistribute :他のプロトコルで取得したルートの BGP への再配布をイネーブルにします。再配布は IPv4 ルートと IPv6 ルートの両方でサポートされます。ほかのプロトコルによって学習したルートの BGP への再配布をディセーブルにするには、このコマンドの no 形式を使用します。

direct route-map name :直接接続されているルートを指定します。

eigrp AS-num route-map name :Enhanced IGP(EIGRP)ルートを指定します。範囲は 1 ~ 65535 です。

isis src-protocol route-map name :ISO IS-IS ルートを指定します。

ospf src-protocol route-map name :Open Shortest Path First(OSPF)ルートを指定します。

rip src-protocol route-map name :Routing Information Protocol(RIP)ルートを指定します。

static route-map name :スタティック ルートを指定します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、グローバル アドレス ファミリ コンフィギュレーション モードで IPv4 ユニキャスト アドレス ファミリにルータを配置する例を示します。

switch(config)# feature bgp
switch(config)# router bgp 64496
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)#
 

次に、ネイバー 192.0.2.1 の IPv4 マルチキャストをアクティベートし、ネイバー アドレス ファミリ コンフィギュレーション モードで IPv4 マルチキャスト アドレス ファミリにデバイスを配置する例を示します。

switch(config)# feature bgp
switch(config)# router bgp 64496
switch(config-router)# address-family ipv4 multicast
switch(config-router-af)# exit
switch(config-router)# neighbor 192.0.2.1
switch(config-router-neighbor)# remote-as 64496
switch(config-router-neighbor)# address-family ipv4 multicast
switch(config-router-neighbor-af)

 
関連コマンド

コマンド
説明

aggregate-address

BGP サマリー アドレスを設定します。

client-to-client

ルート リフレクションを設定します。

dampening

ルート フラップ ダンプニングを設定します。

default-metric(BGP)

BGP に再配布されたルートにデフォルト メトリックを設定します。

distance(BGP)

管理ディスタンスを設定します。

feature bgp

BGP の設定をイネーブルにします。

maximum-paths(BGP)

等コスト パスの最大数を設定します。

redistribute(BGP)

BGP に経路再配布を設定します。

timers(BGP)

BGP タイマーを設定します。

address-family (EIGRP)

Enhanced IGRP(EIGRP)にアドレス ファミリを設定するには、ルータ コンフィギュレーション モードで address-family コマンドを使用します。

address-family { ipv4 | ipv6 } unicast

 
シンタックスの説明

ipv4

IPv4 アドレス ファミリを指定します。

ipv6

IPv6 アドレス ファミリを指定します。

unicast

ユニキャスト アドレス サポートを指定します。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション
アドレス ファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

4.1(2)

ipv6 キーワードが追加されました。

 
使用上のガイドライン

このコマンドでは Enterprise ライセンスが必要です。

次に、EIGRP インスタンスに IPv4 ユニキャスト アドレス ファミリを設定する例を示します。

switch(config)# router eigrp 201
switch(config-router)# address-family ipv4 unicast
 

 
関連コマンド

コマンド
説明

default-information

デフォルト ルートの配布を制御します。

default-metric

EIGRP に再配布されるルートのデフォルト メトリックを設定します。

distance

管理ディスタンスを設定します。

maximum-paths

等コスト パスの最大数を設定します。

redistribute

EIGRP のルート再配布を設定します。

router-id

ルータ ID を設定します。

timers

EIGRP タイマーを設定します。

address-family (IS-IS)

アドレス ファミリ モードまたは VRF アドレス ファミリ モードに入って、Intermediate System-to-Intermediate System Intradomain Routing Protocol(IS-IS)にサブモード コマンドを設定するには、address-family コマンドを使用します。ルーティング プロトコルを設定するためのアドレス ファミリ サブモードをディセーブルにするには、このコマンドの no 形式を使用します。

address-family ipv4 unicast

no address-family ipv4 unicast

 
シンタックスの説明

ipv4

IPv4 アドレス ファミリを指定します。

unicast

ユニキャスト アドレス サポートを指定します。

 
コマンドのデフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

address-family コマンドを使用し、IS-IS ルーティングを設定中にさまざまなアドレス ファミリ コンフィギュレーション モードを開始します。コンフィギュレーション モードから address-family コマンドを入力する場合、アドレス ファミリをイネーブルにし、グローバル アドレス ファミリ コンフィギュレーション モードを開始します。プロンプトが switch(config-router-af)# に変わります。

経路再配布、アドレス集約、ロード バランシング、およびその他の高度な機能を使用している場合、アドレス ファミリを設定する必要があります。IPv4 ネイバー セッションは、IPv4 ユニキャスト アドレス ファミリをサポートしています。

アドレス ファミリ コンフィギュレーション モードから次のコンフィギュレーション モードが使用できます。

adjacency-check :IS-IS IPv4 プロトコル サポート整合性チェックを hello パケットに対して行うことができるようにします。hello パケットでの整合性チェックをディセーブルにするには、このコマンドの no 形式を使用します。デフォルトで、イネーブルになっています。IS-IS は hello パケットで整合性チェックを行い、同じプロトコルのセットをサポートするネイバー ルータでのみ隣接関係を形成します。

アドレス ファミリ コンフィギュレーション モードで no adjacency-check コマンドを使用して、IPv6 IS-IS の整合性チェックを抑制し、IPv4 IS-IS ルータが IPv4 IS-IS および IPv6 を実行するルータで隣接関係を形成できるようにします。IS-IS は IPv4 IS-IS のみを実行するルータと IPv6 のみを実行するルータの間に隣接関係を形成することはありません。

no adjacency-check コンフィギュレーション モード コマンドを使用して、IPv4 サブネット整合性チェックを抑制し、共通の IPv4 サブネットがあるかどうかに関係なく、ほかのルータで隣接関係を形成できるようにします。デフォルトでは、IS-IS はネイバーと一致する IPv4 アドレス サブネットの hello パケットでチェックを行います。


ヒント 特権 EXEC モードで debug isis adjacency packets コマンドを使用し、隣接関係エラーをチェックします。出力されたエラー メッセージは、ルータが隣接関係の確立に失敗している場所を示している可能性があります。


default-information originate [ always ] [ route-map name ]:デフォルト ルートの生成を制御します。

always :(任意)常にデフォルト ルートをアドバタイズします。

route-map name :(任意)デフォルト ルートを通知するルート マップの名前を指定します。

distance value :管理ディスタンスを指定します。デフォルトのディスタンスに戻すには、このコマンドの no 形式を使用します。255 の管理ディスタンスは、ルーティング情報源がまったく信頼できないため、無視すべきであることを意味します。範囲は 1 ~ 255 です。デフォルトは 115 です。

distribute { level-1 | level-2 } into { level-1 | level-2 } { all | route-map name }:ドメイン全体のプレフィクス配布をレベル間に設定します。

level-1 :エリア間のルートをこの IS-IS インスタンスのレベル 1 に配布します。

level-2 :エリア間のルートをこの IS-IS インスタンスのレベル 2 に配布します。

into :1 つのレベルからほかのレベルに指定します。

all :すべてのルート レベルを配布します。

route-map name :特定のルート マップの配布を阻止します。

exit :現在のコマンド モードを終了します。

no :コマンドを無効にするか、またはデフォルト設定にします。

redistribute protocol as-num [ . as-num ] [ route-map map-tag ]:ほかのルーティング プロトコルからの情報を IS-IS に再配布します。コンフィギュレーション ファイルから redistribute コマンドを削除し、デフォルト設定に戻すには、このコマンドの no 形式を使用します。デフォルトでは、ソフトウェアからルートが再配布されません。詳細については、 redistribute(IS-IS) コマンドを参照してください。

summary-address { ip-addr | ip-prefix / length | ipv6-addr | ipv6-prefix / length } level :IS-IS 集約アドレスを作成します。集約アドレスを削除するには、このコマンドの no 形式を使用します。詳細については、 summary-address コマンドを参照してください。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、アドレス ファミリ コンフィギュレーション モードでルータを配置し、IPv4 アドレス ファミリにユニキャスト アドレス プレフィクスを指定する例を示します。

switch(config)# router isis 100
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)#
 

次に、IS-IS に直接接続されたルートを再配布する例を示します。この例では、10.1.0.0 のみを IS-IS レベル 1 リンクステート PDU にアドバタイズします。

switch(config)# router isis 100
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# redistribute direct route-map core1
switch(config-router-af)# summary-address 10.1.0.0 255.255.0.0
 

次に、既存の IPv4 IS-IS ネットワークに IPv6 を導入する例を示します。すべてのネイバー ルータが IPv6 を使用するように設定されるまで、隣接したネイバー ルータからの hello パケットのチェックがディセーブルになるようにするには、 no adjacency-check コマンドを入力します。

switch(config)# router isis test2
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# no adjacency-check

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

address-family (OSPFv3)

Open Shortest Path First version 3(OSPFv3)プロトコルでアドレス ファミリ モードを開始するには、 address-family コマンドを使用します。

address-family ipv6 unicast

 
シンタックスの説明

ipv6

IPv6 アドレス ファミリを指定します。

unicast

ユニキャスト アドレス サポートを指定します。

 
デフォルト

このコマンドには、デフォルト設定はありません。

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3v3 インスタンスで IPv6 ユニキャスト アドレス ファミリを開始する例を示します。

switch(config)# router ospfv3v3 Enterprise
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)#
 

 
関連コマンド

コマンド
説明

default-information(OSPFv3)

デフォルト ルートの配布を制御します。

default-metric(OSPFv3)

OSPFv3 に再配布されたルートにデフォルト メトリックを設定します。

distance(OSPFv3)

管理ディスタンスを設定します。

maximum-paths(OSPFv3)

等コスト パスの最大数を設定します。

redistribute(OSPFv3)

OSPFv3 に経路再配布を設定します。

timers(OSPFv3)

OSPFv3 タイマーを設定します。

address-family (RIP)

Routing Information Protocol(RIP)にアドレス ファミリを設定するには、ルータ コンフィギュレーション モードで address-family コマンドを使用します。

address-family ipv4 unicast

 
シンタックスの説明

ipv4

IPv4 アドレス ファミリを指定します。

unicast

ユニキャスト アドレス サポートを指定します。

 
デフォルト

このコマンドには、デフォルト設定はありません。

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドにはライセンスは必要ありません。

次に、RIP インスタンスに IPv4 ユニキャスト アドレス ファミリを設定する例を示します。

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
 

 
関連コマンド

コマンド
説明

default-information

デフォルト ルートの配布を制御します。

default-metric

RIP に再配布されたルートにデフォルト メトリックを設定します。

distance

管理ディスタンスを設定します。

maximum-paths

等コスト パスの最大数を設定します。

redistribute

RIP に経路再配布を設定します。

timers

RIP タイマーを設定します。

advertise-map

BGP の条件付きアドバタイズメントを設定するには、 advertise-map コマンドを使用します。BGP 条件付きアドバタイズメントを削除するには、このコマンドの no 形式を使用します。

advertise-map adv-map { exist-map exist-rmap | non-exist-map nonexist-rmap }

 
シンタックスの説明

adv-map

BGP でルートが次のルート マップに渡される前に、ルートが通過すべき match ステートメントが含まれるルート マップ。adv-map は、大文字と小文字が区別される 63 文字以下の英数字文字列です。

exist-map exist-rmap

プレフィクス リストの match ステートメントが含まれるルート マップを指定します。BGP テーブル内のプレフィクスは、BGP でルートがアドバタイズされる前のプレフィクス リスト内のプレフィクスと一致する必要があります。exist-rmap は、大文字と小文字が区別される 63 文字以下の英数字文字列です。

non-exist-map nonexist-rmap

プレフィクス リストの match ステートメントが含まれるルート マップを指定します。BGP テーブル内のプレフィクスは、BGP でルートがアドバタイズされる前のプレフィクス リスト内のプレフィクスと一致する必要はありません。nonexist-rmap は、大文字と小文字が区別される 63 文字以下の英数字文字列です。

 
デフォルト

なし

 
コマンド モード

BGP ネイバー アドレスファミリ コマンド モード

サポートされるユーザ ロール

ネットワーク管理者
ネットワーク オペレータ
VDC 管理者
VDC オペレータ

 
コマンドの履歴

リリース
変更内容

4.2(1)

このコマンドが追加されました。

 
使用上のガイドライン

advertise-map コマンドは、選択されたルートを条件付きでアドバタイズするために使用します。BGP で条件付きでアドバタイズされるルートまたはプレフィクスは、 adv-map exist-map または nonexist-map の 2 つのルート マップで定義されます。 exist-map または nonexist-map で、BGP によって追跡されるプレフィクスを指定します。 adv-map は、条件が満たされたときに BGP から指定されたネイバーにアドバタイズされるプレフィクスを指定します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、BGP 条件付きアドバタイズメントを設定する例を示します。

switch# config t

switch(config)# router bgp 65536

switch(config-router)# neighbor 192.0.2.2 remote-as 65537

switch(config-router-neighbor)# address-family ipv4 unicast

switch(config-router-neighbor-af)# advertise-map advertise exist-map exist

switch(config-router-neighbor-af)# exit

switch(config-router-neighbor)# exit

switch(config-router)# exit

switch(config)# route-map advertise

switch(config-route-map)# match as-path pathList

switch(config-route-map)# exit

switch(config)# route-map exit

switch(config-route-map)# match ip address prefix-list plist

switch(config-route-map)# exit

switch(config)# ip prefix-list plist permit 209.165.201.0/27

 

 
関連コマンド

コマンド
説明

feature bgp

BGP をイネーブルにします。

advertisement-interval (VRRP)

同じグループ内のほかの Virtual Router Redundancy Protocol(VRRP; 仮想ルータ冗長プロトコル)ルータに送信されているアドバタイズメント パケット間で時間間隔を指定するには、 advertisement-interval コマンドを使用します。1 秒のデフォルト間隔値に戻すには、このコマンドの no 形式を使用します。

advertisement-interval seconds

no advertisement-interval

 
シンタックスの説明

seconds

送信されるアドバタイズメント フレーム間の秒数。IPv4 の場合、範囲は 1 ~ 255 秒です。

 
デフォルト

1 秒

 
コマンド モード

VRRP コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

VRRP アドバタイズメントは、仮想ルータ マスターのプライオリティと状態を伝達します。アドバタイズメントは IP パケットにカプセル化され、VRRP グループに割り当てられる IPv4 マルチキャスト アドレスに送信されます。

VRRP は、VRRP アドバタイズメント専用の Internet Assigned Numbers Authority(IANA; インターネット割り当て番号局)標準マルチキャスト アドレス(224.0.0.18)を使用します。このアドレス指定方式では、マルチキャストを処理する必要があるルータの数を最小限に抑え、テスト機器がセグメント上の VRRP パケットを正確に識別できるようにします。IANA で割り当てられた VRRP IP プロトコル番号は 112 です。

このコマンドにはライセンスは必要ありません。

次に、VRRP グループ 250 に 200 秒のアドバタイズメント間隔を指定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# vrrp 250
switch(config-if-vrrp)# advertisement-interval 200

 
関連コマンド

コマンド
説明

show vrrp

VRRP 設定情報を表示します。

clear vrrp

指定の仮想ルータの全ソフトウェア カウンタを消去します。

aggregate-address

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ルーティング テーブルにサマリー アドレスを作成するには、 aggregate-address コマンドを使用します。サマリー アドレスを削除するには、このコマンドの no 形式を使用します。

aggregate-address address/length [ advertise-map map-name ] [ as-set ] [ attribute-map map-name ] [ summary-only ] [ suppress-map map-name ]

no aggregate-address address/mask-length [ advertise-map map-name ] [ as-set ] [ attribute-map map-name ] [ summary-only ] [ suppress-map map-name ]

 
シンタックスの説明

address/length

集約 IP アドレスおよびマスクの長さ。 length の有効な値は、次のとおりです。

IPv4 アドレス:1 ~ 32

IPv6 アドレス:1 ~ 128

advertise-map map-name

(任意)特定のルートからアトリビュートの情報を選択するために使用するルート マップの名前を指定します。

as-set

(任意)寄与しているパスから Autonomous System(AS; 自律システム)のセット パス情報およびコミュニティ情報を生成します。

attribute-map map-name

(任意)特定のルートにアトリビュートの情報を設定するために使用するルート マップの名前を指定します。map-name は、英数字で最大 63 文字のストリングです。

summary-only

(任意)アップデートからのすべてのより具体的なルートをフィルタ処理します。

suppress-map map-name

(任意)より具体的なルートを条件付きでフィルタ処理するために使用するルート マップの名前を指定します。map-name は、英数字で最大 63 文字のストリングです。

 
デフォルト

アトミック 集約アトリビュートは、 as-set キーワードが指定されないかぎり、このコマンドによって集約ルートが作成されるときに自動的に設定されます。

 
コマンド モード

アドレスファミリ コンフィギュレーション
ネイバー アドレスファミリ コンフィギュレーション
ルータ BGP コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

集約ルートを BGP または mBGP に再配布するか、条件付きの集約ルーティング機能を使用することにより、BGP および mBGP に集約ルーティングを実装できます。

キーワードなしで aggregate-address コマンドを使用すると、指定された範囲内にあるより具体的な BGP または mBGP ルートが使用できる場合、BGP または mBGP ルーティング テーブルに集約エントリが作成されます (集約と一致するより長いプレフィクスが RIB 内に存在する必要があります)。集約ルートは、自律システムからのルートとしてアドバタイズされ、情報が消失している可能性があることを示すアトミック集約アトリビュートを設定します (アトミック集約アトリビュートは、 as-set キーワードを指定しないかぎりデフォルトで設定されます)。

as-set キーワードを使用すると、コマンドがこのキーワードなしで従う同じルールを使用する集約エントリが作成されますが、このルートにアドバタイズされるパスは、集約されているすべてのパス内に含まれるすべての要素で構成される AS_SET になります。このルートは集約されたルート変更に関する AS パス到着可能性情報として継続的に削除してアップデートする必要があるため、多くのパスを集約する際に aggregate-address コマンドのこの形式を使用しないでください。

summary-only キーワードを使用すると、集約ルート(192.*.*.* など)が作成されるだけでなく、すべてのネイバーへのより具体的なルートのアドバタイズメントが抑制されます。特定のネイバーへのアドバタイズメントのみを抑制したい場合、 neighbor distribute-list コマンドを使用できますが、慎重に使用すべきです。より具体的なルートがリークした場合、すべての BGP または mBGP ルータは、生成中の具体的でない集約よりもこのルートを優先します(最長一致ルーティングによる)。

suppress-map キーワードを使用すると、集約ルートは作成されますが、指定されたルートのアドバタイズメントが抑制されます。ルート マップの一致句を使用して、集約のより具体的な一部のルートを選択的に抑制し、ほかのルートを抑制しないでおくことができます。IP アクセス リストと AS パス アクセス リストの一致句がサポートされています。

advertise-map キーワードを使用すると、集約ルートの異なるコンポーネント(AS_SET やコミュニティなど)を構築するために使用する特定のルートが選択されます。集約のコンポーネントが別々の AS にあり、AS_SET で集約を作成して同じ AS の一部にアドバタイズしたい場合、 aggregate-address コマンドのこの形式は役に立ちます。AS_SET から特定の AS 番号を省略し、集約が受信ルータの BGP ループ検出メカニズムによってドロップされるのを防ぐことを忘れてはなりません。IP アクセス リストと AS パス アクセス リストの一致句がサポートされています。

attribute-map キーワードを使用すると、集約ルートのアトリビュートを変更できます。AS_SET を構成するルートの 1 つが community no-export アトリビュート(集約ルートがエクスポートされるのを防ぐ)などのアトリビュートで設定されている場合、 aggregate-address コマンドのこの形式は役に立ちます。アトリビュート マップ ルート マップを作成し、集約のアトリビュートを変更することができます。

このコマンドには、Enterprise Services ライセンスが必要です。

as-set の例

次に、集約 BGP アドレスがルータ コンフィギュレーション モードで作成される例を示します。このルートにアドバタイズされるパスは、集約中のすべてのパス内に含まれるすべての要素で構成される AS_SET になります。

switch(config)# router bgp 64496
switch(config-router)# aggregate-address 10.0.0.0 255.0.0.0 as-set

summary-only の例

次に、集約 BGP アドレスがアドレス ファミリ コンフィギュレーション モードで作成され、IP バージョン 4 アドレス ファミリの下にあるマルチキャスト データベース(SAFI)に適用される例を示します。 summary-only キーワードが設定されているため、アップデートからより具体的なルートがフィルタ処理されます。

switch(config)# router bgp 64496
switch(config-router)# address-family ipv4 multicast
switch(config-router-af)# aggregate-address 10.0.0.0 255.0.0.0 summary-only

条件付き集約の例

次に、MAP-ONE というルート マップが作成され、as-path アクセス リストで一致する例を示します。このルートにアドバタイズされるパスは、ルート マップで照合されるパスに含まれる要素で構成される AS_SET になります。

switch(config)# ip as-path access-list 1 deny ^1234_
switch(config)# ip as-path access-list 1 permit .*
switch(config)# !
switch(config)# route-map MAP-ONE
switch(config-route-map)# match ip as-path 1
switch(config-route-map)# exit
switch(config)# router bgp 64496
switch(config-router)# address-family ipv4
switch(config-router-af)# aggregate-address 10.0.0.0 255.0.0.0 as-set advertise-map MAP-ONE
switch(config-router-af)# end

 
関連コマンド

コマンド
説明

route-map map-name

ルート マップを作成します。

area authentication (OSPF)

OSPF エリアの認証をイネーブルにするには、 area authentication コマンドを使用します。エリアの認証を削除するには、このコマンドの no 形式を使用します。

area area-id authentication [ message-digest ]

no area area-id authentication [ message-digest ]

 
シンタックスの説明

area-id

認証をイネーブルにする OSPF エリアの識別子。正の整数値または IP アドレスを指定します。

message-digest

(任意) area-id 引数によって指定されたエリアで Message Digest 5(MD5)認証をイネーブルにします。

 
デフォルト

認証は使用されません。

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area authentication コマンドを使用し、OSPF エリア全体に認証モードを設定します。

認証タイプと認証パスワードは、エリア内のすべての OSPF デバイスで同じである必要があります。インターフェイス コンフィギュレーション モードで ip ospf authentication-key コマンドを使用し、このパスワードを指定します。

message-digest キーワードで MD5 認証をイネーブルにする場合、インターフェイス コンフィギュレーション モードで ip ospf message-digest-key コマンドを使用して、パスワードを設定する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPF ルーティング プロセス 201 のエリア 0 に認証を設定する例を示します。

switch(config)# router ospf 201
switch(config-router)# area 0 authentication message-digest
switch(config-router)# interface ethernet 1/1
switch(config-if)# ip ospf area 0
switch(config)-if# ip ospf message-digest-key 10 md5 0 adcdefgh
 

 
関連コマンド

コマンド
説明

ip ospf authentication-key

OSPF の簡易パスワード認証にパスワードを割り当てます。

ip ospf message-digest-key

OSPF MD5 認証にパスワードを割り当てます。

area default-cost (OSPF)

OSPF スタブまたは Not-So-Stubby Area(NSSA)に送信されるデフォルト サマリー ルートのコストを指定するには、 area default-cost コマンドを使用します。割り当てられたデフォルト ルートのコストを削除するには、このコマンドの no 形式を使用します。

area area-id default-cost cost

no area area-id default-cost cost

 
シンタックスの説明

area-id

デフォルト コストを設定したい OSPF エリアの識別情報。正の整数値または IP アドレスを指定します。

cost

スタブまたは NSSA で使用されるデフォルト サマリー ルートのコスト。範囲は 0 ~ 16777215 です。

 
デフォルト

サマリー ルートのコストは、サマリー ルートを生成した Area Border Router(ABR; エリア ボーダ ルータ)に基づいています。

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

スタブまたは NSSA に接続されている ABR で area default-cost コマンドを使用し、ABR によってスタブ エリアに生成されるサマリー デフォルト ルートにメトリックを設定します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、スタブ ネットワーク 192.0.2.0 に 20 のデフォルト コストを設定する例を示します。

switch(config)# router ospf 201
switch(config-router)# area 192.0.2.0 stub
switch(config-router)# area 192.0.2.0 default-cost 20

 
関連コマンド

コマンド
説明

area stub

エリアをスタブ エリアとして定義します。

area default-cost (OSPFv3)

OSPFv3 スタブまたは NSSA に送信されるデフォルト サマリー ルートのコストを指定するには、 area default-cost コマンドを使用します。割り当てられたデフォルト ルートのコストを削除するには、このコマンドの no 形式を使用します。

area area-id default-cost cost

no area area-id default-cost cost

 
シンタックスの説明

area-id

デフォルト コストを設定したい OSPFv3 エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

cost

スタブまたは NSSA で使用されるデフォルト サマリー ルートのコスト。範囲は 0 ~ 16777215 です。

 
デフォルト

サマリー ルートのコストは、サマリー ルートを生成した Area Border Router(ABR; エリア ボーダ ルータ)に基づいています。

 
コマンド モード

アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

スタブまたは NSSA に接続されている ABR で area default-cost コマンドを使用し、ABR によってスタブ エリアに生成されるサマリー デフォルト ルートにメトリックを設定します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、スタブ ネットワーク 33 に 20 のデフォルト コストを設定する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# area 33 stub
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# area 33 default-cost 20

 
関連コマンド

コマンド
説明

area stub

エリアをスタブ エリアとして定義します。

area filter-list (OSPF)

Area Border Router(ABR; エリア ボーダ ルータ)の OSPF(Open Shortest Path First)エリア間のタイプ 3 Link-State Advertisement(LSA; リンクステート アドバタイズメント)でアドバタイズされたプレフィクスをフィルタ処理するには、area filter-list コマンドを使用します。フィルタを変更するか、または取り消すには、このコマンドの no 形式を使用します。

area area-id filter-list route-map map-name { in | out}

no area area-id filter-list route-map map-name { in | out}

 
シンタックスの説明

area-id

フィルタリングを設定したい OSPF エリアの識別情報。正の整数値または IP アドレスを指定します。

route-map map-name

フィルタ ポリシーとして使用するルート マップの名前を指定します。 map-name 引数は、英数字で最大 63 文字の任意のストリングです。

in

このエリアに送信されるネットワークをフィルタ処理します。

out

このエリアから送信されるネットワークをフィルタ処理します。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area filter-list コマンドを使用し、タイプ 3 LSA をフィルタ処理します。 in キーワードでルート マップを適用すると、ルート マップは、ABR によってこのエリアに発生したすべてのタイプ 3 LSA(area range コマンドによってほかのエリアに発生したタイプ 3 LSA を含む)をフィルタ処理します。

out キーワードでルート マップを適用すると、ルート マップは、ABR によってほかのすべてのエリアにアドバタイズされるすべてのタイプ 3 LSA(このエリアで設定された area range コマンドによってローカルに発生するタイプ 3 LSA を含む)をフィルタ処理します。

Cisco NX-OS は、ルート マップ内のエントリと一致しないプレフィクスを黙示的に拒否します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、ほかのすべてのエリアからエリア 1 に送信されるプレフィクスをフィルタ処理する例を示します。

switch(config)# router ospf 202
switch(config-router)# area 1 filter-list route-map FilterExternal in

 
関連コマンド

コマンド
説明

area range

エリアの境界にあるルートを統合して集約します。

route-map

1 つのルーティング プロトコルからほかのルーティング プロトコルへのルートを再配布するか、またはポリシー ルーティングをイネーブルにするための条件を定義します。

area filter-list (OSPFv3)

Area Border Router(ABR; エリア ボーダ ルータ)の OSPFv3(Open Shortest Path First バージョン 3)エリア間のタイプ 3 Link-State Advertisement(LSA; リンクステート アドバタイズメント)でアドバタイズされたプレフィクスをフィルタ処理するには、area filter-list コマンドを使用します。フィルタを変更するか、または取り消すには、このコマンドの no 形式を使用します。

area area-id filter-list route-map map-name { in | out}

no area area-id filter-list route-map map-name { in | out}

 
シンタックスの説明

area-id

フィルタリングを設定したい OSPFv3 エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

route-map map-name

フィルタ ポリシーとして使用するルート マップの名前を指定します。 map-name 引数は、63 文字以下の任意の英数字文字列にできます。

in

このエリアに送信されるネットワークをフィルタ処理します。

out

このエリアから送信されるネットワークをフィルタ処理します。

 
デフォルト

なし

 
コマンド モード

アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area filter-list コマンドを使用し、タイプ 3 LSA をフィルタ処理します。 in キーワードでルート マップを適用すると、ルート マップは、ABR によってこのエリアに発生したすべてのタイプ 3 LSA(area range コマンドによってほかのエリアに発生したタイプ 3 LSA を含む)をフィルタ処理します。

out キーワードでルート マップを適用すると、ルート マップは、ABR によってほかのすべてのエリアにアドバタイズされるすべてのタイプ 3 LSA(このエリアで設定された area range コマンドによってローカルに発生するタイプ 3 LSA を含む)をフィルタ処理します。

Cisco NX-OS は、ルート マップ内のエントリと一致しないプレフィクスを黙示的に拒否します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、ほかのすべてのエリアからエリア 1 に送信されるプレフィクスをフィルタ処理する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# area 1 filter-list route-map FilterExternal in

 
関連コマンド

コマンド
説明

area range(OSPFv3)

エリアの境界にあるルートを統合して集約します。

route-map

1 つのルーティング プロトコルからほかのルーティング プロトコルへのルートを再配布するか、またはポリシー ルーティングをイネーブルにするための条件を定義します。

area nssa (OSPF)

エリアを OSPF(Open Shortest Path First)Not-So-Stubby Area(NSSA)として設定するには、 area nssa コマンドを使用します。NSSA エリアを削除するには、このコマンドの no 形式を使用します。

area area-id nssa [ default-information-originate [ route-map map-name ]] [ no-redistribution ] [ no-summary ] [ translate type7 [ always | never ] [ suppress-fa ]]

no area area-id nssa [ default-information-originate [ route-map map-name ]] [ no-redistribution ] [ no-summary ] [ translate type7 [ always | never ] [ suppress-fa ]]

 
シンタックスの説明

area-id

OSPF NSSA エリアの識別情報。正の整数値または IP アドレスを指定します。

default-information-
originate

(任意)タイプ 7 のデフォルトを NSSA エリアに生成します。このキーワードは、NSSA Area Border Router(ABR; エリア ボーダ ルータ)または NSSA Autonomous System Border Router(ASBR; 自律システム ボーダ ルータ)でのみ有効です。

route-map map-name

(任意)ルート マップに基づいて、タイプ 7 のデフォルト生成をフィルタ処理します。 map-name 引数は、63 文字以下の任意の英数字文字列にできます。

no-redistribution

(任意)再配布された Link-State Advertisement(LSA; リンクステート アドバタイズメント)がこの NSSA エリアに入るのを阻止します。ルータが NSSA ASBR および NSSA ABR の両方であり、 redistribute コマンドによってルートを通常のエリアにインポートしたいが、NSSA エリアにはインポートしたくない場合、このキーワードを使用します。

no-summary

(任意)エリアが NSSA エリアになることを許可しますが、エリアにサマリー ルートを導入させません。

translate type7

(任意)タイプ 7 LSA をタイプ 5 LSA に変換します。

always

(任意)常に LSA を変換します。

never

(任意)LSA を変換しません。

suppress-fa

(任意)変換された LSA 内の転送アドレスを抑制します。ABR はフォワーディング IPv4 アドレスとして 0.0.0.0 を使用します。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area nssa コマンドを使用し、OSPF AS に NSSA エリアを作成します。変換された LSA に転送アドレスの抑制を設定する前に、ネットワーク トポロジについて理解しておくことを推奨します。宛先の転送アドレスに到達するためのより良いパスが別に存在する場合は、最適なルーティングとは言えません。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、エリア 1 を NSSA エリアとして設定する例を示します。

switch(config)# router ospf 10
switch(config-router)# area 1 nssa
 

次に、エリア 1 を NSSA エリアとして設定し、タイプ 7 LSA をエリア 1 からタイプ 5 LSA に変換するが、タイプ 7 転送アドレスをタイプ 5 LSA に配置しない例を示します (OSPF は 0.0.0.0 を転送アドレスとしてタイプ 5 LSA に配置します)。

switch(config)# router ospf 2
switch(config-router)# area 1 nssa translate type7 suppress-fa
 

 
関連コマンド

コマンド
説明

redistribute

1 つのルーティング プロトコルから学習したルートをほかのルーティング プロトコル ドメインに再配布します。

area nssa (OSPFv3)

エリアを OSPFv3(Open Shortest Path First バージョン 3)Not-So-Stubby Area(NSSA)として設定するには、 area nssa コマンドを使用します。NSSA エリアを削除するには、このコマンドの no 形式を使用します。

area area-id nssa [ default-information-originate [ route-map map-name ]] [ no-redistribution ] [ no-summary ] [ translate type7 [ always | never ] [ suppress-fa ]]

no area area-id nssa [ default-information-originate [ route-map map-name ]] [ no-redistribution ] [ no-summary ] [ translate type7 [ always | never ] [ suppress-fa ]]

 
シンタックスの説明

area-id

OSPFv3 NSSA エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

default-information-
originate

(任意)タイプ 7 のデフォルトを NSSA エリアに生成します。このキーワードは、NSSA Area Border Router(ABR; エリア ボーダ ルータ)または NSSA Autonomous System Border Router(ASBR; 自律システム ボーダ ルータ)でのみ有効です。

route-map map-name

(任意)ルート マップに基づいて、タイプ 7 のデフォルト生成をフィルタ処理します。 map-name 引数は、63 文字以下の任意の英数字文字列にできます。

no-redistribution

(任意)再配布された Link-State Advertisement(LSA; リンクステート アドバタイズメント)がこの NSSA エリアに入るのを阻止します。ルータが NSSA ASBR および NSSA ABR の両方であり、 redistribute コマンドによってルートを通常のエリアにインポートしたいが、NSSA エリアにはインポートしたくない場合、このキーワードを使用します。

no-summary

(任意)エリアが NSSA エリアになることを許可しますが、エリアにサマリー ルートを導入させません。

translate type7

(任意)タイプ 7 LSA をタイプ 5 LSA に変換します。

always

(任意)常に LSA を変換します。

never

(任意)LSA を変換しません。

suppress-fa

(任意)変換された LSA 内の転送アドレスを抑制します。ABR はフォワーディング IPv4 アドレスとして 0.0.0.0 を使用します。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area nssa コマンドを使用し、OSPFv3 AS に NSSA エリアを作成します。変換された LSA に転送アドレスの抑制を設定する前に、ネットワーク トポロジについて理解しておくことを推奨します。宛先の転送アドレスに到達するためのより良いパスが別に存在する場合は、最適なルーティングとは言えません。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、エリア 1 を NSSA エリアとして設定する例を示します。

switch(config)# router ospfv3 10
switch(config-router)# area 1 nssa
 

次に、エリア 1 を NSSA エリアとして設定し、タイプ 7 LSA をエリア 1 からタイプ 5 LSA に変換するが、タイプ 7 転送アドレスをタイプ 5 LSA に配置しない例を示します (OSPFv3 は 0.0.0.0 を転送アドレスとしてタイプ 5 LSA に配置します)。

switch(config)# router ospfv3 2
switch(config-router)# area 1 nssa translate type7 suppress-fa
 

 
関連コマンド

コマンド
説明

redistribute(OSPFv3)

1 つのルーティング プロトコルから学習したルートをほかのルーティング プロトコル ドメインに再配布します。

area range (OSPF)

OSPF エリアの境界にあるルートを統合して集約するには、 area range コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

area area-id range ip-prefix [ not-advertise ]

no area area-id range ip-prefix [ not-advertise ]

 
シンタックスの説明

area-id

ルートを集約したい OSPF エリアの識別情報。正の整数値または IP アドレスを指定します。

ip-prefix

IP アドレス/サブネット マスクの長さ(A.B.C.D/LEN)として指定された IP プレフィクス

not-advertise

(任意)アドレス範囲ステータスを DoNotAdvertise に設定します。タイプ 3 集約 Link-State Advertisement(LSA; リンクステート アドバタイズメント)が抑制され、コンポーネント ネットワークはほかのネットワークから非表示のままです。

 
デフォルト

ディセーブル

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area range コマンドを Area Border Router(ABR; エリア ボーダ ルータ)でのみ使用し、エリアのルートを統合または集約します。ABR は 1 つのサマリー ルートがほかのエリアにアドバタイズされることを通知し、エリアの境界でルーティング情報を集約します。

複数の area range コマンドを設定することにより、OSPF が多くの異なるアドレス範囲のセットのアドレスを集約するように設定できます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、1 つのサマリー ルートが、ABR によってネットワーク 192.0.2.0 上のすべてのホストのほかのエリアにアドバタイズされるように設定する例を示します。

OSPFv3 エリアの境界にあるルートを統合して集約するには、switch(config-if)# interface ethernet 1/2
switch(config-if)# ip address 192.0.2.201 255.255.255.0
switch(config-if)# ip ospf area 201
switch(config-router)# area 0 range 192.0.2.0 255.255.0.0

area range (OSPFv3)

area range コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

area area-id range ipv6-prefix/length [ not-advertise ]

no area area-id range ivp6-prefix [ not-advertise ]

 
シンタックスの説明

area-id

ルートを集約したい OSPF エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

ipv6-prefix/length

IPv6 アドレス/長さ(A:B::C:D/LEN)として指定された IP プレフィクス。 length 引数の範囲は 1 ~ 127 です。

not-advertise

(任意)アドレス範囲ステータスを DoNotAdvertise に設定します。タイプ 3 集約 Link-State Advertisement(LSA; リンクステート アドバタイズメント)が抑制され、コンポーネント ネットワークはほかのネットワークから非表示のままです。

 
デフォルト

ディセーブル

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area range コマンドを Area Border Router(ABR; エリア ボーダ ルータ)でのみ使用し、エリアのルートを統合または集約します。ABR は 1 つのサマリー ルートがほかのエリアにアドバタイズされることを通知し、エリアの境界でルーティング情報を集約します。

複数の area range コマンドを設定することにより、OSPFv3 が多くの異なるアドレス範囲のセットのアドレスを集約するように設定できます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、1 つのサマリー ルートが、ABR によってネットワーク 2001:0DB8::/32 上のすべてのホストのほかのエリアにアドバタイズされるように設定する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# area 0 range 2001:0DB8::/32
 

area stub (OSPF)

エリアを OSPF(Open Shortest Path First)スタブ エリアとして定義するには、 area stub コマンドを使用します。エリアを削除するには、このコマンドの no 形式を使用します。

area area-id stub [ no-summary ]

no area area-id stub [no-summary]

 
シンタックスの説明

area-id

OSPF スタブ エリアの識別情報。正の整数値または IP アドレスを指定します。

no-summary

(任意)Area Border Router(ABR; エリア ボーダ ルータ)が要約リンク アドバタイズメントをスタブ エリアに送信するのを防ぎます。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area stub コマンドを使用し、スタブ エリアに接続されているすべてのデバイスを設定します。スタブ エリアに接続されている ABR で area default-cost コマンドを使用します。 area default-cost コマンドは、ABR によってスタブ エリアに生成されたサマリー デフォルト ルートにメトリックを提供します。

スタブ エリアに送信される Link-State Advertisement(LSA; リンクステート アドバタイズメント)の数をさらに減少させるために、ABR で no-summary キーワードを設定し、集約 LSA(タイプ 3 LSAs3)をスタブ エリアに送信するのを防ぐことができます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPF 209 にスタブ エリア 33 を作成する例を示します。

switch(config)# router ospf 201
switch(config-router)# area 33 stub

 
関連コマンド

コマンド
説明

area default-cost

スタブ エリアに送信されるデフォルト サマリー ルートのコストを指定します。

area stub (OSPFv3)

エリアを OSPFv3(Open Shortest Path First バージョン 3)スタブ エリアとして定義するには、 area stub コマンドを使用します。エリアを削除するには、このコマンドの no 形式を使用します。

area area-id stub [ no-summary ]

no area area-id stub [no-summary]

 
シンタックスの説明

area-id

OSPFv3 スタブ エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

no-summary

(任意)Area Border Router(ABR; エリア ボーダ ルータ)が要約リンク アドバタイズメントをスタブ エリアに送信するのを防ぎます。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area stub コマンドを使用し、スタブ エリアに接続されているすべてのデバイスを設定します。スタブ エリアに接続されている ABR で area default-cost コマンドを使用します。 area default-cost コマンドは、ABR によってスタブ エリアに生成されたサマリー デフォルト ルートにメトリックを提供します。

スタブ エリアに送信される Link-State Advertisement(LSA; リンクステート アドバタイズメント)の数をさらに減少させるために、ABR で no-summary キーワードを設定し、集約 LSA(タイプ 3 LSAs3)をスタブ エリアに送信するのを防ぐことができます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3 209 にスタブ エリア 33 を作成する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# area 33 stub

 
関連コマンド

コマンド
説明

area default-cost(OSPFv3)

スタブ エリアに送信されるデフォルト サマリー ルートのコストを指定します。

area virtual-link (OSPF)

OSPF 仮想リンクを定義するには、 area virtual-link コマンドを使用します。仮想リンクを削除するには、このコマンドの no 形式を使用します。

area area-id virtual-link router-id

no area area-id virtual-link router-id

 
シンタックスの説明

area-id

仮想リンクのトランジット エリアに割り当てられた OSPF エリアの識別情報。正の整数値または IP アドレスを指定します。

router-id

仮想リンク ネイバーに関連付けられたルータ ID。IP アドレスを指定します。ルータ ID は show ip ospf neighbors ディスプレイに表示されます。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area virtual-link コマンドを使用し、リモート エリアからバックボーン エリアへの仮想リンクを確立します。OSPF では、すべてのエリアはバックボーン エリアに接続している必要があります。バックボーンとの接続が失われた場合、仮想リンクを確立することにより修復できます。

area virtual-link コマンドを使用し、次のコマンドを使用できる仮想リンク コンフィギュレーション モードを開始します。

authentication [key-chain | message-digest | null]

authentication-key [0 | 3] key

dead-interval seconds

hello-interval seconds

message-digest-key key-id md5 key

retransmit-interval seconds

transmit-delay seconds

構文と使用方法の詳細については、各コマンドを参照してください。

仮想リンクの両側で、同じエリア ID および対応する仮想リンク ネイバー ルータ ID を設定する必要があります。ルータ ID を表示するには、任意のモードで show ip ospf neighbors コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、すべてのオプションのパラメータのデフォルト値で 2 つのデバイス(A と B)間に仮想リンクを確立する例を示します。

Device A:
switch(config)# router ospf 1
switch(config-router)# router-id 192.0.2.2
switch(config-router)# area 1 virtual-link 192.0.2.1
 
Device B:
switch(config# router ospf 209
switch(config-router)# router-id 192.0.2.1
switch(config-router)# area 1 virtual-link 192.0.2.2
 

 
関連コマンド

コマンド
説明

authentication(OSPF 仮想リンク)

OSPF 仮想リンクの認証をイネーブルにします。

authentication-key(OSPF 仮想リンク)

OSPF の簡易パスワード認証を使用しているネイバー ルータによって使用されるパスワードを割り当てます。

dead-interval(OSPF 仮想リンク)

OSPF 仮想リンクのデッド間隔を設定します。

hello-interval(OSPF 仮想リンク)

OSPF 仮想リンクの hello 間隔を設定します。

message-digest-key(仮想リンク)

OSPF 仮想リンクで OSPF Message Digest 5(MD5)認証をイネーブルにします。

retransmit-interval(OSPF 仮想リンク)

OSPF 仮想リンクの再送信間隔を設定します。

transmit-delay(OSPF 仮想リンク)

OSPF 仮想リンクの送信遅延を設定します。

area virtual-link (OSPFv3)

OSPFv3 仮想リンクを定義するには、 area virtual-link コマンドを使用します。仮想リンクを削除するには、このコマンドの no 形式を使用します。

area area-id virtual-link router-id

no area area-id virtual-link router-id

 
シンタックスの説明

area-id

仮想リンクのトランジット エリアに割り当てられた OSPFv3 エリアの識別情報。IP アドレスまたは番号(0 ~ 4294967295)のいずれかで指定します。

router-id

仮想リンク ネイバーに関連付けられたルータ ID。IP アドレスを指定します。ルータ ID は show ospfv3 neighbors ディスプレイに表示されます。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

area virtual-link コマンドを使用し、リモート エリアからバックボーン エリアへの仮想リンクを確立します。OSPFv3 では、すべてのエリアはバックボーン エリアに接続している必要があります。バックボーンとの接続が失われた場合、仮想リンクを確立することにより修復できます。

area virtual-link コマンドを使用し、次のコマンドを使用できる仮想リンク コンフィギュレーション モードを開始します。

dead-interval seconds

hello-interval seconds

retransmit-interval seconds

transmit-delay seconds

構文と使用方法の詳細については、各コマンドを参照してください。

仮想リンクの両側で、同じエリア ID および対応する仮想リンク ネイバー ルータ ID を設定する必要があります。ルータ ID を表示するには、任意のモードで show ospfv3 neighbors コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、すべてのオプションのパラメータのデフォルト値で 2 つのデバイス(A と B)間に仮想リンクを確立する例を示します。

Device A:
switch(config)# router ospfv3 1
switch(config-router)# router-id 192.0.2.2
switch(config-router)# area 1 virtual-link 192.0.2.1
 
Device B:
switch(config# router ospfv3 209
switch(config-router)# router-id 192.0.2.1
switch(config-router)# area 1 virtual-link 192.0.2.2
 

 
関連コマンド

コマンド
説明

dead-interval(OSPFv3 仮想リンク)

OSPFv3 仮想リンクのデッド間隔を設定します。

hello-interval(OSPFv3 仮想リンク)

OSPFv3 仮想リンクの hello 間隔を設定します。

retransmit-interval(OSPFv3 仮想リンク)

OSPFv3 仮想リンクの再送信間隔を設定します。

transmit-delay(OSPFv3 仮想リンク)

OSPFv3 仮想リンクの送信遅延を設定します。

authentication (GLBP)

Gateway Load Balancing Protocol(GLBP; ゲートウェイ ロード バランシング プロトコル)の認証を設定するには、 authentication コマンドを使用します。認証をディセーブルにするには、このコマンドの no 形式を使用します。

authentication { text string | md5 { key-string [ encrypted ] key | key-chain name-of-chain }}

no authentication { text string | md5 { key-string [ 0 | 7 ] key | key-chain name-of-chain }}

 
シンタックスの説明

text string

認証ストリングを指定します。範囲は 1 ~ 255 文字です。

md5

Message Digest 5(MD5)認証を指定します。

key-string key

MD5 認証の秘密キーを指定します。範囲は 1 ~ 255 文字です。少なくとも 16 文字を使用することを推奨します。

encrypted

(任意)暗号化キーを指定します。

key-chain name-of-chain

認証キーのグループを識別します。

 
デフォルト

GLBP メッセージの認証は発生しません。

 
コマンド モード

GLBP コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

相互運用を保証するには、同じ GLBP グループのメンバーであるすべてのゲートウェイに同じ認証方式を設定する必要があります。ゲートウェイは、誤った認証情報を含むすべての GLBP メッセージを無視します。

このコマンドにはライセンスは必要ありません。

次に、GLBP グループ 10 の認証ストリングとしてストリング xyz を設定する例を示します。

switch(config)# interface ethernet 1/1
switch(config-if)# glbp 10
switch(config-glbp)# authentication text stringxyz
 

次に、キー チェーンの AuthenticateGLBP を使用して、MD5 認証用の現在アクティブなキーとキー ID を取得するように GLBP を設定する例を示します。

switch(config)# interface ethernet1/1
switch(config-if)# glbp 2
switch(config-glbp)# authentication md5 key-chain AuthenticateGLBP
 

 
関連コマンド

コマンド
説明

glbp

GLBP グループを作成し、GLBP コンフィギュレーション モードを開始します。

ip(GLBP)

インターフェイス上で GLBP をイネーブルにします。

key chain

キー チェーンを作成します。

authentication (HSRP)

Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)の認証を設定するには、 authentication コマンドを使用します。認証をディセーブルにするには、このコマンドの no 形式を使用します。

authentication { text string | md5 { key-chain key-chain | key-string { 0 | 7 } text [ timeout seconds ]}}

no authentication { text string | md5 { key-chain key-chain | key-string { 0 | 7 } text [ timeout seconds ]}}

 
シンタックスの説明

text string

認証ストリングを指定します。範囲は 1 ~ 255 文字です。デフォルトの文字列は「cisco」です。

md5

Message Digest 5(MD5)認証を指定します。

key-chain key-chain

認証キーのグループを識別します。

key-string

MD5 認証の秘密キーを指定します。

0

クリア テキスト文字列を指定します。

7

暗号化文字列を指定します。

text

MD5 認証用の秘密キー。範囲は 1 ~ 255 文字です。少なくとも 16 文字を使用することを推奨します。

timeout seconds

(任意)認証タイムアウト値を指定します。範囲は 0 ~ 32767 です。

 
デフォルト

ディセーブル

 
コマンド モード

HSRP コンフィギュレーションまたは HSRP テンプレート モード

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

authentication text コマンドを使用し、誤って設定されたルータが参加する意図のない HSRP グループに参加するのを防ぎます。認証ストリングはすべての HSRP メッセージに暗号化されていない状態で送信されます。相互運用を保証するために、同じ認証ストリングを同じグループのすべてのルータに設定する必要があります。認証しない HSRP プロトコル パケットは無視されます。


注意 2 台のルータで同じ HSRP IP アドレスが設定されているが、異なる認証ストリングが設定されている場合、いずれのルータも重複を認識しません。

このコマンドにはライセンスは必要ありません。

次に、HSRP グループ 2 に認証ストリングを設定する例を示します。

switch# configure terminal
switch(config)# interface ethernet 0/1
switch(config-if)# ip address 10.0.0.1 255.255.255.0
switch(config-if)# hsrp 2
switch(config-if-hsrp)# priority 110
switch(config-if-hsrp)# preempt
switch(config-if-hsrp)# authentication text sanjose
switch(config-if-hsrp)# ip 10.0.0.3
switch(config-if-hsrp)# end

 
関連コマンド

コマンド
説明

feature hsrp

HSRP をイネーブルにし、HSRP コンフィギュレーション モードを開始します。

hsrp group

HSRP グループを作成します。

authentication (OSPF virtual link)

OSPF 仮想リンクの認証タイプを指定するには、authentication コマンドを使用します。仮想リンクの認証タイプを削除するには、このコマンドの no 形式を使用します。

authentication [ key-chain key-name | message-digest | null ]

no ip ospf authentication

 
シンタックスの説明

key-chain key-name

(任意)使用するキー チェーンを指定します。 key-name 引数は、英数字で最大 63 文字の任意のストリングです。

message-digest

(任意)メッセージ ダイジェスト認証を使用するように指定します。

null

(任意)認証を使用しないように指定します。エリアに設定されている場合、認証をディセーブルにします。

 
デフォルト

オプションのキーワードなしで認証を設定すると、デフォルトでパスワード認証になります。

 
コマンド モード

OSPF 仮想リンク コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

仮想リンク コンフィギュレーション モードで authentication コマンドを使用し、仮想リンクで使用する認証方式を設定します。 message-digest キーワードを使用して MD5 メッセージ ダイジェスト認証を設定し、 message-digest-key コマンドを使用してこの認証設定を完了します。 key-chain キーワードを使用してキー チェーンによるパスワード認証を設定し、key chain コマンドを使用してこの認証設定を完了します。キーワードなしで authentication コマンドを使用して仮想リンクのパスワードを設定し、 authentication-key コマンドを使用してこの認証設定を完了します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、メッセージ ダイジェスト認証をイネーブルにする例を示します。

switch(config)# router ospf 22
switch(config-router)# area 99 virtual-link 192.0.2.12
switch(config-router-vlink)# authentication message-digest
switch(config-router-vlink)# message-digest key 4 md5 0 abcd

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証をイネーブルにします。

authentication-key(OSPF 仮想リンク)

OSPF のパスワード認証を使用しているネイバー ルート用のパスワードを指定します。

key chain

認証キーを管理するためのキー チェーンを作成します。

message-digest-key(OSPF 仮想リンク)

OSPF Message Digest 5(MD5)認証をイネーブルにします。

authentication (VRRP)

Virtual Router Redundancy Protocol(VRRP; 仮想ルータ冗長プロトコル)の認証を設定するには、 authentication コマンドを使用します。認証をディセーブルにするには、このコマンドの no 形式を使用します。

authentication text password

no authentication

 
シンタックスの説明

text password

英数字で最大 8 文字の単純なテキスト パスワードを使用するように選択します。

 
デフォルト

認証は使用されません。

 
コマンド モード

VRRP コンフィギュレーション モード

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドにはライセンスは必要ありません。

次に、VRRP に Message Digest 5(MD5)認証を設定する例を示します。

switch# config t
switch(config)# interface ethernet 2/1
switch(config-if)# vrrp 250
switch(config-if-vrrp)# authentication text mypwasswd
 

 
関連コマンド

コマンド
説明

show vrrp

VRRP 設定情報を表示します。

clear vrrp

指定の仮想ルータの全ソフトウェア カウンタを消去します。

authentication key-chain (EIGRP)

EIGRP パケットの認証をイネーブルにし、インターフェイス上で使用できるキーのセットを指定するには、 authentication key-chain コマンドを使用します。認証を禁止するには、このコマンドの no 形式を使用します。

authentication key-chain name-of-chain

no authentication key-chain name-of-chain

 
シンタックスの説明

name-of-chain

有効なキー グループ

 
デフォルト

EIGRP パケットには認証は適用されません。

 
コマンド モード

ルータ コンフィギュレーション
アドレス ファミリ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(3)

このコマンドが追加されました。

 
使用上のガイドライン

VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)コンフィギュレーション モードで authentication mode コマンドを使用し、認証モードを設定します。インターフェイスに対する認証設定を完了するには、 key-chain コマンドを使用して、別途キー チェーンを設定する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

キーチェーン ツリーに属しているキーの受け入れと送信をインターフェイスに設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# vrf red
switch(config-router-vrf)# authentication key-chain trees

 
関連コマンド

コマンド
説明

authentication mode(EIGRP)

VRF で EIGRP の認証モードを設定します。

ip authentication key-chain eigrp

EIGRP の認証をイネーブルにして、インターフェイスに使用可能なキー セットを指定します。

key-chain

認証方式で使用可能なキー セットを作成します。

authentication key-chain (IS-IS)

Intermediate System-to-Intermediate System(IS-IS)の認証をイネーブルにするには、 authentication key-chain コンフィギュレーション モード コマンドを使用します。このような認証をディセーブルにするには、このコマンドの no 形式を使用します。

authentication key-chain auth-key { level-1 | level-2 }

no authentication key-chain auth-key { level-1 | level-2 }

 
シンタックスの説明

auth-key

認証キー チェーン

level-1

レベル 1 の Link State Packets(LSP; リンクステート パケット)、Complete Sequence Number Packet(CSNP)、および Partial Sequence Number Packet(PSNP)のみに認証キーを指定します。

level-2

レベル 2 の LSP、CSNP、および PSNP パケットのみに認証キーを指定します。

 
コマンドのデフォルト

ルータ レベルでは、IS-IS パケットにキー チェーン認証は適用されません。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

authentication key-chain コマンドにキー チェーンが設定されていない場合、キー チェーン認証は行われません。

キー チェーン認証は、クリア テキスト認証または MD5 認証に適用できます。モードは authentication mode コマンドで設定されます。

IS-IS に一度に適用できる認証キー チェーンは 1 つだけです。たとえば、別の authentication key-chain コマンドを設定すると、最初の認証キー チェーンは上書きされます。

isis authentication key-chain コマンドを使用することにより、個々の IS-IS インターフェイスに認証を指定できます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、IS-IS が site1 というキー チェーンに属しているキーを受け入れて送信するように設定する例を示します。

switch(config)# router isis real_secure_network
switch(config-router)# authentication key-chain site1 level-1

 
関連コマンド

コマンド
説明

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータ上の IS-IS をイネーブルにします。

isis authentication key-chain

個々の IS-IS インターフェイスの認証をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

authentication mode (EIGRP)

EIGRP パケットで使用する認証のタイプを指定するには、authentication mode コマンドを使用します。認証を削除するには、このコマンドの no 形式を使用します。

authentication mode md5

no authentication mode md5

 
シンタックスの説明

md5

Message Digest 5(MD5)認証を指定します。

 
デフォルト

なし

 
コマンド モード

ルータ コンフィギュレーション
アドレス ファミリ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスに使用される認証方式を MD5 に設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# vrf red
switch(config-router-vrf)# authentication mode md5

 
関連コマンド

コマンド
説明

authentication key-chain eigrp

EIGRP の認証をイネーブルにして、インターフェイスに使用可能なキー セットを指定します。

ip authentication mode eigrp

インターフェイスで EIGRP の認証モードを設定します。

key chain

認証方式で使用可能なキー セットを作成します。

authentication-check

Intermediate System-to-Intermediate System(IS-IS)インスタンスに対して、認証が送信中の(受信されていない)IS-IS パケットでのみ行われるように指定するには、 authentication-check コンフィギュレーション モード コマンドを使用します。ルータ レベルで認証が設定されている場合に、その認証が送信と受信のパケットに実行されるように IS-IS インスタンスを設定するには、このコマンドの no 形式を使用します。

authentication-check { level-1 | level-2 }

no authentication-check

 
シンタックスの説明

level-1

レベル 1 の送信パケットのみ(受信パケットは含まれない)に認証が実行されるように指定します。

level-2

レベル 2 の送信パケットのみ(受信パケットは含まれない)に認証が実行されるように指定します。

 
コマンドのデフォルト

認証がルータ レベルで設定されている場合、その認証が送信と受信の IS-IS パケットに適用されます。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

 
使用上のガイドライン

認証モードと認証キー チェーンを設定する前に、authentication-check コマンドを入力します。authentication-check コマンドを入力すると、認証が送信中のパケットでのみ行われ、受信中のパケットではチェックされない場合、ルータではキーが各ルータで設定されるためのより多くの時間が与えられます。通信しているすべてのルータに authentication-check コマンドを入力してから、各ルータに対する認証モードとキー チェーンをイネーブルにします。次に、 no authentication-check コマンドを入力し、コマンドをディセーブルにします。

このコマンドは、クリア テキスト認証または Message Digest 5(MD5)認証に適用できます。モードは authentication mode コマンドで設定されます。

isis authentication-check { level-1 | level-2 } インターフェイス コンフィギュレーション モード コマンドを使用することにより、個々の IS-IS インターフェイスに認証を指定できます。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、IS-IS レベル 1 パケットが送信中の(受信されていない)パケットでクリア テキスト認証を使用するように設定する例を示します。

switch(config)# router isis test1
switch(config-router)# authentication-check level-1
switch(config-router)# authentication key-chain site1 level-1
switch(config-router)#
 

 
関連コマンド

コマンド
説明

feature isis

ルータ上の IS-IS をイネーブルにします。

isis authentication-check

特定のインターフェイスから送信中の(受信されていない)IS-IS パケットで認証をイネーブルにします。

router isis

IS-IS をイネーブルにします。

authentication-key (OSPF virtual link)

OSPF 仮想リンクで使用されるパスワードを割り当てるには、authentication-key コマンドを使用します。過去に割り当てられた OSPF パスワードを削除するには、このコマンドの no 形式を使用します。

authentication-key [ 0 | 3 ] password

no authentication-key

 
シンタックスの説明

0

(任意)暗号化されていない認証キーを指定します。

3

(任意)トリプル DES 暗号化認証キーを指定します。

password

キーボードから入力可能な文字による最大 8 バイトの連続したストリング

 
デフォルト

非暗号化パスワード

 
コマンド モード

OSPF 仮想リンク コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

authentication-key コマンドを使用し、OSPF 仮想リンクでパスワード認証のパスワードを設定します。同じ仮想リンクにあるすべてのデバイスは、OSPF 情報を交換できるように同じパスワードをもっている必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、ストリング yourpass により認証キーをイネーブルにする例を示します。

switch(config)# router ospf 22
switch(config-router)# area 99 virtual-link 192.0.2.12
switch(config-router-vlink)# authentication
switch(config-router-vlink)# authentication-key yourpass

 
関連コマンド

コマンド
説明

authentication(仮想リンク)

OSPF 仮想リンクの認証をイネーブルにします。

authentication-type

Intermediate System-to-Intermediate System(IS-IS)インスタンスに、IS-IS パケットで使用する認証のタイプを指定するには、 authentication-type コンフィギュレーション モード コマンドを使用します。クリア テキスト認証に戻すには、このコマンドの no 形式を使用します。

authentication-type { cleartext | md5 } [ level-1 | level-2 ]

no authentication-type

 
シンタックスの説明

cleartext

クリア テキスト認証を指定します。

md5

Message Digest 5(MD5)認証を指定します。

level-1

レベル 1 の Link State Packets(LSP; リンクステート パケット)、Complete Sequence Number Packet(CSNP)、および Partial Sequence Number Packet(PSNP)パケットのみに対して、指定された認証をイネーブルにします。

level-2

レベル 2 の LSP、CSNP、および PSNP パケットのみに対して、指定された認証をイネーブルにします。

 
コマンドのデフォルト

このコマンドを使用しても、ルータ レベルでは、IS-IS パケットに認証は適用されません。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

level-1 level-2 のいずれのキーワードも入力しないと、そのモードが両方のレベルに適用されます。

authentication-type コマンドを使用することにより、認証のタイプとそのタイプが 1 つの IS-IS インターフェイスに対して(IS-IS インスタンス単位ではなく)適用されるレベルを指定できます。

isis authentication-type { cleartext | md5 } [ level-1 | level-2 ] インターフェイス コンフィギュレーション モード コマンドを使用することにより、個々の IS-IS インターフェイスに認証タイプを指定できます。

次に、MD5 認証がレベル 1 パケットで行われるように IS-IS インスタンスに設定する例を示します。

switch(config)# router isis TEST1
switch(config-router)# authentication-type md5 level-1
switch(config-router)#

 
関連コマンド

コマンド
説明

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータ上の IS-IS をイネーブルにします。

isis authentication-type

個々の IS-IS インターフェイスの認証タイプを指定します。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

auto-cost (OSPF)

OSPF(Open Shortest Path First)がインターフェイスのデフォルト メトリックを計算する方法を制御するには、 auto-cost コマンドを使用します。40 Gb/s のデフォルト基準帯域幅を割り当てるには、このコマンドの no 形式を使用します。

auto-cost reference-bandwidth bandwidth [Gbps | Mbps]

no auto-cost reference-bandwidth

 
シンタックスの説明

reference-bandwidth bandwidth

インターフェイスのデフォルト メトリックを計算するために使用する基準帯域幅を設定します。範囲は Gbps キーワードを使用するか MBps キーワードを使用するかによって異なります。

Gbps

(任意)レートを Gbps で指定します(帯域幅)。範囲は 1 ~ 4000 で、デフォルトは 40 です。

Mbps

(任意)レートを Mbps で指定します(帯域幅)。範囲は 1 ~ 4000000 で、デフォルトは 40000 です。

 
デフォルト

40 Gb/s。 Gpbs または Mbps キーワード を指定しない場合、帯域幅はデフォルトで Gb/s になります。

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

auto-cost コマンドを使用し、OSPF コスト メトリックの計算により使用される基準帯域幅を設定します。

ip ospf cost コマンドによって設定された値は、 auto-cost コマンドによって設定されたコストを上書きします。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPF インスタンス内のすべてのローカル インターフェイスに基準帯域幅を設定する例を示します。

switch(config)# router ospf 201
switch(config-router)# auto-cost reference-bandwidth 10

 
関連コマンド

コマンド
説明

ip ospf cost

インターフェイス上でパケットを送信するコストを明示的に指定します。

auto-cost (OSPFv3)

OSPFv3(Open Shortest Path First バージョン 3)がインターフェイスのデフォルト メトリックを計算する方法を制御するには、 auto-cost コマンドを使用します。40 Gb/s のデフォルト基準帯域幅を割り当てるには、このコマンドの no 形式を使用します。

auto-cost reference-bandwidth bandwidth [Gbps | Mbps]

no auto-cost reference-bandwidth

 
シンタックスの説明

reference-bandwidth bandwidth

インターフェイスのデフォルト メトリックを計算するために使用する基準帯域幅を設定します。範囲は Gbps キーワードを使用するか MBps キーワードを使用するかによって異なります。

Gbps

(任意)レートを Gbps で指定します(帯域幅)。範囲は 1 ~ 4000 で、デフォルトは 40 です。

Mbps

(任意)レートを Mbps で指定します(帯域幅)。範囲は 1 ~ 4000000 で、デフォルトは 40000 です。

 
デフォルト

40 Gb/s。 Gpbs または Mbps キーワード を指定しない場合、帯域幅はデフォルトで Gb/s になります。

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

auto-cost コマンドを使用し、OSPFv3 コスト メトリックの計算により使用される基準帯域幅を設定します。

ipv6 ospfv3 cost コマンドによって設定された値は、 auto-cost コマンドによって設定されたコストを上書きします。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、OSPFv3 インスタンス内のすべてのローカル インターフェイスに基準帯域幅を設定する例を示します。

switch(config)# router ospfv3 201
switch(config-router)# auto-cost reference-bandwidth 10

 
関連コマンド

コマンド
説明

ipv6 ospfv3 cost

インターフェイス上でパケットを送信するコストを明示的に指定します。

autonomous-system

EIGRP アドレス ファミリ用の自律システム番号を設定するには、 autonomous-system コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

autonomous-system as-number

no autonomous-system as-number

 
シンタックスの説明

as-number

Autonomous System(AS; 自律システム)番号。有効範囲は 1 ~ 65535 です。

 
デフォルト

なし

 
コマンド モード

アドレス ファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンドの履歴

リリース
変更内容

4.1(2)

このコマンドが追加されました。

 
使用上のガイドライン

autonomous-system コマンドは、アドレス ファミリ内のすべての EIGRP インスタンスに共通する AS 番号を設定するために使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

次に、EIGRP for IPv6 ユニキャスト用の AS 番号を設定する例を示します。

switch(config)# router eigrp 201
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# autonomous-system 64496

 
関連コマンド

コマンド
説明

address-family(EIGRP)

EIGRP のアドレス ファミリ コンフィギュレーション モードに入ります。