Cisco NX-OS Interfaces コマンド リファレンス Release 4.0
Cisco NX-OS インターフェイス コマンド
Cisco NX-OS インターフェイス コマンド
発行日;2012/01/23 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 740KB) | フィードバック

目次

Cisco NX-OS インターフェイス コマンド

bandwidth (interface)

carrier-delay

channel-group

clear counters interface port-channel

clear lacp counters

encapsulation dot1Q

feature interface-vlan

feature lacp

feature tunnel

interface loopback

interface port-channel

interface tunnel

interface vlan

lacp port-priority

lacp system-priority

medium

port-channel load-balance ethernet

show interface counters trunk

show interface port-channel

show interface port-channel counters

show interface switchport

show interface trunk

show lacp counters

show lacp interface

show lacp neighbor

show lacp port-channel

show lacp system-identifier

show port-channel compatibility-parameters

show port-channel database

show port-channel load-balance

show port-channel rbh-distribution

show port-channel summary

show port-channel traffic

show port-channel usage

show running-config interface port-channel

switchport

switchport access vlan

switchport host

switchport mode

switchport trunk allowed vlan

switchport trunk native vlan

system default switchport

tunnel destination

tunnel mode

tunnel path-mtu-discovery

tunnel source

tunnel ttl

vlan dot1q tag native

Cisco NX-OS インターフェイス コマンド

この章では、Cisco NX-OS インターフェイス コマンドについて説明します。

bandwidth (interface)

インターフェイスの継承帯域幅値および受信帯域幅値を設定するには、インターフェイス コンフィギュレーション モードで bandwidth コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

bandwidth { kbps | inherit [ kbps] }

no bandwidth { kbps | inherit [ kbps] }

 
シンタックスの説明

kbps

意図する帯域幅(キロビット/秒)。有効な値は 1 ~ 10000000 です。

inherit

(任意)サブインターフェイスがメイン インターフェイスの帯域幅を継承する方法など、継承する帯域幅を指定します。

 
デフォルト

1000000 kbps

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

bandwidth コマンドは、上位プロトコルに現在の帯域幅のみが通信するように情報パラメータを設定します。このコマンドでは、インターフェイスの実際の帯域幅を調整することはできません。


) これはルーティング パラメータのみです。物理インターフェイスには影響しません。


bandwidth inherit コマンドは、サブインターフェイスがメイン インターフェイスの帯域幅を継承する方法を制御します。

no bandwidth inherit コマンドを使用すると、設定された帯域幅に関係なく、すべてのサブインターフェイスがメイン インターフェイスのデフォルトの帯域幅を継承するようになります。サブインターフェイスに帯域幅が設定されていない状態で bandwidth inherit コマンドを使用した場合、すべてのサブインターフェイスがメイン インターフェイスの現在の帯域幅を継承します。メイン インターフェイスに新しい帯域幅を設定すると、すべてのサブインターフェイスでその新しい値が使用されます。

サブインターフェイスに帯域幅を設定せずに、メイン インターフェイスに bandwidth inherit コマンドを設定した場合、サブインターフェイスはその指定された帯域幅を継承します。

いずれの場合も、インターフェイスに明示的な帯域幅が設定されている場合、そのインターフェイスでは、帯域幅の継承設定が有効かどうかにかかわらず、その明示的な帯域幅が使用されます。

このコマンドにライセンスは不要です。

次に、設定されている帯域幅を継承するように、メイン インターフェイスのすべてのサブインターフェイスを設定する例を示します。

switch(config-if)# bandwidth inherit 30000
 

 
関連コマンド

コマンド
説明

show interface

インターフェイス構成情報を表示します。

carrier-delay

インターフェイスにキャリア遅延を設定するには、 carrier-delay コマンドを使用します。デフォルトのキャリア遅延値に戻すには、このコマンドの no 形式を使用します。

carrier-delay { sec | { msec value }}

no carrier-delay

 
シンタックスの説明

sec

遅延時間(秒)。値の範囲は 0 ~ 60 です。

value

遅延時間(ミリ秒)。値の範囲は 0 ~ 1000 です。

 
デフォルト

デフォルトは 2 秒または 50 ミリ秒です。

 
コマンド モード

Interface

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0(3)

このコマンドが導入されました。

 
使用上のガイドライン


) このコマンドを使用する前に、feature interface-vlan コマンドを使用して VLAN インターフェイス機能をイネーブルにしておく必要があります。


リンクがダウンし、キャリア遅延タイマーが切れる前に回復した場合、ダウン状態は効率的にフィルタリングされ、デバイス上の他のソフトウェアによってリンクダウン イベントの発生が認識されることはありません。キャリア遅延タイマーの時間を長くすると、検出されるリンクアップ イベントおよびリンクダウン イベントが少なくなります。キャリア遅延時間を 0 に設定すると、発生するリンクアップ イベントおよびリンクダウン イベントがすべて検出されます。


carrier-delay コマンドは、VLAN インターフェイス モードでのみサポートされます。他のインターフェイス モードでは、このコマンドはサポートされません。


ほとんどの環境では、キャリア遅延時間は短い方が望ましい状態です。選択する必要のある正確な値は、リンク停止の種類、およびそのリンクがネットワークで持続する予測時間によって決まります。データリンクが短時間の停止を受けやすい場合は(特に、IP ルーティングが収束するのに要する時間より停止時間の方が短い場合)、キャリア遅延の値を長く設定することで、短時間の停止を防止してルーティング テーブルで不要なチャーンが発生しないようにする必要があります。ただし、停止が長くなる傾向にある場合は、キャリア遅延時間を短く設定することで、停止がすぐに検出され、IP ルート収束がただちに開始および終了するようにします。

このコマンドにライセンスは不要です。

次に、VLAN 6 に対してキャリア遅延タイマーを 20 分に設定する例を示します。

switch(config)# interface vlan 6
switch(config-if)# carrier-delay 20
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface vlan

VLAN インターフェイスに関する情報を表示します。

channel-group

物理インターフェイスをポート チャネル グループに割り当てて設定するには、 channel-group コマンドを使用します。チャネル グループ設定をインターフェイスから削除するには、このコマンドの no 形式を使用します。

channel-group number [ force ] [ mode { active | on | passive }]

no channel-group [ number ]

 
シンタックスの説明

number

チャネル グループの数。設定可能な最大ポート チャネル数は VDC 全体で 192 であり、値の範囲は 1 ~ 4096 です。

force

インターフェイスをチャネル グループに加入させます。ただし、一部のパラメータは互換性がありません。互換性のあるパラメータおよび強制可能なパラメータについては、次の「使用上のガイドライン」を参照してください。

mode

インターフェイスのポート チャネル モードを指定します。

on

デフォルトのチャネル モードです。Link Aggregation Control Protocol(LACP)が実行されていないポート チャネルはすべて、このモードのままになっています。LACP をイネーブルにする前にチャネル モードを active または passive に変更しようとすると、エラー メッセージが返されます。
feature lacp コマンドを使用して LACP をグローバルでイネーブルにしてから、チャネル モードを active または passive に設定して、各チャネルの LACP をイネーブルにします。このモードのインターフェイスでは、LACP パケットの開始も応答も行われません。LACP が on 状態のインターフェイスとのネゴシエーションを試みた場合、LACP パケットは受信されず、そのインターフェイスとの個別リンクになります。したがって、チャネル グループへの加入は行われません。

デフォルト モードは on です。

active

LACP をイネーブルにするときに、指定のインターフェイスの LACP がイネーブルになります。インターフェイスはアクティブ ネゴシエーション状態です。ポートは、LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

passive

LACP をイネーブルにする場合、LACP デバイスが検出されたときにのみ LACP がイネーブルになります。インターフェイスはパッシブ ネゴシエーション状態です。ポートは、受信した LACP パケットには応答しますが、LACP ネゴシエーションは開始しません。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

操作中のインターフェイスが含まれるチャネル グループを作成し、特定のインターフェイスをそのチャネル グループに追加したりそのチャネル グループから削除したりするには、このコマンドを使用します。また、あるチャネル グループから別のチャネル グループにポートを移動する場合も、このコマンドを使用します。ポートの移動先となるチャネル グループを入力します。指定したポートは自動的に現在のチャネル グループから削除され、指定のチャネル グループに追加されます。

feature lacp コマンドを使用して LACP をグローバルでイネーブルにしてから、チャネル モードを active または passive に設定することによって、各チャネルの LACP をイネーブルにします。 on チャネル モードのポート チャネルは純粋なポート チャネルであり、最大 8 つのポートを集約できます。このポート チャネルでは LACP は実行されません。

既存のポート チャネルのモードを(そのポート チャネルで LACP が実行されていない場合はそのインターフェイスも)変更することはできません。したがって、チャネル モードは on のままとなります。変更しようとすると、エラー メッセージが返されます。

1 つのポート チャネル内のポートはすべて、同じ Virtual Device Context(VDC; 仮想デバイス コンテキスト)に配置されている必要があります。LACP がイネーブルになっている場合、この要件は、8 つのアクティブ ポートおよび 8 つのスタンバイ ポートに適用されます。ポート チャネルは、1 つの VDC で作成し(そのチャネルのすべてのポートが同じ VDC に存在)、別の VDC のポート チャネルと組ませることができます(この場合も、そのチャネルのすべてのポートがその VDC に存在している必要があります)。

ポート チャネルから物理インターフェイスを削除するには、このコマンドの no 形式を使用します。ポート チャネルから最後の物理インターフェイスを削除しても、そのポート チャネルは削除されません。ポート チャネルを完全に削除するには、この interface port-channel コマンドの no 形式を使用します。

互換性チェックに含まれる操作アトリビュートは次のとおりです。

ネットワーク層

(リンク)速度機能

速度設定

デュプレックス機能

デュプレックス設定

ポート モード

アクセス VLAN

トランク ネイティブ VLAN

タグ付き/タグなし

許可される VLAN のリスト

MTU サイズ

SPAN -- SPAN の送信元ポートおよび宛先ポートは不可

レイヤ 3 ポートではサブインターフェイスは不可

ストーム制御

フロー制御機能

フロー制御設定

Cisco NX-OS で使用される完全な互換性チェック リストを確認するには、 show port-channel compatibility-parameters コマンドを使用します。

チャネル モードが on に設定されているインターフェイスは、スタティックなポート チャネル(設定された集約プロトコルはなし)にのみ追加できます。また、チャネル モードが active または passive に設定されているインターフェイスは、LACP が実行されているポート チャネルにのみ追加できます。

これらのアトリビュートは、メンバー ポートごとに設定できます。互換性のないアトリビュートがメンバー ポートに設定された場合、Cisco NX-OS により、ポート チャネル内のそのポートは一時停止されます。

また、以下のパラメータが同じであれば、互換性のないパラメータを持つポートを強制的にポート チャネルに加入させることもできます。

(リンク)速度機能

速度設定

デュプレックス機能

デュプレックス設定

フロー制御機能

フロー制御設定

インターフェイスがポート チャネルに加入すると、個々のパラメータの一部が削除され、次のようなポート チャネルの値に置き換えられます。

帯域幅

遅延

Extended Authentication Protocol over UDP

VRF

IP アドレス(v4 および v6)

MAC アドレス

スパニング ツリー プロトコル

NAC

サービス ポリシー

Quality of Service(QoS; サービス品質)

ACL

以下に示すインターフェイス パラメータの多くは、インターフェイスがポート チャネルに加入および脱退しても影響を受けません。

ビーコン

説明

CDP

LACP ポート プライオリティ

デバウンス

UDLD

MDIX

速度モード

シャットダウン

SNMP トラップ

ポート チャネル インターフェイスにサブインターフェイスが設定されていて、ポート チャネルからメンバー ポートが削除されている場合、ポート チャネル サブインターフェイスの設定はメンバー ポートに伝播されません。

ポート チャネル インターフェイスに対し、互換性のあるパラメータに加えた設定変更は、そのポート チャネルと同じチャネル グループ内のすべてのインターフェイスに伝播されます(たとえば、設定変更は、ポート チャネルには含まれなくてもチャネル グループには含まれる物理インターフェイスにも伝播されます)。

物理インターフェイスをチャネル グループに割り当てる前にポート チャネル インターフェイスを作成する必要はありません。ポート チャネル インターフェイスは、チャネル グループが最初の物理インターフェイスを取得したときに自動的に作成されます(まだ作成されていない場合)。

interface port-channel コマンドを入力したとき、またはチャネル グループが最初の物理インターフェイス割り当てを取得したときに、レイヤ 2 またはレイヤ 3 のポート チャネルを作成できます。ポート チャネルは、実行時あるいは動的に作成されることはありません。

このコマンドにライセンスは不要です。

次に、インターフェイスを active モードで LACP チャネル グループ 5 に追加する例を示します。

switch(config-if)# channel-group 5 mode active
switch(config-if)#
 

 
関連コマンド

コマンド
説明

show interface port-channel

指定されたポート チャネル インターフェイスのトラフィックに関する情報を表示します。

show port-channel summary

ポート チャネルに関する情報を表示します。

show lacp

LACP 情報を表示します。

clear counters interface port-channel

特定のポート チャネルの全インターフェイスの統計情報を消去するには、 clear counters interface port-channel コマンドを使用します。

clear counters interface port-channel channel-number

 
シンタックスの説明

channel-number

ポート チャネル番号。値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは不要です。

次に、特定のポート チャネルのすべてのカウンタを消去する例を示します。

switch(config)# clear counters interface port-channel 5
switch(config) #
 

 
関連コマンド

コマンド
説明

show interface port-channel counters

ポート チャネルの統計情報を表示します。

clear lacp counters

Link Aggregation Control Protocol(LACP)グループのすべてのインターフェイスの統計情報を消去するには、 clear lacp counters コマンドを使用します。

clear lacp counters [ interface port-channel channel-number ]

 
シンタックスの説明

channel-number

(任意)LACP ポート チャネル番号。値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

スタティックなポート チャネル グループに対してこのコマンドを入力しても、集約プロトコルがイネーブルでない場合は、無視されます。

チャネル番号が指定されていない場合は、すべての LACP ポート グループの LACP カウンタが消去されます。

このコマンドにライセンスは不要です。

次に、すべての LACP カウンタを消去する例を示します。

switch(config)# clear lacp counters
switch(config) #
 

次に、LACP ポート チャネル グループ 20 のすべての LACP カウンタを消去する例を示します。

switch(config)# clear lacp counters interface port-channel 20
switch(config)#
 

 
関連コマンド

コマンド
説明

show lacp counters

LACP の統計情報を表示します。

encapsulation dot1Q

VLAN(仮想 LAN)の特定のサブインターフェイスのトラフィックの IEEE 802.1Q カプセル化をイネーブルにするには、サブインターフェイス コンフィギュレーション モードで encapsulation dot1q コマンドを使用します。カプセル化をディセーブルにするには、このコマンドの no 形式を使用します。

encapsulation dot1Q vlan-id

no encapsulation dot1Q vlan-id

 
シンタックスの説明

vlan-id

インターフェイスがアクセス モードのときに設定する VLAN。有効な値は 1 ~ 4094 です。内部スイッチ用に予約されている VLAN は除きます。

 
デフォルト

カプセル化なし

 
コマンド モード

サブインターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

IEEE 802.1Q カプセル化は、Ethernet インターフェイスで設定可能です。IEEE 802.1Q は、複数のスイッチとルータの相互接続、および VLAN トポロジーを定義するための標準プロトコルです。

VLAN ID をサブインターフェイスに適用するには、 encapsulation dot1q コマンドをサブインターフェイス範囲設定モードで使用します。

このコマンドにライセンスは不要です。

次に、VLAN 30 のサブインターフェイスでの dot1Q カプセル化をイネーブルにする例を示します。

switch(config-subif)# encapsulation dot1q 30
 

 
関連コマンド

コマンド
説明

show vlan dot1Q

VLAN の dot1Q カプセル化情報を表示します。

feature interface-vlan

VLAN インターフェイス(Switched Virtual Interface [SVI; スイッチ仮想インターフェイス])の作成をイネーブルにするには、グローバル コンフィギュレーション モードで feature interface-vlan コマンドを使用します。VLAN インターフェイス機能をディセーブルにするには、このコマンドの no 形式を使用します。

feature interface-vlan

no feature interface-vlan

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

feature interface-vlan コマンドは、VLAN インターフェイスを作成する前に使用する必要があります。

このコマンドにライセンスは不要です。

次に、VLAN インターフェイス機能をイネーブルにする例を示します。

switch(config)# feature interface-vlan
 

 
関連コマンド

コマンド
説明

interface vlan

VLAN インターフェイスを作成します。

feature lacp

Link Aggregation Control Protocol(LACP)ポート チャネリングをデバイスでイネーブルにするには、 feature lacp コマンドを使用します。デバイスの LACP をディセーブルにするには、このコマンドの no 形式を使用します。

feature lacp

no feature lacp

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

LACP をディセーブルにする前に、デバイスのすべてのポート チャネルからすべての LACP 設定パラメータを削除しておく必要があります。LACP 設定がデバイスに残っていると、LACP をディセーブルにすることはできません。

LACP をグローバルでイネーブルにしたあとも、デバイスのすべてのポート チャネルで LACP を実行する必要はありません。各チャネル モードで LACP をイネーブルにするには、 channel-group mode コマンドを使用します。

このコマンドにライセンスは不要です。

次に、デバイスの LACP ポート チャネリングをイネーブルにする例を示します。

switch(config)# feature lacp
switch(config)#

 
関連コマンド

コマンド
説明

show lacp port-channel

LACP がイネーブルになっているポート チャネルに関する情報を表示します。

feature tunnel

トンネル インターフェイスの作成をイネーブルにするには、グローバル コンフィギュレーション モードで feature tunnel コマンドを使用します。トンネル インターフェイス機能をディセーブルにするには、このコマンドの no 形式を使用します。

feature tunnel

no feature tunnel

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

feature tunnel コマンドは、トンネル インターフェイスを作成する前に使用する必要があります。

このコマンドには Enterprise ライセンスが必要です。

次に、トンネル インターフェイス機能をイネーブルにする例を示します。

switch(config)# feature tunnel
 

 
関連コマンド

コマンド
説明

interface tunnel

トンネル インターフェイスを作成します。

interface loopback

ループバック インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface loopback コマンドを使用します。ループバック インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface loopback number

no interface loopback number

 
シンタックスの説明

number

インターフェイス番号を指定します。有効な値は 0 ~ 1023 です。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

ループバック インターフェイスの作成または変更を行うには、 interface loopback コマンドを使用します。

このコマンドにライセンスは不要です。

次に、ループバック インターフェイスを作成する例を示します。

switch(config)# interface loopback 50
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface loopback

指定されたループバック インターフェイスのトラフィックに関する情報を表示します。

interface port-channel

ポート チャネル インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface port-channe l コマンドを使用します。論理ポート チャネル インターフェイスまたはサブインターフェイスを削除するには、このコマンドの no 形式を使用します。

interface port-channel channel-number

no interface port-channel channel-number

 
シンタックスの説明

channel-number

論理ポート チャネル インターフェイスに割り当てられているチャネル番号。有効な値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

ポート チャネル グループの作成や削除、およびポート チャネルのインターフェイス コンフィギュレーション モードを開始するには、 interface port-channel コマンドを使用します。

ポート チャネルの作成は、 bandwidth (interface) コマンドを使用すると暗黙的に行うことができ、 feature tunnel コマンドを使用すると明示的に行えます。

ポートは、1 つのチャネル グループにのみ属すことができます。

レイヤ 3 ポート チャネル インターフェイスにはサブインターフェイスを作成できます。ただし、すでにサブインターフェイスがあるレイヤ 3 インターフェイスを、ポート チャネルに追加することはできません。


) レイヤ 3 ポート チャネル インターフェイスは、ルーテッド インターフェイスです。


Link Aggregation Control Protocol(LACP)システムの ID は各 VDC で一意であり、別の VDC ではチャネル グループの番号と名前を再利用できます。

interface port-channel コマンドを使用する場合は、次のガイドラインに従ってください。

CDP を使用する場合は、ポート チャネル インターフェイスではなく物理インターフェイスでのみ設定を行う必要があります。

ポート チャネル インターフェイスにスタティック MAC アドレスを割り当てなかった場合は、自動的に MAC アドレスが割り当てられます。スタティック MAC アドレスを割り当て、その後削除した場合は、その MAC アドレスが自動的に割り当てられます。

ポート チャネルの MAC アドレスは、チャネル グループに最初に追加された稼働ポートのアドレスです。最初に追加されたポートがチャネルから削除された場合は、その次に追加された稼働ポートから MAC アドレスが取得されます(そのポートが存在する場合)。

このコマンドにライセンスは不要です。

次に、チャネル グループ番号が 50 のポート チャネル グループ インターフェイスを作成する例を示します。

switch(config)# interface port-channel 50
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface port-channel

指定されたポート チャネル インターフェイスのトラフィックに関する情報を表示します。

show port-channel summary

ポート チャネルに関する情報を表示します。

show lacp

LACP 情報を表示します。

interface tunnel

トンネル インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface tunnel コマンドを使用します。トンネル インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface tunnel number

no interface tunnel number

 
シンタックスの説明

number

インターフェイス番号を指定します。有効な値は 0 ~ 32767 です。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

トンネル インターフェイスの作成または変更を行うには、 interface tunnel コマンドを使用します。

Cisco NX-OS では、IETF RFC 2784 に定義されている GRE ヘッダーがサポートされます。ただし、IETF RFC 1701 のトンネル キーとその他のオプションはサポートされません。

IP トンネルは、デフォルトの Virtual Device Context(VDC; 仮想デバイス コンテキスト)でのみ設定可能です。

このコマンドには Enterprise ライセンスが必要です。

次に、トンネル インターフェイスを作成する例を示します。

switch(config)# interface tunnel 50
switch(config-if)#

 
関連コマンド

コマンド
説明

tunnel source

IP トンネルの送信元を設定します。

tunnel destination

IP トンネルの宛先を設定します。

show interface tunnel

指定されたトンネル インターフェイスのトラフィックに関する情報を表示します。

interface vlan

VLAN インターフェイスを作成して、インターフェイス コンフィギュレーション モードを開始するには、 interface vlan コマンドを使用します。VLAN インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface vlan vlan-id

no interface vlan vlan-id

 
シンタックスの説明

vlan-id

インターフェイスがアクセス モードのときに設定する VLAN。有効な値は 1 ~ 4094 です。内部スイッチ用に予約されている VLAN は除きます。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

VLAN インターフェイスの作成または変更を行うには、 interface vlan コマンドを使用します。

VLAN インターフェイスは、特定の VLAN に対して初めて interface vlan コマンドを入力したときに作成されます。 vlan-id 引数は、Inter-Switch Link(ISL; スイッチ間リンク)、IEEE 802.1Q カプセル化トランク、およびアクセス ポートに設定されたVLAN ID のデータ フレームに関連付けられた VLAN タグに対応しています。

このコマンドにライセンスは不要です。

次に、VLAN 50 の VLAN インターフェイスを作成する例を示します。

switch(config)# interface vlan 50
switch(config-if)#

 
関連コマンド

コマンド
説明

feature interface-vlan

VLAN インターフェイスを作成する機能をイネーブルにします。

show interface vlan

指定された VLAN インターフェイスのトラフィックに関する情報を表示します。

lacp port-priority

Link Aggregation Control Protocol(LACP)の物理インターフェイスのプライオリティを設定するには、 lacp port-priority コマンドを使用します。ポート プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

lacp port-priority priority

no lacp port-priority

 
シンタックスの説明

priority

物理インターフェイスのプライオリティ。有効な値の範囲は 1 ~ 65535 です。

 
デフォルト

32768

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

LACP を使用するように設定されている各ポートには、LACP ポート プライオリティがあります。LACP ポート プライオリティには、32768 というデフォルト値をそのまま指定できます。また、1 ~ 65535 の値を設定することも可能です。LACP では、ポート プライオリティとポート番号を組み合わせてポート ID を作成します。ポート プライオリティは、ポート ID の作成のためにポート番号とともに使用されます。ポート プライオリティは、互換性のあるすべてのポートの集約を妨げるハードウェア上の制約がある場合、あるいは、チャネル グループに 9 以上のポートを設定した場合に、スタンバイ モードにするポートを判断するのに使用されます。

プライオリティを設定する際は、数字が 大きい ほど、プライオリティが 低く なる点に注意してください。

このコマンドにライセンスは不要です。

次に、インターフェイスの LACP ポート プライオリティを 2000 に設定する例を示します。

switch(config-if)# lacp port-priority 2000
switch(config-if)#

 
関連コマンド

コマンド
説明

show lacp

LACP 情報を表示します。

lacp system-priority

Link Aggregation Control Protocol(LACP)のデバイスのシステム プライオリティを設定するには、 lacp system-priority コマンドを使用します。システム プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

lacp system-priority priority

no lacp system-priority

 
シンタックスの説明

priority

物理インターフェイスのプライオリティ。有効な値の範囲は 1 ~ 65535 です。

 
デフォルト

32768

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

LACP が実行される各デバイスには、LACP システム プライオリティ値があります。このパラメータには、32768 というデフォルト値をそのまま指定できます。また、1 ~ 65535 の値を設定することも可能です。LACP では、システム ID を作成する場合や、他のシステムとのネゴシエーション中に、MAC アドレスのあるシステム プライオリティを使用します。システム ID は、各 Virtual Device Context(VDC; 仮想デバイス コンテキスト)で一意です。

プライオリティを設定する際は、数字が 大きい ほど、プライオリティが 低く なる点に注意してください。

このコマンドにライセンスは不要です。

次に、デバイスの LACP システム プライオリティを 2500 に設定する例を示します。

switch(config-if)# lacp system-priority 2500
switch(config-if)#

 
関連コマンド

コマンド
説明

show lacp

LACP 情報を表示します。

show lacp system identifier

LACP システム ID に関する情報を表示します。

medium

インターフェイスのメディア モードを設定するには、インターフェイス設定コマンドで medium コマンドを使用します。このエントリを削除するには、このコマンドの no 形式を使用します。

medium {broadcast | p2p}

no medium {broadcast | p2p}

 
シンタックスの説明

broadcast

インターフェイスをブロードキャスト メディアとして設定します。

p2p

インターフェイスをポイントツーポイント メディアとして設定します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

medium コマンドは、インターフェイスをブロードキャストまたはポイントツーポイントとして設定する場合に使用します。

このコマンドにライセンスは不要です。

次に、インターフェイスをポイントツーポイント メディアに設定する例を示します。

switch(config-if)# medium p2p
 

port-channel load-balance ethernet

チャネル グループ バンドルのインターフェイスにロード バランシング方式を設定するには、 port-channel load-balance ethernet コマンドを使用します。システム プライオリティをデフォルト値に戻すには、このコマンドの no 形式を使用します。

port-channel load-balance ethernet method [ module slot ]

no port-channel load-balance ethernet [ method [ module slot ]]

 
シンタックスの説明

method

ロード バランシング方式。有効な値のリストについては、「使用上のガイドライン」を参照してください。

module slot

(任意)モジュールのスロット番号を指定します。

 
デフォルト

レイヤ 2 パケット -- src-dst-mac

レイヤ 3 パケット -- src-dst-ip

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

モジュールを指定しない場合、デバイス全体でのロード バランシングが設定されます。module パラメータを使用すると、指定したモジュールのロード バランシングが設定されます。

method の有効な値は次のとおりです。

dst-ip -- 宛先 IP アドレスの負荷分散

dst-mac -- 宛先 MAC アドレスの負荷分散

dst-port -- 宛先ポートの負荷分散

src-dst-ip -- 送信元 XOR 宛先の IP アドレスの負荷分散

src-dst-mac -- 送信元 XOR 宛先の MAC アドレスの負荷分散

src-dst-port -- 送信元 XOR 宛先のポートの負荷分散

src-ip -- 送信元 IP アドレスの負荷分散

src-mac -- 送信元 MAC アドレスの負荷分散

src-port -- 送信元ポートの負荷分散


) VDC ごとにポート チャネルを使用してロード バランシングを設定することはできません。この機能は、デフォルト VDC で設定する必要があります。この機能を別の VDC で設定しようとすると、エラーが返されます。


個々のモジュールをポート チャネリング モードまたはロード バランシング モードに設定するには、 module 引数を使用します。その際、デバイス全体に適用されるように設定しないと、現在デバイス全体に設定されているロード バランシング方式(デフォルトの方式)が、残りのモジュールに適用されます。 module 引数とともに no 引数を入力した場合、指定したモジュールでのロード バランシング方式は、デバイス全体で使用されている現在のロード バランシング方式になります。デバイス全体にロード バランシング方式を設定した場合、指定されたモジュールでは、デフォルトの src-dst-ip および src-dst-mac ではなく、設定された方式が使用されます。個別のモジュール設定は、デバイス全体に設定されたロード バランシング方式に優先します。

デバイス全体に対し、1 つのロード バランシング モードを設定できます。また、指定したモジュールには別のモードを、他のモジュールには別のモードを設定することもできます。個別のモジュール設定は、デバイス全体のロード バランシング設定に優先します。

設定では、多様なロード バランス基準を備えたオプションを使用してください。たとえば、ポート チャネルのトラフィックが 1 つの MAC アドレスにのみ送られ、ポート チャネルのロード バランシングの基準としてその宛先 MAC アドレスが使用されている場合、ポート チャネルでは常にそのポート チャネルの同じリンクが選択されます。したがって、送信元アドレスまたは IP アドレスを使用すると、結果的により優れたロード バランシングが得られることになります。

このコマンドにライセンスは不要です。

次に、送信元ポートが使用されるように、デバイス全体のロード バランシング方式を設定する例を示します。

switch(config)# port-channel load-balance ethernet src-port
switch(config)#

 
関連コマンド

コマンド
説明

show port-channel load-balance

ポート チャネルのロード バランシングに関する情報を表示します。

show interface counters trunk

レイヤ 2 スイッチ ポート トランク インターフェイスのカウンタを表示するには、 show interface counters trunk コマンドを使用します。

show interface { ethernet slot/port } counters trunk

 
シンタックスの説明

ethernet slot/port

表示するトランク インターフェイスのモジュール番号とポート番号を指定します。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

このデバイスでは、IEEE 802.1Q カプセル化のみサポートされます。このコマンドでは、トランク ポート チャネルのカウンタも表示されます。

このコマンドにライセンスは不要です。

次に、トランク インターフェイスのカウンタを表示する例を示します。ここでは、トランク インターフェイスを介して送受信されたフレーム、および、トランク カプセル化が不適切なフレームの数が示されています。

switch# show interface ethernet 2/9 counters trunk
 
---------------------------------------------------------------------
Port TrunkFramesTx TrunkFramesRx WrongEncap
---------------------------------------------------------------------
Ethernet2/9 0 0 0
switch#
 

 
関連コマンド

コマンド
説明

clear counters interface

指定のインターフェイスのカウンタを消去します。

show interface port-channel

ポート チャネルに関する記述的な情報を表示するには、 show interface port-channel コマンドを使用します。

show interface port-channel channel-number [ brief | description | flowcontrol | status | switchport | trunk ]

 
シンタックスの説明

channel-number

ポート チャネル グループの番号。有効な値は 1 ~ 4096 です。

brief

(任意)指定したポート チャネルの要約情報が示されます。

description

(任意)指定したポート チャネルの説明が表示されます。

flowcontrol

(任意)指定したポート チャネルのフロー制御のステータス制御に関する情報、および、送受信されたフロー制御のポーズ パケットの統計情報が表示されます。

status

(任意)指定したポート チャネルのステータスに関する情報が示されます。

switchport

(任意)アクセス モードやトランク モードなど、指定したレイヤ 2 ポート チャネルに関する情報が示されます。

trunk

(任意)トランク モードにある指定したレイヤ 2 ポート チャネルに関する情報が示されます。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

指定したポート チャネルに関する詳細な統計情報を表示するには、 show interface port-channel counters コマンドを使用します。

このコマンドにライセンスは不要です。

次に、特定のポート チャネルに関する情報を表示する例を示します。このコマンドでは、ポート チャネルで 1 分間隔で収集された統計情報が表示されます。

switch(config)# show interface port-channel 50
port-channel50 is down (No operational members)
Hardware is Port-Channel, address is 0000.0000.0000 (bia 0000.0000.0000)
MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is access
auto-duplex, auto-speed
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
Members in this channel: Eth2/10
Last clearing of "show interface" counters 2d71.2uh
5 minute input rate 0 bytes/sec, 0 packets/sec
5 minute output rate 0 bytes/sec, 0 packets/sec
Rx
0 input packets 0 unicast packets 0 multicast packets
0 broadcast packets 0 jumbo packets 0 storm suppression packets
0 bytes
Tx
0 output packets 0 multicast packets
0 broadcast packets 0 jumbo packets
0 bytes
0 input error 0 short frame 0 watchdog
0 no buffer 0 runt 0 CRC 0 ecc
0 overrun 0 underrun 0 ignored 0 bad etype drop
0 bad proto drop 0 if down drop 0 input with dribble
0 input discard
0 output error 0 collision 0 deferred
0 late collision 0 lost carrier 0 no carrier
0 babble
0 Rx pause 0 Tx pause 0 reset
 

次に、ポート チャネルのモード、ステータス、速度、プロトコルを含む、特定のポート チャネルに関する簡単な説明を表示する例を示します。

switch# show interface port-channel 5 brief
 
--------------------------------------------------------------------------------
Port-channel VLAN Type Mode Status Reason Speed Protocol
Interface
--------------------------------------------------------------------------------
eth access down No operational members auto(D) lacp
 

次に、特定のポート チャネルの説明を表示する例を示します。

switch# show interface port-channel 5 description
 
-------------------------------------------------------------------------------
Interface Description
-------------------------------------------------------------------------------
port-channel5 test
 

次に、特定のポート チャネルのフロー制御情報を表示する例を示します。

switch# show interface port-channel 50 flowcontrol
 
------------------------------------------------------------------------------
Port Send FlowControl Receive FlowControl RxPause TxPause
admin oper admin oper
------------------------------------------------------------------------------
Po50 off off off off 0 0
 

次に、特定のポート チャネルのステータスを表示する例を示します。

switch# show interface port-channel 5 status
 
--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
test down 1 auto auto --
 

次に、特定のレイヤ 2 ポート チャネルに関する情報を表示する例を示します。

switch# show interface port-channel 50 switchport
Name: port-channel50
Switchport: Enabled
Switchport Monitor: Not enabled
Operational Mode: trunk
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: 1-3967,4048-4093
Administrative private-vlan primary host-association: none
Administrative private-vlan secondary host-association: none
Administrative private-vlan primary mapping: none
Administrative private-vlan secondary mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
 

このコマンドでは、アクセス モードとトランク モード両方のレイヤ 2 ポート チャネルに関する情報が表示されます。

このコマンドをルーテッド ポート チャネルに対して使用すると、次のメッセージが返されます。

Name: port-channel20
Switchport: Disabled
 

次に、トランク モードにある特定のレイヤ 2 ポート チャネルに関する情報を表示する例を示します。

switch# show interface port-channel 5 trunk
 
switch# show interface port-channel 50 trunk
port-channel50 is down (No operational members)
Hardware is Ethernet, address is 0000.0000.0000
MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec
Port mode is access
Speed is auto-speed
Duplex mode is auto
Beacon is turned off
Receive flow-control is off, Send flow-control is off
Rate mode is dedicated
Members in this channel: Eth2/10
Native Vlan: 1
Allowed Vlans: 1-3967,4048-4093
 

このコマンドでは、トランク モードにあるレイヤ 2 ポート チャネルの情報だけが表示されます。したがって、アクセス モードにあるレイヤ 2 ポート チャネルに関する情報は表示できません。

 
関連コマンド

コマンド
説明

show interface port-channel counters

チャネル グループの統計情報を表示します。

show port-channel summary

すべてのチャネル グループの要約情報を表示します。

show interface port-channel counters

ポート チャネルの統計情報を表示するには、 show interface port-channel counters コマンドを使用します。

show interface port-channel channel-number counters [ brief | detailed [ all | snmp ] | errors [ snmp ] | trunk ]

 
シンタックスの説明

channel-number

ポート チャネル グループの番号。有効な値は 1 ~ 4096 です。

brief

(任意)指定されたポート チャネルのレート MB/s および合計フレーム数が示されます。

detailed

(任意)指定されたポート チャネルのゼロ以外のカウンタが示されます。

all

(任意)指定されたポート チャネルのカウンタが示されます。

snmp

(任意)指定されたポート チャネルの SNMP MIB 値が示されます。

errors

(任意)指定されたポート チャネルのインターフェイス エラー カウンタが示されます。

trunk

(任意)指定されたポート チャネルのインターフェイス トランク カウンタが示されます。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドでは、LACP 対応のポート チャネルおよび集約プロトコルに関連付けられていないポート チャネルを含むすべてのポート チャネルの統計情報が表示されます。

このコマンドにライセンスは不要です。

次に、特定のポート チャネルのカウンタを表示する例を示します。ここでは、送受信されたユニキャスト パケットとマルチキャスト パケットが示されています。

switch# show interface port-channel 2 counters
 
Port InOctets InUcastPkts InMcastPkts InBcastPkts
Po2 6007 1 31 1
 
Port OutOctets OutUcastPkts OutMcastPkts OutBcastPkts
Po2 4428 1 25 1
switch#
 

次に、特定のポート チャネルの簡単なカウンタを表示する例を示します。ここでは、送信および受信された速度と合計フレーム数が示されています。

switch# show interface port-channel 20 counters brief
 
-------------------------------------------------------------------------------
Interface Input (rate is 1 min avg) Output (rate is 1 min avg)
------------------------- -----------------------------
Rate Total Rate Total
MB/s Frames MB/s Frames
-------------------------------------------------------------------------------
port-channel20 0 0 0 0
 

次に、特定のポート チャネルの詳細カウンタをすべて表示する例を示します。

switch# show interface port-channel 20 counters detailed all
port-channel20
64 bit counters:
0. rxHCTotalPkts = 0
1. txHCTotalPks = 0
2. rxHCUnicastPkts = 0
3. txHCUnicastPkts = 0
4. rxHCMulticastPkts = 0
5. txHCMulticastPkts = 0
6. rxHCBroadcastPkts = 0
7. txHCBroadcastPkts = 0
8. rxHCOctets = 0
9. txHCOctets = 0
10. rxTxHCPkts64Octets = 0
11. rxTxHCpkts65to127Octets = 0
12. rxTxHCpkts128to255Octets = 0
13. rxTxHCpkts256to511Octets = 0
14. rxTxHCpkts512to1023Octets = 0
15. rxTxHCpkts1024to1518Octets = 0
16. rxTxHCpkts1519to1548Octets = 0
17. rxHCTrunkFrames = 0
18. txHCTrunkFrames = 0
19. rxHCDropEvents = 0
 
All Port Counters:
0. InPackets = 0
1. InOctets = 0
2. InUcastPkts = 0
3. InMcastPkts = 0
4. InBcastPkts = 0
5. InJumboPkts = 0
6. StormSuppressPkts = 0
7. OutPackets = 0
8. OutOctets = 0
9. OutUcastPkts = 0
10. OutMcastPkts = 0
11. OutBcastPkts = 0
12. OutJumboPkts = 0
13. rxHCPkts64Octets = 0
14. rxHCPkts65to127Octets = 0
15. rxHCPkts128to255Octets = 0
16. rxHCPkts256to511Octets = 0
17. rxHCpkts512to1023Octets = 0
18. rxHCpkts1024to1518Octets = 0
19. rxHCpkts1519to1548Octets = 0
20. txHCPkts64Octets = 0
21. txHCPkts65to127Octets = 0
22. txHCPkts128to255Octets = 0
23. txHCPkts256to511Octets = 0
24. txHCpkts512to1023Octets = 0
25. txHCpkts1024to1518Octets = 0
26. txHCpkts1519to1548Octets = 0
27. ShortFrames = 0
28. Collisions = 0
29. SingleCol = 0
30. MultiCol = 0
31. LateCol = 0
32. ExcessiveCol = 0
33. LostCarrier = 0
34. NoCarrier = 0
35. Runts = 0
36. Giants = 0
37. InErrors = 0
38. OutErrors = 0
39. InputDiscards = 0
40. BadEtypeDrops = 0
41. IfDownDrops = 0
42. InUnknownProtos = 0
43. txCRC = 0
44. rxCRC = 0
45. Symbol = 0
46. txDropped = 0
47. TrunkFramesTx = 0
48. TrunkFramesRx = 0
49. WrongEncap = 0
50. Babbles = 0
51. Watchdogs = 0
52. ECC = 0
53. Overruns = 0
54. Underruns = 0
55. Dribbles = 0
56. Deferred = 0
57. Jabbers = 0
58. NoBuffer = 0
59. Ignored = 0
60. bpduOutLost = 0
61. cos0OutLost = 0
62. cos1OutLost = 0
63. cos2OutLost = 0
64. cos3OutLost = 0
65. cos4OutLost = 0
66. cos5OutLost = 0
67. cos6OutLost = 0
68. cos7OutLost = 0
69. RxPause = 0
70. TxPause = 0
71. Resets = 0
72. SQETest = 0
73. InLayer3Routed = 0
74. InLayer3RoutedOctets = 0
75. OutLayer3Routed = 0
76. OutLayer3RoutedOctets = 0
77. OutLayer3Unicast = 0
78. OutLayer3UnicastOctets = 0
79. OutLayer3Multicast = 0
80. OutLayer3MulticastOctets = 0
81. InLayer3Unicast = 0
82. InLayer3UnicastOctets = 0
83. InLayer3Multicast = 0
84. InLayer3MulticastOctets = 0
85. InLayer3AverageOctets = 0
86. InLayer3AveragePackets = 0
87. OutLayer3AverageOctets = 0
88. OutLayer3AveragePackets = 0
 

次に、特定のポート チャネルのエラー カウンタを表示する例を示します。

switch# show interface port-channel 5 counters errors
 
--------------------------------------------------------------------------------
Port Align-Err FCS-Err Xmit-Err Rcv-Err UnderSize OutDiscards
--------------------------------------------------------------------------------
Po5 0 0 0 0 0 0
--------------------------------------------------------------------------------
Port Single-Col Multi-Col Late-Col Exces-Col Carri-Sen Runts
--------------------------------------------------------------------------------
Po5 0 0 0 0 0 0
 
--------------------------------------------------------------------------------
Port Giants SQETest-Err Deferred-Tx IntMacTx-Er IntMacRx-Er Symbol-Err
--------------------------------------------------------------------------------
0 -- 0 0 0 0
 

次に、特定のポート チャネルのトランク インターフェイスに関する情報を表示する例を示します。

switch# show interface port-channel 5 counters trunk
 
-------------------------------------------------------------------------------
Port TrunkFramesTx TrunkFramesRx WrongEncap
-------------------------------------------------------------------------------
port-channel5 0 0 0
 

 
関連コマンド

コマンド
説明

clear counters interface port-channel channel-number

特定のチャネル グループに属するすべてのインターフェイスの統計情報を消去します。

show interface switchport

すべてのスイッチ ポート インターフェイスに関する情報を表示するには、 show interface switchport コマンドを使用します。

show interface [ ethernet type/slot | port-channel channel-number ] switchport

 
シンタックスの説明

ethernet type/slot | port- channel channel-number

(任意)表示したいインターフェイスのタイプおよび番号

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスを指定しない場合、アクセス インターフェイス、トランク インターフェイス、ポート チャネル インターフェイスを含むすべてのレイヤ 2 インターフェイスおよびすべてのプライベート VLAN ポートに関する情報が表示されます。

指定したレイヤ 2 インターフェイスの統計情報を表示するには、 show interface counters コマンドを使用します。

このコマンドにライセンスは不要です。

次に、すべてのレイヤ 2 インターフェイスに関する情報を表示する例を示します。

switch# show interface switchport
Name: Ethernet2/5
Switchport: Enabled
Switchport Monitor: Not enabled
Operational Mode: access
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: 1-3967,4048-4093
Administrative private-vlan primary host-association: none
Administrative private-vlan secondary host-association: none
Administrative private-vlan primary mapping: none
Administrative private-vlan secondary mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
 
Name: Ethernet2/9
Switchport: Enabled
Switchport Monitor: Not enabled
Operational Mode: trunk
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: 1-3967,4048-4093
Administrative private-vlan primary host-association: none
Administrative private-vlan secondary host-association: none
Administrative private-vlan primary mapping: none
Administrative private-vlan secondary mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
 
Name: port-channel5
Switchport: Enabled
Switchport Monitor: Not enabled
Operational Mode: access
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: 1-3967,4048-4093
Administrative private-vlan primary host-association: none
Administrative private-vlan secondary host-association: none
Administrative private-vlan primary mapping: none
Administrative private-vlan secondary mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
 
switch#

 
関連コマンド

コマンド
説明

switchport mode

指定したインターフェイスをレイヤ 2 のアクセス インターフェイスまたはトランク インターフェイスとして設定します。

show interface trunk

すべてのトランク インターフェイスに関する情報を表示するには、 show interface trunk コマンドを使用します。

show interface [ ethernet type/slot | port-channel channel-number ] trunk [ module number | vlan vlan-id ]

 
シンタックスの説明

ethernet type/slot | port- channel channel-number

(任意)表示したいインターフェイスのタイプおよび番号

module number

(任意)モジュール番号を指定します。

vlan vlan-id

(任意)VLAN 番号を指定します。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイス、モジュール番号、または VLAN 番号を指定しない場合、すべてのトランク インターフェイスに関する情報が表示されます。

このコマンドでは、レイヤ 2 のすべてのトランク インターフェイスおよびトランク ポート チャネル インターフェイスに関する情報が表示されます。

指定のレイヤ 2 インターフェイスの統計情報を表示するには、 show interface counters コマンドを使用します。

このコマンドにライセンスは不要です。

次に、すべてのレイヤ 2 トランク インターフェイスに関する情報を表示する例を示します。

switch(config)# show interface trunk
 
-----------------------------------------------------------------------------
Port Native Status Port
Vlan Channel
-----------------------------------------------------------------------------
Eth2/9 1 trunking --
Eth2/10 1 trnk-bndl Po50
Po50 1 not-trunking --
 
-----------------------------------------------------------------------------
Port Vlans Allowed on Trunk
-----------------------------------------------------------------------------
Eth2/9 1-3967,4048-4093
Eth2/10 1-3967,4048-4093
Po50 1-3967,4048-4093
 
-----------------------------------------------------------------------------
Port STP Forwarding
-----------------------------------------------------------------------------
Eth2/9 none
Eth2/10 none
Po50 none
 
switch#

 
関連コマンド

コマンド
説明

switchport mode trunk

指定したインターフェイスをレイヤ 2 トランク インターフェイスとして設定します。

show lacp counters

Link Aggregation Control Protocol(LACP)の統計情報を表示するには、 show lacp counters コマンドを使用します。

show lacp counters [ interface port-channel channel-number ]

 
シンタックスの説明

channel-number

(任意)LACP チャネル グループの番号。有効な値は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

channel-number を指定しない場合は、すべてのチャネル グループが表示されます。

このコマンドにライセンスは不要です。

次に、特定のチャネル グループの LACP 統計情報を表示する例を示します。

switch# show lacp counters interface port-channel 1
 
LACPDUs Marker Marker Response LACPDUs
Port Sent Recv Sent Recv Sent Recv Pkts Err
-----------------------------------------------------------------------------
port-channel1
Ethernet1/1 554 536 0 0 0 0 0
Ethernet1/2 527 514 0 0 0 0 0
Ethernet1/3 535 520 0 0 0 0 0
Ethernet1/4 515 502 0 0 0 0 0
Ethernet1/5 518 505 0 0 0 0 0
Ethernet1/6 540 529 0 0 0 0 0
Ethernet1/7 541 530 0 0 0 0 0
Ethernet1/8 547 532 0 0 0 0 0
Ethernet1/9 544 532 0 0 0 0 0
Ethernet1/10 513 501 0 0 0 0 0
Ethernet1/11 497 485 0 0 0 0 0
Ethernet1/12 493 486 0 0 0 0 0
Ethernet1/13 492 485 0 0 0 0 0
Ethernet1/14 482 481 0 0 0 0 0
Ethernet1/15 481 476 0 0 0 0 0
Ethernet1/16 482 477 0 0 0 0 0
 

 
関連コマンド

コマンド
説明

clear lacp counters

すべての LACP インターフェイスまたは特定の LACP チャネル グループに属するインターフェイスの統計情報を消去します。

show lacp interface

特定の Link Aggregation Control Protocol(LACP)インターフェイスに関する情報を表示するには、 show lacp interface コマンドを使用します。

show lacp interface ethernet slot/port

 
シンタックスの説明

slot/port

表示するインターフェイスのスロット番号およびポート番号

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

LACP_Activity フィールドには、そのリンクが設定されているポート チャネル モードがアクティブかパッシブかが示されます。

Port Identifier フィールドには、ポートのプライオリティが表示されます。また、このフィールドの情報の一部にはポート番号が含まれています。次の例で、ポートのプライオリティとポート番号の識別方法を示します。

Port Identifier=0x8000,0x101
 

この例では、ポートのプライオリティの値は 0x8000 で、ポート番号の値は 0x101 です。

このコマンドにライセンスは不要です。

次に、特定のチャネル グループの LACP 統計情報を表示する例を示します。

switch# show lacp interface ethernet 1/1
 
switch(config-if-range)# show lacp interface eth1/1
Interface Ethernet1/1 is up
Channel group is 1 port channel is Po1
PDUs sent: 556
PDUs rcvd: 538
Markers sent: 0
Markers rcvd: 0
Marker response sent: 0
Marker response rcvd: 0
Unknown packets rcvd: 0
Illegal packets rcvd: 0
Lag Id: [ [(8000, 0-11-11-22-22-74, 0, 8000, 101), (8000, 0-11-11-22-22-75, 0, 8
000, 401)] ]
Operational as aggregated link since Wed Jun 11 20:37:59 2008
 
Local Port: Eth1/1 MAC Address= 0-11-11-22-22-74
System Identifier=0x8000,0-11-11-22-22-74
Port Identifier=0x8000,0x101
Operational key=0
LACP_Activity=active
LACP_Timeout=Long Timeout (30s)
Synchronization=IN_SYNC
Collecting=true
Distributing=true
Partner information refresh timeout=Long Timeout (90s)
Actor Admin State=
Actor Oper State=
Neighbor: 4/1
MAC Address= 0-11-11-22-22-75
System Identifier=0x8000,0-11-11-22-22-75
Port Identifier=0x8000,0x401
Operational key=0
LACP_Activity=active
LACP_Timeout=Long Timeout (30s)
Synchronization=IN_SYNC
Collecting=true
Distributing=true
Partner Admin State=
Partner Oper State=
 

 
関連コマンド

コマンド
説明

show port-channel summary

すべてのポート チャネル グループに関する情報を表示します。

show lacp neighbor

Link Aggregation Control Protocol(LACP)ネイバーに関する情報を表示するには、 show lacp neighbor コマンドを使用します。

show lacp neighbor [ interface port-channel channel-number ]

 
シンタックスの説明

channel-number

表示する LACP ネイバーのポート チャネル番号。値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

channel-number を指定しない場合は、すべてのチャネル グループが表示されます。

このコマンドにライセンスは不要です。

次に、特定のポート チャネルの LACP ネイバーに関する情報を表示する例を示します。

switch# show lacp neighbor interface port-channel 1
Flags: S - Device is sending Slow LACPDUs F - Device is sending Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
port-channel1 neighbors
Partner's information
Partner Partner Partner
Port System ID Port Number Age Flags
Eth1/1 32768,0-11-11-22-22-750x401 44817 SA
 
LACP Partner Partner Partner
Port Priority Oper Key Port State
32768 0x0 0x3d
 
Partner's information
Partner Partner Partner
Port System ID Port Number Age Flags
Eth1/2 32768,0-11-11-22-22-750x402 44817 SA
 
LACP Partner Partner Partner
Port Priority Oper Key Port State
32768 0x0 0x3d
 

 
関連コマンド

コマンド
説明

show port-channel summary

すべてのポート チャネル グループに関する情報を表示します。

show lacp port-channel

Link Aggregation Control Protocol(LACP)ポート チャネルに関する情報を表示するには、 show lacp port-channel コマンドを使用します。

show lacp port-channel [ interface port-channel channel-number ]

 
シンタックスの説明

channel-number

表示する LACP チャネル グループのポート チャネル番号。値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

channel-number を指定しない場合は、すべてのチャネル グループが表示されます。

このコマンドにライセンスは不要です。

次に、LACP ポート チャネルに関する情報を表示する例を示します。

switch# show lacp port-channel
 
port-channel1
Local System Identifier=0x8000,0-11-11-22-22-74
Admin key=0x0
Operational key=0x0
Partner System Identifier=0x8000,0-11-11-22-22-75
Operational key=0x0
Max delay=0
Aggregate or individual=1
port-channel2
Local System Identifier=0x8000,0-11-11-22-22-74
Admin key=0x1
Operational key=0x1
Partner System Identifier=0x8000,0-11-11-22-22-75
Operational key=0x1
Max delay=0
Aggregate or individual=1
 

 
関連コマンド

コマンド
説明

show port-channel summary

すべてのポート チャネル グループに関する情報を表示します。

show lacp system-identifier

デバイスの Link Aggregation Control Protocol(LACP)システム ID を表示するには、 show lacp system-identifier コマンドを使用します。

show lacp system-identifier

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

LACP システム ID は、設定可能な LACP システム プライオリティ値と MAC アドレスを組み合わせたものです。

LACP が実行される各システムには、LACP システム プライオリティ値が設定されています。このパラメータには、32768 というデフォルト値をそのまま指定できます。また、1 ~ 65535 の値を設定することも可能です。LACP では、システム ID を作成するために、MAC アドレスのあるシステム プライオリティが使用されます。また、他のデバイスとのネゴシエーション中にもシステム プライオリティが使用されます。システム プライオリティ値が大きいほど、プライオリティが低くなります。

システム ID は、Virtual Device Context(VDC; 仮想デバイス コンテキスト)ごとに異なります。

このコマンドにライセンスは不要です。

次に、特定のポート チャネルの LACP ポート チャネルに関する情報を表示する例を示します。

switch> show lacp system-identifier
8000,AC-12-34-56-78-90

 
関連コマンド

コマンド
説明

lacp system-priority

LACP のシステム プライオリティを設定します。

show port-channel compatibility-parameters

ポート チャネルに加入するためにメンバー ポート間で同一でなければならないパラメータを表示するには、 show port-channel compatibility parameters コマンドを使用します。

show port-channel compatibility-parameters

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

チャネル グループにインターフェイスを追加する場合、そのインターフェイスにチャネル グループとの互換性があるかどうかを確認するために、特定のインターフェイス アトリビュートがチェックされます。たとえば、レイヤ 2 のチャネル グループにレイヤ 3 のインターフェイスを追加することはできません。また、インターフェイスをポート チャネル集約に参加させる前に、そのインターフェイスの多数の操作アトリビュートもチェックされます。

このコマンドは、システムで使用される互換性チェック リストを表示します。

以下のパラメータが同じである場合、 channel-group コマンドを使用して、互換性のないパラメータを持つポートを強制的にポート チャネルに加入させることができます。

(リンク)速度機能

速度設定

デュプレックス機能

デュプレックス設定

フロー制御機能

フロー制御設定


) ポート チャネルへのポートの加入については、「channel-group コマンド」を参照してください。


このコマンドにライセンスは不要です。

次に、インターフェイスをチャネル グループに参加させる前に、システムで実行される互換性チェックのリストを表示する例を示します。

switch# show port-channel compatibility-parameters
* port mode
 
Members must have the same port mode configured, either E or AUTO. If they
are configured in AUTO port mode, they have to negotiate E mode when they
come up. If a member negotiates a different mode, it will be suspended.
 
* speed
 
Members must have the same speed configured. If they are configured in AUTO
speed, they have to negotiate the same speed when they come up. If a member
negotiates a different speed, it will be suspended.
 
* MTU
 
Members have to have the same MTU configured. This only applies to ethernet
port-channel.
 
* MEDIUM
 
Members have to have the same medium type configured. This only applies to
ethernet port-channel.
 
* Span mode
 
Members must have the same span mode.
 
* sub interfaces
 
Members must not have sub-interfaces.
 
* Duplex Mode
 
Members must have same Duplex Mode configured.
 
* Ethernet Layer
 
Members must have same Ethernet Layer (switchport/no-switchport) configured.
 
* Span Port
 
Members cannot be SPAN ports.
 
* Storm Control
 
Members must have same storm-control configured.
 
* Flow Control
 
Members must have same flowctrl configured.
 
* Capabilities
 
Members must have common capabilities.
 
* port
 
Members port VLAN info.
 
* port
 
Members port does not exist.
 
* switching port
 
Members must be switching port, Layer 2.
 
* port access VLAN
 
Members must have the same port access VLAN.
 
* port native VLAN
 
Members must have the same port native VLAN.
 
* port allowed VLAN list
 
Members must have the same port allowed VLAN list.
 

 
関連コマンド

コマンド
説明

channel-group

ポート チャネル グループへのインターフェイスの追加、ポート チャネル グループからのインターフェイスの削除、インターフェイスへのポート チャネル モードの割り当てを行います。

show port-channel database

ポート チャネルの現在の実行に関する情報を表示するには、 show port-channel database コマンドを使用します。

show port-channel database [interface port-channel channel-number ]

 
シンタックスの説明

channel-number

表示したい情報のポート チャネル番号。値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

channel-number を指定しない場合は、すべてのチャネル グループが表示されます。このコマンドでは、Link Aggregation Control Protocol(LACP)対応のポート チャネル、および対応する集約プロトコルのないポート チャネルが表示されます。

このコマンドにライセンスは不要です。

次に、すべてのポート チャネルの現在の実行に関する情報を表示する例を示します。

switch# show port-channel database
port-channel5
Administrative channel mode is active
Operational channel mode is active
Last membership update is successful
1 ports in total, 0 ports up
Age of the port-channel is 1d:16h:18m:50s
Time since last bundle is 1d:16h:18m:56s
Last bundled member is
Ports: Ethernet2/5 [down]
 
port-channel20
Administrative channel mode is active
Operational channel mode is active
Last membership update is successful
1 ports in total, 0 ports up
Age of the port-channel is 1d:16h:18m:50s
Time since last bundle is 1d:16h:18m:56s
Last bundled member is
Ports: Ethernet2/20 [down]
 

次に、特定のポート チャネルの現在の実行に関する情報を表示する例を示します。

switch# show port-channel database interface port-channel 20
port-channel20
Administrative channel mode is active
Operational channel mode is active
Last membership update is successful
1 ports in total, 0 ports up
Age of the port-channel is 1d:16h:23m:14s
Time since last bundle is 1d:16h:23m:20s
Last bundled member is
Ports: Ethernet2/20 [down]

 
関連コマンド

コマンド
説明

show port-channel summary

すべてのポート チャネルに関するサマリー情報を表示します。

show port-channel load-balance

ポート チャネルを使用したロード バランシングに関する情報を表示するには、 show port-channel load-balance コマンドを使用します。

show port-channel load-balance [forwarding-path interface port-channel channel-number ]

 
シンタックスの説明

forwarding-path interface port-channel

(任意)パケットを転送するポート チャネル内のポートを指定します。

channel-number

表示するロード バランシング転送パスのポート チャネル番号。値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは不要です。

次に、システムの現在のポート チャネルのロード バランシングに関する情報を表示する例を示します。

switch# show port-channel load-balance
 
Port Channel Load-Balancing Configuration:
System: source-dest-ip-vlan
 
Port Channel Load-Balancing Addresses Used Per-Protocol:
Non-IP: source-dest-mac
IP: source-dest-ip-vlan
 

 
関連コマンド

コマンド
説明

port-channel load-balance ethernet

ポート チャネルを使用したロード バランシングを設定します。

show port-channel rbh-distribution

ポート チャネルの Result Bundle Hash(RBH)に関する情報を表示するには、 show port-channel rbh-distribution コマンドを使用します。

show port-channel rbh-distribution [interface port-channel channel-number ]

 
シンタックスの説明

channel-number

表示する情報のポート チャネル番号。値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

RBH の値の範囲は 0 ~ 7 です。RBH は、ポート チャネルのポート メンバー間で共有されます。

このコマンドにライセンスは不要です。

次に、特定のポート チャネルの RBH 分散を表示する例を示します。

switch# show port-channel rbh-distribution interface port-channel 4
 
ChanId Member port RBH values Num of buckets
-------- ------------- ----------------- ----------------
4 Eth3/13 4,5,6,7 4
4 Eth3/14 0,1,2,3 4
 

 
関連コマンド

コマンド
説明

port-channel summary

ポート チャネルに関する要約情報を表示します。

show port-channel summary

ポート チャネルに関するサマリー情報を表示するには、 show port-channel summary コマンドを使用します。

show port-channel summary

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

Link Aggregation Control Protocol(LACP)がイネーブルではない場合、出力の Protocol カラムには NONE と表示されます。

チャネル グループのインターフェイスの稼働状態は次のようになります。

Down -- 管理のためにシャットダウンされているか、ポート チャネルとは無関係の他の理由により、インターフェイスがダウンしています。

Individual -- インターフェイスはポート チャネルの一部ですが、プロトコル交換の問題により、ポート チャネルに集約することができません。

このインターフェイスは、単独のリンクとしてトラフィックを転送し続けます。

STP はこのインターフェイスを認識します。

Suspended -- インターフェイスの運用パラメータは、ポート チャネルと互換性がありません。このインターフェイスはトラフィックを転送していません。ただし、物理 MAC リンクはアップ状態です。

Switched -- インターフェイスは切り換えられています。

Up(port-channel) -- ポート チャネルはアップしています。

Up in port-channel(members) -- ポート チャネルのポート メンバーはアップしています。

Hot-standby(LACP only) -- インターフェイスは、現在 LACP チャネルに参加しているインターフェイスのいずれかがダウンした場合、ポート グループに加入することができます。

このインターフェイスは、データ トラフィックは転送せず、Protocol Data Unit(PDU; プロトコル データ ユニット)のみ転送します。

このインターフェイスは STP を実行しません。

Module-removed -- モジュールは削除されています。

Routed -- インターフェイスはルーティングされています。

このコマンドにライセンスは不要です。

次に、ポート チャネルに関する要約情報を表示する例を示します。

switch# show port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)
-------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
-------------------------------------------------------------------
5 Po5(SD) Eth LACP Eth2/5(D)
20 Po20(RD) Eth LACP Eth2/20(D)
 

 
関連コマンド

コマンド
説明

show port-channel usage

使用されているポート チャネル番号および空いているポート チャネル番号を表示します。

show port-channel traffic

ポート チャネルの送信および受信されたユニキャストの割合、マルチキャストの割合、ブロードキャストの割合を表示します。

show port-channel traffic

ポート チャネルのトラフィック統計情報を表示するには、 show port-channel traffic コマンドを使用します。

show port-channel traffic [interface port-channel channel-number ]

 
シンタックスの説明

channel-number

表示するトラフィック統計情報のポート チャネル番号。値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにより、ポート チャネルで送受信されたユニキャスト トラフィック、マルチキャスト トラフィック、ブロードキャスト トラフィックの割合が表示されます。

channel-number を指定しない場合は、すべてのポート チャネルに関する情報が表示されます。

このコマンドにライセンスは不要です。

次に、すべてのポート チャネルのトラフィック統計情報を表示する例を示します。

switch(config)# show port-channel traffic
ChanId Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
------ --------- ------- ------- ------- ------- ------- -------
5 Eth2/5 0.0% 0.0% 0.0% 0.0% 0.0% 0.0%
------ --------- ------- ------- ------- ------- ------- -------
20 Eth2/20 0.0% 0.0% 0.0% 0.0% 0.0% 0.0%
 

次に、特定のポート チャネルのトラフィック統計情報を表示する例を示します。

switch(config)# show port-channel traffic interface port-channel 5
ChanId Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
------ --------- ------- ------- ------- ------- ------- -------
5 Eth2/5 0.0% 0.0% 0.0% 0.0% 0.0% 0.0%

 
関連コマンド

コマンド
説明

port-channel summary

ポート チャネルに関する要約情報を表示します。

show port-channel usage

使用されているポート チャネル番号および空いているポート チャネル番号を表示するには、 show port-channel usage コマンドを使用します。

show port-channel usage

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにより、監視中の Virtual Device Context(VDC; 仮想デバイス コンテキスト)で使用されているポート チャネル番号および空いているポート チャネル番号が表示されます。

システム全体のすべての VDC で使用できるポート チャネル番号は 1 ~ 4096 です。

このコマンドにライセンスは不要です。

次に、すべてのポート チャネルの使用状況を表示する例を示します。

switch# show port-channel usage
Totally 2 port-channel numbers used
====================================
Used : 5 , 20
Unused: 1 - 4 , 6 - 19 , 21 - 4096
switch#

 
関連コマンド

コマンド
説明

port-channel summary

ポート チャネルに関するサマリー情報を表示します。

show running-config interface port-channel

特定のポート チャネルの実行コンフィギュレーションを表示するには、 show running-config interface port-channel コマンドを使用します。

show running-config interface port-channel { channel-number }

 
シンタックスの説明

channel-number

ポート チャネル グループの番号。値の範囲は 1 ~ 4096 です。

 
デフォルト

なし

 
コマンド モード

任意のコマンド モード

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは不要です。

次に、ポート チャネル 10 の実行コンフィギュレーションを表示する例を示します。

switch(config)# show running-config interface port-channel 10
version 4.0(1)
 
interface port-channel10
switchport
switchport mode trunk
 

 
関連コマンド

コマンド
説明

show port-channel summary

ポート チャネルのサマリー情報を表示します。

switchport

インターフェイスをレイヤ 2 スイッチング ポートとして設定するには、 switchport コマンドを使用します。インターフェイスをデフォルトのレイヤ 3 ルーテッド インターフェイス ステータスに戻し、すべてのレイヤ 2 コンフィギュレーションを消去するには、このコマンドの no 形式を使用します。

switchport

no switchport

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

インターフェイスはデフォルトでレイヤ 3 となります。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

キーワードを使用して追加の switchport コマンドを入力する前に、キーワードなしで switchport コマンドを入力して、LAN インターフェイスをレイヤ 2 インターフェイスとして設定しておく必要があります。この処理は、インターフェイスに対して switchport コマンドを入力しなかった場合にのみ必要となります。

デフォルトの switchport モードはアクセス モードです。以下を行うには、 switchport mode コマンドを使用します。

インターフェイスをレイヤ 2 アクセス モードに設定します。

インターフェイスをレイヤ 2 トランク モードに戻します。

プライベート VLAN でインターフェイスを使用します。

ポートをシャットダウンし、再度イネーブルにするには、 no switchport コマンドを入力します。この処理により、ポートの接続先のデバイスでメッセージが表示されることがあります。

no switchport コマンドを使用すると、そのインターフェイスからすべてのレイヤ 2 コンフィギュレーションが削除され、デフォルトの VLAN コンフィギュレーションになります。

インターフェイス モードを変更すると、ポートがダウンし、再初期化されます。

このコマンドにライセンスは不要です。

次に、ポート インターフェイスが Cisco ルーテッド ポートとして動作するのを停止させ、レイヤ 2 スイッチド インターフェイスに変換する例を示します。

Router(config-if)# switchport
Router(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび稼働ステータスを表示します。

switchport access vlan

インターフェイスがアクセス モードのときにアクセス VLAN を設定するには、 switchport access vlan コマンドを使用します。アクセス モードの VLAN をデバイスのデフォルトの VLAN にリセットするには、このコマンドの no 形式を使用します。

switchport access vlan vlan-id

no switchport access vlan

 
シンタックスの説明

vlan-id

インターフェイスがアクセス モードのときに設定する VLAN。有効な値は 1 ~ 4094 です。内部スイッチ用に予約されている VLAN は除きます。

 
デフォルト

VLAN 1

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

switchport access vlan コマンドを入力する前に、キーワードなしで switchport コマンドを入力して、LAN インターフェイスをレイヤ 2 インターフェイスとして設定しておく必要があります。この処理は、インターフェイスに対して switchport コマンドを入力しなかった場合にのみ必要となります。

ポートをシャットダウンし、再度イネーブルにするには、 no switchport access vlan コマンドを入力します。この処理により、ポートの接続先のデバイスでメッセージが表示されることがあります。

アクセス モードの VLAN をデバイスのデフォルトの VLAN にリセットするには、 switchport access vlan コマンドの no 形式を使用します。

このコマンドにライセンスは不要です。

次に、すでにスイッチド インターフェイスとして設定されているポート インターフェイスを、プラットフォームのデフォルトの VLAN ではなく、VLAN 2 のアクセス ポートとしてインターフェイス コンフィギュレーション モードで稼働させる例を示します。

Router(config-if)# switchport access vlan 2
Router(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび稼働ステータスを表示します。

switchport host

レイヤ 2 アクセス ポートとして他のデバイスに接続されていないポートを、パケット転送を最適化して設定するには、 switchport host コマンドを使用します。レイヤ 2 アクセス ポートとして他のデバイスに接続されていないポートをディセーブルにするには、このコマンドの no 形式を使用します。

switchport host

no switchport host

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

インターフェイスはデフォルトでレイヤ 3 となります。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

switchport host コマンドを入力する前に、キーワードなしで switchport コマンドを入力して、LAN インターフェイスをレイヤ 2 インターフェイスとして設定しておく必要があります。この処理は、インターフェイスに対して switchport コマンドを入力しなかった場合にのみ必要となります。

インターフェイスで switchport host コマンドを入力すると、以下が実行されます。

レイヤ 2 インターフェイスをアクセス ポートにします。

レイヤ 2 インターフェイスを STP エッジ ポートにします。これにより、パケット転送の始動に要する時間が短縮されます。

インターフェイスのポート チャネリングをディセーブルにします。

switchport host コマンドの入力は、シングル ホストに接続されているポートでのみ行います。シングル ホスト以外に接続されているインターフェイスでこのコマンドを使用すると、エラー メッセージが返されます。

ポート設定を最適化するには、 switchport host コマンドを入力してスイッチ ポート モードをアクセスに設定し、チャネル グループ化をディセーブルにします。端末だけがこの設定を受け入れることができます。

このコマンドは、ポートが up 状態の場合にポートを切り替えます。

このコマンドにライセンスは不要です。

次に、ホスト接続のためにアクセス ポート設定を最適化する例を示します。

switch(config-if)# switchport host
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび稼働ステータスを表示します。

switchport mode

レイヤ 2 インターフェイス タイプを設定するには、 switchport mode コマンドを使用します。インターフェイスをレイヤ 2 アクセス モードに戻すには、このコマンドの no 形式を使用します。

switchport mode { access | trunk }

no switchport mode

 
シンタックスの説明

access

インターフェイスを非トランキングでタグなしのシングル VLAN レイヤ 2 インターフェイスとして指定します。アクセス ポートは、1 つの VLAN でのみトラフィックを送ります。

trunk

トランキング VLAN インターフェイスをレイヤ 2 で指定します。トランク ポートは、同じ物理リンクの(トランク可能 VLAN リスト設定に基づいた)1 つまたは複数の VLAN でトラフィックを送ることができます。

 
デフォルト

アクセス ポート

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

switchport mode コマンドを入力する前に、キーワードなしで switchport コマンドを入力して、LAN インターフェイスをレイヤ 2 インターフェイスとして設定しておく必要があります。この処理は、インターフェイスに対して switchport コマンドを入力しなかった場合にのみ必要となります。

access モードを入力すると、インターフェイスは非トランキング モードになり、 trunk モードを入力すると、インターフェイスはトランキング モードになります。

複数の VLAN に対応するトランク ポートでトラフィックが正しく送信されるようにするため、スイッチでは IEEE 802.1Q カプセル化(すなわちタギング)方式が使用されます。ヘッダー内に 802.1Q タグのあるパケットがアクセス ポートで受信されると、送信元 MAC アドレスが確認されることなくそのパケットは廃棄されます。


) ポートは、アクセス ポート、トランク ポート、またはプライベート VLAN ポートのいずれかとして機能することができ、同時に 3 つのポートになることはできません。


インターフェイス モードを変更すると、ポートはダウンし、再初期化されます。

このコマンドにライセンスは不要です。

次に、インターフェイスをトランキング モードに設定する例を示します。

switch(config-if)# switchport mode trunk
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび稼働ステータスを表示します。

switchport trunk allowed vlan

トランキング インターフェイスで許可される VLAN のリストを設定するには、 switchport trunk allowed vlan コマンドを使用します。トランキング インターフェイスで すべて の VLAN を許可するには、このコマンドの no 形式を使用します。

switchport trunk allowed vlan { vlan-list | all | none | [ add | except | remove { vlan-list }]}

no switchport trunk allowed vlan

 
シンタックスの説明

vlan-list

トランキング モード時にタグ付き形式でこのインターフェイス経由で送信を行う許可 VLAN。有効な値の範囲は 1 ~ 4094 です。

all

すべての適切な VLAN が、トランキング モード時にタグ付き形式でこのインターフェイス経由で送信を行うようにします。

none

VLAN が、トランキング モード時にタグ付き形式でこのインターフェイス経由で送信を行わないようにブロックします。

add

(任意) リストを置き換えるのではなく、現在設定されている VLAN に VLAN の定義済みリストを追加します。

except

(任意) 指定した値を除くすべての VLAN が、トランキング モード時にタグ付き形式でこのインターフェイス経由で送信を行うようにします。

remove

(任意) リストを置き換えるのではなく、現在設定されている VLAN から VLAN の定義済みリストを削除します。

 
デフォルト

すべての VLAN

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

switchport trunk allowed vlan コマンドを入力する前に、キーワードなしで switchport コマンドを入力して、LAN インターフェイスをレイヤ 2 インターフェイスとして設定しておく必要があります。この処理は、インターフェイスに対して switchport コマンドを入力しなかった場合にのみ必要となります。

Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)の宛先ポートがトランク ポートまたはアクセス ポートであるインターフェイスでは、 switchport trunk allowed vlan コマンドを入力できます。

トランクから VLAN 1 を削除しても、トランク インターフェイスは引き続き、VLAN 1 で管理トラフィックの送受信を行います。

このコマンドにライセンスは不要です。

次に、連続する一連の VLAN を、トランキング ポートで許可された VLAN のリストに追加する例を示します。

switch(config-if)# switchport trunk allowed vlan add 40-50
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび稼働ステータスを表示します。

switchport trunk native vlan

インターフェイスがトランキング モードのときにネイティブ VLAN ID を変更するには、 switchport trunk native vlan コマンドを使用します。ネイティブ VLAN ID を VLAN 1 に戻すには、このコマンドの no 形式を使用します。

switchport trunk native vlan vlan-id

no switchport trunk native vlan

 
シンタックスの説明

vlan-id

802.1Q トランキング モードのトランクのネイティブ VLAN。有効な値の範囲は 1 ~ 4094 です(内部的に予約されている VLAN 3968 ~ 4047 および 4094 を除く)。

 
デフォルト

VLAN 1

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

switchport trunk native vlan コマンドを入力する前に、キーワードなしで switchport コマンドを入力して、LAN インターフェイスをレイヤ 2 インターフェイスとして設定しておく必要があります。この処理は、インターフェイスに対して switchport コマンドを入力しなかった場合にのみ必要となります。


) 802,1Q トランク ポートのネイティブ VLAN 設定の詳細については、「vlandot1q tag native」コマンドを参照してください。


ネイティブ モードの VLAN をデバイスのデフォルトの VLAN 1 にリセットするには、 native vlan コマンドの no 形式を使用します。

このコマンドにライセンスは不要です。

次に、トランク モードのインターフェイスのネイティブ VLAN を設定する例を示します。

switch(config-if)# switchport trunk native vlan 5
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび稼働ステータスを表示します。

system default switchport

システムのデフォルトのインターフェイス モードをレイヤ 3 ルーティングからレイヤ 2 スイッチングに変更するには、 system default switchport コマンドを使用します。システムをデフォルトのレイヤ 3 ルーティング インターフェイス モードに戻すには、このコマンドの no 形式を使用します。

system default switchport [ shutdown ]

no system default switchport [ shutdown ]

 
シンタックスの説明

shutdown

(任意)管理状態をダウンとして設定します。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

system default switchport コマンドによって、すべてのインターフェイスのレイヤ 2 がアクセス ポートになります。

このコマンドにライセンスは不要です。

次に、すべてのインターフェイスがレイヤ 2 アクセス モードになるようにシステムを設定する例を示します。

switch(config-if)# system default switchport
switch(config-if)#

 
関連コマンド

コマンド
説明

show interface switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび稼働ステータスを表示します。

tunnel destination

トンネルの宛先エンドポイントを設定するには、 tunnel destination コマンドをインターフェイス コンフィギュレーション モードで使用します。トンネルの宛先を削除するには、このコマンドの no 形式を使用します。

tunnel destination { ip-address | host-name }

no tunnel destination { ip-address | host-name }

 
シンタックスの説明

ip-address

トンネルの宛先の IP アドレス

host-name

トンネルの宛先のホスト名

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

IP トンネルの宛先アドレスを設定するには、 tunnel destination コマンドを使用します。

同じカプセル化モードを使用する、送信元アドレスと宛先アドレスが同一の 2 つのトンネルを持つべきではありません。

このコマンドにはエンタープライズ ライセンスが必要です。

次に、トンネルの宛先を設定する例を示します。

switch(config-if)# tunnel destination 192.0.2.120

 
関連コマンド

コマンド
説明

tunnel source

IP トンネルの送信元を設定します。

interface tunnel

IP トンネルを作成します。

show interface tunnel

指定したトンネル インターフェイスのトラフィックに関する情報を表示します。

tunnel mode

トンネルのトンネル カプセル化モードを設定するには、 tunnel mode コマンドをインターフェイス コンフィギュレーション モードで使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

tunnel mode gre { ip | ipv6 }

no tunnel mode gre { ip | ipv6 }

 
シンタックスの説明

ip

このトンネル カプセル化モードを IPv4 として設定します。

ip v6

このトンネル カプセル化モードを IPv6 として設定します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

トンネルのトンネル カプセル化モードを設定するには、 tunnel mode コマンドを使用します。

このコマンドにはエンタープライズ ライセンスが必要です。

次に、トンネル モードを設定する例を示します。

switch(config-if)# tunnel mode gre ip

 
関連コマンド

コマンド
説明

tunnel destination

IP トンネルの宛先を設定します。

interface tunnel

IP トンネルを作成します。

show interface tunnel

指定されたトンネル インターフェイスのトラフィックに関する情報を表示します。

tunnel path-mtu-discovery

トンネル インターフェイスで Path MTU Discovery(PMTUD; パス最大伝送ユニット ディスカバリ)をイネーブルにするには、インターフェイス コンフィギュレーション モードで tunnel path-mtu-discovery コマンドを使用します。トンネル インターフェイスで PMTUD をディセーブルにするには、このコマンドの no 形式を使用します。

tunnel path-mtu-discovery [ age-timer { aging-mins | infinite } | min-mtu mtu-bytes ]

no tunnel path-mtu-discovery [ age-timer { aging-mins | infinite } | min-mtu mtu-bytes ]

 
シンタックスの説明

age-timer

(任意)指定の間隔で実行されるようにタイマーを設定します(分単位)。タイマーが経過すると、トンネル インターフェイスにより、パスの Maximum Transmission Unit(MTU; 最大伝送ユニット)は、GRE トンネルの場合はデフォルトのトンネル Maximum Transmission Unit(MTU; 最大伝送ユニット)から 24 バイト差し引いた値に、また、IP-in-IP トンネルの場合はデフォルトのトンネル最大伝送ユニットから 20 バイト差し引いた値にリセットされます。

aging-mins

時間(分)。範囲は 10 ~ 30 で、デフォルトは 10 です。

infinite

エージング タイマーがディセーブルになります。

min-mtu mtu-bytes

(任意)GRE トンネル全体の最小のパス最大伝送ユニットを指定します。範囲は 92 ~ 65535 バイトです。デフォルトは 92 です。

 
デフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

トンネル インターフェイスで PMTUD(RFC 1191)がイネーブルになっているときに、ルータはトンネル IP パケットの PMTUD 処理を行います。ルータは常に、トンネルに入った元のデータ IP パケットに対して PMTUD 処理を行います。PMTUD がイネーブルになっているときは、トンネル経由で伝送されるカプセル化されたパケットでパケット フラグメンテーションは発生しません。パケット フラグメンテーションがなければ、TCP 接続のスループットは向上します。PMTUD は、トンネル インターフェイスのエンドポイント間のネットワークで使用可能な帯域幅を最大限に利用します。

PMTUD がイネーブルになると、トンネルに転送される IP パケットのヘッダーの Don't Fragment(DF)ビットが外部 IP パケットの IP ヘッダーにコピーされます。外部 IP パケットはカプセル化 IP パケットです。DF ビットを追加すると、PMTUD メカニズムによってトンネルのトンネル パスが使用できるようになります。トンネル エンドポイントは、メッセージ サイズ超過の Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)到達不能メッセージを待ち受け、トンネル インターフェイスの IP 最大伝送ユニットを必要に応じて変更します。

エージング タイマーが設定されている場合に、このタイマーが切れると、トンネル コードによってトンネル最大伝送ユニットがリセットされます。トンネル最大伝送ユニットのリセット後は、トンネル PMTUD をトリガーして、トンネル最大伝送ユニットを減らすために、DF ビット セットを持つ一連のフルサイズ パケットが必要になります。トンネル最大伝送ユニットが変わるたびに、少なくとも 2 つのパケットが廃棄されます。

PMTUD がディセーブルになると、1 に設定された DF ビットがカプセル化パケットの DF ビットが 1 に設定されていても、外部(カプセル化)IP パケットの DF ビットは 0 に設定されます。

min-mtu キーワード は、PMTUD プロセスで学習できる最大伝送ユニットを介して下限を設定します。設定されている最小の最大伝送ユニットより小さい最大伝送ユニットを指定する受信 ICMP 信号は無視されます。この機能を使用すると、極度に小さい最大伝送ユニットが指定されたルータに、ICMP メッセージを送信できるノードからの DoS 攻撃(サービス拒絶攻撃)を防ぐことができます。


) トンネル インターフェイスで PMTUD を使用するには、トンネル エンドポイントがトンネルのパスで、ルータによって生成された ICMP メッセージを受信できるようにする必要があります。PMTUD を使用する前に、ファイアウォール接続で ICMP メッセージを受信できるかどうかをチェックする必要があります。


このコマンドにはエンタープライズ ライセンスが必要です。

次に、PMTUD を設定する例を示します。

switch(config-if)# tunnel path-mtu-discovery

 
関連コマンド

コマンド
説明

tunnel destination

IP トンネルの宛先を設定します。

interface tunnel

IP トンネルを作成します。

show interface tunnel

指定したトンネル インターフェイスのトラフィックに関する情報を表示します。

tunnel source

トンネルの送信元エンドポイントを設定するには、 tunnel source コマンドをインターフェイス コンフィギュレーション モードで使用します。トンネルの送信元を削除するには、このコマンドの no 形式を使用します。

tunnel source { ip-address | interface-type number }

no tunnel source [ ip-address | interface-type number ]

 
シンタックスの説明

ip-address

トンネルの送信元の IP アドレス

interface-type number

トンネルの送信元のインターフェイス

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

IP トンネルの送信元アドレスを設定するには、 tunnel source コマンドを使用します。

同じ送信元アドレスと宛先アドレスを指定した 2 つのトンネルを同じカプセル化モードで使用しないでください。

このコマンドには Enterprise ライセンスが必要です。

次に、トンネルの送信元を設定する例を示します。

switch(config-if)# tunnel source 192.0.2.120

 
関連コマンド

コマンド
説明

tunnel destination

IP トンネルの宛先を設定します。

interface tunnel

IP トンネルを作成します。

show interface tunnel

指定したトンネル インターフェイスのトラフィックに関する情報を表示します。

tunnel ttl

トンネルの存続可能時間を設定するには、 tunnel ttl コマンドをインターフェイス コンフィギュレーション モードで使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

tunnel ttl value

no tunnel ttl [ value ]

 
シンタックスの説明

value

トンネルの存続可能時間。範囲は 1 ~ 255 です。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

IP トンネルの存続可能時間を設定するには、 tunnel ttl コマンドを使用します。

このコマンドにはエンタープライズ ライセンスが必要です。

次に、トンネル インターフェイスの存続可能時間を設定する例を示します。

switch(config-if)# tunnel ttl 30

 
関連コマンド

コマンド
説明

tunnel destination

IP トンネルの宛先を設定します。

interface tunnel

IP トンネルを作成します。

show interface tunnel

指定したトンネル インターフェイスのトラフィックに関する情報を表示します。

vlan dot1q tag native

トランクのネイティブ VLAN の dot1q(IEEE 802.1Q)タギングをイネーブルにするには、 vlan dot1q tag native コマンドを使用します。デフォルト(トランクのネイティブ VLAN では パケットがタグ付けされない )に戻すには、このコマンドの no 形式を使用します。

vlan dot1q tag native

no vlan dot1q tag native

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者

vdc 管理者

 
コマンド履歴

リリース
変更内容

4.0

このコマンドが導入されました。

 
使用上のガイドライン

通常、802.1Q トランクはネイティブ VLAN ID を使用して設定します。そうすることで、その VLAN のすべてのパケットからタギングが取り除かれ、すべてのタグなしトラフィックと制御トラフィックをスイッチに中継できます。ネイティブ VLAN ID の値と一致する 802.1Q タグを持つ、スイッチに着信するパケットも、同様にタギングが取り除かれます。ネイティブ VLAN でのタギングを維持し、タグなしトラフィックを廃棄する場合は、 vlan dot1q tag native コマンドを入力します。

ネイティブ VLAN で受信したトラフィックにタグ付けするようにスイッチを設定して、802.1Q タグ付きフレームのみ認め、タグなしトラフィック(ネイティブ VLAN のタグなしトラフィックを含む)を廃棄するには、 vlan dot1q tag native コマンドを使用します。 vlan dot1q tag native コマンドがイネーブルになっていても、トランク ポートのネイティブ VLAN のタグなし制御トラフィックは引き続き許可されます。

スイッチのすべてのトランク ポートの全ネイティブ VLAN でタギング動作をイネーブルにするには、このコマンドを使用します。


) あるスイッチで 802.1Q タギングをイネーブルにし、別のスイッチでディセーブルにすると、すべてのトラフィックが廃棄されます。したがって、各スイッチの 802.1Q タギング設定は同一にする必要があります。


このコマンドにライセンスは不要です。

次に、スイッチのすべてのトランク ポートのすべての VLAN で dot1q タギングをイネーブルにする例を示します。

switch(config)# vlan dot1q tag native
switch(config)#

 
関連コマンド

コマンド
説明

show vlan dot1q tag native

ネイティブ VLAN タギング情報を表示します。