Cisco NX-OS Virtual Device Context コマンド リファレンス Release 4.0
Cisco NX-OS VDC のコマンド
Cisco NX-OS VDC のコマンド
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 451KB) | フィードバック

目次

Cisco NX-OS VDC のコマンド

allocate interface ethernet

copy running-config startup-config vdc-all

ha-policy

limit-resource monitor-session

limit-resource port-channel

limit-resource u4route-mem

limit-resource u6route-mem

limit-resource vlan

limit-resource vrf

show resource

show running-config vdc

show running-config vdc-all

show startup-config vdc-all

show vdc

show vdc current-vdc

show vdc membership

show vdc resource

show vdc resource template

switchback

switchto vdc

template

vdc

vdc resource template

Cisco NX-OS VDC のコマンド

Cisco NX-OS Virtual Device Context(VDC; 仮想デバイス コンテキスト)のコマンドについて説明します。

allocate interface ethernet

イーサネット インターフェイスを Virtual Device Context(VDC; 仮想デバイス コンテキスト)に割り当てるには、 allocate interface ethernet コマンドを使用します。

allocate interface ethernet slot / port

allocate interface ethernet slot / port [- port ]

allocate interface ethernet slot / port , ethernet slot1 / port ... [, ethernet slot1 / port ]

 
シンタックスの説明

slot / port

イーサネット インターフェイスのスロット番号とポート番号

 
デフォルト

なし

 
コマンド モード

VDC コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

最初は、すべてのインターフェイスがデフォルト VDC に属しています。個別のインターフェイス、インターフェイスの範囲、またはインターフェイスのリストを割り当てることができます。

物理デバイス上の VDC に割り当てられている現在のインターフェイスを表示するには、 show vdc membership コマンドを使用します。


) インターフェイスを別の VDC に割り当てると、そのインターフェイスの設定はすべて失われます。


インターフェイスを VDC から削除して、デフォルト VDC に戻す場合は、デフォルト VDC で VDC コンフィギュレーション モードを開始して、そのインターフェイスをデフォルト VDC に割り当てる必要があります。

このコマンドには、Advanced Services ライセンスが必要です。

次に、1 つのイーサネット インターフェイスを VDC に割り当てる例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# allocate interface ethernet 2/1

Moving ports will cause all config associated to them in source vdc to be removed. Are you sure you want to move the ports? [yes] yes

 

次に、同じモジュール上にあるイーサネット インターフェイスの範囲を VDC に割り当てる例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# allocate interface ethernet 2/1 - 4

Moving ports will cause all config associated to them in source vdc to be removed. Are you sure you want to move the ports? [yes] yes

 

次に、同じモジュール上にあるイーサネット インターフェイスのリストを VDC に割り当てる例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# allocate interface ethernet 2/1, ethernet 2/3, ethernet 2/5

Moving ports will cause all config associated to them in source vdc to be removed. Are you sure you want to move the ports? [yes] yes

 

次に、1 つのイーサネット インターフェイスをデフォルト VDC に戻す例を示します。

switch# config t
switch(config)# vdc switch
switch(config-vdc)# allocate interface ethernet 2/1

Moving ports will cause all config associated to them in source vdc to be removed. Are you sure you want to move the ports? [yes] yes

 

 
関連コマンド

コマンド
説明

show vdc membership

VDC インターフェイス メンバシップ情報を表示します。

vdc

VDC を作成または指定して、VDC コンフィギュレーション モードを開始します。

copy running-config startup-config vdc-all

すべての Virtual Device Context(VDC; 仮想デバイス コンテキスト)の実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーするには、 copy running-config startup-config vdc-all コマンドを使用します。

copy running-config startup-config vdc-all

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

このコマンドにライセンスは必要ありません。

次に、物理デバイス上のすべての VDC の実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーする例を示します。

switch# copy running-config startup-config vdc-all
[########################################] 100%
 

ha-policy

Virtual Device Context(VDC; 仮想デバイス コンテキスト)でハイ アベイラビリティ(HA)ポリシーを設定するには、 ha-policy コマンドを使用します。

ha-policy {dual-sup {bringdown | restart | switchover} | single-sup {bringdown | reload | restart}}

 
シンタックスの説明

dual-sup

デュアル スーパーバイザ モジュール構成のデバイスに対し、HA ポリシーを指定します。

bringdown

VDC を障害ステートにします。障害ステートから回復するには、物理デバイスをリロードする必要があります。

restart

VDC を削除して、スタートアップ コンフィギュレーションを使用して再作成します。

switchover

スーパーバイザ モジュールのスイッチオーバーを実行します。

dual-sup

デュアル スーパーバイザ モジュール構成のデバイスに対し、HA ポリシーを指定します。

reload

物理デバイスをリロードして、スタートアップ コンフィギュレーションを使用して VDC を再作成します。

 
デフォルト

デフォルト VDC: dual-sup のデフォルトは switchover
single-sup のデフォルトは reload

デフォルト以外の VDC: dual-sup のデフォルトは switchover
single-sup のデフォルトは restart

 
コマンド モード

VDC コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

デフォルト VDC の HA ポリシーは変更できません。

このコマンドには、Advanced Services ライセンスが必要です。

次に、VDC に対して HA ポリシーを指定する例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# ha-policy reset

 
関連コマンド

コマンド
説明

show vdc

VDC インターフェイス メンバシップ情報を表示します。

vdc

VDC を作成または指定して、VDC コンフィギュレーション モードを開始します。

limit-resource monitor-session

Virtual Device Context(VDC; 仮想デバイス コンテキスト)または VDC リソース テンプレートの Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)監視セッションのリソース制限を設定するには、 limit-resource monitor-session コマンドを使用します。デフォルトの設定に戻すには、コマンドの no 形式を使用します。

limit-resource monitor-session minimum min-value maximum { max-value | equal-to-min}

no limit-resource monitor-session

 
シンタックスの説明

minimum

VDC に予約する最小値を指定します。

min-value

SPAN 監視セッションの最小数。範囲は 0 ~ 2 です。

maximum

リソースの使用が可能な最大制限値を指定します。

max-value

SPAN 監視セッションの最大数。範囲は 0 ~ 2 です。

equal-to-min

最大制限は最小制限と常に等しい値になります。

 
デフォルト

デフォルトの最小値は 0 です。
デフォルトの最大値は 2 です。

 
コマンド モード

VDC コンフィギュレーション
VDC リソース テンプレート コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

NX-OS ソフトウェアにより、リソースの最小制限が予約されます。SPAN 監視セッションの最小制限を変更すると、変更はすぐに反映されます。

このコマンドにライセンスは必要ありません。

次に、VDC の SPAN 監視セッション制限を設定する例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# limit-resource session-monitor minimum 1 maximum 2
 

次に、VDC の SPAN 監視セッション制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# no limit-resource session-monitor
 

次に、VDC リソース テンプレートの SPAN 監視セッション制限を設定する例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# limit-resource session-monitor minimum 0 maximum 1
 

次に、VDC リソース テンプレートの SPAN 監視セッション制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# no limit-resource session-monitor
 

 
関連コマンド

コマンド
説明

show vdc resource [ detail ]

VDC リソース制限情報を表示します。

show vdc resource template

VDC リソース制限情報を表示します。

vdc

VDC を作成または指定して、VDC コンフィギュレーション モードを開始します。

limit-resource port-channel

Virtual Device Context(VDC; 仮想デバイス コンテキスト)または VDC リソース テンプレートのポート チャネル リソース制限を設定するには、 limit-resource port-channel コマンドを使用します。デフォルトの設定に戻すには、コマンドの no 形式を使用します。

limit-resource port-channel minimum min-value maximum { max-value | equal-to-min}

no limit-resource monitor-session

 
シンタックスの説明

minimum

VDC に予約する最小値を指定します。

min-value

ポート チャネルの最小数。範囲は 0 ~ 192 です。

maximum

リソースの使用が可能な最大制限値を指定します。

max-value

ポート チャネルの最大数。範囲は 0 ~ 192 です。

equal-to-min

最大制限は最小制限と常に等しい値になります。

 
デフォルト

デフォルトの最小値は 0 です。
デフォルトの最大値は 192 です。

 
コマンド モード

VDC コンフィギュレーション
VDC リソース テンプレート コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

NX-OS ソフトウェアにより、リソースの最小制限が予約されます。ポート チャネルの最小制限を変更すると、変更はすぐに反映されます。

このコマンドにライセンスは必要ありません。

次に、VDC のポート チャネル制限を設定する例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# limit-resource port-channel minimum 8 maximum 64
 

次に、VDC のポート チャネル制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# no limit-resource port-channel
 

次に、VDC リソース テンプレートのポート チャネル制限を設定する例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# limit-resource port-channel minimum 4 maximum 128
 

次に、VDC リソース テンプレートのポート チャネル制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# no limit-resource port-channel
 

 
関連コマンド

コマンド
説明

show vdc resource

VDC リソース制限情報を表示します。

vdc

VDC を作成または指定して、VDC コンフィギュレーション モードを開始します。

vdc resource template

VDC リソース テンプレートを作成または指定して、VDC リソース テンプレート コンフィギュレーション モードを開始します。

limit-resource u4route-mem

Virtual Device Context(VDC; 仮想デバイス コンテキスト)または VDC リソース テンプレートの IPv4 ルート マップ メモリ リソース制限を設定するには、 limit-resource u4route-mem コマンドを使用します。デフォルトの設定に戻すには、コマンドの no 形式を使用します。

limit-resource u4route-mem minimum min-value maximum max-value

no limit-resource u4route-mem

 
シンタックスの説明

minimum

VDC に予約する最小値を指定します。

min-value

IPv4 ルート メモリの最小容量(メガバイト単位)。範囲は 1 ~ 80 MB です。

maximum

リソースの使用が可能な最大制限値を指定します。

max-value

IPv4 ルート メモリの最大容量(メガバイト単位)。最大値は 80 MB です。

 
デフォルト

デフォルト VDC のデフォルト最小値は 32 MB です。
デフォルト VDC のデフォルト最大値は 80 MB です。
デフォルト以外の VDC のデフォルト最小値は 8 MB です。
デフォルト以外の VDC のデフォルト最大値は 80 MB です。

 
コマンド モード

VDC コンフィギュレーション
VDC リソース テンプレート コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

IPv4 の Routing Information Base(RIB; ルーティング情報ベース)は共有メモリにあります。4 GB メモリ搭載の物理デバイス上の全 VDC に対する RIB の使用可能な共有メモリの総容量は 256 MB です。4 MB の IPv4 ルート マップ メモリ内に、それぞれ 16 のネクストホップがある約 11,000 のルートを持つことができます。


) VDC の IPv4 ルート マップ メモリを予約する際は、使用可能な容量を超える共有メモリを予約しないように注意してください。


NX-OS ソフトウェアにより、リソースの最小制限が予約されます。IPv4 ルート マップ メモリの最小制限を変更した場合、デバイスのリロード後、またはステートフル スーパーバイザ モジュールがスイッチオーバーしたあとに変更が反映されます。

このコマンドにライセンスは必要ありません。

次に、VDC の IPv4 ルート メモリ制限を設定する例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# limit-resource u4route-mem minimum 8 maximum 64
 

次に、VDC の IPv4 ルート メモリ制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# no limit-resource u4route-mem
 

次に、VDC リソース テンプレートの IPv4 ルート メモリ制限を設定する例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# limit-resource u4route-mem minimum 4 maximum 40
 

次に、VDC リソース テンプレートの IPv4 ルート メモリ制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# no limit-resource u4route-mem
 

 
関連コマンド

コマンド
説明

show vdc resource

VDC リソース制限情報を表示します。

vdc

VDC を作成または指定して、VDC コンフィギュレーション モードを開始します。

vdc resource template

VDC リソース テンプレートを作成または指定して、VDC リソース テンプレート コンフィギュレーション モードを開始します。

limit-resource u6route-mem

Virtual Device Context(VDC; 仮想デバイス コンテキスト)または VDC リソース テンプレートの IPv6 ルート マップ メモリ リソース制限を設定するには、 limit-resource u6route-mem コマンドを使用します。デフォルトの設定に戻すには、コマンドの no 形式を使用します。

limit-resource u6route-mem minimum min-value maximum max-value

no limit-resource u6route-mem

 
シンタックスの説明

minimum

VDC に予約する最小値を指定します。

min-value

IPv6 ルート メモリの最小容量(メガバイト単位)。範囲は 1 ~ 48 MB です。

maximum

リソースの使用が可能な最大制限値を指定します。

max-value

IPv6 ルート メモリの最大容量(メガバイト単位)。最大値は 48 MB です。

 
デフォルト

デフォルト VDC のデフォルト最小値は 16 MB です。
デフォルト VDC のデフォルト最大値は 48 MB です。
デフォルト以外の VDC のデフォルト最小値は 4 MB です。
デフォルト以外の VDC のデフォルト最大値は 48 MB です。

 
コマンド モード

VDC コンフィギュレーション
VDC リソース テンプレート コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

IPv6 の Routing Information Base(RIB; ルーティング情報ベース)は共有メモリにあります。4 GB メモリ搭載の物理デバイスでの RIB の利用可能な共有メモリの総容量は、IPv4 および IPv6 ルート マップ メモリの両方で 256 MB です。4 MB の Ipv6 ルート マップ メモリ内に、それぞれ 16 のネクストホップがある約 11,000 のルートを持つことができます。


) VDC の IPv6 ルート マップ メモリを予約する際は、使用可能な容量を超える共有メモリを予約しないように注意してください。


NX-OS ソフトウェアにより、リソースの最小制限が予約されます。IPv6 ルート マップ メモリの最小制限を変更した場合、デバイスのリロード後、またはステートフル スーパーバイザ モジュールがスイッチオーバーしたあとに変更が反映されます。

このコマンドにライセンスは必要ありません。

次に、VDC の IPv6 ルート メモリ制限を設定する例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# limit-resource u6route-mem minimum 8 maximum 24
 

次に、VDC の IPv6 ルート メモリ制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# no limit-resource u6route-mem
 

次に、VDC リソース テンプレートの IPv6 ルート メモリ制限を設定する例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# limit-resource u6route-mem minimum 4 maximum 32
 

次に、VDC リソース テンプレートの IPv6 ルート メモリ制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# no limit-resource u6route-mem
 

 
関連コマンド

コマンド
説明

show vdc resource

VDC リソース制限情報を表示します。

vdc

VDC を作成または指定して、VDC コンフィギュレーション モードを開始します。

vdc resource template

VDC リソース テンプレートを作成または指定して、VDC リソース テンプレート コンフィギュレーション モードを開始します。

limit-resource vlan

Virtual Device Context(VDC; 仮想デバイス コンテキスト)または VDC リソース テンプレートの VLAN リソース制限を設定するには、 limit-resource vlan コマンドを使用します。デフォルトの設定に戻すには、コマンドの no 形式を使用します。

limit-resource vlan minimum min-value maximum { max-value | equal-to-min}

no limit-resource vlan

 
シンタックスの説明

minimum

VDC に予約する最小値を指定します。

min-value

VLAN の最小数。範囲は 16 ~ 4094 です。

maximum

リソースの使用が可能な最大制限値を指定します。

max-value

VLAN の最大数。範囲は 16 ~ 4094 です。

equal-to-min

最大制限は最小制限と常に等しい値になります。

 
デフォルト

デフォルトの最小値は 16 です。
デフォルトの最大値は 4094 です。

 
コマンド モード

VDC コンフィギュレーション
VDC リソース テンプレート コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

NX-OS ソフトウェアにより、リソースの最小制限が予約されます。VLAN の最小制限を変更すると、変更はすぐに反映されます。

このコマンドにライセンスは必要ありません。

次に、VDC の VLAN 制限を設定する例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# limit-resource vlan minimum 32 maximum 2056
 

次に、VDC の VLAN 制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# no limit-resource vlan
 

次に、VDC リソース テンプレートの VLAN 制限を設定する例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# limit-resource vlan minimum 24 maximum 3000
 

次に、VDC リソース テンプレートの VLAN 制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# no limit-resource vlan
 

 
関連コマンド

コマンド
説明

show vdc resource

VDC リソース制限情報を表示します。

vdc

VDC を作成または指定して、VDC コンフィギュレーション モードを開始します。

vdc resource template

VDC リソース テンプレートを作成または指定して、VDC リソース テンプレート コンフィギュレーション モードを開始します。

limit-resource vrf

Virtual Device Context(VDC; 仮想デバイス コンテキスト)または VDC リソース テンプレートの Virtual Routing and Forwarding(VRF)インスタンスのリソース制限を設定するには、 limit-resource vrf コマンドを使用します。デフォルトの設定に戻すには、コマンドの no 形式を使用します。

limit-resource vrf minimum min-value maximum { max-value | equal-to-min}

no limit-resource vrf

 
シンタックスの説明

minimum

VDC に予約する最小値を指定します。

min-value

VRF の最小数。範囲は 16 ~ 8192 です。

maximum

リソースの使用が可能な最大制限値を指定します。

max-value

VRF の最大数。範囲は 16 ~ 8192 です。

equal-to-min

最大制限は最小制限と常に等しい値になります。

 
デフォルト

デフォルトの最小値は 16 です。
デフォルトの最大値は 8192 です。

 
コマンド モード

VDC コンフィギュレーション
VDC リソース テンプレート コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

NX-OS ソフトウェアにより、リソースの最小制限が予約されます。VRF の最小制限を変更すると、変更はすぐに反映されます。

このコマンドにライセンスは必要ありません。

次に、VDC の VRF 制限を設定する例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# limit-resource vrf minimum 32 maximum 4000
 

次に、VDC の VRF 制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# no limit-resource vrf
 

次に、VRF リソース テンプレートの VLAN 制限を設定する例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# limit-resource vrf minimum 64 maximum 6000
 

次に、VRF リソース テンプレートの VLAN 制限をデフォルトに戻す例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)# no limit-resource vrf
 

 
関連コマンド

コマンド
説明

show vdc resource

VDC リソース制限情報を表示します。

vdc

VDC を作成または指定して、VDC コンフィギュレーション モードを開始します。

vdc resource template

VDC リソース テンプレートを作成または指定して、VDC リソース テンプレート コンフィギュレーション モードを開始します。

show resource

Virtual Device Context(VDC; 仮想デバイス コンテキスト)のリソース使用状況を表示するには、 show resource コマンドを使用します。

show resource [monitor-sessions | port-channel | u4route-mem | u6route-mem | vlan | vrf]

 
シンタックスの説明

monitor-sessions

(任意)監視セッションのリソース使用状況が表示されます。

port-channel

(任意)ポート チャネルのリソース使用状況が表示されます。

u4route-mem

(任意)IPv4 ルート マップ メモリのリソース使用状況が表示されます。

u6route-mem

(任意)IPv6 ルート マップ メモリのリソース使用状況が表示されます。

monitor-sessions

(任意)監視セッションのリソース使用状況が表示されます。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator
vdc-admin
vdc-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにライセンスは必要ありません。

次に、VDC のリソース使用状況を表示する例を示します。

switch# show resource
 
Resource Min Max Used Unused Avail
----------- ----- ----- ------ -------- -------
port-channel 0 192 4 0 188
monitor-session 0 2 2 0 0
vlan 16 4094 12 4 4082
u6route-mem 16 256 16 0 232
u4route-mem 32 256 32 0 208
vrf 16 8192 2 14 8158
 
 

show running-config vdc

デフォルト VDC 実行コンフィギュレーションの VDC 情報を表示するには、 show running-config vdc コマンドを使用します。

show running-config vdc

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator
vdc-admin
vdc-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

このコマンドにライセンスは必要ありません。

次に、実行コンフィギュレーションの VDC 情報を表示する例を示します。

switch# show running-config vdc
version 4.0(1)
vdc switch id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 32 maximum 256
limit-resource u6route-mem minimum 16 maximum 256
vdc Payroll id 2
allocate interface Ethernet2/47
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 8 maximum 256
limit-resource u6route-mem minimum 4 maximum 256
vdc Engineering id 3
allocate interface Ethernet2/46
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 8 maximum 256
limit-resource u6route-mem minimum 4 maximum 256
vdc resource template MyTemplate
 

show running-config vdc-all

すべての VDC の実行コンフィギュレーションを表示するには、 show running-config vdc-all コマンドを使用します。

show running-config vdc-all [all]

 
シンタックスの説明

all

(任意)実行コンフィギュレーションの VDC デフォルト設定情報が表示されます。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator
vdc-admin
vdc-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

このコマンドにライセンスは必要ありません。

次に、すべての VDC の実行コンフィギュレーションを表示する例を示します。

switch# show running-config vdc-all
!Running config for vdc: switch
 
 
switchto vdc switch
version 4.0(1)
snmp-server enable traps entity
power redundancy-mode combined force
feature tacacs+
feature pbr
feature private-vlan
feature interface-vlan
feature dot1x
feature lacp
feature glbp
feature dhcp
feature eou
feature tunnel
feature cts
logging level glbp 6
role name MyRole
username adminbackup password 5 $1$Oip/C5Ci$oOdx7oJSlBCFpNRmQK4na. role network
-operator
username admin password 5 $1$x.9srJIq$jvKISFQ1sxR4oi44YanxJ0 role network-admin
username User1 password 5 $1$Dm4XUUyR$V1/3B25/84g3YRkOt3Rj50 role network-opera
tor
telnet server enable
ssh key rsa 768 force
kernel core target 0.0.0.0
kernel core limit 1
aaa group server radius aaa-private-sg
use-vrf management
vlan dot1Q tag native
system default switchport
no system default switchport shutdown
snmp-server user User1 auth md5 0xbc9d5254b8aedec4747ad156d8726ae0 priv 0xbc9d52
54b8aedec4747ad156d8726ae0 localizedkey engineID 128:0:0:9:3:0:24:186:216:63:188
snmp-server user admin auth md5 0xbc9d5254b8aedec4747ad156d8726ae0 priv 0xbc9d52
54b8aedec4747ad156d8726ae0 localizedkey engineID 128:0:0:9:3:0:24:186:216:63:188
snmp-server enable traps license
vrf context management
ip route 0.0.0.0/0 172.28.230.1
logging level sysmgr 1
logging server 172.28.254.254
vdc switch id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 32 maximum 256
limit-resource u6route-mem minimum 16 maximum 256
vdc Payroll id 2
allocate interface Ethernet2/47
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 8 maximum 256
limit-resource u6route-mem minimum 4 maximum 256
vdc Engineering id 3
allocate interface Ethernet2/46
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 8 maximum 256
limit-resource u6route-mem minimum 4 maximum 256
vdc resource template MyTemplate
 
interface Vlan1
 
interface Ethernet2/1
shutdown
switchport
switchport monitor
ip access-group markin in
ip dhcp snooping limit rate 80
ip arp inspection limit rate 300 burst interval 5
 
interface Ethernet2/2
shutdown
no switchport
 
interface Ethernet2/2.1
shutdown
 
interface Ethernet2/3
no cdp enable
shutdown
storm-control broadcast level 20
storm-control unicast level 20
switchport
dot1x mac-auth-bypass
 
....
 
interface mgmt0
ip address 172.28.231.193/23
 
line console
speed 115200
logging level cdp 6
event manager applet x
monitor session 1
no shut
monitor session 2
no shut
source interface Ethernet2/2 both
source interface Ethernet2/5 both
destination interface Ethernet2/1
destination interface Ethernet2/3
filter vlan 50
monitor session 3
no shut
logging level dhcp_snoop 6
logging level eth_port_channel 6
logging ip access-list cache entries 8000
logging ip access-list cache interval 300
logging ip access-list cache threshold 0
acllog match-log-level 6
 
!Running config for vdc: Payroll
 
 
switchto vdc Payroll
im_verify_ifindex failed for 0x5000000
status: 0x411a0000 - shared pss not opened
if_info_status: 0x0
version 4.0(1)
username admin password 5 $1$f89fb1AG$TK6vd.TAq0rp9Gwzc7j6y0 role network-admi
telnet server enable
ssh key rsa 768 force
aaa group server radius aaa-private-sg
use-vrf management
snmp-server user admin network-admin auth md5 0xddf68fa88ad2a5ea0818856db35fa9f
priv 0xddf68fa88ad2a5ea0818856db35fa9fb localizedkey
vrf context management
ip route 0.0.0.0/0 172.28.230.1
logging server 172.28.254.254
 
interface Ethernet2/47
logging ip access-list cache entries 8000
logging ip access-list cache interval 300
logging ip access-list cache threshold 0
acllog match-log-level 6
 
!Running config for vdc: Engineering
 
 
switchto vdc Engineering
im_verify_ifindex failed for 0x5000000
status: 0x411a0000 - shared pss not opened
if_info_status: 0x0
version 4.0(1)
username admin password 5 $1$pPFrW5.g$rciQSDOB/A/c0N8eXf1081 role network-admi
telnet server enable
ssh key rsa 768 force
aaa group server radius aaa-private-sg
use-vrf management
snmp-server user admin network-admin auth md5 0x67568a735d6a1f7e4833fd0de8c196f
priv 0x67568a735d6a1f7e4833fd0de8c196fb localizedkey
vrf context management
ip route 0.0.0.0/0 172.28.230.1
logging server 172.28.254.254
 
interface Ethernet2/46
logging ip access-list cache entries 8000
logging ip access-list cache interval 300
logging ip access-list cache threshold 0
acllog match-log-level 6

show startup-config vdc-all

スタートアップ コンフィギュレーションのすべての VDC の設定情報を表示するには、 show startup-config vdc-all コマンドを使用します。

show startup-config vdc-all

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator
vdc-admin
vdc-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

このコマンドにライセンスは必要ありません。

次に、スタートアップ コンフィギュレーションのすべての VDC の情報を表示する例を示します。

switch# show startup-config vdc-all
 

show vdc

VDC 情報を表示するには、 show vdc コマンドを使用します。

show vdc [ vdc-name ] [detail]

 
シンタックスの説明

vdc-name

(任意)VDC 名

detail

(任意)VDC に関する詳細情報が表示されます。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator
vdc-admin
vdc-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

デフォルト VDC の場合、このコマンドにより、物理デバイス上のすべての VDC に関する情報が表示されます。デフォルト以外の VDC の場合、このコマンドにより、現在の VDC に関する情報のみが表示されます。

このコマンドにライセンスは必要ありません。

次に、デフォルト VDC の VDC に関するサマリー情報を表示する例を示します。

switch# show vdc
 
vdc_id vdc_name state mac
------ -------- ----- ----------
1 switch active 00:18:ba:d8:3f:fd
2 Payroll active 00:18:ba:d8:3f:fe
3 MyVDC active 00:18:ba:d8:3f:ff
 

次に、デフォルト VDC の VDC に関する詳細情報を表示する例を示します。

switch# show vdc detail
vdc id: 1
vdc name: switch
vdc state: active
vdc mac address: 00:18:ba:d8:3f:fd
vdc ha policy: RESET
vdc swover policy: RESET
 
vdc id: 2
vdc name: Payroll
vdc state: active
vdc mac address: 00:18:ba:d8:3f:fe
vdc ha policy: RESTART
vdc swover policy: BRINGDOWN
 
vdc id: 3
vdc name: MyVDC
vdc state: active
vdc mac address: 00:18:ba:d8:3f:ff
vdc ha policy: RESTART
vdc swover policy: BRINGDOWN
 

次に、デフォルト以外の VDC の VDC に関するサマリー情報を表示する例を示します。

switch-Payroll# show vdc
 
vdc_id vdc_name state mac
------ -------- ----- ----------
2 Payroll active 00:18:ba:d8:3f:fe
 

次に、デフォルト以外の VDC の VDC に関する詳細情報を表示する例を示します。

switch-Payroll# show vdc detail
vdc id: 2
vdc name: Payroll
vdc state: active
vdc mac address: 00:18:ba:d8:3f:fe
vdc ha policy: RESTART
vdc swover policy: BRINGDOWN
 

show vdc current-vdc

現在の VDC の識別情報を表示するには、 show vdc current-vdc コマンドを使用します。

show vdc current-vdc

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator
vdc-admin
vdc-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、すべての VDC で使用できます。

このコマンドにライセンスは必要ありません。

次に、現在の VDC の識別情報を表示する例を示します。

switch-Payroll# show vdc current-vdc
Current vdc is 2 - Payroll
 

show vdc membership

VDC のインターフェイス メンバシップ情報を表示するには、 show vdc membership コマンドを使用します。

show vdc membership [status]

 
シンタックスの説明

status

(任意)インターフェイスに関するステータス情報が表示されます。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator
vdc-admin
vdc-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC のみで使用できます。

このコマンドにライセンスは必要ありません。

次に、デフォルト VDC のインターフェイス メンバシップ情報を表示する例を示します。

switch# show vdc membership
 
vdc_id: 1 vdc_name: switch interfaces:
Ethernet2/1 Ethernet2/2 Ethernet2/3
Ethernet2/4 Ethernet2/5 Ethernet2/6
Ethernet2/7 Ethernet2/8 Ethernet2/9
Ethernet2/10 Ethernet2/11 Ethernet2/12
Ethernet2/13 Ethernet2/14 Ethernet2/15
Ethernet2/16 Ethernet2/17 Ethernet2/18
Ethernet2/19 Ethernet2/20 Ethernet2/21
Ethernet2/22 Ethernet2/23 Ethernet2/24
Ethernet2/25 Ethernet2/26 Ethernet2/27
Ethernet2/28 Ethernet2/29 Ethernet2/30
Ethernet2/31 Ethernet2/32 Ethernet2/33
Ethernet2/34 Ethernet2/35 Ethernet2/36
Ethernet2/37 Ethernet2/38 Ethernet2/39
Ethernet2/40 Ethernet2/41 Ethernet2/42
Ethernet2/43 Ethernet2/44 Ethernet2/45
Ethernet2/48
vdc_id: 2 vdc_name: Payroll interfaces:
Ethernet2/47
vdc_id: 3 vdc_name: MyVDC interfaces:
Ethernet2/46
 

次に、デフォルト以外の VDC のインターフェイス メンバシップ情報を表示する例を示します。

switch-Payroll# show vdc membership
 
vdc_id: 2 vdc_name: Payroll interfaces:
Ethernet2/47
 

次に、デフォルト VDC のインターフェイス ステータス情報を表示する例を示します。

switch# show vdc membership status
 
vdc_id: 1 vdc_name: switch interfaces:
Port Status
---- ----------
Eth2/1 OK
Eth2/2 OK
Eth2/3 OK
Eth2/4 OK
Eth2/5 OK
Eth2/6 OK
Eth2/7 OK
Eth2/8 OK
Eth2/9 OK
Eth2/10 OK
...
 

show vdc resource

VDC リソース情報を表示するには、 show vdc resource コマンドを使用します。

show vdc resource [monitor-session | port-channel | u4route-map | vlan | vrf] [detail]

 
シンタックスの説明

monitor-session

(任意)Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)監視セッションのリソースのみが表示されます。

port-channel

(任意)ポート チャネルのリソース情報のみが表示されます。

u4route-map

(任意)IPv4 ルート マップのリソース情報のみが表示されます。

vlan

(任意)VLAN のリソース情報のみが表示されます。

vrf

(任意)Virtual Routing and Forwarding(VRF)インスタンスのリソース情報のみが表示されます。

detail

(任意)詳細情報が表示されます。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator
vdc-admin
vdc-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

このコマンドにライセンスは必要ありません。

次に、VDC リソースのサマリー情報を表示する例を示します。

switch# show vdc resource
 
port-channel 0 used 0 unused 192 free 192 total
 
monitor-session 0 used 0 unused 2 free 2 total
 
vlan 14 used 34 unused 16370 free 16384 total
 
u4route-mem 48 used 0 unused 208 free 256 total
 
vrf 6 used 42 unused 8186 free 8192 total
 

次に、VDC リソースの詳細情報を表示する例を示します。

switch# show vdc resource detail
 
port-channel 0 used 0 unused 192 free 192 total
--------------
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 0 192 0 0 192
Payroll 0 192 0 0 192
MyVDC 0 192 0 0 192
 
monitor-session 0 used 0 unused 2 free 2 total
-----------------
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 0 2 0 0 2
Payroll 0 2 0 0 2
MyVDC 0 2 0 0 2
 
vlan 14 used 34 unused 16370 free 16384 total
------
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 16 4094 10 6 4084
Payroll 16 4094 2 14 4092
MyVDC 16 4094 2 14 4092
 
u4route-mem 48 used 0 unused 208 free 256 total
-------------
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 32 256 32 0 208
Payroll 8 256 8 0 208
MyVDC 8 256 8 0 208
 
vrf 6 used 42 unused 8186 free 8192 total
-----
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 16 8192 2 14 8158
Payroll 16 8192 2 14 8158
MyVDC 16 8192 2 14 8158
 

次に、ポート チャネルの VDC リソースのサマリー情報を表示する例を示します。

switch# show vdc resource port-channel
 
port-channel 0 used 0 unused 192 free 192 total
 

次に、ポート チャネルの VDC リソースの詳細情報を表示する例を示します。

switch# show vdc resource port-channel detail
 
port-channel 0 used 0 unused 192 free 192 total
--------------
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 0 192 0 0 192
Payroll 0 192 0 0 192
MyVDC 0 192 0 0 192
 

show vdc resource template

VDC リソース テンプレート情報を表示するには、 show vdc resource template コマンドを使用します。

show vdc resource template [ vdc-template-name ]

 
シンタックスの説明

vdc-template-name

(任意)VDC リソース テンプレート名

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator
vdc-admin
vdc-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

このコマンドにライセンスは必要ありません。

次に、すべての VDC リソース テンプレートのサマリー情報を表示する例を示します。

switch# show vdc resource template
 
MyTemplate
------------
Resource Min Max
---------- ----- -----
port-channel 8 64
 
global-default
----------------
Resource Min Max
---------- ----- -----
u4route-mem 32 256
 
vdc-default
-------------
Resource Min Max
---------- ----- -----
port-channel 0 192
monitor-session 0 2
vlan 16 4094
u4route-mem 8 256
vrf 16 8192
 

次に、特定の VDC リソース テンプレートのサマリー情報を表示する例を示します。

switch# show vdc resource template MyTemplate
 
MyTemplate
------------
Resource Min Max
---------- ----- -----
port-channel 8 64
 

次に、VDC リソースの詳細情報を表示する例を示します。

switch# show vdc resource detail
 
port-channel 0 used 0 unused 192 free 192 total
--------------
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 0 192 0 0 192
Payroll 0 192 0 0 192
MyVDC 0 192 0 0 192
 
monitor-session 0 used 0 unused 2 free 2 total
-----------------
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 0 2 0 0 2
Payroll 0 2 0 0 2
MyVDC 0 2 0 0 2
 
vlan 14 used 34 unused 16370 free 16384 total
------
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 16 4094 10 6 4084
Payroll 16 4094 2 14 4092
MyVDC 16 4094 2 14 4092
 
u4route-mem 48 used 0 unused 208 free 256 total
-------------
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 32 256 32 0 208
Payroll 8 256 8 0 208
MyVDC 8 256 8 0 208
 
vrf 6 used 42 unused 8186 free 8192 total
-----
Vdc Min Max Used Unused Avail
----- ----- ----- ------ -------- -------
switch 16 8192 2 14 8158
Payroll 16 8192 2 14 8158
MyVDC 16 8192 2 14 8158
 

switchback

Virtual Device Context(VDC; 仮想デバイス コンテキスト)をデフォルトの VDC に戻す場合は、 switchback コマンドを使用します。

switchto vdc vdc-name

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Advanced Services ライセンスが必要です。

次に、デフォルト VDC に戻す例を示します。

switch-MyVDC# switchback
switch(config)#
 

 
関連コマンド

コマンド
説明

show current vdc

現在の VDC に関する情報が表示されます。

switchto vdc

デフォルト以外の VDC に切り替わります。

switchto vdc

デフォルト Virtual Device Context(VDC; 仮想デバイス コンテキスト)を別の VDC に切り替える場合は、 switchto vdc コマンドを使用します。

switchto vdc vdc-name

 
シンタックスの説明

vdc-name

VDC 名

 
デフォルト

なし

 
コマンド モード

任意のコンフィギュレーション モード

サポートされるユーザ ロール

network-admin
network-operator

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)からのみ使用できます。

デフォルト VDC に戻るには、EXEC モードで exit コマンドを使用するか、または switchback コマンドを使用します。

このコマンドには、Advanced Services ライセンスが必要です。

次に、VDC に切り替える例を示します。

switch# switchto vdc MyDevice
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2008, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained in this software are
owned by other third parties and used and distributed under
license. Certain components of this software are licensed under
the GNU General Public License (GPL) version 2.0 or the GNU
Lesser General Public License (LGPL) Version 2.1. A copy of each
such license is available at
http://www.opensource.org/licenses/gpl-2.0.php and
http://www.opensource.org/licenses/lgpl-2.1.php
switch-MyDevice#
 

 
関連コマンド

コマンド
説明

show current vdc

現在の VDC に関する情報が表示されます。

switchback

デフォルト VDC に戻ります。

template

Virtual Device Context(VDC; 仮想デバイス コンテキスト)のリソース テンプレートを VDC に適用するには、 template コマンドを使用します。

template vdc-template-name

 
シンタックスの説明

vdc-template-name

VDC リソース テンプレート名

 
デフォルト

なし

 
コマンド モード

VDC コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

このコマンドにライセンスは必要ありません。

次に、リソース テンプレートを VDC に適用する例を示します。

switch# config t
switch(config)# vdc MyDevice
switch(config-vdc)# template MyTemplate
 

 
関連コマンド

コマンド
説明

show vdc

VDC インターフェイス メンバシップ情報を表示します。

vdc

VDC を作成または指定して、VDC コンフィギュレーション モードを開始します。

vdc

Virtual Device Context(VDC; 仮想デバイス コンテキスト)を作成または指定して、VDC コンフィギュレーション モードを開始するには、 vdc コマンドを使用します。VDC を削除するには、コマンドの no 形式を使用します。

vdc vdc-name [{dual-sup {bringdown | restart | switchover} [single-sup {bringdown | reload | restart}] | single-sup {bringdown | reload | restart} [dual-sup {bringdown | restart | switchover}]}] [id vdc-id ] [template vdc-template-name ]

no vdc vdc-name

 
シンタックスの説明

ha-policy

(任意)回復不能なエラーが発生したときのために、VDC のハイ アベイラビリティ(HA)ポリシーを指定します。デフォルトは restart です。

dual-sup

デュアル スーパーバイザ モジュール構成のデバイスに対し、HA ポリシーを指定します。

bringdown

VDC を障害ステートにします。障害ステートから回復するには、物理デバイスをリロードする必要があります。

restart

VDC を削除して、スタートアップ コンフィギュレーションを使用して再作成します。

switchover

スーパーバイザ モジュールのスイッチオーバーを実行します。

dual-sup

デュアル スーパーバイザ モジュール構成のデバイスに対し、HA ポリシーを指定します。

reload

物理デバイスをリロードして、スタートアップ コンフィギュレーションを使用して VDC を再作成します。

id vdc-id

(任意)VDC ID を指定します。デフォルトは、使用可能な最初の番号です。

template vdc-template-name

(任意)VDC リソース テンプレート名を指定します。デフォルトは、デフォルト VDC リソース テンプレートです。

 
デフォルト

デフォルト VDC のデフォルト HA ポリシー: dual-sup のデフォルトは switchover
single-sup のデフォルトは reload

デフォルト以外の VDC のデフォルト HA ポリシー: dual-sup のデフォルトは switchover
single-sup のデフォルトは restart

デフォルト VDC ID は、使用可能な最初の番号です。
デフォルト VDC リソース テンプレートはデフォルトのテンプレートです。
デフォルトのスイッチオーバー ポリシーは bringdown です。

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

VDC を作成するときには、NX-OS ソフトウェアによって、VDC の内部リソースが割り当てられます。このプロセスが完了するには、VDC 用に要求する内部リソースの量に応じて数分かかる場合があります。

VDC を削除するときには、NX-OS ソフトウェアによって、インターフェイス設定が削除され、インターフェイスをデフォルト VDC に返します。

このコマンドでデフォルト以外の VDC を作成および管理するには、Advanced Services ライセンスが必要です。デフォルト VDC の管理にはライセンスは不要です。

次に、VDC を作成して、VDC コンフィギュレーション モードを開始する例を示します。

switch# config t
switch(config)# vdc MyDevice
Note: VDC creation is a time consuming process, please wait until the command completes
switch(config-vdc)#
 

次に、VDC を削除する例を示します。

switch# config t
switch(config)# no vdc MyDevice
Deleting this vdc will remove its config. Continue deleting this vdc? [no] yes
Note: VDC deletion is a time consuming process, please wait until the command completes
 

 
関連コマンド

コマンド
説明

show vdc

VDC ステータス情報を表示します。

vdc resource template

Virtual Device Context(VDC; 仮想デバイス コンテキスト)リソース テンプレートを作成または指定して、VDC リソース テンプレート コンフィギュレーション モードを開始するには、 vdc コマンドを使用します。VDC リソース テンプレートを削除するには、コマンドの no 形式を使用します。

vdc resource template vdc-template-name

no vdc resource template vdc-template-name

 
シンタックスの説明

vdc-template-name

VDC リソース テンプレート名を指定します。名前は 32 文字以内で指定します。大文字と小文字は区別されません。

 
デフォルト

リソース
最小
最大

IPv4 ルート マップ メモリ 1

8

256

IPv6 ルート マップ メモリ 1

4

256

ポート チャネル

0

256

SPAN セッション

0

2

VLAN

16

4094

VRF

16

8192

1.ルート マップ メモリ制限はメガバイト単位で表しています。

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

network-admin

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、デフォルト VDC(VDC 1)のみで使用できます。

NX-OS ソフトウェアによって提供されたデフォルト VDC のリソース テンプレートは変更することはできません。

最大 64 の VDC リソース テンプレートを作成できます。

このコマンドにライセンスは必要ありません。

次に、VDC リソース テンプレートを作成または指定して、VDC リソース テンプレート コンフィギュレーション モードを開始する例を示します。

switch# config t
switch(config)# vdc resource template MyTemplate
switch(config-vdc-template)#
 

次に、VDC リソース テンプレートを削除する例を示します。

switch# config t
switch(config)# no vdc resource template MyTemplate
 

 
関連コマンド

コマンド
説明

show vdc resource template

VDC ステータス情報を表示します。