Cisco NX-OS Unicast Routing コマンド レファレンス Release 4.0
I コマンド
I コマンド
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

I コマンド

ip(GLBP)

ip(HSRP)

ip arp gratuitous

ip authentication key-chain eigrp

ip as-path access-list

ip authentication mode eigrp

ip bandwidth eigrp

ip bandwidth-percent eigrp

ip community-list

ip delay eigrp

ip distribute-list eigrp

ip eigrp shutdown

ip hello-interval eigrp

ip hold-time eigrp

ip load-sharing address

ip next-hop-self eigrp

ip offset-list eigrp

ip ospf authentication

ip ospf authentication-key

ip ospf cost

ip ospf dead-interval

ip ospf hello-interval

ip ospf message-digest-key

ip ospf mtu-ignore

ip ospf network

ip ospf passive-interface

ip ospf priority

ip ospf retransmit-interval

ip ospf shutdown

ip ospf transmit-delay

ip passive-interface eigrp

ip policy route-map

ip prefix-list

ip prefix-list description

ip rip authentication key-chain

ip rip authentication mode

ip rip metric-offset

ip rip offset-list

ip rip passive-interface

ip rip poison-reverse

ip rip route-filter

ip rip summary-address

ip router ospf area

ip split-horizon eigrp

ip summary-address eigrp

ipv6 address

ipv6 prefix-list

ipv6 prefix-list description

ipv6 rip metric-offset

ipv6 rip offset-list

ipv6 rip passive-interface

ipv6 rip poison-reverse

ipv6 rip route-filter

ipv6 rip summary-address

ipv6 route

is-type

isis authentication key-chain

isis authentication-check

isis authentication-type

isis circuit-type

isis csnp-interval

isis hello padding

isis hello-interval

isis hello-multiplier

isis lsp-interval

isis mesh-group

isis metric

isis passive

isis priority

I コマンド

ここでは、[I] から始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

ip(GLBP)

グループに対して Gateway Load Balancing Protocol(GLBP)をアクティブにするには、 ip コマンドを使用します。グループの GLBP をディセーブルにするには、このコマンドの no 形式を使用します。

ip [ ip-address [ secondary ]]

no ip [ ip-address [ secondary ]]

 
シンタックスの説明

ip-address

(任意)GLBP グループのバーチャル IP。この IP アドレスはインターフェイス IP アドレスと同じサブネット内になければなりません。

secondary

(任意)IP アドレスがセカンダリ GLBP バーチャル アドレスであることを示します。

 
デフォルト

ディセーブル

 
コマンド モード

GLBP コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

設定済みのインターフェイスに対して GLBP をアクティブにするには、 ip コマンドを使用します。バーチャル IP アドレスを設定する場合、そのアドレスは GLBP グループ全体の専用 IP アドレスになります。バーチャル IP アドレスを設定しない場合、ゲートウェイは同じ GLBP グループ内の別のゲートウェイからバーチャル IP アドレスを学習します。GLBP が Active Virtual Gateway(AVG; アクティブ バーチャル ゲートウェイ)を選択できるようにするには、その LAN 上の 1 つ以上のゲートウェイにバーチャル IP アドレスを設定する必要があります。

AVG にバーチャル IP アドレスを設定すると、現在使用されているバーチャル IP アドレスが上書きされます。

インターフェイスに ip コマンドを設定すると、プロキシ Address Resolution Protocol(ARP; アドレス解決プロトコル)要求の処理方法が変更されます(プロキシ ARP がディセーブルに設定されていない場合)。ホストは IP アドレスを MAC アドレスにマッピングするために ARP 要求を送信します。GLBP ゲートウェイは、ARP 要求を代行受信し、接続先ノードの代わりに ARP 要求に応答します。GLBP グループのフォワーダがアクティブである場合、プロキシ ARP 要求への応答には、グループ内の最初のアクティブ フォワーダの MAC アドレスが使用されます。アクティブなフォワーダがない場合、プロキシ ARP 要求は停止されます。


ip コマンドを使用してバーチャル IP アドレスを指定し、GLBP グループをアクティブにする前に、すべての GLBP オプションを設定する必要があります。


このコマンドにはライセンスは必要ありません。

インターフェイス Ethernet 1/1 上のグループ 10 の GLBP をアクティブにする例を示します。GLBP グループ用のバーチャル IP アドレスは、192.0.2.10 に設定されます。

switch(config)# interface ethernet 1/1
switch(config-if)# ip address 192.0.2.32 255.255.255.0
switch(config-if)# glbp 10
switch(config-glbp)# ip 192.0.2.10
 

インターフェイス Ethernet 2/1 上のグループ 10 の GLBP をアクティブにする例を示します。GLBP グループ用のバーチャル IP アドレスは、同じ GLBP グループ内に設定される別のゲートウェイから学習されます。

switch(config)# interface ethernet 2/1
switch(config-if)# glbp 10
switch(config-glbp)# ip

 
関連コマンド

コマンド
説明

glbp

GLBP コンフィギュレーション モードを開始し、GLBP グループを作成します。

show glbp

GLBP の情報を表示します。

ip(HSRP)

HSRP グループにバーチャル アドレスを指定するには、 ip コマンドを使用します。グループの HSRP をディセーブルにするには、このコマンドの no 形式を使用します。

ip [ ip-address [ secondary ]]

no ip [ ip-address [ secondary ]]

 
シンタックスの説明

ip-address

バーチャル ルータのバーチャル IP アドレス(HSRP グループ)。この IP アドレスはインターフェイス IP アドレスと同じサブネット内になければなりません。その HSRP グループ内の 1 つ以上のルータにバーチャル IP アドレスを設定する必要があります。グループ内の他のルータはこのアドレスを選択します。

secondary

(任意)IP アドレスがセカンダリ HSRP バーチャル アドレスであることを示します。

 
デフォルト

ディセーブル

 
コマンド モード

HSRP コンフィギュレーション

サポートされるユーザ ロール

スーパーユーザ
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

設定済みのインターフェイスに対して HSRP をアクティブにするには、 ip コマンドを使用します。バーチャル IP アドレスを設定する場合、そのアドレスは HSRP グループ全体の専用 IP アドレスになります。バーチャル IP アドレスを設定しない場合、ゲートウェイは同じ HSRP グループ内の別のゲートウェイからバーチャル IP アドレスを学習します。HSRP が Active Virtual Gateway(AVG; アクティブ バーチャル ゲートウェイ)を選択できるようにするには、その LAN 上の 1 つ以上のゲートウェイにバーチャル IP アドレスを設定する必要があります。

AVG にバーチャル IP アドレスを設定すると、現在使用されているバーチャル IP アドレスが上書きされます。

インターフェイスに ip コマンドを設定すると、プロキシ Address Resolution Protocol(ARP; アドレス解決プロトコル)要求の処理方法が変更されます(プロキシ ARP がディセーブルに設定されていない場合)。ホストは IP アドレスを MAC アドレスにマッピングするために ARP 要求を送信します。HSRP ゲートウェイは、ARP 要求を代行受信し、接続先ノードの代わりに ARP 要求に応答します。HSRP グループのフォワーダがアクティブである場合、プロキシ ARP 要求への応答には、グループ内の最初のアクティブ フォワーダの MAC アドレスが使用されます。アクティブなフォワーダがない場合、プロキシ ARP 要求は停止されます。


ip コマンドを使用してバーチャル IP アドレスを指定し、HSRP グループをアクティブにする前に、すべての HSRP オプションを設定する必要があります。このようにすれば、グループを初めてイネーブルにする際に設定の作成が遅れても、他のルータに認証エラー メッセージや不測の状態変更が生じるのを避けることができます。常に IP アドレスを指定することを推奨します。


このコマンドにはライセンスは必要ありません。

インターフェイス Ethernet 1/1 上のグループ 10 の HSRP をアクティブにする例を示します。HSRP グループ用のバーチャル IP アドレスは、192.0.2.10 に設定されます。

switch# config t
switch(config)# interface ethernet 1/1
switch(config-if)# ip address 192.0.2.32 255.255.255.0
switch(config-if)# hsrp 10
switch(config-hsrp)# ip 192.0.2.10
 

次の例では、インターフェイス Ethernet 2/1 上のグループ 10 の HSRP をアクティブにします。HSRP グループ用のバーチャル IP アドレスは、同じ HSRP グループ内に設定される別のゲートウェイから学習されます。

switch(config)# interface ethernet 2/1
switch(config-if)# hsrp 10
switch(config-hsrp)# ip
 

次の例では、インターフェイス Ethernet 1/1 でグループ 2 の HSRP をアクティブにし、インターフェイスにセカンダリ IP アドレスを作成する方法を示します。

switch# config t
switch(config)# interface ethernet 1/1
switch(config-if)# ip address 20.20.20.1 255.255.255.0 secondary
switch(config-if)# ip address 10.10.10.1 255.255.255.0
switch(config-if)# hsrp 2
switch(config-if-hsrp)# ip 10.10.10.2
switch(config-if-hsrp)# ip 20.20.20.2 secondary

 
関連コマンド

コマンド
説明

feature hsrp

HSRP コンフィギュレーションをイネーブルにします。

show hsrp

HSRP の情報を表示します。

ip arp gratuitous

gratuitous Address Resolution Protocol(ARP; アドレス解決プロトコル)をイネーブルにするには、 ip arp gratuitous コマンドを使用します。gratuitous ARP をディセーブルにするには、このコマンドの no 形式を使用します。

ip arp gratuitous { request | update }

no ip arp gratuitous { request | update }

 
シンタックスの説明

request

アドレス重複検出時の gratuitous ARP 要求の送信をイネーブルにします。

update

gratuitous ARP 用の ARP キャッシュのアップデートをイネーブルにします。

 
デフォルト

イネーブル

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(3)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにはライセンスは必要ありません。

インターフェイス Ethernet 2/1 上の gratuitous ARP 要求をディセーブルにする例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip arp request

 
関連コマンド

コマンド
説明

ip arp

スタティック ARP エントリを設定します。

ip authentication key-chain eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)パケットの認証をイネーブルにして、インターフェイスで使用可能なキー セットを指定するには、 ip authentication key-chain eigrp コマンドを使用します。認証をディセーブルにするには、このコマンドの no 形式を使用します。

ip authentication key-chain eigrp instance-tag name-of-chain

no ip authentication key-chain eigrp instance-tag name-of-chain

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

name-of-chain

有効なキー グループ

 
デフォルト

EIGRP パケットには認証は適用されません。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイス コンフィギュレーション モードで ip authentication mode eigrp コマンドを使用して、認証モードを設定する必要があります。インターフェイスに対する認証設定を完了するには、 key-chain コマンドを使用して、別途キー チェーンを設定する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

キーチェーン ツリーに属しているキーの受け入れと送信をインターフェイスに設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 1/2
switch(config-if)# ip authentication key-chain eigrp 209 trees

 
関連コマンド

コマンド
説明

ip authentication mode eigrp

インターフェイスに EIGRP の認証モードを設定します。

key-chain

認証方式で使用可能なキー セットを作成します。

ip as-path access-list

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)Autonomous System(AS; 自律システム)番号に対する access-list フィルタを設定するには、 ip as-path access-list を使用します。フィルタを削除するには、このコマンドの no 形式を使用します。

ip as-path access-list name { deny | permit } regexp

no ip as-path access-list name { deny | permit } regexp

 
シンタックスの説明

name

AS パス アクセス リスト名。名前には最大 63 文字の英数字を使用できます。

deny

AS 番号が regexp 引数と一致するパケットを拒否します。

permit

AS 番号が regexp 引数と一致するパケットを許可します。

regexp

BGP AS パスと照合する正規表現。正規表現についての詳細は、次の URL で『 Cisco NX-OS Fundamentals Configuration Guide, Release 4.0 』を参照してください。

http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_0/nx-os/fundamentals/configuration/guide2/fun_nx-os_book.html

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

自律システム パス フィルタを設定するには、 ip as-path access-list コマンドを使用します。着信と発信の両方の BGP パスに自律システム パス フィルタを適用できます。各フィルタは正規表現で定義されます。正規表現が、ルートの自律システム パスの ASCII ストリング表現と一致した場合、許可または拒否の条件が適用されます。自律システム パスにはローカル自律システム番号を含めないでください。

このコマンドにはライセンスは必要ありません。

AS 番号 55:33 および 20:01 を許可する AS パス フィルタを BGP に設定し、着信フィルタリングの BGP ピアにこのフィルタを適用する例を示します。

switch# configure terminal
switch(config)# ip as-path access-list filter1 permit 55:33,20:01
switch(config) router bgp 33:20
switch(config-router)# neighbor 192.0.2.1/16 remote-as 99:20
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# filter-list filter1 in

 
関連コマンド

コマンド
説明

filter-list

BGP ピアに対する AS パス フィルタを指定します。

show ip as-path access-list

IP AS パス アクセス リストに関する情報を表示します。

ip authentication mode eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)パケットに使用される認証タイプを指定するには、 ip authentication mode eigrp コマンドを使用します。認証を削除するには、このコマンドの no 形式を使用します。

ip authentication mode eigrp instance-tag md5

no ip authentication mode eigrp instance-tag md5

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

md5

Message Digest 5(MD5)認証を指定します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスに使用される認証方式を MD5 に設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 1/2
switch(config-if)# ip authentication mode eigrp 209 md5

 
関連コマンド

コマンド
説明

authentication mode(EIGRP)

VRF の EIGRP の認証モードを設定します。

ip authentication key-chain eigrp

EIGRP の認証をイネーブルにして、インターフェイスに使用可能なキー セットを指定します。

key chain

認証方式で使用可能なキー セットを作成します。

ip bandwidth eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスの帯域幅を設定するには、 ip bandwidth eigrp コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

bandwidth eigrp instance-tag bandwidth

no bandwidth eigrp

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

bandwidth

帯域幅値。範囲は 1 ~ 10,000,000 キロビットです。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

自律システム 209 で帯域幅 10000 が使用されるように EIGRP を設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip bandwidth eigrp 209 10000

 
関連コマンド

コマンド
説明

ip bandwidth-percent eigrp

インターフェイスの帯域幅のうち、EIGRP に使用できる割合をパーセントで設定します。

ip bandwidth-percent eigrp

インターフェイス上で Enhanced Interior Gateway Routing Protocol(EIGRP)に使用できる帯域幅のパーセンテージを設定するには、 ip bandwidth eigrp コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

bandwidth-percent eigrp instance-tag percent

no bandwidth-percent eigrp

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

percent

EIGRP に使用できる帯域幅のパーセンテージ

 
デフォルト

percent : 50

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

EIGRP が使用する帯域幅は、リンクの帯域幅の最大 50 %です。このパーセンテージは、 ip bandwidth インターフェイス コンフィギュレーション コマンドで定義されます。このデフォルトのパーセンテージを変更するには、 ip bandwidth-percent コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

自律システム 209 でインターフェイスの帯域幅の最大 75 %を使用するように EIGRP を設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip bandwidth-percent eigrp 209 75

 
関連コマンド

コマンド
説明

ip bandwidth eigrp

インターフェイスの EIGRP 帯域幅値を設定します。

ip community-list

コミュニティ リストのエントリを作成するには、 ip community-list グローバル コンフィギュレーション コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

ip community-list standard list-name {deny | permit} { aa : nn | internet | local-AS | no-advertise | no-export}

no ip community-list standard list-name

ip community-list expanded list-name {deny | permit} regexp

no ip community-list expanded list-name

 
シンタックスの説明

standard list-name

標準コミュニティ リストを設定します。

permit

一致条件のアクセスを許可します。

deny

一致条件のアクセスを拒否します。

aa : nn

(任意)4 バイトの新コミュニティ形式で入力する自律システム番号およびネットワーク番号。2 つの 2 バイトの番号をコロンで区切って設定します。2 バイトの各番号には、1 ~ 65535 の数値を入力できます。単一のコミュニティを入力することも、スペースで区切って複数のコミュニティを入力することもできます。

これらの任意のコミュニティ キーワードを複数選択できます。

internet

(任意)インターネット コミュニティを指定します。このコミュニティのルートは、すべてのピア(内部および外部)にアドバタイズされます。

これらの任意のコミュニティ キーワードを複数選択できます。

no-export

(任意)no-export コミュニティを指定します。このコミュニティのルートは、同じ自律システム内のピアのみ、または同じコンフェデレーション内の他のサブ自律システムのみにアドバタイズされます。これらのルートは外部ピアにはアドバタイズされません。

これらの任意のコミュニティ キーワードを複数選択できます。

local-AS

(任意)local-as コミュニティを指定します。このコミュニティのルートは、ローカル自律システムの一部であるピアまたは同じコンフェデレーションのサブ自律システム内のピアのみにアドバタイズされます。これらのルートは外部ピアにも、コンフェデレーション内の他のサブ自律システムにもアドバタイズされません。

これらの任意のコミュニティ キーワードを複数選択できます。

no-advertise

(任意)no-advertise コミュニティを指定します。このコミュニティのルートは、どのピアにも(内部と外部のいずれも)アドバタイズされません。

これらの任意のコミュニティ キーワードを複数選択できます。

expanded list-name

拡張コミュニティ リストを設定します。

regexp

入力ストリングとの照合パターンの指定に使用される正規表現。正規表現についての詳細は、次の URL で Cisco NX-OS Fundamentals Configuration Guide, Release 4.0 を参照してください。

http://www.cisco.com/en/US/docs/switches/datacenter/sw/4_0/nx-os/fundamentals/configuration/guide2/fun_nx-os_book.html


) 正規表現を使用できるのは拡張コミュニティ リストだけです。


 
デフォルト

コミュニティの交換はデフォルトではイネーブルになりません。

 
コマンド モード

グローバル コンフィギュレーション(config)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

BGP コミュニティ フィルタリングを設定するには、 ip community-list コマンドを使用します。BGP コミュニティ値は 4 バイトの数値で設定されます。先頭の 2 バイトは自律システム番号を表し、末尾の 2 バイトはユーザ定義のネットワーク番号を表します。名前のコミュニティ リストと数値のコミュニティ リストがサポートされています。BGP ピア間での BGP コミュニティ アトリビュートの交換は、指定ネイバーに neighbor send-community コマンドが設定された場合にイネーブルになります。BGP コミュニティ アトリビュートは、RFC 1997 および RFC 1998 に定義されています。

BGP コミュニティの交換はデフォルトではイネーブルになりません。neighbor send-community コマンドを使用して、ネイバー単位でイネーブルに設定されます。このコマンドまたは set community コマンドで他のコミュニティ値が設定されるまで、デフォルトではすべてのルータまたはプレフィクスにインターネット コミュニティが適用されます。

指定のコミュニティ セットと照合するように許可値が設定されている場合、コミュニティ リストはデフォルトで、他のすべてのコミュニティ値に対する暗黙拒否になります。

標準コミュニティ リスト

標準コミュニティ リストは、well-known コミュニティや特定のコミュニティ番号の設定に使用されます。任意のコミュニティ キーワードを複数選択できます。各標準コミュニティ リストには最大 16 のコミュニティを設定できます。16 を超えるコミュニティを設定しようとすると、制限数を超えた後続のコミュニティは処理されないか、または実行コンフィギュレーション ファイルに保存されます。

設定できる最大コミュニティ数は 32 です。

拡張コミュニティ リスト

拡張コミュニティ リストは正規表現によるフィルタ コミュニティに使用されます。正規表現は、コミュニティ アトリビュートの照合パターンの設定に使用されます。* または + の文字を使用した照合の順序は、最長のコンストラクトが最初になります。入れ子式のコンストラクトは外側から内側へ照合されます。連結コンストラクトは左側から照合されます。ある正規表現が、1 つの入力ストリングの異なる 2 つの部分と一致する可能性がある場合、早く入力された部分が最初に一致します。

コミュニティ リストの処理

同じコミュニティ リスト文に複数の値を設定すると、論理 AND 条件が作成されます。AND 条件を満たすためにはすべてのコミュニティ値が一致しなければなりません。別のコミュニティ リスト文に複数の値を設定すると、論理 OR 条件が作成されます。条件に一致する最初のリストが処理されます。

このコマンドにはライセンスは必要ありません。

指定コミュニティのルートがすべてのピア(内部と外部の両方)にアドバタイズされるような標準コミュニティ リストの設定例を示します。

switch(config)# ip community-list standard test1 permit internet
switch(config)#
 

次に、以下の場所からのルートを許容するような標準コミュニティ リストの設定例を示します。

自律システム 65534 のネットワーク 40、および自律システム 65412 のネットワーク 60

同じ自律システム内のピア、または同じコンフェデレーション内のサブ自律システムのピア

この例では、論理 AND 条件が使用されているので、すべてのコミュニティ値が一致しないとリストは処理されません。

switch(config)# ip community-list standard test1 permit 65534:40 65412:60 no-export
switch(config)#
 

次の例では、自律システム 65534 のネットワーク 40 および自律システム 65412 のネットワーク 60 からのコミュニティを持つルートを拒否するような標準コミュニティ リストが設定されます。

switch(config)# ip community-list standard test2 deny 65534:40 65412:60
 

次の例では、ローカル自律システム内のすべてのルート、または自律システム 40000 内のネットワーク 20 からのルートを許可するような名前方式の標準コミュニティ リストが設定されます。

switch(config)# ip community-list standard RED permit local-AS
 
switch(config)# ip community-list standard RED permit 40000:20
switch(config)#
 

次の例では、プライベート自律システムからのコミュニティを持つルートを拒否するような拡張コミュニティ リストが設定されます。

switch(config)# ip community-list expanded 500 deny _64[6-9][0-9][0-9]_|_65[0-9][0-9][0-9]_
switch(config)#
 

次の例では、自律システム 50000 のネットワーク 1 ~ 99 からのルートを拒否するような名前方式の拡張コミュニティ リストが設定されます。

switch(config)# ip community-list list expanded BLUE deny 50000:[0-9][0-9]_
switch(config)#
 

ip delay eigrp

インターフェイスでの Enhanced Interior Gateway Routing Protocol(EIGRP)のスループット遅延を設定するには、 ip delay eigrp コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

ip delay eigrp instance-tag seconds

no ip delay eigrp instance-tag

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

seconds

スループット遅延(10 マイクロ秒)。範囲は 1 ~ 16777215 です。

 
デフォルト

100(10マイクロ秒単位)

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

10 マイクロ秒単位でインターフェイスにスループット遅延を設定します。たとえば、ip delay eigrp コマンドを 100 に設定すると、スループット遅延は 1000 マイクロ秒になります。

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスの遅延を 400 マイクロ秒に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip delay eigrp 1 40

 
関連コマンド

コマンド
説明

ip hello-interval eigrp

自律システム番号で指定される EIGRP ルーティング プロセスに対する インターフェイスの hello 間隔を設定します。

ip distribute-list eigrp

インターフェイスでの Enhanced Interior Gateway Routing Protocol(EIGRP)の配布リストを設定するには、 ip distribute-list eigrp コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

ip distribute-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out }

no ip distribute-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out }

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

prefix-list list-name

EIGRP ルートのフィルタリングに使用する IP プレフィクス リストの名前を指定します。

route-map map-name

EIGRP ルートのフィルタリングに使用するルート マップの名前を指定します。

in

着信ルートにルート ポリシーを適用します。

out

発信ルートにルート ポリシーを適用します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスに対するルート フィルタ ポリシーを設定するには、 ip distribute-list eigrp コマンドを使用します。この設定を完了するためには、ルート マップまたはプレフィクス リストの名前を設定する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスに着信するすべての EIGRP ルートのルート マップを設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip distribute-list eigrp 209 route-map InputFilter in

 
関連コマンド

コマンド
説明

prefix-list

プレフィクス リストを設定します。

route-map

ルート マップを設定します。

ip eigrp shutdown

インターフェイスの Enhanced Interior Gateway Routing Protocol(EIGRP)をシャットダウンするには、 ip eigrp shutdown コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

ip eigrp instance-tag shutdown

no ip eigrp instance-tag shutdown

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスの EIGRP を ディセーブルにする例を示します。

switch(config)# router eigrp 201
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip eigrp 201 shutdown

 
関連コマンド

コマンド
説明

router eigrp

EIGRP のインスタンスを設定します。

ip hello-interval eigrp

インターフェイスの Enhanced Interior Gateway Routing Protocol(EIGRP)hello 間隔を設定するには、 ip hello-interval eigrp コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

ip hello-interval eigrp instance-tag seconds

no ip hello-interval eigrp instance-tag

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

seconds

hello 間隔(秒)。範囲は 1 ~ 65535 です。

 
デフォルト

5 秒

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスの hello 間隔を 10 秒に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip hello-interval eigrp 1 10

ip hold-time eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスのホールド タイムを設定するには、 ip hold-time eigrp コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

ip hold-time eigrp instance-tag seconds

no ip hold-time eigrp instance-tag

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

seconds

ホールド タイム(秒)。範囲は 1 ~ 65535 です。

 
デフォルト

15 秒

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

非常に輻輳した大規模ネットワークでデフォルトのホールド タイムを拡大するには、 ip hold-time eigrp コマンドを使用します。

ホールド タイムは、hello 間隔の 3 倍以上の値に設定することを推奨します。指定のホールド タイム内にルータが hello パケットを受信しないと、このルータを通じたルートは使用できないと判断されます。

ホールド タイムを大きくすると、ネットワーク全体のルート コンバージェンスが遅延します。

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスのホールド タイムを 40 秒に設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip hold-time eigrp 209 40

 
関連コマンド

コマンド
説明

ip hello-interval eigrp

自律システム番号で指定される EIGRP ルーティング プロセスに対する インターフェイスの hello 間隔を設定します。

ip load-sharing address

ユニキャスト RIBで使用される負荷分散型アルゴリズムを設定するには、 ip load-sharing address コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

ip load-sharing address { destination port destination | source-destination [ port source-destination ]} [ universal-id seed ]

no ip load-sharing address { destination port destination | source-destination [ port source-destination ]} [ universal-id seed ]

 
シンタックスの説明

destination port destination

宛先のアドレスおよびポートに基づく負荷分散型アルゴリズムを設定します。

source-destination

送信元と宛先のアドレスに基づく負荷分散型アルゴリズムを設定します。

port source-destination

(任意)送信元と宛先のアドレスおよびポート アドレスに基づく負荷分散型アルゴリズムを設定します。

universal-id seed

(任意)負荷分散型ハッシュ アルゴリズムのシードを設定します。範囲は 1 ~ 4294967295 です。

 
デフォルト

宛先アドレスおよびポート アドレス

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

ユニキャスト RIB による RIB 内の等コスト パスからのパス選択に使用される負荷分散型アルゴリズムを設定するには、 ip load-sharing address コマンドを使用します。

このコマンドにはライセンスは必要ありません。

送信元および宛先のアドレスを使用する負荷分散型アルゴリズムの設定例を示します。

switch(config)# ip load-sharing address source-destination

 
関連コマンド

コマンド
説明

show ip load-sharing

負荷分散型アルゴリズムを表示します。

show routing hash

RIB が選択するパスの送信元/宛先ペアを表示します。

ip next-hop-self eigrp

ルートのアドバタイズ時にネクストホップ アドレスとしてローカル IP アドレスを使用するように Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスに指示するには、 next-hop-self eigrp コマンドを使用します。受信したネクストホップ値を使用するには、このコマンドの no 形式を使用します。

ip next-hop-self eigrp instance-tag

no ip next-hop-self eigrp instance-tag

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

 
デフォルト

EIGRP は常に、IP ネクストホップ値を自身に設定します。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

デフォルトの設定では、EIGRP は、ルータがルートを学習したインターフェイスと同じインターフェイス上でルートをアドバタイズする場合も、アドバタイズするルートの IP ネクストホップ値として自身を設定します。このデフォルト設定を変更するには、 no ip next-hop-self eigrp インターフェイス コンフィギュレーション コマンドを使用して、ルートのアドバタイズ時に受信したネクストホップ値を使用するように EIGRP に指示する必要があります。

デフォルトの IP ネクストホップ値を変更し、受信したネクストホップ値を使用するように EIGRP に指示する例を示します。

RP/0/RP0/CPU0:switch(config)# router eigrp 209
RP/0/RP0/CPU0:switch(config-router)# interface ethernet 2/1
RP/0/RP0/CPU0:switch(config-eigrp-af-if)# no ip next-hop-self eigrp 209

ip offset-list eigrp

インターフェイスでの Enhanced Interior Gateway Routing Protocol(EIGRP)のオフセット リストを設定するには、 ip offset-list eigrp コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

ip offset-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out } offset

no ip offset-list eigrp instance-tag { prefix-list list-name | route-map map-name } { in | out } offset

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

prefix-list list-name

EIGRP ルートのフィルタリングに使用する IP プレフィクス リストの名前を指定します。

route-map map-name

EIGRP ルートのフィルタリングに使用するルート マップの名前を指定します。

in

着信ルートにルート ポリシーを適用します。

out

発信ルートにルート ポリシーを適用します。

offset

EIGRP メトリックに追加する値

 
デフォルト

このコマンドにはデフォルト値はありません。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイス上でアドバタイズするルートを左右するには、 ip offset-list eigrp コマンドを使用します。Cisco NX-OS は、指定のプレフィクス リストまたはルート マップと一致するすべてのルートに、設定されたオフセット値を追加します。この設定を完了するためには、ルート マップまたはプレフィクス リストの名前を設定する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

次の例では、ルート マップ OffsetFilter と一致するインターフェイスに着信する EIGRP ルートのメトリックに 20 を追加するように、オフセット リスト フィルタを設定します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip offset-list eigrp 209 route-map OffsetFilter in 20

 
関連コマンド

コマンド
説明

prefix-list

プレフィクス リストを設定します。

route-map

ルート マップを設定します。

ip ospf authentication

Open Shortest Path First(OSPF)インターフェイスの認証タイプを指定するには、 ip ospf authentication コマンドを使用します。インターフェイスの認証タイプを削除するには、このコマンドの no 形式を使用します。

ip ospf authentication [ key-chain key-name | message-digest | null ]

no ip ospf authentication

 
シンタックスの説明

key-chain key-name

(任意)認証に使用するキー チェーンを指定します。 key-name 引数には、任意の英数字を使用できます。

message-digest

(任意)message-digest 認証を使用するように指定します。

null

(任意)認証が使用されないように指定します。このキーワードを使用すると、そのエリアに設定されている他の認証すべてが変更されます。

 
デフォルト

認証は使用されません。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

OSPF インターフェイスの認証モードを設定するには、 ip ospf authentication コマンドを使用します。キーワードを指定せずにこのコマンドを使用する場合は、 ip ospf authentication-key コマンドでパスワードを設定します。 message-digest キーワードを使用する場合は、 ip ospf message-digest-key コマンドで インターフェイスの message-digest キーを設定します。

インターフェイスに認証を設定すると、そのエリアに設定した認証が変更されます。

このコマンドには、Enterprise Services ライセンスが必要です。

message-digest 認証の設定例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ip ospf authentication message-digest
switch(config-if)# ip ospf message-digest-key 33 md5 0 mypassword

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証をイネーブルにします。

ip ospf authentication-key

OSPF のパスワード認証を使用しているネイバー ルート用のパスワードを指定します。

ip ospf message-digest-key

OSPF MD5 message-digest キーを設定します。

ip ospf authentication-key

ネイバー Open Shortest Path First(OSPF)ルータに使用される簡易パスワード認証用のパスワードを指定するには、 ip ospf authentication-key コマンドを使用します。以前に指定された OSPF パスワードを削除するには、このコマンドの no 形式を使用します。

ip ospf authentication-key [ 0 | 3 ] password

no ip ospf authentication-key

 
シンタックスの説明

0

非暗号化パスワードを設定します。

3

3DES 暗号化パスワード ストリングを設定します。

password

キーボードから入力可能な文字による最大 8 バイトの連続したストリング

 
デフォルト

非暗号化パスワード

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

簡易パスワード認証のパスワードを設定するには、 ip ospf authentication-key コマンドを使用します。このコマンドで作成されたパスワードは、Cisco NX-OS がルーティング プロトコル パケットを開始するときに、OSPF ヘッダーに直接挿入されるキーとして使用されます。インターフェイス単位で各ネットワークに個別のパスワードを指定できます。同じネットワーク上のすべてのネイバー ルータが OSPF 情報を交換できるようにするためには、これらのルータに同じパスワードを設定する必要があります。


) Cisco NX-OS は、ip ospf authentication インターフェイス コンフィギュレーション コマンドでインターフェイスの認証をイネーブルにする場合、またはルータ コンフィギュレーション モードの area authentication コマンドで認証エリアを設定する場合にこのキーを使用します。


このコマンドには、Enterprise Services ライセンスが必要です。

ストリング yourpass を使用して非暗号化認証キーを設定する例を示します。

switch(config-if)# ip ospf authentication-key yourpass

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証タイプを指定します。

ip ospf authentication

インターフェイスの認証タイプを指定します。

ip ospf cost

インターフェイス上のパケット送信コストを指定するには、 ip ospf cost コマンドを使用します。パス コストをデフォルトの設定にリセットするには、このコマンドの no 形式を使用します。

i p ospf cost interface-cost

no ip ospf cost interface-cost

 
シンタックスの説明

interface-cost

link-state メトリックを表す符号なし整数値。範囲は 1 ~ 65535 です。

 
デフォルト

参照帯域幅を、設定されているインターフェイス帯域幅で割る方法でコストを計算します。参照帯域幅を設定するか、または40 Gb/s のデフォルト値にします。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

各インターフェイスのコスト メトリックを手動で設定するには、 ip ospf cost コマンドを使用します。このコマンドによって、ルータ コンフィギュレーション モードの reference-bandwidth コマンドで設定した参照帯域幅の設定値は無効となります。

このコマンドを使用しない場合、リンク コストは次の式で算出されます。

リンク コスト = 参照帯域幅/インターフェイスの帯域幅

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイス コスト値を 65 に設定する例を示します。

switch(config)# interface ethernet 1/2

switch(config-if)# ip ospf cost 65

 
関連コマンド

コマンド
説明

reference-bandwidth

OSPF がリンク コストの算出に使用する参照帯域幅を指定します。

ip ospf dead-interval

ネイバーから少なくとも 1 回 hello パケットを受信する必要のある間隔(この間隔に 1度も受信しないと、ルータはそのネイバーがダウン状態であると宣言します)を設定するには、 ip ospf dead-interval コマンドを使用します。デフォルトにリストアするには、このコマンドの no 形式を使用します。

ip ospf dead-interval seconds

no ip ospf dead-interval

 
シンタックスの説明

seconds

ルータがネイバーから hello パケットを 1 回以上受信しなければならない間隔(秒)。受信しない場合、そのネイバーの隣接関係はローカル ルータから削除され、ルーティングから除外されます。範囲は 1 ~ 65535 です。ネットワーク上のすべてのノードに同じ値を設定する必要があります。

 
デフォルト

seconds のデフォルト値は、 ip ospf hello-interval コマンドで設定された間隔の 4 倍です。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

OSPF が hello パケットでアドバタイズするデッド間隔を設定するには、 ip ospf dead-interval コマンドを使用します。特定のネットワーク上のすべてのネットワーキング デバイスでこの値を同一にする必要があります。

ダウン状態のネイバーを迅速に検出し、コンバージェンスを改善するには、デッド間隔を小さくします。デッド間隔が小さすぎると、ルーティングが不安定になる可能性があります。

デッド間隔と hello 間隔を確認するには、 show ip ospf interface コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

OSPF デッド間隔を 20 秒に設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip ospf dead-interval 20

 
関連コマンド

コマンド
説明

ip ospf hello-interval

OSPF がそのインターフェイスで hello パケットを送信する間隔

show ip ospf interface

OSPF 関連情報を表示します。

ip ospf hello-interval

Open Shortest Path First(OSPF)がそのインターフェイスで hello パケットを送信する間隔を指定するには、 ip ospf hello-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

i p ospf hello-interval seconds

no ip ospf hello-interval

 
シンタックスの説明

seconds

間隔(秒)を指定します。特定のネットワーク上のすべてのノードでこの値を同一にする必要があります。範囲は 1 ~ 65535 です。

 
デフォルト

10 秒

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

OSPF が hello パケットをアドバタイズするレートを設定するには、 ip ospf hello-interval コマンドを使用します。hello 間隔を小さくするほど、OSPF はトポロジの変更を短時間で検出できます。特定のネットワーク上のすべてのルータおよびアクセス サーバでこの値を同一にする必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

hello パケットの間隔を 15 秒に設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip ospf hello-interval 15

 
関連コマンド

コマンド
説明

ip ospf dead-interval

ルータがダウン状態であるとネイバーが宣言するために必要とされる hello パケット非受信期間を設定します。

ip ospf message-digest-key

Open Shortest Path First(OSPF)Message Digest 5(MD5)認証をイネーブルにするには、 ip ospf message-digest-key コマンドを使用します。以前の MD5 キーを削除するには、このコマンドの no 形式を使用します。

ip ospf message-digest-key key-id md5 [0 | 3] key

no ip ospf message-digest-key key-id

 
シンタックスの説明

key-id

1 ~ 255 の範囲の識別子

0

(任意)md5 キーを生成するための非暗号化パスワードを指定します。

3

(任意)md5 キーを生成するための暗号化 3DES パスワードを指定します。

key

最大 16 バイトの英数字パスワード

 
デフォルト

非暗号化

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

MD5 digest 認証モードを設定する場合は ip ospf message-digest-key コマンドを使用します。ネットワーク上のすべてのネイバー ルータで key 値を同一にする必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

キー 19、パスワード 8ry4222 を設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip ospf message-digest-key 19 md5 8ry4222

 
関連コマンド

コマンド
説明

area authentication

OSPF エリアの認証をイネーブルにします。

ip ospf authentication

インターフェイスの認証タイプを指定します。

ip ospf mtu-ignore

受信 Database Descriptor(DBD)パケットに対する Open Shortest Path First(OSPF)最大伝送ユニット(maximum transmission unit; MTU)不一致検出をディセーブルにするには、 ip ospf mtu-ignore コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf mtu-ignore

no ip ospf mtu-ignore

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

OSPF MTU 不一致検出はイネーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスの MTU 不一致検出をディセーブルにするには、 ip ospf mtu-ignore コマンドを使用します。デフォルトでは、OSPF は、共通のインターフェイス上でネイバーが同一の MTU を使用しているかどうかをチェックします。着信インターフェイスに設定されている IP MTU よりも受信 MTU が大きい場合、OSPF は隣接関係を確立しません。このチェックをディセーブルにして、OSPF ネイバー間で MTU 値が異なる場合に隣接関係を許可するには、 ip ospf mtu-ignore コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

受信 DBD パケットに対する MTU 不一致検出をディセーブルにする例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip ospf mtu-ignore

 

ip ospf network

Open Shortest Path First(OSPF)ネットワーク タイプをインターフェイスのデフォルト以外に設定するには、 ip ospf network コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf network { broadcast | point-to-point }

no ip ospf network

 
シンタックスの説明

broadcast

ネットワーク タイプをブロードキャストに設定します。

point-to-point

ネットワーク タイプをポイントツーポイントに設定します。

 
デフォルト

ネットワーク タイプに応じて決まります。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

ネットワーク タイプは OSPF インターフェイスの動作に影響を与えます。OSPF ネットワーク タイプは、通常はブロードキャストであり、OSPF マルチキャスト機能を使用します。このネットワーク タイプでは、代表ルータおよびバックアップ代表ルータが選択されます。ポイントツーポイント ネットワークでは、ネイバーは 2 つだけなので、マルチキャストは必要ありません。インターフェイス上のルータをネイバーにするためには、すべてのルータのネットワークタイプを一致させる必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

OSPF ネットワークをブロードキャスト ネットワークに設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip address 192.0.2.33 255.255.255.0
switch(config-if)# ip ospf network broadcast

 

ip ospf passive-interface

インターフェイスの Open Shortest Path First(OSPF)ルーティング アップデートを停止するには、 ip ospf passive-interface コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf passive-interface

no ip ospf passive-interface

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスが受動インターフェイスに設定されている場合、そのインターフェイスは OSPF プロトコルに参加しません。また、隣接関係を確立せず、ルーティング アップデートも送信しません。ただし、ルーティング ネットワークの一部として通知されます。

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスを受動に設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip ospf passive-interface

ip ospf priority

Open Shortest Path First(OSPF)インターフェイスのルータ プライオリティを設定するには、 ip ospf priority コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf priority number-value

no ip ospf priority number-value

 
シンタックスの説明

number-value

ルータのプライオリティを示す数値。範囲は 0 ~ 255 です。

 
デフォルト

プライオリティ 1

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

ルータ プライオリティの設定には、 ip ospf priority コマンドを使用します。ルータ プライオリティによって、ネットワークの代表ルータが決まります。ネットワークに 2 つのルータが接続されている場合は、両方とも代表ルータになろうとします。ルータ プライオリティ値の高いルータが優先されます。プライオリティ値が同じ場合は、ルータ ID の大きい方が優先されます。ルータ プライオリティがゼロに設定されているルータは代表ルータにも、バックアップ代表ルータにもなれません。

ルータ コンフィギュレーション モードの neighbor を使用して、OSPF をブロードキャスト ネットワークに設定した場合、Cisco NX-OS はこのプライオリティ値を使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

ルータ プライオリティ値を 4 に設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip ospf priority 4

 
関連コマンド

コマンド
説明

ip ospf network

OSPF ネットワーク タイプをそのメディアのデフォルト以外のタイプに設定します。

ip ospf retransmit-interval

インターフェイスに属している隣接ルータに対する Open Shortest Path First(OSPF)リンクステート アドバタイズメント(LSA)の再送間隔を指定するには、 ip ospf retransmit-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf retransmit-interval seconds

no ip ospf retransmit-interval

 
シンタックスの説明

seconds

再送間隔(秒)。接続されているネットワーク上の 2 つのルータ間に予測されるラウンドとリップ遅延時間よりも大きくなければなりません。有効範囲は 1 ~ 65535 秒です。デフォルトは 5 秒です。

 
デフォルト

5 秒

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

LSA 再送間隔を設定するには、 ip ospf retransmit-interval コマンドを使用します。ルータは LSA をネイバーに送信する際に、そのネイバーから確認応答メッセージを受信するまで、その LSA を保持します。ルータが再送間隔内に確認応答を受信しないと、そのローカル ルータは LSA を再送信します。

このコマンドには、Enterprise Services ライセンスが必要です。

再送信のインターバルを 8 秒に設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip ospf retransmit-interval 8

 

ip ospf shutdown

Open Shortest Path First(OSPF)インターフェイスをシャットダウンするには、 ip ospf shutdown コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf shutdown

no ip ospf shutdown

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスの OSPF をシャットダウンするには、 ip ospf shutdown コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスの OSPF をシャットダウンする例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip ospf shutdown

 

ip ospf transmit-delay

インターフェイスで Open Shortest Path First(OSPF)リンクステート アップデート パケットを送信するために必要と予測される時間を設定するには、 ip ospf transmit-delay コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip ospf transmit-delay seconds

no ip ospf transmit-delay

 
シンタックスの説明

seconds

リンクステート アップデートの送信に必要とされる時間(秒)。有効範囲は 1 ~ 450 秒です。

 
デフォルト

1 秒

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

LSA アップデート パケットの送信に必要と予測される時間を設定するには、 ip ospf transmit-delay コマンドを使用します。OSPF は、LSA アップデートを送信する前に遅延時間を送信することによって LSA 経過時間を増分します。この値を設定する際には、インターフェイスの送信遅延や伝搬遅延を考慮する必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

送信遅延値を 8 秒に設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip ospf transmit-delay 8

 

ip passive-interface eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスのすべてのルーティング アップデートを停止するには、 ip passive-interface eigrp コマンドを使用します。ルーティング アップデートの送信を再度イネーブルにするには、このコマンドの no 形式を使用します。

ip passive-interface eigrp instance-tag

no ip passive-interface eigrp instance-tag

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

 
デフォルト

インターフェイス上でルーティング アップデートが送信されます。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスでのルーティング アップデートをすべて停止するには、 ip passive-interface eigrp コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイス Ethernet 2/1 の EIGRP ルーティング アップデートを停止する例を示します。

switch(config)# router eigrp 201
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip passive-interface eigrp 201

ip policy route-map

インターフェイスでのポリシー ルーティングに使用するルート マップを特定するには、 ip policy route-map コマンドを使用します。ルート マップを削除するには、このコマンドの no 形式を使用します。

ip policy route-map name

no ip policy route-map [ name ]

 
シンタックスの説明

name

ルート マップの名前。名前には最大 63 文字の英数字を使用できます。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

ポリシー ルーティングに使用するルート マップを特定するには、 ip policy route-map コマンドを使用します。ルート マップを作成するには、 route-map コマンドを使用します。各 route-map コマンドは、 match リストおよび関連する set コマンドで構成されます。 match コマンドでは、パケットの宛先 IP アドレスに基づいて、一致基準(そのインターフェイスにポリシー ルーティングが許可される条件)を指定します。 set コマンドでは、set 処理( match コマンドによる基準が満たされた場合に実行する特定のポリシー ルーティング処理)を指定します。 no ip policy route-map コマンドは、ルート マップへのポインタを削除します。

match ip address コマンドを使用し、拡張 IP アクセス リストを参照する場合、拡張 IP アクセス リストに定義可能なあらゆる一致基準でポリシーベース ルーティングを実行できます。

ip policy route-map コマンドを使用する前に、 feature pbr コマンドでポリシーベース ルーティングをイネーブルにする必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

インターフェイスにポリシーベース ルート マップを設定する例を示します。

switch# configure terminal
switch(config)# feature pbr
switch(config)# interface ethernet 2/1
switch(config-if)# ip policy route-map policymap

 
関連コマンド

コマンド
説明

feature pbr

ポリシーベース ルーティング機能をイネーブルにします。

route-map

ルート マップを作成します。

show route-map pbr-statistics

ポリシーベース ルート マップについての統計情報を表示します。

ip prefix-list

IP パケットまたはルートを照合するプレフィクス リストを作成するには、ip prefix-list コマンドを使用します。プレフィクス リストを削除するには、このコマンドの no 形式を使用します。

ip prefix-list name [ seq number ] { permit | deny } prefix [ eq length | [ ge length ] [ le length ]]

no prefix-list name [ seq number ] { permit | deny } prefix [ eq length | [ ge length ] [ le length ]]

 
シンタックスの説明

name

IP プレフィクス リストの名前。名前には最大 63 文字の英数字を使用できます。

seq number

(任意)プレフィクス リストのエントリの順序を示すシーケンス番号。範囲は 1 ~ 4294967294 です。

permit

プレフィクス リストと一致するルートまたは IP パケットを許可します。

deny

プレフィクス リストと一致するルートまたは IP パケットを拒否します。

prefix

A.B.C.D/長さの形式の IP プレフィクス

eq length

(任意)照合するプレフィクスの長さ(完全一致)。範囲は 1 ~ 32 です。

ge length

(任意)照合するプレフィクス長の最大値。範囲は 1 ~ 32 です。

le length

(任意)照合するプレフィクス長の最小値。範囲は 1 ~ 32 です。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

IP プレフィクス フィルタリングを設定するには、 ip prefix-list コマンドを使用します。permit または deny のキーワードを指定してプレフィクス リストを設定することにより、一致条件に基づいてプレフィクスを許可または拒否します。プレフィクス リストは、IP アドレスとビット マスクで構成されています。ビット マスクは 1 ~ 32 の数値で入力します。プレフィクス リストのいずれのエントリとも一致しないトラフィックには、暗黙拒否が適用されます。

プレフィクス リストは、完全一致方式で指定のプレフィクス長と照合するように設定することも、またプレフィクスの範囲と照合するように設定することもできます。 ge le のキーワードを使用して照合するプレフィクス長の範囲を指定することにより、network/length 引数だけを指定するよりも柔軟な設定が可能となります。 ge le のいずれのキーワードも設定しない場合、Cisco NX-OS は完全一致方式でプレフィクス リストを処理します。 ge ge-length le l e-length の両方のキーワードと引数を設定した場合、許可されるプレフィクス長の範囲は ge-length 引数と le-length 引数の間になります。この動作は、次の式で表すことができます。

network/length < ge ge-length < le le-length <= 32

シーケンス番号を設定しないと、Cisco NX-OS によって、プレフィクス リスト エントリにデフォルトのシーケンス番号である 5 が適用され、後続のプレフィクス リスト エントリのシーケンス番号は 5 ずつ増分されます(5、10、15 など)。最初のプレフィクス リスト エントリのシーケンス番号を設定し、後続のエントリにシーケンス番号を設定しないと、Cisco NX-OS によって、後続のエントリのシーケンス番号は 5 ずつ増分されます(たとえば、最初に設定したシーケンス番号が 3 の場合、後続のエントリは、8、13、18 のように増分されます)。デフォルトのシーケンス番号の適用を停止するには、seq キーワードを指定して、このコマンドの no 形式を使用します。

Cisco NX-OS は、シーケンス番号が最も小さいエントリからプレフィクス リストの評価を開始し、一致するものが見つかるまで順番に評価していきます。ネットワークに該当するような一致が見つかると、そのネットワークに permit または deny 文が適用され、リストの残りは評価されません。


ヒント 最も処理される頻度の高いプレフィクス リスト文のシーケンス番号を最小にすれば、最良のパフォーマンスを得ることができます。seq number のキーワードと引数はリシーケンスに使用できます。


ネイバー アドレスファミリ モードで prefix-list コマンドを入力すると、特定のピアのインバウンドまたはアウトバウンドのアップデートにプレフィクス リストを適用できます。プレフィクス リストの情報とカウンタは、 show ip prefix-list コマンドの出力に表示されます。prefix-list カウンタをリセットするには、 clear ip prefix-list コマンドを入力します。

このコマンドにはライセンスは必要ありません。

プレフィクス リストを設定し、BGP ピアに適用する例を示します。

switch# config t
switch(config)# ip prefix-list allowprefix 10 permit 192.0.2.0 eq 24
switch(config)# ip prefix-list allowprefix 20 permit 209.165.201.0 eq 27
switch(config) router bgp 33:20
switch(config-router)# neighbor 192.0.2.1/16 remote-as 99:20
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# prefix-list allowprefix in

 
関連コマンド

コマンド
説明

clear ip prefix-list

IP プレフィクス リストのカウンタをクリアします。

prefix-list

BGP ピアにプレフィクス リストを適用します。

show ip prefix-list

IP プレフィクス リストについての情報を表示します。

ip prefix-list description

IP プレフィクス リストを説明する文字列を設定するには、 ip prefix-list description コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

ip prefix-list name description string

no ip prefix-list name description

 
シンタックスの説明

name

プレフィクス リストの名前。名前には最大 63 文字の英数字を使用できます。

string

プレフィクス リストを説明する文字列最大 90 文字の英数字を使用できます。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにはライセンスは必要ありません。

IP プレフィクス リストの説明の設定例を示します。

switch# configure terminal
switch(config)# ip prefix-list test1 description “this is a test”

 
関連コマンド

コマンド
説明

ip prefix-list

IPv6 プレフィクス リストを作成します。

show ip prefix-list

IPv6 プレフィクス リストについての情報を表示します。

ip rip authentication key-chain

Routing Information Protocol(RIP)Version 2 パケットの認証をイネーブルにして、インターフェイスで使用可能なキー セットを指定するには、インターフェイス コンフィギュレーション モードで ip rip authentication key-chain コマンドを使用します。認証をディセーブルにするには、このコマンドの no 形式を使用します。

ip rip authentication key-chain name-of-chain

no ip rip authentication key-chain [ name-of-chain ]

 
シンタックスの説明

name-of-chain

有効なキー グループを指定します。

 
デフォルト

RIP パケットには認証は適用されません。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスに対する認証設定を完了するには、 key-chain コマンドを使用して、別途キー チェーンを設定する必要があります。

このコマンドにはライセンスは必要ありません。

キーチェーン ツリーに属しているキーの受け入れと送信をインターフェイスに設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip rip authentication key-chain trees

 
関連コマンド

コマンド
説明

key-chain

認証方式で使用可能なキー セットを作成します。

ip rip authentication mode

Routing Information Protocol(RIP)Version 2 パケットに使用される認証タイプを指定するには、インターフェイス コンフィギュレーション モードで、 ip rip authentication mode コマンドを使用します。クリア テキスト認証をリストアするには、このコマンドの no 形式を使用します。

ip rip authentication mode { text | md5 }

no ip rip authentication mode

 
シンタックスの説明

text

クリア テキスト認証を指定します。

md5

Message Digest 5(MD5)認証を指定します。

 
デフォルト

キー チェーンを設定した場合、RIP パケットにクリア テキスト認証が適用されます。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

RIPng for IPv6 には、IPv6 に組み込まれた認証が使用されます。

このコマンドにはライセンスは必要ありません。

インターフェイスに使用される認証方式を MD5 に設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip rip authentication mode md5

 
関連コマンド

コマンド
説明

ip rip authentication key-chain

RIP Version 2 パケットの認証をイネーブルにして、インターフェイスに使用可能なキー セットを指定します。

key chain

ルーティング プロトコルの認証をイネーブルにします。

ip rip metric-offset

インターフェイスの着信 IP Routing Information Protocol(RIP)ルート メトリックに追加値を設定するには、インターフェイス コンフィギュレーション モードで ip rip metric-offset コマンドを使用します。メトリックをデフォルト値に戻すには、このコマンドの no 形式を使用します。

ip rip metric-offset value

no ip rip metric-offset

 
シンタックスの説明

value

インターフェイスの着信ルート メトリックに追加する値。範囲は 1 ~ 15 で、デフォルトは 1 です。

 
デフォルト

value : 1

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

ip route metric-offset コマンドは、Cisco NX-OS が使用するルートに影響を与えます。このコマンドを使用すると、1つのインターフェイスのすべての着信ルートのルート メトリックに固定オフセットを追加できます。あるインターフェイスの metric-offset を 5 に設定し、着信ルート メトリックが 5 の場合、Cisco NX-OS はそのルート テーブルにメトリック 10 のルートを追加します。

このコマンドにはライセンスは必要ありません。

インターフェイス Ethernet 2/1 のすべての着信 RIP ルートにメトリック オフセット 10 を設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ip rip metric-offset 10

 
関連コマンド

コマンド
説明

ip rip offset-list

着信 RIP ルート メトリックにオフセット値を追加します。

ip rip offset-list

Routing Information Protocol(RIP)を通じて学習されたルートの着信および発信メトリックにオフセットを追加するには、インターフェイス コンフィギュレーション モードで ip rip offset-list コマンドを使用します。オフセット リストを削除するには、このコマンドの no 形式を使用します。

ip rip offset-list value

no ip rip offset-list

 
シンタックスの説明

value

インターフェイスの着信ルート メトリックに追加する値。範囲は 1 ~ 15 で、デフォルトは 1 です。

 
デフォルト

value : 1

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにはライセンスは必要ありません。

インターフェイス Ethernet 2/1 のすべての着信 RIP ルートにオフセット 10 を設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ip rip offset-list 10

 
関連コマンド

コマンド
説明

ip rip metric-offset

着信 RIP ルート メトリックにオフセット値を追加します。

ip rip passive-interface

インターフェイスでの Routing Information Protocol(RIP)アップデートの送信を停止するには、インターフェイス コンフィギュレーション モードで ip rip passive-interface コマンドを使用します。アップデートの停止を解除するには、このコマンドの no 形式を使用します。

ip rip passive-interface

no ip rip passive-interface

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

インターフェイス上で RIP アップデートが送信されます。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

RIP によって、受動インターフェイス上のマルチキャスト(またはブロードキャスト)アドレスに対するルーティング アップデートの送信は停止されますが、そのインターフェイス上のネイバーからのルーティング アップデートの受信および処理は続行されます。

このコマンドにはライセンスは必要ありません。

インターフェイス Ethernet 1/2 を受動インターフェイスとして設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip rip passive-interface

ip rip poison-reverse

Routing Information Protocol(RIP)ルータ アップデートのポイズン リバースをイネーブルにするには、インターフェイス コンフィギュレーション モードで ip rip poison-reverse コマンドを使用します。RIP アップデートのポイズン リバース処理をディセーブルにするには、このコマンドの no 形式を使用します。

ip rip poison-reverse

no ip rip poison-reverse

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

スプリット ホライズンは常にイネーブルです。ポイズン リバース処理はディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

RIP ルータ アップデートのポイズン リバース処理をイネーブルにするには、 ip rip poison-reverse コマンドを使用します。デフォルトでは、Cisco NX-OS は、RIP ルートを学習したインターフェイスからの RIP ルートのアドバタイズは行いません(スプリット ホライズン)。ポイズン リバースとスプリット ホライズンを両方とも設定した場合、Cisco NX-OS はルートを学習したインターフェイスを通じて、その学習ルートは到達不能であるとアドバタイズします。

このコマンドにはライセンスは必要ありません。

RIPを実行するインターフェイスのポイズン リバース処理をイネーブルにする例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip rip poison-reverse

ip rip route-filter

インターフェイスの着信または発信 Routing Information Protocol(RIP)ルートをフィルタリングするには、インターフェイス コンフィギュレーション モードで route-filter コマンドを使用します。インターフェイスからフィルタリングを削除するには、このコマンドの no 形式を使用します。

ip rip route filter { prefix-list list-name | route-map map-name } { in | out }

 
シンタックスの説明

prefix-list list-name

RIP パケット フィルタリング用のプレフィクス リストを関連付けます。

route-map map-name

RIP の再配布ポリシーを設定するルート マップを関連付けます。

in

着信ルートをフィルタリングします。

out

発信ルートをフィルタリングします。

 
デフォルト

ルート フィルタリングはディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスの着信ルートまたは発信ルートをフィルタリングするには、 ip rip route-filter コマンドを使用します。

このコマンドにはライセンスは必要ありません。

RIP インターフェイスのルート フィルタリングにルート マップを使用する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip rip route-filter route-map InRipFilter in

 
関連コマンド

コマンド
説明

route-map

ルート マップを作成します。

prefix-list

プレフィクス リストを作成します。

 

ip rip summary-address

Routing Information Protocol(RIP)インターフェイスにおけるサマリー集約アドレスを設定するには、インターフェイス コンフィギュレーション モードで ip rip summary-address コマンドを使用します。特定のアドレスまたはサブネットの集約をディセーブルにするには、このコマンドの no 形式を使用します。

ip rip summary-address ip-prefix/mask

no ip rip summary-address ip-prefix/mask

 
シンタックスの説明

ip-prefix/length

集約する IP プレフィクスおよびプレフィクス長

 
デフォルト

デフォルトではディセーブルになります。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

特定のインターフェイスのアドレスまたはサブネットを集約するには、 ip rip summary-address コマンドを使用します。

このコマンドにはライセンスは必要ありません。

次の例では、サマリー アドレス 192.0.2.0 がインターフェイス Ethernet 1/2 からアドバタイズされます。

switch(config)# interface ethernet 1/2
switch(config-if)# ip summary-address rip 192.0.2.0/24
 

ip router ospf area

インターフェイスの Open Shortest Path First(OSPF)インスタンスとエリアを設定するには、 ip router ospf area コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

i p router ospf instance-tag area area-id [secondaries none]

no ip router ospf instance-tag area area-id [secondaries none]

 
シンタックスの説明

instance-tag

インスタンス タグ。英数字で指定します。

area-id

認証をイネーブルにする OSPF エリアの識別子。正の整数値または IP アドレスを指定します。

secondaries none

(任意)セカンダリ IP アドレスを除外します。

 
デフォルト

10 秒

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスのエリアおよび OSPF インスタンスを指定するには、 ip router ospf area コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

hello パケット間のインターバルを 15 秒に設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ip router ospf Base area 33

ip split-horizon eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスのスプリット ホライズンをイネーブルにするには、 ip split-horizon eigrp コマンドを使用します。スプリット ホライズンをディセーブルにするには、このコマンドの no 形式を使用します。

ip split-horizon eigrp instance-tag

no ip split-horizon eigrp instance-tag

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

 
デフォルト

イネーブル

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスのスプリット ホライズンをディセーブルにするには、 no ip split-horizon eigrp コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

イーサネット リンクのスプリット ホライズンをディセーブルにする例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-eigrp-af-if)# no ip split-horizon eigrp 209

ip summary-address eigrp

指定の Enhanced Interior Gateway Routing Protocol(EIGRP)インターフェイスのサマリー集約アドレスを設定するには、 ip summary-address eigrp コマンドを使用します。設定をディセーブルにするには、このコマンドの no 形式を使用します。

ip summary-address eigrp instance-tag { ip-address /length | ip-address mask } [ admin-distance ]

no ip summary-address eigrp instance-tag { ip-address /length | ip-address mask }

 
シンタックスの説明

instance-tag

EIGRP インスタンスの名前。instance-tag には、大文字と小文字を区別して、最大 64 文字の英数字を入力できます。

ip-address/length

インターフェイスに適用するサマリー IP プレフィクスとプレフィクス長(4 分割ドット付き 10 進表記)。たとえば、/8 は、IP プレフィクスの最初の 8 ビットがネットワーク ビットであることを示します。 length を使用する場合、スラッシュが必要です。

ip-address

インターフェイスに適用するサマリー IP アドレス(4 分割ドット付き 10 進表記)。

mask

IP アドレス マスク

admin-distance

(任意)管理ディスタンス。範囲は 1 ~ 255 です。

 
デフォルト

EIGRP サマリー ルートには、管理ディスタンス 5 が適用されます。
事前設定されるサマリー アドレスはありません。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイス レベルのアドレス集約を設定するには、 ip summary-address eigrp コマンドを使用します。EIGRP サマリー ルートの管理ディスタンスは 5 です。

このコマンドには、Enterprise Services ライセンスが必要です。

EIGRP インターフェイスの 192.168.0.0/16 サマリー アドレスに管理ディスタンス 95 を設定する例を示します。

switch(config)# router eigrp 209
switch(config-router)# interface ethernet 2/1
switch(config-if)# ip summary-address eigrp 209 192.168.0.0/16 95

ipv6 address

インターフェイスに IPv6 アドレスを設定するには、 ipv6 address コマンドを使用します。アドレスを削除するには、このコマンドの no 形式を使用します。

ipv6 address { addr [ eui64 ] [ route-preference preference ] [ secondary ] tag tag-id ] | use-link-local-only ]

no ipv6 address { addr [ eui64 ] [ route-preference preference ] [ secondary ] [ tag tag-id ] | use-link-local-only

 
シンタックスの説明

addr

IPv6 アドレス。A:B::C:D/length の形式を使用します。長さの範囲は 1 ~ 128 です。

eui64

(任意)アドレスの下位 64 ビットに Extended Unique Identifier(EUI64)を設定します。

route-preference preference

(任意)ローカル ルートまたは直接ルートのルート プリファレンスを設定します。範囲は 0 ~ 255 です。

secondary

(任意)セカンダリ IPv6 アドレスを作成します。

tag tag-id

(任意)ローカル ルートまたは直接ルートのルート タグ値を設定します。

 
デフォルト

なし

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

4.0(3)

tag キーワードが追加されました。

 
使用上のガイドライン

インターフェイスに IPv6 のアドレスまたはセカンダリ アドレスを設定するには、 ipv6 address コマンドを使用します。

このコマンドにはライセンスは必要ありません。

IPv6 アドレスの設定例を示します。

switch# config t
switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 address 2001:0DB8::3/48

 
関連コマンド

コマンド
説明

ip address

インターフェイスに IPv4 アドレスを設定します。

ipv6 prefix-list

IPv6 パケットまたはルートを照合するプレフィクス リストを作成するには、 ip prefix-list コマンドを使用します。プレフィクス リストを削除するには、このコマンドの no 形式を使用します。

ipv6 prefix-list name [ seq number ] { permit | deny } prefix [ eq length | [ ge length ] [ le length ]]

no ipv6 prefix-list name [ seq number ] { permit | deny } prefix [ eq length | [ ge length ] [ le length ]]

 
シンタックスの説明

name

IPv6 プレフィクス リストの名前。名前には最大 63 文字の英数字を使用できます。

seq number

(任意)プレフィクス リストのエントリの順序を示すシーケンス番号。範囲は 1 ~ 4294967294 です。

permit

プレフィクス リストと一致するルートまたは IP パケットを許可します。

deny

プレフィクス リストと一致するルートまたは IP パケットを拒否します。

prefix

A:B::C:D/length 形式の IP プレフィクス

eq length

(任意)照合するプレフィクスの長さ(完全一致)。範囲は 1 ~ 128 です。

ge length

(任意)照合するプレフィクス長の最大値。範囲は 1 ~ 128 です。

le length

(任意)照合するプレフィクス長の最小値。範囲は 1 ~ 128 です。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

IPv6 プレフィクス フィルタリングを設定するには、 ipv6 prefix-list コマンドを使用します。Permit または deny のキーワードを指定してプレフィクス リストを設定し、一致条件に基づいてプレフィクスを許可または拒否します。プレフィクス リストは、IPv6 アドレスとビット マスクで構成されています。ビット マスクは 1 ~ 128 の数値で入力します。プレフィクス リストのいずれのエントリとも一致しないトラフィックには、暗黙拒否が適用されます。

プレフィクス リストは、完全一致方式で指定のプレフィクス長と照合するように設定することも、またプレフィクス範囲と照合するように設定することもできます。 ge le のキーワードを使用して照合するプレフィクス長の範囲を指定することにより、network/length 引数だけを指定するよりも柔軟な設定が可能となります。 ge le のいずれのキーワードも設定しない場合、Cisco NX-OS は完全一致方式でプレフィクス リストを処理します。 ge ge-length le le-length の両方のキーワードと引数を設定した場合、許可されるプレフィクス長の範囲は ge-length 引数と le-length 引数の間になります。この動作は、次の式で表すことができます。

network/length < ge ge-length < le le-length <= 32

シーケンス番号を設定しないと、Cisco NX-OS によって、プレフィクス リスト エントリにデフォルトのシーケンス番号である 5 が適用され、後続のプレフィクス リスト エントリのシーケンス番号は 5 ずつ増分されます(5、10、15 など)。最初のプレフィクス リスト エントリのシーケンス番号を設定し、後続のエントリにシーケンス番号を設定しないと、Cisco NX-OS によって、後続のエントリのシーケンス番号は 5 ずつ増分されます(たとえば、最初に設定したシーケンス番号が 3 の場合、後続のエントリは、8、13、18 のように増分されます)。デフォルトのシーケンス番号の適用を停止するには、seq キーワードを指定して、このコマンドの no 形式を使用します。

Cisco NX-OS は、シーケンス番号が最も小さいエントリからプレフィクス リストの評価を開始し、一致するものが見つかるまで順番に評価していきます。ネットワークに該当するような一致が見つかると、そのネットワークに permit または deny 文が適用され、リストの残りは評価されません。


ヒント 最も処理される頻度の高いプレフィクス リスト文のシーケンス番号を最小にすれば、最良のパフォーマンスを得ることができます。seq number のキーワードと引数はリシーケンスに使用できます。


ネイバー アドレスファミリ モードで prefix-list コマンドを入力すると、特定のピアのインバウンドまたはアウトバウンドのアップデートにプレフィクス リストを適用できます。プレフィクス リストの情報とカウンタは、 show ipv6 prefix-list コマンドの出力に表示されます。prefix-list カウンタをリセットするには、 clear ipv6 prefix-list コマンドを入力します。

このコマンドにはライセンスは必要ありません。

IPv6 プレフィクス リストを設定し、BGP ピアに適用する例を示します。

switch# config t
switch(config)# ipv6 prefix-list allowprefix 10 permit 2001:0DB8::/48 eq 24
switch(config) router bgp 33:20
switch(config-router)# neighbor 2001:0DB8::1/64 remote-as 99:20
switch(config-router-neighbor)# address-family ipv6 unicast
switch(config-router-neighbor-af)# prefix-list allowprefix in

 
関連コマンド

コマンド
説明

clear ip prefix-list

IP プレフィクス リストのカウンタをクリアします。

prefix-list

BGP ピアにプレフィクス リストを適用します。

show ip prefix-list

IP プレフィクス リストについての情報を表示します。

ipv6 prefix-list description

IPv6 プレフィクス リストを説明する文字列を設定するには、 ipv6 prefix-list description コマンドを使用します。デフォルトの設定に戻すには、このコマンドの no 形式を使用します。

ipv6 prefix-list name description string

no ipv6 prefix-list name description

 
シンタックスの説明

name

プレフィクス リストの名前。名前には最大 63 文字の英数字を使用できます。

string

プレフィクス リストを説明する文字列。最大 90 文字の英数字を使用できます。

 
デフォルト

なし

 
コマンド モード

グローバル コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにはライセンスは必要ありません。

IPv6 プレフィクス リストの説明の設定例を示します。

switch# configure terminal
switch(config)# ipv6 prefix-list test1 description “this is a test”

 
関連コマンド

コマンド
説明

ipv6 prefix-list

IPv6 プレフィクス リストを作成します。

show ipv6 prefix-list

IPv6 プレフィクス リストについての情報を表示します。

ipv6 rip metric-offset

インターフェイスの着信 IP Routing Information Protocol(RIP)ルート メトリックに追加値を設定するには、インターフェイス コンフィギュレーション モードで ipv6 rip metric-offset コマンドを使用します。メトリックをデフォルト値に戻すには、このコマンドの no 形式を使用します。

ipv6 rip metric-offset value

no ipv6 rip metric-offset

 
シンタックスの説明

value

インターフェイスの着信ルート メトリックに追加する値。範囲は 1 ~ 15 で、デフォルトは 1 です。

 
デフォルト

value : 1

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

ipv6 route metric-offset コマンドは、Cisco NX-OS が使用するルートに影響を与えます。このコマンドを使用すると、1つのインターフェイスのすべての着信ルートのルート メトリックに固定オフセットを追加できます。あるインターフェイスの metric-offset を 5 に設定し、着信ルート メトリックが 5 の場合、Cisco NX-OS はそのルート テーブルにメトリック 10 のルートを追加します。

このコマンドにはライセンスは必要ありません。

インターフェイス Ethernet 2/1 のすべての着信 RIP ルートにメトリック オフセット 10 を設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 rip metric-offset 10

 
関連コマンド

コマンド
説明

ipv6 rip offset-list

着信 RIP ルート メトリックにオフセット値を追加します。

ipv6 rip offset-list

Routing Information Protocol(RIP)を通じて学習されたルートの着信および発信メトリックにオフセットを追加するには、インターフェイス コンフィギュレーション モードで ipv6 rip offset-list コマンドを使用します。オフセット リストを削除するには、このコマンドの no 形式を使用します。

ipv6 rip offset-list value

no ipv6 rip offset-list

 
シンタックスの説明

value

インターフェイスの着信ルート メトリックに追加する値。範囲は 1 ~ 15 で、デフォルトは 1 です。

 
デフォルト

value : 1

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにはライセンスは必要ありません。

インターフェイス Ethernet 2/1 のすべての着信 RIP ルートにオフセット 10 を設定する例を示します。

switch(config)# interface ethernet 2/1
switch(config-if)# ipv6 rip offset-list 10

 
関連コマンド

コマンド
説明

ipv6 rip metric-offset

着信 RIP ルート メトリックにオフセット値を追加します。

ipv6 rip passive-interface

インターフェイスでの Routing Information Protocol(RIP)アップデートの送信を停止するには、インターフェイス コンフィギュレーション モードで ipv6 rip passive-interface コマンドを使用します。アップデートの停止を解除するには、このコマンドの no 形式を使用します。

ipv6 rip passive-interface

no ipv6 rip passive-interface

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

インターフェイス上で RIP アップデートが送信されます。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

RIP によって、受動インターフェイス上のマルチキャスト(またはブロードキャスト)アドレスに対するルーティング アップデートの送信は停止されますが、そのインターフェイス上のネイバーからのルーティング アップデートの受信および処理は続行されます。

このコマンドにはライセンスは必要ありません。

インターフェイス Ethernet 1/2 を受動インターフェイスとして設定する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ipv6 rip passive-interface

ipv6 rip poison-reverse

Routing Information Protocol(RIP)ルータ アップデートのポイズン リバース処理をイネーブルにするには、インターフェイス コンフィギュレーション モードで ipv6 rip poison-reverse コマンドを使用します。RIP アップデートのポイズン リバース処理をディセーブルにするには、このコマンドの no 形式を使用します。

ipv6 rip poison-reverse

no ipv6 rip poison-reverse

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

スプリット ホライズンは常にイネーブルです。ポイズン リバース処理はディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

RIP ルータ アップデートのポイズン リバース処理をイネーブルにするには、 ip v6rip poison-reverse コマンドを使用します。デフォルトでは、Cisco NX-OS は、RIP ルートを学習したインターフェイスからの RIP ルートのアドバタイズは行いません(スプリット ホライズン)。ポイズン リバースとスプリット ホライズンを両方とも設定した場合、Cisco NX-OS はルートを学習したインターフェイスを通じて、その学習ルートは到達不能であるとアドバタイズします。

このコマンドにはライセンスは必要ありません。

RIPを実行するインターフェイスのポイズン リバース処理をイネーブルにする例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ipv6 rip poison-reverse

ipv6 rip route-filter

インターフェイスの着信または発信 Routing Information Protocol(RIP)ルートをフィルタリングするには、インターフェイス コンフィギュレーション モードで ipv6 rip route-filter コマンドを使用します。インターフェイスからフィルタリングを削除するには、このコマンドの no 形式を使用します。

ipv6 rip route filter { prefix-list list-name | route-map map-name } { in | out }

 
シンタックスの説明

prefix-list list-name

RIP パケット フィルタリング用のプレフィクス リストを関連付けます。

route-map map-name

RIP の再配布ポリシーを設定するルート マップを関連付けます。

in

着信ルートをフィルタリングします。

out

発信ルートをフィルタリングします。

 
デフォルト

ルート フィルタリングはディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

インターフェイスの着信ルートまたは発信ルートをフィルタリングするには、 ipv6 rip route-filter コマンドを使用します。

このコマンドにはライセンスは必要ありません。

RIP インターフェイスのルート フィルタリングにルート マップを使用する例を示します。

switch(config)# interface ethernet 1/2
switch(config-if)# ipv6 rip route-filter route-map InRipFilter in

 
関連コマンド

コマンド
説明

route-map

ルート マップを作成します。

prefix-list

プレフィクス リストを作成します。

 

ipv6 rip summary-address

Routing Information Protocol(RIP)インターフェイスにおけるサマリー集約アドレスを設定するには、インターフェイス コンフィギュレーション モードで ipv6 rip summary-address コマンドを使用します。特定のアドレスまたはサブネットの集約をディセーブルにするには、このコマンドの no 形式を使用します。

ipv6 rip summary-address ipv6-prefix/length

no ipv6 rip summary-address ipv6-prefix/length

 
シンタックスの説明

iv6p-prefix/length

集約する IPv6 プレフィクスおよびプレフィクス長

 
デフォルト

デフォルトではディセーブルになります。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

特定のインターフェイスにおけるアドレスまたはサブネットを集約するには、 ipv6 rip summary-address コマンドを使用します。

このコマンドにはライセンスは必要ありません。

次の例では、サマリー アドレス 2001:0DB8::/48 がインターフェイス Ethernet 1/2 からアドバタイズされます。

switch(config)# interface ethernet 1/2
switch(config-if)# ipv6 summary-address rip 2001:0DB8::/48
 

ipv6 route

スタティック IPv6 ルートを設定するには、 ipv6 route コマンドを使用します。スタティック ルートを削除するには、このコマンドの no 形式を使用します。

ipv6 route ipv6-prefix/length {{ next-hop-addr | next-hop-prefix } | interface-type number | link-local-addr { interface-type number ] [ route-preference ] [ tag tag-id ]

no ipv6 route ipv6-prefix/length

 
シンタックスの説明

iv6p-prefix/length

集約する IPv6 プレフィクスおよびプレフィクス長

 
デフォルト

デフォルトではディセーブルになります。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

特定のインターフェイスにおけるアドレスまたはサブネットを集約するには、 ipv6 rip summary-
address
コマンドを使用します。

このコマンドにはライセンスは必要ありません。

次の例では、サマリー アドレス 2001:0DB8::/48 がインターフェイス Ethernet 1/2 からアドバタイズされます。

switch(config)# interface ethernet 1/2
switch(config-if)# ipv6 summary-address rip 2001:0DB8::/48
 

is-type

Intermediate System-to-Intermediate System(IS-IS)ルーティング プロセスのインスタンスにルーティング レベルを設定するには、 is-type コンフィギュレーション モード コマンドを使用します。デフォルト値にリセットするには、このコマンドの no 形式を使用します。

is-type {level-1 | level-1-2 | level-2}

no is-type {level-1 | level-1-2 | level-2}

 
シンタックスの説明

level-1

ルータが level-1(エリア内)ルーティングのみを実行するように指定します。

level-1-2

ルータが level-1 と level-2 のルーティングを両方実行するように指定します。

level-2

ルーティング プロセスが level-2(エリア間)ルータのみとして機能するように指定します。

 
コマンドのデフォルト設定

通常、ルータはデフォルトの設定で level-1(エリア内)および level-2(エリア間)のルータとして機能します。マルチエリア IS-IS 設定では、設定されている IS-IS ルーティング プロセスの最初のインスタンスはデフォルトで level-1-2(エリア内およびエリア間)ルータになります。設定されている IS-IS プロセスの残りのインスタンスはデフォルトで level-1 ルータになります。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

IS-IS ルーティング プロセスのルーティング レベルは次のように定義されています。

level-1 ― ルータが level-1(エリア内)ルーティングのみを実行するように指定します。このルータが学習するのはそのエリア内の宛先だけです。level-2(エリア間)ルーティングは、最も近い level-1-2 ルータで実行されます。

level-1-2 ― ルータが level-1 と level-2 のルーティングを両方実行するように指定します。このルータは、ルーティング プロセスのインスタンスを 2 つ実行します。このルータにはエリア内の宛先に関する Link-State Packet Database(LSDB)があり、最短パス優先(SPF)計算によってエリア トポロジが検出されます。このルータには、その他すべてのバックボーン(level-2)ルータの Link-State Packet(LSP; リンクステート パケット)が保存された別の LSDB もあり、別の SPF 計算によって、バックボーンのトポロジやその他すべてのエリアに存在するものが検出されます。

level-2 ― ルーティング プロセスが level-2 (エリア間)ルータのみとして機能するように指定します。このルータはバックボーンの一部であり、そのエリア内の level-1 専用ルータとは通信しません。

IS-IS ルーティング プロセスのタイプを設定することを推奨します。マルチエリア IS-IS を設定している場合は、ルータのタイプを設定するか、またはデフォルト設定のままにしておく必要があります。デフォルトでは、router isis コマンドで設定した IS-IS ルーティング プロセスの最初のインスタンスは、level-1-2 ルータになります。

ネットワークにエリアが 1 つだけしかない場合は、必ずしも level-1 と level-2 の両方のルーティング アルゴリズムを実行する必要はありません。IS-IS が IP ルーティングのみに使用され、エリアが 1 つしかない場合は、常に level-2 だけを実行できます。すでに level-1-2 エリアがある場合、その後追加されたエリアは、デフォルトで level-1 エリアになります。

ルータ インスタンスが level-1-2(シスコ製デバイスにおける IS-IS ルーティング プロセスの最初のインスタンスのデフォルト)に設定されている場合、is-type コマンドを使用して、そのエリアの level-2(エリア間)ルーティングを削除できます。is-type コマンドを使用してエリアに level-2 ルーティングを設定できるのは、シスコ製デバイスで level-2 に設定されている唯一の IS-IS ルーティング プロセス インスタンスの場合だけです。

エリア ルータの指定例を示します。

switch(config)# router isis
switch(config-router)# is-type level-2-only

 
関連コマンド

コマンド
説明

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータの IS-IS をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

isis authentication key-chain

個々の Intermediate System-to-Intermediate System(IS-IS)インターフェイスに関して、IS-IS の認証をイネーブルにするには、 isis authentication key-chain インターフェイス コンフィギュレーション モード コマンドを使用します。認証をディセーブルにするには、このコマンドの no 形式を使用します。

isis authentication key-chain auth-key {level-1 | level-2}

no isis authentication key-chain auth-key {level-1 | level-2}

 
シンタックスの説明

auth-key

認証キー チェーン

level-1

level-1 の Link State Packets(LSP; リンクステート パケット)、Complete Sequence Number Packet(CSNP)、および Partial Sequence Number Packet(PSNP)のみに認証キーを指定します。

level-2

level-2 の LSP、CSNP、および PSNP パケットのみに認証キーを指定します。

 
コマンドのデフォルト設定

ルータ レベルでは、IS-IS パケットにキー チェーン認証は適用されません。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

isis authentication key-chain コマンドでキー チェーンを設定しないと、キー チェーン認証は実行されません。

キー チェーン認証は、クリア テキスト認証または MD5 認証に適用できます。モードは authentication mode コマンドで設定されます。

IS-IS に一度に適用できる認証キー チェーンは 1 つだけです。2 つめの isis authentication key-chain コマンドを設定すると、最初の認証キー チェーンは無効になります。

authentication key-chain コンフィギュレーション コマンドを使用すると、IS-IS インスタンスごとにキー チェーン認証を設定できます。

次の例では、特定のインターフェイスに対して、site1 という名前のキー チェーンに属しているすべてのキーの受け入れと送信を実行するように IS-IS が設定されます。

switch(config)# router isis test1
switch(config-router)# interface ethernet 2/5
switch(config-if)# isis authentication key-chain site1 level-1
switch(config-if)#

 
関連コマンド

コマンド
説明

authentication key-chain

IS-IS インスタンス単位で認証をイネーブルにします。

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータの IS-IS をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

isis authentication-check

特定のインターフェイスから送信される Intermediate System-to-Intermediate System(IS-IS)パケットのみ(受信パケットは含まれない)に対して認証が実行されるように IS-IS インスタンスを指定するには、 isis authentication-check インターフェイス コンフィギュレーション モード コマンドを使用します。ルータ レベルで認証が設定されている場合に、その認証が送信と受信のパケットに実行されるように IS-IS インスタンスを設定するには、このコマンドの no 形式を使用します。

authentication-check {level-1 | level-2}

no authentication-check

 
シンタックスの説明

level-1

level-1 の送信パケットのみ(受信パケットは含まれない)に認証が実行されるように指定します。

level-2

level-2 の送信パケットのみ(受信パケットは含まれない)に認証が実行されるように指定します。

 
コマンドのデフォルト設定

認証がルータ レベルで設定されている場合、その認証が送信と受信の IS-IS パケットに適用されます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
使用上のガイドライン

isis authentication-check コマンドは、認証モードと認証キー チェーンを設定する前に入力してください。 isis authentication-check コマンドを入力すると、送信パケットのみに認証が挿入され、受信パケットはチェックされないため、各ルータに許容されるキー設定時間が長くなります。通信しているすべてのルータに authentication-check コマンドを入力してから、各ルータに対する認証モードとキー チェーンをイネーブルにします。その後、このコマンドをディセーブルにする場合は、 no isis authentication -check コマンドを入力します。

このコマンドは、クリア テキスト認証または Message Digest 5(MD5)認証に適用できます。モードは authentication mode コマンドで設定されます。

authentication-check コンフィギュレーション モード コマンドを使用すると、ISIS インスタンスごとに認証チェックを指定できます。

送信パケットに(受信パケットは含まれない)クリア テキスト認証を使用するように、特定インターフェイス上の IS-IS level-1 パケットを設定する例を示します。

switch(config)# router isis test1
switch(config-router)# interface ethernet 2/5
switch(config-if)# isis authentication-check level-1
switch(config-if)# isis authentication key-chain site1 level-1
switch(config-if)#

 
関連コマンド

コマンド
説明

authentication-check

送信される IS-IS パケットのみ(受信パケットは含まれない)に認証が実行されるように指定します。

feature isis

ルータの IS-IS をイネーブルにします。

router isis

IS-IS をイネーブルにします。

isis authentication-type

特定のインターフェイス上の Intermediate System-to-Intermediate System(IS-IS)パケットに使用される認証タイプを指定するには、 isis authentication-type インターフェイス コンフィギュレーション モード コマンドを使用します。クリア テキスト認証をリストアするには、このコマンドの no 形式を使用します。

isis authentication-type { cleartext | md5 } [level-1 | level-2]

no isis authentication-type

 
シンタックスの説明

cleartext

クリア テキスト認証を指定します。

md5

Message Digest 5(MD5)認証を指定します。

level-1

level-1 の Link State Packets(LSP; リンクステート パケット)、Complete Sequence Number Packet(CSNP)、および Partial Sequence Number Packet(PSNP)パケットのみに対して、指定された認証をイネーブルにします。

level-2

level-2 の LSP、CSNP、および PSNP パケットのみに対して、指定された認証をイネーブルにします。

 
コマンドのデフォルト設定

このコマンドを使用しても、ルータ レベルでは、IS-IS パケットに認証は適用されません。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

level-1 level-2 のいずれのキーワードも入力しないと、そのモードが両方のレベルに適用されます。

authentication-type コンフィギュレーション モード コマンドを使用すると、IS-IS インスタンスごとに認証タイプを設定できます。

特定のインターフェイス上の level-1 パケットにMessage Digest 5(MD5)認証が実行されるように、IS-IS インスタンスを設定する例を示します。

switch(config)# router isis test1
switch(config-router)# interface ethernet 2/5
switch(config-if)# isis authentication-type md5 level-1
switch(config-router)#

 
関連コマンド

コマンド
説明

authentication-type

IS-IS インスタンス単位で認証タイプを指定します。

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータの IS-IS をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

isis circuit-type

隣接のタイプを設定するには、インターフェイス コンフィギュレーション モードで isis circuit-type コマンドを使用します。インターフェイスの認証タイプを削除するには、このコマンドの no 形式を使用します。

isis circuit-type {level-1 | level-1-2 | level-2-only}

no isis circuit-type

 
シンタックスの説明

level-1

level-1 隣接のみのルータを設定します。

level-1-2

level-1 および level-2 隣接のルータを設定します。

level-2-only

level-2 隣接のみのルータを設定します。

 
コマンドのデフォルト設定

level-1 および level-2 隣接が確立されます。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドの設定は必須ではありません。level-1-only、level 1-2、または level 2-only のシステムとしてルータを設定することを推奨します。使用されない level-1 hello パケットの送出による帯域幅の浪費を避けるために一部のインターフェイスを level-2-only に設定するのは、エリア間ルータ(level 1-2 ルータ)だけにしてください。ポイントツーポイント インターフェイスでは、level-1 と level-2 の hello は同じパケットである点に留意してください。

level 1 隣接を確立できるのは、このシステムとそのネイバーの間に共通のエリア アドレスが 1 つ以上ある場合です。このインターフェイス上では、level-2 隣接は確立されません。

Level-1 と level-2 の隣接が確立されるのは、ネイバーも level-1-2 として設定され、共通のエリアが 1 つ以上ある場合です。共通のエリアがない場合は、level-2 隣接が確立されます。これがデフォルトです。

Level-2 隣接が確立されるのは、他のルータが level 2 ルータまたは level 1-2 ルータで、それらのインターフェイスが level-1-2 または level-2 用に設定されている場合です。このインターフェイスでは level-1 隣接は確立されません。

次の例では、イーサネット インターフェイス 2/5 上の他のルータが同じエリアにあり、イーサネット インターフェイス 1 上の他のルータは別のエリアにあるので、ルータは level-1 hello の送信を停止します。

switch(config)# router isis test1
switch(config-router)# interface ethernet 2/5
switch(config-if)# isis circuit-type level-2-only
switch(config-if)#

isis csnp-interval

Intermediate System-to-Intermediate System(IS-IS)Complete Sequence Number(CSNP)間隔を設定するには、インターフェイス コンフィギュレーション モードで isis csnp-interval コマンドを使用します。デフォルト値にリストアするには、このコマンドの no 形式を使用します。

isis csnp-interval seconds { level-1 | level-2 }

no isis csnp-interval [ level-1 | level-2 ]

 
シンタックスの説明

seconds

マルチアクセス ネットワークにおける CSNP の送信間隔(秒)。この間隔は代表ルータだけに適用されます。範囲:0 ~ 65535。デフォルト: 10

level-1

level-1 CSNP 専用の送信間隔を設定します。

level-2

level-2 CSNP 専用の送信間隔を設定します。

 
コマンドのデフォルト設定

デフォルトの設定値は次のとおりです。

10 秒

level 1 および level 2

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

通常は、このコマンドのデフォルト値を変更する必要はありません。

このコマンドは、代表ルータまたは指定インターフェイスのみに適用されます。データベースの同期を維持するため、代表ルータのみが CSNP パケットを送信します。CSNP 間隔は Level-1 と level-2 のそれぞれに設定できます。

ポイントツーポイント サブインターフェイスに対して isis csnp-interval コマンドを使用する場合は、IS-IS mesh-group 機能も使用する必要があります。

30 秒ごとに CSNP を送信するようにインターフェイス Ethernet 2/5 を設定する例を示します。

switch(config)# router isis test1
switch(config-router)# interface ethernet 2/5
switch(config-if)# isis csnp-interval 30 level-1
switch(config-if)#

 
関連コマンド

show isis interface

IS-IS 情報を表示します。

isis hello padding

インターフェイス レベルで Intermediate System-to-Intermediate System(IS-IS)hello パディングを再度イネーブルにするには、インターフェイス コンフィギュレーション モードで isis hello padding コマンドを入力します。 IS-IS hello パディングをディセーブルにするには、このコマンドの no 形式を使用します。

isis hello padding

no isis hello padding

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
コマンドのデフォルト設定

IS-IS hello パディングはイネーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

IS-IS hello は最大伝送ユニット(maximum transmission unit; MTU)にフル サイズまで埋め込まれます。IS-IS hello をフル MTU に埋め込む利点は、大きなフレームに関連した送信問題によるエラーや隣接インターフェイスの MTU 不一致によるエラーを検出できることです。

両方のインターフェイスの MTU が同じである場合やトランスレーショナル ブリッジングの場合には、ネットワーク帯域幅の無駄を省くため、hello パディングをディセーブルにできます。hello パディングがディセーブルになっても、シスコ製ルータは、MTU 不一致検出の利点を維持するため、最初の 5 回の IS-IS hello をフルサイズの MTU に埋め込みます。

特定のインターフェイスの hello パディングを選択的にディセーブルにするには、インターフェイス コンフィギュレーション モードで no isis hello padding コマンドを入力します。IS-IS ルーティング プロセスに関して、ルータ上のすべてのインターフェイスの hello パディングをディセーブルにするには、ルータ コンフィギュレーション モードで no hello padding コマンドを入力します。

インターフェイス Ethernet 0/0 に関して、インターフェイス レベルの hello パディングをオフにするには、次のように、インターフェイス コンフィギュレーション モードで no isis hello padding コマンドを入力します。

switch(config)# router isis test1
switch(config-router)# interface ethernet 0/0
switch(config-if)# no isis hello padding
switch(config-if)#

 
関連コマンド

コマンド
説明

hello padding

ルータ レベルの IS-IS hello パディングを再度イネーブルにします。

isis hello-interval

Cisco NX-OS ソフトウェアが送信する hello パケットの間隔を指定するには、インターフェイス コンフィギュレーション モードで isis hello-interval コマンドを使用します。デフォルト値にリストアするには、このコマンドの no 形式を使用します。

isis hello-interval seconds { level-1 | level-2 }

no isis hello-interval { level-1 | level-2 }

 
シンタックスの説明

seconds

hello パケットの間隔(秒)。デフォルトでは、送信される hello パケットで、hello 間隔の seconds の 3 倍の値がホールド タイムとしてアドバタイズされます(乗数 3 を変更するには、 isis hello-multiplier コマンドで指定します)。hello 間隔を小さくすると、トポロジの変更は迅速に検出されますが、ルーティング トラフィックが増大します。範囲:0 ~ 65535。デフォルト: 10


) Designated Intermediate System(DIS)インターフェイスでは、設定値の 3 分の 1 だけしか使用されません。設定された hello 間隔の全体値が使用されるのは、DIS 以外のインターフェイスだけです。


level-1

level 1 独自の hello 間隔を設定します。X.25、Switched Multimegabit Data Service(SMDS)、フレーム リレー マルチアクセス ネットワークでは、これを使用します。

level-2

level 2 独自の hello 間隔を設定します。X.25、SMDS、フレーム リレー マルチアクセス ネットワークでは、これを使用します。

 
コマンドのデフォルト設定

デフォルトの設定値は次のとおりです。

10 秒

level 1 および level 2

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

ホールド タイムは、hello 間隔× hello 乗数になります。

level- と level-2 のそれぞれに hello 間隔を設定できます。LAN インターフェイスには、 level-1 および level-2 のキーワードが使用されます。

hello 間隔を短くすると、コンバージェンスが迅速に実行されますが、帯域幅と CPU 利用率が増大します。また、ネットワークが不安定になることもあります。hello 間隔を大きくすると、帯域幅と CPU 利用率を節約できます。特に、hello 間隔を大きくしたうえに、hello 乗数も大きくすると、ネットワーク全体の安定性が増します。DIS インターフェイスに hello 間隔を設定する場合、インターバル値の 3 分の 1 だけしか使用されません。したがって、DIS インターフェイスのホールド タイム(hello 間隔× hello 乗数)も、DIS 以外のインターフェイスの 3 分の 1 になります。

ポイントツーポイントインターフェイスの場合は、LAN インターフェイスの場合よりも hello 間隔と hello 乗数による調整効果があります。

次の例では、5 秒ごとに hello パケットをアドバタイズするようにインターフェイス Ethernet 2/3 を設定します。ルータはステーション ルータとして動作するように設定されています。この設定では、インターバルを大きい値に設定した場合よりも生成されるトラフィック量は多くなりますが、トポロジの変更は短時間で検出されます。

switch(config)# router isis test1
switch(config-router)# interface ethernet 2/3
switch(config-if)# isis hello-interval 5 level-1
switch(config-if)#

 
関連コマンド

コマンド
説明

isis hello-multiplier

隣接のダウンをルータが宣言するまでのネイバーの非受信 IS-IS hello パケット数。

isis hello-multiplier

隣接のダウンをルータが宣言するまでに必要なネイバーの非受信 Intermediate System-to-Intermediate System(IS-IS)hello パケット数を指定するには、インターフェイス コンフィギュレーション モードで、 isis hello-multiplier コマンドを使用します。デフォルト値にリストアするには、このコマンドの no 形式を使用します。

isis hello-multiplier multiplier { level-1 | level-2 }

no isis hello-multiplier { level-1 | level-2 }

 
シンタックスの説明

multiplier

整数値。範囲:3 ~ 1000。デフォルト: 3

level-1

level 1 隣接独自の hello 乗数を設定します。

level-2

level 2 隣接独自の hello 乗数を設定します。

 
コマンドのデフォルト設定

デフォルトの設定値は次のとおりです。

multiplier : 3

level 1 および level 2

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

IS-IS hello パケットの「ホールド タイム」とは、ネイバーが次の hello パケットを待つ時間です。この時間が経過すると、ネイバーのダウンが宣言されます。この値によって、障害状態のリンクやネイバーの検出とルート再計算にかかる時間が決まります。IS-IS hello パケットでアドバタイズされるホールド タイムは、hello 間隔に hello 乗数を掛けた値に設定されます。アドバタイズされたホールド タイムの間 IS-IS hello パケットを受信しないと、ネイバーはこのルータとの隣接関係がダウンしていると宣言します。ホールド タイム(つまり hello 乗数および hello 間隔)はインターフェイス単位で設定できます。また同じエリア内の異なるルータ間で異なるホールドタイムを使用することもできます。

hello 乗数を小さくすると、コンバージェンスが高速になりますが、ルーティングが不安定になる可能性があります。必要に応じて、ネットワークの安定性を高めるために hello 乗数の値を大きくしてください。hello 乗数をデフォルトの 3 未満の値に設定しないでください。

hello パケットが頻繁に失われ、IS-IS の隣接関係が不必要に障害状態になる場合は、 isis hello-
multiplier
コマンドを使用してください。hello 乗数を大きくして、hello 間隔を小さくすると( isis hello-interval コマンド)、リンク障害検出の所要時間を伸ばすことなく、hello プロトコルの信頼性を高めることができます。

ポイントツーポイント リンクでは、1 つの hello だけで level-1 と level-2 の両方に対応するので、異なる hello 乗数を設定できるのは、イーサネットや FDDI のようなマルチアクセス ネットワークの場合だけです。X.25、Frame Relay、ATM などのマルチポイント モードの Nonbroadcast Multizccess(NBMA)ネットワークでは、level-1 と level-2 に個別の hello パケットも送信されます。ただし、IS-IS は WAN NBMA メディアを通じたポイントツーポイント サブインターフェイスで実行することを推奨します。

次の例では、ネットワーク管理者は、隣接関係がダウンするのは、多数(10)の hello パケットが非受信になった場合だけにして、ネットワークの安定性を高めたいと考えています。リンク障害の検出にかかる総時間は 60 秒です。この設定では、ネットワークは安定した状態になりますが、リンクは完全に輻輳します。

switch(config)# router isis test1
switch(config-router)# interface ethernet 2/3
switch(config-if)# ip router isis
switch(config-if)# isis hello-interval 6 level-1
switch(config-if)# isis hello-multiplier 10 level-1

 
関連コマンド

コマンド
説明

isis hello-interval

Cisco NX-OS ソフトウェアによる hello パケットの送信間隔を指定します。

isis lsp-interval

後続の Intermediate System-to-Intermediate System(IS-IS)Link-State Packet(LSP)との間の送信遅延時間を設定するには、インターフェイス コンフィギュレーション モードで isis lsp-interval コマンドを使用します。デフォルト値にリストアするには、このコマンドの no 形式を使用します。

isis lsp-interval milliseconds

no isis lsp-interval

 
シンタックスの説明

milliseconds

後続の LSP(ミリ秒)との間の遅延時間。範囲:10 ~ 65535

 
コマンドのデフォルト設定

デフォルトの遅延時間は 33 ミリ秒です。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

IS-IS ネイバーやインターフェイスの数が多いトポロジでは、LSP の送受信による CPU 負荷によってルータに問題が生じることがあります。このコマンドを使用すると、LSP の送信レート(および他のシステムの受信レート)を削減できます。

次の例では、システムがインターフェイス Ethernet 0/0 で LSP を 100 ミリ秒ごとに送信するように(1 秒あたり 10 パケット)設定します。

switch(config)# router isis test1
switch(config-router)# interface ethernet 0/0
switch(config-if)# isis lsp-interval 100

 
関連コマンド

コマンド
説明

isis retransmit-interval

ポイントツーポイント リンクでの各 LSP(IS-IS リンクステート PDU)の送信間隔を設定します。

isis mesh-group

高メッシュのポイントツーポイント トポロジの NonBroadcase Multiaccess(NBMA)ネットワークで Link-State Packet(LSP)フラッディングを最適化するには、インターフェイス コンフィギュレーション モードで isis mesh-group コマンドを使用します。メッシュ グループからサブインターフェイスを削除するには、このコマンドの no 形式を使用します。

isis mesh-grou p { number | blocked }

no isis mesh-group { number | blocked }

 
シンタックスの説明

number

このインターフェイスがメンバーとして属しているメッシュグループの識別番号。範囲:1 ~ 4294967295

blocked

このサブインターフェイスでは LSP フラッディングが実行されないように指定します。

 
コマンドのデフォルト設定

インターフェイスは通常のフラッディングを実行します。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

メッシュ グループに属していないサブインターフェイスで最初に受信された LSP は通常、他のすべてのサブインターフェイスにフラッディングされます。

メッシュ グループに属しているサブインターフェイスで最初に受信された LSP は同じメッシュ グループ内のインターフェイスを除くすべてのインターフェイスににフラッディングされます。サブインターフェイスに blocked キーワードを入力すると、新しく受信された LSP は、そのインターフェイスからフラッディングされません。

不完全なフラッディングの可能性を最小限に抑えるためには、無制限のフラッディングを許可するのはメッシュ内の最小限のリンクだけにする必要があります。すべての物理パスをカバーするような論理リンクの最小セットを選択すると、フラディングは非常に少なくなりますが、ロバストネスが低下します。LSP フラッディングによってスケーリング パフォーマンスが阻害されず、しかも最大の障害時にも、ネットワークの他の部分から論理的に切断されるルータがないように、必要十分なリンクだけを選択できれば理想的です。つまり、すべてのリンクのフラッディングをブロックすれば、スケーリング パフォーマンスは最高になりますが、フラッディングはまったく生じなくなります。すべてのリンクでフラッディングを許可すると、スケーリング パフォーマンスが大きく低下します。

3 つのメッシュ グループ内の 6 つのインターフェイスを設定する例を示します。受信された LSP は次のように処理されます。

最初に Ethernet 1/0 を通じて受信された LSP は、Ethernet 1/0.2(同じメッシュ グループ内)と Ethernet 1/2.1(ブロックされている)を除くすべてのインターフェイスにフラッディングされます。

最初に Ethernet 1/1.2 を通じて受信された LSP は、Ethernet 1/1.1(同じメッシュ グループ内)と Ethernet 1/2.1(ブロックされている)を除くすべてのインターフェイスにフラッディングされます。

最初に Ethernet 1/2.1 を通じて受信された LSP は無視されず、通常どおりすべてのインターフェイスにフラッディングされます。最初に Ethernet 1/2.2 を通じて受信された LSP は、Ethernet 1/2.1(ブロックされている)を除くすべてのインターフェイスにフラッディングされます。

switch(config)# router isis test1
switch(config-router)# interface ethernet 1/0.1
switch(config-if)# isis mesh-group 10
 
switch(config)# router isis test1
switch(config-router)# interface ethernet 1/0.2
switch(config-if)# isis mesh-group 10
 
switch(config)# router isis test1
switch(config-router)# interface ethernet 1/1.1
switch(config-if)# isis mesh-group 11
 
switch(config)# router isis test1
switch(config-router)# interface ethernet 1/1.2
switch(config-if)# isis mesh-group 11
 
switch(config)# router isis test1
switch(config-router)# interface ethernet 1/2.1
switch(config-if)# isis mesh-group blocked
 
switch(config)# router isis test1
switch(config-router)# interface ethernet 1/2.2
switch(config-if)# isis mesh-group 12

 
関連コマンド

コマンド
説明

router isis

IS-IS ルーティング プロトコルをイネーブルにして、IS-IS プロセスを指定します。

isis metric

Intermediate System-to-Intermediate System(IS-IS)メトリック値を設定するには、インターフェイス コンフィギュレーション モードまたはサブインターフェイス モードで isis metric コマンドを使用します。デフォルト値にリストアするには、このコマンドの no 形式を使用します。

isis metric metric-value { level-1 | level-2 }

no isis metric metric-value { level-1 | level-2 }

 
シンタックスの説明

metric-value

リンクに指定されたメトリック。このメトリックは、このリンクを通じてネットワーク内の他の各ルータからその他の宛先へのコストの計算に使用されます。level 1 または level 2 のルーティングに対してこのメトリックを設定できます。範囲:1 ~ 16777215。デフォルト: 10

maximum

SPF(最短パス優先)計算からリンクまたは隣接を除外します。

level-1

Level-1(エリア内)ルーティングの SPF 計算のみにこのメトリックが使用されるように指定します。オプションのキーワードを指定しないと、level-1 と level 2 のルーティングに対してメトリックがイネーブルになります。

level-2

level-2(エリア間)ルーティングの SPF 計算のみにこのメトリックが使用されるように指定します。レベルを指定しないと、level-1 と level 2 のルーティングに対してメトリックがイネーブルになります。

 
コマンドのデフォルト設定

デフォルトのメトリック値は 10 秒です。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

level-1 または level-2 のキーワードを指定すると、level-1 または level-2 のそれぞれのルーティングに対してだけメトリックがリセットされます。

すべてのインターフェイスにメトリックを設定することを推奨します。メトリックを設定しないインターフェイスがあると、IS-IS メトリックはホップカウント メトリックと同様になります。

Link-State Packet(LSP)での IPv4 情報のアドバタイズに使用される TLV は拡張メトリックのみを使用するように定義されるので、 metric-style wide コマンドを使用して、IS-IS が 新形式の Type-Length-Value(TLV)を使用するように設定することを推奨します。Cisco NX-OS ソフトウェアは、24 ビット メトリック フィールドをサポートしています。24 ビットメトリック フィールドは ワイド メトリック と呼ばれています。新しいメトリック形式を使用すると、リンク メトリックの最大値は 16777215 、総パスメトリックは 4261412864 になります。

インターフェイス Ethernet 3/2 に対して、level 1 のリンクステート メトリック コストを 15 に設定する例を示します。

switch(config)# router isis test1
switch(config-router)# interface ethernet 3/2
switch(config-if)# isis metric 15 level-1

 
関連コマンドC

コマンド
説明

metric-style wide

IS-IS を実行中のルータが新形式の TLV のみを生成、受信するように設定します。

isis passive

インターフェイスに関連したプレフィクスのアドバタイズを続けながら、そのインターフェイスでの隣接関係の形成を停止する場合は、インターフェイス コンフィギュレーション モードで isis passive コマンドを使用します。停止をディセーブルにするには、このコマンドの no 形式を使用します。

isis passive {level-1 | level-1-2 | level-2-only}

no isis passive {level-1 | level-1-2 | level-2-only}

 
シンタックスの説明

level-1

level 1 PDU のみを停止します。

level-1-2

level 1 と level 2 の PDU を停止します。

level-2-only

level 2 PDU のみを停止します。

 
デフォルト

デフォルトの設定値は次のとおりです。

デフォルトでは、このコマンドはディセーブルです。

イネーブルにした場合のデフォルトは level-1-2 です。

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには、Enterprise Services ライセンスが必要です。

level 1 で インターフェイス Ethernet 3/2 の隣接関係を停止する例を示します。

switch(config)# router isis test1
switch(config-router)# interface ethernet 3/2
switch(config-if)# isis passive level-1

 

isis priority

代表ルータのプライオリティを設定するには、インターフェイス コンフィギュレーション モードで isis priority コマンドを使用します。デフォルトのプライオリティにリセットするには、このコマンドの no 形式を使用します。

isis priority number-value [ level-1 | level-2 ]

no isis priority [ level-1 | level-2 ]

 
シンタックスの説明

number-value

ルータのプライオリティを設定します(0 ~ 127 の数値)。デフォルト値は 64 です。

level-1

(任意)level 1 独自のプライオリティを設定します。

level-2

(任意)level 2 独自のプライオリティを設定します。

 
デフォルト

プライオリティ 64
level 1 および level 2

 
コマンド モード

インターフェイス コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

プライオリティは level-1 と level-2 のそれぞれに設定できます。 level-1 または level-2 のキーワードを指定すると、level-1 または level-2 のそれぞれのルーティングのプライオリティだけがリセットされます。

プライオリティ値は、LAN 上の代表ルータまたは Designated Intermediate System(DIS)を決める際に使用されます。プライオリティは hello パケットでアドバタイズされます。プライオリティが最高のルータが DIS になります。

Intermediate System-to-Intermediate System(IS-IS)では、バックアップ代表ルータはありません。プライオリティを 0 に設定すると、そのシステムが DIS になる可能性は低くなりますが、完全に回避することはできません。プライオリティの高いルータがオンラインになると、現在の DIS からその役割を引継ぎます。プライオリティ値が同一の場合は、MAC アドレス値が高いルータが優先されます。

プライオリティ レベルを 80 に設定することによって level-1 ルーティングを優先する例を示します。このルータは DISになる確立が高くなります。

switch(config)# router isis test1
switch(config-router)# interface ethernet 3/2
switch(config-if)# isis priority 80 level-1