Cisco NX-OS Unicast Routing コマンド レファレンス Release 4.0
M コマンド
M コマンド
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

M コマンド

match as-path

match community

match ip address

match ip multicast

match ip next-hop prefix-list

match ip route-source prefix-list

match ipv6 address

match ipv6 multicast

match ipv6 next-hop prefix-list

match ipv6 route-source prefix-list

match length

match route-type

match tag

max-lsp-lifetime

max-metric router-lsa(OSPF)

maximum-paths(BGP)

maximum-paths(IS-IS)

maximum-paths(RIP)

maximum-paths(EIGRP)

maximum-paths(OSPF)

maximum-paths(OSPFv3)

maximum-prefix

message-digest-key(OSPF virtual link)

policy statistics enable(OSPF)

metric maximum-hops

metric weights

M コマンド

ここでは、[M] から始まる Cisco NX-OS ユニキャスト ルーティング コマンドについて説明します。

match as-path

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)自律システム パス アクセス リストと照合するには、ルートマップ コンフィギュレーション モードで match as-path コマンドを使用します。パス リスト エントリを削除するには、このコマンドの no 形式を使用します。

match as-path name [... name ]

no match as-path name [... name ]

 
シンタックスの説明

name

自律システム パス アクセス リスト。名前には最大 63 文字の英数字を使用できます。

...name

(任意)自律システム パス アクセス リスト。最大 32 のアクセス リスト名を設定できます。

 
デフォルト

パス リストは定義されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

match as-path コマンドを使用して値を設定すると、グローバル値が上書きされます。

ルート マップは複数の部分で構成できます。 route-map コマンドに関連した match 節と 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

このコマンドにはライセンスは必要ありません。

自律システム パスを BGP 自律システム パス アクセス リスト 20 と照合するように設定する例を示します。

switch(config)# route-map IGP2BGP
switch(config-route-map)# match as-path 20

 
関連コマンド

コマンド
説明

match community

BGP コミュニティと照合します。

match ip address

標準アクセス リストまたは拡張アクセス リストで宛先ネットワーク番号のアドレスが許可されているルートを配布し、パケットのポリシー ルーティングを行います。

match ip next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match route-type(IP)

指定タイプのルートを再配布します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set comm-list

ルート マップの設定におけるタグ値を自動計算します。

set community

BGP コミュニティ リストを設定します(削除用)。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set origin(BGP)

BGP オリジン コードを設定します。

set tag(IP)

宛先ルーティング プロトコルの値を設定します。

set vrf

ネクストホップ解決の VRF を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match community

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)コミュニティと照合するには、ルートマップ コンフィギュレーション モードで match community コマンドを使用します。コンフィギュレーション ファイルから match community コマンドを削除し、システムをデフォルトの条件(BGP コミュニティ リスト エントリを削除)に戻すには、このコマンドの no 形式を使用します。

community name [... name ] [ exact-match ]

no community name [... name ] [ exact-match ]

 
シンタックスの説明

name

1 つ以上のコミュニティ リスト名。名前には最大 63 文字の英数字を使用できます。最大 32 のコミュニティ リストを設定できます。

exact-match

(任意)完全一致が必要であることを示します。指定されたすべてのコミュニティのみが存在する必要があります。

 
コマンドのデフォルト設定

ルート マップではコミュニティ リストの照合は行われません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

ルート マップは複数の部分で構成できます。 route-map コマンドに関連した match コマンドと 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

コミュニティ リスト番号に基づく照合は、BGP に適用できる match コマンドのタイプの 1 つです。

このコマンドにはライセンスは必要ありません。

次の例では、2 つの BGP コミュニティと照合されます。

switch(config)# route-map test2
switch(config-route-map)# match community 1 10
 

次の例では、コミュニティ リスト 1 と一致するルートの重み値が 200 に設定されます。重み値が 200 に設定されるのは、標準コミュニティ 109 のルートだけです。

switch(config)# ip community-list standard 1 permit 109
switch(config)# route-map set_weight
switch(config-route-map)# match community 1 exact-match
switch(config-route-map)# set weight 200
 

次の例では、コミュニティ リスト LIST_NAME と一致するルートの重み値が 100 に設定されます。重み値が 100 に設定されるのは、標準コミュニティ 101 のルートだけです。

switch(config)# ip community-list standard LIST_NAME permit 101
switch(config)# route-map set_weight
switch(config-route-map)# match community LIST_NAME
switch(config-route-map)# set weight 100
 

次に示すのは、コミュニティ リスト 500と一致するルートの例です。拡張コミュニティ 1 を持つルートは重み値が 150 に設定されます。

switch(config)# ip community-list expanded 500 permit [0-9]*
switch(config)# route-map MAP_NAME permit 10
switch(config-route-map)# match community 500
switch(config-route-map)# set weight 150

 
関連コマンド

コマンド
説明

ip community-list

BGP のコミュニティ リストを作成し、アクセスを制御します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

 

match ip address

宛先 IP ネットワーク番号アドレスが標準アクセス リスト、拡張アクセス リスト、またはプレフィクス リストで許可されているルートを配布する場合、またはパケットにポリシー ルーティングを実行する場合は、ルートマップ コンフィギュレーション モードで match ip address コマンドを使用します。 match ip address エントリを削除するには、このコマンドの no 形式を使用します。

match ip address { access-list-name [ access-list-name... ] | prefix-list prefix-list-name [ prefix-list-name... ]}

no match ip address { access-list-name [ access-list-name... ] | prefix-list prefix-list-name [ prefix-list-name... ]}

 
シンタックスの説明

access-list-name...

標準アクセス リストまたは拡張アクセス リストの名前。最大 63 文字の英数字を使用できます。省略符合は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

prefix-list prefix-list-name...

プレフィクス リストに基づいてルートを配布します。プレフィクス リスト名には最大 63 文字の英数字を使用できます。省略符合は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
デフォルト

アクセス リスト名もプレフィクス リストも指定されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

access-list-name 引数がサポートされるのは、PBR のルートマップに限定されます。

このコマンド構文内の省略符号(...)は、 access-list-name 引数または prefix-list-name 引数に複数の値を入力できることを示します。

同じルート マップ サブブロック内の類似 match は、「OR」(論理和)でフィルタリングされます。ルート マップ サブブロック全体の中に一致する match 節が 1 つあれば、照合の成功として処理されます。非類似 match 節は、「AND」(論理積)でフィルタリングされます。したがって、非類似照合は論理的にフィルタリングされます。最初の条件セットが満たされない場合、2番めの match 節がフィルタリングされます。このプロセスは一致するものが見つかるまで、または match 節がなくなるまで続きます。

ルートを再配布する場合、またはパケットにポリシー ルーティングを適用する場合は、ルート マップを使用します。ここでは、この両方の用途について説明します。

再配布

1 つのルーティング プロトコルから別のルーティング プロトコルへのルートの再配布条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set のルートマップ コンフィギュレーション コマンドを使用します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドでは、 一致基準 (現行の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定の再配布処理)を指定します。 no route-map コマンドを使用すると、ルート マップが削除されます。

match ルートマップ コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で入力できます。 set コマンドで指定された set 処理 に基づいてルートが再配布されるためには、すべての match コマンドを「通過する」必要があります。 match コマンドの no 形式を使用すると、そのコマンドで指定された一致基準が削除されます。

ルート マップを使用してルートを渡す場合、ルートマップの複数のセクションに特定の match 節を入力できます。 route-map コマンドに関連した match 節と 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

ポリシー ルーティング

ルートマップには、ポリシー ルーティングをイネーブルにするというもう 1つの用途があります。match ip address コマンドを使用すると、拡張アクセス リスト(プロトコル、プロトコル サービス、ソースまたは宛先の IP アドレスなど)による一致基準に基づいたパケットのポリシー ルーティングが可能になります。パケットのポリシー ルーティング条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set ルートマップ コンフィギュレーション コマンドに加えて、 ip policy route-map インターフェイス コンフィギュレーション コマンドも使用します。各 route-map コマンドは、関連する match コマンドおよび set コマンドのリストで構成されます。 match コマンドでは、 一致基準 (ポリシー ルーティングが発生する条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定のルーティング処理)を指定します。送信元に基づくパケットのポリシー ルーティングを、たとえばアクセス リストを使用して実行できます。

このコマンドにはライセンスは必要ありません。

次の例では、アクセス リスト test で指定されたアドレスを持つルートが一致とみなされます。

switch(config)# feature pbr
switch(config)# interface ethernet 2/10
switch(config-if)# ip policy route-map chicago
switch(config-if)# exit
switch(config)# route-map chicago
switch(config-route-map)# match ip address test

 
関連コマンド

コマンド
説明

ip policy route-map

インターフェイスに対するポリシー ルーティングに使用するルート マップを特定します。

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match interface(IP)

指定されたインターフェイスのどれかがネクストホップであるルートを再配布します。

match ip next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match ip route-source

アクセス リストで指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

レベル 3 パケット長に基づいてポリシー ルーティングを実行します。

match metric(IP)

指定メトリックのルートを再配布します。

match route-type(IP)

指定タイプのルートを再配布します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

タグ値を自動的に算出します。

set community

BGP コミュニティ アトリビュートを設定します。

set ip default next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先、および Cisco NX-OS ソフトウェアに宛先への明示的なルートがないパケットの送出先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルの値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match ip multicast

ルート マップの照合に IPv4 マルチキャスト機能を設定するには、 match ip multicast ルートマップ コンフィギュレーション コマンドを使用します。この match 設定を削除するには、このコマンドの no 形式を使用します。

match ip multicast { group address/length | rp address/length [ rp-type { asm | bidir} ]}

no match ip multicast

 
シンタックスの説明

group address/length

ネットワーク アドレスおよびネットワーク マスクの長さ(ビット)を次の形式で指定します。 A . B . C . D / length 。ネットワーク番号には、任意の有効な IP アドレスまたはプレフィクスを指定できます。ビット マスクは、0 ~ 32 の数値です。

group と rp の両方のオプションを設定できます。

rp address/length

IPv4 Rendezvous Prefix(RP)および IPv4 プレフィクス マスクの長さ(ビット)を次の形式で指定します。 A . B . C . D / length 。ネットワーク番号には、任意の有効な IPv4 アドレスまたはプレフィクスを指定できます。ビット マスクは、0 ~ 32 の数値です。

group と rp の両方のオプションを設定できます。

rp-type

(任意)マルチキャスト Rendezvous Point(RP; ランデブー ポイント)タイプを指定します。

asm

Any-Source Multicast(ASM)RP タイプを指定します。

bidir

双方向(bidir)マルチキャスト RP タイプを指定します。

 
コマンドのデフォルト設定

なし

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

照合するマルチキャスト アトリビュートを指定するには、 match ip multicast コマンドを使用します。

ルート マップ コンフィギュレーション モードを開始するには、 route-map コマンドを使用します。 route-map コマンドを入力すると、プロンプトが次のように変更されます。

switch(config-route-map)#
 

ルートマップ コンフィギュレーション モードになると、 match ip multicast コマンドを入力できます。

group と rp の両方のオプションを設定できます。

このコマンドにはライセンスは必要ありません。

照合するネイバーの group IPv4 プレフィクスと、IPv4 プレフィクスの長さを指定する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match ip multicast group 192.0.0.0/19
switch(config-route-map)#
 

照合するネイバーの group IPv4 プレフィクスと、rp IPv4 プレフィクスを両方指定する例を示します。

switch(config)# route-map raspberry
switch(config-route-map)# match ip multicast group 192.0.0.0/19 rp 209.165.201.0/27
switch(config-route-map)#

 
関連コマンド

コマンド
説明

ip policy route-map

インターフェイスに対するポリシー ルーティングに使用するルート マップを特定します。

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match interface(IP)

指定されたインターフェイスのどれかがネクストホップであるルートを再配布します。

match ip next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match ip route-source

アクセス リストで指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

レベル 3 パケット長に基づいてポリシー ルーティングを実行します。

match metric(IP)

指定メトリックのルートを再配布します。

match route-type(IP)

指定タイプのルートを再配布します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

タグ値を自動的に算出します。

set community

BGP コミュニティ アトリビュートを設定します。

set ip default next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先、および Cisco NX-OS ソフトウェアに宛先への明示的なルートがないパケットの送出先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match ip next-hop prefix-list

指定のアクセス リストの 1 つとネクストホップ ルータ アドレスが一致した IPv4 ルートを再配布するには、ルートマップ コンフィギュレーション モードで、 match ip next-hop prefix-list コマンドを使用します。ネクストホップ エントリを削除するには、このコマンドの no 形式を使用します。

match ip next-hop prefix-list prefix-list-name [ ...prefix-list-name ]

no match ip next-hop prefix-list prefix-list-name [ ...prefix-list-name ]

 
シンタックスの説明

prefix-list-name

プレフィクス リストの番号または名前。最大 63 文字の英数字を使用できます。省略符合は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
コマンドのデフォルト設定

ネクストホップ アドレスの一致を必要とせず、自由にルートが再配布されます。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 prefix-list-name 引数に複数の値を入力できることを示します。

1 つのルーティング プロトコルから別のルーティング プロトコルへのルートの再配布条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set のルートマップ コンフィギュレーション コマンドを使用します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドでは、 一致基準 (現行の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定の再配布処理)を指定します。 no route-map コマンドを使用すると、ルート マップが削除されます。

match ルートマップ コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で入力できます。 set コマンドで指定された set 処理 に基づいてルートが再配布されるためには、すべての match コマンドを「通過する」必要があります。 match コマンドの no 形式を使用すると、そのコマンドで指定された一致基準が削除されます。

ルート マップを使用してルートを渡す場合、ルートマップを複数の部分で構成できます。 route-map コマンドに関連した match 節と 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

このコマンドにはライセンスは必要ありません。

次の例では、ネクストホップ ルータ アドレスがプレフィクス リスト test で一致したルートが再配布されます。

switch(config)# route-map blue
switch(config-route-map)# match ip next-hop prefix-list test

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match ip address

標準アクセス リストまたは拡張アクセス リストで宛先ネットワーク番号のアドレスが許可されているルートを配布し、パケットのポリシー ルーティングを行います。

match ip route-source

アクセス リストで指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match route-type(IP)

指定タイプのルートを再配布します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

タグ値を自動的に算出します。

set community

BGP コミュニティ アトリビュートを設定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルの値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match ip route-source prefix-list

アクセス リストに指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされた IPv4 ルートを再配布するには、ルートマップ コンフィギュレーション モードで、 match ip route-source prefix-list コマンドを使用します。ルート ソース エントリを削除するには、このコマンドの no 形式を使用します。

match ip route-source prefix-list prefix-list-name [ ...prefix-list-name ]

no match ip route-source prefix-list prefix-list-name [ ...prefix-list-name ]

 
シンタックスの説明

prefix-list-name

プレフィクス リストの番号または名前。最大 63 文字の英数字を使用できます。省略符合は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
デフォルト

ルート ソースに対するフィルタリングは実行されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 prefix-list-name 引数に、複数の値を入力できることを示します。

1 つのルーティング プロトコルから別のルーティング プロトコルへのルートの再配布条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set のルートマップ コンフィギュレーション コマンドを使用します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドでは、 一致基準 (現行の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定の再配布処理)を指定します。 no route-map コマンドを使用すると、ルート マップが削除されます。

match ルートマップ コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で入力できます。 set コマンドで指定された set 処理 に基づいてルートが再配布されるためには、すべての match コマンドを「通過する」必要があります。 match コマンドの no 形式を使用すると、そのコマンドで指定された一致基準が削除されます。

ルート マップは複数の部分で構成できます。 route-map コマンドに関連した match 節と 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

ルートのネクストホップとソース ルータ アドレスが同じではない場合もあります。

このコマンドにはライセンスは必要ありません。

次の例では、アクセス リスト 5 および 80 で指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートが再配布されます。

switch(config)# route-map blue
switch(config-route-map)# match ip route-source prefix-list 5 80

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match ip address

標準アクセス リストまたは拡張アクセス リストで宛先ネットワーク番号のアドレスが許可されているルートを配布し、パケットのポリシー ルーティングを行います。

match ip next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match route-type(IP)

指定タイプのルートを再配布します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

タグ値を自動的に算出します。

set community

BGP コミュニティ アトリビュートを設定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match ipv6 address

宛先 IPv6 ネットワーク番号アドレスが標準アクセス リスト、拡張アクセス リスト、またはプレフィクス リストで許可されているルートを配布する場合、またはパケットにポリシー ルーティングを実行する場合は、ルートマップ コンフィギュレーション モードで match ipv6 address コマンドを使用します。 match 文をルート マップから削除するには、このコマンドの no 形式を使用します。

match ipv6 address { prefix-list prefix-list-name [ prefix-list-name... ] | access-list-name

no match ipv6 address { prefix-list prefix-list-name [ prefix-list-name... ] | access-list-name }

 
シンタックスの説明

access-list-name...

標準アクセス リストまたは拡張アクセス リストの名前。最大 63 文字の英数字を使用できます。

使用できるのは、ポリシーベース ルーティング用のアクセス リストだけです。

prefix-list prefix-list-name...

プレフィクス リストに基づいてルートを配布します。プレフィクス リストには最大 63 文字の英数字を使用できます。省略符号は、複数の値を入力可能であることを示します。最大 32 のプレフィクス リストを設定できます。

 
デフォルト

アクセス リスト名もプレフィクス リストも指定されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

access-list-name 引数がサポートされるのは、PBR のルートマップに限定されます。

このコマンド構文内の省略符号(...)は、 prefix-list-name 引数に複数の値を入力できることを示します。

同じルート マップ サブブロック内の類似 match は、「OR」(論理和)でフィルタリングされます。ルート マップ サブブロック全体の中に一致する match 節が 1 つあれば、照合の成功として処理されます。非類似 match 節は、「AND」(論理積)でフィルタリングされます。したがって、非類似照合は論理的にフィルタリングされます。最初の条件セットが満たされない場合、2番めの match 節がフィルタリングされます。このプロセスは一致するものが見つかるまで、または match 節がなくなるまで続きます。

ルートを再配布する場合、またはパケットにポリシー ルーティングを適用する場合は、ルート マップを使用します。ここでは、この両方の用途について説明します。

再配布

1 つのルーティング プロトコルから別のルーティング プロトコルへのルートの再配布条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set のルートマップ コンフィギュレーション コマンドを使用します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドでは、 一致基準 (現行の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定の再配布処理)を指定します。 no route-map コマンドを使用すると、ルート マップが削除されます。

match ルートマップ コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で入力できます。 set コマンドで指定された set 処理 に基づいてルートが再配布されるためには、すべての match コマンドを「通過する」必要があります。 match コマンドの no 形式を使用すると、そのコマンドで指定された一致基準が削除されます。

ルート マップを使用してルートを渡す場合、ルートマップの複数のセクションに特定の match 節を入力できます。 route-map コマンドに関連した match 節と 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

このコマンドにはライセンスは必要ありません。

次の例では、アクセス リスト名 red で指定されたアドレスを持つルートが一致とみなされます。

switch(config)# feature pbr
switch(config)# route-map blue
switch(config-route-map)# match ipv6 address red

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match interface(IP)

指定されたインターフェイスのどれかがネクストホップであるルートを再配布します。

match ip next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match ip route-source

アクセス リストで指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

レベル 3 パケット長に基づいてポリシー ルーティングを実行します。

match metric(IP)

指定メトリックのルートを再配布します。

match route-type(IP)

指定タイプのルートを再配布します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

タグ値を自動的に算出します。

set community

BGP コミュニティ アトリビュートを設定します。

set ip default next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先、および Cisco NX-OS ソフトウェアに宛先への明示的なルートがないパケットの送出先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match ipv6 multicast

ルート マップの照合に IPv6 マルチキャスト機能を設定するには、 match ipv6 multicast ルートマップ コンフィギュレーション コマンドを使用します。この match 設定を削除するには、このコマンドの no 形式を使用します。

ip multicast { group address/length | rp address/length [ rp -type { asm | bidir }]}

 
シンタックスの説明

group address/length

ネットワーク アドレスおよびネットワーク マスクの長さ(ビット)を次の形式で指定します。 A : B :: C : D / length 。ネットワーク番号には、任意の有効な IPv6 アドレスまたはプレフィクスを指定できます。 length の範囲は、0 ~ 0x7FFFFFFF です。

group rp の両方のオプションを指定できます。

rp address/length

IPv6 Rendezvous Prefix(RP)およびIPv6 プレフィクス マスクの長さ(ビット)を次の形式で指定します。 A : B :: C : D / length 。ネットワーク番号には、任意の有効な IPv6 アドレスまたはプレフィクスを指定できます。ビット マスクは、0 ~ 32 の数値です。

group rp の両方のオプションを指定できます。

rp-type

(任意)マルチキャスト Rendezvous Point(RP; ランデブー ポイント)タイプを指定します。

asm

Any-Source Multicast(ASM)RP タイプを指定します。

bidir

双方向(bidir)マルチキャスト RP タイプを指定します。

 
コマンドのデフォルト設定

なし

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

照合するマルチキャスト アトリビュートを指定するには、 match ipv6 multicast ルートマップ コンフィギュレーション コマンドを使用します。 route-map コマンドを入力する前に、 feature pbr グローバル コンフィギュレーション モード コマンドを入力して PBR をイネーブルにする必要があります。

ルート マップ コンフィギュレーション モードを開始するには、 route-map コマンドを使用します。 route-map コマンドを入力すると、プロンプトが次のように変更されます。

switch(config-route-map)#
 

ルートマップ コンフィギュレーション モードになると、 match ipv6 multicast コマンドを入力できます。

group rp の両方のオプションを指定できます。

このコマンドにはライセンスは必要ありません。

照合するネイバーの group IPv6 プレフィクスと、IPv6 プレフィクスの長さを指定する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match ipv6 multicast group 30:0::0:0/12
switch(config-route-map)#
 

照合するネイバーの group IPv6 プレフィクスと、rp IPv6 プレフィクスを両方指定する例を示します。

switch(config)# route-map red
switch(config-route-map)# match ipv6 multicast group 30:0::0:0/12 rp 2001:0DB8::/48
switch(config-route-map)#

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match ipv6 next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match ipv6 route-source

アクセス リストで指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

レベル 3 パケット長に基づいてポリシー ルーティングを実行します。

match route-type

指定タイプのルートを再配布します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布します。

route-map

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set ipv6 default next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先、および Cisco NX-OS ソフトウェアに宛先への明示的なルートがないパケットの送出先を示します。

set ipv6 next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルの値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match ipv6 next-hop prefix-list

指定のアクセス リストの 1 つとネクストホップ ルータ アドレスが一致した IPv6 ルートを再配布するには、ルートマップ コンフィギュレーション モードで、 match ip next-hop prefix-list コマンドを使用します。ネクストホップ エントリを削除するには、このコマンドの no 形式を使用します。

match ipv6 next-hop prefix-list name [ ...name ]

no match ipv6 next-hop prefix-list name [ ...name ]

 
シンタックスの説明

name...

プレフィクス リストの名前。最大 63 文字の英数字を使用できます。省略符合は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
コマンドのデフォルト設定

ネクストホップ アドレスの一致を必要とせず、自由にルートが再配布されます。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 name 引数に複数の値を入力できることを示します。

1 つのルーティング プロトコルから別のルーティング プロトコルへのルートの再配布条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set のルートマップ コンフィギュレーション コマンドを使用します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドでは、 一致基準 (現行の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定の再配布処理)を指定します。 no route-map コマンドを使用すると、ルート マップが削除されます。

match ルートマップ コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で入力できます。 set コマンドで指定された set 処理 に基づいてルートが再配布されるためには、すべての match コマンドを「通過する」必要があります。 match コマンドの no 形式を使用すると、そのコマンドで指定された一致基準が削除されます。


match コマンドがなく、set コマンドだけの許可ルート マップでは、すべてのルートが許可されます。


ルート マップを使用してルートを渡す場合、ルートマップを複数の部分で構成できます。 route-map コマンドに関連した match 節と 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

このコマンドにはライセンスは必要ありません。

次の例では、ネクストホップ ルータ アドレスがプレフィクス リスト 5 で一致したルートが再配布されます。

switch(config)# route-map blue
switch(config-route-map)# match ipv6 next-hop prefix-list test

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match ipv6 next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match ip route-source

アクセス リストで指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

レベル 3 パケット長に基づいてポリシー ルーティングを実行します。

match route-type

指定タイプのルートを再配布します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布します。

route-map

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set ipv6 default next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先、および Cisco NX-OS ソフトウェアに宛先への明示的なルートがないパケットの送出先を示します。

set ipv6 next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match ipv6 route-source prefix-list

アクセス リストに指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされた IPv6 ルートを再配布するには、ルートマップ コンフィギュレーション モードで、 match ipv6 route-source prefix-list コマンドを使用します。ルート ソース エントリを削除するには、このコマンドの no 形式を使用します。

match ipv6 route-source prefix-list name [ ...name ]

no match ipv6 route-source prefix-list name [ ...name ]

 
シンタックスの説明

name...

プレフィクス リストの名前。最大 63 文字の英数字を使用できます。省略符合は、複数値(最大 32 のプレフィクス リスト)の入力が可能であることを示します。

 
デフォルト

ルート ソースに対するフィルタリングは実行されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 name 引数に複数の値を入力できることを示します。

1 つのルーティング プロトコルから別のルーティング プロトコルへのルートの再配布条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set のルートマップ コンフィギュレーション コマンドを使用します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドでは、 一致基準 (現行の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定の再配布処理)を指定します。 no route-map コマンドを使用すると、ルート マップが削除されます。

match ルートマップ コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で入力できます。 set コマンドで指定された set 処理 に基づいてルートが再配布されるためには、すべての match コマンドを「通過する」必要があります。 match コマンドの no 形式を使用すると、そのコマンドで指定された一致基準が削除されます。

ルート マップは複数の部分で構成できます。 route-map コマンドに関連した match 節と 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

ルートのネクストホップとソース ルータ アドレスが同じではない場合もあります。

このコマンドにはライセンスは必要ありません。

次の例では、プレフィクス リスト test で指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートが再配布されます。

switch(config)# route-map blue
switch(config-route-map)# match ipv6 route-source prefix-list test

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match ip address

標準アクセス リストまたは拡張アクセス リストで宛先ネットワーク番号のアドレスが許可されているルートを配布し、パケットのポリシー ルーティングを行います。

match ip next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match route-type(IP)

指定タイプのルートを再配布します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

タグ値を自動的に算出します。

set community

BGP コミュニティ アトリビュートを設定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match length

レベル 3 パケット長に基づくポリシー ルーティングを実行するには、ルートマップ コンフィギュレーション モードで、 match length コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

match length minimum-length maximum-length

no match length minimum-length maximum-length

 
シンタックスの説明

minimum-length

一致として許容されるレベル 3 パケット長の最小値(この値を範囲に含む)。範囲:0 ~ 2147483647

maximum-length

一致として許容されるレベル 3 パケット長の最大値(この値を範囲に含む)。範囲:0 ~ 2147483647

 
コマンドのデフォルト設定

パケット長に基づくポリシー ルーティングは実行されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

IPv4 でパケットのポリシー ルーティング条件を定義するには、 ip policy route-map インターフェイス コンフィギュレーション コマンド、 route-map グローバル コンフィギュレーション コマンド、および match set のルートマップ コンフィギュレーション コマンドを使用します。 ip policy route-map コマンドでは、ルート マップを名前で指定します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドでは、 一致基準 (ポリシー ルーティングが発生する条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定のルーティング処理)を指定します。

IPv4 の match ルートマップ コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で入力できます。 set コマンドで指定された set 処理 に基づいてパケットがルーティングされるようにするためには、すべての match コマンドを「通過する」必要があります。 match コマンドの no 形式を使用すると、そのコマンドで指定された一致基準が削除されます。

IPv4 では、パケット長に基づくポリシー ルーティングが可能なため、インタラクティブ トラフィックとバルク トラフィックを異なるルータに送信できます。

このコマンドにはライセンスは必要ありません。

パケット長を 3 ~ 200 バイトに設定する例を示します。

switch(config)# route-map blue
switch(config-route-map)# match length 3 200

 
関連コマンド

コマンド
説明

match ip address

標準アクセス リストまたは拡張アクセス リストで宛先ネットワーク番号のアドレスが許可されているルートを配布し、パケットのポリシー ルーティングを行います。

match ipv6 address

IPv6 の PBR でパケットの照合に使用する IPv6 アクセス リストを指定します。

match length

レベル 3 パケット長に基づいてポリシー ルーティングを実行します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set ip default next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先、および Cisco NX-OS ソフトウェアに宛先への明示的なルートがないパケットの送出先を示します。

set ipv6 default next-hop

一致パケットが転送されるデフォルトの IPv6 ネクストホップを指定します。

set ipv6 next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set ipv6 precedence

IPv6 パケット ヘッダーのプリファレンス値を設定します。

match route-type

指定タイプのルートを再配布するには、ルートマップ コンフィギュレーション モードで match route-type コマンドを使用します。ルート タイプ エントリを削除するには、このコマンドの no 形式を使用します。

match route-type { external | internal | level-1 | level-2 | local | nssa-external | type-1 | type-2 }

no match route-type { external | internal | level-1 | level-2 | local | nssa-external | type-1 | type-2 }

 
シンタックスの説明

external

外部ルートを指定します(Border Gateway Protocol [BGP]、Enhanced Interior Gateway Routing Protocol [EIGRP]、および Open Shortest Path First [OSPF] タイプ 1/2)。

複数のキーワードを指定できます。

internal

内部ルートを指定します(OSPF エリア内/エリア間)

複数のキーワードを指定できます。

level-1

Intermediate System-to-Intermediate System(IS-IS)レベル 1 ルートを指定します。

複数のキーワードを指定できます。

level-2

IS-IS レベル 2 ルートを指定します。

複数のキーワードを指定できます。

local

ローカル生成ルートを指定します。

複数のキーワードを指定できます。

nssa-external

NSSA 外部ルートを指定します(OSPF タイプ 1/2)。

複数のキーワードを指定できます。

type-1

OSPF 外部タイプ 1 ルートを指定します。

複数のキーワードを指定できます。

type-2

OSPF 外部タイプ 2 ルートを指定します。

複数のキーワードを指定できます。

 
デフォルト

デフォルトでは、このコマンドはディセーブルです。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

1 つのルーティング プロトコルから別のルーティング プロトコルへのルートの再配布条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set のルートマップ コンフィギュレーション コマンドを使用します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドでは、 一致基準 (現行の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定の再配布処理)を指定します。 no route-map コマンドを使用すると、ルート マップが削除されます。

match ルートマップ コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で入力できます。 set コマンドで指定された set 処理 に基づいてルートが再配布されるためには、すべての match コマンドを「通過する」必要があります。 match コマンドの no 形式を使用すると、そのコマンドで指定された一致基準が削除されます。

ルート マップは複数の部分で構成できます。 route-map コマンドに関連した match 節と 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

複数のキーワードを指定できます。

このコマンドにはライセンスは必要ありません。

内部ルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match route-type internal
 

内部ルートと タイプ 1 OSPF ルートを再配布する例を示します。

switch(config)# route-map blueberry
switch(config-route-map)# match route-type internal type-1

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match ip address

標準アクセス リストまたは拡張アクセス リストで宛先ネットワーク番号のアドレスが許可されているルートを配布し、パケットのポリシー ルーティングを行います。

match ip next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match ip route-source

アクセス リストで指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定メトリックのルートを再配布します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布するには、ルートマップ コンフィギュレーション モードで match tag コマンドを使用します。タグ エントリを削除するには、このコマンドの no 形式を使用します。

match tag tag-value [ ...tag-value ]

no match tag tag-value [ ...tag-value ]

 
シンタックスの説明

tag-value

1 つ以上のルート タグ値のリスト。各値は 0 ~ 4294967295 の整数で指定できます。最大 32 のタグを設定できます。

 
デフォルト

match tag の値は定義されません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンド構文内の省略符号(...)は、 tag-value 引数に複数の値を入力できることを示します。

1 つのルーティング プロトコルから別のルーティング プロトコルへのルートの再配布条件を定義するには、 route-map グローバル コンフィギュレーション コマンドと、 match および set のルートマップ コンフィギュレーション コマンドを使用します。各 route-map コマンドには、関連する match コマンドおよび set コマンドのリストがあります。 match コマンドでは、 一致基準 (現行の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、 set 処理 match コマンドによる基準が満たされた場合に実行する特定の再配布処理)を指定します。 no route-map コマンドを使用すると、ルート マップが削除されます。

match ルートマップ コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で入力できます。 set コマンドで指定された set 処理 に基づいてルートが再配布されるためには、すべての match コマンドを「通過する」必要があります。 match コマンドの no 形式を使用すると、そのコマンドで指定された一致基準が削除されます。

ルート マップは複数の部分で構成できます。 route-map コマンドに関連した match 節と 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。一部のデータのみを変更したい場合は、2 番めのルートマップ セクションに明示的に match を指定する必要があります。

このコマンドにはライセンスは必要ありません。

次の例では、ルーティング テーブルに保存されているタグ 5 のルートが再配布されます。

switch(config)# route-map blueberry
switch(config-route-map)# match tag 5

 
関連コマンド

コマンド
説明

match as-path

BGP 自律システム パス アクセス リストと照合します。

match community

BGP コミュニティと照合します。

match ip address

標準アクセス リストまたは拡張アクセス リストで宛先ネットワーク番号のアドレスが許可されているルートを配布し、パケットのポリシー ルーティングを行います。

match ip next-hop

指定アクセス リストの 1 つとネクストホップ ルータ アドレスが一致したルートを再配布します。

match ip route-source

アクセス リストで指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric

指定メトリックのルートを再配布します。

match tag

指定タグと一致するルーティング テーブル内のルートを再配布します。

route-map(IP)

1 つのルーティング プロトコルから別のルーティング プロトコルへのルート再配布の条件を定義するか、またはポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ アトリビュートを設定します。

set level

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクストホップのアドレスを指定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング テーブルの BGP 重み値を指定します。

max-lsp-lifetime

Link-State Packet(LSP; リンクステート パケット)がリフレッシュされずに維持される最大時間を設定するには、 max-lsp-lifetime コンフィギュレーション モード コマンドを使用します。デフォルトの時間に戻すには、このコマンドの no 形式を使用します。

max-lsp-lifetime value

no max-lsp-lifetime

 
シンタックスの説明

value

(任意)最大 LSP ライフタイム(秒)。範囲:1 ~ 65535。デフォルト: 1200

 
コマンドのデフォルト設定

デフォルトは 1200 秒です。

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

LSP の最大ライフタイムは、LSP のリフレッシュ間隔よりも大きな値にする必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

 
コマンドのデフォルト設定

LSP の最大維持時間を 11,000 秒(3 時間以上)に設定する例を示します。

switch(config)# router isis

switch(config-router)# max-lsp-lifetime 11000

 
関連コマンド

コマンド
説明

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータの IS-IS をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

max-metric router-lsa(OSPF)

最大メトリックのアドバタイズによって、他のルータがそのルータを Shortest Path First(SPF; 最短パス優先)計算の中間ホップとして優先的に使用しないように Open Shortest Path First(OSPF)プロトコルを設定するには、 max-metric router-lsa コマンドを使用します。最大メトリックのアドバタイズをディセーブルにするには、このコマンドの no 形式を使用します。

max-metric router-lsa [ on-startup [seconds | wait-for bgp tag ]]

no max-metric router-lsa [ on-startup [seconds | wait-for bgp tag ]]

 
シンタックスの説明

on-startup

(任意)起動時にルータが最大メトリックをアドバタイズするように設定します。

seconds

(任意)指定の時間間隔でアドバタイズされる最大メトリック(秒)。設定範囲は 5 ~ 86400 秒です。デフォルトは 600 秒です。

wait-for bgp tag

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ルーティング テーブルがコンバージするまで、またはデフォルト タイマーが切れるまで、最大メトリックをアドバタイズします。デフォルト タイマーは 600 秒です。

 
デフォルト

通常のリンク メトリックでルータの Link-State Advertisement(LSA; リンクステート アドバタイズメント)を開始します。

 
コマンド モード

ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

max-metric router-lsa コマンドを使用すると、非スタブリンク全体に最大メトリック(LSInfinity:0xFFFF)の LSA が開始されます。これによって、トラフィックの中継に使用されることなく、BGP ルーティング テーブルのコンバージが可能です(そのルータへのより低コストの代替パスがない場合)。設定されたタイマーまたはデフォルト タイマーの満了後、あるいは BGB によってルーティング テーブルのコンバージェンス終了が通知されたあとは、ルータは正確な(通常の)メトリックをアドバタイズします。


) スタブ リンクのコストは常に出力インターフェイス コストに設定されているので、最大または無限のメトリックを設定しても、スタブ ネットワーク内の直接接続リンクには影響しません。


max-metric router-lsa コマンドは次の場合に使用できます。

ルータのリロード時。ルータのリロード後、Interioir Gateway Protocol(IGP)はすぐにコンバージするので、他のルータは新しくリロードされたルータを通じてトラフィックを転送しようとする可能性があります。そのルータがまだ BGP ルーティング テーブルを確立中の場合、そのルータが BGP を通じて学習していない他のネットワークを宛先とするパケットは廃棄されます。

ルータをネットワークに導入するが、そのルータがトラフィックを中継しないようにする場合。OSPF ネットワークにルータを接続したいが、他にも良い代替パスがある場合は、そのルータを通じて実際のトラフィックを転送したくない場合もあります。代替パスがない場合は、このルータがトラフィックの中継を受け入れます。

ネットワークからルータを正常に取り外す場合。この機能を使用して、すべてのリンクに最大メトリックをアドバタイズすると、ルータのシャットダウン前に他のルータはトラフィック伝送に代替パスを選択できるようになるため、ルータを正常終了させて取り外すことができます。


) ルータにグレースフル シャットダウンが設定されている場合は実行コンフィギュレーションを保存しないでください。保存すると、リロード後にもルータは最大メトリックのアドバタイズを続行します。


このコマンドには、Enterprise Services ライセンスが必要です。

100 秒の最大メトリックをアドバタイズするように OSPF 実行ルータを設定する例を示します。

switch(config)# router ospf 100
switch(config-router)# max-metric router-lsa on-startup 100
 

次の例では、ルータは、BGP ルーティング テーブルがコンバージするまで、またはデフォルト タイマーが満了する(600 秒)まで、最大メトリックをアドバタイズします。

switch(config)# router ospf 100
switch(config-router)# max-metric router-lsa on-startup wait-for bgp bgpTag

 
関連コマンド

コマンド
説明

show ip ospf

OSPF ルーティング プロセスについての全般的な情報を表示します。

maximum-paths(BGP)

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)がサポートするパラレル ルートの最大数を制御するには、 maximum-paths コンフィギュレーション モード コマンドを使用します。デフォルトのパラレル ルート数に戻すには、このコマンドの no 形式を使用します。

maximum-paths [ ibgp ] number-paths

no maximum-paths [ ibgp ] number-paths

 
シンタックスの説明

ibgp

interior BGP(iBGP)パスの最大数を設定します。

number-paths

IP ルーティング プロトコルがルーティング テーブルにインストールするパラレル ルートの最大数。範囲は 1 ~ 16 です。

 
コマンドのデフォルト設定

8 パス

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには使用上のガイドラインはありません。

BGP ルーティング プロセスで、1 つの宛先に最大 16 のパスを許容する例を示します。

switch(config)# router bgp 33
switch(config-router)# maximum-paths 16

 
関連コマンド

コマンド
説明

feature bgp

ルータの BGP 機能をイネーブルにします。

router bgp

BGP をイネーブルにします。

maximum-paths(IS-IS)

IP ルーティング プロトコルがサポートするパラレル ルートの最大数を制御するには、 maximum-
paths
コンフィギュレーション モード コマンドを使用します。デフォルトのパラレル ルート数に戻すには、このコマンドの no 形式を使用します。

maximum-paths number-paths

no maximum-paths

 
シンタックスの説明

number-paths

IP ルーティング プロトコルがルーティング テーブルにインストールするパラレル ルートの最大数。範囲は 1 ~ 16 です。

 
コマンドのデフォルト設定

8 パス

 
コマンド モード

ルータ コンフィギュレーション
VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドには使用上のガイドラインはありません。

IS-IS ルーティング プロセスで、1 つの宛先に最大 16 のパスを許容する例を示します。

switch(config)# router isis 3
switch(config-router)# maximum-paths 16

 
関連コマンド

コマンド
説明

exit

現在のコンフィギュレーション モードを終了します。

feature isis

ルータの IS-IS をイネーブルにします。

no

コマンドを無効にするか、またはデフォルト設定にします。

router isis

IS-IS をイネーブルにします。

maximum-paths(RIP)

Routing Information Protocol(RIP)がルーティング テーブルにインストールする等価コスト パラレル ルートの最大数を設定するには、ルータ アドレスファミリ コンフィギュレーション モードで、 maximum-paths コマンドを使用します。 maximum-paths コマンドを削除し、RIP に関してシステムをデフォルトの条件に戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum-paths

 
シンタックスの説明

maximum

RP がルーティング テーブル内にインストールできるパラレル ルートの最大数。範囲は 1 ~ 16 です。

 
デフォルト

8 パス

 
コマンド モード

ルータ アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドにはライセンスは必要ありません。

次の例では、1 つの宛先に最大 16 の等コスト パスが許可されます。

switch(config)# router rip Enterprise
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# maximum-paths 16

 
関連コマンド

コマンド
説明

address-family

アドレスファミリ コンフィギュレーション モードを開始します。

maximum-paths(EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)がサポートするパラレル ルータの最大数を制御するには、 maximum-paths コマンドを使用します。コンフィギュレーション ファイルから maximum-paths コマンドを削除し、デフォルトに戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum- paths

 
シンタックスの説明

maximum

EIGRP がルーティング テーブル内にインストールできるパラレル ルートの最大数。範囲は 1 ~ 16 ルートです。

 
デフォルト

8 パス

 
コマンド モード

アドレスファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

4.0(2)

デフォルトの最大パスが 16 から 8 に変更されました。

 
使用上のガイドライン

EIGRP がルーティング テーブルに各プレフィクスに対して複数のパスをインストールできるようにするには、 maximum-paths コマンドを使用します。内部ルートと外部ルートの両方について、同じ自律システムで学習され、等コスト(EIGRP 最適パス アルゴリズムに基づいて)である複数のパスがインストールされます。

このコマンドには、Enterprise Services ライセンスが必要です。

次の例では、1 つの宛先に最大 10 のパスが許可されます。

switch(config)# router eigrp 1
switch(config-router)# maximum-paths 10

maximum-paths(OSPF)

Open Shortest Path First(OSPF)がサポートするパラレル ルートの最大数を制御するには、 maximum-paths コマンドを使用します。コンフィギュレーション ファイルから maximum-paths コマンドを削除し、デフォルトに戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum- paths

 
シンタックスの説明

maximum

OSPF がルーティング テーブル内にインストールできるパラレル ルートの最大数。範囲は 1 ~ 16 ルートです。

 
デフォルト

8 パス

 
コマンド モード

ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

OSPF がルーティング テーブルに各プレフィクスに対して複数のパスをインストールできるようにするには、 maximum-paths コマンドを使用します。内部ルートと外部ルートの両方について、同じ自律システムで学習され、等コスト(OSPF 最短パス優先アルゴリズムに基づいて)である複数のパスがインストールされます。

このコマンドには、Enterprise Services ライセンスが必要です。

次の例では、1 つの宛先に最大 10 のパスが許可されます。

switch(config)# router ospf 1
switch(config-router)# maximum-paths 10

maximum-paths(OSPFv3)

Open Shortest Path First version 3(OSPFv3)がサポートするパラレル ルートの最大数を制御するには、 maximum-paths コマンドを使用します。コンフィギュレーション ファイルから maximum-paths コマンドを削除し、デフォルトに戻すには、このコマンドの no 形式を使用します。

maximum-paths maximum

no maximum- paths

 
シンタックスの説明

maximum

OSPFv3 がルーティング テーブル内にインストールできるパラレル ルートの最大数。範囲は 1 ~ 16 ルートです。

 
デフォルト

8 パス

 
コマンド モード

アドレスファミリ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

OSPF がルーティング テーブルに各プレフィクスに対して複数のパスをインストールできるようにするには、 maximum-paths コマンドを使用します。内部ルートと外部ルートの両方について、同じ自律システムで学習され、等コスト(OSPFv3 最短パス優先アルゴリズムに基づいて)である複数のパスがインストールされます。

このコマンドには、Enterprise Services ライセンスが必要です。

次の例では、1 つの宛先に最大 10 のパスが許可されます。

switch(config)# router ospfv3 1
switch(config-router)# address-family ipv6 unicast
switch(config-router-af)# maximum-paths 10

maximum-prefix

ネイバーから受信可能なプレフィクスの数を設定するには、ピア テンプレート コンフィギュレーション モードで、 maximum-prefix コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

maximum-prefix maximum [ threshold ] [ restart restart-interval ] [ warning-only ]

no maximum-prefix

 
シンタックスの説明

maximum

指定ネイバーから受信できるプレフィクスの最大数。設定可能なプレフィクス数は、ルータ上の使用可能なシステム リソースのみによって制限されます。範囲:1 ~ 300000

threshold

(任意)最大プレフィクス数の制限値の何パーセントになったらルータが警告メッセージを生成するかを示すパーセンテージ。範囲:1 ~ 100。デフォルト: 75

restart interval

(任意)ピアリング セッションが再確立される時間間隔(分)。範囲:1 ~ 65535

warning-only

(任意)最大プレフィクス数の制限値を超えた場合、ピアリング セッションを終了せずに、ルータが syslog メッセージを生成できるようにします。

 
コマンドのデフォルト設定

デフォルトでは、このコマンドはディセーブルです。プレフィクスの最大数を超えると、ピアリング セッションはディセーブルになります。再起動間隔(restart interval)を設定しないと、 最大プレフィクスの制限値超過後、ディセーブルになったセッションはダウン状態のままになります。

 
コマンド モード

ピア テンプレート コンフィギュレーション
ルータ BGP コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

設定可能なプレフィクス数は、ルータ上の使用可能なシステム リソースのみによって制限されます。

maximum-prefix コマンドを使用すると、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ルーティング プロセスが指定ピアから受け入れるプレフィクスの最大数を設定できます。この機能は、ピアから受信されるプレフィクスの制御メカニズムを提供します(配布リスト、フィルタ リスト、ルート マップに加えて)。

受信プレフィクスの数が設定されている最大数を超えると、BGP はピアリング セッションをディセーブルにします(デフォルト)。 restart キーワードが設定されている場合、BGP は設定されている時間間隔でピアリング セッションを自動的に再確立します。 restart キーワードが設定されていないと、最大プレフィクス数の制限値を超えたためにピアリング セッションが終了した場合、そのピアリング セッションは clear ip bgp コマンドが入力されるまで再確立されません。 warning-only キーワードが設定されていれば、BGP はログ メッセージだけを送信し、送信側とピアを保ちます。

このコマンドで設定できるプレフィクス数には、デフォルトの制限値はありません。設定可能なプレフィクス数の制限は、システム リソースの容量によって決まります。

192.168.1.1 ネイバーから受け入れる最大プレフィクス数を 1000 に設定する例を示します。

switch(config)# router bgp 40000
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 1000
 

次の例では、192.168.2.2 ネイバーから受け入れるプレフィクスの最大数が 5000 に設定されます。さらに、このルータは、最大プレフィクス数の制限の 50 %(2500 プレフィクス)に到達すると、警告メッセージを表示するように設定されます。

switch(config)# router bgp 40000
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 5000 50

 

次の例では、192.168.3.3 ネイバーから受け入れるプレフィクスの最大数が 2000 に設定されます。さらに、このルータは、ディセーブルになったピアリング セッションを 30 秒後に再確立するように設定します。

switch(config)# router bgp 40000
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 2000 restart 30
 

次の例では、192.168.4.4 ネイバーの最大プレフィクス数の制限値(500)を超えると警告メッセージが表示されます。

switch(config)# router bgp 40000
switch(config-router)# network 192.168.0.0
switch(config-router)# maximum-prefix 500 warning-only

message-digest-key(OSPF virtual link)

仮想リンクの Open Shortest Path First(OSPF)Message Digest 5(MD5)認証をイネーブルにするには、 message-digest-key コマンドを使用します。以前の MD5 キーを削除するには、このコマンドの no 形式を使用します。

message-digest-key key-id md5 [0 | 3] key

no message-digest-key key-id

 
シンタックスの説明

key-id

1 ~ 255 の範囲の識別子

0

MD5 キーを生成するための非暗号化パスワードの使用を指定します。

3

MD5 キーを生成するための暗号化 3DES パスワードの使用を指定します。

key

最大 16 バイトの英数字パスワード

 
デフォルト

非暗号化

 
コマンド モード

仮想リンク コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

MD5 認証モードを設定する場合は message-digest-key コマンドを使用します。仮想リンク上の両方のインターフェイスで key 値を同じにする必要があります。

このコマンドには、Enterprise Services ライセンスが必要です。

キー 19、パスワード 8ry4222 を設定する例を示します。

switch(config-router)# area 22 virtual-link 192.0.2.2
switch(config-router-vlink)# message-digest-key 19 md5 8ry4222

 
関連コマンド

コマンド
説明

authentication(virtual-link)

仮想リンク上に認証モードを設定します。

policy statistics enable(OSPF)

Open Shortest Path First(OSPF)ポリシー統計をイネーブルにするには、 policy statistics enable コマンドを使用します。ポリシー統計をディセーブルにするには、このコマンドの no 形式を使用します。

policy statistics enable

no policy statistics enable

 
シンタックスの説明

このコマンドには、引数またはキーワードはありません。

 
デフォルト

ポリシー統計はディセーブルです。

 
コマンド モード

ルータ コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

この OSPF インスタンスに適用されるルート ポリシーに基づいた統計情報の収集をイネーブルにするには、 policy statistics enable コマンドを使用します。

このコマンドには、Enterprise Services ライセンスが必要です。

OSPF 2 でポリシー統計の収集をイネーブルにする例を示します。

switch(config)# ospf 2
switch(config-router)# policy statistics enable

 
関連コマンド

コマンド
説明

show ip ospf policy statistics

ポリシー統計を表示します。

metric maximum-hops

指定した値よりも高いホップ カウントの Enhanced Interior Gateway Routing Protocol(EIGRP)が到達不能であることをアドバタイズするには、 metric maximum-hops コマンドを使用します。値を デフォルトにリセットするには、このコマンドの no 形式を使用します。

metric maximum-hops hops-number

no metric maximum-hops

 
シンタックスの説明

hops-number

最大ホップ カウント。範囲は 1 ~ 255 ホップです。

 
デフォルト

hops-number :100

 
コマンド モード

アドレスファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

metric maximum-hops コマンドは、 hops-number 引数に指定された値よりも大きいホップ カウントのルートを到達不能として EIGRP にアドバタイズさせる安全メカニズムを提供します。

このコマンドには、Enterprise Services ライセンスが必要です。

ホップ カウントを 200 に設定する例を示します。

switch(config)# router eigrp 1
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# metric maximum-hops 200

 
関連コマンド

コマンド
説明

metric weights

EIGRP メトリック計算を調整します。

metric weights

Enhanced Interior Gateway Routing Protocol(EIGRP)メトリック計算を調整するには、 metric weights コマンドを使用します。デフォルト値にリセットするには、このコマンドの no 形式を使用します。

metric weights tos k1 k2 k3 k4 k5

no metric weights

 
シンタックスの説明

tos

常にゼロにする必要のある Type of service(ToS; タイプ オブ サービス)

k1 k2 k3 k4 k5

EIGRP メトリック ベクトルをスカラー量に変換する定数。この引数の値は次のとおりです。

k1 ― 範囲は 0 ~ 255、デフォルト値は 1 です。

k2 ― 範囲は 0 ~ 255、デフォルト値は 0 です。

k3 ― 範囲は 0 ~ 255、デフォルト値は 1 です。

k4 ― 範囲は 0 ~ 255、デフォルト値は 0 です。

k5 ― 範囲は 0 ~ 255、デフォルト値は 0 です。

 
デフォルト

tos :0

k1 :1

k2 :0

k3 :1

k4 :0

k5 :0

 
コマンド モード

アドレスファミリ コンフィギュレーション
ルータ コンフィギュレーション
ルータ VRF コンフィギュレーション

サポートされるユーザ ロール

ネットワーク管理者
VDC 管理者

 
コマンド履歴

リリース
変更内容

4.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

EIGRP のルーティングおよびメトリック計算のデフォルト動作を変更し、特定の ToS の EIGRP メトリック計算の調整を可能にするには、 metric weights コマンドを使用します。

k5 が 0 の場合、Cisco NX-OS は複合 EIGRP メトリックの計算を次の式に従って行います。

メトリック = [k1 ×帯域幅 +(k2 ×帯域幅)/(256 - 負荷)+ k3 ×遅延]

k5 が 0 でない場合、Cisco NX-OS は次の計算を追加します。

メトリック = メトリック× [k5/(信頼性 + k4)]

帯域幅メトリックの設定には、インターフェイス コンフィギュレーション モードで bandwidth コマンドを使用します。

遅延の設定には、インターフェイス コンフィギュレーション モードで delay コマンドを使用します。

255 は 100 %の信頼性または完全に安定したリンクを表します。負荷 255 は、完全に飽和状態のリンクを表します。

このコマンドには、Enterprise Services ライセンスが必要です。

metric weights のデフォルト値の変更例を示します。

switch(config)# router eigrp 1
switch(config-router) address-family ipv4 unicast
switch(config-router-af)# metric weights 0 2 0 2 0 0

 
関連コマンド

コマンド
説明

bandwidth

インターフェイス コンフィギュレーション モードで EIGRP 帯域幅メトリックを設定します。

delay

インターフェイス コンフィギュレーション モードで EIGRP 遅延メトリックを設定します。