Cisco Nexus 7000 シリーズ NX-OS インターフェイス コンフィギュレーション ガイド
レイヤ 3 インターフェイスの設定
レイヤ 3 インターフェイスの設定

目次

レイヤ 3 インターフェイスの設定

機能情報の確認

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、https:/​/​tools.cisco.com/​bugsearch/​ の Bug Search Tool およびご使用のソフトウェア リリースのリリース ノートを参照してください。 このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「新規および変更された情報(New and Changed Information)」の章または以下の「機能の履歴」表を参照してください。

レイヤ 3 インターフェイスについて

レイヤ 3 インターフェイスは、IPv4 および IPv6 パケットをスタティックまたはダイナミック ルーティング プロトコルを使って別のデバイスに転送します。 レイヤ 2 トラフィックの IP ルーティングおよび内部 Virtual Local Area Network(VLAN)ルーティングにはレイヤ 3 インターフェイスが使用できます。

共有インターフェイスをレイヤ 3 インターフェイスとして設定することはできません。 共有インターフェイスについては、『Cisco NX-OS FCoE Configuration Guide for Cisco Nexus 7000 and Cisco MDS 9500』を参照してください。

Cisco NX-OS リリース 6.2(2) 以降のリリースでは、Cisco ファブリック エクステンダがキュー マッピングへのホスト インターフェイス(HIF)および DSCP 上のレイヤ 3 プロトコル隣接関係をサポートします。 Cisco リリース 6.2(2) より前は、ファブリック エクステンダ(FEX)ポートをホスト接続のためのレイヤ 3 インターフェイスとして設定できますが、ルーティング用には設定できません。 ファブリック エクステンダの詳細については、『Configuring the Cisco Nexus 2000 Series Fabric Extender』を参照してください。 ファブリック エクステンダの詳細については、『Configuring the Cisco Nexus 2000 Series Fabric Extender』を参照してください。

ルーテッド インターフェイス

ポートをレイヤ 2 インターフェイスまたはレイヤ 3 インターフェイスとして設定できます。 ルーテッド インターフェイスは、IP トラフィックを他のデバイスにルーティングできる物理ポートです。 ルーテッド インターフェイスはレイヤ 3 インターフェイスだけで、スパニングツリー プロトコル(STP)などのレイヤ 2 プロトコルはサポートしません。

すべてのイーサネット ポートは、デフォルトでルーテッド インターフェイスです。 このデフォルト動作を変更するには、CLI セットアップ スクリプトまたは system default switchport コマンドを使用します。

ポートに IP アドレスを割り当て、ルーティングをイネーブルにし、このルーテッド インターフェイスにルーティング プロトコル特性を割り当てることができます。

Cisco リリース 4.2(1) からスタティック Media Access Control(MAC)アドレスをレイヤ 3 インターフェイスに割り当てられます。 デフォルトでは、レイヤ 3 インターフェイスの MAC アドレスは、割り当て先の仮想デバイス コンテキスト(VDC)の MAC アドレスです。 MAC アドレスの設定については、『Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide』を参照してください。

ルーテッド インターフェイスからレイヤ 3 ポート チャネルも作成できます。 ポート チャネルの詳細については、「ポート チャネルの設定」を参照してください。

ルーテッド インターフェイスおよびサブインターフェイスは、指数関数的に減少するレート カウンタをサポートします。 Cisco NX-OS はこれらの平均カウンタを用いて次の統計情報を追跡します。

  • 入力パケット数/秒

  • 出力パケット数/秒

  • 入力バイト数/秒

  • 出力バイト数/秒

サブインターフェイス

レイヤ 3 インターフェイスとして設定した親インターフェイスに仮想サブインターフェイスを作成できます。 親インターフェイスは物理ポートでもポート チャネルでもかまいません。

親インターフェイスはサブインターフェイスによって複数の仮想インターフェイスに分割されます。これらの仮想インターフェイスに IP アドレスやダイナミック ルーティング プロトコルなど固有のレイヤ 3 パラメータを割り当てることができます。 各サブインターフェイスの IP アドレスは、親インターフェイスの他のサブインターフェイスのサブネットとは異なります。

サブインターフェイスの名前は、親インターフェイスの名前(たとえば Ethernet 2/1)+ ピリオド(.)+そのインターフェイス独自の番号です。 たとえば、イーサネット インターフェイス 2/1 に Ethernet 2/1.1 というサブインターフェイスを作成できます。この場合、.1 はそのサブインターフェイスを表します。

Cisco NX-OS では、親インターフェイスがイネーブルの場合にサブインターフェイスがイネーブルになります。 サブインターフェイスは、親インターフェイスには関係なくシャットダウンできます。 親インターフェイスをシャットダウンすると、関連するサブインターフェイスもすべてシャットダウンされます。

サブインターフェイスを使用すると、親インターフェイスがサポートするそれぞれの仮想ローカル エリア ネットワーク(VLAN)に独自のレイヤ 3 インターフェイスを実現できます。 この場合、親インターフェイスは別のデバイスのレイヤ 2 トランキング ポートに接続します。 サブインターフェイスを設定したら 802.1Q トランキングを使って VLAN ID に関連付けます。

以下の図は、インターフェイス E 2/1 のルータ B に接続するスイッチのトランク ポートを示しています。 このインターフェイスには 3 つのサブインターフェイスがあり、トランキング ポートに接続する 3 つの VLAN にそれぞれ関連付けられています。

図 1. VLAN のサブインターフェイス



VLAN の詳細については、『Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide』を参照してください。

VLAN インターフェイス

VLAN インターフェイスまたはスイッチ仮想インターフェイス(SVI)は、デバイス上の VLAN を同じデバイス上のレイヤ 3 ルータ エンジンに接続する仮想ルーテッド インターフェイスです。 VLAN には 1 つの VLAN インターフェイスだけを関連付けることができますが、VLAN に VLAN インターフェイスを設定する必要があるのは、VLAN 間でルーティングする場合か、または管理 VRF(仮想ルーティング/転送)以外の VRF インスタンスを経由してデバイスを IP ホスト接続する場合だけです。 VLAN インターフェイスの作成をイネーブルにすると、Cisco NX-OS によってデフォルト VLAN(VLAN 1)に VLAN インターフェイスが作成され、リモート スイッチ管理が許可されます。

設定の前に VLAN ネットワーク インターフェイス機能をイネーブルにする必要があります。 Cisco NX-OS リリース 4.2 から、システムは機能のディセーブル化の前に自動的にチェックポイントを作成するため、このチェックポイントにロールバックできます。 ロールバックおよびチェックポイントについては、『Cisco Nexus 7000 Series NX-OS System Management Configuration Guide』を参照してください。

VLAN と同じ VDC に VLAN ネットワーク インターフェイスを設定する必要があります。


(注)  


VLAN 1 の VLAN インターフェイスは削除できません。


VLAN インターフェイスをルーティングするには、トラフィックをルーティングする VLAN ごとに VLAN インターフェイスを作成し、その VLAN インターフェイスに IP アドレスを割り当ててレイヤ 3 内部 VLAN ルーティングを実現します。 IP アドレスおよび IP ルーティングの詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

以下の図は、デバイス上の 2 つの VLAN に接続されている 2 つのホストを示しています。 VLAN ごとに VLAN インターフェイスを設定し、VLAN 間の IP ルーティングを使ってホスト 1 とホスト 2 を通信させることができます。 VLAN 1 は VLAN インターフェイス 1 のレイヤ 3 で、VLAN 10 は VLAN インターフェイス 10 のレイヤ 3 で通信します。

図 2. VLAN インターフェイスに接続した 2 つの VLAN




(注)  


シャーシ内に F1 シリーズ モジュールがある Cisco Nexus 7000 シリーズ デバイスでインバンド管理のための VLAN インターフェイスを設定できます。


ループバック インターフェイス

ループバック インターフェイスは、常にアップ状態にある単独のエンドポイントを持つ仮想インターフェイスです。 ループバック インターフェイスを通過するパケットはこのインターフェイスでただちに受信されます。 ループバック インターフェイスは物理インターフェイスをエミュレートします。 VDC ごとに最大 1024 のループバック インターフェイスが設定できます。VDC には 0 ~ 1023 の番号が付いています。

ループバック インターフェイスを使用すると、パフォーマンスの分析、テスト、ローカル通信が実行できます。 ループバック インターフェイスは、ルーティング プロトコル セッションの終端アドレスとして設定することができます。 ループバックをこのように設定すると、アウトバウンド インターフェイスの一部がダウンしている場合でもルーティング プロトコル セッションはアップしたままです。

トンネル インターフェイス

Cisco NX-OS は、IP トンネルとしてトンネル インターフェイスをサポートします。 IP トンネルを使うと、同じレイヤまたは上位層プロトコルをカプセル化して、2 台のルータ間で作成されたトンネルを通じて IP の結果を転送できます。 IP トンネルの詳細については、「IP トンネルの設定」を参照してください。

レイヤ 3 インターフェイスのハイ アベイラビリティ

レイヤ 3 インターフェイスは、ステートフル再起動とステートレス再起動をサポートします。 切り替え後、Cisco NX-OS は実行時の設定を適用します。

ハイ アベイラビリティの詳細については、『Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide』を参照してください。

レイヤ 3 インターフェイスの仮想化サポート

レイヤ 3 インターフェイスは、仮想ルーティング/転送(VRF)インスタンスをサポートします。 VRF は仮想化デバイス コンテキスト(VDC)内にあります。 特に別の VDC や VRF を設定しない限り、デフォルトでは、Cisco NX-OS のデフォルトの VDC およびデフォルトの VRF が使用されます。 ある VDC に設定されたレイヤ 3 論理インターフェイス(VLAN インターフェイス、ループバック)は、同じ番号を持つ別の VDC に設定されたレイヤ 3 論理インターフェイスとは区別されます。 たとえば、VDC 1 のループバック 0 は VDC 2 のループバック 0 とは異なります。

VDC ごとに最大 1024 のループバック インターフェイスを設定できます。

このインターフェイスは VRF に関連付けることができます。 VLAN インターフェイスの場合、VLAN と同じ VDC に設定する必要があります。

VDC については、『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide』を、VRF でのインターフェイスの設定については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。


(注)  


そのインターフェイスに IP アドレスを設定する前に、インターフェイスを VRF に割り当てる必要があります。


インターフェイスのライセンス要件

IP トンネルおよび vPC には Enterprise Services ライセンスが必要です。 このライセンスは IP トンネルをイネーブルにするシステムごとにインストールする必要があります。

他のインターフェイスにはライセンスが必要ありません。

ライセンス 3 インターフェイスの前提条件

ライセンス 3 インターフェイスには次の前提条件があります。
  • VDC を設定する場合は、アドバンスド サービス ライセンスをインストールし、目的の VDC を入力している(『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide』を参照)。

  • IP アドレッシングおよび基本設定を熟知している。 IP アドレッシングについては、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

注意事項と制約事項

レイヤ 3 インターフェイスの設定には次の注意事項と制約事項があります。

  • レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変更する場合、Cisco NX-OS はインターフェイスをシャットダウンしてインターフェイスを再度イネーブルにし、レイヤ 3 固有の設定をすべて削除します。

  • レイヤ 2 インターフェイスをレイヤ 3 インターフェイスに変更する場合、Cisco NX-OS はインターフェイスをシャットダウンしてインターフェイスを再度イネーブルにし、レイヤ 2 固有の設定をすべて削除します。

  • Cisco Nexus 2000 ファブリック エクステンダは、デバイスがそのポートに接続されている場合、ルーティング プロトコルの隣接関係に参加できません。 スタティックな直接ルートだけがサポートされます。 この制限事項は、次のサポートされる接続例両方に適用されます。

    • レイヤ 2 モードのファブリック エクステンダ単一ポートまたはポート チャネルを有する SVI。

    • レイヤ 3 モードのファブリック エクステンダ ポートまたはポート チャネル。

  • レイヤ 3 ルータ インターフェイスおよびサブインターフェイスは、F1 I/O モジュールでは設定できません。

  • F2 シリーズ I/O モジュールは VLAN 単位の統計情報はサポートしません。 したがって、show interface コマンドは、スイッチ仮想インターフェイス(SVI)の VLAN 単位の Rx/Tx カウンタまたは統計情報を表示しません。


(注)  


Cisco IOS の CLI に慣れている場合、この機能に対応する Cisco NX-OS コマンドは通常使用する Cisco IOS コマンドと異なる場合があるので注意してください。


レイヤ 3 インターフェイスのデフォルト設定

表 1 レイヤ 3 インターフェイスのデフォルト パラメータ

パラメータ(Parameters)

デフォルト

管理状態

閉じる

レイヤ 3 インターフェイスの設定

ルーテッド インターフェイスの設定

任意のイーサネット ポートをルーテッド インターフェイスとして設定できます。

はじめる前に

正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

手順
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal  

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2switch(config)# interface ethernet slot/port  

    インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 3switch(config-if)# no switchport  

    インターフェイスをレイヤ 3 インターフェイスとして設定し、このインターフェイス上のレイヤ 2 に固有の設定をすべて削除します。

     
    ステップ 4switch(config-if)# ip address ip-address/length
    オプション 説明
    ipv6 address ipv6-address/length

    このインターフェイスの IPv6 アドレスを設定します。

     

    このインターフェイスの IP アドレスを設定します。 IP アドレスおよび IPv6 アドレスの詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

     
    ステップ 5switch(config-if)# show interfaces   (任意)

    レイヤ 3 インターフェイスの統計情報を表示します。

     
    ステップ 6switch# show interface status error policy [detail]   (任意)

    ポリシー プログラミング中にエラーを生成するインターフェイスおよび VLAN が表示され、ポリシーがハードウェア ポリシーと一致することを確認できます。

    エラーを生成するインターフェイスの詳細を表示するには、detail コマンドを使用します。

     
    ステップ 7switch# no shutdown   (任意)

    ポリシーがハードウェア ポリシーと一致するインターフェイスおよび VLAN のエラーをクリアします。 このコマンドにより、ポリシー プログラミングが続行でき、ポートがアップできます。 ポリシーが対応していない場合は、エラーは error-disabled ポリシー状態になります。

     
    ステップ 8switch(config)# copy running-config startup-config   (任意)

    実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

     

    インターフェイス メディアをポイント ツー ポイントまたはブロードキャストのどちらかとして設定するには、medium コマンドを使用します。

    コマンド

    目的

    medium {broadcast | p2p}

    インターフェイス メディアをポイント ツー ポイントまたはブロードキャストのどちらかとして設定します。

    デフォルト設定は broadcast であり、この設定はどの show コマンドにも表示されません。 ただし、p2p に設定を変更した場合、show running-config コマンドを入力すると、この設定が表示されます。

    レイヤ 3 インターフェイスをレイヤ 2 インターフェイスに変換するには、switchport コマンドを使用します。

    コマンド

    目的

    switchport

    インターフェイスをレイヤ 2 インターフェイスとして設定し、このインターフェイス上のレイヤ 3 固有の設定を削除します。

    次に、ルーテッド インターフェイスを設定する例を示します。
    switch# configure terminal
    switch(config)# interface ethernet 2/1
    switch(config-if)# no switchport
    switch(config-if)# ip address 192.0.2.1/8
    switch(config-if)# copy running-config startup-config

    インターフェイスのデフォルト設定がルーテッドされます。 レイヤ 2 にインターフェイスを設定するには、switchport コマンドを入力します。 レイヤ 2 インターフェイスをルーテッド インターフェイスに変更する場合は、no switchport コマンドを入力します。

    サブインターフェイスの設定

    ルーテッド インターフェイスまたはルーテッド インターフェイスで作成したポート チャネルに 1 つまたは複数のサブインターフェイスを設定できます。

    はじめる前に

    親インターフェイスをルーテッド インターフェイスとして設定します。

    「ルーテッド インターフェイスの設定」の項を参照してください。

    このポート チャネル上にサブインターフェイスを作成するには、ポート チャネル インターフェイスを作成します。

    正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

    手順
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal  

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2switch(config)# interface ethernet slot/port  

      インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 3switch(config-if)# ip address ip-address/length
      オプション 説明
      ipv6 address ipv6-address/length

      このインターフェイスの IPv6 アドレスを設定します。

       

      このインターフェイスの IP アドレスを設定します。 IP アドレスおよび IPv6 アドレスの詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

       
      ステップ 4switch(config-if)# encapsulation dot1q vlan-id  

      サブインターフェイス上の IEEE 802.1Q VLAN カプセル化を設定します。 範囲は 2 ~ 4093 です。

       
      ステップ 5switch(config-if)# show interfaces   (任意)

      レイヤ 3 インターフェイスの統計情報を表示します。

       
      ステップ 6switch(config)# copy running-config startup-config   (任意)

      実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

       
      次に、サブインターフェイスを作成する例を示します。
      switch# configure terminal
      switch(config)# interface ethernet 2/1.1
      switch(config-if)# ip address 192.0.2.1/8
      switch(config-if)# encapsulation dot1Q 33
      switch(config-if)# copy running-config startup-config
      Cisco NX-OS リリース 6.1 以降では、show interface eth コマンドの出力が、次の例に示すように、サブインターフェイスに対し拡張されます。
      switch# show interface ethernet 1/2.1
      Ethernet1/2.1 is down (Parent Interface Admin down)
      admin state is down, Dedicated Interface, [parent interface is Ethernet1/2]
      Hardware: 40000 Ethernet, address: 0023.ac67.9bc1 (bia 4055.3926.61d4)
      Internet Address is 10.10.10.1/24
      MTU 1500 bytes, BW 40000000 Kbit, DLY 10 usec
      reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation 802.1Q Virtual LAN, Vlan ID 11, medium is broadcast
      Auto-mdix is turned off
      EtherType is 0x8100
      L3 in Switched:
        ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes
      L3 out Switched:
        ucast: 0 pkts, 0 bytes - mcast: 0 pkts, 0 bytes

      インターフェイスでの帯域幅の設定

      ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅を設定できます。 上位層プロトコルは帯域幅パラメータを使用してパス コストを計算します。 サブインターフェイスの帯域幅は、次のいずれかの方法で設定できます。

      • 明示的:サブインターフェイスの帯域幅を直接設定します。

      • 継承:サブインターフェイスが固有の値として、つまり親インターフェイスの帯域幅を親インターフェイスから継承するように帯域幅を設定します。

      サブインターフェイスの帯域幅を設定しない場合、または親インターフェイスの帯域幅を継承しない場合、サブインターフェイスの帯域幅は次の方法で決定されます。

      • 親インターフェイスがアップしている場合、サブインターフェイスの帯域幅は親インターフェイスの動作速度と同じです。 ポートの場合、サブインターフェイスの帯域幅は設定されているリンク速度またはネゴシエート対象のリンク速度です。 ポート チャネルの場合、サブインターフェイスの帯域幅は、ポート チャネルの各メンバのリンク速度の集合です。

      • 親インターフェイスがダウンしている場合、サブインターフェイスの帯域幅は親インターフェイスのタイプによって異なります。

        • ポート チャネル サブインターフェイスの場合、サブインターフェイスの帯域幅は 100 Mb/s です。

        • 1 Gb/s イーサネット ポートの場合、サブインターフェイスの帯域幅は 1 Gb/s です。

        • 10 Gb/s イーサネット ポートの場合、サブインターフェイスの帯域幅は 10 Gb/s です。

      インターフェイスの帯域幅を設定するには、インターフェイス モードで次のコマンドを使用します。

      コマンド

      目的

      帯域幅

      ルーテッド インターフェイス、ポート チャネル、またはサブインターフェイスに帯域幅パラメータを設定します。

      親インターフェイスから帯域幅を継承するようにサブインターフェイスを設定するには、インターフェイス モードで次のコマンドを使用します。

      コマンド

      目的

      bandwidth inherit [value]

      設定された帯域幅の値を継承するように、このインターフェイスのすべてのサブインターフェイスを設定します。 値を設定しない場合、サブインターフェイスは親インターフェイスの帯域幅を継承します。 指定できる範囲は 1 ~ 10000000(KB 単位)です。

      VLAN インターフェイスの設定

      VLAN インターフェイスを作成して内部 VLAN ルーティングを行うことができます。

      はじめる前に

      正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

      手順
         コマンドまたはアクション目的
        ステップ 1switch# configure terminal  

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2switch(config)#feature interface-vlan  

        VLAN インターフェイス モードをイネーブルにします。

         
        ステップ 3switch(config)# interface vlan number  

        VLAN インターフェイスを作成します。 number の範囲は 1 ~ 4094 です。

         
        ステップ 4switch(config-if)# ip address ip-address/length
        オプション 説明
        ipv6 address ipv6-address/length

        このインターフェイスの IPv6 アドレスを設定します。

         

        このインターフェイスの IP アドレスを設定します。 IP アドレスおよび IPv6 アドレスの詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

         
        ステップ 5switch(config-if)# show interface vlan number   (任意)

        レイヤ 3 インターフェイスの統計情報を表示します。

         
        ステップ 6switch(config-if)# show interface status error policy [detail]   (任意)

        ポリシー プログラミング中にエラーを生成するインターフェイスおよび VLAN が表示され、ポリシーがハードウェア ポリシーと一致することを確認できます。

        エラーを生成するインターフェイスの詳細を表示するには、detail コマンドを使用します。

         
        ステップ 7switch(config-if)# no shutdown   (任意)

        ポリシーがハードウェア ポリシーと一致するインターフェイスおよび VLAN のエラーをクリアします。 このコマンドにより、ポリシー プログラミングが続行でき、ポートがアップできます。 ポリシーが対応していない場合は、エラーは error-disabled ポリシー状態になります。

         
        ステップ 8switch(config-if)# copy running-config startup-config   (任意)

        実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

         
        次に、VLAN インターフェイスを作成する例を示します。
        switch# configure terminal
        switch(config)# feature interface-vlan
        switch(config)# interface vlan 10
        switch(config-if)# ip address 192.0.2.1/8
        switch(config-if)# copy running-config startup-config

        Nexus シャーシでのインバンド管理の設定

        シャーシ内に F1 シリーズ モジュールのみがある場合に、Cisco Nexus 7000 シリーズ デバイスでインバンド管理のための VLAN インターフェイスを設定できます。


        注意    


        F1 シリーズ モジュールのインバンド管理には専用の VLAN を使用することを推奨します。 インバンド管理に使用している VLAN 上でデータ トラフィックを実行しないでください。


        はじめる前に

        正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

        手順
           コマンドまたはアクション目的
          ステップ 1switch# configure terminal  

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2switch(config)#feature interface-vlan  

          VLAN インターフェイス モードをイネーブルにします。

           
          ステップ 3switch(config)# interface vlan number  

          VLAN インターフェイスを作成します。 number の範囲は 1 ~ 4094 です。

           
          ステップ 4switch(config-if)# no shutdown  

          インターフェイスを管理上のアップ状態にします(インターフェイスをイネーブルまたはディセーブルにします)。

           
          ステップ 5switch(config-if)# management  

          VLAN インターフェイスの IP アドレスへのインバンド管理アクセスを許可します。

           
          ステップ 6switch(config-if)# ip address ip-address/length  

          このインターフェイスの IP アドレスを設定します。 IP アドレスの詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

           
          ステップ 7switch(config-if)# show interface vlan number   (任意)

          レイヤ 3 インターフェイスの統計情報を表示します。

           
          ステップ 8switch(config-if)# show interface status error policy [detail]   (任意)

          ポリシー プログラミング中にエラーを生成するインターフェイスおよび VLAN が表示され、ポリシーがハードウェア ポリシーと一致することを確認できます。

          エラーを生成するインターフェイスの詳細を表示するには、detail コマンドを使用します。

           
          ステップ 9switch(config-if)# no shutdown   (任意)

          ポリシーがハードウェア ポリシーと一致するインターフェイスおよび VLAN のエラーをクリアします。 このコマンドにより、ポリシー プログラミングが続行でき、ポートがアップできます。 ポリシーが対応していない場合は、エラーは error-disabled ポリシー状態になります。

           
          ステップ 10switch(config-if)# copy running-config startup-config   (任意)

          実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

           
          次に、Cisco Nexus 7000 シャーシでインバンド管理を作成する例を示します。
          switch# configure terminal
          switch(config)# feature interface-vlan
          switch(config)# interface vlan 5
          switch(config-if)# no shutdown
          switch(config-if)# management
          switch(config-if)# ip address 192.0.2.1/8
          switch(config-if)# copy running-config startup-config

          ループバック インターフェイスの設定

          ループバック インターフェイスを設定して、常にアップ状態にある仮想インターフェイスを作成できます。

          はじめる前に

          ループバック インターフェイスの IP アドレスが、ネットワークの全ルータで一意であることを確認します。

          正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

          手順
             コマンドまたはアクション目的
            ステップ 1switch# configure terminal  

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 2switch(config)# interface loopback instance  

            ループバック インターフェイスを作成します。 指定できる範囲は 0 ~ 1023 です。

             
            ステップ 3switch(config-if)# ip address ip-address/length
            オプション 説明
            ipv6 address ipv6-address/length

            このインターフェイスの IPv6 アドレスを設定します。

             

            このインターフェイスの IP アドレスを設定します。 IP アドレスおよび IPv6 アドレスの詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

             
            ステップ 4switch(config-if)# show interfaces loopback instance  

            ループバック インターフェイスの統計情報を表示します。

             
            ステップ 5switch(config-if)# copy running-config startup-config   (任意)

            実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

             

            次に、ループバック インターフェイスを作成する例を示します。
            switch# configure terminal
            switch(config)# interface loopback 0
            switch(config-if)# ip address 192.0.2.100/8
            switch(config-if)# copy running-config startup-config

            VRF へのインターフェイスの割り当て

            VRF にレイヤ 3 インターフェイスを追加できます。

            はじめる前に

            正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

            VRF 用のインターフェイスを設定した後で、トンネル インターフェイスに IP アドレスを割り当てます。

            手順
               コマンドまたはアクション目的
              ステップ 1switch# configure terminal  

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 2switch(config)# interface interface-type number  

              インターフェイス コンフィギュレーション モードを開始します。

               
              ステップ 3switch(config-if)# vrf member vrf-name  

              このインターフェイスを VRF に追加します。

               
              ステップ 4switch(config-if)# ip address ip-address/length  

              このインターフェイスの IP アドレスを設定します。 IP アドレスの詳細については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

               
              ステップ 5switch(config-if)# show vrf [vrf-name] interface interface-type number   (任意)

              VRF 情報を表示します。

               
              ステップ 6switch(config-if)# copy running-config startup-config   (任意)

              実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

               
              次に、VRF にレイヤ 3 インターフェイスを追加する例を示します。
              switch# configure terminal
              switch(config)# interface loopback 0
              switch(config-if)# vrf member RemoteOfficeVRF
              switch(config-if)# ip address 209.0.2.1/16
              switch(config-if)# copy running-config startup-config

              レイヤ 3 インターフェイス設定の確認

              コマンド

              目的

              show interface ethernet slot/port

              レイヤ 3 インターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

              show interface ethernet slot/port brief

              レイヤ 3 インターフェイスの動作ステータスを表示します。

              show interface ethernet slot/port capabilities

              レイヤ 3 インターフェイスの機能(ポート タイプ、速度、およびデュプレックスを含む)を表示します。

              show interface ethernet slot/port description

              レイヤ 3 インターフェイスの説明を表示します。

              show interface ethernet slot/port status

              レイヤ 3 インターフェイスの管理ステータス、ポート モード、速度、およびデュプレックスを表示します。

              show interface ethernet slot/port.number

              サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

              show interface port-channel channel-id.number

              ポート チャネル サブインターフェイスの設定情報、ステータス、カウンタ(インバウンドおよびアウトバウンド パケット レートおよびバイト レートが 5 分間に指数関数的に減少した平均値を含む)を表示します。

              show interface loopback number

              ループバック インターフェイスの設定情報、ステータス、カウンタを表示します。

              show interface loopback number brief

              ループバック インターフェイスの動作ステータスを表示します。

              show interface loopback number description

              ループバック インターフェイスの説明を表示します。

              show interface loopback number status

              ループバック インターフェイスの管理ステータスおよびプロトコル ステータスを表示します。

              show interface vlan number

              VLAN インターフェイスの設定情報、ステータス、カウンタを表示します。

              show interface vlan number brief

              VLAN インターフェイスの動作ステータスを表示します。

              show interface vlan number description

              VLAN インターフェイスの説明を表示します。

              show interface vlan number private-vlan mapping

              VLAN インターフェイスのプライベート VLAN 情報を表示します。

              show interface vlan number status

              VLAN インターフェイスの管理ステータスおよびプロトコル ステータスを表示します。

              show interface status error policy [detail]

              ハードウェア ポリシーと矛盾するインターフェイスおよび VLAN のエラーを表示します。

              detail コマンドを使用すると、エラーを受信するインターフェイスおよび VLAN の詳細を表示できます。

              レイヤ 3 インターフェイスのモニタリング

              レイヤ 2 インターフェイスを表示するには、次のコマンドを使用します。

              コマンド

              目的

              load- interval {interval seconds {1 | 2 | 3}}

              Cisco Nexus 7000 シリーズ デバイスの Cisco NX-OS Release 4.2(1) から、3 種類のサンプリング間隔をビットレートおよびパケットレートの統計情報に設定します。 VLAN ネットワーク インターフェイスでの範囲は 60 ~ 300 秒であり、レイヤ インターフェイスでの範囲は 30 ~ 300 秒です。

              show interface ethernet slot/port counters

              レイヤ 3 インターフェイスの統計情報を表示します(ユニキャスト、マルチキャスト、ブロードキャスト)。

              show interface ethernet slot/port counters brief

              レイヤ 3 インターフェイスの入力および出力カウンタを表示します。

              show interface ethernet slot/port counters detailed [all]

              レイヤ 3 インターフェイスの統計情報を表示します。 オプションとして、32 ビットと 64 ビットのパケットおよびバイト カウンタ(エラーを含む)をすべて含めることができます。

              show interface ethernet slot/port counters errors

              レイヤ 3 インターフェイスの入力および出力エラーを表示します。

              show interface ethernet slot/port counters snmp

              SNMP MIB から報告されたレイヤ 3 インターフェイス カウンタを表示します。

              show interface ethernet slot/port.number counters

              サブインターフェイスの統計情報(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

              show interface port-channel channel-id.number counters

              ポート チャネル サブインターフェイスの統計情報(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

              show interface loopback number counters

              ループバック インターフェイスの入力および出力カウンタ(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

              show interface loopback number counters detailed [all]

              ループバック インターフェイスの統計情報を表示します。 オプションとして、32 ビットと 64 ビットのパケットおよびバイト カウンタ(エラーを含む)をすべて含めることができます。

              show interface loopback number counters errors

              ループバック インターフェイスの入力および出力エラーを表示します。

              show interface vlan number counters

              VLAN インターフェイスの入力および出力カウンタ(ユニキャスト、マルチキャスト、およびブロードキャスト)を表示します。

              show interface vlan number counters detailed [all]

              VLAN インターフェイスの統計情報を表示します。 オプションとして、レイヤ 3 パケットおよびバイト カウンタをすべて含めることができます(ユニキャストおよびマルチキャスト)。

              show interface vlan number counters snmp

              SNMP MIB から報告された VLAN インターフェイス カウンタを表示します。

              これらのコマンドについては、『Cisco Nexus 7000 Series NX-OS Interfaces Command Reference』を参照してください。

              関連資料

              関連項目

              マニュアル タイトル

              『Cisco Nexus 7000 Series NX-OS Interfaces Command Reference』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​nexus7000/​sw/​interfaces/​command/​reference/​if_​cmds.html

              『Interfaces Configuration Guide, Cisco DCNM for LAN』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​6_x/​dcnm/​interfaces/​configuration/​guide/​if_​dcnm.html

              『Cisco Nexus 7000 Series NX-OS System Management Configuration Guide』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​6_x/​nx-os/​system_management/​configuration/​guide/​sm_​nx_​os_​cg.html

              『Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​nx-os/​high_availability/​configuration/​guide/​b_​Cisco_​Nexus_​7000_​Series_​NX-OS_​High_​Availability_​and_​Redundancy_​Guide.html

              『Cisco Nexus 2000 Series NX-OS Fabric Extender Software Configuration Guide for Cisco Nexus 7000 Series Switches, Release 6.x』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​nexus2000/​sw/​configuration/​guide/​rel_6_1/​b_​Cisco_​Nexus_​2000_​Series_​NX-OS_​Fabric_​Extender_​Software_​Configuration_​Guide_​Release_​6-x.html

              『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​nx-os/​virtual_device_context/​configuration/​guide/​b-7k-Cisco-Nexus-7000-Series-NX-OS-Virtual-Device-Context-Configuration-Guide.html

              『Cisco NX-OS Licensing Guide』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​nx-os/​licensing/​guide/​b_​Cisco_​NX-OS_​Licensing_​Guide.html

              VLAN、MAC アドレス テーブル、プライベート VLAN、およびスパニング ツリー プロトコル。

              『Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​nx-os/​layer2/​configuration/​guide/​b_​Cisco_​Nexus_​7000_​Series_​NX-OS_​Layer_​2_​Switching_​Configuration_​Guide.html

              『Cisco Nexus 7000 Series NX-OS FabricPath Command Reference』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​nexus7000/​sw/​fabricpath/​command/​reference/​fp_​cmd_​book.html

              『Cisco Nexus 7000 Series NX-OS FabricPath Configuration Guide』

              http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​6_x/​nx-os/​fabricpath/​configuration/​guide/​b-Cisco-Nexus-7000-Series-NX-OS-FP-Configuration-Guide-6x.html

              『Cisco Nexus 7000 Series NX-OS Release Notes』

              http:/​/​www.cisco.com/​c/​en/​us/​support/​switches/​nexus-7000-series-switches/​products-release-notes-list.html

              MIB

              MIB

              MIB のリンク

              • IF-MIB

              • CISCO-IF-EXTENSION-MIB

              • ETHERLIKE-MIB

              MIB を検索およびダウンロードするには、次の URL にアクセスしてください。

              http:/​/​www.cisco.com/​public/​sw-center/​netmgmt/​cmtk/​mibs.shtml

              レイヤ 3 インターフェイスの機能履歴

              この表には、機能が追加または変更されたリリースの更新のみが含まれています。

              機能名

              リリース

              機能情報

              ポリシー プログラミング中のエラーを表示。

              6.2(2)

              ポリシー プログラミング中にエラーを生成するインターフェイスおよび VLAN を表示する show interface status error policy コマンドが追加されました。

              インターフェイスから SNMP カウンタをクリア

              6.2(2)

              インタフェースから SNMP 値をクリアするためのオプションを提供するキーワード snmp を含めるため clear counters interface コマンドが更新されました。

              FEX

              6.2(2)

              Cisco ファブリック エクステンダは、キュー マッピングへのホスト インターフェイス(HIF)および DSCP 上のレイヤ 3 プロトコル隣接関係をサポートします。

              (注)     

              Cisco リリース 6.2(2) より前は、ファブリック エクステンダ(FEX)ポートをホスト接続のためのレイヤ 3 インターフェイスとして設定できますが、ルーティング用には設定できません。

              サブインターフェースの出力の表示拡張

              6.1(1)

              show interface eth コマンド出力が更新されました。

              インターフェイス統計情報の 3 つの設定可能なサンプリング間隔

              4.2(1)

              load-interval コマンドが追加されました。

              レイヤ 3 インターフェイス

              4.0(1)

              この機能が導入されました。