Cisco Nexus 7000 シリーズ NX-OS インターフェイス コンフィギュレーション ガイド
IP トンネルの設定
IP トンネルの設定

IP トンネルの設定

機能情報の確認

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、https:/​/​tools.cisco.com/​bugsearch/​ の Bug Search Tool およびご使用のソフトウェア リリースのリリース ノートを参照してください。 このモジュールに記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「新規および変更された情報(New and Changed Information)」の章または以下の「機能の履歴」表を参照してください。

IP トンネルについて

IP トンネルを使うと、同じレイヤまたは上位層プロトコルをカプセル化して、2 台のデバイス間で作成されたトンネルを通じて IP に結果を転送できます。

IP トンネルの概要

IP トンネルは次の 3 つの主要コンポーネントで構成されています。

  • パッセンジャ プロトコル:カプセル化する必要があるプロトコル。 パッセンジャ プロトコルの例には IPv4 があります。

  • キャリア プロトコル:パッセンジャ プロトコルをカプセル化するために使用するプロトコル。 Cisco NX-OS はキャリア プロトコルとして GRE をサポートします。

  • トランスポート プロトコル:カプセル化したプロトコルを伝送するために使用するプロトコル。 トランスポート プロトコルの例には IPv4 があります。

IP トンネルは IPv4 などのパッセンジャ プロトコルを使用し、このプロトコルを GRE などのキャリア プロトコル内にカプセル化します。 次に、このキャリア プロトコルは IPv4 などのトランスポート プロトコルを通じてデバイスから送信されます。

対応する特性を持つトンネル インターフェイスをトンネルの両端にそれぞれ設定します。

詳細については、「IP トンネルの設定」の項を参照してください。

設定の前にトンネル機能をイネーブルにする必要があります。 Cisco NX-OS リリース 4.2 から、システムは機能のディセーブル化の前に自動的にチェックポイントを作成するため、このチェックポイントにロールバックできます。 ロールバックおよびチェックポイントについては、『Cisco Nexus 7000 Series NX-OS System Management Configuration Guide』を参照してください。

GRE トンネル


(注)  


Cisco NX-OS リリース 5.1(1) 以降では、ソフトウェアは GRE トンネルを通じてマルチキャスティングをサポートします。


Generic Routing Encapsulation(GRE)をさまざまなパッセンジャ プロトコルのキャリア プロトコルとして使用できます。

以下の図は、GRE トンネルの IP トンネルのコンポーネントを示しています。 オリジナルのパッセンジャ プロトコル パケットは GRE ペイロードとなり、デバイスはパケットに GRE ヘッダーを追加します。 次にデバイスはトランスポート プロトコル ヘッダーをパケットに追加して送信します。

図 1. GRE Protocol Data Unit(PDU)



パス MTU ディスカバリ

パス最大伝送単位(MTU)ディスカバリ(PMTUD)は、パケットの発信元から宛先へのパスに沿って最小 MTU を動的に決定することで、2 つのエンドポイント間のパスのフラグメンテーションを防ぎます。 PMTUD は、パケットにフラグメンテーションが必要であるという情報がインターフェイスに届くと、接続に対する送信 MTU 値を減らします。

PMTUD をイネーブルにすると、インターフェイスはトンネルを通過するすべてのパケットに Don't Fragment(DF)ビットを設定します。 トンネルに入ったパケットがそのパケットの MTU 値よりも小さい MTU 値を持つリンクを検出すると、リモート リンクはそのパケットをドロップし、パケットの送信元にインターネット制御メッセージ プロトコル(ICMP)メッセージを返します。 このメッセージには、フラグメンテーションが要求されたこと(しかし許可されなかったこと)と、パケットをドロップしたリンクの MTU が含まれています。


(注)  


トンネル インターフェイスの PMTUD は、トンネル エンドポイントがトンネルのパスでデバイスによって生成される ICMP メッセージを受信することを要求します。 ファイアウォール接続を通じて PMTUD を使用する前に、ICMP メッセージが受信できることを確認してください。


仮想化のサポート

Cisco NX-OS リリース 4.2 以降では、非デフォルトの VDC および非デフォルトの VRF のトンネルを設定できます。 ある VDC に設定されたトンネルは、同じ番号を持つ別の VDC に設定されたトンネルとは区別されます。 たとえば、VDC 1 のトンネル 0 は VDC 2 のトンネル 0 とは異なります。

Cisco NX-OS リリース 6.1(1) より前の場合は、トンネル インターフェイスとトンネル トランスポートは同じ VRF にある必要があります。 VDC については、『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide』を、VRF については、『Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide』を参照してください。

High Availability(高可用性)

IP トンネルはステートフル再起動をサポートします。 ステートフル再起動はスーパーバイザ切り替え時に発生します。 切り替え後、Cisco NX-OS は実行時の設定を適用します。

インターフェイスのライセンス要件

IP トンネルおよび vPC には Enterprise Services ライセンスが必要です。 このライセンスは IP トンネルをイネーブルにするシステムごとにインストールする必要があります。

他のインターフェイスにはライセンスが必要ありません。

IP トンネルの前提条件

IP トンネルには次の前提条件があります。

  • IP トンネルを設定するための TCP/IP に関する基礎知識があること。

  • スイッチにログインしている。

  • Cisco NX-OS の Enterprise Services ライセンスをインストールしていること。

  • IP トンネルを設定してイネーブルにする前にデバイスのトンネリング機能をイネーブルにしておくこと。

注意事項と制約事項

IP トンネルの設定に関する注意事項と制約事項は次のとおりです。

  • Cisco NX-OS は、IETF RFC 2784 に定義されている GRE ヘッダーをサポートします。 Cisco NX-OS は、トンネル キーと IETF RFC 1701 のその他のオプションをサポートしません。

  • トンネルは、Cisco Nexus 7000 シリーズ プラットフォームの M シリーズのカードでのみサポートされます。

  • Cisco NX-OS は、トンネル インターフェイスの Web Cache Control Protocol(WCCP)をサポートしません。

  • Cisco NX-OS は、GRE トンネル キープアライブをサポートしません。

デフォルト設定

パラメータ(Parameters)

デフォルト

Path MTU Discovery 経過時間タイマー

10 分

パス MTU ディスカバリの最小 MTU

64

トンネル機能

ディセーブル

IP トンネルの設定

トンネリングのイネーブル化

IP トンネルを設定する前にトンネリング機能をイネーブルにする必要があります。

手順
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal  

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2switch(config)# feature tunnel  

    新しいトンネル インターフェイスを作成できます。

    トンネル インターフェイス機能をディセーブルにするには、このコマンドの no 形式を使用します。

     
    ステップ 3switch(config)# show feature   (任意)

    デバイス上でイネーブルされている機能に関する情報を表示します。

     
    ステップ 4switch(config)# copy running-config startup-config   (任意)

    実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

     

    トンネル インターフェイスの作成

    トンネル インターフェイスを作成して、この論理インターフェイスを IP トンネルに設定できます。

    はじめる前に

    Cisco NX-OS リリース 6.1 とそれ以降のリリースでは、異なる VRF でトンネル送信元およびトンネル宛先を設定できます。 トンネリング機能がイネーブルになっていることを確認します。

    手順
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal  

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2switch(config)#interface tunnel number  

      新しいトンネル インターフェイスを作成します。

       
      ステップ 3switch(config-if)# tunnel source {ip-address | interface-name}  

      この IP トンネルの送信元アドレスを設定します。

       
      ステップ 4switch(config-if)# tunnel destination {ip-address | host-name}  

      この IP トンネルの宛先アドレスを設定します。

       
      ステップ 5switch(config-if)# tunnel use-vrf vrf-name  

      設定された VRF をトンネルの IP 宛先アドレスの検索に使用します。

       
      ステップ 6switch(config-if)# show interfaces tunnel number   (任意)

      トンネル インターフェイスの統計情報を表示します。

       
      ステップ 7switch(config-if)# copy running-config startup-config   (任意)

      実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

       

      トンネル インターフェイスおよび関連するすべての設定を削除するには、no interface tunnel コマンドを使用します。

      コマンド

      目的

      no interface tunnel number

      トンネル インターフェイスおよび関連する設定を削除します。

      次のオプション パラメータを設定して、インターフェイス コンフィギュレーション モードでトンネルを調整することができます。

      コマンド

      目的

      description string

      トンネルの説明を設定します。

      mtu value

      インターフェイスで送信される IP パケットの MTU を設定します。

      tunnel ttl value

      トンネルの存続可能時間を設定します。 範囲は 1 ~ 255 です。

      次に、トンネル インターフェイスを作成する例を示します。
      switch# configure terminal
      switch(config)# interface tunnel 1
      switch(config-if)# tunnel source ethernet 1/2
      switch(config-if)# tunnel destination 192.0.2.1
      switch(config-if)# copy running-config startup-config

      GRE トンネルの設定

      トンネル インターフェイスを GRE トンネル モードに設定できます。

      はじめる前に

      トンネリング機能がイネーブルになっていることを確認します。

      手順
         コマンドまたはアクション目的
        ステップ 1switch# configure terminal  

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 2switch(config)# interface tunnel number  

        新しいトンネル インターフェイスを作成します。

         
        ステップ 3switch(config-if)# tunnel mode gre ip  

        このトンネル モードを GRE に設定します。

         
        ステップ 4switch(config-if)# show interfaces tunnel number   (任意)

        トンネル インターフェイスの統計情報を表示します。

         
        ステップ 5switch(config-if)# copy running-config startup-config   (任意)

        実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

         

        Path MTU Discovery のイネーブル化

        トンネルでパス MTU ディスカバリをイネーブルにするには、tunnel path-mtu discovery コマンドを使用します。

        コマンド

        目的

        tunnel path-mtu-discovery [age-timer min] [min-mtu bytes]

        トンネル インターフェイスで Path MTU Discovery(PMTUD)をイネーブルにします。 パラメータは次のとおりです。
        • mins:分数を指定します。 有効な範囲は 10 ~ 30 です。 デフォルトは 10 です。

        • mtu-bytes:認識された最小 MTU。 範囲は 92 ~ 65535 です。 デフォルト値は 92 です。

        トンネル インターフェイスへの VRF メンバーシップの割り当て

        VRF にトンネル インターフェイスを追加できます。

        はじめる前に

        トンネリング機能がイネーブルになっていることを確認します。

        正しい VDC を使用していることを確認します(または switchto vdc コマンドを使用します)。

        VRF 用のインターフェイスを設定した後で、トンネル インターフェイスに IP アドレスを割り当てます。

        手順
           コマンドまたはアクション目的
          ステップ 1switch# configure terminal  

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 2switch(config)# interface tunnel number  

          インターフェイス コンフィギュレーション モードを開始します。

           
          ステップ 3switch(config-if)# vrf member vrf-name  

          このインターフェイスを VRF に追加します。

           
          ステップ 4switch(config-vrf)# ip address ip-prefix/length  

          このインターフェイスの IP アドレスを設定します。 このステップは、このインターフェイスを VRF に割り当てたあとに行う必要があります。

           
          ステップ 5switch(config-vrf)# show vrf [vrf-name] interface interface-type number   (任意)

          VRF 情報を表示します。

           
          ステップ 6switch(config-vrf)# copy running-config startup-config   (任意)

          実行コンフィギュレーションを、スタートアップ コンフィギュレーションにコピーします。

           
          次に、VRF にトンネル インターフェイスを追加する例を示します。
          switch# configure terminal
          switch(config)# interface tunnel 0
          switch(config-if)# vrf member RemoteOfficeVRF
          switch(config-if)# ip address 209.0.2.1/16
          switch(config-if)# copy running-config startup-config

          IP トンネリングの設定例

          次の例では、簡易 GRE トンネルを示します。 イーサネット 1/2 は、ルータ A のトンネル送信元であり、ルータ B のトンネル宛先です。 イーサネット インターフェイス 2/1 は、ルータ B のトンネル送信元であり、ルータ A のトンネル宛先です。

          ルータ A:
          feature tunnel
          interface tunnel 0
            ip address 209.165.20.2/8
            tunnel source ethernet 1/2
            tunnel destination 192.0.2.2
            tunnel mode gre ip
            tunnel path-mtu-discovery 25 1500
          interface ethernet1/2
            ip address 192.0.2.55/8
          ルータ B:
          feature tunnel
          interface tunnel 0
            ip address 209.165.20.1/8
            tunnel source ethernet2/1
            tunnel destination 192.0.2.55
            tunnel mode gre ip
          interface ethernet 2/1
          ip address 192.0.2.2/8

          IP トンネル設定の確認

          IP トンネルの設定情報を確認するには、次のいずれかの作業を行います。

          コマンド

          目的

          show interface tunnel number

          トンネル インターフェイスの設定を表示します(MTU、プロトコル、転送、および VRF)。 入力および出力パケット、バイト、およびパケット レートを表示します。

          show interface tunnel number brief

          トンネル インターフェイスの動作状態、IP アドレス、カプセル化のタイプ、MTU を表示します。

          show interface tunnel number description

          トンネル インターフェイスに設定された説明を表示します。

          show interface tunnel number status

          トンネル インターフェイスの動作ステータスを表示します。

          show interface tunnel number status err-disabled

          トンネル インターフェイスの errdisable 状態を表示します。

          関連資料

          関連項目

          マニュアル タイトル

          『Cisco Nexus 7000 Series NX-OS Interfaces Command Reference』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​nexus7000/​sw/​interfaces/​command/​reference/​if_​cmds.html

          『Interfaces Configuration Guide, Cisco DCNM for LAN』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​6_x/​dcnm/​interfaces/​configuration/​guide/​if_​dcnm.html

          『Cisco Nexus 7000 Series NX-OS System Management Configuration Guide』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​6_x/​nx-os/​system_management/​configuration/​guide/​sm_​nx_​os_​cg.html

          『Cisco Nexus 7000 Series NX-OS High Availability and Redundancy Guide』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​nx-os/​high_availability/​configuration/​guide/​b_​Cisco_​Nexus_​7000_​Series_​NX-OS_​High_​Availability_​and_​Redundancy_​Guide.html

          『Cisco Nexus 2000 Series NX-OS Fabric Extender Software Configuration Guide for Cisco Nexus 7000 Series Switches, Release 6.x』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​nexus2000/​sw/​configuration/​guide/​rel_6_1/​b_​Cisco_​Nexus_​2000_​Series_​NX-OS_​Fabric_​Extender_​Software_​Configuration_​Guide_​Release_​6-x.html

          『Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​nx-os/​virtual_device_context/​configuration/​guide/​b-7k-Cisco-Nexus-7000-Series-NX-OS-Virtual-Device-Context-Configuration-Guide.html

          『Cisco NX-OS Licensing Guide』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​nx-os/​licensing/​guide/​b_​Cisco_​NX-OS_​Licensing_​Guide.html

          VLAN、MAC アドレス テーブル、プライベート VLAN、およびスパニング ツリー プロトコル。

          『Cisco Nexus 7000 Series NX-OS Layer 2 Switching Configuration Guide』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​nx-os/​layer2/​configuration/​guide/​b_​Cisco_​Nexus_​7000_​Series_​NX-OS_​Layer_​2_​Switching_​Configuration_​Guide.html

          『Cisco Nexus 7000 Series NX-OS FabricPath Command Reference』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​nexus7000/​sw/​fabricpath/​command/​reference/​fp_​cmd_​book.html

          『Cisco Nexus 7000 Series NX-OS FabricPath Configuration Guide』

          http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​switches/​datacenter/​sw/​6_x/​nx-os/​fabricpath/​configuration/​guide/​b-Cisco-Nexus-7000-Series-NX-OS-FP-Configuration-Guide-6x.html

          『Cisco Nexus 7000 Series NX-OS Release Notes』

          http:/​/​www.cisco.com/​c/​en/​us/​support/​switches/​nexus-7000-series-switches/​products-release-notes-list.html

          IP トンネル設定の機能履歴

          この表には、機能が追加または変更されたリリースの更新のみが含まれています。

          機能名

          リリース

          機能情報

          GRE トンネル

          6.2(10)

          F3 シリーズ モジュールのサポートが追加されました。

          異なる VRF のトンネルとトランスポートのサポート

          6.1(1)

          この機能が導入されました。

          デフォルト以外の VDC および VRF 内の IP トンネル

          4.2(1)

          この機能が導入されました。

          IP トンネル

          4.0(1)

          この機能が導入されました。